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Chapter 2:

House Design
Tutorial

This House Design Tutorial shows you how to get started on a design project. The tutorials that 
follow continue with the same plan. When we are finished, we will have created a sample plan 
named “Stucco Beach House.” You can then apply the tools and techniques learned to your 
own plans.

 In this tutorial you will learn about:
•      Before You Begin
•      Getting Started
•      Drawing Walls
•      Creating Dimension Lines
•      Adjusting Wall Positions

•      Creating Rooms
•      Creating a Camera View
•      Adding Floors
•      Placing Doors and Windows
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Before You Begin
Home Designer Landscape and Deck may look differently on your screen than it does in the 
following tutorials. 

• Screen captures are taken from a smaller window to optimize image quality, so the size and 
proportion of your interface may be different.

• Some features, such as the Reference Grid, have been turned off to optimize image quality. 
For more information, see “General Plan Defaults Dialog” on page 43 of the Reference 
Manual.

• As the program is updated, features may be added or removed. If you are using the latest 
version of Home Designer Landscape and Deck, you may see buttons and/or menu items 
that have been added or removed since this tutorial was written. For more information, see 
“Program Updates” on page 20.

• Depending on your operating system and Windows system settings, dialogs and toolbars 
may appear differently than they do in the tutorials.

Getting Started
We’ll start with a new, blank plan. 

To start Home Designer Landscape and Deck
1. Click the Windows Start button and select All Programs.
2. Browse to Chief Architect> Home Designer Landscape and Deck 2014> Home Designer 

Landscape and Deck 2014, and click to start the program.
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3. When Home Designer Landscape and Deck launches, the Getting Started window 
displays. For more information, see “Startup Options” on page 18 of the Reference 
Manual.

• Click New Plan  to open a new, blank plan.
• If you have disabled the Startup Options at startup or already have the program open, 

you can select File> New Plan  to open a new, blank plan. 
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4. The Create New Plan dialog displays next.

5. Home Designer Landscape and Deck includes a selection of Landscape & Terrain, 
Landscaping, Decks and Pools templates to choose from. Some templates contain empty 
yards you can place your own house into. Other templates contain buildings and/or 
landscaping designs. For this tutorial, select the Design Your Own template from any 
category, then select the U.S. Units radio button.

6. You should begin work on any new file by saving it. To do this: 

• Select File> Save  from the menu to open the Save Plan File dialog.
• Specify the location on your computer where you would like to save the plan.
• Type a name for your plan.
• Click Save. 

7. It is wise to save your work, and save it often, as you proceed. To do this, you can:

• Select File> Save  from the menu to open the Save Plan File dialog

• Click the Save  button on the toolbar.
• Type Ctrl + S on your keyboard.

For more information about saving files, see “Saving, Exporting, and Backing Up Files” on 
page 32 of the Reference Manual. 
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 To set the Dimension Defaults
1. Select Edit> Default Settings  to open the Default Settings dialog. 
2. Click on "Dimension" and click the Edit button. 

3. Review each of the tabs and settings available for setting up your Dimension Defaults. For 
more information, see      Dimension Defaults Dialog.

To set the Wall Defaults

1. Select Edit> Default Settings  to open the Default Settings dialog. 
2. Click on Walls, and click on the Edit button.
3. From the Exterior Wall drop down menu, we will select Stucco-6, and click OK.

4. Click the Done button to close the Default Settings dialog.

You may want to review some of the other available defaults when setting up your template. 

Drawing Walls
We’ll start by drawing some exterior walls. When drawing walls, do not try to size or position 
them precisely - they can be more easily positioned after they are created. For more 
information, see “Walls, Railings & Fencing” on page 93 of the Reference Manual.
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To draw exterior walls

1. Select Build> Wall> Straight Exterior Wall  from the menu or click the 
corresponding toolbar button. 

• Click and drag from left to right to draw a wall. 

Wall length is indicated in the Status Bar as the wall is drawn
2. There are a few things to make note of as you draw a wall.

• The wall’s length displays in two places: above the wall and in the Status Bar at the 
bottom of the screen. 

• Wall angles are restricted to increments of 7.5° when Angle Snaps  are on. . See 
“Snap Behaviors” on page 60 of the Reference Manual for more information.

3. Continue drawing walls, creating a rough outline of the building’s exterior, as shown in the 
following image. 

• Exact dimensions are not important yet, but it is helpful to keep the final size of the 
structure in mind as you draw. The overall length of this building’s sides will be 41’ x 
39’6". 

• It is important that exterior walls (and any other wall types with an interior side and an 
exterior side) are drawn clockwise to ensure the proper orientation of wall surfaces. 
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4. When your walls completely enclose an area, a roof will automatically be generated. For 
the purposes of this tutorial, this roof can be removed. Select Build> Roof> Delete 

Roof . When asked if you want to turn Auto Rebuild Roofs off, click Yes. 

To delete a wall

1. While the Select Objects  tool is active, click on a wall with the pointer to select it.

2. Press the Delete key or click the Delete  edit button.

Creating Dimension Lines
Dimension lines locate walls, openings in walls, and other objects. In Home Designer 
Landscape and Deck, you can generate types of automatic dimension lines and draw a variety 
of manual dimensions . For more information, see “Dimensions” on page 335 of the Reference 
Manual.

Note: The “Auto Rebuild Roofs” option is a fast and convenient alter-
native to manual roof design. It has been turned off in this tutorial to
simplify the display of our building in floor plan view. The option is
located in the Build Roof dialog. For more information, see “Build
Roof Dialog” on page 181 of the Reference Manual.
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To create automatic exterior dimension lines

1. Select CAD> Dimensions > Auto Exterior Dimensions .

2. For a closer view of a certain area, click the Zoom  tool, click and drag a box around 
the area you want to see in detail, and release the mouse button. That area fills the screen. 
For more information, see “Zoom & View Tools” on page 305 of the Reference Manual.

3. To return to the previous zoom factor, select Window> Undo Zoom .
4. If you can’t see all the exterior dimension lines at once, select Window> Fill Window 

Building Only  to center your plan on screen.

Adjusting Wall Positions
Now we’ll adjust the spacing of walls with more precision. There are a couple of ways to move 
walls into position, but the fastest and most accurate uses dimension lines. For more 
information about using dimensions to relocate objects with accuracy, see “Moving Objects 
Using Dimensions” on page 343 of the Reference Manual.
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To move walls using dimensions

1. Let’s begin by selecting Window> Fill Window Building Only  so we can see the 
entire building.

2. Click the Select Objects  button, then click on a wall that you want to move.
3. Click on a dimension line that indicates how far the selected wall is from another wall. 

There are a couple ways to determine which dimensions can be used for this purpose:
• Move the selected wall and see which dimensions update.
• Move your pointer over a dimension. If it is an associated dimension, the icon will 

change to a pointing hand ( ).

4. Click on the associated dimension and enter a new value. Remember, numbers entered 
with an apostrophe denote feet and numbers entered with quotes denote inches. If neither 
apostrophes or quotes are included, the entered value defaults to inches.

5. Use the Enter key on your keyboard to close the dialog and apply the change so that the 
wall will move the specified distance.

6. Repeat this process for the adjacent exterior wall, continuing in a clockwise direction. It 
may help to refresh Auto Exterior Dimensions (Shift + A) between commands. 

Dimensions can also be used to change the length of a selected wall. Bear in mind, though, that 
the when a wall is resized in this manner its Start point will always be locked and its End point 
will always be moved. When, adjusting all the walls in a floor plan, it is often easier to move 
them than to resize them. See “Editing Walls” on page 104 of the Reference Manual. 

If you use dimensions to reposition walls, you should always work in
the same direction, adjusting one wall section after another.

Selected Wall

Associated Dimension
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When you are finished, the dimensions of your model should match those in the following 
image. 

When your exterior walls are positioned properly, you may find it helpful to delete the 
dimensions. 

To delete all dimensions at once

1. Select Edit> Delete Objects  to open the Delete Objects dialog. See “Delete Objects 
Dialog” on page 91 of the Reference Manual. 

2. Select the All Rooms On This Floor radio button.
• Check Manual Dimensions to delete manually-drawn dimension lines such as those 

drawn by the  tool;
• Check Automatic Dimensions to delete automatically generated dimension lines such 

as those created by the Auto Exterior Dimensions  tool;
• Click OK. 
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Although using dimensions is generally the fastest and most accurate way to move walls, you 
can also move them using their edit handles and edit tools.

To move walls using their edit handle

1. Click the Select Objects  tool then click on an exterior wall to select it. 
2. Click and drag the Move edit handle that displays at the position along the wall where you 

clicked. Walls can be moved perpendicular to the direction that they are drawn.
3. As you move the wall, the dimension lines that indicate how far it is from other walls will 

update. 

If you have difficulty positioning a wall at the desired location because it jumps over that 
location as you move it, try zooming in on it by scrolling with your mouse wheel or by using 

either the Zoom  or Zoom In  tool. You can also use the Accurate Move  edit tool to 
slow your mouse movement.

To use the Accurate Move edit tool 
1. Click on the wall that you wish to move more slowly and with greater accuracy.

2. Click the Accurate Move  edit button.
3. Click and drag the Move edit handle to the desired position. 

Your mouse will move more slowly for this edit only. The next time you want to move or resize 

the wall slowly, you will need to click the Accurate Move  edit button again.

Creating Rooms
Now that the exterior of the house has been finalized we can begin laying out rooms. Rooms 
are defined by the walls that enclose them. They are then assigned a Room Type that assigns 
common room attributes. For more information about rooms, see “Room Types” on page 121 
of the Reference Manual. 

Room Types
Rooms in Home Designer Landscape and Deck are given special attributes by assigning a 
Room Type. For example, porches use a concrete floor material and have a ceiling and roof, 
while decks use floor planking and have no ceiling or roof. For more information, see “Rooms” 
on page 117 of the Reference Manual.
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Creating a Camera View
Let’s take a look at our plan in 3D and see how it looks so far. For more information, see “3D 
Views” on page 313 of the Reference Manual. 

To create a camera view

1. In floor plan view, click the Fill Window  button to zoom out as needed to fill the view 
window with the entire drawing. 

2. Select 3D> Create Camera View> Camera  (or press Shift + J).
3. Click at the bottom of the floor plan view window and drag a line that stops at the Entry. 

The point where you click (A) defines the point of perspective and the line (B) defines the 
direction of perspective.

4. Release the mouse button to create the 3D camera view. Where the mouse is released (C) is 
the camera’s focal point.

5. If necessary, you can use the Mouse-Orbit Camera  tool to change the camera’s 
perspective. The camera will revolve around its focal point (C). See “Repositioning 
Cameras” on page 318 of the Reference Manual for more information.

A

B

C
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6. Once you have accurately positioned your camera, to smooth out the edges and create a 
more realistic rendering of the model, you can select 3D> Camera View Options> Final 

View  or Final View with Shadows .

7. To return to floor plan view, select File> Close from the menu.

Adding Floors
Creating new floors in a plan is easy, but it is best to do so only after the first floor plan has 
been finalized. Now that we have done so in our plan, we’ll add a second story and basement. 
For more information about working with multiple floors, see “Multiple Floors” on page 161 of 
the Reference Manual. 

To add a second floor

1. Select Build> Floor> Build New Floor . The New Floor dialog displays.
2. Select Derive new 2nd floor plan from the 1st floor plan and click OK to close the New 

Floor dialog to display the Floor 2 Defaults.

Click OK and a floor plan for the second floor is created based on the exterior walls of the first 
floor plan.To create a foundation or basement

1. Select Build> Floor> Build Foundation . In the Build Foundation dialog: 
• Change the Wall Height to 100 inches.
• Click OK to close the dialog and create a foundation level for your plan. 

2. Select Derive New Foundation Plan From the First Floor Plan and click OK to close 
the New Floor dialog. For more information, see “Adding Floors” on page 162 of the 
Reference Manual. 

Final Views often take significantly longer to generate than Previews, so
the 3D view reverts back to the Preview Settings as soon as anything is
changed within the view.
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3. You can select Window> Fill Window Building Only  from the menu to center the 
plan on screen.

4. Select 3D> Create View> Full Overview  from the menu to create a 3D overview of 
our entire plan so far. 

To add a second story balcony

Now that we have a second floor, we’ll use the tools and techniques we learned earlier to add a 
second story balcony that is aligned with the floor below. 

1. Press Ctrl + Tab on your keyboard to switch back to floor plan view and return to Floor 2. 

2. If they are not already displayed, click Reference Display  to display the first floor 
walls.
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3. Select Build> Wall> Straight Railing .

4. Draw a balcony as shown in the following image. You can manually align the wall with the 
first floor deck below in the following steps.

5. Next, use the Select Objects  tool to select one of the railings, and click on the Open 

Object  edit tool to display the Railing Specification dialog. On the General tab, 
increase the Thickness to 8 1/8” then click OK.

6. Repeat this process for the remaining railings in the plan.
7. Select a section of railing that has a wall below it on the first floor and click the Align with 

Wall Below  edit button. 

• Note: If Align with Wall Below  is not available, the selected railing either needs 
to be moved closer to the wall below, or the railing is already aligned with the one 
below. See “Aligning Walls” on page 107 of the Reference Manual. 

8. Repeat this step for each section of railing that has a railing directly below it on the first 
floor.

Placing Doors and Windows
We’re making progress on our house, but we can’t get into it, and neither can light. Now is a 
good time to add some doors and windows. For more information about doors and windows, 
see “Doors” on page 131 of the Reference Manual and “Windows” on page 145 of the 

For best results, do not use the Deck Railing tool or specify the balcony
room as a Deck. 
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Reference Manual.

To add a door
1. If your views are still tiled, close the 3D view and maximize the floor plan view.

2. Select Build> Door> Hinged Door .
3. Move the pointer to the entry and click on the front wall, left of its center, to place a door.

To add a window

1. Select Build> Window> Window .
2. Move the pointer to the entry and click on the wall, right of center, to place a window. 

To edit a door
1. So that we can better see the results when we edit our door, let’s select 3D> Create 

Camera View> Perspective Full Camera  to create a camera view of the entry. Click 
and drag a camera arrow inside the structure, pointed at the entry.

2. Click the Select Objects  tool, then click on the door to select it in the 3D view.

3. Click the Open Object  edit button to open the Door Specification dialog. For more 
information, see “Door Specification Dialog” on page 140 of the Reference Manual.

4. On the General tab, set the Door Style to Glass and set the Width to 36".
5. On the Frame & Lites tab, set the Frame Bottom to 8 inches. Press the Tab key to update 

the preview image on the right side of the dialog so that it reflects your change.
6. On the Lites tab, set the Lites across to 3 and Lites vertical to 5.
7. On the Hardware Tab, set the Handle In from Door Edge to 2"
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8. Click OK to return to the 3D view.

To edit a window
1. Next, click on the window to select it.

2. Click the Open Object  edit button to open the Window Specification dialog. For 
more information, see “Window Specification Dialog” on page 155 of the Reference 
Manual.

3. On the General tab, select “Fixed Glass” from the Window Type drop-down list.
4. On the Lites tab, change the Lites across to 4 and Lites vertical to 4.
5. Click OK to close the Window Specification dialog.
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To change the door swing
1. Return to floor plan view and select the door.

2. Click the Change Opening/Hinge Side  edit button.

To copy a window or door
1. Return to the 3D view and select the window, or door, you wish to copy.

2. Click the Copy/Paste  edit button. For more information about copying objects, see 
“Copying and Pasting Objects” on page 63 of the Reference Manual.

Doors and windows can be placed, selected, deleted, copied, pasted, and edited in either 2D or 
3D views. If there is a window design that you will be using throughout a plan, you can create 
it once, then just copy and paste it. An even better approach is to set your door and window 
defaults to the desired settings before placing these objects. For more information, see “Default 
Settings vs Preferences” on page 42 of the Reference Manual. 

Use the tools and techniques you’ve learned to add window and doors to the rest of the plan, as 
shown in the following images. Doors placed in interior walls become interior doors and have 
different specifications than exterior doors. If you feel inspired, customize the doors and 

If you would like all of your doors and/or windows to be customized, make
your changes in the Door Defaults and Window Defaults dialogs before

placing these objects. For more information, see “Default Settings vs Prefer-
ences” on page 42 of the Reference Manual.
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windows as you see fit. For example, increase a door’s width to 48" or greater and the program 
will automatically create a double door.

When you have finished, Save  your work. 

If you would like, you can continue working on this plan in the Landscaping Tutorial. You can 
also learn about materials in the Materials Tutorial or find out more about roofs in the Roof 
Tutorial. 

1st Floor

 2nd Floor
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