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Chapter 1:

Program Overview

Home Designer Pro is specifically designed 
for the residential and light commercial 
design professional. It allows you to easily 
and  efficiently produce 3D models and 
construction documents for your projects. 
We thank you for choosing Home Designer 
Pro and wish you the best in your design 
work.

Chapter Contents
•      Startup Options
•      The Home Designer Pro Environment
•      Toolbars
•      Menus
•      Dialogs
•      The Status Bar
•      Message Boxes
•      Preferences and Default Settings
•      Drawing a Plan
•      Viewing Your Plan
•      Getting Help
•      About Home Designer Pro
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Startup Options
When Home Designer Pro opens, the 
Startup Options dialog displays, 

allowing you to choose how you want to 
begin working in the program or access 
useful resources. 

The Startup Options dialog can be opened at 
any time by selecting File> Startup 

Options .

Getting Started- Click to launch your 
default internet browser to the Getting 

Started page on our web site,
 www.HomeDesignerSoftware.com. There, 
you will find links to a variety of online 
resources to help you begin using the 
program.

Select a File command to open a .plan 
or .layout file.

• Click New Plan  to open a new, blank 
plan. See “Creating a New Plan or Lay-
out” on page 42.

• Choose Open Plan/Layout to work 
on an existing plan or layout file. See 
“Opening and Importing Files” on page 
48.

2

3 

4 

1

5 

1

2

http://www.homedesignersoftware.com/
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Recent Files lists the names of the most 
recently opened files. Click on a name 

to open the file.

Remove the check from Show Options 
on Startup if you do not want this 

dialog to display when you launch Home 
Designer Pro. Instead, a new blank plan the 
Create New Plan dialog opens. 

To have the Startup Options dialog display 
at startup again, select File> Startup 

Options  and place a check mark at Show 
Options on Startup. 

The Build number of the program 
version you are using and the first five 

characters of your software license Product 
Key display here. 

The Home Designer Pro Environment

Object-Based Design
Home Designer Pro’s parametric, object-
based design technology means you place 
and edit objects, rather than work with the 
many individual lines or surfaces used to 
represent them. 

You can quickly select and edit the location, 
size, shape, style and other properties of 
objects as well as change the materials 
applied to their surfaces. 

Use Home Designer Pro’s editing 
capabilities to make the objects you place in 
a plan match the objects they represent in 
real life. For example, you can set up your 
windows and doors to match those available 
from your supplier. 

3D Drafting
In Home Designer Pro, the entire drawing 
area is laid out on a Cartesian grid, a three 
dimensional coordinate system described 
using the X, Y and Z axes. The current 
position of your mouse pointer displays in 
the Status Bar at the bottom of the program 
window.

Architectural objects take up space in all 
three dimensions and their height, width and 
depth can be specified in Imperial or metric 
units. In addition, the location of objects can 
be precisely defined using coordinates, again 
specified in Imperial or metric units.

CAD objects such as lines and arcs take up 
space in two dimensions in the current view. 
Their dimensions can also be specified in 
Imperial or metric units and their locations 
precisely defined using coordinates.

Objects can be rotated relative to the 
Cartesian grid system, as well. When the 
program presents the option to rotate to an 
Absolute Angle, this angle will be measured 
relative to an imaginary horizontal line 
drawn in floor plan view from the origin in 
the positive X direction. See “Rotating 
Objects” on page 161. 

Easy Access to Tools
You can access Home Designer Pro’s 
features in various ways using the mouse and 
keyboard. 
• Menus provide access to most tools.

3

3 4 
3 5 
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• Convenient toolbar buttons allow fast 
access to tools and let you customize the 
interface.

• Keyboard shortcuts are available for most 
tools.

• Contextual menus display with a right-
click of the mouse.

• The Status Bar at the bottom of the screen 
provides tool descriptions and other 
information about the current task. 

Using the Mouse
Many objects, such as doors and cabinets, are 
created by clicking the left mouse button. 
Others, such as walls, stairs and dimension 
lines, are created by dragging the pointer 
from one end of the object to the other.

The left button is the primary 
button used in Home Designer Pro. 
Unless specified otherwise, Home 
Designer Pro documentation refers 

to the left mouse button.

The Right button has several uses. 
Right-click to select any object.

If, for example, the Straight Exterior 

Wall  tool is active, the left mouse button 
allows you to select only walls. You can 

Status Bar

Parent 
Tools

Menus

Library 
Browser

Edit  
Toolbar

Pointer Crosshair 
Lines

Reference 
Grid Lines

Selected 
Object

Temporary 
Dimension

Library 
Preview 
Panes

Title 
Bar

Note: If you are left-handed and have re-pro-
grammed your mouse, reverse the instruc-
tions for left and right buttons in this manual. 
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select other object types such as cabinets 
with the right mouse button.

Use the right mouse button to temporarily 
switch to the Alternate edit behavior. See 
“Edit Behaviors” on page 120.

You can also use the right mouse button to 
open a context sensitive menu with 
additional editing commands.

The Middle button can be used to 
pan in floor plan view or to 
temporarily use the Move edit 
behavior. 

You can also program it to work as a double-
click.

The Mouse Wheel can be used to 
zoom in and out in most views.

The Back, or X1, button on a 5-button mouse 
can be used to temporarily enable the 
Concentric edit behavior. See the 
documentation for your mouse.

The Forward, or X2, button on a 5-button 
mouse can be used to temporarily enable the 
Resize edit behavior. See the documentation 
for your mouse.

Using the Edit Handles
When you select an object, its edit handles 
display. How each handle behaves when it is 
clicked and dragged may depend on which 

Edit Behavior  is currently active. See 
“Edit Behaviors” on page 120. 

When you pass the mouse over the edit 
handles, the pointer changes to show how 
you can use that handle. 

• A two-headed arrow indicates that the 
object, corner or edge can be moved in 
the direction of the arrows.  

• A four-headed arrow indicates that the 
selected object or edge may be moved in 
multiple directions. 

• A circular arrow indicates that the 
selected object can be rotated.

Resize handles display along the edges of the 
object are used to change the size. See 
“Resizing Objects” on page 157.

The Move handle at the object’s center lets 
you move the object. See “Moving Objects” 
on page 152.

The triangular Rotate handle lets you rotate 
the object. See “Rotating Objects” on page 
161.

You can cancel any edit handle operation 
before it is completed by pressing the Esc 
key on your keyboard or by pressing any two 
mouse buttons at the same time. 

The edit handles that display depend on the 
type of object selected, the current view, and 
how far you are zoomed out. 
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Edit handles do not resize as you zoom in or 
out. If you are zoomed out far enough, some 
edit handles may be hidden so that they do 

not stack over one another.  As you zoom in, 
these handles become visible again.

Toolbars
Using the toolbar buttons is the fastest, 
easiest way to access many program features. 
You can move the toolbars, customize them 
by adding or removing buttons, or create 
your own toolbars from scratch. “Toolbar 
Customization Dialog” on page 93.

The toolbars that display in a given view 
depend on the view type. For example, 
toolbars that control camera position display 
in 3D views but not in floor plan view.

When you pass the pointer over a toolbar 
button, a “tool tip” displays the name of the 
tool. When you see one of these tool tips, 
press F1 to get more information about that 
item. A more detailed description displays in 
the Status Bar at the bottom of the window.

You can use either of two styles of toolbar 
interface: drop-down tools or parent-child 
buttons.

Drop-Down Tools
Click on the arrow to the right of a button to 
display a drop-down list of related tools. For 
example, click the arrow to the right of the 

Window  button to display a drop-down 
list of the other Window Tools.

The most recently selected tool displays in 
the toolbar.

Parent and Child Tools
An alternative to the Drop-Down toolbar 
interface are Parent and Child tools. Parent 
toolbar buttons have a blue triangle in the 
lower right corner. When you select a parent 
button, child tools display on the right side of 
the toolbar. 

When you click the Window Tools  
parent button, for example, its child buttons 
display to the right.

You can select either Parent-Child or Drop-
Down tools in the Preferences dialog. See 
“Appearance Panel” on page 61.



Toolbars

 29

Toolbar Configurations
Toolbar configurations are sets of toolbars 
that are organized for certain tasks. 

There are eight toolbar configurations in 
Home Designer Pro. Each can be accessed in 
the Toolbar Customization dialog by right-
clicking on a toolbar button, or by clicking a 
button: 

The Default Configuration displays 
a selection of architectural, file 

management and display settings tools.

The Terrain Configuration displays 
a selection of terrain, file management 

and display setting tools.

The Space Planning Configuration 
displays a selection of file 

management and display setting tools, as 
well as the House Wizard tools. 

The Plan Detailing Configuration 
displays a selection of display 

settings, file management, annotation and 
other documentation tools.

The CAD Configuration displays a 
selection of CAD, file management 

and display setting tools.

Customizable Toolbars
Since the work you are doing determines the 
tools you need, Home Designer Pro allows 
you to tailor toolbars to suit your own needs. 
You can store various toolbar configurations 
for future use. For more information about 
customizing toolbars, see “Toolbar 
Customization Dialog” on page 93.

You can add toolbars to each configuration 
using the Toolbar Customization dialog 
while that configuration is active.

The Edit Toolbar
When you select an object, the edit toolbar 
appears. By default, it is located at the 
bottom of the program window, just above 
the Status Bar. The toolbar buttons that 
display can be used to edit the selected 
object(s). Which buttons display depends on 
the type of object selected, the current view, 
and how you selected the object.

The edit toolbar buttons are the same as the 
options in the contextual menu when you 
right-click on an object.

Hotkeys
Many commands can be invoked from the 
keyboard.  Press Alt on your keyboard and 
press the underlined letter in a menu name to 
access that menu, as well as items in the 
menus and submenus. 

Other keys or key combinations will invoke a 
variety of program commands. If a Home 
Designer Pro menu item has a keyboard 
shortcut, or hotkey, associated with it, that 
hotkey will display to the right of its name in 
the menu.
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Menus
Home Designer Pro uses a standard 
Windows menu format. The menus are 
located below the title bar in the program 
window and can be used to access nearly all 
tools in the program. Click on a menu name 
to expand it, then click on a menu item to 
either activate that tool or access the item’s 
submenu. Items with a submenu have an 
arrow to the right of the name.

Menu items with an icon to their left have a 
toolbar button associated with them. Some 
buttons are not included on the toolbars but 
can easily be added. See “Toolbar 
Customization Dialog” on page 93.

The menus can be accessed using the 
keyboard. Press the Alt key once to enable 
this functionality - one letter in each menu 
will become underlined. Press the key 
associated with one of these underlined 
letters to expand its menu - one letter in each 
menu item’s name will be underlined. Press 
the key associated with one of these letters to 
activate that tool or access the item’s 
submenu. Press the Esc key to undo your last 
selection, or click with the mouse to exit out 
of this functionality. 

Many tools in Home Designer Pro also have 
hotkeys associated with them. If a menu item 
has a hotkey, it will display to the right of the 
item’s name. See “Hotkeys” on page 99.

In the Home Designer Pro documentation, 
menu paths are written in this format: Build> 

Window> Box Window . An icon image 
after the menu path indicates that a toolbar 
button is also available. 

Contextual Menus
Contextual menus are context sensitive 
menus that display tools relevant to a 
selected object or view.

To access contextual menus, right-click on an 
object, in an empty space in a view window 
or in a text field in any dialog box. 

Contextual menus can be enabled or disabled 
in the Preferences dialog. See “Appearance 
Panel” on page 61. 

Dialogs
Default and preference settings, object 
specifications, display settings, and many 
other functions are accessed through dialog 
boxes. 

Dialog tabs and settings can be accessed 
using the mouse. You can also navigate the 

settings on a given dialog tab using the 
keyboard:
• Press the Tab key proceed from one set-

ting to the next, or Shift + Tab to go in the 
reverse direction. 

Edit menu items with button icons 
to the left and hotkeys to the right
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• Line items in tree lists can be browsed 
using the arrow keys. Up and Down navi-
gate the list, while Left and Right expand 
and contract categories.

• Settings with spin control arrows  can 
be adjusted by typing in the text field, 
using the up and down arrow keys, or the 
mouse scroll wheel.

• Settings with slider bars  can be 
adjusted by typing in the text field, using 
the left and right arrow keys, or the 
mouse scroll wheel.

• Press Enter on your keyboard to close 
any dialog and apply your changes.

Many dialogs have a preview that shows how 
the changes affect the object. This preview 
updates when you click in a different field or 
press the Tab key on your keyboard. 

Some dialog boxes are resizable. Resizable 
dialogs have a size grip at the lower right 
corner of the box which you can click and 
drag. 

Specification Dialogs
Each object in Home Designer Pro has 
a unique specification dialog where 

you can enter size, style and other 
information specific to the selected object. 
To access it, select the object and click the 
Open Object edit button. You can also 

double-click on an object with the Select 

Objects  tool active to open its 
specification dialog. See “Selecting Objects” 
on page 124.

You can open the specification dialog for 
group-selected objects if they are of the same 
type, such as base cabinets. 
• If a particular setting varies among the 

different objects, its check box will have 
a solid fill instead of a check mark. Click 
once to clear the box for all selected 
objects, or click a second time to place a 
checkmark for all selected objects. 

• In some dialogs, if a particular setting 
varies among the different objects, it will 
have a “No Change” radio button. Leave 
this button selected, or choose a different 
option to apply it to all objects in the 
selection set. 

•  If the setting has a text field or drop-
down list, it will say “No Change”. 
Changes made to such a setting can be 
undone by replacing the value in the text 
field with the letter N before you click 
OK. 

If you select multiple objects of different 

types, the Open Object  edit button is 
usually not available. The button may 
display if the objects have data in common, 
but you can only edit the common data.

The Status Bar
The Status Bar at the bottom of the main 
program window displays information about 
the current state of the program. 

This information depends on a variety of 
conditions such as settings in the 
Preferences dialog, the type of object 
selected, and the current position of the 
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pointer. The information may include the 
following:
• A brief description of the toolbar button 

or menu item highlighted by the mouse.
• A description of the selected object.
• The total number of objects currently 

group-selected.
• Basic information about a selected library 

object, folder, or catalog.
• The layer that the selected object is on.
• The current floor.

• The current CAD coordinates of the 
mouse pointer.

• The screen redraw time.
• The length and/or angle of an object as it 

is being drawn.

The number format used in the Status Bar is 
set in the Dimension Defaults dialog, while 
the angle style can be specified in the 
Number Style/Angle Style dialog. See 
“Format Tab” on page 722 and “Number 
Style/Angle Style Dialog” on page 89.

Message Boxes
As you work in Home Designer Pro, the 
program will alert you if you command it to 
do something that could potentially cause a 
problem, or if the program encounters a 
problem that needs your attention. 

Situations where such message boxes may 
display include: 
• Closing a file or view without saving;
• A file referenced outside the program, 

such as an image or texture, is missing;
• Creating an object in a space too small to 

contain it.

You can access the settings in a message box 
using the mouse, or navigate them using the 
keyboard: 

• Press the Tab key proceed from one set-
ting to the next, or Shift + Tab to go in the 
reverse direction. 

• When a checkbox is the active setting, 
press the Spacebar to check or to clear it.

• Buttons have hotkeys associated with 
them. Press the Alt key on the keyboard 
to underline the hotkeys in the current 
message box.

• Press Enter on your keyboard to close the 
message box and perform the action asso-
ciated with the highlighted button.

Some message boxes include a “Remember 
my choice” or a “Do not show this again” 
checkbox. Check this box to prevent 
messages of this specific type from 
displaying in the future.

To allow all message boxes to display again, 
click the Reset Message Boxes button in the 
Preferences dialog. See “Reset Options 
Panel” on page 89. 
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Preferences and Default Settings
Preferences and default settings control 
many aspects of the user interface and tool 
behavior in Home Designer Pro. You can use 
these settings to customize the program to 
suit your personal work style.

For more information about defaults and 
preferences, see “Preferences & Default 
Settings” on page 55.

Preferences
Preference settings let you change program 
behavior to suit your workflow. For example, 
you can: 
• Turn certain display elements on or off.
• Choose background and editing feedback 

colors.
• Set frequency of autosaves, maximum 

number of “undos,” and file locking.
• Set default folders for various files.
• Control the editing behaviors of objects.
• Setup the materials list categories, sub-

categories, and report style, as well as 
manufacturer and supplier information.

• Set rendering specifications to maximize 
efficiency and quality. 

Preference settings are global, affecting all 
plan and layout files.

Defaults
Most objects in Home Designer Pro derive 
their intial properties from their respective 
default dialogs. 

For example, a newly placed Window  
gets its initial values from the Window 
Defaults dialog and a newly placed Hinged 

Door  gets its initial values from the Door 
Defaults dialog. 

Once an object is placed in a plan, its initial 
properties can be overridden, but setting up 
your defaults before you begin drawing can 
save you considerable time as you build a 
model in the program.

Default settings, unlike Preferences, are file 
specific.

Dynamic Defaults
Most default settings are static: if you change 
one, any objects of that type in the current 
file will not be affected. A few defaults, 
however, are dynamic: they are tied to 
existing objects in the drawing and if you 
change the default, those objects may be 
affected. See “Dynamic Defaults” on page 
57. 

Drawing a Plan
When you draw a plan in Home Designer 
Pro, you are placing 3D objects that 
represent building components. Home 
Designer Pro comes with predefined default 

settings so you can start drawing plans 
immediately. You should review these 
default settings to be sure they match your 
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drawing and building methods. See 
“Preferences & Default Settings” on page 55.

Set the Defaults

1. Open a new plan using the template of 
your choice. See “Template Plans” on 
page 43. 

2. Set the structural defaults:
•  Floor Defaults. Set the default ceiling 

height for Floor 1. See “Floor Defaults 
Dialog” on page 316.

•  Foundation Defaults. Set the founda-
tion specifics such as type, footing size, 
and stem wall height. See “Foundation 
Defaults” on page 330.

•  Framing Defaults. Set the floor framing 
specifications, including type and 
dimensions. See “Framing Defaults” 
on page 436.

•  Default Wall Types. Specify the 
defaults for walls and railings. See 
“Wall, Railing, and Fencing Defaults” 
on page 176. 

3. Set material defaults for roof, walls, and 
rooms (optional). See “Material 
Defaults” on page 650.

4. Set style defaults for doors, windows, 
molding, cabinets and other objects.  

Draw the Floors

1. While the size of the drawing area in 
Home Designer Pro is limited only by 
the resources on  your computer, it is 
best to begin your drawing near the ori-
gin, 0,0,0. See “3D Drafting” on page 
25.

2. Draw the exterior walls on Floor 1. See 
“Drawing Walls” on page 189.

3. Adjust the perimeter shape and size as 
required. See “Using the Edit Handles” 
on page 197.

4. Place any first floor bearing walls. 
5. Define types for special rooms such as 

garages and decks in the plan. See 
“Room Types” on page 234. 

6. Place perimeter doors and windows. See 
“Doors” on page 253 and “Windows” on 
page 279.

7. Build additional floors. See “Adding 
Floors” on page 317.

8. Specify the default ceiling height for 
each floor as soon as it is created. See 
“Floor Defaults Dialog” on page 316.

9. Adjust the perimeter shape of additional 
floors as needed. See “Editing Walls” on 
page 197.

10. Align edited or moved walls with those 
above or below where appropriate. See 
“Aligning Walls” on page 201.

Entering Dimensions
When using Imperial units, enter distances as 
inches or feet and inches, in fractional or 
decimal form. Millimeters are the default 
unit for all metric distances. See “Dimen-
sions” on page 719.
• To enter feet, include the ( ' ) marker or 

the program assumes inches.
• In most cases, the program allows 

precision to 1/16th of an inch. Fractions 
with denominators 2, 4, 8 and 16 are 
allowed.
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• The program usually converts decimals 
to fractions.

• You can enter angles as decimal degrees, 
degrees, minutes, and seconds, quadrant 
bearings, or azimuth bearings. See 
“Number Style/Angle Style Dialog” on 
page 89.

Build the Foundation

1. Derive the foundation plan from the first 
floor. See “Building a Foundation” on 
page 334.

2. Adjust the foundation perimeter shape 
as needed.

3. Place interior foundation walls as 
needed for the first floor bearing walls.

4. Place any other foundation walls 
required.

5. Align with Above as needed. See 
“Aligning Walls” on page 201.

Add Structure and Details

1. Build non-structural interior walls. 
Begin on floor one and work up in mul-
tiple story structures. 

2. Add walls where needed to create fea-
tures such as chimney chases, plumbing 
walls, or Open Below areas.

3. Finish the relevant interior structure 
including interior doors, doorways, cabi-
nets, fixtures, and fireplaces.

4. Build the roof planes. If you generate the 
roof automatically, remember to carry 
the roof directives in the walls from the 
first floor up to the top floor for multiple 
story structures. See “Roofs” on page 
349. 

5. Build the framing. See “Framing” on 
page 435. 

6. Build the terrain and landscaping. See 
“Terrain” on page 537.

7. Create the plot plan. See “Plot Plans” on 
page 553. 

Create the Layout

1. If one does not exist, create a Layout file 
with a title block, placing the border, 
title block, and other text on page 0. See 
“Layout” on page 863.

2. Send views to the layout. See “Sending 
Views to Layout” on page 866.

3. Print the plan. See “Printing & Plotting” 
on page 841.

Viewing Your Plan
You can see your model in a variety of 
different 2D and 3D views. You can display 
more than one view at a time; and in any 
view, you can pan or zoom in or out. See 
“Zoom & View Tools” on page 653. 

Floor plan view is a 2D view of the model and 
is most commonly used for drawing and 
editing. In floor plan view, each floor displays 
separately and you can only edit one floor at a 
time; however, you have extensive control 
over which objects display at any given time, 
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can easily switch between floors, and can also 
display items on a second floor for reference. 

You can create interior and exterior 3D views 
of your model from any perspective. As in 
floor plan view, you can select and edit many 
objects in 3D views and control which objects 
are visible. See “3D Views” on page 663. 

You can also create Doll House Views that 
show only the current floor plus any floors 
beneath it. Ceilings on the current floor are 
omitted so you can see the interior, visualize 
the relationships between spaces, and plan 
traffic flow.

Framing Overviews display framing in 3D, 
provided that framing has been built. You can 
customize 3D views to serve special purposes 
such as this.

The Cross Section and Elevation camera tools 
create scaled 2D views of a model’s exterior 
and interior that can be dimensioned and 
annotated. Just as in other views, you can 
select and edit objects in a Cross Section/
Elevation view as well as control which 
objects display. 

Layout
All plan views can be sent to a layout 
where they can be arranged to produce 

construction documentation. See “Sending 
Views to Layout” on page 866.

All views can also be exported as a graphic 
image. See “To export a picture” on page 
811.
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Getting Help
There are many forms of help 
available in Home Designer Pro 

including: Tool Tips, the Status Bar, and the 
online Help menu. 

All these forms of help assume you have a 
basic working knowledge of the Windows® 
operating system, including how to use a 
mouse, open, close and save files, copy, 
paste, and right-click to access contextual 
menus. Help also assumes you are familiar 
with Windows® terminology.

More information is available in the product 
documentation in both printed and electronic 
format and on Home Designer’s official web 
site,  www.HomeDesignerSoftware.com. See 
“Additional Resources” on page 905.

Tool Tips
When you move the pointer over a toolbar 
button or menu item, a Tool Tipdisplays, 
offering a brief description of the tool. More 
information displays in the Status Bar at the 
bottom of the window.

Online Help Menu
Online Help is a searchable menu that 
provides information about all of the tools in 

Home Designer Pro. Select Help> Contents 

& Index  to open the online Help and 
explore the table of contents, browse the 
Index, or search for keywords.

Current Mode Help
Online Help can also be used to provide 
instant information about toolbar buttons, 
menu items, and objects in your plan.
• When you move the cursor over a toolbar 

button or menu item, a brief summary of 
that tool displays in the Status Bar. Press 
the F1 key to open online Help to a page 
with more information about the tool.

• When an object is selected, edit handles 
display. Place the cursor over an edit han-
dle and press F1 to open online Help to a 
page with information about that handle. 

• Press the Help button in any dialog box 
to open online Help to a page describing 
the options in that dialog. 

About Home Designer Pro
Select Help> About Home Designer Pro to 
view information about your software 
license, the program’s version number, and 
its release date.

Contact information for Chief Architect, Inc. 
is available on the More Information tab.

Chief Architect strives to make our docu-
mentation as helpful as possible for all of
our customers. Please send any questions,
comments, or feedback to 
documentation@chiefarchitect.com.

http://www.homedesignersoftware.com/
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Upgrade to Chief Architect
Select Help> Upgrade to Chief Architect to 
launch your default web browser to the Chief 
Architect web page, www.chiefarchi-
tect.com, where you can learn about this 
powerful home design software for building 
professionals.

Chief Architect can open plans originally 
created in Home Designer, and offers an 
extensive set of drawing, editing and 
rendering tools that allows you to produce 
complete, professional working drawings.

http://www.chiefarchitect.com/
http://www.chiefarchitect.com/
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Chapter 2:

File Management

Home Designer Pro reads and edits two main 
document types: .plan files and .layout files. 
The complete 3D model of a structure, 
surrounding terrain and any CAD data 
associated with it are stored in the plan file. 
Data used to create working drawings and 
the links to various views are stored in the 
layout file.

All commands related to opening, saving and 
closing plans are located in the File menu. 
You can also open plans from the Startup 
Options dialog. See “Startup Options” on 
page 24.

Just as with files created in other software 
applications, you should back up your plan 
and layout files externally on a regular basis 
to avoid accidental loss of work.

Chapter Contents
•      Compatibility with Other Programs
•      Organizing Your Files
•      Home Designer Pro Data
•      Creating a New Plan or Layout
•      Saving, Exporting, and Backing Up Files
•      Thumbnail Images
•      Auto Archive
•      Undo Files
•      Opening and Importing Files
•      Searching for Plans
•      Backup Entire Plan
•      Closing Views and Files
•      Exiting Home Designer Pro
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Compatibility with Other Programs
Plans and layout files produced in the 
following programs can all be read by Home 
Designer Pro 2014. 

• Chief Architect® X1 through X4 (limited 
editability if enabled)

• Chief Architect® 5.0 through 10.08 (read 
only)

• 3D Home Architect® 3.0 and 4.0

• Chief Architect® Home Edition 5.0
• All Better Homes and Gardens Home 

Designer® products, Interior Designer, 
and Landscaping and Deck Designer, Ver-
sions 6 through 8.

• All Chief Architect Home Designer® 
products, Interior Designer, and Land-
scaping and Deck Designer, Versions 9 
through 2014.

• Trading Spaces® Design Companion™

Only the .PL1, .LA1, .plan, and .layout files 
from prior versions can be opened in Home 
Designer Pro 2014.

Files that have been opened and saved in 
Home Designer Pro 2014 cannot be read by 
any of the program versions listed above. To 
continue to read files in the program in which 
they were created, be sure to create copies of 
your files before opening them in Home 
Designer Pro 2014. 

Plans created in Chief Architect, build 11.4 
and later, can be opened in Home Designer 
programs for viewing and annotating only. 
Limited editability in Home Designer 
programs is an option that can be enabled 
when the file is opened in Chief Architect.

Several steps are required to successfully 
convert plans created in an earlier program 
version to the Home Designer Pro 2014 
format. Before doing so, see “Before You 
Begin” on page 917.

Organizing Your Files
You should keep your plan and layout files 
separate from the support files needed to run 
Home Designer Pro. To keep files organized, 
you may find it helpful to create a new folder 
for each project.

Home Designer Pro files may use imported 
images, textures and other custom content 
saved in their own external data files. 

Consider storing copies of all external files in 
the same folder as the plan and layout files 
that use them so that they are easily found. 

Here is one way to organize your files:
• Create a folder in  your Documents direc-

tory  (“My Documents” in Windows XP) 
called  “Home Designer Pro Plans” or 

Note: 3D Home Architect 5.0 was not devel-
oped by Chief Architect, Inc. Plans written
using 3D Home Architect 5.0 or later cannot
be read by Home Designer Pro.
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another name you prefer. See Microsoft 
Windows Help to learn how to create 
folders.

• Inside this folder, make a new folder for 
each client or project. Save all the files for 
that client or project inside this folder, 
including plan and layout files and refer-
enced external files. See “Saving, Export-
ing, and Backing Up Files” on page 43.

Bear in mind, though, that path names 
exceeding 260 characters cannot be opened 
by Home Designer Pro. As a result, it is a 
good idea to limit the number of embedded 
folders you use in your file organization 
method.

Once you understand the file management of 
Home Designer Pro, you should decide on a 
naming convention that suits your needs. 

To specify a default Save As location

1. Select Edit> Preferences , then 
select New Plans from Category list. See 
“New Plans Panel” on page 71. 

2. Under Open and Save As, click Use this 
Folder. The Browse button becomes 
available.

3. Browse to the folder you plan to save 
your projects in. Click OK.

Home Designer Pro Data
When Home Designer Pro 2014 is installed, 
the program automatically creates a folder in 
the user Documents directory called Home 
Designer Pro 2014 Data. This folder 
contains important user-specific information 
saved in the following folders and files and 
should not be moved, renamed or deleted: 
• Archives - A folder of automatically 

archived plan and layout files. See “Auto 
Archive” on page 46. 

• Backdrops - A folder of custom back-
drop images. See “3D Backdrops” on 
page 679.

• Images - A folder of custom images. See 
“Adding Materials and Images” on page 
614.

• Database Libraries - A folder of user 
library data. See “Library Content” on 
page 609.

• Scripts - A folder for custom Ruby 
scripts associated with Chief Architect 
plans.

• Templates - A folder of plan and layout 
template files. See “Creating a New Plan 
or Layout” on page 42.

• Textures - A folder where you can save 
image files used to create custom material 
textures. See “Creating Materials” on 
page 637. 

• Toolbars - A folder of customized toolbar 
files. See “Toolbar Customization Dia-
log” on page 93. 

It is recommended that each layout file
be saved in the same folder as the plan

file(s) associated with it. See “Managing Lay-
out Links” on page 873. 
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• mmaster.mat - The Master Materials List 
file. See “The Master List” on page 899. 

• units.dat - A list of user-created units of 
measurement. See “Unit Conversions 
Panel” on page 71. 

The name of the Home Designer Pro 2014 
Data folder cannot be changed, but you can 
specify its location on your computer in the 

Preferences  dialog. It’s best to use a 
location on your local hard drive. See 
“Folders Panel” on page 69.

Just as with your plan and layout files, it is a 
good idea to back up your Home Designer 
Pro 2014 Data folder. 

Because the Home Designer Pro 2014 Data 
contains custom user data, it is not deleted 
when the program is uninstalled. See 
“Uninstalling Home Designer Pro” on page 
23 of the User’s Guide.

Creating a New Plan or Layout
To open the Create New Plan dialog, 
select File> New Plan. 

You can also choose New Plan in the 
Startup Options dialog. See “Startup 
Options” on page 24.

Create a new layout file by selecting 
File> New Layout or by sending a 

view to layout when no layout file is yet open 
or associated with the current plan file. See 
“Creating a Layout File” on page 865.

By default, a new layout file will be assigned 
the same name of the first plan file sent to it, 
associating the layout files with the plan files 
used. 

New, blank plans are called  Untitled.plan 
and new, blank layout files, Untitled.layout. 

Unless these files are named and saved, they 
will be lost when closed. See “Saving, 
Exporting, and Backing Up Files” on page 
43.

Units of Measurement
All plan and layout files save measurements 
in either Imperial or metric units. New files 
are created using one or the other, depending 

on the current setting in the Preferences  
dialog. When the program is first installed, 
the Windows OS setting for units determines 
what system is used. See “New Plans Panel” 
on page 71.

A plan or layout file’s unit of measurement 
must be specified before it is created and 
cannot be changed later.

While it is recommended that you create new 
plans using the type of unit that you plan to 
use, you can display dimensions using any 

If the Home Designer Pro 2014 Data
folder is renamed, moved or deleted,

the program will automatically replace it
using default information from the Home
Designer Pro installation folder.  When this
occurs, customized user settings and cus-
tom user library content will not be available.

Note: Only one layout file can be open at any
given time.
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type of unit. See “Dimension Preferences 
and Defaults” on page 719.

Template Plans
When you select File> New Plan in 
Home Designer Pro, the Create New 

Plan dialog opens, letting you select a 
template for your new plan. The resulting 
new plan uses either metric or Imperial units 
of measurement and predefined default 
settings, layer settings, wall definitions, and 
page setup information. 

Home Designer Pro includes a selection of 
plan templates, each with different default 
settings that allow you to begin working in a 
particular plan style quickly. See “Default 
Settings” on page 56.

Choose a category from the drop-down list, 
then select a style template from the 
scrollable list beneath it. If you are uncertain 

as to the right style for your plan, choose 
Default, as you cannot change the plan style 
template once a plan has been created.

Select either U.S. Units or Metric Units of 
measurement, and click OK. The floor plan 
view window opens, ready for you to begin 
drawing.

Saving, Exporting, and Backing Up Files
Saving, exporting, and backing up your files 
are three separate tasks that accomplish 

different things: 
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• Saving a plan or layout file retains your 
work so that it can be later opened in 
Home Designer Pro.

• Exporting a file allows you to save certain 
kinds of data in a format that can be used 
by a program other than Home Designer 
Pro.

• Backing up your files involves taking 
steps to make sure that your valuable data 
is protected and available when needed. 

Saving Plan and Layout Files
When you first save a new, 
untitled file, you must select a 

location for it on your computer and give it a 
name. There are two options for saving plan 
and layout files: File> Save and File> Save 
As.

By default, a new layout file is assigned the 
same name as the first plan file from which a 
view is sent to it. It is also saved in the same 
directory as the plan file. If no view has been 
sent to a layout, it remains untitled until you 
save it.

Both Save  and Save As  can be used 
to save your plan and layout files; however, 
they accomplish this in two different ways.

• File> Save  saves the current state of 
your plan or layout file without changing 
its name and should normally be used for 
saving your work.

• File> Save As  opens the Save Plan 
File dialog, allowing you to save the plan 
or layout file using a different name or 
location on your computer. 

To save an untitled plan or layout file

1. Select File> Save  to open the Save 
Plan File dialog.

2. In the Save in drop-down, browse to the 
location on your computer where you 
would like to save the file. See “Orga-
nizing Your Files” on page 40.

3. In the File name text field, type a name 
for the file. 

4. Home Designer Pro automatically 
assigns the File of type and file exten-
sion .plan to plan files and .layout to 
layout files.

5. When both the Save in location and File 
name are correct, click Save. 

Any previously saved cross section/elevation 
views associated with the plan are also saved 
with this command.

When saving a layout, the program saves all 
the links to the various views saved in the 
layout, and all the CAD objects added to the 
.layout file.

Although the program warns you if you
try to exit without saving, you should get

in the habit of saving plan files before exiting
the program.
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Initially, all Open  and Save As  
operations go to the “My Documents” folder 
of your computer. After that, the location last 
visited is remembered and subsequent 

Open  or Save As  commands default 
to the directory last used for that operation. 
This path is saved when the program exits. 
The next time Home Designer Pro is 
launched, these defaults are used.

If you prefer, you can instead specify a 

directory to be used for all Open  or Save 

As  operations in the Preferences  
dialog. See “New Plans Panel” on page 71.

Exporting Files
Home Designer Pro has a number of options 
for exporting  and importing information out 
of and your drawings. Often, file export 
dialogs are nearly identical to the Save Plan 
File dialog. See “Importing & Exporting” on 
page 827. 

Similarly, file import dialogs are often 
similar to the Open Plan File dialog. See 
“Importing Files” on page 49. 

Revision Files
Revisions are a common aspect of any design 
project. There are a number of possible 
strategies for organizing revision files:
• Prepending the file name;
• Appending the file name;
• Saving revisions in separate folders.

To avoid confusion and potential mistakes, it 
is recommended that you always give files 
unique names - including revision files. If 
you choose to organize your revisions by 

saving them in separate folders, you should 
also give each file a unique name that makes 
it impossible to confuse it with another file 
saved in a different folder.

Backup Entire Plan

File> Save As  is a simple way to transfer 
a plan or layout to a different location on 
your computer. Bear in mind, though, that 
plan and layout files often reference external 
data files such as imported textures, images, 
and backdrops. These external files are not 

affected when Save As  is used. 

If you transfer a plan file from one computer 
to another, the program will warn you of 
missing files if the external data files used by 
the plan cannot be found when you open it. 

Layouts are also dynamically linked to plan 
files. When transferring layout files to 
another computer, be aware that the plan files 
are also external file references and are not 
actually contained in the layout. 

When transferring plans or layouts to another 
computer that does not have these external 

files, use the Backup Entire Plan  tool. 
See “Backup Entire Plan” on page 52.

Backing Up Your Files
It is always a good idea to create 
backup copies of all your important 

files on your computer. 

It is strongly recommended, however, that 
you never save directly:
• Across a network, such as onto a server;
• Onto removable media such as a USB 

thumb drive, CD, or DVD;
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• Across the Internet.

Instead, copy your files to such locations in 
Windows Explorer only after you have saved 
them on your computer’s hard drive and 
exited the program.

Similarly, you should never open files saved 
in these locations. Copy the files to the local 
hard drive, and then open them. See 
“Opening and Importing Files” on page 48.

Archive folders are used by Home Designer 
Pro to manage prior versions of your files. 
You should not view these files as a 
substitute for your own backup routine, and 

should never save a file in an archive folder. 
See “Auto Archive” on page 46.

When backing up your Home Designer Pro 
files, consider backing up not only your 
.plan and .layout files, but your custom user 
data, as well - including library content, 
toolbar configurations, and textures. This 
custom data is all located in the Home 
Designer Pro Data folder, so it can be easily 
backed up. See “Home Designer Pro Data” 
on page 41.

You can, if you wish, create a folder inside 
the Data folder for your .plan and .layout 
files, as well. See “Organizing Your Files” on 
page 40.

Thumbnail Images
A thumbnail is a miniature image that helps 
identify a file in the Open Plan File dialog 
and in the Find Plan Wizard. Any view of a 
plan or any layout page can be saved as the 
thumbnail. See “Searching for Plans” on 
page 50.

If thumbnails are enabled in the 

Preferences  dialog, the program 
automatically creates one when you first save 
a new plan or layout. You can choose to 
generate small or large thumbnails. See “File 
Management Panel” on page 68. 

To create a custom thumbnail image

1. You must save the file and give it a name 
before you can save a thumbnail.

2. Create the 2D or 3D view that you want 
to use as a thumbnail for the current file.

3. With the desired view active, select 

File> Save Plan Thumbnail .

Thumbnails are saved using the same 
filename as the associated plan or layout file 
with the _p.jpg file extension for plans and 
_l.jpg for layouts. If a thumbnail already 
exists, the program asks if you want to 
overwrite the existing thumbnail.

Auto Archive
The first time a plan or layout is saved, 
Home Designer Pro creates an Archive 
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folder in the Home Designer Pro Data folder. 
The Archive folder contains Auto Save and 
Archive files. 

The program does not create Auto Save and 
Archive files for untitled plans and layouts. 
In order for these to be created, a file must 
have been previously saved and given a 
name and save location on your computer. 
Further, Archive files are only updated when 
you save your work.

Auto Save and Archive files should not be 
viewed as a substitute for regularly saving 

your work by selecting File> Save  or 
pressing Ctrl + S on the keyboard, nor should 
they be considered an alternative to your own 
file backup routine.

Archive Files
Every time a drawing is saved, Archive files 
that keep a historical archive of your plan are 
automatically created or updated. 

Plan, layout and related files from previous 
versions of the program are automatically 
moved to the archive folder when the plan is 
opened and saved in Home Designer Pro.

Archive files are meant to be for emergency 
use only. If you must access an archive file, 
open it as you would any other file. See 
“Creating a New Plan or Layout” on page 42. 

As soon as the file is open, use Save As  
to save this file to another location.

Auto Save Files
As you work, Home Designer Pro 
automatically creates Auto Save files at 
regular intervals when changes are made to a 
file but not saved by selecting File> 

Save . 

These Auto Save files are appended 
_auto_save.plan or _auto_save.layout and 
are saved in the Archive folder. 

When you close a file normally, its Auto 
Save file is retained until the next time the 
file is opened - at which time the Auto Save 
file is overwritten.

You can enable Auto Save and set its 

frequency in the Preferences  dialog. See 
“General Panel” on page 67. 

Auto save files created as a result of an 
improper program shutdown are appended 
_auto_save_bak.plan or 
_auto_save_bak.layout.

If your computer shuts down accidentally, 
you can recover some of your work by 
opening the _auto_save_bak file.

When you reopen a file after a computer shut 
down or system crash, the following dialog 

Regardless of what archiving option you
select in the Preferences dialog, iIf you

do not save your work regularly, your archive
files will not be updated.

A file is auto saved only if you have
saved it previously. Auto Save does not

work for unnamed files. 

Auto Save file after normal shut-down

Auto Save file after abnormal shut-down
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displays if an Auto Save file newer than the 
original file is found. 

Even with Auto Save, you should save your 
work manually on a regular basis using any 
of the following methods: 

• Click the Save  button.

• Select File> Save .
• Press Ctrl + S on the keyboard.

Undo Files
Home Designer Pro stores a set number of 
copies of all open plan file changes, known 
as undo files. Undo files are referenced 

whenever you select Edit> Undo  or 

Edit> Redo . See “Undo and Redo” on 
page 173.

Undo files are stored in the Undo Directory, 
which can be specified in the Preferences 

 dialog. See “Folders Panel” on page 69.

By default, the Undo Directory is the 
Windows Temporary Directory.  When you 

use Windows system cleanup features, these 
files can be deleted.  Because of this, you 
should only use these type of utilities when 
Home Designer Pro is not running.

The maximum number of Undo files is 
specified in the Maximum Undos value in 
the Preference settings. If you have Undo 
enabled, be sure to define a directory on a 
hard drive with enough space for these files.

When Home Designer Pro is closed 
normally, any current Undo files are deleted.

Opening and Importing Files
Opening and importing files are often similar 
tasks, but accomplish two very different 
things:
• Opening a file refers to opening it in the 

program in which it was created. Only 
plan or layout files can be opened in 
Home Designer Pro. See “Compatibility 
with Other Programs” on page 40. 

• Importing a file brings data that was cre-
ated in a different program into Home 
Designer Pro. A number of different file 

types can be imported into Home 
Designer Pro.

Select File> Open Plan to open 
an existing .plan file or File> 

Open Layout to open an existing .layout file 
located on your computer. Home Designer 
Pro automatically browses to either the 
directory last used or to a specific directory, 

depending on your current Preferences  
settings. See “New Plans Panel” on page 71.
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The Open Plan File and Open Layout File 
dialogs can be resized by clicking and 
dragging the lower right corner. 

• In the Look in drop-down, browse to the 
location on your computer where the file 
you wish to open is saved. 

• Any folders and either .plan or .layout 
files in the current location display in the 
field below. The file type that displays 
depends on the Files of Type selection.

• Click on the file you wish to open. Its 
name will display in the File name text 
field. 

• If a preview image of the file is available, 
it will display on the right side of the dia-
log. See “Thumbnail Images” on page 46.

• The only file types available in the Files 
of type list are .plan and .layout. 

• When the desired file is selected, click 
Open. 

Plan files open to the floor that was active 
when the file was last saved and closed; 
layout files open to the page that was active.  

Importing Files
Home Designer Pro has a number of options 
for exporting and importing information out 
of and into your drawings. Often, file import 
dialogs are nearly identical to the Open Plan 
File dialog. See “Importing & Exporting” on 
page 827. 

Similarly, file export dialogs are often similar 
to the Save Plan File dialog. See “Exporting 
Files” on page 45. 

Recently Opened Files
The names of the plan and layout files you 
most recently opened or saved display at the 
bottom of the File menu. Click on a recent 

Never open a file located on a server or
other computer on a network, or on a

removable storage device. Copy such files to
your local machine’s hard drive first, and then
open the copy.
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file to open that file without using the Open 
Plan File dialog. 

The maximum number of recent files listed 
in the File menu can be changed in the 

Preferences  dialog. See “File 
Management Panel” on page 68.

The names of recently open files also display 
in the Startup Options dialog. Click on the 
name of a file to open it. See “Startup 
Options” on page 24.

Searching for Plans
Select Tools> Plan Database> 
Search for Plans to locate an 

existing, fully-editable sample plan or search 
a selection of non-editable plans by popular 

home designers. This command opens the 
Find Plan Wizard, which helps you search 
for plans based on parameters that you 
define. 

Find Plan Wizard
The Find Plan Wizard can be used to search 
for plans using stored information about each 

plan, such as the style of construction and the 
number of bedrooms and other room types. 

Begin by selecting either a database of 
editable sample plans or a collection of house 

plan drawings by popular home plan 
companies, then click Next to continue. 
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House Style

At the bottom of each page, the number of 
plans that match your current search 
parameters displays. As you modify the 
parameters, this number increases or 
decreases as matching plans are found.

On any page, click the Back button to 
modify any  previously selected parameters. 

Select the style of house desired, the number 
of floors in the house, and the number of 
bedrooms, then click Next to continue. 
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House Size

Select the number of bathrooms and square 
footage of the house, then click Next to 
continue. 

Plan Details
Click on the name of a plan in the list to see a 
preview of the plan 

Click Next, then click the Finish button to 
open the selected plan. 

Backup Entire Plan
Because Home Designer Pro plans 
and layouts often contain many 

references to other external files, it is 
necessary to copy all the associated files to a 
new location when a plan or layout is moved. 
You can do this easily by selecting File> 
Backup Entire Plan.

Backing up an Entire Plan is important when:
• Migrating legacy files created in older 

program versions. 
• Transferring files to another computer or 

sending them to another user. 
• Archiving or backing up your work.
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To back up a plan or layout

1. To copy all associated plan or layout 
files to a new directory, select File> 

Backup Entire Plan . The Backup 
Entire Plan dialog opens for you to 
choose what files are copied.

•  Choose Backup All Files to copy all 
plan or layout files and all externally 
referenced files such as linked plan 
files, inserted picture files, metafiles, 
and texture, image, and backdrop 
graphics files. 

•  Choose Backup Plan Files Only to 
copy all associated plan files and any 
externally linked files and inserted pic-
ture files, but no graphics or texture 
files. This is best used only when trans-
ferring a file to a computer that already 
has the graphics files installed.

2. When you click the OK button in the 
Backup Entire Plan dialog, the Browse 
for Folder dialog opens. Here you can 

select the destination folder for the asso-
ciated plan files.

3. Navigate to any empty folder on your 
system and click on it to select it. 

•  To create a new folder, click on a folder 
already present on your system, then 
click the Make New Folder button. 

4. With the destination folder for the 
backup selected, click OK. 

Closing Views and Files
Choose File> Close to close the active 
window. If it is the last open view for a plan 
and you have not saved it, the program  
prompts you to save before closing. Edited 
cross section/elevation views also prompt 
you to save before closing. 

Select File> Close All to close all currently 
open windows. 

You must select an empty folder for the
Backup Entire Plan feature to work. If

you select an existing folder that is not empty,
the backup is cancelled.

Although the program warns you if you
try to exit without saving, you should get

in the habit of saving plan files before exiting. 
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Exiting Home Designer Pro
Select File> Exit to exit the program. If you 
have not saved any open plans, you are 
reminded to do so. It is better to save your 
work before exiting than to save on exit. 

When you exit from the program using File> 
Exit, all Autosave files and Undo files are 
automatically deleted. 
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Chapter 3:

Preferences &
Default Settings

Preferences are global settings that affect the 
functionality and appearance of the Home 
Designer Pro environment, while default 
settings control what objects look like when 
they are initially created. You can save time 
and increase your productivity by becoming 
familiar with these settings and customizing 
them before you begin a new project or as 
needed thereafter.

Chapter Contents
•      Default Settings vs Preferences
•      Dynamic Defaults
•      General Plan Defaults Dialog
•      Reset to Defaults
•      Preferences Dialog
•      Number Style/Angle Style Dialog
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Default Settings vs Preferences
Default and preference settings have 
important effects on how the tools in Home 
Designer Pro function. Default settings are 
file specific, while Preferences are global, 
taking effect regardless of what file is open. 

Defaults and Preference settings can be 
customized to suit your needs and improve 
your efficiency, so it is recommended that 
you become familiar with them and learn 
how you can use them to your advantage.

Default Settings
Default settings determine the initial 
characteristics of objects when they 

are first drawn. For example, when you place 
a base cabinet in a plan, its size, materials, 
front items, hardware are determined by 
settings in the Base Cabinet Defaults 
dialog.

Some defaults affect the structure of your 
model: for example, Floor, Foundation, 
Framing, and Wall defaults. 

Defaults are file-specific, which means that 
any changes that you make to the default 
settings in one plan or layout file will have 
no effect on other plans or layout files. 

You can access a complete list of the various 
default settings by selecting Edit> Default 

Settings  from the menu.

• Click the + beside a category to expand it 
and access the defaults for items related to 
that category.

• To open the defaults dialog associated 
with an item in the list, double-click on 
the line item, or click on the item and then 
click the Edit button.

• General CAD defaults are view-specific 
and are only available in views where 
CAD objects can drawn. See “CAD 
Defaults Dialog” on page 770. 

Many defaults dialogs can also be opened by 
double-clicking on a parent and/or child 
toolbar button of a tool affected by the 
settings in that dialog. For example, you can:

• Double-click the Cabinet Tools  par-
ent button to open the Defaults Settings 
dialog for Cabinet tools only;
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• Double-click the Base Cabinet  child 
button to open the Base Cabinet Defaults 
dialog.

Preferences
Preference settings influence the 
overall environment of the program, 

such as what the interface looks like, how the 
tools are accessed, and the basic rules 
governing how objects are drawn and edited. 
See “Preferences Dialog” on page 60. 

Unlike default settings, preferences are 
global, which means that any changes that 
you make to them will take effect in all plan 
and layout files. 

To access the Preferences dialog, select 

Edit> Preferences  from the menu.

Region and Language Settings
There are a few formatting considerations in 
Home Designer Pro that are set based on 
your Windows® operating system’s Region 
and Language Format: 
• Units of measurement - When you first 

install and launch the program, your tem-
plate plan and layout files will be set to 
use either Imperial or metric units, 
depending on your Windows settings. See 
“New Plans Panel” on page 71. 

• Decimal mark format - Depending on 
your Windows settings, either a period or 
a comma will be used in dimension lines, 
dialogs, and anywhere the program can 
display a numeric value using decimals.

• Currency - The currency associated with 
your Region and Language Format will 
be used in the Materials List, 
Components dialogs, and Loan Calcula-
tor. See “Materials Lists” on page 887 and 
“Loan Calculator” on page 802. 

Dynamic Defaults
Dynamic defaults are values that can be 
changed globally throughout a model. 
• If you change a dynamic default value in 

a defaults dialog, all objects of that type 
that are set to use the default will update 
automatically to use the new value.

• Any objects of that type that are not using 
the default value because of editing will 
not be affected if you change the default. 

Dynamic defaults are found in the default 
dialogs of a variety of objects, including 
dimension lines, walls, doors, cabinets and 
rooms.

Materials are another example of an attribute 
that uses Dynamic Defaults. See “Material 
Defaults” on page 650.

In object specification dialogs, dynamic 
defaults are followed by either a (D) in the 
value field or a Default check box.
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To edit a dynamic default, delete the (D) or 
remove the check from Default box and type 
the desired value. 

To reset a value back to the dynamic default, 
type the letter D in the field or click the 
Default checkbox.

General Plan Defaults Dialog
The settings in the General Plan Defaults 
dialog control basic features of the Home 
Designer Pro environment. To open this 

dialog, select Edit> Default Settings , 

select Plan, and click the Edit button, or 

double-click the Select Objects  button.

General Settings - Specify the default 
functionality for a variety of general 

behaviors in the program. 
• Check Warn Before Delete Selected 

Item if you want the program to require 
confirmation before an item is deleted.

• Check Ignore Casing for Opening 
Resize to allow wall openings such as 
doors to be positioned against an inter-
secting wall. Clear this box retain suffi-
cient space for the opening’s specified 
trim width.

1 2

3 4

1
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• Check Fixture/Furniture Resize Enable 
to allow the resizing of library symbols. 
When enabled, fixtures and furniture can 
be resized from 1 to 2000 inches (10 to 
32760 mm).

• Check Show Pitch as Degrees to display 
the roof pitch in degrees.

•  Home Designer Pro automatically calcu-
lates the square footage of each floor in 
the plan and shows this number as the liv-
ing area in floor plan view. Uncheck 
Show “Living Area” to disable the dis-
play of the Living Area label. See “Living 
Area” on page 237. 

• Enter the number of Inches/MM Scrolled 
by Hotkeys in floor plan view. See 
“Using the Arrow Keys” on page 655.

Specify the Allowed Angles used when 
Angle Snaps are enabled. See “Angle 

Snaps” on page 111.
• Select 15 Degrees to enable Angle Snaps 

in 15° increments.
• Select 7 1/2 Degrees and additional 

angles to enable Angle Snaps in 7 ½° 
increments. 

You can also enter up to eight Additional 
Angles in the fields provided. Click the 
Number Style button to specify the format 
used to enter angles. See “Number Style/
Angle Style Dialog” on page 89.

The Snap Grid allows you to snap 
objects to specific points on-screen as 

they are moved or resized. See “Grid Snaps” 
on page 112.
• Check Use Snap Grid/Units to enable 

Grid Snaps.
• Specify the Snap Unit you wish to use. 

• Uncheck Show Snap Grid to turn off the 
display of the Snap Grid, a visual indica-
tor of the location of the snap points. 

• Click the Color bar to specify the Snap 
Grid Color. See “Color Chooser Dialog” 
on page 651. 

• Check Display as Dots to display the 
Snap Grid using dots rather than lines. 

Specify the display of the Reference 
Grid.

• Specify the Reference Grid Size.
• Check Display as Dots to display the 

Reference Grid using dots rather than 
lines. 

You can also click Grid Snaps  toggle 
button to turn on/off grid snapping or click 

the Display Reference Grid  toggle 
button to turn on/off the grid display. 

Reset to Defaults
Select Edit> Reset to Defaults to open the 
Reset to Defaults dialog. 

This dialog allows you to clear the special 
settings you have made in various parts of 
your plan. 

2

It may be helpful to change the Snap
Unit temporarily when working with

large objects such as terrain or small objects
such as molding profiles.

3

4
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The settings can be cleared for the 
current floor or for All Floors.

Floor and Ceiling Heights - Floor and 
ceiling heights for any room can be 

changed in the Room Specification dialog. 
Check to reset the default values as specified 

in the Floor Defaults dialog. See “Floor 
Defaults Dialog” on page 316.

Roof Groups - You can designate a 
different roof group for a room in the 

Room Specification dialog. This builds the 
roof over this room and others in the same 
roof group independently from the roof built 
over other parts of the plan. Check to reset to 
the default roof group, zero. See “Roof 
Groups” on page 353. 

Roof Directives - You can specify how 
the roof builds above an exterior wall in 

its Wall Specification dialog. When Roof 
Directives are reset, all items on the Roof tab 
are unchecked and any value, such as the 
roof pitch, is reset to the default. See “Roof 
Directives in Walls” on page 353. 

Wall Top Heights and Wall Bottom 
Heights - Wall shape and height can be 

edited in 3D views. Check to reset wall 
shapes and heights. See “Editing Walls” on 
page 197.

Preferences Dialog
The settings in the Preferences 
dialog are global: they apply to all 

plan and layout files and are preserved 
between sessions. To access this dialog, 
select Edit> Preferences. 

The Preferences dialog consists of panels 
which are accessed by clicking on the names 
in the Category tree along the left side.

The category tree structure is similar to other 
Windows programs. A “+” next to a category 
indicates that it has subcategories. Click the 
“+” to make the subcategories visible; to hide 
them, click the “-.”

The program remembers which panel you 
last accessed and opens to that panel the next 
time you open the dialog.

Preference dialog panels: 
•      Appearance Panel
•      Colors Panel
•      Font Panel
•      Library Browser Panel
•      Text & Page Setup Panel
•      General Panel
•      File Management Panel
•      Folders Panel
•      New Plans Panel
•      Unit Conversions Panel

1

2
3

4
5

1

2

3

4

5
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•      Architectural Panel
•      CAD Panel
•      Line Properties Panel
•      Sun Angle Panel
•      Edit Panel
•      Behaviors Panel
•      Snap Properties Panel

•      Materials List Panel
•      Report Style Panel
•      Master List Panel
•      Categories Panel
•      Render Panel
•      Video Card Status Panel
•      Reset Options Panel

Appearance Panel

When Contextual Menus are enabled, 
you can right-click an object and a 

contextual menu displays with options that 
are unique to the selected object. The options 

in a contextual menu are usually the same as 
those on the Edit toolbar. 

A menu of general commands displays if you 
right-click in an empty space in a view 
window, away from any object. 

1
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Since Home Designer Pro can use the right-
click as a general select, you have the option 
to disable or limit the contextual menus. 
• Check Enabled to activate contextual 

menus. Clear the check box to disable 
contextual menus.

• Check Click Twice to Display to require 
two right-clicks on an object before the 
contextual menu displays. This allows the 
first right-click to be a general select. See 
“Selecting Objects” on page 124. 

In 3D views, the two clicks must be on 
the same object surface in order for the 
contextual menu to display: Clicking on 
two different surfaces of the same object 
is treated like two single-clicks. 

The Status Bar at the bottom of the 
main window displays information 

about the current state of the program. See 
“The Status Bar” on page 31.

• Check Enable to activate the Status Bar 
or clear the check box to disable it.

• Check Show Screen Redraw Time to 
display the number of seconds it takes to 
redraw the screen. This is useful for deter-
mining the effectiveness of the 3D accel-
eration of your graphics card. 

• Check Show Coordinates to display the 
coordinates of your cursor at all times on 
the right side of the Status Bar.

The number style for the coordinates is 
controlled in the Number Style/Angle Style 
dialog.  See “Number Style/Angle Style 
Dialog” on page 89.

Check Show Line Weights to represent 
line weights on-screen. Because of 

monitor DPI, lines may appear to be much 
wider on screen than when they are printed. 
Zooming closer may reflect a more accurate 
idea of the actual line width. 

Specify the Min Display Weight, the lowest 
line weight possible on screen, regardless of 
how far you zoom out. A Minimum Display 
Weight of 0 is the same as 1. This setting is 
ignored when printing or when Print 

Preview  is enabled.

Specify how Toolbars present child 
tools when a parent button is clicked.

• Choose Parent-Child to display child 
tools as buttons at the end of the toolbar 
where the parent button resides.

The contextual menu for a base cabinet

2

The line weight for CAD objects may be
defined individually through each

object’s specification dialog or globally in the
Layer Display Options dialog.

3
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• Choose Drop Down to display child tools 
when the drop-down arrow to the right of 
the parent button is clicked.

Images and Pictures - Check Always 
Display in Color to display images and 

pictures in color, even if color is turned off in 
a particular view. If you uncheck the box, 
pictures and images appear in grayscale 
when color is turned off.

Check Show Icons to display tool icons 
next to items in the menus.

Double Buffer Drawing - Double 
buffering means that all drawing is 

done to an offscreen bitmap and then copied 
to the screen. The result is that the screen 
does not flicker, but there may be a slight 
delay before individual objects appear on 
screen. This option does not affect Rendered 
views.
• Check Plans and Layouts to double-buf-

fer in floor plan view and layouts.
• Check Elevations and Vector Views to 

double buffer in cross/section elevation 
and Vector views.

• Check Auto Cache to save a bitmap of 
the last screen draw. This bitmap is used 
to refresh the screen if no changes are 
made to the model. This option is not 
available on computers running Windows 
Vista.

Color Off is - Specify whether views 
appear in Black and White or  

Grayscale when color is toggled off. Does 
not apply to Rendered views. See “In Vector 
Views” on page 678.

Specify the Minimum Display Size of 
Dimensions and Labels, in pixels. This 

is the on-screen size and does not affect 
printed or exported output. To display 
dimensions and labels on-screen at the 
printed scale, set this value to 0 or turn on 

Print Preview . 
• Dimension sizes are set in the Dimension 

Defaults dialog. See “Dimension 
Defaults Dialog” on page 720. 

Colors Panel

Click a color bar to open the Color Chooser 
dialog. See “Color Chooser Dialog” on page 

651. 
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Background Color - Click the color 
bar to select the background color for 

all views except some 3D views. See 
“Rendering Techniques” on page 710.

The background color for 3D views that do 
not use the Vector View Rendering 
Technique or a backdrop image is set in the 
3D View Defaults dialog. See “Backdrop 
Tab” on page 671.

Move Color - Click the color bar to 
select the color of the lines that 

represent object(s) as they are being moved.

Handle Fill Color - Click the color bar 
to select the color for the edit handles 

for selected objects.

Selection Fill Color - Click the color 
bar to specify a color for selected 

objects. The color may change to ensure that 
selected objects are always visible, so this 
may not always be the color you expect.

Specify the Editing Transparency, 
which is the degree to which the 

selection fill and edit handles are transparent. 
The default value is 20%. 

Font Panel
The Font panel controls the conversion of 
text in legacy plans when they are opened in 

Home Designer Pro as well as the text used 
in the Materials List.

Choose Legacy Text Conversion, 
Legacy Dimension Conversion, or 

Materials to define the font for that use.

Legacy Text Conversion sets the default 
font for text created in previous versions of 

1

2

3

If the move color and the handle fill
color are similar, it may be difficult to

distinguish between active and inactive
points. The colors should be sufficiently dis-
similar to avoid confusion between active and
inactive points.

4

5
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Home Designer Pro. See “Character Size” on 
page 745.

Legacy Dimension Conversion sets the 
fonts for dimensions created in previous 
versions of Home Designer Pro. See 
“Dimensions” on page 719.

Materials sets the default font for the 
Materials List and Master List created in 
previous versions of Home Designer Pro. 
See “Materials Lists” on page 887. 

Click the arrow to select a font for the 
specified use. See “Fonts and 

Alphabets” on page 745.

Select one or more font styles to apply 
to the specified use.

Sample text displays the selected font 
and font style.

Text size is set individually in the Text 
Specification dialog or globally in the Text 
Defaults dialog. See “Text, Callouts & 
Markers” on page 743.

Library Browser Panel
The Library Browser panel controls the 
appearance of the Library Browser window. 
See “The Library Browser” on page 604.

Legacy Text and Dimension Conversion
settings only affect plans from previous

versions when they are opened in Home
Designer Pro. Set these values to the default
font that you used in previous versions before
opening legacy files.
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View options control the display of the 
main sections of the Library Browser.

• Hide Selection Pane - Check to hide the 
pane that displays objects in a selected 
library or library folder.

• Hide Preview Pane - Check to hide the 
pane that shows a preview of a selected 
object.

• Show Status Bar - Check to display the 
Library Browser Status Bar. 

Preview Pane - Specify how selected 
library items look in the Preview Pane. 

• Render Display - Library items previews 
display textures and appear as they do in 
rendered 3D views. See “Types of 3D 
Views” on page 664.

• Vector Display - Library item previews 
are line-based and display patterns as they 
do in 3D Vector Views. 

Selection Pane View items control the 
display style of objects in the Selection 

Pane.
• Tiled to Fit Window - Select to display 

all objects in a library or library folder. If 
there are many objects, they appear very 
small.

• Scrollable List - Select to display all 
library objects at the highlighted level on 
a scrollable list.

• Show Names in Selection Pane - Check 
to display the names of the objects in the 
Selection Pane.

Preview Pane - Selection Pane 
Layout - Select a radio button to 

change the appearance of the Library 
Browser. 
• Vertical - Displayed sections of the 

Library Browser are divided vertically. 
• Horizontal - Displayed sections are 

divided horizontally. 
• Stacked - Displayed sections are divided 

both horizontally and vertically.

Disable Docking - Check to prevent 
the Library Browser from docking to 

the sides of the Home Designer Pro window. 
See “Docking the Library Browser” on page 
608.

Click the Restore Position/Size Defaults 
button to restore the original position and 
size of the Library Browser: docked on the 
right side of the Home Designer Pro window.

Text & Page Setup Panel
The Text & Page Setup panel controls some 
text objects behaviors as well as the Page 
Setup information for legacy plan and layout 
files.

 

1

2

3

4 

5

Legacy Plan and Layout Page Setup
settings only affect files from 6 when

they are opened in Version 2014. You should
set these values to the default font that you
used in previous versions of Home Designer
Pro before opening legacy files. See “What’s
New in Home Designer Pro 2014” on page
917.
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Uncheck Text Specification Enter 
Key to close the Text and Rich Text 

Specification dialogs when the Enter key is 
pressed. When checked, a new line of text is 
created when Enter is pressed.  See “Text, 
Callouts & Markers” on page 743. 

Click the Legacy Plan Page Setup 
button to open the Page Setup dialog. 

These settings apply whenever you open a 

plan, or elevation, created in version 6 of 
Home Designer Pro. See “Page Setup 
Dialog” on page 853.

Click the Legacy Layout Page Setup 
button to open the Page Setup dialog. 

These settings applied whenever you open a 
layout file created in an earlier version of 
Home Designer Pro. See “Page Setup 
Dialog” on page 853.

General Panel
The General panel contains settings that affect 
file management and program updates.

Undo - Click in the Enable check box 
to enable Undos and Redos. See “Undo 

and Redo” on page 173.
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Maximum Undos - Specify how many 
levels of  Undo and Redo you want available, 
from 1 to 100. Undo files are saved in the 
Undo Directory.

Record undo state only if idle longer than - 
Use this setting to control how often undo 
states are recorded. If set to 0 milliseconds, 
an undo state is recorded every time a change 
is made to a plan.

If set to a number larger than 0, an undo state 
is recorded if the specified amount of time 
has elapsed since the last change was made. 
Depending on the time specified and the 
speed work is being done, multiple changes 
might be reversed with one undo.

This setting can have a significant effect on 
the performance of the undo feature when 
working with large plans.

Check For Program Updates - Check 
Enable and specify a frequency in days 

to check for program updates. By default 
Home Designer Pro will check for program 
updates once a day, whenever the program is 
launched. 

Check Show Options at Startup to 
open the Startup Options dialog when 

Home Designer Pro is launched. See “Startup 
Options” on page 24.

Troubleshooting - Uncheck Optimize 
for Multi-Core CPUs to turn off 

program optimizations for multi core 
processors. This box is checked by default 
and should only be unchecked for technical 
troubleshooting purposes.

File Management Panel
The settings on the File Management panel 
let you modify functions related to the 
program’s plan and layout file management. 

To use Auto Save, select the Enable 
check box and enter a value greater 

than zero in the text field to specify the 

frequency in minutes that Auto Save files are 
created. Auto Save files are stored in the 
Archive folder.
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In the event that your computer shuts down 
unexpectedly, you can recover your most 
recent work by opening the auto save file 
created by the program. See “Auto Save 
Files” on page 47.

File Locking - Choose whether or not 
to lock .plan and .layout files when 

they are open. File Locking prevents another 
program or copy of Chief Architect software 
from opening and modifying the same file at 
the same time. 
• Select Use File Locking to lock files.
• Select Disable File Locking to disable 

the feature. You should not disable the 

feature unless you have conflicts with file 
locking.

Recent File List - Specify the 
maximum number of files to list at the 

bottom of the File menu and in the Startup 
Options dialog. Additional files are included 
if you increase the value. You can open any 
of the files in this list by selecting them, 
making the list a quick way to access your 
most recent work.

Check Enable Thumbnail Images to 
automatically create thumbnail images 

of files that display when opening or 
searching for saved files.If this option is 
disabled, you can still create thumbnails 
manually. See “Thumbnail Images” on page 
46. 

Select either Small or Large thumbnails. 
Large thumbnails provide a higher quality 
image but result in larger file sizes. 

Folders Panel
Home Designer Pro stores many support files 
in various folders on your computer. The 
default locations of these directories are 
listed and can be redefined on the Folders 
panel if necessary. 

You do not need to change default locations 
under normal circumstances, but sometimes 

it may be preferable to locate certain files in 
another location. To specify a new default 
folder for a particular purpose, click the 
Browse button to the right of that item. 

Even with Auto Save active, you should
frequently save your work to the hard

drive by selecting File> Save.

2

3

4

Changing the settings on the Folders
panel can result in unexpected program

functionality. 
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Important user-specific information is 
saved in a folder on your computer 

called Home Designer Pro 2014 Data. This 
folder contains custom library content, 
toolbars, template files, archive files, and 
other important data and is located in My 
Documents by default. See “Home Designer 
Pro Data” on page 41.

While you cannot change the name of this 
directory, you can change its location. To 
avoid unexpected results, it is best to use a 
location on your local hard drive.

If you move this folder on your computer 
without specifying its location here, the 
program will automatically replace it using 
default information from the Home Designer 
Pro installation folder. The same result will 
occur if you specify a location on a network 
or removable device and this location 
becomes inaccessible. When this occurs, 
customized user settings will not be used and 
custom library content will not be available. 

By default, Temporary files and Undo 
files are stored in the same folder: by 

default, the Windows Temporary Directory. 
If you wish to use a different folder, you 
must specify a directory on a hard drive with 
sufficient space to hold these files. 

You can specify any directory as your Home 
Designer Pro temporary folder, but you 
should never relocate the Windows 
Temporary Directory nor use it for anything 
other than temporary files.

Home Designer Pro will not let you save 
your work to or open files saved in the 
Temporary or Undo folder. See “Undo and 
Redo” on page 173.

You can share Patterns with other 
users by copying these items into the 

appropriate Shared Folder in Windows 
Explorer. Click the Browse button to select a 
location on your computer that other users 
can access. See “Patterns and Textures” on 
page 632. 
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New Plans Panel

Open/Save As Directory - Control how the 
program behaves when a new plan is opened 
or an existing plan is saved. 
• Use Last Directory refers the program to 

the directory last used to save or open a 
plan file. 

• Use This Directory refers the program to 
a particular location specified by you.

• Click the Browse button to define a par-
ticular directory when Use This Direc-
tory is selected.

Unit Conversions Panel
In many places throughout Home Designer 
Pro, you can specify the size of an object 
with any Length unit listed on the Unit 
Conversions panel. Using the data on this 
panel, the program will convert your entry 
into the unit set in the Number Style/Angle 
Style dialog. See “Number Style/Angle Style 
Dialog” on page 89.

These conversions are also useful when you 
import drawings. When an object is drawn in 

a Home Designer Pro plan file, it is always at 
its true, unscaled size and the drawing is only 
scaled when you print it. This means that if 
you import a scaled drawing, you must 
compensate for its scaling by creating a 
custom unit of measurement. See “Import 
Drawing Wizard” on page 829. 

The default unit conversions are locked and 
cannot be changed, but custom conversions 
can be added to the list and later modified.
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A list of available units of measurement 
displays here. Click on the name of a 

unit to select it.

The Sample area shows how the unit 
selected above converts to a selection 

of similar units. You can use this to verify 
that any unit conversion you add is correct.

Add, Edit, Delete, or Copy the unit 
conversions. Certain unit conversions 

are locked and cannot be edited or deleted.

If you click Add, Edit or Copy, the Add Unit 
Conversion dialog displays. 

Unit Name - Type a short, descriptive 
name of the new unit. Names must be 

unique: the names of units installed with the 
program cannot be used.

Names can include any characters, as well as 
spaces. Bear in mind, though, that names of 

units for measuring length that have numbers 
in them may be unusable if entered in some 
dialogs in the program. 

Check Default Unit to display this new 
unit in places that present lists of 

available units. For example, if you have 
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inches as units and make inches a default, 
inches appear on the list when you are given 
a choice of units, such as in the Import 
Drawing Wizard. In other places, such as the 
Materials List, all units are listed.

Measurement Type specifies what the 
new unit measures. Select the 

appropriate radio button.

Multiply by gives you a number to 
multiply by to convert to the unit you 

select from the drop-down list. A 
measurement type must be selected before 
the list is populated. 

To create a new unit of measurement

When importing a drawing with a 1” = 20’ 
scale, for example, create a unit to convert 
this scaling to 1” = 1”.

1. Click the Add button to open the Add 
Unit Conversion dialog.

2. Type a short, descriptive name like 
“convert 1:20” in the Unit Name field.

•  Because this unit will be used only for 
scaling conversion, including numbers 
in its name will not cause any issues.

3. Select Length as the Measurement 
Type.

4. Type 20 in the Multiply by field.
5. Select “ft” from the drop-down list.

6. Click OK to close the dialog.

Architectural Panel

Select the desired default behaviors for 
selected Walls.

• Check Show Same Wall Type Handles 
to display edit handles on selected walls 

that draw new walls of the same type 
when dragged. See “Same Wall Type Edit 
Handles” on page 198. 

3

4

Note: You can achieve the same results if you
Multiply by 240 to convert to inches.
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• Check Select Room Before Wall in 3D 
to select the room defined by a wall when 
you click on the wall in 3D views. See 
“Selecting Walls” on page 197. 

Opening Appearance - Specify the 
appearance of opening indicators on 

cabinets, doors, and windows. See 
“Displaying Cabinets” on page 514, 
“Displaying Doors” on page 257, or 
“Displaying Windows” on page 287.
• Select Opening Indicators Point to 

Hinge Side for opening indicators that 
point to the hinge side of the opening.

• Select Opening Indicators Point to 
Handle Side for opening indicators that 
point to the handle side of the opening.

Check Stair Sections Move 
Independently to allow stair sections 

connected by landings to move separately, 
without moving the entire staircase. See 
“Editing Stairs and Ramps” on page 403.

Check Automatically Place Roof 
Intersection Points to have the 

program generate temporary CAD points that 
correspond to roof plane intersection points. 
When unchecked, these temporary points are 
not created. See “Locating Intersections” on 
page 367. 

CAD Panel
The CAD panel controls whether or not 
objects snap together to form polylines and 

objects that behave like polylines. See 
“Polylines” on page 790.

• Check Edit Object Parts to edit the indi-
vidual components of a polyline or poly-
line-like object. This functionality can 
also be accessed by clicking the Edit 

Object Parts  button. See “Edit 
Object Parts” on page 125.

2
3

4

Note: Unlike other Preferences, the program
always resets Edit Object Parts to be off
whenever you close the program.
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Line Properties Panel
The Line Properties panel controls the 
appearance of CAD lines. 

Printed Length - The beginning and end of 
CAD lines that are not solid are sometimes 
difficult to distinguish. Endcaps can be 

placed to eliminate this problem. Specify the 
printed endcap length in inches (mm).

Sun Angle Panel

Define a default Latitude, Longitude and 
Time Zone used when creating Sun Angles. 

See “Sun Angles” on page 701.
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Edit Panel
The settings on the Edit panel of the 
Preferences dialog control the appearance 
of the cursor and selection behavior of edit 
handles. See “Using the Mouse Cross Hairs” 
on page 154.

Use a cursor with Cross Hairs in 
different view types and control its 

appearance. 
• Check Enable in Plan and Cross Sec-

tion/Elevation Views to use a cross hair 
cursor in floor plan and cross section/ele-
vation views. This option is checked by 
default.

• Check Enable in Perspective Views to 
use a cross hair cursor in perspective cam-
era views and overviews.

• Click the Color bar to open the Color 
Chooser dialog and specify the color of 
the cross hairs. 

• Cross hair size is specified as a percent-
age of the width of the view window. 
Specify the Size (% of Window Width) 
as 100% to extend the cross hairs across 
the entire screen. 

• Set the Aperture Size, measured in pix-
els. The aperture is the space where the 
cross hairs meet. A value of 0 makes the 
cross hairs meet at a point. Larger num-
bers leave a gap in the center.

• When Synchronize with Cursor is 
checked, the mouse pointer and cross 
hairs always move together on screen. If 
you feel that they do not keep up with 
your mouse movements, try unchecking 
this option. 
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Specify the desired Selection settings, 
which affect how objects are selected 

and their appearance. 
• Enter an Edit Handle Size in pixels. The 

edit handles are twice this number of pix-
els plus one. For example, the default 
value is 3, which results in a handle that is 
7 x 7 pixels (3 x 2=6, and 6 + 1=7). A 
value of 1 results in a handle that is 3 x 3 
pixels. 

• Enter a value, in pixels, for Edit Handle 
Tolerance to specify how close to an edit 
handle you must click in order to select it. 
The default value is 0. 

• Check (S)tart and (E)nd Indicators to 
display an S and an E at the start and end 
points of a selected wall or the selected 
edge of a CAD-based object. This can 
make it easier to edit the selected edge in 
the object’s specification dialog. See 
“Selected Edge” on page 125. 

Specify program behavior when using 
Marquee Selection to select objects. 

See “Marquee Select” on page 126. 

• Choose Select Intersected Objects  to 
select any objects whose bounding boxes 
are intersected by or located within the 
marquee.  

• Choose Select Contained Objects  to 
select only objects located entirely within 
the marquee. This option provides the 
best results in most situations.

• Choose Select Objects by Center  to 
select only objects whose center points 
are located within the marquee.

2

You can add the Selection Modes tools
to your toolbars. See “To add a button
to a toolbar” on page 94. 

3
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Behaviors Panel
The settings on the Behaviors panel of the 
Preferences dialog define basic editing 
behaviors of CAD and architectural objects.

Rotate/Resize About defines the point 
an object or a group of objects rotates 

or resizes about. See “Rotate/Resize About” 
on page 109.
• Select Object Center to rotate or resize 

the selection about its center point. Object 
Center is the default setting. 

• Select Current Point to rotate the object 
about the current CAD point instead. 

To resize a CAD object about a current point, 
select the Resize Edit Type. 

This function can also be accessed by 
selecting Edit> Edit Behaviors> 

Resize . See “Edit Behaviors” on page 
120.

Rotate Jump defines the angle an object or 
group of objects jumps to when it is rotated. 
It overrides the angle snaps set in Plan 
Defaults. If you set this to zero, the angle 
snaps set under Plan Defaults are used.

1 2

3

1

Rotate about 
Object Center

Rotate about 
Current Point

Concentric 
Resize

Resize About 
Current Point
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Select one of the four Edit Type 
options. For detailed information about 

the different edit types and how they affect 
different objects, see “Edit Behaviors” on 
page 120.

• If Concentric is selected, specify the 
desired Jump increment. 

• Uncheck Behavior Indicators to turn off 
the display of the mouse pointer icons 
associated with these Edit Behaviors. This 
box is checked by default. 

The Primary Movement Methods 
control the directions that you can 

move objects using their edit handles. 
• Select Orthogonal to move an object per-

pendicular to any of its edges.
• Select Polar to move an object at 

Allowed Angles.

Snap Properties Panel
The settings on the Snap Properties panel of 
the Preferences dialog control the behavior 
of Object Snaps as well as the appearance of 
snap indicators. See “Object Snaps” on page 
110.

Box rotating about Current 
Point with Jump set to 45°

2

Note: Unlike other Preferences, the program
always restores the Default Edit Behavior
whenever you close the program.
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Options - 

• Check Angle Snaps  to enable snap-
ping to Allowed Angles. See “Angle 
Snaps” on page 111.

• Specify the Snap Distance (pixels), 
which is how far your the cursor can be 
from a snap point for the snap to occur. 
This value is measured in screen pixels; 
the default value is 12. 

When working with very small objects, 
you may find it helful to reduce this 
value; when working with very large 
objects, you may find it helpful to 
increase it. 

This setting also controls the minimum 
length of camera and cross section/eleva-
tion lines of sight. See “Creating Camera 
Views” on page 673. 

• Check Bumping/Pushing  to enable 
bumping and pushing. See “Bumping/
Pushing” on page 152.

• Specify the Maximum Bump Distance 
(pixels), which is the distance that a 
selected object must be dragged to over-
ride bumping and move past an obstruct-
ing object. 

Enable any combination of Object 
Snaps. You can also turn these options 

on an off with the toggle buttons on the 
toolbar.

Check Object Snaps to enable the object 
snap options, below. 

Endpoint - Enables snapping to the 
ends of lines, arcs, splines and other 

objects.

Midpoint - Enables snapping to the 
midpoint of an object such as a line or 

arc. For objects such as boxes, you can snap 
to the midpoint of any side of the box. 

Center - Enables snapping to the 
center of cabinets, fixtures, furniture, 

as well as circles and arcs. 

Quadrant -  Enables snapping to the 
left, right, top, or bottom of an object. 

Only used for arcs and circles.

On Object - Enables snapping to any 
point on the selected object, including 

CAD objects and cabinets.

Points/Markers - Allows you to snap 
to any temporary points you may have 

placed, as well as callouts and markers.

1

2

Note: Center snapping only works for arcs
and circles if Show Arc Centers and Ends is
turned on. See.“Aligning Arc Centers” on
page 156. 

Endpoint and midpoint snaps

Quadrant snaps

On object snaps
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Intersection - Enables snapping to the 
intersection of two objects, such as the 

intersection of a line with another line. 
Intersection snapping also snaps extension 
lines to objects, and allows you to snap two 
extension lines to each other.

When Intersection snapping is enabled, wall 
extension line snapping will also occur. See 
“Drawing Walls” on page 189.

Control the appearance of Snap 
Indicators.

• Specify a snap Indicator Size in pixels.
• Click the color bar to select a snap Indi-

cator Color from the Color Chooser dia-
log. See “Color Chooser Dialog” on page 
651. 

Points/Markers snaps

Intersection snaps

3
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Materials List Panel
The settings on the Materials List panel 
control which categories are included in 
Materials Lists. The names of all categories 

and their ID prefixes are listed here. They are 
defined by the program and cannot be 
changed. 

When a material is entered in the Materials 
List, the program decides what category it 
goes in and assigns it an ID, which is the 
prefix followed by a number. EX1 would be 
the first exterior trim piece entered in the 
Materials List for a particular plan.

Include These Categories - Check the 
categories you want to to include in every 

new materials list generated. Before you  
hide a category, make sure you know what 
items are listed within it.

It is usually better to remove categories
from individual plan lists in the Layer

Display Options dialog, rather than globally.
See “Layer Display Options Dialog” on page
104.
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Report Style Panel
The Report Style panel controls the initial 
appearance of Materials Lists. Most of these 
options can also be specified per individual 
Materials List by choosing Tools> Display 

Options  while that Materials List is 
active. See “Materials List Display Options 
Dialog” on page 891. 

Include These Columns - Check the 
columns that should be included in the 

Materials List.

Use the Move Up and Move Down buttons 
to change the order that columns appear. To 
change the order, select one or more items in 
the list and click the button. The selected 
columns move up or down by one in the list. 

For a more detailed description of Materials 
Lists, see “Materials Lists” on page 887.

When Querying Suppliers & 
Manufacturers - Select an option to 

narrow or broaden your query when 
searching the Master List.

 Grid - Choose whether or not grid 
lines display in the materials list. If you 

want lines, choose to have horizontal, 
vertical, or both. If the lines are turned off, 
they do not show on-screen or in print. You 
can select Solid Lines for the grids instead of 
dotted lines.

Background Colors can be set for 
even and odd numbered lines.

1

2

3
4
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2
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Specify the Text Font Size, which is 
the height of the font used in the 

Materials List, Master List and the 

Components dialog. See “Character Size” 
on page 745. 

Master List Panel
The Master List panel specifies how the 
Master List(s) for materials appears. Master 
Lists contain price and manufacturer 
information for materials. You can maintain 

Multiple Master Lists, but only one may be 
used at any given time. See “Materials Lists” 
on page 887.

Include These Columns - Check each 
column to include it in the Master 

materials list.

Use the Move Up and Move Down buttons 
to change the order of columns. To change 
the order, select one or more items in the list 
and click the button. The selected columns 
move up or down by one in the list. 

Master List File - The name and 
pathname of the Master List currently 

referenced is shown. It is referenced for all 
subsequently opened plans when a materials 
list is generated from any model. 

Press Browse to select a different 
Master List. Navigate the directory 

structure until you find the new Master List 
to be used, select it, and click OK.

Press New to create a new Master List. 
Name and save it in the location of your 

choice. When you create a new Master List, 
it is blank until you build a materials list and 
enter prices, supplier or manufacturer 
information. The Master List is saved 
automatically when you close.

5
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Categories Panel
The Categories panel allows you to 
customize the organization of the Materials 
List by creating subcategories under the pre-
defined Materials List categories. See 
“Organizing Materials Lists” on page 889. 

Subcategories may also be included in 
schedules in the Chief Architect program. 
See “Upgrade to Chief Architect” on page 
907. 

To create or modify a subcategory

Select a Category from the list. 

Existing subcategories display here.

To Add, Edit or Delete a subcategory, 
select it and click the appropriate 

button. Clicking Add or Edit opens the Sub-
Category dialog. 

In the Sub Category dialog, type a 
name of the subcategory to appear in 

the SubCat column of the Materials List. 

The Sub Cat name can be any sequence of 
characters, up to 12 characters in length. 

Doors, Windows, Cabinets, Fixtures, 
Furniture, and Electrical objects can 

generate schedules in Chief Architect. Type a 
Column Heading for Schedules. 

In the example above, two subcategories are 
added to the Windows category:  GLZ 
(Glazing) and EXT (Exterior Trim). 

2

3

4

5
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Render Panel
The Render panel settings control how 3D 
views are generated, particularly Render 

Previews and Final Views. See “Previews vs 
Final Views” on page 698.

The General Options settings affect 
both Render Previews and Final Views.

• Optimizations On saves rendering data 
to your video card, which speeds up ren-
dering time. This option may cause prob-
lems if the rendering data for your model 
exceeds the video card’s memory. 

If your computer stops responding when 
rendering, try unchecking Optimizations 
On. This slows down rendering time con-
siderably, though, so if the problem is not 
solved, leave this check box selected.

• Zoom Using Field of View directs the 
program to zoom in 3D views by adjust-

ing the camera’s Field of View, which can 
result in perspective distortion. See “Field 
of View” on page 686.

When Zoom Using Field of View is 
unchecked, zooming in 3D views is done 
by cropping or expanding the view’s 
extents. See “Zooming” on page 686.

• When Use Enhanced Lighting is 
checked, Standard rendered views gener-
ate lighting effects that require a video 
card that supports OpenGL 2.0. Uncheck-
ing this box may speed up Standard ren-
dering times somewhat; however, the 
quality of lighting effects will be reduced. 

1

2

3

1
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Not available if your video card does not 
support OpenGL 2.0. See “OpenGL and 
Hardware” on page 664. 

• Hardware Edge Smoothing uses the 
video card to remove the jagged edges 
that sometimes result along surface edges, 
producing cleaner lines. Not available if 
your video card does not support this fea-
ture. 

• Hardware Culling improves rendering 
times by preventing surfaces not actually 
visible in the scene from being generated. 
On some systems, this setting may slow 
down rendering times. If unchecking it 
does not solve the problem, though, leave 
this check box selected. See “System 
Requirements” on page 7 of the User’s 
Guide.

• Soft Shadows displays shadows with soft 
edges instead of hard edges. This feature 
is only used when Show Shadows and a 
Software Edge Smoothing value greater 
than 0% are also used. See “Rendering 
Tips” on page 697.

• Surface Backdrop generates the back-
drop image using hardware acceleration. 
For some graphics cards, this option 
improves rendering speed considerably. 

• Horizon Lines are lines that generate 
along the curved edges of symbol objects 
in Vector Views. Uncheck this box to 
increase the speed of Vector View genera-
tion but also suppress these lines. See 
“Vector View” on page 711. 

• Aggressive Cache Flushing regularly 
flushes cached video memory, which may 
be helpful for older video cards. On most 
systems, unchecking this box will pro-
duce faster rendering times. 

• OpenGL Vector View directs the pro-
gram to generate Vector Views using 
OpenGL hardware acceleration. See 
“OpenGL and Hardware” on page 664.

If you encounter problems creating Vector 
Views, try unchecking OpenGL Vector 
View. This slows down Vector View gen-
eration time considerably, though, so if 
the problem is not solved, leave this check 
box selected.

The Preview Options settings affect 
only Render Previews. 

• Hardware Texture Filtering uses your 
video card to filter textures and improve 
their appearance: noticeably, on surfaces 
angled away from the camera. In some 
rare instances, this may slow rendering 
time somewhat. Not supported by some 
video cards. 

• Smooth Faces generates smooth curved 
surfaces. It uses new surface normals to 
alter the lighting effects on surfaces, mak-
ing them appear curved, even though it 
does not alter the shape of the surfaces.

• Show Images controls the display of 
images, such as plants, cars and people, in 
rendered views. See “Displaying Images” 
on page 807. 

• Show Shadows controls whether or not 
shadows display. Shadows are extremely 
complex to calculate and slow down ren-
dering speed significantly, particularly 

Note: If OpenGL Vector View is not selected,
you can create Vector Views but cannot apply
any of the other Rendering Techniques to
them. See “Rendering Techniques” on page
710.

2
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when multiple lights are set to cast shad-
ows. They are typically used only for 
Final Views. See “Lighting” on page 699.

• Use Transparency allows materials such 
as window glass to display effects. For 
some video cards, rendering may be 
slowed when this feature is selected.

• Use Textures controls whether or not sur-
faces are rendered with textures. This 
only affects surfaces with materials that 
have assigned textures. When textures are 
turned off, surfaces are rendered using the 
color assigned to the material, but not the 
texture. See “Mapping Patterns and Tex-
tures” on page 638.

Textures can also be turned on or off ren-
dered views by selecting 3D> Camera 

View Options> Toggle Textures .
• Use Triangles divides large surfaces, 

such as walls, floors, and ceilings, into 
small triangles. This feature enhances 
lighting effects when point or spot light 
sources are used. Triangles are not used 
by the Standard, Technical Illustration or 
Vector View rendering techniques.

• Max Triangle Size controls the size of 
the surface triangles modeled by the pro-
gram. Lighting looks better with smaller 

triangles, but rendering takes longer. See 
“Rendering Tips” on page 697. 

The initial settings for Previews and Final 
Views are 60” (1500 mm) and 24” (600 
mm), respectively. The minimum value is 
6" (150 mm). 

• Software Edge Smoothing removes the 
jagged edges that sometimes result along 
surface edges, producing cleaner lines. 
Use the slide bar or text field to specify 
how much jagged edge lines should be 
smoothed. 

Initial Software Edge Smoothing settings 
for Previews and Final Views are 0% and 
80%, respectively.

The Final View Options settings are 
exactly the same as the Preview 

Options, but affect Final Views instead of 
Render Previews. See “Previews vs Final 
Views” on page 698

Select a Codec for walkthrough 
recordings from the drop-down list. 

“Cinepak codec” is selected by default; but 
any other codecs that you  may have installed 
on your system will also display in the list.  
See “Walkthroughs” on page 819.

Video Card Status Panel
The Video Card Status panel displays 
information about your video card, including 
the vendor and the version of OpenGL it 
uses. See “OpenGL and Hardware” on page 
664.

This information may be important if you are 
having problems generating 3D views.

Notice the information following the 
Acceleration label. If your video card 
supports hardware acceleration for OpenGL, 
this says “Installed Client Driver.” If it does 
not, it says “No Hardware Acceleration.” 
There is a significant difference in speed 
between rendering with acceleration and 
without.

3
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The Max Lights value indicates how many 
lights you can have turned on at any given 
time when generating a 3D view. This value 

should be 8 or higher, depending on your 
video card. See “Lighting” on page 699.

Reset Options Panel

If message boxes have been suppressed, you 
can make them display again by clicking 
Reset Message Boxes.

Home Designer Pro retains a list of locations 
where you have located missing files in the 
past. If you find that the program takes a long 
time to search for files before informing you 
that they are missing, you can click the Reset 
Search Folders button to clear this list.

Click the Reset Preferences button to restore 
all preferences to those that originally came 
with the program. For the reset to take effect, 
you will need to restart the program. 

Number Style/Angle Style Dialog
At the bottom of many dialogs, you can click 
the Num Style/Angle Style button to open 
the Number Style/Angle Style dialog. 

The settings in this dialog are global and 
control the format of distances, coordinates 
and angles of angles in dialog boxes as well 
as in the Status Bar. See “The Status Bar” on 
page 31.

These settings control the format of values 
used in dialogs but do not limit how you 
must enter these values. For example, if you 
set  your Number Style to use Inches, values 
will display using fractional inches. You can, 
however, enter values using decimal inches, 
inches and feet, or even decimal feet. When 
the dialog you’re typing in updates, the value 
will be converted to fractional inches. 

Resetting all preferences to default can
be a drastic step if you have made

many changes to your defaults and should be
done with caution.
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When Imperial units are used, the Inches and 
Feet & Inches options use fractional inches 
with denominators of 2, 4, 8 and 16. A few 
objects, notably text, dimensions, and floor, 
ceiling and wall structure layers can be sized 
using smaller fractions with  larger 
denominators. 

Angles can be displayed using one of four 
basic methods: 
• Degrees/Minutes/Bearings - Measured 

counterclockwise from a line drawn hori-
zontally to the right of the angle’s vertex. 
Useful for most drawing tasks. Select the 
level of accuracy that you require.

• Quadrant Bearings - Measured from a 
vertical line representing North/ South, 
Quadrant Bearings use directional bear-

ings in their measurements. Useful for site 
drawings.

• Azimuth Bearings - Measured from a 
line drawn straight up from the angle’s 
vertex (ie, North on a site plan). Useful 
for site drawings, Azimuth Bearings use 
degrees, minutes, and seconds in their 
measurements.

• Pitch - Defined as a ratio of vertical rise 
to horizontal run. In Imperial units, the 
run is always 12”; in metric units it is 
1000 mm. Useful for roofs. 

Quadrant and Azimuth Bearings are affected 

by the orientation of the North Pointer , 
if one is present in the current plan. See 
“North Pointer” on page 778.
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Chapter 4:

Toolbars &
Hotkeys

Two of the most efficient ways to access 
Home Designer Pro’s tools are the toolbars 
and keyboard shortcuts, also referred to as 
hotkeys.

Toolbars are organized into configurations, 
which are basically collections of multiple 
toolbars arranged for use during specific 
drawing tasks.  Within a given toolbar 
configuration, buttons are arranged so that 
similar tools are located near one another. 

Chapter Contents
•      Toolbar Arrangement
•      Customizing Toolbars
•      Toolbar Configurations
•      Hotkeys
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Toolbar Arrangement
Home Designer Pro installs a set of Toolbar 
Configurations, which determines what tools 
are initially included in the toolbars, as well 
as where these toolbars are located. 

Toolbar Preferences
Toolbars can be viewed in Drop-Down or 
Parent-Child arrangement. You can specify 
which to use in the Preferences dialog. See 
“Appearance Panel” on page 61.

Drop-Down toolbar buttons have an arrow to 
the right of the button that accesses 
additional, related tools. 

Alternatively, you can use the Parent-Child 
toolbar arrangement. In this arrangement, 
you select a “parent” button to display its 
“child” buttons to the right.

You can also turn off the display of toolbars 
entirely by selecting Tools> Toolbars> Hide 
Toolbars.

Moving Toolbars
You can, if you wish, move any toolbar to a 
different location.  Toolbars can be docked to 
any side of the program window, or they can 
be undocked and left floating. Undocked 
toolbars can also be moved outside of the 
program window. 

Toolbars are saved between program 
sessions. To restore the original toolbar 
locations, as well as their display, click the 
Reset Toolbars button in the Toolbar 
Customization dialog. See “Toolbar Tab” on 
page 96. 

Restoring Toolbars
Toolbars can be moved, added to and 
removed from any toolbar configuration.

If you make changes to a configuration, they 
will be saved whenever you: 
• Switch to a different configuration; 
• Close the Toolbar Configuration dialog; 
• Exit out of Home Designer Pro.

To discard your changes and restore all 
toolbar configurations to their original 
condition, click the Reset Toolbars button in 
the Toolbar Configuration dialog. See 
“Toolbar Tab” on page 96.
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Customizing Toolbars
You can create custom toolbars as well as 
entire custom toolbar configurations in the 
Toolbar Customization dialog. In this 
dialog, you can:

• Add and remove buttons from toolbars.
• Specify which of the available toolbars 

display in different view types. 
• Select the active toolbar configuration.

Toolbar Customization Dialog
Select Tools> Toolbars> Customize 
Toolbars to open this dialog. 

Tools Tab
The Tools tab allows you to add or remove 
buttons from your toolbars.

Select the type of View you would like 
to add toolbar buttons in. As you select 

various views, the tools available change.

A description of the selected button 
displays here.

Check Sort Alphabetically to sort the 
tools in alphabetical order rather than 

the order they appear on the toolbars.

A list of the Main Toolbar Buttons 
available for the selected View displays 

here. 
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Click on a button to display any child buttons 
to the right and a description at the lower left 
of the dialog. See “Parent and Child Tools” 
on page 28. 

If you do not see a particular button in the 
list, it may not be available in the currently 
selected View, or it may be the child of a 
parent tool.

Click on a button in the “Main Toolbar 
Buttons” area to display its child 

buttons in this Child Buttons area. If no 
child buttons display, the button you selected 
is not a parent tool. 

In the image above, the Cabinet Tools  
parent button is selected under “Main 
Toolbar Buttons” and its child tools display 
under “Child Buttons”. 

Child tools are permanently associated with 
the parent tool. If, for example, you add the 

Cabinet Tools  parent button to a toolbar, 
its child tools will always display whenever 
it is selected. An individual child tool can, 
however, be placed on a toolbar by itself.

To add a button to a toolbar

1. Select the View type that you want to 
add a toobar button in.

2. Select the desired button or its parent 
from the Main Toolbar Buttons list.

3. If the desired button is a child button, 
select it from the Child Buttons list.

4. Click and drag the button you wish to 
add to a toolbar out of the dialog box.

•  Drop it onto an existing toolbar to add 
the button to that toolbar.

•  Drop it away from an existing toolbar 
to create a new toolbar. The selected 
button is first in the new toolbar. The 
new toolbar is named with the current 
view followed by a number. 

To create a new toolbar

1. Select the View type to which you want 
to add a new toobar.

•  If you select All Views, your new tool-
bar will display in all views.

•  You can add any buttons you like to an 
All Views toolbar; however, not all 
buttons will necessarily be available 
for use in all views. 

2. Select the first button that you want on 
the toolbar from the Main Toolbar But-
tons or Child Buttons areas.

3. Click and drag the button out of the dia-
log box and drop it:.

•  In an empty section of the program 
window border to create a new toolbar 
docked at that location.

•  In the drawing area to create a new, 
undocked toolbar.

4. Additional buttons can be added to this 
new toolbar.

5. After you click Done, you can return to 
this dialog to assign a name to your new 
toolbar. See “Toolbar Tab” on page 96.

An undocked toolbar can be docked, or vice 
versa, at any time.

Removing Tools from Toolbars
To remove a button from a toolbar, select 
Tools> Toolbars> Customize Toolbars to 

You can use the Empty Space button in
your toolbars as a spacer.

5
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open the Toolbar Customization dialog. 
With this dialog open, click and drag the 
button off its toolbar. 

Buttons cannot be added to or removed from 
the Edit toolbar. See “The Edit Toolbar” on 
page 29.

You can only remove a button from a
toolbar when the Toolbar Customization

dialog is open.
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Toolbar Tab
The Toolbar tab allows you to manage your 
individual toolbars.
 

Select a type of View to display the 
toolbars available for use in it.

The toolbars available for the selected 
View display here. Select a toolbar by 

clicking on its name. 
• If the selected toolbar is not active, the 

Activate button is available. Click Acti-
vate to make the selected toolbar active.

• Click Rename to rename the selected 
toolbar. Toolbar names must be unique.

• Click Delete to remove the selected tool-
bar from the list. A deleted toolbar is no 
longer available.

Click Reset Toolbars to restore all the 
toolbars to their original configuration. 

See “Restoring Toolbars” on page 92. 

Check Display Tool Tips to show Tool 
Tips when you move the cursor over 

buttons.

Check Lock Toolbars to lock toolbars 
in their current position on screen.

1 2
3

4
5

1

2
Clicking on the Reset Toolbars button
deletes any toolbar customization you
have done.

3

4

5



Customizing Toolbars

 97

Configurations Tab
The Configurations tab allows you to add, 
remove and switch between toolbar 

configurations. See “Toolbar 
Configurations” on page 98.

A list of toolbar configurations displays 
here. Select a configuration before 

clicking the Remove, Copy, or Switch To 
buttons.

Add - Click to browse for a toolbar 
configuration file and add it to the list.

Remove - Click to remove the selected 
toolbar configuration. This removes the 

configuration from the list but does not 
delete the configuration file permanently. 

Copy - Click to create a copy of the 
selected toolbar configuration. 

Switch To - Click to switch to the 
selected toolbar configuration. You can 

also right-click on any toolbar and select a  
configuration from the menu, or click a 
Toolbar Configuration button.

The location of the Current Toolbars 
Folder displays here. It can be 

specified in the Preferences dialog. See 
“Folders Panel” on page 69.
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Note: If you customize your toolbars, it is a
good idea to back up your toolbar configura-
tion files (*.toolbar). See “Home Designer Pro
Data” on page 41.
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Toolbar Configurations
The Home Designer Pro program window 
has limited space for toolbar buttons. How 
many can be shown depends on your 
monitor’s size and screen resolution settings. 

The toolbar configurations that come with 
Home Designer Pro organize tools based on 
the type of work being done as well as on 
monitor screen resolution.  

• The Default Configuration  displays 
architectural tools used for house design, 
including walls, windows, doors, stairs, 
cabinets, etc. 

• The Terrain Configuration  displays 
buttons associated with the terrain and 
road tools, including the plant and sprin-
kler tools. See “Terrain Toolbar Configu-
ration” on page 538.

• The Space Planning Configuration  
displays buttons associated with the 
House Wizard. See “House Wizard” on 
page 799.

• The Plan Detailing Configuration  is 
designed for dealing with materials lists, 
time tracking, and client and designer 
information.

• CAD Configuration  shows the tools 
needed for CAD drawings. See “CAD 
Objects” on page 769.

To switch toolbar configurations

There are several ways to switch from one 
toolbar configuration to another.
• Click a Toolbar Configuration button.

• Choose a configuration in the Toolbar 
Customization dialog. See “Configura-
tions Tab” on page 97.

• Right-click on a toolbar and select a con-
figuration from the contextual menu. 

To create a custom configuration

You can create a custom configuration that 
shows only the buttons you need.

1. Access the Configurations tab of the 
Toolbar Customization dialog.

2. Select a configuration similar to the one 
you want to create and click Copy.

3. Give the new configuration a name. It 
should be saved to the Home Designer 
Pro Toolbars folder. See “Home 
Designer Pro Data” on page 41.

4. Click Save. The program switches to the 
new configuration and it appears high-
lighted in the list.

5. Drag tools you want to add out of the 
Toolbar Customization dialog and onto 
the toolbars.

6. Drag any tools you do not want off the 
toolbars.

7. When you are satisfied with the appear-
ance of your new toolbar, click Close.

You can make your own button icon for your 
custom toolbar configuration. Create a .bmp 
file with the same name as the configuration 
and save it in the Toolbars folder. To see an 
example, look at the Default.bmp file in the 
Home Designer Pro Toolbars folder, which 
corresponds to the Default Toolbar 
configuration.
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• Toolbar button bitmaps must be 20 x 20 
pixels in size. 

• The color (R:192, G:192, B:192) maps to 
the system 3D face color.

• The color (R:128, G:128, B:128) maps to 
the system 3D Shadow color.

• The color (R:223, G:223, B:223) maps to 
the system 3D light color.

To import a custom configuration

You can import an existing toolbar 
configuration. 

1. Access the Configurations tab of the 
Toolbar Customization dialog.

2. Click Add.
3. Browse to the location of the toolbar you 

want to import.
4. Click Open. If the .toolbar file is not in 

the Home Designer Pro Toolbars folder, 
a copy of the file will be created there.

Hotkeys
Many Home Designer Pro tools have a 
keyboard shortcut, or hotkey, associated with 
them. If such a hotkey exists, it will display 
to the right of the tool’s name in the menu.

To use a hotkey, simply press the appropriate 
key or combination of keys on your keyboard 
instead of selecting the menu item or clicking 
the toolbar button. For example, press the 
Ctrl and Z keys at the same time to perform 

an Undo .

Edit menu items with button icons 
to the left and hotkeys to the right
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Chapter 5:

Layers

Layers are used to organize and manage the 
display of all objects in all views. A layer can 
be thought of as a transparency sheet with 
objects placed on it for viewing. Nearly all 
views use multiple layers, like a stack of 
transparencies put together to show different 
types of objects. 

You can customize how each layer displays 
in a particular view in the Layer Display 
Options dialog. 

Multiple layers are organized into Layer 
Sets, which allow you to control which 
objects display in different views.

Chapter Contents
•      Displaying Objects
•      Layer Sets
•      Layer Display Options Dialog
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Displaying Objects
The display of objects in different views is 
controlled by layer sets and layers in the 
Layer Display Options dialog. See “Layer 
Display Options Dialog” on page 104.

Primary and Secondary Layers
Every object is placed on a layer which 
controls whether it displays in a given view. 
This layer is referred to as the object’s 
primary layer. 

In addition, some objects have secondary 
layers which may alter the appearance of 
objects on the primary layer, but do not 
control whether the objects display or not. 

For example, the primary layer for base 
cabinets is “Cabinets, Base”. In addition, 
base cabinets have a number of secondary 
layers that control the display of the 
countertop, face indicators, door opening 
indicators, module lines and labels.

All layers with a check in the “Disp.” column 
display when the current layer set is active. 
Objects that are not displayed cannot be seen 
or selected. If you try to place or draw an 
object on a layer that is hidden, the program 
asks if you want to turn the layer on.

Some objects cannot stand alone in a 
drawing: they can only be inserted into 
another object. If the display of an object that 
contains an inserted object is turned off, the 
display of the inserted object will be turned 
off, as well  For example, if the display of a 
wall is turned off, any doors and windows in 
that wall will not display either. See 
“Inserted Objects” on page 621.

Line and Text Styles
A layer’s Color, Style, Size and Text Style 
attributes determine how an object on that 
layer appears in floor plan view and in 3D 
views using the Vector View rendering 
technique.

Many objects, including all CAD and text 
objects, allow you to override these settings 
for an individiual instance without changing 
its layer.

Note: If an object’s primary layer is turned off,
information on its secondary layers will not
display - even if those layers are turned on.



Layer Sets

 103

Locking Layers
Objects on layers with a lock symbol in the 
Lock column cannot be selected by the user. 

New objects cannot be drawn on a locked 
layer, either. If you lock a layer and then 
attempt to draw a new object on that layer, a 
message box will ask you to unlock the layer.

Layers with objects that you need to see as a 
reference while working, but not select, are 
good candidates for locking. For example: 
• Locking the “Rooms” layer can make it 

easier to select objects located inside of 
rooms. 

• Locking the “Roof Planes” layer can 
make it easier to select objects located 
under the eaves. 

Layer Sets
Layer Sets are used to control the layer 
settings for different views in a plan or layout 
file. All views associated with a plan file - 
including views sent to layout - make use of 
layer sets stored in that .plan file. 

A layer set consists of a complete list of the 
layers in the current plan or layout along with 
the display settings for each layer as set for a 
particular type of view. These display 
settings can be modified, and can be different 
for each type of view. See “Layer Display 
Options Dialog” on page 104.

Layer sets are file specific, which means that 
changes made in one plan or layout file have 
no effect on the settings in other files. 

Home Designer Pro uses a different layer set 
for the each type of view of your plan:
• Floor plan view.

• Aerial Views. See “Aerial View” on page 
660.

• Camera views and Overviews. See “3D 
View Tools” on page 672.

• Elevation views. See “Cross Section/Ele-
vation Views” on page 675.

• Framing Overviews. See “Framing Over-
view” on page 675.

• Reference Display. See “The Reference 
Floor” on page 327.

• Print Model. See “Print Model” on page 
858.

While any view is active, select Tools> 

Display Settings> Display Options  to 
make changes to the layer set used for that 
view type. 

Any changes made to settings in the Layer 
Display Options dialog for one particular 

Locking a layer does not prevent
objects on that layer from being modi-

fied. Most objects can be deleted using the
Delete Objects dialog. Objects are also
deleted if the floor they are placed on is
deleted. See “Deleting Objects” on page 171. 
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view will affect all views using that same 
layer set. For example, if you make changes 
for a camera view, all camera views and 
overviews in the current plan will be 

affected. See “Layer Display Options 
Dialog” on page 104. 

Unlike other layer sets, the Aerial View and 
Print Model layer sets cannot be modified.

Layer Display Options Dialog
The Layer Display Options dialog 
controls the display of layers in the 

active layer set. It consists of a table that lists 
all available layers and the attributes for 
each.

From any view except the Materials List, 
select Tools> Display Settings> Display 

Options  to open the Layer Display 
Options dialog. This dialog is resizeable and 
maintains its size between program sessions. 

Selecting Tools> Reference Floors> 

Reference Display Options  opens the 
Layer Display Options dialog with the 
Reference Display Set active. See “The 
Reference Floor” on page 327.

Selecting Tools> Display Options  in a 
materials list opens the Materials List 
Display Options dialog. See “Materials List 
Display Options Dialog” on page 891.
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Click the column header to sort all layers in 
the Layer Display Options dialog by that 
column. 
• The Name column is sorted alphabeti-

cally. Sorting is also case sensitive to 
allow greater control over organization.

• A red + in the Used column indicates 
which layers have objects placed on them 
in the current plan. This column cannot 
be edited. 

• A check in the Disp column indicates 
which layers are set to be visible. This 
controls the display of objects in 2D and 
3D views.

• A yellow  in the Lock column indicates 
which layers are locked, preventing 
objects on that layer from being manually 
edited.

• The Color column shows the line color 
for each layer. You can sort this column 
so that like colors are listed together.

• The Line Style column shows the line 
style for each layer and can be sorted so 
that like line styles are listed together.

• The Size column displays the line weight 
used by each layer and can be sorted so 
that like line weights are listed together. 
See “Line Weights” on page 849. 

• The Text Style column shows the text 
style assigned to each layer and can be 
sorted so that layers using the same style 
are listed together. See “Text Styles” on 
page 765.

Layers are named so that similar object types 
such as Cabinets, Base and Cabinets, Wall 
are listed near one another alphabetically. 

If a layer is turned on, a checkmark is shown 
in the Disp column.  If a layer is turned off, 
the column is blank.

Layers are selected by clicking them in the 
table. Hold down the Shift key or the Ctrl 
key to select multiple layers at once. Click 
the Select All button to select all layers in the 
table. When selected, a layer’s attributes 
display at the bottom of the dialog. If 
multiple layers are selected, “no change” 
may display for attributes that are different 
among the selected layers.

When a layer or layers is selected, single or 
shared layer attributes can be edited in the 
section titled Properties for “Selected 
Layer”. Line Color, Style and Size affect 
lines in floor plan view and surface edge 
lines in vector views.
• To change the color of lines on a selected 

layer, click the Color bar to select a new 
color in the Color Chooser dialog. See  
“Color Chooser Dialog” on page 651. 

• To change the width of lines on a selected 
layer, enter a Line Size. See “Line 
Weights” on page 849.

• To change the Line Style of a selected 
layer, click the drop-down arrow.

• To change the Text Style of a selected 
layer, click the drop-down arrow. See 
“Text Style Defaults” on page 765.

• To turn off a selected layer, uncheck 
Display. See “Displaying Objects” on 
page 102. 

When one or more layers are selected
and you click OK, the program remem-

bers your selection so that the same layers
are selected when you reopen the Layer Dis-
play Options dialog.
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• To protect the objects on a selected layer 
from accidental changes, check Lock. 
Items on locked layers display but cannot 
be selected. See “Locking Layers” on 
page 103.

Note: Not all objects display in all views. For
instance, door labels do not appear in 3D
views.
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Chapter 6:

Creating Objects

There are a wide variety of objects in Home 
Designer Pro that you can use to create 
complete 3D models and working drawings. 
Although these objects are sometimes very 
different from one another, the methods used 
to create them are similar. 

Once an object is created, it can be selected 
and edited to meet the requirements of your 
project. The editing characteristics common 
to most objects are described elsewhere. See 
“Editing Objects” on page 119. 

Chapter Contents
•      Architectural vs CAD Objects
•      Defaults and Preferences
•      Snap Behaviors
•      Object Snaps
•      Angle Snaps
•      Grid Snaps
•      Creating Objects
•      Copying and Pasting Objects
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Architectural vs CAD Objects
There are two broad categories of objects in 
Home Designer Pro: architectural objects 
and CAD objects. 

CAD objects such as  lines, arcs, text, and 
dimensions are 2D objects that can be 
created and edited in floor plan view and 
cross section/elevation views, and on layout 
pages but do not display in 3D camera views 
and overviews. See “The CAD Drawing 
Tools” on page 771. 

In contrast, architectural objects such as 
walls, cabinets, doors, windows, and stairs 
display in 2D and 3D views. Architectural 
objects can be created and edited in 2D and 
3D views but not on layout pages.

Some architectural objects, such as custom 
countertops and slabs, have some behaviors 
in common with CAD objects and are 
referred to as CAD-based.

Defaults and Preferences
The ways that objects in the program behave 
as they are created and edited are affected by 
a number of default and preference settings. 
See “Preferences & Default Settings” on 
page 55.

Snap Settings
Select Edit> Snap Settings to access 
the three categories of Snap Settings 

that determine how objects snap to one 
another and whether they snap to allowed 
angles or to points on a grid, as well as object 
bumping and pushing behaviors.

Object Snaps enable snapping to 
objects. See “Object Snaps” on page 

110.

Angle Snaps enable snapping at 
Allowed Angles. See “Angle Snaps” 

on page 111.

Grid Snaps enable snapping to the 
Snap Grid.  See “Grid Snaps” on page 

112. 

Bumping/Pushing enables bumping 
and pushing behaviors. See 

“Bumping/Pushing” on page 152.

Edit Behaviors
Select Edit> Edit Behaviors to 
access the six global edit behavior 

modes that determine how dragging the edit 
handles with the left mouse button affects a 
selected object and may also affect how 
objects are drawn. 

The Default edit behavior provides 
the most commonly used editing 

options. See “Default” on page 120.

The Alternate edit behavior provides 
an alternative to the Default behaviors 

It is a good idea to be familiar with these
options and how they affect both draw-

ing and editing in the program.
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that may be more useful in some situations. 
See “Alternate” on page 121.

The Resize edit behavior scales an 
object as you drag a corner handle. 

See “Resize” on page 121.

The Concentric edit behavior allows 
you to resize objects so that the 

distance moved by each edge is the same as 
all other edges. See “Concentric” on page 
122.

The Fillet edit behavior allows you to 
add a fillet at any corner of an object. 

See “Fillet” on page 123.

Edit Object Parts
Select Edit> Edit Behaviors> Edit 
Object Parts to toggle the ability to 

edit the individual segments of polyline-
based objects and connected walls. It also 
affects the ability to snap line- and arc-based 
objects together as they are drawn to form a 
polyline. See “Edit Object Parts” on page 
125. 

Rotate/Resize About
Objects can be rotated or resized 
about either their own centers or the 

Current CAD point. See “Point Tools” on 
page 772. 

Specify which behavior is used by selecting 
Edit> Edit Behaviors> Rotate/Resize 

About Current Point  or in the 
Preferences dialog. See “Behaviors Panel” 
on page 78. 

Arc Creation Modes
Select Edit> Arc Creation Modes to 
access the five Arc Creation Modes 

that control how arcs and curved walls are 
drawn.

Free Form Arc mode allows you to 
define an arc by clicking and dragging 

along the desired path. See “Free Form Arc” 
on page 784.

Snap Behaviors
There are three categories of 
snap behavior in Home 

Designer Pro that affect how objects are 
created and how they can be edited: 

•      Object Snaps , which snap CAD 
and architectural objects to other objects. 

•      Angle Snaps , which snap objects 
at specific angles. 

•      Grid Snaps  , which snap objects 
to points on a grid.

Snap behaviors can be controlled in the 
Preferences dialog and in the Plan or 
Layout Defaults dialogs. See “Snap 
Properties Panel” on page 79 and “General 
Plan Defaults Dialog” on page 58.

You can select Edit> Snap Settings  to 
quickly turn Object, Angle and Grid Snaps 
on or off. 

To temporarily disable Snap Behaviors and 
other move restrictions, press the Ctrl key 
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while dragging an edit handle. See “Moving 
Objects” on page 152.

Hotkeys
You can also temporarily enable individual 
Snap Behaviors during a mouse editing 
operation using hotkeys. This can be helpful 
if you wish to use one particular type of snap 
behavior when you begin an operation, but a 
different behavior when you end it. 

The Snap Behavior hotkeys are listed on the 

right side of the Edit> Snap Settings  
submenu. See “Hotkeys” on page 99.

To use snap behavior hotkeys

1. Select Edit> Snap Settings  and 
toggle off the snap behavior category 
that you wish to control using hotkeys.

2. Select a tool that you wish to draw with 
or an object you wish to edit.

3. Begin drawing or editing and hold down 
the left mouse button without releasing.

4. Press and hold the appropriate key on 
your keyboard to enable the snap behav-
ior associated with it. 

5. When you are finished using the snap 
behavior, release the hotkey but continue 
holding down your left mouse button.

6. If you wish, you can press and hold a 
different hotkey on your keyboard and 
continue the drawing or editing opera-
tion.

7. When you are finished, release the left 
mouse button.

Object Snaps
Object Snaps allow you to position 
objects precisely relative to each 

other; for example, to position lines so that 
their endpoints meet or roof plane edges so 
that they are colinear.

Object Snaps can be turned on or off by 
selecting Edit> Snap Settings> Object 

Snaps , by clicking the toggle button, or 
in the Preferences dialog. See “Snap 
Properties Panel” on page 79.

Object Snaps are indicated visually as you 
create or edit objects. To remove any object 
snap indicators that are visible on screen, 
press the 1 (one) key. As you continue 
drawing or editing, new indicators may 
appear.

With the exception of On Object  snaps, 
have priority over all other types of snapping 
in Home Designer Pro. Bumping/Pushing 

 overrides Object Snaps. See “Bumping/
Pushing” on page 152.

Object Snap Locations
There are many locations on an object that 
other objects can snap to. Each type of object 
snap can be toggled by selecting Edit> Snap 

Settings  or in the Preferences dialog. 
See “Snap Properties Panel” on page 79.

Regardless of which Object Snaps are active, 
when multiple objects are selected the 
selection set’s only snap point is its midpoint.
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Extension Snaps
Extension snaps allow you to snap to a point 
that is not actually on an object. Instead, 
these snaps locate points that are either 
colinear to the end of a wall or orthogonal (at 
a 90° angle) to it. 

Extension snaps function when you are 
drawing or editing walls and create a “sticky 

point” and blue extension line where the wall 
being drawn reaches a point that is either 
colinear or orthogonal to another wall’s end 
point. See “Drawing Walls” on page 189. 

Object Snaps Hotkeys
• Hold down the “S” key to temporarily 

disable Object Snaps.

Angle Snaps
It is often important that objects be 
drawn at exact angles. This can be 

accomplished using Angle Snaps.

Angle Snaps allow you to draw lines, walls, 
and other objects at specified Allowed 
Angles. Angle Snaps also affect the way 
objects rotate, the radius of arcs, and a 
variety of other operations.

Angle Snaps allow you to snap at either 15° 
or 7.5° angles plus any additional Allowed 
Angles that you may specify. See “General 
Plan Defaults Dialog” on page 58. 

Angle Snaps can be turned on or off by 
selecting Edit> Snap Settings> Angle 

Snaps , by clicking the toggle button, or 
in the Preferences dialog. See “Snap 
Properties Panel” on page 79.

Angle Snap Settings
You can change Allowed Angle settings for 
Angle Snaps in the Plan Defaults or Layout 
Defaults dialog. See “General Plan Defaults 
Dialog” on page 58. 

Specify 15 Degree or 7 ½ Degree angle 
snaps. When 7 ½ Degree Angle Snaps are 

selected, you can also specify Additional 
Angles. 

Angle Snaps and 
Object Snaps

Angle Snaps have a higher priority than Grid 

Snaps and On Object Snaps , but a lower 
priority to all other Object Snaps. If a valid 
Object Snap exists, the program uses that 
instead of an Angle Snap. 

Sometimes both Angle Snaps and Object 
Snaps apply. For example, suppose a CAD 
line is drawn at 15°  using Angle Snaps and 
another line is approached. You can draw the 

new line at 15° using Intersection Snaps  
to snap to a point on the existing line. 

Walls are an exception to this snapping
prioritization. When walls are drawn or

edited, Angle Snaps take higher priority than
Object Snaps. See “Drawing Walls” on page
189. 
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Now suppose that we don't want the new line 
to end on the existing line. Hold down the 
“S” key to temporarily disable Object Snaps, 
allowing only Angle Snaps.

Grid Snaps
Grid Snaps allow you to snap objects 
to points on an on-screen grid. The 

display and size of this Snap Grid can be 
controlled in the Plan or Layout Defaults 
dialog. See “General Plan Defaults Dialog” 
on page 58.

Grid Snaps are turned on and off by selecting 

Edit> Snap Settings>Grid Snaps , by 
clicking the toggle button, or in the Plan or 
Layout Defaults dialog. 

In addition to the Snap Grid, the Reference 
Grid is provided to give you a visual sense 
of scale. The Reference Grid is useful for 
zooming in and out, or for general layout 
guidelines, but is not used for snapping. 

Grid Snaps and Angle Snaps
Of the three snap behaviors, Grid Snaps have 
the lowest priority and are overridden by 
Angle Snaps and Object Snaps. 

When Grid snaps and Angle Snaps are both 
enabled, objects are drawn and edited using 
Polar Coordinates. For example, if the grid 
Snap Unit is set to 12" (1 foot), drawing a 
new wall at an Allowed Angle snaps the wall 
length to 0", 12", 24", and so on.

Creating Objects
In Home Designer Pro, there are five ways to 
create objects: by clicking to place an object, 
by clicking and dragging to draw an object, 
by entering coordinates, or by importing 
custom symbols, drawings, pictures or 
metafiles.

If you create an object using any of these 
methods and the layer it will go on is either 
locked or turned off, the program will ask 
you if you want to display or unlock the 

layer. Objects can be created on layers that 
are not set to display, but they cannot be 
created on locked layers. See “Object 
Creation and Layers” on page 114.

While the size of the drawing area in Home 
Designer Pro is limited only by the resources 
on your computer, it is best to begin your 
drawing near the origin, 0,0,0. The current 
position of your mouse pointer displays in 

Use both Object 
Snapping and 
Angle Snapping to 
create a 15-degree 
line that intersects 
an existing line

To draw a line or wall at an Allowed
Angle but with unrestricted length, dis-

able Grid Snaps and leave Angle Snaps on.
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the Status Bar at the bottom of the program 
window. See “3D Drafting” on page 25. 

Click-to-Create
Many objects, including doors and windows, 
cabinets, library symbols, terrain objects, 
text, pictures and images  are created by 
clicking. Select a or library object, then click 
in the drawing area to place the object at that 
location. 

Continue clicking to place the selected object 
until another tool is selected.

If you click at a location where there is not 
enough room for the object to be placed, one 
of two things may happen:
• Some objects, notably cabinets, doors, 

and windows, will resize smaller to fit 
into the space. 

• Most objects cannot resize in this man-
ner, so the program will present a warn-
ing message indicating that there is not 
sufficient space at the current location.

When most drawing tools are active or 
library symbols selected for placement, a 
preview outline follows your mouse pointer, 
indicating the size and shape of the object to 
be created. If your pointer is positioned at a 
location where the object cannot be placed, 
this preview outline will not display.

As you move the mouse pointer, the center 
point of the object’s back edge will snap to 

active snap points when Grid Snaps  or 

Object Snaps  are enabled. See “Snap 
Behaviors” on page 109.

Many architectural objects can be created in 
floor plan view or any 3D view. In order to 
place a stand-alone, click-to-create object in 

3D, it is necessary to click near a wall or 
within the Terrain Perimeter as these objects 
help orient the new object within the 3D 
space. 

Clicking and Dragging
Other objects, including walls and railings, 
straight stairs, and CAD and CAD-based 
objects are created by clicking and dragging 
to define either a path or an enclosed area. 
Select a tool, then click and drag in the 
drawing area to draw an object between your 
start and end points.

Continue drawing the selected object until 
another tool is selected.

You can temporarily slow the movement of 
the mouse as you drag by holding down the 
Shift key on your keyboard..

You can cancel any click-and-drag drawing 
operation before it is completed by pressing 
the Esc key on your keyboard, or by pressing 
any two mouse buttons at the same time. 

Polyline- and Spline-based objects can be 
created by snapping multiple Line-, Arc-, 
and/or Spline-based objects together. These 
objects will only snap together to form a 
polyline or spline if they are on the same 
layer and share identical attributes such as 
color, line style, and arrow specifications. 
See “Editing Objects” on page 119. 

Entering Coordinates
CAD lines, arcs and points can be created 
using the Input Line, Input Arc and Input 
Point dialogs. See “Input Point” on page 
773, “Input Line” on page 777, or “Input 
Arc” on page 785.
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Importing Objects
Custom symbols, drawings, pictures and 
metafiles can be imported into the program 
and placed in the drawing area with a click. 
See “Importing & Exporting” on page 827 
and “Pictures, Images, & Walkthroughs” on 
page 805. 

Converting Objects
A variety of objects can be created by 
converting existing CAD objects and many 
CAD-based objects into another type of 
object. See “Converting Objects” on page 
164. 

Object Creation and Layers
When it is created, every object is placed on 
a layer which controls whether and how it 
displays. See “Layers” on page 101. 

If you try to create an object on a layer that is 
not set to display in the current view, the 
program will ask if you want to turn that 
layer on. See “Message Boxes” on page 32. 
• Click Yes to create the object and turn on 

its layer in the current view.
• Click No to create the object but leave its 

layer turned off in the current view. 
• Click Cancel to not create the object and 

leave the layer turned off.

If you try to create an object on a layer that is 
locked, the program will prompt you to 
unlock the layer. If you choose to leave the 
layer locked, the object will not be created. 
See “Locking Layers” on page 103.

Copying and Pasting Objects
New objects can also be created by cutting, 
copying, and pasting existing objects, either 
individually or in groups. Objects can be 
copied from one floor to another, one view 
window to another, and one file to another. 
Because copying uses the Windows 
Clipboard, some objects can be pasted into 
other applications, as well.

Objects cannot be pasted into any views that 
they cannot be created in normally. For 
example, CAD objects cannot be pasted into 
a 3D camera view or overview. 

Similarly, architectural objects cannot be 
pasted onto a layout page.

A few objects, such as Terrain Perimeters 
and camera symbols, cannot be copied. 

Cut
Select Edit> Cut to remove the 
selected object(s) from the file and 

save them in the Windows Clipboard. To 
paste the selection in Home Designer Pro or 
another application, select Edit> Paste or 
press Ctrl + V while in that application to 
enable the Paste function.

Copy
Select Edit> Copy to copy the 
selected object(s) to the Windows 

Clipboard. To paste the selection in Home 



Copying and Pasting Objects

 115

Designer Pro or another application, select 
Edit> Paste or press Ctrl + V while in that 
application to enable the Paste function. 

Paste
Select Edit> Paste to enable Paste 
mode, then left- or right-click in the 

current view to paste the selected object(s) 
previously copied to the Windows Clipboard 
at that location. 

Once pasted, these object(s) are selected. 
Objects pasted in 3D views are selected on 
their top surfaces.

If the selection being pasted consists of text, 
it is placed in a Text object.

If the selection being pasted is an image, the 
Paste Image dialog opens.

Specify how you would like to paste the 
selected image:
• Select Backdrop to add the image to the 

My Backdrops library category. The 
image will display in the preview panes. 
To use this backdrop, select 3D> 3D Set-

tings  from the menu. See “3D View 
Defaults Dialog” on page 668. 

• Select Image to add the image to the My 
Images library category. The image will 

display in the preview panes and will be 
selected. Click in the plan to place it. 

• Select Material to add the image to the 
My Materials library category The image 
will display in the preview panes. Select 

3D> Materials> Material Painter  to 
apply the material. See “The Material 
Painter” on page 632.

• Select Picture to display the picture in 
the current Home Designer Pro floor plan 
view. See “Importing Pictures” on page 
812.

Copy/Paste
Click the Copy/Paste edit button to 
copy the selected object(s) to the 

Windows Clipboard and immediately enable 

the Paste  function in Home Designer 
Pro. 

The Copy/Paste  edit button activates 
Paste mode in which each available edit tool 
and handle makes a copy in addition to its 
primary function and four new edit buttons 
display on the edit toolbar.

• Click the Sticky Mode  edit button 
remain in the current mode and place 
multiple copies of the selected object(s). 

• Click the Point to Point Move  edit 
button to make a copy of the selection at 
a specific location. See “Point to Point 
Move” on page 153. 

• Click the Reflect About Object  edit 
button to make a copy of the selection 
reflected about another object. See 
“Reflect About Object” on page 163. 
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• Click the Main Edit Mode  edit but-
ton or press the Esc key to return to the 
selected objects’s main edit toolbar.

If you paste a selection in a file other than its 
original source file, when you return to the 
original, Paste mode is still enabled. 

The Copy/Paste  edit button can be used 
with the edit handles in either of two ways: 
by clicking or by dragging an edit handle.

To Copy/Paste by clicking

1. Select an object or objects to copy.

2. Click the Copy/Paste  edit button, 

select Edit> Copy  from the menu or 
press Ctrl + C to copy and then Ctrl + 
V to activate the Paste functionality. The 
cursor displays the Copy/Paste icon.

3. If you wish to paste the copy in a differ-
ent view or program window, open that 
window. 

4. If your cursor does not display the Copy/
Paste icon, select Edit> Paste from the 
menu or press Ctrl + V.

5. Left- or right-click once to paste a copy 
of the object at that location.

To Copy/Paste by dragging

1. Select an object or objects to copy.

2. Click the Copy/Paste  edit button, 

select Edit> Copy  from the menu or 
press Ctrl + C. The cursor displays the 
Copy/Paste icon.

3. Drag an edit handle:

•  Drag the Move edit handle to position 
the copy at a new location. 

•  Drag a corner handle to create a copy in 
the same location but with a different 
size or shape.  The result depends on 

which Edit Behavior  you use. See 
“Edit Behaviors” on page 120. 

4. You can resize or position the copy 
accurately with respect to the original by 
watching the moved distance in the Sta-
tus Bar at the bottom of the screen.

Sticky Mode
Normally, after an action is performed 
using the edit tools or handles while in 

an edit mode such as Paste mode, you  return 
to the Main Edit Mode. Click the Sticky 
Mode edit button to remain in Paste mode 
and continue pasting copies of the selected 
object(s). 

To exit Paste mode and return to the main 
edit toolbar for the selected object, click the 

Main Edit Mode  edit button or press the 
Esc key on your keyboard. If you have not 
pasted a copy of the selected object and 

immediately click Copy/Paste  after 
returning to the Main Edit Mode, Sticky 

Mode  is still enabled. 

Use the Concentric edit behavior to cre-
ate concentric copies of CAD-based

objects. See “To create setback lines” on
page 199 of the User’s Guide for an exam-
ple. 

Sticky Mode is available when the Copy/
Paste edit button is clicked. 
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Copy and Paste in Place
Click the Copy and Paste in Place 
edit button to create a copy of the 

selected object(s) at the same location as the 
original. The copy remains selected so you 
can perform additional operations.

Because multiple walls, railing and fencing 
cannot share the same space, the Copy and 

Paste in Place  edit button is not avail-
able for these objects.

Paste Hold Position
When copying between different 
floors or view windows, you can paste 

a copy at the same absolute position as the 
original selection using Paste Hold Position.

To use Paste Hold Position

1. Select the object(s) to be copied.

2. Click the Copy/Paste  edit button.
3. Switch to the desired floor or plan file 

and select Edit> Paste> Paste Hold 

Position .
4. A copy is placed at the same X, Y coor-

dinates on the new floor or in the new 
plan as the original’s position.

Paste Special
The Paste Special tool allows you to 
choose a representation for the 

selection to be pasted. 

Selections can be pasted as:
• Enhanced Windows Metafiles (EMF). 

See “Metafiles” on page 814. 

• Device Independent Bitmaps (BMP). See 
“Importing Pictures” on page 812.

• Unformatted non-unicode text (TXT).
• File Name (a path to a file). Depending 

on the file type, it will be either opened or 
imported (if supported). 

• Unformatted text (HTML). Pastes as text.
• Model Objects - Home Designer Pro for-

mat, not compatible with other programs.

To use Paste Special

1. Select an object, image, text or file on 
your computer and copy it.

2. Switch to the desired Home Designer 
Pro view window and select Edit> 

Paste> Paste Special .
3. In the Paste Special dialog, select the 

desired representation for the selection 
and click OK.

4. Click in the drawing area to place the 
copy at that location.

Using the Transform/
Replicate Object Dialog
Objects and groups of objects can be 
copied and pasted using the 

Transform Replicate Object dialog. See 
“Transform/Replicate Object Dialog” on 
page 166.

Copy Region as Picture
The Copy Region as Picture tool 
allows you to copy any portion of the 

screen and save it as a picture.  See “Copy 
Region as Picture” on page 819. 
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Using Point to Point Move
The Point to Point Move edit button 
can be used in combination with 

Copy/Paste  to make a copy of the 
selected object(s) at a specified location. See 
“Point to Point Move” on page 153.

To point to point copy

1. Select the object(s) to be copied, click 

the Copy/Paste  edit button, then the 

Point to Point Move  edit button.
2. Click at the start point and then at the 

end point. 

3. An exact copy of the selected object(s) 
is created at the end point while the orig-
inal remains unchanged. 

Using Reflect About Object
The Reflect About Object edit button 
can be used in combination with 

Copy/Paste  to make a reflected copy of 
the selected object(s), much the way Point to 

Point Move  can. See “Reflect About 
Object” on page 163.
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Chapter 7:

Editing Objects

Just as the methods used to create different 
objects in Home Designer Pro are similar, the 
options for moving, rotating, resizing, and 
otherwise editing them are also alike. 

Edit handles allow objects to be resized, 
relocated, or rotated using the mouse. Edit 
toolbar buttons and the contextual menus 
access edit tools relevant to the selected 
object(s). Most objects have a specification 
dialog that allows you to edit it in ways that 
are specific to that type of object. 

The editing characteristics common to most 
objects are described in this chapter. Unique, 
object-specific editing behaviors and the 
specification dialogs are covered in their 
respective chapters. 

Chapter Contents
•      Defaults and Preferences
•      Edit Behaviors
•      Selecting Objects
•      Editing Line Based Objects
•      Editing Arc Based Objects
•      Editing Open Polyline Based Objects
•      Editing Closed-Polyline Based Objects
•      Editing Box-Based Objects
•      Editing Spline Based Objects
•      Editing Circles, Ovals and Ellipses
•      Displaying Objects
•      Moving Objects
•      Aligning Objects
•      Resizing Objects
•      Reshaping Objects
•      Rotating Objects
•      Reflecting Objects
•      Converting Objects
•      Transform/Replicate Object Dialog
•      Edit Area Tools
•      Deleting Objects
•      Undo and Redo
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Defaults and Preferences
The same defaults and preference settings 
that affect how objects are drawn also 
influence how they can be edited. See 
“Defaults and Preferences” on page 108.

Edit Behaviors
There are five Edit Behavior modes 
that determine how edit handles affect 

an object, and may also affect how objects 
are drawn. The currently active edit behavior 
is a global preference setting, affecting all 
plan and layout files.

Two of these modes, Default and Alternate, 
are useful for most drawing and editing 
needs and can be considered primary editing 
modes. Default mode, in particular, accesses 
the most commonly used behaviors and is the 
best choice in most circumstances. When an 
Edit Behavior other than Default is active, its 
icon displays near the mouse pointer. 

The other three modes, Resize, Concentric 
and Fillet, offer special editing behaviors 
that may be useful only in certain situations 
and can be considered secondary. 

Each edit behavior can be temporarily 
enabled using the different buttons on your 
mouse or by pressing the keyboard keys 
associated with each. See “Using the Mouse” 
on page 26 and “Hotkeys” on page 99. 

You can also specify which edit behavior 
mode is active when the left mouse button is 
used in the Preferences dialog, by selecting 

Edit> Edit Behaviors , or by clicking the 
corresponding toggle button, which can be 
added to your toolbar. See “Behaviors Panel” 
on page 78.

Default
The Default mode is one of the 
primary edit behavior modes. It offers 

access to the most commonly used edit 
behaviors and should be selected as your 
preference in most situations.

• Drawing - Standard click and drag 
drawing behavior is enabled. See 
“Creating Objects” on page 112. 

• Resize/Reshape - Default allows you to 
adjust the angle of any corner of a poly-
line without affecting adjacent corners, 
changing the object’s shape. 

It is a good idea to be familiar with these
options and how they affect drawing

and editing in the program.

Note: Regardless of which Edit Behavior is
active, the Default behavior is restored when
you close the program. 

When the use of a tool is described in
this manual, it is assumed that the

Default edit behavior mode is active.
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• For box-based objects, the Default mode 
functions the same as the Alternate mode. 

• Movement - Default allows you to move 
objects orthogonal, or at a right angle, to 
any of their edges.

• Rotation - In Default mode, objects snap 
at Allowed Angles as they are rotated.

You can temporarily enable the Default  
edit mode when another mode is active by 
pressing Alt + Z or Alt + / while performing 
an edit or drawing operation.

Alternate
The Alternate mode is the second 
primary edit behavior mode. When 

this mode is active, the Alternate  icon 
displays near the mouse pointer.

• Alternate allows you to drag an end han-
dle on an open polyline to change it from 
a line to an arc or vice versa. 

• Alternate overrides the Lock Center set-
ting of arc-based objects.

• Movement - Alternate allows you to 
move objects at Allowed Angles when 

Angle Snaps  are enabled, or orthogo-
nal to any of its edges when they are not. 
See “Angle Snaps” on page 111. 

• Rotation - Alternate snaps objects at 
Allowed Angles as they are rotated.

You can temporarily enable the Alternate 

 edit mode when another mode is active 
by pressing Alt or using the right mouse 
button while performing an edit operation.

Resize
The Resize edit behavior allows you 
to rescale an object. As you drag a 

corner edit handle of an object, you get an 
exactly scaled version of the original. For 
example, you can resize an object to 50% of 
its original size while maintaining the same 
proportions. When this mode is active, the 
Resize  icon displays near the mouse 
pointer.
• Drawing - Standard click and drag 

drawing behavior is enabled.  
• Resize/Reshape - Resize allows you to 

keep the angle between adjacent edges 
fixed when a corner handle is moved. 

Note: Not all commands have an Alternate
edit behavior. If a selected tool does not, it
will not work when this edit mode is active. 

Default edit behavior
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• Movement - Resize allows you to move 
an object orthogonal, or at a right angle, 
to any of its edges.

• Rotation - In Resize Mode, objects snap 
at Allowed Angles as they are rotated. 

You can temporarily enable the Resize  
edit mode when another mode is active by 
pressing X or the period key, or using the X2 
button on a five-button mouse while 
performing an edit or drawing operation. See 
“Using the Mouse” on page 26.

Concentric
The Concentric mode allows you to 
resize objects so that the distance 

moved by each edge is the same. For 
example, you can resize an irregularly 
shaped polyline so that each edge is exactly 
ten feet in from the original position, which 
is useful for creating site plans with setbacks. 
When this mode is active, the Concentric  
icon displays near the mouse pointer.

• Drawing - Standard click and drag 
drawing behavior is enabled.  

• Resize/Reshape - Concentric allows you 
to resize an irregularly-shaped polyline 
so that each edge is moved the same dis-
tance from its original location. 

• Concentric mode also allows you to 
move opposite edges of an object so that 
each edge is moved the same distance 
from its original location. 

To proportionally resize an object,
always drag a corner edit handle and

not an edge handle.

Resize edit behavior

Note: The Concentric edit behavior can be
used to create concentric copies of CAD-
based objects. See “To create setback lines”
on page 199 of the User’s Guide. 

Concentric edit behavior



Edit Behaviors

 123

• Movement - Concentric mode allows 
you to move an object orthogonal, or at a 
right angle, to any of its edges.

• Rotation - In Concentric mode, objects 
snap at Allowed Angles as they are 
rotated.

In some cases, the Concentric and Resize 
edit behaviors have the same result, such as 
when a circle is resized. Usually, though, the 
two behaviors are different because 
concentric resizing does not maintain the 
original ratio between an irregular polyline’s 
edges. 

In Concentric mode, objects resize in 
Concentric Jump increments specified in 
the Preferences dialog. See “Behaviors 
Panel” on page 78. 

When the Concentric Jump distance is set 
at 0", objects resize according to the Snap 
Unit specified in the Plan Defaults dialog. 
See “Grid Snaps” on page 112. 

You can temporarily enable the 

Concentric  edit mode when another 
mode is active by pressing C or the comman 

key, or using the X1 button on a five-button 
mouse while performing an edit or drawing 
operation. See “Using the Mouse” on page 
26.

Fillet
The Fillet mode allows you to add a 
fillet, or curve, at any corner of an 

object. Dragging a corner edit handle adjusts 
the fillet radius at that corner. When this 
mode is active, the Fillet  icon displays 
near the mouse pointer.
• Drawing - Standard click and drag 

drawing behavior is enabled. 
• Resize/Reshape - Fillet allows you to 

create a fillet at by dragging a corner edit 
handle inward. 

• Movement - Move mode allows you to 
move objects at Allowed Angles.

• Rotation - In Move mode, objects snap 
at Allowed Angles as they are rotated.

The Fillet  edit behavior adjusts all the 
corners of a box at once. The radius of each 
corner is the same.

Fillet  does not have an effect on circles, 
ovals, ellipses or arc segments.

To concentrically resize an object with
no restrictions, set the Concentric Jump

value on the Edit> Behaviors panel of the
Preferences dialog to zero and turn off Grid
Snaps.

Concentric 
edit behavior

Resize edit 
behavior

Fillet edit behavior
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You can temporarily enable the Fillet  
edit mode when another mode is active by 
pressing F while performing an edit or 
drawing operation.

Selecting Objects
“Select” refers to selecting an object for 
editing. An object must be selected before it 
can be edited. 

In order for an object to be selected, it must 
be both unlocked and visible in the current 
view. See “Layers” on page 101. 

When an object is selected, it displays edit 
handles and a selection fill color. See “Colors 
Panel” on page 63.

In 3D views, a selected object will also 
display lines representing the selected edge 
or surface. The size of the edit handles does 
not change as you zoom in or out and is set in 
the Preferences dialog. See “Edit Panel” on 
page 76. To prevent them from stacking on 
one another, some edit handles may not 
display as you zoom away from the selected 
object. 

When an object is selected, its edit toolbar 
also displays, typically at the bottom of the 
Home Designer Pro program window just 
above the Status Bar.  See “The Edit 
Toolbar” on page 29.

Information about the selected object or 
objects may also display in the Status Bar. 
See “The Status Bar” on page 31.

A selected object remains selected until 
another object is selected, a different tool is 

activated, the Esc key on the keyboard is 
pressed, or any two mouse buttons are 
pressed at the same time. 

Select Objects
With the exception of temporary CAD 
points, any object created using Home 

Designer Pro can be selected using the Select 
Objects tool. Select Edit> Select Objects, 
click the toolbar button or press the Space 
bar on your keyboard to activate this tool, 
then click on an object to select it.

You can also select objects or open context 
sensitive menus using the right mouse button 
when any tool is active.

By default, you can select an object by 
clicking within 12 pixels of it. You can adjust 
this distance by changing the Snap Distance 
in the Preferences dialog. A lower value, for 
example, can be helpful for working with 
small objects but can also make it very 
difficult to select larger objects. See “Snap 
Properties Panel” on page 79. 

 Selecting Similar Objects

If a tool other than Select Objects  is 
active, you can only select objects of that 
type using the left mouse button. For 

To produce fillets or chamfers of an
exact radius, set the Fillet Chamfer

Radius and use the Fillet two Lines or Cham-
fer Two Lines edit button. See “Fillet Two
Lines” on page 159 and “Chamfer Two Lines”
on page 160.
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example, if the Straight Exterior Wall  
tool is active, you can only select walls using 
the left mouse button. 

This can be useful for selecting an object 
when many objects of a different type 
occupy the same space in floor plan view. 

Objects can be selected using the right mouse 
button, regardless of which tool is active. 

Right-Clicking
Regardless of which tool is active, you can 
select an eligible object by right-clicking on 
it once. When you right-click to select an 
object a contextual menu also appears, 
displaying the object’s edit tools. You can 
turn contextual menus on or off in the 
Preferences dialog. See “Contextual 
Menus” on page 30.

If a drawing tool is active and you right-click 
to select an object, you can unselect it by 
left-clicking in an empty space in the 
drawing area. Although a drawing tool is 
active, it is not used. If you then left-click a 
second time, the active tool will be used. 

Selected Edge
When you click on a polyline- or box-based 
object, the edge that you click nearest 
becomes the selected edge and displays an 
edit handle larger than those on other edges. 
The handle on this edge may also display at 
the point where you clicked to select it.  

This edge can be edited on the Selected Line 
or Selected Arc tab of the object’s 
specification dialog, as well as using a 
variety of edit toolbar buttons. It can also be 
moved using dimensions. See “Moving 
Objects Using Dimensions” on page 737, 
“Line Tab” on page 780 and “Arc Tab” on 
page 787.

The Start and End points of a CAD-based 
object’s selected edge or of a wall can be 
indicated by an S and an E when the object is 
selected. These Start and End indicators can 
be helpful when editing the selected edge in 
the object’s specification dialog, and their 
display can be turned on and off in the 
Preferences dialog. See “Edit Panel” on 
page 76. 

Edit Object Parts
Polyline-based objects are composed 
of lines and arcs that are connected 

end to end. The individual edges of open and 
closed polylines can be selected and edited 
independently of the object’s other edges 
when Edit Object Parts is enabled.

Select Edit> Edit Behaviors> Edit Object 

Parts  to enable or disable the ability to 

Selected edge with start and end indicators
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edit polyline segments individually. Edit 

Object Parts  can also be turned on or off 
in the Preferences dialog. See “CAD Panel” 
on page 74.

Edit Object Parts  also affects 
connections between walls, railings and 
fences, but does not affect Walkthrough 
Paths or closed polyline CAD-based objects 
such as slabs and roof planes.

To use Edit Object Parts

1. Turn on Edit Object Parts . Your 
cursor will display the Edit Object 
Parts  icon.

2. Click on an individual edge of a poly-
line, or a segment of wall, railing or ter-
rain path to select it. 

3. Notice that it is no longer connected to 
the rest of the polyline or adjacent walls.

4. The individual segment can now be 
edited entirely independent of its neigh-
bors.

5. To connect the segment to the polyline 

again, turn off Edit Object Parts  
and move the end handles so that they 
snap to the ends of adjacent segments.

When Edit Object Parts  is enabled, 
only objects that you click on are actually 
affected by it. Any objects that you do not 
select remain intact. 

Select Next Object
If there is more than one object in a 
particular space, it may be difficult to 

select the desired object. When a nearby 
object is selected, click the Select Next 
Object edit button or press the Tab key until 
the desired object becomes selected. This 
function cannot be applied to groups of 
selected objects.

Marquee Select
Groups of objects can be selected by holding 
down either the Shift or Ctrl key when the 

Select Objects  tool is active and then 
dragging a marquee around the objects to be 
selected. 

You can specify whether objects must be 
totally contained in or intersected by the 
marquee, or whether an object’s center point 
must be contained in the marquee, in the 
Preferences dialog or using the Selection 

Mode  buttons, which can be added to 
your toolbars. See “Edit Panel” on page 76. 

If an object is currently selected and a 
selection marquee is drawn around it, that 
object becomes de-selected.  If an object is 
currently selected and a marquee is drawn 
around other objects, the original object  
remains selected and the other objects are 
added to the selection set.

Edit Object Parts off Edit Object Parts on

A selected Terrain Wall

Note: Edit Object Parts is always reset to be
off when you close the program. 
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When using the marquee-select method, both 
CAD and architectural objects included in 
the marquee are selected. To remove an 
object from the selection set, hold down the 
Shift key and click it.

The Shift key can also be used to marquee-
select objects of a similar type. For example, 

click the Hinged Door  child button, hold 
down the Shift key, drag a marquee, release 
the mouse button, and only door objects 
within the marquee are selected. The Ctrl key 
will always marquee-select objects of all 
types, regardless of the active tool. 

Shift Select
You can select a group of objects by adding 
them to the selection set one by one. Select 
an object, hold down either the Shift or Ctrl 
key, and click additional objects to select 
them. 

More than one type of object can be selected 
using this method, but the ability to edit the 
group-selected items is limited to attributes 
that all selected objects have in common.

To remove an object from a selection set, 
click it once more - again, with either the 
Shift or Ctrl key pressed.

Edit Area Tools
The Edit Area Tools allow you to 
define an area of your plan and select 

the objects within that area for editing. See 
“Edit Area Tools” on page 168.

Editing Line Based Objects
Objects are considered line-based when they 
can be edited similar to CAD lines using 
their edit handles.

CAD lines, framing members, straight walls 
and railings, straight stairs and straight roads 
are examples of line-based objects. 

Most line-based objects can be connected to 
other like objects to form polylines or 
polyline-based objects. See “Editing Open 
Polyline Based Objects” on page 134 and 
“Editing Closed-Polyline Based Objects” on 
page 138.

Some objects, notably walls, have line-based 
editing behavior only when selected on 

certain surfaces. See “Editing Walls” on page 
197.

Wall openings such as doors and windows 
have line-based editing behavior in floor plan 
view only but cannot be rotated, reversed or 
converted to an arc. See “Editing Doors” on 
page 258 and “Editing Windows” on page 
289.

To make marquee selection easier, you
can turn off the display of objects you

do not want to include in your selection set.
See “Displaying Objects” on page 102.
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Other objects, such as stairs and roads, have 
additional edit handles that allow you to 
concentrically adjust the object’s width. 

Using the Edit Handles
When selected, a typical line-based object 
displays four edit handles.  

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Click and drag the Move handle to move 

the object according to the currently 

active Edit Behavior . See “Edit 
Behaviors” on page 120. 

• Movement may be limited or stopped by 
other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 153.

Rotate
• The Rotate handle is used to rotate the 

object, either about its center or about the 
current CAD point. See “Rotating 
Objects” on page 161.

Extend/Change Angle 
• Drag an end handle parallel to the 

selected line to change its length. 
• Drag an end handle at an angle to the 

selected line to change its angle. When 

Angle Snaps  are on, the line snaps to 
Allowed Angles. See “Angle Snaps” on 
page 111.

• Right-click and drag it to change the 
adjacent line into an arc, or vice versa. 
See “Alternate” on page 121. 

Adjust Width

Some line-based objects, such as stairs and 
roads, have additional handles that allow the 
width of the object to be adjusted.

• Click and drag a small, round Expand 
handle to increase or decrease the 

The behavior of the edit handles may
depend on the currently active Edit

Behavior. See “Edit Behaviors” on page 120.

Rotate

Extend/Change Angle

Move

Adjust Width
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object’s width. By default, objects are 
resized in 1" increments. This Snap Unit 
is defined in the Plan Defaults dialog. 
See “General Plan Defaults Dialog” on 
page 58.

Using Dimensions
Dimensions can be used to position 
line-based objects relative to other 

objects. See “Moving Objects Using 
Dimensions” on page 737.

Dimensions cannot, however, be used to 
adjust the length of line-based objects, or the 
width of line-based objects such as stairs.

Using the 
Specification Dialog

Line-based objects can be edited using 
their specification dialogs. See “Line 

Specification Dialog” on page 780.

Using the Edit Toolbar
A selected line-based object can be edited in 
a variety of ways using the buttons on the 
edit toolbar. 

The following toolbar buttons may display 
on the edit toolbar for a selected line-based 
object: 

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 124.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 31.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 
elsewhere. See “Copying and Pasting 
Objects” on page 114.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 117.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 171.

• Click the Transform/Replicate 

Object  edit button to copy, move, 
rotate, resize, or reflect the selected 
object(s). See “Transform/Replicate 
Object Dialog” on page 166.

• Click the Accurate Move  edit button 
to slow down the mouse speed when 
using the edit handles. See “Accurate 
Move” on page 153.

• Click the Make Parallel/Perpendicular 

 edit button to make the selected 
object(s) parallel or perpendicular to a 
straight edge. See “Using Make Parallel/
Perpendicular” on page 155. 

• Click the Point to Point Move  edit 
button to accurately move the selected 
object(s). See “Point to Point Move” on 
page 153. 

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 156.
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• Click the Reflect About Object  edit 
button to reflect the selected object(s) 
about another object. See “Reflecting 
Objects” on page 163. 

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 151.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 158.

• Click the Reverse Direction  edit but-
ton to reverse the direction of the selected 
object(s). See “Reverse Direction” on 
page 164.

• Click the Convert Polyline  edit but-
ton to convert the object into a special 
polyline-based object. See “Convert 
Polyline” on page 165.

• Click the Change Line/Arc  edit but-
ton to change a line-based object to an 
arc, or vice versa. See “Change Line/
Arc” on page 159.

• Click the Fillet Two Lines  edit but-
ton, then click on a non-parallel line or 
arc to create an additional arc connecting 
the two. See “Fillet Two Lines” on page 
159.

• Click the Chamfer Two Lines  edit 
button, then click an edge adjacent to the 
selected edge to chamfer the corner 
between them. See “Chamfer Two Lines” 
on page 160.

Editing Arc Based Objects
Objects are considered arc-based when they 
can be edited similar to CAD arcs using their 
edit handles.  

CAD arcs, curved walls and railings, curved 
stairs, and curved roads are examples of arc-
based objects.  

Most arc-based objects can be connected to 
other like objects to form polylines or 
polyline-based objects. See “Editing Open 
Polyline Based Objects” on page 134 and 
“Editing Closed-Polyline Based Objects” on 
page 138.

Some objects, notably curved walls, have 
arc-based editing behavior only when 
selected on certain surfaces. See “Editing 
Walls” on page 197.
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Other objects, such as curved stairs and 
roads, have additional edit handles that allow 
you to concentrically adjust the object’s 
width. 

The currently active Arc Creation Mode  
determines how an arc-based object is 
drawn. Once an arc is drawn, the active Arc 
Creation Mode does not affect it. See 
“Drawing Arcs - Arc Creation Modes” on 
page 784.

Using the Edit Handles
When selected, a typical arc-based object 
displays seven edit handles. 

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Two Move edit handles allow the arc to 

be relocated without changing its shape. 

One is located at the center of the chord 
and the other, at the arc center. 

• If you would like to snap one of these 
center points to another point, use that 
handle when moving the arc. See “Align-
ing Arc Centers” on page 156.

• Click and drag the Move handle to move 
the object according to the currently 

active Edit Behavior . See “Edit 
Behaviors” on page 120. 

• Movement may be limited or stopped by 
other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 153.

Rotate
• The Rotate handle is used to rotate the 

arc, either about its center or about the 
current CAD point. See “Rotating 
Objects” on page 161.

Extend
• The end edit handles expand or contract 

the arc when moved along the arc radius 
or chord. 

• If you follow the path of the arc, the end 
edit handles allow you to adjust the arc 
length.

• The angle formed by the center point of 
the arc and its two endpoints is referred to 
as the Included Angle. If Angle 

The behavior of the edit handles may
depend on the currently active Edit

Behavior. See “Edit Behaviors” on page 120.

Extend
 (along arc or chord)

Move Arc 
Center

Reshape
(moves center)

Resize
(changes radius)

Rotate

Move 
Chord

Move edit handle
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Snaps  are on, the Included Angle of 
the arc, as measured in degrees, can be 
rotated at Allowed Angles. See “Angle 
Snaps” on page 111.

• Right-click and drag it to change the 
adjacent arc into a line, or vice versa. See 
“Alternate” on page 121. 

Resize
• Drag the small, round Resize edit handle 

to change the radius and included angle 
of the arc while maintaining its center. 

Reshape
• Drag the small triangular Reshape 

handle to change the length and location 
of the center without moving the 
endpoints.

Adjust Width

Some arc-based objects, such as stairs, have 
additional handles that allow the width of the 
object to be adjusted. 

• Click and drag a small, round edit handle 
to increase or decrease the object’s width. 
By default, objects are resized according 
to the Snap Unit defined in the Plan 
Defaults dialog. See “General Plan 
Defaults Dialog” on page 58.

Using Dimensions
Dimensions can be used to position 
arc-based objects. Dimension lines 

typically locate tangent extension lines and 
any extension lines that may be parallel to 
those lines rather than the arc itself. See 
“Moving Objects Using Dimensions” on 
page 737.

Using the 
Specification Dialog

Arc-based objects can be edited using 
their specification dialogs. See “Arc 

Specification Dialog” on page 786.

Extend edit handles

Resize edit handle

Reshape edit handle

Adjust Width
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Using the Edit Toolbar
A selected arc-based object can be edited in a 
variety of ways using the buttons on the edit 
toolbar. 

The following toolbar buttons may display 
on the edit toolbar for a selected arc-based 
object:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 124.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 31.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 
elsewhere. See “Copying and Pasting 
Objects” on page 114.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 117.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 171.

• Click the Transform/Replicate 

Object  edit button to copy, move, 
rotate, resize, or reflect the selected 
object(s). See “Transform/Replicate 
Object Dialog” on page 166.

• Click the Accurate Move  edit button 
to slow down the mouse speed when 

using the edit handles. See “Accurate 
Move” on page 153.

• Click the Point to Point Move  edit 
button to accurately move the selected 
object(s). See “Point to Point Move” on 
page 153. 

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 156.

• Click the Reflect About Object  edit 
button to reflect the selected object(s) 
about another object. See “Reflecting 
Objects” on page 163. 

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 151.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 158.

• Click the Reverse Direction  edit but-
ton to reverse the direction of the selected 
object(s). See “Reverse Direction” on 
page 164.

• Click the Convert Polyline  edit but-
ton to convert the object into a special 
polyline-based object. See “Convert 
Polyline” on page 165.

• Click the Change Line/Arc  edit but-
ton to change an arc-based object to a 
line, or vice versa. See “Change Line/
Arc” on page 159.
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• Click the Fillet Two Lines  edit but-
ton, then click on a non-parallel line or 
arc to create an additional arc connecting 
the two. See “Fillet Two Lines” on page 
159.

• Click the Chamfer Two Lines  edit 
button, then click an edge adjacent to the 
selected edge to chamfer the corner 
between them. See “Chamfer Two Lines” 
on page 160.

Show Arc Centers
When working with arc-based objects 
or circles, it can be helpful to see their 

center points. Click the Show Arc Centers 
and Ends toggle button on the utility toolbar 
to turn on their display. You can also turn on 
their display in the CAD Defaults dialog. See 
“CAD Defaults Dialog” on page 770.

Arc-based objects can be aligned using their 
center points. See “Aligning Arc Centers” on 
page 156.

Editing Open Polyline Based Objects
Open polyline-based objects are composed 
of individual line- and arc-based objects that 
are connected at their end points but do not 
form an enclosed area. See “Polylines” on 
page 790. 

Objects are considered open polyline-based 
when they can be edited similar to open CAD 
polylines using their edit handles. 

Open CAD polylines, connected walls, 
stairs, and roads are examples of open 
polyline-based objects. 

Other objects, such as connected stair and 
road segments, have additional edit handles 
that allow you to concentrically adjust the 
width of all segments of the object. 

If Edit Object Parts is enabled, clicking
on a CAD polyline edge selects the indi-

vidual edge rather than the entire polyline.
See “Edit Object Parts” on page 125.
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Using the Edit Handles
A polyline can be composed of many 
segments. See “Polylines” on page 790. 

When selected, an open polyline-based 
object displays a Move handle, a Rotate 
handle, a Reshape handle at the intersection 
of each segment, and an Extend handle at 
each end. 

Each straight, line-based segment also has a 
Move edit handle along its length. 

Each curved, arc-based segment has its own 
Move handle at the center of its chord, a 
Resize handle and, if it has an unlocked 
center, a Reshape handle. See “Editing Arc 
Based Objects” on page 130.

When a polyline is selected, the edge that 
you click nearest is called the selected edge, 
and certain operations affect only this edge. 
The Move handle of the selected edge is 
larger than that of other edges. It displays 
along the length of a line segment, or at the 
center of the chord on an arc segment. See 
“Selected Edge” on page 125.

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Click and drag the Move handle to move 

the object according to the currently 

active Edit Behavior . 
• Movement may be limited or stopped by 

other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 153.

Rotate
• The Rotate handle is used to rotate the 

object, either about its center or about the 
current CAD point. Its position varies 
depending on which edge is currently 
selected. See “Rotating Objects” on page 
161.

Extend
• Click and drag an Extend handle to 

lengthen or shorten the unconnected end 
of the selected line or arc segment, or to 
change the radius of the selected arc. See 
“Editing Arc Based Objects” on page 
130.

• Right-click and drag it to change the 
adjacent line into an arc, or vice versa. 
See “Alternate” on page 121. 

The behavior of the edit handles
depends on the currently active Edit

Behavior. See “Edit Behaviors” on page 120.

Move 
polyline

Move arc 
segment

Rotate
Extend

Resize 
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Reshape 
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Move line 
segment

Reshape 
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Reshape 
• Click and drag a Reshape edit handle to 

change the angle and/or length of the seg-
ments on either side of it, or the size of 
the object, depending on the currently 

active Edit Behavior . 

Move Line Segment
• The Move Line Segment edit handle is 

found on straight segments of open poly-
lines and moves the straight section 
according to the currently active Edit 

Behavior . Adjacent segments may 
extend or contract in their original direc-
tions to maintain their connections. 

Move Arc
• Click and drag the Move Arc edit handle 

to change the radius and/or chord length 
or position, depending on the currently 

active Edit Behavior  and whether 
the arc has a locked center. Adjacent seg-
ments may extend, contract, or change 
angle to maintain their connections. 

Resize Arc
• Click and drag the Resize Arc edit handle 

to change the radius, chord length and 
chord position of the arc segment, 
depending on the currently active Edit 

Behavior  and whether the arc has a 
locked center. Adjacent segments may 
extend, contract, or change angle to 
maintain their connections. 

Reshape Arc
• Click and drag the Reshape Arc edit han-

dle to change the radius of the arc without 
moving its end points. Only available if 
the arc has an unlocked center.

Adjust Width

Some arc-based objects, such as stairs and 
roads, have additional handles that allow the 
width of the object to be adjusted. 

• Click and drag a small, round edit handle 
to increase or decrease the object’s width. 
By default, objects are resized in 1" 
increments. This Snap Unit is defined in 
the Plan Defaults dialog. See “General 
Plan Defaults Dialog” on page 58.

Using Dimensions
Dimensions can be used to move or 
reshape polyline-based objects. See 

“Moving Objects Using Dimensions” on 
page 737.

Using the Specification 
Dialog

Open polyline-based objects can be 
edited using their specification 

dialogs. See “Polyline Specification Dialog” 
on page 791.

Using the Edit Toolbar
A selected open polyline-based object can be 
edited in a variety of ways using the buttons 
on the edit toolbar. 

The following toolbar buttons may display 
on the edit toolbar for a selected open 
polyline-based object:

Adjust 
Width
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• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 124.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 31.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 
elsewhere. See “Copying and Pasting 
Objects” on page 114.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 117.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 171.

• Click the Transform/Replicate 

Object  edit button to copy, move, 
rotate, resize, or reflect the selected 
object(s). See “Transform/Replicate 
Object Dialog” on page 166.

• Click the Accurate Move  edit button 
to slow down the mouse speed when 
using the edit handles. See “Accurate 
Move” on page 153.

• Click the Make Parallel/Perpendicular 

 edit button to make the selected 
straight edge parallel or perpendicular to 
another straight edge. See “Using Make 
Parallel/Perpendicular” on page 155. Not 

available when the selected edge is an 
arc.

• Click the Point to Point Move  edit 
button to accurately move the selected 
object(s). See “Point to Point Move” on 
page 153. 

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 156.

• Click the Reflect About Object  edit 
button to reflect the selected object(s) 
about another object. See “Reflecting 
Objects” on page 163. 

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 151.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 158.

• Click the Reverse Direction  edit but-
ton to reverse the direction of the selected 
object(s). See “Reverse Direction” on 
page 164.

• Click the Close Polyline  edit button 
to convert the selected open polyline into 
a closed polyline. See “Using Close 
Polyline” on page 138.  

• Click the Convert Polyline  edit but-
ton to convert the object into a special 
polyline-based object. See “Convert 
Polyline” on page 165.



138

Home Designer Pro 2014 Reference Manual

• Click the Change Line/Arc  edit but-
ton to change a line-based polyline edge 
to an arc, or vice versa. See “Change 
Line/Arc” on page 159.

• Click the Record Walkthrough Along 

Path  edit button to record a walk-
through video of your model along the 
path defined by the selected polyline. See 
“Walkthroughs” on page 819.

• Click the Fillet Two Lines  edit but-
ton, then click on an adjacent edge to cre-
ate an arc connecting the two. See “Fillet 
Two Lines” on page 159. Cannot be used 
if the adjacent edge is an arc. 

• Click the Chamfer Two Lines  edit 
button, then click on an edge adjacent to 
the selected edge to chamfer the corner 
between them. See “Chamfer Two Lines” 
on page 160.

Using Close Polyline
An open polyline-based object can be 
converted into a closed polyline using 

the Close Polyline edit tool. This tool adds 
an edge to the open polyline, connecting its 
two ends and closing the gap between them. 
Close Polyline is not available when Edit 

Object Parts  is enabled. See “Edit 
Object Parts” on page 125. 

Editing Closed-Polyline Based Objects
Closed polyline-based objects are composed 
of individual line- and arc-based objects 
joined end-to-end and forming an enclosed 
area. See “Polylines” on page 790. 

Objects are considered closed polyline-based 
when they can be edited similar to closed 
CAD polylines using their edit handles. 

Closed CAD polylines, slabs and roof planes 
are examples of closed polyline-based 
objects. 

Some objects, notably walls, have closed 
polyline-based editing behavior only when 
they are selected on certain surfaces in 3D 
views. See “Editing Walls” on page 197.

Other objects, such as connected road 
segments, have additional edit handles that 
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allow you to concentrically adjust the width 
of all segments of the object. 

Using the Edit Handles
A polyline can be composed of many 
segments. See “Polylines” on page 790. 

When selected, a closed polyline-based 
object displays a Move handle, a Rotate 
handle, and a Reshape handle at the 
intersection of each segment. 

Each straight, line-based segment has a 
Move edit handle along its length. 

Each curved, arc-based segment has its own 
Move handle at the center of its chord, a 
Resize handle and, if it has an unlocked 
center, a Reshape handle. See “Editing Arc 
Based Objects” on page 130.

When a polyline is selected, the edge that 
you click nearest is called the selected edge, 
and certain operations affect only this edge. 
The Move handle of the selected edge is 
larger than that of other edges. It displays 
along the length of a line segment, or at the 
center of the chord on an arc segment. See 
“Selected Edge” on page 125.

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Click and drag the Move handle to move 

the object according to the currently 

active Edit Behavior . 
• Movement may be limited or stopped by 

other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 153.

Rotate
• The Rotate handle is used to rotate the 

object, either about its center or about the 
current CAD point. Its position varies 
depending on which edge is currently 
selected. See “Rotating Objects” on page 
161.

Reshape 
• Click and drag a Reshape edit handle to 

change the angle and/or length of the seg-
ments on either side of it, or the size of 
the object, depending on the currently 

active Edit Behavior . 

Move Line Segment
• The Move Line Segment edit handle is 

found on straight segments of closed 
polylines and moves the straight section 
according to the currently active Edit 

If Edit Object Parts is enabled, clicking
on a polyline edge selects the individual

edge rather than the entire polyline. See “Edit
Object Parts” on page 125.

The behavior of the edit handles may
depend on the currently active Edit

Behavior. See “Edit Behaviors” on page 120.
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Behavior . Adjacent segments may 
extend or contract in their original direc-
tions to maintain their connections. 

Move Arc
• Click and drag the Move Arc edit handle 

to change the radius and/or chord length 
or position, depending on the currently 

active Edit Behavior  and whether 
the arc has a locked center. Adjacent seg-
ments may extend, contract, or change 
angle to maintain their connections. 

Resize Arc
• Click and drag the Resize Arc edit handle 

to change the radius, chord length and 
chord position of the arc segment, 
depending on the currently active Edit 

Behavior  and whether the arc has a 
locked center. Adjacent segments may 
extend, contract, or change angle to 
maintain their connections. 

Reshape Arc
• Click and drag the Reshape Arc edit han-

dle to change the radius of the arc without 
moving its end points. Only available if 
the arc has an unlocked center.

Using Dimensions
Dimensions can be used to move or 
reshape closed polyline-based objects. 

See “Moving Objects Using Dimensions” on 
page 737.

Using the 
Specification Dialog

Closed polyline-based objects can be 
edited using their specification 

dialogs. See “Polyline Specification Dialog” 
on page 791.

Using the Edit Toolbar
A selected closed polyline-based object can 
be edited in a variety of ways using the 
buttons on the edit toolbar. 

The following toolbar buttons may display 
on the edit toolbar for a selected closed 
polyline-based object:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 124.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 31.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 
elsewhere. See “Copying and Pasting 
Objects” on page 114.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 117.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 171.

• Click the Transform/Replicate 

Object  edit button to copy, move, 
rotate, resize, or reflect the selected 
object(s). See “Transform/Replicate 
Object Dialog” on page 166.
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• Click the Accurate Move  edit button 
to slow down the mouse speed when 
using the edit handles. See “Accurate 
Move” on page 153.

• Click the Make Parallel/Perpendicular 

 edit button to make the selected 
straight edge parallel or perpendicular to 
another straight edge by either rotating 
the selected edge or the entire polyline. 
See “Using Make Parallel/Perpendicular” 
on page 155. Not available when the 
selected edge is an arc.

• Click the Point to Point Move  edit 
button to accurately move the selected 
object(s). See “Point to Point Move” on 
page 153. 

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 156.

• Click the Reflect About Object  edit 
button to reflect the selected object(s) 
about another object. See “Reflecting 
Objects” on page 163. 

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 151.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 158.

• Click the Reverse Direction  edit but-
ton to reverse the direction of the selected 
object(s). See “Reverse Direction” on 
page 164.

• Click the Convert Polyline  edit but-
ton to convert the object into a special 
polyline-based object. See “Convert 
Polyline” on page 165.

• Click the Change Line/Arc  edit but-
ton to change a line-based polyline edge 
to an arc, or vice versa. See “Change 
Line/Arc” on page 159.

• Click the Fillet Two Lines  edit but-
ton, then click on an adjacent edge to cre-
ate an arc connecting the two. See “Fillet 
Two Lines” on page 159. Cannot be used 
if the adjacent edge is an arc. 

• Click the Record Walkthrough Along 

Path  edit button to record a walk-
through video of your model along the 
path defined by the selected polyline. See 
“Walkthroughs” on page 819.

• Click the Chamfer Two Lines  edit 
button, then click an edge adjacent to the 
selected edge to chamfer the corner 
between them. See “Chamfer Two Lines” 
on page 160.

Editing Box-Based Objects
Objects are considered box-based when they 
can be edited similar to CAD boxes using 

their edit handles. 
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Box-based objects are similar to closed 
polyline-based objects, but must always have 
four sides with right-angled corners. 

In addition to the CAD Box tools, Text 
objects, many library symbols, pictures and 
images are examples of box-based objects.

Using the Edit Handles
When selected, a box-based object displays 
ten edit handles. Unlike polylines, boxes 
must always have four sides with right-
angled corners.

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

• Click and drag the Move handle to move 
the object according to the currently 

active Edit Behavior . See “Edit 
Behaviors” on page 120. 

• Movement may be limited or stopped by 
other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 153.

• The four Resize handles located at each 
corner are used to increase or decrease 
the size of the object. 

• The four Extend handles display along 
each edge. If you select an object on an 
edge, the Extend handle displays at the 
point where you clicked; otherwise, it 
displays at the center of the edge.

The behavior of the edit handles may
depend on the currently active Edit

Behavior. See “Edit Behaviors” on page 120.

Move

Rotate

Resize
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• The triangular Rotate handle located 
near the selected edge of the object is 
used to rotate it either about its center or 
the current CAD point. The pointer 
changes to a circular arrow  when 
moved over this handle. See “Rotating 
Objects” on page 161.

Using Dimensions
Dimensions can be used to move or 
reshape box-based objects. See 

“Moving Objects Using Dimensions” on 
page 737.

Using the 
Specification Dialog

Box-based objects can be edited using 
their specification dialogs. See “Box 

Specification Dialog” on page 795.

Using the Edit Toolbar
A selected closed polyline-based object can 
be edited in a variety of ways using the 
buttons on the edit toolbar.  

The following toolbar buttons may display 
on the edit toolbar for a selected closed 
polyline-based object:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 124.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 31. 

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 
elsewhere. See “Copying and Pasting 
Objects” on page 114.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 117.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 171.

• Click the Transform/Replicate 

Object  edit button to copy, move, 
rotate, resize, or reflect the selected 
object(s). See “Transform/Replicate 
Object Dialog” on page 166.

• Click the Accurate Move  edit button 
to slow down the mouse speed when 
using the edit handles. See “Accurate 
Move” on page 153.

• Click the Make Parallel/Perpendicular 

 edit button to make the selected 
straight edge parallel or perpendicular to 
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another straight edge. See “Using Make 
Parallel/Perpendicular” on page 155. Not 
available when the selected edge is an 
arc.

• Click the Point to Point Move  edit 
button to accurately move the selected 
object(s). See “Point to Point Move” on 
page 153. 

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 156.

• Click the Reflect About Object  edit 
button to reflect the selected object(s) 
about another object. See “Reflecting 
Objects” on page 163. 

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 151.

• Click the Convert Polyline  edit but-
ton to convert the object into a special 
polyline-based object. See “Convert 
Polyline” on page 165.

Editing Spline Based Objects
Objects are considered spline-based when 
they can be edited similar to CAD splines 
using their edit handles. See “Splines” on 
page 796. 

Sprinkler lines, spline terrain curbs, spline 
terrain walls and both round and kidney-
shaped terrain features are spline-based 
objects. See “Terrain” on page 537.

Using the Edit Handles
When a spline is selected, several different 
types of handles display.

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Click and drag the Move handle to move 

the object according to the currently 

The behavior of the edit handles may
depend on the currently active Edit

Behavior. See “Edit Behaviors” on page 120.
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active Edit Behavior . See “Edit 
Behaviors” on page 120. 

• Movement may be limited or stopped by 
other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 153.

Rotate
• Click and drag the Rotate edit handle to 

rotate the entire spline. 

Reshape
• The Reshape edit handles display along 

the spline at each vertex. Click and drag a 
Reshape edit handle to change the length, 
angle and curve of adjacent segments 
without affecting other reshape handles. 

Resize
• The Resize edit handles display along the 

spline, between each vertex. Click and 
drag a Resize edit handle to move the 
adjacent vertices and lengthen or shorten 
adjacent segments.

Using the 
Specification Dialog

Spline-based objects can be edited 
using their specification dialogs. See 

“Polyline Specification Dialog” on page 791.

Using the Edit Toolbar
A selected spline-based object can be edited 
in a variety of ways using the buttons on the 
edit toolbar.  

The following toolbar buttons may display 
on the edit toolbar for a selected spline-based 
object:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 124.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Polyline 
Specification Dialog” on page 791.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 
elsewhere. See “Copying and Pasting 
Objects” on page 114.
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• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 117.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 171.

• Click the Transform/Replicate 

Object  edit button to copy, move, 
rotate, resize, or reflect the selected 
object(s). See “Transform/Replicate 
Object Dialog” on page 166.

• Click the Accurate Move  edit button 
to slow down the mouse speed when 
using the edit handles. See “Accurate 
Move” on page 153.

• Click the Make Parallel/Perpendicular 

 edit button to make the selected 
spline edge parallel or perpendicular to 
another straight edge. See “Using Make 
Parallel/Perpendicular” on page 155. 

• Click the Point to Point Move  edit 
button to accurately move the selected 
object(s). See “Point to Point Move” on 
page 153. 

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 156.

• Click the Reflect About Object  edit 
button to reflect the selected object(s) 
about another object. See “Reflecting 
Objects” on page 163. 

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 151.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 158.

• Click the Convert Polyline  edit but-
ton to convert the object into a special 
polyline-based object. See “Convert 
Polyline” on page 165.

• Click the Record Walkthrough Along 

Path  edit button to record a walk-
through video of your model along the 
path defined by the selected polyline. See 
“Walkthroughs” on page 819. 

Editing Circles, Ovals and Ellipses
Objects created using the Circle Tools 
are unusual in that no architectural 

objects share their functionalities.

Using the Edit Handles
When selected, circles, ovals and ellipses 
display eleven edit handles. 
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Unlike Ovals  and Ellipses , a Circle 

 cannot be edited into any other shapes;  it 
can only be a circle.

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Click and drag the Move handle to move 

the object according to the currently 

active Edit Behavior . See “Edit 
Behaviors” on page 120. 

• Movement may be limited or stopped by 
other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 153.

Rotate
• Click and drag the Rotate handle of an 

oval or ellipse to change its orientation.

Reshape
• The eight edit handles beyond the perim-

eter are Reshape edit handles. Move them 
in or out to resize and reshape an oval or 
ellipse.

• Unlike ovals and ellipses, circles cannot 
be reshaped.  When a Reshape handle is 
dragged on a circle, it is only resized.

Concentric Resize
• The Concentric Resize edit handle dis-

plays on the perimeter of a circle between 
a corner Reshape handle and the center.  
Click and drag this handle to resize the 
circle without moving its center point. 

The behavior of the edit handles may
depend on the currently active Edit

Behavior. See “Edit Behaviors” on page 120.

Move

Concentric 
Resize

Rotate

Reshape
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Using Dimensions
Dimensions can be used to move or 
resize circle-based objects. See 

“Moving Objects Using Dimensions” on 
page 737.

Using the 
Specification Dialog

Circles, ovals and ellipses can be 
edited using their specification 

dialogs. See “CAD Circle/Oval/Ellipse 
Specification Dialog” on page 789.

Using the Edit Toolbar
A selected circle, oval or ellipse can be 
edited in a variety of ways using the buttons 
on the edit toolbar.  

The following toolbar buttons may display 
on the edit toolbar for a selected circle, oval 
or ellipse:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 124.

• Click the Open Object  edit button to 
open the specification dialog for the 

selected object(s). See “Specification 
Dialogs” on page 31.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 
elsewhere. See “Copying and Pasting 
Objects” on page 114.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 117.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 171.

• Click the Transform/Replicate 

Object  edit button to copy, move, 
rotate, resize, or reflect the selected 
object(s). See “Transform/Replicate 
Object Dialog” on page 166.

• Click the Accurate Move  edit button 
to slow down the mouse speed when 
using the edit handles. See “Accurate 
Move” on page 153.

• Click the Make Parallel/Perpendicular 

 edit button to make the selected edge 
parallel or perpendicular to another 
straight edge. See “Using Make Parallel/
Perpendicular” on page 155. 

• Click the Point to Point Move  edit 
button to accurately move the selected 
object(s). See “Point to Point Move” on 
page 153. 

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
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fixture. See “Using Center Object” on 
page 156.

• Click the Reflect About Object  edit 
button to reflect the selected object(s) 
about another object. See “Reflecting 
Objects” on page 163. 

• Click the Move to Front of Group  
edit button to display the selected object 

in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 151.

• Click the Convert Polyline  edit but-
ton to convert the object into a special 
polyline-based object. See “Convert 
Polyline” on page 165.

Displaying Objects
The display of objects in 2D and 3D views 
can be controlled by layer. See “Displaying 
Objects” on page 102.

Text, Line and Fill Styles
In addition to text-based objects, a variety of 
objects can display text as part of their line 
style or label. The appearance of this text can 
be controlled by layer. See “Line and Text 
Styles” on page 102. 

Line style, weight and color can be 
controlled by layer or overridden in the 
specification dialogs for many objects. See 
“Line Style Tab” on page 781. 

You can also toggle the on screen display of 
line weights on and off. See “Show Line 
Weights” on page 845.

In addition, many objects have a fill style 
that can be specified in the objects’ 
specification dialogs. See “Fill Style Tab” on 
page 792.

Color On/Off
The display of color on-screen can be 
toggled on and off in all views except 

perspective views by selecting Tools> 
Display Settings> Color On/Off. 

You can set defaults to specify whether cross 
section/elevations, camera views and 
overviews using the Orthographic rendering 
technique are generated with colors turned in 
the 3D View Defaults dialog. See “Options 
Tab” on page 669.

The display of colors may or may not make a 
view easier to understand. Experiment to see 
what works for you, then set your default in 
the 3D View Defaults dialog for each view.

Colors are used in Orthographic Views to 
represent different materials. The colors can 
be printed if you have a color printer, or can 
appear as shades of gray on a black and white 
printer. If you have assigned a picture file to 
represent the texture of a material in 
perspective views, the program can sample 
that picture file and define an approximate 
color to use in all Orthographic views. See 
“Define Material Dialog” on page 643. 
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To display views in gray scale

1. Select Tools> Display Settings> Color 

Off  to toggle color off.

2. Select Edit> Preferences  to open 
the Preferences dialog. 

3. On the Appearance panel, check Obey 
Color On/Off Setting. See “Appear-
ance Panel” on page 61.

To display views in black and white

1. Select Tools> Display Settings> Color 

Off  to toggle color off.

2. Select Edit> Preferences  to open 
the Preferences dialog. 

3. On the Appearance panel, uncheck 
Obey Color On/Off Setting. 

When color is toggled off and Obey Color 
On/Off Setting is unchecked, all lines 
appear in black and solid fills appear in either 
white or black, depending on which is closer 
to the actual line or fill color when color is 
turned on. The background remains as 
defined in the Preferences dialog. See 
“Colors Panel” on page 63.

You can also print in color, black and white, 
or gray scale. See “Print Dialog” on page 
855.

Arc Centers and Ends
The display of arc center- and 
endpoints, and the display of circle 

center points can be enabled by clicking the 
Show Arc Centers and Ends toggle button 
or in the CAD Defaults dialog. See “CAD 
Defaults Dialog” on page 770. 

Drawing Groups
Each object in a plan or layout file belongs to 
one of three drawing groups, which 
influences whether it displays in front of or 
behind other objects. 
• The Default Group is where most 

objects are placed when first created. 
• Objects moved to the Back Group dis-

play behind those in the other two draw-
ing groups.

• Objects moved to the Front Group dis-
play in front of those in the other two 
drawing groups. 

Most objects are drawn in the Default Group. 
Notable exceptions are imported pictures, 
which are placed in the Back Group, and 
Walkthrough Paths, which are placed in the 
Front Group. Objects in the Default Group 
display in front or behind one another 
according to program-defined rules that can 
be modified in only limited ways.

Once most CAD or CAD-based objects are 
created, though,  you can control how they 
display relative to other objects using their 
specification dialog. See “Line Style Tab” on 
page 781.

For example, you can move an object to the 
Back Group or Front Group so that it 
displays behind or in front of objects in the 
other drawing groups.

You can also check Move to Front of Group 
or use the edit button of the same name to 
display the object in front of other objects in 
its drawing group, but not necessarily in 
front of objects in other groups.  
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Move to Front of Group
Click the Move to Front of Group 
edit button to move the selected 

object(s) so that it displays in front of other 
objects in the same drawing group. Move to 
Front of Group functions like the checkbox 
of the same name in the object’s specification 
dialog.

An object moved to the front of the Default 
Group, for example, will display in front of 
objects in that group and those in the Back 
Group, but will still display behind objects in 
the Front Group. 

Move to Front of Group  only affects 
the display of objects in the Default Group 
when they are of the same type: for example, 
CAD objects, furnishings, base cabinets, or 
wall cabinets. It cannot make a base cabinet 
display in front of a wall cabinet; but it can 
make a selected wall cabinet display in front 
of other wall cabinets. 

Move to Front of Group  is useful for 
creating a sense of depth or to improve a 
drawing’s clarity. For example, in a cross 
section detail, you can move a CAD circle 
representing rebar to the front of a wall with 

a concrete fill pattern so that the rebar is not 
masked by the wall’s fill pattern. 

Move to Front of Group  is not available 
for Walkthrough Paths.  

Patterns and Textures
The appearance of architectural objects in 3D 
views is affected by the materials applied to 
the objects’ surfaces. See “Materials” on 
page 631. 

Material patterns display in Technical 
Illustration and Vector Views, while textures 
display in Standard rendered views. See 
“Rendering Techniques” on page 710. 

In 3DStandard rendered views that use 
textures, you can turn on or off the display of 
textures by selecting 3D> Toggle 

Textures . 

Delete Surface
In any 3D view, select 3D> Delete 
Surface, then click a surface in the 

view to temporarily remove the surface from 
the current view. See “Delete 3D Surface” on 
page 679.

Refresh Display
Refresh Display redraws the current 
window to clean up extra lines, show 

missing items, and correct random on-screen 
effects caused by changes to a model. Select 
Tools> Display Settings> Refresh Display 
or press the F5 key to refresh the on-screen 
display. 



152

Home Designer Pro 2014 Reference Manual

Moving Objects
Objects can be moved using the edit handles 
as well as a variety of edit tools. Multiple 
selected objects can also be moved as a 
group. See “Selecting Objects” on page 124.

Using the Edit Handles
Select an object, then click the Move edit 
handle and drag it to a new location. When 
your pointer is over the Move handle, it 
displays a four-headed arrow. 

As an object is moved, it jumps at set 

increments when Grid Snaps  are 
enabled. See “Grid Snaps” on page 112.

When Object Snaps  are enabled, a 
selected object snaps to its original location 
if it passes over that location while being 
moved.

The behavior of the Move edit handle varies 
depending on the currently active Edit 

Behavior . See “Edit Behaviors” on page 
120.  

• If the Default , Resize , Concen-

tric  or Fillet  edit behavior is 
active, the object moves orthogonal, or at 
a right angle to, any of its edges.

• If the Alternate  edit behavior is 
active, the selected object(s) can be 
moved at Allowed Angles if Angle 

Snaps  are enabled, or orthogonal to 
any of its edges if they are not. See 
“Alternate” on page 121.

You can temporarily slow the movement of 
your mouse as you drag an edit handle by  
holding down the Shift key on your 
keyboard.

Bumping/Pushing
When Edit> Snap Settings> 
Bumping/Pushing is enabled, CAD 

and CAD-based objects with CAD Stops 
Move and/or Wall Stops Move enabled, as 
well as architectural objects, bump into and 
can push one another as they are moved. See 
“Line Style Tab” on page 781. 

When an object bumps into another similar 
object while it is being moved, it stops. 
Continue dragging and the selected item  
resumes movement through the obstructing 
object. The Maximum Bump Distance, or 
the distance you must drag to override 
bumping, is set in the Preferences dialog. 
See “Snap Properties Panel” on page 79. 

Bumping/Pushing  also affects objects 
when they are moved using dimensions.  See 
“Moving Objects Using Dimensions” on 
page 737.  

Walls, wall openings, cabinets, furnishings 
and fixtures, and CAD and CAD-based 
objects are examples of objects that can push 
other objects of these same types once they 
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have bumped into them. Instead of dragging 
through the obstructing object(s), release the 
mouse button and then click and drag the 
Move edit handle a second time in the same 
direction to push. 

Certain types of objects, notably roof planes, 
and objects on locked layers can be bumped 
but cannot be pushed. See “Layer Display 
Options Dialog” on page 104. 

CAD Stops Move/
Wall Stops Move

CAD and CAD-based objects can be set to 
stop at other CAD objects and/or at walls as 
they are being moved. See “Line Style Tab” 
on page 781.

Some objects, such as cross boxes, framing 
members and insulation, are automatically 
set to stop when moved against other CAD 
objects. 

CAD Stops Move and Wall Stops Move do 

not function if Bumping/Pushing  is 
turned off.

Unrestricted Movement
Many objects have restrictions placed on 
their movement by their own properties or 
specification settings. Architectural objects, 
for example, bump into other 3D objects as 
they are being moved when Bumping/

Pushing  is enabled. 

CAD-based objects may be set to stop at 
other CAD objects or at walls. See “Line 
Style Tab” on page 781.

Other move restrictions are activated by the 

Snap Settings . See “Snap Behaviors” on 
page 109.

These restrictions can be overridden when 
necessary by holding down the Ctrl key 
while dragging to move an object.

To move an object freely 

1. Select the object. 
2. Hold down the Ctrl key.
3. Click  the Move edit handle and drag it 

to the new location.

You can also press the Ctrl key while 
dragging an object’s Move handle to override 
move restrictions. 

Accurate Move
Click the Accurate Move edit button, 
then move the selected object(s) at a 

slower speed than normal for greater 
precision. Accurate Move can also be used 
to resize, reshape or rotate objects.

Accurate Move  is not a toggle button: it 
only affects the speed of the mouse during 
the next edit. The next time you want to use 
this edit tool, you need to click it again.

You can also slow down the movement speed 
of a selection after you have started moving 
it by pressing the Shift key. Release the Shift 
key to resume movement at normal speed. 

Point to Point Move
The Point to Point Move edit button 
allows a selected object or group of 

objects to be accurately moved. 
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To use Point to Point Move

1. Select one or more objects that you 
would like to move, then click the Point 

to Point Move  edit button.
2. Click a point that you want to accurately 

reposition.
3. Click the point in the plan where you 

would like the selected point to be relo-
cated when it is moved.

4. The selected object(s) are moved so that 
they maintain their position relative to 
the point. 

Point to Point Move  can be used with 

the Copy/Paste  edit button. See “To 
point to point copy” on page 118.

Point to Point Move  can also be used 

with the Edit Area  tools. See “Edit Area 
Tools” on page 168.

Center Object
The Center Object edit button allows 
you to move walls, cabinets and other 

objects so that they are centered along a wall 
within a room or relative to a window or 
cabinet. 

Move to Framing Reference
Framing members can be positioned 
relative to a Framing Reference using 

the Move to Framing Reference edit tool. 
See “Framing Reference Marker” on page 
442.

Using Dimensions
Objects or the selected edges of some 
objects can be moved using 

dimensions. See “Moving Objects Using 
Dimensions” on page 737.

Using the Transform/
Replicate Object Dialog
Objects and groups of objects can be 
moved relative to themselves or an 

absolute location using the Transform 
Replicate Object dialog. See “Transform/
Replicate Object Dialog” on page 166.

Aligning Objects
It is often important to align objects such as 
text boxes, roof plane edges or walls, or to 
align objects on different floors. There are 
several methods to choose from. 

Using the Mouse 
Cross Hairs

Objects can be aligned by eye using the 
mouse cross hairs as a reference. This 

method can help you draw, place and edit 
objects quickly and with reasonable 
accuracy, but is not necessarily as accurate as 
some of the other approaches described here.

The mouse cross hairs can be turned on and 
off in the Preferences dialog. See “Edit 
Panel” on page 76.
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Using Snap Settings

With Object Snaps  on, you can snap the 
edge of a selected object to that of another. 
Select an edge of an object. Drag it to the 
edge of another object to reveal an Object 
Snap point, then release the mouse.

With Grid Snaps  on and Angle 

Snaps  off, select the left side of the 
object, and drag from the center move 
handle. This snaps the selected side to the 
grid.

When both Grid Snaps  and Angle 

Snaps  on, objects snap at increments 
equal to the Snap unit specified in the Plan 
Defaults dialog rather than onto the grid 
itself. This does not align objects to the grid 
unless they were already snapped to the grid. 
See “Snap Behaviors” on page 109. 

Using Dimensions
Create a temporary or manual 
dimension relative to an object such as 

a wall or line, and relocate the objects to the 
same dimension. See “Moving Objects 
Using Dimensions” on page 737. 

CAD Stops Move/
Wall Stops Move

CAD and CAD-based objects can be aligned 
using another CAD object or a wall as a 
guide. Check the CAD Stops Move and/or 

Wall Stops Move boxes in the objects’ 
specification dialogs, then move them until 
they bump into the CAD object or wall that 
you wish to use as a guide for alignment. See 
“Line Style Tab” on page 781.

Using Make Parallel/
Perpendicular

The Make Parallel/Perpendicular 
edit button allows you to make a 

selected object parallel or perpendicular to 
any straight edge. 

If you select an edge of a polyline-based 
object, adjacent edges extend or contract to 
maintain contact, but other edges are remain 
unchanged. The selected edge rotates about 
its endpoint if selected near the end, or about 
its center if you click within its middle third. 

To use Make Parallel/Perpendicular

1. Select an object such as a roof plane on 
the edge that you would like to make 
parallel or perpendicular to another 
object.

•  Click near the center of the edge to 
rotate it about the center.

•  Click near an end to rotate the edge 
about that end.

2. Click the Make Parallel/

Perpendicular  edit button
3. Click on a straight edge such as a wall.
4. If the first object is within 45° of parallel 

to the second object, it is made parallel. 
Otherwise, it is made perpendicular to 
the second object. 

Text objects can be aligned using set-
tings in the Text Specification dialog.

See “Aligning Text” on page 756.
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You can also make the selected edge parallel 
by rotating the entire object. See “Make 
Parallel/Perpendicular with Polyline Based 
Objects” on page 162.

Using Center Object
The Center Object edit button can be 
used to center a variety of objects 

relative to another object. 

To center an object 

1. Select an object.

2. Click the Center Object  edit button.
3. Move the mouse pointer over the object 

you would like to center the selected 
object relative to.

•  As the pointer passes over an eligible 
object, it becomes highlighted and a 
dashed centering axis line displays.

4. When the desired centering axis dis-
plays, click once to center the selected 
object along that axis line.

To center an object in a room

1. Select an object such a cabinet.

2. Click the Center Object  edit button.
3. Move the mouse pointer in the room that 

you would like to center the selected 
object relative to.

•  As you move the pointer, a centering 
axis will display along the wall it is 
closest to.

•  The selected object does not have to be 
inside a room in order to be centered 
relative to that room.

4. When a centering axis displays along the 
correct wall, click once. 

5. The object is moved perpendicular to the 
centering axis. 

If you click outside an exterior wall instead 
of clicking inside, the selected object is 
centered along the edge of the Exterior 
Room. See “The Exterior Room” on page 
232. 

Aligning Arc Centers
The center points of circles and arc-based 
objects can be aligned, even if the objects are 
on different floors, when the Reference 
Display is turned on and Show Arc Centers 

and Ends  is enabled. See “The 
Reference Floor” on page 327 and “CAD 
Defaults Dialog” on page 770.

To align center points easily, it is helpful to 

turn on Object Snaps  and turn off Angle 

Snaps . See “Object Snaps” on page 110 
and “Angle Snaps” on page 111.

Select edge

Click button

Click 

Result

wall
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Aligning Objects on 
Different Floors

Objects on different floors can be aligned 

with one another using Object Snaps  

and the Reference Display . See “Object 
Snaps” on page 110 and “The Reference 
Floor” on page 327.

Resizing Objects
Objects can be resized using the edit handles, 
specification dialogs, and the Transform/
Replicate Object dialog. 

Using the Edit Handles
Depending on the currently active Edit 

Behavior , the end, corner and/or side 
edit handles can be used to resize a selected 
object. See “Edit Behaviors” on page 120.

When the Concentric  edit behavior is 
active, dragging an object’s corner or end 
handle  resizes it according to the 
Concentric Jump value set in the 
Preferences dialog. See “Concentric” on 
page 122.

Objects can be resized about either their 
center points or the current CAD point. See 
“Behaviors Panel” on page 78.

To override any movement restrictions 
caused by snap settings or the presence of 
other objects, press the Ctrl key while 
dragging an edit handle.

As an object is resized, any dimensions 
indicating its size will update to reflect yoru 
changes. You can use dimensions as 
references to help you achieve the correct 
size for most objects. 

You can temporarily slow the movement of 
your mouse as you drag an edit handle by  

holding down the Shift key on your 
keyboard.

Using the 
Specification Dialog

Most objects can be accurately resized 
in their specification dialogs. See 

“Specification Dialogs” on page 31. 

Using Dimensions
Many objects can be resized by 
selecting an edge and then moving 

that edge using dimensions. See “Moving 
Objects Using Dimensions” on page 737.

Walls can also be resized using dimensions; 
however, it is important to understand that 
the selected edges of other objects cannot be 
resized using dimensions - they can only be 
moved. To resize an edge, select an adjacent 
edge and move that edge instead.

Using the Transform/
Replicate Object Dialog
Most objects can be resized about 
either their centers or an absolute 

point using the Transform Replicate Object 
dialog. See “Transform/Replicate Object 
Dialog” on page 166.



158

Home Designer Pro 2014 Reference Manual

Reshaping Objects
There is a variety of ways to reshape objects 
using the edit handles, specification dialogs 
and edit toolbar buttons.

Some objects, notably circles and box-based 
objects, cannot be reshaped - only resized. 
See “Resizing Objects” on page 157.

Using the Edit Handles

Depending on the Edit Behavior  in use, 
the end, corner and/or side edit handles can 
be used to reshape a selected object. See 
“Edit Behaviors” on page 120.

When a line-based, arc-based, or open-
polyline based object is selected, you can 
right-click and drag an end handle to change 
a line into an arc or vice versa. This behavior 
does not apply to closed polylines.

To override any movement restrictions 
caused by snap settings or the presence of 
other objects, press the Ctrl key while 
dragging an edit handle.

You can temporarily slow the movement of 
your mouse as you drag an edit handle by  
holding down the Shift key on your 
keyboard.

Using the 
Specification Dialog

A variety of CAD and CAD-based 
objects can be reshaped by editing 

values on either the Selected Line or Selected 
Arc tab of their specification dialogs. See 
“Polyline Specification Dialog” on page 791.

Using Dimensions
Both temporary and manually drawn 
dimensions can be used to increase or 

decrease the distance between the edge a 
line- or polyline-based object and another, 
parallel edge or line. 

Angular Dimensions  can be used to 
adjust the angle where two polyline segments 
meet. See “Using Angular Dimensions” on 
page 162.

Break Line
The Break Line edit button can be 
used to break an individual line-, arc-, 

or spline-based object into two segments. 
The edges of a polyline-based object can also 
be broken.

The Break Line  edit tool can be used to 
create two types of breaks: partial breaks and 
complete breaks.

When a partial break is created, a new corner 
edit handle is placed at the location of the 
break. Partial breaks are also referred to as 
joints, nodes or pivot points.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. 

Note: The Break Line edit button is not avail-
able for box-based objects, objects created
with the Circle Tools, North Pointers, Sun
Angles, Joist Direction Lines, or some archi-
tectural objects such as stairs and trusses.
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To create a partial break

1. Click the object or edge that you want to 
break into two segments.

2. Click the Break Line  edit button 
once or press the 3 key. 

3. Click the edge to create a new corner 
edit handle at that location and two sepa-
rate edges on either side of that handle. 

If you click and drag one of the edit handles 
on either side of the partial break, the edge 
moves at a right angle to itself and another 
edge forms, connecting the moved edge with 
the one on the other side that does not move.

You can remove an edge from a polyline-
based object by clicking and dragging a 
corner handle until it snaps to an adjacent 
corner handle.

When a complete break is created, the object 
or edge is totally severed at that point. 

With the exception of framing members, 
complete breaks cannot be created on CAD-
based architectural objects. In the case of 
framing members, only complete breaks can 
be created.

To create a complete break

1. Click the object or edge that you want to 
break into two segments.

2. Double-click the Break Line  edit 
button. 

3. Click the edge to create a complete 
break at that location. 

You can now click either side of the location 
of the break and move the selected object or 
edge completely independent of the object or 
edge on the other side of the break.

When Object Snaps  are enabled, breaks 
can be placed at snap locations such as 
midpoints. See “Object Snaps” on page 110.

If you place a complete break at a polyline 
corner, the adjacent polyline edges become 
disconnected. 

Change Line/Arc
Select an individual line-based or arc-
based object or a segment of a 

polyline-based object and click the Change 
Line/Arc edit button to convert the selected 
segement from a line to an arc or vice versa.

Make Parallel/Perpendicular
The Make Parallel edit button can be 
used to reshape a polyline by making 

a selected edge parallel or perpendicular to 
another straight edge. See “Using Make 
Parallel/Perpendicular” on page 155. 

Fillet Two Lines
The Fillet Two Lines edit tool allows 
you to connect two non-parallel line-

based objects using an arc of a specified 
radius. If the two lines are already connected, 
this arc is inserted between them. 

If the two objects are not connected and one 
of them is an arc, both objects will extend or 
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contract as needed to become connected. No 
additional arc is created.

The Fillet Two Lines  edit tool is 
available for a selected roof or ceiling plane; 
however, it cannot be used to create an arc at 
a corner. Instead, it can only be used to 
remove edges.

To use Fillet Two Lines

1. Click on a line or polyline segment that 
you would like to connect to another line 
or segment with a filleted corner.

2. Double-click the Fillet Two Lines  
edit button to open the Fillet/Chamfer 
dialog.

3. Specify the desired Fillet Radius and 
click OK.

4. Click on the line or polyline segment 
that you want the selected line to con-
nect to with a fillet.

5. Continue filleting two lines by clicking 
on one line, clicking the Fillet Two 

Lines  edit button, then clicking on 
the second line. The same Fillet Radius 
is used until you open the Fillet/
Chamfer dialog again and change it.

Once two lines are filleted, the arc between 
them can be edited. See “Editing Arc Based 
Objects” on page 130.

The Fillet Two Lines  edit tool can also 
be used to join non-adjacent edges of an open 
or closed polyline as long as those edges are 
not parallel. In doing so, the edges will 
lengthen or shorten and polyline edges may 
be removed.

To remove polyline edges 

1. Click on a polyline edge that you would 
like to connect to another edge.

2. Click the Fillet Two Lines  edit but-
ton.

3. Click on a non-adjacent edge of the 
same polyline. The edges will lengthen 
or shorten as necessary to join together.

Chamfer Two Lines
The Chamfer Two Lines edit tool 
allows you to create a straight corner 

bevel of a specified size connecting any two 
non-parallel lines. It can also be used to 
extend an arc so that it joins to another arc.

The Chamfer Two Lines  edit tool is 
used much the way as the Fillet Two 

Lines  edit tool. First, set the Chamfer 
Distance in the Fillet/Chamfer dialog, then 
select a line, click the button and click a sec-
ond line to chamfer the two. 

Deleting Intervening Lines

Fillet Two Lines  and Chamfer Two 

Lines  can also be used to eliminate parts 
of a polyline. To use, fillet or chamfer two 
non-adjacent lines that are in the same closed 
polyline.
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A dialog warns you that lines will be deleted 
if you proceed. Click OK to approve the 
polyline edit and see the changes occur.

Close Polyline
An open polyline-based object can be 
converted into a closed polyline using 

the Close Polyline edit tool. See “Using 
Close Polyline” on page 138. 

Rotating Objects
Objects can be rotated using the edit handles 
as well as a variety of edit tools. Multiple 
selected objects can also be rotated as a 
group. See “Selecting Objects” on page 124. 

By default, an object or group of objects  
rotate about the center point of the selection 
set. You can instead specify that objects 
rotate about the current CAD point.  See 
“The Current Point” on page 774.

Using the Edit Handles
Select an object, then click the triangular 
Rotate edit handle and drag it in any 
direction. When your pointer is over the 
Rotate handle, it displays a curved arrow.

The angles of line-based objects can also be 
changed by dragging an end handle in a 
direction other than parallel to the object. 
The object rotates about the opposite end 
point. See “Editing Line Based Objects” on 
page 127.

When Angle Snaps  are enabled, objects 
snap to Allowed Angles as specified in the 
Plan Defaults dialog as they are rotated. See 
“Angle Snaps” on page 111. 

To override any movement restrictions 
caused by snap settings or the presence of 
other objects, press the Ctrl key while 
dragging an edit handle.

You can temporarily slow the movement of 
your mouse as you drag an edit handle by  
holding down the Shift key on your 
keyboard.

Using the 
Specification Dialog

The exact angle of some objects such 
as lines, arcs, walls and the selected 

edges of polylines can be specified on either 
the General tab, Selected Line tab, or 
Selected Arc tab of that object’s specification 
dialog. See “Polyline Specification Dialog” 
on page 791.

Rotate/Resize About
Objects can be rotated or resized 
about either their own centers or the 

current CAD point. See “The Current Point” 
on page 774. 
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You can specify which behavior is used by 
selecting Edit> Edit Behaviors> Rotate/

Resize About Current Point . When this 
option is selected, objects rotate about the 
current CAD point; when it is not selected, 
object rotate about their centers. 

The Rotate/Resize About behavior can also 
be specified in the Preferences dialog. See 
“Behaviors Panel” on page 78. 

Using Angular Dimensions
Angular Dimensions are useful for 
adjusting the angles of a variety of 

objects with straight edges. See “Angular 
Dimensions” on page 729. 

To change an angular dimension

1. Draw an Angular Dimension  
between the objects you want to move.

•  Begin and end as close as possible to 
the two objects you wish to locate.

2. Select the edge that you want to move.
3. Click the dimension value to open the 

Set Angular Dimension dialog.
•  The Previous Value is indicated 

degrees, minutes and seconds. 

4. Enter a value in the New Value field.
5. Select Rotate Edge to move the selected 

edge when OK is clicked or select 
Rotate entire polyline to rotate the 
entire object the selected edge is a part 
of, maintaining the Previous Value of the 
angle.

6. Click OK to apply the change.

When an entire polyline is rotated using the 
Set Angular Dimension dialog, it rotates 
around the vertex of the angle. 

Make Parallel/Perpendicular 
with Polyline Based Objects

The Make Parallel/Perpendicular 
edit button usually adjusts the angle of 

a selected polyline edge. See “Using Make 
Parallel/Perpendicular” on page 155. 

To rotate the entire polyline instead, double-

click the Make Parallel  edit button to 
open the Make Parallel dialog.



Reflecting Objects

 163

Choose to either Rotate only selected edge, 
as before, or to Rotate entire polyline. Your 
setting remains until you access the Make 
Parallel dialog again and change it. 

Polylines rotate according to the current 
Rotate/Resize About setting. See 
“Behaviors Panel” on page 78.

Using the Transform/
Replicate Object Dialog
Objects and groups of objects can be 
rotated to a relative or absolute angle 

using the Transform Replicate Object 
dialog. See “Transform/Replicate Object 
Dialog” on page 166.

Rotate Plan View
To rotate everything in floor plan 
view, including all objects on all 

floors, the Snap and Reference Grids, the 
plan’s Cartesian coordinates, and the 

drawing sheet, select Tools> Rotate Plan 
View to open the Rotate Plan View dialog. 

Enter the degrees to rotate the floor plan 
view to using decimal units with either 
positive or negative values. 

The degrees rotated displays in ±180º format. 
For example, if you enter 270º, it displays as 
-90º when the dialog is reopened.

Rotate Plan View  rotates a plan relative 
to its original orientation. For example, 
entering 90º twice results in a rotation of 90º, 
not 180º.

Text objects rotate with the plan unless you 
uncheck Rotate with plan in the Text 
Specification dialog for each object. See 
“Rich Text Specification Dialog” on page 
747.

Reflecting Objects
There are several ways to reflect an object, 
group of objects, or an entire plan about an 
axis or another object. Either the original 
object(s) or copies of the original(s) can be 
reflected. 

Reflect About Object
A selected object or objects can be 
reflected about another object, 

regardless of its angle, using the Reflect 
About Object edit tool. 

The Rotate Plan View tool does not
rotate objects; it literally rotates your

view of those objects. As a result, it does not
alter the orientation of the plan in layout views
or on the printed page. 
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Line-based objects are often used for 
reflecting a selection, but most objects have 
an axis that can be used.  
• When an open or closed polyline-based 

object is used as the reflective object, the 
edge that is clicked on acts as the axis.

• When a circle or box-based object such 
as a CAD box or cabinet is used as the 
reflective object, the axis runs down the 
center of the object from back to front.

• In 3D views, architectural objects can 
only be reflected about a vertical axis - 
not a horizontal axis.

To use Reflect About Object

1. Draw a CAD line to act as the reflection 
line. 

2. Select the object(s) to be reflected. 

3. Click the Reflect About Object  edit 
button.

4.  Click the CAD line to reflect the selec-
tion about the line. 

5. The selection is reflected around the 
CAD line, and the original is no longer 
there. 

To retain a copy of the selected object(s) in 
the original location, click the Copy/

Paste  edit button before clicking the 

Reflect About Object  button.

Using the Transform/
Replicate Object Dialog
Objects and groups of objects can also 
be reflected horizontally or vertically 

using the Transform Replicate Object 
dialog. See “Transform/Replicate Object 
Dialog” on page 166.

Reverse Plan
The Reverse Plan tool is a quick way 
to mirror a plan so that everything on 

all floors of the entire plan is swapped left to 
right. 

Select Tools> Reverse Plan  to reflect an 
entire plan right to left, as though it were 
reflected about a vertical line. 

Reversing a plan rebuilds the entire model 
and affects views sent to layout. 

Reverse Direction
Select a line-based, arc-based or 
polyline-based object and click the 

Reverse Direction edit button to reverse its 
direction. Not available for Terrain Path 
objects.

Reversing a line or polyline is useful with 
certain line styles or with an arrow at one 
end.

Converting Objects
CAD objects and many CAD-based objects 
can be converted into a variety of other types 
of objects.

CAD to Walls
CAD to Walls allows you to convert a 
2D line drawing into a 3D model. 
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Double CAD lines and arcs drawn to 
represent wall layers and other structural 
items can be converted to actual Home 
Designer Pro walls, railings, windows, or 
doors. See “CAD to Walls” on page 208.

Convert Polyline
The Convert Polyline edit button lets 
you to turn CAD objects into CAD-

based architectural objects such as counter 
tops and stair landings, special polylines 
such as materials list polylines, and a variety 
of slab, hole and terrain objects.

To convert a CAD object into one of these 
3D objects, select the object and click the 

Convert Polyline  edit button to open the 
Convert Polyline dialog.

Convert Polyline Dialog

Click the radio button beside one of the 
objects in this dialog, then click OK. 

Countertop - Convert the selected closed 
polyline to a countertop. See “Custom 
Countertops” on page 510.

Slab - Convert the selected closed polyline to 
a slab. See “The Slab Tools” on page 341.

Slab with Footing - Convert the selected 
closed polyline to a slab with footing.  

Landing - Convert the selected closed 
polyline to a landing. Only available when 
the closed polyline is not a spline. See 
“Landings” on page 406.

Walkthrough Path - Convert the selected 
polyline to a Walkthrough Path. See 
“Walkthroughs” on page 819. 

Sprinkler Line - Convert to a sprinkler line. 
See “Sprinkler Tools” on page 580.

Terrain Perimeter - Convert to the terrain 
permeter. See “Terrain Perimeter” on page 
538. This option is only available when: 
• The polyline is closed
• A terrain perimeter does not yet exist 
• Only one polyline is currently selected

Elevation Line - Convert to an elevation 
line. See “Elevation Lines” on page 542. 
Only available when a terrain perimeter 
exists.

Terrain Break - Convert to a terrain Break. 
See “Terrain Breaks” on page 544.

Terrain Feature - Convert to a terrain 
feature. See “Terrain Feature Tools” on page 
546. Only available when a terrain perimeter 
exists.

Click OK to convert the object or objects.
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The specification dialog appropriate to the 
newly converted object opens, allowing you 
to specify its height, material and other 
information.

Convert to Plain Polyline
Click the Convert to Plain Polyline 
edit button to convert special 

polylines to plain polylines. 

After a special polyline is converted into a 
plain polyline, it can be converted into a 
special of the same or different type.

Transform/Replicate Object Dialog
Select any object or group of objects 
and click the Transform/Replicate 

Object edit button to open the Transform/
Replicate Object dialog.

If multiple options are selected in the 
Transform/Replicate Object dialog, they are 
performed in the order they appear in the 
dialog, from top to bottom.

Always double-check values entered in
the Transform/Replicate Object dialog.

Large offset values, resize factors, or num-
bers of copies can result in objects that are
time-consuming to create or may be off the
screen. 
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Transform/Replicate Object Dialog

Check Copies, then specify the 
Number of Copies to make.

Check Move, then specify how far or 
where to move the object(s).

• Select Relative to Itself  to move the 
object relative to its current position, then 
specify the X Delta, Y Delta and Z Delta 
values, which are the object’s changes in 
position along each axis. 

• Select Absolute Location to move the 
object to an absolute location. You can 
either specify its X and Y Position, or 
Angle and Distance, if Polar is checked.

• Select Relative to Current Point to 
move the object relative to the current 
CAD point. See “Point Tools” on page 
772. You can either specify its X Delta 
and Y Delta, or Angle and Distance, if 
Polar is checked.

Rotate - Select this option, then specify 
the Angle to rotate the object(s). 

1

2

3

4

5

6

1

2

When a CAD-based object is moved to
a new floor, only its display in floor plan

view is moved - its physical locations in the
model remains unchanged. See “Architec-
tural vs CAD Objects” on page 108.

3
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• Select Absolute Angle to rotate the 
object relative to an imaginary horizontal 
line drawn in the positive X direction 
from the origin. See “3D Drafting” on 
page 25. 

• Select Relative Angle to rotate the object 
the specified angle relative to its current 
orientation.

You can also specify the point the selected 
object(s) rotate about, below. 

Select Resize, then specify the Resize 
Factor in decimals. A resize factor of 2 

doubles the size of the object, while a resize 
factor of 0.5 halves the object’s size. Not 
available for all objects, including line- and 
arc-based objects and Primitives. 

You can also specify the point the selected 
object(s) is resized about, below. 

Reflect - Select this option, then 
specify which axis to reflect about.

• Horizontally - Select this option to 
reflect the object horizontally.

• Vertically - Select this option to reflect 
the object vertically.

You can also specify the point the selected 
object(s) is reflected about, below. 

Rotate/Resize/Reflect About - This 
section is enabled when the Rotate, 

Resize and/or Reflect functions are selected.
• X Position - Specify the X coordinate of 

the point to perform the selected edit 
function(s) about when About Absolute 
Point is selected.

• Y Position - Specify the Y coordinate of 
the point to perform the selected edit 
function(s) about when About Absolute 
Point is selected.

• About Object Center - Select this option 
to perform the selected edit function(s) 
about the object’s center.

• About Absolute Point - Select this 
option to perform the selected edit func-
tion(s) about the specified point.

• About Current Point - Select this option 
to perform the selected edit function(s) 
about the current CAD point. 

Edit Area Tools
The Edit Area Tools allow you to 
quickly define an area of your plan 

and select the objects in that area. Once 
selected, they can then be repositioned, 
copied or deleted. Select Edit> Edit Area to 
access the Edit Area Tools.

Unlike other selection methods, the Edit 

Area Tools  cut walls, railing and fencing 
where the selection marquee intersects them, 

allowing you to edit only the selected portion 
of these objects. 

Some objects, such as cabinets, are included 
in the selection only if more than half of the 
object is contained within the marquee.  

A few objects, notably CAD points, are not 

affected by the Edit Area Tools .

4

5

6
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Edit Area
Select Edit> Edit Area> Edit Area 
and draw a rectangular marquee 

around the area of the plan to be edited. 

Edit Area  affects all objects included in 
the selection marquee that are located on the 
current floor, regardless of whether they are 
displaying in floor plan view or not.

Edit Area Visible
Select Edit> Edit Area> Edit Area 
Visible and draw a marquee around 

the area of the plan to be edited. 

Edit Area Visible  only affects visible 
objects included in the selection marquee: 
objects not currently displayed in floor plan 
view are unaffected.

Edit Area (All Floors)
Select Edit> Edit Area> Edit Area 
(All Floors) and draw a marquee 

around the area of the plan to be edited. 

Edit Area (All Floors)  affects all objects 
on all floors of the plan that are included in 
the selection marquee, regardless of whether 
they display in floor plan view. 

Edit Area (All Floors) Visible
Select Edit> Edit Area> Edit Area 
(All Floors) Visible and draw a 

marquee around the area of the plan to be 
edited. 

Edit Area (All Floors) Visible  affects all 
visible objects on all floors of the plan that 
are included in the selection marquee. 
Objects not currently displaying in floor plan 
view are not affected.

Edit Area Polyline
If a rectangular marquee’s shape does not 
allow you to define an area precisely, use a 
closed polyline instead. 

Select a polyline that defines the desired area 
in floor plan view and then select one of the 

Edit Area Tools . The polyline becomes 
temporarily highlighted and acts as an Edit 
Area marquee. 

Using the Edit Handles
An Edit Area marquee displays edit handles 
that are similar to those of a closed polyline. 
See “Using the Edit Handles” on page 139.
• Click the Move edit handle to move the 

entire selection set. See “Moving 
Objects” on page 152.

• Click the Rotate edit handle to rotate the 
entire selection set. See “Rotating 
Objects” on page 161.

• Click and drag the Reshape and Resize 
edit handles at each corner and along 
each edge to adjust the size and shape of 
the marquee. See “Using the Edit Han-
dles” on page 139.

Adjusting the size or shape of an Edit Area 
marquee may change which objects are 
included in the selection set but does not 
otherwise affect those objects.

The Edit Area tools can cause wide-
spread changes across an entire plan

and should always be used with caution.
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Using the Edit Toolbar
A selected Edit Area marquee and/or the 
objects within it can be edited in a variety of 
ways using the buttons on the edit toolbar.  
See “Using the Edit Toolbar” on page 140. 

The following toolbar buttons may display 
on the edit toolbar for an Edit Area marquee:

• Click the Copy/Paste  edit button to 
copy the selection set to the Windows 
Clipboard so it can be pasted elsewhere. 
See “Copying and Pasting Objects” on 
page 114.

• Click the Delete  edit button to delete 
the selection set. See “Deleting Objects” 
on page 171.

• Click the Transform/Replicate Object 

 edit button to copy, move, rotate, 
resize, or reflect the selection set. See 
“Transform/Replicate Object Dialog” on 
page 166.

• Click the Accurate Move  edit button 
to slow down the mouse speed when 
using the edit handles. See “Accurate 
Move” on page 153.

• Click the Make Parallel/Perpendicular 

 edit button to rotate the Edit Area 
marquee and the selection set so that the 
selected marquee edge is parallel or per-
pendicular to another straight edge. See 
“Using Make Parallel/Perpendicular” on 
page 155. 

• Click the Point to Point Move  edit 
button to accurately move the selection 
set. See “Point to Point Move” on page 
153. 

• Click the Center Object  edit button 
to center the selection along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 156.

• Click the Reflect About Object  edit 
button to reflect the selection set about 
another object. See “Reflecting Objects” 
on page 163. 

• Click the Allowed Angles  edit button 
to open the Place at Allowed Angles 
dialog. 

Place at Allowed 
Angles Dialog

If more than one percent of the 
straight walls included in an Edit Area 

marquee are not at an allowed angle, the 
Allowed Angles edit button displays. 

Click the Allowed Angles  edit button to 
display the Place at Allowed Angles dialog.

Select the first option and click OK to rotate 
the plan so that the largest group of off-angle 
walls move to an Allowed Angle. This may 
place this largest group at Allowed Angles, 
but has two disadvantages. 
• First, other groups of off angle walls  

remain off angle. 
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• Second, any walls that were at an allowed 
angle before this action will move to an 
off angle. The dialog shows how much 
(weighted by length) of the selected walls 
are in each category. 

Select the second option and click OK to add 
new entries to the Allowed Angles list and 
allow new walls to be placed at these angles. 
Walls already at Allowed Angles remain so. 
See “Angle Snaps” on page 111.

Select the third option and click OK to do 
nothing, which is the same as clicking 
Cancel.

You may want to rotate the majority of the 
walls to one of the normal allowed angles. 

Then, use an Edit Area  tool to select 
everything again and select the second option 
to provide new angle entries to cover the 
remaining walls. 

Deleting Objects
Objects can be deleted in a variety of ways: 
• Select an object or group of objects, then 

click the Delete  edit button, select 

Edit> Delete  from the menu, or press 
the either the Delete or Backspace key on 
your keyboard. 

• Entire categories of objects can be 
deleted using the Delete Objects dialog.

• Objects are deleted if the floor they are 
placed on is deleted. See “Deleting 
Floors” on page 320.

If an object has a line with arrow or text 
leader attached to it, the arrow or leader is 
deleted if the object is deleted. To prevent the 
arrow from being deleted, drag the attached 
end away from the object before deleting it. 

A variety of objects in the program can be 
generated automatically, including roofs, the 

foundation, and framing. Automatically 
generated objects cannot be deleted unless 
the automatic creation option is disabled. 

Delete Objects Dialog
Use the Delete Objects dialog to 
delete all objects of one or more 

specified types in one room, on the current 
floor, or in the entire plan. 

To use the Delete Objects dialog

1. Select Edit> Delete Objects  to open 
the Delete Objects dialog.

Although objects on locked layers can-
not be selected, most can nevertheless

be deleted using the Delete Objects dialog. 
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2. Specify the Delete Scope as Single 
Room, All Rooms On This Floor, or 
All Floors. 

3. In the Delete section, check the box for 
each category of objects you want to 
delete. Click Select All to check all the 
boxes or Clear All to uncheck all boxes.

•  If “Roof Planes” cannot be selected, 
they may be locked. See “Editing Roof 
and Ceiling Planes” on page 365.

4. When the scope is set to Single Room:
•  Move your cursor into the drawing area 

and click in a room of the plan to delete 

objects of the selected type within that 
room without closing the dialog. 

•  Continue clicking on rooms or choose a 
different Delete Scope.

•  Click Done when all selections have 
been deleted.

5. If you select All Rooms On This Floor 
or All Floors, you do not need to click in 
floor plan view. The Delete button 
becomes available, and clicking it closes 
the dialog and deletes the specified 
objects. 

Deleting Polyline Edges
There are number of different ways to delete 
individual edges of polyline-based objects:

• Select Edit Object Parts . Select the 
edge and delete. See “Edit Object Parts” 
on page 125.

• Drag a corner handle until it overlaps an 
adjacent corner handle to remove the 
edge between them and merge them into 
a single handle.

• Create a complete break at both ends. 
Select the edge and delete. See “To create 
a complete break” on page 159.

• The Fillet Two Lines  and Chamfer 

Two Lines  tools can be used to delete 
polyline edges. See “Reshaping Objects” 
on page 158.

Delete Surface
In any 3D view, select 3D> Delete 
Surface, then click a surface in the 

view to temporarily remove the surface from 
the current view without permanently 
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affecting the object. See “Delete 3D Surface” 
on page 679.

Undo and Redo
The Undo and Redo commands 
allow you to both undo the last 

action performed, as well as redo actions that 
were recently Undone. 

The ten most recent actions can be Undone 
or Redone, depending on your settings in the 
Preferences dialog. See “General Panel” on 
page 67. Actions that can be Undone and 
Redone include creating, editing, and 
deleting objects. 

To Undo an action, select Edit> Undo , 

click the Undo  button, or press Ctrl + Z 
on your keyboard.

The Redo command is only available 
immediately after Undo has been used. To 
Redo an Undone action, select Edit> 

Redo , click the Redo  button or press 
Ctrl + Y on your keyboard. 

It is important to note that Undo  and 

Redo  do not affect all actions in the 
program, including:
• Save and Save As. See “Saving, Export-

ing, and Backing Up Files” on page 43. 
• Changes made in the Library Browser. 

See “The Library Browser” on page 604. 
• Changes made in a dialog while the dia-

log box is open. See “Dialogs” on page 
30.

• Changes made to the display by panning 
the display or zooming in or out. See 
“Undo Zoom” on page 654.
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Chapter 8:

Walls, Railings &
Fencing

Walls are the single most important building 
component in Home Designer Pro. By 
creating walls and defining the rooms created 
by the walls, you are telling the program how 
you want the 3D model built.

There are several ways that walls can be 
created in Home Designer Pro. The most 
common is to simply draw them with the 
Wall Tools. 

In addition, exterior walls can be generated 
automatically when a new floor is built by 
using another floor as a model. For more, see 
“Adding Floors” on page 317.

2D CAD lines can also be converted into 
actual walls using the CAD to Walls tool.

Another feature that can be used to generate 
walls automatically is the House Wizard. 
See “House Wizard” on page 799.

Chapter Contents
•      Wall, Railing, and Fencing Defaults
•      The Wall Tools
•      The Deck Tools
•      The Fencing Tools
•      Exterior and Interior Walls
•      Foundation Walls
•      Pony Walls
•      Railings
•      Invisible Walls
•      Polygon Shaped Decks
•      Hatch Wall
•      Break Wall
•      Drawing Walls
•      Connecting Walls
•      Displaying Walls
•      Measuring Walls
•      Editing Walls
•      Editing Straight/Curved Wall Combinations
•      Aligning Walls
•      Roof Directives in Walls
•      Attic Walls
•      Stepped and Raked Walls
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•      CAD to Walls
•      Wall Type Definitions
•      Wall Type Definitions Dialog

•      Wall Specification Dialog
•      Railing and Fencing Specification Dialogs
•      Wall Hatch Specification Dialog

Wall, Railing, and Fencing Defaults
There are several defaults dialogs for 
walls. Default Settings can be accessed 

by selecting Edit> Default Settings. Click 
the + next to “Walls” to display the walls 
sub-headings. Select a subheading and click 
the Edit button to open the Wall Defaults 
dialog associated with your selection: 

The defaults dialog for each wall tool can 
also be accessed by double-clicking its 
toolbar button. 

The settings in the various wall defaults 
dialogs determine what wall types are drawn 
when the different wall tools are used. It is a 
good idea to be familiar with these settings 
and how they relate to your style of building. 
See “Wall Type Definitions” on page 209.

General Wall Defaults
The General Wall Defaults dialog 
controls the general behavior and 

display attributes of all walls, railings and 
fencing. 

For quick access, the General Wall 

Defaults  button can be added to the 
toolbar or you can press Alt+Q on your 
keyboard.

Resize About - These radio buttons 
determine what part of a wall retains its 

position when its wall type or wall type 
definition is changed. See “Resize About” on 
page 202.

The Resize About location is also where any 
snap points will be located along a wall as it 

is drawn or connected to other walls, and is 
where a wall’s length is measured. 
• Outer Surface - Snap to and resize about 

the exterior surface. When a wall is 
resized, its exterior surface does not 
move.

1 2 

1
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• Main Layer Outside - Snap to and resize 
about the outer line of the Main Layer. 
When a wall is resized, the outer line of 
its Main Layer does not move.

• Wall Center - Snap to and resize about 
the center line. When a wall is resized, its 
center line does not move, but wall layers 
on either side may.

• Main Layer Inside - Snap to and resize 
about the inner line of the Main Layer. 
When a wall is resized, the inner line of 
its Main Layer does not move.

• Inside Surface - Snap to and resize about 
the interior surface. When a wall is 
resized, its interior surface does not move.

Check Show Wall Length When 
Editing to display a temporary length 

dimension when a wall is drawn or edited. 
Wall length only displays when Display 

Temporary Dimensions  is on. See 
“Display Temporary Dimensions” on page 
731. 

Exterior/Interior Wall Defaults Dialog
Specify which wall types are drawn using the 

Exterior  and Interior Wall  tools in 
the Exterior/Interior Wall Defaults dialog.

You can also double-click the Straight or 
Curved Exterior or Interior Wall toolbar 
buttons to open this dialog. 

Exterior Wall Tool - From the drop-
down list, select the wall type drawn 

with the Exterior Wall  tool.  

Note: In most circumstances, it is recom-
mended that you Resize About the Main
Layer Outside to avoid unexpected results. 

2

1 

2

1
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Click the Define button to open the Wall 
Type Definitions dialog. See “Wall Type 
Definitions Dialog” on page 211.

Interior Wall Tool - From the drop-
down list, select the wall type drawn by 

the Interior Wall  tool. 

Click the Define button to open the Wall 
Type Definitions dialog.

Foundation Wall Defaults
Specify which wall types is drawn when the 

Foundation Wall  tool is used either 
manually or when a stem wall or pier 
foundation is generated in the Foundation 
Wall Defaults dialog. See “Foundation 
Walls” on page 183.

The Foundation Wall Defaults dialog also 
controls the wall type drawn by the 

Retaining Wall  tool. Unlike other walls, 

Retaining Walls  are used to modify your 

terrain rather than build a structure. See 
“Terrain Wall and Curb Tools” on page 549.

Footing size and other information used 
when building stem wall or pier foundations 
is also specified here. For more information, 
see “Foundation Defaults” on page 330.

The tabs in this dialog are the same as their 
respective tabs in the Wall Specification 
dialog. See “Wall Specification Dialog” on 
page 214.

Pony Wall Defaults
Specify the wall types used for the upper and 
lower portions of pony walls and other data 
associated with pony walls in the Pony Wall 

Defaults dialog. See “Pony Walls” on page 
184.

2
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Upper Wall - From the drop-down list, 
select the default wall type for the 

upper portion of pony walls.
• Click the Define button to open the Wall 

Type Definitions dialog, where you can 
create and modify wall types. See “Wall 
Type Definitions Dialog” on page 211.

Lower Wall - From the drop-down list, 
select the default wall type for the 

lower portion of pony walls.
• Height of Lower Wall - Specify the 

default height of the lower portion of 
pony walls. 

• Click the Define button to open the Wall 
Type Definitions dialog.

Align Pony Wall - Specify the default 
option for aligning the layers of the 

upper and lower pony walls.  See “Wall 
Types Tab” on page 221.

Display In Plan - Specify how pony 
walls appear in floor plan view.

• Select Show Upper Wall to display this 
wall type in floor plan view instead of the 
lower wall type. 

• Select Show Lower Wall to display this 
wall type in floor plan view instead of the 
upper wall type. 

• Check Hide Openings in Non-Displayed 
Parts of Walls to hide any doors and win-
dows located in the parts of pony walls 
that are not visible. When unchecked, 

1

2
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these openings will display along with 
those located in the visible parts of pony 
walls. 

Railing and Deck Railing Defaults
Specify the types of railings created when the 
Railing and Deck Railing tools are used. See 
“Railings” on page 185.

The tabs in these dialogs are the same as their 
respective tabs in the Wall Specification 
dialog. See “Wall Specification Dialog” on 
page 214.

Half-Wall Defaults

Double-click the Half-Wall  or Curved 

Half-Wall  button to open the Half-Wall 
Defaults dialog and specify the attributes of 
a solid railing drawn using either Half Wall 
tool. 

The tabs in this dialog are the same as their 
respective tabs in the Wall Specification 
dialog. See “Wall Specification Dialog” on 
page 214.

Fencing Defaults

Double-click the Fencing Tools  parent 
button or either of its child tools to open the 
Fencing Defaults dialog and specify the 
attributes of fencing drawn using either 
Fencing tool. 

The tabs in this dialog are the same as their 
respective tabs in the Wall Specification 
dialog. See “Wall Specification Dialog” on 
page 214.

Invisible Wall Defaults

Double-click the Invisible Wall  button 
to open the Invisible Wall Defaults dialog 
and specify what type of wall is drawn when 
using the Invisible Wall tool. See “Invisible 
Walls” on page 187.

The tabs in this dialog are the same as their 
respective tabs in the Wall Specification 
dialog. See “Wall Specification Dialog” on 
page 214.

Note: By default, Railiings and Deck Railngs
are drawn using two separate wall types:
“Interior Railing” and “Deck Railing/Fence”.
See “Wall Type Definitions” on page 209.
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The Wall Tools
Select Build> Wall  to access the Wall 
Tools. The type of wall drawn by each 

wall tool is specified in its corresponding 
defaults dialog. 

The Curved Wall tools are similar to 
their corresponding Straight Wall 

Tools. Select Build> Curved Wall  to access 
these tools. 

Exterior Walls
The Exterior Wall and Curved 
Exterior Wall tools draw walls 

using the default wall type specified for 
exterior walls in the Exterior/Interior Wall 
Defaults dialog. See “Exterior and Interior 
Walls” on page 183.

Interior Walls
The Interior Wall and Curved 
Interior Wall tools draw walls 

using the wall type specified for interior 
walls. The interior wall type is defined in the 
Exterior/Interior Wall Defaults Defaults 
dialog. 

Foundation Walls
The Foundation Wall and 
Curved Foundation Wall tools 

draw foundation walls. Foundation walls 
normally have a footing and can be drawn on 
any floor of the model, not just the 

foundation floor. See “Foundation Walls” on 
page 183.

Pony Walls
A Pony Wall, also called a split 
wall, is defined as a wall with 

two separate wall types, one for the upper 
portion and another for the lower portion.

The Pony Wall and Curved Pony Wall tools 
draw pony walls using the information 
specified in the Pony Wall Defaults dialog. 
You can also convert a normal wall into a 
pony wall and vice versa in the Wall 
Specification dialog. See “Pony Walls” on 
page 184.

Railings
The Railing and Curved Railing 
tools create railings. The style 

and height of railings drawn with this tool are 
defined in Railing Defaults dialog. See 
“Railing and Deck Railing Defaults” on page 
180.

Half-Walls
The Half-Wall and Curved 
Half-Wall tools create solid 

railings: walls that are 36” (900 mm) high 
topped with a handrail. The height and other 
attributes of solid railings drawn with this 
tool are defined in Half-Wall Defaults dialog. 
See “Half-Wall Defaults” on page 180. 

Invisible Wall
Invisible Walls are walls used to 
define separate room areas in a plan. 

Note: Whether a wall is recognized as an
exterior or interior wall by the program is
determined by its position in the model, not
by the tool used to draw it. See “Exterior and
Interior Walls” on page 183.
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They can display in floor plan view but not in 
3D views. You can also convert a normal 
wall into an invisible wall and vice versa in 
the Wall Specification dialog. See “Invisible 
Walls” on page 187. 

Hatch Wall
The Hatch Wall tool applies a hatch 
pattern to a wall that displays in floor 

plan views. You must click the wall that you 
want to apply the hatch pattern to. You can 
then select the hatch and resize it if you want 
to only hatch a portion of a wall. See “Hatch 
Wall” on page 188.

Break Wall
The Break Wall tool applies a break 
in a wall. Once a wall is broken, the 

two wall segments are separate walls that can 
be modified independent of each other. See 
“Break Wall” on page 189.

Fix Wall Connections
The Fix Wall Connections tool 
connects walls whose ends are within 

a few inches of each other but are not 
connected. See “Fix Connections” on page 
192.

Define Wall Types
The Define Wall Types tool opens 
the Wall Type Definitions dialog, 

where wall types can be created, copied and 
edited. See “Wall Type Definitions Dialog” 
on page 211.

The Deck Tools
Select Build> Deck to access the 
Deck Tools. When a room is defined 

using deck railing, its Room Type is 
automatically set to “Deck”. See “Decks” on 
page 238.

Deck Railing
The Straight Deck Railing and 
Curved Deck Railing tools draw 

decks, complete with framing and bounded 
by a railing. If a foundation level exists, 
supports for the deck are also created. See 
“Railings” on page 185.

Deck Edges
The Straight Deck Edge and 
Curved Deck Edge draw decks 

complete with framing, but without a railing. 
No deck supports are created. 

Polygon Shaped Deck
The Polygon Shaped Deck tool opens 
the New Polygon Shaped Deck 
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dialog, where you can specify the exact size 
and number of sides of a new polygonal deck 
room and then click in floor plan view to 

create that deck room. See “Polygon Shaped 
Decks” on page 187.

The Fencing Tools
Select Build> Fencing or click the 
Fencing Tools to access the fencing 

tools. 

The Fencing and Curved 
Fencing tools are used to draw 

fences, which are similar to railings but by 
default do not define room areas. Fencing is 
created and edited much like walls and 
railings, and normally used outside of a 
building and follows the shape of the terrain.  
See “Terrain” on page 537.

Fencing automatically follows the shape of 
the terrain. You can choose to have the 

fencing follow the terrain smoothly or to 
have each segment step as it follows the 
terrain. See “Rail Style Tab” on page 224.

Define the default fence style in the Fencing 
Defaults dialog. See “Fencing Defaults” on 
page 180.

Exterior and Interior Walls
Most walls are drawn using either the 

Exterior Wall  or Interior Wall  tool. 
The only difference between these two tools 
is the wall type used. You can specify the 
default wall type for each tool in the Wall 
Defaults dialog. 

To draw a wall using a different wall type, 
you can change the default wall type for 
either tool in the Wall Defaults dialog. You 
can also draw a wall using the default type 

and then change the wall type in the Wall 
Specification dialog.

Whether a wall is recognized by the program 
as an actual exterior or interior wall is based 
on the model, not by which tool you use to 
draw the wall. Any wall that is entirely 
surrounded by interior room areas is 
considered an interior wall. Any wall 
exposed to the outside of the building is 
considered an exterior wall.

Foundation Walls
Foundation walls are similar to the 
interior and exterior walls but also 

have a footing. Foundation walls can either 
be created automatically when a foundation 
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floor is created or manually by drawing them 
using the Straight or Curved Foundation 
Wall tool. See “Building a Foundation” on 
page 334. 

The initial foundation wall type and footing 
size are specified in the Foundation Wall 
Defaults dialog. These values can be 
changed for individual walls in the Wall 
Specification dialog. See “Wall 
Specification Dialog” on page 214. 

You can draw a foundation wall on any floor 
of a plan, not just on the foundation level. 
Any wall can be specified as a foundation 

wall, regardless of the tool used to draw it. 
See “Foundation Tab” on page 219. 

Foundation walls are placed on the “Walls, 
Foundation” layer. In floor plan view, 
foundation wall footings are placed on the 
“Footings” layer; in 3D views, they are on 
the “Walls, Foundation” layer. See 
“Displaying Walls” on page 192.

Slab Footings
When a monolithic slab foundation is 
created, the slabs are defined by specially 
defined foundation walls that have footing 
widths equal to that of the wall type - by 
default, 16” (350 mm). For Garage curbs, the 
footings should be wider than the wall type.  
See “Foundation Tab” on page 219. 

Rooms defined by these Slab Footing walls 
will have a Ceiling Height of 0 and a 
Monolithic Slab Foundation. See “Structure 
Tab” on page 245. 

Pony Walls
A Pony Wall, sometimes called a 
split wall, is a wall with two 

separate wall types for the upper and lower 
portions. 
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Walls drawn using the Pony Wall  tool 
are created using the wall types and other 
information specified in the Pony Wall 
Defaults dialog. See “Pony Wall Defaults” 
on page 178.

You can also convert a normal wall into a 
pony wall and vice versa in the Wall 
Specification dialog. See “Wall Types Tab” 
on page 221.

The height where the upper portion meets the 
lower can be adjusted in the Wall 
Specification dialog and in 3D views using 
the wall’s edit handles. Because the upper 
and lower sections of a pony wall are linked, 
if either portion is modified along the 
division between the two, such as raking or 
the stepping of a footing, the other portion of 
the pony wall adjusts to match. See “Stepped 
and Raked Walls” on page 207.

You can specify whether the upper or lower 
portion of pony walls displays in floor plan 
view in the Pony Wall Defaults dialog. This 
option can also be set for individual walls in 
the Wall Specification dialog. 

Changing Wall Types 
for Pony Walls

The default upper and lower parts of a pony 
wall can be specified in the Pony Wall 
Defaults dialog. See “Pony Wall Defaults” 
on page 178.

The upper and lower parts of a pony wall can 
be redefined as different wall types in the 
Wall Specification dialog. See “Wall Types 
Tab” on page 221.

Railings
Railings are created and edited 
just like walls. See “Drawing 

Walls” on page 189. The attributes for 
railings when they are first drawn are defined 
in the Railing Defaults dialog. See “Railing 
and Deck Railing Defaults” on page 180.

Railings are ideal for a number of tasks:
• Creating changes in floor and/or ceiling 

height. See “Floor & Ceiling Heights” on 
page 239.

• Creating stairwells. See “Creating a Stair-
well” on page 419.

• Drawing decks. See “Decks” on page 
238.

To produce a break in a railing for a stairway 

or other access, use a Doorway  . This 
keeps the railing continuous and maintains 

Note: The only way to control the materials
displaying on a pony wall is by changing the
wall types. 
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room definition. See “Room Definition” on 
page 231.  

When first drawn, railings are specified as 
No Locate, which prevents Auto Exterior 

Dimensions  from locating them. The No 
Room Def attribute may also be helpful if 
you do not want a railing to divide an area 
into two separate rooms. See “General Tab” 
on page 214.

By default, newels and balusters do not 
display in floor plan view, but their display 
can be turned on. See “Newels/Balusters 
Tab” on page 226.

Railing Types
A variety of railing types can be specified in 
the Railing and Deck Railing Specification 
dialogs. See “Rail Style Tab” on page 224. 
Available types include:
• Baluster creates railings composed of 

newel posts, balusters, a railing, and an 
optional bottom rail. 

• Solid produces a framed railing wall, or 
Half Wall. See “Half-Walls” on page 181. 

• If Panels is selected, you can choose a 
panel style such as cable, glass, or iron-
work from the library. See “Newels/Bal-
usters Tab” on page 226.

Wall Types and Railings
Just like regular walls, railings are assigned a 
wall type: “Interior Railing”. This wall type 
has three layers: a framing layer in the 

middle and a layer of drywall on each side. 
See “Wall Type Definitions” on page 209. 

You can use a different wall type definition 
for railings if you wish, but bear in mind that 
this wall type definition determines several 
important things: 
• The railing’s appearance in floor plan 

view. See “Displaying Walls” on page 
192. 

• The actual thickness of Solid railings in 
3D views. 

• The extent of the floor platform, if a plat-
form edge is defined by the railing. is 
defined by the outer surface of the wall 
type. See “Floor and Ceiling Platforms” 
on page 321. 

• If the railing is used to create a change in 
floor height, this wall type controls the 
structure and position of the partial wall 
built beneath the railing, if one is 
required. See “Floor & Ceiling Heights” 
on page 239. 

If the railing is a type other than Solid, its 
sizing is specified on the Newels/Balusters 
tab of the Railing Specification dialog, and 
the railing is centered along the width of the 
wall type. This will not be evident in floor 
plan view unless newels and balusters are set 
to display. 

Deck Railing is also assigned a wall type: 
“Deck Railing/Fencing”. This wall type has a 
single framing layer and is recommended for 
use only with deck railing and fencing. 
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Invisible Walls
Invisible walls can display in floor 
plan view but not in 3D views or the 

Materials List. They are used to create or 
modify room definition, most often by 
defining smaller areas within larger rooms. 
See “Room Definition” on page 231. 

Invisible walls can also be used to define 
areas with different floor or ceiling materials 
or heights. 

Common uses for invisible walls include 
dividing areas of an open floor plan into 
areas with different purposes. 

An invisible wall can be turned into a normal 
wall, or vice versa, by clicking the Invisible 
check box in its Wall Specification dialog. 
See “General Tab” on page 214.

Invisible walls are drawn using the attributes 
specified in the Invisible Wall Defaults 
dialog and are placed on the “Walls, 
Invisible” layer by default. A wall placed on 
a non-default layer and then specified as 
Invisible, however, will not move to the 
“Walls, Invisible” layer. See “Invisible Wall 
Defaults” on page 180. 

Important Notes on 
Invisible Walls

• Floor, wall and ceiling areas are calcu-
lated separately for rooms divided by 
invisible and normal walls.

• Invisible walls are ignored by the Auto 

Place Outlets  tool; it functions as 
though they were not present. 

• Cabinets, fixtures and furniture can be 
moved freely through Invisible walls. 

• Invisible walls can be drawn through a 
cabinet to attach to the wall behind.

• Invisible Walls are automatically gener-
ated to connect “island” rooms to the 
larger structure around them. See “Room 
Definition” on page 231.

Polygon Shaped Decks
Select Build> Deck> Polygon 
Shaped Deck to open the New 

Polygon Shaped Deck dialog and create a 
polygon shaped deck with regular sides.

Invisible walls separate this dining area 
from adjacent rooms 
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The settings in this dialog are saved between 
program sessions. 

To create a polygon shaped deck

1. Click the radio button beside an option 
to specify whether you want to Define 

Polygon by Side Length, Radius to 
Corner or Radius to Side.

2. Specify the desired Number of Sides.
3. Specify the desired Side Length or,
4. Specify the desired Radius.
5. Uncheck Include Railing to produce a 

deck platform defined by Deck Edges. 
This option is not available in the New 
Polygon Shaped Room dialog.

6. Click OK, then click once in floor plan 
view to create the specified polygon 
shaped deck.

Hatch Wall
The Hatch Wall tool can be used to 
fill wall segments with a single hatch 

pattern in floor plan view.  

To apply wall hatching, select Build> Wall> 

Hatch Wall , then click on a wall. The 
hatch pattern covers the entire length and 
width of the wall segment.

Hatch Wall  places a hatch pattern across 
all layers of the selected wall, covering any 
fill styles specified for that wall type.

In many cases, it is preferable to create a wall 
type definition rather than use the Hatch 

Wall  tool because multiple fill styles can 

be created for display purposes. See “Wall 
Type Definitions Dialog” on page 211.

Once created, wall hatching can be selected, 
edited and deleted much like other line-based 
objects. See “Editing Line Based Objects” on 
page 127.

If you use the Hatch Wall  tool to apply a 
hatch pattern to a wall that has been divided 
into multiple segments using the Break 

Wall  tool, the pattern is only applied to 
the segment that you clicked on . See “Break 
Wall” on page 189.

Like doors and windows, wall hatching 
cannot extend across multiple wall segments. 
Unlike these objects, hatching cannot be 
located by dimension lines.

The wall hatch pattern and its line weight can 
be specified in the Wall Hatch Specification 

Note: The Hatch Wall tool cannot be used to
apply a hatch pattern to Invisible Walls. See
“Invisible Walls” on page 187.
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dialog. See “Wall Hatch Specification 
Dialog” on page 227. 

When editing or deleting wall hatching, 
make sure that it is selected rather than the 

wall by noting that “Wall Hatching” displays 
in the Status Bar. See “The Status Bar” on 
page 31. 

Break Wall
To divide a wall or railing, select  
Build> Wall> Break Wall and click 

on the wall. The wall is divided into two wall 
sections at the point where you click. 

The Break Wall  tool remains active, so 
you can continue to place breaks in walls. 
When you are finished, select a different 
tool.

If a wall break is placed near the intersection 
of two walls, the break is positioned at the 
center of the intersection. 

Once a break is placed, click the Select 

Objects  tool and select the original wall. 
If edit handles display near the break, the 
wall was correctly broken.

Walls separated by a break can be rejoined. 
Select one of the segments, then click on the 
end edit handle located at the break and drag 
it a few plan inches (mm) away from the 
break. See “Connecting Walls” on page 191.

The Break Wall  tool can be used to 
create aligned walls on either side of a gap. 
See “Creating a Nook” on page 202.

Drawing Walls
Walls are drawn similar to the way CAD 
lines are drawn and can be drawn in floor 
plan view, camera views, and overviews. See 
“Draw Line” on page 776. 

Drawing walls to create a floor plan is simple 
if you keep a few things in mind: 
• Draw exterior walls first to define the 

building’s footprint, then draw the interior 
walls after the perimeter is in place. 

• It is easiest to draw walls at the approxi-
mate location and length needed and then 
move or resize them precisely using 
dimensions later. See “Moving Objects 
Using Dimensions” on page 737. 

• If you wish to input wall lengths as you 
draw, make sure your General Wall 
Defaults are set to Resize About Outer 
Surface. See “Entering Wall Lengths and 
Angles” on page 190. 

• As walls are drawn, “sticky” points and 
extension lines identify points that are 
either collinear or orthogonal to the end 
points of other walls, making alignment 
easier. See “Extension Snaps” on page 
111. 

• When walls enclose an area to form a 
room, the program will orient all exterior 
walls so that the siding material faces out-
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ward. See “Wall Type Definitions” on 
page 209. 

• To flip the layers of a wall after it is 
drawn, select it and click the Reverse 

Layers  edit button. See “Editing 
Walls” on page 197.

• Initial wall heights are determined by the 
default floor and ceiling heights of the 
current floor. See “Floor Defaults Dialog” 
on page 316.

Wall Positioning
The recommended method of drawing walls 
is to draw them at their approximate location 
and length, then move them into position 
with accuracy using dimensions. To make 
this task quick and efficient: 
• Notice the temporary wall that displays as 

you draw. Its length and angle display in 
the Status Bar at the bottom of the win-
dow and adjust as you move the mouse. 
Release the mouse button to draw the wall 
at the displayed length and angle. See 
“The Status Bar” on page 31. 

• Use Snaps to help ensure proper wall 
alignment and orientation. See “Snap 
Behaviors” on page 109. 

Once walls are drawn, they can be accurately 
dimensioned and moved as needed. See 
“Measuring Walls” on page 195. 

Entering Wall Lengths 
and Angles

The fastest way to draw walls is to draw 
them at their appoximate position and length, 
and then move or resize them accurately 
using dimensions. See “Using Dimensions” 
on page 198.

For those that wish to enter walls’ lengths 
and angles as they are drawn, first select 
Resize About Outer Surface in the General 
Wall Defaults dialog. See “Resize About” on 
page 202.

Then draw a wall, select it, and specify its 
Length and Angle in the Wall Specification 
dialog.  Draw a second wall and specify its 
length and angle, and so on. See “General 
Tab” on page 214.

Wall Openings
To create a door or doorway, do not draw 
wall sections with a gap between them. Walls 
should be drawn to completely enclose 
rooms, and then door and window objects 
should be placed in the walls to create 
openings later. See “Doors” on page 253 and 
“Windows” on page 279. 

Masonry fireplaces placed in walls are also 
considered to be types of wall openings. See 
“Fireplaces” on page 343.

Temporary Dimensions
Temporary dimensions will display along the 
length of a wall as it is drawn when Display 

Temporary Dimensions  is toggled on 
and Show Wall Length When Editing is 
checked in the General Wall Defaults dialog. 
See “Display Temporary Dimensions” on 
page 731 and “General Wall Defaults” on 
page 176. 

 Drawing Curved Walls
Drawing a curved wall, curved railing, or 
curved fence is similar to drawing a CAD 
arc. See “Arc Tools” on page 785.
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As with CAD arcs, the method used to draw 
a curved wall depends on which Arc 

Creation Mode  is currently active.  See 
“Drawing Arcs - Arc Creation Modes” on 
page 784.

A straight wall can also be converted into a 
curved wall and vice versa using the Change 

Line/Arc  edit button. See “Change Line/
Arc” on page 159.

A curved wall always has a center point. The 
center displays as a small cross when Show 

Arc Centers and Ends  is enabled. See 
“Show Arc Centers” on page 134. 

The radius of a curved wall is measured from 
the center to a surface or layer of the wall. 
The radius can be defined in the Wall 
Specification dialog. You may elect to 
define the radius to the exterior or interior 
wall layers. See  “General Tab” on page 214.

House Wizard
The House Wizard allows you to place 
and arrange room “objects” that can 

then be converted into a fully editable house 
plan, including walls. See “House Wizard” 
on page 799.

Wall Framing
Once walls have been drawn, they can be 
framed. For best results, avoid generating 
framing until your model is in its final form. 
See “Wall Framing” on page 436. 

Connecting Walls
When walls are drawn sufficiently close to 
one another, they will snap together to form 
an intersection. This snapping occurs when 
the walls’ center lines are within a distance 
defined by the larger of the two walls’ widths 

and will occur even when Object Snaps  
are turned off. See “Object Snaps” on page 
110.

If the two walls in question have the same 
wall type and identical specifications, and 
are collinear, they will merge to become a 
single wall. See “Aligning Collinear Walls” 
on page 202.  

When three or more walls connect to form a 
completely enclosed area, that area defines a 
room. See “Rooms” on page 229.

To create a room in the shape of a cir-
cle, you must draw two curved walls.

Show Arc Center
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When walls snap together to form an 

intersection and Object Snaps  are 
enabled, the program joins them at their 
Resize About line, which is specified in the 
General Wall Defaults dialog. See “Aligning 
Walls” on page 201. 
• The wall that is being drawn or edited will 

move, lengthen, or shorten slightly to 
meet the other wall. 

• The other wall will not move; however, 
its length may be affected. 

Wall Intersections
Any time two walls intersect, one wall will 
build through the other. You can turn on the 
display of.the “Walls, Thru Wall Lines” layer 
in floor plan view to see which walls build 
through and which do not. See “Displaying 
Objects” on page 102. 

When a wall builds through another wall, it 
will extend into the intersected wall until it 
meets the interior surface of that wall’s Main 
Layer. See “The Main Layer” on page 209.

Fix Connections
Occasionally, one or more walls do 
not properly connect. To clean up 

most connections throughout the plan, select 
Build> Walls> Fix Connections. 

If you have only one connection to fix, the 

Connect Walls  edit button is faster to 
use.

Connect Walls
Use the Connect Walls edit button to 
complete an intersection of two walls. 

Select a wall, click the Connect Walls edit 
button, then click on the other wall to 
connect the two. 

If the unconnected wall ends are sufficiently 
close to one another, the tool connects them. 
If the separation is too great, extend one 
towards the other and try again.

Removing Wall Breaks

The Break Wall  tool allows you to break 
a wall into two or more separate wall 
segments. See “Break Wall” on page 189.

To merge two collinear walls separated by a 
break,select one of the segments, then click 
on the end edit handle located at the break 
and drag it a few plan inches (mm) away 
from the break. 

If the two walls do not merge, either one or 
both walls have been moved and they are no 
longer collinear, or one or both has been 
edited in some way and they are no longer 
identical. Open the Wall Specification 
dialog for each wall and determine how they 
differ. See “Wall Hatch Specification 
Dialog” on page 227.

Displaying Walls
While the structure and appearance of 
each wall type is controlled in the 

Wall Type Definitions dialog, the display of 
walls in all views is controlled in the Layer 
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Display Options dialog. See “Displaying 
Objects” on page 102.

If a “Walls” layer is turned off, any doors and 
windows placed in walls on that layer will 
not display, either. See “Displaying Doors” 
on page 257 and “Displaying Windows” on 
page 287.

In Floor Plan View
The appearance of each wall type, including 
line weights and colors and wall layer fill 
styles, is specified in the Wall Type 
Definitions dialog. See “Wall Type 
Definitions Dialog” on page 211.

There are also several options for controlling 
how walls are displayed in floor plan view. 
In the Layer Display Options dialog, you 
can specify whether or not various types of 
walls display. Walls are placed on layers with 
“Walls” at the beginning of the layer name, 
such as “Walls, Normal”. 

The display of the wall layers specified in the 
Wall Type Definitions dialog can be 
controlled. If you turn off the display of the 
layer called “Walls, Layers”, wall types 
display with two lines representing the inside 
and outside surfaces. 

In addition, you can turn off the display of 
non-structural layers and show only the 
walls’ Main Layers by turning on the display 
of the “Walls, Main Layer Only” layer. This 
allows you to create both fully configured 
walls and framing layouts. The “Walls, Main 
Layer Only” layer affects the display of walls 
in floor plan view only. See “The Main 
Layer” on page 209.

The “Walls, Thru Wall Lines” layer controls 
the display of lines indicating which walls 
build through at wall intersections. 

Foundation Walls have footings that display 
in floor plan view as long as the “Footings” 
layer is turned on. See “Displaying 
Foundations” on page 335. 

It is sometimes helpful to display the walls 
from a floor other than the current floor. To 
do this, select and display a reference floor. 
See “The Reference Floor” on page 327. You 
can also specify which layers are included in 
the Reference Display Layer Set in the Layer 
Display Options dialog. 

In 3D Views
As in floor plan view, the display of walls 
can be controlled by layer in the Layer 
Display Options dialog. 

Each layer of a wall is generated when you 
create a 3D view. You can see the different 

layers in 3D using the Delete Surface  
tool. See “Delete 3D Surface” on page 679. 

A wall’s framing layer displays as a solid 
layer rather than studs and plates until wall 
framing is built. See “Framing” on page 435. 
Wall framing is placed on the “Framing, 
Wall” layer by default. 

While most architectural objects in the 
program can display in both floor plan and 
3D views, a few cannot. Invisible walls and 
wall hatching are examples of objects that do 
not display in 3D.

Note: In floor plan view, railings not specified
as Solid display their Main Layer regardless
of whether “Walls, Layers” or “Walls, Main
Layer Only” is turned on. See “Wall Types
and Railings” on page 186. 
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Wall Materials
There are several ways that materials can be 
assigned to walls, depending on how the 
walls and the rooms they define have been 
defined. See “Rooms” on page 229. 

When you draw a wall, it uses the materials 
specified in its wall type definition. See 
“Wall Type Definitions” on page 209. 

You can change the surface material of an 
individual wall in the Wall Specification 
dialog. If you select “Use Default” as the 
material and the wall is used to define a 
room, the program refers to the material 
specified in the Room Specification dialog. 
See “Wall Specification Dialog” on page 
214.

You can also change a room’s wall material 
in the Room Specification dialog. See 
“Materials Tab” on page 635. To restore the 
default Wall Type material, select Use 
Default in the Select Library Object dialog. 
See “Select Library Object Dialog” on page 
622. 

When neither the wall nor the room has a 
material assigned to it, the program refers to 
the general material for walls in the Material 
Defaults dialog. See “Material Defaults” on 
page 650.

Displaying Pony Walls 
in Floor Plan View

Either the upper or lower portion of a pony 
wall can display in floor plan view. Only the 

portion that displays can be snapped to or 
aligned with walls above or below. See  
“Aligning Walls” on page 201.

By default, the upper portion of a pony wall 
displays in floor plan view. To show the 
lower pony wall in floor plan view instead, 
select Show Lower in Plan View in the 
Pony Wall Defaults dialog. See “Pony Wall 
Defaults” on page 178.

When Object Snaps  are enabled, you 
can only snap to the outer, inner and Main 
Layer surfaces of the part of the pony wall 
set to display. 

By default, windows and doors in pony walls 
are visible in floor plan view regardless of 
which part of the pony wall displays. You 
can, if you wish, select Hide Openings in 
Non-Displayed Parts of Walls in the Pony 
Wall Defaults dialog. 

In the Materials List
The materials that make up wall assemblies 
are listed under different Categories in the 
Materials List: 
• Siding - Lists all materials located outside 

of each wall’s Main Layer, such as siding, 
sheathing, and housewrap. 

• Framing - Lists the Main Layer material 
for all walls as well as railings specified 
as Solid. Non-framed walls’ Main Layer 
materials are also listed here when those 
walls are not specified as Foundation. 

Note: Wall materials that are specified on the
Materials tab of either the Wall or Room
Specification dialog are not calculated in the
Materials List.

Note: A window or door that is completely
contained by one part of a pony wall will dis-
play in floor plan view if the other part of the
pony wall is shown, but will display the wall’s
layer or Hatch Wall fill patterns through it.
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Wall framing, including studs, plates, and 
headers, is only counted when a wall’s 
Main Layer is a framing material and wall 
framing has been built. See “Framing” on 
page 435.

• Insulation - Insulation is calculated for 
all exterior walls that are not specified as 
Railing, regardless of the wall type defini-
tion. 

• Wallboard - Lists all materials located 
inside of each wall’s Main Layer, such as 
drywall. Includes all materials aside from 
framing, concrete,and rebar in walls that 
do not define rooms. 

Does not include Wall Coverings or mate-
rials specified in either the Room or Wall 
Specification dialog. See “Materials Tab” 
on page 223.

• Interior Trim - Lists base, crown and 
chair rail moldings, and Wall Covering 

materials specified in the Wall and Room 
Specification dialogs. See “Wall Cover-
ing Tab” on page 223.

• Foundation - Lists the concrete and rebar 
for all walls specified as Foundation as 
well as their footings. See “Foundation 
Walls” on page 183.

With the exception of wallboard, windows 
and doors are taken into account in the 
calculation of these totals.

Additional wall-related information is listed 
in the General category, including the total 
linear feet of each wall type per floor and the 
total heated wall area per floor.

A wall type’s Main Layer plays a central role 
in determining how - or whether - wall 
materials are calculated. For this and other 
reasons, correct Main Layer assignment is 
very important. See “The Main Layer” on 
page 209. 

Measuring Walls
Accurate wall measurements are an essential 
aspect of any drawing, and can be achieved 
by following two basic rules:
• Be aware of what part of a wall assembly 

dimensions are locating;
• Position walls using dimensions rather 

than edit handles or edit tools.

These rules can easily be met when you keep 
the following recommendations in mind.

Use Dimension Defaults
Manually-drawn and automatic dimensions 
can be set to locate walls at their Main 

Layers or at surfaces. Before drawing 
dimensions - and particularly, before using 
them to move your walls into position - make 
sure that your Dimension Defaults are set up 
to meet your needs. See “Dimension 
Preferences and Defaults” on page 719.

Be aware, too, that the wall length dimension 
that displays when a wall is selected as well 
as the Length specification in the Wall 
Specification dialog do not inherit their 
settings from the Dimension Defaults. 
Instead, they follow the Resize About line. 
See “Resize About” on page 202. 
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Edit Dimension Lines
Once a dimension line has been drawn, its 
extension lines can be edited to locate a 
number of locations on a wall assembly:
• The exterior surface
• The Wall Dimension Layer’s exterior
• The center line of the wall assembly
• The Main Layer’s center line
• The Main Layer’s interior
• The interior surface

See “Editing Extension Lines” on page 735. 

Moving Walls Using 
Dimensions

By far, the most precise method of 
positioning walls is using dimension lines. 
To produce accurate measurements, 
remember to:
• Be aware of what part of your walls is 

being located by each type of dimension.
• Avoid specifying dimension values with 

greater accuracy than your dimensions are 
set to display. See “Format Tab” on page 
722. 

See “Using Dimensions” on page 198.

Remember that the temporary wall length 
dimension that displays when a wall is 
selected may be set to locate a different part 
of the wall assembly than other dimension 
lines. See “Wall Length” on page 200. 

Use Object, Angle and 
Grid Snaps

Object Snaps, Angle Snaps, and Grid Snaps 
make it easier to align walls when they are 

being drawn as well as when they are edited. 
See “Snap Behaviors” on page 109. 

Object Snaps  help to ensure consistent 
wall connections and are particularly helpful 
when aligning collinear walls. 

When Grid Snaps  are enabled, walls are 
drawn on a regularly spaced grid, which 
helps avoid inaccurate wall placement. This 
can become particularly important if you 
forego positioning walls using dimensions in 
favor of using edit handles to move them. 

Angle Snaps  make it easy to accurately 
draw walls at regular angles, ensuring walls 
that are truly parallel or perpendicular to one 
another and separated by consistent 
distances.

No Locate
If a wall is specified as No Locate in the 
Wall Specification dialog, it will be ignored 

by Auto Exterior Dimensions  in floor 
plan view, as will any doors or windows 
placed in it.  By default, Railings, Deck 
Railings, and Invisible Walls are specified 
as No Locate. See “General Tab” on page 
214.

The No Locate setting also affects the 

behavior of Manual Dimensions , and 

End to End Dimensions , and Angular 

Dimensions . If a Manual or End to End 
Dimension is drawn between two No Locate 
walls, a dimension line will be created; 
however, if one of the walls is No Locate and 
one is not, no dimension line will be drawn. 

Angular Dimensions  do not recognize 
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No Locate walls under any conditions. See 
“Dimensions” on page 719.

If a wall is on its default layer and is speci-
fied as No Locate, it will be moved to the 
“Walls, No Locate” layer. If this box is later 
unchecked, the wall will return to its default 
layer. If a wall is on a non-default layer, it 

will remain there. See “Displaying Walls” on 
page 192. 

Once a dimension line has been created, it 
can be edited so that it locates a No Locate 
wall or railing that is perpendicular to it. 

Angular Dimensions  cannot be edited in 
this manner and are the exception to this 
statement. See      Editing Dimension Lines. 

Editing Walls
Walls can be selected individually and as a 
group in all views. When a wall is selected, it 
displays edit handles and an edit toolbar that 
can be used to edit it in various ways. When 
a wall is selected, temporary dimensions may 
also display. See “Display Temporary 
Dimensions” on page 731. 

The ways in which a wall can be edited 
depends on the current view and which edge 
is selected. See “Selecting Objects” on page 
124. 

Selecting Walls
• When you try to select a wall in a cross 

section/elevation or 3D view, the interior 
or exterior room that it defines may be 
selected first. Click the Select Next 

Object  edit button or press the Tab 
key on your keyboard to select the wall 
itself. See “Selecting Rooms” on page 
231.

You can specify that the wall be selected 
first instead of the room in the 
Preferences dialog. See “Appearance 
Panel” on page 61. 

• In floor plan view, if wall hatching has 
been applied to a wall using the Hatch 

Wall  tool, the hatching may be 
selected first. Click Select Next 

Object  to select the wall itself. See 
“Hatch Wall” on page 188.

• The Edit Area  tools allow you to 
select only part of a wall or walls. See 
“Edit Area Tools” on page 168.

Using the Edit Handles
Depending on the type of view, a wall 
displays a different set of edit handles when 
selected. 
• In floor plan view, straight and curved 

walls can be edited like other line- and 
arc-based objects. See “Editing Line 
Based Objects” on page 127 and “Editing 
Arc Based Objects” on page 130.

• In floor plan view, a wall’s edit handles 
display along its Resize About line. See 
“Resize About” on page 202.

• In a camera view or overview, click on the 
top surface of a wall to display the same 
edit handles as in floor plan view, allow-
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ing you to rotate, move, and extend or 
shorten the length of the wall. 

• Moving a wall in any view will move any 
cabinets attached to that wall, as well.

• In a cross section/elevation view, the top 
and bottom edges of straight and curved 
walls can be edited like closed polylines. 
See “Editing Closed-Polyline Based 
Objects” on page 138. Only the top and 
bottom edges of walls can be broken, 
angled or curved: the side edges cannot.

• In a camera view or overview, click on an 
interior or exterior surface to display the 
same edit handles as in an elevation view: 
one at each corner and one on the top and 
bottom edges.

• When a wall is connected to other walls 

and Edit Object Parts  is turned off, it 
can only be moved perpendicular to itself 
or, in the case of curved walls, perpendic-
ular to its chord using the Move edit han-
dle. Unconnected walls can be moved at 
Allowed Angles.

• The footings of Foundation Walls and 
Slab Footings can be selected in 3D views 
and edited using the edit handles. See 
“Footing Width and Height” on page 337. 

• The Same Wall Type edit handles can be 
enabled, allowing you to draw a new wall 
segment of the same type as the selected 
wall. 

Same Wall Type 
Edit Handles

When the Same Wall Type edit handles are 
enabled, two edit handles display just beyond 
a selected wall’s Extend edit handles in floor 

plan view or when the top edge of the wall is 
selected in a 3D view.

Click and drag a Same Wall Type edit 
handle at any angle to draw a new wall 
segment of the same type as the selected 
wall. 

To temporarily enable the Same Wall Type 
edit handles, select a wall and click the Same 

Wall Type  edit button.  You can also 
enable these handles globally in the 
Preferences dialog. See “Architectural 
Panel” on page 73. 

In the Specification Dialog
The appearance and structure of walls 
can be customized in the Wall 

Specification dialog. See “Wall 
Specification Dialog” on page 214.

The characteristics of the roof directly above 
a selected wall can also be specified in the 
Wall Specification dialog. See “Roof Tab” 
on page 218.

Using the Edit Tools
A selected wall or walls can be edited in a 
variety of ways using the buttons on the edit 
toolbar. See “The Edit Toolbar” on page 29.

Same Wall Type edit handles
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The characteristics of the roof directly above 
a selected wall can also be specified in the 
Wall Specification dialog. See “Roof Tab” 
on page 218.

Using Dimensions
Automatic, manually-drawn, and 
temporary dimension lines can be 

used to both resize and move walls with 
accuracy. Select a wall, then click on a 
dimension line that locates it and type in the 
value that you need. See “Moving Objects 
Using Dimensions” on page 737.

When a wall is resized using dimensions, the 
inline text field used to edit the dimension 
will have three unique buttons: Move Start, 
Move End, and Move Both Ends. Choose 
the option that you want to use before 
pressing the Enter key.

If both ends of the selected wall intersect 
walls that are not parallel to one another, a 
fourth option will be available: Move Along 

Rails . When this option is used, the 
selected wall both resizes and changes 
position so that it remains connected to the 
other walls when you press the Enter key.

Depending on your Dimension Defaults 
settings, manual and/or automatic dimension 
lines may locate wall surfaces or wall 
dimension lines. See “Locate Objects Tab” 
on page 723.

Wall Thickness
The initial thickness of a wall is determined 
by its wall type definition. You can change a 
wall’s thickness by modifying the definition 
of it’s wall type. If you do this, all instances 
of the wall type used in the plan will be 
affected - not just an individual object. See 
“Wall Type Definitions” on page 209. 

You can also specify a selected wall’s 
thickness in its Wall Specification dialog. 
See “General Tab” on page 214. 

If a selected wall’s thickness is changed: 
• A copy of the wall’s wall type is created 

with the same name but appended with a 
number equal to the thickness of the Main 
Layer, and that new type is assigned to the 
wall. See “The Main Layer” on page 209.

Move Both Ends

Move Start       Move End

Dimension Defaults and Temporary
Dimension Preferences settings can

have a significant effect on wall position. It is
recommended that you review these settings
and make sure that they meet your needs.

 Move Along Rails resizes 
and moves a selected wall.
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• The change in thickness will be applied to 
new wall type’s Main Layer. 

• The Main Layer must be at least 1/16” 
thick, and the wall’s thickness cannot be 
less than the original wall type’s total 
thickness minus the thickness of its Main 
Layer.  

If a wall type’s thickness is modified, the 
wall will resize about the Resize About line 
specified in the General Wall Defaults 
dialog. In some instances, the wall may 
appear to move as a result of changes made 
to the thicknesses of its layers. See “General 
Wall Defaults” on page 176. 

Wall Heights
The height of a wall is controlled by the 
ceiling height of the room(s) it defines. If the 
ceiling or floor height of a room is changed, 
the height of the walls that define it also 
change. 
• The initial ceiling height for all rooms on 

a floor is set in the Floor Defaults dialog 
for that floor. See “Floor Defaults” on 
page 230. Whenever possible, it is best to 
set all ceiling heights using the default.

• The ceiling height of a single room can be 
set in its Room Specification dialog. See 
“General Tab” on page 244.

• The default Floor and Ceiling Heights for 
a given floor can be adjusted by editing 
the top and/or bottom edges of the Exte-
rior Room in a 3D view. See “The Exte-
rior Room” on page 232. 

• If the wall height of the Exterior Room is 
adjusted in a 3D view, the default Floor or 
Ceiling Height of the entire floor is 
changed. See “The Exterior Room” on 
page 232.

• The top or bottom edge of any wall can be 
adjusted independent of floor or ceiling 
heights using the mouse in Cross Section/
Elevation and 3D views. Top and bottom 
edges can also be stepped and raked. See 
“Stepped and Raked Walls” on page 207.

• The edge dividing an upper and lower 
pony wall can be edited in Cross Section/
Elevation and 3D views. In addition, its 
height can be defined in the Wall 
Specification dialog. See “Wall Types 
Tab” on page 221. 

Wall Length
Wall length can be modified in several 
different ways: 
• Using dimensions. See “Measuring 

Walls” on page 195.
• In the Wall Specification dialog. See 

“General Tab” on page 214.
• By dragging the end edit handles. See 

“Editing Line Based Objects” on page 
127 and “Editing Arc Based Objects” on 
page 130. 

Bear in mind that if you try to resize a wall 
by a small amount using one of its edit 
handles and that wall is connected to another 
wall at that end, its length will not change 
because its end will snap back to the existing 
intersection. See “Connecting Walls” on 
page 191. 

The most accurate way to specify wall length 
is using dimensions. By default, wall length 
is measured at the outside edge of the Main 
Layer. You can instead specify that manual 
and/or automatic dimension lines locate 
surfaces in the Dimension Defaults dialogs. 
See “Dimension Preferences and Defaults” 
on page 719.
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Be aware that the wall length dimension that 
displays when a wall is selected as well as 
the Length specification in the Wall 
Specification dialog do not inherit their 
settings from the Dimension Defaults. 
Instead, they follow the Resize About line. 
See “Resize About” on page 202. 

Editing Straight/Curved Wall Combinations
If you move a straight wall connected to a 
curved wall with a locked center and the 
connection cannot be maintained without 
changing the center of the arc, the walls lose 
their connection. 

When an Extend edit handle of a curved wall 
with a locked center is dragged with the 

Alternate  Edit Behavior active, the 

locked center setting will be overridden. See 
“Edit Behaviors” on page 120. 

If you move a straight wall connected to a 
curved wall with a locked center, the curved 
wall extends along its curve and the straight 
wall will either lengthen or shorten as needed 
to stay connected to the curved wall. 

If the connection between the straight and 
curved wall cannot be maintained because of 
the curved wall’s radius, it will be broken.

Aligning Walls
Wall alignment refers to the way wall 
segments line up with one another, either on 
the same floor or on the floor above or 
below.  Walls may need to be aligned in a 
variety of situations.

To make alignment easier when drawing or 
resizing walls, “sticky” points and extension 
lines identify points that are either collinear 
or orthogonal to the end points of other 
walls. See “Extension Snaps” on page 111. 

Note: By default, dimensions and the Resize
About line all use the exterior edge of the
Main Layer. When Resize About is set to use
a different location, dimension lines may not
agree with a wall’s length specification. See
“Measuring Walls” on page 195. 
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Resize About
The Resize About line specified in the 
General Wall Defaults dialog controls two 
important aspects of wall alignment:
• What part of a wall retains its position 

when its wall type or wall type definition 
is changed. See “Wall Type Definitions” 
on page 209.

• Where walls snap together to form an 
intersection. See “Connecting Walls” on 
page 191.

The Resize About line is the line along 
which a selected wall’s length is measured in 
the Wall Specification dialog. See “Wall 
Length” on page 200. 

The Resize About line is also the line along 
which a selected wall’s edit handles display, 
and is the line along which any snap points 
will be located. See “Editing Walls” on page 
197. 

Aligning Collinear Walls
Collinear walls are parallel walls connected 
end to end and drawn on the same floor. 
When collinear walls join end-to-end, the 
walls snap together. If these walls have the 
same wall type and identical specifications, 

and if Object Snaps  are enabled, they 
will merge to become a single wall segment.

Creating a Nook
Walls can be aligned across an opening such 
as a nook, so that they are collinear, using the 

Break Wall  tool. 

To align walls across  a gap

1. Select a wall to build a nook into and 

click the Break Wall  edit button. 
2. Click at a point on the wall close to one 

side of the nook area. Do not worry 
about exact placement right now. 

3. Click again near the other side of the 
nook. Two short lines at each location 
where you clicked indicate Wall Breaks. 

4. Right-click the middle section of the 
wall to select the wall section. 

5. Click the middle Move handle and drag 
the wall outward. 

6. Draw side walls to connect the wall back 
to the rest of the house. 

7. Move these short walls using dimen-
sions to accurately size the nook. 

Aligning Walls 
Between Floors

Walls can be aligned between floors by 

clicking the Align With Wall Above  and 

Align With Wall Below  edit buttons.

Place Wall 
Breaks here

Position these 
walls as needed



Aligning Walls

 203

By default, walls on different floors are 
aligned by the outer edges of their Main 
Layers. See “The Main Layer” on page 209.

To align walls between floors

1. Select a wall that you want to align with 
another wall either above or below it.

2. If the wall is above or below the other 
wall along only part of its length, you 
must click on it along that part. Select 
Tools> Reference Floors> Reference 

Display On  to help make sure you 
click on the correct part of the wall.

3. When you have selected the wall at the 
desired location, click either the Align 

With Wall Above  or Align With 

Wall Below  edit button.

Aligning Curved Walls 
Between Floors

Curved walls are aligned between floors 
using the same technique to align straight 
walls. If the centers and radii of the walls are 
within a few inches of each other, the Align 

With Wall Above  and Align With Wall 

Below  edit buttons are enabled for the 
selected wall. The selected curved wall will 
take on the radius and center of the 
referenced wall when the walls are aligned.

Aligning Pony Walls 
Between Floors

When aligning a pony wall with either the 
wall above or below:

• Align With Wall Below  will always 
align the lower pony wall with the wall 
below, as specified in the lower pony 
wall’s Wall Type Definition. See “Wall 
Type Definitions” on page 209.

• Align With Wall Above  will always 
align the upper pony wall with the wall 
above, as specified in the upper pony 
wall’s Wall Type Definition. 

Aligning Railing on 
Different Platforms

Two collinear Railings or Deck Railings on 
the same floor can be aligned one above the 
other when they define rooms with different 
floor heights.

To align railing on different platforms

1. Click and drag to draw a Railing or 
Deck Railing that divides a room such as 
a deck in two.

2. Click the Select Objects  button, 
then click in one of the room areas.

3. Click the Open Object  edit button, 
and on the General tab of the Room 
Specification dialog:

In order for these edit tools to be avail-
able, the areas of the walls in question

must be partially aligned, or overlapping.



204

Home Designer Pro 2014 Reference Manual

•  Specify a Floor Height that differs 
from that of the other by at least the 
height of the railing, then click OK.

•  The default railing height is 36”, so for 
best results the Floor Height should be 
changed by at least this amount.

4. Click on the railing drawn in step 1, then 

click the Open Object  edit button. 
On the Rail Style tab of the Railing or 
Deck Railing Specification dialog, 
check Generate on Low Platform. See 
“Rail Style Tab” on page 224. 

5. Click and drag a second railing parallel 
to the one drawn in step 1.

6. Select this second railing and click the 

Open Object  edit button. On the 
General tab of the Railing or Deck 
Railing Specification dialog, check the 
box beside No Room Def and click OK. 

7. With the railing still selected, Ctrl + drag 
it into the same position as the first rail-
ing. See “To move an object freely” on 
page 153.

Roof Directives in Walls
To automatically generate a roof plane using 
values other than the defaults or to not 
generate a roof plane bearing on a particular 
wall (as for a gable or the sides of a shed 
roof), you can change the settings in the Wall 
Specification dialog. See “Roof Tab” on 
page 218. 

Hip, Gable, and Shed Roofs
By default, the program will produce a roof 
plane over each exterior wall to create a hip 
roof. You can instead specify a gable or shed 
roof above the selected wall. 
• Check Full Gable Wall to create a gable 

with a ridge centered above the selected 
wall(s).

• Check High Shed/Gable Wall for the 
side walls or the wall under the high side 
of a shed roof.  

• You can also select a  wall and click the 

Change to Gable Wall(s)  edit button, 

or change it back by clicking the Change 

to Hip Wall(s)  edit button. 

Pitch
The default pitch for roof planes is set in the 
Build Roof dialog. However, any exterior 
wall can define the pitch of the roof plane 
built above it.

You can also specify a second, upper pitch 
above a given wall. Mansard, gambrel, gull 
wing and half-hip are examples of roof styles 
that use two pitches. See “Roof Tutorial” on 
page 69 of the User’s Guide.

Overhangs and Roof Returns
You can specify the overhang of the roof 
plane to be generated above the selected 
wall. This setting only takes effect when 
Same Height at Exterior Walls is unchecked 
in the the Build Roof dialog, which is also 
where the default Overhang value is set. 
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Check Auto Roof Return to generate roof 
returns on the selected wall. In most cases, 
roof returns only generate on Full Gable 
Walls. See “Roof Returns” on page 393.

Extend Slope Downward
Check Extend Slope Downward to extend 
the roof plane downward over a bumpout, 
instead of creating additional roof planes. 
The two connecting walls that create the 
bumpout must be Full Gable walls.

In the following image, the bearing wall of 
the bumpout has Extend Slope Downward 
checked. The two short side walls are Full 
Gable Walls. 

Clerestory and Dormer Walls
Occasionally, walls are built between two 
roof planes rather than between a roof plane 
and a floor platform. Common examples 
include clerestory walls and the side, or the 
cheek, walls of floating dormers.

Check Roof Cuts Wall at Bottom to have 
the bottom of the selected wall clipped by the 
roof plane below, as where a floating dormer 
wall meets the main roof plane.

Exterior/Interior Pony Walls
It’s not uncommon for an individual wall to 
be an exterior wall near its top, and an inte-
rior wall near its bottom. 

Before

After

Full Gable 
Wall

Extend Slope 
Downward

Clerestory wall built between two roof planes
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Check Lower Wall Type If Split By Butt-
ing Roof to achieve this. When this option is 
checked, the selected wall is specified as a 

pony wall and a second, lower wall type can 
be specified. Unlike with other pony walls, 
the change in wall type occurs wherever a 
roof plane builds to the exterior of the wall. 
See “Pony Walls” on page 184. 

Attic Walls
In Home Designer Pro, walls are built 
between the floor and ceiling platforms of 
the current floor.  See “Floor & Ceiling 
Heights” on page 239. When the program 
detects an open space between a wall and the 
roof plane above it, it automatically creates 
an Attic Wall on the floor above that wall to 
fill in the gap. 

Attic Walls are typically found above Full 
Gable Walls, forming a gable or closing the 
top portion of a side wall of a shed roof. 
They are also generated above all exterior 
walls when the Raise Off Plate value in the 
Build Roof dialog is 3” (175 mm) or greater. 
See “Build Roof Dialog” on page 355. 

Attic walls are often found on the Attic floor, 
but can be generated on other floors, as well. 
See “The Attic Floor” on page 327. 

You can eliminate an existing Attic wall by 
combining it with the wall below it. To do 
this, select Combine with Above Wall in the 
Wall Specification dialog for the wall below. 
See “Roof Tab” on page 218.

Attic Walls are specified as such in the Wall 
Specification dialog. If needed, you can 
specify a regular wall as an Attic Wall. See 
“General Tab” on page 214.

When you Rebuild Walls/Floors/

Ceilings , all Attic Walls in the plan are 
deleted and rebuilt.

Knee Walls
Knee Walls are a bit like Attic Walls in that 
they are not meant to generate to full ceiling 
height. Instead, they build upward until they 
encounter a roof plane. Unlike Attic Walls, 

Upper Wall 
Type

Lower 
Wall Type

Lower Wall Type If Split By Butting Roof
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however, Knee Walls are used in the interior 
of a structure, typically to separate unused 
areas from rooms on the upper floor of a 
story-and-a-half structure. See “Room 
Types” on page 234.

Home Designer Pro does not specify walls as 
Knee Walls automatically. If an interior wall 
is drawn in a location where the roof is lower 
than the ceiling height, you should specify it 
as a Knee Wall in the Wall Specification 
dialog. See “Roof Tab” on page 218.

Stepped and Raked Walls
Stepped and raked walls can be created using 

the Break Line  tool and the wall’s edit 
handles in any 3D or Cross Section/Elevation 
view. In many cases, working in a Back-

clipped Cross Section  is easiest and 
allows the greatest accuracy.

Stepped Walls & Footings
A typical example of stepped walls is a 
stepped foundation with pony walls. In the 
illustration below, the lower part of the pony 
wall is the concrete wall with footing, and 
the upper part of the pony wall is a framed 
wall with brick siding built to the first floor 
platform. See “Pony Walls” on page 184. 

To add a step to a wall

1. Select the wall in a Backclipped Cross 

Section  view. 

2. Click the Break Line  tool, then 
click the top or bottom edge of the wall 
to place the break. 

3. In addition to the corner handles, two 
handles display along the broken edge. 

4. Select one of these two handles, and 
drag up or down.

5. A square step is created.

The vertical edges of a wall cannot be 
broken, although they can be raked as well as 
moved side to side.

By default, a stepped foundation wall  
displays an “S” symbol at the location of 
each step in floor plan view. The display of 
this “S” is controlled in the Foundation 
Defaults dialog. See “Foundation Tab” on 
page 331.

Raked Walls
A raked wall has an angled top or bottom 
edge. 

When you try to select a wall in a 3D
view, the interior or exterior room that it

defines may be selected first. Click the Select
Next Object edit button to select the wall
itself. See “Selecting Walls” on page 197. 
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To create a simple raked wall

1. Select the wall in Cross Section/Eleva-
tion or 3D view. 

2. Click one of the corner edit handles and 
drag that handle either up or down. 

3. To rake a wall at a specific angle, you 
can: 

•  Use Angle Snaps  and Allowed 
Angles. See “Angle Snaps” on page 
111.

•  ,Draw a CAD Line  at the desired 
angle and use the Make Parallel/

Perpendicular  edit tool. See 

“Using Make Parallel/Perpendicular” 
on page 155. 

Compound Raked Walls
A compound raked wall is a wall that has a 
top or bottom edge with multiple angles. 

To create a compound raked wall

1. Select the wall in Cross Section/Eleva-
tion or 3D view. 

2. Use the Break Line  tool to add 
breaks to the wall edge, as for a stepped 
wall. 

3. Select a segment of the edge and adjust 
its angle, as for a raked wall. 

CAD to Walls
The CAD to Walls tool can be used to 
convert CAD lines in floor plan view 

into architectural objects. Two or more 
parallel CAD lines can be converted to both 
straight or curved walls or rails. CAD lines 
representing windows and doors can also be 
converted. 

All lines that you want to convert to walls 
must be located on one layer. The same is 
true for windows, doors, and rails. See 

“Layer Display Options Dialog” on page 
104. 

To convert the lines of an imported drawing 

using CAD to Walls , map its layers in 
the Import Drawing Wizard. Do not check 
“Boxes” or “Polylines”. See “Select File” on 
page 830. 

When CAD objects are located properly, 

select CAD> CAD to Walls  to display 
the CAD to Walls dialog.
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Convert CAD to Walls Dialog

Specify wall types for the new walls. One, 
two, or neither can be specified. 

To convert to a specific wall type, the lines 
must be within one inch or 25mm of that wall 
type’s width. If two wall types are specified, 

new walls are converted to the one having 
the closest width. The new wall expands or 
contracts about its centerline to reach the 
width of the wall type. Typically, only two 
wall types are used in a plan and an interior 
and exterior wall type are specified.

Conversion works better if lines representing 
windows and doors are on different layers, 
although it may still be satisfactory if they 
are on the same layer. In either case, the arc 
indicating door swing helps to identify a door 
and should be placed on the same layer as 
doors.

Click OK to complete the conversion. 
Converted items are found in the Layer 
Display Options dialog.

Wall Type Definitions
Every wall drawn in a plan is assigned a wall 
type, and its Wall Type Definition determines 
its structure, its appearance in floor plan 
view, and its default materials. 

Material information in the Wall Type 
Definition can be calculated for take-offs in 
the Materials List. See “Materials Lists” on 
page 887.

Wall types can be viewed, edited and created 
in the Wall Type Definitions dialog. See 
“Wall Type Definitions Dialog” on page 211. 

Walls can have up to ten layers defined, each 
representing a different material. All of these 
layers can be calculated in the Materials List. 
Materials that are applied to the outer layers 
of the wall type definition also determine  the 
wall’s appearance in 3D views.

You can specify the default wall types used 
when walls are first created, and can specify 
the wall type of any wall after it is drawn in 
the Wall Specification dialog. See “Wall, 
Railing, and Fencing Defaults” on page 176 
and “Wall Types Tab” on page 221.

The Main Layer
In most circumstances, the Main Layer 
should be specified as the structural layer of 
the wall, particularly when the wall is a 
framed type. The Main Layer determines 
many things, including:
• Floor and ceiling platforms and automati-

cally built foundation walls normally 
build to the outer edge of the Main Layer.
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• At intersections, walls join at the interior 
surfaces of their Main Layers. See “Con-
necting Walls” on page 191. 

• Exterior walls on different floors are 
aligned by the exterior edges of their 
Main Layers. 

• Roof baselines are placed at the outer 
edge of the Main Layer when roofs are 
automatically generated. See “The Base-
line” on page 363.

• Roof base lines and gable/roof lines that 
are manually drawn snap to the edge of 
this layer. 

• When wall framing is generated, stud 
depth is based on the thickness of each 
wall’s Main Layer.

• By default, walls resize about the exterior 
surface of their Main Layer when their 
wall type or Wall Type Definition is 
changed. See “Resize About” on page 
202. 

• By default, Object Snaps  locate the 
exterior surface of a wall’s Main Layer. 
See “Object Snaps” on page 110. 

All of this information is reliant on the Main 
Layer, so creating your wall type definitions 
accurately beforehand and specifying the 
Main Layer is very important.

The Dimension Layer
Dimension Defaults can be set to locate walls 
at their surfaces or at the exterior line of their 

Wall Dimension Layer. See “Locate Objects 
Tab” on page 723. 

The Main Layer is the default Wall 
Dimension Layer for installed wall types; 
however, this can be changed if need be in 
the Wall Type Definitions dialog. In addition 
to the Wall Dimension Layer, the program 
will locate the inside surface of the Main 
Layer, as well. 

Whether Surface or Wall Dimension Layer is 
selected on the Locate Objects tab of the 
Dimension Defaults dialog determines a 
number of aspects related to how dimensions 
locate walls:
• How Auto Exterior and Manual Dimen-

sions measure the lengths of walls.
• Where both Manual and Automatic Reach 

are measured from.
• Where Extension line lengths and their 

Gap From Marked Object are measured 
from.

• Where First Line Offset for Auto Exte-

rior Dimensions  is measured from.
• How the minimum enclosed area required 

by Auto Exterior Dimensions  is 
measured.

The settings on the Locate Objects tab 
control how dimensions initially locate 
walls. Once a dimension line has been 
created, you can move its extension lines or 
add new extensions to locate other points 
along a wall’s assembly. See “Measuring 
Walls” on page 195.

Interior and Exterior Surfaces
Every wall has an interior and exterior 
surface - including walls in a plan that are 

Wall framing will only generate in a wall
when a Framing material such as Fir

Stud 16” OC or Metal Stud 24” OC is speci-
fied for its framing layer. See “Material Types”
on page 640.
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recognized by the program as being interior 
walls. See “Exterior and Interior Walls” on 
page 183.

Having separate designations for a wall’s two 
surfaces allows you to specify different 
materials for each in the Wall Specification 
dialog. See “Materials Tab” on page 223.

In the Wall Type Definitions dialog, the 
exterior surface is shown at the top of the 
wall assembly diagram. In floor plan view, 
you can identify a selected wall’s exterior 
surface by the location of its edit handles, 
which display on the exterior of the Main 
Layer by default. See “Resize About” on 
page 202.

Legacy Wall Types
In Home Designer Pro version X2 and prior, 
generic, single-layer wall types were used as 
the default for railings, deck railings and 
fencing. In the earliest program versions, 
they were the defaults for walls, as well. 
• In Home Designer Pro X1 and prior, there 

were two such wall types: “Default (wood 
frame 16”OC)” and “Default (concrete)”. 

• In Home Designer Pro X2, these two wall 
types were replaced by one named 
“Adjustable Thickness Wall”. 

When plans that include either of these wall 
types - in the drawing itself or set as a default 
- are opened in Home Designer Pro 2014, the 

legacy wall type is replaced by a new wall 
type named “Wall-X”, where X is the 
thickness of the wall’s Main Layer, rounded 
up. There are a few exceptions:
• If legacy wall types with the same thick-

ness but different materials are found, 
they use the same naming convention 
appended with and additional _X. 

• If a wall using a legacy wall type is speci-
fied as a Foundation wall, the resulting 
wall type will be named “Foundation 
Wall-X”. 

• If a legacy wall type has the same attri-
butes as a wall type installed with Home 
Designer Pro 2014, such as 8” Concrete 
Stem Wall, it will be replaced by that wall 
type. 

Unless a wall is specified as a Foundation 
wall, Deck Railing, or Fencing, it will be 
treated as a framed wall and its new wall type 
will acquire two additional 1/2” (13 mm) 
thick wall layers: an interior and an exterior 
layer. These new layers will use the interior 
and exterior materials of the original wall. 
The wall’s original layer will maintain its 
original thickness, acquire a framing 
material, and will become the new wall 
type’s Main Layer.

Foundation, Deck Railing, and Fencing wall 
types converted in this manner will continue 
to have only one layer.

Wall Type Definitions Dialog
The Wall Type Definitions dialog is 
used to define new wall types and 

redefine existing wall types in the current 

plan file. Select Build> Wall> Define Wall 
Types to open this dialog. 

You can also click the Define button on the 
Wall Types tab of the Wall Specification or 



212

Home Designer Pro 2014 Reference Manual

in most Wall Defaults dialogs. See “Wall 
Types Tab” on page 221.

Changes made to an existing wall type 
definition affect all walls in the current plan 
using that wall type. Walls in other plan files 
are unaffected.

If changes to a wall type affect its thickness, 
the position of any walls in the plan using 
that wall type may be affected. See “General 
Wall Defaults” on page 176.

Manage the list of wall types available 
in the current plan.

• Click this drop-down list to display all 
available wall types in the current plan. 
Select a wall type from the list to display 
its definition. You can rename a wall type 
by typing in a new name. 

• To create a new wall type, click New to 
define a new wall type from scratch or 
click Copy to copy the current wall type. 
A copied wall type can then be renamed 
and redefined. 

• To remove a wall type, select it and click 
Delete. Wall types currently being used in 
your plan or set as plan defaults cannot be 
deleted.

1

2

4

3

5

7

6

1
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The selected wall type’s layers are 
listed here. 

• Wall layers are numbered and are listed 
from exterior at the top to interior at the 
bottom. 

• If the selected wall type has multiple wall 
layers, select a radio button to specify the 
Main Layer. The Main Layer is usually 
the structural layer and is often thicker 
than other layers.

• Define the Thickness for each wall layer. 
Very thin layers can be created, but for 
best results, avoid using a thickness of 0. 
The number format can be changed by 
clicking the Num Style button. 

• To select a layer for editing, click in its 
Layer Thickness text field. The arrow to 
the right of the wall assembly diagram 
points to the selected layer, while the 
arrow to the left of the diagram points to 
its exterior surface.

Manage the layers associated with the 
selected wall type definition. 

• The TOTAL thickness of the wall type 
definition displays here. If you change 
this value, the thickness of the Main 
Layer automatically updates to account 
for the difference.

• Click the Insert button to create a new 
layer directly above the selected layer in 
the wall type definition. 

• To insert a layer at the bottom, or interior, 
of the wall type definition, click on the 

bottom line in the wall assembly diagram 
and then click the Insert button. 

• Click Delete to remove the selected layer 
from the wall type definition. 

Specify the attributes of the selected 
Wall Line. Wall Lines define the 

extents of the layers in the wall assembly 
diagram at the bottom of the dialog. To select 
a Wall Line for editing, simply click on it in 
the diagram. The arrow to the left of the 
diagram points to the selected line. 
• Define the Color, Style, and Weight for 

the selected Wall Line. 
• Check By Layer if you want the line to 

assume the attributes of the wall’s layer as 
defined in the Layer Display Options 
dialog. See “Displaying Objects” on page 
102. 

• Check Build Platform to This Line to 
build floor and ceiling platforms to the 
selected Wall Line. This option can only 
be selected for one Wall Line at a time. 
By default, this option is checked for the 
exterior side of the Main Layer. 

• Check Dimension to This Line to have 
dimensions locate the selected Wall Line. 
This option can only be selected for a sin-
gle wall layer, and can only be selected 
for the Main Layer or a layer located 
between the Main Layer and the exterior 
surface. By default, this option is checked 
for the Main Layer. Does not affect Inte-
rior Dimensions. See “The Dimension 
Layer” on page 210.

You can also select a wall layer by
clicking on it in the wall assembly dia-
gram at the bottom of the dialog.

2

3 Note: If Floor Platform to This Line is checked
for the exterior surface line of the wall type,
no siding material will generate to cover the
floor platform. 

4
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Specify the Layer Material for the 
selected wall layer, which is calculated 

in the Materials List, as well as the layer’s fill 
pattern, which displays in floor plan view. 
• Click the Library Material button or 

either of the two material preview boxes 
to open the Select Library Object dialog 
tand choose a material for the selected 
wall layer. See “Select Library Object 
Dialog” on page 622.

• Click Plan Materials to open the Plan 
Materials dialog and choose a material 
for the selected wall layer. See “Plan 
Materials Dialog” on page 642. 

• Click the Fill Style button to open the 
Layer Fill Style dialog and specify a fill 
style for the selected wall layer. This dia-
log is similar to the Fill Style tab for CAD 
objects. See “Fill Style Tab” on page 792. 

• Wall layer fill styles are overridden if you 

use the Hatch Wall  tool on a wall in 
floor plan view. 

An assembly diagram of the selected 
wall type definition displays here. Any 

changes made in this dialog display in the 
diagram, which illustrates how the wall dis-
plays in floor plan view. See “Displaying 
Walls” on page 192.
• The arrow to the left of the diagram points 

to the selected Wall Line. Wall Lines 
define the extents of each wall layer. To 
select a Wall Line, simply click on it.

• The arrow to the right of the wall assem-
bly diagram points to the selected layer. 
To select a layer, click on a layer in the 
diagram or click in its Thickness field.

Click the Num Style button to open the 
Number Style/Angle Style dialog. 

Here you can change the numbering format. 
See “Number Style/Angle Style Dialog” on 
page 89.

Wall Specification Dialog
To open the Wall Specification 
dialog, select a wall or group of walls 

and click the Open Object edit button. 

The tabs of the Wall Specification dialog are 
also found in the Railing, Deck Railing, and 
Fencing Specification dialogs. See “Railing 
and Fencing Specification Dialogs” on page 
224. 

The settings in this dialog are also similar to 
those in the various Wall Defaults dialogs. 
The settings in these defaults dialogs 
determine the initial characteristics of 
railings, deck railings and fencing when they 
are first drawn. See “Wall, Railing, and 
Fencing Defaults” on page 176.

General Tab
The settings on the General tab determine the 
basic use of the selected wall, as well as its 
length, angle, and other attributes.

5 6

7
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Some items on the General tab are available 
only when they apply to the selected wall(s) 
or railing(s).

The Thickness of the selected wall 
displays and can be changed here. If the 

wall is a Post to Overhead Beam railing, this 
setting also affects the width of the beam. 
See “Wall Thickness” on page 199. 

Check Foundation to specify the 
selected wall as a foundation wall. 

More foundation wall settings are available 
on the Foundation tab.

Check Railing to specify the selected 
wall as a railing. More railing settings 

are found on the Railing and Newels/
Balusters tab. 

 Specify the Wall Angle and Wall 
Length of a straight wall. These 

options are not available for curved walls.

• Wall Angle - The current absolute angle 
of the wall in a floor plan view is shown. 
Type in a new angle to rotate the wall 
about its locked point. See “3D Drafting” 
on page 25.

• Wall Length - The current length, as 
measured along the Resize About line, is 
shown. Type in a new length. The part of 
the wall that extends or contracts is deter-
mined by where it is locked. See “Resize 
About” on page 202. 

Select a radio button to Lock the 
selected straight wall at its Start, End or 

Center. When the Wall Angle or Wall 
Length of the selected wall is changed, this 
point along the wall does not move. Not 
available for curved walls. 

Check any of the Options to modify the 
selected wall accordingly. In most 

cases, multiple options can be selected.
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• Check Invisible to specify the wall as 
invisible. Invisible walls can display in 
floor plan view but not 3D views and are 
used to divide rooms areas not separated 
by a wall or railing. Unless the wall is on 
a non-default layer, it will be moved to 
the “Walls, Invisible” layer when this box 
is checked. See “Invisible Walls” on page 
187.

• Check No Room Def. to display the wall 
in floor plan and/or 3D views but not cre-
ate room definition. See “Room Defini-
tion” on page 231. 

• Check No Locate to prevent Auto Exte-

rior Dimensions  from locating the 
wall in floor plan view. See “No Locate” 
on page 196.

• Check Attic Wall to prevent the wall 
from extending through the roof above. 
Unless the wall is on a non-default layer, 
it will be moved to the “Walls, Attic” 
layer when this box is checked. See “Attic 
Walls” on page 206.

• Automatic Wall displays for reference 
and is checked whenever the selected wall 
was generated by the program. Typically, 
automatic walls are also Attic walls.

• Select Terrain Retaining Wall to treat 
the wall as a terrain retaining wall. See 
“Retaining Walls” on page 550. 

Radius To - This section is only active 
for curved walls and controls the 

definition of the curved wall radius.
• Select Outer to define the radius from the 

center of the curved wall to the outer sur-
face of the wall.

• Select Inner to define the radius from the 
center of the curved wall to the inner sur-
face of the wall.

• Select Outer Main to display or modify 
the radius from the center of the curved 
wall to the outside of the main layer of the 
wall.

• Select Inner Main to define the radius 
from the center of the curved wall to the 
inside of the main layer of the wall.

• Radius - Displays the radius length as 
defined by the above radio buttons. Mod-
ify this value to change the curvature of 
the wall.

Structure Tab
The settings on the Structure tab control the  
height and other structural attributes of the 
selected wall(s).

Select Railing and Invisible to place
walls where there is a vertical break in
the floor or ceiling level at the invisible

wall’s location. If railing is not selected, there
will be a gap where the levels change.

7
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The Platform Intersection settings 
control the relationship between the 

selected wall and the floor and ceiling 
platforms above and below it. 
• Default Wall Top Height and Default 

Wall Bottom Height are enabled if the 
selected wall top and/or bottom height has 
been edited. Check these boxes to restore 
the default heights. 

• Select Stop at Platform to have the bot-
tom of the wall stop at the top surface of a 
floor platform. This is the default for 
framed wall types. 

• Select Go Through Platform to have the 
bottom of the wall go through a floor plat-
form. If there is a wall directly below, the 
framing will continue downward to its top 
plate. This is the default for concrete wall 
types. Does not affect interior walls. 

• Select Stop at Ceiling to have the top of 
the wall stop at the bottom of a ceiling 
platform.

• Select Balloon Through Ceiling to have 
the top of the wall go past the ceiling plat-
form. If there is a wall directly above, the 
framing will continue upward to its bot-
tom plate. The two walls remain separate 
objects on different floors, however, 
unless the wall above is an Attic Wall. 
Does not affect interior walls. 

• Select Generate Between Platforms to 
fill in the gap between floor and/or ceiling 
platforms when the selected railing or 
invisible wall separates rooms with differ-
ent floor and/or ceiling heights. When 
unchecked, this gap is not closed. Only 
available for railings, invisible railings, 
and invisible walls. See “Stepped Floor & 
Ceiling Platforms” on page 321.

Specify the number of Rim Joists for 
the floor platform below the selected 

wall(s). See “Framing” on page 435.
• Select Single or Double to generate one 

or two rim joists, respectively. 
• Select Automatic to generate two rim 

joists if there is no wall below the selected 
wall, and one rim joist when there is a 
wall below. Automatic produces a single 
rim joist for Deck Railing.

1 2

3

Whether a wall is a framed or concrete type is
determined by material assigned to its Main
Layer. See “Wall Type Definitions Dialog” on
page 211.

1

2
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Check Retain Wall Framing to 
preserve the framing of the selected 

wall when the wall framing is globally 

rebuilt. See “Keeping Framing Current” on 
page 461. 

Roof Tab
Any automatically generated roof style other 
than a hip requires roof information to be 
defined in the exterior walls. On the Roof 
tab, you can specify how the selected wall 

interacts with the roof plan, defining the 
portion of the roof plan that bears on it. See 
“Automatic vs. Manual Roofs” on page 350.

Roof Options - Specify the shape of 
the wall relative to the roof. 

• Check Full Gable Wall to create a gable 
end over the selected wall. 

• Check High Shed/Gable Wall to specify 
the selected wall as the high end of a shed 
roof. 

• Check Knee Wall to define the selected 
interior wall as a knee wall. Only an inte-
rior wall can be defined as a knee wall. A 
knee wall’s height is defined by the roof 

above, not the ceiling height. See “Knee 
Walls” on page 206.

• Check Extend Slope Downward to con-
tinue a roof down over a bumpout in an 
exterior wall. See “Extend Slope Down-
ward” on page 205. 

• Check Roof Cuts Wall at Bottom to pre-
vent the portion of a selected wall located 
below an intersecting roof plane from 
building. 

3
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• Combine with Above Wall is only avail-
able when a selected wall has an Attic 
wall above it. Check this box to balloon 
frame the two walls when automatic 
framing is built. The two walls remain 
separate objects. See “Attic Walls” on 
page 206. 

Pitch Options - Specify the pitch or 
pitches of the roof plane(s) above the 

selected wall.
• Enter a value to define the Pitch of the 

roof plane bearing on the selected wall. 
• Check Upper Pitch to create a roof with 

two pitches or, if the selected wall is a 
Full Gable Wall, a half hip condition.

• Enter the Pitch of the second, upper roof.
• Specify the Height that the Upper Pitch 

Starts at, or define the distance in from 
Baseline that the second pitch begins. The 
two values are dynamic. Press the Tab key 
to update the relative numbers.

Check Auto Roof Return to generate 
roof returns on the selected wall. In 

most cases, roof returns only work for Full 
Gable Walls. See “Roof Returns” on page 
393.
• Specify the horizontal Length of the roof 

return in inches.
• Enter a value in inches to Extend the roof 

returns from the overhang. 
• Specify a Gable, Hip, or Full roof return. 

Specify a Sloping or Flat roof return. See 
“Roof Tutorial” on page 69 of the User’s 
Guide.

• Check the boxes to  Include Gutteron the 
roof returns.

Specify the Overhang Length, which 
is the horizontal distance from the 

baseline to the eave. See “The Baseline” on 
page 363.

Check Lower wall type if split by 
butting roof to specify the desired wall 

type for the portion of the selected wall 
located beneath an adjacent, abutting roof 
plane, should one be present. The upper por-
tion is defined on the Wall Types tab.

Foundation Tab

2
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Check Specify Foundation to turn the 
selected wall into a foundation wall and 

enable the settings on this tab. This box is 
checked by default for automatically 
generated foundation walls as well as walls 

drawn with the Foundation Wall  tool, 
and produces a footing beneath the wall.

The Thickness of the selected wall 
displays and can be changed here. 

Check Footing to assign a concrete 
footing to the selected wall(s) and 

enable the settings below.
• Specify the Width and Height of the 

footing below the selected foundation 
wall(s). The Height value will be unavail-
able if the bottom height of the footing 

has been edited. See “Stepped Founda-
tions” on page 340.

• Check Automatic Footing Bottom 
Height to restore the default height of the 
selected wall’s footing. Only available 
when the footing bottom height has been 
edited.

• Check Vertical Footing to generate foot-
ings that run up and down along any steps 
in the foundation wall’s bottom height. 

Specify how Monolithic Slab footings 
generate. 
• Specify the Chamfer Width and Height, 

which define the angled corners where the 
footing meets the underside of the slab. 

1

2
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Wall Types Tab

Choose the selected wall’s Wall Type 
from the drop-down list of all currently 

available types. A preview of the selected 
wall type displays below the drop-down list.
• Click the Define button to open the Wall 

Type Definitions dialog to create or mod-
ify existing wall types. See “Wall Type 
Definitions Dialog” on page 211.

Check Pony Wall to specify the 
selected wall as a pony wall having 

different wall types on its upper and lower 
portions. See “Pony Walls” on page 184.

If the selected wall is a Foundation Wall, its 
initial wall type will become the Lower Wall 

Type. For all other walls, the initial wall type 
will be the upper Wall Type.

Specify the Lower Wall Type: the wall 
type of the lower portion of the pony 

wall. A preview of the selected wall type 
displays below the drop-down list.
• Click the Define button to open the Wall 

Type Definitions dialog. 

Align pony wall - Specify how the 
layers of the selected wall’s Upper and 

Lower portions align. 
• No change is used by default when multi-

ple pony walls with different alignment 
settings are selected. Choose this to leave 

2
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the alignment as it was when the dialog 
was opened. 

• Select Outer surface to align wall types 
at their outer surfaces.

• Select Outer main to align wall types at 
the exterior edge of their main layers.

• Select Central main to align the centers 
of the main layers of both wall types.

• Select Inner main to align the wall types 
at the interior side of their main layers.

• Select Inner surface to align wall types 
at their interior surfaces.

Specify the height of the division 
between the upper and lower walls. 

These two settings are dynamic: if one is 
changed, the other will update accordingly.
• Specify the Elevation of Lower Wall 

Top, which is the division between the 
upper and lower walls. If the top of the 
lower pony wall is stepped or raked, this 
value will be “No Change”. This value is 
measured from 0” (mm) - the default floor 

height for Floor 1. See “Floor Defaults 
Dialog” on page 316. 

• Specify the Height Off Floor of the divi-
sion between the upper and lower walls. 
This value is measured from the floor 
height of the room(s) defined by the 
selected wall. If the wall defines rooms 
with different floor heights, “No change” 
will display.

Specify which part of the pony wall you 
would like to Display in Plan view. 

• Select Default to display the portion of 
the pony wall specified in the Pony Wall 
Defaults dialog. See “Wall, Railing, and 
Fencing Defaults” on page 176.

• Select Upper Wall to display the upper 
portion of this pony wall in floor plan 
view regardless of the default setting.

• Select Lower Wall to display the lower 
portion of this pony wall in floor plan 
view regardless of the default setting.

• When walls are group-selected, choose 
No Change to allow each wall in the 
selection set to maintain its own setting.

5
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Wall Covering Tab

All wall covering materials applied to 
the selected wall are listed here. Select 

one from the drop-down list to edit it or 
remove it from the wall. 

Add, replace or remove the selected 
wall’s wall coverings.

• Click Add New to apply a new wall cov-
ering to the selected wall. See “Select 
Library Object Dialog” on page 622.

• Click Select to replace the current wall 
covering with a new one from the library.

• Click Delete to remove the current wall 
covering from the selected wall.

Specify the position of the current wall 
covering. Preview panes of the current 

wall covering also display here. 
• Enter the heights of the current wall cov-

ering’s Top To Ceiling and Floor To Bot-
tom. The wall covering’s Height from it’s 
top edge to its bottom edge can also be 
specified.

• Check Interior and/or Exterior to apply 
the wall covering to the inside and/or out-
side of the selected wall. Interior is 
checked by default. See “Wall Type Defi-
nitions” on page 209.

Rail Style Tab
The settings on the Rail Style tab are only 
available for Railings. See      Rail Style Tab.

Newels/Balusters Tab
The settings on the Newels/Balusters tab are 
only available for Railings. See      Newels/
Balusters Tab.

Materials Tab
All walls - including interior walls, railings 
and fencing - have an “Exterior Wall 
Surface” and an “Interior Wall Surface”. See 
“Interior and Exterior Surfaces” on page 210. 
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The materials specified on the Materials tab 
affect the appearance of walls and Solid 
Railings in 3D views but are not calculated in 
the Materials List. See “Materials Lists” on 
page 887. 

For most railing types, the “Exterior Wall 
Surface” component only affects the 
appearance of the floor platform under the 
railing. and “Interior Wall Surface” 
component is not used. For fencing, neither 
material component is used. 

Railing and Fencing Specification Dialogs
To open the Railing or Fencing 
Specification dialog, select a railing 

or fencing, or a group of railings or fencing, 
and click the Open Object edit button. 

The Railing and Fencing Specification 
dialogs are the same as the Wall 
Specification dialog, but have two tabs that 
apply only to Railings, Deck Railings, and 
Fencing. See “Wall Specification Dialog” on 
page 214. 

Rail Style Tab

Check Specify Railing to specify the 
selected wall as a railing and enable the 

other options on this tab. Railings can be also 

drawn directly using the Railing  or Deck 

Railing  tools.

Railing Type - Select the radio button 
for the desired railing type. A preview 

of the selected type displays to the left.
• Check Balusters to create balusters. 
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• Check Solid to create a solid, wall style 
railing. The wall is the type defined by the 
current wall layer definition.

• Check Open to create a railing with only 
a top rail.

• Check Middle Rail to create a railing 
with a top and a middle rail.

• Check No Rail  to eliminate rails, leaving 
only pillars or posts (and overhead beam, 
if selected). 

• Check Panels to create a solid panel. You 
can specify the panel style on the Newels/
Balusters tab.

Newel Posts -

• Check Post to Rail to create newel posts 
from floor to rail height. This option is 
selected by default.

• Check Post to Overhead Beam to create 
newel posts from floor to an overhead 
beam placed just under the ceiling height. 
The beam’s width is based on the Thick-
ness of the selected railing wall.

• Check Post to Ceiling to extend the 
newel posts to the ceiling.

The Bottom Rail options control the 
placement of the bottom rail, or shoe. If 

neither box is checked, the bottom rail is 
placed at floor platform level. Not available 
for railings specified as Solid or No Rail. 
• Uncheck Include Bottom Rail to elimi-

nate the bottom rail and extend the balus-
ters to the floor. Not available for Panel 
railings.

• Check Raise Bottom Rail, then specify 
the bottom rail’s height off the floor plat-
form in the text field below.

A preview of the railing displays here 
and updates as options are changed.

• Uncheck Show Color to display the pre-
view as a line drawing rather than in 
color. 

Choose a Halfpost option for the 
desired halfpost placement and shape.

• Check No Halfpost to prevent a half-
width post from being placed when a rail-
ing intersects a wall.

• Check Square Halfpost to use a square 
halfpost where a railing intersect with a 
wall. Not available if No Halfpost is 
checked.

Specify whether the selected railing fol-
lows the slope of terrain or that of 

stairs. These options only apply when railing 
or fencing is drawn outside of a building on 
top of a defined terrain, or when the railing is 
drawn at the same location as a staircase. 
• Check Step Terrain to have the railing or 

fencing follow the terrain in horizontal 
steps between each newel. 

• Check Follow Terrain to have the railing 
or fencing follow the terrain smoothly.

• Check Follow Stairs to have the railing or 
fencing follow the rise of stairs drawn in 
the same location. See “Railing Panels” 
on page 418.

Check Generate on Low Platform to 
display the selected railing on the lower 

floor platform when the railing defines two 
room areas with different floor heights. See 
“Aligning Railing on Different Platforms” on 
page 203.
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Newels/Balusters Tab

Railing Height - Specify the railing 
height. For interior railings, this is 

measured from the height of the floor finish. 
See “Floor and Ceiling Platform Definitions” 
on page 322. 

Baluster Width - Specify the width or 
diameter of each baluster at its widest 

point. For a Panel railing, this is the panel’s 
thickness and can be no larger than the 
railing’s total thickness, shown on the 
General tab.

Specify the characteristics of the 
selected railing’s newels.  

• Specify the Newel Width. For a library 
newel, this is its width or diameter at its 
widest point.

• Specify the Newel Height, which is the 
height from the ground to the top of the 
newel. Not available if Post to Rail, Post 
to Overhead Beam or Post to Ceiling is 
selected on the Rail Style tab.

• Specify the Newel Offset, which is the 
amount each newel is offset from the cen-

ter of the railing. Use this when creating a 
fence with the newels to one side of the 
fence boards.

Panel Type is only available when the 
railing type has been specified as 

Panels on the Rail Style tab. Select “Solid”, 
“Framed”, or “Library” to select a symbol to 
be used as a railing panel. 

Baluster Type - Only available when 
the railing type is “Balusters.” Select 

square, round, or Library balusters and 
specify their on-center (O.C.) spacing.

Newel Type - Select square, round, or 
Library newels and specify their on-

center (O.C.) spacing.
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Note: Selecting Library from the  Panel, Bal-
uster or Newel Type drop-down list is the
same as clicking the Library button to the
immediate right and allows you to select a
symbol from the library. See “Select Library
Object Dialog” on page 622.
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Wall Hatch Specification Dialog 
To open the Wall Hatch Specification 
dialog, select a Wall Hatch and click 

the Open Object edit button. See “Hatch 
Wall” on page 188.

The settings in the Wall Hatch Specification 
dialog are found on the Fill Style tabs of the 
specification dialogs for many different 
objects. See “Fill Style Tab” on page 792.
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Chapter 9:

Rooms

When walls or railings create an enclosed 
area, a “room” is created. You can select 
rooms defined in this manner like other 
objects in Home Designer Pro.

Rooms are assigned a Room Type. Each 
Room Type has predefined characteristics. 
For example, a room defined as Porch is 
assigned certain attributes that are different 
than a Kitchen. 

Floor and ceiling heights, baseboard, chair-
rail, and crown moldings and materials can 
be defined room-by-room or for the entire 
floor.

Chapter Contents
•      Floor and Room Defaults
•      Room Definition
•      Selecting Rooms
•      Displaying Rooms
•      Editing Rooms
•      Room Types
•      Room Labels
•      Decks
•      Floor & Ceiling Heights
•      Special Ceilings
•      Room Specification Dialog
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Floor and Room Defaults
Select Edit> Default Settings to open 
the Default Settings dialog where 

you can access several defaults dialogs 
which directly affect rooms. 

Floor Defaults
Default values for rooms are specified in the 
Floor Defaults dialog for the current floor. 
This dialog also controls important 
information that the program uses to create 
3D models - particularly floor and ceiling 
heights and materials. Moldings can also be 
specified in the Floor Defaults dialog. 

The default Floor and Ceiling Structure and 
Finish definitions in the Floor Defaults 
dialog are drawn from the Normal Room 
Defaults. See “Floor and Ceiling Platforms” 
on page 321. 

Only the defaults for the first floor of a 
building can be set ahead of time. The 
program uses the setting from the first floor 
to create subsequent floors. Once a new floor 
is built, its floor defaults can be changed. See 
“Floor Defaults Dialog” on page 316.

Room Defaults
Additional structural and material defaults 
for several categories of Room Types can 
also be specified:
• Normal Rooms
• Kitchens/Baths/Utility Rooms

• Decks
• Garage/Porches/Slabs

These Room Defaults dialogs are accessed 
by expanding the “Rooms” category in the 
Default Settings dialog. Select a room type 
and click the Edit button to open the defaults 
dialog for that room type. See “Room Types” 
on page 234.

These dialogs allow you to specify the floor 
and ceiling structures and finishes for 
different Room Types. See “Structure Tab” 
on page 245.

Room Label Defaults
The Room Label Defaults dialog allows you 
to specify the initial appearance of room 
labels. This dialog is also accessed by 
expanding the “Rooms” category in the 
Default Settings dialog. See “Room Labels” 
on page 236. 

The options on most tabs of the Room Label 
Defaults dialog are similar to those in the 
Text Specification dialog.

Any text added to the Room Label Defaults 
dialog displays in all subsequently created 
room labels, after the Room Name. Changes 
made to default settings do not alter existing 
room labels. To update existing labels so that 
they reflect changes made to the defaults, 
delete and replace them. See “Editing Room 
Labels” on page 237.
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Room Definition
A room is a totally enclosed area defined by 
any combination of joined walls or railings, 
visible or invisible. To be recognized as a 
room by Home Designer Pro, a room must 
have an unbroken perimeter.

Unless otherwise specified, rooms generate 
floor and ceiling platforms automatically. 
Most rooms are also automatically covered 
by the roof when one is built. There are 
exceptions to this, such as rooms defined as 
Decks. See “Room Types” on page 234.

If a room is drawn within a larger structure 
and none of its walls connect to the exterior 
walls, either directly or indirectly by 
connecting to walls that do, it is referred to as 
an “island” room. The program will connect 
such a room to the larger structure with an 
Invisible Wall. See “Invisible Walls” on page 
187.

Room definition disappears if part or all of a 
surrounding wall is deleted. It is a good idea 
to finalize the position of walls before 
defining rooms with names and attributes 
such as floor height and ceiling height.

Subdividing Rooms
When a room area is first defined, it inherits 
its characteristics from the Floor Defaults 
dialog for that floor. If the room is then 
specified as a particular type, it may inherit 
properties from the Room Defaults dialog 
associated with its type. 

If a new room is created by subdividing a 
larger room, it inherits its characteristics 
from that larger room - including any non-
default settings.  

Selecting Rooms
Room definition is established when a room 
is completely enclosed by walls. You can 
confirm that a room has room definition by 

using the Select Objects  tool to select it. 
When a fully-enclosed room is selected, the 
room highlights. 

The room at left is selected
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The Exterior Room
You can also select the exterior of a model. 
This allows you to control the building’s 
exterior wall coverings and materials using 
the Room Specification dialog. 

Click just outside an exterior wall using the 

Select Objects  tool to select the Exterior 
Room. When it is selected, a highlighted 
band around the plan’s exterior displays. 
This band represents the selection area for 
the Exterior Room.

In camera views and overviews, the Exterior 
Room can be selected by clicking on the 
exterior surface of an exterior wall using the 

Select Objects  tool, provided that Select 
Room Before Wall in 3D is selected in the 
Preferences dialog. See “Architectural 
Panel” on page 73.

In 3D Views
Click on the floor of a room or on a wall 
surface inside the room in a 3D view using 

the Select Objects  tool. If you select 
another object instead of the room, click 

Select Next Object  edit button or press 
the Tab key until the room is selected. The 
Status Bar indicates which object is currently 
selected.

The Exterior Room can also be in 3D views 
selected by clicking once on the exterior 
surface of an exterior wall using the Select 

Objects  tool, provided that Select Room 
Before Wall in 3D is selected in the 
Preferences dialog. See “Architectural 
Panel” on page 73. 

Displaying Rooms
Unlike most things in Home Designer Pro, a 
room is not an individual object. Rather, a 
room is defined by the walls that enclose it.

In Floor Plan View
Rooms typically display a transparent fill in 
floor plan view. You can, however, specify a 
solid color or fill pattern for all the rooms on 
an entire floor in the Floor Defaults dialog, 

Note: The selection color can be specified in
the Preferences dialog. See “Colors Panel”
on page 63.

The Exterior Room is selected

Note: If the wall height of the Exterior Room
is adjusted in a 3D view, the default Floor or
Ceiling Height of the entire floor is changed.
See “Floor and Room Defaults” on page 230.
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or for individual rooms in the Room 
Specification dialog. See “Fill Style Tab” on 
page 250.

In order for room fill styles to display, the 
“Rooms” layer must be turned on. See 
“Displaying Objects” on page 102. 

Room labels that include the room’s name as 
well as its size and other information can be 
set to display in floor plan view. See “Room 
Labels” on page 236. 

In 3D Views
Rooms can be viewed in 3D views created by 
any of the 3D view tools. The Dollhouse 
View tools can be used to see all rooms on 
the current floor without their ceilings. See 
“Creating Overviews” on page 674.

In the Materials List
The contents of a room, including 
furnishings and floor and ceiling materials 
can be calculated using the Calculate From 
Room tool. See “Calculate From Room” on 
page 888.

Editing Rooms
Once a room is defined by walls or railings, 
its structure and appearance can be edited 
using the edit buttons or the Room 
Specification dialog. 

In 3D Views
The floor and ceiling heights for floors, 
rooms, and individual walls can be edited 
using edit handles in 3D views. Lowered 
ceilings cannot be edited in 3D. See “3D 
Views” on page 663. 

The default floor and ceiling heights for an 
entire model can be edited by selecting the 
Exterior Room. See “The Exterior Room” on 
page 232.

To change default ceiling heights in 3D

1. Create a 3D or Cross Section/Elevation 
view of the exterior of your plan. 

2. Click on the exterior surface of a wall to 
select the Exterior Room. The Status Bar 

indicates when the exterior room is 
selected. See “The Exterior Room” on 
page 232.

3. Click and drag the edit handle on the top 
wall edge to adjust the default ceiling 
height, or the edit handle on the bottom 
edge to adjust the default floor height. 
Temporary dimensions display.

To adjust room heights in 3D

1. Create a 3D or Cross Section/Elevation 
view of your plan.

2. Click on the surface of a wall that faces 
the room to select it. When the room is 
selected in 3D:

Note: Any rooms that do not update when the
default floor or ceiling height is changed are
not using the default values. To use the
default values for a specific room, check
Default for any of the room height values in
its specification dialog. See “General Tab” on
page 244.
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•  The room highlights. 
•  The Status Bar says “Room”. See “The 

Status Bar” on page 31.
•  Two edit handles display on the top and 

bottom edges of the highlighted wall.
3. Click and drag the edit handle on the top 

wall edge to adjust the room ceiling 
height, or the handle on the bottom edge 
to adjust its floor height. Temporary 
dimensions display.

4. As you drag a handle, notice that all 
walls defining that room are affected.

To adjust the height of a wall in 3D

1. Create a 3D or Cross Section/Elevation 
view of your plan. 

2. Click on a surface of the wall. By 
default, the room will be selected. You 
can change this behavior in the 
Preferences dialog. See “Architectural 
Panel” on page 73.

3. Click the Select Next Object  edit 
button to select the wall. The Status Bar 
says “Wall.” See “The Status Bar” on 
page 31.

4. Click and drag the edit handles. Tempo-
rary dimensions display in elevation 
views. See “Editing Closed-Polyline 
Based Objects” on page 138.

Room materials such as floor, ceiling, and 
wall materials can be changed in 3D views 

using the Material Painter . See “The 
Material Painter” on page 632.

In the Specification Dialog
Floor and ceiling heights, floor 
platform structure, moldings, wall 

coverings, and materials can all be specified 
in the Room Specification dialog. See 
“Room Specification Dialog” on page 244.

Using the Edit Tools
A selected room can be edited using the edit 
toolbar. See “The Edit Toolbar” on page 29.
• Click the Calculate Materials for 

Room  edit button to create a materi-
als list of the contents of the selected 
room, not including walls. See “Calculate 
From Room” on page 888.

Room Types
When a room is first created by enclosing an 
area with walls, it is assigned a generic room 
type of “Unspecified.” 

Once your floor plan is laid out, each room 
should be assigned a Room Type in the 
Room Specification dialog. See “General 
Tab” on page 244. The Room Type applies 
appropriate structural and display properties 
to the room. 

When you assign a Room Type, a label 
showing the room’s Type displays in floor 
plan view.

You can edit the text of a room label in floor 
plan view, but the type of room originally 
assigned remains until it is changed in the 
Room Specification dialog. See “Editing 
Room Labels” on page 237.
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Available Room Types
There are three categories of room types: 
Interior, Exterior and Hybrid.

Interior - Living, Dining, Family, Kitchen, 
Nook, Bath, Master Bath, Master Bedrm, 
Bedroom, Study, Office, Entry, Hall, Closet, 
Dressing, Storage, Laundry, Utility and 
Unspecified.

Exterior - Court, Deck, Balcony.

Hybrid - Open Below, Garage, Slab, Porch, 
Attic.

Effects of Room Types
The program applies specific structural and 
display properties to rooms depending on the 
assigned Room Type.

Living Area
• All interior type rooms are included in 

Living Area calculations by default; exte-
rior and hybrid rooms are not. 

Ceilings and Roofs
• Interior rooms have a ceiling and roof 

above them unless specified otherwise.
• Exterior rooms are assumed to be open to 

the outside and do not generate a roof 
above them, or room moldings.

• Attic rooms are ignored by the program’s 
automatic roof generator.

• Garage, Slabs, and Porches are treated 
like exterior rooms in all cases except that 
they generate a ceiling and a roof above 
them.

• A room’s default ceiling structure and fin-
ish definitions are determined by its 
Room Type. See “Room Defaults” on 
page 230.

Floors and Foundations
• Open Below is a unique type of interior 

room. It has no floor platform and can be 
used for defining stairwell openings. 

• Exterior walls of rooms default to create 
the foundation type specified in the 
Foundation Defaults dialog. 

• Walls that define the garage have a foun-
dation under them defined by the 
Foundation Defaults dialog with a con-
crete slab at the top of stem wall or grade 
beam.

• The floor in Garage and Slab rooms dis-
play in 3D on Floor 0, not the first floor. 
See “Garages” on page 338.

• A room’s default floor structure and finish 
definitions are determined by its Room 
Type. See “Room Defaults” on page 230.

• Defining a room as Slab causes the floor 
platform thickness to equal the slab thick-
ness value in the Foundation Defaults 
dialog.

• Courts, decks and balconies do not gener-
ate foundations.

Doors and Windows
• A window placed in a wall between an 

exterior room and an interior room always 
faces out toward the exterior. 

• Windows placed between interior rooms 
generate a warning message. 

• Door placed between interior and exterior 
type rooms display threshold lines.

• Interior doors do not display thresholds.
• Open Below rooms are treated as interior 

rooms for window and door placement.
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Electrical

• The Auto Place Outlets  tool adds 
outlets automatically to all interior rooms 
except bathrooms. Only one outlet over 
each sink is added for a bathroom.

• The Auto Place Outlets  tool places 
fewer outlets in hybrid rooms. 

• The Auto Place Outlets  tool does not 
place outlets in exterior type rooms, 
Porches or Open Below rooms.

• Any outlet manually placed in an exterior 
room automatically becomes a waterproof 
outlet designed for exterior use. 

Trim and Molding
• Moldings are not automatically drawn in 

exterior or hybrid rooms.
• Baseboards and chair rails are not initially 

drawn in Open Below rooms, but crown 
molding, if present, is. 

Plan Check

• Plan Check  uses the room type and 
its characteristics for basic plan checking. 
For example, a closet does not need a 
smoke detector but a bedroom does. See 
“Plan Check” on page 801. 

Room Labels
A label can display in floor plan view for any 
area defined as a room. There are two parts 
to each room label: 
• The Room Name, which is similar to a 

Text  object and can be selected and 
edited. See “The Text Tools” on page 746. 

• The room area, which is not a standard 
text entry and cannot be directly edited. 

You can assign a custom Room Name, move 
a room label or even delete it without 
affecting the Room Type. See “Room Types” 
on page 234.

Room Label Defaults
The initial settings that control the 
size, font, color and other aspects of 

room label appearance are controlled in the 

Room Label Defaults dialog. See “Room 
Label Defaults” on page 230. 

Custom Room Labels
The Room Names that display in room labels 
are often based on the Room Types assigned 
in the Room Specification dialog. You can, 
however create a custom name for a selected 
room, also in the Room Specification 
dialog. See “General Tab” on page 244.

Before creating a custom Room Name, 
assign the Room Type most similar to the 
room’s actual use.  For example, if you wish 
to name a room “Guest Room”, begin by 
specifying it as a “Bedroom” since these 
rooms have similar uses. 

When a Room Name is based on its Room 
Type, the name in the label will be in all 
capital letters. When a custom Room Name 
is used, capitalization is user-defined. 

Room labels can move or even disap-
pear when room entries are revalidated.
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If you wish to further customize a room’s 
label by adding text, uncheck Show Room 
Label in the Room Specification dialog and 
create  your own label using a Text object. 
See “The Text Tools” on page 746. 

Displaying Room Labels
The display of room labels is controlled in 
the Layer Display Options dialog. Room 
labels are placed on the “Rooms, Labels” 
layer and use the Text Style assigned to that 
layer. See “Layer Display Options Dialog” 
on page 104. 

You can specify how the area of rooms is 
calculated by the program by turning on the 
display of one or more of these layers: 
• Rooms, Standard Area is measured from 

the center of interior walls to either the 
outside surface of exterior walls or exte-
rior wall framing, depending on the Liv-
ing Area to setting in the Floor Defaults 
dialog. It is rounded to the nearest square 
foot or mm and does not include the area 
within bay, box and bow windows. See 
“General Tab” on page 316.

• Rooms, Interior Area is measured from 
the inner surfaces of all the room's walls. 
Its format is set on the Dimension Format 
tab of the Room Label Defaults dialog 
for the current floor. See “Room Label 
Defaults” on page 230.

• Rooms, Interior Dimensions is also 
measured from the inner surfaces of the 
room walls. Its format is set in the Floor 
Defaults dialog for the current floor. 

The display of room labels can also be 
controlled on a room by room basis in the 
Room Specification dialog. See “General 
Tab” on page 244. 

Editing Room Labels

Room labels are similar to simple Text  
objects and can be changed, moved and 
resized much like any other text object. You 
can also modify a room label’s Text Style 
and other attributes in the Room Label 
Specification dialog.

The text of a room label cannot be modified 
in its specification dialog, however: it must 
be specified in the Room Specification 
dialog. See “General Tab” on page 244.

If you delete a room label, the Room Type 
and Room Name remain unchanged in the 
Room Specification dialog. To restore the 
label, check the Show Room Label check 
box on the General tab of that dialog.

Room Area
Unlike the rest of a room label, the room area 
and dimensions are not standard text entries 
and cannot be edited or changed. The room 
area moves, resizes and rotates with the rest 
of the room label, but you can turn the area 
and dimensions on or off separately in the 
Layer Display Options dialog. See 
“Displaying Rooms” on page 232.

The Interior Area room area calculation 
includes the areas within bay, box or bow 
windows, while the Standard Area and 
Interior Dimensions calculations do not.

Living Area
The Living Area label displays the area of 
the floor platform for living areas in a plan. It 
is found near the bottom center of the plan as 
soon as a room area is defined by walls and/
or railing. The area is recalculated every time 
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you add, delete, or move walls, or Rebuild 

Walls/Floors/Ceilings .

The Living Area displays for an individual 
building if half or more of that building's area 
is living area. For example, a living area 
label would not display for a detached garage 
that contains a bathroom or small shop.

You can choose not to display this label by 
clearing the Show “Living Area” check box 
in the Plan Defaults dialog or by turning off 
the display of the Room Labels layer in the 
Layer Display Options dialog.

The Living Area label can be moved or 
deleted. To restore a deleted Living Area 
label, select Tools> Checks> Plan 

Check . You can click the Done button 
immediately, without actually completing 
Plan Check. See “Plan Check” on page 801.

Living Area vs. Footprint
The Living Area should not be mistaken for 
the footprint of the house. Only true livable 
areas are included in the Living Area 
calculation. By default, exterior and hybrid 
room types such as Garage, Deck, and Porch 
are not included. Neither is any room labeled 
Open Below or Attic. See “Available Room 
Types” on page 235. 

Regardless of its room type, you can specify 
whether a room is included in the Living 
Area calculation in the RoomSpecification 
dialog. See “General Tab” on page 244. 

Living Area is measured from either the 
outside surface or the outer surface of the 
Main Layer of exterior walls. When walls 
separate the living area from exterior or 
hybrid room types, it is measured to the wall 
center line. See “Wall Type Definitions” on 
page 209.

Decks
A Deck room is an exterior-type room that 
uses deck planking and framing to create a 
floor platform rather than using a floor finish 
that spans the entire room area. See “Floor 
and Ceiling Platform Definitions” on page 
322. 

The default settings for deck planking and 
framing are set in the Deck Room Defaults 
dialog. The defaults for deck post footings 
are set in the Framing Defaults dialog. See 
“Room Defaults” on page 230 and “Posts/
Beams Tab” on page 449. 

To draw a deck, select Build> Deck> Deck 

Railing , then click and drag to draw a 
railing. 

• To create a deck without a railing, use one 
of the Deck Edge tools. See “The Deck 
Tools” on page 182.

• You can also create a regular, polygon-
shaped deck using the Polygon Shaped 

Deck  tool. See “Polygon Shaped 
Deck” on page 182.

A room does not have to be defined by Deck 
Railing to be specified as a “Deck.” See 
“Room Types” on page 234. You can also 
define a room as a “Deck” in the Room 
Specification dialog. See “General Tab” on 
page 244.
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By default, decks do not have roofs. If you 
want a roof over a deck, check Roof Over 
This Room in the Room Specification 
dialog. See “Structure Tab” on page 245.

To give the roof a visible means of support, 
you can select the Post to Beam option in the 
Wall Specification dialog. See “Rail Style 
Tab” on page 224.

Openings in deck railings can be created 

using Doorways . See “Openings in 
Railings” on page 264. 

Deck Framing and Planking
When a Deck room is created, the floor 
platform is modeled using joists, beams, 
posts, and planking as specified in the Deck 
Room Defaults dialog. See “Structure Tab” 
on page 245 and “Deck Tab” on page 248. 
• If a floor is present below the one that the 

Deck room is created on, the framing will 
be created there. If needed, beams may be 
generated with posts beneath them, if 
specified. When terrain is present, the 
posts will have footings, again, if speci-
fied. 

• If a floor is not present below the Deck, 
framing will be generated on the same 
floor as the room. Beams may be created 
but posts will not. 

• Deck framing and planking are placed on 
the “Framing, Deck Framing” and “Fram-

ing, Deck Planking” layers, which are 
often turned off in floor plan view. See 
“Layer Display Options Dialog” on page 
104.

If standard floor framing is present when a 
room is specified as a Deck, that framing is 
deleted and replaced with deck framing. 

If changes are later made to the settings on 
the Deck tab of the Room Specification 
dialog, the deck framing and planking will be 
automatically rebuilt in response. To prevent 
this from happening, uncheck Automatic 
Deck Framing.

Once created, the individual planking and 
framing objects generated for a Deck room 
can be selected and edited like other framing 
objects, provided that Automatic Deck 
Framing is turned off. See “Editing 
Framing” on page 460. 

To rebuild a deck’s framing and remove any 
changes you may have made to individual 
deck framing or planks, select the Deck room 

and click the Build Deck Framing  edit 
button.

If you delete a Deck room, its deck framing 
and planking will be automatically deleted, 
as well. To prevent this from happening, 
check Keep Deck Framing After Deck 
Room is Deleted. See “Deck Tab” on page 
248.

Floor & Ceiling Heights
Default floor and ceiling heights are defined 
in the Floor Defaults dialog for each floor, 
including the foundation. Use the Floor 

Defaults dialog to change these values on a 
floor-by-floor basis. See “Floor and Room 
Defaults” on page 230.
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Use the Room Specification dialog to set 
floor heights on a room-by-room basis. See 
“Room Specification Dialog” on page 244. 

Different rooms on the same floor can have 
unique floor and ceiling heights, allowing 
you to create:
• Split levels and bi-levels
• Sunken living rooms and garages
• Cathedral, vaulted, and coffered ceilings.

In 3D views, you can adjust the default floor 
and ceiling height for the entire floor, the 
floor and ceiling height for an individual 
room, or the top and bottom heights of an 
individual wall. See “In 3D Views” on page 
233.

All floor and ceiling heights are measured 
relative to zero, which is the default floor 
height for Floor 1. Unlike other default floor 
and ceiling heights, the default floor height 
for Floor 1 cannot be changed, but the floor 
heights of rooms on Floor 1 can be edited 
individually. 

In order to raise or lower an area’s floor or 
ceiling height, you must give it a room 
definition. To create room definition without 
enclosing an area with solid walls, use 

Railings . 

Invisible walls and railings will fill in the 
vertical space between floor platforms of 
different heights as long as Generate 
Between Platforms is checked in their 
specification dialog. See “General Tab” on 
page 214. 

Ceiling and floor heights are interrelated. 
Changing the floor height in one room can 
affect ceiling heights of the rooms below. 
• If a room’s floor is lowered, its ceiling 

height is increased while the ceiling 
below that room drops. 

• If the floor is raised, the ceiling height 
decreases while the ceiling below that 
room is raised. 

If the rooms above a particular room have 
more than one floor height, the room’s 
ceiling is stepped.

In a situation like this, a Lowered Ceiling can 
be used to cover “steps” made by different 
floor heights on the floor above. See 
“General Tab” on page 244.

Dropped Ceilings
You can create a dropped, or suspended, 
ceiling by specifying its structure in the 
Ceiling Finish dialog either for a room or the 
defaults for a floor. See “Floor and Ceiling 
Platform Definitions” on page 322.
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To create a framed dropped ceiling

1. Select a room and click the Open 

Object  edit button. 
2. On the Structure tab of the Room 

Specification dialog, click the Ceiling 
Finish button. See “Structure Tab” on 
page 245.

3. In the Ceiling Finish dialog:
•  Check Frame Lowered Ceiling.
•  Specify the depth of the Air Gap, or 

the distance between the bottom of the 
ceiling platform and the top of the low-
ered ceiling framing.

•  Specify the Framing Thickness, 
which is the depth of the framing layer.

A dropped ceiling composed of a metal grid 
requires only two layers: one for the plenum 
and one for the tiles. To achieve this, set the 
Framing Thickness to 0” (mm).

Split Levels
A split level can be created by raising or 
lowering the floor and ceiling heights of 
various areas of the plan.

In the following example, the lowest floor 
height is 0, the next is 24, and the next is 48 
inches. The ceiling height in each room is set 
at 109 inches. See “Split Levels” on page 
325.
 

Special Ceilings
By default, the program builds a flat ceiling 
platform on top the wall plates of a room. 
More varied and complex ceilings are made 
using settings in the Room Specification 

dialog and the Ceiling Plane  tool. 
Ceiling planes are drawn and can be edited 
much like roof planes. See “Ceiling Planes” 
on page 379.

Lowered Ceilings
You can define a lowered or dropped ceiling 
in a room without affecting the top plate 
height of the walls by specifying the lowered 
ceiling framing as a layer in the ceiling 
finish.

In the following illustration, the default 
ceiling height for the entire first floor is 120", 
and the room on the right has a ceiling finish 
lowered to 96".  
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To create a lowered ceiling

1. Select the room in which you would like 
to specify a lowered ceiling.

2. Click the Open Object  edit button 
to open the Room Specification dialog.

3. On the Structure tab, click the Ceiling 
Finish button to open the Ceiling Finish 
dialog. See “Floor/Ceiling Structure 
Definition Dialog” on page 323.

•  Check Frame Lowered Ceiling.

•  Specify the Air Gap, which is the dis-
tance between the bottom of the plat-
form above and the top of the lowered 
ceiling framing.

•  Specify the Framing Thickness, 
which is the depth of the lowered ceil-
ing joists. 

4. When you are finished, click OK to 
close the Ceiling Finish Definition dia-
log.

5. On the Structure tab, notice that the pre-
view diagram represents the Finished 
Ceiling height (F).

Vaulted and Cathedral Ceilings
A cathedral ceiling has the same pitch as the 
roof and is created using the underside of the 
roof above the room. A vaulted ceiling 
typically has a different pitch from that of the 
roof and is often framed using scissor 
trusses. See “Scissors Trusses” on page 478.

To create a cathedral ceiling

1. Build a roof for your plan. See “Roofs” 
on page 349. 

2. Select the room and open the Room 
Specification dialog. See “Room Speci-
fication Dialog” on page 244.

3. On the Structure tab, clear the check box 
for Ceiling Over This Room.

By default, cathedrals ceiling use the ceiling 
material set in the Room Specification 
dialog. If you require a different material on 
a given roof plane, uncheck Use Room Ceil-
ing Finish in the Roof Plane Specification 
dialog. See “Options Tab” on page 374.

To create a vaulted ceiling

1. To create a ceiling pitch different from 
the roof’s, select Build> Roof> Ceiling 

Normal ceiling Lowered ceiling
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Plane  and draw ceiling planes. See 
“Ceiling Planes” on page 379.

2. Select each ceiling plane and specify its 
pitch. See “Ceiling Plane Specification 
Dialog” on page 380.

Tray Ceilings
A tray ceiling is flat in the center and sloped 
around the perimeter, and is easily created 
using the underside of roof planes above.

To create an automatic tray ceiling

1. In the Room Specification dialog, make 
sure that Ceiling Over this Room is 
checked, then specify the desired height 
of the walls as the Ceiling Height. See 
“Structure Tab” on page 245.

2. Make sure that Auto Rebuild Roofs is 
unchecked, then build the roof. See 
“Build Roof Dialog” on page 355.

3. Change the Ceiling Height of the room 
to the desired height of the flat ceiling 
surface in its center. 

In floor plan view, dashed lines indicate 
where the ceiling changes from sloped to 
flat. These lines are located on the “Ceiling 
Break Lines” layer in the Layer Display 
Options dialog. See “Layer Display Options 
Dialog” on page 104.

If the roof is rebuilt after the ceiling height is 
adjusted upward, the new roof will be raised 
to match the new ceiling height and a tray 
ceiling will not be created.

In the following example, a hip roof is built 
on 8’ (2400 mm) ceilings. After the roof is 
built, the Ceiling Height is raised to 10’ 
(3000 mm). The resulting ceiling follows the 
roof pitch for 2’ (600 mm), then becomes a 
flat ceiling. 

Cantilever Undersides
Occasionally, a room will cantilever out past 
an exterior wall. You can specify the surface 
material of the underside of a cantilever on 
the Materials tab of the Room Specification 

dialog. For no material, select “No Material” 
from the Plan Materials dialog. See “Room 
Specification Dialog” on page 244.

       Hip roof with 
cathedral ceiling over.

Hip roof, ceiling over, 
ceiling height raised.

Ceiling Break lines in 
   floor plan view. 
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Other Special Ceilings

Soffits  can be used in various ways to 
enhance the 3D model. Soffits’ ability to 
follow the slope of the roof offers unlimited 
possibilities, such as exposed beams or 
trusses and coffered ceilings. See “Special 
Applications for Soffits” on page 590. 

Framing members and locked roof trusses 
can also be used for similar purposes.

Room Specification Dialog
The Room Specification dialog 
controls the structural characteristics 

and appearance of a selected room. To open 
the Room Specification dialog, select a 
room and click the Open Object edit button. 
See “Selecting Rooms” on page 231. 

Several of the tabs in the Room 
Specification dialog are also found in the 
Floor and Room Defaults dialogs. See 
“Floor and Room Defaults” on page 230. 

Some values in this dialog are dynamic. A 
value with Default checked is referenced 
from the Floor Defaults dialog. To return a 
value to the default, replace the check mark. 
See “Dynamic Defaults” on page 57.

The settings in this dialog are similar to those 
in the Floor Defaults dialog, but affect only 
the selected room See “Floor Defaults 
Dialog” on page 316.

General Tab
The General tab is not available in the Room 
Defaults dialog, and only two of the settings 

here are active in the Floor Defaults dialog. 
See “Floor and Room Defaults” on page 230.
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The settings here control the Room 
Type and the appearance of the Room 

Label.
• Select the Room Type. This affects some 

of the room’s characteristics. Not avail-
able when multiple rooms are selected. 
See “Room Types” on page 234.

• Check Show Room Label to display the 
room label in floor plan view. This option 
is unchecked automatically if you select 
“Unspecified” as the room type. See 
“Room Labels” on page 236.

• If you wish to use a custom name in the 
room label, uncheck Use Room Type, 
then specify the desired Room Name in 
the text field.

Specify whether the selected room is 
included in the Living Area 

calculation. See “Living Area” on page 237. 

• Select Include in Total Living Area Cal-
culation to include the room in the Living 
Area regardless of its Room Type. 

• Select Exclude from Total Living Area 
Calculation exclude the room in the Liv-
ing Area regardless of its Room Type. 

• Select Use Default for Room Type 
(Included/Excluded) to base the selected 
room’s inclusion in the Living Area on its 
Room Type. 

Specify the Roof Group of the selected 
room. Change this value to control how 

the program combines the selected room’s 
roof system with that of the rest of the 
building when automatic roofs are built. This 
value is nearly always left at zero. See “Roof 
Groups” on page 353.

Structure Tab
The Structure tab is also found in the Floor 
and Room Defaults dialogs and features a 
cross section diagram that shows the 
relationships between its various heights and 
platform thicknesses. It is meant to represent 
the relationships between heights and 

thicknesses rather than provide a scaled 
drawing of the model.

Two floors can be included in the diagram: 
the floor that the selected room is located on, 
and the floor below it, if one exists. 

1

2

3

1

2

3
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What appears in both the diagram and in the 
settings to its left may be affected by the 
location where you clicked to select the 
room. For example:
• If the selected room is located above two 

rooms with different structural settings, 
the position of the pointer relative to these 
two lower rooms determines which of 
them displays as the floor below.

• If the selected room is located below two 
rooms with different floor heights, its 
absolute and relative ceiling height set-
tings will be disabled. 

When multiple rooms are selected, only the 
Floor and Ceiling Structure and Finish can be 
specified. In some Room Defaults dialogs, 
only the Floor Structure and/or Finish can 
be modified. See “Floor and Room Defaults” 
on page 230.

Check the Default box beside any height 
value to restore the default setting. In the 
Floor Defaults dialog, the Floor and Ceiling 
Structure and Finish defaults are drawn from 
the Normal Room Defaults dialog. See 
“Dynamic Defaults” on page 57. 

Absolute Elevations - These height 
values are measured from the default 

first floor height of zero.  See “Floor & 
Ceiling Heights” on page 239.

• Specify the Floor Above height, which is 
the floor height of the room or rooms on 
the floor above the selected room. If mul-
tiple floor heights are specified directly 
above the selected room, this setting will 
be inactive and “No Change” will display. 

• Specify the Ceiling height of the selected 
room. Not available in the Room or Floor 
Defaults dialog or if multiple floor 
heights are specified above the selected 
room. 

• Specify the Floor height. 

1

2

3

5

4

1
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If a room is defined directly beneath the 
selected room on the floor below, additional 
settings may be available. 
• Specify the Floor Below height, which is 

the floor height of the room directly 
below where you clicked to select the cur-
rently selected room. 

• If the selected room is directly above a 
Garage and there is a foundation present, 
you can specify the SWT Below height, 
which is the top height of the concrete 
stem walls around the perimeter of the 
garage. 

Relative Heights - These height values 
are measured from surfaces within the 

selected room or the room below. 
• Specify the Rough Ceiling height, as 

measured from the subfloor surface to the 
bottom of the ceiling framing. Not avail-
able if multiple floor heights are specified 
directly above the selected room.

• Specify the Finished Ceiling height, as 
measured from the finished floor surface 
to the finished ceiling surface. Not avail-
able if multiple floor heights are specified 
directly above the selected room.

• Specify the distance from the Stem Wall 
Top to Ceiling. Only available when 
Floor for this Room is Supplied by the 
Foundation ‘Room’ from the Floor 
Below has been checked.

• Specify the Ceiling Below height, which 
is the height of the ceiling of the room 

below, as measured from that room’s sub-
floor to rough ceiling surfaces. Not avail-
able when Auto Rebuild Foundation is 
enabled or if there is no room below the 
selected room. See “Rebuilding Founda-
tions” on page 336.

• Specify the Stem Wall height, which is 
measured from the bottom of the room’s 
floor framing to the top of the foundation 
wall footing and including a treated sill 
plate, if one is specified. Only available if 
the selected room or the room below it is 
defined by foundation walls.

Specify the characteristics of the 
room’s Ceiling. 

• If Roof Over This Room is checked, a 
roof automatically generates over the 
room. If unchecked, no roof generates.

If this option is unchecked and a roof 
plane is manually drawn over this room, 
its structure will be that of an eave rather 
than a regular roof. See “Roof Tab” on 
page 451.

• If Ceiling Over This Room is checked, 
the room has a flat ceiling. If unchecked, 
the ceiling follows the underside of the 
roof or manually drawn ceiling planes.

• Check Use Soffit Surface for Ceiling to 
frame the roof over the selected room 
using the framing defaults for fascia 
rather than for rafters. 

• Click the Ceiling Structure button to 
open the Ceiling Structure Definition 
dialog and define the layers of materials 
that form the ceiling platform. Not avail-
able for rooms on Floor 0. See “Floor/
Ceiling Structure Definition Dialog” on 
page 323.

Note: The default floor height for Floor 1 is 0.
It can be modified in the Room Specification
dialog, but not in the Floor 1 Defaults dialog.
See “Floor and Room Defaults” on page 230.

2

3
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• Click the Ceiling Finish button to open 
the Ceiling Finish dialog an ddefine the 
layers of materials that form the finished 
ceiling surface. See “Floor/Ceiling Struc-
ture Definition Dialog” on page 323.

• Check the Default box to the right of 
either button to restore the default struc-
ture and/or finish.

Specify the characteristics of the 
room’s Floor. 

• When Floor Under This Room is 
checked, the room has a floor platform as 
specified below. 

• If Floor Supplied by the Foundation 
Room Below is checked, the floor for this 
room is a slab located on the floor below. 

• If Monolithic Slab Foundation is 
checked, a slab is generated beneath the 
selected the room when a stem wall or 
pier and grade beam foundation is gener-

ated. If unchecked, the room receives a 
foundation like the rest of the plan. Only 
available if the selected room is on Floor 
1 and does not have a room beneath it.

• Specify the thickness of the Floor Finish 
layer.

• Click the Floor Structure button to open 
the Floor Structure Definition dialog and 
define the layers of materials that form 
the floor platform. See “Floor/Ceiling 
Structure Definition Dialog” on page 323.

• If the selected room is a Deck, the Floor 
Structure button will be labeled Planks, 
Joists instead. See “Decks” on page 238.

• Check the Default box to the right of 
either button to restore the default struc-
ture and/or finish. 

A cross section diagram showing the 
relationship between the various height 

settings displays here for reference. 

Deck Tab
The options on the Deck tab are only 
available for rooms designated as Decks, and 
control how deck framing and planking are 
generated. See “Deck Framing and 
Planking” on page 239. 

The settings on this tab are also found in the 
Deck Room Defaults dialog, but affect the 
selected Deck room(s) only rather than 
Decks as they are initially created. See 
“Room Defaults” on page 230.

4

5
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Check Automatic Deck Framing to 
generate planking and support framing 

for the deck that updates as changes are made 
to the deck. See “Decks” on page 238.  
• Check Keep Deck Framing After Deck 

Room is Deleted to retain the automati-
cally generated framing and planking 
when the selected deck room is deleted. 
When this box is unchecked, the framing 
is automatically removed if the room is 
deleted. 

Specify the appearance of the Deck 
Planking. 

• Specify how far the deck planking Over-
hangs the rim joists.

• Specify the Plank Width of the deck 
planking.

• Specify the Plank Gap Width, which is 
the distance between individual planks.

• If you want to enter a Plank Direction, 
remove the checkmark from Automatic. 
Enter the direction as degrees.

• Specify the Number of Border Planks. 
These are planks that follow the outside 
edge of the deck and may not be parallel 
with the rest of the planking. Border 
planks generate as long as the length of an 
inside edge is greater than 0”. They do not 
generate on curved deck edges. 

• Check No Border Against Walls to pre-
vent border planking from being gener-
ated along any walls defining the deck. 

• Check Herringbone to produce a her-
ringbone pattern where the border planks 
meet.

Specify whether Deck Posts And 
Footings are generated beneath the 

selected deck. 

1
2

3

4

5

1

2

Note: Planking thickness and joist depth are
specified in the Floor Structure Definition dia-
log. See “Floor and Ceiling Platform Defini-
tions” on page 322. 

3
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The default footing size is set in the Framing 
Defaults dialog, and the default deck post 
size is based on the width of the deck beam 
directly above it. See “Posts/Beams Tab” on 
page 449. 

Specify the configuration of the Deck 
Support Joists. 

• Enter the Width of the joists that support 
the deck.

• Specify the Spacing between joists, as 
measured from joist center to joist center. 

• If you want to specify joist Direction, 
uncheck Automatic and enter the direc-
tion as degrees. When checked, joists are 
run in the direction that results in the 
shortest spans.

Specify the configuration of the Deck 
Support Beams. 

• Enter the Depth and Width of the beams 
that support the deck. The Width value 
also controls the size of automatically 
generated deck posts.

• Specify the Spacing between beams, as 
measured from beam center to center. 

• Select the Type of deck joists from the 
drop-down list. See “Framing Member 
Types” on page 463.

Moldings Tab
Chair rail, crown and base moldings can be 
assigned to one or more rooms on the 
Moldings tab. Moldings are placed around 
the wall surfaces of a room and continue 
around the surface of any soffit that is 
attached to the wall at the molding height.

The settings on the Moldings tab are similar 
to those found in other specification dialogs 

throughout the program. See “Moldings Tab” 
on page 503.

The settings on this tab are also similar to 
those found in the Floor Defaults dialog, but 
affect only the selected room instead of all 
rooms on the current floor. 

Wall Covering Tab
The settings on the Wall Covering tab of the 
Room Specification dialog are the same as 
those on the same tab of the Wall 
Specification dialog. When a wall covering 
is assigned in the Room Specification 
dialog, it is applied to all walls in the selected 
room only. See “Wall Covering Tab” on page 
223.

Fill Style Tab
The settings on this tab affect the appearance 
of the room in floor plan view. This tab is 
also found in the Floor Defaults dialog. For 
more information, see “Fill Style Tab” on 
page 792.

Materials Tab
The settings on this tab affect the appearance 
of a selected room’s walls, floor, ceiling and 
moldings in 3D views. See “Materials Tab” 
on page 635. 

Default molding and ceiling and floor 
covering materials can be set in the Floor 
Defaults dialogs.

4

5 Wall coverings can be applied to exte-
rior rooms as well by selecting the exte-

rior room and opening it for specification. See
“Selecting Rooms” on page 231 for informa-
tion about selecting exterior rooms. 
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Chapter 10:

Doors

Home Designer Pro comes with tools for 
creating a wide variety of interior and 
exterior doors. In addition, the library offers 
a large selection of specialty doors and 
doorways including hinged, sliding, pocket, 
bifold, and garage doors. Additional name-
brand door catalogs are also available for 
download from our web site,  
www.HomeDesignerSoftware.com.

Chapter Contents
•      Door Defaults
•      The Door Tools
•      Displaying Doors
•      Editing Doors
•      Changing Door Swings
•      Special Doors
•      Door Specification Dialog

Door Defaults
Default Settings are accessed by 
selecting Edit> Default Settings. 

Click the “+” next to Doors to show the door 
sub-headings. Select a subheading and click 
the Edit button to open the defaults dialog 
associated with your selection: 

Door Defaults can also be accessed by 

double-clicking the Door Tools  parent 

button or the Hinged Door  or Sliding 

Door  child button. Double-clicking the 
other Door Tools child buttons will open the 
defaults dialog for that particular door type. 

http://www.homedesignersoftware.com/
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The values in the Door Defaults dialog are 
initial values for interior or exterior doors. 
Individual doors can be edited after they are 
created. 

The Door Defaults dialogs look nearly the 
same as the Door Specification dialog. See 
“Door Specification Dialog” on page 265. 
There are only a couple of differences: 
• Since default settings are specified here, 

“Use Default” is not an option for some 
settings as it is in the Door Specification 
dialog.

• The Door Type cannot be changed in the 
Defaults dialogs.

Dynamic Door Defaults
A variety of door default values are dynamic, 
including the Add for Rough Opening 
values, Casing and Lintel Specifications,  
and Hardware. When a dynamic default is 
changed, existing doors using the default 

value are affected. See “Dynamic Defaults” 
on page 57. 

All Materials listed under “Doorway” on the 
Materials tab are also dynamic. Materials 
assigned to doors and hardware items from 
the library are listed separately and are 
dynamically linked to the “Interior Door”, 
“Exterior Door” and “Fixture Trim” and 
“Hardware” materials set in the Material 
Defaults dialog rather than the Cabinet 
Defaults dialog. See “Material Defaults 
Dialog” on page 650. 

Door Framing
The default Rough Opening for doors can be 
defined in the Door Defaults dialogs. You 
can also specify an additional amount to 
cutout for door openings in concrete garage 
curbs and foundation walls. See “General 
Tab” on page 266.

The defaults for trimmers and headers can be 
specified in the Build Framing dialog. See 
“Framing Defaults” on page 436. 

The Door Tools
To place a door, select the type you 
want from the Build> Door submenu. 

With a Door Tool active, move your mouse 
pointer over a wall section. If there is room 
enough along the wall to fit a 12” (300 mm) 
wide door, a preview of the door will display. 
When a preview can be seen, click on a wall 
to place a door in the wall at that location.

Hinged and Sliding Doors have both Interior 
and Exterior Door Defaults. If the wall is an 
exterior wall or one that separates an interior 
from an exterior room, the program places an 

exterior door based on the default settings for 
exterior doors. If the wall is an interior wall, 
the program places an interior door based on 
the default settings for interior doors. This 
rule applies to doors copied and pasted from 
one location to another just as it does to 
newly placed doors. See “Door Defaults” on 
page 253.

Doors can also be placed in curved walls. 
See “Options Tab” on page 268.

Once placed, any door may be changed into 
any other type of door using the Door 
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Specification dialog. See “Door 
Specification Dialog” on page 265.

Hinged Doors
Select Build> Door> Hinged Door 
and click a wall where you want to 

place a hinged door. Hinged doors can be 
placed on interior or exterior walls, and can 
be set up so that different door styles are 
placed in each. A hinged door becomes a 
double door when its width is four feet or 
greater. 

The initial swing direction of a hinged door 
depends on the location of the mouse pointer 
relative to the wall when you click. The door 
will swing towards the side of the wall that 
you click nearest. 

The initial hinge side of a hinged door can be 
set by clicking to place the door and then 
holding the mouse button down rather than 
releasing it. Move the mouse toward the end 
of the door that you would like the hinges to 
be on: as the mouse pointer nears either end, 
the door preview’s hinge side will move to 
that end. You can also adjust the door’s 
swing direction in this manner. When the 
swing direction and hinge side are correct, 
release the mouse button.

Doorways
Choose Build> Door>  Doorway and 
click a wall to place a doorway (an 

opening without a door). Doorways can be 
placed on interior or exterior walls, or in 
railings and fences to provide an opening. 
You can assign a door from the library to a 
doorway.

Sliding Doors
Select Build> Door> Sliding Door 
and click a wall where you want to 

place a sliding door. Sliding doors can be 
placed on interior or exterior walls and can 
be set up so that different door styles are 
placed in each. If placed in an exterior wall, 
the door is glass; if placed in an interior wall, 
it is a solid slab.

The initial opening side of a sliding door can 
be specified by moving the mouse pointer 
along the wall while the mouse button is still 
pressed.  

The default sliding door dimensions are 
5’-0” x 6’-8” with a 12” bottom frame and a 
6” frame on the sides and top. 

Pocket Doors
Select Build> Door> Pocket Door  
and click a wall where you want to 

place a pocket door.

As with sliding doors, the initial opening side 
of a pocket door can be specified by moving 
the mouse pointer along the wall while the 
mouse button is still pressed.  

The default pocket door dimensions are 2’-6” 
x 6’-8” high. A pocket door becomes a 
double pocket door if its width is four feet or 
greater. 

Bifold Doors
Choose Build> Door> Bifold Door 
and click a wall where you want to 

place a bifold door.

Like a hinged door, the initial opening side of 
a bifold door depends on the location of the 
mouse pointer relative to the wall when you 
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click. The door will open towards the side of 
the wall that you click nearest. 

Similarly, the initial hinge side of a sliding 
door can be specified by moving the mouse 
pointer along the wall while the mouse 
button is still pressed.  

The default interior single bifold door is 2’-
6” x 6’-8”. A bifold door becomes a double 
bifold if its width is greater than three feet.

Bifold doors always display closed in all 3D 
views.

Garage Doors
Choose Build> Door> Garage Door 
and click a wall to place a garage door.

The default garage door is 8’-0” x 7’-0” high. 
A garage door must be at least two feet wide.

In floor plan view, dashed lines show the size 
and location of the garage door when open.

Garage doors will build into a garage stem 
wall provided the room is designated as a 
garage before the door is inserted. See 
“Room Types” on page 234.

The Doors & Doorways 
Library

The Doors & Doorways library can be 
accessed by selecting Library> 

Library Browser and browsing to Home 
Designer Content> Architectural. This 
library folder contains a variety of interior 

and exterior doors, as well as special 
entryways and wrapped openings. 

Entryways and wrapped openings are 
examples of Doorways, which are wall 
openings that do not have doors within them.

To add a door to the Doorway, select a Door 
Type other than “Doorway” from the drop-
down list in the Door Specification dialog. 
See “General Tab” on page 266. 

You can also select a custom door from the 
library and place it into a doorway in floor 
plan view or any 3D view.

To place a library door in a doorway

1. Go to floor plan view or any 3D view. 
2. Open the Library Browser. 
3. Navigate through the Doors library cate-

gory until you find the custom door style 
desired. 

4. Select the door in the Library Browser, 
then click on the doorway to place the 
selected door within it. If a door already 
exists, it is replaced. 

5. Continue clicking other doorways until 
all changes have been made.
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Displaying Doors
The display of doors, door labels, 
opening indicators, headers, and 

casing is controlled in the Layer Display 
Options dialog. See “Layer Display Options 
Dialog” on page 104. 

Doors can only be placed in walls, so if a 
wall’s layer is turned off, any doors placed in 
that wall will not display, either. See 
“Displaying Walls” on page 192. 

If the “Doors” layer is turned off, doors and 
their casing do not display but openings in 
the walls where they are located are visible.

In Floor Plan View
When the “Doors” layer is turned on in floor 
plan view, door symbols represent the width 
of the opening and indicate its swing. If a 
door is recessed, the affected wall layers will 
adjust to accomodate the casing.

Doors in exterior walls and doors that open 
to exterior type rooms such as a Garage, 
Porch, or Deck have a threshold line across 
the opening in floor plan view. See “Room 
Types” on page 234.

If an exterior door to a Garage room on Floor 
1 extends into a Garage stem wall or curb on 
Floor 0, its location will be indicated on 

Floor 0. You can control the display of this 
concrete cutout in the Door Specification 
dialog. See “Garages” on page 338. 

When the “Doors, Headers” layer is turned 
on in floor plan view, door headers are 
represented by dashed lines within each 
door’s opening. These lines do not 
correspond to actual framing objects and 
cannot be selected. See “Wall Framing” on 
page 436. 

The vertical casing on the sides of doors will 
display in floor plan view when the 
“Casings, Exterior” and “Casings, Interior” 
layers are turned on. See “Casing Tab” on 
page 269. 

In 3D Views
You can specify whether a selected door is 
shown open or closed in 3D views by 

clicking the Show Door Open in 3D  and 

Show Door Closed in 3D  edit buttons as 
well as in the Door Specification dialog. See 
“Options Tab” on page 268.

If a door is set to display open in 3D, the 
angle of the open door can be changed using 
the edit handles. See “Using the Mouse” on 
page 258.

To display opening indicator arrows in 
Vector Views, turn on the “Opening 
Indicators” layer in the Layer Display 
Options dialog. See “Vector View” on page 
711.

Threshold
Line



258

Home Designer Pro 2014 Reference Manual

Reverse door opening indicators on the 
Architectural panel of the Preferences 
dialog. See “Architectural Panel” on page 73.

You can also specify whether door and 
window glass is opaque or transparent in 
Vector Views in the 3D View Defaults 
dialog. See “Options Tab” on page 669.

Door Labels
Door labels display in floor plan view, 
centered on the doors they represent, when 
the “Doors, Labels” layer is turned on. Door 
labels use the Text Style assigned to this 
layer, as well. See “Object Labels” on page 
884. 

 Door labels indicate Width and Height. For 
example: 
• In Imperial plans, the automatic label for 

a 3’-0” wide, 6’-8” high double hung win-
dow will read 3068.

• In metric plans, the automatic label for a 
900 mm wide, 2100 mm high double 
hung window will read 900x2100.

Customized labels as well as label position 
and orientation can also be specified in the 
Door Specification dialog. 

Editing Doors
Before a door can be edited, it must be 
selected. To select a door, click it when the 

Select Objects  tool or any of the Door 

Tools  are active. Doors and/or windows 
can also be group selected and edited. See 
“Selecting Objects” on page 124. 

Blocked units are made up of individual 
doors and windows that have been grouped 
together to act as one object. You can create 
what is essentially a blocked door unit by 
assigning a library door to a doorway from 
the library

Select a blocked unit by clicking on it in any 
view. To select a door that is a component of 
a blocked unit, click at the location of the 
component in question, then click the Select 

Next Object  edit button. See “Selecting 
Objects” on page 124.

In the Specification Dialog
The most precise method of editing a 
door or group of doors is to use the 

Door Specification dialog. Door type, size, 
casing, materials, shape, and more can all be 
specified in this dialog. See “Door 
Specification Dialog” on page 265. 

Using the Mouse
In floor plan view, click either of the two end 
handles and drag along the wall to change the 
width. The label showing the size updates as 
the handles are dragged. Click and drag the 

Door with opening indicator
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Move handle at the center to move the door 
along the wall it is placed in. Use the 
triangular Rotate handle to adjust the door’s 
swing.  If the door’s label displays, an 
additional handle is available to move the 
label.

In 3D views, a selected door has five edit 
handles: the Move handle at the center and a 
Resize handle on each edge.  Click and drag 
an edge handle to resize the door.  

Using the edit handles, a door resizes 
according to the currently active Edit 

Behavior . See “Edit Behaviors” on page 
120.

A door or window moved against an 
intersecting wall temporarily stops when the 
casing meets the intersecting wall. You can 
continue to drag and it resumes movement 
past the intersecting wall. 

Using Dimensions
Like various other objects, doors can 
be moved using dimensions. See 

“Moving Objects Using Dimensions” on 
page 737. 

You can specify how doors and windows are 
located by dimensions in the Dimension 
Defaults dialog. See “Locate Objects Tab” 
on page 723. 

Dimensions can be set to locate the centers, 
sides, casing, or rough opening of wall 
openings, or you can choose to not locate 
openings at all. If you wish, you can move a 
dimension’s extension lines to locate non-
default locations on a door after the 
dimension is drawn. See “Editing Extension 
Lines” on page 735. 

Using the Edit Tools
A selected door or doors can be edited in a 
variety of ways using the buttons on the edit 
toolbar. See “The Edit Toolbar” on page 29.
• Click the Change Opening/Hinge Side 

 edit button to change the side of the 
door that its hinges are on. See “Changing 
Door Swings” on page 260.

• Click the Change Swing Side  edit 
button to change which direction the 
selected door swings. 

• Click the Show Door Open in 3D  or 

Show Door Closed in 3D  edit button 
to control the selected door’s appearance 
in 3D views. See “In 3D Views” on page 
257.

• Click the Gable Over Door/Window  
to create a gable over the selected door(s) 
the next time the roof is rebuilt. See 
“Gable/Roof Lines” on page 382. 

• Click the Components  edit button to 
modify or add information related to the 
selected door in the Materials List. See 
“Components Dialog” on page 901.

Centering Doors
The Center Object edit button allows 
you to center a selected door along a 

wall within a room or relative to a cabinet or 
window. See “Using Center Object” on page 
156.

To center a door along a wall 

1. Select a door or combination of win-
dows and doors in floor plan view. 
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2. Click the Center Object  edit button 
then choose from one of the following 
options: 

•  Click near a wall inside a room to cen-
ter the door along that wall in that 
room.

•  Click outside the house (on the exterior 
room) near an exterior wall to center 
the door along an exterior wall.

Door Sides
Like walls, all doors have two sides: an 
interior side and an exterior side. This is the 
case even for doors placed in interior walls. 
See “Exterior and Interior Walls” on page 
183. 

By default, the interior side of the door will 
face the direction that the door swings to 
open. If you prefer, you can specify that the 
interior side face the opposite direction in the 
Door Specification dialog. See “General 
Tab” on page 266.  

You can specify the materials for the two 
sides separately in the Door Specification 
dialog. See “Materials Tab” on page 277. 

You can also specify different casing for the 
interior and exterior sides of exterior doors - 

that is, doors placed in exterior walls or walls 
defining a Garage or other exterior room 
type. See “Room Types” on page 234.  

Door Casing
Doors typically feature casing, or trim, on 
both sides of the wall opening. 
• Interior doors use the same casing profile 

on both sides.
• Exterior doors can have different casing 

profiles on their interior and exterior 
sides.

The default casing for interior and exterior 
doors is a basic rectangular stock profile. 
You can specify a door’s casing profiles  in 
the Door Specification dialog, or you can 
choose to suppress casing altogether. See 
“Casing Tab” on page 269.

A separate molding profile can be specified 
for the lintel, or top horizontal molding. See 
“Lintel Tab” on page 271.

Interior and exterior door casing will display 
in all views when the “Casings, Exterior” 
and “Casings, Interior” layers are turned on. 
In floor plan view, only the vertical side 
casing will be shown. 

Changing Door Swings
Door swing direction and hinge 
side can be changed using the 

Change Opening/Hinge Side and Change 
Swing Side edit buttons.

Note: If the door is set to draw closed, the
swing as it appears in floor plan view has no
affect on the 3D view. See “Options Tab” on
page 268.
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The Change Opening/Hinge Side  edit 
button is available for all doors except 
double doors and garage doors.

The Change Swing Side  edit button is 
available for all doors except pocket doors. 

Hinged Doors
In addition to using the edit buttons, hinged 
doors’ hinge side and swing direction can be 
changed using the triangular Rotate edit 
handle.

To adjust the angle of swing:

1. In floor plan view, select the door and 
grab the triangular handle.

2. Drag to change the amount of swing. 

3. Release the mouse. 

If you drag near the closed position, the door 
snaps to a closed position.

To change the swing using edit handles:

1. In floor plan view, select the door and 
grab the triangular edit handle.

2. Drag the pointer along the path of the 
new arc to change the hinge side and/or 
swing direction.

3. Release the mouse.

To change the swing using edit buttons:

1. In floor plan view, select the door.
2. To change the hinge side, click the 

Change Opening/Hinge Side  edit 
button.

You can specify a Double Hinged Door
to swing from its center in the Door
Specification dialog. See “Options Tab”

on page 268.
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3. To change the swing direction, click the 

Change Swing Side  edit button.

Sliding Doors
To change the side of a sliding door that is 
fixed, select the sliding door then click the 

Change Opening/Hinge Side  edit 
button.

To flip the fixed and moving sides of the 

door, click the Change Swing Side  edit 
button.

As with hinged doors, you can also change 
the Opening/Hinge and Swing sides of a 
sliding door by clicking and dragging the 
triangular edit handle.

Pocket Doors
To change the direction of a pocket door, 
select it and click the Change Opening/

Hinge Side  edit button.

You can also specify a Hinged Door to
swing in both directions in the Door
Specification dialog. See “Options Tab”

on page 268.

Note: There must be enough room for the
entire door to fit in the opposite wall or the
door does not change.
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As with hinged doors, you can also change 
the Opening/Hinge side of a pocket door by 
clicking and dragging the triangular edit 
handle.

Bifold Doors
To change the side of a bifold door that is 
fixed, select it then click the Change 

Opening/Hinge Side  edit button.

To change the hinged side of the door, click 

the Change Swing Side  edit button.

As with hinged doors, you can also change 
the Opening/Hinge and Swing sides of a 
bifold door by clicking and dragging the 
triangular edit handle.

Garage Doors
To change the side of a garage door that it 
faces, select it and click the Change Swing 

Side  edit button.

As with other door types, you can also 
change the Swing side of a bifold door by 
clicking and dragging the triangular edit 
handle. 

Special Doors
A variety of special doors and doorways can 
be created in Home Designer Pro.

Wrapped Openings
Wrapped openings of various shapes are 
available in the Doors & Doorways 
Library. 

You can also create a wrapped opening by 
placing a doorway in the wall and checking 
Suppress Casing in the Door Specification 
dialog. See “Casing Tab” on page 269. If 
base molding is present, it will wrap around 
the opening. 
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Openings in Railings

Use the Doorway  tool to open a railing 
for a stairway or other access. 

To open a railing across an entire section, 
resize the doorway’s Width so that it is 
greater than the length of the railing in the 
Door Specification dialog. The opening 
resizes to the maximum width possible for 
that space. See “General Tab” on page 266.

To add a gate, specify the doorway’s Door 
Type as a Door, then choose an appropriate 
gate as the Door Style. A selection of gates is 
available in the Fences & Railings library 
folder. See “Placing Library Objects” on 
page 620. 

Transoms Above Doors
Transom windows above doors are created 
the same as other stacked windows. See 
“Grouped Windows” on page 284.

Recessed Doors
A door placed in a brick or stone wall is often 
recessed into the wall’s exterior. In the 
illustration below, the door to the right is 
recessed, so the brick wraps the opening. The 
door on the left is not recessed, so the casing 
is outside the brick. 

You can specify a door as recessed in the 
Door Specification dialog. See “Options 
Tab” on page 268.

Creating a Doorway 
with a Railing

When a railing is specified as No Room Def, 

it can be positioned within a Doorway .

To create a doorway with railing

1. Place a Doorway  at the desired loca-
tion in your plan.

Doorway
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2. Select Build> Wall> Straight 

Railing , then click and drag to draw 
a railing  parallel to the wall with the 
doorway. 

3. Click on the railing, then use the Resize 
edit handles to adjust the length of the 
railing as needed. See “Using the Edit 
Handles” on page 128.

4. With the railing selected, click the Open 

Object  edit button.
5. On the General tab of the Railing 

Specification dialog, check No Room 
Def and click OK. See “General Tab” on 
page 214.

6. With the railing still selected, Ctrl + drag 
it into position within the doorway. See 
“To move an object freely” on page 153.

Placing a Gable Over a Door
Click the Gable Over Door/Window 
edit button to produce a gable roof 

over the selected door(s) the next time 
automatic roofs are built. See “Gable/Roof 
Lines” on page 382.

You can manually edit or delete this gable 
line at any time. Your changes take effect 
when the automatic roofs are rebuilt. This 
can also be used with group selected doors.

Door Specification Dialog
To open the Door Specification 
dialog, select a door or a group of 

doors and click the Open Object edit button 
or double-click on a door using the Select 

Objects  or a Door  tool.

If a group of doors is selected, changes made 
in the Door Specification dialog are applied 
to all the selected doors. If interior doors 
have different attributes than exterior doors, 
they must be selected and edited as a separate 
group. 

Positioning a railing in a doorway
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General Tab

Door Style - Define the door as slab, 
glass, panel, or louvered, or select a 

door style from the library. Choose “Use 
Default” to use the default door style set in 
the Door Defaults dialog. See “Door 
Defaults” on page 253.
• Select “Library” from the list or click the 

Library button to choose a door symbol 
from the library. Once a library door is 
selected, that door is added to the Door 
Style list. See “Select Library Object Dia-
log” on page 622.

Door Type - Specify doorway, hinged, 
slider, pocket, bifold, or garage door.

Slider, pocket, bifold and garage are not 
allowed as Exterior Door Defaults. 

Specify the Size and Position of the 
selected door. 

• Specify the Width, Height, and Thick-
ness of the door. 

• Floor to Bottom - Specify the height of 
the bottom of the door frame as measured 
from the subfloor. 

• Specify the Swing Angle of the selected 
door in floor plan view, between 0° and 
180°. An angle of 0° displays the door as 
closed and an angle of 180° displays it as 
wide open. The Swing Angle for Bifold 
doors and double doors that swing from 
the center can be no more than 90°. 

The Swing Angle also affects the door’s 

1
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appearance in 3D views if Draw Closed 
is unchecked on the Options tab. 

Add for Rough Opening - Specify the 
amount to add to Each Side, the Top 

and the Bottom for the door’s framed rough 
opening. The rough opening should be large 
enough to accomodate the door frame and 
space for shims. If the Bottom Rough 
Opening value is greater than the Floor to 
Bottom value, the difference is added to the 
top of the rough opening when framing is 
built. 

Add for Concrete Cutout - Specify 
the amount to add to Each Side of the 

door opening when the upper part of the door 
is in a framed wall and the lower part is 
located in a concrete wall, stem wall, or 
garage curb. See “Garages” on page 338.

• Uncheck Show in Plan to suppress the 
display of the concrete cutout in floor 
plan view. See “In Floor Plan View” on 
page 257.

 Louvers Size - Specify the vertical 
height of the selected door’s louvers. 

Only available for doors specified as 
Louvered.

By default, louvers face the direction that the 
door swings. Check Reverse Direction to 
reverse the direction that they face.

A preview of the door displays on the 
right side of the dialog box.

• Check Show Color to show the door in 
color in the preview.

• Select Interior or Exterior to specify 
which side of the door displays in the pre-
view.

6
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Options Tab

Specify the number of Door Units or 
panels that the selected door has. Not 

available for garage doors. 
• Select Single Door to force the selected 

hinged, pocket or bifold door to be a sin-
gle door, regardless of its width.

• Select Double Door to force the selected 
hinged, pocket or bifold door to be a dou-
ble door, regardless of its width.

• Select Calculate From Width to use the 
program defaults. Hinged, pocket and 
bifold doors default to Single Door when 
less than four feet (1200 mm) wide. If the 
width is greater than four feet, Double 
Door is the default. 

• If a Slider door is selected, instead choose 
Four, Three or Two Panel.

Door Swing - Specify how the selected 
door swings. Most options here are 

only available when the selected hinged or 
pocket door is a Double Door. Not available 
for bifold, slider or garage doors. See 
“Changing Door Swings” on page 260.
• Check Both Doors Swing to allow both 

sides of a Double Door to swing. 

1

2

3
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Note: The defaults for Calculate From Width
are not editable.
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• Check Left Swing Only or Right Swing 
Only to allow only the left or right side of 
a Double Door to swing. 

• Check Swings From Center to create a 
Double Door with hinges at the center 
rather than at the outside edges.  

• Check Swings Both Directions to allow a 
door or both sides of a Double Door to 
swing both directions. 

Specify the number of Vertical Panels 
to be placed on a selected garage door. 

Only available for garage doors.

Check Tempered Glass to specify the 
selected door’s glass as tempered.

The Recessed into Wall options allow 
you to recess the selected door into a 

wall, away from the exterior surface. Only 
available if the door is placed in a multi-
layered wall. See “Wall Type Definitions” on 
page 209. 

• Check Recessed to activate the settings 
that follow.

• Select To Main Layer to recess the door 
to the wall’s Main Layer. 

• Select To Sheathing Layer to recess the 
door to the wall’s sheathing layer. 

In Curved Wall - Specify whether a 
door placed in a curved wall is Straight 

or Curved. Curved is selected for Pocket 
Doors and cannot be changed. See “Drawing 
Curved Walls” on page 190.
.

3D Display - Specify whether the 
selected door is drawn open or closed in 

3D and cross section/elevation views. 

If Draw Open is selected, the Swing Angle 
set on the General tab is used in 3D views.

Plinth Blocks - Add an Interior Plinth 
Block and/or Exterior Plinth Block to 

the selected door. Plinth blocks do not 
display in 3D views, but are counted in the 
Materials List. 

Casing Tab
Changes made on the Casing tab can only be seen in 3D views. 

3

4

5

Not Recessed

Recessed to Main Layer

Recessed to Sheathing Layer
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Specify the casing for the selected door. 

• Select the Interior or Exterior radio but-
ton to define the casing for that door side 
and display it in the preview image. This 
choice is not available for interior doors, 
which use the same values for both sides.

• Check Suppress Interior/Exterior Cas-
ing to have a wrapped opening instead of 
casing.

• Define the Width of the selected casing.
• Define the Reveal, the distance between 

the inside edge of the door frame and the 
inside edge of the casing. Define the 
Width of the selected casing.

• Check Suppress Sill to prevent a sill from 
being generated under the door.

• Click the Library button to select a mold-
ing profile for the casing. A preview of 
the casing profile displays in the window 
above. See “Select Library Object Dia-
log” on page 622.

• Click the Clear button to remove a 
selected casing profile from the door. 

The Curved Wall Casing settings are 
enabled if the door is placed in a curved 

wall. See “Drawing Curved Walls” on page 
190. 

Door and window casing and jamb can be 
constructed three ways in curved walls: 

1

2
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• Straight - Both the door and casing are 
straight. This can be used where the wall’s 
curvature is not too sharp and the opening 
is not too wide. It cannot be selected for 
Pocket Doors, which must be curved if 
placed in a curved wall. 

• Radial - A vertical surface that would be 
perpendicular to a straight wall has its 
plane pass through the wall's center of 
curvature. 

• Parallel - A vertical surface that would be 
perpendicular to a straight wall remains 
parallel to the line from the wall center 
through the opening center. 

Lintel Tab
The settings on the Lintel tab allow you to 
assign a lintel,or top molding that meets the 
side casing using a butt joint instead of a 

mitred joint. These settings are not available 
if the door has a reflected arch. See “Arch 
Tab” on page 274.

Straight

Radial

Parallel
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Select the Interior or Exterior radio 
button to define the casing for that door 

side and display it in the preview image. This 
choice is not available for interior doors, 
which use the same values for both sides.
• Check Use Exterior/Interior Lintel to 

have a lintel on the selected side of the 
door instead of the regular top casing. 

Specify a lintel for the selected side of 
the door. 

• Define the Width of the lintel. This value 
is independent of the casing’s width; 

however, the lintel does inherit its depth 
from the casing. 

• Specify how far to Extend the lintel past 
the outside edges of the casing on each 
side. 

• Check Wrap to wrap the lintel profile 
back toward the wall. 

• Click the Library button to select a mold-
ing profile for the lintel. A preview of the 
selected profile displays in the window 
above the button.

• Click the Clear button to remove the 
selected lintel profile from the door. 

1
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Frame & Lites Tab

Specify the number of Lites, or panes 
of glass, as well as their configuration. 

Only available for Glass doors. 
• Specify the number of horizontal Lites 

Across. 
• Specify the number of Lites Vertical. 
• Muntin Width - Specify the width of the 

muntins used to divide the lites.
• Choose a Type, or style, from the drop-

down list. 
• Normal style is the most common, with 

vertical and horizontal muntin bars.

• Diamond style uses angled muntins to 
divide the lites.

• Prairie style is based on the normal style, 
but with all the central muntins removed, 
leaving only the two outside muntins, 
both horizontally and vertically. Lites 
Across and Vertical are typically set 
between 6 and 8.

• Craftsman style is based on the normal 
style, but only the topmost horizontal 
muntin is kept with all the portions of the 
vertical muntins above it. Lites Across 
and Vertical are typically set between 4 
and 8.
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If the door is defined as Round Top on 
the Arch tab, you can specify a Ray 

Count of up to 10 radial muntin bars  in the 
portion of the door within the arch. There is 
one more pane of glass than the number of 
rays specified. 

• Check Concentric to produce muntins 
radiating from a curved inner muntin that 
is concentric with the door’s arch. You 
must have at least three lites across for 
this to be used.

Frame - If the door is a glass, panel or 
louvered door, you can specify the 

dimensions of the door’s rails and stiles. 
• Specify the Width of the stiles and top 

rail. 
• Specify the height of the Bottom rail.

Arch Tab
The settings on the Arch tab are not available 
if the selected door is a Sliding, Bifold or 
Garage door. They are also unavailable if the 

selected door has been assigned a lintel. See 
“Lintel Tab” on page 271.

Normal Diamond Prairie Craftsman

2

3
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Define the style and size of the Arch. 

• Select a Type of arch from the drop-down 
list.

• Specify the Height of the arch, as mea-
sured from the base of the arch to the top 
of the door. The height can be defined for 
all arch types except Round Top and 
Octagonal Arches.

• The Radius can also be defined for Tudor 
and Double Arches.

1

2

1

Round
 Top

Gothic Elliptical Flat
Top

Tudor Double Trifoil Octo-
gonal

Dogear

Broken
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Options - Define the orientation of the 
arch. 

• Check Reflect to reflect the arch, top to 
bottom. This is rarely used for doors, but 
can be specified for windows to create 
unique configurations. Not available if a 
lintel is specified for the selected door. 
See “Lintel Tab” on page 271.

• Select Full  Arch to produce an arch with 
the apex at the door’s center.

• Select Left Arch to produce an arch with 
the apex on the door’s right side.

• Select Right Arch to produce an arch 
with the apex on the door’s left side. 

Hardware Tab
Many of the settings on the Hardware tab are 
Dynamic Defaults: if “Use Default” is 
selected, the setting in the Door Defaults 

dialog is used. See “Dynamic Defaults” on 
page 57.

Specify the Handles to be used on the 
selected door. 

• Select an Interior Handle and/or Exte-
rior Handle from the drop-down lists. 

Select “Library” or click the Library but-
ton to select a handle from the library. See 
“Select Library Object Dialog” on page 
622.

2
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• Specify the location of the door handles  
In From Door Edge.

• Specify the location of the door handles 
Up From Bottom.

Specify the door’s interior and exterior 
Locks. 

• Select an Interior Lock and/or Exterior 
Lock from the drop-down lists. Select 
“Library” or click the Library button to 
select a lock from the library. 

• Specify the location of the door locks Up 
From Bottom. The locks use the same In 
From Door Edge value as the handles.

Specify the Hinges to be used on the 
door. Two hinges are placed for interior 

doors, and three for exterior doors.
• Select a style of Hinges from the drop-

down list. Select “Library” or click the 
Library button to select a hinges from the 
library. 

• Specify the distance In From Top/Bot-
tom of the door to the center of the top 
and bottom hinges. 

Check Hardware on Fixed Section to 
include handles, locks, and hinges on 

the fixed side of a double Hinged door. Only 
available for Double Doors with Left or 
Right Swing Only selected. See “Options 
Tab” on page 268. 

Materials Tab
The Materials tab is available for numerous 
objects. For more information, see 
“Materials Tab” on page 635.

Label Tab
Door labels display in floor plan view when 
the “Doors, Labels” is turned on and use the 
Text Style assigned to that layer. See “Door 
Labels” on page 258. 

For information about the settings on this 
tab, see “Label Tab” on page 885.

2

3

Note: For hinges to look right, it is best to
have at least a 1/4" (6 mm) reveal for the inte-
rior, or hinge side, door casing. 

4
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Chapter 11:

Windows

Home Designer Pro can model a wide variety 
of windows. Fixed glass, hung, casement, 
sliding, awning, hopper, and louver window 
styles can all be created with the standard 
Window tool, and even set as the default. 
The shape of a window can be angled or 
made into a round top or other arch styles. 
Home Designer Pro can create bay, box, and 
bow windows at the click of a button. In 
addition, the library contains many mulled 
window combinations. 

Chapter Contents
•      Window Defaults
•      The Window Tools
•      Special Windows
•      Grouped Windows
•      Window Levels
•      Displaying Windows
•      Editing Windows
•      Bay, Box, and Bow Windows
•      Bay, Box, Bow Windows & Roofs
•      Window Specification Dialog
•      Bay/Box Window Specification Dialog
•      Bow Window Specification
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Window Defaults
Default Settings can be accessed by 
selecting Edit> Default Settings. 

Select Window from the Default Settings 
dialog and click the Edit button.

You can also double-click the Window 

Tools  parent button to open the Window 
Defaults dialog. 

The settings in the Window Defaults dialog 
control the attributes of a window when it is 
initially placed in a plan, so you should 
define the type of window that will be placed 
most often in your model. See “Default 
Settings” on page 56.

The tabs in the Window Defaults dialog are 
similar to those found in the Window 
Specification dialog, with one exception: 

On the General tab of the Window Defaults 
dialog, you can specify the Minimum 
Separation for components windows and 
doors in mulled units in the plan.

The Minimum Separation value in the 
Window Defaults dialog specifies how close 
windows in a mulled unit can be to each 
other. This setting also determines the width 

of the shared casing. If 0 is specified, no 
casing is created between mulled units. 

For more information, see “Window 
Specification Dialog” on page 294.

Dynamic Window Defaults
A variety of window default values are 
dynamic, including the Window Type, Add 
for Rough Opening values, Casing, Lintel 
and Sill Specifications, Sash & Frame 
sizes, and Treatments. All Materials are 
also dynamic. When a dynamic default is 
changed, existing windows using the default 
value are affected. See “Dynamic Defaults” 
on page 57. 

Window Framing
The default Rough Opening for windows can 
be defined in the Window Defaults dialogs. 
You can also specify an additional amount to 
cutout for window openings in concrete 
walls when the upper part of the window is 
located in a framed wall. See “General Tab” 
on page 295.

The defaults for headers can be specified in 
the Build Framing dialog. See “Framing 
Defaults” on page 436. 

The Window Tools
To place a window, select Build> 
Window and choose the desired 

window type. Click on a wall to place a 
window of the selected type at that location. 

Bay, box and bow windows can only be 
placed in straight walls, while standard 
windows can be placed in both straight and 
curved walls. 



The Window Tools

 281

Standard Windows
Select Build> Window> Window, 
then click on a straight or curved wall 

to place a standard window at that location.

A standard window is a single window that is 
not a bay, box, bow window, a corner 
window or a blocked unit. These special 
types are made up of multiple standard 
windows. 

A standard window that is part of a special 
window is called a component window.

Standard windows can be specified as any of 
a variety of window types, such as double 
hung, casement and awning. See “Window 
Specification Dialog” on page 294.

Bay Windows

A Bay Window is composed of three 
wall sections, each with a single 

component window. The two side walls are 
at an angle to the main wall. Select Build> 
Window> Bay Window and click on a 
straight wall to produce a bay window. 

When initially placed, bay windows measure  
2’-2” across at the front, 4’-2” across at the 
back, and are 1’-0” deep. The component 
windows are specified in the Window 
Defaults dialog and their sizes adjust to fit 
the available space. 

Box Windows
A Box Window is a bay window with 
side angles set at 90°. Select Build> 

Window> Box Window and click on a 
straight wall to produce a box window. 

Box windows initially measure 4’-2” wide 
with a depth of 1’-6”. The component 
windows are specified in the Window 
Defaults dialog and their sizes adjust to fit 
the available space. 

Bow Windows
A Bow Window is a group of 
identical wall segments that form a 

segmented curve. Select Build> Window> 
Bow Window and click on a straight wall to 
produce a 5-section bow window. 

Bow windows can be composed of between 
two and twenty sections. The number of bow 
window components can be changed in the 
Bow Window Specification dialog. See 
“Bow Window Specification” on page 313.

The component windows are specified in the 
Window Defaults dialog. Their sizes adjust 
to fit the available space.

The 5-section bow below has a 4’-10” radius 
centered 3’-9” inside the wall, giving an 
opening 5’-10” across and a depth of 11½”.

The roof is affected by Bay, Box and
Bow Windows. These windows should

therefore be placed before the roof is built.
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Note that for a bow with an odd number of 
sections, the radial dimension is from the 
center of the arc to an outside corner where 
two window sections join. The depth (11 ½”) 
is measured to the flat area of the center 
section, not to a corner. As a result, the radius 
is a bit greater  than the sum of the depth and 
the distance from the center of the bow’s 
curve to the exterior of the wall.

Pass-Thru
Select Build> Window> Pass-Thru, 
then click on a straight or curved wall 

to place a Pass Thru at that location. 

A Pass-Thru is simply a wall opening 
without a window unit placed inside. Like a 
window, it can have casing and a sill. It does 
not, however, have a sash, frame, or glass. It 
is one of the window Types available in the 
Window Specification dialog. See “General 
Tab” on page 295.

Windows Library
Select Library> Library Browser, 
then browse to Home Designer Core 

Catalogs> Architectural to access a selection 
of special windows. Select the desired 
window, then click on a wall to place the 
window at that location. 

Special Windows
A variety of special windows can be created 
using multiple standard windows, the edit 
tools or custom symbols.

Creating Manual Bay, Box 
and Bow Windows

Sometimes it is easier to draw bay, box and 
bow windows manually than to use the 
automatic tools. Bays created using walls can 
have more than one window per section, 
which is not possible using a bay window 
unit.

Bear in mind that moving a manually created 
bay, box or bow window is generally more 
difficult than moving a unit created with one 

of the Window Tools  since it is 
composed of individual walls.

Corner Windows
Corner windows are produced when each  
window has one edge at or past the interior 
side of the adjacent wall.

Note: Bay, box, and bow window areas are
not included in the living area or in room stan-
dard area calculations. They are included in
room interior area calculations.
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To create a corner window, first create the 
desired window on each side of the corner. 
The header height and the sill height of both 
windows must be the same. 

Slant top, or shaped windows can be 
components of corner windows as long as 
their heights are equal at the corners. 
Windows with single or two segment tops 
can be used, but windows with three cannot. 
If a two segment window is used, the 
segment nearest the corner must be flat.

Once the corner window is formed, its 
components and corner post size can be 
adjusted using dimension lines. Blocked 
units can also meet at a corner this way.

Special Window Shapes
A selection of special shaped windows is 
available in the Windows Library, including 
arched windows and mulled units. 

In addition, you can create a wide variety of 
window shapes in the Window Specification 
dialog, including:
• Arched windows. See “Arch Tab” on 

page 306.
• Trapezoidal windows. See “Shape Tab” 

on page 304.

Recessed Windows
A window or mulled unit placed in a brick or 
stone wall is often recessed into the wall’s 
exterior, so the brick wraps the opening. 

You can specify a window as recessed in the 
Window Specification dialog. See “Options 
Tab” on page 296.

Placing a Gable 
Over a Window

Click the Gable Over Door/Window 
edit button to produce a gable roof 

over the selected window(s) the next time 
automatic roofs are built. See “Gable/Roof 
Lines” on page 382.

You can manually edit or delete this gable 
line at any time. Your changes take effect 
when the automatic roofs are rebuilt. This 
tool can also be used with group selected 
windows.

Stained Glass
A selection of solid stained glass materials is 
available in the Home Designer Core 
Catalogs> Materials> Glass library. See 
“Materials” on page 631.

Vents
A selection of attic, foundation and gable 
vents are available in the Library Browser. 
See “The Library” on page 603.

Vents are placed in the same manner as 
regular windows and can be edited in much 
the same way, as well. 

To move a window all the way into a
corner, check Ignore Casing for Open-

ing Resize in the Plan Defaults dialog. See
“General Plan Defaults Dialog” on page 58.
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Grouped Windows
Windows can be grouped together to create a 
wide variety of custom configurations. 
Stacked windows are easy to create in 3D 
views, particularly cross section/elevation 
views, using their edit handles. See “Editing 
Windows” on page 289.

Notice how the windows and door in this 
example are separate, with spaces between 
them. Doors and/or windows can also be 
organized into a unit in which there are no 
spaces between the windows and door units, 
and the casing between them is shared. 

To help organize their display in floor plan 
view, you can place stacked windows of 
varying heights on different Window Levels. 
See “Window Levels” on page 285.

Automatically Mulled Openings
To form a mulled group of windows and/or 
doors, move them close enough together so 
that their casings touch. Once the casings 
touch, the windows are mulled together with 
one casing between the two of them. 

The sill of each window in the group must be 
at the same level for them to share the middle 
casing. The casing tops do not have to be at 

the same level. The casings are modeled as if 
they are one unit but the windows  remain 
separate objects for dimensioning and the 
Materials List.

Windows can be automatically mulled to 
doors if the bottom of the window is at the 
elevation of the floor, equal to the bottom of 
the door. 

The Minimum Separation value in the 
Window Defaults dialog specifies how close 
mulled window and door units can be to each 
other. Define a value that specifies the 
desired width for the shared casing. See 
“Window Defaults” on page 280.

Mulled Units in the Library
A selection of mulled window units is 
available in the Windows library. To place 
one in your plan, select it and click on a wall 
in any view. See “Placing Library Objects” 
on page 620.

Selecting Components 
of Mulled Units

To select a component of a mulled unit from 
the library, click at the location of the com-
ponent in question, then click the Select 

Next Object  edit button or press the Tab 
key until that individual component is 
selected. Only the component clicked on is 
selectable using this method. If you need to 
select a different component, click on it and 
repeat the process.

The selected component may be on any 
window level in the mulled unit. If there are 
multiple levels, it is easiest to select the 
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components in a 3D view. When you have 
selected an individual component, you can 
change its parameters in the Window 
Specification dialog. See “Window 
Specification Dialog” on page 294.

If the selected component is not itself a 
mulled unit and has no components above it, 
its Height and Arch parameters can be 
changed. Changing the Height causes the 
component top to move. The bottom remains 
stationary.

Displaying Mulled Units
As with other windows, the display of 
mulled window units is controlled in 

the Layer Display Options dialog. See 
“Displaying Objects” on page 102.

Mulled units are placed on the “Windows” 
layer by default and have a single label, 
which is on the “Windows, Labels” layer. 
Mulled units from the library are also 
included in the windows category of the 
Materials List. If the component objects of a 
mulled unit have unique moldings or 
materials, they will not be noted in the 
Materials List.

If a mulled unit includes a door, Treat as 
Door will be checked in the Mulled Unit 
Specification dialog. When this box is 
checked, the unit’s label is placed on the 
“Doors, Labels” layer but the unit itself 
remains on the “Windows” layer unless you 
change it. Units set to Treat as Door are also 
included in the Doors category of the 
Materials List. See “Options Tab” on page 
296. 

You can, if you wish, display a mulled unit’s 
individual component labels instead of a 
single label for the unit. Labels are placed on 
the layers they would be on were the unit not 
mulled. A mulled unit’s label setting also 
affects how it is listedin the Materials List. 
See “Label Tab” on page 311.
• When Suppress All Labels is selected, 

individual components are counted in the 
Materials List. 

• When Show Component Labels is 
selected, components are counted in the 
Materials List.

• When Show Single Label for Entire 
Unit is selected, the unit is treated as a 
single object in schedules and the materi-
als list. 

Window Levels
It is often necessary to position more than 
one window, mulled unit, and/or door at the 
same location along a wall in floor plan 
view: for example, to create an entry with 
side lites and transom. 

To help control and organize the appearance 
of stacked wall openings in floor plan view, 
you can assign windows at various heights to 
different Window Levels. 

Window Levels do not define the height of a 
window, just the appearance and behavior of 
windows and doors in floor plan view.
• In floor plan view, windows and doors on 

the Default Level display the line color 
and style of the layer they are on. See 
“Layers” on page 101. 

• Windows on any other level appear light 
gray, regardless of the layer they are on. 
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The Default Level
The Default Level is the Window Level that 
Standard Windows are initally placed on 
when created and affects several things: 
• In floor plan view, windows and doors on 

the Default Level display the line color 
and style of the layer they are on.  

• When you click on stacked doors and 
windows in floor plan view, those on the 
Default Level are selected first. To select 
an opening on another level, use the 

Select Next Object  edit button. See 
“Select Next Object” on page 126. 

Typically, the Default Level is set as 0 (zero).

Window Level Zero
Window Level 0 (zero) is the level that all 
bay, box and bow windows and doors are 
always placed on. Typically, it is also the 
Default Level that standard windows are 
placed on, as well. 

Because doors are always on Level 0 and 
because Window Levels affect line colors in 
printouts, it is usually best to keep the 
Default Level at 0. If you do change the 
Default Level, remember to change it back 
before printing.

If you specify the Default Level as a value 
other than zero and then place a window in 
your plan, it will not use all Window 
Defaults settings. Instead: 
• The program will position it above any 

windows that are at the same location but 
on a lower level rather than use the 
default Floor to Top height;

• Its Type will be Fixed Glass;
• Its Height will be 12” (300 mm); 

• It will have no Sill. 

Once the window is created, its parameters 
can be changed. See “Editing Windows” on 
page 289.  

Using Window Levels
The door and windows in the illustration 
below were created on different Window 
Levels. 

To stack windows using Window Levels

1. Place the door and side lites on Window 
Level Zero.

2. Open the Window Defaults dialog and 
change the Default Level to 1.

3. Place the second row of windows above 
the door and side lites on Level Zero. 
The program will automatically posi-
tion fixed glass windows above the door 
and side lites. 

4. Edit these fixed glass windows’ Widths 
and other attributes as needed.

5. Open the Window Defaults dialog and 
change the Default Level to 2.

6. Place the top window above the others. 
The program will place a fixed glass 
window above the windows on Level 1.

Level 0

Level 1

Level 2
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7. Edit this window’s Arch and other attri-
butes as needed.

8. When you are finished, open the 
Window Defaults dialog and change the 
Default Level back to 0.

Displaying Windows
The display of windows, window 
labels, openings, casing, and headers 

in floor plan and 3D views can be controlled 
in the Layer Display Options dialog. See 
“Layer Display Options Dialog” on page 
104.

Windows can only be placed in walls, so if a 
wall’s layer is turned off, any windows 
placed in that wall will not display, either. 
See “Displaying Walls” on page 192. 

If the “Windows” layer is not set to display, 
window casing and other components are not 
visible, but the openings in the walls where 
they are located can still be seen.

In Floor Plan View
A window’s frame, glass, casing, and sill are 
all represented in floor plan view. This 
makes some window types, notably Sliding 
and Double and Triple Casement windows, 
distinguishable.

Bay, box,and bow windows have dimensions 
lines associated with them. 
• You can suppress their display by turning 

off the “Manual Dimensions” layer or on 
a unit by unit basis in the unit’s specifica-
tion dialog. See “Bay/Box Window 
Specification Dialog” on page 311. 

• The arrow style and fill are set in the 
Dimension Defaults dialog. See 
“Dimension Defaults Dialog” on page 
720.

Windows in pony walls display in floor plan 
view regardless of which part of the pony 
wall is visible. If you wish, you can instead 
display only openings located entirely in the 
portion of a pony wall that is set to display in 
floor plan view. See “Pony Wall Defaults” on 
page 178. 

Double Hung

Left Sliding

Triple Casement
Window types in floor plan view
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If a window is placed in a Garage room at a 
height where it extends into the stem wall or 
curb, a cutout in the concrete will display on 
the floor below. You can specify the cutout’s 
size and whether it displays in floor plan 
view in the Window Specification dialog. 
See “General Tab” on page 295. 

Interior and exterior window casings will 
display in all views when the “Casings, 
Exterior” and “Casings, Interior” layers are 
turned on. In floor plan view, the sills and 
vertical side casings will be shown, but the 
horizontal top casing or lintel will not. 

In 3D Views
To show opening indicator arrows in Vector 
Views, turn on the “Opening Indicators” 
layer in the Layer Display Options dialog. 
See “Vector View” on page 711. 

You can change the direction of indicator 
arrows in the Preferences dialog. See 
“Architectural Panel” on page 73.

You can also specify whether window and 
door glass is opaque or transparent in Vector 
Views in the 3D View Defaults dialog. See 
“Options Tab” on page 669.

Window Labels
Window labels display in floor plan view, 
centered on the windows they represent, 
when the “Windows, Labels” layer is turned 
on. Window labels use the Text Style 
specified for this layer, as well. See “Object 
Labels” on page 884.

Automatic window labels indicate Width and 
Height, followed by Type. For example: 
• In Imperial plans, the automatic label for 

a 3’-0” wide, 4’-0” high double hung 
window will read 3040 DH.

• In metric plans, the automatic label for a 
900 mm wide, 1200 mm high double 
hung window will read 900x1200 DH.

You can specify whether a Bay, Box or Bow 
Window displays a single label or displays 
the labels of its component windows and/or 
doors. 
• When Suppress All Labels is selected, 

individual components of Bay, Box and 
Bow Windows are counted in the Materi-
als List. 

• When Show Component Labels is 
selected, components of Bay, Box and 
Bow Windows are counted in the Materi-
als List.

• When Show Single Label for Entire 
Unit is selected, the Bay, Box or Bow 
Windows has one label in floor plan view 
but each component is counted separately 
in the materials list. 

These options are also available for mulled 
units but affect their display the materials list 
somewhat differently. See “Displaying 
Mulled Units” on page 285. 

Windows showing opening indicators
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Customized labels as well as label position 
and orientation can also be specified in the 
Window Specification dialog. 

Editing Windows
Before a window can be edited, it must be 
selected. Click on a window when the Select 

Objects  tool or any of the Window 

Tools  are active. Doors and/or windows 
can also be group-selected and edited. See 
“Selecting Objects” on page 124.

To select a window that is part of a blocked 
unit, click the component window, then click 

the Select Next Object  edit button. See 
“Selecting Components of Mulled Units” on 
page 284.

Windows can be edited using their edit 
handles, the edit toolbar buttons, and the 
Window Specification dialog. See “Window 
Specification Dialog” on page 294.

When you select a window in floor plan 
view, the window size label displays the 
width followed by the height. For example, a 
3036 window is 3’-0” wide by 3’-6” high. 

In the Specification Dialog
The most precise method of editing an 
individual window or group of 

windows is to use the Window Specification 
dialog. The window type, size, casing, 
materials, shape, and more can all be 
specified in this dialog. See “Window 
Specification Dialog” on page 294.

Using the Mouse
• In floor plan view, click either of the two 

end handles and drag along the wall to 
change the width. The label showing the 
size updates as the window is resized. 

• In 3D views, a selected window has five 
edit handles: the Move handle at the cen-
ter and a Resize handle on each edge. 
Click and drag an edge handle to resize 
the window.

• Using the edit handles, a window resizes 
according to the currently active Edit 

Behavior . See “Edit Behaviors” on 
page 120.

• A single window or a group of windows 
can be moved with the center edit handle.

• A door or window moved against an 
intersecting wall temporarily stops when 
it is the casing distance from the inter-
secting wall. You can continue to drag 
and it resumes movement past or onto the 
intersecting wall. Enable Ignore Casing 
for Opening Resize in the Plan Defaults 
dialog to turn off this behavior. See “Gen-
eral Plan Defaults Dialog” on page 58.

Note: Using the edit handles is the only way
to resize bay, box and bow window systems.
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Using Dimensions
Like various other objects, windows 
can be moved using dimensions. See 

“Moving Objects Using Dimensions” on 
page 737. 

You can specify how windows and doors are 
located by dimensions in the Dimension 
Defaults dialog. See “Locate Objects Tab” 
on page 723. 

Dimensions can be set to locate the centers, 
sides, casing, or rough opening of wall 
openings, or you can choose to not locate 
openings at all. If you wish, you can move a 
dimension’s extension lines to locate non-
default locations on a window after the 
dimension is drawn. See “Editing Extension 
Lines” on page 735. 

Using the Edit Tools
A selected window or windows can be edited 
in a variety of ways using the buttons on the 
edit toolbar. See “The Edit Toolbar” on page 
29.

• Click the Gable Over Door/Window  
to create a gable over the selected win-
dow(s) the next time the roof is rebuilt. 
See “Gable/Roof Lines” on page 382. 

• Click the Components  edit button to 
modify or add information related to the 
selected window in the Materials List. 
See “Components Dialog” on page 901.

Window Casing & Sills
Windows often feature casing, or trim, on 
both sides of the wall opening as well as a sill 
on one or both sides. 

The default casing for windows is a basic 
rectangular stock profile. You can specify a 
window’s casing profiles in the Window 
Specification dialog, or you can choose to 
suppress casing altogether. See “Casing Tab” 
on page 297.

A separate molding profile can be specified 
for the lintel, or top horizontal molding. A 
sill profile can be specified, as well. See 
“Lintel & Sill Tab” on page 299.

Bay, Box, and Bow Windows
Bay, Box and Bow Windows 
are created much the way 

regular windows are: select a tool, then click 
a wall to place that window type. 

Home Designer Pro automatically builds a 
foundation under bay/box/bow windows 
placed on floor 1 unless they are raised from 
their original position. That section of the 
foundation wall is also a bay/box/bow, but 
without windows. If the foundation was 
generated before the window is placed, the 

foundation must be rebuilt or edited 
manually.

Editing Bay, Box and 
Bow Windows

Bay, box and bow windows are edited 
similar to regular windows, with one 
exception: in floor plan view, a diamond-
shaped Depth edit handle displays on the 
section. Drag this Depth handle outward to 
increase the depth, or inward to decrease the 
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depth of the unit. See “Editing Windows” on 
page 289.

Bay, box and bow windows can also be 
edited in their respective specification 
dialogs. See “Bay/Box Window 
Specification Dialog” on page 311 or “Bow 
Window Specification” on page 313.

Displaying Bay, Box 
and Bow Windows

The display of bay, box and bow windows is 
controlled in the Layer Display Options 
dialog. See “Layer Display Options Dialog” 
on page 104. 

Like other windows, bay, box and bow 
windows can display labels. See “Window 
Labels” on page 288. 

Bay, box and bow window width and radius 
dimensions, which display in floor plan view, 
are placed on the “Dimensions, Manual” 
layer. See “Displaying Objects” on page 102.

Component Windows
A component window within a bay, box or 
bow window can be resized like any other 
standard window. To select a component 
window, click at the location of the 
component in question, then click the Select 

Next Object  edit button or press the Tab 
key. 

• Only the bay or box window component 
that was clicked on is selected using this 
method. If you need to select a different 
component, click on it and repeat the pro-
cess.

• In a bow window, all components are 
identical, so only one component can be 
selected. Changing this component 
changes them all.

Resizing Components
An individual component window can be 
resized using the edit handles, by changing 
settings in the component’s Window 
Specification dialog, or by using the 
Transform/Replicate Object dialog. See 
“Transform/Replicate Object Dialog” on 
page 166. 

When a bay/box/bow window is first created, 
there is room for one standard trimmer on 
each side of each component window. When 
the bay as a whole is moved and resized, its 
components automatically resize so that a 
standard trimmer is still accomodated. 

If you increase a component window’s width 
to the point where there is not enough room 
for standard trimmers, a thinner trimmer can 
be used. The size of this thinner trimmer is 
specified in the Build Framing dialog. See 
“Openings Tab” on page 448. 

If a component window is resized, it retains 
its size if at all possible when the containing 
bay/box/bow window is moved or resized. If 
the bay is resized in such a way that the 
component is too large to fit even with a 
thinner trimmer, the component resumes its 
default behavior, resizing as the containing 
bay window is resized.

Depth edit handle on a bay window
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Floors and Ceilings
When originally created, the floor and 
ceiling within a bay, box, or bow window are 
the same heights as the floor and ceiling of 
the room in which it is placed. 

Both the top and bottom heights of these 
window units can be adjusted in a 3D view 
using the window’s edit handles to create a 
lowered ceiling and/or a bench seat or garden 
window.

When the ceiling is lowered, the top heights 
of the walls that define the window unit are 
also lowered. When a roof is built over the 
unit, its height will be affected, as well.

When the bottom of the window is raised to 
create a bench seat, the unit’s walls will not 
reach the ground. As a result, window units 
with bench seats will have no foundation 
beneath them when the foundation is built.

Bay, Box, Bow Windows & Roofs
Several different roof styles can be specified 
for bay, box and bow window units in the 
Bay/Box and Bow Specification dialogs. 
See “General Tab” on page 312 and “General 
Tab” on page 313. 

If you change a bay, box, or bow window’s 
roof specification, you will need to rebuild 
the roofs to see the changes. See “Rebuilding 
Roofs” on page 355. 

Hip Roofs
By default, a hip roof is built above the unit 
when roofs are automatically generated. No 

roof directives need to be selected in the 
specification dialog to produce this roof.
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Use the Existing Roof
To generate a standard roof that ignores a 
bay, box, or bow window, check Use 
Existing Roof. 

With this option the bay, box, or bow 
windows is tucked under the roof eave. You 
may find it helpful to increase the width of 
the eaves. See “Roof Tab” on page 356.

Extend the Existing Roof
To have the main roof extend down over the 
window unit and follow the shape of the unit, 
select Extend Existing Roof Over. 

For this roof style, the ceiling heights of the 
window unit and the adjacent room must be 
the same. If you lower the ceiling of the 
window unit and then build the roof, a lower 
hip roof over the window is created. See 
“Floors and Ceilings” on page 292.

If a header is desired over the window unit, 
first build the roof, then lower the ceiling of 
the window unit. Once the ceiling is lowered, 

select Rebuild Walls/Floors/Ceilings . 
Do not rebuild roof planes.

Rectangular Hip Roofs
To create a rectangular-shaped hip roof 
above a bay, box, or bow window, select 
Rectangular Roof Over.

Extend Existing Roof - 
Rectangular

To extend the main roof down over a window 
unit to create a rectangular roof over it rather 
than one that follows its shape, select both 
Extend Existing Roof over and 
Rectangular Roof Over. 

Gable Roof
A gable roof is not one of the automatic 
options for the roof above a bay, box or bow 
window. A gable can be created by manually 
editing the rectangular hip roofs that are 
automatically created. See “Roof Planes” on 
page 362.
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To create a gable over a bay window

1. Select the front ridge corner handle of 
each side hip roof plane and drag the 
edge forward until the fascia snaps to the 
edge of the front hip section. 

2. Delete the front hip section. 
3. Adjust the roof’s overhang as needed. 

Window Specification Dialog
To open the Window Specification 
dialog, select a window or a group of 

windows and click the Open Object edit 
button or double-click the window using the 

Select Objects  or a Window  tool. 

The settings in this dialog are similar to those 
in the Window Defaults dialog. See 
“Window Defaults” on page 280.

The settings in this dialog are also similar to 
those in the Mulled Unit Specification 
dialog for mulled units. Although similar, a 
number of the options cannot be edited when  
a mulled unit is selected. See “Grouped 
Windows” on page 284.

To create a gable roof over a normal
window, use the Gable Over Door/

Window edit button. See “Gable/Roof Lines”
on page 382.
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General Tab

Window Type - Select the type of 
window from the list. The first entry in 

the list is the Default type set in the Window 
Defaults dialog. 

Specify the Size and Position of the 
selected window. 

• Specify the Width and Height of the 
window. 

• Floor to Top - Specify the height of the 
top of the window frame as measured 
from the subfloor. 

• Movable Size - Specify the dimension of 
the movable portion of the window. A 
value of 0 defaults the movable size to 
whatever is normal for that type of win-

dow. Not available for Fixed Glass, Sin-
gle or Double Casement, Single Awning 
or Hopper, Louvered, Pass-Thru or 
mulled units. 

• Louver Size - Specify the vertical height 
of the selected window’s louvers. Only 
available for Louvered windows. 

Add for Rough Opening - Specify the 
amount to add to Each Side, the Top 

and the Bottom for the window’s framed 
rough opening. The rough opening should be 
large enough to accomodate the window 
frame and space for shims.

Add for Concrete Cutout - Specify 
the amount to add to Each Side of the 

1
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window opening when the upper part of the 
window is in a framed wall and the lower 
part is located in a concrete wall, stem wall, 
or garage curb. See “Garages” on page 338. 
• Uncheck Show in Plan to suppress the 

display of the concrete cutout in floor 
plan view. See “In Floor Plan View” on 
page 287. 

Swing Direction - Select from the 
available hinge options. The preview in 

the dialog updates as options are changed. 

Only available for Casement, Double and 
Triple Awning, and Double and Triple 
Hopper windows. 

A preview of the selected window 
displays here. 

• Check Show Color to show the window 
preview in color.

• Select Interior or Exterior to specify 
which side of the window displays in the 
preview.

Options Tab

Options -

• Check Interior Corner Block to count 
interior corner blocks in the materials list. 
These do not display in 3D views.

• Check Exterior Corner Block to count 
exterior corner blocks in the materials 
list. These do not display in 3D views. 

• Check Egress to specify the window as 
an egress window in the Materials List. 
Not available for Pass-Thrus.  

• Check Tempered Glass to specify the 
selected window’s glass as tempered.  

5

6
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1

Consult your local building and fire code
authorities for your local egress window

requirements.
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• Check Reverse Symbol to reverse the 
window as though it were reflected about 
a vertical line through its center. 

The Mulled Units options are available 
when a mulled unit is selected.

• Check Treat as Door to include the unit 
in Door category of the Materials List 
rather than in the Materials List category. 
Only available when the selected unit 
contains a door.

• Uncheck Single Label to produce labels 
and Materials List entries for each com-
ponent of the unit. When checked, the 
unit is treated as a single object for 
labeling in floor plan view and in the 
Materials List. 

• Uncheck Single Wall Hole to produce 
individually framed wall openings for 
each unit in a mulled unit. When this box 
is checked, a single wall opening with 
one header for the entire unit is produced. 

Specify the Mullion Depth for the 
casing between the components of a 

blocked unit, measured from wall surface. 
Positive values move the mullion surface 
towards the wall center; negative values, 
away from it. Only available when a mulled 
unit is selected.
• Specify the Inside depth of the mullion 

on the interior surface of the wall. 

• Specify the Outside depth of the mullion 
on the exterior surface of the wall. 

The Recessed into Wall options allow 
you to recess the selected window or 

mulled unit into a wall, away from the 
exterior surface. Only available if the 
window or mulled unit is in a multi-layered 
wall. Check Recessed to enable these 
options. 
• Select To Main Layer to recess the 

window to the wall’s Main Layer. 
• Select To Sheathing Layer to recess the 

window to the wall’s sheathing layer. 

Vertical Stacking - Specify the 
window Level that the selected window 

is placed on. See “Window Levels” on page 
285.

Casing Tab
Changes made on the Casing tab can only be 
seen in 3D views.  

2
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Not Recessed

Recessed (to Main Layer)

Recessed to Sheathing Layer
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Specify the casing for the selected 
window or mulled unit. 

• Select the Interior or Exterior radio but-
ton to define the casing for that window 
side and display it in the preview image. 

• Check Suppress Exterior/Interior Cas-
ing to have a wrapped opening instead of 
casing on the selected side of the window.

• Define the Width of the selected casing, 
including the Apron, if one is being used. 
If a Lintel is defined, this setting does not 
affect the top. See “Lintel & Sill Tab” on 
page 299.

• Define the Depth of the selected casing, 
as measured from the back to the front of 
the casing profile. This setting also 

affects the lintel, sill, and apron if speci-
fied. See “Lintel & Sill Tab” on page 299.

• Define the Overlap Frame value, which 
is the the distance between the outside 
edge of the window frame and the inside 
edge of the casing. The default is 0”, 
which places the inside edge of the casing 
against the outside edge of the frame.

Type a positive value to overlap the cas-
ing over the frame by that amount. 

Type a negative value to produce a gap 
between the casing and the frame.

To produce a reveal of a certain width, 
subtract the desired reveal from the total 

1

2

1
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width of the frame and type the result 
here. 

• Click the Library button to select a 
molding profile for the casing. A preview 
of the casing profile displays in the win-
dow above.

• Click the Clear button to remove a 
selected casing profile from the window. 

Door and window casing and jamb can 
be constructed three ways in curved 

walls: 
• Straight - Both window sash and casing 

are straight. Straight casing may not fit 
properly into a wall if the window is too 
wide or the curvature of the wall, too 
tight.

• Radial - The sides of the casing or jambs 
are inserted in the wall at an angle that 
passes through the center of the curve. 

• Parallel - The sides of the casing are 
inserted in the wall at a right angle to the 
line tangent to the curved wall at the cen-
ter of the window. 

Normally, parallel casing has a straight sash. 
Radial casing is more like traditional curved 
windows, and typically has a curved sash.

Lintel & Sill Tab
The settings on the Lintel tab of the Window 
and Mulled Unit Specification dialogs allow 
you to assign a sill and lintel, or top molding 
that meets the side casing using a butt joint 

instead of a mitred joint. These settings are 
not available if the window has been 
assigned a reflected arch. See “Arch Tab” on 
page 306.

2

Straight

Radial

Parallel
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Select the Interior or Exterior radio 
button to define the lintel and/or sill for 

that window side and display that side in the 
preview image. 
• Check Use Exterior/Interior Lintel to 

have a lintel on the selected side of the 
window instead of regular top casing. 

Specify a lintel for the selected window 
or mulled unit. 

• Define the Width of the lintel. This value 
is independent of the casing’s width; 
however, the lintel does inherit its depth 
from the casing. 

• Specify how far to Extend the lintel past 
the outside edges of the casing on each 
side. 

• Check Wrap to wrap the lintel profile 
back toward the wall. 

• Click the Library button to select a 
molding profile for the lintel. A preview 
of the selected profile displays in the win-
dow to the left of the button.

• Click the Clear button to remove the 
selected lintel profile from the window. 

Specify the sill for the selected window 
or mulled unit. 

• Check Use Exterior/Interior Sill to have 
a sill on the selected side of the window. 

• Specify how far to Extend the sill past 
the outside edges of the casing on each 
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side. If an Apron is specified, it will also 
be affected by this setting.

• Check Wrap to wrap the sill profile back 
toward the wall. 

• Check Apron to include an apron under 
the sill. When Wrap is checked, the 
Apron will always be 1/2” (12 mm) 
shorter than the sill on each side; when 

Wrap is unchecked, it will be the same 
length as the sill.

• Click the Library button to select a 
molding profile for the sill. A preview of 
the sill profile displays in the window to 
the left of the button.

• Click the Clear button to remove the 
selected sill profile from the window. 

Sash & Frame Tab
The settings in the Sash & Frame tab are not 
available in the Mulled Unit Specification 
dialog.

Specify the size and position of the 
Sash. Increasing the Side, Middle, Top 

or Bottom decreases the area of the glass.
• Specify the Side width of all vertical sash 

members: those at the window sides as 
well as the central members of casement 
and sliding windows. This is also the 
width of the top portion of the window 
when an arch is specified.

• Specify the Middle width of horizontal 
components between the top and bottom 
sash in double hung, double and triple 
awning, and double and triple hopper 
windows. It does not affect casement and 
sliding windows.

• Specify the Top and Bottom sash widths. 
The Top value is not used if the window 
has an arch.

1 2
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• Specify the Depth, or thickness, of the 
sash stock measured from the exterior to 
the interior.

• Specify the Inset, the distance between 
the frame and the outermost sash. If there 
is no frame, the inset is measured from 
the outer surface of the wall’s main layer.

Specify the size and position of the 
Frame. If this value is set to zero, the 

wall’s main layer thickness is used as the 
frame depth. 
• Specify the Side, Top and Bottom widths 

of the window frame. 
• Uncheck Fit Frame to Wall to specify 

the Depth and Inset of the selected win-
dow’s frame. When this box is checked, 
the frame’s outside surface aligns with 
the outer surface of the wall layer outside 
of the Main Layer, and its depth extends 
to the wall’s interior surface. 

• Specify the frame Depth. 
• Specify the distance that the frame is 

Inset from the exterior of the wall’s Main 
Layer. When this value is 0, the outer sur-
face of the frame aligns with the outer 
surface of the Main Layer. A  positive 
value moves the frame towards the wall’s 

interior while a negative value moves it 
towards the exterior.

Curved Sash Options - Specify 
whether a window placed in a curved 

wall is also curved or is straight.  Normally, a 
curved sash is used with radial casing. See 
“Casing Tab” on page 297.

Lites Tab
The Lites tab allows you to add muntins to 
various window styles. There are four 
possible styles of muntin bars for regular 
windows, plus two additional options for 
arch top or round top windows.

A window that has been modified using the 
Shape tab cannot have divided lites or 
shutters added.
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Specify the number, position and style 
of Lites for the selected window.

• Enter the number of horizontal Lites 
Across in each sash. 

• Enter the number of vertical Lites Verti-
cal in each sash.

• Specify the Muntin Width, which is the 
width of the bars dividing the panes of 
glass.

• Check or uncheck Lites in Fixed and 
Lites in Moveable to specify either one 
or both of the sashes to have divided lites.

Select a Type, or style, of window lite 
from the drop-down list. 

• Normal style is the most common, with 
muntins going horizontally and vertically. 
Colonial windows are an example of the 
normal style.

• Diamond style uses angled muntin bars 
to divide up the lites. French windows are 
an example of the diamond style.

1

2

1

Lites in Fixed Lites in Movable

Note: Because the fixed window in a Triple
Sliding window is twice the size of the mov-
able windows, the fixed section has a vertical
muntin bar. To eliminate this, clear the Lites in
fixed check box.

2
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• Prairie style is based on the normal style, 
but with all the central muntin bars 
removed, leaving only the two outside 
muntin bars both horizontally and verti-
cally. Typically, both Lites Across and 
Lites Vertical should be set between 6 
and 8. Federal or Federation windows are 
an example of the Prairie style.

• Craftsman style is based on the normal 
style, but only the topmost horizontal 
muntin bar is kept with all the portions of 
the vertical muntin bars above it. Typi-
cally, both Lites Across and Lites Vertical 
should be set between 4 and 8.

If the window is defined as Round 
Top, you can specify a Ray Count of 

up to 10 radial muntin bars in the portion of 
the window within the arch. There is one 
more pane of glass than the number of rays 
specified. See “Arch Tab” on page 306.

• Check Concentric to produce muntins 
radiating from a curved inner muntin that 
is concentric with the window’s arch. 
You must have at least three lites across 
for this to be used.

Shape Tab
Any type of non-symbol window may be 
shaped. All “shaped” windows are defined as 
“Fixed Glass” on the General tab. 

If the selected window has an arch assigned 
to it on the Arch tab and changes are made on 
Shape Tab, the window will lose its arch 
assignment. 

3
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Window Width displays for reference. 
It can be changed on the General tab.

Left Side - Specify the Height of the 
left upper corner, as measured from the 

bottom of the window. Unless changed, this 
matches the window height. Minimum value 
is 1/4” (4 mm). 

The height of the Right Side can be specified 
in a similar manner.

Check Left Inner Corner to add an 
additional corner along the top edge.

• Specify the Height of the left inner cor-
ner, as seen from the exterior, measured 
from the bottom of the window.

• Specify the Offset of the left inner cor-
ner, as measured from the left side of the 
window. Minimum value is 1” (10 mm). 

An additional Right Inner Corner can be 
specified in a similar manner.

Check Raise Bottom Left to raise the 
height of the bottom left corner.

• Specify the Height of the bottom left cor-
ner, as seen from the exterior, measured 
from the bottom of the window. This 
value cannot exceed the Height of the 
Left Side.

1
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6

Note: The Left Side settings for a window’s
Interior affect the Right Side settings for its
Exterior, and vice versa.
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The height of the Bottom Right corner can 
be raised in a similar manner.

Click Match Roof to match the angle 
of the top of the window to the pitch of 

the roof on a gable end. The window 
maintains the angle even when resized and 
repositioned. Left and Right Inner Corner 
must both be unchecked for this to work. 
This option does not work for curved roofs.
• Click Revert to restore the window to its 

original shape, type and arch settings. 

A shaped window must have two vertical 
sides at least 1/4” high. 

The following diagram represents added 
Inner corners using open circles and the left 
and right corners using solid black circles:

• A has different left and right heights with 
no Inner corner added. 

• B has matching left and right heights with 
an added Inner corner. 

• C is the same as B, except that the left 
and right heights have been shortened to 
1/4”. 

• D is the same as B except it has two 
added Inner corners.

• E is the same as A except that Raise Bot-
tom Right has been defined.

A preview of the selected window 
displays here.

• Check Show Color to show the window 
preview in color.

• Select Interior or Exterior to specify 
which side of the window displays in the 
preview. This can significantly affect a 
shaped window’s appearance in the 
preview, as the Left and Right Side 
settings refer to the side of the window 
shown in the preview. 

Arch Tab
The settings on Arch tab of the Mulled Unit 
Specification dialog define the overall shape 
of the blocked unit’s top. If the mulled unit 

already includes a component window with 
an arch, these settings cannot be modified.

5

6
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A window that has been modified using the 
Shape tab cannot have an arched top.

Define the style and size of the Arch. 

• Select the Type of arch desired from the 
drop-down list.

1

2

3

1

Round
Top

Gothic Elliptical Flat
Top

Broken

Tudor Double Octo-
gonal

Trifoil Dogear
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• Specify the Height of the arch, as mea-
sured from the base of the arch to the top 
of the window. The height can be defined 
for all arch types except Round Top and 
Octagonal Arches.

• The Radius can also be defined for Tudor 
and Double Arches.

Options - Define the orientation of the 
arch. 

• Check Reflect to reflect the arch, top to 
bottom. You can reflect a window with a 
Round Top arch to create a round win-
dow. Not available if a lintel is specified 

for the selected window. See “Lintel & 
Sill Tab” on page 299.

• Select Full Arch to produce an arch with 
the apex at the window’s center. 

• Select Arch on Left to produce an arch 
with the apex on the window’s right side. 

• Select Arch on Right  to produce an arch 
with the apex on the window’s left side.

A preview of the selected window 
displays here.

• Check Show Color to show the window 
preview in color.

• Select Interior or Exterior to specify 
which side of the window displays in the 
preview. This can significantly affect a 
shaped window’s appearance in the 
preview, as the Left and Right Side 
settings refer to the side of the window 
shown in the preview. 

Treatments Tab
The settings on the Treatments tab allow you 
to assign embellishments to the interior and 

exterior of the selected window or mulled 
unit.

Note: The settings on the Shape tab take pre-
cedence over those on the Arch tab. If the
window’s Shape has been modified, you can
select an Arch but it will have no effect on the
window’s appearance.

2
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Specify Interior  Treatments for the 
selected window or mulled unit. 
• Specify a style of Curtains by selecting 

“Use Default”, “None” or “Library” from 
the drop-down list.  If a non-default 
library item has been selected, its name 
will display in the list, as well.

• Click the Library button or select 
“Library” from the Curtains drop-down 
list to choose a style of curtain from the 
library. See “Select Library Object Dia-
log” on page 622. 

• Specify the Height Off Floor of the bot-
tom edge of the curtains. 

• Specify the Height Above Casing of the 
top of curtains. 

• Specify a style of Blinds in the same 
manner that Curtains are chosen, above.

A preview of the selected window displays 
on the right.
• Check Show Color to show the window 

preview in color.
• Select Interior or Exterior to specify 

which side of the window displays in the 
preview. In order to see interior 
treatments in the preview, Interior must 
be selected. 
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Shutters Tab
The settings on the Shutters tab allow you to 
specify exterior shutters for the selected 
window or mulled unit. 

Check Use Shutters to apply shutters 
to the selected window’s exterior and 

enable the settings below. 

Specify the Shutter Width for the 
selected window.

• Unheck Set Width by Window to type a 
width in the Specify Width field. If the 
window is later resized, the shutters 
width will not adjust in response.

• When Set Width by Window is checked, 
a shutter width exactly half that of the 
window, excluding casing, is used.

Additional Shutter Options can be 
specified here.

• Check Outside Casing to position shut-
ters outside the window casing, as deco-
rative shutters often are. Uncheck this to 
position the shutters just outside the win-
dow frame, like functional shutters.

• Check Louver for louvered shutters. 
Uncheck this for solid shutters. If Outside 
Casing is checked, the louvers face out-
ward, away from the wall; if checked, 
louvers face toward the wall.

1
2
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• Check No Arch for shutters with flat tops 
that reach the bottom of the curved por-
tion of an arched window. Only available 
when an Arch is selected. See “Arch Tab” 
on page 306.

Shutter Sides - Specify which sides of 
the selected window receive shutters. 

• Select Automatic to assign shutters to 
both sides of the window as long as there 
is sufficient room on the wall. If the win-
dow is next to a wall intersection or cor-
ner, the shutter closest to the intersection 
will not generate. 

• Select Both Sides to assign shutters to 
both sides of the window under all cir-
cumstances, even if there isn’t enough 
room on the wall for one or both of them.

• Select Left Side Only to assign a shutter 
to the left side of the window and none on 
the right. 

• Select Right Side Only to assign a shut-
ter to the right side of the window and 
none on the left.

A preview of the selected window 
displays on the right.

• Check Show Color to show the window 
preview in color.

• Select Interior or Exterior to specify 
which side of the window displays in the 
preview. In order to see exterior shutters 
in the preview, Exterior must be selected. 

Materials Tab
The settings on the Materials tab are the 
same as those found on the same tab in 
dialogs throughout the program. See 
“Materials Tab” on page 635.

The settings on the Materials tab of the 
Mulled Unit Specification dialog apply to all 
components of the blocked unit. Any settings 
made for individual components of the 
blocked unit are overridden here.

Label Tab
Window labels display in floor plan view 
when the “Windows, Labels” layer is turned 
on and use the Text Style assigned to that 
layer. See “Window Labels” on page 288. 

For more information about the settings on 
this tab. See “Label Tab” on page 885.

Bay/Box Window Specification Dialog
To open the Bay/Box Window 
Specification dialog, select one or 

more bay or box windows and click the 
Open Object edit button.

The options in this dialog can only be set for 
objects placed in a plan: bay or box windows 
do not have defaults dialogs. Many of these 
same options are available for Bow 
windows. See “Bow Window Specification” 
on page 313. 

4
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General Tab

Specify the Bay Angle, which is the 
angle of the side components of the bay 

or bow window. Bay windows have an angle 
of 45° by default; box windows have an 
angle of 90°.

Specify the structure of the automatic 
Roof over the selected window unit. 

See “Bay, Box, Bow Windows & Roofs” on 
page 292. 
• Check Use Existing Roof if the existing 

roof needs no changes to accomodate the 
bay window.

• Check Extend Existing Roof Over to 
extend the existing roof plane to cover 
the bay window below.

• Check Rectangular Roof Over to create 
a roof over the bay window that is square 
across the end instead of following the 
profile of the roof. 

Specify the appearance of the selected 
window unit’s Labels in floor plan 

view and the Materials List.
• Check Suppress Dimension to suppress 

the automatically-produced dimensions 
that show the size of the window unit in 
floor plan view. 

Specify the structure of the selected 
window unit’s Components and the 

wall sections containing them.
• Uncheck Has Component Windows to 

remove the component windows of the 
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bay or box window unit and disable the 
settings that follow.

By default, Bay and Box Windows have one 
standard trimmer when first created. 
• Check No Trimmers for Components to 

eliminate the trimmer stud for bay com-
ponents, allowing the component win-
dow width to increase. See “Wall 
Framing” on page 436.

• Check No Framing Between Compo-
nents to remove both studs between the 
bay components.

If the selected unit is later moved or resized, 
its components automatically resize to use a 
standard trimmer, regardless of whether 
either of the two options above are selected.
• Check Components Recessed to recess 

the exterior casing into the wall. Typi-
cally used if the window is placed in a 

brick wall and you want to produce a 
brick molding. When checked, the 
options below become available. 

• Select To Main Layer to recess the com-
ponents to the wall’s Main Layer instead 
of the outside wall layer. See “The Main 
Layer” on page 209. 

• Select To Sheathing Layer to recess the 
components to the sheathing layer instead 
of the outside wall layer.

Label Tab
Bay and Box Window labels display in floor 
plan view when the “Windows, Labels” layer 
is turned on and use the Text Style assigned 
to that layer. See “Window Labels” on page 
288. 

For more information about the settings on 
this tab. See “Label Tab” on page 885.

Bow Window Specification
To open the Bow Window 
Specification dialog, select one or 

more Bow Windows and click the Open 
Object edit button or double-click on a Bow 

Window using the Select Objects  or a 

Window  tool. 

Many of the options in this dialog are the 
same as the Bay/Bow Window 
Specification. See “Bay/Box Window 
Specification Dialog” on page 311. 

General Tab
Four  options are unique to the Bow Window 
Specification dialog:

Specify the Number of Sections, or 
components, in the window unit.

Check Suppress Standard Dimension 
to suppress the automatically produced 

dimensions that show the width and depth of 
the bow in floor plan view.

Check Suppress Dimension to Center 
to suppress the radial dimension.

Check Connect Outer Casing to have 
the exterior casing surround all three 

1
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bay component windows together, not 
separately. Mullions are provided between 
components. This is how casing is always 
done for the interior. 

Label Tab
Bow Window labels display in floor plan 
view when the “Windows, Labels” layer is 

turned on and use the Text Style assigned to 
that layer. See “Window Labels” on page 
288. 

For more information about the settings on 
this tab. See “Label Tab” on page 885.
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Chapter 12:

Multiple Floors

When a new plan file is opened in Home 
Designer Pro, two floor levels are present: 
Floor 1 and the Attic Floor. You can add 
more floors whenever you like: up to 3 total. 
Once created, floors can also be copied and 
deleted. 

Home Designer Pro also supports special 
floors for foundations and attics. Only one 
foundation level and one attic can exist in a 
plan. Foundations are discussed in their own 
chapter. See “Foundations” on page 329.

Chapter Contents
•      Floor Defaults Dialog
•      Floor Tools
•      Adding Floors
•      Displaying Floors
•      Deleting Floors
•      Floor and Ceiling Platforms
•      Floor and Ceiling Platform Definitions
•      Copying Floors
•      Rebuilding Walls, Floors & Ceilings
•      Split Levels
•      The Current Floor
•      The Attic Floor
•      The Reference Floor
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Floor Defaults Dialog
There is a Floor Defaults dialog for 
each floor in a plan file. The defaults 

for the current floor can be accessed by 
selecting Edit> Default Settings. Select 
“Floor” from the category tree and click the 
Edit button to open the Floor Defaults 
dialog for the currently active floor. See 
“Default Settings vs Preferences” on page 
56.
• The Floor Defaults dialog can also be 

opened by double-clicking the Floor 

Tools  parent button.

• In addition, the Floor Defaults  button 
can be added to a toolbar for quick access 
to the Floor Defaults dialog. See “Tool-
bar Customization Dialog” on page 93.

The Floor Defaults dialog also opens 
whenever you add a new floor to the plan. 
See “Adding Floors” on page 317. 

The Floor Defaults dialog does not open 
when you build a foundation; however, the 
Floor 0 Default settings are created based on 
the current Foundation Defaults. See 
“Foundation Defaults” on page 330. 

The Floor Defaults dialog is similar to the 
Room Specification dialog, but controls the 
default settings for all rooms on the current 
floor. The settings here also control the 
height of individual walls as they are drawn 
on the floor in question. See “Room 
Specification Dialog” on page 244.

General Tab
Only one setting on the General tab is unique 
to the Floor Defaults dialog.

On Floor 1 only, define the wall layer that 
you would like to calculate the Living Area 
To. See “Living Area” on page 237.

Structure Tab
The settings on the Structure tab are similar 
to those in the Room Specification dialog. 
See “Structure Tab” on page 245. 

Note: The default floor height for Floor 1 is 0.
It can be modified in the Room Specification
dialog, but not in the Floor 1 Defaults dialog.
See “Floor and Room Defaults” on page 230.
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Moldings Tab
The settings on the Moldings tab are similar 
to those in the Room Specification dialog. 
See “Moldings Tab” on page 250. 

Fill Style Tab
The settings on the Fill Style tab are similar 
to those in the specification dialogs for many 

objects throughout the program. See “Fill 
Style Tab” on page 792. 

Materials Tab
The settings on the Materials tab are similar 
to those in the specification dialogs for many 
objects throughout the program. See 
“Materials Tab” on page 635. 

Floor Tools
Select Build> Floor to access the 
floor tools.

Select Build> Floor> Build New 
Floor to build a new floor. A new 

floor can be generated based upon the 
perimeter of the floor below or a blank floor 
can be created and drawn from scratch. See 
“Adding Floors” on page 317.

Select Build> Floor> Insert New 
Floor to insert a new floor below the 

current floor. See “Adding Floors” on page 
317.

Choose Build> Floor> Delete 
Current Floor to remove the current 

floor from the plan. For more information, 
see “Deleting Floors” on page 320.

Choose Build> Floor> Build 
Foundation to open the Foundation 

Defaults dialog and build a foundation floor. 
See “Building a Foundation” on page 334.

Select Build> Floor> Delete 
Foundation to remove the foundation 

from the plan. See “Deleting Foundations” 
on page 338.

Choose Build> Floor> Rebuild 
Walls/Floors/Ceilings to force Home 

Designer Pro to recalculate the relationship 
between the walls, floors, and ceilings in 
your model. See “Rebuilding Walls, Floors 
& Ceilings” on page 324.

Select Build> Floor> Rebuild Slabs 
to force the rebuild of any slabs in the 

plan.

Adding Floors
New floors can be added in floor plan view 
and 3D views. 

To create a new floor

1. Select Build> Floor> Build New 

Floor  to open the New Floor dialog. 
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2. Select the options that you need and 
click OK.

•  Derive new 2nd floor plan from the 
1st floor plan creates a new top floor 
with exterior walls generated directly 
over the exterior walls of the floor 
below. Wall types and roof directives 
associated with the walls on the floor 
below are duplicated; however, interior 
walls are not. See “Roof Tab” on page 
218.

•  Check Move Highest Floor’s Roof Up 
to move any roof planes displaying on 
the highest floor in the plan up one 
floor when the new floor is created. 
Roof planes displaying on floors other 
than the top floor are unaffected. This 
option is only available if there are roof 
planes built on the top floor and is not 
available when Auto Rebuild Roofs is 
enabled. See “Build Roof Dialog” on 
page 355.

•  Make new (blank) plan for the 2nd 
floor creates a new top floor that is 
blank. This option is typically selected 
only if none of the exterior walls on the 

new floor will be directly above the 
exterior walls on the floor below. If 
you choose this method, it may be 
helpful to turn on the Reference Dis-
play when drawing walls on the new 
floor. See “The Reference Floor” on 
page 327.

3. The Floor Defaults dialog for the newly 
created floor opens next. Make any nec-
essary changes to the floor structure, 
moldings, or materials and click OK. 
See “Floor Defaults Dialog” on page 
316.

4. The new floor becomes the current floor 
in floor plan view. If, however, the new 
floor is created in a 3D view, the camera 
remains on its original floor and does 
not move. 

Inserting Floors
A floor can be inserted beneath the current 
floor in both floor plan view and 3D views. 

If you are in a 3D view, begin by selecting 
Tools> Reference Floors> Change Floor/

Reference  and select the floor you would 
like to insert a floor under as the Current 
Floor. See “Change Floor / Reference” on 
page 328.

To insert a floor

1. Select Build> Floor> Insert New 

Floor . The Insert Floor dialog 
opens. 

When Move highest floor roof up is
checked, roof planes on the top floor

will move even if the “Roof Planes” layer is
locked and manually edited roof planes are
set to be retained. See “Roof Tab” on page
356.

Note: Home Designer Pro allows only one
floor, the foundation/basement, below the first
floor. Keep this in mind when you begin an
as-built or plan for a multi-story building.
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2. Select one of the two available options: 
•  Select Derive new 2nd Floor plan 

from the 1st Floor plan to insert a 
new floor below the current floor, 
based on the exterior walls of the cur-
rent floor. 

•  Select Make new (blank) plan to 
insert a blank floor below the current 
floor. 

3. Click OK. The existing floor and any 
floors above it are moved up, and a new 
floor is created below. 

Adding a Foundation
To add a foundation, select Build> Floor> 

Build Foundation . See “Building a 
Foundation” on page 334.

Displaying Floors
Home Designer Pro allows you to view the 
floors in your plan in a variety of ways.

In Floor Plan View
In floor plan view, only one floor can be 
active for editing at a time. This is referred to 
as the Current Floor. See “The Current 
Floor” on page 326. 

In addition to the Current Floor, one other 
floor can be displayed for reference 
purposes: the Reference Floor. Objects on 
the Current Floor can snap to those on the 
Reference Floor, helping you align objects. 
See “The Reference Floor” on page 327.

Floor and ceiling platforms do not display in 
floor plan view.  When floor and/or ceiling 
framing is present, its display can be turned 
on; however, other components of floor and 
ceiling platforms like sheathing, drywall, and 
finish materials, cannot.

In 3D Views
In most 3D views, all floors in a plan are 
visible, from the foundation up to the attic. 
There are three exceptions: 

• Perspective Floor Camera  views.

• Orthographic  and Perspective Doll 

House Views . 

• Wall Elevation  views.

Floor Cameras and Doll House Views show 
the Current Floor only, not including its ceil-
ing, while the Wall Elevation tool creates an 
elevation of a wall on a single floor in a sin-
gle room. See “3D View Tools” on page 672. 

In the Materials List
The materials that make up floor and ceiling 
platform assemblies are listed under different 
Categories in the Materials List: 
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• Subfloor - Lists floor framing and struc-
tural subflooring materials specified in all 
Floor Structure Definitions in the current 
plan. See “Floor and Ceiling Platform 
Definitions” on page 322.

• Flooring - Lists flooring and subflooring 
materials specified in all Floor Finish 
Definitions in the current plan.

• Framing - Lists ceiling framing and any 
other materials specified in all Ceiling 
Structure Definitions in the current plan.

• Wall Board - Lists ceiling finish materi-
als specified in all Ceiling Finish Defini-
tions in the current plan.

• Insulation - Floor insulation is calculated 
for all rooms that have a floor, and ceiling 
insulation is calculated for all rooms that 
have a ceiling - regardless of the Floor or 
Ceiling Structure Definition. When a ceil-
ing is not present, insulation is calculated 
for the roof. See “Structure Tab” on page 
245. 

• Foundation - Lists the concrete and mesh 
for all Floor Structure Definitions in the 
current plan with a layer of concrete 
material. See “Material Types” on page 
640.

See “Materials Lists” on page 887. 

Copying Floors
The Edit Area  tools can be used to make 
copies of entire floors in a plan. See “Edit 
Area Tools” on page 168.  You can use these 
tools to:
• Make a copy of an existing floor to be 

pasted onto a new floor.
• Make a copy of all existing floors in a 

plan to be pasted into a different plan.

You can also copy the information on a floor 
by pressing Ctrl + A (Select All), then using 

Copy  and Paste Hold Position . See 
“Paste Hold Position” on page 117.

Copying Between Plans
While you can copy and paste floors from 
one plan file to another, this is not always the 
best approach. 
• To make a copy of the plan for backup or 

your records, use Save As  to save the 
file using a new name. See “Saving, 
Exporting, and Backing Up Files” on 
page 43.

• To copy the model into another plan with 
multiple structures, consider exporting it 
as a symbol and importing it into the new 
plan. See “Custom Symbols” on page 43.

Deleting Floors
Select Build> Floor> Delete Current 
Floor to remove the current floor 

from the plan. If there is a floor above, it 
becomes the current floor; if there is no floor 

below, the floor beneath becomes the current 
floor. 

To delete Floor 0, select Build> 
Floor> Delete Foundation. You can 
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delete the foundation without actually being 
on Floor 0. Floor 0 cannot be deleted while 
Auto Rebuild Foundation is turned on. See 
“Deleting Foundations” on page 338.

Floor and Ceiling Platforms
In many ways, floors in Home Designer Pro 
are defined by the floor platforms below 
them and the floor and/or ceiling platforms 
above. 

You can specify the thickness and framing 
materials used to construct floor and ceiling 
platforms on a floor-by-floor basis in the 
Framing Defaults dialog. See “Floor Tabs” 
on page 443. 

You can also specify the floor and ceiling 
structures of individual rooms in the Room 
Specification dialog. See “Structure Tab” on 
page 245. 

Floor vs Ceiling Platforms
Floor and ceiling platforms are not the same 
thing in Home Designer Pro. Floor platforms 
have living space above them and are 
designed to be weight-bearing. Ceiling 
platforms, on the other hand, have living 
space below them but not above them. They 
are not designed to bear weight and are 
typically less strong - and less thick - than 
floor platforms. 

Stepped Floor & 
Ceiling Platforms

Each floor has default floor and ceiling 
heights. You can, however, use the Room 

Specification dialog to specify floor and 
ceiling heights on a room by room basis to 
create stepped floors and ceilings. See 
“Structure Tab” on page 245. 

If you require a single floor platform with a 
uniform height and thickness but different 
ceiling heights for the rooms below, specify a 
lowered ceiling using the Ceiling Finish 
Specification dialog. See “Lowered 
Ceilings” on page 241.

By default, the gap between floor and ceiling 
platforms that step at a railing or invisible 
wall is closed off by a short section of solid 
wall. If you require a gap between the 
platforms, uncheck Generate Between 
Platforms in the Wall or Railing 
Specification dialog. See “General Tab” on 
page 214. 

Cantilever Undersides
If a room cantilevers out past an exterior 
wall, the cantilever will use the floor 
platform of the room above it. You can 
specify the surface material of the underside 
of a cantilever on the Materials tab of the 
Room Specification dialog. For no material, 
select “No Material” from the Plan Materials 
dialog. See “Room Specification Dialog” on 
page 244.

When a floor is deleted, all objects on
that floor are deleted with it, including

locked roof planes and any other objects on
locked layers. See “Locking Layers” on page
103.
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Platform Edges
Typically, floor and ceiling platforms are 
built so that they bear on top of walls. The 
edges of the platform structures extend 
through exterior walls to the layer of the wall 
type definition with the Build Platform to 
This Line setting. See “Wall Type Defini-
tions” on page 209. 
• For framed walls, the Build Platform to 

This Line layer is set as the outside of the 
wall’s Main Layer, 

• For concrete walls, it’s the inside of the 
wall’s Main Layer. 

• The platforms of rooms with raised floors 
and/or lowered ceilings build in the same 
manner: to the Build Platform to This 
Line layer of the wall type assigned to the 
railing or invisible wall defining the 
room. See “Floor & Ceiling Heights” on 
page 239. 

For a given wall type, you can specify a 
different Build Platform to This Line wall 
layer surface provided that it  is on the 
exterior side of the Main Layer. 

In addition, you can specify that individual 
walls build through floor and ceiling 
platforms in the Wall Specification dialog.  
See “General Tab” on page 214.

Floor and Ceiling Platform Definitions
Floor and ceiling platforms are made up of 
layers of different materials such as framing, 
subflooring, drywall, and finish materials. 
You can specify the composition of floor 
and/or ceiling platforms on a floor-by-floor 
and also a room-by-room basis. You can 
specify how these platforms are constructed 
in the Floor and Ceiling Structure 
Definition dialogs. 
• To specify the composition of the floor 

and ceiling platforms for an entire floor: 
open the Structure tab of the Floor 
Defaults dialog and click the Floor 
Structure or Ceiling Structure button. 

• To specify the floor and/or ceiling struc-
ture for an individual room, open the 
Structure tab of its Room Specification 
dialog and click the Floor Structure or 

Ceiling Structure button. See “Structure 
Tab” on page 245.

In addition to the structural layers of a 
platform, floors and ceilings also have a 
finish layer. You can specify floor and ceiling 
finish materials for an entire floor or 
individual room on the Materials tab of either 
the Floor Defaults or Room Specification 
dialog. See “Materials Tab” on page 635.

Floor and ceiling platform definitions play a 
role in determining floor and ceiling 
heights.Floor and ceiling finishes can be 
used to create dropped ceilings. See “Floor & 
Ceiling Heights” on page 239. 

All floor and ceiling materials are used for 
the calculation of the materials list. 
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Floor/Ceiling Structure Definition Dialog
The settings in the Floor and Ceiling 
Structure Definition dialogs are similar to 
one another. They are also similar to the 

settings found in the Floor Finish Definition 
dialog.

The layers of the floor or ceiling 
platform structure definition are listed 

here. Layers are numbered and listed from 
the top of the structure to its bottom. 

To select a layer for editing, click in its Layer 
Thickness text field. The arrow to the right of 
the structure diagram points to the selected 
layer, while the arrow to the left of the 
diagram points to its top surface.

Define the Thickness for each structural 
layer by typing in the text field. The layer 
thickness format can be changed by clicking 
the Num Style button.

The Total thickness of the structure 
definition displays here as a reference.

Specify the Layer Material of the 
selected structural layer. 

• Click the Library Material button to 
open the Select Library Object dialog. 
See “Select Library Object Dialog” on 
page 622.
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on it in the structure diagram at the bot-
tom right of the dialog.
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• Click the Plan Materials button to open 
the Plan Materials dialog. See “Plan 
Materials Dialog” on page 642 .

Previews of the selected material’s pattern 
and texture display in the boxes to the left of 
the Library and Plan Materials buttons. 

Click the Fill Style button to open the 
Layer Fill Style dialog and specify a fill 

style for the selected wall layer. This dialog 
is similar to the Fill Style tab for CAD 
objects. See “Fill Style Tab” on page 792. 

A preview of the selected layer’s fill style 
displays to the left of the Fill Style button. 

Click the Structure Type drop-down 
and select the type of framing member 

used for the platform structure. Only 
available when the selected material is a 
Framing type. See “Framing Member Types” 
on page 463.

The arrow to the right of the structure 
diagram points to the selected layer. To 

select a layer, click on a layer in the diagram 
or click in its Thickness field.

The arrow to the left of the structure diagram 
points to the selected layer’s surface. 

Click the Num Style button to open the 
Number Style/Angle Style dialog. 

Here you can change the numbering format 

used in dialogs like this one. See “Number 
Style/Angle Style Dialog” on page 89. 

Ceiling Finish Dialog

Check Frame Lowered Ceiling to 
enable the two settings that follow. 

These settings are only available when 
Frame Lowered Ceiling is checked.

• Specify the Air Gap, which is the vertical 
distance between the lowered ceiling 
framing and the framing of the platform 
above it.

• Specify the Framing Thickness, which is 
the vertical depth of the framing of the 
lowered ceiling. 

Specify the Finish Thickness, which is 
the vertical depth of the ceiling finish 

material.

The Total thickness of the structure 
definition displays here for reference.

Rebuilding Walls, Floors & Ceilings
When you make a change to the walls 
or to the floor or ceiling platforms in 

your plan, they may not immediately resize 
or move in the 3D model. The program does 
detect such changes, though, and the next 

time you generate a 3D or section/elevation 
view, walls,  floors and ceilings are rebuilt.

By default, walls, floors and ceilings are also 
rebuilt when an automatic roof is generated. 
See “Build Roof Dialog” on page 355.
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You can direct the program to rebuild walls, 
floors and ceilings at any time by selecting 
Build> Floor> Rebuild Walls/Floors/

Ceilings  or by pressing the F12 key.

If you do not want the program to rebuild 
walls, floors and ceilings when a 3D view is 
created, uncheck Auto Rebuild Floors & 

Ceilings in the 3D View Defaults dialog. 
This may speed up plan view editing for very 
large plans. When this is unchecked and the 
structure is not up to date, the Rebuild Walls, 
Floors, Ceilings  icon displays near your 
mouse pointer. See “Options Tab” on page 
669. 

Split Levels
Both split level floor plans and split level 
entries can be created by controlling the floor 
and ceiling heights of individual rooms in a 
multiple story structure. 

Split Level Floor Plans
A split level, or tri-level, structure is a 
building where the floor level in one part of 
the plan is located approximately half way 
between the floor and ceiling levels of 
another part of the plan. 

To create a simple split level plan

1. Draw a simple rectangular structure 
divided into two separate halves by an 
interior wall.

2. Select one of the rooms and click the 

Open Object  edit button. See 

“Room Specification Dialog” on page 
244.

3. Raise the Floor Height then press the 
Tab key.

4. Restore the Relative Rough Ceiling to 
the default value, then click OK.

5. Build a stem wall foundation. See 
“Foundations” on page 329.

•  The foundation under the room with 
the lower floor height will have the 
specified Min Stem Wall Height. 

•  The foundation under the room with 
the raised floor will have taller stem 
walls. 

•  Both can be edited in the Room 
Specification dialog.

6. If you add a Floor 2, note that the Ceil-
ing Height in the room on Floor 1 will 
be reset to the default value. 

•  To maintain a stepped condition on 
multiple floors, return to this room and 
set the Relative Rough Ceiling back to 
using the default.

For more detailed instructions, visit  
www.HomeDesignerSoftware.com.

Split Level Home

http://www.homedesignersoftware.com/support/displayfaq.php?faqNumber=932
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Split Level Entries
A split level entry, or divided entry, is 
characterized by an entry door that opens 
onto a landing positioned half way between 
the basement floor and first floor levels. 

To create a simple split level entry

1. Create a plan file with a full basement at 
the location of the entry door. See 
“Basement Rooms” on page 339.

2. Go to Floor 0 and draw a stair Landing 

 at the location of the entry. See 
“Landings” on page 406.

3. Specify the desired height of the land-
ing. See “Stair Landing Specification 
Dialog” on page 433.

4. Draw stairs upward from the basement 
floor to the landing.

5. Draw a second stair section from the 
landing upward. 

6. Select the stairs and click the Auto 

Stairwell  edit button. See “Creating 
a Stairwell” on page 419. 

Split level entries are often associated with 
daylight basements. See “Daylight 
Basements” on page 340. 

For more detailed instructions, visit  
www.HomeDesignerSoftware.com.

The Current Floor
Only one floor can be active at any given 
time. The active floor is referred to as the 
Current Floor, and it is the only floor on 
which objects can be edited.

If you want to edit two different floors at the 
same time, you can open the plan again. This 
opens a second window on the current open 
plan that has the same editing abilities as the 
first. Only one of these windows can be 
active at any given time.

Floor Up / Floor Down
If you are working with 
more than one floor, you 

can select Tools> Reference Floors> Up 

One Floor or Down One Floor to switch 
from one floor to another. 

You can change the current floor in floor 
plan, cross section/elevation and 3D views. 
The current floor displays on the Change 

Floor/Reference  button, which can be 
found between the Down One Floor and the 
Up One Floor buttons. 

Floors become available once they have been 
built. The Attic and foundation levels are 
also accessible using these tools. 

Change Floor / Reference
If there are multiple floors, select 
Tools> Reference Floors> Change 

Split Level Entry

http://www.homedesignersoftware.com/support/displayfaq.php?faqNumber=269&subject=floors
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Floor/Reference to open the Change Floor/
Reference dialog, where you can select both 
the current floor and which floor is used in 

the Reference Display, as well as control the 
appearance of the Reference Display. 

The Attic Floor
Home Designer Pro automatically 
creates a floor above the top 

numbered floor level of each plan. This floor 
is called the Attic floor and has only one 
purpose: to provide a space for automatically 
generated Attic walls. See “Attic Walls” on 
page 206.

Because the Attic floor is not meant to be a 
living area, a warning message will display if 

you try to draw walls or other objects on this 
floor.

In some situations, you may find it necessary 
to draw one or more walls on this floor; 
however, even if you enclose an area with 
walls, rooms cannot be created on the Attic 
floor.

If you wish to create an attic loft, bonus 
room, or storage area in your plan, you will 
need do so on a numbered floor level. 

The Reference Floor
When there is more than one floor in a 
model, it is often helpful to see how different 
floors relate to each other. Any floor can be 
shown as the Reference Floor along with the 
current floor. 

When the Reference Display is turned on, the 
floor that you were last on prior to the current 
floor is used as the Reference Floor. Objects 
on the current floor can snap to objects on the 
Reference Floor; however, objects on the 
Reference Floor cannot be selected or edited.

Reference Display
To display the Reference Floor, select 
Tools> Reference Floors> Reference 

Display or press F9 on your keyboard. The  
reference floor can also be toggled on or off 

quickly in floor plan view by clicking the 
Reference Display toggle button on the 
utility toolbar. 

If the Reference Display is on when a floor 
plan view is sent to layout, the Reference 
Display is always on in that layout view and 
cannot be turned off. 

If the Reference Display is turned on when a 
view is printed, it will be included in the 
printed output. See “Display Options and 
Printing” on page 844. 

Note: If objects on the current floor and the
Reference Floor have edges that line up, the
Reference Floor may be difficult to see on
screen. When lines of two different colors are
superimposed upon each other, discoloration
may result.
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Reference Display Options
The display of objects in the 
Reference Display is controlled by 

selecting Tools> Reference Floors> 
Reference Display Options. See “Layer 
Display Options Dialog” on page 104.

Change Floor / Reference
By default, the floor below the current 
floor is the Reference Floor, but any 

floor can be referenced using the Change 
Floor/Reference dialog. To open the dialog, 
select Tools> Reference Floors> Change 
Floor/Reference button. 

The Reference Floor currently used for 
reference is highlighted here. You can 

select another floor. 

The Current Floor is highlighted here. 
You can select another floor to make it 

the current floor.

Click the Reference Display Options 
button to open the Layer Display 

Options dialog and change the settings for 
the reference display. See “Layer Sets” on 
page 103.

Swap Floor/Reference
If one floor is defined as the current 
floor and another floor is defined as 

the reference floor, select Tools> Reference 
Floors> Swap Floor/Reference to switch 
the status of the two floors.
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Chapter 13:

Foundations

There are three foundation types in Home 
Designer Pro: stem walls with footings, walls 
with piers and monolithic slab. All three can 
be generated automatically or manually. The 
foundation type can be specified in the 
Foundation Defaults dialog when the 
foundation is built.

There can be only one foundation level in 
your plan, Level 0. Foundation walls can be 
drawn on upper floors using the Foundation 
Wall and Slab tools.

Chapter Contents
•      Foundation Defaults
•      Building a Foundation
•      Displaying Foundations
•      Editing Foundations
•      Aligning Foundation Walls
•      Deleting Foundations
•      Foundations and Rooms
•      Foundations and the Terrain
•      The Slab Tools
•      Editing Slabs
•      Editing Piers and Pads
•      Slab Specification Dialog
•      Fireplaces
•      Fireplace Specification Dialog
•      Library Fireplaces
•      Chimneys

Always consult registered geotechnical
and civil engineers for information

regarding the proper foundation for your site. 
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Foundation Defaults
There are several defaults dialogs that 
affect the foundation. TheyFoundation 

Defaults can be accessed by selecting Edit> 
Default Settings. 

Select “Foundation” and click the Edit 
button to open the Foundation Defaults 
dialog. 

If a foundation has been built and you are on 
Floor 0, select “Floor” and click the Edit 
button to open the Floor 0 Defaults dialog. 

The settings here are initially drawn from 
those in the Foundation Defaults dialog.  
See “Floor Defaults Dialog” on page 316.

Click the + beside “Walls” to display the 
subheadings, then select “Foundation Wall” 
and click the Edit button to open the defaults 
dialog for the Foundation Wall tool. See 
“Wall, Railing, and Fencing Defaults” on 
page 176. 

Foundation Defaults Dialog
The Foundation Defaults dialog allows you 
to specify stem wall height, slab thickness, 
treated sill plates, and other characteristics of 
a foundation. These values determine how a 
new foundation is generated as well as the 
sizes for manually drawn foundation walls 
added to an existing foundation. 

The settings in the Foundation Defaults 
dialog are similar to those in the Build 
Foundation dialog, which opens when 

Build> Floor> Build Foundation  is 
selected. The primary difference is that when 
you click OK in the Foundation Defaults 
dialog, no changes are made to the model. 
See “Building a Foundation” on page 334.
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Foundation Tab

Check Auto Rebuild Foundation to 
automatically rebuild the foundation 

whenever changes are made to Floor 1 that 
affect the structure of the foundation.  See 
“Rebuilding Foundations” on page 336. 

Three different Foundation Types can 
be created in Home Designer Pro. 

Select the radio button next to the desired 
type. 
• Select Walls with Footings to produce a 

foundation composed of stem walls with 
footings that run continuously under the 
base of the walls. 

• Select Walls with Piers to generate a pier 
and grade beam foundation. The floor 
framing rests directly on top of the grade 
beam. 

• Select Monolithic Slab to build a slab 
foundation defined by slab footings. The 
foundation forms the floor platform for 
Floor 1. It is visible on Floor 0 and can be 
selected and edited.

Each type of foundation has different default 
settings, options, and behaviors.  

The Walls settings affect the generation 
of all three Foundation Types.

• The name of the Default Foundation 
Wall Type displays here for reference. 

• Click the Edit Default Foundation Wall 
button to open the Foundation Wall 
Defaults dialog and change the default 
settings for foundation walls. See “Foun-
dation Walls” on page 183. 

• If Monolithic Slab is the selected Foun-
dation Type, the Edit Garage Curb but-
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ton will be available. Click it to open the 
Foundation Wall Defaults dialog and 
define the walls that form curbs around 
Garage and Slab rooms. 

• Specify the Minimum Stem Wall 
Height, which is the minimum height for 
foundation walls and grade beams and 
includes the treated sill plate. 

• The Basement Ceiling Height displays 
here as a reference. This is the distance 
from the top of the slab floor to the base-
ment ceiling and is equal to the Minimum 
Wall Height minus the Slab Thickness. 

If the Minimum Wall Height is at least 
76” (1900 mm), a Ceiling Finish is added 
to the foundation room automatically. A 
slab floor is also generated above the 
footing. The ceiling height and finish can 
be changed later. See “Room Specifica-
tion Dialog” on page 244. To remove this 
slab, specify the room areas in the base-
ment as “Open Below”. See “Room 
Types” on page 234. 

• Specify the Garage Floor to Stem Wall 
Top, which is the distance between the 
slab and the tops of the stem walls in both 
Garage and Slab rooms. Available for 
Walls with Footings and Walls with Piers 
foundation types. See “Foundation 
Defaults” on page 330. 

• Specify the Lower Garage Floor height, 
which is the distance that Garage and 
Slab room floors are lowered when a 

Monolithic Slab foundation is  built. This 
value is also the height of the curbs 
around these rooms.  See “Garages” on 
page 338. 

• Specify the Minimum Garage Stem 
Wall Height, which is  the minimum 
height that stem walls defining a Garage 
foundation will be, regardless of the Min-
imum Stem Wall Height for the rest of the 
foundation. 

Slab 

• Specify the Slab Thickness, which is the 
thickness of the slab produced above the 
footing or at the top of the stem wall.

• Check Slab at top of Stem Wall to raise 
the slab so its top is flush with the top of 
the stem walls. Only available when 
Walls with Footings is the selected Foun-
dation Type.

If Slab at top of Stem Wall is selected, 
all rooms on the first floor are automati-
cally set to Floor Supplied by the Foun-
dation Room Below in the Room 
Specification dialog. See “Structure 
Tab” on page 245.

Check Show “S” Markers on Step 
Foundation to include an “S” symbol 

in floor plan view anywhere there is a step in 
foundation wall height. See “Displaying 
Foundations” on page 335. 

The Piers options are only available 
when Walls with Piers is the selected 

Foundation Type. 
• Specify the Width, Depth, and Maxi-

mum Separation of the piers.
• Choose either Round or Square piers.

Note: The Garage Floor to Stem Wall Top set-
ting only affects Garage rooms that have a
Floor Height of 0. See “Structure Tab” on
page 245. 
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Treated Sill Plate Size - Enter a Width 
and Height for the treated sill plate, 

also referred to as a mudsill. If the Height is 
set to zero, no sill plate is produced. A sill 
plate is only produced if the Main Layer of 

the wall above is a framing type. Not 
available if Monolithic Slab is the selected 
Foundation Type. See “Treated Sill Plates” 
on page 437.

Options Tab
The Options tab allows you to include rebar 
and other materials related to the foundation  
in the Materials List. See “Materials Lists” 
on page 887. 

Some options on this tab may be unavailable 
depending on the foundation type selected on 
the Foundation tab. 

# bars/course - Specify the number of  
rebar in the Footing, the number of 

Horizontal and Vertical rebar courses in the 
stem walls, and the number of rebar layers in 
the Slab. If piers are used, specify how many 
rebar are used per Pier. Rebar does not 
display in 3D or cross section/elevation 
views, but is added to the Materials List. 

Course Spacing - Define the Wall 
Horizontal and Wall Vertical spacing 

for the rebar in the stem wall, and in Slabs. If 

slabs are to have rebar instead of mesh, this 
spacing value applies to both directions.

Bar size - Define the rebar size in 1/8th 
inches. 4 represents 4/8, or ½ inch.

Specify the Overlap where sticks of 
rebar meet, in terms of the rebar’s 

Diameter. A value of 40.0, for example, 
equals 40 times the Rebar Size. 

Check  Use Mesh to reinforce the slab 
floor with mesh instead of rebar, or 

uncheck it to use rebar. 
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Select either Foam Seal, Termite 
Flashing or both. These options are 

added to the Materials List, but do not 
display in the model.

Building a Foundation
Foundations can be generated 
automatically or drawn manually. A 

combination of the two methods can also be 
used. 

Three foundation types are available: stem 
walls with footings, walls with piers and 
monolithic slabs. The first two options are 
created using walls; the last creates concrete 
slabs with footings.

Automatically built foundations are placed 
on Floor 0 and are based on wall positions 
and floor heights on Floor 1. Foundation 
walls or slab footings are generated under:
• All exterior walls on Floor 1 that define a 

room other than a Court, Deck or Bal-
cony room type. See “Room Definition” 
on page 231.

• Any interior walls on Floor 1 defining 
rooms with different floor heights. See 
“Floor & Ceiling Heights” on page 239. 

At least one room must be defined on Floor 1 
for a foundation to be automatically 
generated. If no rooms are defined on Floor 
1, a blank Floor 0 is created. 

Once a foundation is generated, you can add 
walls, piers, and slabs to customize it.

There can be only one Floor 0 per plan. If 
your plan requires a foundation on more than 
one floor, you will need to draw the required 
foundation walls or slabs yourself.

To build an automatic foundation

1. Select Build> Floor> Build Founda-

tion . 
2. Specify the desired foundation type and 

other information in the Build 
Foundation dialog. The settings in this 
dialog are similar to those in the Foun-
dation Defaults dialog. See “Foundation 
Defaults” on page 330.

3. In the New Floor dialog, select Derive 
new Foundation plan from the 1st 
floor plan and click OK to build a foun-
dation based on Floor 1.

If you prefer, you can instead select Make 
new (blank) plan for the Foundation to 
create an empty foundation level where you 
can manually draw foundation walls or slabs.

In most cases, it is preferable to base Floor 0 
off the first floor plan and then manually edit 
the foundation as needed. See “Editing 
Foundations” on page 335.

Openings in Foundation Walls
Any doors placed in walls around a Garage 
will receive cutouts in the garage stem wall 
or curb. The width of that cutout can be 
specified in the Door Specification dialog. 
See “General Tab” on page 266.

6
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Displaying Foundations
The display of foundation walls, slabs, 
curbs, piers and footings is controlled 

in the Layer Display Options dialog. See 
“Layer Display Options Dialog” on page 
104. 
• Foundation Walls, including grade 

beams, slab footings and Garage curbs, 
are placed on the “Walls, Foundation” 
layer.

• Footings under Foundation Walls and 
slab footings are placed on the “Foot-
ings” layer, as are foundation piers. 

• Slabs created using the Slab Tools  
are placed on the “Slabs, Custom” layer.

In Floor Plan View
The appearance of foundation wall types, 
including line weights, colors and fill styles, 
is specified in the Wall Type Definitions 
dialog. See “Wall Type Definitions Dialog” 
on page 211.

Changes in stem wall and monolithic slab 
foundation heights are represented in floor 
plan view with S markers. These markers are 
located on the “Footings, Step Markers” 
layer and use the Text Style assigned to that 

layer. See “Stepped Foundations” on page 
340.

If a door on Floor 1 extends into a stem wall 
or curb defining a Garage room, its location 
will be indicated on Floor 0. See “Displaying 
Doors” on page 257.

In 3D Views
In 3D views, all objects on Floor 0 will only 
display when the “Foundation” layer is 
turned on. 

While the display of foundation walls and 
their footings can be controlled independent 
of one another in floor plan view, in 3D 
views this is not the case. If a foundation 
wall is set to display, its footing will as well - 
even if the “Footings” layer is turned off. The 
reverse is also true - if a foundation wall’s 
display is turned off, so will its footing’s.

The display of monolithic slab foundations in 
3D views is controlled by the “Foundation” 
layer. Slab footings are located on the 
“Walls, Foundation” layer; but if this layer is 
turned off, any slab footings that define a 
foundation room will continue to display as 
long as the “Foundation” layer is on. 

Editing Foundations
Stem wall with footings, wall with piers and 
monolithic slab foundations are all created 
using walls which enclose room areas.
• Foundation walls can be selected and 

edited much like other walls. See “Edit-
ing Walls” on page 197.

• Footing size can be changed on a wall by 
wall basis. See “Footing Width and 
Height” on page 337. 

• Foundation rooms can also be selected 
and edited like other rooms. See      Foun-
dations and Rooms.
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Rebuilding Foundations
By default, foundations do not update 
automatically when changes are made to the 
structure on Floor 1. For example, if exterior 
walls are moved or floor platforms are raised 
or lowered, the foundation must be rebuilt.

You can direct the program to rebuild an 
automatically generated foundation 
whenever changes are made on Floor 1 that 
affect the foundation by checking Auto 
Rebuild Foundation in the Foundation 
Defaults dialog. See “Foundation Tab” on 
page 331.

You can also rebuild an automatically 
generated foundation by selecting Build> 

Floor> Build Foundation  from the 
menu. 

When Auto Rebuild Foundation is enabled, 
walls cannot be edited, manually drawn or 
deleted on Floor 0. When the foundation is 
rebuilt, any manually drawn or edited walls 
are deleted. Similarly, rooms on Floor 0 
cannot be edited while this option is enabled.

Changing Foundation Types
When a foundation is generated, the program 
creates Floor Defaults settings for Floor 0 
based on the information in the Build 
Foundation dialog. If you specify a 
Monolithic Slab foundation, the default 
Floor Structure on Floor 1 will also be 
changed to a slab rather than a framed 
platform. See “Floor Defaults Dialog” on 
page 316.

If you rebuild the foundation using a 
different Foundation Type, it is advisable to 
check the floor heights of all rooms on Floor 
1 - particularly Garage and Slab rooms, as 

well as any rooms that do not use the default 
floor height of 0”. 

Stem Wall Height
When a foundation is created, all of Floor 0 
uses the stem wall height specified in the 
Foundation Defaults dialog, 

This height is measured from the bottom of 
floor platform of Floor 1 to top of the stem 
walls’ footings. If Floor 1 has multiple floor 
platform heights, the foundation stem walls 
will be stepped.

Once a foundation is created, stem wall 
heights can be adjusted either on a room-by-
room basis or for individual walls.

To change a room’s stem wall height

1. Select a room on Floor 0 and click the 

Open Object  edit button. 
2. Specify the desired Stem Wall Height 

in the Room Specification dialog. See 
“General Tab” on page 244.

3. If you wish to reduce the Stem Wall 
Height, you will first need to reduce the 
Ceiling Height value by the same 
amount. 

If adjacent rooms have stem wall heights that 
differ by at least 1/16 of an inch, the stem 
wall separating them uses the larger of these 
two values.

In 3D views, individual stem walls can be 
selected and edited. In most cases,this 
method should only be used for stepping the 

To avoid unexpected results, it is rec-
ommended that you not change the

Foundation Type once the foundation is built.
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bottom of the foundation wall. See “Stepped 
Walls & Footings” on page 207. 

Footing Width and Height
Foundation Wall footings derive their Width 
and Height from in the Foundation Wall 
Defaults dialog, Once a Foundation Wall is 
created, its footing can be adjusted in its 
specification dialog. See “Foundation Tab” 
on page 219.

Stem wall footing heights can also be edited 
in 3D views just as the rest of the stem wall 
can. Slab footing heights, on the other hand, 
cannot be adjusted in 3D.

You can specify whether stepped stem walls 
have vertical footings on the Foundation tab 

of the Foundation Wall Defaults and 
Specification dialogs. 

Interior Footings
Slab foundations often have interior footings: 
to support posts, for example. See 
“Foundation Tab” on page 219. Home 
Designer Pro does not generate interior 
footings automatically, but you can easily 

draw them using the Slab  tool. See “The 
Slab Tools” on page 341. 

To create an interior footing

1. Select Build> Slab> Slab , then 
click and drag to draw a slab on Floor 0. 
This slab will serve as a footing.

2. Select the slab and click the Open 

Object  edit button.
3. In the Slab Specification dialog, spec-

ify the desired Height and Thickness. 
See “General Tab” on page 342.

•  The Height should be set so that it 
meets the bottom surface of the mono-
lithic slab above.

4. Use the edit handles, dimensions and/or 
the Reference Display to position the 
slab at the desired location. 

Aligning Foundation Walls
By default, foundation walls and slab 
footings will align with walls on the floor 
above along the outside surface of the Main 
Layer of both wall types. See “Wall Type 
Definitions” on page 209. 

If there is only one layer for both the stem 
wall and the first floor wall above it, the 
exterior surfaces of the walls align. The 
footing is centered on the stem wall.

Stepped stem 
walls with 
vertical footing
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Deleting Foundations
Select Build> Floor> Delete Foun-
dation to delete the entire foundation 

floor. 

You can also select and delete individual 
foundation walls and slabs by clicking the 

Delete  edit button or pressing the Delete 
key. See “Deleting Objects” on page 171.

Deleting and rebuilding the foundation is 
often the quickest way to update the model 
when substantial changes are made to Floor 1 
after the foundation is built.

Foundations and Rooms
When a foundation plan is created, rooms 
included in the Living Area calculation 
generate a stem wall, grade beam, or slab 
foundation below them. Garage rooms 
generate slab foundations, but exterior rooms 
such as Decks, Courts and Balconies do not 
generate any foundation. 

Interior foundation walls are not generated 
unless:
• They separate the area under a Slab or 

Garage room from the rest of the plan;
• They separate the area under a room 

specified as having a slab foundation 
from the rest of the plan; 

• They define areas under rooms with dif-
ferent floor heights.

Garages
When a foundation is generated based on the 
floor plan of Floor 1, a room on the first floor 
specified as either a Garage or Slab type will 

receive a stem wall or pier foundation with a 
slab floor and stem walls. If a monolithic 
slab foundation is generated, the room will 
receive a slab floor with curbs.

An opening placed in a wall defining a 
Garage will receive a cutout in the stem wall 
or curb that displays in floor plan view on the 
floor below. The width of the concrete cutout 
can be defined, and you can specify whether 
the cutout displays, in the Door or Window 
Specification dialog. See “General Tab” on 
page 266. 

By default, a room on Floor 1 specified as a 
Garage or a Slab will be assigned a lower 
floor height when the foundation is built. The 
amount that it is lowered depends on the 
foundation type:
• The floor height will drop the default 

thickness of the floor platform for Floor 1 
plus 12” (300 mm) in a Walls with Foot-
ings or Walls with Piers foundation.

• The floor height will drop 3 1/2” (88 mm) 
in a Monolithic Slab foundation. 

These values are set in the Foundation 
Defaults dialog. See “Foundation Tab” on 
page 331. 

Note: To remove all or part of the concrete
slab in the basement area, select a basement
room and define it as Open Below in the
Room Specification dialog.
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To build a Garage slab with stem walls

1. Before the foundation is generated, 
specify the room as a Garage or Slab. 

2. Build an automatic Wall with Footings 
or Walls with Piers foundation.

In the Floor 1 Garage’s Room Specification 
dialog, Floor Supplied by the Foundation 
Room Below will now be checked. See 
“Structure Tab” on page 245.

By default, the program produces a  4" (100 
mm) slab and 24” (600 mm) high stem walls 
around the garage. These stem walls are 
drawn on Floor 0 and will indicate the 
locations of any doors that extend into them. 

To build a Garage slab with curbs

1. Before the foundation is generated, 
specify the room as a Garage or Slab. 

2. Build an automatic Monolithic Slab 
foundation, specifying the required 
Lower Garage Floor value.

By default, the program produces a  4" (100 
mm) slab and 3 1/2” (88 mm) high curb 
around the garage. The curbs are drawn on 
Floor 0, use the Default Foundation Wall 
type, and will indicate the locations of any 
doors that extend into them. 

The floor height of the garage and the stem 
wall or curb height can then be adjusted, if 
necessary, in the Garage room’s Room 
Specification dialog. See “Structure Tab” on 
page 245. 

Basement Rooms
When a foundation’s type is Walls with 
Footings or Walls with Piers, and it is 
assigned a Minimum Wall Height of 76” 
(1900 mm) or greater, the resulting basement 
is automatically created with a 4” (100 mm) 
concrete slab floor. 

Similarly, if a foundation is set up to have a 
Basement Ceiling Height of 72” (1800 mm) 
or greater when built, it is automatically 
given a painted drywall Ceiling Finish. See 
“Foundation Tab” on page 331.

Regardless of its ceiling height, however, 
you can specify a ceiling finish for any room 
in the Room Specification dialog. See 
“Structure Tab” on page 245.

The resulting basement can be divided into 

separate rooms using Interior Walls  or 
any wall type you wish. If the rooms in a 
basement have different floor heights, it is 
best to separate them using walls specified as 

Foundation Walls .

Foundations and the Terrain
Home Designer Pro automatically positions 
the terrain a set distance below Floor 1. See 
“Terrain Height vs Floor Height” on page 
539. 

In a plan with a foundation present, this 
distance will be: 

• 6” (187 mm) below the top of the stem 
walls or grade beams in a Walls with 
Footings or Walls with Piers foundation. 

• 8” (200 mm) below the top of the slab in 
a Monolithic Slab foundation. 
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By default, the program will also create a 
flattened pad under the building footprint.

Not all foundations have these requirements, 
of course, so you can customize your 
foundation and terrain to suit your needs.

Daylight Basements
Daylight basements, also referred to as look-
out basements, have walls that are tall 
enough for basement windows to be 
positioned above the terrain. They are often 
found in split level or split entry structures.

To create a daylight basement condition,  
build a stem wall foundation and modify 
these settings in the Terrain Specification 
dialog: 
• Uncheck Auto Calculate Elevation.
• Increase the Building Pad Elevation, 

which is the distance between the default 
floor height of Floor 1 and the terrain. 

Walkout Basements
Walkout basements are a type of daylight 
basement typically located on sloped terrain. 
They feature walls that are above ground at 

the lower end of the slope so that a door can 
be positioned above the terrain at that end. 

To create a walkout basement, build a stem 
wall foundation and modify these settings in 
the Terrain Specification dialog: 
• Uncheck Flatten Pad.
• Uncheck Auto Calculate Elevation.

You will also need to create sloped terrain 
and adjust the Building Pad Elevation and/
or terrain data so that the terrain is at the 
appropriate height relative to the structure at 
both the high and low ends of the slope.

Stepped Foundations
Stepped foundations are usually built on 
sloping terrain. A stepped foundation will be 
produced automatically if more than one 
floor height is present on Floor 1 when the 
foundation is built. 

In floor plan view, steps in stem wall and 
monolithic slab foundations are represented 
using S markers. See “Displaying 
Foundations” on page 335.

As with a walkout basement, you will need 
to build a stem wall foundation and modify 
these settings in the Terrain Specification 
dialog: 
• Uncheck Flatten Pad.
• Uncheck Auto Calculate Elevation.

You will also need to create sloped terrain 
and adjust the Building Pad Elevation and/
or terrain data so that the terrain is at the 
appropriate height relative to the structure at 
both the high and low ends of the slope.

You can also create a stepped foundation by 
editing foundation rooms and walls. See 
“Stem Wall Height” on page 336.

Floor platform

Stem Wall Top

Terrain
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The Slab Tools
Select Build> Slab to access the Slab 
Tools. The Slab Tools are designed for 

more generic purposes than foundations and 
should not be substituted for a foundation 
plan. The settings in the Foundation 
Defaults dialog do not affect slabs created 
with the Slab Tools.

Slabs
Select Build> Slab> Slab or 
Slab With Footing, then either 

click or click and drag a rectangle to draw a 
slab. See “Rectangular Polyline” on page 
794.

Once created, slabs can be edited like other 
closed polylines. See “Editing Closed-
Polyline Based Objects” on page 138.

Piers & Pads
Piers and pads can be manually 
placed under walls, railings, or 

beams on any floor. Select Build> Slab> 
Round Pier or Build> Slab> Square Pad 
and click in floor plan view to place a pier or 
pad. 

For information about editing Piers and Pads, 
see “Editing Piers and Pads” on page 341.

Slabs and the Materials List
If the slab material type is specified as 
Concrete or Volume, the materials list  
calculates the total volume of the slab and all 
footings. See “Define Material Dialog” on 
page 643.

Editing Slabs
Slabs and Slab Holes can be selected in 2D 
and 3D views both individually and as a 
group and can be edited using the edit 
handles, the edit toolbar and the Slab 
Specification dialog. See “Slab 
Specification Dialog” on page 342.

Using the Mouse
Slabs and Slab Holes can be edited like other 
closed-polyline base objects in both 2D and 

3D views. See “Editing Closed-Polyline 
Based Objects” on page 138. 

Using the Edit Tools
One or more selected  Slabs or Slab Holes 
can be edited in a variety of ways using the 
buttons on the edit toolbar. As with most 
objects, slabs can be copied, replicated, 
moved, deleted, etc. See “The Edit Toolbar” 
on page 29. 

Editing Piers and Pads
Round Piers and Square Pads can be selected 
individually and in groups in 2D and 3D 

views  and edited using their edit handles and 
edit toolbars. 
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There are several ways to move piers and 
pads; however, they must always be 
positioned under a wall. A pier or pad can 
only be moved away from the wall it is 
placed beneath if it is moved to another wall.

Using the Mouse
In floor plan view, piers and pads can be 
edited like CAD lines. Three edit handles 
allow the pier or pad to be resized and moved 
along the wall it is placed beneath. See 
“Editing Line Based Objects” on page 127. 

In 3D views, piers and pads can be edited 
like CAD boxes. See “Editing Box-Based 
Objects” on page 141. 

Using Dimensions
In floor plan view, piers and pads can also be 
moved using dimensions. See “Moving 
Objects Using Dimensions” on page 737.

Using the Edit Tools
A selected pier or pad can be edited in a 
variety of ways using the buttons on the edit 
toolbar. As with most objects, piers and pads 
can be copied, replicated, moved, deleted, 
etc. See “The Edit Toolbar” on page 29. 

Slab Specification Dialog
Select a slab and click the Open 
Object edit button to open the Slab 

Specification dialog.

General Tab

Specify the characteristics of the 
selected Slab. 

• Specify the Elevation at Top, which is 
the height of the slab’s top surface.

If you move a foundation wall or beam,
any piers or pads it contains move with

it.

1

2

1
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• Specify the Thickness, which is the mea-
surement from the slab’s top to bottom 
surface.

Specify the characteristics of the 
selected slab’s Footing. 

• Check Has Footing if you would like the 
slab to have a footing around the inside of 
its perimeter.

• Specify the Height and Width for the 
footing.

Polyline Tab
The Length/Perimeter, total Area, and 
Volume of the selected slab displays here. 
The volume is the amount of concrete 
required to pour the slab.

Selected Line Tab
The Selected Line tab is available when the 
selected edge is a line as opposed to an arc. 
For information about the settings on this 

tab, see “Polyline Specification Dialog” on 
page 791.

Selected Arc Tab
The Selected Line tab is available when the 
selected edge is an arc as opposed to a line. 
See “Change Line/Arc” on page 159.

Line Style Tab
For information about the settings on this 
tab, see “Line Specification Dialog” on page 
780.

Fill Style Tab
The settings on the Fill Style tab affect the 
selected slab’s appearance in floor plan view. 
For information about these settings, see 
“Fill Style Tab” on page 792.

Materials Tab
For information about the settings on this 
tab, see “Materials Tab” on page 635.

Fireplaces
A masonry fireplace can be placed in 
or away from a wall by selecting 

Build> Fireplace and then clicking in the 
drawing area. 
• If created in a wall, it is considered a wall 

opening and can be moved or resized like 
a window or door. 

• If created away from a wall, it moves and 
resizes similar to a cabinet.

A selection of prefabricated metal fireplaces 
is also available from the Fixtures (Interior) 
library category. These can be framed in with 
standard walls. See “The Library” on page 
603.

The display of fireplaces is controlled in the 
Layer Display Options dialog. See “Layer 
Display Options Dialog” on page 104.

Fireplaces are edited, moved, resized, and 
deleted similar other objects. See “Editing 
Objects” on page 119.

2
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Built into a Wall
To place a masonry fireplace in a wall, select 

Build> Fireplace  and click on a wall. A 
fireplace is created with the outside of the 
fireplace flush with the outside of the wall.

Select the fireplace to display four edit 
handles located along the wall.

Click the diamond-shaped Depth handle and 
drag toward the outside of the wall. The 
fireplace will stop when the firebox front is 
flush with the inside edge of the wall.

In 3D views, fireplaces placed in walls 
display five edit handles: a Resize handle 
along each edge and a Move handle at the 
center. 

Fireplaces always face the interior when 
placed on an exterior wall. When placing a 
fireplace in an interior wall, click on the edge 
of the wall that you want the fireplace to 
face. The fireplace is created with the firebox 

on the same side as the wall edge you clicked 
on to create it. 

Freestanding
To place a free-standing masonry fireplace, 

select Build> Fireplace  and click in an 
open area away from a wall.

Unlike fireplaces placed in walls, free-
standing fireplace have ten edit handles when 
selected and may be rotated, resized, or 
moved in any direction, similar to the way 
CAD boxes can. See “Editing Box-Based 
Objects” on page 141.

Free-standing fireplaces can be selected and 
replaced with a symbol from the library by 

clicking the Replace From Library  edit 
button. See “Replace From Library” on page 
624. 

Fireplace Foundations
When a Walls with Footings or Walls with 
Piers foundation is built, a fireplace 
foundation will be generated under any Fire-

places  present on Floor 1. See “Building 
a Foundation” on page 334.

Fireplace foundations are the same material 
type as the original fireplace, but do not have 
a firebox or a hearth. Fireplace foundations 
can be edited or deleted as needed. A firebox 
and hearth can be added in the Fireplace 
Specification dialog. 
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Fireplace Specification Dialog
Select a masonry fireplace and click 
the Open Object edit button to 

display the Fireplace Specification dialog. 
Multiple fireplaces can be group-selected, 

but all objects in selection group must be 
either placed in a wall or free-standing. 

Dimensions in this dialog here must be 
entered in whole inches. Fractions and 
decimals are not accepted.

General Tab

Specify the Size and Position of the 
selected fireplace and its hearth. 

• Specify the Height of the fireplace.
• Specify the Width of the fireplace.
• Specify the Depth of the fireplace.
• Specify the Hearth Depth. This is mea-

sured from the front of the fireplace out 
into the room. To eliminate the hearth 
altogether, enter a zero for this value.

• Specify the Hearth Height, relative to 
the floor in that room.

• Enter the Floor to Bottom distance from 
the floor to the bottom of the hearth.

• When the selected free-standing fireplace 
is outside a room and Auto Adjust 
Height is checked , its Floor to Bottom 
height is measured relative to the terrain 
height. When this is unchecked, the Floor 
to Bottom height is measured from the 
default floor height of Floor 1. Only 
available for free-standing fireplaces. See 
“Terrain Height vs Floor Height” on page 
539 of the Reference Manual. 

1

2

3

4

1
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Check Suppress Dimensions to turn 
off the display of the selected 

fireplace’s width and firebox width 
dimensions in floor plan view. 

Add for Rough Opening - Specify the 
amount to add to Each Side, the Top 

and the Bottom for the fireplace’s framed 
rough opening. Only available for a fireplace 

placed in a wall, Each Side and Top are set 
to 2” (50 mm) by default. 

If the Bottom Rough Opening value exceeds 
the fireplace’s distance to the floor, the 
difference is added to the top when wall 
framing is built. See “Framing” on page 435. 

The preview image of the fireplace 
updates as changes are made. Press the 

Tab key to update to the most recent change.

Firebox Tab

Check No Firebox to eliminate the 
firebox from the fireplace. This is 

checked by default for a fireplace object 
generated on Floor 0 to serve as a solid 
matching base for a fireplace on Floor 1.

Define the Size of the selected 
fireplace’s firebox.

• Specify the firebox’s Height and Width.
• Specify the Depth of the firebox.

• The defaults are 25, 24, and 18 inches 
respectively.

Define the firebox Offset, measured 
from the center of the fireplace. 

• Enter offset Distance, which is how far 
the firebox is offset from the fireplace 
center. A value of 0 centers the fire box in 
the fireplace. 

• Offset to Left/Right - Choose to offset 
the firebox to the left or to the right. 

2
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Materials Tab
For information about the settings on this 
tab, see “Materials Tab” on page 635.

Library Fireplaces
A variety of different fireplace symbols are 
available in library. The fireplace symbols in 
the Library behave just like other Library 
objects.  See “The Library” on page 603. 

Placing a Library Fireplace
A variety of fireplace symbols are available 
in the library. See “Placing Library Objects” 
on page 620.

Flush fireplaces are designed to snap to wall 
surfaces. 

Some fireplace symbols can be enclosed by 
walls or positioned to project through a wall.

Chimneys
Chimneys can be created using a variety of 
methods. 

Masonry Fireplace Chimneys

To create a chimney on a masonry fireplace

1. Select the fireplace in a 3D view. 

2. Ctrl + drag the top edge of the chimney 
upward through all the floors and the 
roof until it is to the desired height. See 
“Unrestricted Movement” on page 153.

3. When the chimney is approximately the 
correct height, select the fireplace, click 

the Open Object  edit button, and 
type in the exact height.

Always check the manufacturer’s prod-
uct information for the framing and

clearance requirements of the fireplace unit
you plan to use, and design your plan
accordingly

Open Front fireplace projecting through a wall
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Chimney Chases & Caps
There are two ways to draw a chimney chase. 
• Place a closed box geometric shape or 

soffit in position over the chimney chase, 
resize it to match, then increase its height 
either in its specification dialog or in a 
3D view using the same method as 
extending a masonry fireplace. 

• Define the chimney chase as a room area 
using walls, making sure these walls are 
aligned between floors. The chimney 

chase “room” on the uppermost floor 
should have a much higher ceiling than 
the other rooms on that floor and should 
also have no ceiling or roof. See “Room 
Specification Dialog” on page 244.

A selection of chimney tops is available in 
the library.  In addition, custom chimney 
caps can be made using  Geometric Shapes 
and/or soffits. See “General Shapes” on page 
589 and “Soffits” on page 589.
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Chapter 14:

Roofs

Home Designer Pro’s manual and automatic 
Roof Tools allow you to draw almost any 
roof style. 

Proficiency with the Roof Tools can only be 
attained through practice, but mastering 
these tools saves you time and effort in plan 
development. For information about creating 
specific roof styles, see “Roof Tutorial” on 
page 69 of the User’s Guide.

Chapter Contents
•      Automatic vs. Manual Roofs
•      Roof Defaults
•      The Roof Tools
•      Automatic Roofs
•      Build Roof Dialog
•      Roof Planes
•      Displaying Roofs
•      Editing Roof and Ceiling Planes
•      Roof Plane Specification Dialog
•      Roof Baseline Polylines
•      Roof Baseline Specification Dialog
•      Roof and Ceiling Framing
•      Ceiling Planes
•      Ceiling Plane Specification Dialog
•      Gable/Roof Lines
•      Skylights
•      Roof Hole/Skylight Specification Dialog
•      Dormers and Crickets
•      Editing Auto Dormers
•      Dormer Specification Dialog
•      Roof Returns and Other Details
•      Roof Pitches in Degrees

Verify that all roof planes join as
intended. The program does not con-

firm correct geometry between manually
designed or edited roof planes. It is possible
to design and edit roof planes with hips and
valleys that do not meet properly. 
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Automatic vs. Manual Roofs
Home Designer Pro can create just about any 
roof style. Most common roof styles such as 
hips and gables can easily be generated 
automatically. See “Roof Tutorial” on page 
69 of the User’s Guide. 

More complex roof styles, including curved 
roof planes, can be created manually. The 
manual roof tools allow you to create any 
roof system that can be represented using 
roof planes.

Automatically 
Generated Roofs

The quickest and easiest way to create a roof 
over a structure is automatically. By default, 
a roof plane is generated over each exterior 
wall, creating a hip roof. The program 
automatically joins the roof planes at ridges, 
hips, and valleys and tries to create roof 
planes that join together to form a single, 
integrated system. See “Automatic Roofs” 
on page 353.

Any deviations from the default hip roof can 
be specified on the Roof tab of the Wall 
Specification dialog for any exterior wall. 
Here, you can specify a Full Gable Wall, 
High/Shed Gable Wall, or other options 
instead of a default hip roof. You can also 
specify a different overhang, pitch, an upper 
pitch, and the elevation where the upper 
pitch begins for the roof plane that rests on 
the selected wall. See “Roof Directives in 
Walls” on page 204.

When you need the roof planes over an area 
of a plan to be entirely separate from those 
over the rest of the structure, you can assign 

those areas to a non-default Roof Group. See 
“Roof Groups” on page 353.

Roofs can also be automatically generated 
based on a Roof Baseline Polyline. When a 
Roof Baseline Polyline is used, information 
that determines where and how roof planes 
are generated is contained in the Roof 
Baseline Specification dialog. See “Roof 
Baseline Polylines” on page 375.

Bay, bow, and box windows also produce 
roof planes automatically. For information 
about these windows and the roof styles that 
can be used with them, see “Bay, Box, Bow 
Windows & Roofs” on page 292.

Manually Drawn Roofs
Any roof system that can be created 
automatically can also be created manually. 
Each roof plane is drawn and edited 
individually, offering full control over the 
process and limiting the possibilities only to 
your imagination. 

Using Both Techniques
Another useful option is to start with an 
automatically generated roof and use manual 
design techniques to finish it. Using both 
automatic roof generation and the manual 
roof drawing and editing techniques, you can 
quickly design highly customized roof 
systems. 

Note: You cannot manually draw or edit roof
planes when Auto Rebuild Roofs is enabled
in the Build Roof dialog. See “Roof Tab” on
page 356.
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Roof Defaults
Select Edit> Default Settings, to 
open the Default Settings dialog for a 

variety of drawing tools, several of which 
directly affect roof generation. 

Build Roof Dialog
While not listed in the Default Settings 
dialog, the Build Roof dialog functions as 
the defaults dialog for roofs. Many, but not 
all, initial default values for both manually 
drawn and automatically generated roofs are 
set in this dialog. See “Build Roof Dialog” 
on page 355.

If changes are made to the settings in this 
dialog after the roof has been built, you will 
need to rebuild the roof in order for your 
changes to take effect. 

Roof Framing Defaults
Default settings for framing can be specified 
in either the Build Roof or the Framing 
Defaults dialog. Framing defaults control the 
depth of roof planes as well as the depth of 
floor and ceiling platforms, which influence 
roof plane heights. See “Framing Defaults” 
on page 436.

To create roof planes of a particular depth, 
begin by setting up the desired roof framing 
defaults, then build the roof. If you later need 
to change the structure of the roof planes, 
make the needed change to the Framing 
Defaults, and then rebuild the roof. You can 
also edit the structure of individual roof 
planes.

Floor and Ceiling Heights
The initial heights of floors and ceilings, 
which influence roof heights, are specified in 
the Floor Defaults dialog for each floor. See 
“Floor Defaults Dialog” on page 316.

The floor and ceiling heights in individual 
rooms also influence roof heights and are 
specified in the Room Specification dialog. 
See “Structure Tab” on page 245.

Wall Specification Dialog
By default, when an automatic roof is built, a 
roof plane is generated over each exterior 
wall, creating a hip roof. 

Any deviations from this default hip roof, 
such as a gable or a different pitch, can be 
specified in the Wall Specification dialog for 
any exterior wall. See “Roof Tab” on page 
218. 

Dormer Defaults
The settings in the Dormer Defaults dialog 
determine the initial settings for automatic 
dormers and are much like those in the 
Dormer Specification dialog. See “Dormer 
Specification Dialog” on page 391.

The Dormer Defaults dialog can be opened 
from the Default Settings dialog or by 

If Auto Rebuild Roofs is checked in the
Build Roof dialog and you change floor

or ceiling heights, floor or ceiling platform
depths, wall positions or roof directives in
walls, the roof rebuilds to reflect your
changes. See “Rebuilding Roofs” on page
355.
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double-clicking either of the Auto 

Dormer  tools. 

The Roof Tools
Select Build> Roof to access the Roof 
Tools. 

Build Roof
Select Build> Roof> Build Roof to 
open the Build Roof dialog, specify 

the settings for automatically generated and 
manually drawn roof planes as well as 
manually drawn ceiling planes, and build or 
rebuild a roof. See “Build Roof Dialog” on 
page 355.

When roofs are automatically generated, a 
roof plane is created over each exterior wall 
by default, resulting in a hip roof, and the 
program tries to join them together to form a 
single, integrated system.

To automatically generate a roof plane using 
values other than the defaults or to not 
generate a roof plane bearing on a particular 
wall (as with a gable or the sides of a shed 
roof), you can change the settings in the Wall 
Specification dialog. See “Roof Tab” on 
page 218.

For more information about creating 
different roof styles, see “Roof Tutorial” on 
page 69 of the User’s Guide. 

Roof Plane
Select Build> Roof> Roof Plane to 
draw a roof plane manually. See 

“Roof Planes” on page 362. You can also 
double-click the Roof Plane button to open 
the Build Roof dialog.

Ceiling Plane
Select Build> Roof> Ceiling Plane to 
draw a ceiling plane manually. Ceiling 

planes are drawn and behave much like roof 
planes. See “Ceiling Planes” on page 379.

Gable/Roof Line
Select Build> Roof> Gable/Roof 
Line to draw a gable line that 

generates a gable along a baseline edge when 
roofs are automatically generated. See 
“Gable/Roof Lines” on page 382.

Skylight
Select Build> Roof> Skylight, then 
draw a rectangle over an existing roof 

plane to create a skylight. The skylight, sky-
light shaft, and ceiling hole (if a ceiling 
exists) are drawn at the same time. See 
“Skylights” on page 385.

Auto Floating Dormer
Select Build> Roof> Auto Floating 
Dormer and click within an existing 

roof plane to place an auto floating dormer. 
See “Dormers and Crickets” on page 387.

Note: You cannot use the Roof Plane tool
when Auto Rebuild Roofs is enabled in the
Build Roof dialog. See “Manually Drawn
Roofs” on page 350.



Automatic Roofs

 353

Auto Dormer
Select Build> Roof> Auto Dormer 
and click within a roof plane to place a 

dormer. See “Dormers and Crickets” on page 
387.

Delete Roof Planes
Select Build> Roof> Delete Roof 
Planes to delete all roof planes in the 

plan. See “Deleting Roof Planes” on page 
371.

Delete Ceiling Planes
Select Build> Roof> Delete Ceiling Planes 
to delete all manually drawn ceiling planes in 
the plan. See “Ceiling Planes” on page 379.

Fix Roofs
Select Build> Roof> Fix Roofs to 
remove breaks where a single edge of 

one roof plane meets the broken edge of 
another along a ridge, hip or valley. Fix 
Roofs does not affect eave edges. See 
“Aligning Roof Edges” on page 366.

Automatic Roofs
When roofs are automatically generated, a 
roof plane is created over each exterior wall 
by default, resulting in a hip roof, and the 
program tries to join them together to form a 
single, integrated system.

There are a number of options available to 
produce variations in this default roof style. 

Roof Directives in Walls
To automatically generate a roof plane using 
values other than the defaults or to not 
generate a roof plane bearing on a particular 
wall (as with a gable or the sides of a shed 
roof), you can change the settings in the Wall 
Specification dialog for that wall. See “Roof 
Tab” on page 218.

For more information about creating 
different roof styles, see “Roof Tutorial” on 
page 69 of the User’s Guide. 

Roof Groups
When an automatic roof is generated, the 
program tries to create roof planes that join 
together to form a single, integrated system. 
Different parts of the structure influence how 
the roof is generated over the whole. 

When you need the roof planes over an area 
of a plan to be entirely separate from those 
over the rest of the structure, you can assign 
those areas to a non-default Roof Group. The 
program treats different Roof Groups as 
separate buildings for the purpose of 
automatic roof generation, preventing their 
roofs from influencing one another. 

Bear in mind that the use of Roof Groups 
typically involves using a combination of 
both automatic roof generation and manual 
roof editing, and that changes to Attic walls 
may also be necessary. See “Using Both 
Techniques” on page 350. 

Roof Groups are assigned using numbers. 
The Default Roof Group is always 0, and you 
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can assign rooms to other roof groups in the 
Room Specification dialog. See “General 
Tab” on page 244.

Curved Walls and Roofs
Automatically generated roof planes are 
placed over curved walls at specified 
increments. In the Build Roof dialog, you 
can specify the degree increments for the 
roof over curved walls, from 6° to 90°. The 

lower the number, the more roof sections are 
created over the curved wall. 

The following  illustrations show a roof 
created at two different curved increments: 
30° and 15°.

Concave Curved Walls & Roofs
Regular roof plane sections can also generate 
over concave curved walls. For roof sections 
to generate over a concave curved wall, the 
sections’ baselines must be longer than the 
Minimum Alcove Size value on the Build 
tab of the Build Roof dialog. 
If the baselines are shorter, the automatically 
generated roofs are simplified by either: 
• Ignoring the curved wall, as if the walls 

on either side extended to their meeting 
point.

• Spanning the concave curved wall with a 
straight Baseline and produce a roof plane 
for it from that.
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Rebuilding Roofs
By default, when changes are made to the 
model, the roof does not update to reflect 
these changes. This is the case even if the 
roof was automatically built. 

When Auto Rebuild Roofs is checked in the 
Build Roofs dialog, on the other hand, any 
changes made to the position of an exterior 
wall or to its roof directives will prompt the 
roof to regenerate to reflect these changes. 
See “Roof Tab” on page 356.

Changes made to floor heights, ceiling 
heights, or floor or ceiling platform 
thicknesses will also cause the roof to be 
automatically rebuilt.

You can also rebuild the roof at any time to 
reflect the current state of the model by 
opening the Build Roof dialog, checking 
Build Roof Planes, and clicking OK.

When the roof is rebuilt using Auto Rebuild 
Roof or Build Roof Planes in the Build 
Roof dialog, all roof planes in the plan, both 
automatically generated and manually 
drawn, are deleted and replaced.
• To preserve any manually drawn roof 

planes, check Retain Manually Drawn 
Roof Planes on the Build tab of the Build 
Roof dialog before the roof is rebuilt. 

• To preserve any automatically generated 
roof planes that you have edited, check 
Retain Edited Roof Planes on the Build 
tab of the Build Roof dialog before the 
roof is rebuilt.

Roof planes cannot be edited or manually 
drawn when Auto Rebuild Roofs is turned 
on. If you try to either edit or draw a roof 

plane using the Roof Plane  tool, a 
warning message will display.

Build Roof Dialog
The Build Roof dialog is used to 
automatically build or rebuild roof 

planes and generate Roof Baseline Polylines. 
The settings in this dialog act as defaults for 
both manually drawn and automatic roofs. 
See “Roof Defaults” on page 351.

To open the Build Roof dialog, select Build> 

Roof> Build Roof . You can also double-

click the Roof Tools  button or the Roof 

Plane  button to open this dialog.

Note: Under some conditions, when the roof
is rebuilt new roof planes may be generated
in the same location as retained manually
drawn or automatic roof planes. 
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Roof planes and Roof Baseline Polylines are 
generated based on the positions and roof 
directive settings for each exterior wall in the 
plan. If you make changes to any of these 
walls or to any of the settings in this dialog, 
you will need to build the roof again for them 
to take effect. See “Roof Tab” on page 218. 

The settings in this dialog are similar to those 
found in the Roof Plane Specification 
dialog, but affect all subsequently created 
roof planes rather than one or more selected  

roof planes. See “Roof Plane Specification 
Dialog” on page 371. 

There are six tabs in the Build Roof dialog: 
•      Roof Tab
•      Options Tab
•      Framing Tab
•      Arrow Tab
•      Materials Tab
•      Roof Styles Tab

Roof Tab

The Build options are commands 
related to building and rebuilding roof 

planes. 
• Check Build Roof Planes to build a new 

roof structure over the entire model. 
Unless you specify otherwise, the pro-

gram discards the existing roof planes  
and produces new ones. 

• If you check Auto Rebuild Roofs, the 
program automatically rebuilds the roof  
whenever you make a change that affects 
the generation of roofs, such as changes to 
exterior walls or ceiling heights.

1 3

2
4
5
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• Check Make Roof Baseline Polylines to 
delete the existing roof and to create Roof 
Baseline Polyline(s) based on the exterior 
wall layout and roof information defined 
in those walls. If checked, Build Roof 
Planes becomes unchecked. See “Roof 
Baseline Polylines” on page 375.

Specify how manually drawn or edited roof 
planes are handled when the roof is rebuilt 
automatically. These options are only avail-
able when Build Roof Planes is checked. 
See “Rebuilding Roofs” on page 355. 
• Check Retain Manually Drawn Roof 

Planes to prevent manually drawn roof 
planes from being deleted when roof 
planes are rebuilt. Automatic roof planes 
may be generated in the same location. 
Also available if Make Roof Baseline 
Polylines is checked. 

• Check Retain Edited Automatic Roof 
Planes to prevent automatic roof planes 
that have been manually edited - includ-
ing roof planes over exploded dormers - 
from being deleted when roof planes are 
rebuilt. Also available if Make Roof 
Baseline Polylines is checked.

If a newly generated roof plane is copla-
nar with a retained plane, and the area by 
which they overlap is at least half the area 
of either of them, the new roof plane is 
deleted and only the retained plane is 
kept. 

• Check Use Existing Roof Baselines to 
produce a roof plan based on your Roof 
Baseline Polyline(s) instead of the exte-
rior wall layout. 

You can also rebuild aspects of the structure 
related to roofs. 
• Check Rebuild Walls/Floors/Ceilings to 

rebuild the walls and floor and ceiling 
platforms of your model before the roof is 
built. It is independent of Build Roof 
Planes and helps ensure that your roof is 
generated based on the most up-to-date 
model. See “Rebuilding Walls, Floors & 
Ceilings” on page 324. 

• Check Build Fascia and Roof Trim to 
regenerate fascia and gutters. See “Fas-
cia” on page 393. You can check this box 
without also rebuilding the roof. 

Build Fascia and Roof Trim is invoked 
automatically after you manually edit roof 
planes or draw new roof planes if Auto 
Rebuild Walls/Floors/Ceilings is checked 
in the 3D View Defaults dialog. See “Options 
Tab” on page 669.

The options in the Specifications 
section are basic roof structure settings. 

• Enter a value to describe the Pitch as a 
ratio over 12. For a conversion to degrees, 
see “Roof Pitches in Degrees” on page 
395.

Roof Overhang is measured horizontally 
from the outside Main Layer of exterior 
walls to the end of the top of the rafter. It 
includes fascia but not gutters. See “The 
Main Layer” on page 209. 
• Eave is the overhang distance outside of 

bearing walls for roof planes using the 
default Pitch. If a particular roof plane has 

Note: Under some conditions, new roof
planes may be generated in the same loca-
tion as manually drawn or automatic roof
planes that have been retained. 

2
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a different Pitch, its overhang will adjust 
to keep its fascia at the same height. Over-
hang may be greater for a shallower pitch, 
lesser for a greater pitch. 

• Gable is the overhang distance at gable 
ends or rake walls. 

Check Trusses (no Birdsmouth) if you wish 
to frame the roof using trusses rather than 
rafters. The roof is raised so that the bottom 
edge of the truss top chord (or rafter) is flush 
with the top of the wall. See “Roof Trusses” 
on page 470.
• When Trusses (no Birdsmouth) is 

checked, roof plane depth is based on the 
Top Chord size specified in the Framing 
Defaults dialog. See “Trusses Tab” on 
page 453.

• When Trusses (no Birdsmouth) is 
unchecked, roof plane depth is based on 
the Rafter Depth specified in the 
Framing Defaults dialog. See “Roof Tab” 
on page 451. 

If Trusses (no Birdsmouth) is unchecked 
when the roof is built, and you then draw a 
roof truss, its bottom chord may be longer 
than expected and its top chord, higher: 

The Roof Height options affect the 
heights of roof planes. 

• Check Ignore Top Floor to ignore the top 
living floor when roof planes are gener-
ated. Roof planes are built on the top 
plates of the walls below the top floor. 

Specify the amount to Raise/Lower From 
Ceiling Height, which controls the height of 
roof planes relative to the ceiling height 
specified for the rooms below. 
• The default value is 0, which creates roof 

planes that bear on the wall top plates at 
the Ceiling Height of the room below.

• Increase this value to raise roof planes so 
they do not bear directly on the wall top 
plates. If roofs are raised sufficiently, 
Attic walls will automatically generate to 
support them. The exact height depends 
on the roof pitch. 

• Decrease this value to drop roof planes 
downward, decreasing the height of the 
bearing walls. If roofs are lowered suffi-
ciently, they may cut extend into rooms, 
producing areas with angled ceilings. 

Specify the structure of roof planes and how 
they bear on the walls below. The Raise Off 
Plate and Birdsmouth settings do not affect 
the bearing wall heights.

If the roof overhang values are not suffi-
cient to extend past the outer surface of

exterior walls, the walls may not generate
correctly in 3D views. 3
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• Uncheck Automatic Birdsmouth Cut to 
specify the birdsmouth cut for stick 
framed roofs or the energy heel for roof 
trusses. When this box is checked, the 
program produces a birdsmouth cut, and 
no energy heel. See “Birdsmouth Cut” on 
page 371. 

• Enter a positive Raise Off Plate value in 
this field to produce the trusses with an 
energy heel to allow for more insulation. 

• Enter a negative Birdsmouth Cut value 
to control the Birdsmouth Depth.  For 
example, for the Birdsmouth Depth of 3”, 
enter -3”. The location of the Baseline 
may change if you use the Raise Off 
Plate setting to specify the birdsmouth 
depth. See “Birdsmouth Cut” on page 
371. 

• Specify the Birdsmouth Seat, which is 
the horizontal depth of the birdsmouth 
cut. If you change this value, the Raise 
Off Plate/Birdsmouth Cut value will 
automatically adjust. 

To control the Birdsmouth Cut, you should 
also check Same Roof Height at External 
Walls. 
• The Vertical Rafter Depth displays here 

as a reference. It can be changed on the 
Framing tab. See “Framing Tab” on page 
362. 

Specify how you would like the eaves of roof 
planes with different pitches to meet. See 
“Aligning Eaves” on page 368.
• Check Same Roof Height at External 

Walls to keep bearing walls the same 
height and change horizontal roof over-
hang distances as needed so that eaves 
meet correctly. See “Aligning Eaves” on 
page 368.

When checked, this option ignores any 
overhang values you may have entered in 
the Wall Specification dialog. See “Roof 
Directives in Walls” on page 204.

Uncheck this option to raise or lower 
some roof planes relative to the wall’s top 
plate, allowing all horizontal overhangs to 
be the same unless a non-default value 
has been entered in the Wall 
Specification dialog. 

• Check Same Height Eaves to keep the 
eave height for all roof planes the same. 
Roof planes are raised and lowered as 
needed so that eaves meet correctly. 

The eave height used when this box is 
checked is that of a roof plane using the 
default Pitch and Overhang values. When 
this box is checked, all roof planes are 
affected,  including those that do not need 
adjustment in order to align with adjacent 
planes.

When Same Height Eaves is checked, 
any non-default overhang values speci-
fied in the Wall Specification dialog are 
used. Roof planes are raised or lowered so 
that the eave height is the same, regard-
less of the horizontal overhang.

• Uncheck Allow Low Roof Planes only 
when an upper floor overhangs roof 
planes below. 

Segment Angle at Curved Wall - 
Enter the maximum angle for a roof 

segement that covers a curved wall. This 
value is only used when roofs are 
automatically generated. A smaller angle 
produces more roof planes.

4
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Specify the Minimum Alcove Size, 
which is the minimum depth and width 

of an alcove (depression into an otherwise 
straight exterior wall). Any alcove with both 
a depth and width less than this value is 
treated as though the exterior wall continues 
straight across. Alcoves either wider or 
deeper than this value are not roofed over; 
they affect how the roof is generated. 

The following is an example showing this 
difference. If Minimum Alcove Size is 36", 
a 36" wide alcove requires a change in the 

roof line and each wall of the alcove has an 
eave. On the right, the alcove is less than the 
36" minimum, so the roof builds right over it.

Options Tab

Select Square Cut or Plumb Cut to 
determine how the rafter tails are cut. 

This change displays only after you have 
rebuilt roofs. Individual roof planes can have 
this defined in their own Roof Plane 
Specification dialog. 

Check Boxed Eave to produce 
horizontal boxed eaves or uncheck it 

for sloping eaves. You can also change this 
for individual roof planes in the Roof Plane 
Specification dialog.
• Higher Eaves Boxed - If the selected 

roof plane contains more than one eave, 
check this box to box the higher eaves as 
well as the lower ones. 

5
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• You can specify the Length of the boxed 
eaves or check Default to Overhang to 
extend the boxed eave from the edge of 
the roof to the exterior main layer of the 
wall, covering the overhang area. 

Specify how the Ceiling surface on the 
underside of roof planes is built. See 

“Vaulted and Cathedral Ceilings” on page 
242.
• When Use Room Ceiling Finish is 

checked, the ceiling finish thickness and 
material on the undersides of roof planes 
are defined by the room below. Uncheck 
this box to enable the two settings that 
follow and define the ceiling finish as part 
of the roof planes instead. 

• Check Has Ceiling to enable the Ceiling 
Thickness option. When this box is 
unchecked, the selected roof plane will 

have no ceiling surface at all and the 
“Ceiling Surface” component will not be 
available on the Materials tab.

• Specify the Ceiling Thickness, which is 
the thickness of the bottom surface of the 
ceiling plane. 

When Use Room Ceiling Finish is 
unchecked, you can specify the Ceiling 
Surface material on the Materials Tab. 

Specify the material components to 
Supply for subsequently-built roof 

planes. When checked, these items are 
calculated in the Materials List. See 
“Materials Lists” on page 887. Only Gutter is 
available in the Roof Plane Specification 
dialog. 
• Uncheck Gutter to not include gutters on 

subsequently-built roof planes. This 
option affects both the Materials List and 
3D views.

• Check Edge Flashing to calculate edge 
flashing in the Materials List.

• Check Ridge Vent to calculate ridge vent-
ing in the Materials List.

• Check Ridge Cap Shingles  to calculate 
ridge caps in the Materials List.

• Check Metal Drip Edge at Eave to cal-
culate metal drip edge along the eaves in 
the Materials List.

• Check Metal Drip Edge at Gable to cal-
culate metal drip edge along any gable 
eaves in the Materials List.

• Check Valley Flashing to calculate valley 
flashing in the Materials List. 

3D Display - When Show All Ridges is 
checked, a line along each hip between 

roof planes forming the conical roof above a 
curved wall displays in Vector Views. 

With Boxed Eave checked

With Higher Eaves Boxed checked

3

4

5
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Uncheck this box to suppress these lines. See 
“Rendered and Vector Views” on page 665.

Framing Tab
The settings on the Framing tab of the Build 
Roof dialog are the same as those on the 
Roof tab of the Build Framing dialog. 
Changes made in one dialog are also applied 
in the other. See “Roof Tab” on page 451.

Arrow Tab
The settings on this tab allow you to control 
the appearance of roof plane slope direction 
arrows. See “Displaying Roofs” on page 364.

For information about these settings, see 
“Arrow Tab” on page 783.

Materials Tab
The settings on this allow you to specify 
materials for the roof’s various components. 
See “Materials Tab” on page 635.

The “Ceiling Surface” component is only 
available when Use Room Ceiling Finish is 
unchecked on the Options Tab.

Roof Styles Tab
The Roof Styles tab provides links to tutorial 
information about creating different roof 
styles automatically. Click on a roof style to 
launch the online Help to a page with 
information about the roof style you selected. 
See “Roof Tutorial” on page 69 of the User’s 
Guide. 

Roof Planes
When creating a roof, it is helpful to know 
how to draw a roof plane manually and be 
familiar with its parts. 

Drawing Roof Planes
Roof planes are CAD-based objects 
that are created and edited like much 

closed polylines, and also have pitch, 
elevation and structural properties.  

Before drawing roof planes, you should set 
your roof defaults so that the 3D attributes of 
your roof planes are correct. See “Roof 
Defaults” on page 351.

To draw a roof plane

1. Select Build> Roof> Roof Plane . 
2. As in the following example, click and 

drag a Baseline from point 1 to point 2. 

Note: Changes made on the Framing tab will
not affect the structure of existing roof planes.
To make changes take effect, rebuild the roof.

Line 1 - 2 is the Baseline
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3. Release the mouse button at point 2 and 
move your cursor in the upslope direc-
tion. As you move the cursor, a preview 
outline of the roof plane displays.

4. Click at point 3 to build the roof plane. 
Point 3 is located on the ridge edge of 
the roof plane. 

The upslope mark displays at the center 
point of the Baseline and indicates the 
upslope direction of the roof plane. 

The distance from the outer main layer of the 
wall to the end of the eave is the overhang.

The Baseline
The pitch direction and initial height of any 
roof plane - manual or automatic - is 
determined by its Baseline.

The Baseline of the roof plane is normally 
located over the outer main layer of the wall 
and is used as the pivot point for the roof 
plane when the pitch is changed.  

The Baseline height is determined by the 
following formula: 

          Elevation of the wall top plate
       + Vertical Rafter Depth
        - Vertical Birdsmouth Depth 
       = Baseline Height
In a cross section, the Baseline is located 
directly above the outer surface of the main 
wall layer, at the top surface of the roof 
framing. 

A roof Baseline displays as a separate line 
within its roof plane when the “Roofs, 
Baselines” layer is turned on. In 3D views, it 
can only be seen if the roof plane is selected. 

A Baseline has a tick mark at its center point 
which indicates the direction that the roof 
plane slopes upward. If the upslope tick is 
pointing the wrong direction, either rotate the 
entire roof plane or delete it and draw a new 
one. 

When drawing the Baseline of a roof plane, 
here are some things to consider:
• A Baseline does not have to be drawn 

over a wall, although it often is.
• A Baseline drawn along a wall should be 

drawn over the outer edge of the wall’s 
main layer. It tries to snap to that layer. 

• The elevation of the top plate is defined 
by the ceiling height in the room. If the 
roof plane is not drawn over a wall, it’s 
height is based on the default ceiling 
height value for the current floor. 

• If a Baseline is drawn over the top of any 
other roof plane, the Baseline height 
equals the height of the existing roof 

Note: You cannot manually draw roof planes
when Auto Rebuild Roofs is enabled in the
Build Roof dialog. See “Roof Tab” on page
356.

Location of Roof Baseline in cross-section

Straight up from outside 
of main wall layer at top 
surface of roof framing
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plane at the point where you started draw-
ing.

Once drawn, a Baseline can be selected in 
floor plan view and edited independent of the 
roof plane. See “Editing Roof Baselines” on 
page 369. 

Eave and Gable Overhangs
Roof overhangs are measured horizontally 
from the outside Main Layer of exterior 
walls to the end of the top of the rafter. They 
include fascia but not gutters. See “The Main 
Layer” on page 209. 

The location of a roof plane’s fascia and 
shadow boards also determines its area and 
the size of its polyline in floor plan view. See 
“Polyline Tab” on page 374.

Displaying Roofs
Roof planes are drawn on the “Roof 
Planes” layer. 

You can also choose to displaygutters, gable 
lines, the overhang area, Roof Baseline 
Polylines and roof openings.  See “Layer 
Display Options Dialog” on page 104.

If the “Roof Planes” layer is turned off and 
Auto Rebuld Roofs feature is turned on, 
changes made to the plan that cause the roof 
to rebuild will not automatically turn on the 
display of the roof planes. See “Rebuilding 
Roofs” on page 355.

Roof Plane Labels
Roof plane labels indicating the pitch and 
slope direction are located on the “Roofs, 
Labels” layer and can be set to display in 
floor plan view. 

You can specify whether roof plane labels 
display the pitch in terms of rise and run or in 
decimal degrees by checking or unchecking 
Pitch in Degrees in the Roof Plane 
Specification dialog. See “General Tab” on 
page 372.

A roof plane’s label can be customized in its 
specification dialog. See “Label Tab” on 
page 885.

Manually drawn Ceiling Planes  and 

Skylights  can also display labels when 
the “Roofs, Labels” layer is on. Unlike roof 
planes, these objects’ do not include a slope 
indicator and their Automatic Labels are 
blank; however, you can specify a custom 
label using text in their specification dialogs. 
See “Ceiling Planes” on page 379 and 
“Skylights” on page 385.

  Roof Overhang measured horizontally from 
the wall’s Main Layer to outside of the fascia
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When a roof plane, ceiling plane or roof 
hole/skylight is selected in a 3D view, its 
label will display on a temporary basis if the 
“Roofs, Labels” layer is turned on. 

Display on Floor Above/Below
In floor plan view, roof planes 
can display on any floor without 

affecting their height in 3D. 

To move the display of a roof plane to a new 
floor, select it in floor plan view and click 
either the Display on Floor Above or 
Display on Floor Below edit button. The 
display of group-selected roof planes can 
also be controlled in this manner.

Any skylights or roof holes placed in a roof 
plane moved in this manner will move, as 
well. Other associated objects like Auto 
Dormers or gutters will not move, however.

In Cross Section Views
When a roof or ceiling plane is viewed in a 
cross section, the layers that compose it can 
be seen, including the roof surface, 
sheathing, and the ceiling surface. 

• If roof framing has been built, it’s display 
can be turned on, as well. See “Displaying 
Framing” on page 458.

• If a roof or ceiling plane is located over a 
room with Ceiling Over this Room 
checked, the ceiling surface will not gen-
erate. See “Vaulted and Cathedral Ceil-
ings” on page 242.

In the Materials List
The materials that make up roof and ceiling 
plane assemblies are listed under different 
Categories in the Materials List: 
• Roofing - Lists most materials associated 

with roofs, including roofing, sheathing, 
rafters and trusses, gutters,and skylights.

• Insulation - Insulation is calculated for 
roof and ceiling planes above rooms that 
do not have Ceiling Over This Room 
checked. See “Structure Tab” on page 
245. 

• Wallboard - Lists ceiling materials for all 
rooms, including those that use the under-
side of the roof as their ceiling.

• Framing - Lists ceiling framing for man-
ually drawn ceiling planes. 

See “Materials Lists” on page 887. 

Editing Roof and Ceiling Planes
A selected roof or ceiling plane can be edited 
in 2D and 3D using edit handles, edit toolbar 
buttons, its specification dialog, and the 

Material Painter .

A roof or ceiling plane’s Baseline can also be 
selected and edited. To select it, first select 
the roof plane and then click the Select Next 

Object  edit button. See “The Baseline” 
on page 363. 

By default, all roof planes are deleted and 
replaced whenever the roof is rebuilt using 
the Build Roof dialog. If you have manually 
edited roof planes and do not want them to be 
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replaced, be sure to check Retain Edited 
Roof Planes. See “Roof Tab” on page 356.

2D Shape and 3D Orientation
There are two basic aspects to editing roofs: 
2D shape and 3D orientation. 
• The 2D shape of a roof or ceiling plane 

can be edited just like a CAD polyline. As 
a plane is reshaped in 2D, the program 
maintains its height and pitch in 3D. See 
“Editing Closed-Polyline Based Objects” 
on page 138.

• The 3D orientation of a roof or ceiling 
plane is defined by its height and pitch 
and can be edited in its specification dia-
log. See “General Tab” on page 372.  

An understanding of these two concepts  
allows you to design almost any kind of roof.

A roof or ceiling plane’s display and 
appearance can be customized. See 
“Displaying Roofs” on page 364 and “Roof 
Plane Specification Dialog” on page 371.

Adding a Step to an Edge
You can make a step, or jog, in the edge of a 
roof or ceiling plane by selecting it, clicking 

the Break Line  edit button and then 
clicking on the roof edge. See “Break Line” 
on page 158.

Aligning Roof Edges
By default, the edges of a roof plane will 
automatically snap to the outer surface of a 
nearby parallel wall. You can disable this 
Special Snapping behavior for a selected 
roof plane in its specification dialog. See 
“General Tab” on page 372. 

After moving a corner edit handle, it may be 
difficult to make an edge parallel to an eave 
or a wall. Use the Make Parallel/

Perpendicular  edit button to align a roof 
or ceiling plane edge with a wall, another 
roof plane edge, or another object with a 
straight edge. See “Using Make Parallel/
Perpendicular” on page 155. 

Sometimes, what appears to be a single, 
straight roof plane edge may actually be 
broken into two or more edges, which can 
affect your ability to align the edge properly. 

A single edge will have three edit handles; if 
more than three display, more than one edge 
is present. An extra handle can be removed 

Roof planes cannot be edited while
Auto Rebuild Roofs is turned on. If you

try to do so, the program will prompt you to
turn it off.

If opposite sides of a roof plane are par-
allel, Temporary Dimensions will display

between them when one side is selected.
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removed manually by dragging it into an 
adjacent handle. You can also use Build> 

Roof> Fix Roofs . See “Fix Roofs” on 
page 353.

When Bumping/Pushing  is enabled and 
CAD Stops Move is checked in the Roof 
Plane Specification dialog, a roof plane will 
bump against another roof plane, CAD or 
CAD based object as it is moved. Roof 
planes cannot push these objects, however. 
See “Bumping/Pushing” on page 152. 

Join Roof Planes
Two roof or ceiling planes can be 
joined at adjacent edges in both 2D 

and 3D using the Join Roof Planes edit 
button. To use this tool, first identify which 
edges of the roof planes can extend to meet at 
a ridge, hip, or valley. The program will join 
the two planes along the line where they 
intersect whenever possible. 

To use Join Roof Planes

1. Select a roof or ceiling plane on the edge 
to be joined to another plane.

2. Click the Join Roof Planes  edit but-
ton (or press 2 on the keyboard).

3. Move your pointer to the edge of the 
second roof or ceiling plane that the first 
one needs to join to. When your pointer 
is over the second plane, this plane will 
highlight.

4. Click on the edge of the second roof or 
ceiling plane to join it to the first plane.

If the planes are not close enough, or their 
shape is not correct, you may need to align 
their edges, remove extra edges, or move 
them closer. 

When roof or ceiling planes adjust, the 
program joins them at the proper location 
and the adjacent edges extend or contract to 
remain connected. If the joining of the two 
will completely eliminate or reverse an 
adjacent edge, the connection cannot be 
made. 

Locating Intersections
When roof planes of differing slopes meet, 
they create a ridge, hip, or valley. The Join 

Roof Planes  edit tool is the easiest way 
to move roof plane edges so that they meet 
correctly; but you can also locate roof plane 
intersection points where the ridge, hip or 
valley should be. Once you know where the 
planes will meet, you can drag edges or 
corners to those points.

To find roof plane intersection points

1. Make sure that Automatically Place 
Roof Intersection Points is turned on in 
the Preferences dialog. See “Architec-
tural Panel” on page 73. 

2. Select the roof plane you would like to 
place intersection points on.

3. Click the edge of another roof plane to 
place a temporary CAD Point where it 
would meet the selected roof plane.  

Note: Join Roof Planes cannot be used to join
a roof plane and ceiling plane. Only planes of
the same type can be joined using this tool.
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4. Repeat steps 1 and 2 for the ridge edge 
and both fascia edges. You should have 
three points located on the larger roof 
plane: these are the intersection points.

5. Once these intersection points are identi-
fied, you can snap the corners of the sec-
ond roof plane to them.

Aligning Eaves
It is not uncommon for roof plans to feature 
more than one pitch. In order for the eaves of 
roof planes with different pitches to meet 
correctly at ridges and hips, you must control 
the roof planes’ heights and their horizontal 
overhang distances. Two options in the Build 
Roof dialog allow you to control how the 
eaves of automatically generated roof planes 
align. See “Roof Tab” on page 356.
• Same Roof Height at Exterior Walls 

maintains the default height of roof planes 
where they bear on exterior walls. The 
horizontal overhang distances of any non-
default roof planes are adjusted so that 
they continue to join correctly with 
default roof planes.

• Same Eave Heights maintains the default 
roof plane height at the eaves as well as 

any non-default horizontal overhang dis-
tances . All roof planes are raised or low-
ered so that they all have the same height 
at the eaves as default roof planes. 

Roof planes that do not join other roof planes 
with different pitches at ridges or hips are 
referred to as Independent. 
• When Same Roof Height at Exterior 

Walls is checked, Independent roof 
planes are not affected and will maintain 
any non-default overhang values. 

• When both Same Roof Height at Exte-
rior Walls and Same Eave Heights are 
checked, the overhangs of Independent 
roof planes will be adjusted to preserve 
their heights at both the exterior walls and 
the eaves. 

Move to be Coplanar
The Move to be Coplanar edit button 
allows you to move the selected roof 

plane to be coplanar (in the same plane) with 
the next selected roof plane. You can use this 
tool in both 2D and 3D views. The results 
can be easily seen in a cross section view. 
The two roof planes must have parallel 
Baselines for this to work.

Raising/Lowering Roof Planes
Roof planes can be raised or lowered 
in the Roof Plane Specification 

dialog.  Begin by locking the Pitch, then 
change the value of the Baseline Height. See 
“General Tab” on page 372.

You can also raise or lower roof 
planes in the Transform/Replicate 

Object dialog. See “Transform/Replicate 
Object Dialog” on page 166.

roof plane 
intersections 
marked with 
an “X”
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In addition, when a new floor is added to a 
plan, you can choose to move any roof 
planes displaying on the top floor up one 
floor. See “Adding Floors” on page 317. 

Change Roof Pitch or 
Height Dialog

The Change Roof Pitch or Height dialog 
displays when you attempt to snap the corner 
or an edge of a roof plane near the edge of 
another roof plane that does not match 
vertically. This dialog gives you the option to 
move the roof plane vertically, or pivot it 
about a point and change the pitch.

In this case, the current roof plane would 
have to raise its pitch or height in order to 
meet the second roof plane at the corner that 
you moved. 

The amount of vertical displacement 
between the selected roof plane and another 
nearby roof plane is stated at the top left. 
• Click on Pivot About Eave to maintain 

the current eave height and modify the 
baseline and ridge heights and pitch to 
meet the other roof plane. Not available 
when the selected corner is associated 
with the eave edge.

• Click on Pivot About Baseline to main-
tain the current baseline height and mod-
ify the eave and ridge heights and pitch to 

meet the other roof plane. Not available 
when the selected corner is associated 
with the baseline.

• Click on Pivot About Ridge to maintain 
the current ridge top height and modify 
the eave and baseline heights and pitch to 
meet the other roof plane. Not available 
when the selected corner is associated 
with the ridge edge.

• Click on Raise/Lower (no pivot) to 
maintain the current pitch and raise or 
lower the entire plane to connect the 
roofs. This may affect plate heights of the 
walls below.

• Click on None of the Above to close the 
dialog without making any changes to the 
selected roof plane.

To prevent this dialog from displaying, check 
Don’t show again during this session. The 
dialog does not display again until you have 
terminated and restarted the program.

Editing Roof Baselines
The pitch direction and initial height of any 
roof plane - manual or automatic - is 
determined by its Baseline. See “The 
Baseline” on page 363. 

In floor plan view, a Baseline can be selected 
and edited independent of the roof plane. To 
select it, click on the roof plane at the 
location of the Baseline and then click the 

Select Next Object  edit button. The 
Status Bar tells you when the roof plane 

Unless you have a specific reason to
adjust the roof plane this way, it is usu-
ally best to select None of the Above.



370

Home Designer Pro 2014 Reference Manual

Baseline is selected. See “Select Next 
Object” on page 126.  

If a roof plane Baseline is moved, its height 
will not change. Instead, the height of the 
roof plane will be affected. In most cases, 
therefore, moving a roof plane’s Baseline 
independent of the roof plane itself is not 
recommended. 

If the angle of a roof plane’s Baseline is 
changed, the direction of the roof plane’s 
pitch will be modified. The Baseline Angle 
can be modified in either of two ways: 
• In the Roof Plane Specification dialog. 

This will change its angle relative to the 
floor, and will tilt the roof plane along an 
axis perpendicular to its Baseline. This 
method is helpful when a specific eave 
angle is needed. See “General Tab” on 
page 372.

• Using its Rotate edit handle in floor plan 
view. This will change its angle relative to 
the roof plane’s eave or ridge and will 
modify the direction of the pitch. This 
method is best when the pitch direction 
matters more than the angle of the eave.

• Both of these methods can be used to 
modify the same roof plane, although the 
second approach makes it difficult to con-
trol both the pitch direction and eave 
angle, and is not recomended. 

The length of a roof plane Baseline can be 
lengthened or shortened using its edit 
handles without changing any of the roof 
plane’s attributes. 

Set Baseline Height Dialog
If you manually draw a roof plane so that it 
bears on a wall at its Baseline, and is placed 
in the same location as an existing roof 

plane, the Set Baseline Height dialog will 
display. See “The Baseline” on page 363.

• Select Over wall top to create a roof 
plane that bears on the wall it is drawn 
over and has an overhang as specified in 
the Build Roof dialog. This option would 
be appropriate to produce a full height 
dormer. See “Manually Drawn Dormers” 
on page 389.

• Select Top of roof plane at start of base-
line to produce a roof plane with a height 
based on that of the roof plane below it 
rather than the wall. The Baseline height 
equals the top height of the existing roof 
at the point where you began drawing the 
new roof plane Baseline, and has no over-
hang. This option would be appropriate to 
create a dormer vent or cricket. See 
“Manually Drawn Crickets” on page 390.

Editing Roof Plane Structure
To create roof planes of a particular depth, 
begin by setting up the desired roof framing 
defaults, then build the roof. See “Framing 
Defaults” on page 436. 

If you later need to change the structure of 
the roof planes, make the needed change to 
the Framing Defaults, and then rebuild the 
roof. You can also edit roof structure on an 
individual roof plane basis. See “Roof Plane 
Specification Dialog” on page 371. 
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Birdsmouth Cut
The birdsmouth is the notch cut into a rafter 
where it rests on the wall top plate. You can 
control its vertical depth and the width of the 
birdsmouth seat in the Build Roof dialog. 
See “Roof Tab” on page 356. 

There are two ways to create a roof plane 
with no birdsmouth: 
• Check Trusses (No Birdsmouth) in the 

Build Roof dialog before drawing the 
roof plane.

• Specify a Raise Off Plate value of at least 
1/16” in the Build Roof dialog. 

To change the birdsmouth depth after the 
roof is built, you can move the roof planes up 
or down, or change the pitch. For example, if 
you lock the pitch and raise the roof plane by 
one inch, you decrease the birdsmouth depth 
by one inch. 

Locking Roof Planes
When the roof plan is correct, roof planes 
can be locked to prevent accidental changes. 
To do this, lock the “Roof Planes” layer. See 
“Layer Display Options Dialog” on page 
104. 

Locking roof planes will not prevent roof 
planes from being deleted if the floor they 
are on is deleted. 

Deleting Roof Planes
There are several ways to delete roof planes.

Delete the entire roof quickly by 
selecting Build> Roof> Delete Roof 

Planes. 

You can also delete all roof planes at 
once in the Delete Objects dialog. 

See “Delete Objects Dialog” on page 171.

In addition, you can select any roof plane or 
group of roof planes, then press the Delete 

key or click the Delete  edit button to 
delete it from the plan. See “Deleting 
Objects” on page 171.

Generally speaking, roof planes cannot be 
deleted if they are locked. An exception to 
this rule occurs when an entire floor of a plan 
is deleted. Any roof planes present on a floor 
will be deleted when the floor is deleted, 
locked or not. See “Deleting Floors” on page 
320.

Roof Plane Specification Dialog
Select one or more roof planes and 
click the Open Object edit button to 

open the Roof Plane Specification dialog. 
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General Tab

There are four values that define the 3D 
orientation of a roof plane: Ridge/Top 
Height, Baseline Height, Fascia Top 
Height and Pitch.

Locking any of the Height values defines 
that value as the pivot point for the selected 
roof plane. Each of these dimensions is 
measured from the first floor default 
elevation of 0' - 0". 

If you lock the Pitch and change a Height 
value, the roof plane moves vertically, 
keeping the same slope. It will not pivot. For 
a conversion to degrees, see “Roof Pitches in 
Degrees” on page 395.

Changing these values does not affect the 2D 
representation of the roof plane.
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Specify the Height of the selected roof 
plane(s). 

• Define the Ridge/Top height of the 
selected roof plane, or lock this value to 
make it the roof plane’s pivot point.

• Define the Baseline height, or lock this 
value to make it the pivot point. 

• Define the Fascia Top height, or lock this 
value to make it the pivot point.

Specify the Pitch for the selected roof 
plane. Lock the Pitch to move the roof 

plane vertically when a Height value is 
changed. 
• Check Pitch in Degrees to display the 

pitch value in this dialog in degrees in this 
dialog and in roof plane labels. Values 
between -80° and 80° can be entered.

• When Pitch in Degrees in unchecked, 
Pitch is described in terms of rise and run: 
x inches in 12 in Imperial plans and x mm 
in 1000 in metric plans.

Specify the angle of the selected roof 
plane’s Baseline, relative to the XY 

axis. See “Editing Roof Baselines” on page 
369. 
• A positive Baseline Angle value causes 

the Baseline to tilt upward from its default 

height. A negative value causes it to tilt 
downward. The top heights of any walls 
under the selected roof plane will become 
angled, as well. 

• The Baseline Height defined above can 
be maintained at either the Start or End 
point. In floor plan view, the Baseline 
direction is clockwise around the house.

Specify the Rafter Depth for the 
selected roof plane. The default rafter 

depth is set in the Build Framing dialog. See 
“Build Framing Dialog” on page 443. 

Information about the structure of the 
selected roof plane(s) displays here for 

reference.
• The Birdsmouth Depth is the plumb or 

vertical depth of the birdsmouth cut. To 
change it, move the roof plane some way. 
For example, if you lock the pitch and 
raise the roof plane by one inch, you will 
decrease the birdsmouth depth by one 
inch.  See “Birdsmouth Cut” on page 371.

• The Birdsmouth Seat is the horizontal 
width of the birdsmouth cut. This value is 
dynamically linked to the birdsmouth 
depth - if one changes, so does the other.

• The Vertical Rafter Depth is defined by 
measuring a plumb line across the rafter. 
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The degree of pitch affects the Vertical 
rafter width. The greater the pitch, the 
greater the vertical rafter depth.

• Top of Plate is defined by the ceiling 
height for the room.

• Overhang from Baseline is the horizon-
tal overhang measured from the Baseline 
to the eave.

Mark as Edited - When an automatic 
roof plane is moved or reshaped, the 

program marks it as "edited". You can check 
Retain Edited Roof Planes in the Build 
Roof dialog to prevent these marked planes 
from being deleted when the roof is rebuilt. 
Checking Mark as Edited also marks an 
automatically generated roof plane from 
being replaced, even if it has not been edited. 
Edited planes can also be unmarked.

This option is only available for 
automatically generated roof planes. If a 
manually drawn roof plane is selected, the 
words Manual Roof Plane will display here 
instead.

Check No Special Snapping to prevent 
the selected roof plane from snapping 

to the outer surface of any walls that it may 
butt against. When this box is unchecked, the 
roof plane’s edges will automatically snap to 
the outside of any nearby parallel walls. 

Click the Num Style button to change 
the way numbers display in the dialog. 

See “Number Style/Angle Style Dialog” on 
page 89.

Options Tab
The settings on the Options tab are the same 
as those on the tab of the same name in the 
Build Roof dialog, but affect the selected 

roof plane only. See “Options Tab” on page 
360.

Framing Tab
The settings on the Framing tab are the same 
as those on the Roof tab of the Build 
Framing dialog, but apply to the selected 
roof plane only. See “Roof Tab” on page 451.

Polyline Tab
The Polyline tab indicates the length of the 
roof plane’s Perimeter and its enclosed 
Area, calculated using several different 
methods. 

Perimeter - This is the length of the roof 
plane’s perimeter, including fascia, with its 
pitch taken into account. It does not equal the 
perimeter as measured in floor plan view 
unless the pitch is 0. 

Framing Area - This is the area of the roof 
plane’s framing, not including the fascia, 
with the pitch taken into account. It is 
slightly smaller than the Roof Surface Area 
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as roofing typically overhangs the framing 
by a small amount.

Projected Area - This is the area of the roof 
plane polyline, including fascia, as seen in 
floor plan view. It does not equal the Roof 
Surface Area unless the pitch is 0.

Roof Surface Area - This is the area of the 
roof plane’s top surface, which covers the 
fascia, with the pitch taken into account.

Overhang Area - This is the area of the roof 
plane’s overhang, including fascia, with its 
pitch taken into account. 

Projected Overhang Area - This is the area 
of the roof plane’s overhang, including 
fascia, as seen in floor plan view. 

Selected Line Tab
The Selected Line tab is similar to the Line 
tab of the Line Specification dialog. See 
“Line Tab” on page 780.

Line Style Tab
For information about the settings on this 
tab, see “Line Style Tab” on page 781.

Fill Style Tab
The settings on the Fill Style tab control the 
appearance of the selected roof plane in floor 
plan view. For information about these 
settings, see “Fill Style Tab” on page 792. 

Materials Tab
The settings on the Materials tab allow you 
to specify materials for the selected roof 
plane’s various components. For more 
information, see “Materials Tab” on page 
635.

The “Ceiling Surface” component is only 
available when Use Room Ceiling Finish is 
unchecked and Has Ceiling is checked on 
the Options tab.

Label Tab
Roof plane labels display when the “Roofs, 
Labels” layer is turned on and use the Text 
Style assigned to that layer. See “Roof Plane 
Labels” on page 364.

For information about the settings on this 
tab, see “Label Tab” on page 885.

Roof Baseline Polylines
Typically, the program builds an automatic 
roof based on the settings in the Build Roof 
dialog and on the Roof tab of the Wall 
Specification dialog, along with the layout 
of the exterior walls and floor and ceiling 
heights. 

If you want to build a roof that diverges from 
the footprint of your building as well as the 
roof directives in the exterior walls, you can 
use Roof Baseline Polylines.

To create roof baseline polylines

1. Select Build> Roof> Build Roof .
2. On the Build tab of the Build Roof 

dialog, check Make Roof Baseline 
Polylines. 

3. Click OK. A set of roof Baselines is cre-
ated along the outside edge of the Main 
Layer of the exterior walls, forming one 
or more closed polylines.
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As with roof planes, the heights of Roof 
Baseline Polylines are determined by ceiling 
heights in the plan. If roof planes will be 
built at more than one height, a separate 
baseline polyline is created for each height.

Once created, a Roof Baseline Polyline can 
be edited in a variety of ways, then used as 
the basis for the roof then next time it is built 
automatically. 

To create a new roof using the directives in 
your Roof Baseline Polyline(s), check Use 
Existing Roof Baselines in the Build Roof 
dialog and click OK. See “Roof Tab” on page 
356.

Displaying Roof 
Baseline Polylines

Roof Baseline Polylines are placed on the 
“Roofs, Baseline Polylines” layer and use the 
Text Style assigned to that layer. See 
“Displaying Objects” on page 102.

Roof directive information displays along 
each edge of the polyline, including:
• V - vertical (against wall);
• G -gable/shed;
• K - knee wall;
• L - lower (extend slope downward).

If the directive information includes the 
pitch, the roof plane slopes toward that edge; 
if it includes the word (vert), it does not.

 Editing Roof 
Baseline Polylines

A Roof Baseline Polyline’s shape can be 
edited much like a CAD polyline using its 
edit handles and edit toolbar buttons. See 

“Editing Closed-Polyline Based Objects” on 
page 138.  

Roof Baseline Polylines always form a 
closed area with straight sides only. They 
cannot be severed or curved, but additional 
joints or corners can be added.

When a new roof is built, it follows the shape 
of the Roof Baseline Polyline even if that 
shape does not follow the exterior walls. 

In addition to length and direction, each Roof 
Baseline Polyline edge has roof directives 
associated with it, much like the roof 
directives in individual walls. See “Roof 
Directives in Walls” on page 204.

An Example
For a simple example of Roof Baseline 
Polyline editing, consider an L-shaped 
house, with a rectangular roof. The inner part 
of the ’L’ is a patio that is covered under the 
same roof.

On the left is the baseline polyline as it was 
originally produced and the roof plan it 
creates.

To model the roof plan shown on the right

1. Select the Roof Baseline Polyline along 
its bottom-most edge.
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2. Click the Fillet Two Lines  edit but-
ton. See “Reshaping Objects” on page 
158.

3. Click the left-most edge to remove the 
two intervening edges. 

4. A message box informs you that “The 
system must delete intervening lines 

(those on the inside of the L) to join the 
two selected lines.” Click OK.

5. Open the Build Roof dialog and select 
the Build Roof Planes and Use Existing 
Roof Baseline check boxes to model the 
roof plan shown on the right side of the 
image above.

Roof Baseline Specification Dialog
Like walls, each line of a Roof 
Baseline Polyline contains roof 

directives that affect automatic roof 
generation. Select any edge of a Roof 

Baseline Polyline click the Open Object edit 
button open the Roof Baseline 
Specification dialog.

Roof Baseline Tab

Options -

The first four checkboxes: Full Gable Wall, 
High Shed/Gable Wall, Knee Wall, and 
Extend Slope Downward are the same as 
those in the Wall Specification dialog. See 
“Roof Tab” on page 218.

Check Against Wall if the roof plane rising 
from this baseline butts against an exterior 
wall. This is similar to checking High Shed/
Gable Wall.

Specify the Pitch for the selected edge 
of the Roof Baseline Polyline. This 

overrides the default pitch set in the Build 
Roof dialog. See “Build Roof Dialog” on 
page 355.

The Pitch, 2nd Pitch, and Starts at settings 
are the same those in the Wall Specification 
dialog. 

Baseline height - This is the height of 
the entire Roof Baseline Polyline, not 

just that of the selected edge. See “The 
Baseline” on page 363. 
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Polyline Tab
The Polyline tab indicates the length of the 
Roof Baseline Polyline’s Perimeter, its 
enclosed Area, and its Volume. 

Selected Line Tab
This tab is similar to the Line tab of the Line 
Specification dialog. See “Line Tab” on 
page 780.

Line Style Tab
For information about the settings on this 
tab, see “Line Style Tab” on page 781.

Fill Style Tab
The settings on the Fill Style tab control the 
appearance of the selected Roof Baseline 
Polyline in floor plan view. For information 
about these settings, see “Fill Style Tab” on 
page 792.

Roof and Ceiling Framing
Roof framing can be both drawn manually 
and generated automatically. You can also 
combine the two techniques. As with other 
kinds of framing, it is often easiest to begin 
by generating roof framing automatically and 
then editing it as needed. See “Manual vs. 
Automatic Framing” on page 437.

Roof Trusses  cannot be generated 
automatically - they must be drawn manually 
and then replicated. If you intend to use Roof 
Trusses, make sure the settings in the Build 
Roof dialog are properly defined before you 
build the roof. See “Roof Trusses” on page 
470.

When using a combination of Roof Trusses 
and stick framing, begin by drawing the roof 
planes and ceiling planes. When they are in 
place, draw and replicate the Roof Trusses.  
Finally, automatically generate or manually 
draw the stick framing and edit it as needed. 
See “Mixing Rafters and Trusses” on page 
439.

Framing for manually drawn Ceiling 

Planes  cannot be drawn manually - it 
must be automatically generated. The 
framing for manually drawn Ceiling Planes 
is generated when ceiling framing is built 
and uses the settings in the Build Roof dialog 
as defaults. Once it has been created, it can 
be edited. See “Ceiling Plane” on page 352.

Rebuilding Roof Framing
If roof framing defaults are modified after 
the roof and roof framing are built, neither 
will update automatically. In order to update 
the model you need to rebuild the roof, then 
rebuild the roof framing. 

You can also modify the roof framing 
settings for individual roof planes, and then 
either build roof framing or manually redraw 
the framing for just those planes. See 
“Framing Tab” on page 362.

See “Keeping Framing Current” on page 
461.
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Ceiling Planes
Ceiling planes are drawn the same 
way as roof planes and are edited 

using the same tools. They are useful for 
creating custom vaulted ceilings. See 
“Vaulted and Cathedral Ceilings” on page 
242.

Ceiling planes are drawn using the same 
pitch as roof planes, specified in the Build 
Roof dialog. See “Build Roof Dialog” on 
page 355.

If you wish, you can specify the desired pitch 
in the Build Roof dialog before drawing a 
ceiling plane, or you can change the pitch 
after it is drawn in the Ceiling Plane 
Specification dialog. See “Ceiling Plane 
Specification Dialog” on page 380.

There are a few things to remember when 
drawing ceiling planes.
• Ceiling planes should be created over 

rooms that have Ceiling Over this Room 
unchecked in the Room Specification 
dialog. See “Structure Tab” on page 245.

• The Baseline of a ceiling plane should be 
drawn along the outer surface of the bear-
ing wall’s Main Layer. This allows the 
ceiling plane to extend over and be sup-
ported by the wall. See “The Main Layer” 
on page 209. 

• The sloping edge at the side of a ceiling 
plane should butt to the inside of the wall.

• Ceiling planes act independent of the roof 
planes above.

• Usually, the pitch of a ceiling plane is 
lower than the pitch of the corresponding 
roof plane. 

• Ceiling planes can be joined together 

using the Join Roof Planes  edit but-
ton. See “Join Roof Planes” on page 367.

• Select a ceiling plane and click the Open 

Object  edit button to open the Ceiling 
Plane Specification dialog. See “Ceiling 
Plane Specification Dialog” on page 380.

Displaying Ceiling Planes
Ceiling planes are drawn on the 
“Ceiling Planes” layer. 

Manually drawn Ceiling Planes  can also 
display labels when the “Roofs, Labels” 
layer is on. See “Roof Plane Labels” on page 
364.

Cross Section showing ceiling planes.
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Editing Ceiling Planes
Ceiling planes can be edited much like roof 
planes using their edit handles and edit 
toolbar buttons. See “Editing Roof and 
Ceiling Planes” on page 365. 

Ceiling planes can also be edited in the 
Ceiling Plane Specification dialog. See 
“Editing Roof and Ceiling Planes” on page 
365. 

As with roof planes, the ceiling planes layer 
can be locked to prevent editing. 

Deleting Ceiling Planes
Select Build> Roof> Delete Ceiling Planes 
to delete all ceiling planes in the current plan. 

Ceiling planes can also be deleted at 
once in the Delete Objects dialog. 

See “Delete Objects Dialog” on page 171.

In addition, you can select any ceiling plane 
or group of ceiling planes, then press the 

Delete key or click the Delete  edit button 
to delete it from the plan. See “Deleting 
Objects” on page 171.

Ceiling Plane Specification Dialog
Select a ceiling plane and click the 
Open Object edit button to open the 

Ceiling Plane Specification dialog.

The Ceiling Plane Specification dialog is 
similar to the Roof Plane Specification 
dialog. See “Roof Plane Specification 
Dialog” on page 371.

General Tab

There are four values that define the 3D 
orientation of a ceiling plane: Bottom at 

Ridge, Inside Bottom, Outside Bottom and 
Pitch.
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Locking any of the Height values defines 
that value as the pivot point for the selected 
ceiling plane. Each of these dimensions is 
measured from the first floor default 
elevation of 0' - 0". 

If you lock the Pitch and change a Height 
value, the ceiling plane moves vertically, 
keeping the same slope. It will not pivot. 

Changing these values does not affect the 2D 
representation of the ceiling plane.

Specify the Height of the ceiling plane.

• Bottom at Ridge - Set the highest point 
on the underside of the ceiling plane.

• Inside Bottom - Set the underside height 
at the lowest point on the ceiling plane. If 
the plane is drawn over a wall, this is 
located at the inside surface of the wall’s 
Main Layer. 

• Outside Bottom - Only available when a 
ceiling plane is drawn over a wall, this is 
the height of the lower edge of the ceiling 
rafters, were they not clipped by the wall 
below. 

Specify the Pitch of the selected ceiling 
plane. For a conversion to degrees, see 

“Roof Pitches in Degrees” on page 395.
• Check Pitch in Degrees to display the 

Pitch value in degrees.

Rafter Depth - Specify the rafter depth 
for the selected ceiling plane. The 

default rafter depth is the same as that for 
roof planes and is set in the Build Framing 
dialog. See “Build Framing Dialog” on page 
443. 

Information about the selected ceiling 
plane’s structure displays here for 

reference. 
• Vertical Rafter Depth - This is defined 

by measuring a plumb line through a raf-
ter. The greater the pitch, the greater the 
vertical rafter depth.

• Top of Plate - This is the top plate height 
of the bearing wall, which also defines the 
ceiling height of the room.

• Overhang From Inside Bottom - Only 
appearing when a ceiling plane is drawn 
over a bearing wall, this is the horizontal 
distance from the Baseline to the inside 
Main Layer surface of the wall. The Base-
line is typically drawn over the outside 
Main Layer surface, so this value is equal 
to the wall’s Main Layer thickness. 

• Clip End - Only available when a ceiling 
plane is drawn over a bearing wall, this is 
the amount a ceiling rafter’s underside 
must be clipped at its lower end to rest on 
the wall top plate. This is equal to the 
ceiling plane’s rise in slope over the dis-
tance of the Overhang from Inside Bot-
tom.

The Outside Bottom value plus the Clip 
end value equals the Top of Plate value.

When Use Room Ceiling Finish is 
checked, the selected ceiling plane’s 

ceiling finish thickness and material are 
defined by the room below and the “Ceiling 
Surface” component will not be available on 
the Materials tab. Uncheck this box to enable 
the Ceiling Thickness option.
• Specify the Ceiling Thickness, which is 

the thickness of the bottom surface of the 
ceiling plane. 
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Polyline Tab
The Polyline tab indicates the the ceiling 
plane’s Perimeter, its Framing Area, and its 
Projected Area. See “Polyline Tab” on page 
374. 

Selected Line Tab
This tab is similar to the Line tab of the Line 
Specification dialog. See “Line Tab” on 
page 780.

Line Style Tab
For information about the settings on this 
tab, see “Line Style Tab” on page 781.

Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the selected ceiling plane in 

floor plan view. For information about these 
settings, see “Fill Style Tab” on page 792.

Materials Tab
The “Ceiling Surface” component is only 
available when Use Room Ceiling Finish is 
unchecked on the General tab. 

For more information about the settings on 
this tab, see “Materials Tab” on page 635.

Label Tab
Ceiling plane labels display when the 
“Roofs, Labels” layer is turned on and use 
the Text Style assigned to that layer. The 
Automatic Label for ceiling planes is blank, 
but you can specify a custom label. See 
“Roof Plane Labels” on page 364.

For information about the settings on this 
tab, see “Label Tab” on page 885.

Gable/Roof Lines
The Gable/Roof Line tool can be 
used to automatically generate a gable 

above the bearing wall of a hip roof plane. It 
is best used in situations where roof 
directives in walls are not possible. For 
example: 
• If a Wall Break would be required in the 

same location as a door or window; 
• Where a wall is not present, such as 

across the front of an alcove; 
• Over a Bay, Box, or Bow Window.

See “Roof Directives in Walls” on page 204. 

In addition, the Gable Over Door/
Window edit button allows you to add 

a small Gable/Roof Line over one or more 
selected doors or windows the next time 
automatic roof planes are built.

Gable/Roof Lines display in floor plan view 
when the “Roofs, Gable Lines” layer is set to 
display and can be selected and edited much 
like regular CAD lines. See “Editing Line 
Based Objects” on page 127. 
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Creating a Gable

To create a gable using a Gable/Roof Line

1. Select Build> Roof> Gable/Roof 

Line , then click and drag to draw a 
line outside of the exterior wall that you 
want to create a gable over.

2. Position the Gable/Roof Line within 10 
feet (2260 mm) of the wall’s Main Layer 
but not touching it. See “The Main 
Layer” on page 209.

•  Make sure that the Gable/Roof Line is 
exactly parallel to the exterior wall. 

3. Resize the Gable/Roof Line so that it is 
the length of the desired gable.

•  The length of the Gable/Roof Line 
determines the gable width at the wall 
Main Layer, not at the overhang. 

•  At the larger roof eave, a gable roof is 
wider than the gable line by twice the 
overhang distance.

4. Select Build> Roof> Build Roof  
and regenerate the roof. See “Build Roof 
Dialog” on page 355. 

To use the Gable Over Door/Window tool

1. Select one or more doors or windows. 
2. Click the Gable Over Door/

Window edit button.

•  Gable Over Door/Window  is not 
available for openings placed in Full 
Gable Walls or for Bay, Box or Bow 

Windows. See “Bay, Box, Bow 
Windows & Roofs” on page 292.

3. The next time automatic roof planes are 
built, gables will be created over each of 
these doors and windows.

•  Each gable will extend 12” (300 mm) 
on either side of its door or window.

•  If two of these openings are within 30” 
(750 mm) of each other on the same 
wall, a single gable will be created. 

Gables produced using Gable Roof Lines
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•  If you move or resize the door or 
window(s), the associated Gable/Roof 
Line will not update until the roof is 
built again. 

4. To remove a Gable Over Door/Window, 
select the door(s) or window(s) and click 

the Delete Gable Over Opening  
edit button, or select the gable line and 

click the Delete  edit button. The 
next time the roof is built, the gable will 
be removed. 

Covering an Alcove

A Gable/Roof Line  can also be used to 
maintain a roof plane baseline where there is 
no wall below. For example, you can use it to 
extend a roof plane across an alcove, rather 
than wrap into it. 

In order for a Gable/Roof Line  to direct 
the roof to extend over an alcove or other 
area where no wall is present, it must be 
aligned with the exterior walls’ Main Layer. 

Covering a Bay

A Gable/Roof Line  drawn across a bay 
causes a gable to be build above the bay 
when roofs are automatically generated. 

Gable/Roof Lines drawn to extend roof planes Result, after automatic roof generation
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In order for the gable to be built, at least one 
end of the Gable/Roof Line must extend past 
the side walls of the bay. 

If the Gable/Roof Line is drawn along the 
outer edge of the bay’s outer wall’s Main 
Layer, the resulting gable will extend only to 
the eave of the larger roof. Draw the Gable/
Roof Line beyond the bay’s outer wall to 
extend out past the larger roof’s eave.  

Skylights
A skylight can be created by selecting 
Build> Roof> Skylight and drawing a 

rectangular polyline within a single roof 
plane. You can also simply click once within 
a roof plane to place a 2’ x 2’ skylight.

The Skylight  tool places a flat panel 
skylight into a roof hole, produces a hole in 
the ceiling platform below, and automatically 
generates the skylight shaft between these 
two holes.

To place a skylight in a vaulted ceiling, 
uncheck Ceiling Over This Room in the 
Room Specification dialog, draw the ceiling 
planes to produce the vault and edit them as 
needed, and then draw the skylight. See 
“Structure Tab” on page 245.

Gable/roof line used to create a gable over a bay

Gable/roof line extends past end of side wall

Gable/roof line drawn beyond outer wall of 
bay results in gable extending to cover bay

Note: If a sloped ceiling plane is present
under the skylight, a hole in this ceiling plane
is automatically produced. This hole is visible,
and may be located directly under the roof
hole. It can be moved and edited separately. 
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Editing Skylights
Skylights can be selected individually or in 
groups. Once selected, skylights can be 
edited using the edit handles, edit toolbar 
buttons, or the Roof Hole/Skylight 
Specification dialog. See “Roof Hole/
Skylight Specification Dialog” on page 386.

Skylights must always be contained by a 
single roof plane. If the roof plane is deleted, 
any skylights or holes it contains are also 
deleted. Aside from this restriction, skylights 
can be edited much like standard closed 
polylines. See “Editing Closed-Polyline 
Based Objects” on page 138. 

If you clear the Skylight check box in the 
Roof Hole/Skylight Specification dialog, 
the curb and glass for the skylight is removed 
but the opening remains. 

Roof Hole/Skylight Specification Dialog
Select a skylight and click the Open 
Object edit button to open the Roof 

Hole/Skylight Specification dialog. See 
“Skylights” on page 385.

General Tab

1
2

3



Dormers and Crickets

 387

Check Skylight to specify this polyline 
as a skylight. If unchecked, the curb 

and glass for the skylight are removed but the 
opening remains. 

Skylight Frame Width and Height - 
Define the width and height of the 

frame or curb of the skylight.

Angle for Inside Hole Rim - Defines 
the shape of the skylight well where it 

passes through the roof plane.
• Square Sides - The framing for the sky-

light is cut square to the pitch of the roof.
• Plumb Sides - The framing for the sky-

light is plumb-cut.
• Plumb/Square - The bottom edge is 

plumb-cut, the top edge square-cut.

Polyline Tab
The Polyline tab indicates the roof hole/
skylight’s Perimeter, its Framing Area, and 
its Projected Area. See “Polyline Tab” on 
page 374.

Selected Line Tab
This tab is similar to the Line tab of the Line 
Specification dialog. See “Line Tab” on 
page 780.

Line Style Tab
For information about the settings on this 
tab, see “Line Style Tab” on page 781.

Fill Style Tab
The settings on the Fill Style tab control the 
appearance of the selected roof hole or 
skylight in floor plan view. For information 
about these settings, see “Fill Style Tab” on 
page 792.

Materials Tab
For information about the Materials tab, see 
“Materials Tab” on page 635.

Label Tab
Roof hole and skylight labels display when 
the “Roofs, Labels” layer is turned on and 
use the Text Style assigned to that layer. The 
Automatic Label for these objects is blank, 
but you can specify a custom label. See 
“Roof Plane Labels” on page 364.

For information about the settings on this 
tab, see “Label Tab” on page 885.

Dormers and Crickets
Dormers can be drawn manually 
or placed automatically using the 

Auto Dormer tools.

Automatic Dormers can  be placed only 
under certain conditions: 
• Automatic Dormers can only be placed 

entirely within a single roof plane. They 

cannot extend past the eaves or ridge of 
this roof plane.

• Automatic Dormer side walls cannot be 
positioned above other walls in the plan.

If you click within a roof plane to place an 
automatic dormer, but click too close to an 
eave or the ridge, a dormer will not be 
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created; however, its outline will. Move this 
outline box to a location that meets the 
dormer’s requirements and it will be created.

Automatic dormers reside by default on their 
own layer, “Auto Dormers”. Their display 
cannot be turned off; however, you can lock 
this layer to prevent unintended editing. See 
“Layer Display Options Dialog” on page 
104.

Auto Floating Dormer
Select Build> Roof> Auto Floating 
Dormer and click the roof plane 

where you would like to place the center of 
the dormer's front wall. 

The bottom edges of all floating dormer 
walls are cut off by the underlying roof 
plane. To produce such a dormer manually, 
check Roof Cuts Wall at Bottom for the 
dormer walls on the Roof tab of the Wall 
Specification dialog.

Usually, no room is defined by the walls of 
this type of dormer. 

The images below show both the outside and 
inside of a typical floating dormer.

A floating dormer can be placed in floor plan 
view on the same floor that its underlying 
roof plane displays on, or it can be placed on 
the floor above. Normally, it does not matter 
what floor the dormer is on, but in some 
cases, it may need to be on the floor above so 
that the dormer walls do not interfere with 
walls or railings in the room below. 

Regardless of which floor it is placed on, a 
dormer must always fit within a single roof 
plane. When placing a dormer on the floor 
above,you may find it helpful to turn on the 

Reference Display . See “Reference 
Display” on page 327. 

You may also find it helpful to display the 
underlying roof plane on the floor above 
using the Roof Plane Specification dialog. 
See “Roof Plane Specification Dialog” on 
page 371.

If the dormer is placed on the same floor as 
the underlying roof plane and the room 
below, and the room has a flat ceiling, then 
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defining a room, which is automatically 
Open Below, causes a hole to be produced in 
the ceiling under the dormer.

Auto Dormer
Select Build> Roof> Auto Dormer 
and click on a roof plane where you 

want the center of the dormer's front wall to 
be. 

The walls of an auto dormer go to the floor 
and meet a knee wall on either side on the 
back of the dormer. This knee wall must run 
parallel to the underlying roof plane’s 
Baseline.
• If you are creating a (non-floating) auto 

dormer, a knee wall must already exist. 
The dormer side walls run back to the 
knee wall and the knee wall is broken 
where the dormer walls meet it. 

• The knee wall does not have to be desig-
nated as such in the Wall Specification 
dialog unless you are generating an auto-
matic roof. See “Knee Walls” on page 
206.

• A non-floating dormer must always be 
created on the same floor as the knee 
walls. 

The initial width, height, roof style and other 
settings of Auto Dormers are set in the 
Dormer Defaults dialog. See “Dormer 
Defaults” on page 351.

Manually Drawn Dormers
Once you are familiar with Home Designer 
Pro’s roof tools, drawing dormers manually 
can be quite simple. There are several 
different ways to draw dormers; some 
methods work better in certain applications. 

A variety of resources with information 
about drawing dormers manually is available 
at www.HomeDesignerSoftware.com . 

See, too, “Manually Drawn Dormers” on 
page 87 of the User’s Guide.

http://www.homedesignersoftware.com/
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There are a few things to keep in mind.
• Walls extend upward until they meet an 

overlying roof plane. 
• A wall can also be cut by underlying roof 

planes if Roof Cuts Wall at Bottom is 
checked in the Wall Specification dialog. 
For this to work properly, the edge of the 
roof plane must extend completely 
through the width of the wall. See “Clere-
story and Dormer Walls” on page 205.

• Polylines can be converted into a Hole in 
Roof/Ceiling that allows walls to extend 
above or below the roof line. See “Con-
vert Polyline” on page 165.

Manually Drawn Crickets
The automatic roof generator will not 
produce crickets in a roof plan; however, you 
can manually draw a cricket using the Roof 

Plane  tool. See “Crickets and Dormer 
Vents” on page 95 of the User’s Guide. 

Editing Auto Dormers
Auto Dormers are a collection of objects that 
behave as one. When a dormer is selected, it 
can be edited using its edit handles, edit 
tools, and specification dialog. See “Dormer 
Specification Dialog” on page 391.

If you click the Explode Dormer  edit 
button, the dormer’s individual components 
can be edited.

Using the Mouse
When selected, an auto dormer displays three 
edit handles. The Move handle displays over 
the front wall and allows you to relocate the 
dormer. Two resize handles display on the 
side walls and allow you to change the width 
of the dormer.

There are some things to keep in mind when 
editing auto dormers and auto floating 
dormers using the mouse.
• Dormers move at 90° angles unless the 

Ctrl key is pressed before moving them.
• The dormer must be contained within one 

underlying roof plane.
• Auto dormers cannot be moved beyond 

the required knee wall.

Editing the Window
Dormer windows can be selected, edited, 
deleted and replaced just like other windows. 
See “Editing Windows” on page 289. You 
can place several windows in the front wall.

Unless the dormer's window has been edited 
or changed in the Window Specification 
dialog, when the dormer width is changed, its 
width changes automatically to fill the front 
dormer wall. If the window has been edited, 
its width stays fixed. If a change to the 
dormer makes its front wall too short to hold 
the window, the window reverts to auto 
width.

Move Resize
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Exploding Dormers
Click the Explode Auto Dormer edit 
button to explode the auto dormer into 

its component parts. The dormer walls, roof 
planes, window, and hole in the roof/ceiling 
can be edited individually. 

The program treats roof planes over an 
exploded anto dormer as though they were 
manually drawn, allowing you to protect 
them from being rebuilt in the Build Roof 
dialog. See “Roof Tab” on page 356.

Dormer Specification Dialog
Select a dormer or dormers and click 
the Open Object edit button to open 

the Dormer Specification dialog.

The settings in the Dormer Defaults dialog 
are much like those in the Dormer 
Specification dialog, but apply to all 
dormers as they are created rather than to a 
selected dormer.

General Tab
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Specify characteristics of the selected 
dormer’s Dormer Roof. 

• Choose a Roof Type from the drop-down 
list.  You can choose from Hip, Gable, 
Shed, Gambrel, Mansard, Barrel, Curved 
Eave, Hip Curved Eave or Eyebrow. 

• Specify the Pitch of the dormer roof 
planes. Initially, the default dormer pitch 
matches the roof pitch for all dormer roof 
types except Shed, which has a default 3 
in 12 pitch. For Gambrel and Mansard 
types, this applies to the lowest, or eave, 
roof planes. 

• Check Pitch in Degrees to display the 
pitch in degrees rather than in rise and 
run.

The Second Pitch specifies the upper 
roof of a Gambrel, Mansard, curved 

eave, and hip curved eave. Specify the In 
from Eave distance measured from the 
lower roof plane eave to where the upper 
roof plane starts.

Plumb or Square cut eaves can be 
specified for dormer roof planes, as 

well as Gutters and Boxed Eaves.

Eave and Gable Overhang, Fascia 
Depth for gable fascia, Eave Fascia 

Depth and Rafter Depth can also be set.

Only available in the Dormer Defaults 
dialog, if Set Inside Window Trim 

Width is checked, the inside casing width for 
dormer windows defaults to the Inside 
Window Trim value entered below. Dormer 
windows can appear too narrow on the 
outside due to the space required for the 
inside casing to clear the inside surfaces of 
the side walls. This value sets the width for 
the inside casing of the dormer window.

Specify the Wall Type of the dormer 
walls here. 

Specify the Height of the dormer, as 
measured from where the top of the 

underlying roof plane meets the dormer front 
wall exterior to the top plate of the dormer 
roof’s bearing walls.

This top height is called the dormer ceiling 
height, even if the ceiling in the dormer is not 
flat. The top dormer window casing is 
usually close to this height.
• Check Set to Existing Ceiling to assign 

the ceiling height of the room behind the 
dormer to the dormer.

• Height to Reach Existing shows the dif-
ference between the dormer height where 
the inside of the wall meets the underside 
of the roof and the ceiling of the room 
behind it.

Width is measured between the outside 
surfaces of the dormer side walls.

Form Room Inside Dormer is used 
only for floating dormers and creates a 

flat ceiling in the dormer. If you check this 
option, you should define the dormer on the 
floor above the room it is positioned over. If 
this room has a flat ceiling, checking this 
option makes a hole in the ceiling under the 
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dormer. This option should normally be left 
unchecked.

Roof Returns can be specified only for 
gable dormers. See “Roof Returns” on 

page 393.

Line Style Tab
For information about the settings on this 
tab, see “Line Style Tab” on page 781.

Roof Returns and Other Details
Home Designer Pro offers a selection of 
tools to add architectural details to your roof 
design.

Roof Returns
A roof return is a small decorative roof plane 
that connects to the low side of a gable roof 
overhang and extends below the upper 
triangular portion of the gable wall. Three 
styles of roof returns that can be produced 
automatically.

The first two styles are called Gable and Hip 
returns since the return ends in a gable or hip. 

The third is called a Full return because it 
extends under the entire gable to connect 
both sides and is sometimes referred to as a 
water table. In order for a Full return to be 

created, the roof planes on each side must 
have the same Fascia Top Height.

It is not difficult to manually draw roof 
returns using small roof planes, but it is 
quicker to produce them automatically. 

Roof returns are generated automatically on 
a wall by wall basis using settings found in 
the Wall Specification dialog. See “Roof 
Tab” on page 218.

The structure of automatically generated roof 
returns is the same as that of the subfascia 
and eaves of the roof plane above. See “Roof 
Tab” on page 451.

These roof return settings are also found in 
the Dormer Specification dialog for gable 
roof dormers and function similarly. See 
“General Tab” on page 391.

Fascia
Fascia can be added to both automatic and 
manually drawn roof planes. They can be 

10
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generated when the roof planes are drawn 
when specified in the Build Roof dialog, and 
can also be added to or removed from 
individual roof planes in the Roof Plane 
Specification dialog.
• Fascia and eave fascia can be specified in 

the Build Framing and Build Roof dia-
logs. See “Roof Tab” on page 451.

• Fascia is generated whenever Build Fas-
cia and Roof Trim is checked. See “Roof 
Tab” on page 356.

• The material used for fascia can be speci-
fied. See “Materials Tab” on page 362. 

Fascia display in 3D views and are included 
in the materials list. You can also display 
them in floor plan view, if you wish. See 
“Layer Display Options Dialog” on page 
104.

Fascia

The material specified for fascia in the Build 
Roof dialog displays as part of the roof plane 
rather than as a separate object. 

In addition, fascia boards are generated when 
roof framing is generated and are placed on 

the “Framing, Roof” layer. The fascia 
material is not applied to these framing 
members, however.

The width and depth of fascia and eave fascia 
can be specified in the Build Framing dialog. 
See “Roof Tab” on page 451.

Gutters
Gutters are added to non-sloping eaves on 
both automatic and manually drawn roof 
planes when Gutters is checked in the Build 
Roof dialog. They can also be added to or 
removed from individual roof planes in the 
Roof Plane Specification dialog. See 
“Options Tab” on page 360. 

Automatically generated guttersfollow the 
eaves of the roof but are not created on 
sloped gable eaves. 

Gutters are placed on the “Roofs, Gutters” 
layer. By default, this layer is turned on in 3D 
views but not in plan view, is included in the 
materials list, and is locked. See “Layer 
Display Options Dialog” on page 104.



Roof Pitches in Degrees

 395

Roof Pitches in Degrees
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Chapter 15:

Stairs, Ramps
& Landings

Staircases can be composed of one or more 

straight or curved stair sections, ramps, and 
landings. Stairs and ramps can be drawn, 
selected and edited in 2D and 3D views.

Stair sections can be edited individually or as 
a group. Starter treads can be defined, stair 
sections can be flared, treads can be 
wrapped, and curved sections can be turned 
into winders. 

Landings can be created automatically or 
manually and their shape customized. You 
can edit an existing landing, or create a 
landing from a closed CAD polyline. 
Landing heights can be defined or you can let 
them automatically adjust as needed.

Stairwells can be created automatically or 
manually and can be seen in 3D views. 

Chapter Contents
•      Stair and Ramp Defaults
•      The Stair Tools
•      Anatomy of a Staircase
•      Drawing Stairs and Ramps
•      Displaying Stairs, Ramps, and Landings
•      Editing Stairs and Ramps
•      Merging Stair and Ramp Sections
•      Landings
•      Maintaining Tread Depth
•      Flared Stairs and Curved Treads
•      Starter Treads
•      Winders
•      Wrapped Stairs
•      Other Special Railings & Stairs
•      Creating a Stairwell
•      Rooms Below Staircases
•      Staircase Specification Dialog
•      Ramp Specification Dialog
•      Stair Landing Specification Dialog

Local building and fire authorities must
be consulted for specific stair construc-

tion codes and access requirements.
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Stair and Ramp Defaults
The purpose of interior stairs is to provide 
passage from one floor platform to another, 
so the attributes that influence floor heights - 
including ceiling heights, floor platform 
thicknesses, and floor finish materials - also 
influence the structure of stairs. When 
considering a staircase’s structure, bear in 
mind that riser height is directly dependent 
on the distance from one floor platform to 
another. 

When Automatic Heights are used, stairs 
are built so that they rest on the top of the 

floor structure of the floor where they are 
drawn, and build up to the top of the floor 
structure on the floor above. Risers are 
measured to the floor finish surfaces on both 
floors. See “Floor and Ceiling Platform 
Definitions” on page 322. 

Ramps are built in a similar manner: interior 
ramps bear on the floor structure, and when 
Automatic Heights are used, the top surface 
of both interior and exterior ramps locates 
floor finish surfaces. 

The Stair Tools
Select Build> Stairs to access the 
Stair Tools.

Straight Stairs
To draw a straight staircase select 
Build> Stairs> Straight Stairs, then 

click and drag in floor plan or a 3D view. 
You can also click once to place a staircase 
that extends from the current floor up to the 
next floor. See “Drawing Stairs and Ramps” 
on page 400.

Click Stairs
 Select Build> Stairs> Click Stairs to 
create stairs between levels on the 

same floor with a single click of the mouse. 
Click the low side, within a few feet of where 
the floor changes height. 
• If you click on the low side of a floor 

platform defined by a railing, a doorway 

will be created in the railing, adjacent to 
the stairs. 

• If you click on the low side of a floor 
platform defined by a wall, stairs will be 
created but a doorway will not.

• If you click at a location that is not near 
the edge of a floor platform, a full height 
staircase will be created.

Curved Stairs
Select Build> Stairs> Curve to 
Left or Curve to Right and click 

once in floor plan view to place a curved 
staircase. See “Curved Stairs and Ramps” on 
page 401.

Landing
Select Build> Stairs> Landing to 
draw a landing, which is a platform 

connecting two or more stair sections. See 
“Landings” on page 406.
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There are two ways to create a landing using 
this tool:
• Click once to place a landing measuring 

39” (975 mm) on each side.
• Click and drag from end to end to draw a 

rectangular landing sized as needed. See 
“Polylines” on page 790.  

You can also create a landing by converting a 
CAD polyline. See “Convert Polyline 
Dialog” on page 165.

Ramp
Select Build> Stairs> Ramp to draw 
a sloped ramp. By default, ramps are 

drawn at a 1:12 slope to a maximum height 
of 30” (760 mm). See “Drawing Stairs and 
Ramps” on page 400.

Anatomy of a Staircase
Stairs are often described in terms of rise and 
run. Rise is typically between 6" and 8", and 
the run between 10" and 12". In metric plans,  
rise is 177 to 190 mm, and the run is about 
250 mm.

Staircase Terminology
Balusters - The vertical members that run 
between the handrail and the treads or 
bottom rail. 

Bracket - Decorative L-shaped supports on 
the exposed side of stairs below each tread.

Landing - A platform connecting two or 
more stair sections.

Newels - The end post of a stair railing 
located at landings and the beginnings and 
endings of new stair sections.

Rise - The height of a riser, measured from 
tread surface to tread surface, Also referred 
to as Unit Rise. 

Rise Angle - The angle of the staircase or 
stair section, defined by a line drawn through 
the back surfaces of its treads.

Riser - The vertical stair member located 
between the treads. Risers may be solid or 
open. When open, the front surfaces of the 
stringers are considered the risers. 

Run - The depth of a tread, measured from 
riser surface to riser surface. Run does not 
include the Tread Overhang. Also referred to 
as Unit Run. 

Runner - The carpet that runs down the 
center of the staircase.

Shoe - The bottom railing, placed on the 
landing floor, that anchors the balusters at 
landings. 

Stringer - The inclined support member of a 
staircase that supports the treads and risers.

Tread - The horizontal member of a stair that 
the foot is placed on. 

Tread Overhang - The portion of a tread 
extending past the front surface of the riser 
and over the tread below. Also referred to as 
Nosing or Nosing Extension, it is not 
included in the Run or Tread Depth 
measurements.
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Thread Thickness - The vertical depth of 
the tread material.

Winder - A wedge-shaped stair tread used 
where curved or angled stairways change 
direction.

Stair Structure and the Model
By default, stairs locate the height of the 
floor platform that they are drawn on, and 
seek the next level, which may be the floor 
platform of the floor above or a landing. The 
stringers locate the subfloor of the floor 
platforms and maintain consistent riser 
height. If the stairs are long enough to reach 
the next level at a reasonable rise angle, their 
tread depth and number of treads are 
automatically calculated to create a staircase 
with consistent tread and riser dimensions 
along its entire length. 

You can modify this behavior or turn off it 
off altogether in the Staircase Specification 
dialog and specify your own rise and run 
values. Bear in mind, though, that if you turn 
it off, you will need to specify the correct 
Top and Bottom Heights to make sure that 
the stairs actually meet both floor platforms 
correctly. See “General Tab” on page 422. 

Stair Sections and 
Subsections

In Home Designer Pro, staircases can be 
composed of multiple sections and 
subsections. See “Merging Stair and Ramp 
Sections” on page 404. 
• Stair sections are separated by landings.
• Subsections are considered part of the 

same section because they are connected 
to one another directly rather than sepa-
rated by a landing.  

Drawing Stairs and Ramps
Stairs and ramps can be drawn in floor plan 
and 3D views but not in cross section/
elevation views. In 3D views, these objects 
can only be drawn in the presence of a floor 
platform or terrain perimeter. See “Working 
in 3D” on page 687.

There are a few things to keep in mind when 
drawing stairs.
• Before stairs are created, make sure that 

the heights for both the lower and upper 
floors are correctly defined. 

• Stairs are drawn going UP, so they should 
be drawn from the lower of the two floors 
they connect. 

• By default, stairs adjust their riser and 
tread dimensions to connect two floor 
heights if possible. The rise and run are 
calculated so that the steps are consistent 
in size. 

• If you have the Reference Display  
turned on, stairs snap to the reference dis-
play. See “Reference Display” on page 
327.

• If a stairwell room has been defined on 
the floor above, the top of the stairs can 
be dragged until it stops at the railing or 
wall defining the stairwell.

• When drawing stairs or a ramp up from 
the terrain, it is a good idea to make sure 
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the terrain is up to date. See “Building the 
Terrain” on page 552.

Straight Stairs and Ramps

Straight Stairs  can be created in three 
different ways:
• Click and drag in a straight line to draw 

stairs that are the length that you drag.
• Click once to place stairs that go from the 

current floor up to the height of the next 
floor level.

• Click once using the Click Stairs  
tool to create stairs between rooms on the 
same floor with different floor heights or 
between exterior rooms and the terrain.

Similarly, Ramps  can be created by 
either clicking and dragging or by clicking. 
A ramp created with a single click will be 
30” (760 mm) high, have a slope of 1:12, and 
be 360” (9120 mm) long. 

An individual stair or ramp section must be 
between 6” (150 mm) and 100’ (30,000 mm) 
in length. If a greater length is needed, 
connect two sections using a landing.

Curved Stairs and Ramps
Curved Stairs can be created in 
floor plan view by selecting 

Build> Stairs> Curve to Left or Curve to 
Right. Click to place a 90º curved stair 
section that can then be edited. You can 
continue clicking to place additional curved 
staircases until another tool is selected.

In addition, you can change a straight stair 
section into curved stairs, or vice versa: 

• Select the stairs and click the Change 

Line/Arc  edit button. See “Change 
Line/Arc” on page 159.

• Select the stairs, hold down the Alt key 
(or right-click), and drag an end edit han-
dle. See “Alternate” on page 121.

Curved Ramps  can only be created by 
first creating a straight ramp and then 

clicking the Change Line/Arc  edit 
button.  

Drawing Stairs and Ramps 
Downward

Stairs and ramps can be drawn from the 
current floor level downward; however, 
drawing stairs or ramps between floors in 
this manner is not recommended. Drawing 
downward should only be used to create a 
staircase or ramp between a porch or deck 
and the terrain when you require the 
direction arrow to say “DN” instead of “UP”. 

Alt+ 
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To draw stairs going downward

1. Select Build> Stairs> Straight 

Stairs .
2. Hold down the Alt key or the right 

mouse button.
3. Click and drag to create straight stairs.

When drawing stairs or ramps from a floor 
platform to the terrain, or vice versa, they 
will locate the height of the terrain as long as 
it is lower than the floor height. You can also 
create a landing or “room” outside the 
structure and use it to establish the bottom 
height of the stairs or ramp. Then, draw in an 
upward direction from the lower platform to 
the upper platform. 

Displaying Stairs, Ramps, and Landings
The display of stairs, ramps, and 
landings in all views is controlled in 

the Layer Display Options dialog. Stairs, 
ramps, and landings are placed on the Stairs 
& Ramps” layer. See “Displaying Objects” 
on page 102.

In Floor Plan View
In floor plan view, stairs, ramps and landings 
display on the floor they were drawn on and 
are only visible from the floor above if there 
is a stairwell. 

Stairs and ramps have an arrow indicating 
the direction they run. Interior stairs and 
ramps have an UP arrow on the floor they 
were created on and a DN arrow when 
viewed from the floor above. See “Drawing 
Stairs and Ramps” on page 400. 

The style and size of a direction arrow can be 
specified in the Staircase or Ramp 
Specification dialog. The color and display 
are controlled by the “Stairs & Ramps, Up/
Down Arrows” layer. See “Arrow Tab” on 
page 783. 

When a staircase is selected in floor plan 
view, the numbers associated with each of its 
sections and subsections display. Stair 

sections are assigned a single-digit number. 
Subsection numbers have two parts: a section 
number and subsection number, separated by 
a hyphen.

To see the center of a stair section curve in 
floor plan view, click Show Arc Centers 

and Ends . See “Show Arc Centers” on 
page 134. 

In 3D Views
Although stairs span between two floors, 
they can only belong to one floor. As a result, 
only multi-floor views show the upper floor 
with the platform opening and the lower 
floor with the staircase simultaneously. In 
Floor Cameras and Doll House Views, 
stairwells may appear as an empty spaces. 
See “3D View Tools” on page 672.

Stair section 
number

Stair subsection 
numbers
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Editing Stairs and Ramps
Staircases and ramps can be selected and 
edited in floor plan view and 3D views. See 
“Selecting Objects” on page 124. 

Using the Mouse
When a staircase or ramp is selected, its edit 
handles display. These edit handles can be 
used to customize the object in many ways. 
See “Editing Objects” on page 119.
• Straight stair sections and ramps are 

edited like lines. They have additional 
edit handles for resizing the width of the 
section. See “Editing Line Based 
Objects” on page 127.

• Curved stair sections and ramps are 
edited like arcs and also include edit han-
dles for resizing the stair’s width. See 
“Editing Arc Based Objects” on page 
130.

• Ramps can be resized to a maximum top 
height of  30” (760 mm). If you extend a 
ramp’s length to greater than 360” (9120 
mm), it’s slope will decrease. For a taller 
ramp and control over the slope, uncheck 
Automatic Heights in the Ramp 
Specification dialog and specify the 
values you need. See “General Tab” on 
page 431.

• When stair sections are merged, the edit 
handles display differently depending on 
what subsection is currently selected. See 
“Merging Stair and Ramp Sections” on 
page 404.

• When moving merged stair or ramp sec-
tions, all merged sections move as one.

• Additional edit handles display on the 
first two treads of a staircase if the 

Starter Tread  edit button is clicked. 
See “Starter Treads” on page 413. 

• Several additional edit handles display on 

a staircase if the Flare/Curve Stairs  
edit button has been clicked. See “Flared 
Stairs and Curved Treads” on page 410. 

In the Specification Dialog
Stairs and ramps can be customized 
and their structure precisely defined in 

the Staircase and Ramp Specification 
dialogs. See “Staircase Specification Dialog” 
on page 422 and “Ramp Specification 
Dialog” on page 430.

Using the Edit Tools
A selected staircase or ramp can be edited in 
a variety of ways using the buttons on the 
edit toolbar. See “The Edit Toolbar” on page 
29.

Adjusting the Radius 
of Curved Stairs

The easiest way to match the radius of a stair  
section to the radius of a curved wall is to 
draw a staircase near one side of the curved 

wall using the Straight Stairs  tool. The 
stairs snap to the wall, and the radius of the 
new staircase is defined. See “Curved Stairs 
and Ramps” on page 401. 

Existing curved stairs can be aligned with an 
existing curved wall by aligning their 
centers, much the same way that curved 
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stairs on different floors can be aligned. See 
“Aligning Objects” on page 154.

If there is no curved wall, the radius of a stair 
section can be aligned to a CAD arc or circle.

To align curved stairs to an object 

1. Align the centers of the CAD object and 
the staircase. 

2. Select the curved stairs and move the 
side nearest to the arc or circle edge 
using the Resize edit handle. 

Finally, restore the stair width by dragging 
from the other side handle or using the Stair 
Specification dialog.

Merging Stair and Ramp Sections
Any combination of straight and curved stair 
sections or straight and curved ramps using 
Automatic Heights can be merged. The 
resulting staircase or ramp section is made up 
of subsections and, if there are no landings, 
functions as a single unit. 

Stair and ramp subsections must be drawn in 
the same direction if they are to be merged: 
• The top edge of a stair section or ramp 

cannot merge with the bottom edge of 
another section or ramp.

• Combinations of stairs drawn in the UP 
and DOWN directions cannot be merged. 

Stair subsections merge at the center points 
of their upper and lower edges. 

Stair sections and ramps cannot be merged 
directly. If a combination of stairs and a ramp 
is required, connect them with a landing. See 
“Landings” on page 406.

To merge stair or ramp sections 

1. Confirm that the stairs or ramps that you 
wish to merge are using Automatic 
Heights. See “General Tab” on page 
422.

2. Position the sections so they are in the 
desired relationship to each other. 

•  In order to merge stair sections cor-
rectly, they must be parallel to one 
another.  

•  To create merged subsections that 
change direction, make one of the 
merged sections curved and then spec-
ify Winders. See “Winders” on page 
414.

3. Select either stair or ramp section so that 
its edit handles display.

4. Click the Extend handle on the end to be 
merged and drag it to the point where the 
two stairs or ramps are to meet. 
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A staircase consisting of merged subsections 
resembles a single stair section in floor plan 
view. The UP (or DN) arrows join, becoming 
a single direction arrow. 

When a subsection is selected, the entire 
staircase is selected. Additional edit handles, 
indicating the presence of multiple 
subsections and allowing you to reposition 
the line along which they join.  See “Using 
the Mouse” on page 403.

Lock Tread Depth
If a staircase with Lock Tread Depth 
selected in the Staircase Specification 
dialog is resized, its length increases or 
decreases one full tread at a time. See 
“General Tab” on page 422. 

When Lock Tread Depth is checked, it can 
be difficult to merge the section with another 
section or landing. If this is a problem, you 
can temporarily uncheck Lock Tread Depth. 
After the stairs are merged, the tread depth 
can be locked again. 

Curved Subsections
Stair subsections attached at both ends by 
other sections do not have a free end that can 
be dragged into a curve. In this situation, 
change the middle sub-section to a curve 

using the Change Line/Arc  edit button. 
See “Change Line/Arc” on page 159.

To curve an enclosed stair subsection

1. Draw three straight stair sections and 
connect them end to end.

2. Select the middle subsection.

3. Click the Change Line/Arc  edit 
button. The center section turns into a 
curved stair section.

Merging parallel stair sections

Select the middle stair subsection
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4. Use the triangular Change Curve edit 
handle to adjust the curvature of the 
middle section as needed.

Stairs joined in this manner can easily be 
turned into winders. See “Winders” on page 
414.

Landings
Stair landings are platforms between stair 
sections and/or ramps, and can be created in 
either of three ways:

• Using the Landing  tool. 
• By clicking between two stair sections 

using the Straight Stairs  tool.
• By converting a closed CAD polyline 

into a landing. See “Convert Polyline” on 
page 165.

To create a landing between stair sections:

1. Draw two stair sections going UP. They 
can be at any angle.

2. Click between the two sections using the 

Straight Stairs  tool to create a land-
ing. Notice that only one direction arrow 
displays after the sections are joined by 
a landing.

Similarly, a landing can be created between 
two ramps by clicking between them with the 

Ramp  tool active. 

Multiple stair sections and/or ramps can be 
connected to one landing. For example, two 
or three stair sections might meet at a landing 
with a single stair section continuing to the 
next level.

To be linked by a landing, all sections must 
be drawn in the same UP direction and the 
top of one section should be near the bottom 
of the next.

After using Change Line/Arc

Creating a stair landing
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Stair sections connected with a landing will 
move together as a single unit unless Stair 
Sections Move Independently is checked in 
the Preferences dialog. See “Architectural 
Panel” on page 73.

A landing formed between two stair sections 
having less than a 90º angle between them 
are created with a short edge not less than 6” 
(150 mm). This is because most building 
codes require the shortest tread to be at least 
6” wide. This edge can be manually edited to 
less than 6” if needed.

Editing Landings
Landings can be selected in 2D and 3D 
views, both individually and in groups, and 
edited using the edit handles, the edit toolbar, 
and the Landing Specification dialog. See 
“Stair Landing Specification Dialog” on 
page 433. 

Landings derive their initial materials and 
railing characteristics from the stairs and/or 
ramps attached to them. You can assign a 
unique material to a landing in its 
specification dialog or using the Material 

Painter ; however, the railing style is 
always defined by the attached stairs or 
ramps. 

Custom Shaped Landings
Landings can be edited like other closed 
polyline-based objects. You can add or 
remove edges, convert an edge from straight 
to curved, or vice versa. A curved landing 
creates curved railings. See “Editing Closed-
Polyline Based Objects” on page 138.

You can also create a stair landing out of 
closed polyline created with the CAD tools 

using the Convert Polyline  edit button. 
See “Convert Polyline” on page 165.

You can edit the shape of a landing into a 
wide variety of shapes. So that the railings of 
stair sections connect properly to the landing 
railings, make sure that each stair section end 
is snapped to a landing edge with the same 
length as the stair’s width. If necessary, use 

the Break Line  tool to create a break in a 
landing edge if it is longer than the 
connecting stairs are wide. See “Break Line” 
on page 158.

Landing Height
A landing’s height can be either user-defined 
or controlled by the program.

A landing with a height that has not been 
specified by the user is considered unlocked, 
and its height will adjust automatically as the 
stairs attached to it are modified so that the 
stairs maintain a consistent rise angle.

If you specify a landing’s height, that landing 
becomes locked and will maintain that height 
no matter how the stairs connected to it are 
adjusted.

Unlocked Landings
By default, new landings are unlocked, 
which means that their height is determined 
by the stair or ramp sections attached to it. 
An unlocked landing will automatically 
adjust its height as necessary to maintain the 
same riser height and rise angle for all 
attached sections. 

In this example, two stair sections with eight 
treads each are connected by a landing. 
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Because the sections have the same number 
of treads, the landing height is one half of the 
distance between the two connected floors.

If a change is made to either stair section, the 
program will maintain the stairs’ connection 
to the floors above and below, and will 
instead modify the height of the landing and 
the other stair section so that a consistent 
riser height is maintained.

As long as a stair or ramp system consists of 
a landing connecting only two stair sections, 
the program can easily set landing heights 
and produce consistent a rise angle. If more 
than two stair sections meet at a landing, the 
relationship between them becomes more 
complex. In this situation, you may want to 

define the exact height of the landing instead 
of letting the program define it for you.

Locked Landings
A locked landing has a specifically defined 
height that does not adjust automatically 
when there are changes in the attached stairs. 
Instead, the stairs adjust to the landing. 

For example, start with the same staircase 
used to illustrate unlocked landings, with one  
change: the landing height is now defined at 
78 inches (1980 mm). 

Since the landing height is now closer to the 
upper floor than to the lower floor, the upper 
stair section has a very shallow riser height 
and the lower section has a tall riser height.

Stair and ramp sections attached to a locked 
landing no longer relate to one another: 
• Changes to one section do not affect the 

other. 
• The Staircase and Ramp Specification 

dialogs show only the selected section 

Unlocked landings maintain 
   consistent riser height

 Locked landings produce 
independent stair sections
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and those connected to it by unlocked 
landings, rather than the entire system.

• Locked landings do not move when 
attached stair or ramp sections are 
moved. Only unlocked landings and the 
sections attached to them will move.

Locked landing can be used to break up a 
complex network of stairs and landings into 
smaller pieces with known bottom and top 
heights. 

To lock a landing

1. Select the landing and click the Open 

Object  edit button to open the Stair 
Landing Specification dialog. 

2. On the General tab, uncheck Auto 
Adjust Height When Connected to 
Stairs. 

3. Specify the desired Top Height and 
click OK. 

4. The landing moves to the specified 
height and all stairs that connect to that 
landing are redefined.

To unlock a landing, open its specification 
dialog, check Auto Adjust Height When 
Connected to Stairs, and click OK. The Top 
Height will automatically adjust to any stair 
or ramp sections attached to it and will try to 
produce a staircase with a single riser height. 

To move stair sections independently 
regardless of whether attached landings are 
locked or unlocked, select Stair Sections 
Move Independently  in the Preferences 
dialog. See “Architectural Panel” on page 73.

Maintaining Tread Depth
Most building codes require staircases to 
maintain a consistent tread depth. 

Walk Line
By default, Home Designer Pro measures a 
stair section’s length and tread depth along a 
Walk Line located 12" (30 cm) from the right 
edge of the stair section by default. On 
curved stairs, it is located 12” (30 cm) from 
the inside edge of the curve. 

The distance of the Walk Line from the 
staircase edge can be specified in the 
Staircase Specification dialog. See “Style 
Tab” on page 425.

Alternatively, you can turn the Walk Line 
feature off and tread depth will be measured 
at the tread center. 

When a curved stair section has Automatic 
Treads specified in the Staircase 
Specification dialog and the Walk Line is 
used, the number and/or width of treads in a 
section or subsection changes when the inner 

Walk Line at 12" Center Line



410

Home Designer Pro 2014 Reference Manual

edge is moved. For this reason, it is best to 
finalize stair section width as early as 
possible.

There are two ways to keep tread depth even 
throughout a stair section made of multiple 
subsections.

Lock Tread Depth
The first way to maintain tread depth is to 
Lock Tread Depth to a specified value in 
the Staircase Specification dialog. See 
“General Tab” on page 422. 

Once locked, any changes to the length of the 
stair section are achieved by keeping the 
specified tread depth and changing the 
number of treads. 

Ignore Subsection 
Boundaries

Curved stair sections typically have treads 
that are wider on one side than on the other. 
When they are connected to other stair 
sections, as with winders, it is possible to 
have treads that are too narrow at the Walk 
Line. See “Winders” on page 414. 

Uniform tread depth in a stair section with 
subsections can be maintained by checking 
Ignore Subsection Boundaries in the 
Staircase Specification dialog. See 
“General Tab” on page 422. 

When Ignore Subsection Boundaries is 
checked, the Tread Depth value may change 
when the stair section is edited, but will 
remain consistent throughout all subsections.  

Because the boundaries between stair 
sections are being ignored, the treads where a 
straight section joins a curved section may 
shift position or change angle to accomodate 
the adjustment.

Flared Stairs and Curved Treads
Any stair section can be flared and/or 
its treads curved using the Flare/

Curve Stairs edit button. 

Only exposed sides of a stair section can be 
flared. If one side of a stair section is against 
a wall or wrapped (see “Wrapped Stairs” on 
page 415), only the exposed end can be 
flared. 

Creating a Flared Stair
Flared stairs grow wider near one end, 
typically sweeping outward at the bottom. 
Stairs can also be flared at the top or on both 
ends.

Flaring, curved treads, and special
treads should be the last changes that

you make to any stairs.
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To create flared stairs

1. Create the stairs and connect them to a 
landing, floor platform edge, or another 
stair section. 

2. Specify the section width, tread depth, 
and any other needed information.

3. Select the stairs and click the Flare/

Curve Stairs  edit button. New Flare 
edit handles display on all four corners 
of the stairs.

4. Drag one of the corner handles to flare 
that corner. As you drag the flare, the 
Status Bar shows the distance the side 
handle moves. This allows you to move 
the opposite handle the same amount.

5. When you are finished editing the flare, 

click the Main Edit Mode  to restore 
the stairs’ regular edit handles and tool-
bar buttons. 

Symmetrically Flared Stairs
Use the dimension information that displays 
in the Status Bar as a reference to create 
symmetric flares on both sides.

Adjusting the Flare Radius
After a flared staircase has been created, you 
may want to soften the radius of the flare.

The four handles at the sides and the four 
handles at the corners flare the stair section 
when dragged outward. The two handles in 
the center of the section move the starting 
point for flaring along the stair section.

Creating flared stairs

Flare 
dimensions 
display in the 
Status Bar

Flare 
dimensions 
display in the 
Status Bar

Creating symmetrically flared stairs
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To adjust the flare radius

First, adjust the curvature of the flared 
section.

1. Select the flared stair and click the 

Flare/Curve Stairs  edit button to 
access the flare handles again. 

2. Select the handle along the flared edge 
of the stair. Drag this handle outward 
very slightly. This forms a more gradual 
flare. 

Then, adjust the starting point of the flare:

1. Select the flared stair and click the 

Flare/Curve Stairs  edit button to 
access the flare handles again. 

2. This time, drag the lower of the two cen-
tral handles upward. The handle above it 
moves with it. This moves the start point 
for the bottom flare from the middle of 
the section toward its top, making the 
flare even more gradual.

Treads Perpendicular to Flare
Flared stairs often look best when the treads 
curve to meet the flared side perpendicular to 
the radius.

To curve the edges of flared treads

1. Select the flared stair and click the 

Flare/Curve Stairs  edit button to 
access the flare handles again. 

2. Drag a corner edit handle upward one 
tread depth or less.

3. When you are finished editing the curve, 

click the Main Edit Mode  to restore 
the stairs’ regular edit handles and tool-
bar buttons. 

This type of tread curving works only on 
flared edges and concentrates the curvature 
at that edge.

Adjusting the flare curvature

Adjusting the flare’s starting point

Curving the edges of flared treads



Starter Treads

 413

Flared treads can also be curved using the 
Curve edit handle, which curves the treads 
more uniformly.

Curving the Treads
When treads are curved, all treads in the 
section show some degree of curvature. 
Treads close to the curved end have a greater 
curve than those at the opposite end, but both 
ends can be curved. 

To curve stair treads

1. Select the staircase, then click the Flare/

Curve Stairs  edit button. 
2. Drag the edit handle at the center of the 

bottom edge a small distance to curve 
the treads.

3. When you are finished editing the curve, 

click the Main Edit Mode  to restore 
the stairs’ regular edit handles and tool-
bar buttons. 

Starter Treads
The first and second treads of a 
staircase can be turned into starter 

treads by clicking the Starter Tread edit 
button. Starter treads extend to the side of the 
staircase, have rounded edges and are 
common on traditional staircases. 

A starter tread can be added only to open 
sides of a stair section. If one side of a stair 
section is against a wall or wrapped (see 
“Wrapped Stairs” on page 415), only the 
exposed tread end can become a starter tread. 

Creating curved stair treads
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To create starter treads

1. Click on a staircase to select it.

2. Click the Starter Tread  edit button. 
An edit handle displays on each end of 
both the first and second treads.

3. Drag either of the handles on the first 
tread outward from the stair section. If 
the stair section is against a wall, only 
one handle displays on the side opposite 
the wall.

4. As you drag, the ends of the tread 
become rounded.

5. Two additional edit handles display on 
each side of the tread, along the back 
edge. 

6. Drag either of the two square handles 
upward to increase the width of the 
rounded ends of the tread. 

7. Drag the edit handle on the second tread 
outward from the stair section to create a 
second starter tread. 

8. To make changes to existing starter 
treads, select the stairs, click the Starter 

Tread  edit button and repeat the 
above steps as needed. 

9. When you are finished editing the starter 

treads, click the Main Edit Mode  to 
restore the stairs’ regular edit handles 
and toolbar buttons. 

Winders
Winders are steps located where a staircase 
turns and are narrower on the inside of the 

turn than they are on the outside. A staircase 
defined as a winder expands to fill in any 
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gaps between the side of the stairs and 
nearby walls. 

Curved stair sections are typically used to 
create winders, although straight stairs can 
also be used. See “Curved Stairs and Ramps” 
on page 401.

To create winders

1. In an enclosed room area, place and con-
nect the stair sections that you want to 
be winders. For best results:

•  The stairs should be two straight sec-
tions connected by a curved section 
between them;

•  The curved section should be adjacent 
to a 90° corner, as illustrated.

2. Select any subsection of the stairs and 

click the Open Object  edit button to 
open the Staircase Specification dia-
log. 

3. On the General tab, place a check in the 
box beside Winder and click OK. 

4. The steps nearest the wall corner adjust 
their shapes and extend into the corner 
after the stair is changed to a winder. 

 

The Winders attribute directs the stair section 
to expand or contract to meet  nearby walls, 
and can also be used to create a partial 
railing. See “Partial Railings” on page 416.

Winders sometimes have treads that are too 
narrow at the inside curve. The Ignore 
Subsection Boundaries option can address 
this issue. See “Ignore Subsection 
Boundaries” on page 410.

Wrapped Stairs
Check Allow Wrap on the Style tab of the 
Staircase Specification dialog and the 
selected stairs can be wrapped around the 
corner of a deck or landing. Curved stairs 
and stairs with multiple subsections cannot 
be wrapped. See “Style Tab” on page 425.

Stair sections that wrap around a corner to 
meet one another must have identical 

attributes. As a result, edits made to one 
wrapped stair section apply to all adjacent, 
wrapped sections. 

To wrap stairs around a deck

1. Draw a deck if you have not already 
done so. See “Decks” on page 238. 

Winders must be in a room with valid
room definition. You cannot create

winders in an area composed of only 2 corner
walls. If this configuration is needed, enclose
the area in with Invisible walls so that a room
area is defined.

Winders extend to nearby walls
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2. Use the Click Stairs  tool to draw a 
stair section on each side of the corner 
around which you want them to wrap.

3. Draw a second set of stairs on the other 
edge of the deck the same way.

4. If necessary, move the stair sections 
toward the corner of the deck. The two 
sections merge to form wrapped steps.

To wrap stairs around a landing

1. Draw two perpendicular Straight 

Stair  sections.
2. Click between them to create a landing.
3. Rotate one stair section 180°. 

4. The stairs wrap around the corner. 
Notice that the Up arrow displays on the 
most recently edited stair section.

Other Special Railings & Stairs
Stairs can be customized to meet a variety of 
needs.

Partial Railings
A staircase can be enclosed on one side by a 
combination of wall and railing.

You can also draw stairs down from a
deck by right-clicking to draw them or by

pressing the Alt key while you drag. See “To
draw stairs going downward” on page 402.
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Partial railings can be created by specifying 
the stairs as winders and increasing the Max 
Tread Contraction in the Staircase 
Specification dialog. See “Style Tab” on 
page 425.

The Max Tread Contraction defines the 
largest distance that any section of the stair 
system is allowed to move inward when the 
stairs are turned into winders. If any point on 
the edge of the stairs would have to move 
inward more than this defined amount in 
order to locate the surface of the wall, the 
stairs do not contract and snap to that wall.

To create a partial stair railing

1. Create a staircase and draw an Interior 

Wall  against, but not underneath, the 
stairs.

2. Select the stairs and click the Auto 

Stairwell  edit button to create a 
stairwell.

3. On the General tab of the Staircase 
Specification dialog, check Winders.

4. On the Style tab, define the Max Tread 
Contraction (for Winder). If the inte-

rior wall is 4" thick, setting this value to 
4" should be sufficient. 

5. On the Style tab, increase the Stringer 
Bottom value to enclose the area under 
the stairs with railings. The best value 
depends on the design of your stairs.

6. On the Newels/Balusters tab, remove the 
check from either Right or Left Railing 
at Wall, depending on the position of 
the stairs and wall in your plan.

7. Click the Object Snaps  toggle but-
ton to temporarily turn off Object Snaps. 
See “Object Snaps” on page 110.

8. Select the stairs and use the side edit 
handle to move the edge of the stairs to 
approximately the middle of the wall.

9. You may need to Zoom  in on the 
stairs and wall to move the stair edge.

Solid Railings
To create a solid rail along a staircase, create 
the Railing against, but not underneath, the 
stairs and specify it as Solid. See “Rail Style 
Tab” on page 224.

Resizing stairs to the middle of the wall
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The solid railing recognizes the adjacent 
stairs and climbs alongside them. 

If any balusters show beyond the railing, 
eliminate them by unchecking Left railing 
or Right railing in the Staircase 
Specification dialog. See “Style Tab” on 
page 425.

Railing Panels
You can use railing panels, including glass 
panels or cable, as stair railing instead of 
newels and balusters by drawing a 

Railing  under the stairs or ramp. 

To use railing panels with stairs

1. Create a staircase and draw a 

Railing  under the stairs. 
•  Make sure that the railing is located 

entirely within a single stair section.

•  Position it so that it is aligned with the 
left edge.

2. Select the railing and click the Open 

Object  edit button. See “Wall Speci-
fication Dialog” on page 214.

3. On the Rail Style tab of the Railing 
Specification dialog, 

•  Select the Panels radio button.
•  Check Follow Stairs.

4. On the Newels/Balusters tab, click the 
Browse button to the right of Panel 
Type and select the railing panel you 
want to use on the stairs, then click OK.

5. Select the staircase and click the Open 

Object  edit button. 
6. On the Newels/Balusters tab of the 

Railing Specification dialog, uncheck 
Left Railing to prevent the default stair 
railing from generating in addition to the 
railing panel.

7. Repeat these steps if you want railing 
panels under the right side of the stairs, 
as well.

Concrete Stairs

To make a solid concrete staircase

1. On the Style tab of the Staircase 
Specification dialog: 

•  Set the Tread Overhang to zero. 

Solid Railing
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•  Set the Tread Thickness to zero.
•  Uncheck Open Risers.
•  If you want, you can also uncheck 

Open Underneath and check Large 
Stringer Base.

2. On the Materials tab, specify the “Riser/
Trim”, “Support Wall”, and “Tread” 
materials as concrete.

Masonry Stairs

To make a set of masonry stairs

1. On the Style tab of the Staircase 
Specification dialog: 

•  Set the Tread Overhang to zero. 
•  Set the Tread Thickness to the thick-

ness of the masonry material.

2. On the Materials tab, assign the desired 
masonry material to the “Tread” compo-
nent and specify the “Riser/Trim” mate-
rial as concrete.

Steel Stringer

To make a steel stringer with concrete 
treads

1. On the Style tab of the Staircase 
Specification dialog, 

•  Check Open Underneath. 
•  Select the Single Stringer check box. 
•  Set the Tread Thickness to 2 inches or 

more.
•  Select the Single Stringer check box. 

2. On the Materials tab, specify the 
“Tread” material as concrete and the 
“Riser/Trim” material as steel. 

Creating a Stairwell
An interior staircase must be located in a 
stairwell, an opening to the floor above. A 
stairwell is an Open Below room type on the 
floor above. See “Room Types” on page 234.

If you create a stairwell away from other 
walls so the Open Below is created in the 
center of another room, connect a wall of the 
Open Below room to another wall using an 
invisible wall. 

Creating a Stairwell 
Automatically

To create a stairwell that matches the 
perimeter of a selected staircase, click 

the Auto Stairwell edit button. This button is 
only available when a living space exists 
above the staircase. It will not be available if 
the space above is Open Below or on the 
Attic Floor.



420

Home Designer Pro 2014 Reference Manual

Auto Stairwell  automatically creates a 
room on the floor above enclosed by railings, 
defined as Open Below in the Room 
Specification dialog, and given a Stairwell 
room label. This room can be selected and 
edited like any other room.

Creating a Stairwell Manually
Stairwells can also be created manually. 

To create a manual stairwell

1. Draw a two-story building. Create the 
staircase on the first floor.

2. Make the second floor the Current 
Floor and the first floor the Reference 
Floor. See “The Reference Floor” on 
page 327.

3. Select Tools> Reference Floors> 

Reference Display  to show the Ref-
erence Floor, including the stairs. 

4. On the upper floor, use the Railing  
tool to create a room around the stairs. 
Use the edit handles to position the rail-
ings as needed. 

5. Select the railings one at a time and 
move them into position. 

•  When a railing is selected, its bounding 
box shows the location of the outer sur-

face of the railing’s drywall layer. For 
best results, this outer surface (which 
does not display when the railing is not 
selected) should meet the top edge of 
the stairs. See “Wall Types and Rail-
ings” on page 186.

•  If you prefer, you can also go Down 

One Floor  and adjust the top edge 
of the staircase to snap it to the surface 
of the railing on the floor above.

6. When the railings are positioned prop-
erly, select Tools> Reference Floors> 

Reference Display  to turn off the 
display of the Reference Floor.

7. Click inside the room using the Select 

Objects  tool to select it, then click 

the Open Object  edit button.
8. On the General tab of the Room 

Specification dialog, select “Open 
Below” from the Room Type list. Click 
OK to close the dialog.

9. Place a Doorway  in the railing at the 
top step for an opening. 

10. Select the doorway and define a large 
width in the Door Specification dialog. 
If the doorway is specified wider than 
the railing, its width maximizes to fit the 
space available.
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Rooms Below Staircases
Rooms such as closets or storage areas are 
commonly located beneath staircases.

To create a room below a staircase

1. Draw a staircase, select it, and click the 

Open Object  edit button to open the 
Staircase Specification dialog.

•  If Winders are specified for this stair-
case, set Max Tread Contraction to 2" 
on the Style tab to allow walls to be 
built entirely under the staircase.

•  On the Fill Style tab, select None 
(Transparent) so the walls and other 
objects under the stairs can be seen.

2. On the same floor as the staircase, draw 

the Interior Walls  under them, fol-
lowing their shape. 

3. Reposition the walls as needed, making 
sure that each is entirely under the stairs.

4. The wall at the foot of the stairs should 
be placed no closer to the bottom than 
the second step.

5. Add a door and specify the Room Type.
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Staircase Specification Dialog
Staircases can be defined with the 
greatest accuracy using the Staircase 

Specification dialog. To open the Staircase 
Specification dialog, select a stair section 
and click the Open Object edit button or 
double-click a stair section using the 

Straight Stairs   or Select Objects  
tool. 

If a staircase is composed of multiple stair 
sections, the section that you clicked on to 
select the staircase is the Selected Section; 
however, information about all the sections is 
available and can be edited in this dialog. 

General Tab

It is recommended that all floor heights,
ceiling heights and platform thicknesses

be established before using the Staircase
Specification dialog.

1
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Staircase Information - Structural 
information about the selected staircase 

displays here. This information cannot be 
edited directly, but updates as changes are 
made in the dialog. If you modify a value 
elsewhere, press the Tab key to update this 
information. 
• The first comment tells whether or not 

the staircase reaches the next level, which 
may be a floor platform or locked land-
ing. It also indicates whether its rise 
angle is either steeper or more shallow 
than the Best Fit, described below. If 
Automatic Heights is unchecked, this 
comment instead says “Start and end 
heights are set manually”. 

• The second comment, Best fit riser 
height of ___ requires ___ total risers 
to reach ___ to next level, describes the 
ideal rise and run for the selected 
staircase. The program defines the Best 
Fit Riser Height as the riser height closest 
to 6 3/4” (168.75 mm) that allows the 
selected staircase to meet the next level 
precisely.  This comment is only active if 
Automatic Heights is checked, below.

If the staircase includes a locked landing, its 
height is used to calculate this information. 
See “Locked Landings” on page 408.
• The total number of stair Sections, 

Landings, and Risers associated with the 
selected staircase also display here. 

• The Rise Angle of the currently active 
stair section also displays here.

• Click the Make Best Fit button to add or 
remove risers to the Selected Section. 
Only available when Automatic Heights 
is checked and the staircase does not cur-
rently use the Best Fit Riser Height. 

Make Best Fit will also extend stairs drawn 
in a downward direction until they reach the 
terrain. See “Terrain Perimeter” on page 538. 

The Advanced Options apply to all 
sections and subsections.

Automatic Treads, Lock Tread Depth, and 
Lock Number of Treads affect how treads are 
calculated. Only one of these options can be 
selected at a time. 
• Select Automatic Treads to have the 

program define the depth and number of 
stair treads. If the staircase has multiple 
sections, each may have different tread 
depths. 

• Select Lock Tread Depth to specify the 
Tread Depth for each stair section, below, 
and prevent them from changing. When 
Lock Tread Depth is selected and the 
length of the stairs is changed, the num-
ber of treads will change.

• Select Lock Number of Treads to spec-
ify the number of treads in each stair sec-
tion and prevent it from changing. When 
Lock Number of Treads is selected and 
the length of the stairs is changed, the 
tread depths will change.

• Uncheck Automatic Heights if you 
would like to specify the bottom and top 
heights of each stair section, as measured 
from the default floor height of Floor 1, 
0” (mm). When checked, the program 
automatically defines the top and bottom 
heights by precisely locating floor plat-
forms and landings.

• Check Ignore Subsection Boundaries to 
maintain tread depth throughout a stair 
section composed of merged subsections, 
regardless of whether the subsections 
have different tread depths assigned to 

1

2
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them. See “Ignore Subsection Boundar-
ies” on page 410.

Lock Bottom and Lock Top are actions rather 
than settings. If you make changes to the 
staircase that will affect its length, first lock 
either the bottom or top end of the Selected 
Section to prevent it from moving. The 
height of the Selected Section’s locked end is 
not affected by these settings - only its 
position on the X/Y axis.
• Select Lock Bottom to lock the position 

of the selected stair section’s bottom end 
to prevent it from moving. Sections and 
landings below the selected section do 
not move when you click OK, while 
those above do move. 

• Select Lock Top to lock the position of 
the selected stair section’s top end to pre-
vent it from moving. Sections and land-
ings above the selected section do not 
move when you click OK, while those 
below do move.

The specifications for each stair section 
and subsection display and can be edited 

here. A maximum of ten items can display. 

A change in one value usually affects other 
values. You may need to reposition the 
staircase after making changes.
• The Section # column identifies the 

Selected Section and the number of each 
section of the selected staircase. If Ignore 
Subsection Boundaries is unchecked, 
subsection numbers are also identified. 
The radio button to the left indicates 

which section or subsection is selected. 
See “Displaying Stairs, Ramps, and 
Landings” on page 402.

• Define the Length, or run, of each sec-
tion or subsection measured along the 
Walk Line. The length is equal to the 
number of treads multiplied by the tread 
depth. See “Walk Line” on page 409.

When the length of a section changes, 
other sections and landings in the stair-
case unit move in response. You can 
specify whether the bottom or top edge of 
the Selected Section moves when you 
resize it by selecting either the Lock Bot-
tom or Lock Top radio button, above. 

• Define the Width of each section. Only 
one width can be defined for a section, so 
all subsections in the same section have 
the same width. If a section is connected 
to a landing, its width should equal the 
length of the landing edge that it connects 
to. See “Landings” on page 406. 

• Specify the Tread Depth, or run, of each 
stair tread in the selected section. To lock 
this value, check Lock Tread Depth, 
above. 

If a landing is created by clicking between 
two stair sections and one of them has locked 
tread depth, the resulting staircase also has 
locked tread depth. Any landings or sections 
connected to this new staircase adjust to meet 
it and then have locked tread depth as well. 
• Define the number of Treads in a stair 

section or subsection. To lock this value, 
select Lock Number of Treads, above.

• Define the Bottom Height, the height of 
the stair section’s bottom edge. To lock 
this value, click the radio button to the 
left of the section’s number, then click the 

If you select a staircase by clicking near
its bottom end, Lock Top will be

selected; if you select it near its top end, Lock
Bottom will be selected. 

3



Staircase Specification Dialog

 425

Lock Bottom radio button, above, and 
click OK.

• Define the Top Height, the height of the 
stair section’s top edge. To lock this 
value, click the radio button to the left of 
the section’s number, then click the Lock 
Top radio button, above, and click OK. 

• Define the Riser Height, the height of 
the risers in each stair section. 

• Check Winders to specify the Selected 
Section as winders. This affects the sec-
tion as a whole, including subsections. 
See “Winders” on page 414. 

A diagram of a sample staircase’s  
structure displays here for reference. 

Style Tab
The settings on the Style tab affect all stair 
sections and subsections. 

Specify the attributes of the selected 
staircase’s Stringers, which are the 

angled support members that support the 
treads. See “Anatomy of a Staircase” on page 
399. 
• Check Stringer at Wall to produce a 

raised stringer top baseboard at the sides 

of the stair sections against walls. This 
baseboard follows the slope of the stair.

• Check Single Stringer to form a single 5-
inch (125 mm) thick stringer in the center 
of the staircase.

Checking Single Stringer automatically 
checks Open Risers and unchecks 
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Stringer at Wall and Closed Stringer. 
You may want to increase the tread thick-
ness when this is checked.

• Check Closed Stringer to raise the tops 
of the exposed stringers to cover the sides 
of the treads. If this is checked, no central 
stringer is applied to open riser stairs. 
This setting only affects those stringers 
that are not against a wall.

• Check Large Stringer Base to widen the 
stringers at the foot of the staircase. This 
is helpful when walls are created below 
the stairs.

• Extend Stringer Top is checked by 
default and extends a triangular portion 
of the stringer under the landing or plat-
form at the top of the stairs.

• Specify the height of the Stringer Top 
when Stringer at Wall or Closed 
Stringer is selected. This is measured 
along the plane of the riser face from the 
top of a tread to the top of the stringer. It 
cannot be less than 2 inches (5 cm). 

• Specify the height of the Stringer Bot-
tom. This is measured from the top back 
corner of a tread down to the bottom edge 
of the stringer. It must be equal to or 
greater than the riser height.

The Open Options control whether the 
selected stairs have open risers or an 

open underside. 

• Uncheck Open Underneath to add a 
skirt below the staircase along the two 
sides. It looks like a wall in 3D, but it has 
only a single face. Base molding does not 
generate along the bottom of the skirt, 
and doors cannot be placed in it.

• Specify the Side Inset of the skirt below 
the staircase. The default value of 0 
aligns the skirt with the outside of the 
surface of the stringers. Only available 
when Open Underneath is unchecked. 

In most cases, the recommended way to 
enclose the area beneath stairs is to use walls. 
See “Rooms Below Staircases” on page 421.
• Check Open Risers to eliminate the riser 

face under each tread and expose the 
stringers. If Closed Sides is also selected, 
no central stringer is supplied.

Specify the attributes of the staircase’s 
carpet Runner. A runner is added to all 

sections connected by unlocked landings. 
Only available when Open Risers is 
unchecked, above.
• Specify the Runner Width. The default 

value of 0 does not create a runner. Only 
available when Open Risers is 
unchecked, above.

• Check Runner not Tucked to have the 
runner drop straight down from the tread 
front to the riser below. This is unchecked 
by default. 

Check Use Walk Line to have the 
program calculate the tread depth based 

on a Walk Line. Uncheck the box to disable 
this function. See “Walk Line” on page 409.
• Specify the distance of the Walk Line 

from Edge. The default value is 12” 
(300 mm).

Large Stringer Base shown at right
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• Check Show Walk Line to show the 
Walk Line in floor plan view.

Additional options control the behavior 
and appearance of the staircase. 

• Check Automatic Railing Openings to 
automatically create a doorway opening 
when the selected stairs are snapped to a 
railing drawn on the same floor as the 
stairs. This is checked by default.

• Check Allow Wrap to wrap the selected 
stairs around the corner of a deck or land-
ing where another, identical stair section 
is present. See “Wrapped Stairs” on page 
415.

Define the Max Tread Contraction 
(for Winder) value, which is the 

amount a tread’s width may be reduced when 
it meets a wall. See “Partial Railings” on 
page 416.

This option only takes effect when the stairs 
are specified as Winders on the General tab. 

Specify the characteristics of the 
staircase Treads. See “Anatomy of a 

Staircase” on page 399.
• Specify the Tread Overhang, which is 

the distance that each tread overhangs the 
riser.

• Specify the Tread Thickness.

Specify the appearance of the staircase 
where it meets the Top Landing. The 

edges of landings are not affected by these 
options.
• Check Nosing at Top Landing to pro-

duce tread nosing attached to platform 
edge at the top of stairs. 

• Check Riser Surface at Top Landing to 
produce a riser surface against the plat-
form edge at the top of the stairs. This 
allows stair risers to match all the way to 
the top of the platform.

Railing Tab
The settings on the Railing tab can also be 
found in the Ramp Specification dialog and 
will affect the appearance of railings on any 

landings attached to the selected staircase or 
ramp. See “Landings” on page 406.
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Specify the height and width of stair and 
landing rails. 

• Stair Rail Height defines the height from 
tread surface directly over the riser to 
railing top. 

• Landing Rail Height defines the height 
of the landing rail top from the landing 
surface.

• Handrail Width defines the horizontal 
width of the handrail used by the selected 
staircase and any attached landings. 

Baluster specifications.

•  Baluster Type - Select Square, Round, 
or Library balusters. Selecting Library 
from the drop-down list is the same as 
clicking the Library button to the right 
and allows selection of a baluster from 
the library.

• Specify the Baluster Width, which is the 
width or diameter of each baluster. For 

Library balusters, this is the width at its 
widest point. 

• Cut Baluster Top - Each tread normally 
has two to three balusters, growing lon-
ger toward its back. The default is to use 
the same baluster and cut it off at the bot-
tom to shorten it toward the tread front. 
Check this box to cut the balusters at the 
top instead.

Newel specifications.

• Newel Type - Select Square, Round, or 
Library newels. Selecting Library from 
the drop-down list is the same as clicking 
the Library button to the right and 
allows selection of a newel from the 
library.

• Specify the Newel Width, which is the 
width or diameter of each newel. For 
Library newels, this is the width at its 
widest point.

• Specify the Newel Height, which is the 
height from the landing surface to the top 
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of the newel. This is used only when Rail 
passes over Newel is unchecked.

• Check Newels at First Tread to place a 
newel where the rail starts at the base of 
the stairs. A newel is placed only on a 
side of the stairs not against a wall. 

• Uncheck Rail Passes Over Newel, then 
adjust the Newel Height to as needed. 
When this is checked, the Newel Height 
setting is ignored.

Railing specifications. 

• Railing On - Select Left and/or Right to 
specify placement of railings on stair sec-
tions.

• Railing at Wall - Select Left and/or 
Right to specify the placement of wall 
railings. Not available for ramps.

• Check Railing Transitions to create 
“gooseneck” connections between stair 
and landing railings. This option only has 
an effect when Rail Passes Over Newel 
is checked. Not available for ramps.

• Check Smooth Transitions to specify 
the placement of smooth connections 
between stair and landing railings. Not 
available for ramps. 

Check both Railing Transitions and 
Smooth Transitions to produce a handrail 
like this:

• Check Include Bottom Rail on Land-
ings to place a low rail on the landing 
surface that receives the balusters ends. 

4
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Line Style Tab
The settings on the Line Style tab are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Tab” on page 781.

Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the selected staircase in floor 
plan view. For information about these 
settings, see “Fill Style Tab” on page 792.

Materials Tab
The settings on the Materials tab affect the 
appearance of the selected staircase in 3D 
views and are available for a variety of 
objects throughout the program. For 
information about these settings, see 
“Materials Tab” on page 635.

The settings on this tab will also affect the 
materials applied to any landings attached to 
the selected staircase. See “Landings” on 
page 406.

Arrow Tab
The settings on the Arrow tab control the 
appearance of the selected staircase’s 
direction arrow in floor plan view. See “In 
Floor Plan View” on page 402.

For information about these settings, see 
“Arrow Tab” on page 783.

Ramp Specification Dialog
Ramps can be defined with the 
greatest accuracy using the Ramp 

Specification dialog. To open this dialog, 
select one or more ramps and click the Open 

Object edit button or double-click a ramp 

section using the Ramp  or Select 

Objects  tool. 
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General Tab

Specify the Ramp Length and Width. 
 

Uncheck Automatic Height to activate 
the settings below, then specify the 

height and slope of the ramp. 
• Specify the Start Height, which is the 

height of the ramp’s at its low end.
• Specify the End Height, which is the 

height of the ramp at its high end.
• Specify the ramp’s Slope (Rise/Run) in 

the form of a ratio. Type the Rise value in 
the first field, and the corresponding Run 
value in the second field.

• Specify the Base Height, which is the 
height of the bottom surface of the ramp.

Options - 

• Check Automatic Railing Openings to 
automatically create a doorway opening 
when the selected ramp is snapped to a 
railing drawn on the same floor as the 
ramp. This is checked by default.

• Check Open Underneath to remove the 
skirt around the bottom of the ramp so 
that it has a uniform, sloped thickness 
that may not reach the floor or terrain at 
the high end. This is unchecked by 
default.

• Specify the Max Thickness, which is the 
ramp’s maximum thickness. At the low 
end of the ramp, where it meets the floor 
or terrain, its thickness may be less than 
this value. 
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Specify the structure of the ramp’s 
Tread, which an optional surface layer 

placed over the top of the ramp.
• Check Has Tread Surface to apply a top 

tread surface to the ramp and enable the 
settings below. 

• Specify the Tread Overhang, which is 
the distance the tread surface extends past 
the ramp’s edges. 

• Specify the Tread Thickness, which is 
the tread surface’s vertical depth. 

Railing Tab
The settings on the Railing tab are similar to 
those on the same tab in the Staircase 
Specification dialog. For information about 
these settings, see “Railing Tab” on page 
427.

Selected Line Tab
The Selected Line tab is available when the 
selected ramp section is straight as opposed 
to curved. See “Selected Edge” on page 125.

The settings on this tab are available for a 
variety of other objects in the program. For 
information about the settings on this tab, see 
“Line Tab” on page 780.

Selected Arc Tab
The Selected Arc tab is available only when 
the selected ramp section has been converted 
to an arc. See “Change Line/Arc” on page 
159.

The settings on this tab are available for a 
variety of other objects in the program. For 

information about these settings, see “Arc 
Tab” on page 787.

Line Style Tab
The settings on the Line Style tab are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Tab” on page 781.

Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the selected ramp in floor plan 
view. For information about these settings, 
see “Fill Style Tab” on page 792.

Materials Tab
The settings on the Materials tab affect the 
appearance of the selected ramp in 3D views 
and are available for a variety of objects 
throughout the program. For information 
about these settings, see “Materials Tab” on 
page 635.

The settings on this tab will also affect the 
materials applied to any landings attached to 
the selected ramp. See “Landings” on page 
406.

Arrow Tab
The settings on the Arrow tab control the 
appearance of the selected ramp’s direction 
arrow in floor plan view. See “In Floor Plan 
View” on page 402.

For information about these settings, see 
“Arrow Tab” on page 783.

4
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Stair Landing Specification Dialog
Select a landing and click the Open 
Object edit button to open the Stair 

Landing Specification dialog. See 
“Landings” on page 406.

General Tab

Uncheck Auto Adjust Height When 
Connected to Stairs to specify the 

selected landing’s Top Height. 
• A free-standing interior landing will have 

a default Top Height of 6 3/4” (169 mm) 
plus the thickness of the default floor fin-
ish. A free-standing exterior landing will 
have a default top height equal to its 
thickness. When this box is checked, the 
landing height may adjust as needed to 
maintain consistent riser height in all 
connected stair sections. 

• The Top Height field is only active when 
Auto Adjust Height When Connected to 
Stairs is unchecked. See “Locked Land-
ings” on page 408. 

Uncheck Auto Adjust Thickness 
When Connected to Stairs to specify 

the selected landing’s Thickness. 
• A free-standing landing will have a 

default thickness of 6 3/4” (169 mm). 

When checked, the thickness is based on 
the riser height of the stair sections it is 
attached to, or the thickness of the ramps 
it is attached to.

• The Thickness field is only active when 
Auto Adjust Thickness When Connected 
to Stairs is unchecked. 

Check No Rail on Selected Edge to 
suppress the railing on the selected 

edge of this landing. See “Selected Edge” on 
page 125.

Polyline Tab
The Polyline tab indicates the length of the 
landing’s Perimeter, its enclosed Area, and 
its Volume. 

The settings on the this tab are available for a 
variety of other objects in the program. For 
information about the settings on this tab, see 
“Polyline Tab” on page 792.
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Selected Line Tab
The Selected Line tab is available when the 
selected edge is a line as opposed to an arc. 
See “Selected Edge” on page 125.

The settings on this tab are available for a 
variety of other objects in the program. For 
information about the settings on this tab, see 
“Line Tab” on page 780.

Moving the Start of a line segment moves the 
end of the previous connected line. Similarly, 
moving the End of a line segment moves the 
start of the next connected line.

Selected Arc Tab
The Selected Arc tab is available only when 
the selected edge has been converted to an 
arc. See “Change Line/Arc” on page 159.

The settings on this tab are available for a 
variety of other objects in the program. For 
information about these settings, see “Arc 
Tab” on page 787.

Line Style Tab
The settings on the Line Style tab are 
available for a variety of objects throughout 
the program. For information about these 
settings, see “Line Tab” on page 780.

Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the selected landing in floor 
plan view. For information about these 
settings, see “Fill Style Tab” on page 792.

Materials Tab
When a landing is attached to stairs or a 
ramp, its initial materials are derived from 
the stairs or ramp. When the landing is 
attached to a ramp, its top surface material is 
defined by the Landing Sides component 
unless the ramp is using a Tread material.  

The settings on this are available for a variety 
of objects throughout the program. For 
information about these settings, see 
“Materials Tab” on page 635.
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Chapter 16:

Framing

In Home Designer Pro, framing can be 
produced both manually and automatically, 
and can be calculated in the Materials List. 

Manual framing members are drawn by 
clicking and dragging, like drawing a CAD 
line. Automatic framing for the major 
components of a 3D model (floors, ceilings, 
walls and roofs) can be generated using the 
Build Framing dialog. 

Both manually drawn and automatically 
generated framing members can be selected 
and edited in 2D and 3D views.  

Trusses are covered in their own chapter, 
“Trusses” on page 469.

Chapter Contents
•      Framing Defaults
•      Manual vs. Automatic Framing
•      The Framing Tools
•      Build Framing Dialog
•      Framing Reference Markers
•      Bearing Lines
•      Joist Direction Lines
•      Displaying Framing
•      Editing Framing
•      Keeping Framing Current
•      Framing and the Materials List
•      Framing Specification Dialog
•      Post Specification Dialog
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Framing Defaults
Select Edit> Default Settings to open 
the Default Settings dialog. Select 

Framing from the list, then click the Edit 
button to open the Framing Defaults dialog. 

Both automatic and manually-drawn framing 
are generated according to the settings in the 
Framing Defaults dialog. 

This dialog is nearly identical to the Build 
Framing dialog in both appearance and 
function. The only difference is that the 
Build Framing dialog has checkboxes that 
allow you to automatically generate different 
types of framing in your plan. See “Build 
Framing Dialog” on page 443.

Any changes made in the  Framing Defaults 
or Build Framing dialogs will affect 
subsequently drawn or generated framing, 
but not framing already present in the plan. 

Floor and Ceiling Framing
Floor and ceiling platform depths contribute 
to the overall height of a structure, so their 
default values should be set as early as 
possible. See “Floor Tabs” on page 443. 

If you plan to draw floor trusses, also see 
“Trusses Tab” on page 453. 

The default floor and ceiling platform 
settings for a given floor can be overridden 
on a room by room basis in the Room 
Specification dialog, or for individual 

platforms using Joist Direction  lines. 
See “Structure Tab” on page 245 and “Joist 
Direction Lines” on page 457.

Deck rooms have special framing generated 
in them automatically and are not affected by 
the settings in the Framing Defaults or Build 
Framing dialogs. See “Decks” on page 238. 

Wall Framing
Like other types of framing, wall framing is 
generated based on settings in the Framing 
Defaults dialog. See “Wall Tab” on page 
446, “Openings Tab” on page 448 and 
“Headers Tab” on page 448.

In addition, wall framing is dependent on 
settings from other sources:
• The wall type definition settings used by 

each wall type in the plan. See “Wall Type 
Definitions Dialog” on page 211.

• The definition of the framing material 
assigned to each wall type used in a plan. 
See “Material Types” on page 640.

• The structural specifications for individ-
ual walls in the plan. See “General Tab” 
on page 214.

In order for wall framing to automatically 
generate, a wall’s framing layer must be set 
as its Main Layer and its framing material 
just be a Framing type. See “The Main 
Layer” on page 209. 

The settings in the Framing Defaults
dialog directly affect a variety of impor-

tant structural elements in each plan which
determine floor, ceiling and roof heights; so it
is best to set your Framing Defaults before
building your model. See “Drawing a Plan” on
page 33. 
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Rough Openings
The rough openings for doors, windows, and 
fireplaces are set in their respective defaults 
and specification dialogs. See:
• “Door Specification Dialog” on page 265
• “Window Specification Dialog” on page 

294
• “Fireplace Specification Dialog” on page 

345

Treated Sill Plates
Treated sill plates automatically generate 
over all exterior walls that have either 
Concrete or Brick material type as their Main 
Layer material and support a floor platform 
or a framed wall directly above. See “The 
Main Layer” on page 209 and “Material 
Types” on page 640. 

These sill plates are placed on the “Framing, 
Floor” layer and are specified as Treated. 
See “Displaying Framing” on page 458.

When a monolithic slab foundation is 
created, the bottom plates of framed walls 
built on the slab are specified as Treated and 
are placed on the “Framing, Wall” layer. 

Multiple bottom plates can be specified in 
the Framing Defaults dialog, but only the 
bottommost plate is specified as Treated. 
See “Wall Tab” on page 446. 

The default size of treated sill plates is 
specified in the Foundation Defaults dialog.  
See “Foundation Tab” on page 331. 

Roof Framing
Settings on the Roof and Trusses tabs of the 
Framing Defaults dialog determine the 
structure of roof planes and manually drawn 
ceiling planes as well as how they rest on 
bearing walls, so it is important that their 
default values be set before building the roof. 
See “Roof Tab” on page 451 and “Trusses 
Tab” on page 453.

If changes are made to these defaults that you 
need to apply to the entire roof plan, you will 
need to rebuild the entire roof - not just the 
roof framing. See “Roofs” on page 349. 

Framing Types
By default, all framing is set to use 
“Lumber” as the material type. You can 
select from a number of other types, 
however, including Glulam and steel. See 
“Framing Member Types” on page 463.

Manual vs. Automatic Framing
Platform, roof, and wall framing can be 
produced manually or automatically. In most 
cases, automatically-generated framing is 
preferable because it is faster than manually 
placing, replicating and editing numerous 
individual framing members. 

In many plans, though, framing is drawn 
using both approaches. For example, a 
combination of automatically generated 
rafters and manually drawn trusses can be 
used to model a roof framing plan. See 
“Mixing Trusses with Stick Framing” on 
page 475. 
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Regardless of how it is created, individual 
framing members can be selected and edited. 
See “Editing Framing” on page 460. 

Automatic Framing
Automatic framing of floor and ceiling 
platforms, walls and roofs can be generated 
using the Build Framing dialog. The settings 
in this dialog control the size, spacing, and 
type of framing drawn in a plan, and related 
structural information for the major 
components of the 3D model. See “Build 
Framing Dialog” on page 443.

Automatic framing of a particular structural 
component is not generated until the Build 
Framing dialog is opened to the appropriate 
tab and one of two checkboxes selected:  
• Select the Build checkbox to build auto-

matic framing once. For example, check 
Build Wall Framing on the Wall tab, 
then click OK to build wall framing once 
based on the current state of the model. 

• Select the Automatic checkbox, then 
click OK to build automatic framing 
every time a change is made to that struc-
tural component in the plan. For example, 
check Automatic Wall Framing on the 
Wall tab to rebuild all wall framing any 
time a wall is affected by changes to the 
model. 

Manual Framing
Framing objects can also be drawn manually. 
With the exception of Posts, framing objects 
are drawn by clicking and dragging in a 

straight line, the way other line-based objects 
are. See “Draw Line” on page 776.

The manual framing tools are organized into 
families: general framing, floor and ceiling 
framing and roof framing. The family that a 
drawing tool belongs to determines where it 
can be used: 
• Roof framing objects can only be drawn 

within the area of one or more roof 
planes.

• Floor and ceiling framing objects can 
only be drawn within one or more floor or 
ceiling platforms.

• General Framing  objects and 

Posts  can be drawn anywhere in a 
model.

Rebuilding Framing
It is important to remember that by default, 
framing does not update automatically when 
changes are made to the model. For example, 
if a window is moved or resized, the wall 
framing must be rebuilt. If the footprint is 
enlarged, the wall framing and any roof or 
platform framing that is affected must be 
rebuilt.

You can direct the program to rebuild the 
automatic framing of floors/ceilings, walls 
and/or roofs every time a change to the 
model affects one of these components. To 
do this, select the Automatic checkbox on  
the Floor, Wall and/or Roof tabs of the Build 
Framing dialog. 

To learn more, see “Keeping Framing 
Current” on page 461.

When automatic framing associated with a 
particular tab in the Build Framing dialog is 

Note: When Automatic framing of a particular
type is enabled, framing of that type cannot
be manually edited or deleted. 
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built, any previously existing automatically 
produced framing of the same type is deleted 
and replaced. 

With the exception of wall framing, 
manually drawn framing is unaffected when 
automatic framing is rebuilt and remains 
along with the newly produced automatic 
framing. By default, manually drawn wall 
framing is deleted when automatic framing is 
rebuilt; however, you can prevent this from 
occurring by checking Retain Wall 
Framing in the Wall Specification dialog. 
See “General Tab” on page 214.  

Mixing Rafters and Trusses
If you plan to mix roof trusses with rafters 
and/or ceiling joists, you can save time by:
• Check Trusses (No birdsmouth) in the 

Build Roof dialog before automatically 
building or manually drawing a roof. See 
“Build Roof Dialog” on page 355.

• Draw and position all roof trusses before 
using the automatic framing generator to 
produce rafters and ceiling joists. See 
“Floor and Ceiling Trusses” on page 470.

Some other important things to consider:
• Rafters and joists that are parallel to a 

roof truss are not generated closer than 14 
inches (350mm) to the truss. 

• Automatically produced rafters and joists 
do not cross an existing truss, but do gen-
erate from the eave inward until they butt 
into a truss.

• Rafters and hip ridges can pass over a 
drop hip truss. See “Drop Hip or Califor-
nia Hip” on page 476.

• Lookouts can pass over a reduced gable 
truss.

• When rafters are parallel to trusses, the 
tops of the rafters are placed in line with 
the tops of the trusses. Since the depth of 
a rafter is normally greater than that of a 
truss's top chord, the lower rafter edge is 
below the top plate of the supporting wall, 
requiring a birdsmouth cut into the rafter. 
If the truss is raised to provide space for 
insulation, the rafter may not need to be 
cut at all. If the truss is raised too much, 
the rafter may not rest on the top plate at 
all.

Framing with Beams

Floor/Ceiling Beams  can be drawn in a 
plan either before or after automatic framing 
has been generated. If a beam is created 
before automatic framing, you can specify 
whether joists bear on the beam or hang on 
its sides.

To build joists that bear on a beam

1. Draw a Floor/Ceiling Beam  at the 
desired location in your plan.

2. Select the beam and click the Open 

Object  edit button. On the General 
tab of the Beam Specification dialog, 
confirm that: 

•  The Top Height value is equal to the 
Ceiling Height of the room(s) over 
which the beam is placed.

•   Bearing Beam is checked. 
3. Click OK, then select Build> Framing> 

Build Framing  and build the appro-
priate floor or ceiling framing. See 
“Floor Tabs” on page 443.
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To build joists that butt against a beam

1. Draw a Floor/Ceiling Beam  at the 
desired location in your plan.

2. Select the beam and click the Open 

Object  edit button. On the General 
tab of the Beam Specification dialog: 

•  Specify the desired Depth value and 
then lock it.

•  Specify the Bottom Height value so 
that it is equal to the Ceiling Height of 

the room(s) over which the beam is 
placed.

•  Uncheck Bearing Beam. 
3. If necessary, select Build> Framing> 

Joist Direction Line  and draw a line 
perpendicular to the beam and within the 
floor or ceiling platform. 

4. Click OK, then select Build> Framing> 

Build Framing  and build the appro-
priate floor or ceiling framing. See 
“Floor Tabs” on page 443.

The Framing Tools
Select Build> Framing to access the 
automatic and manual Framing Tools.

The Framing Tools family has three separate 

parent buttons: General Framing Tools , 

Floor/Ceiling Framing Tools , and Roof 

Framing Tools .

The default settings for framing members are 
derived from their respective tabs in the 
Framing Defaults dialog.

Most types of framing can be created both 
manually and automatically. Once created, 
both automatically generated and manually 
drawn framing members can be selected and 
edited. See “Editing Framing” on page 460.

Build Framing
Select Build> Framing> Build 
Framing to open the Build Framing 

dialog. Here, you can define settings that 
control how framing is drawn and generate 
automatic framing. See “Build Framing 
Dialog” on page 443. 

General Framing
General Framing objects are generic, 
framing members that can be drawn 

outside of a floor or ceiling platform or roof 
plane. Select Build> Framing> General 
Framing, then click and drag in a straight 
line to create one of these objects. In floor 
plan view, a horizontal framing member is 
created.

Post
Posts can only be placed manually. To 
do so, select Build> Framing> Post 

and click in floor plan view. Placing a post 

As a general rule, horizontal framing
members are referred to as "joists"

(floor/ceiling platform framing); vertical fram-
ing members are referred to as "studs" (wall
framing); and sloped framing members are
referred to as rafters (roof framing).
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on the lowest level of a plan also creates a 
footing. 

Rafter
Rafters can be drawn both manually 
and automatically. To draw a rafter 

manually, select Build> Framing> Rafter, 
in floor plan view, then click and drag in a 
straight line within a roof plane. 

Rafters are edited like other framing 
members, except that you cannot set the 
height. If a rafter is moved, its height and 
slope are automatically reset to fit under the 
roof plane at its new position.

Roof Blocking
Roof blocking can only be drawn 
manually. To do so, select Build> 

Framing> Roof Blocking in floor plan view 
and click and drag in a straight line within a 
roof plane. 

Each run of blocking has gaps where it 
crosses rafters, trusses or other blocking but 
behaves as a single object. 

Blocking is typically drawn perpendicular to 
the rafters, but at the same pitch.  so blocking 
as seen in floor plan view represents the 
position of the top of the blocking. 

Before drawing Roof Blocking:
• Specify whether you want In Line, Stag-

ger blocking, or Cross bridging in the 
Framing Defaults dialog. 

• Build the roof framing. See “Roof Tab” 
on page 451.

In 3D, roof blocking is tilted to follow the 
pitch of the roof plane in which it is drawn. 

Roof Truss
Roof trusses can only be drawn 
manually. To do so, select Build> 

Framing> Roof Truss in floor plan view 
and click and drag  in a straight line within 
one or more roof planes. Roof planes and 
either a default or manually drawn ceiling 
must be present before a roof truss can be 
drawn. See “Roof Trusses” on page 470.

Roof Beam
Roof beams can only be drawn 
manually. To do so, select Build> 

Framing> Roof Beam in floor plan view 
and click and drag in a straight line. Roof 
beams are normally be drawn across rafters 
and placed directly under them. 

Joist
Floor and ceiling joists can be drawn 
both manually and automatically. To 

manually draw a joist, select Build> 
Framing> Joist in floor plan view, then 
click and drag in a straight line within a floor 
or ceiling platform. 

Joists are always drawn as the ceiling 
framing for the current floor. See “The 
Current Floor” on page 326. Whether a floor 
or ceiling joist is drawn is determined by the 
presence of a floor platform above. 
• If there is no floor platform above, a ceil-

ing joist is drawn. 
• If there is a floor platform above, a floor 

joist is drawn. 

If you want to draw floor joists for Floor 1, 
for example, you must do so on Floor 0. See 
“Foundations” on page 329.
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Joists can be automatically generated for 
multiple floors in the Build Framing dialog. 
See “Floor Tabs” on page 443. 

Joist Blocking
Joist blocking can only be drawn 
manually. To do so, select Build> 

Framing> Joist Blocking in floor plan view 
and click and drag in a straight line within a 
floor or ceiling platform. 

Each run of blocking behaves as a single 
object. 

Before drawing Joist Blocking:
• Specify whether you want In Line, Stag-

ger blocking, or Cross bridging in the 
Framing Defaults dialog. 

• Build the floor and/or ceiling platform. 
See “Floor Tabs” on page 443.

Floor/Ceiling Truss
Floor and ceiling trusses can only be 
drawn manually. To do so, select 

Build> Framing> Floor/Ceiling Truss in 
floor plan view and click and drag in a 
straight line within a floor or ceiling 
platform. See “Floor and Ceiling Trusses” on 
page 470.

Floor/Ceiling Beam
Floor and ceiling beams can only be 
drawn manually. To draw one, select 

Build> Framing> Floor/Ceiling Beam in 
floor plan view and click and drag in a 

straight line within a floor or ceiling 
platform.

Beams can be drawn in two different ways:
• Under Joists places the beam underneath 

the joists so the joists can bear on it. 
• With Joists places the top of the beam 

even with the tops of the joists it supports. 
The joist then butts against it. See “Posts/
Beams Tab” on page 449.

Framing Reference Marker
Framing Reference Markers are 
reference points that specify how to 

lay out automatically-produced framing and 
can only be drawn manually. To place one, 
select Build> Framing> Framing 
Reference Marker in floor plan view and 
click to place a framing reference marker. 

A Framing Reference Marker  can also 

be created by placing a Marker  and then 
specifing its type. See “Markers” on page 
762 and “Framing Reference Markers” on 
page 454. 

Bearing Line
Bearing Lines direct the program to 
lap or butt joists and/or rafters where 

they cross the line instead of framing across 
it to the next wall and can only be drawn in 
floor plan view. To draw one, select Build> 
Framing> Bearing Line and click and drag 

Ceiling joists, floor joists and rafters
have their own layers. Proper layer

assignment maximizes display and materials
flexibility.

Beams should be placed before joists
are produced by automatic framing. If

With Joists is specified, the joists are cut by
and butted against the beam. If Under Joists
is specified, the joists are automatically
butted or lapped over the beam. 
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in a straight line. See “Bearing Lines” on 
page 456.

Joist Direction
Joist direction lines define the 
direction in which joists run in a floor 

or ceiling platform and can only be drawn in 
floor plan view. To draw one, select Build> 
Framing> Joist Direction and click and 
drag within a floor or ceiling platform. See 
“Joist Direction Lines” on page 457.

Build Framing Dialog
Automatic framing can be generated 
by selecting Build> Framing> Build 

Framing to open the Build Framing dialog. 
This dialog can also be accessed by double-

clicking either the Framing Tools  button 

or the Rafter  tool.

The Build Framing dialog is organized so 
that each major structural component of the 
model has its own tab or tabs. The number of 
tabs in the dialog varies depending on how 
many floors are in your model. There is be a 
tab called  “1st” for the first floor, “2nd” for 
the second floor, and so on.
• Floor and ceiling framing settings are 

found on the Floor Tabs.  

• Wall framing settings are located on the 
Wall Tab, Openings Tab, and Headers 
Tab. 

• Post, floor/ceiling beam and roof beam 
settings are found on the Posts/Beams 
Tab. 

• Roof framing settings are located on the 
Roof Tab and Trusses Tab. 

• The settings on the Roof tab are the same 
as those on the Framing tab of the Build 
Roof Dialog. 

• You can set the default materials used for 
framing on the Materials Tab. See “Mate-
rials Tab” on page 454.

Floor Tabs
The Build Framing dialog opens to the 
framing tab for the current floor, such as 
Foundation, 1st or 2nd. Each tab specifies 
framing for specific floors or assemblies. 
Switch between tabs to define all settings.

The floor framing information for a given 
floor is found on the Floor tab for the floor 
below it, because that is where the framing 
will display in floor plan view when it is 
generated. For example, the floor framing 
information for Floor 2 is found on the 1st 

tab, while the floor framing for Floor 1 is 
found on the Foundation tab. 

To automatically generate the floor framing 
for Floor 1, a Floor 0 must be present. If a 
Floor 0 has not been built, the Build Floor 
Framing check box on the Foundation tab 
will not be available. 

Each Floor tab is divided into two halves: 
• The right half is for floor framing specifi-

cations, and applies to the model when the 
floor above has living space.
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• The left half is for ceiling framing specifi-
cations, and is relevant only for rooms 
that do not have living spaces above them. 
See “Floor and Ceiling Platforms” on 
page 321.

The platform structure settings defined here 
affect all rooms on the floor, but can be 
overridden for individual rooms in the Room 
Specification dialog or for individual 

platforms using Joist Direction  lines. 
See “Structure Tab” on page 245.

By default, joists automatically generate in 
the direction that results in the shortest span; 
however, you can produce different results 

using Bearing Lines , Floor/Ceiling 

Beams  and/or Joist Direction  lines. 
See “Bearing Lines” on page 456 and “Joist 
Direction Lines” on page 457.

Check Automatic Floor/Ceiling 
Framing to regenerate floor and ceiling 

framing whenever changes are made to the 
model. See “Automatic Framing” on page 
438. 

Check Build Ceiling Framing to 
generate or regenerate ceiling framing 

when the OK button is clicked. Only 
available when there is no living space above 
at least part of the current floor. 

Use Framing Reference - This applies 
to ceiling framing only. The Framing 

Reference Marker is the starting point for 
framing layout. If a reference is placed, the 
center of the first joist is placed at this point 
and spacing goes from there. If joists are 
lapped, the surface is placed at this point. 

If the check box is cleared, the program 
attempts to position ceiling joists so that they 
coincide with rafters. Be sure to build the 
roof framing first if you are doing this.

1

3
4

5

2

6

8
9

10

12

7

11

13

1

2

3



Build Framing Dialog

 445

A Framing Reference Marker is not usually 
used for both ceiling joists and nearby rafters 
that run the same way because one is placed 
on top of the other.

For floor joists, the starting point for a joist 
layout is always the Framing Reference 
Marker. See “Framing Reference Markers” 
on page 454.

Specify whether the ceiling framing 
members Lap or Butt over bearing 

walls. The lap is 8” (200 mm) and centered 
over the support. 
• When a Framing Reference Marker is 

used and Butt Over Support is selected, 
the joists are placed at reference spacing. 

• If Lap is selected, the surfaces where the 
joists lap are placed at reference spacing, 
so that joists are placed on either side of 
the framing reference locations.

Specify the spacing and size of the 
ceiling framing. 

• Enter a value for the Spacing of ceiling 
joists above the current floor. 

• Specify the Joist Width, which is their 
horizontal thickness. 

Click the Ceiling Structure button to 
open the Ceiling Structure Definition 

dialog and define the layers of materials that 
form the ceiling platform. See “Floor/Ceiling 
Structure Definition Dialog” on page 323.

Blocking / Bridging specifies how 
blocking is manually drawn after joists 

have been placed. See “Joist Blocking” on 
page 442. 
• In Line produces blocking pieces that 

align with each other.

• Stagger produces blocking that alternates 
on either side of the line you draw. 

• Cross  produces cross bridging that looks 
like in line blocking in floor plan view, 
but shows as cross bridging in 3D views 
and the materials list.

Check Build floor framing to generate 
or regenerate floor framing when the 

OK button is clicked. Build Ceiling Framing 
is only available when there is no living 
space above at least part of the current floor. 

Check Rim Joist to automatically 
produce a rim joist across the ends of 

the floor joists. If this is unchecked, line 
blocking across the ends of the floor joists is 
usually drawn in later. 

Specify if the framing members Lap or 
Butt over bearing walls. See #4, above.

Specify the spacing and size of the floor 
framing. 

• Enter a value for the Spacing of floor 
joists above the current floor. 

• Specify the Subfloor Thickness, which is 
the thickness of the floor sheathing. 

• Specify the Joist Width, which is their 
horizontal thickness. 

• Specify the Joist Depth, which is their 
vertical depth. 

The Subfloor Thickness and Joist Depth both 
affect floor platform thicknesses and can be 
overridden per room in the Room 
Specification dialog. See “Structure Tab” on 
page 245.

When viewing framing, Subfloor Thickness 
may be represented by a gap. To remove this 
gap, change the value to zero and rebuild the 
framing. 
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If the material Concrete is applied to the 
floor, platform thickness is specified in the 
Foundation Defaults dialog. See “Building 
a Foundation” on page 334.

Click the Floor Structure button to 
open the Floor Structure Definition 

dialog and define the layers of materials that 

form the floor platform. Only available if 
there is living space above at least part of the 
current floor. See “Floor/Ceiling Structure 
Definition Dialog” on page 323.

Specify how Blocking / Bridging is 
manually drawn after joists have been 

placed. See “Joist Blocking” on page 442. 

Wall Tab
The Wall, Openings, and Headers tabs are all 
referenced by the program to determine how 
walls are framed. The settings on these three 
tabs define how automatic framing generates 
and how wall framing is calculated for the 
Materials List.

Specify how Wall studs and bridging 
are built. 

• Check Build Wall Framing to build wall 
framing for the entire model. Framing is 
built in walls whose  Main Layer material 
type is “framing”. See “Wall Type Defini-
tions” on page 209.

• Check Automatic Wall Framing to 
regenerate wall framing whenever 

changes are made to the model. See 
“Automatic Framing” on page 438.

• Check Use Wall Framing Material to 
use the stud thickness and spacing defined 
for the framing material used by each wall 
type.  See “Define Material Dialog” on 
page 643. Uncheck this box to use the 
thickness and spacing values below for all 
wall types. 

12 13

You can still make changes to your plan
once you have framed your model. If

your changes affect framing, if a wall or ceil-
ing were moved for instance, rebuild framing
to update the model.
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• Specify the Stud Thickness for all walls 
in the plan. Stud depth is set by each 
wall's Main Layer thickness. Not avail-
able when Use Wall Framing Material is 
used.

• Specify the Stud Spacing for all walls in 
the plan, starting from the Framing Refer-
ence Marker, if one is present. See “Fram-
ing Reference Markers” on page 454. Not 
available when Use Wall Framing Mate-
rial is used.

Specify where and how Bridging is drawn. 
Each run of bridging behaves as a single 
object but has gaps where it crosses studs.
• Check Exterior to automatically produce 

bridging on external walls when wall 
framing is built. 

• Check Interior to automatically produce 
bridging on internal walls when wall 
framing is built.

• In Line produces bridging pieces that 
align with each other. 

• Stagger produces bridging that alternates 
on either side of a center line along the 
wall. 

Wall bridging is generated exactly half-way 
up each wall’s total height. Once created, it 
can be selected in a Framing Overview. 

Define how top and bottom Plates are 
generated.

• Specify the Number of Top Plates, as 
well as their Thickness.

• Specify the Number of Bottom Plates, as 
well as their Thickness.

Mitre Ends of Angle Walls - Specify 
how wall corners that are not right 

angles are framed. 90° corners are not 
affected by these settings. 
• Select Mitre Plate Ends to mitre the ends 

of the top and bottom plates. If 
unchecked, top and bottom plates will be 
butted together.

• Select Rotate End Studs to rotate the 
studs closest to mitre ends to the angle of 
the mitre. If unchecked, studs will remain 
perpendicular to the angle of the walls.

• Select Horizontal Frame Thru to frame 
through the horizontal walls in floor plan 
view, butting vertical walls against them. 
If unchecked, walls that are vertical in 
floor plan view will frame through.

2

3
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Openings Tab
The rough openings for doors and windows 
can be specified in the Door and Window 
Defaults dialogs. See “Default Settings” on 
page 56.

Specify when to build more than one 
Trimmer, which is a stud shortened to 

support a header, based on wall opening 
width.  
• Double Trimmer At - Openings up to 

this value in width have two trimmers on 
each side. 

• Triple Trimmer At - Openings up to this 
value in width have three trimmers. 

• Specify the Max Bay Trimmers , which 
is the maximum number of trimmers that 
a bay, box or bow window with a lowered 
top height can have on each side of the 
opening. Enter 0 to suppress trimmers for 
bay/box/bow window opening headers. 

• Specify the Bay Component Thickness, 
which is the thickness of a thinner trim-
mer for bay/box/bow window component 
headers if a standard trimmer does not fit 
after the component window is manually 
resized. See “Resizing Components” on 
page 291. The default for this value is 3/
4” (20mm).

Specify the construction of the window 
Sills, which refer to the framing below 

the window rather than the finished sill. 
• Specify the Thickness for window sills. 
• Check Double Sill to specify a double sill 

for all windows. 

Headers Tab

1 2

1

2

Home Designer Pro does not calculate loads or bearings. It is dependent upon user
input and does not attempt any structural analysis. Always consult your local building

authorities and contact a licensed engineer for structural calculations.
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Specify the header depth dependent on 
the opening width. These values should 

be set so that the wider the opening, the 
deeper the header. 

Check Use precut headers for ‘Mixed 
Reporting’ to show precut headers in 

the Materials List. Precut headers are shown 
only if the walls have been framed and 
Mixed Reported is selected as the reporting 
method. See “Structural Member Reporting” 
on page 898.

If this is unchecked, the Materials List 
produces a total footage for all headers. 
When checked, each different length of 
precut header is listed separately. Note that 
the total number of headers is twice the 
number of openings if Count is set to 2.

Specify the Thickness of all headers. 
 

Specify the Count of boards required to 
make a header. Using this number, the 

program generates a count of header stock 
for you in the Materials List.

When using stock as thin as 1-1/2 inches, 
headers are usually doubled or laminated, so 
the default number of boards making up a 
header in Count is 2.

If the top of the rough opening is closer 
to the top plate than the value in Max 

Depth, a solid header is produced to fill the 
entire area. This disables the building of 
short cripple studs between the top of the 
header top and bottom of the plate. The 
default of 12 1/16 inch works well for 6’8” 
headers in 8’0” walls.

Specify the Type of material used for 
headers. See “Framing Member Types” 

on page 463.

Posts/Beams Tab
Posts and beams are not produced by the 
automatic framing. They can only be created 
manually.

Posts are created by clicking in floor plan 
view where a post is desired using the 

Post  tool. 

3
1

2

4
5

6

1

2

3

4

5

6



450

Home Designer Pro 2014 Reference Manual

Beams are drawn manually in floor plan 

view using the Floor/Ceiling Beam  or 

Roof Beam  tool. 

Specify the size of the beams in the 
plan. These settings do not affect 

automatically generated deck beams.
• Specify the beams’ vertical Depth.
• Specify the beam Thickness, which 

appears as width in floor plan view.

Select the Type of beam from the drop-
down list.  See “Framing Member 

Types” on page 463.

Under Joists/With Joists - A beam can 
be drawn under the joists or up in the 

floor platform with the joists. If floor joist 
depths and subfloor thickness have been set 
in the Build Framing dialog, the beam height 
is properly positioned even if the joists have 

not yet been produced. If With Joists is 
specified, the beams should be drawn before 
framing is automatically produced. Then the 
joists are broken and butted to the beam.

Align Exterior with Outer Layer/
Main Layer - When a beam is drawn 

along and over an exterior wall, its outer 
surface snaps to either the wall’s outer layer 
or outer main layer, as specified here.

Post Initial Values - Specify the initial 
characteristics of posts placed manually 

using the Post  tool. These settings do not 
affect automatically generated deck posts.
• Dimension - This is the length of each 

side of a square post and the diameter of a 

Posts and beams may be created under
a Deck room automatically, depending

on its size, location, and other variables.
Deck Framing defaults are set in the Deck
Room Defaults dialog. See “Deck Framing
and Planking” on page 239.
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round post. Once created, posts not speci-
fied as Round can be edited to have a rect-
angular shape with any dimensions. 
Round posts can be resized but always 
remain circular.

• Select the Type of post from the drop-
down list. The Round Type is unique to 
Posts.

Post Footing Initial Values  - When a 
post is placed on the lowest floor of a 

plan and inside a floor platform or generated 
under a deck, a footing for it is automatically 

produced and included in the Materials List. 
See “Materials Lists” on page 887. 
• Specify the Top up to Floor value, which 

is the distance from the top of the footing 
to the bottom of the floor platform.

• Specify the Width of the automatically 
produced footing under a new post.

• Specify the Height of the automatically 
produced footing under a new post.

• Select the Square or Round radio button 
to specify the shape of post footings. 

Roof Tab
The settings on the Roof tab of the Build 
Framing dialog are exactly the same as those 
on the Framing tab of the Build Roof dialog. 
See “Build Roof Dialog” on page 355.

6

Note: Changes made on the Roof tab will not
affect the structure of existing roof planes. To
make changes take effect, rebuild the roof.

2

31



452

Home Designer Pro 2014 Reference Manual

Roof - 

• Check Build Roof Framing to build roof 
framing for the entire model. Only avail-
able if roof planes are present in the plan. 
See “Roofs” on page 349.

• Check Automatic Roof Framing to auto-
matically rebuild roof framing if changes 
are made to the roof plan. See “Automatic 
Framing” on page 438.

• Check  Use Framing Reference to use a 
defined starting point for rafter layout. 
See “Framing Reference Markers” on 
page 454.

• Check Angled Dormer Hole to create a 
5-sided hole in a roof plane to accommo-
date a gable dormer. The two top edges of 
the hole are located under the dormer val-
leys, and an angled double-header runs 
between the doubled rafters on one side to 
the ridge. A shorter angled doubled 
header frames the opposite valley.

If Angled Dormer Hole is unchecked, a 
rectangular hole is framed under the dor-
mer. A double header is placed where the 
peak of the dormer roof meets the main 
roof plane, and rafters are placed under 
the dormer valleys.

If the double header does not fit within 
the main roof plane, angled headers are 
produced regardless of this setting.

• Uncheck Generate Fascia if you do not 
want fascia boards on the roof eaves. If 
unchecked, the Gable Fascia and Eave 
Fascia options under Roof Size will be 
unavailable. 

• Uncheck Generate Eave Sub Fascia if 
you do not want subfascia boards on the 
roof eaves. If unchecked, Eave Sub Fascia 
under Roof Size will be unavailable.

• Uncheck Trim To Soffits to generate full-
depth rafters all the way to the subfascia. 
If checked, rafter depths are trimmed to 
the top surface of the soffits in the eave 
area.

• Specify the Spacing of automatically 
generated rafters.

• Select the Rafter Type from the drop-
down list.  See “Framing Member Types” 
on page 463.

Specify how Blocking/Bridging is 
manually drawn after rafters have been 

placed. A row of blocking is drawn and can 
be moved and edited as a single object, but 
displays as separate pieces separated by the 
rafters. See “Roof Blocking” on page 441. 
• Check Vertical to generate blocking that 

is oriented vertically, or plumb. When 

Note: Use Framing Reference is useful when
framing a gable roof, but not necessarily a hip
roof. See “Framing References and Roof
Framing” on page 455.

1

Angled Dormer Holerectangular dormer
hole
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unchecked, blocking is perpendicular to 
the roof framing. 

• In Line produces blocking pieces that 
align with each other.

• Stagger produces blocking that alternates 
on either side of the line you draw. 

• Cross produces cross bridging that looks 
like in line blocking in floor plan view, 
but shows as cross bridging in 3D views 
and the materials list. 

Specify the desired Width and Depth 
for Rafters, the Ridge, Lookouts, 

Gable Sub Fascia (barge rafter), Eave Sub 
Fascia, Gable Fascia, Eave Fascia and 
Blocking.

Uncheck the boxes beside Lookout, Eave 
Sub Fascia, Gable Fascia and/or Eave 
Fascia to prevent these framing members 
from generating when roof framing is built. 
When these boxes are checked, these items 
will generate as specified here. 

Trusses Tab
The parameters set in this tab apply to any 
subsequently drawn trusses. They can be 
overridden for any selected group of trusses 
using the Truss Specification dialog. See 
“Trusses” on page 469.

The program uses these values to model 
trusses for graphic representation only. 

Member Depth - Specify the depth of 
the truss chords and webbing.

• Specify the depth of the Top Chord.
• Specify the depth of the Bottom Chord.
• Specify the depth of the Webbing

For triangular trusses, check Require 
Kingpost to require a vertical member 

from the roof peak to the bottom chord.

If this is not checked, a vertical member may 
still be supplied, depending on what is 
needed to support the chords at or closer than 
the specified maximum spans. 

3

Home Designer Pro does not engineer
trusses. Always consult an engineer or

truss company to have your trusses profes-
sionally designed.
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The Maximum Span settings control 
the maximum length between junctions 

of the supporting webbing to the Top Chord 
and Bottom Chord. Changing these values 
may cause different truss configurations such 
as kingpost, queenpost, fink, double fink, 
fan, howe, or double howe to be represented. 

These distances are measured horizontally 
for both roof and floor and ceiling trusses. In 
some instances, especially in more complex 
trusses, making these spans equal may result 

in the webbing appearing more normal or 
standard. See “Trusses” on page 469.

Select either Roof or Floor/Ceiling to 
specify whether the settings apply to 

Roof or Floor/Ceiling trusses.

Specify the Ceiling Step, which is the 
maximum distance its bottom chord can 

step down to locate a ceiling on the floor 
below the top floor. See “Ceiling Steps” on 
page 478.

Materials Tab
The default materials that display on General 
Framing objects, Posts, and Rafters in 3D 
views are specified on the Materials tab. 
These materials are not used in the Materials 
List. Materials List information is derived 
from the structure Type of each framing 
object. See “Framing and the Materials List” 
on page 462.

Changes made on the Materials tab of the 
Build Framing dialog only affect 
subsequently created framing: both manually 
drawn and automatically generated.

The settings in the Materials tab of the Build 
Framing dialog are the same as in many 
other specification dialogs. See “Materials 
Tab” on page 635.

Framing Reference Markers
Framing Reference Markers are 
reference points that specify how to 

lay out automatically-produced framing. 
• Wall and floor framing always build to the 

Framing Reference Marker.
• Ceiling and roof framing only build to the 

Framing Reference Marker when Use 
Framing Reference is specified for that 
type of framing.

Typically, a single framing reference marker 
on Floor 1 is used for the entire model.
• When more than one marker is present, 

framing layout starts at the marker closest 
to the center of the area to be framed. 

• If no framing reference marker is found 
on the floor being framed, the closest 
framing reference marker on the first 
floor is used. 

When Automatic Wall Framing is checked, 
wall framing automatically rebuilds if a 
Framing Reference Marker is added or 
moved. See “Automatic Framing” on page 
438.
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If no framing reference markers exist in
your plan, the point at 0, 0 is used as

the framing reference marker location and
unexpected results may occur.
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Automatic Floor/Ceiling Framing and 
Automatic Roof Framing, on the other 
hand, do not respond when a Framing 
Reference Marker is added or moved. These 
framing types must be rebuild using the 
Build Framing dialog. See “Build Framing 
Dialog” on page 443.

Placing Framing 
Reference Markers

To place a Framing Reference Marker, select 
Build> Framing> Framing Reference 

Marker . Click in floor plan view to 
place the framing reference marker. 

When Object Snaps  are enabled, 
framing reference markers snap to framing 
members and other CAD-based objects first, 
and then to a wall main layer surface or 
corner if possible. 

Framing Reference Markers  can be 
modified just like other markers. See 
“Markers” on page 762.

When framing is generated using a Framing 
Reference Marker, the first framing member 
of a given type snaps to this point and all 
other framing members are laid out from 
there. 
• Wall and roof framing snap to the Fram-

ing Reference Marker at their centers.
• Floor and ceiling framing snap to the 

Framing Reference Marker along an edge.

Move to Framing Reference
Manually drawn framing and 
automatic framing that was not 

generated using a Framing Reference Marker 
can be moved relative to a Framing 

Reference Marker using the Move to 
Framing Ref edit button. 

When a framing member using the Move to 

Framing Ref  edit button, the on-center 
spacing distance set in the Build Framing 
dialog is used.  

The Move to Framing Ref  edit button 
may also reference spacing specific to a 
particular floor or ceiling platform. See 
“Joist Direction Lines” on page 457.

A group of selected framing objects that are 
all parallel to each other can be moved using 

the Move to Framing Ref  edit button. 
Only one of the objects in the group is 
compared to the framing reference marker 
and moved; the remaining objects are simply 
moved the same amount as the first object. 
Ideally, therefore, the group should have 
proper spacing relative to each other before 
the move. 

To move framing objects to a framing 
reference marker

1. Group select the framing objects.

2. Click the Move to Framing Ref  edit 
button.

3. The framing members are moved to the 
nearest Framing Reference Marker.

Framing References and 
Roof Framing

Framing Reference Markers are useful when 
framing a gable roof, but not necessarily a 
hip roof. When a Framing Reference is used, 
common rafters on either side of a hip rafter 
do not meet in the same place. 
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If the Framing Reference is not used, the 
automatic framing utility starts common 
rafter spacing from each end of the 

horizontal ridges, which results in common 
rafters on either side of hip jacks meeting 
each other. 

Bearing Lines
Bearing Lines direct the program to 
lap or butt joists and/or rafters where 

they cross the line instead of framing across 
it to the next wall.

Select Build> Framing> Bearing Line , 
then click and drag to draw a bearing line as 
you would draw a CAD line. Bearing lines 
are edited just like CAD lines or polylines, as 
well. See “Editing Line Based Objects” on 
page 127 or “Editing Open Polyline Based 
Objects” on page 134.

If a bearing line exists, the program laps or 
butts the joist and/or rafters over the line, 
depending on the option selected in the Build 
Framing dialog. See “Floor Tabs” on page 
443.

A bearing line should start outside the floor 
or ceiling platform and end outside of it, 
passing completely through the building. 

Bearing lines snap to the center of nearby 
parallel walls when framing is built.

A platform can be split into two by a bearing 
line, and the joist direction and/or depth can 
be specified separately on each side of the 
bearing line. Each platform takes on 
properties given by the joist direction line it 
contains. See “Joist Direction Lines” on page 
457.

Placing a Floor/Ceiling Beam  in a plan 
can also have the same effect as a Bearing 
Line when Bearing Beam is checked in its 
Beam Specification dialog. See “Framing 
Specification Dialog” on page 463.Joists lapping over a Bearing Line

Joists butting over a Bearing 
    Line and interior wall
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Joist Direction Lines
A Joist Direction line defines the 
direction in which joists run in the 

floor or ceiling platform in which it is drawn, 
as well as the joists’ depth and spacing. 

If a direction line is not specified, joists run 
in the direction that results in the shortest 
span and use the depth and spacing set in the 
Framing Defaults dialog.. See “Floor and 
Ceiling Framing” on page 436.

Using Joist Direction Lines
Select Build> Framing> Joist 

Direction  and draw a joist direction line 
just as you would draw a CAD line. In order 
to work, Joist Direction Lines must be drawn 
within the area of a floor or ceiling platform.

The text along the joist direction line states 
the joist size and spacing for the platform. 
Initially, these values reflect the settings in 
the Framing Defaults dialog. See “Floor 
Tabs” on page 443. 

Joist Direction Lines are located on the 
“Framing, Bearing Lines” layer and use the 
Text Style assigned to the layer that the Joist 
Direction Line is on. See “Text Styles” on 
page 765. 

Each floor in a plan can have more than one 
floor platform, and each floor platform can 
have its own joist direction. 

Two Joist Direction lines, one on either side 
of a Bearing Line, can divide a single floor 
or ceiling platform into two, allowing you to 
define different framing specifications for 
each area.

Joist Direction Specification Dialog
A Joist Direction line controls the joist 
depth and spacing information for the 

floor or ceiling platform in which it is drawn. 
To change this information, select a joist 
direction line and click the Open Object edit 
button. The Joist Direction Specification 
dialog opens. 
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• Define the Spacing of the joists in this 
platform.

• Define the Depth of these joists. 

The Joist Direction line affects the joists in 
the entire platform, but does not change the 
settings in the Build Framing or Room 
Specification dialogs. Settings in the Joist 

Direction Specification dialog affect 
subsequently produced framing only in the 
platform that contains the selected joist 
direction.

Line Style Tab
For information about the settings on this 
tab, see “Line Style Tab” on page 781.

Arrow Tab
For information about the settings on this 
tab, see “Arrow Tab” on page 783.

Displaying Framing
The display of framing members is 
controlled in the Layer Display 

Options dialog. See “Displaying Objects” on 
page 102.

In Floor Plan View 
Joists, rafters and trusses are represented in 
floor plan view by line-based CAD objects 
that are essentially long, thin rectangles. See 
“Editing Line Based Objects” on page 127.

If you prefer, framing and trusses can instead 
be represented by a single line. See “Line 
Properties Panel” on page 75.

By default, framing polylines have a solid 
white fill, and new members display in front 
of older ones, helping to distinguish newer 
members from those drawn previously. You 
can specify whether new framing members 
are drawn with this fill. See “CAD Defaults 
and Preferences” on page 770.

Note: This is not the recommended method
for specifying joist depth. You should instead
use the settings in the Room Specification
dialog. See “Room Specification Dialog” on
page 244.
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In 3D Views
The easiest way to view framing in 3D is to 
use either the Orthographic Framing 

Overview  or Perspective Framing 

Overview  tool, which display the model 
using the 3D Framing Set layer set. See 
“Framing Overview” on page 675. 

Framing objects can display in other 3D and 
cross section/elevation views, although by 
default they are not set to do so. If you wish 
to see framing in these views, turn on the 
framing layers when the view is active.

To reveal framing covered by other objects 

or wall layers, use the Delete Surface  
tool. See “Delete 3D Surface” on page 679. 

In Cross Section/
Elevation Views

To display framing in a cross section/
elevation view, make sure the framing layers 
are turned on in the Layer Display Options 
dialog. See “Layer Display Options Dialog” 
on page 104. 

You can also use the Delete Surface  tool 
to temporarily delete the surfaces of wall 
layers or other objects that block the view. 

In cross section/elevation views, framing 
objects that are cut by the cross section plane 
display as boxes containing an ’X’. 

Framing Materials and Types
The appearance of a framing member in 3D 
and cross section/elevation views is affected 
by the material assigned to it and also by its 
Type.

The material specified for a framing member 
determines what it looks like in camera 
views by applying a texture, pattern, or color 
to its surface. Materials have no effect on 
how the framing is calculated in the 
Materials List, however.

The default materials for framing are set:
• In the Floor and Ceiling Structure 

Definition dialogs for floor and ceiling 
framing. See “Floor and Ceiling Platform 
Definitions” on page 322.

• In the Wall Type Definitions dialog for 
wall framing. See “Wall Type Definitions 
Dialog” on page 211.

• In the Framing Defaults dialog for Gen-
eral Framing, Posts, and Rafters. See 
“Materials Tab” on page 454. 

Framing Types can also influence how a 
framing member looks in camera views 
because some types have special profiles - 
for example, I-Joists, Steel-I, and C-Channel. 
Framing types are also stated in the 

I-joists, a rim joist, and wall plates 
cut in a cross section view
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Description column in the Materials List. See 
“Framing Member Types” on page 463. 

In the Materials List
When framing is calculated in the materials 
list, its dimensions and type are noted. 

Treated lumber is also counted separately 
form regular lumber. See “Framing Member 
Types” on page 463. 

Framing lengths can be counted using one of 
several methods to produce, for example, cut 
lists and buy lists. See “Structural Member 
Reporting” on page 898.

If framing is not present in a plan when a 
Materials List is created, it will not be 
calculated.  See “Framing and the Materials 
List” on page 462. 

Editing Framing
Framing members can be individually 
selected in all views. Some framing members 
can be group selected. Once selected, 
framing members can be edited using the edit 
handles, edit toolbar buttons, or the Framing 
Specification dialog. See “Framing 
Specification Dialog” on page 463.

When Start and End Indicators are enabled 
in the Preferences dialog, a selected framing 
member will display an S and an E at its start 
and end points. This makes it easier to 
choose which end to lock when specifing its 
Length or Angle. See “Edit Panel” on page 
76.

Framing is organized into families which 
determine where it is generated and where it 
can be manually drawn. See “Manual vs. 
Automatic Framing” on page 437. Once 
framing has been created, however, it can be 
moved out of its structural component. In 
order to move roof framing above or below a 
roof plane, you must first check Manual 

Rafter Height in the Framing Specification 
dialog. See “General Tab” on page 464. 

Using the Edit Handles
Framing members can be drawn, edited and 
moved much the way CAD lines can. See 
“Editing Line Based Objects” on page 127. 

In Cross Section/Elevation views, joists and 
rafters cut by the cross section and displaying 
a cross box can also be edited. See “Editing 
Box-Based Objects” on page 141. Also, in 
Cross Section/Elevation views headers can 
be edited like closed polylines. See “Editing 
Closed-Polyline Based Objects” on page 
138. 

In a camera view or overview, the handles 
that display on a framing member depend on 
where it is clicked for selection and your 
current zoom factor.
• Click the top surface to display the same 

edit handles as in floor plan view, allow-

Materials and framing types control 
how framing looks in 3D views 
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ing you to rotate, move, and extend or 
shorten the length of the member.

• Click a side surface to display the same 
edit handles as in an elevation view, one 
at each end and one at the center.

• Zoom in and click on the appropriate edge 
to display edit handles that control the 
width and depth of framing members.

Using Dimensions
Framing members can be both moved and 
resized using dimensions. See “Moving 
Objects Using Dimensions” on page 737. 

Using the Edit Tools
A selected framing member can be edited in 
a variety of ways using the buttons on the 
edit toolbar. See “The Edit Toolbar” on page 
29.

Mitered Joints
Mitered joints can be created using the Fillet 

Two Lines  edit button. Click on the end 
edge of a framing member such as a joist, 

click the Fillet Two Lines  edit button, 
then click on the end edge of another nearby 
joist to extend one framing item to another 
framing item and join them with angled cut. 
See “Fillet Two Lines” on page 159.

Steel and Concrete
You can set framing defaults to generate steel 
framing and concrete structural members as 
well as lumber and other framing types. 
Individual framing members can also be 
specified as concrete or steel, as well.  

When setting up defaults or modifying an 
individul object, make sure you specify both 
the desired framing Type and the material. 
See “Framing Materials and Types” on page 
459. 

Roof and Floor Trusses
Roof and floor trusses cannot be edited like 
regular framing members can and are 
discussed in their own chapter. See “Editing 
Truss Envelopes” on page 474.

Deleting Framing
Individual and group-selected framing 
members can be deleted the way other 
objects in the program are. See “Deleting 
Objects” on page 171. 

Categories of framing, such as wall framing 
or floor and ceiling framing, can also be 
deleted in the Delete Objects dialog. See 
“Delete Objects Dialog” on page 171.

Keeping Framing Current
When you modify your plan, move walls, 
raise or lower platforms or redesign the roof, 
any framing present in the plan will not 
update to reflect your changes. In order for 
the framing to be updated, you must 

regenerate automatically produced framing 
and either edit or delete and replace manual 
framing. 

For this reason, it is recommended that you 
wait until your model is finished, or nearly 
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finished, before creating framing. See 
“Drawing a Plan” on page 33.

Automatic Framing
Automatically-generated framing can be 
rebuilt using either of two checkboxes in the 
Build Framing dialog:
• Select a Build checkbox to build auto-

matic framing once. For example, check 
Build Wall Framing on the Wall tab to 
build wall framing once based on the cur-
rent state of the model. If the model is 
changed later, you may need to do this 
again. 

• Select an Automatic checkbox to build 
automatic framing every time a change is 
made to that structural component in the 
plan. For example, check Automatic 
Wall Framing on the Wall tab to rebuild 

all wall framing any time a wall is 
affected by changes to the model. 

When floor, ceiling or roof framing is 
regenerated, all automatically produced 
framing objects and any copies of them are 
deleted and new framing is calculated. See 
“Rebuilding Framing” on page 438.

Manual Framing
It is vital to remember that manually drawn 
framing objects and copies of them are not 
retained when automatic framing is rebuilt. 

If a plan is not final, therefore, do not spend a 
lot of time altering or copying automatically 
produced framing objects. It is best to wait 
until your design is final before doing 
manual framing work. 

Framing and the Materials List
Each framing member created in a plan is 
counted in the Materials List. See “Materials 
Lists” on page 887.

Framing can be calculated using one of 
several reporting methods. See “Structural 
Member Reporting” on page 898.

Depending on what a framing member is 
used for, it may be listed in the Framing (F), 
Subfloor (SF), or Roofing (R) category. See 
“Categories” on page 890.
• Framing includes all wall framing, posts, 

and General Framing objects.
• Sub Floor lists floor and ceiling framing 

joists as well as sheathing.
• Roofing includes trusses, rafters, and 

sheathing.

It is important to note that the floor, ceiling, 
and roof framing counted in the Materials 
List may vary considerably depending on 
whether framing of those types is actually 
present in the plan: 
• If no framing is present in the model, then 

the required floor, ceiling, and roof fram-
ing is estimated. Total lineal footage for 
various depths of rafters and joists is esti-
mated, rather than a quantity of specific 
lumber lengths and sizes. Wall framing is 
not estimated. 

• If even one floor, ceiling, or roof framing 
object exists in the plan, then objects  in 
that category are counted instead of esti-
mated for the Materials List. 



Framing Specification Dialog

 463

Framing Member Types
A variety of framing member types is 
available for use in Home Designer Pro: 
Lumber, I-Joist, Glulam, Engineered 
Lumber, LVL, Steel I, Steel Box, Solid 
Concrete, C Channel, and U Channel. In 
addition, Round is an available Type for 
posts.

You can select any of these types as the 
default for floor and ceiling framing, 
headers, posts and beams, and roof framing. 
See “Build Framing Dialog” on page 443. 

You can also specify the type for individual 
framing members in their specification 
dialog. See “General Tab” on page 464.

Changing the framing member type does not 
affect how framing is placed, but it may 
change its profile in cross section and 3D 
views and will affect its description in the 
Materials List. 

The framing member type does not affect the 
appearance of the material used by a framing 
member in 3D views. See “Framing 
Materials and Types” on page 459. 

Structural Member Reporting
You can specify whether framing materials 
are calculated by lineal foot, as a cut list, or 
as a buy list. See “Structural Member 
Reporting” on page 898. 

Framing Materials and 
the Materials Tab

The materials applied to framing objects in 
3D views are not used in the Materials List. 
Materials List information is derived from 
the structural use of each framing object and 
its Type - not the material seen on its 
surfaces in 3D views. See “Materials Tab” on 
page 454.

Framing Specification Dialog
Select a floor or ceiling joist, wall stud 
or rafter and click the Open Object 

edit button to open the Framing 
Specification dialog for the framing member 
type selected. 

The options available in this dialog may vary 
depending on the type of object selected.

The settings in this dialog are similar to those 
in the Beam Specification dialog. See 
“Framing with Beams” on page 439.



464

Home Designer Pro 2014 Reference Manual

General Tab

Depth and Height - Click the radio 
button beside one of the height values 

to lock it, then change a value that remains 
available. Changing the Top Height, Bottom 
Height or Depth may change the other two 
values. 
• Specify the Top Height of the post, as 

measured from the first floor subfloor at 
0”. For a rafter, this is the top height at its 
low end.

• Specify the Bottom Height of the post, as 
measured from the first floor subfloor at 
0”. For a rafter, this is the bottom height 
its low end.

• Specify the Depth of the framing object. 
For a rafter, this is the depth measured 
perpendicular to the roof plane.

• Click the radio button beside Raise/
Lower to enable it, then enter a value to 
raise or lower the framing object from its 
current position. Once a value is entered, 
the other controls are disabled. The 
amount is added to both the top height 

and the bottom height when you click 
OK, and does not affect the depth. 

• Manual Rafter Height - Normally, the 
height of each Rafter or Roof Beam end is 
reset after any move or edit so that it is 
located just under the roof surface. Check 
this box to allow the height of the object 
to be changed. Only available for Rafters 
and Roof Beams. 

Length and Angle - Lock the point 
about which you want like the selected 

object to resize and/or rotate, then specify its 
exact length and angle. See “Editing 
Framing” on page 460. 
• Length of the framing object. Rafter 

length is measured along the top of the 
rafter, and so is greater than the length 
measured in floor plan view. 

• Angle of the framing object in floor plan 
view. Changing this rotates the object 
about the location specified by the radio 
buttons described below.

1

2

3
4

5
6

1

2
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• Select Lock Center to resize or rotate the 
object about its center point. 

• Select Lock Start to resize or rotate the 
object about the location from which you 
started drawing the framing object.

• Select Lock End to resize or rotate the 
object about the location where you 
stopped drawing it.

Check Bearing Beam to specify the 
selected Floor/Ceiling Beam as a load-

bearing beam. When checked, automatically 
generated joists run perpendicular to the 
selected beam and either lap or butt over it, 
as specified in the Build Framing dialog. See 
“Floor Tabs” on page 443. Only available for 
Floor/Ceiling Beams.

Check Treated to specify that the 
selected framing  member be counted 

as treated in the Materials List.

Set the framing member’s Thickness, 
which appears as its width in floor plan 

view.

Select a Type of structural member 
from the drop-down list. See “Framing 

Member Types” on page 463. 

Line Style Tab
For information about the settings on this 
tab, see “Line Style Tab” on page 781.

Fill Style Tab
The settings on the Fill Style tab affect the 
selected object’s appearance in floor plan 
view. For information about these settings, 
see “Fill Style Tab” on page 792.

Materials Tab
The default materials on this tab are set in the 
Build Framing dialog. If you change the 
selected object’s framing Type, the material 
here may update - unless you have specified 
a non-default material. For information about 
the settings on this  tab, see “Materials Tab” 
on page 635.

Post Specification Dialog
Select a post and click the Open 
Object edit button to open the Post 

Specification dialog. 

3

4

5

6

Note: Instead of counting individual concrete
posts and beams in the Materials List, the
total volume of their concrete is calculated.
The square footage for beam and post forms
is also listed.
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General Tab

Post Height - Click the radio button 
beside a height value to lock it, then 

change an unlocked value. Changing the Top 
Height, Bottom Height or Total Height may 
change to the other values. 
• Specify the Top Height of the post, as 

measured from the first floor subfloor at 
0’ 0”.

• Specify the Bottom Height of the post, as 
measured from the first floor subfloor.

• Specify the Total Height of the post, 
which is the difference between the Top 
and Bottom Heights.

• Click the radio button beside Raise/
Lower to enable it, then enter a value to 
raise or lower the post from its current 
position. When Raise/Lower is selected, 
the other controls are disabled. The 
amount is added to both the top height 
and the bottom height when you click 
OK, and does not affect the total height. 

Post Width 1 & 2 - Specify the post 
width in each dimension.

• Specify the Angle of the post’s rotation.

Select a Type from the drop-down list. 
The Round Type is unique to Posts. See 

“Framing Member Types” on page 463.

Line Style Tab
For information about the settings on this 
tab, see “Line Style Tab” on page 781.

Fill Style Tab
The settings on the Fill Style tab affect the 
selected object’s appearance in floor plan 
view. For information about these settings, 
see “Fill Style Tab” on page 792.

1

2

3

1

Note: Instead of counting individual concrete
posts and beams in the Materials List, the
total volume of their concrete is calculated.
The square footage for beam and post forms
is also listed.

2

3
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Materials Tab
The default materials on this tab are set in the 
Build Framing dialog. If you change the 
selected object’s framing Type, the material 

here may update - unless you have specified 
a non-default material. For information about 
the settings on this  tab, see “Materials Tab” 
on page 635.
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Chapter 17:

Trusses

There are two basic ways to frame a roof. 
The first is commonly called “stick framing,” 
or sometimes “handstacking” or “cut-and-
stack.” This type of roof incorporates 
framing such as rafters, ridges, and ceiling 
joists. See “Framing” on page 435.

The other method is to use prefabricated, 
engineered roof trusses. Home Designer Pro 
allows you to design and display a wide 
variety of trusses.

Disclaimer
Home Designer Pro does not engineer 
trusses. The trusses displayed by Home 
Designer Pro are for illustrative purposes 
only. They can show how trusses are used in 
your plan, and help you communicate to the 
licensed engineer who produces your final 
truss design where you want your trusses and 
how you would like them to work.

Chapter Contents
•      Truss Defaults
•      Floor and Ceiling Trusses
•      Roof Trusses
•      Drawing Trusses
•      Displaying Trusses
•      Editing Trusses
•      Editing Truss Envelopes
•      Truss Labels
•      Mixing Trusses with Stick Framing
•      Hip Trusses
•      Special Roof Trusses
•      Roof Truss Specification Dialog
•      Floor/Ceiling Truss Specification Dialog

Always have your truss designs
approved by a licensed engineer.
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Truss Defaults
The default settings for floor, ceiling 
and roof trusses are set in the Framing 

Defaults dialog. Select Edit> Default 
Settings and in the Default Settings dialog, 
select Framing and click the Edit button.
• The default settings for truss chord and 

webbing depth, maximum span, and king-
post are set in the Framing Defaults dia-
log. See “Trusses Tab” on page 453. 

• The overall depth of individual Floor/

Ceiling Trusses  are based on the 
thicknesses of the platforms in which they 
are drawn. See “Floor Tabs” on page 443. 

• The structure of Roof Trusses  is 
determined by the position of the roof 
plane(s) above and the ceiling plane(s) 
below. See “Roof Planes” on page 362 
and “Ceiling Planes” on page 379. 

Floor and Ceiling Trusses
Floor and ceiling trusses can be used 
instead of joists to frame platforms. 

As with manually-drawn floor and ceiling 
framing, the presence of a room above 
determines whether a floor or ceiling truss is 
drawn. For example, a truss drawn on the 
first floor of a single story home will be a 
ceiling truss, while a truss drawn on the first 
floor of a two-story building will be a floor 
truss for the 2nd floor.

Floor and ceiling trusses can only be drawn 
manually. To place a floor or ceiling truss in 

your plan, select Build> Framing> Floor/

Ceiling Truss , then click and drag within 
a floor or ceiling platform in floor plan view. 
See “Drawing Trusses” on page 471. 

The Trusses tab of the Build Framing dialog 
contains default settings for floor and ceiling 
trusses. See “Trusses Tab” on page 453. 
These default settings can be overridden by 
the settings in the Floor/Ceiling Truss 
Specification dialog. See “Floor/Ceiling 
Truss Specification Dialog” on page 482.

Roof Trusses
Roof trusses can be used instead of or 
in combination with rafters to frame 

roofs and ceilings.  

Roof trusses can only be drawn manually, 
and can only be created where roof and 
ceiling planes already are present. Select 

Build> Framing> Roof Truss , then 
click and drag in floor plan view within one 

or more roof planes to manually draw a roof 
truss. See “Drawing Trusses” on page 471. 

If you intend to use roof trusses, you need 
first to build your roof planes with this in 
mind. Before building the roof, select the 
Trusses (no Birdsmouth) check box in the 
Build Roof dialog. When this is checked, 
roof plane thickness is based on the default 
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Top Chord Depth set in the Framing 
Defaults dialog. See “Trusses Tab” on page 
453.

If Trusses (no Birdsmouth) is not checked, 
the roof plane thickness is determined by the 
rafter Depth setting on the Roof tab of the 
Framing Defaults dialog. 

Roof Truss Placement
A roof truss can only exist in the space 
defined by the roof planes above it and the 
ceiling planes below it. This is because the 
shape of a truss is defined by the location of 
the roof and the ceiling. 

If Ceiling Over This Room is unchecked in 
the Room Specification dialog, you must 

manually draw a Ceiling Plane  before a 
roof truss can be drawn over that room. See 
“Structure Tab” on page 245.

If the program either does not find both roof 
and ceiling planes, or if there is not enough 
room between them, to model a truss, a 
warning message displays. For example, if 
you draw a truss in a roof overhang where 
there is no ceiling, this message displays:

“Roof and ceiling surfaces too close together 
or cannot be found, so cannot make truss.” 

The incorrect truss may still display in floor 
plan view with a label of the form “TR-*”. If 
it does, it should be deleted or moved. See 
“Editing Trusses” on page 473.

One or both ends of a truss may be truncated 
if they are drawn across another truss. If this 
happens, it will end exactly on the surface of 
the existing truss, producing a girder truss. 
See “Girder Trusses” on page 478.

Trusses can end on interior walls. You can 
draw a truss that partially crosses the 
building by starting and/or ending it within 
24” (600mm) of an interior wall. The truss 
extends over the wall’s Main Layer. Its end 
lines up with the Main Layer surface on the 
far side of the wall.

Roof Truss Webbing
The webbing in a newly drawn truss is 
controlled by the Top Chord and Bottom 
Chord settings in the Framing Defaults 
dialog. See “Trusses Tab” on page 453.

Changing these default values may cause 
different truss configurations such as 
kingpost, queenpost, fink, double fink, fan, 
howe, or double howe to be represented. 

Drawing Trusses
Trusses cannot be generated automatically: 
the must be manually drawn and then 
replicated. All trusses are drawn similar to 
the way CAD lines are and can be drawn in 
floor plan view only. See “Draw Line” on 
page 776. 

To draw and replicate trusses

1. Select the either the Floor/Ceiling 

Truss  or Roof Truss  tool, then 
click and drag within either a floor/ceil-
ing platform or one or more roof planes.



472

Home Designer Pro 2014 Reference Manual

•  Roof trusses seek an exterior wall and 
adjust their length automatically. 

•  Floor/Ceiling trusses will snap to the 
wall surfaces, the exterior surface of a 
wall’s Main Layer, as well as to a vari-
ety of CAD-based objects, and can be 
drawn to any length.

2. Reposition the truss:
•  Floor/ceiling trusses are often posi-

tioned relative to an exterior wall or 

Framing Reference Marker . See 
“Framing Reference Markers” on page 
454.

•  Roof trusses are can be positioned over 
a gable end wall or at the ridge end of a 
hip. 

3. Open the truss’s specification dialog and 
edit its settings to meet your needs. See 

“Roof Truss Specification Dialog” on 
page 479 or “Floor/Ceiling Truss Speci-
fication Dialog” on page 482. 

4. Make multiple copies of the truss at 
specified intervals using the Transform/

Replicate Object  edit tool. See 
“Transform/Replicate Object Dialog” on 
page 166.

The copies of Roof Trusses automatically 
conform to the structural conditions in their 
new locations. As a result, replicated Roof 
Trusses and their labels may be different 
from the original. See “Truss Labels” on 
page 474. 

Unlike Roof Trusses, Floor/Ceiling Trusses 
do not conform to new structural conditions 
when they are either moved or copied. See 
“Moving Trusses” on page 473.

Displaying Trusses
The display of trusses and their labels 
is controlled in the Layer Display 

Options dialog. See “Layer Display Options 
Dialog” on page 104.

Truss labels display in floor plan view and 
are used in the Materials List. See “Truss 
Labels” on page 474.

In 3D Views
The easiest way to view trusses in 3D is to 
use either the Orthographic Framing 

Overview  or Perspective Framing 

Overview  tool, which display the model 
using the 3D Framing Set layer set. See 
“Framing Overview” on page 675. 

Trusses can display in other 3D and cross 
section/elevation views, although by default 
they are not set to do so. If you wish to see 
trusses in these views, turn on the “Framing, 
Trusses” layer when the view is active.

You can create exposed trusses by placing 
roof and ceiling planes to produce the desired 
truss structure, drawing the trusses, and then 
removing the ceiling. See “Vaulted and 
Cathedral Ceilings” on page 242. 

To reveal trusses covered by other objects, 

you can use the Delete Surface  tool. See 
“Delete 3D Surface” on page 679.
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In the Materials List
All trusses are listed under the Roofing 
category in the Materials List. Their labels 

appear in the Size column, along with their 
length. See “The Materials List Tools” on 
page 888. 

Editing Trusses
Trusses can be selected like other objects in 
Home Designer Pro. See “Selecting Objects” 
on page 124 for more information.

Once selected, trusses can be edited using 
dimensions, their edit handles, the edit 
toolbar buttons, or by opening them for 
specification.

When Start and End Indicators are enabled 
in the Preferences dialog, a truss selected in 
floor plan view will display an S and an E at 
its start and end points.  See “Edit Panel” on 
page 76.

Trusses can be deleted all at once in the 
Delete Objects dialog. See “Delete Objects 
Dialog” on page 171.

Using Dimensions
Trusses can be relocated precisely using 
dimensions. See “Moving Objects Using 
Dimensions” on page 737.

Using the Edit Handles
When selected in floor plan view, trusses edit 
like CAD lines. See “Editing Line Based 
Objects” on page 127.

The depth of truss chords can be changed in 
the truss’s specification dialog, but not using 
the edit handles.

When selected in Cross Section/Elevation 
views and 3D views, trusses edit like closed 

polylines. See “Editing Closed-Polyline 
Based Objects” on page 138.

Like joists or rafters, trusses can be selected 
and moved in 3D views. The only difference 
is that the Lock Truss and Webbing setting 
in the Roof Truss Specification dialog 
prevents the truss from moving back to 
between the roof and ceiling planes the next 
time it is edited or otherwise changed. 

Using the Edit Tools
A selected truss can be edited in a variety of 
ways using the buttons on the edit toolbar. 
See “The Edit Toolbar” on page 29.

Moving Trusses
Trusses can be moved using either their 
Move edit handle or the Transform/

Replicate Object  edit tool. 

When a Roof Truss  is moved, it snaps to 
two things: 
• If drawn along an exterior wall, it snaps 

so that its outer surface is flush with the 
outer surface of the wall's Main Layer. 

• The center line can snap to the edge or 
corner of a nearby roof plane. 

To prevent this, special snapping, check No 
Special Snapping in the Roof Truss 
Specification dialog. See “General Tab” on 
page 480.
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In addition, when a Roof Truss  is 
moved, its shape updates to conform to the 
structural conditions defined by the roof and 
ceiling in its new location. As a result, a Roof 
Truss’s label could change when the truss is 
moved to a new location. To prevent this 
from occurring, check Lock Truss Envelope 
in the Roof Truss Specification dialog 
before moving the truss. See “Roof Truss 
Specification Dialog” on page 479.

This is not the case with Floor/Ceiling 

Trusses : when moved to a location with 
a different platform structure, a Floor/Ceiling 
Truss will not update to conform to its new 
surroundings. It is important to draw, 
position, and copy them within the same 
floor or ceiling platform structure. If a 
different Floor/Ceiling Truss depth is 
needed, a new truss should be drawn. 

Editing Truss Envelopes
When a truss is viewed at a 90° angle in a 3D 
view, its envelope, or shape, can be edited. 
Click on the truss to select it and edit handles 
display on a surrounding polyline. Change 
the shape of this polyline and the truss 
regenerates inside it. Use this function to 
change overhang or truss end details rather 
than the overall truss shape.

The Lock truss and webbing attribute is set 
after editing so that the truss does not reshape 
itself back between the roof and ceiling 
planes the next time it is edited or otherwise 
changed. See “Roof Truss Specification 
Dialog” on page 479. 

Truss Labels
Labels for roof  trusses display in floor plan 
view when the “Framing, Roof Truss Labels” 
layer is turned on in the Layer Display 
Options dialog. Similarly, floor and ceiling 
trusses display in the floor plan view when 
the “Framing, Floor/Ceiling Truss Labels” is 
turned on. Truss labels use the Text Style 
associated with their layer. See “Layer 
Display Options Dialog” on page 104.

Truss labels are also used in the Materials 
List, where they are listed under the Size 
column. See “Displaying Trusses” on page 
472. 

By default, truss labels are centered on the 
truss that they identify. If the truss is moved 
or deleted, the label is moved or deleted as 
well. Truss labels have their own Move edit 
handle which displays when their truss is 
selected. See “Editing Trusses” on page 473.

Truss labels obey the Minimum Display 
Size for labels set in the Preferences dialog. 
See “Appearance Panel” on page 61. 

Note: Truss labels only display when the
trusses they identify are also displaying. See
“Displaying Trusses” on page 472. 
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Truss Label Format
Roof truss labels use the format TR-X, where 
X is a number indicating the order in which 
each distinct truss configuration was created. 
For example, the first truss type created in a 
plan is labeled TR-1; the second, TR-2; and 
so on. 

Floor and ceiling trusses are labeled FTR-X 
and use the same numbering convention. 

If two or more  trusses share the same 
configuration with identical chords and 
webbing, they will also share the same truss 
label. 

Mixing Trusses with Stick Framing
After the trusses for your roof are in place, 
the Build Framing dialog can be used to 
create roof framing in areas not framed by 
the trusses. See “Mixing Rafters and 
Trusses” on page 439.

The framing produced is extended or 
truncated where it encounters a truss. The 

exception to this truncation is that hip ridges 
and common rafters at the end of a hip roof 
can pass over a drop hip truss. 

Lookouts at a gable end are modeled to pass 
over a truss at the gable and end at the next 
truss in. Both standard and hip ridges are 
chopped into blocking between the trusses.

Hip Trusses
A variety of different hip truss configurations 
can be created, including: 
•      Step Down Hip trusses
•      Drop Hip or California Hip trusses
•      Subgirder Hip trusses 

Step Down Hip
Step Down hip roofs are the quickest style of 
hip truss framing to produce. 

To create a step down hip truss system 

1. First, draw a Roof Truss  at the apex 
of the triangular hip roof plane. When 

Object Snaps  are enabled, it will 

snap into position. See “Object Snaps” 
on page 110.

2. Select the truss; click the Transform/

Replicate Object  edit button; and 
create enough copies of the truss in the 
direction of the hip to reach a reasonable 
minimum height. See “Transform/Repli-
cate Object Dialog” on page 166. 

3. Using the Roof Truss  tool, draw hip 
jacks along the hip ridge from the last 
truss out into the overhang.

4. Using the Roof Truss  tool, draw a 
jack truss from the intersection of the 
last hip truss and the hip jack to the eave. 

5. Select the jack truss; click the 

Transform/Replicate Object  edit 



476

Home Designer Pro 2014 Reference Manual

button; and lay out jack trusses up to the 
other hip jack.

Drop Hip or California Hip
A Drop Hip, or California Hip, system uses 
trusses with lowered top chords to support 
stick frame hip ridges and common rafters. 

To create a drop hip truss system

1. Start a drop hip truss system as you 
would a step down hip system.

2. When the hip trusses are drawn, group 
select them, open the Truss 
Specification dialog, and select the 
Drop Hip Truss check box. See “Gen-
eral Tab” on page 480.

3. Use the Build Framing dialog to pro-
duce the common rafters, and the short 
joists at the hip end. See “Build Framing 
Dialog” on page 443.

The amount that the top chord is lowered is 
derived from the rafter Depth on the Roof 
tab of the Framing Defaults dialog. Because 
both common rafters and hip ridges must 

pass over this truss, the ridge depth should be 
set equal to that of the rafter depth. 

Subgirder Hip
Subgirders are the partial trusses that butt 
into the doubled truss at the end of the main 
run. 

To create a subgirder truss system

1. Draw a Roof Truss  where the hip 
apex meets the ridge.

2. Double it by drawing a second truss on 
the far side from the hip section. 

3. Using the Roof Truss  tool, draw the 
first subgirder from the hip apex out to 
the eaves. 

4. Select it and use the Transform/

Replicate Object  edit button to 
make copies in both directions. Stop 
when the height of the subgirders reach 
a reasonable minimum.

5. Finish off with hip jacks and jack trusses 
as in a step down hip system.

Special Roof Trusses
A number of special purpose roof trusses can 
be created in Home Designer Pro. 

Energy Heels
To provide more space for ceiling insulation 
at the exterior walls, roofs are sometimes 

raised off of the top plate with an energy 
heel. To create a truss with an energy heel, a 
vertical member is added over the supporting 
wall and the bottom chord stops there rather 
than extending into the overhang. 
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To create an energy heel

1. In the Build Roof dialog:
•  Check Trusses (no Birdsmouth);
•  Uncheck Automatic Birdsmouth Cut;
•  Specify the desired energy heel height 

as a positive Raise Off Plate value.
2. Automatically generate or manually 

draw the roof planes.
3. Draw and position the first truss. See 

“To draw and replicate trusses” on page 
471. 

4. Open this truss’s specification dialog 
and check Energy Heel and Force 
Truss Rebuild, then click OK. See 
“Roof Truss Specification Dialog” on 
page 479. 

5. Use the Transform/Replicate Object  
edit tool to replicate the truss as needed. 

Attic Trusses
Attic trusses, a variation of roof trusses, can 
be drawn if a plan contains an Attic area on 
both sides and above an upstairs room, such 
as in a Cape Cod style home. The following 
is a typical cross section view of a building 
with attic trusses:

Certain conditions must be met before an 
attic truss can be built: 
• The structure should be sufficiently wide 

to allow for a loft and attic spaces.
• The loft area must be on a living floor. It 

cannot be on the Attic floor. See “The 
Attic Floor” on page 327.

• The loft area must have Attic rooms on 
both sides. See “Room Types” on page 
234.

• The loft area must be separated from the 
Attic rooms on both sides by Knee Walls. 
See “Knee Walls” on page 206.

• A flat ceiling in the loft area and a floor 
below must be present. 

• The roof pitch must be steep enough to 
provide appropriate ceiling height for the 
loft area. Typical pitches for such a condi-
tion are 8 in 12 or greater.

• The roof should bear on the walls of the 
floor below the loft area and form contin-
uous planes from ridge to baselines.

Once these conditions are met, a roof truss is 
ready to be designated as an attic truss. 

1. Select the roof truss in floor plan view 

and click the Open Object  edit 
button to display the General tab of the 
Roof Truss Specification dialog. 

Energy Heel

No Energy Heel
 Flat ceilings

 Knee walls
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2. Select the Attic Truss check box and 
click OK. See “Roof Truss Specification 
Dialog” on page 479.

Ceiling Steps
If a roof truss is drawn across areas with 
different ceiling heights on the top floor of a 
plan, the bottom chord will automatically 
step to accomodate those ceiling heights.

In addition, a roof truss can be made to 
recognize ceiling heights on two different 
floors: one on the top floor of the structure 
and one on the floor below. 

To create a ceiling step

1. The area in which the step is to be pro-
duced must be a separate room specified 
as an “Attic”. See “Room Types” on 
page 234.

2. Select the roof truss in floor plan view 

and click the Open Object  edit 
button to display the General tab of the 
Roof Truss Specification dialog. 

3. In the Ceiling Step field, specify the dis-
tance that the bottom chord must step 
down to locate the ceiling platform of 
the room beneath the Attic.

•  If the Ceiling Step value will place the 
bottom of the stepped bottom chord 
within the ceiling platform, a step will 
be created to the bottom of the ceiling 
platform.

•  Check Force Truss Rebuild, then click 
OK to regenerate the truss.

4. Use the Transform/Replicate Object  
edit tool to replicate the truss within the 
area of the roof plan requiring a step. 

For best results, you may want to make sure 
that the Bottom Chord is the same depth as 
the ceiling platform framing. See “Structure 
Tab” on page 245.

Scissors Trusses
Trusses drawn between roof planes and 
sloping ceiling planes of a different pitch 
than the roof are called  Scissor trusses. See 
“Ceiling Planes” on page 379.

The following is an example of a scissors 
truss drawn beneath a 8 in 12 pitch gable roof 
and above 4 in 12 pitch ceiling planes. 

Girder Trusses
Girder trusses provide support for trusses 
that are cut short, for example, by a reverse 
gable or a skylight. They are often doubled- 
or tripled-up for strength. 

Draw a new truss from an existing truss to 
the roof edge, as you would to draw a hip or 
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end jack truss; or draw a truss between two 
trusses, forming a girder. This may be 
necessary for a large opening, such as a 
skylight.

Trusses cannot be drawn through each other. 
If a truss is drawn through an existing truss, 
the program automatically shortens it so that 
it butts into the existing truss.

Roof Truss Specification Dialog
Select a roof truss or group of roof 
trusses and click the Open Object edit 

button to open the Roof Truss Specification 
dialog. 

The Roof Truss Specification dialog allows 
you to redefine parts of an existing truss or 
group of trusses. Some settings affect only 
individual trusses, such as gable trusses, 
while others affect the whole group.
The shape or volume of a roof truss is 
controlled by the roof planes above it and the 
ceiling planes below it. It cannot be changed 
from this dialog.
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General Tab

Specify the Depth of the different 
members that form the selected truss.

• Specify the depth of the Top Chord.
• Specify the depth of the Bottom Chord.
• Specify the depth of the Webbing.

Specify the structure of the selected 
truss.

• Check Require Kingpost to require a 
vertical webbing member from the roof 
peak to the bottom chord.

If Require Kingpost is unchecked, a kingpost 
may still be supplied, depending on the truss 
length and the specified maximum spans. 

• Check End Truss to replace the webbing 
with vertical members positioned and 
spaced the same as the wall studs below.

If an End Truss is in the same position as a 
gable attic wall, it replaces the framing that 
would otherwise be produced for that wall.
• Check Drop Hip Truss to lower the flat 

top of a truss in the hip area of a roof so 
that common rafters and hip ridges can 
pass over and be supported by it. See 
“Drop Hip or California Hip” on page 
476.

• Check Energy Heel to model remove the 
bottom chord from the overhang area. For 
an energy heel to be modeled, the roof 
should also be raised off the top plates by 

1
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3

4
5
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Kingpost

End Truss with vertical supports
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at least 7”, depending on the roof pitch. 
See “Energy Heels” on page 476. 

• Check Reduce Gable to lower the top 
chord of an End Truss so that lookouts 
can pass over the truss. Reduced trusses 
do not have overhangs, but you can draw 
short rafters drawn at the ends of the truss.

• Check Attic Truss to specify an attic 
truss. See “Attic Trusses” on page 477. 

Specify the Maximum Span, which is 
the maximum horizontal distance 

between supports along the Top Chord and 
the Bottom Chord. When these values are 
equal, the truss webbing often appears more 
regular.

The default Maximum Span settings are set 
in the Build Framing dialog. See “Trusses 
Tab” on page 453. 

Specify the Thickness, or truss width 
in floor plan view. This setting 

overrides default settings. 

Specify the Maximum Height of the 
selected truss.

Specify the Ceiling Step of the selected 
truss, which is the maximum distance 

its bottom chord can step down to locate a 
ceiling on the floor below the top floor. See 
“Ceiling Steps” on page 478.

Specify special truss behaviors.
 

• Check Force Truss Rebuild to rebuild 
the truss envelope based on the current 
state of the ceiling and roof when you 
click OK. Not available if Lock Truss 
Envelope is checked. 

• Check Lock Truss Envelope to lock the 
size and configuration of the selected 
truss. If a locked truss is moved, it will 
maintain its original settings and will not 
fit properly if the new roof and ceiling 
conditions are different from the original.

• Check No Special Snapping to prevent 
the selected truss from snapping along its 
long edge to a wall’s Main Layer or to the 
corner of a roof plane. If enabled, Object 

Snaps  may still occur. See “Object 
Snaps” on page 110.

Energy Heel

No Energy Heel

Reduce Gable 
End Truss

Lookouts

3

Truss webbing is drawn for representa-
tional purposes only and as with trusses

in Home Designer Pro in general, is not engi-
neered.

4

5

6

7
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Line Style Tab
The settings on this tab affect the appearance 
of the selected truss in floor plan view only. 
See “Line Style Tab” on page 781.

Fill Style Tab
The settings on this tab affect the appearance 
of the selected truss in floor plan view. See 
“Fill Style Tab” on page 792.

Materials Tab
The settings on the Materials tab affect the 
appearance of the selected truss in 3D views. 
See “Materials Tab” on page 635.

Floor/Ceiling Truss Specification Dialog
To open the Floor or Ceiling Truss 
Specification dialog, select a floor 

truss in floor plan view and click the Open 
Object edit button. See “Floor and Ceiling 
Trusses” on page 470. 

Default values for trusses are set in the Build 
Framing dialog. See “Trusses Tab” on page 
453. 

General Tab

Specify the Depth of the different 
members that form the selected truss.

• Specify the depth of the Top Chord.
• Specify the depth of the Bottom Chord.
• Specify the depth of the Webbing.

Check Vertical Supports to use 
vertical supports in the selected truss. 

Specify the Maximum Span, which is 
the maximum horizontal distance 

between supports along the Top & Bottom 
Chord. 
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Specify the Overall Thickness of the 
selected truss.

Specify the Webbing Thickness 
thickness of the webbing. 

Check Force Truss Rebuild to rebuild 
the truss envelope based on the existing 

floor or ceiling platform when you click OK. 
Not available if Lock truss envelope is 
checked, below. 

Check Lock Truss Envelope to lock 
the size and configuration of the truss. 

A locked truss which has been relocated will 
maintain its original settings.

Line Style Tab
The settings on this tab affect the appearance 
of the selected truss in floor plan view only. 
See “Line Style Tab” on page 781.

Fill Style Tab
The settings on this tab affect the appearance 
of the selected truss in floor plan view. See 
“Fill Style Tab” on page 792. 

Materials Tab
The settings on the Materials tab affect the 
appearance of the selected truss in 3D views. 
See “Materials Tab” on page 635.

Top Chord Vertical Support

Bottom Chord Webbing

4

5
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Chapter 18:

Electrical

The electrical plan shows the location of all 
electrical objects such as lights, switches, 
outlets, smoke detectors and vent fans. Basic 
wiring diagrams show which objects share 
circuits and the locations of the controlling 
switches.

Electrical objects can be displayed in 2D and 
3D views. Some electrical light fixtures also 
add light sources to 3D views. See 
“Lighting” on page 699.

Usually, the electrical plan is one of the last 
additions to a plan since the position of most 
electrical objects is determined by the 
location of walls, cabinets and other objects.

Chapter Contents
•      Electrical Defaults
•      The Electrical Tools
•      Creating Wiring Schematics
•      Auto Place Outlets
•      Electrical Library
•      Displaying Electrical Objects
•      Editing Electrical Objects
•      Electrical Service Specification Dialog

Building requirements vary throughout
the country and around the world. It is

your responsibility to comply with local codes.
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Electrical Defaults
Default Settings for electrical objects 
control which symbols are placed in 

the current plan when the Electrical Tools are 
used and can be accessed by selecting Edit> 
Default Settings from the menu or by 

double-clicking the Electrical Tools  
button. See “Default Settings” on page 56.

Default heights of individual objects can be 
overridden in the Electrical Service 
Specification dialog. See “Electrical Service 
Specification Dialog” on page 492. 

Default Library Objects - These are 
the items used when electrical objects 

are created or automatically generated using 
the Electrical Tools. Select an item in the 
scrollable list to see a preview image to the 
right and the symbol’s name below.

Select an item in the Default Library 
Objects list and click the Library 

button to select a new default object from the 
library. See “Select Library Object Dialog” 
on page 622.

Symbol Name - The name of the object 
shown in the preview image displays 

here.

Default Heights - Specify the heights 
at which electrical outlets and switches 

are initially placed.
• Check Use Default Heights to apply the 

default heights specified here to electrical 
objects placed directly from the library in 
floor plan view. See “Placing Library 
Objects” on page 620. 

• Outlet - Specify the default height for 
outlets, and phone, cable and tv jacks.

1
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• Switch - Specify the default height for  
switches, doorbells and thermostats.

• Above Cabinet - Specify the default 
height for switches and outlets placed 

above most cabinets in floor plan view, as 
measured from the countertop. See 
“Adjusting the Height of Electrical 
Objects” on page 491.

The Electrical Tools
Select Build> Electrical to access the 
Electrical Tools. 

Click in floor plan view to place an electrical 
object. Some can only be placed against 
walls, some only on the ceiling or floor, and 
some automatically change as needed. If you 
click within 12" of the wall, the selected 
object is placed on the wall. 

Electrical objects are placed according to the 
settings in the Electrical Defaults dialog.

Once an electrical object has been placed, it 
can be edited in the Electrical Service 
Specification dialog. See “Electrical Service 
Specification Dialog” on page 492.

Outlets
Select Build> Electrical> 110V 
Outlet to place 110 volt duplex 

outlets in walls or on the floor. Select Build> 
Electrical> 220V Outlet to place 220 volt 
outlets. 

Certain room types and situations cause 
various types of outlets to be placed. For 
example:
• In rooms defined as Kitchen, Bath or 

Master Bath, Ground Fault Circuit Inter-
rupt (GFCI) outlets are placed. 

• Outlets placed on the wall behind a base 
cabinet containing a dishwasher or sink 
are placed at the normal 12" (300 mm) 
above the floor. If an outlet is placed 
above a cabinet, the default Above Cabi-
net Default Height is used instead. 

• Outlets placed outside the building or in 
an exterior area such as a deck or porch 
are labeled WP, or Water Proof.

To take advantage of the program’s 
capabilities, define room types properly 
before placing electrical objects. See “Room 
Types” on page 234.

Light Fixtures
Select Build> Electrical> Light to 
place light fixtures as specified in the 

Electrical Defaults dialog. All light fixtures 
placed in a plan can also serve as light 
sources in most 3D views. To place a light 
fixture using the Light tool
• Click near a wall to place a wall-mounted 

fixture at that location. 
• Click away from a wall to place a ceiling 

mounted light. 

If standard outlets are placed in a room
prior to defining it as a Kitchen or Bath,

you should replace them with GFCI outlets.
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• Some light symbols from the library can 
be mounted under wall cabinets, as well. 

The rendering characteristics of individual 
lights that control how they appear in Render  
views can be specified on the Light Data tab 
of the Electrical Service Specification 
dialog. See “Light Data Tab” on page 493.

Switches
Select Build> Electrical> Switch to 
place electrical switches as specified 

in the Electrical Defaults dialog. Like 
outlets, the height of switches is measured 
from the floor to the center of the object.

An electrical switch can be placed on either a 
wall or a cabinet, depending on the type of 
switch. A selection of each type is available 
in the Library Browser. See “Placing Library 
Objects” on page 620.

Switches placed from the Electrical Library 
do not automatically update by default, but 
can be specified to do so. See “Electrical 
Service Specification Dialog” on page 492.

Lighting and Electrical 
Libraries

A selection of free-standing and 
ceiling-, wall- and cabinet-mounted 

light fixtures is available in the Library 
Browser at Home Designer Core Catalogs> 
Architectural> Lighting. 

Special use outlets, switches, jacks and 
numerous other electrical items can be found 
at Home Designer Core Catalogs> 
Mechanical, Electrical, Plumbing> 
Electrical. See “The Library” on page 603. 

Creating Wiring Schematics
Electrical schematics can be created in two 

ways. Using the Connect Electrical  tool 
is quick and easy, but if you need detailed 
schematics, you can create your own wiring 
diagrams using the CAD tools.

Connect Electrical
Select Build> Electrical> Connect 
Electrical to illustrate circuits. Using 

this tool, you can show which lights and 
outlets are attached to any given switch. 

To create a new circuit or to add to an 
existing circuit, click one electrical object 

while using Connect Electrical  tool, 
drag to the next object and release. You can 
also draw electrical circuits using the 

Alternate  continuous drawing mode. 
See “Alternate” on page 121. 

Remove an electrical object from a circuit by 

selecting it and clicking the Delete  edit 
button. See “Deleting Objects” on page 171.

More than one switch can control an object 
or group of objects. Two switches controlling 
the same objects are referred to as three-way 
switches. Three switches controlling the 
same objects are called four-way switches. 

If you connect two or more switches in a
circuit, they update to 3-way or 4-way

switches automatically.
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The number of “ways” is one more than the 
number of switches in the same circuit. This 

number displays with the switch symbol in 
floor plan view.

Auto Place Outlets
Select Build> Electrical> Auto Place 
Outlets and click in a room tool to 

place outlets, usually 110 volt, around the 
entire room at intervals not greater than 
twelve feet so that no wall position is farther 
than six feet (1800mm) from the nearest 
outlet. 

Outlets are placed based on settings in the 
Electrical Defaults dialog. See “Electrical 
Defaults” on page 486. It is important that 
the room type be defined before using Auto 

Place Outlets  so that outlets are placed 
appropriately in each room type. For 
example, GFCI (Ground Fault Circuit 
Interrupter) outlets are placed over cabinets 
in Kitchen, Bath and Master Bath rooms 

Stand-alone or built-in appliances such as 
ranges, washers, and dryers each have their 
required 110 volt or 220 volt outlets placed 

automatically. Lights are always placed 
above sinks.

Auto Place Outlets  requires a room to 
have a door before outlets are automatically 
placed and does not work in any room 
defined as an exterior room. Exterior rooms 
require that the outlets be placed individually 

using the 110V Outlets  tool or from the 
Electrical Library. See “Room Types” on 
page 234.

Railings and invisible walls do not separate 

rooms for Auto Place Outlets : If Auto 

Place Outlets  is used in a room defined 
by railings or invisible walls, outlets are 
automatically placed in all adjacent rooms 
that share these wall types with that room.

Any outlet can be moved, deleted, or merged 
with other outlets or switches. See 
“Switches” on page 488.

Electrical Library
Select Library> Library Browser to 
accesses a variety of electrical 

symbols. See “The Library” on page 603.

Browse for electrical objects such as bath 
vent fans, an electrical panel, fluorescent 
lights, chandeliers, a smoke detector, 
thermostat, and more. Select a symbol, then 

click in your plan to place it on a wall, floor, 
or ceiling.

You can also assign electrical objects from 
the library to toolbar buttons for easy access 
and placement to frequently-used library 
objects. See “Place Library Object Button” 
on page 623.
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Displaying Electrical Objects
The display of electrical objects and 
connections is controlled in the Layer 

Display Options dialog. See “Displaying 
Objects” on page 102.

When displayed in 3D views, light fixtures 
act as sources of light that help illuminate the 
3D model. See “Lighting” on page 699.

Electrical Labels
Electrical labels display in floor plan view 
when the “Electrical, Labels” layer is turned 
on. Electrical labels use the Text Style 
assigned to their layer. See “Object Labels” 
on page 884.

Customized labels using text as well as label 
position and orientation can be specified in 
the Electrical Service Specification dialog.

In the Materials List
Electrical objects, including outlets, 
switches, lights, and symbols from the 
library such as jacks and fans, are listed 
under the Electrical Category in the 
Materials List. See “Materials Lists” on page 
887. 

Editing Electrical Objects
Electrical objects can be selected as a group 
and individually in 2D and 3D and edited 
using the edit handles, the edit toolbar and 
their specification dialog. See “Electrical 
Service Specification Dialog” on page 492. 

Light fixtures and Added Lights can be 
group-selected, but their light data cannot be 
edited unless they have the same number of 
light sources associated with each. See 
“Lighting” on page 699.

Lights can also be edited using the Adjust 
Lights dialog. See “Adjust Lights Dialog” on 
page 704.

Moving Electrical Objects 
Using Dimensions

Electrical objects can be moved precisely 
using manual dimensions. See “Moving 
Objects Using Dimensions” on page 737. 
First, dimensions must be checked on the 
Locate Objects tab of the Dimension 
Defaults dialog. See “Dimension 
Preferences and Defaults” on page 719.

Using the Edit Handles
The edit handles for electrical objects vary 
depending on the location of the object. Wall 
mounted electrical objects cannot be rotated, 
so only the Move edit handle displays.

Note: Some electrical objects are repre-
sented in floor plan view by a symbol that
includes text. This text is not part of the
object’s label and does not use the Text Style
assigned to the “Electrical, Labels” layer. 
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Electrical objects placed on floors and 
ceilings can be rotated.

Electrical connections edit like splines. See 
“Editing Spline Based Objects” on page 144.

Using the Edit Buttons
A selected electrical symbol can be edited in 
a variety of ways using the buttons on the 
edit toolbar. See “The Edit Toolbar” on page 
29.

Adjusting the Height 
of Electrical Objects

The heights where electrical objects display 
in 3D views are initially based on settings in 
the Electrical Defaults dialog. See 
“Electrical Defaults” on page 486.

In floor plan view, an outlet placed where a 
base cabinet meets a wall is placed above the 
counter unless the cabinet contains a fixture 

or appliance other than a bathroom sink. If 
the fixture requires electricity, the outlet 
remains behind the cabinet at normal wall 
height, where it can supply power to the 
fixture or appliance. 

Kitchen sinks are assumed to require 
electricity since they often contain a garbage 
disposal. Dishwashers are not considered to 
require electricity since they are usually 
plugged in under a nearby sink. If an outlet is 
needed above a cabinet containing a kitchen 
sink, place the outlet before adding the sink, 
or move the outlet up.

To change the height of an electrical object in 
floor plan view, open the object for 
specification and type the desired height in 
the Electrical Service Specification dialog. 
See “Electrical Service Specification Dialog” 
on page 492.

Electrical objects placed in 3D views are 
placed wherever you click a wall, regardless 
of the height. In 3D views, the position of an 
electrical object can be adjusted using its edit 
handles.

Deleting Electrical Objects
An electrical object can be deleted by 

selecting it and clicking the Delete  edit 
button or by pressing the Delete key.

All electrical objects in a room, on a floor, or 
in the entire plan can be deleted as a group 
using the Delete Objects dialog. See 
“Deleting Objects” on page 171.

Wall-mounted outlet in 2D and 3D views
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Electrical Service Specification Dialog
Select one or more electrical objects 
and click the Open Object edit button 

to open the Electrical Service Specification 
dialog. The settings in this dialog vary, 
depending on the type of object(s) you select.

The Electrical Service Specification dialog 
consists of four tabs: 
• The General Tab specifies the location of 

the selected electrical object(s). 

• The Light Data Tab specifies how lights 
appear in rendered views.  Not available 
for switches or outlets. See “Lighting” on 
page 699. 

• The Materials Tab allows you to change 
materials on electrical objects. 

• The Label Tab lets you specify the 
selected object’s label. 

General Tab
The items on this tab vary, depending on the 
type of electrical object selected.

The Name of the selected object as 
used in the Library Browser and 

Materials List displays here.

1
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Specify the Position of the selected 
electical symbol. The options available 

depend on the type of electrical symbol 
selected.
• Specify the Offset From Ceiling of a 

ceiling outlet or ceiling mounted light. If 
the light is mounted to a cabinet, this 
value is the offset from the cabinet.

• Specify the Height to Center of a 
switch, wall outlet or wall light. 

• Specify the Offset From Floor of a floor 
outlet or floor lamp. 

• Specify the Distance From Wall of a 
wall mounted symbol. A negative value 
will recess the symbol into the wall and 
may prevent it from being seen in 3D. 

Specify the Size of the selected 
electical symbol. 

• Specify the Height, Width and Depth of 
the selected symbol. 

• Click the Reset button to restore the elec-
trical symbol’s original size 

Check Automatically Change Switch 
Type When Wiring for a selected 

switch to become a three- or four-way switch 
if your wiring plan later uses it as such. See 
“Connect Electrical” on page 488. Switches 
placed from the toolbar use this option by 
default; switches placed from the library do 
not. Only available for switches. 

Light Data Tab
The Light Data tab is available when the 
selected electrical object is a light fixture. 
The available options vary depending on the 
type of light selected.

The settings on this tab are similar to those 
on the same tab of the Light Specification 
dialog. See “Light Specification Dialog” on 
page 706.

2 3

4
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The currently selected Light Source 
displays here. Each fixture can have 

multiple light sources. Not available for 
Added Lights. See “Lighting” on page 699.
• Select an existing Light Source 

associated with the selected light fixture 
from the drop-down list . 

• Click Add Light or Delete Light to add 
or delete light sources from the list. If the 
selected fixture has only one light source, 
Delete Light will not be available.

Select a light Source Type from the 
drop-down list for the currently 

selected Light Source. The type selected 
determines what options are enabled on this 
tab. See “Light Types” on page 705. 

Select an Intensity from the drop-down 
list. The available options are described 

using lumens and correspond to commonly 
used light bulb wattages. 
• Select “Custom” from the list to open the 

Custom Light Intensity dialog and 
create a custom Intensity setting. See 
“Custom Light Intensity Dialog” on page 
495.

Click the Color bar to define the color 
of the selected light source. Colored 

lights alter the appearance of textures and 
can be used to achieve special effects. See 
“Color Chooser Dialog” on page 651. 

The default color of light is pure white, 
which has the least affect on the appearance 
of material colors and textures.

Specify the direction and drop off rate 
of a Parallel or Spot Light source. Not 
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available when the selected Source Type is 
Point Light. 
• The Tilt Angle controls the angle of the 

illumination with respect to the horizon. 
A value of -90° points the light straight 
down and a value of 90° points it straight 
up. 0° is parallel to the horizon.

• The Direction Angle defines the 
direction of the illumination relative to 
the ground. 0° is measured horizontally 
pointing to the right. Positive values 
rotate in a counter-clockwise direction 
from there. Enter a value up to 360°. If 
you enter a negative value, the program 
adds 360° to it when you click OK or 
press the Tab key.

• The Cut Off Angle controls the angle of 
the cone of illumination for Spot Lights 
only. A cone angle of 180° creates a spot 
light that shines in a half sphere on one 
side of the light source. A small cone 
angle, for example 10°, creates a very 
narrow cone of light. The cut off angle 
should always be between 0° and 180°. 

• The Drop Off Rate affects how fast the 
intensity of illumination drops off from 
the center of the cone to the outside edge. 
This is only available for Spot Lights.

The default drop off value is 7.5, which 
means the light drops off fairly quickly. 
Do not set this value too low because 
there are limitations in the OpenGL 
lighting model that result in jagged 
circles of light when they are shining on 
large flat surfaces. Appearances can be 
improved by decreasing the Maximum 

Triangle Size and increasing the Drop off 
Rate.

Offset Position gives you control over 
the location of the light source relative 

to the fixture.  
• From Base controls how far the light 

source is from the fixture base. The 
fixture base is determined by the surface 
that it is attached to (i.e. wall, floor, or 
ceiling). 

• Offset in X/Offset in Y allow you to 
position the light source relative to the 
center of the fixture, along the floor/
ceiling.

Additional display options are available 
here.

• Check On to use the light source is used 
in camera or ray trace views, or uncheck 
it if you prefer that the light source not be 
used. See “Lighting” on page 699. 

• Casts Shadows controls whether or not 
the light source casts shadows in Final 
Views with Shadows. See “Previews vs 
Final Views” on page 698. 

• Check Show Position in Camera View 
to indicate the position of a selected Point 
or Spot Light source in 3D views when it 
is turned On. This tool can be used to 
determine if your light source is 
positioned correctly.

Custom Light Intensity Dialog
Select “Custom” from the Intensity drop-
down list on the Light Data tab to open the 
Custom Light Intensity dialog. 

6
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• Intensity - Use the sider bar or text field 
to control how bright the light appears in 
camera views.

• Check Auto Adjust Intensity to have the 
program to scale the Intensity depending 
on the number of lights in the room. 
When unchecked, the Intensity set here is 
used. 

• Check Attenuated to control how 
quickly a light source’s  intensity drops as 
its distance from the light source 
increases. When unchecked, the light 
does not drop off. Only Spot and Point 
Lights have attenuation.

The three Attenuated values represent the 
three coefficients (a, b, and c) in the 
expression 1 / (a + b*d+c*d*d), where d is 

the distance from the light source. Increasing 
any of these values results in the light 
intensity dropping faster (the light does not 
travel as far). Decreasing any value results in 
the light intensity dropping slower (the light 
travels farther). Small changes in these 
coefficients can have significant impact on 
lighting effects. You may need to experiment 
to fully understand how to use them.

Materials Tab
The Materials tab is found in the 
specification dialogs for a variety of objects. 
For more information, see “Materials Tab” 
on page 635.

Label Tab
Labels for electrical fixtures display when 
the “Electrical, Labels” layer is turned on 
and use the Text Style assigned to that layer. 
See “Electrical Labels” on page 490. 

For information about the settings on this 
tab, see “Label Tab” on page 885.



 497

Chapter 19:

Trim & Molding

The Trim Tools allow you to place corner 
boards and quoins at wall intersections that 
form corners. 

You can also assign moldings to a variety of 
objects, such as rooms and cabinets, in those 
objects’ specification dialogs. See 
“Specification Dialogs” on page 31.

Chapter Contents
•      Trim and Molding Defaults
•      Corner Boards
•      Corner Board Specification Dialog
•      Quoins
•      Quoin Specification Dialog
•      Editing Corner Boards and Quoins
•      Millwork
•      Moldings Tab
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Trim and Molding Defaults
Select Edit> Default Settings to open 
the Default Settings dialog where 

you can access the defaults for a variety of 
drawing tools, including a number that affect 
trim and moldings. 
• Click the + beside “Corner Trim” to 

access the defaults for Corner Boards and 
Quoins. See “Corner Boards” on page 
498 and “Quoins” on page 500. 

• Select “Floor” and click the Edit button 
to specify the default moldings for rooms 
on the current floor. See “Floor Defaults” 
on page 230. 

• Click the + beside “Door” ” to access the 
defaults for Interior and Exterior Doors. 
See “Door Defaults” on page 253. 

• Select “Window” and click the Edit but-
ton to specify the default casing for win-
dows. See “Window Defaults” on page 
280.

• Click the + beside “Cabinet”to access the 
defaults for the Cabinet Tools, where you 
can specify default crown and other 
moldings. See “Cabinet Defaults” on 
page 507.

Corner Boards
Corner boards are added to a building 
exterior in any view by selecting 

Build> Trim> Corner Boards.

Click at a wall corner where you want to add 
trim. Be sure to click where the outside wall 
surfaces meet. If you click where the inside 
surfaces meet, corner trim will be created 
inside the room.

You can also add Corner Boards to all 
exterior corners at once by selecting Build> 

Trim> Auto Place Corner Boards .

By default, Auto Place Corner Boards  
adds Corner Boards to outside corners only. 
If you prefer, you can specify that inside 
corners receive corner boards in the Corner 
Board Defaults dialog. See “General Tab” 
on page 499.

Note: The Auto Place Corner Boards tool
does not place corner boards on manually
drawn dormers or at intersections with Attic
Walls. See “Attic Walls” on page 206.

Inside Corner

Outside Corners
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Corner boards extend from the top plate 
down to the bottom of the floor platform of 
the floor on which it is placed, but do not 
extend to other floors. You must add corner 
boards to all floors of the building that you 
want to have corner boards. 

A selected corner board or boards can be 
moved, but only to another wall corner or 
corners.  In 3D views, corner boards can be 

lengthened or shortened using the edit 
handles. Corner boards can be copied, 
deleted and resized similar to other objects 
using the edit toolbar or  the Corner Board 
Specification dialog. 

The default material for corner boards is 
defined by the Exterior Trim entry in the 
Material Defaults dialog. See “Material 
Defaults” on page 650.

Corner Board Specification Dialog
Select one or more corner boards and 
click the Open Object edit button to 

open the Corner Board Specification 
dialog.

The settings in this dialog are similar to those 
in the Corner Board Defaults dialog, but 
affect the selected corner boards rather than 
all subsequently created corner boards. 

General Tab

Specify the Width and Thickness of 
the selected corner board(s).

Check Set Top/Set Bottom to specify 
the top and bottom heights of the corner 

board(s). 
• If Set Top is unchecked, the top of the 

corner board automatically extends to the 
top plate.

• If Set Bottom is unchecked, the bottom 
of the corner board automatically extends 
to the bottom of the floor platform.

In the Corner Board Defaults dialog, an 
additional Auto Place Option is available.
• Check Include Inside Corners to place 

Corner Boards on inside corners when 

the Auto Place Corner Boards  tool 
is used. When unchecked, only outside 
corners receive corner boards. 

1
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Materials Tab
The settings on the Materials tab are 
available for a wide variety of objects in the 
program. For information about these 
settings, see “Materials Tab” on page 635.

Quoins
Select Build> Trim> Quoins in any 
view and click at a wall corner where 

you want to place quoins. 

You can also add Quoins to all exterior 
corners at once by selecting Build> Trim> 

Auto Place Quoins .

By default, Auto Place Quoins  adds 
Quoins to outside corners only. If you prefer, 
you can specify that inside corners receive 
quoins in the Quoin Defaults dialog. See 
“General Tab” on page 499.

A selected quoin or quoins can be moved, 
but only to another wall corner or corners. In 
3D views, quoins can be lengthened or 
shortened using the edit handles. Quoins can 
be copied, deleted and resized similar to 
other objects using the edit toolbar or  the 
Quoin Specification dialog. 

The size of quoins in floor plan view is 
relative on their size in 3D.

Initially, quoins use the same material as the 
default material of the wall surface they are 
placed against. This material is specified in 

Inside Corner

Outside Corners

Note: The Auto Place Quoins tool does not
place quoins on manually drawn dormers or
at intersections with Attic Walls. See “Attic
Walls” on page 206.

Inside Corner

Outside Corners
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the Wall Type Definitions dialog. See “Wall 
Specification Dialog” on page 214.

Quoin Specification Dialog
Select one or more quoins and click 
the Open Object edit button to open 

the Quoin Specification dialog.

The settings in this dialog are the same as 
those in the Quoin Defaults dialog, but 
affect the selected quoins rather than all 
subsequently created quoins.

General Tab

Specify the dimensions of the quoins in 
the selected Quoin object. 

• Specify the Width, which is the long 
dimension of each quoin in the selected 
Quoin object. The dimension along the 
other wall is half this value when they are 
staggered or mirrored.

• Specify the Thickness, which is the 
amount that the quoin protrudes from the 
exterior surface of the wall.

• Specify the Quoin Height for individual 
quoins in the selected Quoin object.

• Specify the Quoin Gap, which is the dis-
tance between successive quoins.

Check Set Top/Set Bottom to specify 
the top and bottom heights of the 

quoin(s) in the text fields. 
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• If Set Top is unchecked, the top of the 
corner board automatically extends to the 
top plate.

• If Set Bottom is unchecked, the bottom 
of the quoin automatically extends to the 
bottom of the floor platform.

Specify the arrangement of quoins used 
by the selected Quoin object(s). 

• Uniform - Produce quoins that are of 
equal length on both sides of the corner.

• Staggered - Produce quoins that have 
one long side and one short side stag-
gered on opposite sides of the corner.

• Mirrored - Produce quoins that alternate 
having either two long sides or two short 
sides.

• When Staggered or Mirrored is selected, 
check Swap Start Block to switch the 
starting order for the quoins. 

In the Quoin Defaults dialog, an additional 
Auto Place Option is available.
• Check Include Inside Corners to place 

Quoins on inside corners when the Auto 

Place Quoins  tool is used. When 
unchecked, only outside corners receive 
quoins.

Materials Tab
The settings on the Materials tab are 
available for a wide variety of objects in the 
program. For information about these 
settings, see “Materials Tab” on page 635.

3

Staggered
Uniform

Mirrored

Inside Corner

Outside Corners
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Editing Corner Boards and Quoins
Before a corner board or quoin can be edited, 
it must be selected. Click on a trim object 

when the Select Objects  tool is active. 
Corner boards and quoins can also be group 
selected and edited. See “Selecting Objects” 
on page 124

Corner boards and quoins can be edited using 
their edit handles, the edit toolbar buttons, 
and their specification dialogs. 

Using the Mouse
Depending on the type of view, a corner 
board or quoin displays a different set of edit 
handles when selected. 
• In floor plan view, corner boards and 

quoins display one edit handle and can be 
moved from one eligible location at a 
wall corner to another.

• In3D views, corner boards and quoins 
can be moved, lengthened, and shorted 
much the other line-based objects are. 
See “Editing Line Based Objects” on 
page 127. 

Using the Edit Buttons
A selected corner board or quoin can be 
edited in a variety of ways using the buttons 
on the edit toolbar. See “The Edit Toolbar” 
on page 29.

Deleting Corner Trim
Corner boards and quoins can be selected 
individually or in groups and deleted using 

the Delete  edit button or the Delete key 
on the keyboard. They can also be removed 
using the Delete Objects dialog. See 
“Deleting Objects” on page 171. 

Millwork
A selection of various types of millwork 
including columns, corbels and finials is 
available in the Library Browser. See “The 
Library Browser” on page 604. 

Most millwork items can be placed in a plan 
as free-standing objects.  Some items - 
notably, newels and balusters - can be 
assigned to objects such as railings, stairs 
and ramps. See “Placing Library Objects” on 
page 620. 

Moldings Tab
The specification dialogs for a variety of 
objects in the program include a Moldings 
tab. Objects that can have moldings assigned 
to them include rooms, cabinets, and custom 
countertops. 

Select an object or group of similar objects 

and click the Open Object  edit button to 
open the specification dialog for that 
selection. 
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Only available for rooms, uncheck 
Default to make the settings that follow 

active. Check this box to use the defaults set 
in the Floor Defaults dialog for the current 
floor. See “Floor Defaults” on page 230.

A drop-down list of the Molding 
profile(s) assigned to the selected 

object displays here. Select the name of a 
molding to edit it or remove it from the list. 
• If multiple objects with different mold-

ings assigned to them are selected, a No 
Change checkbox will be available just 
above the Molding drop-down list.

Uncheck this box to make the settings 
that follow active but note that only 
moldings that all selected objects have in 
common will be retained. 

Add or remove molding profiles and/or 
symbols from the selected object.

• Click the Add New button to open the 
Select Library Object dialog and add a 
new molding profile or symbol to the list. 
See “Select Library Object Dialog” on 
page 622. 

• Click the Select button to remove the 
selected profile or symbol and replace it 
with a new one from the Select Library 
Object dialog. Only available when a 
profile is already selected.

• Click the Delete button to remove the 
currently selected profile or symbol from 
the list. 

Molding Specification - Specify the 
size and position of the currently 

selected molding.
• Specify the Height of the molding pro-

file. 
• Specify the profile’s Width. 

1
2

3
4

1

2

3

4



Moldings Tab

 505

Define the Offset of the molding relative to 
the object it is assigned to. 
• Specify the offset From Floor of the 

selected molding profile; for objects 
other than rooms, specify the Vertical 
offset. A positive offset moves the mold-
ing upward and a negative offset  moves 
the molding downward.

• Select To Top to specify that the top of 
the molding is offset vertically from the 
top of the object it is applied to. 

• Select To Bottom to specify that the bot-
tom of the molding is offset vertically 
from the bottom of the object it is applied 
to. 

• Choose the currently selected molding’s 
Type from the drop-down list: Base 
Molding, Chair Rail, or Crown Molding. 
Only available for rooms.
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Chapter 20:

Cabinets

With Home Designer Pro’s cabinet tools you 
can create base, wall, and full height cabinets 
as well as soffits, shelves, partitions, and 
custom countertops. These objects are very 
versatile, allowing for a wide range of 
customization. 

A selection of cabinet door and drawer styles 
are available in the Library Browser.

Home Designer Pro also has many 
customized cabinet symbols and cabinet 
groups available in the library.

Chapter Contents
•      Cabinet Defaults
•      The Cabinet Tools
•      Cabinet Fillers
•      Placing Cabinets
•      Custom Countertops
•      Displaying Cabinets
•      Cabinet Labels
•      Editing Cabinets
•      Editing Cabinet Styles
•      Editing Custom Countertops
•      Special Cabinets
•      Cabinet Specification Dialog
•      Cabinet Shelf Specification Dialog
•      Shelf/Partition Specification Dialog
•      Custom Countertop Specification Dialog

Cabinet Defaults
Access default settings for each 
cabinet tool by selecting Edit> 

Default Settings, then clicking the + beside 
Cabinets. Select a subheading and click the 
Edit button to open the defaults dialog 
associated with your selection: 

The Cabinet Defaults dialogs can also be 
accessed by double-clicking the Cabinet 

Tools  parent button. 
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Double-clicking a Cabinet Tools child button 
also opens its corresponding defaults dialog, 
if that object has a defaults dialog.

Each type of cabinet object has default 
definitions for size, style, materials and much 
more. In fact, the default dialog for each 
cabinet type is similar to its corresponding 
specification dialog. For descriptions of 
these settings, see “Cabinet Specification 
Dialog” on page 522, “Shelf/Partition 
Specification Dialog” on page 533 and 
“Soffit Specification Dialog” on page 592.

Custom Countertops do not have defaults 
dialogs. Instead, their initial settings are 
based on the those of other objects. 

• Custom Countertops’ initial settings are 
based on Base Cabinet Default settings 
but are also influenced by the settings of 
cabinets beneath them. See “Custom 
Countertops” on page 510.

Dynamic Cabinet Defaults
The following cabinet default values are 
dynamic: Separation, Backsplash Height 
and Thickness, Countertop Overhang and 
Thickness, Toe Kick Height and Depth, 
Side and Vertical Overlap, Stiles, and  
Hardware spacing. See “Dynamic Defaults” 
on page 57. 

All Materials are also dynamic, with one 
exception: materials assigned to doors and 
drawers when the default door/drawer is a 
library symbol. When this is the case, the 
default door/drawer material is dynamically 
linked to the “Cabinet Door/Drawer” 
material set in the Material Defaults dialog 
rather than the Cabinet Defaults dialog. See 
“Material Defaults Dialog” on page 650. 

When a dynamic default is changed, existing 
cabinet objects using the default value are 
affected.

General Cabinet Defaults
The General Cabinet Defaults dialog can be 
accessed only from the Default Settings 
dialog.
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Specify the Minimum Cabinet Width. The 
minimum allowable width is 1/16 of an inch 
(10 mm). 

Specify how Cabinet Resizing takes place 
when the edit handles are used.

• Select Use Grid Snaps to resize cabinets 
using Snap Grid increments. See “Grid 
Snaps” on page 112.

• Select Use Resize Increment to resize 
cabinets using the increment specified 
here. 

• Set the Resize Increment at which cabi-
nets resize. The minimum allowable 
increment is 1/16 of an inch (10 mm).

Uncheck Show Partial Module Lines to 
display lines between merged cabinet 
modules as specified by the “Cabinets, 
Module Lines” layer. Check this box to 
represent module lines as grey lines that do 
not extend across the cabinets. See 
“Displaying Cabinets” on page 514.

The Cabinet Tools
Select Build> Cabinet to access the 
Cabinet Tools.

Cabinets are easily created with a single click 
in floor plan view or any camera view. See 
“Click-to-Create” on page 113.

Typically, groups of cabinet objects are 
positioned closely together and arranged to 
form work spaces, and there are some special 
behaviors and techniques to be aware of. See 
“Placing Cabinets” on page 512.

Once created, cabinets, soffits, shelves, 
partitions and fillers can be selected and 
edited much like other box-based objects. 
See “Editing Cabinets” on page 517.

Base Cabinets
Select Build> Cabinet> Base 
Cabinet and click in any view. Base 

cabinets can be placed directly under wall 
cabinets and generate a countertop and toe 
kick by default.

Wall Cabinets
To place a wall cabinet, select Build> 
Cabinet> Wall Cabinet and click in 

any view. Wall cabinets can be placed 
directly over base cabinets. 

Full Height Cabinets
To place a full height cabinet, select 
Build> Cabinet> Full Height and 

click in any view. Full height cabinets 
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generate a toe kick by default and cannot be 
placed on top of other cabinets.

Soffits
Soffits typically fill the space between 
cabinet tops and the ceiling, but can 

also be used to create any object that can be 
modeled as a 3D box. To place a soffit, select 
Build> Cabinet> Soffit and click in any 
view.

By default, soffits use the material assigned 
to interior walls in the Material Defaults 
dialog. Like cabinets, soffits can have 
molding profiles applied to them.

For more information about using soffits for 
a variety of purposes, see “Other Objects” on 
page 589.

Shelves
Select Build> Cabinet>  Shelf and 
click in any view to create a shelf. 

Create corner shelves by placing one shelf on 
each wall, then moving or stretching them 
until they touch.

Once created, shelves can be selected and 
edited. See “Shelf/Partition Specification 
Dialog” on page 533.

You can also specify shelves inside of base, 
wall, and full height cabinet boxes. See 
“Cabinet Shelf Specification Dialog” on 
page 532.

Partitions
Select Build> Cabinet> Partition 
button and click in any view to create 

a vertical partition. 

Like shelves, partitions can be selected and 
edited after they are placed.  

Partitions can be used with shelves to create 
complex storage systems.

Custom Countertops
Custom Countertops are drawn and 
edited just like other closed-polyline 

based objects. Select Build> Cabinet> 
Custom Countertop, then either click and 
drag a rectangle or single-click to place a 
2’x2’ countertop. See “Custom Countertops” 
on page 513.You can also generate a custom 
countertop over one or more base cabinets 

using the Generate Custom Countertop  
edit tool. See “Using the Edit Tools” on page 
517.

Cabinets Library
In the Library Browser, browse to 
Home Designer Core Catalogs> 

Architectural> Cabinets to access a selection 
of specialty cabinets. Select the library object 
you want, then click in any view to place it in 
the plan. Once placed, library cabinets can be 
edited. See “The Library” on page 603.

Cabinet Doors, Drawers, 
& Panels Library

A selection of special cabinet doors, 
drawers and panels is available in  

Home Designer Core Catalogs> 
Architectural.  Select an item, then click on a 
cabinet in your plan to place the door or 
drawer onto that cabinet. Doors, drawers and 
panels can be assigned to a cabinet in its 
specification dialog, as well. Cabinet doors, 
drawers and panels can also be placed as 
stand-alone fixtures. 
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Built-In Appliances
A variety of fixtures and appliances such as 
sinks, cooktops, and dishwashers can be 
placed into cabinets. See “Inserted Objects” 
on page 621. 

To insert a fixture into a cabinet, select the 
fixture in the Library Browser, then click on 
a cabinet. There must be enough space in the 
cabinet or adjoining cabinets to contain the 
selected fixture. 

If a sink or cooktop is inserted into a cabinet 
with a top Drawer or Double Drawer, its Item 
Type will automatically change to a False 
Drawer or False Double Drawer. 

Once placed, an inserted fixture can be 
selected and edited:

• To select a fixture in a cabinet top, click 
on it and then click the Select Next 

Object  edit button. See “Select Next 
Object” on page 126.

• Front fixtures can only be modified or 
deleted in the Cabinet Specification dia-
log. See “Front Tab” on page 526. 

Electrical Switches & Outlets
Electrical switches and outlets placed within 
the backsplash area of a base cabinet will 
display in front of the backsplash in 3D 
views when the “Electrical” layer is turned. 
See “The Electrical Tools” on page 487.

Cabinet Fillers
By default, Home Designer Pro models a 
continuous countertop and generates fillers 
automatically  when cabinets of the same 
height are either touching or placed with 3” 
(30 mm) of one another. 

If two cabinets meeting at a corner are 
separated from each other by 3”(30 mm) or 
less, the program will automatically generate 
a filler in the angle between them. A filler is 
used to separate the front of one of these 
cabinets from the one it meets so that 
drawers and doors have room to operate.

Place fixtures and appliances into cabi-
nets early, so that any resizing can be

done while there is adequate free space.
Fixtures can be added to both the top
and front of the same cabinet. It is up to

you to determine which can be effectively and
safely combined in the real world. 

Two base cabinets and the filler between them
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Placing Cabinets
Cabinets are easily created with a single click 
in any view. See “Click-to-Create” on page 
113. 

 When used near a wall corner, the Cabinet 
Tools will produce corner cabinets and 
soffits. See “Corner Cabinets” on page 520.

When created, cabinets are positioned 
relative to the floor of the room in which they 
are placed. Base and full height cabinets 
typically rest on the floor while wall cabinets 
are placed a set distance above the floor. See 
“Cabinet Defaults” on page 507.

If the ceiling height of the room does not 
accomodate the height of a cabinet, its Floor 
to Bottom value will be retained and its 
Height will be reduced so that it fits under 
the ceiling. When this happens, some front 
items may be removed from the cabinet if 
there is not enough room for them. See 
“Front Tab” on page 526.

Because cabinets are typically organized into 
groups with shared attributes, they have 
some special behaviors. 

Cabinet Snapping and Aligning
Cabinets have several special snapping and 
aligning behaviors which help you create 
precisely aligned cabinets quickly and easily.
• When Base and/or Full Height cabinets 

are within 3” of one another’s sides, they 
will snap together. Wall cabinets snap in a 
similar manner, but only with other Wall 
cabinets.

• When Base and/or Full Height cabinets 
are within 3” of one another’s sides and 
their front or back surfaces are within 3” 

of aligning, they will become aligned. 
Wall cabinets snap in a similar manner 
with other Wall cabinets as well as Full 
Height cabinets.

• When a Base and/or Full Height cabinet 
is placed against the back of another Base 
or Full Height cabinet, its back surface 
will automatically face the other cabinet’s 
back. Wall cabinets snap in a similar 
manner with other Wall as well as Full 
Height cabinets.

• When a cabinet or cabinet filler is placed 
against a wall, its back and/or side will 
snap to the wall and, if the wall is moved, 
the cabinet will move with it.

When cabinets are snapped to a wall or to 
other cabinets, only exposed end cabinets 
have side counter overhangs.

Cabinet snapping and aligning occurs even 

when when Object Snaps  are turned off; 
however, you can override this behavior by 
moving a cabinet into the desired position 
using dimensions. See “Moving Objects 
Using Dimensions” on page 737.

Cabinet Merging
When cabinets of the same height and type 
are placed side-by-side within 3” (30 mm) of 
one another they will automatically merge, 
making any shared components such as the 
toe kick, countertop, backsplash and 
moldings continuous. Any gap between 
merged cabinets will be automatically filled.

The exposed ends of merged cabinets have 
side counter overhangs.
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Cabinets placed at different angles will also 
merge if they face toward one another and 
meet at a front corner. Cabinets that meet at a 
back corner will also merge provided that 
they face away from one another at an angle 
no greater than 87°. In either case, a filler is 
created in the angle between the two. 

If the side of a cabinet is placed within 3” (30 
mm) of a wall, the countertop will extend to 
the wall and a filler will be created. 

Cabinet merging occurs even when Object 

Snaps  are turned off.

Base and Wall Cabinets
Base and wall cabinets have different default 
heights, so they can be placed directly above 
or below one another without interference. 

You can use Object Snaps  to center a 
wall cabinet’s back center point above that of 

a base cabinet, or vice versa. See “Click-to-
Create” on page 113.

Minimum Cabinet Size
If you try to place a cabinet into a space that 
is too narrow for its default size, the program 
will place a smaller cabinet with a width that 
is a multiple of the default Resize 
Increment. For example, if you try to place a 
24” wide cabinet in a 20” wide space and 
your Resize Increment is 3”, the program 
places an 18” cabinet. See “General Cabinet 
Defaults” on page 508.

If you try to place a cabinet into a space 
narrower than the default Minimum 
Cabinet Width, a cabinet will not be placed. 
If, for example, you have a space that is 8” 
and your Minimum Cabinet Width is 9”, no 
cabinet is placed. 

Custom Countertops
Countertops are automatically 
generated on top of base cabinets. 

These default countertops are basically 
components of the cabinets. They can be 
edited in the Cabinet Specification dialog 
but cannot be selected and modified 
separately. You can instead use Custom 
Countertops, which are drawn and edited 
just like other closed-polyline based objects 
can be selected and edited independent of the 
cabinets beneath. See  “Rectangular 
Polyline” on page 794.

Select Build> Cabinet> Custom 

Countertop , then either click and drag a 
rectangle or single-click to place a 2’x2’ 

countertop. Custom Countertops can be 
drawn in any view except cross section/
elevation views.

You can also generate a custom countertop 
over one or more selected base cabinets by 
clicking the Generate Custom Countertop 

 edit button. See “Using the Edit Tools” 
on page 517.

When a Custom Countertop covers any 
portion of a base cabinet, it overrides the 
default countertop. 

A custom countertop bases its thickness and 
height on the base cabinet(s) below. 
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• If there are multiple cabinets below, it 
uses the specifications for the cabinet 
with the greatest overall height.

• If there is no base cabinet below, its 
height and thickness are based on the 
base cabinet defaults. See “Cabinet 
Defaults” on page 507.

The countertop initially uses the default 
countertop material set in the Base Cabinet 

Defaults dialog. You can specify a different 
material as well as the height and position in 
the Custom Countertop Specification 
dialog. See “Custom Countertop 
Specification Dialog” on page 535.

Once created, a custom countertop can be 
edited like other closed-polyline based 
objects. See “Editing Closed-Polyline Based 
Objects” on page 138.

Displaying Cabinets
The display of the various cabinet 
object types, labels, module lines, 

door opening indicators and more is 
controlled in the Layer Display Options 
dialog. See “Displaying Objects” on page 
102.

In Floor Plan View
Cabinets are drawn so that wall cabinets, 
soffits and shelves are always in front of base 
and full height cabinets, countertops and 
partitions. You can select a cabinet of any 
type, though, and click the Move to Front 

 edit button to make that object display in 
front of other cabinets of the same type. See 
“Move to Front of Group” on page 151. 

If the “Cabinets, Labels” layer is turned on, 
cabinets will display labels centered on the 
cabinet they represent. See “Cabinet Labels” 
on page 515.

Fill Styles and colors can be assigned to 
cabinet objects. Custom Countertops use a 
transparent fill style by default. If generated 

using the Generate Custom Countertop  
edit tool, a Custom Countertop uses the same 

fill style as the selected cabinet. See “Fill 
Style Tab” on page 792. 

Countertops display if the “Cabinets, 
Countertops” layer is turned on. Custom 
Countertops can be assigned a molding 
profile, and can display the width of this 
profile if Display Molding Edges is selected 
in the Custom Countertop Specification 
dialog. See “General Tab” on page 535.

By default, cabinet module lines display in 
floor plan view when cabinet objects of the 
same type are placed side by side. If you 
prefer that these lines not display, turn off the 
“Cabinets, Module Lines” layer. You can 
also specify whether module lines are full or 
partial. See “General Cabinet Defaults” on 
page 508.

You can also display cabinet front indicator 
arrows in floor plan view by turning on the 
“Cabinets, Front Indicators” layer. 

In 3D Views
To show door opening indicator arrows in 
cross section/elevation and Orthographic 
views, turn on the “Opening Indicators” 
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layer. Opening indicators display in Vector 
Views only. See “Vector View” on page 711. 

In the Materials List
There are a number of ways to control how, 
or whether, cabinets are included in the 
Materials List. See “Organizing Materials 
Lists” on page 889. 

You can add and edit information about 
cabinet accessories and sub-accessories in its 

Components dialog. See “Components 
Dialog” on page 901. 

If a base cabinet has an under-counter 
appliance inserted into it, that cabinet will 
not be counted in the Materials List - only the 
countertop materials associated with it will 
be listed. The cabinet will also display the 
appliance’s label information instead of its 
own. 

Any crown or other moldings applied to 
cabinets are calculated separately and listed 
under the “Interior Trim” category. 

Cabinet Labels
Labels for cabinets display in floor plan view 
when the “Cabinets, Labels” layer is turned 
on. See “Object Labels” on page 884. 

Shelves and Partitions can also display labels 
when the “Cabinets, Labels” layer is turned 
on. Unlike cabinets, their Automatic Label is 
blank; however, you can specify a custom 
label using text in their specification dialogs. 

Cabinet labels use the Text Style specified 
for the “Cabinets, Labels” layer. See “Text 
Styles” on page 765. 

If a base cabinet has an under-counter 
appliance inserted into it, that cabinet will 
display the appliance’s label information 
instead of its own on the “Cabinets, Labels” 
layer. 

The minimum on-screen display size of 
object labels can be specified in the 
Preferences dialog. See “Appearance 
Panel” on page 61.

Automatic Labels
The format for automatic cabinet labels has 
four parts: Key, Code, Size, and Door Swing. 

The Key provides basic information about 
the cabinet box and its use. B refers to base 
cabinets, W refers to wall cabinets and U 
refers to full height cabinets. 

Together with the key, the Code provides 
additional information about the shape of the 
cabinet box:

Code
All Cabinets

LS + Key Lazy Susan
LSD + Key Lazy  Susan Diagonal Door
DC + Key Diagonal Door 
LC + Key Left Corner
BC + Key Blind Corner
Key + F Filler
E + Key Right or Left End
A + Key Angled Front
PR + Key Peninsula Radius
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Blind corner cabinets are dependent on the 
cabinet’s position in the plan. A cabinet can 
only be a blind corner cabinet when its front 
is partially hidden by another cabinet. See 
“Blind Cabinets” on page 522. If a cabinet is 
moved, therefore, its Code information may 
change. 

The Size follows the Code in a cabinet label. 
Cabinet width is always included in the label; 
depth and height, on the other hand, may be 
included depending on the cabinet type and 
whether they are standard or non-standard.

Base and full height cabinet labels present 
Size information in this order: width, depth, 
height. Wall cabinet labels present it in a 
slightly different order: width, height, depth.

Door Swing is included at the end of the 
label as either L or R, but only if all the 
doors on a cabinet have the same swing.

Here are a few examples of automatic 
cabinet labels and their meanings: 
• 3DB24: Base cabinet with 3 drawers, 24” 

wide. Depth and height are standard.
• SB24R: Sink base, 24” wide, with a right 

door. Depth and height are standard.
• BCW2436R: Blind wall cabinet, 24” 

wide, 36” high, with a right door. Depth 
is standard.

• DCW2436L: Diagonal corner wall 
cabinet, 24” wide, 36” high, with a left 
door. Depth is standard (equal to width).

• OTC362490: Full height cabinet with 
oven, 36” wide, 24” deep, 90” high.

R + Key Radius End
B Base
     OB       Oven Base
     SB       Sink Base
     RB       Range Base
     #DB       Drawer Bank (# is the 

      number of drawers
     FHB       Full Height Base (1 full 

      height door 

W Wall
    Code from
above + #D

      Drawer (# is the number 
     of drawers

U Full Height (Utility)
     OTC       Tall Oven
     RTC       Tall Refrigerator

Sizes
Base W(D)(H)
     Width (W) Always included
     Depth (D) 24” (60 cm)
     Height (H) 34 1/2” (90 cm)

     Corner 
     Depth (D)

Depth = Width

Wall WH(D)
     Width (W) Always included
     Height (H) Always included
     Depth (D) 12” (30 cm)
     Corner 
     Depth (D)

Depth = Width

Full Height WDH
     Width (W) Always included
     Depth (D) Always included
     Height (H) Always included
     Corner 
     Depth (D)

Always included

The Automatic Labels for Shelves and
Partitions are blank, but you can specify

custom labels for both. See “Shelf/Partition
Specification Dialog” on page 533.
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Editing Cabinets
Cabinets can be selected in 2D and 3D views 
both individually and in groups and edited 
using the edit handles, the edit toolbar and 
their specification dialog.

Using the Mouse
Cabinets can be edited like other box-based 
objects. See “Editing Box-Based Objects” on 
page 141. The edit handles that a cabinet 
displays when selected will vary depending 
on the view. 

When a cabinet is selected in floor plan view 
or on its top surface in a 3D view, ten edit 
handles display: the Move handle at the 
center, the Rotate handle, and a Resize 
handle on each edge and at each corner.

In 3D views, cabinets can be selected on any 
surface: front, side, back or top. When the 
side of a cabinet is selected, five edit handles 
are available: the Move handle and a Resize 
handle on each edge. 

When cabinet labels are displayed, a label 
will move as its cabinet is moved or resized. 
See “Displaying Cabinets” on page 514. 

Cabinets cannot be concentrically resized, 
even when the Concentric edit behavior is 
enabled. See “Edit Behaviors” on page 120.

In the Specification Dialog
A selected cabinet can be customized 
in a variety of ways in its specification 

dialog. See “Cabinet Specification Dialog” 
on page 522. 

Multiple Cabinets
When multiple cabinets are selected as a 
group, any specifications that they share in 
common can be modified in the Cabinet 
Specification dialog. 

When you group select cabinets of different 
types, some options are not available in the 
Cabinet Specification dialog. For example, 
you cannot modify the crown molding on a 
full height cabinet if it is selected with a base 
cabinet that does not have crown molding.

Soffits, shelves, and partitions can be group 
selected and edited using their corresponding 
specification dialog. It is important that only 
soffits, or only shelves, or only partitions be 
a part of the selection set in order to access 
the needed specification dialog. 

Using the Edit Tools
A cabinet or cabinets can be edited in a 
variety of ways using the buttons on the edit 
toolbar. See “The Edit Toolbar” on page 29.

Using Dimensions
Like various other objects, cabinets 
can be moved and resized using 

dimensions. See “Moving Objects Using 
Dimensions” on page 737. 
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In order to be edited using dimensions, 
cabinets must be located by them. You can 
specify whether cabinets are located by 
dimensions in the Dimension Defaults 
dialog. See “Locate Objects Tab” on page 
723. 

Dimensions can be set to locate the sides 
and/or corners of cabinet boxes - not the 
countertop. If you wish, you can move a 
dimension’s extension lines to locate the 
countertop after the dimension is drawn. See 
“Editing Extension Lines” on page 735. 

Temporary Dimensions will locate the wall 
surface nearest the selected object edge or 
either cabinet boxes or Custom Countertops, 
depending on which type of object is 
selected: 
• If a cabinet box is selected, Temporary 

Dimensions will locate the nearest wall 
surface or another cabinet box, but not 
Custom or automatically generated 
Countertops.

• If a Custom Countertop is selected, Tem-
porary Dimensions will locate the nearest 
wall surface or another Custom Counter-
top, but not cabinet boxes or automati-
cally generated counters.

Moving Walls with 
Cabinets Attached

When a cabinet is placed or moved against a 
wall, it will snap to the wall and become 
attached to it. When a wall is moved, all 
attached cabinets move with it. 

Moving a wall to an unattached cabinet will 
not attach the cabinet to it: the cabinet must 
be moved to the wall. A cabinet can also be 

attached to a wall when Plan Check  is 
used. See “Plan Check” on page 801. 

When wall layers are resized or the wall 
layer definition redefined, the cabinets may 
become unattached. To reattach, select them, 
drag them away from the wall, and then drag 
them back again.

Editing Cabinet Styles
A variety of settings allow you customize the 
appearance of your cabinets to create styles 
ranging from traditional to contemporary.

If the desired style is known before cabinets 
are placed, you can save time by specifing 
that style in the Cabinet Defaults dialogs 
before you start drawing. See “Cabinet 
Defaults” on page 507.

Cabinet Front Items
A variety of different front items can be 
added to any cabinet, including doors, 

drawers, cutting boards, and horizontal 
separations. Front items can also be moved, 
resized, as well as removed. See “Front Tab” 
on page 526.

Doors, Drawers & Panels
Cabinet doors, drawers, and panels can be 
applied in either of two ways:  
• In the Cabinet Specification dialog. See 

“Door/Drawer Tab” on page 529.
• Directly from the Library  Browser.
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Select a style in the library, then click on a 
cabinet to apply the selected style to that 
cabinet. In 3D views, click on a face item to 
apply the selected library object to that item. 
See “Placing Library Objects” on page 620.

A secondary door or drawer style can also be 
specified - for example, to create glass doors 
above solid doors in wall cabinets. See 
“Front Tab” on page 526.

Cabinet Hardware & Moldings
Cabinet handles, pulls, and hinges can be 
assigned in the Cabinet Specification 
dialog. See “Door/Drawer Tab” on page 529.

In 3D views, pulls and handles can also be 
applied directly from the Library Browser. 
Select a hardware item, then click on the 
cabinet face item to apply it to that face item.

Multiple molding profiles can also be applied 
around the perimeter of a cabinet at any 
height. For example, you may want a wood 
edge around base cabinet countertops and a 
crown molding that ties together the tops of 
the wall cabinets and full height cabinets. 
See “Moldings Tab” on page 503. 

Countertops & Backsplashes
Countertop thickness, overhang, and material 
for a selected base cabinet can be specified in 
the Base Cabinet Specification dialog. See 
“General Tab” on page 523. 

Backsplashes can also be applied to base 
cabinets, also on the General tab of their 
specification dialog.

Cabinet Shelves
You can customize the shelves inside of base, 
wall, and full height cabinet boxes. See 
“Cabinet Shelf Specification Dialog” on 
page 532.  

Editing Custom Countertops
Custom Countertops can be selected in 2D 
and 3D views and edited using the edit 
handles, the edit toolbar and their 
specification dialogs. See “Custom 
Countertop Specification Dialog” on page 
535.

Wall cabinet with crown molding and light rail
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Using the Mouse
Custom countertops are considered to be 
CAD-based objects and are edited the way 
closed polylines are. See “Editing Closed-
Polyline Based Objects” on page 138.

Using the Edit Toolbar
A selected Custom Countertop can be edited 
in a variety of ways using the buttons on the 

edit toolbar. See “The Edit Toolbar” on page 
29.

Countertop Edge Profiles
You can specify the edge profile of a custom 
countertop in the Custom Countertop 
Specification dialog. See “Moldings Tab” 
on page 534.

Special Cabinets
There are a number of special cabinet shapes 
that can be specified. Certain requirements 
must be met before some special cabinet 
shapes can be specified. If the requirements 
are not met, a warning message will explain 
what is needed. See “Cabinet Specification 
Dialog” on page 522.

Standard Cabinets

Select Build> Cabinet> Base Cabinet  
and click in floor plan view to place a 
standard, rectangular base cabinet.

Corner Cabinets
To create a corner cabinet, click as close to 
an inside wall corner as possible in using 

either the Base Cabinet , Wall Cabinet 

, or Full Height  cabinet tool. A 
corner cabinet remains a corner cabinet when 
it is moved, edited or copied.

Turn an existing cabinet  into a corner 
cabinet by selecting Corner Cabinet from the 
Special drop-down list in its specification 
dialog. See “General Tab” on page 523.
• Before a corner cabinet can be specified 

in the Cabinet Specification dialog, the 
cabinet’s Width must be greater than its 
Depth.

• The Left and the Right Side Widths can 
be set independently for corner cabinets. 

Note: Only Standard cabinets can be the
default cabinet Type. See “Cabinet Defaults”
on page 507. 

Standard (default) cabinet
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• You can specify a Diagonal Door on cor-
ner cabinets to create an angled corner 
cabinet. See “Front Tab” on page 526.

End Cabinets
Open a cabinet for specification and select 
Left or Right End Cabinet from the Special 
drop-down list to create an end cabinet.

• End Cabinets have an angled front and 
side.

• The cabinet width must be no greater 
than its depth for an end cabinet to be 
specified.

Radius End Cabinets
Open a cabinet for specification and select 
Right or Left Radius End from the Special 
drop-down list to create a radius end cabinet.

As you face the cabinet, a right radius end 
curves to the right, and a left radius end 
curves to the left.

Peninsula Radius Cabinets
Open a cabinet for specification and select 
Pen. Radius from the Special drop-down list 
to create peninsula radius cabinet.

The radius can be adjusted by changing the 
Depth/Bow Depth value. See “General Tab” 
on page 523.

Corner cabinet with sides of equal width

Corner cabinet with diagonal door

Left End Cabinet

Radius End cabinets have a 90° arch

Left 
Radius 
End

Right 
Radius 
End

Peninsula Radius Cabinet
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Angled Front Cabinets
Open a cabinet for specification and select 
Angled Front from the Special drop-down 
list to create an angled front cabinet.

• The length of the left and right side of an 
Angled Front cabinet can be defined by 
changing the Depth/Bow Depth value. 
See “General Tab” on page 523.

Kitchen Islands
To create a kitchen island, simply place 
several cabinets back-to-back and/or side-to-
side. Match the widths so that each cabinet 
back or side meets the back or side of only 
one other cabinet. If this is not done, the lines 
separating the cabinets cannot be suppressed. 

Two cabinets cannot merge with the same 
side of another cabinet. The picture shows 
two instances when cabinets are placed back-
to-back. Cabinet fronts and joining surfaces 
are shown.

Blind Cabinets
Often, when two cabinets meet in a corner, 
one is partially hidden by the other. This 
partially hidden cabinet is called a “blind” 
cabinet. Home Designer Pro will resize and 
offset the front items of the partially hidden 
cabinet so that they are not located in the 
hidden portion of the cabinet face.

You can also create a blind cabinet manually 
by controlling the widths of a cabinet’s left or 
right stile in its Cabinet Specification 
dialog. See “Front Tab” on page 526.

Cabinet Specification Dialog
Select one or more cabinet and click 
the Open Object edit button to open 

the Cabinet Specification dialog.

The options in the Cabinet Specification 
dialogs are similar to the corresponding 
Cabinet Defaults dialog. See “Cabinet 
Defaults” on page 507.

Angled Front Cabinet

Correct - 
Widths of front and 

back cabinets match

Incorrect - 
Solid line here is not 

suppressed.
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General Tab

A number of Special cabinet types are 
available in the drop-down list. Certain 

requirements must be met before some 
special cabinet shapes can be specified. Not 
available in the Cabinet Defaults dialogs.  
See “Special Cabinets” on page 520. 

Size/Position - The selected cabinet’s 
dimensions and position relative to the 

floor can be specified here. Fractional values 
are supported to 1/16th of an inch (1 mm).

• Specify the Height (Including Counter) 
of the cabinet box, as measured from bot-
tom to top. For base cabinets, this value 
includes the countertop thickness, but not 
the height of the backsplash. 

1
2

3

4

5

6

1

2 Note: Height refers to the height of the entire
cabinet, including countertop and toe kick. If
you change the Countertop Thickness or Toe
Kick Height, the cabinet’s total height is not
altered. Instead, the cabinet face height and
the heights of face items change in response. 
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• Specify the Width of the cabinet box, as 
measured across the front of the cabinet 
box from left to right. This does not 
include the countertop overhang.

• Specify the Depth of the cabinet box, as 
measured from front to back. It does not 
include the thickness of overlay doors or 
the countertop overhang. 

• For corner cabinets, the Width and 
Depth fields become Right Side Width 
and Left Side Width. If a corner cabinet 
is assigned a diagonal door on the Front 
tab, the second Right Side Width field 
specifies the bow depth: a positive num-
ber creates a bow and a negative number, 
an inside bow.

• Specify the Floor to Bottom distance. 
For base and full height cabinets, this is 
usually 0.  

• When the selected cabinet is outside a 
room and Auto Adjust Height is 
checked , its Floor to Bottom height is 
measured relative to the terrain height. 
When this is unchecked, the Floor to Bot-
tom height is measured from the default 
floor height of Floor 1. See “Terrain 
Height vs Floor Height” on page 539 of 
the Reference Manual. 

Specify the dimensions and style of the 
Countertop here. Only available for 

base cabinets. 
• Specify the countertop Thickness. 

Changing this value does not alter the 
cabinet height, but it does affect the 
height of face items. See “Front Tab” on 
page 526.

• Specify the countertop Overhang. The 
Overhang is used for any side of a cabinet 
not against a wall or another cabinet. 

• Check Flat Sides to eliminate the counter 
overhang on the cabinet’s exposed ends.

• Check Flat Back to eliminate the over-
hang on cabinets with an exposed back. 

• Countertop Corner Treatment - Spec-
ify clipped or rounded countertop cor-
ners. 

The dimensions and style of the 
Backsplash are specified here. The 

backsplash only displays when the cabinet is 
against a wall. Only available for base and 
wall cabinets. 
• Specify the backsplash Height and 

Thickness. Height is only available for 
base cabinets - not wall cabinets. 

• Check Side to add the same height back-
splash on the side of the cabinet if it is 
against a wall or a taller cabinet. 

• Check Always Present to display the 
backsplash at all times. If unchecked, a 
backsplash is present only when the cabi-
net is against a wall.

• Check Backsplash to Base Below to 
extend a backsplash  from the selected 
wall cabinet down to the backsplash or 
countertop of the base cabinet below. 
Only available for wall cabinets. 

The backsplash for a base cabinet is 
measured from the countertop up. The 
backsplash for a wall cabinet extends from 
the bottom of the cabinet down to the base 
cabinet or its backsplash. 

Toe Kick - The dimensions and style of 
the toe kick are specified here. Only 

available for base and full height cabinets.
• Specify the Toe Kick Height and Depth 

values for base or full height cabinets. 
Changing the Toe Kick Height does not 
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alter the cabinet height but does affect the 
heights of the cabinet face and face items.

If the Toe Kick Height or Depth is set to 
use the default “(D),” the toe kick is only 
generated when the Floor to Bottom 
height is 0. Delete the “(D)” and enter a 
positive value to display a toe kick on a 
cabinet that is raised off the floor. 

• Flat Sides can be added to base and full 
height cabinets. Checking Flat Sides 
eliminates the toe kick area on the 
exposed end(s) of the cabinet.

• Check Flat Back to eliminate the toe 
kick on a cabinet with an exposed back. 

This does not eliminate the toe kick on 
the cabinet front.

• Check Closed Toe to extend the cabinet 
sides to cover the sides of the toe kick 
area. If pilasters that do not extend to the 
floor are specified, checking this places a 
support block under them at exposed cor-
ners.

The preview of the cabinet updates as 
the cabinet changes.

• Uncheck Show Color to show the cabi-
net preview in black and white.

• The Cabinet Label displays below the 
preview diagram. See “Cabinet Labels” 
on page 515.

6



526

Home Designer Pro 2014 Reference Manual

Front Tab

Click on a face item in the preview 
diagram to select it. The selected item 

is highlighted, and the Face Items settings 
below become active, allowing you to edit 
the selected item.

Face items are usually separated by a frame 
piece known as a rail or Separation. The 
frame pieces on the sides are referred to as 
stiles and cannot be selected in the preview.

Define the Face Items on the front of 
the selected cabinet. For best results, 

edit face items starting at the top of the 
cabinet and work down.

The Item Number of the selected face item 
displays here. Click the drop-down list to 
select a different item. Item numbers start at 
the top of the cabinet and go down the face. 
Item Number 1 is usually the top face frame 
rail (separation). 

Click the Item Type drop-down list to apply 
a type to the selected Face Item, such a door, 
drawers or panel.

1
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• Cabinet fronts may be composed of any 
combination of face items, but there is a 
limit to the number of items that can rea-
sonably fit on a given cabinet’s front. 

• Auto Right and Auto Left Doors become 
double doors automatically when the cab-
inet width is greater than 24” (600 mm). 
Left, Right and Double Doors are as 
specified regardless of the cabinet width.

• False Drawers assume the appearance of 
the drawer style and hardware assigned to 
the cabinet.

• Door Panels assume the appearance of 
the cabinet’s door style but without door 
hardware.

• The backsplash can be selected but its 
Type cannot be changed. 

Item Height - Define a value for the selected 
item in the cabinet front. Fractional heights 
are supported to 1/16th of an inch (1 mm). 
• When the height of a cabinet is changed, 

or the height of a face item is changed, 
the height of the lowest face item is 
altered to make up the difference. 

• If you modify the lowest item, the item 
directly above is adjusted. Set the coun-
tertop height and the toe kick height first, 
and then work from the top to the bottom 
when adjusting face items.

• If the height of an appliance has been 
altered, entering “d” restores its default 
height. 

Click Specify Shelves to open the Cabinet 
Shelves Specification dialog and specify 
the shelf configuration for a selected Door or 
Opening Face Item. See “Cabinet Shelf 
Specification Dialog” on page 532. 

Specify Appliance/Door/Drawer - Click the 
Library button to choose an appliance, door 
style, or drawer style for the selected Face 
Item from the library. See “Select Library 
Object Dialog” on page 622. 
• If “Appliance” is the selected Item Type, 

you can specify an appliance. See “Built-
In Appliances” on page 511.

• If a Door or Drawer Item Type is 
selected, you can specify a secondary 
door or drawer style. See “Doors, Draw-
ers & Panels” on page 518. 

• Click the Clear button to remove the 
library appliance, door, or drawer from 
the selected Face Item. 

Click Add New to add a new face item 
directly below the currently selected item.
• When you click Add New, the New 

Cabinet Face Item dialog displays. 
Define the Item Type, Item Height and 
click OK. 

• If you click Add New with no face item 
selected, the program adds the new item 
at the bottom of the cabinet face. 

• When a face item is added to the cabinet 
front, the program attempts to reduce the 

Note: To ensure that Face Item heights
always equal the total cabinet front height,
the program automatically adjusts the bottom
Face Item as changes are made elsewhere.
This means you should start editing Face
Items at the top and work down. 
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height of the lowest item on the cabinet 
front to make room for the new item. 

Click Delete to remove the currently selected 
item. 
• When a face item is deleted, the height of 

the lowest item is usually increased to 
make up the difference.

• When an Auto Left, Auto Right, Left, 
Right, or Double Door is deleted, it is 
replaced by an Opening.

Click Move Up to move the currently 
selected item up one position, switching 
places with the item directly above.

Click Move Down to move the currently 
selected item down one position, switching 
places with the item directly below.

Define the Box Construction of the 
selected cabinet. Select Framed to 

create a traditional framed cabinet and enable 
the settings below, or choose Frameless for a 
European style cabinet. 
• Specify the Separation value, which is 

the width of the horizontal face frame 
piece between doors, drawers, and face 
items. 

• Specify the widths of the Left and Right 
Stile, which are the vertical frame pieces 
to the left and right of all face items. 

When set to default (D), the program uses 
the default Separation value for the left 
and right stile widths. 

Define the Door/Drawer Overlay of 
the selected cabinet.  

• Select Traditional Overlay, then specify 
the Side and Vertical Overlap values.

The Side Overlap is the distance that 
doors and drawers overlap the vertical 
stiles of the cabinet box and is applied to 
both sides of the doors and drawers.

The Vertical Overlap is the distance that 
doors and drawers overlap the horizontal 
separations between front items and is 
applied to both the top and bottom of the 
doors and drawers.

• Select Full Overlay, then specify the 
Reveal, which is the distance between 
door and drawer front items. 

• Select Inset to produce doors and draw-
ers that are flush with the rails and stiles 
rather than overlaying it. 

Face Options 

• Check Stile Between Doors to have dou-
ble doors and double drawers separated 
by a stile. This has no effect on other item 
types.

• Check Double Face to replace the cabi-
net’s face items with two faces, each 
approximately half as wide.

• Check Triple Face to replace the cabinet 
face items with three faces.

The Corner Options are available 
when the selected cabinet is specified 

as a Corner Cabinet Type. See “Corner 
Cabinets” on page 520. 
• Uncheck Diagonal Door to create double 

doors at right angles instead of a single 

Note: The program tries to maintain a single
separation between all face items. When you
add or delete a face item, separations are
usually added or deleted with them.
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diagonal door. This option is checked by 
default in the Cabinet Defaults dialog.

• Check Lazy Susan to indicate a lazy 
Susan in the cabinet’s label and its 
appearance in floor plan view. This 
option does not display in 3D views.

The Appliance Options are available 
when the selected cabinet has an 

appliance inserted into it. See “Inserted 
Objects” on page 621.

• Select Reverse Appliance to reverse the 
fixture from left to right: for example, to 
change a left hand door on a built-in 
refrigerator to a right hand door. 

• Specify the Front Offset, which is the 
distance from the front of a top-mounted 
appliance to the counter edge. Only avail-
able for base cabinets with a top-mounted 
fixture, such as a sink or cooktop. 

Door/Drawer Tab
The settings on the Door/Drawer tab allow 
you to control the appearance of the selected 
cabinet’s doors, drawers, and hardware. 

7
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Specify the style and hardware for any 
Doors applied to selected cabinet(s). 

Select a door Style from the drop-down list. 
See “Doors, Drawers & Panels” on page 518.
• Select “Use Default” to apply the door 

style specified in the defaults dialog for 
the selected cabinet’s type. See “Cabinet 
Defaults” on page 507. 

• Select “Slab Doors” to apply a flat door 
front or “Framed Doors” to apply a door 
with a frame and flat panel front.

• Select “Library” or click the Library 
button to select a cabinet door from the 
library. If a library door has been previ-
ously selected, its name will display in 
the list. See “Select Library Object Dia-
log” on page 622.

Specify the characteristics of the cabinet’s 
door Handles. 
• Select a door handle Style from the drop-

down list or choose one from the library. 
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• Specify the position of the handle In 
From Edge,as  measured from the edge 
of the door opposite the hinges.

• Specify the height of the handle Down 
From Top, as measured from the top 
edge of the door. For wall cabinets, this 
value is measured Up From Bottom.

Specify the characteristics of the cabinet 
door Hinges. 
• Select a door hinge Style from the drop-

down list or choose one from the library. 
• Specify the location of the hinges Up/

Down From Edge, as measured from the 
door edge. If the cabinet door is more 
than 35 1/4” (880 mm) high, three hinges 
will be created instead of two. 

Glass Doors is available for cabinets with 
Slab or Framed doors. Framed door panels 
are created using a glass material. The entire 
door is glass on Slab doors. 

Specify the style and hardware for any 
Drawers applied to the cabinet(s). 

Select a Drawer Style from the drop-down 
list or choose one from the library. For best 
results, Framed drawers should be at least  6” 
(150 mm) high.

Select a drawer Handle Style from the drop-
down list or choose one from the library. 
• The In From Drawer Edge setting cre-

ates two handles the specified distance 
from the left and right drawer edges. A 
value of 0 creates a single handle cen-
tered horizontally on the drawer.

• Specify the location of the handle Down 
From Top. A value of 0 centers the han-
dle vertically on the drawer.

Options 

• Enter a Bevel width value to create bev-
eled edges on Slab drawers and doors. 
This does not affect Framed or Library 
doors. The bevel width, as viewed from 
the front, has a maximum value of 3” (75 
mm).

Moldings Tab
The settings on the Moldings tab allow you 
to assign one or more horizontal moldings 
around the selected cabinet. See “Editing 
Cabinet Styles” on page 518.

For information about the settings on this 
tab, see “Moldings Tab” on page 503.

Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the selected cabinet in floor 
plan view. For more information, see “Fill 
Style Tab” on page 792.

Materials Tab
The settings on the Materials tab affect the 
appearance of the selected cabinet in 3D 
views. For information about these settings, 
see “Materials Tab” on page 635.

Some material options may be disabled if the 
selected cabinet is a manufacturer symbol. 

Label Tab
Cabinet labels display in floor plan view 
when the “Cabinets, Labels” layer is turned 
on and use the Text Style assigned to that 
layer. See “Cabinet Labels” on page 515. 
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For more information about the settings on 
this tab, see “Label Tab” on page 885.

Cabinet Shelf Specification Dialog
From the Front tab of the Base Cabinet, 
Wall Cabinet, or Full Height Cabinet 
Specification dialog, select a door or 
opening face item in the preview diagram 

and click the Specify Shelves button to open 
the Cabinet Shelf Specification dialog.  See 
“Front Tab” on page 526.

Automatic
By default, cabinet shelves are 
specified automatically. The default 

number of shelves, shelf type, thickness, 
spacing, and depth display here.

Manual
Select the Manual radio button to 
specify cabinet shelving for the selected 

door or opening. If a cabinet is resized after 
shelving has been manually edited, the 
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specifications are maintained, but all shelves 
may not be display in all situations.

The Number of Shelves can be specified. 
Equal Spacing is checked by default. 

The shelf type, thickness, spacing, and 
depth can be specified on a per shelf 

basis or for all shelves at once. To determine 
which, select the shelf number or All Shelves 
from the drop-down list. 

• Specify the shelf Type from the drop-
down list. 

• Enter a shelf Thickness in fractions or 
decimals.

• Changing the Spacing From Previous 
unchecks Equal Spacing above.

• You can select Full, Half or Specify the 
shelf Depth manually.

The preview shows shelf numbers, 
thickness, depth, and spacing. Press the 

Tab key to update the preview as changes are 
made.

Shelf/Partition Specification Dialog
Select a shelf or partition and click the 
Open Object edit button to open the 

Shelf Specification or Partition 
Specification dialog.

The options in these specification dialogs are 
similar to the corresponding defaults dialogs. 
See “Cabinet Defaults” on page 507.

Note: If All Shelves is selected after changes
have been made to any one shelf, “no
change” displays, indicating that all shelves
are not the same.

3
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General Tab

Specify the Height, Width, Depth, and the 
distance from the Floor to Bottom of the 
shelf or partition. 

When the selected object is outside a room 
and Auto Adjust Height is checked , its 
Floor to Bottom height is measured relative 
to the terrain height. When this is unchecked, 
the Floor to Bottom height is measured from 
the default floor height of Floor 1. See 
“Terrain Height vs Floor Height” on page 
539 of the Reference Manual. 

Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the selected object in floor 

plan view. For information about these 
settings, see “Fill Style Tab” on page 792.

Moldings Tab
The settings on the Moldings tab allow you 
to apply molding to the selected object. For 
information about these settings, see 
“Moldings Tab” on page 531.

Materials Tab
The settings on the Materials tab affect the 
appearance of the selected object in 3D 
views. For information about these settings, 
see “Materials Tab” on page 635.
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Label Tab
Shelf and Partition labels display in floor 
plan view when the “Cabinets, Labels” layer 
is turned on and use the Text Style assigned 
to that layer. The Automatic Labels for 

Shelves and Partitions are blank, but you can 
specify custom labels. See “Cabinet Labels” 
on page 515.

For more information about the settings on 
this tab, see “Label Tab” on page 885.

Custom Countertop Specification Dialog
Select a custom countertop and click 
the Open Object edit button to open 

the Custom Countertop Specification 
dialog.

General Tab

Uncheck Set Height From Cabinet to 
specify Height of the selected 

countertop. When checked, the Countertop 
Height is determined by the cabinet below.
• Top Height - Specify the height of the 

top of the custom countertop independent 
of the cabinet below. Set Height From 
Cabinet must be unchecked.

Uncheck Set Thickness From Cabinet 
to specify the thickness of the selected 

countertop. When checked, the Countertop 
Thickness is determined by the cabinet 
below.

• Specify the Thickness of the countertop 
independent of the cabinet below. Set 
Thickness From Cabinet must be 
unchecked.

• Check No Molding on Selected Edge to 
turn off molding on the selected edge.

Polyline Tab
The Polyline tab state’s the length of the 
countertop’s Length/Perimeter, its Area, 
and its Volume. 

Selected Line/Arc Tab
The Selected Line tab is available when the 
selected edge is a line as opposed to an arc. 
For more information, see  “Line Tab” on 
page 780.

The Selected Arc tab is available when the 
selected edge has been converted to an arc. 
For more information, see  “Arc Tab” on 
page 787.

Moldings Tab
The settings on the Moldings tab allow you 
to apply an edge profile to the selected 
countertop. For information about these 
settings, see “Moldings Tab” on page 531.
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Line Style Tab
For information about the settings on this 
tab, see “Line Style Tab” on page 781.

Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the selected countertop in 
floor plan view. For information about these 
settings, see “Fill Style Tab” on page 792.

Materials Tab
The settings on the Materials tab affect the 
appearance of hte selected countertop in 3D 
views. For information about these settings, 
see “Materials Tab” on page 635.
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Chapter 21:

Terrain

Home Designer Pro allows you to model the 
terrain around a house. Begin by specifying 
elevation data that creates the surface 
contours, and then add surface features such 
as planting areas, water features and plants.

You can import terrain data from a variety of 
sources and use this data to produce your 3D 
model. 

Once the terrain is modeled, shadows that 
follow the terrain can be created using the 
Sun Angle tool. See “Sun Angles” on page 
701. 

Roads and sidewalks are among the objects 
that can be placed in your terrain and are 
discussed in “Roads, Driveways & 
Sidewalks” on page 583.

Chapter Contents
•      Terrain Toolbar Configuration
•      Terrain Perimeter
•      Elevation Data Tools
•      Terrain Modifier Tools
•      Terrain Feature Tools
•      Garden Bed Tools
•      Water Feature Tools
•      Stepping Stone Tools
•      Terrain Wall and Curb Tools
•      Sun Shadows
•      Terrain Objects in the Library
•      Displaying Terrain
•      Editing Terrain Objects
•      Terrain Object Specification Dialogs
•      Importing Elevation Data
•      Converting CAD Lines to Terrain Data
•      Plant Tools
•      Plant Image Specification Dialog
•      Plant Chooser Dialog
•      Hardiness Zones
•      Sprinkler Tools
•      Sprinkler Specification Dialog
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Terrain Toolbar Configuration
The Terrain and Road Tools can be 
accessed through the Terrain menu. 

You can also display these tools on your 
toolbar using the Terrain Configuration. 
See “Toolbar Configurations” on page 98. 

The Terrain Configuration and Terrain menu 
both display the following terrain and road 
parent tools:

• Elevation Data Tools  allow you to 
add elevation data to your terrain.

• Terrain Modifier Tools  model 
changes in elevation within a defined 
area.

• Terrain Feature Tools  let you add 
materials over the top of the terrain. 

• Garden Bed Tools  create Terrain 
Features with a mulch material.

• Water Feature Tools  create Terrain 
Features with a water material.

• Stepping Stone Tools  are used to cre-
ate paths composed of multiple Terrain 
Features.

• Terrain Wall and Curb Tools  let you 
draw walls and curbs that follow the ter-
rain.

• Road, Driveway and Sidewalk 

Tools  allow you to create paved areas 
that can form intersections.

• Plant Tools  allow you to place plant 
images and 3D plant symbols.

• Sprinkler Tools  are used to lay out 
sprinkler symbols and irrigation lines.

Terrain Perimeter
The Terrain Perimeter is a closed 
polyline defining the boundary of the 

terrain that generates in 3D views and of the 
contour lines that generate in floor plan view. 
A Terrain Perimeter should be present in 
your plan already, but if one is not, select 
Terrain> Create Terrain Perimeter to 
create one.

If you create a terrain perimeter in floor plan 
view but do not see it, select Window> Fill 

Terrain Perimeter
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Window . See “Zoom Tools” on page 
654. 

When created in a new, blank plan, a new 
terrain perimeter will be 50’ x 100’. If you 
create a terrain perimeter after you have 
drawn all or part of a 3D model, it may 
increase in size as needed to encompass 
everything in floor plan view. 

Once created, the terrain perimeter can be 
resized and edited like other polyline-based 
objects. See “Editing Closed-Polyline Based 
Objects” on page 138. 

When a terrain perimeter is first created, it is 
completely flat and is placed at a height of 
0’-0”, or sea level.

The terrain perimeter by itself does not have 
elevation data associated with it. You can use 

the Elevation Data  and Terrain 

Modifier  tools to create terrain that 
slopes in a wide variety of ways. If you do 
not create elevation data within the terrain 
perimeter, the terrain remains flat at an 
elevation of 0' - 0". See “Elevation Data 
Tools” on page 540 and “Terrain Modifier 
Tools” on page 545.

Terrain Height vs Floor Height
Home Designer Pro always defines the 
default height of Floor 1 at 0’-0”. This height 

value is the constant by which the heights of 
architectural objects and structural elements 
in the program, including walls, floors, and 
ceilings, are measured. 

The default height of Floor 1 is not, however, 
the absolute by which terrain elevation is 
measured. Instead, elevation data is  
measured relative to sea level. This means 
that if you want to, you can use real-world 
elevation data to generate a 3D terrain model 
without also having to measure floor and 
ceiling heights from sea level. See 
“Importing Elevation Data” on page 567. 

The program automatically positions Floor 1 
a set distance above the terrain. To do this, it 
first finds the center point of the building 
footprint. Then, it determines the elevation of 
the terrain at that point. Finally, it adds 6” 
(150 mm) plus the thickness of the floor 
platform and treated sill plate to this value. 
The resulting value, referred to as the 
Building Pad Elevation, is how far the 
default height of Floor 1 is above sea level in 
the current plan. See “Foundations and the 
Terrain” on page 339.

In a plan with a foundation present, the 
Elevation distance will equal the exact 
terrain elevation at the building footprint 
center point, plus 6” (150 mm), plus the 
thickness of the floor platform.
• In a plan with no elevation data, the ter-

rain is assumed to be at sea level and this 
Elevation distance is 6” (150 mm) plus 
the thickness of the floor platform when a 
foundation is present. 

• In a plan with flat terrain at 100’ (30 m) 
and a foundation present, the Elevation 
distance is 100’ 6” (30.468 m) plus the 
thickness of the floor platform.

Terrain perimeter at 0' - 0" in a 3D view
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Once terrain has been built, the Elevation 
distance is stated in the Terrain 
Specification dialog. You can specify a 
custom Elevation value to produce a daylight 
or walkout basement. See “General Tab” on 
page 554. 

Build Terrain
Select Terrain> Build Terrain to 
generate the terrain surface based on 

the provided elevation data. Build Terrain 
also updates the Building Pad Elevation 
value in the Terrain Specification dialog. 
See “Building the Terrain” on page 552.

Clear Terrain
To remove the generated terrain 
contours, select Terrain> Clear 

Terrain. When the terrain is cleared, 
contours do not display in 3D and contour 
lines do not display in floor plan view.

Clear Terrain  does not remove the 
terrain perimeter, elevation data, or terrain 
features from the model. Rather it deletes all 
program-generated 2D contour lines and 3D 
contours.

The Terrain Perimeter has a variety of  
editable properties, including many that 

affect the appearance of the terrain in 2D and 
3D views.  See “Terrain Specification 
Dialog” on page 554.

Terrain Surface Triangles
Home Designer Pro generates 3D terrain 
surfaces by dividing them into triangles. The 
size of the triangles determines how detailed 
contour lines and terrain surfaces in the 3D 
model can be. You can specify triangle size 
in the Terrain Perimeter Specification 
dialog. See “General Tab” on page 554.

Increasing the triangle count decreases 
triangle size, yielding more detailed contour 
lines and a better 3D approximation of the 
terrain. Smaller triangles demand longer 
terrain generation time and increased 
memory requirements. If you select a large 
number of small triangles for a large site, you 
may wait a long time for the calculation. 

Decreasing the triangle count increases 
triangle size. Elevation lines are sampled less 
frequently, speeding up terrain generation. If 
you specify a small number of triangles for a 
plan with detailed elevation data, contour 
lines and 3D surfaces may not generate 
correctly. 

Elevation Data Tools
Select Terrain> Elevation Data to 
add elevation information to your 

terrain. 

When terrain is generated, this data is used to 
calculate the surface of your site and is 
represented by contour lines in floor plan 

Note: When no foundation has been built, the
distance from Floor 1 to the terrain is 12” (320
mm). 

When a large terrain perimeter is used,
consider increasing the Triangle Count

to help make sure all Elevation Data and Ter-
rain Modifiers generate contours. 
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view and a curved surface in 3D. See 
“Displaying Terrain” on page 551.

Elevation data can be specified using the 

Elevation Point , Elevation Line , 

Elevation Spline , Elevation Region  

and Terrain Break  tools. 

Elevation data can also be imported. See 
“Importing Elevation Data” on page 567.

The elevation of each Elevation Line, Spline 
and Region is specified relative to sea level. 

In order to create rising and/or falling terrain, 
multiple terrain data objects with different 
elevation values must be used. If only one 
terrain data object is placed, the terrain will 
be flat regardless of the object’s specified 
elevation.

Elevation Points
An Elevation Point contains the 
absolute elevation data for one point 

in the terrain model. Typically, Elevation 
Points are imported rather than placed 
manually. 

Home Designer Pro requires many points to 
make an accurate approximation of your site. 
Even small sites may require over a hundred 
points to generate an accurate model of the 
terrain if it is sloped. For the sake of 
illustration, the following example shows 
only a few elevation points.

To place an elevation point

1. Select Terrain> Elevation Data> Ele-

vation Point  and click in floor plan 
view at the point where you would like 
to place elevation data. See “Place 
Point” on page 773.

2. The Elevation Point Specification dia-
log opens. Enter an elevation value and 
click OK. See “Elevation Point Specifi-
cation Dialog” on page 557.

3. Click somewhere else in floor plan view 
and the Elevation Point Specification 
dialog opens again with the last eleva-
tion value entered. 

4. Repeat steps 1, 2 and 3 to place addi-
tional elevation points with varied eleva-
tion values as needed.

5. Select Terrain> Build Terrain . See 
“Building the Terrain” on page 552.

To avoid unexpected results, do not
draw Elevation Data objects with differ-

ent elevation information at the same loca-
tion. 

Elevation Points before terrain generation
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Elevation Lines
An Elevation Line contains absolute 
elevation data for many points along a 

line at a constant elevation. Elevation lines 
can be connected to create a polyline with 
many straight sections. For the sake of 
illustration, the images in the following 
example show single-section elevation lines.

To draw an elevation line

1. Select Terrain> Elevation Data> Ele-

vation Line , then click and drag a 
line inside the Terrain Perimeter in floor 
plan view. 

2. Click on the elevation line to select it, 

then click the Open Object  edit but-
ton.

3. At first, an elevation line is at elevation 
0' - 0". In the Elevation Line 
Specification dialog, specify the desired 
elevation and click OK. See “Elevation 
Line/Region Specification Dialog” on 
page 559.

4. Repeat steps 2 and 3 to draw additional 
elevation lines as needed. 

5. Select Terrain> Build Terrain . See 
“Building the Terrain” on page 552.

Elevation Points are most effective
when they are imported. When adding

elevation data manually, use Elevation Lines
and Splines instead. See “Importing Elevation
Data” on page 567.

Contour lines after terrain generation
120"

0"

Elevation Lines before terrain generation

Contour lines after terrain generation
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After it is drawn, an Elevation Line can be 
edited much the way other line-based objects 
can. See “Editing Line Based Objects” on 
page 127. 

Elevation Splines
Elevation Splines can be used to form 
complex curves and shapes. Like 

elevation lines, elevation splines contain 
absolute elevation data for many points along 
a constant elevation.

To place an elevation spline, select Terrain> 

Elevation Data> Elevation Spline  and 
click and drag multiple sections in floor plan 
view.  See “Splines” on page 796.

Elevation splines are initially placed at 
elevation 0' - 0"and must be opened and 
assigned an elevation. See “Elevation Line/
Region Specification Dialog” on page 559.

After it is drawn, an Elevation Spline can be 
edited much the way other spline-based 
objects can. See “Editing Spline Based 
Objects” on page 144.

Elevation Regions
An Elevation Region contains 
absolute elevation data for an 

enclosed region. 

Elevation Regions are similar to Flat Regions 
in that they produce an area with a flat 
surface; however, they differ in that an 
Elevation Region affects the contours of the 

Full Overview after terrain generation

Elevation splines before terrain generation

60"

36"

0"

Contour lines after terrain generation
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terrain outside of its perimeter and may also 
have some sloping within its perimeter. See 
“Flat Regions” on page 546.

To create an elevation region

1. Select Terrain> Elevation Data> 

Elevation Region .
2. There are two ways to add a Terrain 

Modifier to your plan: 
•  Click once to place an 8’ (0.6 m) 

square feature at that location.
•  Click and drag from end to end to draw 

a feature sized as needed. See “Rectan-
gular Polyline” on page 794.

3. Click on the region to select it, then click 

the Open Object  edit button.
4. At first, an elevation line is at elevation 

0' - 0". In the Elevation Region 
Specification dialog, specify the desired 
elevation and click OK. See “Elevation 
Line/Region Specification Dialog” on 
page 559. An Elevation Region  can also be created 

by drawing a closed polyline using Eleva-

tion Lines . 

After it is drawn, an Elevation Region can be 
reshaped much the way other closed 
polyline-based objects can. See “Editing 
Closed-Polyline Based Objects” on page 
138.

Terrain Breaks
A Terrain Break creates a division 
along the terrain surface that affects 

terrain generation. Elevation data on one side 
of the terrain break does not affect the terrain 
generation on the other side, allowing you to 
create immediate drops in terrain.

240"

0"

120"

Elevation lines create a terrain grade; an 
elevation region creates a building pad.

Contour lines after terrain generation

Full Overview after terrain generation
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To place a Terrain Break, select Terrain> 

Elevation Data> Terrain Break  and 
click and drag a line in floor plan view. 
• If the Terrain Break divides the terrain 

perimeter into two separate pieces, the 
terrain data on either side is calculated 
independently and smoothed separately, 
resulting in sharp terrain contours. 

• If the Terrain Break does not extend com-
pletely from one side of the terrain perim-
eter to the other, the areas near each end 
of the Terrain Break are blended. 

The Retaining Wall  tool creates a 
similar effect by drawing a Terrain Break as 
well as a retaining wall that rests against the 
break. By default, the top height of the 
retaining wall matches the terrain on the high 
side of the break and the bottom matches the 
low side. See “Retaining Walls” on page 550.

Terrain Modifier Tools
Select Terrain> Modifier to access 
tools that allow you to modify the 

existing elevation data by drawing a closed 
polyline. Their height is relative to the terrain 
surface generated from the Elevation Data 
provided in your plan. 

The elevation data associated with a Terrain 
Modifier only affects the terrain within its 
perimeter. The rest of the terrain is 
unaffected. 

240"

0"

120"

A Terrain Break (dashed line) 
creates a vertical drop.

84"
18"

Contour lines after terrain generation

Full Overview after terrain generation
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Raised and Lowered Regions
The Raised Region tool creates a 
raised area with a top surface that 

is flattened like a plateau but follows the 
surface of the terrain. The Lowered Region 
tool creates a depression with a bottom that 
follows the terrain and is flattened. 

Hills and Valleys
The Hill and Valley tools create 
raised and lowered areas in the 

terrain that come to a point rather than  
flattening at their highest or lowest 
elevations. 

Flat Regions
The Flat Region tool creates an area 
with a surface that is flattened like a 

plateau but is level rather than following the 
contours of the terrain. 

There are two ways to add a Terrain Modifier 
to your plan: 
• Click once to place a modifier with end-

points that form a 10’ (4 m) square at that 
location. 

• Click and drag from end to end to draw a 
feature sized as needed. See “Rectangular 
Polyline” on page 794.

Terrain Modifiers can only be drawn when a 
Terrain Perimeter is present, and will only 
display in 3D when they are drawn within the 
perimeter. See “Displaying Terrain” on page 
551.

Once created, Terrain Modifiers can be 
selected and edited in a variety of ways. See 
“Editing Spline Based Objects” on page 144. 

Terrain Feature Tools
Select Terrain> Feature to access 
tools for drawing bounded areas that 

follow the contours of the terrain rather than 
modifying them. 

Terrain Features are useful for creating 
landscaping features because they have 
specified heights and materials. You can, for 
example, create paths and planting beds with 
gravel or mulch materials that stand out in a 

Lowered 
Region

Raised 
Region

Valley
Hill

Flat Region

Raised 
RegionLowered 

Region
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grassy Terrain Perimeter. See “Adding 
Terrain Features” on page 178 of the User’s 
Guide. 

In fact, Garden Beds , Water Features 

 and Stepping Stones  are special 
Terrain Features with material and height 
attributes already applied to them, saving 
you time when drawing these objects.

Terrain Features can only be drawn when a 
Terrain Perimeter is present, and will only 
display in 3D when they are drawn within the 
perimeter. See “Displaying Terrain” on page 
551.

Terrain Features can be created in either of 
two ways: 
• Click once to place a feature with end-

points that form a 10’ (4 m) square at that 
location. 

• Click and drag from end to end to draw a 
feature sized as needed. See “Rectangular 
Polyline” on page 794.

Once created, Terrain Features can be edited 
into nearly any shape you require. See “Edit-
ing Closed-Polyline Based Objects” on page 
138 and “Editing Spline Based Objects” on 
page 144.

Rectangular Features
The Rectangular Feature tool can be 
used to create straight-sided features 

that can be edited into a wide variety of 
shapes. 

Rectangular Features can also be edited like 
other closed polyline-based objects. See 

“Editing Closed-Polyline Based Objects” on 
page 138.

Spline Feature
The Spline Feature tool can be used 
to create features with rounded edges 

and smoothly curved corners. 

Spline Features can be edited like other 
closed spline-based objects. See “Editing 
Spline Based Objects” on page 144.

Kidney Shaped Features
The Kidney Shaped Feature tool 
allows you to quickly create features 

with curved edges, smooth corners and a 
right angle bend in its shape.

Kidney Shaped Features can be edited like 
other closed spline-based objects. See “Edit-
ing Spline Based Objects” on page 144.

Terrain features can also be converted from 
closed 2D polylines or splines using the 

Convert Polyline  edit tool. See “Convert 
Polyline” on page 165. 

For information about adding height and 
material information to Terrain Features, see 
“Terrain Feature Specification Dialog” on 
page 562.

Terrain Holes
A Terrain Hole is a region that cuts a 
hole in the terrain. Using this tool is 

the same as creating a Terrain Feature and 
checking Make Hole in the Terrain Feature 
Specification dialog. See “Terrain Feature 
Specification Dialog” on page 562.

Terrain Features can be drawn in 2D
and 3D views. 
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Terrain Holes  are useful for manually 
clipping the terrain around a foundation that 
does not match the footprint of the first floor.

Garden Bed Tools
Select Terrain> Garden Bed to 
access tools that can be used to place 

garden bed features in your terrain. 

Garden Beds are basically Terrain Features 
with material and height attributes typical of 
planting beds. See “Terrain Feature Tools” 
on page 546.

In addition, you can choose to distribute 
copies of a plant image within a Garden Bed. 
See “Distributed Plant Tab” on page 563.

Polyline Garden Bed
This tool draws a garden bed with 
straight sides and four right angles. 

See “Rectangular Features” on page 547.

Round Garden Bed
Use this tool to draw garden beds with 
rounded edges and smoothly curved 

corners. See “Spline Feature” on page 547. 

Kidney Shaped Garden Bed
You can draw a kidney shaped garden 
bed with this tool. See “Kidney 

Shaped Features” on page 547.

Once drawn, Garden Beds can be selected 
and edited just like other Terrain Features. 

Specify the material and set the height of 
Garden Beds in the Terrain Feature 
Specification dialog.  See “Terrain Feature 
Specification Dialog” on page 562.  

Water Feature Tools
Select Terrain> Water Feature to 
access tools for drawing ponds and 

streams in your terrain.

Ponds are basically Terrain Features with 
material and height attributes typical of 
bodies of water. See “Terrain Feature Tools” 
on page 546.

Similarly, Streams are Terrain Curbs with a 
water material. See “Terrain Wall and Curb 
Tools” on page 549. 

Round Pond
Use this tool to draw a pond with 
rounded edges. See “Spline Feature” 

on page 547. 

Kidney Shaped Pond
This tool draws a kidney shaped pond. 
See “Kidney Shaped Features” on 

page 547.
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Stream
Select the Stream tool, then click and 
drag to draw a stream. Streams are 

drawn and edited the same way that splines 
are. See “Splines” on page 796 and “Editing 
Spline Based Objects” on page 144.

Streams follow the contours of the 
terrain, so they may appear to flow uphill if 
they are not drawn correctly in the terrain. 

Try to draw them so that they follow a 
downward course for their entire length.

Once drawn, Water Features can be selected 
and edited just like any other Terrain Feature. 

Specify the material and set the height of 
Water Features in their specification dialogs.  
See “Terrain Object Specification Dialogs” 
on page 553.  

Stepping Stone Tools
Select Terrain> Stepping Stone to 
place a walkway made of individual 

stepping stones. 

Stepping Stones are basically Terrain 
Features with material and height attributes 
typical of walking paths. See “Terrain 
Feature Tools” on page 546.

There are two ways to draw Stepping Stones: 
• Click once to place a stepping stone with 

endpoints that form a 1’ (300 mm) square 
at that location. 

• Click and drag from end to end to draw a 
stepping stone sized as needed. See 
“Rectangular Polyline” on page 794.

Polyline Stepping Stone
The Polyline Stepping Stone tool 
draws rectangular stepping stones. See 

“Rectangular Features” on page 547. 

Round Stepping Stone
The Round Stepping Stone tool 
draws stepping stones with rounded 

edges. See “Spline Feature” on page 547.

Once drawn, Stepping Stones can be selected 
and edited just like any other Terrain Feature. 

By default, Stepping Stones have a concrete 
material; however, you can specify the 
material and set the height of Stepping 
Stones in the Terrain Feature Specification 
dialog.  See “Terrain Feature Specification 
Dialog” on page 562. 

Terrain Wall and Curb Tools
Select Terrain> Terrain Wall and 
Curb to draw landscaping walls and 

curbs that follow the contours of the terrain. 

Straight and curved Terrain Walls and Curbs 
are drawn just as other walls are. See 
“Drawing Walls” on page 189.
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Terrain Walls and Curbs are examples of 
Terrain Paths. Other examples include 
Sidewalks and Streams. See “Terrain Path 
Specification Dialog” on page 566.

Terrain Walls
Use the Straight Terrain Wall tool to 
draw a wall that sits on top of and 

follows the terrain. 

Use the Spline Terrain Wall to draw 
a curved terrain wall. This wall is 

drawn the same way as a CAD Spline. See 
“Splines” on page 796.

Once drawn, a Terrain Wall can be like other 
line-based objects. See “Editing Line Based 
Objects” on page 127 and “Editing Spline 
Based Objects” on page 144.

Terrain walls are 5’ (1500 mm) high and con-
crete by default, but you can specify the 
material, height and more in the Terrain Path 
Specification. See “Terrain Path 
Specification Dialog” on page 566. 

Retaining Walls
The Retaining Wall tools function similarly 
to Terrain Breaks, but include a wall. See 
“Terrain Breaks” on page 544.

Use the Straight Retaining Wall tool 
draws a straight wall that holds back 

sloped terrain.

Use the Curved Retaining Wall tool 
to draw a curved retaining wall. 

A Retaining Wall’s height is determined by 
the elevation of the terrain on each side. By 
default, the height of the wall matches the 
terrain on the high side of the break and the 
bottom matches the low side. If you insert a 
Retaining Wall into flat terrain, it looks like a 
concrete strip in 3D views.

Once drawn, a Retaining Wall can be edited 
much like other walls. See “Editing Walls” 
on page 197.

Terrain Curbs 
Terrain Curbs are useful for creating curbs 
around planting beds and along paths.

Use the Straight Terrain Curb tool 
to draw a straight landscaping curb.

 Use the Spline Terrain Curb tool to 
draw a curved landscaping curb. This 

curb is drawn the same way as a CAD 
Spline. See “Splines” on page 796. 

Once drawn, a Terrain Curb can be like other 
line-based objects. See “Editing Line Based 
Objects” on page 127 and “Editing Spline 
Based Objects” on page 144.

You can specify the height of straight and 
spline terrain curbs on the General tab of the 
Terrain Path Specification. See “Terrain 
Path Specification Dialog” on page 566. 

Sun Shadows
Sun shadows are computed based on the 
contour of the terrain. If a terrain perimeter 

exists, the sun shadow adjusts to the terrain.

You can also add Fencing to your ter-
rain, complete with gates from the

Doors Library. See “The Fencing Tools” on
page 183. 
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The Sun Shadow is automatically rebuilt 
whenever terrain is rebuilt. If you generate a 
Sun Shadow and the terrain is not up-to-date, 

the terrain automatically rebuilds. You can 
turn off the automatic rebuild. See “Sun 
Angle Specification Dialog” on page 708.

Terrain Objects in the Library
The Library Browser contains a 
variety of objects that can be placed in 

a plan’s terrain, including plants, exterior 
fixtures, accessories and roadway objects. 
See “The Library Browser” on page 604. 

You can also create your own objects and 
save them in the library. Select any 
combination of elevation points, elevation 

lines, terrain features, roads, sidewalks, road 
markings, or even the terrain perimeter itself 
and send them to the library as one unit. This 
library object can then be placed into any 
plan. Once placed into a plan, each object is 
independent and is no longer part of the 
group. See “Adding Library Content” on 
page 613. 

Displaying Terrain
The display of terrain objects in 2D 
and 3D views is controlled in the 

Layer Display Options dialog. See “Layer 
Display Options Dialog” on page 104.

You can customize appearance of Terrain 
Features, Roads and other terrain objects in 
floor plan view by changing their line and fill 
styles. See “Terrain Object Specification 
Dialogs” on page 553. 

Plant images are represented in floor plan 
view by 2D CAD symbols. You can select a 
plant’s symbol in the Plant Image 
Specification dialog. See “Image Tab” on 
page 575. 

Contour Lines
When elevation data has been drawn or 
imported into a plan, contour lines will 
display in floor plan view. See “Elevation 
Data Tools” on page 540.

Home Designer Pro can produce both 
primary and secondary contours. They are on 
two different layers so you can control their 
display separately. Contour line labels use 
the Text Styles assigned to the “Terrain, 
Primary Contours” and “Terrain, Secondary 
Contours” layers. 

By default, all contour lines are set to be 
primary, but you can specify secondary 
contours, frequency and other attributes of 
contour lines in the Terrain Specification 
dialog.  See “Contours Tab” on page 555. 

In 3D Views
In order for objects such as Terrain Features 
and Roads to be visible in 3D views, the 
Terrain Perimeter layer must also display. In 
addition, only the portions of these objects 
that are drawn within the Terrain Perimeter 
will be seen in 3D views. See “Terrain 
Feature Tools” on page 546.
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A variety of tools are available to help you 
adjust the perspective of your 3D views. See 
“Editing 3D Views” on page 684.

Building the Terrain
When terrain is generated, Home 
Designer Pro gathers all elevation data 

that has been added to the model and creates 
a terrain surface. The program interpolates 
the data to produce smooth contours. 

A terrain perimeter with no additional 
elevation data drawn within it generates 
terrain that is flat at the elevation 0' - 0", or 
sea level. 

By default, the terrain is automatically built 
before a 3D view is generated and when a 
sun shadow is created. This process takes a 
variable amount of time, depending on the 
amount of elevation data and number of 
terrain features in the plan. The Building 
Terrain progress dialog displays as terrain is 
generated, sometimes only briefly, indicating 
the progress.

You can turn off Auto Rebuild Terrain in 
the 3D View Defaults dialog for 3D views 
and in the Sun Angle Specification dialog 
for sun shadows, and rebuild the terrain 
manually only when needed by selecting 

Terrain> Build Terrain . When Auto 
Rebuild Terrain is turned off and the terrain 
is not up to date, the Rebuild Terrain  icon 
displays near your mouse pointer. See 
“Options Tab” on page 669 and “Earth Data 
Tab” on page 708.

Terrain & 3D Drawing Time
Terrain is typically large with many surface 
triangles, which often increases the drawing 
time of 3D views. The time required is 
affected by the quality of the terrain, the 
amount of elevation data and number of 
terrain features present. For information 
about surface triangles and how they 
influence terrain quality, see “General Tab” 
on page 554. 

Lights and symbols can be placed outdoors 
and included in 3D views when the terrain is 
generated. These objects can also contribute 
to the time needed to generate 3D views. See 
“Rendering Tips” on page 697.

Editing Terrain Objects
Before a terrain object can be edited, it must 
be selected. All terrain objects can be 
selected in floor plan view. In addition, the 
Terrain Perimeter and Terrain Features can 

be selected in 3D views. See “Selecting 
Objects” on page 124. 

A selected terrain object can be edited using 
its edit handles, edit tools and specification 



Terrain Object Specification Dialogs

 553

dialog. See “Specification Dialogs” on page 
31.

Any time elevation data is changed, the 
terrain must be regenerated. This occurs 
automatically when a 3D view is created. It 
can also be done manually by selecting 

Terrain> Build Terrain .

Using the Edit Handles
• The shape of the Terrain Perimeter can be 

edited like other polyline-based objects. 
See “Editing Closed-Polyline Based 
Objects” on page 138. 

• Elevation Points can be moved in floor 
plan view using the Move edit handle.

• Elevation Lines, Elevation Splines and 
Terrain Breaks are edited like other line- 
and spline-based objects. See “Editing 
Line Based Objects” on page 127, “Edit-
ing Closed-Polyline Based Objects” on 
page 138, and “Editing Spline Based 
Objects” on page 144. 

• The shape of a Raised Region, Lowered 
Region, Hill, Valley, and Flat Region 
can be edited like a spline. See “Editing 
Spline Based Objects” on page 144.

• Terrain Features are edited like other 
spline- and polyline-based objects. See 

“Editing Closed-Polyline Based Objects” 
on page 138 and “Editing Spline Based 
Objects” on page 144.

Using the Edit Tools
A selected terrain object can be edited in a 
variety of ways using the buttons on the edit 
toolbar. The edit tools available for a terrain 
object depends on the type of terrain object 
selected. See “The Edit Toolbar” on page 29.

Moving Terrain Objects 
Using Dimensions

If dimensions display when a terrain object is 
selected, the object can be moved using the 
them. For more information see “Moving 
Objects Using Dimensions” on page 737.

Plot Plans
Using the CAD drawing and editing tools, 
you can create an accurate plot plan of any 
building site. For more information, see 
“Creating a Plot Plan” on page 195 of the 
User’s Guide. 

Terrain Object Specification Dialogs
Just as there are a number of different 
types of terrain objects, there are a 

number of different specification dialogs for 
them.

Note: If you copy terrain objects from one
plan to another, you cannot view the pasted
objects in 3D unless a Terrain Perimeter
exists. 
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Terrain Specification Dialog
The Terrain Specification dialog 
controls how your terrain is modeled, 

as well as its appearance.

The Terrain Specification dialog can be 
accessed in any of three ways:

• Select Terrain> Terrain 

Specification .
• Select the Terrain Perimeter and click the 

Open Object  edit button.
• Double-click the Terrain Perimeter using 

the Select Objects  tool. 

General Tab

Home Designer Pro builds 3D terrain 
surfaces by splitting them into triangles. See 
“Terrain Surface Triangles” on page 540.

Triangles are computed roughly as follows:

Size of Triangle = Area of Terrain Perimeter / 
Number of Triangles

The Low (1000), Medium (2000), and High 
(4000) values work well for a terrain 
perimeter of approximately 20,000 sq ft 

(1858 m²). If your terrain perimeter varies 
greatly from this, consider defining the 
number of triangles using the Custom setting 
or the Triangle Size setting. 

Triangle Count - Specify the number 
of surface triangles used to generate the 

terrain in 3D views. A lower count value will 
generate more quickly but with reduced 
quality.
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• Custom - Specify a custom triangle count 
value. 

• Triangle Size - Specify the maximum tri-
angle size in the terrain surface. Smaller 
triangles produce better quality results in 
3D but take longer to generate.

 Smoothing - Control the amount of 
rounding applied to terrain edges. A 

low value for smoothing produces terrain 
that has sharp peaks and abrupt changes in 
slope. A high value results in terrain that 
continuously flows from point to point. 

Specify how the Building Pad is 
generated beneath the structure. See 

“Foundations and the Terrain” on page 339.
• Check Flatten Pad to flatten the area 

beneath the building. To create a walkout 
basement, uncheck this box.

• Check Auto Calculate Elevation to have 
Home Designer Pro automatically posi-
tion the first floor 6” (150 mm) above the 
terrain. See “Terrain Height vs Floor 
Height” on page 539.

• To specify the distance between Floor 1 
and the terrain at the building footprint 
center, uncheck Auto Calculate Elevation 

and enter a value in the Pad Elevation 
field. 

Check Hide terrain intersected by 
building to cut out the portion of the 

terrain that is intersected by the first floor 
footprint. Checking this box prevents the 
generation of contour lines inside the house. 

If your foundation footprint differs from your 
first floor footprint, you may need to use the 

Terrain Hole  tool for custom clipping 
instead. See “Terrain Feature Tools” on page 
546.

Define the thickness of the Skirt added 
to the terrain. The skirt is only visible in 

3D views and gives the viewer a sense of 
depth when viewing the terrain. 
• Flat specifies that the skirt be flat at its 

base. Home Designer Pro determines the 
lowest point in the terrain and then offsets 
this value by the user specified thickness 
value. The resulting value is used as a uni-
form elevation for the base of the skirt. 

• Follow Terrain specifies that the skirt 
base maintains a consistent distance 
below the terrain. The distance is equiva-
lent to the specified Thickness value.

Contours Tab
Home Designer Pro identifies two types of 
contour lines: Primary and Secondary. They 

are drawn on different layers, so you can 
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control how they display in floor plan view. 
See “Contour Lines” on page 551.

Specify the Frequency at which 
contour lines are generated.

• Define the Interval between contour 
lines, which is the change in elevation 
between contours. If the interval is set to 
12”, a contour line is computed for each 
elevation change of 12”.

• Specify the Offset value. When the Offset 
is 0, a contour line will be drawn at zero 
elevation and additional contours will 
generate based on the Interval value. If 
the Offset is changed to 5, a contour line 
will be drawn 5 units from zero elevation 
rather than at 0, and additional contours 
will generate from there.

• Primary Contour Every__Contours - 
Specify the interval for primary contours. 
A value of 1 produces only primary con-
tours, while a value of 5 defines every 
fifth contour line as a primary contour.

Control the display of contour line 
Labels in floor plan view. 

• Check Label Primary Contours to label 
primary contour lines with their elevation 
data using the Units specified below. 

• Check Label Secondary Contours to 
label secondary contour lines with their 
elevation data. 

• Check Highlight Negative Elevations to 
display labels of contour lines with eleva-
tions below 0 in red. When unchecked, 
they use the color set in the Text Style 
assigned to their layer. 

If contour Smoothing is turned on, 
Home Designer Pro attempts to remove 
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Primary and secondary contour line
labels use the Text Style assigned to

their respective layers. See “Text Styles” on
page 765.
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sharp bends and jagged sections from the 2D 
contour lines.
• Specify the number of Passes to perform 

when smoothing. The more passes, the 
smoother the contour lines become, but 
contours become less accurate.

Specify the Units used by contour line 
labels. Select either Inches or Decimal 

Feet (Millimeters or Meters for metric).

Polyline Tab
The Polyline tab indicates the polyline’s 
Length/Perimeter, its enclosed Area, and 
its Volume. 

The settings on the this tab are available for a 
variety of other objects in the program. For 
information about these settings, see 
“Polyline Tab” on page 792.

Selected Line Tab
The Selected Line tab is available when the 
selected edge of the Terrain Perimeter is a 
line as opposed to an arc. See “Selected 
Edge” on page 125.

The settings on this tab are available for a 
variety of other objects in the program. For 
information about these settings, see “Line 
Tab” on page 780.

Selected Arc Tab
The Selected Arc tab is available when the 
selected segment of the polyline is an arc as 
opposed to a line. See “Change Line/Arc” on 
page 159.

The settings on this tab are available for a 
variety of other objects in the program. For 
information about these settings, see “Arc 
Tab” on page 787.

Line Style Tab
The settings on the Line Style tab are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Tab” on page 781.

Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the Terrain Perimeter in floor 
plan view. For information about these 
settings, see “Fill Style Tab” on page 792.

Materials Tab
The settings on the Materials tab let you 
specify the terrain surface and terrain skirt 
materials used in 3D views. These materials 
are not calculated in the Materials List. See 
“Materials Tab” on page 635.

Elevation Point Specification Dialog
To open the Elevation Point 
Specification dialog, select an eleva-

tion point and click the Open Object edit 
button, or double-click on an elevation point 

using the Select Objects  tool.

Use the Elevation Point Specification 
dialog to define the selected elevation point 
and control its appearance in floor plan view. 

4
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When all changes are made, click OK to 
store the changes or Cancel to ignore them.

General Tab

Location - Specify the exact location of 
the elevation point.

• Elevation - Enter the height of the eleva-
tion point in inches and/or feet (mm for 
metric). For example entering 5’6 (with 
the apostrophe as foot mark) results in an 
elevation of 66 inches.

• X Coordinate - Enter the x coordinate of 
the elevation point.

• Y Coordinate - Enter the y coordinate of 
the elevation point.

Text - Enter notes, such as elevation, in 
this box. This text displays beside the 

elevation point in floor plan view. You can 
also enter a pound (#) sign to display the 
elevation value in floor plan view. 

Enter the Marker Radius in inches (or 
millimeters). 

Line Style Tab
The settings on the Line Style tab are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Tab” on page 781.

Text Style Tab
The settings on the Text Style tab control the 
appearance of the selected Elevation Point’s 
text. For more information, see “Text Style 
Tab” on page 766. 
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Elevation Line/Region Specification Dialog
To open the Elevation Line or 
Elevation Region Specification dia-

log, select one or more Elevation Line/
Splines, or a polyline composed of elevation 
Lines/Splines, or an Elevation Region and 
click the Open Object edit button. You can 
also double-click an Elevation Line/Spline 

using the Select Objects  tool.

The Elevation Line Specification dialog is 
used to define the selected Elevation Line/
Spline and controls its appearance in floor 
plan view. 

The settings in this dialog are the same as 
those in the Elevation Region Specification 
dialog. See “Elevation Regions” on page 
543. 

Elevation Tab

Elevation - Enter the elevation of the Line/
Spline in inches and/or feet (mm for metric). 
For example entering 5’6 (with the 
apostrophe as foot mark) results in an 
elevation of 66 inches.

Polyline Tab
The Polyline tab indicates the line or 
polyline’s Length/Perimeter. If multiple 
Elevation Line/Spline segments form a 
closed Elevation Region, its Area will be 

calculated. Elevation Lines/Splines do not 
have a thickness, so they have no Volume. 

Spline Tab
The Spline tab has a single option and is only 
available when the selected object is an 
elevation spline. See “Splines” on page 796.

New Segment Angle - Specify the angle 
between line segments that are used to draw 
the spline. Specifying a smaller angle makes 
the spline smoother. Specify a larger angle to 
draw the spline faster.

Selected Line Tab
The Selected Line tab is available when the 
selected object or segment is a line as 
opposed to one that has been converted to an 
arc. See “Selected Edge” on page 125.

The settings on this tab are available for a 
variety of other objects in the program. For 
information about these settings, see “Line 
Tab” on page 780.

Selected Arc Tab
The Selected Arc tab is available when the 
selected object or segment is an arc as 
opposed to a line.

The settings on this tab are available for a 
variety of other objects in the program. For 
information about these settings, see “Arc 
Tab” on page 787.
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Line Style Tab
The settings on the Line Style tab are 
available for a variety of other objects in the 

program. For information about these 
settings, see “Line Style Tab” on page 781.

Flat Region Specification Dialog
To open the Flat Region 
Specification dialog, select a Flat 

Region and click the Open Object edit 
button, or double-click a Flat Region using 

the Select Objects  tool. See “Flat 
Regions” on page 546. 

The options in the Flat Region Specification 
dialog are similar to those a number of other 
dialogs in the program.

Polyline Tab
The Polyline tab indicates the length of the 
polyline’s Length/Perimeter, its enclosed 
Area, and the Volume of a closed polyline.

Spline Tab
The Spline tab has a single option and is only 
available when the selected object is a spline.  
See “Splines” on page 796.

New Segment Angle - Specify the angle 
between line segments that are used to draw 
the spline. Specifying a smaller angle makes 
the spline smoother. Specify a larger angle to 
draw the spline faster.

Selected Line Tab
The Selected Line tab is available when the 
selected edge of the polyline is a line as 
opposed to an arc. See “Selected Edge” on 
page 125.

Moving the Start of a line segment moves the 
end of the previous connected line, if there is 
one. Similarly, moving the End of a line 
segment moves move the start of the next 
connected line, if there is one. 

The settings on this tab are available for a 
variety of objects in the program. For 
information about these settings, see “Line 
Tab” on page 780.

Selected Arc Tab
The Selected Arc tab is available when the 
selected segment of the polyline is an arc as 
opposed to a line.  See “Change Line/Arc” 
on page 159.

The settings on this tab are available for a 
variety of objects in the program. For 
information about these settings, see “Arc 
Tab” on page 787.

Line Style Tab
The settings on the Line Style tab are 
available for a variety of objects in the 
program. For information about these 
settings, see “Line Style Tab” on page 781.
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Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the selected object in floor 

plan view. For information about these 
settings, see “Fill Style Tab” on page 792.

Hill / Valley Specification Dialog
The Hill/Valley Specification defines 
the selected Hill or Valley and 

controls its appearance in floor plan view. 

To open the Hill/Valley Specification dialog, 
select one or more Hill or Valley and click 
the Open Object edit button, or double-click 

the region(s) using the Select Objects  
tool.

Hill / Valley Tab

Enter a Height for the selected Hill or Valley. 
This height is relative to the terrain surface 
that is generated from the Elevation Data in 
your plan. See “Terrain Modifier Tools” on 
page 545.

Polyline Tab
The Polyline tab indicates the polyline’s 
Length/Perimeter and its enclosed Area. 
Hills and Valleys do not have a volume 
measurement.

Spline Tab
The Spline tab has a single option and is only 
available when the selected object is a spline.  
See “Splines” on page 796.

New Segment Angle - Specify the angle 
between line segments that are used to draw 
the spline. Specifying a smaller angle makes 
the spline smoother. Specify a larger angle to 
draw the spline faster.

Line Style Tab
The settings on the Line Style tab are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Tab” on page 781.

Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the selected object in floor 
plan view. For information about these 
settings, see “Fill Style Tab” on page 792.
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Raised / Lowered Region Specification Dialog
To open the Raised/Lowered Region 
Specification dialog, select one or 

more raised or lowered regions and click the 
Open Object edit button, or double-click the 

region(s) using the Select Objects  tool.

The Raised / Lowered Region 
Specification dialog is similar to the Hill / 
Valley Specification dialog. See “Hill / 
Valley Specification Dialog” on page 561.

Terrain Feature Specification Dialog
To open the Terrain Feature 
Specification dialog, select a Terrain 

Feature or group of Terrain Features and 
click the Open Object edit button or double-
click the Terrain Feature(s) using the Select 

Objects  tool.

The settings in this dialog control the 
appearance, size, and shape of the selected 
Terrain Feature.

Most of the tabs in this dialog are similar to 
those for a variety of other objects in the 
program.

General Tab

Specify the Height and Thickness of 
the terrain feature relative to the terrain 

surface. 
• Specify the top Height of the feature 

using a positive or negative number. 
• Specify the feature’s Thickness.

If a feature’s height above the terrain is 
greater than its thickness, the program will 
fill in the resulting gap.

• Check Make Hole to specify the selected 
Terrain Feature as a Terrain Hole. See 
“Terrain Holes” on page 547.

Clipping - Check Clip Overlapping 
Terrain Features to suppress the 3D 

display of any part of the selected Terrain 
Feature intersected by other Terrain Features 
with a lower Height value. Clipping is useful 
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for creating features that contain other 
features such as planters or swimming pools.

Distributed Plant Tab
This tab is only available when the selected 
terrain feature is a Garden Bed. See “Garden 
Bed Tools” on page 548.

Polyline Tab
The Polyline tab indicates the polyline’s 
Length/Perimeter, its enclosed Area, and 
the Volume of a closed polyline. 

Spline Tab
The Spline tab has a single option and is only 
available when the selected object is a spline.  
See “Splines” on page 796.
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New Segment Angle - Specify the angle 
between line segments that are used to draw 
the spline. Specifying a smaller angle makes 
the spline smoother. Specify a larger angle to 
draw the spline faster.

Selected Line Tab
The Selected Line tab is available when the 
selected edge of the Terrain Perimeter is a 
line as opposed to an arc. See “Selected 
Edge” on page 125.

The settings on this tab are available for a 
variety of other objects in the program. For 
information about these settings, see “Line 
Tab” on page 780.

Selected Arc Tab
The Selected Arc tab is available when the 
selected segment of the polyline is an arc as 
opposed to a line. See “Change Line/Arc” on 
page 159.

The settings on this tab are available for a 
variety of other objects in the program. For 

information about these settings, see “Arc 
Tab” on page 787.

Line Style Tab
The settings on the Line Style tab are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Tab” on page 781.

Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the selected object in floor 
plan view. For information about these 
settings, see “Fill Style Tab” on page 792.

Materials Tab
The settings on the Materials tab affect the 
appearance of the selected object in 3D 
views. See “Materials Tab” on page 635.

Garden Bed Specification Dialog
To open the Garden Bed 
Specification dialog, select a Garden 

Bed or group of Garden Beds and click the 
Open Object edit button or double-click the 

Garden Bed(s) using the Select Objects  
tool.

Because a Garden Bed is a type of terrain 
feature, the settings in this dialog are 
essentially the same as those in the Terrain 
Feature Specification dialog. See “Terrain 
Feature Specification Dialog” on page 562.

Terrain Break Specification Dialog
To open the Terrain Break 
Specification dialog, select a Terrain 

Break or group of Terrain Breaks and click 
the Open Object edit button or double-click 
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the Terrain Break(s) using the Select Objects 

 tool. See “Terrain Breaks” on page 544. 

General Tab

Transition Distance - Define the distance 
from the edge of the terrain break to where 
the break stops affecting the terrain. 

Polyline Tab
The Polyline tab indicates the line or 
polyline’s Length/Perimeter. Terrain Breaks 
do not have a thickness, so they have no 
Volume. If multiple Terrain Break segments 
form a closed polyline, its Area will be 
calculated. 

Spline Tab
The Spline tab has a single option and is only 
available when the selected object was 
converted to a Terrain Break from a spline.  
See “Splines” on page 796.

New Segment Angle - Specify the angle 
between line segments that are used to draw 
the spline. Specifying a smaller angle makes 
the spline smoother. Specify a larger angle to 
draw the spline faster.

Selected Line Tab
The Selected Line tab is available when the 
selected edge of the polyline is a line as 
opposed to an arc. See “Selected Edge” on 
page 125.

Moving the Start of a line segment moves the 
end of the previous connected line, if there is 
one. Similarly, moving the End of a line 
segment moves move the start of the next 
connected line, if there is one. 

This tab is similar to the Line tab of the Line 
Specification dialog. See “Line Tab” on 
page 780.

Selected Arc Tab
The Selected Arc tab is available when the 
selected segment of the polyline is an arc as 
opposed to a line.  

This tab is similar to the Arc tab of the Arc 
Specification dialog. See “Arc Tab” on page 
787.

Line Style Tab
For information about the Line Style tab, see 
“Line Style Tab” on page 781.

Fill Style Tab
The Fill Style tab is only available when 
multiple Terrain Break segments enclose an 
area. The settings on this tab affect the 
appearance of the closed shape in floor paln 
view. For more information, see “Fill Style 
Tab” on page 792.



566

Home Designer Pro 2014 Reference Manual

Terrain Path Specification Dialog
To open the Terrain Path 
Specification dialog, select one or 

mores Streams, Terrain Walls or Terrain 
Curbs and click the Open Object edit button 
or double-click the terrain path(s) using the 

Select Objects  tool.

Most of the tabs in this dialog are similar to 
those for a variety of other objects in the 
program.

General Tab

Enter the Width of the object and the 
Height. If you enter a negative number 

for the height, the object sinks into the 
terrain. 

When one terrain path joins another, 
you can Flare the intersection. 

• Check Start and/or End to create a flare 
at that end of the terrain path.

• Specify the Radius for each flare in 
inches (mm).

Polyline Tab
The Polyline tab indicates the Terrain Path 
polyline’s Length/Perimeter, its enclosed 
Area, and the Volume of a closed polyline. 

Spline Tab
The Spline tab has a single option and is only 
available when the selected object is a spline 
path. See “Splines” on page 796.

New Segment Angle - Specify the angle 
between line segments that are used to draw 
the spline. Specifying a smaller angle makes 
the spline smoother. Specify a larger angle to 
draw the spline faster.

Selected Line Tab
The Selected Line tab is available when the 
selected edge of the Terrain Perimeter is a 
line as opposed to an arc. See “Selected 
Edge” on page 125.

The settings on this tab are available for a 
variety of other objects in the program. For 
information about these settings, see “Line 
Tab” on page 780.
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Selected Arc Tab
The Selected Arc tab is available when the 
selected segment of the polyline is an arc as 
opposed to a line. See “Break Line” on page 
158.

The settings on this tab are available for a 
variety of other objects in the program. For 
information about these settings, see “Arc 
Tab” on page 787.

Line Style Tab
The settings on the Line Style tab are 
available for a variety of other objects in the 

program. For information about these 
settings, see “Line Style Tab” on page 781.

Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the selected object in floor 
plan view. For information about these 
settings, see “Fill Style Tab” on page 792.

Materials Tab
The settings on the Materials tab affect the 
appearance of the selected object in 3D 
views. See “Materials Tab” on page 635.

Importing Elevation Data
Elevation data can be added to a plan using 
the tools and techniques described in this 
chapter or it can be imported from a file. 

Home Designer Pro can import elevation 
data saved in DXF, GPS Exchange (.gpx) 
and a variety of text file formats (.txt, .csv, 
.prn, .xyz, .auf and .nez). If your terrain data 
is not saved in one of these file formats, there 
are third party programs available that can 
convert to these formats. 

DXF Files
If you have a model of your terrain created 
on another program that contains contour 
lines and elevation data, that information can 
be imported directly as elevation data into 
Home Designer Pro as a .dxf file. See 
“Importing DXF Elevation Data” on page 
572. 

Text Files
Elevation data can be saved in text files as x, 
y, and z coordinates where x and y define the 
location of a point on a Cartesian grid, and z 
defines the elevation for that point. Each 
elevation point must be on a separate line in 
the text file. 

Importable text files can come from 
surveyors, other software programs, or you 
can create your own using a GPS system. 

Elevation data saved in text files can be 
imported using the Import Terrain Wizard. 

GPS Exchange Files
Elevation data in standard format .gpx files 
created using a GPS system can also be 
imported using the Import GPS Data 
Wizard. See “Import GPS Data Wizard” on 
page 570. 
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GPS data may include three types of points - 
Way, Track, and Route. Home Designer Pro 
can only import a .gpx file if it includes one 
or more Way Points, and cannot use Route 
Points at all. If a .gpx file does not include 
any Way Points, it will not be imported, and 

if it includes any Route Points, they will be 
ignored.  

Home Designer Pro supports the import of 
data in standard .gpx files that adhere to the 
GPX 1.1 Schema. Files that do not follow 
this standard cannot be imported.

Import Terrain Wizard
The Import Terrain Wizard allows you 
to import elevation data saved in text 

(.txt) file format into your model.

Select File> Import> Terrain Data  to 
open the Import Terrain Wizard. Click Next.

Select File

Select File to Import -Enter the name 
of a text file, or Browse to locate a file 

on your computer. 

Select the Organization of the Data - 
You need to know how the data in your 

text file is organized. Each data point con-
tains information about its X-axis (East to 
West location), Y-axis (North to South 
location), and Z-axis (elevation). It might 
also contain a brief description. 

Elevation information can come in one of six 
different sequences, and is separated by 
either a comma (comma delimited) or a 
space (space delimited). 

XYZ - Information in this format begins with 
the X coordinate, followed by the Y 
coordinate and the Z coordinate.

#XYZ - Information in this format begins 
with a number that belongs to each data point 
followed by the X coordinate, the Y 
coordinate, and the Z coordinate.

#XYZ Description - Information in this 
format begins with a number that belongs to 
each data point followed by the X 
coordinate, the Y coordinate, the Z 
coordinate, and a description.
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YXZ - Information in this format begins with 
the Y coordinate followed by the X 
coordinate and the Z coordinate.

#YXZ - Information in this format begins 
with a number that belongs to each data point 
followed by the Y coordinate, the X 
coordinate, and the Z coordinate.

#YXZ Description - Information in this 
format begins with a number that belongs to 
each data point followed by the Y 
coordinate, the X coordinate, the Z 
coordinate, and a description.

Scale Data

This describes the total number of data 
points to be imported and the range of 

the coordinates of those points.

Translate - Accurately position the 
terrain beneath your plan. You need to 

know where the origin is located in your 
plan, and where that origin is located relative 
to the geographical data in your text file. The 
coordinates of the data point that correspond 
with the origin point in Home Designer Pro 
should be entered here.

Units - Select the units of measurement 
used in your data for each axis. Only 

linear units are available. The units in the 
drop-down lists are a subset of the units in 
the Edit Preferences dialog. For more 
information on specifying default units, see 
“Unit Conversions Panel” on page 71.
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To find the origin point in your plan,
open the Move Point dialog, enter abso-

lute coordinates X=0, Y=0, and click OK to
move the point to the (0, 0) location. See
“Move Point Dialog” on page 775.
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Scale Coordinates - Multiply the 
coordinates of each axis by a specific 

number to decrease or increase the relative 
size or relief of your terrain.

Rotate Coordinates - Accurately 
rotate terrain data counterclockwise 

around the Z axis.

Import GPS Data Wizard
The Import GPS Data Wizard allows 
you to import terrain data from the 

standard .gpx file format. Select File> 
Import> GPS Data to open the Import GPS 
Data Wizard. See “GPS Exchange Files” on 
page 567.

Click Next to continue.

Select File

Enter the name and directory of the file you 
want to import, or click Browse to select a 
.gpx file on your computer. 

4 5

Due to the lack of accuracy in some
GPS systems, exact distances using

the Import GPS Data Wizard are not guaran-
teed.

Note: Not all GPS programs use the standard
.gpx file format; however, only files using the
standard format can be imported. 
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Click Next to continue.

Import Data As

Specify which items you want to import 
by checking the box to the left of the 

Name. Items with unchecked boxes are not 
imported.

Specify what you would like each item 
to Import As from the drop-down list.

• Only Way Points have elevation data 
associated with them. To import this data, 
import them as “Elevation Data”. 

• Select “Marker” to import either Way 
Points or Track Points as location mark-
ers. Markers have no elevation data asso-
ciated with them.

• Select “Polyline” to create an open CAD 
polyline based on the position of Way 

Points or Track Points. The points them-
selves are not imported. Polylines have no 
elevation data associated with them.

• Select “Terrain Perimeter” to create a 
closed Terrain Perimeter polyline based 
on the position of either Way Points or 
Track Points. The points themselves are 
not imported. A Terrain Perimeter has no 
elevation data associated with it. See 
“Terrain Perimeter” on page 538. 

Click Next to continue.
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Way Points are typically imported as
“Elevation Data”, while Track Points are

imported as “Markers”, “Polylines’, or “Terrain
Perimeter”. 
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Transform Coordinates

Map - Specify the point in the imported 
terrain data, defined by degrees 

latitude and degrees longitude, that you 
would like to locate at the origin in the Home 
Designer Pro plan.

Lower Elevation Data - Specify the 
amount that you would like to lower all 

imported elevation data.

Rotate - Accurately rotate the position 
of north in the imported terrain data 

counterclockwise around the Z axis.

Click Finish to close the Import GPS Data 
Wizard and return to floor plan view.

If you do not see the imported terrain, select 

Window> Fill Window . 

Importing DXF Elevation Data
Select File> Import> Drawing 
(DXF)  to open the Import Drawing 

Wizard, which you can use to import 
elevation data in .dxf format. See “Import 
Drawing Wizard” on page 829. 

On the Select File page of the Wizard, check 
the Terrain Elevation Data box. 

Lines and points in the imported drawing are 
converted to elevation lines and elevation 
points, preserving the elevation data 
associated with them. 
• If an imported line has vertices with the 

same Z values, an elevation line is cre-
ated.
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• If the vertices have differing Z values, an 
elevation point is created for each vertex.

• Imported points are converted to eleva-
tion points.

• Other imported entities (solids, faces, 
etc.) are imported normally. If a terrain perimeter does not already exist in 

the plan, a perimeter that surrounds the data 
is generated. 

Converting CAD Lines to Terrain Data
CAD lines can be selected and 
converted to terrain data using the 

Convert Polyline edit tool.

Using this tool, you can convert CAD lines 
in an imported drawing into terrain data that 
can be used to generate a 3D terrain model.

Select a CAD line, spline, or polyline in floor 
plan view and click the Convert 

Polyline  edit button to open the Convert 

Polyline dialog. See “Convert Polyline 
Dialog” on page 165.

If a terrain perimeter is not present in your 
plan, this will be the only terrain object 
available to select. A terrain perimeter must 
exist before any of the other terrain objects 
can be created. 

When you click OK, the terrain object’s 
specification dialog opens, allowing you to 
specify elevation data or other attributes. 

Plant Tools
Select Terrain> Plant to add plants 
to your landscaping plan. Plants can 

also be placed in a plan directly from the 
library. See “Placing Library Objects” on 
page 620.

Plant objects are actually images, which 
provide realism while avoiding high 3D 
surface count. Once created, plant images 
can be selected and edited much like other 
image objects. See “Editing Images” on page 
808.

Plants have labels which you can display in 
floor plan view. 

Select Terrain> Plant> Plant 
Chooser to open the Plant Chooser 

dialog. See “Plant Chooser Dialog” on page 
577.

Select Terrain> Plant> Create Plant 
Image to create a plant image. Once a 

plant image is created, it can be added to the 
library for future use. See “Adding Library 
Content” on page 613. 

Choose Terrain> Plant> Grow All 
Plants to open the Grow Plants 

dialog. 

When importing elevation data, only
import layers containing this data. To

import other layers as normal CAD, run the
Terrain Import Wizard again with Terrain Ele-
vation data unchecked.
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Click and drag the slider bar and select a 
growth period from zero to twenty years. 
This only works for plants that have a mature 
height and mature age specified in the Plant 
Image Specification dialog. See “Plant 
Information Tab” on page 576.

Select Terrain> Plant> Show 
Hardiness Zones  to access regional 

climate zone maps. See “Hardiness Zones” 
on page 579.

Plant Schedules
The Plant Schedule tool allows you 
to create customizable plant schedules 

and plant labels that display schedule 
numbers. See “Plant Schedules & Object 
Labels” on page 879. 

Plant Image Specification Dialog
Select one or more plant in a floor 
plan or 3D view and click the Open 

Object edit button to open the Plant Image 
Specification dialog. 

This dialog can also be accessed by selecting 

Terrain> Plant> Create Plant Image .

The Plant Information and Plant Description 
tabs are also found in the Plant Information 
dialog, which can be accessed from the Plant 
Chooser dialog. See “Plant Chooser Dialog” 
on page 577.
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Image Tab

Image File - The path and name of the 
selected image file displays here. Click 

Browse to specify the saved location on your 
computer of the image that represents the 
plant in 3D views.

A number of 2D Plant Symbols are 
available to mark the location of the 

image in floor plan view. Select one from the 
drop-down list.

Options 

• Check Reverse Image to reflect the 
appearance of the image about an imagi-
nary vertical line through its center. 

• Check Do not rotate in 3D view to pre-
vent the plant image from rotating with 
the camera.

Specify the Size of the plant image, as 
seen in 3D views. 

• Enter a Height for the image. 
• Enter a Width for the image. 
• When Retain Aspect Ratio of is checked, 

if you change either the Height or Width, 
the other value changes to maintain this 
ratio. If this is unchecked and you resize 
the plant image, it may become distorted.

• Click Reset Original Aspect Ratio of to 
reset the image’s original aspect ratio and 
remove any distortion caused by resizing.

Specify the Location of the selected 
plant image.

• Precisely position the selected plant 
image in reference to the plan coordinates 
by specifying its X Coordinate and Y 
Coordinate.

• Specify the selected plant image’s Height 
Above Ground.

1
2

3

4

5

1

2

3

4

5



576

Home Designer Pro 2014 Reference Manual

Transparency Tab
The settings on the Transparency tab of this 
dialog are similar to those on the same tab of 
the Image Specification dialog. For more 

information, see “Transparency Tab” on page 
810.

Plant Information Tab
The settings on the Plant Information tab 
correspond to the search parameters in the 
Plant Chooser. See “Plant Chooser Dialog” 
on page 577.

Plant Description Tab

A detailed Description of the plant 
displays in this text field.

Information in the Lighting 
Comments fields describes the plant’s 

light requirements.

When multiple plants with differing attri-
butes are selected, some button icons

may be replaced by an X symbol, which signi-
fies “No Change”.

1
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Hardiness Zone Comments are given 
here. See “Hardiness Zones” on page 

579.

Fill Style Tab
The Fill Style tab controls the appearance of 
the selected plant’s 2D Plant Symbol in floor 
plan view.  By default, plant images’ fill style 

is None (Transparent). For information about 
the settings on this tab, see “Fill Style Tab” 
on page 792.

If the plant’s 2D Plan Symbol does not form 
a closed shape, the settings on the Fill Style 
tab will have no effect on the appearance of 
the plant in floor plan view. 

Plant Chooser Dialog
Select Terrain> Plant> Plant 
Chooser to open the Plant Chooser 

dialog or click the button at the bottom of the 
Library Browser window.

Use the Plant Chooser to search the library 
for plant images and symbols that meet your 
search parameters. You can search using any 
or all of the options in this dialog.

3
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The search parameters in the Plant Chooser 
dialog correspond to the settings on the Plant 
Information tab of the Plant Image 
Specification dialog. See “Plant Information 
Tab” on page 576.

The Common Name, Scientific Name 
or Variety Name for the plant. A 

Pronunciation field is also provided.

Specify the Flower Color to search for 
here.

Specify the Leaf Color to search for 
here.

Specify the Bloom Time to search for, 
which is the season when the plant 

produces flowers. 

Check one or more boxes to search for 
plants with Special Characteristics.

Specify the plant Height at maturity to 
search for. This is used with the Grow 

Plants feature. See “Plant Tools” on page 
573.
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• An average mature height range can be 
entered using the From and To drop-
down lists.

• A specific Height at Maturity to search 
for can be entered in the text field.

• A specific Age at Maturity, in months, 
can be entered in the text field.

• A specific Starting Age, in months, can 
be entered in the text field.

Specify the plant Needs to search for. 
These include the Sun, Water, Soil pH, 

and Hardiness Zone range. See “Hardiness 
Zones” on page 579.

Check one or more boxes to indicate 
selected plant Type to search for.

Check one or more boxes to specify the 
selecte Sub-Type to search for.

Click the Search button at the bottom 
of the dialog to search for plants that 

meet your search criteria. The search results 
display to the right. 

Specify whether you want the search 
results to use the Common Name or 

Scientific Name. 

Click on the name of a plant in the list 
to see its location in the Library 

Browser.
• If the selected plant has been downloaded, 

you can click the View Item button to see 
more information about it in the Plant 
Information dialog. See “Plant Image 
Specification Dialog” on page 574.

Hardiness Zones
Select Terrain> Plant> Show 
Hardiness Zones to view a selection 

of regional Hardiness Zone Maps. Click the 
drop-down list to select various regions.
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Sprinkler Tools
Use the Sprinkler Tools to design a 
sprinkler system in your plan. 

Select Terrain> Sprinkler> 
Sprinkler Head to open the Select 

Library Object dialog. Browse to a sprinkler 
type in the library, click OK, then click in the 
drawing area to place as many as you need. 
Once drawn, sprinkler heads can be selected 
and edited. See “Sprinkler Specification 
Dialog” on page 580.

Select Terrain> Sprinkler> 
Sprinkler Line to draw sprinkler 

lines in your plan. Sprinkler lines are 2D 
objects and are drawn and edited much like 
CAD Lines. See “Line Tools” on page 776.

Select Terrain> Sprinkler> 
Sprinkler Spline to draw curved 

sprinkler lines in your plan. Sprinkler splines 
are 2D objects and are drawn and edited like 
CAD Splines. See “Splines” on page 796.

Displaying Sprinklers
The display of Sprinkler Heads, Lines and 
Splines can be controlled in the Layer 
Display Options dialog. See “Displaying 
Objects” on page 102.

In floor plan view, Sprinkler Head symbols 
indicate the spray angle. 

Unlike Sprinkler Heads, Sprinkler Lines and 
Splines do not display in 3D views. Their 
total length is calculated in the Materials 
List, however. See “Materials Lists” on page 
887. 

Sprinkler Specification Dialog
To open the Sprinkler Specification 
dialog, select a sprinkler or group of 

sprinklers and click the Open Object edit 

button. You can also double-click the sprin-

kler(s) using the Select Objects  tool. 

Sprinkler Line Sprinkler Spline

90° 
Spray 

180° 
Spray 

360° 
Spray 
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General Tab

Specify the selected sprinkler’s Size/
Position.

• Enter the Height, Width, and Depth of 
the sprinkler.

• Enter a Floor to Bottom value to define 
the distance from the bottom of the sprin-
kler to elevation 0 of Floor One. 

• Click the Reset button to return the sprin-
kler values to the defaults.

• Uncheck Auto Adjust Height if you wish 
to specify an absolute Floor to Bottom 
height measured from the default floor 
height of Floor 1, rather than have the 
sprinkler follow the surface of the terrain. 
See “Terrain Height vs Floor Height” on 
page 539 of the Reference Manual.

Check Auto Adjust Height and enter a 
Floor to Bottom value to set sprinkler’s 

elevation relative to the terrain surface. For 
example, a value of -6” recesses the sprinkler 
head 6 inches below the surface of the 
terrain. 

Check Reverse Symbol to reverse the 
sprinkler from left to right.

Set the sprinkler Spray Angle and 
Spray Radius.

Fill Style Tab
The Fill Style tab controls how the area 
within the sprinkler’s reach displays in floor 
plan view and is similar to the Fill Style tab 
found in many dialogs. See “Fill Style Tab” 
on page 792. 
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The elevation of a sprinkler can be
edited in cross section/elevation views. 
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Materials Tab
The Materials tab lets you control the 
appearance of the selected object in 3D 
views. For information about the settings on 
this tab, see “Materials Tab” on page 635.

Label Tab
Sprinkler labels display in floor plan view 
when the “Sprinklers, Labels” layer is turned 
on and use the Text Style assigned to that 
layer. For information about the settings on 
this tab, see “Label Tab” on page 531.
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Chapter 22:

Roads, Driveways
& Sidewalks

Roads and sidewalks are modeled in 3D like 
other terrain objects in Home Designer Pro. 
Because they have much in common with 
terrain objects and rely upon terrain data to 
be viewed in 3D, it is helpful to be familiar 
with terrain modeling before using these 
tools. See “Terrain” on page 537.

Chapter Contents
•      Road, Driveway and Sidewalk Tools
•      Displaying Road Objects
•      Editing Road Objects
•      Road Specification Dialog
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Road, Driveway and Sidewalk Tools
Road objects can be drawn in floor 
plan view, camera views and 

overviews, but only when a Terrain 
Perimeter exists in the plan. See “Terrain 
Perimeter” on page 538. 

Road objects created with the Road Tools 
have a consistent width that can be defined in 
their specification dialogs. See “Road 
Specification Dialog” on page 586, “Terrain 
Feature Specification Dialog” on page 562, 
and “Terrain Path Specification Dialog” on 
page 566.  

Driveways and Parking Lots are actually 
Terrain Features.  See “Terrain Feature 
Tools” on page 546. They are drawn as 
rectangles but can be edited to any shape. 
See “Editing Closed-Polyline Based 
Objects” on page 138.

Roads and sidewalks are flat along their 
widths, which makes it easy to create roads 
on sloping terrain. Driveways and Parking 
Lots follow the contours of the terrain rather 
than cut into them. 

Once road objects have been placed, they can 
be edited individually or as a group. See 
“Editing Road Objects” on page 586.

Straight Road
To place a road without any curves, 
select Terrain> Road> Straight 

Road and click and drag to draw a line in 
floor plan view. The ends of multiple road 
sections can be connected together.

Roads are edited alone their center line like 
CAD lines and polylines. See “Editing Line 
Based Objects” on page 127.

Spline Road
Use Terrain> Road> Spline Road to 
draw a curved road. Spline roads are 

drawn and edited like CAD splines. See 
“Splines” on page 796. 

A driveway cuts out a curb wherever it meets 
a road.  

Straight Sidewalk
To create a sidewalk with no curves, 
select Terrain> Road and Sidewalk> 

Straight Sidewalk, then click and drag from 
end to end to draw a line. The ends of 
multiple sidewalk sections can be connected 
together.

Sidewalks are edited along their center line 
like line- and polyline- based objects. See 
“Editing Line Based Objects” on page 127. 

Sidewalks can be edited in their specification 
dialog. See “Terrain Path Specification 
Dialog” on page 566.
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Spline Sidewalk
Use the Spline Sidewalk tool to 
create a curved sidewalk. Select 

Terrain> Sidewalk> Spline Sidewalk. 
Spline roads are drawn and edited like CAD 
splines. See “Splines” on page 796.

Driveway Area
A Driveway Area is a terrain feature with a 
concrete material assignment. To create a 
driveway, select Terrain> Road and 
Sidewalk> Driveway Area, then click and 

drag from corner to corner to draw a 
rectangle. See “Polylines” on page 790. 

Height, thickness and material information 
can be specified in a driveway’s specification 
dialog. See “Terrain Feature Specification 
Dialog” on page 562.

Driveways can be edited like other closed 
polylines. See “Editing Closed-Polyline 
Based Objects” on page 138. 

Parking Lot
A Parking Lot is a terrain feature 
with an asphalt material assignment. 

To place a parking lot, select Terrain> Road 
and Sidewalk> Parking Lot, then click and 
drag from corner to corner to draw a 
rectangle. See “Polylines” on page 790. 

Height, thickness and material information 
can be specified in a parking lot’s 
specification dialog. See “Terrain Feature 
Specification Dialog” on page 562.

Displaying Road Objects
Roads and sidewalks display in floor 
plan and 3D views based on the 

settings for their layers in the Layer Display 
Options dialog. See “Layers” on page 101.

In 3D Views
Road objects display in 3D views within the 
Terrain Perimeter. If the display of the 
Terrain Perimeter is turned off in 3D views, 
roads and sidewalks will not display, either: 
even if their layers are turned on.

By default, terrain rebuilds automatically 
when road objects are added, removed or 
edited. If it does not, you can select Terrain> 

Build Terrain . See “Terrain Perimeter” 
on page 538.
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Editing Road Objects
Road objects can be selected individually 
and as a group in 2D and 3D views and 
edited using the edit handles, the edit toolbar 
and their specification dialogs. 

Using the Mouse
The edit handles available for a selected road 
object depend on the type of object selected. 

• Straight Roads  and Straight 

Sidewalks  are edited along their cen-
terline like a line or open polyline. See 
“Editing Line Based Objects” on page 
127. 

• Spline Roads  and Spline Sidewalks 

 are edited along their centerline like 
CAD splines. See “Splines” on page 796.

• Driveway Areas  and Park-

ing Lots  are edited like other closed 
polyline based objects. See “Editing 
Closed-Polyline Based Objects” on page 
138.

In the Specification Dialog
Road objects can be customized in 
their specification dialogs. See “Road 

Specification Dialog” on page 586, “Terrain 
Feature Specification Dialog” on page 562, 
and “Terrain Path Specification Dialog” on 
page 566.

Using the Edit Tools
A selected road object can be edited in a 
variety of ways using the buttons on the edit 
toolbar. See “The Edit Toolbar” on page 29.

Road Specification Dialog
To open the Road Specification 
dialog, select a Straight Road or 

Spline Road and click the Open Object edit 
button. 

Many of the settings in this dialog are similar 
to those in the Terrain Path Specification 
dialog. 

General Tab

1

2
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Specify the Width and Height of the 
road relative to the terrain.

Flare - Roads can be flared at the Start 
and the End when they intersect with 

other road objects. Check one or both boxes.
• Radius - Enter the flare radius.

Polyline Tab
The Polyline tab lists the length of the road’s 
Perimeter, Area and Volume. For more 
information, see “Polyline Tab” on page 792. 

Selected Line/Arc Tab
The Selected Line tab is available when a 
Straight Road is selected. For more 
information, see “Line Tab” on page 780.  

The Selected Arc tab is available when the 
curved segment of a  Straight Road is 
selected. See “Arc Tab” on page 787.  

Spline Tab 
The Spline tab is available when a Spline 
Road is selected. Specify the angle between 
the line segments used to draw the spline. 

For more information, see “Spline Tab” on 
page 792. 

Line Style Tab
This tab is the same as the Line Style tab in 
many other specification dialogs. See “Line 
Style Tab” on page 781. 

Fill Style Tab
The settings on the Fill Style tab affect the 
appearance of the selected object in floor 
plan view. For information about these 
settings, see “Fill Style Tab” on page 792.

Materials Tab
The settings on the Materials tab affect the 
appearance of the selected object in 3D 
views. For information about these settings, 
see “Materials Tab” on page 635.

The material selected here is not calculated 
in the Materials List. See “Materials Lists” 
on page 887. 

1
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Chapter 23:

Other Objects

Home Designer Pro has additional objects 
that can be used to customize your design. 

Chapter Contents
•      General Shapes
•      Soffits
•      Special Applications for Soffits
•      Calculating Materials on Soffits
•      Soffit Specification Dialog

General Shapes
Items in the Home Designer Core Catalogs> 
Shapes library catalog allow you to create a 
variety of custom objects using basic 
geometric shapes. These shapes can can be 

used individually or combined to create a 
wide variety of custom objects. 

General Shape objects are placed and edited 
much like other library objects. See “Editing 
Box-Based Objects” on page 141.

Soffits
Soffits typically fill the space between 
the tops of wall cabinets and the 

ceiling, but they are very versatile and can be 
used to create almost any other object that 
can be modeled as a 3D box. Select Build> 
Cabinet> Soffit to activate this tool.

Soffit Defaults
The default settings for soffits are set in the 
Soffit Defaults dialog. The settings in this 
dialog are similar to those in the Soffit 
Specification dialog. See “Soffit 
Specification Dialog” on page 592.



590

Home Designer Pro 2014 Reference Manual

For best results when placing soffits above 
wall cabinets:
• The default soffit should be the same 

width as and 1" (20mm) deeper than the 
default wall cabinet. See “Cabinet 
Defaults” on page 507. 

• The default soffit Floor to Bottom value 
should equal the sum of the default wall 
cabinet’s Floor to Bottom value plus its 
Height. See “General Tab” on page 593.

• The default soffit Height should be equal 
to or greater than the space between the 
ceiling and the top of the wall cabinets. 

If the sum of the default soffit’s Floor to 
Bottom value and Height is larger than the 
ceiling height of the room in which a soffit is 
placed, the Floor to Bottom value will be 
retained and its Height will be adjusted so 
that it fits under the ceiling. 

The maximum soffit width is 250 feet (48m), 
and the minimum width is 1/16" (1 mm).

Once a soffit is placed in a plan, you can 
change its size and position to meet a variety 
of needs. 

Placing Soffits
Soffits can be created in both 2D and 3D 

views by simply clicking with the Soffit  
tool active. See “Click-to-Create” on page 
113. 

They can be assigned materials that are 
calculated in the Materials List, but by 
default they use the material assigned to the 
default wall. See “Wall, Railing, and Fencing 
Defaults” on page 176.

When positioned against a wall in a room, 
soffits will display any moldings present in 
that room that are at the same height as the 
soffit. See “Moldings Tab” on page 250.

Like cabinets, soffits can also have custom 
molding profiles specified. See “Moldings 
Tab” on page 531.

To create a corner soffit, click as close to an 
inside wall corner as possible. A corner soffit 
retains its shape when it is moved, edited, or 
copied. 

When a soffit is created, it is placed on the 
“Cabinets, Soffits” layer. See “Displaying 
Objects” on page 102. 

Special Applications for Soffits
Nearly any object with straight, flat sides can 
be represented by one or more Soffits. They 
can be resized to as small as 1/16" (1mm) per 
side, or as large as 250 feet (48m).

Soffits can have materials applied to them to 
represent simple mirrors, posts, chimneys 
and so on. Following are some additional 
examples.

Roof Beams and Coffered 
Ceilings

Sloped soffits can be used to represent beams 
or rafters that follow the pitch of the roof in 
rooms with cathedral ceilings. See “Sloped 
Soffits” on page 594.
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Soffits can also be used to create coffered 
ceilings. When placed against a wall, a soffit 
will display any moldings assigned to the 
room it is in that are at its height. In addition, 
you can assign moldings directly to a soffit in 
its specification dialog. See “Moldings Tab” 
on page 594.

Accent Tiles
A material such as ceramic tile can be 
assigned to one or more soffits applied to the 
walls above tubs or in showers.

Masonry Veneer
As an alternative to a pony wall, you can use 
a soffit to create a brick or stone veneer over 
part of a wall. Specify a soffit depth equal to 
the masonry material to be used. 

Soffits automatically stop at the floor 
platform when moved downward or at the 
ceiling platform when moved upward - even 
when the soffit is not located in a room. To 
more or resize a soffit through a floor or 
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ceiling platform, select it and hold the Ctrl 
key down while dragging its edit handles. 
See “Unrestricted Movement” on page 153.

Calculating Materials on Soffits
The number of bricks, tiles, shingles, shakes 
or other materials applied to a soffit is 
calculated using the following rules:
• If the soffit depth is less than the larger of 

4 inches (10 mm) or 1 ½ times the mate-
rial thickness, then only the front area of 
the soffit is used. Thus if a soffit is 
48"x48”x4” thick, and the Dark Red 
brick material is used (3"x 8" with 3/8” 
mortar joint) the front of the soffit is 
48"x48”=2304 square inches. Including 
the mortar joint, each brick requires 3 3/
8” x 8 3/8” = 28.26 square inches. 2304 
sq. in. divided by 28.26 sq. in. per brick 
gives 81.5 bricks.

• If the soffit depth is greater than both 4 
inches (10 mm) and 1 ½ times the mate-
rial thickness, then the surface areas of 
the soffit back, sides and top are used in 
addition to the front, if these surfaces are 
not attached to a wall or other soffit. 
However, only those portions of the 
sides, top and bottom remaining after 

subtracting twice the material thickness 
are used. So, for Dark Red brick, which 
has a depth of 4", the sides, top and bot-
tom surface areas cannot contribute to the 
brick count unless the soffit depth is 
greater than 8 inches.

• If surface materials such as brick are 
applied to a large soffit, the soffit center 
is assumed to be hollow, with only a sin-
gle layer of the material applied to each 
applicable face.

• For shingles and shakes, the overlap 
amount should be subtracted from the 
height, as opposed to brick or tile, where 
the joint width is added to the size.

• For materials in the area category, the 
soffit area calculation above is used, with 
the material thickness treated as zero.

• For materials in the volume, concrete or 
earth categories, the true volume of the 
soffit is used.

Soffit Specification Dialog
To customize a soffit using the Soffit 
Specification dialog, double-click on 

the soffit using the Soffit  tool or select 
the soffit and click the Open Object edit 
button.

The settings in this dialog are similar to those 
in the Soffit Defaults dialog, but affect only 
the selected object(s). 
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General Tab

Define the Size and Position of the 
selected soffit relative to the floor or 

terrain. 
• Specify the Width of the soffit. 
• Define the vertical Height of the soffit. 
• Depth - Define the distance between the 

front and the back of the soffit. When 
selected in floor plan view, the front of a 
soffit has a “V,” and the back of the soffit 
has a triangular rotation handle.

• If the selected soffit is a corner soffit, the 
Width controls its left side width, and 
Depth controls its right side width. 

• Floor to Bottom - Specify the distance 
from the bottom of the soffit to the floor. 
This is sometimes more easily done by 
positioning the soffit in a 3D view.

• Height at Front applies to sloped soffits 
and becomes enabled when Sloped Sof-
fit  is checked. See “Sloped Soffits” on 
page 594.

• When the selected soffit is outside a room 
and Auto Adjust Height is checked , its 
Floor to Bottom height is measured rela-
tive to the terrain height. When this is 
unchecked, the Floor to Bottom height is 
measured from the default floor height of 
Floor 1. See “Terrain Height vs Floor 
Height” on page 539 of the Reference 
Manual. 

Options - Specify a sloped soffit and/or 
position relative to the roof or ceiling. 

• Check Sloped Soffit to slope the soffit 
vertically from the back up towards the 
front. When you specify a soffit as 
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sloped, the options on the General tab 
change. See “Sloped Soffits” on page 
594.

• Check Place Under Roof to have the sof-
fit’s slope follow that of the roof. The 
soffit moves up and the top of the soffit is 
in the same plane as the roof, at the same 
pitch as the roof. Be sure to place the 
front of the soffit toward the high side of 
the roof. Only available when Sloped 
Soffit is checked. Not available in the 
Soffit Defaults dialog.

• Check Place Under Ceiling to move the 
soffit vertically until the top contacts the 
ceiling plane. Not available in the Soffit 
Defaults dialog. 

A preview of the soffit displays on the 
right side of the dialog box.

Check Show Color to display the 
soffit’s material in the preview.

Moldings Tab
For information about the settings on this 
tab, see “Moldings Tab” on page 531.

Fill Style Tab
The settings on the fill style tab affect the 
selected soffit’s appearance in floor plan 
view. For information about the settings on 
this tab, see “Fill Style Tab” on page 792.

Materials Tab
For information about the settings on this 
tab, see “Materials Tab” on page 635.

Label Tab
Soffit labels display in floor plan view when 
the “Cabinets, Labels” layer is turned on and 
use the Text Style assigned to that layer. The 
Automatic Label for Soffits is blank, but you 
can specify a custom label. See “Cabinet 
Labels” on page 515. 

For more information about the settings on 
this tab, see “Label Tab” on page 885.

Sloped Soffits
When a soffit is specified as a sloped soffit, 
the options on the General tab of the Soffit 
Specification dialog change. 
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• Width is measured left to right across the 
soffit, parallel to the frontof the soffit.

• Thickness is measured perpendicular to 
the slope of the soffit.

• Horizontal Length is measured from 
back to front in floor plan view. Since the 
soffit is sloped, this measurement is not 
the actual length of the soffit. It cannot, 
for example, be used to determine the 
length of a sloped beam.

Both the front and back heights of a sloped 
soffit must be defined.
• Height at Back is measured from the fin-

ished floor to the lowest point at the back 
of the soffit.

• Height at Front is measured from the 
finished floor to the underside of the sof-
fit at the upper end.
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Chapter 24:

Architectural
Blocks

An architectural block is a collection of 
individual 3D objects that are grouped 
together so that they can be placed and 
moved as a single object. Although blocked 
together, these objects retain many of their 
own attributes, such as materials.

Architectural blocks can also be exploded so 
that the individual sub-objects become 
independent of one another.

Chapter Contents
•      Creating Architectural Blocks

Creating Architectural Blocks
An architectural block is created by 
group-selecting multiple architectural 

objects and then clicking the Make 
Architectural Block edit button. 

The following is a list of objects that can be 
included in architectural blocks:
• Cabinets (Base, Wall, Full Height)
• Soffits, Shelves, Partitions
• Fixture/Furniture Symbols 
• Hardware Symbols
• Millwork Symbols

• Geometric Shape Symbols
• Electrical objects
• Images
• Custom Countertops
• Slabs & Foundation Slabs
• Roads, Driveways, Sidewalks
• Terrain Features and Terrain Modifiers

Once blocked, the set of blocked objects is 
contained in a bounding box, indicating that 
they are now an architectural block. 
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Architectural blocks can be created in any 
view. 
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Displaying Architectural Blocks
Architectural blocks are placed on the 
“Architectural Blocks” layer and can be 
displayed in all views. The display of 
architectural blocks, including their 
bounding box, is controlled in the Layer 
Display Options dialog. See “Displaying 
Objects” on page 102.

You can select an architectural block and 

click the Move to Front  edit button to 
make that block display in front of other 
objects in the same drawng group, including 

cabinets and some library symbols. See 
“Move to Front of Group” on page 151. 

Architectural Block Labels
In floor plan view, architectural blocks can 
display labels for both the block and any 
component objects that have labels.  Labels  
for architectural blocks are placed on the 
“Architectural Blocks, Labels” layer and use 
the Text Style assigned to that layer. See 
“Object Labels” on page 884.

Editing Architectural Blocks
Architectural blocks can be selected and 
edited in 2D and 3D views. See “Selecting 
Objects” on page 124. 

Once selected, an architectural block can be 
edited using its edit handles and edit toolbar 
buttons.

Using the Edit Handles
A selected architectural block displays a 
Move handle and a Rotate handle.  

Architectural blocks cannot be resized, but 
the individual objects in the block can be. 

Using the Edit Tools
A selected architectural block or blocks can 
be edited in a variety of ways using the 
buttons on the edit toolbar. See “The Edit 
Toolbar” on page 29.

Editing Sub-Objects
The individual objects included in an 
architectural block can also be selected and 
edited. See “To select a sub-object” on page 
600.

Explode Architectural Block
You can break an architectural block 
to make its objects independent. 

Select the architectural block and click the 
Explode Architectural Block edit button.  

Note: Moving an architectural block in 3D
view regenerates the view. If the architectural
block contains terrain objects, the terrain is
rebuilt.
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Once exploded, an architectural block cannot 
be made into a single object again. 

Architectural Blocks, Sub-Objects, and Components
An architectural block is composed of a 
group of sub-objects that have been blocked 
together. For example, a kitchen island 
architectural block may consist of cabinets, 
appliances, a custom countertop, and other 
accessories.

Each of the sub-objects in an architectural 
block may contain additional parts called  
components. The cabinets in a kitchen island, 
for example, may contain handles, hinges, 
and drawer glide.

Sub-Objects
Certain attributes of an architectural block 
can be edited at the sub-object level. A sub-
object can be edited by accessing its 
specification dialog in either of two ways:
• Explode the architectural block, select 

the sub-object, and click the Open 

Object  edit button.
• Select the sub-object while it is part of 

the architectural block and click the 

Open Object  edit button. Some attri-
butes may not be editable while the 
object is part of a block. See “Editing 
Architectural Blocks” on page 599.

To select a sub-object

1. Click the Select Objects  button, 
then click on the sub-object that you 
would like to edit.

2. With the architectural block selected, 

click the Select Next Object  edit 
button or press the Tab key. 
The selection switches to the individual 
object and it can be edited using its edit 
handles, edit toolbar and specification 
dialog.

The ability to edit an object as part of a block 
may be more restricted than if the object 
were independent. If more extensive editing 
is required, the architectural block must be 
exploded.  

Components
You can view and/or modify the 
components of an architectural block 

(or group of blocks) through the 
Components dialog. The Components 
dialog lists all the sub-objects that comprise 
an architectural block, as well as the 
components that make up each sub-object.

To open the Components dialog, select an 
architectural block and click the 

Note: If you open a plan created in another
version of Home Designer and an architec-
tural block includes an object that you cannot
create in your version of the software, you
cannot unblock it or edit its components. 
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Components  edit button. See 
“Components Dialog” on page 901.
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Chapter 25:

The Library

Home Designer Pro’s library offers 
thousands of symbols, materials, and images 
that can enhance any plan. 

New library catalogs and enhancements are  
made available by Chief Architect on a 
continuing basis and are available for 
download for the current program version. 

You can also customize items from the 
library or import new items from outside the 
program and then save them in the library for 
future use.

Chapter Contents
•      The Library Browser
•      Searching the Library
•      Library Content
•      Downloading Library Content
•      Importing Library Catalogs
•      Adding Library Content
•      Organizing the Library
•      Filtering the Display of Library Content
•      Exporting Library Catalogs
•      Placing Library Objects
•      Select Library Object Dialog
•      Replace From Library
•      Displaying Library Objects
•      Editing Library Objects
•      Symbol Object Specification Dialogs
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The Library Browser
The Home Designer Pro Library 
Browser allows you to manage the 

contents of the library as well as add library 
content to your drawings. 

To open the Library Browser:

• Select Library> Library Browser .

• Click the Library Browser button .
• Press Ctrl + L on your keyboard.

By default, the Library Browser is docked to 
the right side of the program window, but can 
be undocked or docked to another side. See 
“Docking the Library Browser” on page 608.

The Library Browser has four sections: 
• The search options at the top. 

• The Directory and Search Results Pane. 
• The Selection Pane. 
• The Preview Pane. 

To adjust the height or width of a section, 
place the pointer over the split bar you want 
to move. When the double-headed arrow  
displays, click and drag. 

You can work on your drawing with the 
Library Browser open. To close the Browser, 
click the Close  button or double-click on 
an object in the Selection Pane. 

You can control the configuration of the
Library Browser panes in the Prefer-

ences dialog. See “Library Browser Panel” on
page 65.
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The library has five categories: Home 
Designer Core Catalogs, Home Designer 
Bonus Catalogs, Manufacturer Catalogs, 
User Catalog and Trash. See “Library 
Content” on page 609. 

Specify what displays in the Directory 
Pane’s tree list by selecting a filter from 

the drop-down list. See “Filtering the Dis-
play of Library Content” on page 618. 
• When “Not Filtered” is selected, all 

installed library content will display in 
the tree list.

• “Not Filtered” will be the only available 
option until you create a custom filter.

• Click the Manage Library Filters  
button to open the Manage Library 

Filters dialog. See “Manage Library Fil-
ters Dialog” on page 619. 

Search the library using keywords and 
optional search filters. See “Searching 

the Library” on page 608.
• Begin typing in the text field to search for 

library items. As you type, search results 
will display in the Directory Pane. 

• Right-click on an item in the Search 
Results list and select Show in Browser 
to view the item’s location in the Direc-
tory list.

• Click the Browse  button to stop 
searching and restore the Directory list.

• Click the Search  button to display the 
search results for your search entry.

1

3
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• Click the Turn On Search Filtering  
button to display the search filtering 
options and customize your search 
parameters. 

• Click the Turn Off Search Filtering  
button to display the search filtering 
options and customize your search 
parameters. 

The library Directory and Search 
Results display here. The basic 

structure of the directory tree is: 

Library items are always placed in 
alphabetical order within their heirarchy.

The Library Browser includes a Trash bin, 
where deleted items are moved until you 
choose to Empty Trash. See “Deleting 
Library Items” on page 617.

Navigate the Directory Pane using the 
mouse. Click the  beside a catalog or 
folder to display its contents. Once 
expanded, you can click the  beside it to 
close it again. You can also scroll the list 
using the arrow keys on your keyboard. 

Click on an item to select it. Preview images 
display in the Selection and Preview Panes 
and basic information about it also displays 
in the program’s Status Bar. See “The Status 
Bar” on page 31.

The Selection Pane shows a thumbnail 
image of the item selected in the 

Directory Pane.  

When an item is selected in the Directory 
Pane, a basic line-based representation of the 
item displays in the Selection Pane.
• If the selected item is a single object, a 

preview of that object displays in the Pre-
view Pane. You can move your cursor 
into the drawing area to place the item. 
See “Placing Library Objects” on page 
620. 

• If the selected item is a folder, a thumb-
nail image displays, representing each 
item inside. Move your pointer over an 
item in this pane to see a Tool Tip with 
the item’s name. Click on a folder in the 
Selection Pane to display its contents 
here and make it the item selected in the 
Directory Pane.

• Some folders may have too many items 
to display useful thumbnails for each; 
when this is the case, they do not display.

If you have Scrollable List checked in the 
Preferences dialog, a scroll bar is present at 
the bottom of the Selection Pane. 

Click the Show/Hide Selection Pane  
button to toggle the Selection Pane on and 
off.

When an individual object is selected in 
either the Directory or Selection Pane, 

an image of it displays in the Preview Pane. 

You can click the Toggle Display  button 
at the bottom of the browser window to 
switch between preview images in Standard 
Render and Vector View styles. 

If the selected object is a 3D symbol, you can  
rotate and zoom in or out on the Preview 
using the mouse.

3

4

5
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If you have rotated a view in the Preview 
Pane, you can restore the default angle either 
by clicking in the Selection Pane or by right-
clicking on the Preview Pane and selecting 
Reset Preview.  

Click the Show/Hide Preview Pane  
button to toggle the Preview Pane on and off. 

The toolbar at the bottom of the 
browser aids in searching, displaying 

panes, and managing library content. 

Click the Plant Chooser button to 
open the Plant Chooser dialog. See 

“Plant Chooser Dialog” on page 577.

Click the Get Additional Online 
Content button to launch your default 

web browser to the Home Designer Pro web 
site, where additional library content is 
available for download.

Click the Show/Hide Selection Pane 
button to toggle the Selection Pane on 

and off.

Click the Show/Hide Preview Pane 
button to toggle the Preview Pane on 

and off.

Click the Toggle Display button to 
switch between Standard Render and 

Vector View images of a selected library 
object in the Preview Pane. See “Rendered 
and Vector Views” on page 665. 

Click the Preferences button at the 
bottom of the Library Browser to open 

the Preferences dialog, where display 
properties for the Library Browser can be 
controlled. See “Library Browser Panel” on 
page 65. 

Using the Contextual Menus
A number of important library functions can 
be accessed using the contextual menus. 
Right-click on an item in the Library 
Browser to open a contextual menu 
displaying options related to that item. See      
Contextual Menus.

The options in the contextual menu vary 
depending on the item selected, but may 
include: 
• Cut/Copy/Paste
• Paste Shortcut
• Rename
• Delete
• Export Library
• Open
• Components
• Reset Preview
• Expand All/Collapse All
• Show in Browser

Keyboard Commands
The Library Browser can be navigated using 
the arrow keys on your keyboard. 
• The right and left arrow keys expand and 

collapse folders.
• The up and down keys change which 

library object is currently selected.

6
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• Select an item and press F2 to rename it.
• Select an item and press the Delete key to 

delete it. 

If you have Scrollable List selected in the 
Preferences dialog, pressing the Tab key 
switches focus between the Directory and 
Selection Panes. Use your mouse to select an 
object for placement. See “Library Browser 
Panel” on page 65.

If you have Tiled To Fit Window selected 
instead, pressing the Tab key switches focus 
between the tree view and the Selection 
Pane. You can then use the arrow keys to 
select a library object within the Selection 
Pane.

Expand/Collapse All
When a library category or folder is selected 
in the Directory Pane, Expand All and 
Collapse All are available in the contextual 
menu, allowing you to expand or contract its 
contents in the tree view.

Docking the Library 
Browser

Initially, the Library Browser is docked to 
the right side of the Home Designer Pro 
program window.

To undock the browser window, double-click 
the striped grab bar. You can also undock it 
by clicking on the grab bar and dragging it 
into the center of the program window.

Once undocked, the Library Browser can be 
moved by clicking and dragging the title bar.

When moved to the top, bottom, or side of 
your screen, it automatically docks in a 
vertical or horizontal orientation, depending 
on its location.
• Disable Docking in the Preferences 

dialog prevents the Library Browser from 
docking to the side of the screen. See 
“Library Browser Panel” on page 65. 

• Holding down the Ctrl key prevents the 
Library Browser from docking while 
moving.

• If you close the program with the Library 
Browser docked, it displays in the same 
position the next time the program is 
opened. 

To return the browser window to its original 
position and size, click the Restore Position/
Size button on the Library Browser Panel of 
the Preferences dialog.

Closing the Library 
Browser

The Library Browser can be closed in either 
of two ways: 

• Click the Close  button at the top right 
corner of the browser window.

• Select Library> Close Library 

Browser .

Searching the Library
The Library Browser filtering options let you 
focus your searches to meet parameters that 
you define. 
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To search the Library Browser

1. Select Library> Library Browser  
and click in the Search field at the top of 
the Library Browser.

2. Begin typing a keyword to search for.
3. As you type, the search results will pop-

ulate in the Directory Pane below.
4. If you move your mouse pointer over the 

Search field, a Tool Tip will state the 
number of results of your search.

5. Right-click on an item in the Search 
Results list and select Show in Browser 
to view the item’s location in the Direc-
tory list.

Substrings are not included. For example, 
searching for “windows” will not produce 
“window” as a search result. On the other 
hand, searching for “window” will produce 
“windows” as a search result.

To search using custom filters

1. Click the Turn on search filtering 
optons  button. 

•  Check Match Keyword to match the 
entered search keyword with an 
object’s search attributes. 

•  Check Match Entire Word to match 
the entire keyword or words with the 
complete name of the object. 

•  Check Match Folders to include 
library folders in your search.

2. Check Filter by to enable additional fil-
tering options, which display below.

3. Select a filtering option from the drop-
down list on the left, then choose what to 
include in the filter from the drop-down 
list on the right:

•  Select Type, then select a category of 
library item to include in your search.

•  Select Style, then choose a design style 
to restrict the search results to objects 
of that style.

•  Select Manufacturer, then choose the 
name of a manufacturer to include in 
your search. Manufacturer catalogs 
that were imported during the current 
program session will not be listed until 
you exit out of and restart Home 
Designer Pro.

4. Multiple filters can be created and used 
at the same time:

•  Click the Add  button to the right of 
a filter to make copy of that filter.

•  Specify a new Type, Style, and/or 
Manufacturer for the new filter. 

•  Click the Delete  button to the right 
of a filter to remove that filter.

Library Content
The Home Designer Pro library has five 
categories: Home Designer Core Catalogs, 
Home Designer Bonus Catalogs, 

Manufacturer Catalogs, User Catalog and 
Trash. See Getting Started Guide, “Deleting 
Library Items” on page 617.

Note: Your custom search settings are not
retained when you end the current program
session.
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Home Designer Core Catalogs
The Home Designer Core Catalogs category 
contains a wide selection of 3D symbols, 
images, and materials. When you install the 
program from DVD, this library content will 
also be installed; if you download the 
software, you will be able to download the 
Core Catalogs separately, after the program 
is installed. 

When you launch the program for the first 
time, it will ask if you want to download the 
Core Catalogs. Click Yes to begin the 
download. If you click No, you can 
download at any time by selecting Library> 
Install Core Content from the menu. 

Home Designer Bonus Cata-
logs

Chief Architect regularly posts new library 
catalogs available for download. Select  
Library> Get Additional Content 

Online  from the menu to access the 
bonus catalogs and content. 

Manufacturer Catalogs
A variety of  name brand library catalogs are 
available for download on the Home 
Designer web site with content ranging from 
materials to fixtures.

Select Library> Get Additional Content 

Online  to access these Manufacturer 
Catalogs. 

The User Catalog
The User Catalog is the location for items 
that you add to the library either from a 

drawing or by importing. See “Adding 
Library Content” on page 613. 

You can create and organize custom library 
folders and imported items such as symbols, 
images, backdrops, and materials. See 
“Organizing the Library” on page 615.

Updating Library Catalogs
The Home Designer Core Catalogs, Bonus 
Catalogs, and Manufacturer Catalogs are 
updated periodically to include new and 
improved content. You can update your 
installed catalogs to include the latest content 
by selecting Library> Update Library 
Catalogs at any time. 

The program will gather information about 
the content in each of these three categories, 
and then download and replace any content 
that is not up to date, and you may see a 
progress indicator at the bottom of the 
Library Browser while it is doing so. See 
“Download Progress” on page 611.

Backing up Library Content
The Home Designer Pro User Catalog File, 
User_Library.calib, is located in the Home 
Designer Pro 2014 Data folder. See “Home 
Designer Pro Data” on page 41. 

The best way to back up your custom library 
content is to export the items in your User 
Catalog, as this will ensure that the textures 
used by custom materials or imported 
symbols are not lost. See “Backing Up Your 
Files” on page 45. 

Exported libraries use the .calibz file format: 
a zipped file type that can include textures 
and images along with other library data.
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To back up your custom library content

1. Launch Home Designer Pro and select 

Library> Library Browser  from 
the menu.

2. Right-click on a folder or item in the 
User Catalog. 

3. Select Export Library fron the contex-
tual menu.

4. The Export Library Data dialog is a typ-
ical Save dialog. See “Exporting Files” 
on page 45.

•  Notice that the file type in the Save as 
type field is “Library File with Tex-
tures/Images (*.calibz)”.

Downloading Library Content
The Home Designer Core Catalogs, Home 
Designer Bonus Catalogs, Manufacturer 
Catalogs are all available for internet 
download. 

Core Catalogs
When you launch Home Designer Pro for the 
first time, you will be asked if you want to 
download the Core Catalogs. Click Yes to 
begin the download. 

If you click No, you can download at any 
time by selecting Library> Install Core 
Content from the menu. 

Bonus and Manufacturer 
Catalogs

Bonus and Manufacturer Catalogs can be 
downloaded from our web site,
 www.homedesignersoftware.com. Select 
Library> Get Additional Content 

Online  to launch your default internet 
browser to our Content Resources page. 

Download Progress
When library content is downloading, a 
green progress bar will display at the bottom 

of the Library Browser. If you choose to 
download the Core Catalogs while the library 
is not open, the Browser will open so the 
progress indicator can display. 

Click on the progress bar to display the name 
of the current file being downloaded, the 
total amount of data to be downloaded in 
KB, and the amount downloaded so far.

Pausing and Resuming
Library downloads can only take place while 
Home Designer Pro is running. If you close 
the program while a download is in progress, 
a dialog will confirm whether you wish to 
stop the download.
• Click Stop Download and Close Pro-

gram to stop the download and close the 
program. 

• Click Cancel to leave the program open 
and continue downloading. 



612

Home Designer Pro 2014 Reference Manual

Most catalogs are composed of a single file. 
If you stop the download midway, none of 
the downloaded data will be retained.

The Core Catalogs, on the other hand, 
contain a large volume of data saved in 
multiple files. If you close the program and 
stop the Core Catalogs download midway, 
only data associated with the file currently 
being downloaded will be lost. You can 
resume the download beginning with that file 

at a later time by selecting Library> Install 
Core Content.

Download Errors
If any problems occur during the library 
download process, a dialog box will notify 
you at the end of the download. Click Retry 
Download to repeat the download and 
correct any errors or click Cancel to discard 
the downloaded catalog. 

Importing Library Catalogs
Home Designer Pro library files have two 
different file extensions: .calib and .calibz. 
Both files can include any combination of 
Home Designer Pro library items; in 
addition, .calibz files are able to save data 
associated with textures and images. Both 
file types can be imported into the Home 
Designer Pro library.

There are several ways to import a .calib or 
.calibz file into the program library:
• Double-click on the file in Windows 

Explorer.
• Drag the file from a Windows Explorer 

window and drop it into the Home 
Designer Pro program window. 

• Select Library> Import Library from 
the program menu.

To import library files into the library

1. Select Library> Import Library to dis-
play the Import Library Data dialog.

2. Browse to the .calib or .calibz file(s) 
that you want to import and either single 

or group-select the files so that their 
names display in the File Name field.

•  To select a group of files, click on the 
first one, hold down the Shift key, then 
click on another file. The two files plus 
all files in between are selected.

•  To select multiple files individually, 
click on one, hold down the Ctrl key, 
then click on additional files. Only the 
files you click on are selected.

•  To select all files in the directory, click 
on one and press Ctrl + A. Only do this 
if you wish to import all files in the 
folder.

3. Click the Open button. 
4. A progress bar will display, telling you 

the progress of each library data file as it 
is imported. Once imported, each file 
will be located in the User Catalog.

When a .calib or .calibz file is imported into 
the program, its contents are automatically 
placed in the User Catalog. Any images or 
textures saved in a .calibz file will be copied 
into the Home Designer Pro 2014 
Data\Images and Textures folders for backup 
purposes. The program will only reference 
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these copies if it cannot locate the files in 
their original locations. See “Home Designer 
Pro Data” on page 41. 

Legacy Library Conversion
You can import .calib and .calibz files 
created in Home Designer versions 2012, 10, 
or 9 for use in version 2014 at any time. See 
“Exporting Library Catalogs” on page 620.

In addition, legacy .alb files created in Home 
Designer versions 8.0 and prior can be 
converted for use in version 2014. 

To convert legacy library files

1. Select Library> Convert Legacy (.alb) 
Library Files. 

2. In the Select a Legacy Library File 
Folder dialog, select one or more .alb  
files that you want to bring in to Home 
Designer Pro 2014.

3. The selected files’ names will display in 
the File name: field.

4. Click the Open button to import these 
prior version third party .alb files into 
the User Catalog.

5. Organize the imported content to suit 
your needs. See “Organizing the 
Library” on page 615.

Third Party Library Content
There are a variety of third party sources for 
3D symbols, textures and other items that 
may be of use in Home Designer Pro. Some 
sources even provide this content in .alb file 
format, which was the library file format 
used by Home Designer Pro versions 8.0 
through X1. These third party libraries can 
be converted for use in Home Designer Pro 
2014 as described above. 

Adding Library Content
In addition to downloading Home Designer 
Pro Content and importing entire catalogs 
into the library, you can also add a variety of 
individual objects to the library. 

Add to Library
Nearly any object imported into a plan or 
placed from the Library Browser can be 
added to the User Catalog in the library. 
• Check Add to Library in the Import 3D 

Symbol dialog. See “Importing 3D 
Symbols” on page 838.

• Select an object in your plan and click the 

Add to Library  edit button.

In addition, some Home Designer Pro 
objects that are not symbols, such as 
cabinets, terrain objects, architectural blocks, 
windows, and doorways can be added to the 
library. See “Native Objects vs Symbols” on 
page 626.

An object created using a drawing tool in 
Home Designer Pro will automatically be 
added to the User Catalog using the name of 
that tool, whereas a symbol imported will 

Note: Library content exported from Home
Designer Pro 2012 will not include catalog
names. Any subscribed content that has not
been downloaded will not be included, either. 
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automatically use the Symbol Name. These 
objects can be renamed after adding them to 
the Library, either before or after moving 
them to their appropriate user created folder 
in the User Catalog. See “Renaming Library 
Items” on page 616. 

Adding Materials and Images
New materials, images, and plant images can 
be created in the User Catalog. Right-click 
on the User Catalog or a folder within it, 
select New> from the contextual menu, then 
select the type of item you wish to create 
from the submenu. 

Home Designer Pro can use materials and 
images in a variety of file formats and 
provides several means of adding new 
material and image files to the library. For 
more information, see “Creating Materials” 
on page 637 and “To create an image in the 
Library Browser” on page 807. 

Adding New Backdrops
Backdrops are images that display behind the 
model in 3D views. See “3D Backdrops” on 
page 679.

New backdrops can be created using a 
variety of graphic file formats. Backdrops 
are automatically adjusted to fit the window 
size, so they look best when they are created 
with the same height to width proportions as 
the window you are working in.

To add a backdrop to the library

1. Select File> Import> Backdrop  to 
open the Import Backdrop File dialog, 
which is similar to the Import Picture 
File dialog. See “Importing Pictures” on 
page 812.

2. Browse to an image file on your com-
puter, select it, and click Open. This 
backdrop can now be found in the My 
Backdrops library.

You can also create a new backdrop by 
copying and pasting an image into Home 
Designer Pro. See “Copying and Pasting 
Objects” on page 114. 

Adding 3D Symbols
An imported symbol can be added to the 
library in either of two ways.

To import 3D symbols into the library

1. Select File> Import> 3D Symbol . 
2. In the Import 3D Symbol dialog, make 

sure Add Symbol to Library is 
checked. See “Import 3D Symbol 
Dialog” on page 838.

3. Browse to the 3D file(s) that you want to 
import and either single or group-select 
the files so that theirits names displays 
in the File Name box.

4. Click the Open button.
•  A progress bar will display telling you 

the progress of each symbol, and once 
it has completed importing a file, that 
symbol will be located in the Import 
category of the Library Browser.

You can create digital photos of a build-
ing site for use as a backdrop.
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5. Click and drag the imported content to 
the appropriate folder that you have cre-
ated for it in your User Catalog.

If Add Symbol to Library is not checked 
when a symbol is imported into the program, 
you can still add it to the library at a later 
time by selecting it and clicking the Add to 

Library  edit button. See “Add to 
Library” on page 613.

Adding a Customized Object
You can customize an existing library object 
and save your changes for future use by first 
copying the item into an unlocked library. 

To customize a library object

1. Right-click on a library item and select 

Copy  from the contextual menu.
2. Browse to an unlocked library or library 

folder and right-click on it.
3. Select Paste from the contextual menu 

to make a copy of the library item in this 
new location.

4. Right-click on the copied item and select 

Open  from the menu.
5. The item’s specification dialog opens, 

and you can make any changes that you 
wish to the item.

6. Make any needed changes to the item, 
then click OK. Your changes will be 
saved with this item for use in any plan.

Organizing the Library
Library folders and objects can be copied, 
pasted, moved, and deleted: allowing you to 
organize your User Catalog to best suit your 
work style and needs.  

Adding New Folders
New folders can be added to the User 
Catalog or to any folder located within it. To 
add a new folder, right-click on User Catalog 
or one of its sub-folders and select New> 
Folder from the contextual menu. 

The new folder is created inside the library 
item you right-clicked on and is initially 
named “Untitled”. Type a short, descriptive 
name and press Enter. 
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Selecting Library Items
To select a library object, folder, or category, 
simply click on it. You can also multiple-
select library items:

•  To select a group of items, click on the 
first one, hold down the Shift key, then 
click on another file. The two files plus 
all files in between are selected.

•  To select multiple items individually, 
click on one, hold down the Ctrl key, 
then click on additional files. Only the 
files you click on are selected.

When an item is selected, preview images 
display in the Selection and Preview Panes 
and basic information about it also displays 
in the program’s Status Bar. See “The Status 
Bar” on page 31. 

A selected library item can be modified in a 
number of ways to help meet your 
organizational needs. When multiple items 
are selected, these options may be limited 
depending on the specific selection set. 

Renaming Library Items
Only folders and objects in the User Catalog 
can be renamed. There are several ways to do 
this from the tree list: 
• Right-click on the item, select Rename 

from the contextual menu, and type a 
new name. 

• Click once on the item, press F2 on your 
keyboard and type a new name.

• Click once on the item, pause for a 
moment, then click a second time and 
type a new name.

Library names are case-sensitive and can 
contain up to 63 characters. While you can 
have more than one library item that uses the 

same name, it is best to use short, descriptive 
and unique names.

Moving Library Items
Folders and objects in the User Catalog can 
be moved to new locations within the User 
Catalog. Folders and library objects are 
always organized alphabetically within each 
hierarchy.

To move one or more items to a different 
location, select it in the tree list, then click 
and drag it to the new location in the list. 
Directories and folders able to accept new 
content highlight as your ouse pointer moves 
over them. Release the mouse button to 
relocate the selected library item in the 
highlighted location.

Copying Library Items
All library folders and library objects can be 
copied and pasted to new locations in the 
User Catalog. 

There are two ways to copy one or more 
library items to the Windows Clipboard: 
• Right-click on it and select Copy from 

the contextual menu. 
• Click on the library item and press 

Ctrl + C on your keyboard.

To Paste the item, click on a library catalog 
or folder in the Library Browser tree view 
and either:
• Right-click on the new location and 

select Paste from the contextual menu.
• Press Ctrl + V on your keyboard. 

When a library item is copied and pasted, the 
new item that results is independent of the 
original item. If you make changes to it, the 
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original item is unaffected. Similarly, 
changes to the original item do not affect the 
copy.

Library Shortcuts
In addition to copying and pasting to create 
new, independent library items, you can copy 
and paste to create Library Shortcuts. Library 
Shortcuts are not independent items - they 
are linked to the original item and are 
affected if changes are made to the original.

Library Shortcuts are advantageous because 
you can place a given library item in multiple 
locations to suit your organizational style 
without increasing the size of the library 
database and without having to maintain 
multiple copies of the same item.

To create a Library Shortcut, copy a library 
item to the Windows Clipboard. Then, right-
click on the location where you would like to 
create a copy and select Paste Shortcut from 
the contextual menu. Library Shortcuts use 
the same name as their source item but use 

the Library Shortcut  icon.

To locate a Library Shortcut’s source item, 
right-click on it in the tree list and select 
Locate Shortcut Source 

If you move or delete an item from the 
library, any shortcuts to it will not be updated 
or removed. If you try to use a “hanging” 
shortcut, a message about its status will 
display in the library preview panes.

Deleting Library Items
The five installed library categories: Home 
Designer Core Catalogs, Home Designer 
Bonus Catalogs, Manufacturer Catalogs, 
User Catalog, and Trash cannot be deleted. 

Catalog level folders in all categories can be 
deleted; however, individual subfolders and 
objects can only be deleted out of the User 
Catalog.

Items in the library that are eligible for 
deletion can be deleted in either of two ways: 
• Right-click on it and choose Delete from 

the contextual menu.
• Select it and press the Delete key on your 

keyboard.

When items from the User Catalog are 
deleted, they are moved to the Library 

Browser Trash . Items in the Trash can be 
retrieved by clicking and dragging them into 
any location in the User Catalog.

To empty the Trash , right-click on it and 
select Empty Trash from the contextual 
menu. 

Depending on how much content is in the 
Trash, emptying it can be time consuming. 
You can click the Cancel button to end the 
process if you wish. 

The Empty Trash command is both
immediate and permanent. It cannot be

undone, so use care when using it. You
should back up all your library files regularly.
See “Backing up Library Content” on page
610. 
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Filtering the Display of Library Content
Depending on how much library 
content you have imported or 

customized, the tree list in the Directory 
Pane can be very large. You can control what 
content displays in the list using Library 
Filters. 

Library Filters do not remove content from 
the library database. They do, however, 
affect the library Search: unless you check 
Include Filtered in the advanced Search 
options, library content that is not displaying 
is not included in your searches. 

You can also set up filters for your library 
Search results, but these two types of filters 
are unrelated. See “To search using custom 
filters” on page 609. 

Library filters can be created, edited, and 
deleted in the Manage Library Filters dialog. 

Click the Manage Library Filters  
button at the top of  the Library Browser to 
open this dialog or select Library> Manage 

Library Filters  from the menu.

Any library filters that you create will be 
listed in the Active Filters list at the top of 
the Library Browser. Select a filter from the 
list to display content in the library tree list 
according to its settings. See “The Library 
Browser” on page 604. 

You can also add the Manage Library
Filters button to your toolbars and
assign a hotkey to it. See “Toolbars &

Hotkeys” on page 91. 
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Manage Library Filters Dialog

A list of available library filters 
displays here. Click on a filter in the list 

to select it. The Selected Filter is highlighted 
and can be edited using the options to the 
right.

Click the New button to create a new 
filter or click the Delete button to 

remove the Selected Filter from the list.

Select the Active Filter from the drop-
down list. This is the filter in use in the 

Library Browser when the Manage Library 
Filters dialog is closed. 

Specify the Name of the Selected 
Filter. 

A list of all Home Designer Core, 
Home Designer Bonus and 

Manufacturer Catalogs installed in your 
library display here.
• Check the box beside a library catalog’s 

name to prevent it from displaying in the 
Library Browser Directory Pane tree list. 

• Click the Select All button below either 
list to prevent all catalogs in that list from 
displaying in the Directory Pane tree list. 

• Click the Clear All button below either 
list to include all catalogs in that list in 
the Directory Pane tree list. 

1
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Exporting Library Catalogs
Exporting library files allows you to: 
• Back up your custom library content.
• Transfer library content between comput-

ers.
• Share custom library content with col-

leagues.

Exporting is often preferable to simply 
copying library files because it allows you to 
include images and textures in the exported 
library. 

To export content from the library

1. Locate an object, folder, or catalog that 
you want to export, right click on it, and 
select Library> Export Library.

2. In the Export Library Data dialog.
•  Choose the appropriate Save in: loca-

tion for your exported library file.
•  Type a short, descriptive name for your 

library file in the File Name field.
•  Click the Save as type: drop down list 

and select whether or not you want the 
library to include Textures/Images.

•  Click Save.
3. Your exported library file can now be 

copied to a network location or storage 
device in Windows Explorer. 

Placing Library Objects
Library objects are subject to placement 
restrictions based upon typical real-life 
placement. Most library objects require 
sufficient free space at the location where 
they are placed, for example, and some 
library objects have additional requirements.

Library windows and doors, for example, 
must be placed in a wall just like standard 
windows and doors, and some fixtures are 
designed to be placed in cabinets.

Library symbols have placement restrictions 
that are determined when the symbol is 
created but can be changed later. See “Native 
Objects vs Symbols” on page 626 and 
“Symbol Specification Dialog” on page 43.

If a warning message displays when placing 
a library object, it will indicate where the 
object can be placed. 

There are three main categories of items 
available in the Library Browser:
• Stand-alone objects that can be placed 

directly into a plan. Examples include 
cabinet modules, furnishings and images.

• 3D objects designed to be inserted into 
another 3D object. Examples include 
cabinet fixtures, windows and doors. 
Some items, such as cabinet doors and 
fixtures and fence panels, can be inserted 
into another object or placed as stand-
alone objects. 

If any of the items being exported are
images or use textures, be sure to
select the .calibz file type.
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• Materials and molding profiles, which 
cannot stand alone and must be assigned 
or applied to another object.

Stand-Alone Objects
Most library categories contain objects that 
can be selected in the Library Browser and 
placed directly in a 2D or 3D view. 
• Most stand-alone objects are designed to 

rest on the floor or terrain.
• Some objects will rest on top of a cabinet, 

shelf, furniture or roof plane object if one 
is located at the point where they are first 
placed.

• A few objects, notably some light fix-
tures, will mount on the bottom of a wall 
cabinet or on the ceiling.

• In addition, some objects will attach to a 
wall if one is nearby.

To place a stand alone library object

1. Click on an object in the tree view or 
Selection Pane of the Library Browser to 
select it for placement. See “The Library 
Browser” on page 604. 

2. Move your cursor into the view area and 
notice that it displays an icon indicating 
the type of object selected instead of an 
arrow icon.

3. Click to place the selected object at that 
location. 

4. Continue clicking to place as many 
instances of the selected object as 
needed. When you are finished, click the 

Select Objects  button. 

Once a stand-alone object has been placed, it 
can be edited in a variety of ways. See 
“Editing Library Objects” on page 625.

Inserted Objects
Some objects cannot stand alone and must be 
placed into other objects in a plan. For 
example, doors and windows must be 
inserted into a wall, while some appliances 
and plumbing fixtures must be placed inside 
a base cabinet. See “Doors” on page 253, 
“Windows” on page 279 and “Cabinets” on 
page 507.

An inserted object can only display in a 2D 
or 3D view if the object that contains it is set 
to display. This is the case even if the 
inserted object’s layer is turned on. See 
“Displaying Library Objects” on page 624. 

To insert a library object

1. Click on an object in the tree view or 
Selection Pane of the Library Browser to 
select it for placement. See “The Library 
Browser” on page 604. 

2. Move your cursor into the drawing area.
3. Click on the object into which you wish 

to insert the selected library item. The 
library item is inserted into the object.

4. Continue clicking to place as many 
instances of the selected item as needed. 
When you are finished, click the Select 

Objects  button.

Assigned Items
Some library items, such as moldings and 
materials, are not objects in themselves but 
can be applied to objects in a variety of ways.
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• Using the specification dialog of the con-
taining object. See “Select Library Object 
Dialog” on page 622.

• By selecting the item in the library and 
then clicking on the containing object in 
floor plan view.

• Materials can be assigned to objects 
directly from the library in 3D views by 
by selecting the material and then 
clicking on an object’s surface. See “The 
Material Painter” on page 632.

Select Library Object Dialog
The Select Library Object dialog is a modal 
version of the Library Browser that is 
accessible from object specification dialogs 
that display the  button. Click this 
button to select and apply items from the 
library to the object currently opened for 
specification. See “Specification Dialogs” on 
page 31. 

The Select Library Object dialog only 
displays categories that are related to the 
opened object. For example, this is how the 
dialog looks when accessed from the General 
tab of the Door Specification dialog: To make your selection, highlight the desired 

object and click OK, or simply double-click 
on the object in the Selection Pane to close 
the Select Library Object dialog. 

The Select Library Object dialog includes 
the search and search filtering options, can 
be resized , and can display the resizable 
Preview and Selection Panes.  

If the Select Library Object dialog is opened 
by clicking the Library Material button on 
the Materials tab of any specification dialog  
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or using the Material Painter , two 
additional options are available: 

• Click the Add New Material  button 
to open the Define Material dialog and 
create a new material.

• Check Use default material to apply the 
default material for the selected object, if 
one exists. See “Material Defaults” on 
page 650.

See “Materials Tab” on page 635 or “The 
Material Painter” on page 632.

Place Library Object Button
The Place Library Object button can 
be added to your toolbar and used for 

quick access and placement of frequently 
used library items. 

If the Place Library Object  button has 
not yet been assigned a library object, click it 
once to open the Library Object Button 
Specification dialog. 

Double-click a Place Library Object  
button that has been assigned a library object 
to open the Library Object Button 
Specification dialog.

Click the Library button to open the 
Select Library Object dialog and 

assign a library object to the button. If a 
library object has already been assigned, 
click this button to assign a new library 
object. See “Select Library Object Dialog” 
on page 622.

When a library object has been 
selected, assign a button icon. Choose 

from two automatically generated button 
icons or click Browse to browse your 
computer for a different icon.

Up to 100 Place Library Object  buttons 
can be added to the same toolbar, each 
assigned a different object.

The library object assigned to the Place 

Library Object  button is actually saved 
with that particular button. If you move or 
delete the library item from the library, the 
button will continue to function.

1

2

1

2
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Replace From Library
The Replace From Library edit 
button is available for most selected 

objects. Click this button to open the 
Replace From Library dialog and replace 
the selected object, and others like it if you 
choose, with an object of the same type from 
the library. 

Click the Library button to open the 
Select Library Object dialog and select 

an object to use as a replacement. The name 
of the object that is currently selected as a 
replacement displays above.

Select one of the Replacement 
Options.

Select Replace Selected Object to replace 
only the currently selected object.

Select Replace Identical Objects in Room 
to replace all objects that are in the same 
room as, and are identical to, the currently 
selected object.

Select Replace Identical Objects on Floor 
to replace all objects that are on the same 
floor as, and are identical to, the currently 
selected object. 

A few things to remember about Replace 

From Library :
• Works in floor plan and 3D views.
• The replacement option Replace 

Identical Objects in Room is not avail-
able for doors and windows.

Replace From Library  is available for 
any object that can be stored in the Library 
Browser and can be selected, including: 
architectural objects, architectural blocks, 
electrical objects and image objects. 

Objects that cannot be replaced using this 
feature include materials, backdrops, and 
items assigned to other objects, such as 
materials. 

Displaying Library Objects
The display options available for library 
objects depend on the type of object in 
question, as well as the view.

If the display of an object is turned off in a 
2D or 3D view, any objects inserted into it 
will not display in that view, either - even if 

the inserted object’s layer is turned on. See 
“Inserted Objects” on page 621. 

In Floor Plan View
All library objects except materials, doors 
and drawers applied to cabinets, and 
backdrops can display in floor plan view. 

1

2

1

2
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Library objects are represented in floor plan 
view by 2D symbols that resemble the size 
and shape of the object when viewed from 
above. To learn how to specify the symbol 
that represents an object, see “Image 
Specification Dialog” on page 809.

As with other architectural objects, the 
display of library objects is controlled by 
layer in the Layer Display Options dialog. 
Each library category has its own layer.  See 
“Layer Display Options Dialog” on page 
104.

Symbols belong to one of three drawing 
groups that influence which objects display 
in front of others in floor plan view. You can 

click the Move to Front of Group  edit 
button to display a selected symbol in front 
of over symbols or architectural blocks. See 
“Drawing Groups” on page 150.

Object Labels
Fixtures, Furnishings, Geometric Shapes, 
Hardware, Millwork, Architectural Blocks 
and Plants can display labels in floor plan 
view when the appropriate layer is set to 
display in the Layer Display Options dialog. 
For example, fixture labels are placed on the 
“Fixtures, Labels” layer. See “Object Labels” 
on page 884.

Library object labels use the Text Style 
assigned to their layer. See “Text Styles” on 
page 765.

You can also specify a custom label for an 
individual object in its specification dialog. 
See “Label Tab” on page 885. 

In 3D Views
All library objects can display in 3D views. 

By default, images rotate to face the camera 
in 3D views. For information about turning 
off image rotation, see “Image Specification 
Dialog” on page 809.

Doors, windows and cabinets from the 
library may also display opening indicators 
in Vector Views when the “Opening 
Indicators” layer is turned on. See 
“Displaying Objects” on page 102. 

In the Materials List
Most library objects are counted in the 
Materials List, as are any comments added to 
the Components dialog for a library object. 
See “Components Dialog” on page 901.

Editing Library Objects
Like native Home Designer Pro objects, 
library objects can be customized to suit your 
design needs. There are three approaches to 
editing library objects:

• Select an object in the User Catalog, edit 
it using any of the options in its contex-
tual menu, and your changes will be 
reflected when you next place this library 
object in a drawing.

Note: Although the size and materials of
many library objects can be edited, these
changes are not reflected in the Materials
List. See “Materials Lists” on page 887.
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• Place an object in a drawing and then edit 
it using the various edit tools available 
for it. This will not affect the original 
object still saved in the library.

• Place an object in a drawing, edit it using 
the available edit tools, and then add it 
back to the library for future use. This 
will not replace the original object still 
saved in the library. See “Add to Library” 
on page 613.

Library objects placed in a drawing can be 
selected individually or as a group, like other 
objects in Home Designer Pro. See 
“Selecting Objects” on page 124. 

Once selected, library objects can be edited 
in a variety of ways using dimensions, the 
edit handles, the edit toolbar buttons and the 
specification dialog. See “Symbol Object 
Specification Dialogs” on page 627. 

Native Objects vs Symbols
In Home Designer Pro, objects created using 
the program’s standard tools, such as the 

Door Tools  and Cabinet Tools , are 
referred to as native objects. 

On the other hand, objects placed from the 
library, such as fixtures and furnishings, are 
symbols. Symbols are typically more limited 
than native objects in how they can be edited.

In addition to the symbols available in the 
library, you can import additional symbols 
into the program from 3D .obj, .3ds or .skp 
files. See “Importing 3D Symbols” on page 
838. 

Using Edit Handles
Most library symbols are box-based objects 
and can be edited as such once placed in a 
drawing. See “Editing Box-Based Objects” 
on page 141. Depending on the type of view 
and the surface selected, the edit handles a 
symbol displays will vary. 

To resize Fixtures and Furniture, you must 
check Fixture/Furniture Resize Enabled in 
the Plan Defaults dialog. When this option is 
checked, these library objects have edit 
handles when selected and can be resized 
like other objects. See “General Plan 
Defaults Dialog” on page 58. 

When a furnishing or fixture symbol is 
selected in floor plan view or on the top 
surface in a 3D view, up to ten edit handles 
display. They are the Move handle at the 
center, the Rotate handle just outside the 
front indicator (a V) and a Resize handle on 
each edge and at each corner. 

When a symbol is selected on a side in a 
cross section/elevation or 3D view, it 
displays five edit handles: the Move handle 
and a Resize handle on each edge. 

Symbols cannot be concentrically resized, 

even when the Concentric  edit behavior 
is enabled. See “Edit Behaviors” on page 
120. 

The labels of library cabinets, electrical, 
furnishings and fixtures, when displayed, 
have a separate Move edit handle that 
displays when the object is selected. 

Fixtures and furniture placed in a plan are 
subject to bumping/pushing behavior when 
moved. See “Bumping/Pushing” on page 
152.
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Deleting Built-in Fixtures 
and Appliances

A fixture installed into the front of a cabinet 
becomes a cabinet face item, like a door or 
drawer. It can be resized or deleted like other 
face items in the Cabinet Specification 
dialog. See “Front Tab” on page 526. 

Components
Many architectural objects have a 
Components dialog that lets you 

control how that object displays in the 
Materials List. In the Library Browser 
Directory Pane, right-click on a symbol and 
select Components to open the 
Components dialog. See “Components 
Dialog” on page 901. 

Changes made to the Components of an 
object saved in the library do not affect 
instances of that object already placed in a 

plan: they are only applied to instances of the 
object placed in the future. 

Once placed in a plan, many objects have a 

Components  edit tool that allows you to 
make changes to that object’s Components 
without affecting the symbol in the library. 

Terrain objects, CAD blocks, moldings, 
images, backdrops, and materials do not 
display in the Materials List.

In the Specification Dialog
The specification dialog for any image, 
material, or plant image in the library can be 
edited from the Library Browser Directory 
Pane. See “Specification Dialogs” on page 
31. 

Specification dialogs are not available for 
native objects saved in the library. 

Symbol Object Specification Dialogs
The Fixture, Furniture, Geometric 
Shape, Hardware, and Millwork 

Specification dialogs all feature the same 
options. The actual name of the dialog is 
determined by the type of object that is 
currently selected. 

For example, selecting a library object 
placed from the Interiors Core Catalog and 

clicking the Open Object  edit button 
opens the Furniture Specification dialog. 
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General Tab

The Name of the selected object 
displays here.

Specification - Define the size and 
height above the floor of the object. 

• Specify the Height, Width, and Depth of 
the object.

• Floor to Bottom - Enter the distance 
from the floor to the bottom of the object. 
A value of zero makes the object rest on 
the floor. 

• If the selected symbol is ceiling mounted, 
Height Above Ceiling will be available 
instead of Floor to Bottom. Specify the 
selected object’s height above the ceiling. 
Enter a negative value to offset the sym-
bol below the ceiling, or uncheck Follow 
Ceiling if you prefer to specify the 
object’s Floor to Bottom height instead. 

• Click Reset to reset the symbol’s origi-
nal, unmodified size. The Floor to Bot-
tom value is not affected by this button.

• When the selected object is outside a 
room and Auto Adjust Height is 
checked , its Floor to Bottom height is 
measured relative to the terrain height. 
When this is unchecked, the Floor to Bot-
tom height is measured from the default 
floor height of Floor 1. See “Terrain 
Height vs Floor Height” on page 539 of 
the Reference Manual. 

Check Reverse Symbol to reverse the 
object’s appearance, so that features on 

its left are positioned on its right, and vice 
versa. This turns a right-hand refrigerator, for 
example, into a left-hand refrigerator. This 
option has no effect on objects that are 
symmetrical.

1
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A preview of the library object displays 
here and updates with changes.

• Check Show Color to display the pre-
view of the object in color.

Materials Tab
For information about the settings on this 
tab, see “Materials Tab” on page 635.

Label Tab
A variety of library objects can display labels 
in floor plan view. Labels use the Text Style 

assigned to the layer they are on. See “Object 
Labels” on page 625. 

For information about the settings on this 
tab, see “Label Tab” on page 885.

Manufacturer Tab
If the selected symbol or material is from a 
Manufacturers catalog, the Manufactuer’s 
tab lists contact information about the 
manufacturer. See “Manufacturer Catalogs” 
on page 610.

4
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Chapter 26:

Materials

The objects used in Home Designer Pro have 
a variety of 3D properties. These objects - 
walls, windows, doors, cabinets, roof planes, 
lot perimeters, etc. - can have materials 
assigned to them so that they look realistic in 
3D views. These materials can also be used 
to generate materials lists that can help with 
cost estimations.

Designing with objects that look correct in 
3D and calculate properly in the Materials 
List requires that you use realistic material 
definitions and apply them appropriately to 
objects in your plan.

Home Designer Pro comes with many 
materials that are ready for use. From siding, 
roofing, flooring, masonry, tile, and paneling, 
to grass, water, and wood materials, Home 
Designer Pro has materials for every 
application, inside and out. If you cannot find 
a material that suits your needs, you can 
customize the materials provided or create 
your own.

Learning how to create, manage, apply, and 
edit materials saves time and adds that 
professional touch to your designs.

Chapter Contents
•      About Materials
•      The Material Painter
•      Materials Tab
•      Viewing Materials
•      Editing Materials
•      Creating Materials
•      Mapping Patterns and Textures
•      Material Types
•      Managing Plan Materials
•      Define Material Dialog
•      Material Defaults
•      Color Chooser Dialog

Redefining only the visual properties of a
material may create unexpected results.

For example, changing the image of a brick
material to represent siding does not cause
the material to be considered as siding during
material calculations.
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About Materials
The materials that are assigned to objects in 
Home Designer Pro perform two important 
roles:
• They determine what the surfaces of 

objects look like in 3D views. 
• They influence how objects are calculated 

in the Materials List. See “Materials 
Lists” on page 887.

Materials are stored in the Materials library 
in the Library Browser and can be applied to 
objects in either of two ways:

• Using the Material Painter . 
• In an object’s specification dialog. See 

“Materials Tab” on page 635.

Patterns and Textures
In Home Designer Pro, materials have two 
attributes that determine what they look like 
in 3D views: Textures and Patterns.
• Textures are created using special image 

files that tile seamlessly when applied to 
surfaces and are visible in most Render-

ing Techniques. See “In Rendered Views” 
on page 678.

• Patterns are composed of CAD lines and 
are seen in Technical Illustration and Vec-
tor Views. See “Rendering Techniques” 
on page 710.

Unlike textures, patterns are associated with 
a Type that determines if and how materials 
are calculated in the Materials List.

Material Types
Every material is classified by Type, which 
defines how the material is calculated in the 
Materials List. Not every Type is calculated 
in the Materials List; however, most 
determine whether a material is counted by 
piece, area, volume and so on. See “Material 
Types” on page 640.

Some Types are associated with patterns. 
Only Home Designer Pro Pattern Types are 
figured in the Materials List. If a .pat file is 
selected, the pattern type is listed as Custom. 
See “Pattern Tab” on page 647.

The Material Painter
Select 3D> Material Painter to 
access the Material Painter Tools, 

which are used to apply materials to object 
surfaces in 3D views. 

The Material Painter  tool can also be 
activated by selecting a material in the 
library while a 3D view is active. 

 

Material Painter Modes
There are five Material Painter Modes. Each 
mode specifies how broadly or narrowly the 

If you use the Material Painter to change
a Deck room’s planking or framing will

affect its floor structure definition. See “Floor
and Ceiling Platform Definitions” on page 322. 
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selected material will be applied to surfaces 
in your plan. 
• The Material Painter Component Mode 

 is the default mode. This applies the 
selected material to an object component. 
Using this tool is the same as opening an 
object for specification and changing the 
material for one of its components on the 
Materials tab. See “Materials Tab” on 
page 635.

• The Material Painter Object Mode  
applies a material to all components of an 
object that share the same material assign-
ment. 

• The Material Painter Room Mode  
applies a material to all the objects in the 
room that currently have the same mate-
rial. For example, if you apply a material 
to a dining room chair, this mode applies 
the material to all other objects in the 
room with the same original material, 
such as other chairs and the dining table.

• The Material Painter Floor Mode  
applies the selected material to all sur-
faces on the floor that currently have the 
same material. For example, if you apply 
a material to the kitchen countertops 
using this mode, the bathroom counter-
tops on the same floor also have the mate-
rial applied.

• The Material Painter Plan Mode  
applies the selected material to all sur-
faces in the entire plan that currently have 
the same material. For example, if you 
have the same carpet on all floors in a 
plan, applying a selected material while 
this mode is active will change all carpet 
on all floors. 

When the Material Painter  tool is 
active, the Material Painter Mode toolbar 
buttons display in the edit toolbar, allowing 
you to quickly change modes.

You can also specify the active mode by 

selecting 3D> Material Painter . A 
check displays next to the active mode in the 
submenu.

Blend Colors With Materials
In addition to the Material Painter 
Modes, the Blend Colors With 

Materials option allows you to apply a solid 
color to a surface displaying a pattern or 
texture and blend the two. 

Blend Colors With Materials  works in 
all five Material Painter Modes. See 
“Blending Materials” on page 638.

To use the Material Painter tool

1. Create a 3D view in which the patterned/
textured material is visible.

2. Select 3D> Material Painter> Mate-

rial Painter . 
3. Select a solid color material from the 

Select Library Object dialog. See 
“Select Library Object Dialog” on page 
622.

•  Check Use Default Material at the 
bottom left of the dialog to apply the 
default material to any object that has a 
defaults dialog. See “Material 
Defaults” on page 651.
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4. Select a Material Painter Mode from the 
edit toolbar, which displays at the bot-
tom of the program window when the 
Material Painter is enabled.

5. Click the Blend Colors With Textures 

 edit button to turn this feature on or 
off depending on your needs.

6. Note that the name of the material being 
painted displays on the left side of the 
Status Bar at the bottom of the program 
window. See “The Status Bar” on page 
31. 

•  Move your pointer over a surface in the 
3D view. The Status Bar now states 
both the material being painted and the 
current material on the target surface.

7. Click on the surface to apply the 
selected material to that surface. The 
material is applied to surfaces in the 
model based on the active Material 
Painter Mode. 

•  When both the Material Painter  
and Blend Colors With Textures  are 
active, the cursor displays a paint roller 

icon .

•  When the Material Painter  is 
active and Blend Colors With 

Textures  is not, the cursor displays 

a spray can icon . 

8. If either the Component  or Object 

Mode   is active, you can continue to 
click on surfaces to apply the selected 
material. When you are finished, select a 
different tool. 

Material Painter & Walls

As a general rule, the Material Painter  
cannot be used to apply a material to an 
individual wall. Rather, it applies the 
material to an entire room, to all the rooms 
on the floor, or to all the rooms in the entire 
plan, depending on which Material Painter 
Mode is active.

There are a couple of exceptions to this rule 
that apply when the wall surface being 
painted faces an exterior room such a porch 
and/or the Exterior Room. See “Room 
Types” on page 234.

• If the Material Painter Room Mode  
is active, the selected material is applied 
to the entire exterior room. If any walls 
defining this room also define other exte-
rior rooms, their entire lengths are also 
affected. 

• If the Material Painter Component 

Mode  is active, the entire length of 
the individual wall is painted. Other walls 
defining the exterior room(s) are unaf-
fected. 

Material Eyedropper
The Material Eyedropper tool 
allows you to load the material 

assigned to an existing object and apply that 
material to other objects.

In a 3D view, select 3D> Material Painter> 

Material Eyedropper  and then move 
your mouse pointer over a surface in the 
view. The name of the material on that 
surface is stated on the left side of the Status 
Bar. Click on the surface to load its material 
assignment. The pointer then changes to 
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indicate that the material is ready to be 
applied to another object using the Material 

Painter  tool. Depending on the currently 

active Material Painter Mode, you can 
continue to apply the material to the surfaces 
of other objects.

Materials Tab
The specification dialogs for most objects 
include a Materials tab. Select an object or a 
group of similar objects and click the Open 

Object  edit button to open the 
specification dialog for that selection. 

On the Materials tab, you can specify 
material assignments for the components that 
make up that object. When a new material is 
assigned, the appearance of the preview 
image on the right side of the dialog updates. 

The tree list on the left side of the tab lists the 
components of the selected object that can be 
assigned materials. Some objects may only 
have a single component while more 
complex objects may have many. 

Some components contain additional sub-
components, which display separately in the 
components tree list. 

Select a component in the tree list to 
assign a new material to it. 

The two boxes to the right of the tree 
list display a preview of the color, 

pattern and texture of the material assigned 
to the selected component. If “No Texture” 
displays in the preview window, either the 
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material has no texture assigned or the 
texture file could not be found on the system.

Click Library Material to open the 
Select Library Object dialog. Select a 

material and click OK to assign that material 
to the selected component. See “Select 
Library Object Dialog” on page 622. 

Click the Plan Material button to open the 
Plan Materials dialog and select a material 
from those already used in your plan. See 
“Managing Plan Materials” on page 642.

Select OK to close the dialog and return to 
the active view. 

Viewing Materials
Textures display in most Rendering 
Techniques, while patterns display in 
Technical Illustration and Vector Views. See 
“Displaying 3D Views” on page 677. 

In Technical Illustration and Vector Views, 
you can turn the display of material patterns 
on and off by selecting 3D> Toggle Patterns 

. See “Rendering Techniques” on page 
710.

If you receive an error message regarding a 
missing file when creating a 3D view, your 

plan might contain two textures of the same 
name or textures that did not originally come 
with the program and are not currently saved 
in the library.

To resolve this, find the original texture file 
named in the error message and copy it 
(while recreating its path) into the “Old 
Textures” folder. The next time Home 
Designer Pro is opened, it will find the 
missing file and correctly show the texture.

Editing Materials
Much like objects, materials in Home 
Designer Pro can be edited so that they better 
suits your design needs. There are two 
approaches to material editing:
• Select a material in an unlocked library in 

the Library Browser, edit it, and your 
changes will be used when you next use 
the material in any plan. Changes made in 
this manner do not affect materials 
already in use in a plan. 

• Apply a material to an object in a plan and 
then edit that applied material using either 
the Plan Materials dialog or Adjust 

Material Definition  tool. Changes 
made in this way will affect any instances 
of that material in the current plan only. 

Editing the material applied to an object is 
not the same as applying a different material 
to that object. See “The Material Painter” on 
page 632.

Library Browser
Right-click on a material in an unlocked 
library and select Open from the contextual 
menu to open the Define Material dialog for 

3
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that material. See “Define Material Dialog” 
on page 644.

Plan Materials
Select 3D> Materials> Plan 
Materials to open the Plan Materials 

dialog for the current plan. Select a material 
and click the Edit, Copy, or New button to 
open the Define Materials dialog.

Adjust Material Definition
The Adjust Material Definition tool 
is useful for changing plan materials 

directly from a 3D view. 

Select 3D> Materials> Adjust Material 

Definition  and then click any surface in 
a 3D view to modify the material currently 
assigned to that surface in the Define 
Material dialog. See “Define Material Dia-
log” on page 644.

Changing a material definition with this tool 
affects all objects in the current plan that are 
using that material but does not affect any 
materials saved in the library or materials 
used in other plans. See “Adding Library 
Content” on page 613.

Creating Materials
Home Designer Pro provides a wide variety 
of materials - including numerous name 
brand material catalogs - that are ready to 
download and use. If you cannot find a 
suitable material, you can edit an existing 
material or create a new one. See “Editing 
Materials” on page 636.

In the Plan Materials Dialog
There are two ways to create a new material 
in the Plan Materials dialog. See “Plan 
Materials Dialog” on page 643.
• Click the New button to create a new 

material for use in the current plan file. 
• Select a material and click the Copy but-

ton to make a new material based on the 
original, which can then be edited and 
used in the current plan.

In the Library Browser
Materials can be created in the Library 
Browser, making them available for use in 
any plan. See “Adding Library Content” on 
page 613. 

In the directory pane of the Library Browser, 
right-click on an unlocked folder and select 
New> Material from the contextual menu. 
See “Using the Contextual Menus” on page 
607.

In the Define Material dialog, you can create 
a new material in the selected unlocked 
folder. See “Define Material Dialog” on page 
644. 

Using Paste Image
You can create a new material by first 
copying an image that will serve as its 
texture to the Windows Clipboard, then 
navigating to a Home Designer Pro window 
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and selecting Edit> Paste> Paste  from 
the menu. See “Paste” on page 115. 

Blending Materials
In 3D views, you can create a new 
material by blending a solid color 

such as a paint color with a textured and/or 
patterned material. Select 3D> Material 
Painter> Blend Colors With Materials to 
toggle this feature on or off. See “Blend 
Colors With Materials” on page 633.

The result is a new material that is saved in 
the current plan. It can be found in the Plan 

Materials dialog, edited as needed, and 
added to the library if desired. See “Plan 
Materials Dialog” on page 643.

Materials created using the Blend Colors 

With Materials  tool are given the name 
of the patterned/textured material with the 
extension “--PAINTED:” followed by the 
name of the solid color material. 

Mapping Patterns and Textures
Materials have two attributes that determine 
what they look like in 3D views: patterns and 
textures. See “About Materials” on page 632. 

Both patterns and textures have points of 
origin, which determine where the pattern or 
texture begins on an X/Y axis. By default, 
this origin is 0,0; however, you can specify a 
different origin in the Define Material dialog. 
• The origin of a texture can be set either 

globally or independently for each object. 
By default, texture mapping is per object. 
See “Texture Tab” on page 648.

• The origin of a pattern is always per 
object. See “Pattern Tab” on page 647.

If a texture is set to map globally, it may not 
look right on some surfaces in 3D views. If 
this is the case and you do not wish to map 
the texture independently on each object, you 
can create a copy of the material for each 

surface that requires modification and 
specify its texture’s origin.

Determining the Origin
Before a new origin can be specified, the 
display of coordinates in the Status Bar 
should be enabled. See “The Status Bar” on 
page 31.

To determine origin coordinates on the 
horizontal plane, place your cursor over the 
origin location in floor plan view. When the 
pointer is in the position you want to 
establish as the material origin, take note of 
the coordinates that display in the Status Bar. 

To determine origin coordinates on the 
vertical plane, place your cursor over the 
origin location in a cross section/elevation 
view.
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Once you have taken note of the new origin 
coordinates, enter them on either the Pattern 
or Texture tab of the Define Material dialog. 
See “Define Material Dialog” on page 644.

A texture or pattern origin is a property of the 
material rather than of the object that the 
material is assigned to. When an object is 
moved, the pattern or texture maintains its 
absolute position and may not look right. It is 
a good idea to assign pattern or texture 
origins only after the position of the object 
has been finalized.

Stretch to Fit
Some special textures, often used for 
artwork, do not tile. Instead, these textures 
resize to stretch across any surfaces that they 
are applied to. Materials that behave this way 
are specified as Stretch to Fit in the Define 
Material dialog. 

To display an artwork texture, first place a 
wall or desk frame in your plan. A selection 
of both are available in the library. See 
“Placing Library Objects” on page 620.

Next, simply apply a material specified as 
Stretch to Fit to the center portion of the 
frame. See “The Material Painter” on page 
632. 

The pointer’s current coordinates display in the Status Bar

If you have multiple objects using the
same material, they all share the same

origin. Duplicate materials can be created if
you want different origins specified for the
same texture or pattern.
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For more information about creating and 
using custom materials, see “Materials 
Tutorial” on page 145 of the User’s Guide.

Material Types
Every material is classified by Type in the 
Define Material dialog. See “General Tab” 
on page 645. The Type defines how the 
material is calculated in the Materials List. 
Some but not all Types are associated with 
patterns that display in Vector Views. See 
“Vector View” on page 711. 

Not every Type is calculated in the Materials 
List. Those that are are only calculated when 
assigned to structural components like wall, 
floor and ceiling, or roof layers; slabs; or 
generic objects like Primitives. 

Following are the available Material Types 
and their characteristics:

Type Pattern Options Materials List

Framing None n/a Calculates stick framing quantities when
assigned to the Main Layer of a wall type
definition, or a layer in a floor or ceiling
structure or finish definition. See “Fram-
ing” on page 435. 

Brick Typical staggered
running bond brick
course. 

Height, Length, Depth
and Mortar Width.

Calculates the number of units based on
the total surface area. For a masonry wall
with two layers of brick, create a wall type
with two layers to get the right count.
This Type can be specified for anything
using this style of layout, such as plywood
with staggered joints. 

Strip Parallel lines. Height, Grouping, and
Overlap Amount.

Calculates lineal footage based on the
surface area and the height of the strip
minus the Overlap amount. Grouping can
be used to model a material that has a
repeating pattern across its width.

Sheet None n/a Calculates the number of sheets required
to cover the surface area. 
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Gap None n/a Gap materials create a space between
materials. This is equivalent to defining no
material at all and is not calculated in the
Materials List. 

Area None n/a Calculates the total surface area. 

Volume None n/a Calculates cubic feet (meters). 

Concrete None n/a Calculates cubic yards (meters). 

Tile Grid Height, Width, Thick-
ness, and Joint Width.

Calculates the number of units required to
cover the surface area.

Shingles Rows of staggered
rectangles. 

Height, Width, Thick-
ness, and Overlap
Amount.

Calculates the number of shingles
required to cover the surface area. 

Flooring None n/a Calculates the total surface area. 

Shakes Staggered rows of
uneven rectangles.

Height, Width, Thick-
ness, and Overlap
Amount.

Calculates the number of shingles
required to cover the surface area.

Herring-
bone

Herringbone. Height, Length, Depth
and Mortar Width.
Height and Length are
restricted to a 2:1 ratio.

Calculates the number of units required to
cover the surface area.  

Octagon Octagons and
small squares. 

Height, Length, Depth
and Mortar Width.
Height and Length refer
to the small square
edges and are
restricted to a 1:1 ratio.

Calculates the number of units required to
cover the surface area.  Units are com-
posed of one octagon and four squares. 

Hexagon Hexagon Height, Length, Depth
and Mortar Width.
Height and Length are
restricted to a 1:1 ratio.. 

Calculates the number of units required to
cover the surface area. 

Parquet Square parquet
units

Size. Calculates the required number of par-
quet units to cover the surface area.

Textured Similar to a Sand
fill style.

Spacing. The Materials List does not calculate this
material Type.

Type Pattern Options Materials List
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Managing Plan Materials
The Plan Materials dialog can be used 
to manage the materials used in the 

current plan. Select 3D> Materials> Plan 
Materials to open this dialog.

When a material is applied to an object in a 
plan, a copy of that material is made and 
saved with the plan. If you access the Define 
Materials dialog through a menu or 
specification dialog, your changes affect that 

material wherever it is found throughout that 
plan. Other objects in that plan that use that 
material are also affected, but objects outside 
the current plan are not. 

Earth Alternating hatch
pattern similar to
Parquet. 

Size. The Materials List does not calculate this
material Type.

Stars Six sided stars. Size. The Materials List does not calculate this
material Type.

Type Pattern Options Materials List

All materials that come with Home
Designer Pro are stored in the Library

Browser. You can also create your own materi-
als and save them in the Library Browser. See
“Creating Materials” on page 637.
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Plan Materials Dialog

This is the list of materials in your plan. 
Click on the name of a material in the 

list to select it and display a preview of it to 
the right. If multiple materials are selected 
simultaneously by holding down the Shift or 
Ctrl keys, no previews will display. 

If a checkmark displays in the In Use 
column, the material is used by an object in 
your plan or is defined as a default material 
for one or more objects in your plan.

If the In Use column is empty, the material 
was referenced at one time but is no longer 
assigned to any objects or used as a default.

Click Edit to open the Define Material 
dialog for the selected material. See 

“Define Material Dialog” on page 644.

Click New to open the Define Material 
dialog to create a new material.

Click Copy to create a copy of the 
selected material and opens the Define 

Material dialog where you can make changes 
to the copied material.

Click Purge to remove all unused 
materials from the plan.

Click Delete to remove the selected 
material from the plan. If the material is 

used in the model, you cannot delete it.

Click and drag the size grip to resize the 
dialog box. 
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Define Material Dialog
The Define Material dialog allows you to 
adjust how materials look in 3D views and 
can be accessed in a number of ways:

• Use the Adjust Material Definition  
tool. See “Adjust Material Definition” on 
page 637. 

• Select a material from the Plan Materials 
dialog and click Edit, New, or Copy. See 
“Managing Plan Materials” on page 642.

• Right-click on a material in an unlocked 
library in the Library Browser and select 
Open from the contextual menu. See 
“Using the Contextual Menus” on page 
607. 

• You can also right-click on an unlocked 
library and select New> Material. 

If you select a manufacturer’s material, the 
options in the Define Material dialog may 
change. Some options are not available and 
the tabs may vary. 

If you access the Define Material dialog 
through a menu or specification dialog, your 
edits affect that material wherever it is found 
in the current plan. Other objects in that plan 
that use that material are also affected, but 
objects outside the current plan are not. 
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General Tab
The options on the General tab will vary 
depending on the selected material Type. 

The Material Name displays here. You 
can type a different name if you wish. 

Renaming the material does not create a new 
material: it redefines the existing material. 
See “Creating Materials” on page 637. 

Specify the Colors used to represent 
the material’s pattern in Vector Views. 

Click a color box to open the Color Chooser 
dialog and select a color. See “Color Chooser 
Dialog” on page 652.
• The Material color displays in Vector 

Views and in rendered views if Toggle 

Textures  is off or if no texture has 

been selected. See “In Vector Views” on 
page 678.

This color also affects a material’s Trans-
parency: choose white for a fully trans-
parent material or black for one that is 
completely opaque. See “Properties Tab” 
on page 650.

• The color of the Pattern Lines , which 
display in Vector Views, displays here. 

• Specify the Shading Contrast, which is 
the amount of contrast between surfaces 
at different angles to each other in 3D 
Vector Views. 
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The following image shows the same curved 
wall with three different Shading Contrasts 
(combined using a separate graphics 
program). Notice how the lowest contrast at 
the top appears almost flat.

Specifications - 

• Select a material Type from the drop-
down list. The selected Type defines how 
- or whether - the material is calculated in 
the Materials List and may also be associ-
ated with a pattern. See “Material Types” 
on page 640.

Depending on the Type selected, additional 
settings may become available. Unless 
otherwise noted, these settings affect both the 
appearance of the material’s pattern in Vector 
Views and how it is counted in the Materials 
List: 
• Specify the material’s Height. This value 

is restricted to a ratio of the Length for 
Parquet, Octagon, and Hexagon material 

Types. When applied to a Strip, Shingles, 
or Shakes Type, the Height - Overlap 
Amount = Exposure of the material. 

• Specify a Framing material’s Spacing 
OC. This value controls the spacing of 
wall studs only. See “Wall Framing” on 
page 436. 

• Specify the material’s Length. This value 
is restricted to a ratio of the Height for 
Parquet, Octagon, and Hexagon material 
Types. 

• Specify the Thickness of a material Type 
such as Tile. Thickness does not typically 
affect the appearance of the material in 
Vector Views, but is used for Materials 
List calculations. 

• Specify the Depth of a Brick material. 
Depth does not typically affect the 
appearance of the material in Vector 
Views, but is used for Materials List cal-
culations. 

• Some patterns are defined by relative 
Size. The number does not have any units: 
it is more like a scaling factor. Material 
Types with a Size setting are not calcu-
lated in the Materials List.

• Specify the Joint Width, which is the 
grout width between pieces of Tile. This 
affects the size of tiles in Vector Views 
but not the size of the pattern lines. 

• Specify the Mortar Width for a Brick or 
Block material. This affects the size of 

Low Contrast

Normal Contrast

High Contrast

3

Note: When a material is assigned to a wall
type layer, floor or ceiling structure or finish
layer, or to a structural roofing layer, the Thick-
ness value set here is not used for materials
list calculations. 
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bricks and blocks in Vector Views but not 
the size of the pattern lines. 

• Specify the Overlap Amt, which is the 
amount that a Strip, Shingles, or Shakes 
material overlaps itself. The Height - 
Overlap Amount = Exposure of the 
material. 

• Grouping is used to describe the repeat 
of the pattern across the width of a Strip 
material. A 13" wide Strip with an Over-
lap Amt of 1" and a Grouping of 3 calcu-
lates materials based on a 12" coverage 
and a repeat line pattern of 4". 

A preview of the material’s pattern 
displays here. It updates as you change 

the material definition.

Pattern Tab
Patterns are used to represent materials in 
Technical Illustration and Vector Views. 

Pattern Types also affect the Materials List. 
See “Patterns and Textures” on page 632.

The Material Name displays here. You 
can type a different name if you wish. 

Renaming the material does not create a new 
material: it redefines the existing material.

Specify the selected material’s Pattern 
Type. The pattern type affects both how 
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the material looks in Vector Views, and how 
it’s calculated in the Materials List. See 
“Material Types” on page 640. 
• Select Use Material Type to base the 

material’s pattern on the selected Type, 
then select a Type from the drop-down 
list. This drop-down is also found on the 
General tab. 

• Select Use Custom Pattern File to spec-
ify a Custom pattern and enable the 
options below. When a Custom pattern is 
used, the material will be counted as an 
Area type in the Materials List. 

• The pathname of the selected .pat pattern 
file displays here.

• Click the Browse to open the Custom 
Pattern File dialog and select a pattern 
file. This dialog is a typical Open dialog, 
and opens to the Patterns folder in the 
program installation directory.

• Select a pattern from the drop-down list. 
The items available depend on the .pat  
file selected above.

• Specify the pattern’s Scale. If the pattern 
displays as grey in the preview, the 
pattern repeats too often and this value 
should be increased.

Specify a new Origin, if needed, so the 
pattern displays correctly on surfaces in 

Vector Views. 

Specify the Pattern Angle, in degrees 
measured counterclockwise.

Specify the Pattern Line Weight, 
which is the thickness of the lines that 

form the pattern.

This is a preview of the material as it 
appears in Vector Views. The preview 

updates as changes are made.

Texture Tab
In most Rendering Techniques, materials are 
represented by textures. See “Rendering 
Techniques” on page 710.

Transparency information may be contained 
on the alpha channel of a texture; if so, it is 
used in rendered views. 
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The Material Name displays here. You 
can type a different name if you wish. 

Renaming the material does not create a new 
material: it redefines the existing material. 

Texture File - Displays the path and 
file name of the selected texture. 

• Click the Browse button to browse to a 
texture file saved on your computer. Sup-
ported file formats are .jpg, .bmp, .png, 
.gif, .tif, .pcx, .tga. See “Creating 
Materials” on page 637.

Adjust the Mapping of the selected 
material’s texture. See “Mapping Pat-

terns and Textures” on page 638. 
• Adjust the Scale, or height and width 

ratio, of the selected texture. The values 
are in inches (or mm).

In this example, the texture shown is mapped 
to a 32” x 32” area. If a rendered surface is 
larger than this area, the surface has “tiles” of 
the texture that are 32” x 32”. If it is smaller, 
only a portion of the texture is shown.
• Set a new Origin, if needed, so the tex-

ture displays correctly on surfaces in ren-
dered views. 

• Specify the Angle of the texture on the 
surfaces of objects, in degrees.

• Check Stretch to Fit to stretch the texture 
image to cover each surface it is applied 
to.
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Note: Changing the scale or selecting Stretch
to Fit can cause textures to appear distorted if
applied to a surface with a different aspect
ratio than the original texture image.
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• Check Global Symbol Mapping to map 
the texture using the same origin on all 
objects. When unchecked, the origin is 
defined individually for each object. See 
“Mapping Patterns and Textures” on page 
638.

Specify the characteristics of the Color 
applied over the selected material’s 

texture. 
• Check Blend Color and Texture to blend 

the texture with a solid color, then click 
the Material Color button to specify the 
color you want to blend it with.

When a new material is created using the 

Blend Colors With Materials  tool, 
the resulting material has this box 
checked. See “Blend Colors With Materi-
als” on page 633.

• Click the Set Material Color Using Tex-
ture button to use the original color of the 
material’s texture. See “Patterns and Tex-
tures” on page 632.

A preview of the selected texture as it 
appears using the Standard Rendering 

Technique displays here. As the settings are 
changed, the preview updates.

Properties Tab
The Properties tab controls how the material 
appears in most rendered 3D views. The 
preview on the right displays the material 
rendered on a 3’ x 6’ panel using the 
Standard Rendering Technique. As the 
settings are changed, the preview updates. 

A material’s rendered appearance is also 
affected by the Render settings in the 

Preferences dialog and the lights that have 
been placed in the model. See “Light Types” 
on page 705.

To get special lighting effects on an object, 
use at least one point or spot light. For these 
highlights to appear on large flat surfaces, 
select Use Triangles in the Preferences 
dialog. See “Render Panel” on page 86.

The name of the material displays here.
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Brightness controls how bright the 
material appears. It can be used to get 

the desired appearance relative to other 
materials being used.

Shininess controls the sheen of the 
material when it is rendered with a 

point or spot light source on it. Shiny 
materials appear to have a bright white spot 
on them which simulates reflection of light.

Transparency - Use the slider bar or 
text field to control the materials 

transparency. A value of 0 is completely 
opaque and a value of 100 is completely 
transparent. Specifying materials with 

transparency can slow down rendering speed 
in some situations.

Emissive - Use the slider bar or text 
field to control how bright a material 

appears independent of the lighting in the 
scene. It can be used to simulate surfaces that 
are glowing with their own light, such as the 
glass on a light fixture. 

Manufacturer Tab
If the selected material was copied from the 
Manufacturer library category, the 
Manufacturer tab lists contact information. 
See “Manufacturer Catalogs” on page 610. 

Material Defaults
Most objects in the program have 
defaults dialogs which allow you to 

set up a variety of attributes, including 
materials, before the objects are created. 
Default Settings are accessed by selecting 
Edit> Default Settings. See “Preferences & 
Default Settings” on page 55.

Not all objects, however, have default 
settings that can be accessed prior to being 
placed. Garage doors, for example, do not 
have a defaults dialog. Instead, you can 
specify the materials for them in the Material 
Defaults dialog. Once a garage door is 
created, you can change its materials. 

Select Edit> Default Settings  from the 
menu, select “Materials”, and click the Edit 
button to open the Material Defaults dialog. 

Material Defaults Dialog
The settings here are similar to those on the 
Materials tab found in object specification 

dialogs throughout the program. See “Mate-
rials Tab” on page 635.

• Select a category from the scrollable list. 
• Click the Library Material button or 

either preview box to open the Select 
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Library Object dialog. See “Select 
Library Object Dialog” on page 622.

• Click the Plan Material button to open 
the Plan Materials dialog. See “Plan 
Materials Dialog” on page 643.

Color Chooser Dialog
The Color Chooser dialog is opened 
by selecting Tools> Color Chooser or 

by clicking on the color bar that can be found 
in many dialogs throughout the program.

Click in any one of the Base colors 
boxes to select it as the new color.

Click in one of the Custom colors 
boxes to either select it as the new color 

or to specify it as the box for a new custom 
color to be defined.

Click anywhere in the color palette area 
to dynamically choose a color. The 

location of a selected color is identified by a 
black crosshairs.

Click anywhere in the vertical bar to 
adjust the selected color’s darkness.

Drag the Color Chooser Eyedropper 
anywhere on your monitor and release 

the mouse button to select the color 
displaying at that location.

Click Add to Custom Colors to add 
the color to selected Custom Colors 

box.
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You can select a color from any program
window. Before opening the Color

Chooser dialog, make sure the desired color
can be seen onscreen by tiling Home Designer
Pro and the other program window.
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Chapter 27:

Zoom & View Tools

Use the Zoom tools to position the current 
view. To work on a specific area, you may 
need to zoom in so that the entire screen is 
filled by only a single room. At other times 
you may need to view the entire plan.

One layout file can be open at a time, but 
there is no limit to the number of plan files 
that can be open. The name of the file and the 
type of view displays at the top of each view 
window in its title bar. If the view is saved, 
its name also displays. 

There are a number of ways to pan across the 
screen, shifting the visible part of the plan 
slightly while still maintaining the same 
zoom factor. 

Multiple views of one or more open files also 
can be arranged and managed using the View 
tools.

Chapter Contents
•      Zoom Tools
•      Undo Zoom
•      Fill Window
•      Panning the Display
•      Swapping Views
•      Window Menu Tools
•      Cascade
•      Tiling Views
•      Arrange Icons
•      Aerial View
•      Closing Views
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Zoom Tools
Zoom is used to magnify any given 
area on the plan or 3D view. Select 

Window> Zoom, then click and drag a 
marquee around an area on screen. When 
you release the mouse, the selected area 
expands to fill the screen. 

When the zoom is complete, whatever tool 

was active prior to selecting the  Zoom  
tool automatically becomes active again. If 

another zoom is needed, click the  Zoom  
tool again.

Zoom In - Click to zoom in towards 
the screen center by a factor of two.

Zoom Out - Click to zoom out from 
the screen center by a factor of two.

Undo Zoom - Reverse the last zoom 
operation. See .

Fill Window - Fits all visible items on 
screen. See .

Fill Window Building Only - Fits all 
walls and railings on the current floor 

on screen. 

Pan Window - Move the display 
without changing the zoom factor. See 

.

Select Window> Aerial View to open 
the aerial view window. See “Aerial 
View” on page 660.

Zooming With 
the Mouse Wheel

Use the mouse wheel to zoom in and 
out in plan and 3D views. Scrolling 
the mouse wheel one click up or 

down zooms in or out, centering on the 
location of your pointer and changing the 
zoom by about 10%.

Zooming in 3D Views
Zooming in 3D views does not change the 
camera’s location or field of view. Instead, 
the extents of the view are expanded or 
cropped. You can alternatively set cameras to 
zoom by adjusting their Field of View. See 
“Render Panel” on page 86.

Undo Zoom
Select Window> Undo Zoom to 
reverse the last zoom operation. 

Zoom  and Undo Zoom  are also 
available through the contextual menu. See 
“Contextual Menus” on page 30. 

Note: Depending on the configuration of your
mouse, it may be necessary to hold down the
Ctrl key while turning the mouse wheel. If
zooming in and out are not working correctly,
contact the manufacturer of your mouse and
mouse driver for their assistance. 

Note: Undo and Redo do not affect zoom.
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Fill Window
In floor plan view or a cross section/
elevation view, select Window> Fill 

Window or press the F6 key to view nearly 
everything on screen that is visible, including 
the Reference Display. CAD Points are the 
only objects that are not included when Fill 
Window is used. 

If you are zoomed in so that only a portion of 
the drawing displays on screen, selecting Fill 

Window  zooms out so that the entire 
view fits on the screen. If you are zoomed 
out so that the entire drawing is smaller than 

the screen, selecting  Fill Window  
zooms in until the drawing fills the screen.

When the drawing sheet is shown, Fill 

Window  zooms to the sheet borders.

Fill Window Building Only
Window> Fill Window Building 
Only is similar to Fill Window, but 

zooms in or out to so that all walls and 
railings in the view fill the current window. 
Other objects are ignored.

In 3D Views

Fill Window  and Fill Window Building 

Only  behave slightly differently in 
perspective and orthographic 3D views. In 
perspective views, the original zoom factor is 
restored, while in orthographic views the 
camera’s Field of View is adjusted so that all 
surfaces in the 3D view are included. 

Panning the Display
There are four ways to pan the display 
without changing the zoom factor.

Using the Scroll Bars
One method is to use the scroll bars on the 
right and bottom edges of the window.

• Drag the square button in the bar itself in 
order to pan a larger distance. 

• Click the end arrow keys on the scroll 
bars to shift the display in 12" incre-
ments. 

• The 12" increment is defined in the Plan 
Defaults dialog under Inches Scrolled 
by Arrow Key. See “General Plan 
Defaults Dialog” on page 58.

Using the Arrow Keys
In floor plan view, the arrow keys on the 
keyboard work exactly like clicking the 
arrow buttons on the scroll bar. They shift the 
display according to the number of inches 
defined in the Plan Defaults dialog.
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Using the Mouse
If you have a wheel mouse, you can pan the 
display by pressing the middle mouse button, 
or wheel, and moving the mouse in the 
direction you would like to pan. When the 
middle mouse button is held down, the 

pointer changes to a hand  icon. 

Mouse drivers sometimes have other 
functions assigned to the wheel and buttons. 
These override the Home Designer Pro 
setting.

Using the Pan Window Tool
The Pan Window tool works much 
like the mouse wheel method.

• Select Window> Pan Window . The 

pointer changes to a hand  icon. Click 
and drag in floor plan view to pan the 
window. The command is invoked once 
and the program reverts to the previously 
active tool when you release the mouse 
button.

• Double-click the Pan Window  tool 
and the command remains active.

Swapping Views
There are several ways to switch between 
open view windows.

• Select Window> Swap Views  or 
press F7 to switch between the two most 
recent views.

• The Swap Views  button toggles 
between the current view and the view 
that was current before it. 

• Select Window> Next Window  or 

Window> Previous Window  to 

cycle through all open views in the order 
you prefer. 

• Press the Ctrl + Tab (Next Window) or 
Ctrl + Shift + Tab (Previous Window) 
keys to cycle through all open views. 

• A list of all the views currently open is 
located at the bottom of the Window 
menu. Each view is identified by its name 
and what type of view it is. Select one to 
go directly to that view.

Window Menu Tools
Select Window from the menu to access the 
Window Menu tools, which help you display 
multiple view windows of your model at the 
same time.

Note: The Window Menu Tools button
does not display on the toolbar by default
but it can be added. See “Toolbar Cus-
tomization Dialog” on page 93. 
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Select Window> Cascade to cascade 
all open views. See “Cascade” on 

page 657.

Select Window> Tile 
Horizontally or Tile Vertically 

to tile all open views. See “Tiling Views” on 
page 659.

Select Window> Arrange Icons to 
arrange all open views that are 

currently minimized. See “Arrange Icons” on 
page 660. 

Select Window> Next Window to 
switch to the next open view. See 

“Swapping Views” on page 656.

Select Window> Previous Window 
to switch to the previous open view. 

See “Swapping Views” on page 656.

Select Window> Show Layout to 
switch to the layout file. Only 

available if a layout file is currently open. 
See “Layout” on page 863. 

Open View Windows
One layout file can be open at a time, but 
there is no limit to the number of plan files 
that can be open. The name of the file and the 
type of view displays at the top of each view 
window in its title bar. If the view is saved, 
its name also displays. 

There is no limit to the number of 3D view 
windows that you can have open at a given 
time; bear in mind, though, that each window 
demands use of your computer’s resources 
and that you may see poor performance if too 
many views are open. See “3D Views” on 
page 663.

A list of all view windows currently open 
displays at the bottom of the Window menu. 
Each view is identified by its name and what 
type of view it is. A checkmark is beside the 
view that is currently active. Select one to go 
directly to that view. 

The names of up to eight views can display 
here. If more than eight view windows are 
open, More Windows is the last item in the 
menu. Select this option to open the Select 
Window dialog. 

Select the name of a view from the list and 
click OK to make it the active view.

Cascade
Select Window> Cascade to cascade 
all open views. Cascade is a Windows 

function which allows you to organize open 
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windows in a cascading pattern. Click on any 
visible edge to activate that window.
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Tiling Views
The window tiling options allow 
you to display multiple views 

side by side in the Home Designer Pro 
window.

Select Window> Tile Horizontally  to 
display both views in a horizontal 
orientation.

Select Window> Tile Vertically  or press 
Shift + F6 on the keyboard to display both 
views in a vertical orientation. 

To activate a view, click on its title bar or 
anywhere in the view window. Note that any 
changes you make are reflected in other 
views as well.

To end window tiling, click the 

Maximize  button in the upper right 
corner of any open view.

Tiling allows you to see the results of 
changes in floor plan view in 3D or vice 

versa, and can also be useful for copying 
objects from one plan to another.
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Arrange Icons
Arrange Icons is a Windows function 
used when several active windows 

have been minimized. Select Window> 
Arrange Icons to align the minimized title 

bars in a row at the bottom of the working 
desktop. You can then click the minimized 
title bars to reactivate them or use them for 
swapping and closing views.

Aerial View
In floor plan view, select Window> 
Aerial View to open the Aerial View 

window. 

The Aerial View window shows everything 
on the current floor as well as a marquee 
indicating the portion currently visible in the 
floor plan view window.

As you pan around the floor plan view 
window or zoom in or out, the marquee in 
Aerial View moves and resizes to reflect 
these changes. This can make it easier to 
navigate in floor plan view. 

The Aerial View window is initially docked 
on the right side of the window, but it can be 
moved to any other edge or allowed to float. 
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The Aerial View always displays the entire 
plan, so it has no scroll bars.

• The Aerial View window can be moved  
by clicking and dragging the grip bar and 
resized by clicking and dragging an edge. 

• The grey marquee that displays in the 
Aerial View represents the extent of the 
floor plan view. This marquee updates if 
you zoom or pan in floor plan view.

• Use the left mouse button to drag a new 
marquee within the Aerial View window. 
The floor plan view updates to match.

• Use the right mouse button to pan the 
existing marquee within the Aerial View 
window. The floor plan view updates to 
match.

• No matter what tool is active, when you 
move the pointer to the Aerial View win-
dow and drag a marquee, the floor plan 
view zooms in on that area. 

Closing Views
Select File> Close or click the   at the top 
right corner of a window to close it. If the 

view is still needed, swap to a different view 
without closing the current views.

The border that displays in the aerial view window coincides with the floor plan view display.
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Chapter 28:

3D Views

Little preparation is needed to create a 3D 
view of a model: simply click a button to 
create an overview or click and drag to create 
a camera or cross section/elevation view. 

To improve the quality of the rendering and 
create a custom look, you can adjust lighting 
and edit the materials used in the plan. You 
can create Final views that are even more 
realistic. See “3D Rendering” on page 697.

Many objects can be placed and edited in 3D 
views, and any camera view or overview can 
be saved or even used to record a 
walkthrough. See “Pictures, Images, & 
Walkthroughs” on page 805.

Chapter Contents
•      OpenGL and Hardware
•      Types of 3D Views
•      Defaults and 3D Preferences
•      Camera Defaults Dialog
•      3D View Defaults Dialog
•      3D View Tools
•      Creating Camera Views
•      Creating Overviews
•      Cross Section/Elevation Views
•      Displaying 3D Views
•      Repositioning Cameras
•      Editing 3D Views
•      Cross Section Slider
•      Working in 3D
•      Saving & Printing 3D Views
•      Camera Specification Dialog
•      Cross Section/Elevation Camera 

Specification
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OpenGL and Hardware
Home Designer Pro features a built in, easy 
to use rendering engine that makes use of 
OpenGL rendering technology, which has 
good hardware support on most video cards. 

To take full advantage of the rendering 
capabilities of Home Designer Pro, a 
graphics card that supports OpenGL 
hardware acceleration and has at least 256 
MB of dedicated video memory is highly 
recommended. For complex models, an 
accelerated card generates quality renderings 
in seconds that might otherwise take minutes 
or even hours with a non-accelerated card or 
chipset. 

OpenGL is required in order to use the 
stylized Rendering Techniques. See 
“Rendering Techniques” on page 710.
• Standard rendering requires OpenGL 2.0 

when Use Enhanced Lighting is 
checked in the Preferences dialog. See 
“Render Panel” on page 86.

• Technical Illustration rendering requires 
OpenGL 2.0.

• Watercolor rendering requires OpenGL 
1.5.

Types of 3D Views
There are three categories of 3D views in 
Home Designer Pro: camera views, 
overviews and cross section/elevation views. 
Each of these view types can be generated 
using a variety of rendering techniques. See 
“Rendering Techniques” on page 710.

Every 3D view is also either orthographic or 
perspective in nature. Cross section/elevation 
views are always orthographic while camera 
views are always perspective. You can 
choose to generate overviews as either 
orthographic or persective. 

Perspective and 
Orthographic Views

Perspective views have a focal, or vanishing, 
point. Surface edges and lines that would be 
parallel in real life appear to converge 
towards that focal point, and objects closer to 

the camera appear larger while objects 
farther from the camera appear smaller.

Orthographic views do not have a focal or 
vanishing point. Parallel surface edges and 
pattern lines appear parallel in these views 
and objects appear to be the same size 
regardless of their distance from the camera.

Perspective views display 3D objects much 
the way that they appear to the eye in real 
life, so they are ideal for presentation views. 

Perspective Overview Orthographic Overview
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By default, perspective views are created 
using the Standard rendering technique.

Orthographic views, on the other hand, are 
useful for technical drawings. By default, 
orthographic views are created using the 
Vector View technique.

Rendered and Vector Views
3D views can be generated using a variety of 
different rendering techniques. See 
“Rendering Techniques” on page 710.

Most rendered views represent materials 
using textures. Surface edge lines are 
generally not drawn and lighting is often 
modeled, creating results that range from a 
photorealistic appearance to artistic painting 
styles.

Vector Views are non-photorealistic views in 
which objects are drawn using surface edge 
lines, or vectors. Lighting is not calculated, 
and materials are represented using pattern 
lines and solid colors, making Vector Views 
quicker to generate and ideal for layout 
drawings and high resolution printing.

Defaults and 3D Preferences
There are a number of defaults and 
preference settings that allow you to control 
the initial characteristics of 3D views. 

 Camera positioning, field of view and 
related initial settings for camera 

views are specified in the Camera Defaults 
dialog. See “Camera Defaults Dialog” on 
page 665.

 Ambient lighting settings, 3D 
backdrop information, and other 

settings that affect 3D views as they are 
generated are found in the 3D View Defaults 
dialog. See “3D View Defaults Dialog” on 
page 668. 

 Which objects display in a 3D view 
and which do not is controlled in the 

Layer Display Options dialog. See 
“Displaying Objects” on page 102.

3D views can be generated using any 
of the Rendering Techniques. See 

“Rendering Techniques” on page 710. 

The initial settings for each Rendering 
Technique can be set in the 

Rendering Techniques Defaults dialog. See 
“Rendering Technique Options” on page 
713. 

The Render panel of the Preferences 
dialog controls settings for Render 

Previews and Final Views. See “Render 
Panel” on page 86.

Camera Defaults Dialog
Default Settings can be accessed by 
selecting Edit> Default Settings or 

by double-clicking either Perspective View 

Tools parent button or any Camera toolbar 
button.
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The settings in the Camera Defaults dialog 
affect how a camera clips, captures and 
renders views, how it displays in floor plan 
view, how it is positioned, and how it moves.

Once a camera is created, these settings can 
be customized in the Camera Specification 
dialog. See “Camera Specification Dialog” 
on page 691.

The Positioning settings control the 
position and orientation of the camera. 

See “Repositioning Cameras” on page 680.
• The Incremental Move Distance con-

trols how far the camera moves each time 
you Pan in any direction or Dolly for-
wards or backward. For interior views a 
small number is good, but for exterior 
you may want a larger increment.

• The Incremental Rotate Angle defines 
how many degrees the camera rotates 
each time you Tilt, Orbit, or Dolly side to 
side. A setting of 90° would make one 
full rotation in four moves. 

• The Height Above Floor defines the 
height that the camera is above the floor 
level for the current floor.

• The Field of View defines the camera’s 
field of vision in angular degrees.

• The Tilt Angle is the camera’s angle rela-
tive to the horizon. 0° is horizontal, 5° 
points slightly upward, and -5° points 
slightly towards the ground. 

The Plan Display settings control the 
appearance of the camera’s symbol in 

floor plan view. See “Using the Edit 
Handles” on page 685.
• Specify the Camera Symbol Size, mea-

sured in plan inches (mm). This is also 
the default size for Walkthrough Path 
Key Frames. See “Walkthroughs” on 
page 819.
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• Set the Clip Plane Indicator Length for 
Cross Section/Elevation, Backclipped 
Cross Section, and Wall Elevation cam-
era symbols. The length is measured in 
plan inches (mm). See “Cross Section/
Elevation Views” on page 675.

• Check Show Camera Focal Point to dis-
play the camera’s focal point in floor plan 
view.

• Check Show Field of View Indicators to 
display the field of view indicator for 
cameras in floor plan view. You can also 
change the FOV Indicator Length, 
which is measured in plan inches (mm).

• Uncheck Always Display Active Cam-
eras to turn off the display of active cam-
era symbols when the “Cameras” layer is 
turned off. When checked, active cam-
eras always display, regardless of the 
layer setting.

• Check Display Callouts for Sections/
Elevations to represent cross section/ele-
vation cameras in floor plan view using 
callouts instead of camera symbols. See 
“In Floor Plan View” on page 677.

The Wall and Surfaces settings 
determine the extent of camera views.

• Clip Surfaces Within - Specify that the 
camera does not display an object within 
this distance.

• Remove Wall Within - Remove the dis-
play of walls within this distance of the 
camera.

Both of these distances are measured as a 
radius from the camera position.
• Check Unless Opening to display a wall 

that is inside the Remove Wall Within 

range if the camera is pointing through an 
opening such as a door or window.

Orthographic Rendering Techniques 
- Specify which Rendering Techniques 

are used  to create Orthographic 3D views. 
See “Rendering Techniques” on page 710. 
• Select a Rendering Technique from the 

drop-down list to be used when the 

Default Mode  is active. See “Edit 
Behaviors” on page 120.

• Select a Rendering Technique from the 
drop-down list to be used when the 

Alternate Mode  is active. 

Perspective Rendering Techniques - 
Specify which Rendering Techniques 

are used  to create Perspective 3D views. See 
“Perspective and Orthographic Views” on 
page 664. 
• Select a Rendering Technique from the 

drop-down list to be used when the 

Default Mode  is active. 
• Select a Rendering Technique from the 

drop-down list to be used when the 

Alternate Mode  is active. 

Uncheck Show Lower Floors in Floor 
Overviews to show only the current 

floor in Floor Overviews. When checked, the 
current floor plus any floors beneath it are 
shown. See “Doll House View” on page 675. 

Click the Advanced button to open the 
Advanced Camera Options dialog and 

specify how hidden lines are removed when 
OpenGL is not used.  See “OpenGL and 
Hardware” on page 664.
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Advanced Camera Options 
Dialog

• Select NNS Method to use Home 
Designer Pro’s default method. In most 
cases, this method is both faster and 
requires less memory than the BSP 
Method. 

• Select BSP Method to use an alternative 
method. This method may provide better 
results in some situations; however, it 
may be slower and require more memory.

• When the BSP Method is used, checking 
Use Panels may increase speed and 
reduce memory usage.

3D View Defaults Dialog
Select 3D> 3D View Defaults, Edit> 

Default Settings , or double-click 

the Perspective View Tools  parent 
button to display the 3D View Defaults 
dialog.

Some settings in the 3D View Defaults 
dialog affect rendered views, some affect 
Vector Views, and some affect both view 
types. See “Rendered and Vector Views” on 
page 665.
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Options Tab

The General Options affect all 3D 
views. 

• Check  Restrict Floor Camera to Room 
to suppress the generation of objects out-
side the room in which a Floor Camera is 
created. Only affects subsequently gener-
ated Floor Camera views. See “Camera 
Views” on page 672. 

When checked, a view through a door-
way into another room shows only blank 
space or the selected 3D backdrop. Use 
this option to reduce 3D view rendering 
time or to minimize file size when creat-
ing a single room 3D Walkthrough.

• Uncheck Camera Bumps Off Walls to 
allow cameras to move freely through 
walls.

• Check Auto Rebuild Walls/Floors/Ceil-
ings to automatically rebuild floors and 

ceilings before a 3D view or elevation is 
displayed. When this is unchecked and 
the structure is not up to date, the Rebuild 
Walls, Floors, Ceilings  icon displays 
near your mouse pointer. See “Rebuild-
ing Walls, Floors & Ceilings” on page 
324.

• Check Auto Rebuild Terrain to auto-
matically rebuild terrain to reflect recent 
changes before generating a 3D view. If 
this option is unchecked and the terrain is 
not up to date, the Rebuild Terrain  
icon displays near your mouse pointer. 
See “Building the Terrain” on page 552.

• Check Legacy Compatible Texture 
Mapping to use global texture mapping 
settings rather than texture mapping fixed 
to individual objects. 
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• When Auto Adjust Default Glass Prop-
erties is checked, the program automati-
cally adjusts the behavior of window, 
door, and electrical fixture glass in Stan-
dard rendered and ray trace views in 
response to interior and exterior lighting 
conditions. When this box is unchecked, 
these adjustments are not made. 

The Lighting Options control the 
ambient light in rendered views. Click 

and drag the slide bar or type in a percent 
value to adjust these options. See “Ambient 
Light” on page 699.
• Interior Ambient affects interior views.
• Daytime Ambient affects daytime exte-

rior views.
• Nighttime Ambient affects nighttime 

exterior views.
• Click the Reset button to to restore initial 

default values.
• Uncheck Brighten Ceilings to turn off 

the default parallel light source that 
shines upward in interior views to add 
extra illumination to ceilings. See 
“Default Lights” on page 700. 

The Vector View Options only affect 
views using the Vector View rendering 

technique. See “Rendered and Vector Views” 
on page 665.
• Check Opaque Glass to make the glass 

in windows and doors opaque in Vector 
Views. When unchecked, window and 
door glass is completely transparent. 

• View Panel Factors adjust the perfor-
mance of Vector Views. Normally, these 
values should not need changing, but you 
may be able to get modest performance 
improvements by trying other values. See 
“Speeding up 3D View Generation” on 
page 716.

• View Panel Factor 1 determines how 
many surfaces are drawn for each hori-
zontal panel. Each horizontal panel is 
then subdivided into vertical panels - and 
View Panel Factor 2 determines how 
many surfaces are contained in each ver-
tical panel.

• View panel factors represent target num-
bers of surfaces to use in defining each 
panel. A value of 10000 for Factor 1 
means that a total of 10,000 or more sur-
faces are collected to define each panel 
vertically. A value of 2000 for Factor 2 
means that 2,000 or more surfaces are 
collected to define panels horizontally.

• Making these numbers larger results in 
fewer panels; making them smaller 
results in more panels. Adjusting these 
numbers either too low or too high causes 
the time required to draw to increase. 

• Framing Back Clip defines the back clip 
for framing members in cross section 
views. Framing must be set to display to 
see the effects of this value. A zero value 
does not back clip at all.

Default Color Display controls 
whether views created using the Vector 

View rendering technique are generated 
using color or not. See “Rendering 
Techniques” on page 710.
• Select a check box to generate that view 

type in color or uncheck to generate that 
view type as a line drawing. 

Legacy Compatible Texture Mapping
should remain unchecked except in leg-

acy plans with custom rotated textures.

2
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• A colored view can always be changed to 
a line drawing and vice versa by choosing 

Tools> Color Off/Color On .

The Scroll Bars check boxes control 
the display of scroll bars along the right 

side and bottom of each view window. Clear 
a check box to suppress the scroll bar in that 
view type and yield more viewing area. 

When the scroll bars are suppressed, you can 
use the keyboard arrow keys to scroll. To pan 
the display, hold the key and drag the pointer 
across the window. See “Panning the 
Display” on page 655.

Specify how the Surface Edge Lines  
display for all objects in 3D views.

• Check Use Layer Settings to display sur-
face edge lines for objects using the dis-
play settings specified by layer in the 
Layer Display Options dialog.

If this option is not checked, all edge 
lines are drawn black and solid with a 
line weight of 0.

• If Use Layer Settings is checked you can 
also check Use Object Settings. All 
objects that have special settings speci-
fied on the Line Style tab of their specifi-
cation dialog display using those settings, 
overriding the layer settings in the Layer 
Display Options dialog.

Backdrop Tab
The settings on the Backdrop tab allow you 
to specify a backdrop image or color to 

display behind your model in 3D views. See 
“3D Backdrops” on page 679. 

A preview of the selected backdrop is 
shown here, and its name displays for 

reference directly above. 
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Click Select Backdrop to open the 
Select Library Object dialog and 

choose a backdrop image from the library. 
See “Select Library Object Dialog” on page 
622.

Click Remove Backdrop to use a solid 
color instead of a backdrop image. The 

color used is defined in the Background 
Color section of this dialog tab. 

The Show Backdrop in options let you 
specify the conditions under which the 

selected backdrop image displays.
• Specify in which View Types a backdrop 

image is used. By default, only Perspec-
tive Camera Views are set to use a back-
drop. See “3D View Tools” on page 672.

• Specify in which Rendering Techniques 
a backdrop image is used. See 
“Rendering Techniques” on page 710.

Backdrop Options can be used to 
create spherical panoramic backdrops. 

• Check Spherical Panoramic Backdrop 
to place the selected backdrop onto a 
sphere that surrounds your model in cam-
era views and overviews. 

• The Horizontal Angle controls how 
many times the backdrop appears as you 
rotate in a full circle from side-to-side. A 
value of 360° makes the backdrop wrap 
around the scene once. A value of 720° 
makes it wrap around the scene twice. 
180° makes only half the backdrop wrap 
around the scene.

• The Vertical Angle determines how 
much of the backdrop stretches up-and-
down. To have the backdrop stretch from 
the highest point in the sky to the lowest 
point in the ground, use a value of 180°. 
To have the backdrop stretch from just 
below a horizontal render to just above, 
use a smaller value such as 100°.

Some experimenting with backdrop images 
and Angle values may be necessary to 
achieve the desired results.

Click the color bar to select the 
Background Color that displays when 

a backdrop image is not being used. See 
“Color Chooser Dialog” on page 652. 

The Background Color is used in all views 
except Vector Views, which instead use the 
Background Color set in the Preferences 
dialog. See “Colors Panel” on page 63. 

3D View Tools
Select 3D> Create 
Orthographic View to display 

the Orthographic View Tools or 3D> Create 
Perspective View to display the Perspective 
View Tools.

Camera Views
Camera views are perspective views. They 
are not scaled and cannot be annotated but 
are ideal for creating presentation views.

The Full Camera tool creates multi-
floor views of the 3D model. It can be 

used to create interior and exterior 
perspectives, and is good for displaying 
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cathedral ceilings, roofs, lofts, stairwell 
openings, and other variation in floor and 
ceiling levels.

The Floor Camera tool creates 
perspective views of the current floor 

only. Nothing above the ceiling surface is 
generated, and neither is anything below the 
floor. 

Overviews
An overview can be either orthographic in 
nature or perspective, depending on the tool 
used to create it. See “Creating Overviews” 
on page 674.

The Orthographic and 
Perspective Full Overview tools 

create views of the entire model including all 
floors, ceilings, and the roof. 

The Orthographic and 
Perspective Doll House View 

tools create views of the current floor 
without a roof or ceiling. 

The Orthographic and 
Perspective Framing Overview 

tools create views of the framing in the 

model. Framing must be built in order for it 
to display in a framing overview. See 
“Framing Overview” on page 675. 

Cross Section/Elevation Views
Cross Section/Elevation views are similar 
to the traditional, scaled orthographic views 
often used in drafting. They are scaled and 
can be fully annotated. See “Cross Section/
Elevation Views” on page 675.

A Cross Section/Elevation view 
displays all floors of the model except 

floor 0. If the view is created outside the 
structure looking toward it, the result is an 
exterior elevation. If the view is created 
inside the structure, or passes through any of 
the structure, a cross section is created. 

The Backclipped Cross Section tool 
includes only the objects between the 

starting point and stopping point of the cross 
section line.

The Wall Elevation tool creates an 
elevation of a wall on a single floor 

and in a single room. The Wall Elevation 
tool cannot be used to create exterior views. 

Creating Camera Views
All full and floor camera views are created 
using the same method.

To create a camera view

1. In floor plan view, select the desired 
camera tool. The mouse pointer displays 

the camera   icon. 

2. Click and drag a line to define the view 
direction. 

•  Where your line begins is the camera’s 
position. 

•  The line that you drag defines the 
direction the camera is pointed. 

•  The end of the line is the focal point of 
the view, the point the camera rotates 
around.
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•  By default, the field of view is 45°, 
which is similar to what the human eye 
sees or a 50mm camera lens. 

3. When you release the mouse button, a 
view generates in a new window.

4. Return to the floor plan view. A camera 
symbol now displays in floor plan view. 
See “Swapping Views” on page 656.

In order to create a camera view, you must 
click and drag at least as far as your current 
Snap Distance. See “Snap Properties Panel” 
on page 79.

Creating Overviews
In Home Designer Pro, there are three 
different overview types: Full, Floor and 
Framing Overviews. 

Each type of overview can be generated as 
either an orthographic or perspective view. 
An overview window’s title bar indicates 
whether it is perspective or orthographic. See 
“Perspective and Orthographic Views” on 
page 664.

Overviews generate as soon as you select the 
tool and are always created at the same 
angle. The focal point is always located at 
the center of the model; however, the 
position of the camera will vary depending 
on the size of the 3D model. The larger or 
more spread out the model, the further away 
the camera will be from the focal point so 
that the entire model can be seen in the view. 

Once generated, an overview window’s title 
bar indicates whether it is a perspective or 

orthographic view and a camera symbol 
representing the overview displays in floor 
plan view, The overview ‘camera’ can be 
edited much like regular camera views can. 
See “Editing 3D Views” on page 684.

Full Overview
Select 3D> Create Ortho-
graphic View> Full Overview or 

3D> Create PerspectiveView> Full Over-
view to generate an exterior view of the 
entire model.

Camera 
(click)

Focal Point 
(release)

Line of Sight 
(drag)

1.

2.

3.
Field of View 
Indicator
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Doll House View
Select 3D> Create Ortho-
graphic View> Doll House View 

or 3D> Create Perspective View> Floor 
Overview to create a view of the current 
floor with the ceiling removed and all floors 
beneath it visible.

Doll House Views are an effective tool for 
illustrating traffic flow and the relationships 
between spaces.  

To see a different floor, select Tools> 

Reference Floors> Up One Floor  or 

Down One Floor . You can also return to 
floor plan view and make another floor 
current before generating the Doll House 
View.

If you prefer, you can specify in the Camera 
Defaults dialog that only the current floor be 

included in Floor Overviews. See “Camera 
Defaults Dialog” on page 665. 

Framing Overview
Select 3D> Create Ortho-
graphic View> Framing 

Overview or 3D> Create Perspective 
View> Framing Overview to create a view 
of the entire model, displaying only framing 
and the foundation. 

Framing overviews include all floor, wall, 
and roof framing as well as foundations. 
Unlike other overviews, which use the 
Camera View layer set, Framing Overviews 
use the 3D Framing Set. See “Layer Sets” on 
page 103 

Framing must be built before generating this 
view or the view will be empty. 

Cross Section/Elevation Views
The Cross Section/Eleva-
tion, Back-clipped Cross 

Section, and Wall Elevation tools produce 
the traditional, orthogonal views often used 
in drafting. Regardless of their distance from 
the camera, all lines and dimensions in these 
views are their true lengths, making it easy to 
accurately see the spatial relationships of the 
3D objects in the model.

Cross section/elevation views can be clipped 
to limit how much of the model is included in 
the view. See “Camera Tab” on page 695.

Cross section/elevation views are the only 
3D views can be enhanced with the 2D CAD 
tools. They can be fully annotated and 
dimensioned and then printed to scale. 
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Cross Section/Elevation 
Camera Tools

Each of the three cross section/elevation 
camera tools has a specific function. 

A Cross Section/Elevation view 
displays all floors of the model. The 

cross section begins at the point where the 
camera arrow is drawn and continues 
through the entire model. 

The Backclipped Cross Section tool 
includes only the objects or portions 

of objects between the starting point and 
stopping point of the camera’s Line of Sight. 

The Wall Elevation tool creates an 
elevation of a single wall defining the 

room that the camera is drawn in. It does not 
cut through walls or show the ceiling, floor, 
or roof. It creates a 2D projection of a wall 
and the objects between the wall and the 
camera and is used primarily for kitchen and 
bath elevations. By default, Wall Elevations 
recognize room definition created by railings 
and invisible walls; however, you can specify 
This tool cannot be used to create exterior 
views.

Cross Section/Elevation , Backclipped 

Cross Section  and Wall Elevation  
views are created in the same way.

To create a Cross Section/Elevation view

1. Select the Cross Section/Elevation , 

Backclipped Cross Section  or Wall 

Elevation  tool. The pointer changes 
to a  with crosshairs marking the 
position of the pointer.

2. Click and drag a line in floor plan view. 
•  A Camera symbol displays where you 

click, along with a Cross Section Line 
indicating the plane of the camera’s 
cross section cut line.

3. Drag in the direction of the Line of Sight 
to draw a camera arrow.

•  Always drag the camera arrow perpen-
dicular to the wall to be viewed. 

4. When you release the mouse button, the 
view generates in a new window.

•  If the view is a Backclipped Cross Sec-
tion, a second Cross Section Line at the 
end of the Line of Sight indicates the 
furthest extent of the backclip.

As with camera views, you must click and 
drag at least as far as your current Snap 
Distance in order to create a Cross Section/
Elevation view. See “Snap Properties Panel” 
on page 79.

If the Line of Sight does not cut through a 3D 
object and the object is within the back 
clipped distance, such as a window shown in 
elevation, the object retains its 3D definition 
and can be selected, moved, stretched, or 
otherwise modified in the view. The 3D 
model is updated in all views.

Camera 
(click)

Focal Point 
(release)

Line of Sight 
(drag)

1.
2. 3.

Clip Plane Indicators
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Detailing Cross Section/
Elevation Views

CAD objects, including Text and 
Dimensions, can be created in cross 

section/elevation views. These objects are 
superimposed on the view and have no effect 
on the 3D model itself. If CAD objects have 
been added to a cross section/elevation view, 
the program will prompt you to save the view 
before closing the window. This information 
is then stored in the view. 

In cross section views, some objects, such as 
walls, are represented using Cross Section 
lines. If a dimension line finds an object 
surface edge represented by a Cross Section 
line, a Point Marker will be placed at that 
location, and the dimension will locate it 
instead of the Cross Section line. See 
“Markers” on page 762.

CAD objects will snap to the Snap Grid 

when Grid Snaps  are enabled. Note that 
the 3D model may obscure the display of the 
Snap Grid. See “Grid Snaps” on page 112. 

Displaying 3D Views
A variety of tools and settings allow you to 
control the appearance of your 3D views. 
There are also numerous ways to adjust the 
position, focal point and field of view of a 
3D view. See “Editing 3D Views” on page 
684.

The name of the current plan file and the type 
of view displays at the top of each view 
window in its title bar. If a 3D view is saved, 
its name also displays. 

There is no limit to the number of 3D view 
windows that you can have open at a given 
time; bear in mind, though, that each window 
demands use of your computer’s resources 
and that you may see poor performance if too 
many views are open. See “Open View 
Windows” on page 657. 

Layer Display Options
Which objects display in a 3D view is 
controlled in the Layer Display 

Options dialog. See “Layer Display Options 
Dialog” on page 104. 

Different view types use different layer sets 
when they are created. See “Layer Sets” on 
page 103.

To show framing in a cross section/elevation 
view, framing must first be built using the 
Build Framing dialog and the appropriate 
framing layers must be turned on in the 
Section View layer set. See “Framing” on 
page 435.

In Floor Plan View
3D cameras are represented in floor plan 
viewby symbols that indicate the camera’s 
position, field of view and focal point. 
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2D camera symbols are located on the 
“Cameras” layer See “Layers” on page 101.

By default, active camera symbols display 
regardless of whether the “Cameras” layer is 
on or off. If you prefer that their display be 
turned on or off with this layer, uncheck 
Always Display Active Cameras in the 
Camera Defaults dialog. See “Camera 
Defaults Dialog” on page 665. 

Active camera symbols use the Move color 
set in the Preferences dialog. All other 
display attributes are derived from the 
“Cameras” layer. See “Colors Panel” on page 
63.

You can also display camera symbols for 
saved cameras when the “Cameras” layer is 
turned on. See “Layers” on page 101.

Both saved and unsaved active cameras can 
have labels indicating the camera number or 
name. Camera labels are located on the 
“Cameras, Labels” layer. See “Object 
Labels” on page 884. 
• Camera labels are numbered sequentially 

in each plan in the order they were 
created.

• Camera labels always use the Camera 
Name. Saved cameras’ names can be 
specified in the Camera Specification 
dialogs. See “Camera Tab” on page 692.

Camera symbols are an on-screen reference: 
they do not print unless Print Image is used 
and cannot be sent to layout except as an 
image. They are, however, included in views 
exported to .dxf.

In Rendered Views
There are a number of factors that contribute 
to the appearance of rendered 3D views:

• Select 3D> Camera View Options> 

Toggle Textures  in a 3D view to turn 
off the display of material textures. See 
“About Materials” on page 632. Not 
available in Glass House,Technical Illus-
tration or Vector Views. 

• Select 3D> Lighting> Adjust Lights  
to open the Adjust Lights dialog and edit 
the light sources in the current plan. See 
“Adjust Lights Dialog” on page 704.

• Select 3D> Camera View Options> 

Final View  or Final View with 

Shadows  to regenerate the rendered 
view based on the final view settings on 
the Render panel of the Preferences dia-
log. See “Previews vs Final Views” on 
page 698 

In Vector Views
There are also a number of factors that affect 
the appearance of 3D Vector Views:

• Select 3D> Toggle Patterns  in a Vec-
tor View to turn on or off the display of 
the “Patterns, 3D Views” layer, which 
controls the display of material pattern 
lines. See “Layers” on page 101. 

• Select Tools> Display Settings> Color 

On/Off  to control the display line 
and fill colors. See “Color On/Off” on 
page 149. 

• The line style, color, and weight of 
objects in Vector Views can be specified 
by layer or, for some objects, individually 
in their specification dialogs. See “Line 
Style Tab” on page 781.

• The line weight, color, and style of mate-
rial patterns are set in the Define Material 
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dialog. See “Define Material Dialog” on 
page 644.

• Line weights display on screen when 

Show Line Weights  is enabled. See 
“Show Line Weights” on page 845.

3D Backdrops
A backdrop image is like a large billboard 
image that displays behind the model in 3D 
views. Backdrop images often show an 
outdoor scene to add realism and a sense of 
perspective to 3D views. You can select a 
backdrop image for a plan from the library in 
either of two ways: 
• In any view, select 3D> 3D View 

Defaults  to open the 3D View 
Defaults dialog. See “Backdrop Tab” on 
page 671. 

• In a 3D view, open the Library Browser. 
Browse to and select a Backdrop image, 
then move your cursor into the view win-
dow. Click anywhere in the view to apply 
the selected backdrop. 

Regardless of how it is selected, only one 
backdrop can be used in a plan at any given 
time. 

You can specify which view types and 
Rendering Techniques use the selected 
backdrop in the 3D View Defaults dialog. By 
default, Perspective Camera views using the 
Standard, and Watercolor Rendering 
Techniques use backdrops while the other 
techniques and view types do not. 

You can also create your own backdrop 
images and import them into the library. See 
“Adding New Backdrops” on page 614. 

Rendering Techniques
Any 3D view can be assigned a 
Rendering Technique for a range of 

different purposes: from detail drawings to 
artistic presentation views. Select 3D> 
Rendering Techniques to access these tools. 
See “Rendering Techniques” on page 710.

Delete 3D Surface
The individual surface of an object 
can be temporarily removed from any 

3D view by selecting 3D> Delete Surface 
and then clicking on a surface. When the 
pointer is over a surface, that surface will 
become highlighted.

Surfaces removed in one view are removed 
in all 3D views, but are not permanently 
removed from the model. Continue clicking 
surfaces to remove them, then select another 
tool when you are finished.

Surfaces in 3D views are composed of 
multiple triangles. Hold the Alt key while 
clicking to delete one triangular face at a 
time rather than all triangles forming a  
surface. See “Higher Quality Rendering” on 
page 699. 

Select 3D> Delete Surface  or click the 
toolbar button to restore the most recently 
deleted surface. All surfaces can be restored 
by selecting Build> Floor> Rebuild Walls/

Floors/Ceilings  or by exiting the 3D 
view and reopening it.

Rebuild 3D
Select 3D> Rebuild 3D to regenerate 
all 3D data asociated with the current 

plan. All open views will remain open.
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Remove 3D
Select 3D> Remove 3D from floor 
plan view to close all 3D views 

associated with the current plan file and 
remove unsaved 3D data from memory.

Any views saved with the plan are closed but 
not deleted.

Repositioning Cameras
Once a 3D view is created, there are many 
ways to manipulate the camera location and 
the direction of its line of site using the 
mouse, the keyboard, and the menus. 

The Move Camera with Mouse buttons are 
included on the toolbars  in 3D views by 
default; but, you can add the other tools your 
toolbars as well as customize their hotkeys. 
See “Toolbars & Hotkeys” on page 91.

When the keyboard or menu commands are 
used to move or rotate a camera, the 
adjustments occur in regular increments. The 
size of these increments is specified in the 
Camera Specification dialog: 
• The Incremental Move Distance con-

trols Panning movement and forward and 
backward Dolly movement. 

• The Incremental Rotate Angle controls 
Orbit movement, Tilt movement, and side 
to side Dolly movement.

See “Camera Specification Dialog” on page 
691. 

Each time you move the camera, the view is 
updated. If you are using either the toolbar or 
keyboard to move the camera,  you can hold 
down the Shift key, suppressing the redraw 
of the view until the Shift key is released and 
allowing you to move multiple increments 
more quickly. 

Move Camera with Mouse
An active camera’s position can be 
edited using the mouse. Select 3D> 

Move Camera With Mouse to access the 
Move Camera with Mouse modes. With the 

exception of Mouse Orbit Camera, which is 
available in Orthographic Overviews, these 
tools are not available in Orthographic 
views.

Press Ctrl + Alt + S while in a camera
view or overview to spin the view.

Press Esc to stop the spinning.
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Move Camera with Arrow Keys
An active camera’s position can be changed 
using the arrow keys on your keyboard. 
Select 3D> Move Camera with Arrow 
Keys to access Move Camera with Arrow 
Key modes. With the exception of Mouse 
Orbit Camera, which is available in 
Orthographic Overviews, these tools are not 
available in Orthographic views.

These modes use the Incremental Move 
Distance and Incremental Rotate Angle set 
in the active 3D view’s Camera 
Specification dialog. 
• Arrow-Orbit Camera lets you use the 

arrow keys to rotate the camera around 

the current focal point. The camera’s 
position and direction both change.

• Arrow-Pan Camera lets you move the 
camera up, down, right, and left using the 
arrow keys. The camera’s position 
changes, but its direction does not.

• Arrow-Dolly Camera lets you move the 
camera forward and back using the up 
and down arrow keys, and rotate side to 
side using the left and right arrow keys. 

• Arrow-Tilt Camera lets you use the 
arrow keys to tilt the camera up, down, or 
side to side to change the focal point. The 

Hotkey Description

Alt + O Mouse-Orbit Camera lets you move the mouse to rotate the camera 
around its focal point. The camera’s position and direction both change.

To continuously rotate the camera around its focal point, click in the 3D 
view, drag the mouse, and release the mouse button to “throw” the 
view. Click again in the view to stop it from rotating. 

Alt + P Mouse-Pan Camera lets you move the mouse to move the camera up, 
down, left and right. The camera’s position changes, but its direction 
does not.

Alt + D Mouse-Dolly Camera lets you move the mouse up and down to move 
the camera forward and backward. Move the mouse left or right to 
rotate the camera side to side.

Alt + T Mouse-Tilt Camera lets you move the mouse to tilt the camera in any 
direction while staying in the same location. 

3D Center Camera on Point lets you focus the camera at a particular 
point in the scene. This also sets the camera center so that future use of 
Mouse-Orbit Camera rotates around that point. To use the 3D Center 
tool, activate the tool and then click on any object in the scene.



682

Home Designer Pro 2014 Reference Manual

camera’s direction changes, but its posi-
tion does not.

Move Camera Tools
Select 3D> Move Camera in a 3D 
view to access these tools. These tools 

change the active camera’s position, but not 
its direction and are not available in  
Orthographic views. 

These tools use the Incremental Move 
Distance set in the active 3D view’s Camera 
Specification dialog. 

Orbit Camera Tools
Select 3D> Orbit Camera in a 3D 
view to access these tools. Orbiting 

the camera rotates it about the focal point 
using the Incremental Rotate Angle set in 

the active view’s Camera Specification 
dialog. 

These tools are not available in , Back 
Clipped Cross Section, or Wall Elevation 
views.

Hotkey Description

F Move Camera Forward moves the camera and its focal point forward. 

B Move Camera Back moves the camera and the focal point back. 

L Move Camera Left moves the camera and the focal point to the left in 
a line perpendicular to the line of sight. 

R Move Camera Right moves the camera and the focal point to the right 
in a line perpendicular to the line of sight. 

U Move Camera Up moves the camera and the focal point up. 

D Move Camera Down moves the camera and the focal point down. 
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Tilt Camera Tools
Select 3D> Tilt Camera to access 
these tools. Tilting keeps the camera 

in one place and pivots the camera about its 
vertical or horizontal axis. This movement 
uses the Incremental Rotate Angle set in 
the active view’s Camera Specification 

dialog and is similar to tilting your head up 
and down or turning it side-to-side. 

These tools are not available in  
Orthographic views. 

Hotkey Description

I Move Camera In moves the camera closer to the focal point along the 
line of sight. The camera cannot move past the focal point using this 
tool.

O Move Camera Out moves the camera away from the focal point along 
the line of sight. 

Orbit Camera Upward rotates the camera up about the focal point. 
The camera cannot rotate past a vertical line looking straight down on 
the focal point.

Orbit Camera Downward rotates the camera down about the focal 
point. The camera cannot rotate past a vertical line looking straight up 
at the focal point.

Orbit Camera Left rotates the camera to the left about the focal point.

Orbit Camera Right rotates the camera to the right about the focal 
point. 

Hotkey Description

Tilt Camera Upward tilts the camera up while keeping it in the same 
location. The camera cannot tilt beyond the vertical position.

Tilt Camera Downward tilts the camera down while keeping it in the 
same location. The camera cannot tilt beyond the vertical position.
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View Direction Tools
The View Direction Tools allow you 
to view the model from a specific 

direction in a camera view, overview, or 
cross section/elevation view. While one of 
these views is active, select 3D> View 
Direction to access these tools. 

Editing 3D Views
In addition to its position and direction, there 
are other ways to modify a 3D view.

In the Specification Dialog
You can  make adjustments to a 
camera in the Camera Specification 

dialog. This dialog is particularly helpful for 
making fine adjustments to the camera’s 

position, appearance, and other attributes. 
See “Camera Specification Dialog” on page 
691.

Turn Camera Left turns the camera to the left while staying in the 
same location.

Turn Camera Right turns the camera to the right while staying in the 
same location.

Hotkey Description

Description

Front View creates a front view 
of the model.

Back View creates a back view 
of the model.

Top View creates a top view of 
the model.

Bottom View creates a bottom 
view of the model.

Left Side View create a left side 
view of the model.

Right Side View create a right 
side view of the model.

Restore Original View restores 
the original view position.

Description

Tile a 3D view and the floor plan view
and use the camera movement tools to

see how they affect the camera. See “Tiling
Views” on page 659.
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Using the Edit Tools
A camera symbol or symbols selected in 
floor plan view can be edited in a variety of 
ways using the buttons on the edit toolbar. 
See “The Edit Toolbar” on page 29.

Using the Edit Handles
Return to floor plan view without closing the 
3D view. See “Swapping Views” on page 
656. 

Using the Select Objects  tool, select the 
camera object. When a camera symbol is 
selected it displays four edit handles. 

• Drag the Line of Sight handle to change 
the camera angle without moving the 
focal point.

• Drag the Move handle to relocate the 
camera while maintaining its relative 
angle.

• Drag the Focal Point handle to reposition 
the focal point and change the line of 
sight without moving the camera.

• Drag the Rotate handle to rotate the cam-
era’s line of sight about its center.

The 3D view corresponding to the camera 
symbol reflects changes made to the symbol 
in floor plan view. 

Multiple camera symbols can be selected; 
however, their editing options are limited to 
being moved, rotated, and deleted. 

Using the Contextual Menu
In a 3D view, right-click in an empty space in 
which the backdrop or background color 
displays to access the contextual menu. See 
“Contextual Menus” on page 30. 

• In Vector Views, the options are a selec-
tion of commonly used commands from 
the File, Edit, Tools and Window menus. 

• In rendered views, the options are a 
selection of tools and toggles specific to 
rendered views or override the settings in 
the Preferences dialog. See “Render 
Panel” on page 86.

Changing a setting in the contextual menu 
only affects the current view. It does not 
affect the settings in the Preferences dialog.

Up One Floor/Down One Floor
You can move a camera to a different floor. 
While the camera view is active, select 
Tools> Reference Floors> Up One 

Floor  or Down One Floor . 

Rotate

Focal Point

Move

Line of Sight

Move
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The position and movement of a camera is 
affected by its location within the model. 
When the camera is outside a building, its 
height is relative to the terrain and follows 
the terrain as it is moved. When inside a 
building, the camera height is relative to the 
floor of the room it is drawn in.

Which floor an active camera is on 
determines which floor is affected when any 
floor-specific actions are done. For example, 
if a camera is on Floor 2 and changes are 
made to the Floor Default settings while in 
that view, Floor 2 will be affected.

If the camera is on an upper floor and you 
move the camera outside of the building, the 
camera remains at the same height relative to 
the floor it was created on.

Zooming
The Zoom Tools are available in all 
3D views. See “Zoom Tools” on page 

654. 

Selecting Window> Zoom In , Zoom 

Out  or Fill Window  does not change 
the camera’s location or field of view. 
Instead, the extents of the view are expanded 
or cropped. 

If you wish, you can instead set the 

Zoom  tools to change the  Field of View 
when used in a 3D view. See “Render Panel” 
on page 86.

Field of View
The Field of View refers to a camera’s field 
of vision. A wider field of view makes the 
focal point appear further away, as more of 
the image is included in the same view 
window. 

In floor plan view, the angled lines of a 
camera symbol indicate its field of view. 

A camera’s field of view can be adjusted in 
the Camera Specification dialog. See 
“Camera Specification Dialog” on page 691.

The field of view can also be adjusted while 
in a camera view using the keyboard:
• W - Increase camera Field of View.
• N - Decrease camera Field of View.

The field of view can also be adjusted with 
the mouse wheel when Zoom Using Field of 
View is checked in the Preferences dialog. 
See “Render Panel” on page 86.

Cross Section Slider
Select 3D> Camera View Options> 
Cross Section Slider when a camera 

view or overview is active to open the Cross 
Section Slider dialog. 

FOV Indicators
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To use the Cross Section Slider

1. Click on the radio button beneath one of 
the cross section angles to select it.

•  The option at top right turns off the cut-
ting plane, so no cross section is made.

2. Move the Position slider to adjust the 
position of the cutting plane. 

3. You can position the cutting plane with 
accuracy using the text field to the right 
of the slider. 

•  This value is measured from the edge 
of the model that is cut first by the 
selected cross section angle.

4. Click OK to close the dialog. If the 
active camera is saved, its Cross Section 
Slider settings will also be retained. See 
“Saving 3D Views” on page 690. 

Working in 3D 
A variety of tools are available in 3D views 
that allow you to edit your 3D model. You 
can also use the Dimension, Text, and CAD 
Tools to add annotation to cross section/
elevation views.

Creating Objects in 3D Views
You can place windows, doors, cabinets, 
electrical objects, corner trim, and most 
library objects directly into 3D views. To do 
this, select the appropriate tool and click in 

Note: The Cross Section Slider is not avail-
able when the Vector View Rendering Tech-
nique is used. See “Rendering Techniques”
on page 710. 
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the 3D view. You can then edit the object’s 
size and placement. 

When created in 3D, most objects must be 
placed against a wall, on a floor platform, or 
within the Terrain Perimeter.  

You can also click and drag to draw some 
CAD-based objects such as custom 
countertops, roof planes, terrain features and 
road, in camera views and overviews views. 

The Build Framing and Build Roof dialogs 
are also accessible in 3D views, although the 

manual Framing Tools  and Roof Tools 

 are not. 

Selecting and Editing 
Objects in 3D Views

Most objects can be selected and edited in 

3D views. Select Edit> Select Objects  
and click on the surface of an object to select 
it. Once selected, objects can be edited using 
their edit handles, buttons on the edit toolbar, 
and the object’s specification dialog. See 
“Editing Objects” on page 119.

When you select an object, edit handles and a 
handle surface display. The handle surface is 
a rectangle around the perimeter of the object 
that indicates the overall height and width of 
the selected surface. The edit handles that 
display depend on the type of object selected. 
Walls, for example, display two resize edit 
handles when selected while a slab displays 
ten handles, allowing you to move, resize 
and reshape it.

All moving or resizing is in the plane of the 
handle surface. You cannot  move an object 
directly towards or away from the camera, 
for example, because that surface plane 
cannot be seen in the view. 

By default, object movement is restricted to 
one inch or 10 mm increments, but this 
restriction can be set to custom increments in 
the Plan Defaults dialog and toggled off and 

on using the Grid Snaps  button. See 
“Grid Snaps” on page 112.

Unrestricted positioning can also be enabled 
by holding down the Ctrl key while moving 
or resizing an object. See “Unrestricted 
Movement” on page 153. 

When Fixture/Furniture Resize Enable is 
unchecked in the Plan Defaults dialog, only 
a single handle displays for furniture and 
stand-alone fixtures and appliances. In this 
case, the object can only be moved. See 
“General Plan Defaults Dialog” on page 58. 

Temporary dimension lines display when 
many objects are selected to help you resize 
the object and determine its height. These are 
sometimes easier to see when the color is 
toggled off. See “Display Temporary 
Dimensions” on page 731.

Because cross section/elevation views are 
orthogonal and display objects at their actual 
dimensions, they are sometimes more 
suitable for editing objects than camera 
views or overviews. See “Cross Section/
Elevation Views” on page 675.

Note: If the wall height of the Exterior Room
is adjusted in a 3D view, the default Floor or
Ceiling Height of the entire floor is changed.
See “Floor and Room Defaults” on page 230.
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When several 3D views are open, changes 
made in the plan automatically rebuild the 
model in all views.  Because of this, it is 
typically faster to make changes to your plan 
with as few windows open as possible.

Editing Materials in 3D Views
Select 3D> Materials> Adjust 
Material Definition, then click on a 

surface in the 3D view to open the Define 
Material dialog for that material. See “Adjust 
Material Definition” on page 637.

Select 3D> Material Painter to apply 
materials to surfaces in the view using 

the Material Painter Tools. See “The Material 
Painter” on page 632.

Select 3D> Material Painter> 
Material Eyedropper to apply the 

material on a surface in the view to other 
surfaces in the view. See “Material 
Eyedropper” on page 634. 

Rebuild 3D
As changes are made to your plan, a 
3D view automatically updates to 

reflect any changes visible in the view. If you 
find that a view is not updating as expected, 
select 3D> Rebuild 3D to rebuild the entire 
3D model.

Annotating 3D Views
The Dimension Tools, Text Tools, and CAD 
Tools are available in cross section/elevation 
views, allowing you to add technical 
information, call attention to details, and 
other tasks in these views. See “Detailing 

Cross Section/Elevation Views” on page 
677.

Cross Section Lines
Cross Section Lines are created in cross 
section views to represent any objects split 
by the cross section line of the camera. They 
are placed on the “Cross Section Lines” 
layer, which is locked by default, and they 
get deleted and replaced whenever the view 
is redrawn.

When a dimension is drawn to locate an 
object split by a camera’s section line, it 
actually locates Cross Section Lines. So that 
dimensions can be retained when Cross 
Section Lines are regenerated, a Point 

Marker  is automatically created where a 
dimension meets a Cross Section Line and 
the dimension locates it instead of the Cross 
Section Line. See “Point Markers and 
Dimensions” on page 763. 

Cross Section Lines will print when their 
layer is turned on; however, they are not 
included when the view is sent to layout. The 
Point Markers created when dimensions 
locate Cross Section Lines, however, will 
both print and display in views sent to layout. 
See “Layout” on page 863.

The “Cross Section Lines” layer can be 
unlocked, allowing Cross Section Lines to be 
be selected and edited. Additional CAD 
objects can also be placed on this layer when 
it is unlocked, as well; however, when the 
view is redrawn, all CAD objects on this 
layer will be deleted and replaced with a 
fresh set of Cross Section Lines. 
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Saving & Printing 3D Views
3D camera views, overviews and cross 
section/elevation views can be saved with the 
plan in which they are created, exported and 
saved as image files, as well as sent to layout 
and printed. 

Saving 3D Views
 Select 3D> Save Active Camera to 
save the current camera in the plan. 

You can also save a camera view by checking 
the Saved box in the Camera Specification 
dialog. See “Camera Specification Dialog” 
on page 691. 

Saved cameras can be closed and re-opened 
for later use, and retain their Cross Section 
Slider and Rendering Technique settings. See 
“Cross Section Slider” on page 686 and 
“Rendering Techniques” on page 710. 

In addition, if CAD or Text objects are drawn 
in a cross section/elevation view, you will be 
prompted to save the view when you close it. 
Any CAD or Text objects added to a cross 
section/elevation view are saved with the 
view as part of the plan file. 

Activating Saved Views
There are three ways to open a saved 3D 
view: 
• Select the camera symbol in floor plan 

view and click the Open View  edit 
button.

• Double-click the camera symbol using 

the Select Objects  tool.
• Right-click on it and select Open View 

from the contextual menu.

Unsaved cameras that are open in another 
view window can also be activated using the 

Open View  edit button.

If you open a saved camera view and then 
modify its location or direction using any of 
the tools available in that view, the program 
will confirm whether you want to re-save the 
camera using these new settings when you 
close it. See “Repositioning Cameras” on 
page 680.

Exporting 3D Views
All 3D views can be exported and 
saved as .bmp, .jpg, .png, or .tif files. 

Select File> Export> Picture to save the 
current screen image as an image file. See 
“To export a picture” on page 811.

In addition, Vector Views can be exported 
and saved as .emf files. See “Metafiles” on 
page 814. 

Once saved, a picture can be opened and 
converted into many other formats using a 
graphics program. Picture files can be sent to 
layout or used in word processing, desktop 
publishing, and web development programs 
to create advertisements, brochures, etc.

When a picture is exported, it is assigned the 
same size as it displays on screen. You can 
change the size of the view window to create 
a smaller or bigger picture.

Plan Backup
When transferring a plan to another 
computer or to another user, it is 

helpful to include all the Images, Textures, 
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and Backdrops used in the plan so that 
rendered views are complete. The Backup 
Entire Plan tool allows you to do so. See 
“Backup Entire Plan” on page 52.

Printing 3D Views
Since all 3D views other than Vector 
Views are created using pixels instead 

of lines, File> Print> Print Image must be 
used when printing. Print Image is a special 
Home Designer Pro function that prints the 
screen in picture format. The entire view 
prints, including images such as plants and 
textures. 

The quality of your print image is affected by 
your current window size and screen 
resolution. To maximize the quality of your 
printed image, generate it in full screen size 
and use the maximum screen resolution.

3D views can also be sent to layout and then 
printed as part of your construction 
documents.

Select File> Send to Layout to send 
the current view to layout. See 

“Sending Views to Layout” on page 866.

Select a saved, inactive camera 
symbol in floor plan view and click 

the Send Camera’s View to Layout edit 
button to send the view to layout. 

Camera Specification Dialog
The Camera Specification dialog can 
be accessed in floor plan view by 

selecting a single camera symbol and 
clicking the Open Object edit button. See 
“In Floor Plan View” on page 677.

This dialog can also be accessed while a 
camera view or overview is active by 

selecting 3D> Edit Active Camera . 

The selected view’s specific type is indicated 
in the dialog’s title bar: the specification 

dialog for a Full Camera , for example, 
is named Full Camera Specification.  

This dialog can only be opened for one 
camera at a time. If more than one camera 

symbol is selected, Open Object  will not 
be available. 
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Camera Tab

Some settings only affect some types of 
views. Depending on the type of camera 
view selected, not all the settings may be 
editable. 

To change a setting, first uncheck Default, 
then type a new value in the text field.

Specify the Camera Name that 
displays with the camera symbol in 

floor plan view. 
• Check Saved to save this view with the 

plan. As soon as you type anything in the 
text field, this box becomes checked. If 
you click OK while this box is checked, it 
will become checked permanently.

The Positioning settings determine the 
position and orientation of the camera. 

See “Repositioning Cameras” on page 680. 
• The Incremental Move Distance con-

trols how far the camera moves each time 
you Pan in any direction or Dolly for-
wards or backward. For interior views a 

small number is good, but for exterior 
you may want a larger increment.

• The Incremental Rotate Angle defines 
how many degrees the camera rotates 
each time you Tilt, Orbit, or Dolly side to 
side. A setting of 90° would make one 
full rotation in four moves.

• The Height Above Floor defines the 
height that the camera is above the floor 
level for the current floor.

• The Field of View defines the camera’s 
field of vision in angular degrees. See 
“Field of View” on page 686.

• The Tilt Angle determines the angle the 
camera is tilted. The camera maintains its 
focal point and position in floor plan 

2

4
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1

2
You can increase a camera’s Field of
View when the view is active by press-

ing the W key, or decrease the Field of View
by pressing the N key. 
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view, but if the camera is tilted, the focal 
point is above or below the current cam-
era height. 

• Specify the selected camera’s Camera 
Angle. This is an absolute value: an angle 
of 0° points the camera toward the left in 
floor plan view.

• Specify the X Position and Y Position 
for the selected camera. These are abso-
lute coordinates. Specifying zero for both 
places the camera at the plan’s origin 
point (0,0). 

• Check Default for any value to use the 
default setting. 

Settings in the Wall and Surfaces 
section determine the extent of the 

camera view.
• Clip Surfaces Within - Objects located 

within this distance from the camera do 
not display in the view.

• Remove Wall Within - Remove the view 
of walls within this distance of the cam-
era.

Both of these Within distances are measured 
as a radius from the camera position.
• Check Unless Opening to display a wall 

that is inside the Remove Wall Within 
range if the camera is pointing through an 
opening such as a door or window.

• Check Default for any value to use the 
default setting. 

Select the Rendering Technique used 
by the selected camera from the drop-

down list. See “Rendering Techniques” on 
page 710. 

Uncheck Show Lower Floors to show 
only the current floor in the selected 

Floor Overview. When checked, the current 
floor plus any floors beneath it are included 
in the view.  Only available for Floor 
Overviews. See “Doll House View” on page 
675. 

Click the Advanced button to open the 
Advanced Camera Options dialog and 

specify how hidden lines are handled in 
Vector Views when OpenGL is not used. See 
“Advanced Camera Options Dialog” on page 
668. 

Plan Display Tab
The settings on the Plan Display tab control 
the appearance of the selected camera in 

floor plan view. See “In Floor Plan View” on 
page 677. 

3
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The Standard Options settings allow you to 
specify the appearance of the selected 
camera’s standard symbol. Uncheck Default 
beside any of these options to modify it. See 
“Dynamic Defaults” on page 57. 
• The Camera Symbol Size is measured in 

plan inches (mm). 
• Check Show Camera Focal Point to  

display the camera’s focal point in floor 
plan view. When unchecked, the view’s 
line of sight and focal point are hidden 
until the camera is selected; cross section/
elevation camera clip plane indicators are 
suppressed in the same manner when this 
is unchecked. 

• Check Show Field of View Indicators to 
display the camera’s field of view indica-
tors in floor plan view. You can also 
change the FOV Indicator Length, 
which is measured in plan inches (mm).

• Specify the Clip Plane Indicator 
Length in plan inches (mm). This is the 
length of the clip plane indicator line(s) 
for cross section/elevation views only 
and is available when Display as Callout 
is checked. See “To create a Cross Sec-
tion/Elevation view” on page 676. 

Label Tab
In the Camera Specification dialogs, the 
settings on the Label tab are limited to 
Suppress Label checkbox and Position and 
Orientation settings. 

Camera labels always use the Camera Name 
specified on the Camera tab. When callouts 
are used, the Callout Label and Text Below 
Line are specified on the Plan Display tab.

For information about this tab, see “Label 
Tab” on page 885.

Cross Section/Elevation Camera Specification
The Cross Section/Elevation 
Camera and Wall Elevation Camera 

Specification dialogs can be accessed in 
floor plan view by selecting a single cross 
section/elevation camera symbol and 

clicking the Open Object edit button. See 
“In Floor Plan View” on page 677.

These dialogs can also be accessed while a 
cross section/elevation camera view is active 

by selecting 3D> Edit Active Camera . 
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Camera Tab

The Camera Name displays in floor 
plan view.

• Check Saved to save this view with the 
plan. As soon as you type anything in the 
text field, this box becomes checked. If 
you click OK while this box is checked, it 
will become checked permanently.

The View Clipping settings control the 
extents of the camera view.

• Back Clip After - Enter the distance in 
inches (mm) from camera to backclip 
plane. If zero, no back clipping occurs. 

• Check Clip To Sides to limit the selected 
camera view’s side-to-side extents to the 
length of its Clip Plan Indicator line(s) in 
floor plan view. When unchecked, the 
full width of the model is included in the 
view. 

The Clip Plane Indicator Length can be 
specified on the Plan Display tab when 
callouts are not used, or using the cam-
era’s edit handles in floor plan view. See 
“Editing 3D Views” on page 684. 

Settings in the Positioning section 
determine the location of the camera in 

floor plan view.
• Specify the X Position of the camera in 

absolute coordinates.
• Specify the Y Position of the camera in 

absolute coordinates.

Select the Rendering Technique used 
by the selected camera from the drop-

down list. See “Rendering Techniques” on 
page 710.

Click the Advanced button to open the 
Advanced Camera Options dialog and 
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specify how hidden lines are handled in 
Vector Views when OpenGL is not used. See 
“Advanced Camera Options Dialog” on page 
668. 

Plan Display Tab
The settings on this tab are also found in the 
Camera Specification dialog. See “Plan 
Display Tab” on page 693.

Label Tab
In the Cross Section/Elevation Camera 
Specification dialog, the settings on the 

Label tab are limited to Suppress Label 
checkbox and Position and Orientation 
settings. 

Camera labels always use the Camera Name 
specified on the Camera tab. When callouts 
are used, the Callout Label and Text Below 
Line are specified on the Plan Display tab.

For information about this tab, see “Label 
Tab” on page 885.
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Chapter 29:

3D Rendering

There are a variety of tools available to 
create 3D views of a model: simply click a 
button to create an overview, or click and 
drag to create a camera or cross section/
elevation view. See “3D Views” on page 663.

To improve the quality of the rendering and 
create a custom look, you can adjust lighting, 
edit the materials used in the plan, choose 
from several rendering techniques and fine-
tune 3D view quality settings. From most 3D 
views, you can create Final views of even 
higher quality.

Chapter Contents
•      Rendering Tips
•      Lighting
•      Displaying Lights
•      Light Types
•      Default Sun Light Specification Dialog
•      Sun Angle Specification Dialog
•      Rendering Techniques
•      Rendering Technique Options
•      Speeding up 3D View Generation

Rendering Tips
There are a variety of factors which affect the 
appearance and quality of rendered 3D 
views. You can use these tools and settings to 
achieve renderings that meet your needs. 

Lighting
Lighting is extremely important in most 3D 
renderings. Lighting controls the visibility of 
objects in a view, affects the appearance of 

surfaces, and influences the appearances of 
colors and textures on those surfaces. Even 
small changes to light intensity, direction and 
color can have a large impact on image 
quality. See “Lighting” on page 699.

Material Textures
Textures are graphic files that represent 
contoured surfaces of objects such as carpet, 
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bricks, tile, and wood in rendered views. 
Textures are assigned to materials which in 
turn are assigned to objects. See “Patterns 
and Textures” on page 632. 

The display of materials in rendered views is 
controlled by settings on the Texture and 
Properties tabs of the Define Material dialog. 
See “Define Material Dialog” on page 644.

For realistic rendered views, it is important 
to adjust texture properties correctly. 
Textures can be mapped to objects for correct 
placement. See “Mapping Patterns and 
Textures” on page 638. 

Brightness, shininess and transparency 
control how light sources affect the display 
of surfaces in rendered views. See 
“Lighting” on page 699.

If no texture is selected for a material or if 
the display of textures is turned off, affected 
surfaces are a solid color instead.

Images
Images are very important for the appearance 
of rendered views. Images are picture files 
that represent individual objects such as 
trees, flowers, cars,  and people. Images are 
represented in floor plan view by 2D symbol 
and are visible in Vector views. See “Placing 
Images” on page 806.

Backdrops
Backdrops are images that display in the 
background of 3D views. Only one backdrop 
can be used at a time. If a backdrop is not 
applied, Home Designer Pro applies a 
background color. 

Backdrops and background colors are 
selected in the 3D View Defaults dialog. See 
“Backdrop Tab” on page 671.

You can also add a backdrop directly into a 
3D view from the Library Browser. To do 
this, select a backdrop in the the Library 
Browser and move your pointer into the view 
window. The pointer will display the 
Backdrop  icon. Click once in the view to 
apply the selected backdrop to this and all 
other 3D views using backdrops in the 
current plan.

Spherical Panoramic Backdrops are a 
special type of backdrop that wraps around 
the model in 3D views as though it were 
applied to a sphere surrounding it.

It takes a special camera or an image 
processing program to generate spherical 
panoramic backdrops. 

Previews vs Final Views

With the exception of Vector Views, 3D 
views are generated using the Preview 
settings in the Preferences dialog. Rather 
than produce the best quality possible, the 
installed settings for Previews generate 3D 
views quickly but with reasonable quality, 
and are best when working on the model in 
3D. See “Render Panel” on page 86. 

Final Views produce much higher quality 
images that are more suitable for printing or 
saving as graphics files. Final Views often 
take significantly longer to generate than 
Previews, so the 3D view reverts back to the 
Preview settings as soon as anything is 
changed within the view.

When you have finished making adjustments 
in the 3D view, select 3D> Camera View 
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Options> Final View  or Final View 

with Shadows . 

Final View  is not available in Vector 

Views. Final View with Shadows  is not 
available in Vector View, Glass House, or 
Line Drawing views. See “Rendering 
Techniques” on page 710.  

Higher Quality Rendering
The settings on the Render panel of the 
Preferences dialog allow you to adjust 
rendering quality and speed so that you can 
strike a balance that best suits your needs. 
For high quality Final Views, consider 
experimenting with these settings:
• Soft Shadows displays shadows with soft 

edges instead of hard edges. This feature 
is only used when Show Shadows is used 
and  can slow renderings considerably.

• Triangle Size - When you use triangles, 
the program divides surfaces in most 3D 
views into triangles which are used to 
illuminate the surfaces properly. Gener-
ally speaking the smaller the Triangle 
Size, the slower the rendering, but the 
higher-quality result you can achieve. 
Triangles are not used in the Standard and 
Technical Illustration Rendering Tech-
niques. See “Rendering Techniques” on 
page 710.

• Use Transparency - Necessary to dis-
play transparent or semi-transparent sur-
faces such as the glass in windows in 
rendered views. 

• Software Edge Smoothing - A higher 
degree of surface edge smoothing can 
significantly improve the quality of a 3D 
view.

Lighting
In rendered views, lighting is calculated on a 
room-by-room basis; only the light sources 
in the room containing the camera are used. 

When the camera is outside a building, the 
program normally uses sunlight for lighting 
calculations and turns off all other light 
sources. You can turn the sunlight off and use 
all the other exterior lights to simulate night 
time views.

The maximum number of light sources that 
can be turned on in a view at the same time is 
determined by your video card. If your video 
card’s maximum number of lights is eight, 
the program only uses the eight light sources 
closest to the camera’s position. You can 

manually turn on and off individual lights in 
order to get the desired lighting effects. See 
“Displaying Lights” on page 703.

Each individual light source has a set of 
Rendering properties, such as intensity and 
color, that can be defined. See “Light Data 
Tab” on page 706. 

Ambient Light
Ambient light is used to simulate the way 
light “bounces” around a scene and 
approximates this by ensuring that all objects 
are at least as bright as the specified ambient 
value, which is set in the 3DView Defaults 
dialog. See “Options Tab” on page 669. 
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Ambient light is in addition to other light 
sources in a room or scene. Too much 
ambient light can give a rendered view a flat 
look. 
• Interior Ambient controls the ambient 

light in interior rendered views of the 
model.

• Daytime Ambient controls the ambient 
light in exterior rendered views of the 

model when Toggle Sunlight  is on. 
See “Sun Angles” on page 701.

• Nighttime Ambient controls the ambient 
light in exterior rendered views of the 

model when Toggle Sunlight  is off.

In addition to the ambient lighting specified 
in the 3D View Defaults dialog, there are 
four ways to create light sources for rendered 
views:
• Default Lights
• Light Fixtures
• Added Lights
• Sunlight

Default Lights
If you create an interior rendered view of a 
room and no lights have been placed there, 
the program creates a Default Light source 
within that room. The Default interior light 
acts like a central point light source. 

By default, a parallel light source is also 
added to interior views which shines straight 
up to add extra illumination to ceilings. The 
intensity of this light is adjusted with the 
Interior Ambient intensity, and it can be 
turned off entirely in the 3D View Defaults 
dialog. 

The Default Light cannot be adjusted in any 
way. If you want to control the light in an 
interior rendered view, you must add a light 
to the room that you are rendering by placing 
a lighting fixture or by adding a light source 

using 3D> Lighting> Add Lights . 

Light Fixtures
An electric symbol that represents a Light 
Fixture can have one or more light sources 
associated with it. Properties for each light 
source such as light type, color and intensity 
can be modified in the fixture’s Electrical 
Service Specification. See “Electrical 
Service Specification Dialog” on page 492.  

If the light source is a Point or Spot Light, 
you can also adjust the Offsets to specify the 
light source’s position relative to the fixture. 
By using Show Position in Camera View, 
you can tell where in the scene your light is 
located.

Lighting looks most realistic if it is offset 
from a surface.

Added Lights
In floor plan view, select 3D> Light-
ing> Add Lights to quickly add a 

light source to a plan. Added Lights and their 
labels are placed on the “Light Sources” and 
“Light Sources, Labels” layers. 

Added lights only act as light sources in plan 
files that have at least one room defined. 
They display 2D symbols in floor plan view 
but do not display as objects in 3D views. 

While Added Lights do not display as objects 
in 3D, you can specify that an Added Light’s 
position be represented by a cross hairs in 
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rendered views that use lighting. See “Light 
Data Tab” on page 493.

Added lights can be placed into objects that 
normally do not generate light, such as a TV.

There are three types of added light sources:
• Parallel Light sources
• Point Light sources
• Spot Light sources

See “Light Types” on page 705.

Sun Angles
Sun Angle arrows display in floor 
plan view and indicate the angle of the 

sun at a specific time and location on the 
Earth at sea level. Sun Angles control the 
position of the sun in 3D views and can also 
produce sun shadows in floor plan view. 

Multiple Sun Angles can be created in floor 
plan view, each with different specifications. 
For best results, only turn one Sun Angle on 
at a time. See “Sun Angle Specification 
Dialog” on page 708. 

Sun Angles can display their date and time in 
floor plan view. Both Sun Angles and their 

shadows are on the “Sun Angles & Shad-
ows” layer. 

Sun Angles are also Parallel Lights. When an 
exterior 3D view is rendered, the program 
looks for any Sun Angles that are turned on. 
If it finds none, the Default Sun is used. 

To accurately define the Sun’s location 
relative to the model, use a North 

Pointer . See “North Pointer” on page 
778.

To create a Sun Angle

1. Make the first floor or foundation level 
the current floor. Sun Angles can only be 
created on these floor levels.

2. In floor plan view, select CAD> Lines> 

Sun Angle  and click in the d rawing 
area where the Sun Angle arrow should 
display. 

3. In the Sun Angle Specification dialog, 
specify the Sun Angle’s Earth Data and 
other information. See “Sun Angle 
Specification Dialog” on page 708.

4. After it is created, a Sun Angle can be 
moved to a different location in floor 
plan view. Shadows are not affected.

A Sun Angle’s position is specified by Lati-
tude and Longitude. The following table lists 
a sample of latitude and longitude values for 
some cities:

Note: Sun Angle calculations do not adjust for
elevation. They are based on formulas pub-
lished by the United States Naval Observa-
tory and have limited accuracy as
documented by the USNO. 
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Default Sun Light
If you create an exterior rendered view and 
no Sun Angle exists, the program creates a 
Default Sun. The Default Sun acts like a 
parallel light source but its location is not 
based on any real world locations. 

The Default Sun can be opened for 
specification in a rendered view by selecting 

3D> Lighting> Adjust Lights . See 
“Default Sun Light Specification Dialog” on 
page 707.

If you place a Sun Angle  in floor plan 
view, the Default Sun is no longer used as a 
light source in exterior rendered views unless 
the Sun Angle’s light is turned off. 

Sun Shadows

Sun Angles  allow the shadow cast by a 
building at any time of the year to be dis-
played in floor plan and rendered views. 

.

To display shadows created by a Sun Angle 

1. On the Render panel of the Preferences 
dialog, check Show Shadows for Pre-
view and/or Final View. See “Render 
Panel” on page 86.

2. Select a Sun Angle and click the Open 

Object  edit button.
3. On the Render Data tab of the Sun 

Angle Specification dialog, make sure 
that Casts Shadows is checked.

4. To display the shadow in floor plan 
view, click the Make Shadow button on 
the Earth Data tab.

Multiple Sun Angles can be placed in the 
same plan to allow the simultaneous display 
of shadows cast at different times in floor 
plan view. 

Specify different line colors and/or
styles for shadows cast by multiple Sun

Angles in the Sun Angle Specification dialog.
See “Earth Data Tab” on page 708.

Sun angle for:

March 1, 2007

12 p.m. (noon)

Coeur d’Alene, ID
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If no Terrain Perimeter has been created, 
shadows fall on an imaginary plane at height 
zero, the default height for the first floor. If a 
Terrain Perimeter exists, shadows are modi-
fied to indicate where the real shadow would 
fall on the actual terrain.
There are several ways to delete the shadow 
created by a Sun Angle. 
• In floor plan view, select and delete the 

defining polyline.

• In floor plan view, select and delete the 
Sun Angle arrow. 

• In the Sun Angle Specification dialog, 
click the Delete Shadow button. See 
“Earth Data Tab” on page 708.

• In the Sun Angle Specification dialog, 
click the Make Shadow button to delete 
the existing shadow and create a new 
one. 

Displaying Lights
The display of light fixtures and 
Added Lights in floor plan and 3D 

views is controlled in the Layer Display 
Options dialog. See “Layer Display Options 
Dialog” on page 104.

In addition, they can serve as sources of light 
in rendered 3D views. They can be turned on 
and off, as well as set to cast shadows.

In Floor Plan View
Light fixtures are placed on the “Electrical” 
layer, and Added Lights, on the “Light 
Sources” layer. See “Displaying Objects” on 
page 102. 

In floor plan view, both light fixtures and 
Added Lights can display labels when the 
“Electrical, Labels” and/or “Light Sources, 
Labels” layers are is turned on. See “Object 
Labels” on page 884. 

An Added Light’s label in floor plan view 
indicates which of these attributes the light 
has: 
• R - Used in Standard rendered views.
• S - Casts shadows.

• No letters - Light is not turned on.

In 3D Views
Both light fixtures and Added Lights can 
serve as sources of light in rendered views.

To turn a light on or off

There are several ways to turn a light fixture 
or Added Light on or off: 
• Select one or more fixtures or Added 

Lights and click the Turn Light(s) Off in 

3D  or Turn Light(s) On in 3D  
edit button. 

• Uncheck On in the object’s specification 
dialog. See “Light Data Tab” on page 
493. 

A Point Light that casts shadows in 
Standard rendered  views
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• Clear the On/Off checkbox in the Adjust 
LIghts dialog.

Added Lights are not associated with a 3D 
fixture, but you can specify that an Added 

Light’s location be represented in rendered 
3D views using a cross hairs. See “Light 
Data Tab” on page 493.

Adjust Lights Dialog
Light sources in the current plan can 
be accessed and edited using the 

Adjust Lights dialog. Select 3D> Lighting> 

Adjust Lights to open this dialog in floor 
plan or any 3D view.

The names of all lights, as displayed in their 
labels, in the current plan are listed here. 
Additional information about the light 
follows in parentheses. If the dialog is 
opened while a 3D view is active, the Default 
Sun Light will be included in the list; 
however, interior default lights are not listed 
and cannot be altered.  See “Default Sun 
Light” on page 702. 

Check the box beside a light’s name to turn it 
on or uncheck the box to turn it off. 

To adjust the properties a light in the list, 
select it and click the Adjust button. 

Multiple lights can be selected by holding 
down the Shift key. Make changes to the 
light in its specification dialog and click OK. 
For more information, see “Default Sun 
Light Specification Dialog” on page 707, 
“Light Specification Dialog” on page 706 or 
“Electrical Service Specification Dialog” on 
page 492.

Select another light to adjust or click Done. 

If you are in a 3D view that displays lighting, 
the view will regenerate based on the new 
light settings.
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Light Types
There are three types of light source, each of 
which generates light in a different way and 
allows you to create a variety of lighting 
effects: 
• Parallel Light sources
• Point Light sources
• Spot Light sources 

Both the properties and the light type of an 
Added Light can be modified in the Light 
Specification dialog. See “Light 
Specification Dialog” on page 706.

Parallel, Point and Spot lights can also be 
added to an electrical light fixture in the 
Electrical Service Specification dialog. See 
“Light Data Tab” on page 493.

Parallel Lights
A Parallel Light has a direction but 
no position. The light appears to 

illuminate all objects with equal intensity, as 
if it were at an infinite distance from the 
object. A Parallel Light source is commonly 
used to simulate distant light sources, such as 
the sun and works best when placed on the 
exterior of a structure.

To add a Parallel Light

1. In floor plan view, select 3D> Lighting> 

Add Lights . 
2. Click and drag in floor plan view two or 

more plan feet (600 mm) in any direc-
tion. 

3. When you have dragged a sufficient dis-
tance, the light preview will change to a 
parallel light icon. 

4. When you release the mouse, a parallel 
light pointing in the direction that you 
dragged is created.

Point Lights
Like a bare light bulb, a Point Light 
radiates light equally in all directions 
from its origin. Point lights are a more 

realistic representation of non-directional 
electric lighting and should be used when 
realism is the deciding concern. 

If no user defined light exists, Home 
Designer Pro creates a Point Light source to 
represent a light within a room. Any light 
source, except a Sun Angle, can be changed 
into a Point Light. 

To create a Point Light source

1. In floor plan view, select 3D> Lighting> 

Add Lights .
2. Click in floor plan view. Do not drag the 

pointer when you click the screen, or 
you will create a spot or parallel light. 

Spot Lights
A Spot Light focuses the light in a 
specified direction. The location, 
tilt angle, direction and intensity of 

a Spot Light can be defined. You can also 
change a Spot Light’s direction by rotating 
the light in floor plan view. 
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To create a Spot Light source

1. In floor plan view, select 3D> Lighting> 

Add Lights . 
2. Click and drag in floor plan view no 

more than two plan feet (600 mm) in any 
direction. 

3. As you drag, the light preview will look 
like a Spot Light icon. If you drag too 
far, it will change to a Parallel Light 
icon.

4. When you release the mouse, a Spot 
Light pointing in the direction that you 
dragged is created.

Light Specification Dialog
Select one or more parallel, point or 
spot lights and click the Open Object 

edit button to open the Light Specification 
dialog. 

You can also select 3D> Lighting> Adjust 

Lights  to access a list of the light sources 
present in the current plan and open the 
specification dialog for any of them. See 
“Displaying Lights” on page 703. 

In addition, you can right-click on a light 
fixture in an unlocked library (see “Adding 
Library Content” on page 613) or click on it 
and select Library> Edit Light Data to 
open a version of the Light Specification 
dialog that is similar to the Electrical 
Service Specification dialog. See “Light 
Data Tab” on page 493.

Location Tab

Light Display - Specify where the selected 
Added Light displays in floor plan and 3D 
views.
• Select All Floors to display the selected 

light on all floors in floor plan view.
• Select Specify Floor Number to display 

the light on one floor only, then choose a 
floor number from the drop-down list. 

• Specify the selected light’s  Height. The 
Height of an Added Light is always rela-
tive to Floor 1. If you want an Added 
Light to illuminate a room on Floor 2, use 
a Height value that includes the total 
height of the first floor. A value of 0 
equals the floor elevation of Floor 1. See 
“Multiple Floors” on page 315.

Light Data Tab
The settings on this tab are also found on the 
same tab of the Electrical Service 
Specification dialog. See “Light Data Tab” 
on page 493.

Note: The floor or floors that an Added Light
displays on in floor plan view is totally inde-
pendent of where it displays in 3D.
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Depending on the type of light selected, the 
options available here may vary. 

Label Tab
Labels for Added Lights display in floor plan 
view when the “Light Sources, Labels” layer 

is turned on and use the Text Style assigned 
to that layer. See “Text Styles” on page 765.

For information about the settings on this 
tab, see “Label Tab” on page 885. 

Default Sun Light Specification Dialog
The Default Sun Light Specification dialog 
allows you to control the intensity, direction 
and color of the Default Sun light source. 

While in a 3D view, select 3D> Lighting> 

Adjust Lights . See “Adjust Lights 
Dialog” on page 704.

If there are no light fixtures or added lights in 
the plan, this dialog will open as soon as 
Adjust Lights  is selected. 

• Use the Intensity slider bar or text field 
to control how bright the default sun light 
appears in rendered views. 

An intensity of 0% is the same as turning 
the sun light off. An intensity of 100% is 
the maximum brightness allowed. 

• Click the Color bar to define the color of 
the light being modeled. Colored sun 
light may be used to achieve special 
lighting effects, but may alter the appear-
ance of your material colors and textures. 

• Specify the Tilt Angle, which is the angle 
of the sun light with respect to the hori-
zon. A value of 90° means that the light 
points straight up, while a value of -90° 
means that the light points straight down. 
0° is parallel to the horizon.

• Specify the Direction Angle, which is 
the direction that the sun light points 
toward. Zero degrees is measured hori-
zontally on screen, pointing to the right. 
Positive values rotate in a counter-clock-
wise direction from there, while negative 
values rotate clockwise. 

• Specify the Num Style button to specify 
the format used to enter angle values. See 
“Number Style/Angle Style Dialog” on 
page 89. 

The Default Sun light color is pure white, 
which has the least effect on the material 
colors and textures.
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Sun Angle Specification Dialog
Select CAD> Lines> Sun Angle, then 
click anywhere in floor plan view to 

open the Sun Angle Specification dialog 
and create a new sun angle. See “Sun 
Angles” on page 701.

You can also open the Sun Angle 
Specification dialog for an existing sun 
angle by selecting it and clicking the Open 

Object  edit button.

Earth Data Tab
The settings on the Earth Data tab let you 
establish exactly where on the planet your 
plan’s building site is located, and exactly 
when the sun’s light should be calculated. 

This information allows the program to gen-
erate sunlight and sun shadows with accu-
racy. 

Specify the Latitude, which is mea-
sured north or south of the equator. 
Specify the Longitude, which is mea-
sured east or west of the Greenwich 

meridian. 
Specify a Date for each Sun Angle you 
create. 

• Select a month from the first drop-down 
list, a day from the second, and a year 
from the third. 

Specify a Time for each Sun Angle you 
create.

• Select an hour from the first drop-down 
list; minutes in 15 minute increments can 
be selected from the second list.
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• If you want the Sun Angle to observe 
Daylight Savings Time, check this box.

Specify the Time Zone that the build-
ing site is located in.

The previous values default to the settings in 
the Preferences dialog. See “Sun Angle 
Panel” on page 75.

Solar Angles - The Altitude and 
Direction of the sun based on the infor-

mation provided above display here for refer-
ence. 
• The Altitude is the angle of the sun  

above the horizontal plane, in degrees. 
• The Direction is the angle between true 

North and the sun's direction. This is the 
angle the Sun Angle arrow points in floor 
plan view. See “North Pointer” on page 
778. 

Check Always Update to have the pro-
gram update the selected Sun Angle’s 

shadow whenever any of the defining infor-
mation is changed. 
• When checked, the program may be 

slower when changes are made in this 
dialog. 

• If this is not checked, click the Make 
Shadow button to generate a new shadow 
based on the new information.

 Check Show Date on Sun Angle to 
have the date and time display on the 

Sun Angle arrow in floor plan view.  This 

label uses the Text Style assigned to the “Sun 
Angle & Shadows” layer. See “Text Styles” 
on page 765.  

Check Auto Rebuild Terrain to 
rebuild the terrain automatically 

whenever you create a sun shadow. See 
“Building the Terrain” on page 552. 
If Auto Rebuild Terrain is unchecked and 
you regenerate sun shadows, the program 
will prompt you to rebuild the terrain.
When you use the Build Terrain command 
in floor plan view, all sun shadows in the 
plan are automatically updated.

Specify the Length of Plan Symbol, 
which is the length of the Sun Angle 

arrow in floor plan view.
Click the Make Shadow button to cre-
ate or regenerate the sun shadow in 

floor plan view. Sun shadows are polylines 
filled with a hatch pattern. Their shapes and 
sizes are based on the Sun Angle data speci-
fied in this dialog. 
No sun shadow generates if the sun is not 
above the horizon or if the sun is so low on 
the horizon that the shadow would be 
extremely long. 
Note that the Make Shadow option does not 
affect 3D views. To view sun shadows in a 

3D view, use Final View with Shadows . 
See “Previews vs Final Views” on page 698.

Click the Delete Shadow button to 
remove the sun shadow from floor plan 

view. 

Lighting Data Tab
A Sun Angle can be used as a light source in 
rendered views. The settings on the Lighting 
Data tab control attributes of the sunlight 

associated with the selected Sun Angle. 
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The settings defined on the Lighting Data tab 
are not related to how the shadow is dis-
played in floor plan view: they only affect 
rendered 3D views in which lighting and 
shadows can display.

Check On to specify the selected Sun 
Angle as a Parallel Light source. See 

“Parallel Lights” on page 705. 
If there is more than one defined Sun Angle, 
the renderer selects the first Sun Angle that is 
turned on. To make sure you are rendering 
the correct Sun Angle, make sure all others 
do not have this box checked.

Check Casts Shadows to have this 
light source cast shadows. These shad-

ows are similar to the shadow shown in floor 
plan view, but may render differently based 
on the presence of other light sources.

Use the Intensity slider bar or text field 
to define the relative strength of the 

light source. The time of day as set on the 
Earth Data tab does not affect how the Sun 
Angle renders as a light source, but this does.

Click the Color button to select a color 
for the sunlight associated with the 

selected Sun Angle. See “Color Chooser 
Dialog” on page 652. 

Line Style Tab
For information about the Line Style tab, see 
“Line Style Tab” on page 781.

Fill Style Tab
The settings on the Fill Style tab control the 
appearance of the selected Sun Angle’s 
shadow in floor plan view. For information 
about the settings on this tab, see “Fill Style 
Tab” on page 792.

Arrow Tab
For information about the settings on the 
Arrow tab, see “Arrow Tab” on page 783. 

Rendering Techniques
Any camera view, cross section/
elevation view, or overview can be 

generated using one of several rendering 
techniques to produce views for a range of 
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different purposes: from detail drawings to 
artistic presentation views. When a 3D view 
is active, select 3D> Rendering Techniques 
to access these tools. 

There are two ways to create a view using a 
particular rendering technique:
• Create a 3D view, then select the desired 

rendering technique from the menu. 
• Select the desired rendering technique in 

the Camera Defaults dialog, then create 
a 3D view. See “Camera Defaults Dia-
log” on page 665. 

Most of the Rendering Techniques have 
default settings that control their initial 
appearance. Once a view is created, these 
settings can be adjusted for that particular 
view in the Rendering Technique Options 
dialog. See “Rendering Technique 
Options” on page 713. 

If a camera view is saved, its Rendering 
Technique settings are saved, as well. See 
“Saving & Printing 3D Views” on page 690. 

Standard Rendering
Standard rendering is a photo-
realistic technique that represents 

materials using textures, models lighting, and 
can also display shadows. Surface edge lines 
are not drawn and no special colors or effects 
are applied. Lighting is limited to the room 
containing the camera and the capabilities of 
your video card. 

In floor plan view, the camera 
symbol for a view using the 
Standard technique displays an S 
in its center. See “Displaying 3D 

Views” on page 677.

Standard rendering requires a video card 
that supports OpenGL 2.0. 

Vector View
In Vector Views, surface edge lines 
are drawn and pattern lines and colors 

are used to represent materials. Textures and 
lighting are not used, and special colors and 
effects are not applied.  

In floor plan view, the camera 
symbol for a view using the 
Vector View technique displays a 
V in its center. 

Glass House
Glass House rendering uses different 
shades of a single color to display the 

The Watercolor technique requires
more time to generate than other Ren-

dering Techniques.  To save time, adjust the
camera’s perspective before using one of
these techniques. See “Editing 3D Views” on
page 684.
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model with surface edge lines and semi-
transparent surfaces. Lighting is not 
modeled, and materials are not represented, 
so neither pattern lines nor textures are used. 

In floor plan view, the camera 
symbol for a view using the Glass 
House technique displays a G in 
its center. 

Technical Illustration
Technical Illustration rendering 
draws surface edge and pattern lines, 

and uses shades of two colors, Warm and 
Cool. The warm shade is applied to surfaces 
that face the light source in the view, and the 
cool shade,to surfaces that face away from it.

Only one light source is used: the light with 
the hightest Intensity found in the room 
containing the camera. In exterior views, this 
light is always the Default Sun Light. 
Lighting is modeled as non-photorealistic, 
stylized highlights. 

In floor plan view, the camera 
symbol for a view using the 
Technical Illustration technique 
displays a T in its center. 

Technical Illustration requires a video card 
that supports OpenGL 2.0. 

Watercolor
Watercolor rendering uses textures to 
represent materials and models 

lighting, but approximates the effects of 
watercolor painting such as pigment pooling 
and flow. 

In floor plan view, the camera 
symbol for a view using the 
Watercolor technique displays a 
W in its center. 

Watercolor requires a video card that 
supports OpenGL 1.5. 

Note: In some plans, the Watercolor tech-
niques may take a considerable amount of
time. You can press the Esc key to cancel the
rendering.
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Rendering Technique Options
The settings in the Rendering 
Technique Options dialog allow you 

to control the specific effects of each 
rendering technique on an active 3D view. To 
access this dialog, create a camera view, 
cross section/elevation view, or overview and 
select 3D> Rendering Techniques> 
Technique Options.

The Rendering Technique Options dialog 
can also be accessed by double-clicking the 

Rendering Techniques  parent button. 

The settings in the Rendering Technique 
Defaults dialog are the same as those in the 
this dialog, but control the initial settings of 
each technique when it is first applied. 

In the Rendering Technique Options 
dialog, select a technique from the list on the 

left to make its options active on the right. 
When this dialog is first opened, the 
technique currently used by the view is 
selected. If the view is new, the settings are 
based on those in the Rendering Technique 
Defaults dialog. 

As changes are made in the Rendering 
Technique Options dialog, the 3D view 
behind the dialog box automatically updates 
to reflect those changes for all techniques 
except Watercolor. To update views using 
these techniques, which take more time to 
draw than the others, click the Update button 
in the dialog. 

When a 3D view is saved, its Rendering 
Technique Options settings are saved, as 
well. See “Saving 3D Views” on page 690.

Standard Rendering
 There are no Rendering Technique 
Options for Standard rendering; 

however, you can specify the ambient 
lighting for rendered views in the 3D View 

Defaults dialog. See “3D View Defaults 
Dialog” on page 668. 

There are a variety of other tools that affect 
the appearance of standard rendered views. 
See “Displaying 3D Views” on page 677. 

Vector View
There are no Rendering Technique 
Options for Vector View rendering; 

however, a variety of settings that affect the 
appearance of Vector Views an be set in the 

3D View Defaults dialog. See “3D View 
Defaults Dialog” on page 668. 

There are a variety of other tools that affect 
the appearance of Vector Views. See 
“Displaying 3D Views” on page 677. 
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Glass House
The active 3D view immediately 
updates to reflect any changes made to 

the Rendering Technique Options settings for 
Glass House renderings. 

• Click the Color bar to select a color for 
the semi-transparent surfaces and lines in 
a Glass House view. See “Color Chooser 
Dialog” on page 652. 

• Specify the Transparency of the surfaces 
in Glass House view. For example, to cre-
ate a wireframe line drawing of your 
structure, turn transparency to full and 
minimize line thickness.

• Specify the Line Thickness of surface 
lines in Glass House view. 

• Click Reset to Defaults to apply the 
Glass House settings defined in the 
Rendering Technique Defaults dialog. 
If clicked in the defaults dialog, the origi-
nally installed settings are restored. 

• In the Rendering Technique Defaults 
dialog, the Restore Initial Settings but-
ton is available instead. Click this to reset 
the options on this panel to the originally 
installed settings.

Technical Illustration
The active 3D view immediately 
updates to reflect any changes made to 

the Rendering Technique Options settings for 
Technical Illustration renderings. 
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• Click the Color bar to select a Warm 
Color for surfaces that face the light 
source and a Cool Color for surfaces that 
face away from the light. See “Color 
Chooser Dialog” on page 652. 

• Specify the Warm Blend, which is the 
degree to which the selected Warm Color 
is blended with original colors on well-lit 
surfaces in the view. 

• Specify the Cool Blend, which is the 
degree to which the selected Cool Color 
is blended with original colors on shaded 
surfaces in the view. 

• Specify the Line Thickness of all surface 
edge and pattern lines in the view.

• Click Reset to Defaults to apply the 
Technical Illustration settings defined in 
the Rendering Technique Defaults dia-
log.. 

• In the Rendering Technique Defaults 
dialog, the Restore Initial Settings but-
ton is available instead. Click this to reset 
the options on this panel to the originally 
installed settings.

Watercolor
In order for the active 3D view to 
reflect changes made to the Rendering 

Technique Options settings for Watercolor 

renderings, you must click the Update View 
button in the dialog. 

• Specify the Smooth Amount, which is 
the degree to which details are removed 
from the original view.

• Specify the Paint Contrast, which deter-
mines the extent to which variations in 
pigment color are used. 

• Specify the Turbulence Strength, which  
produces “pooling”, or variations in the 
strength of pigment colors.

• Specify the Turbulence Scale, which 
controls the size of the areas of pooling.

• Specify the Pigment Settling Strength, 
which is creates the appearance of pig-
ment settling into low areas in paper.

• Specify the Edge Strength, which is how 
well-defined surface edge lines are.
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• Click Reset to Defaults to apply the 
Watercolor settings defined in the Ren-
dering Technique Defaults dialog.. 

• In the Rendering Technique Defaults 
dialog, the Restore Initial Settings but-
ton is available instead. Click this to reset 
the options on this panel to the originally 
installed settings.

• Click Update View to apply any changes 
made to these settings to the active 3D 
view. 

• Click OK to close the dialog and redraw 
the active 3D view based on these set-
tings. Depending on your plan, this may 
take several moments.

Speeding up 3D View Generation
Depending on the speed of your processor, 
how many cores your processor has, and 
your computer’s video memory, a 3D view 
may generate in a few seconds or less. 

When you have a large, complex model with 
a lot of detail, many objects, extensive 
terrain, or patterns composed of many lines, 
it may take a few minutes to generate a 3D 
view of everything in the model. During this 
process, progress information may display in 
the Status Bar and in a message window. 

There are several ways to speed up the 
generation time of views.

Turn Off Layers
The display of objects in 3D views 
can be turned on or off by layer in the 

Layer Display Options dialog. Turning off 
the display of unneeded objects in 3D views 
can speed up 3D view generation time. See 
“Layer Display Options Dialog” on page 
104. 

Halt Generation with Esc Key
Using the Esc key, you can interrupt the 
modeling process at any point and display 
the incomplete model “as is.” This is 
particularly helpful when you just need to 
reorient a model on the screen for a specific 
angle or view.

The Esc option allows you to place the view 
quickly, then press the F5 function key to 
refresh the display with all 3D faces intact. 

Faster Rendering
To increase rendering speed, consider turning 
off some or all of the following options in the 
Preferences dialog. Bear in mind that render 
quality may be affected. See “Render Panel” 
on page 86.

Use Optimizations - Many video cards with 
OpenGL are capable of optimizing 3D views 
for subsequent redraws. Use of this option 
varies from video card to video card. 

In general, you should leave this option 
turned on unless you are experiencing 
crashes when rendering.

Show Shadows - This option has the greatest 
impact on rendering speed and should only 

You can turn on "Show Screen Redraw
Time" in the Preferences dialog to see

how your changes affect 3D view generation
time. See “Appearance Panel” on page 61.
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be used for Final Views, unless you have an 
extremely fast OpenGL-accelerated video 
card.

When rendering shadows, a percentage 
complete value may display in the Status Bar.

In general, you should make sure you are 
only using a minimum number of lights to 
cast shadows.

Soft Shadows - Only used when Show 
Shadows is turned on, this significantly 
slows down the rendering speed. To save 
time, only use this option for Final Views.

Surface Backdrop - For some OpenGL-
accelerated video cards, this option 
drastically increases rendering speeds. When 
turned on, this option creates surfaces that 
the backdrop is drawn on. When this option 
is turned off, the backdrop is send directly to 
the video card. For most modern video cards, 
Off is the recommended setting.

Software Edge Smoothing - Only use this 
option for Final Views, as this slows down 
even the fastest video cards.

Use Textures - Some older video cards slow 
down significantly using textures. If you find 
that you need to uncheck this box often, you 
may want to upgrade your video card.

Use Triangles - This improves the quality of 
lighting effects on larger surfaces in certain 
views. Triangles are not used in the Standard, 
Technical Illustration, or Vector View 
Rendering Techniques.

View Panel Factors
Vector Views are drawn using an 
adaptive method that saves time by 

dividing the screen into horizontal and 
vertical panels. 

The Options tab of the 3D View Defaults 
dialog has two tuning factors that allow you 
to adjust the way the adaptive method works. 
See “Options Tab” on page 669.

Higher Quality Rendering
There are a number of settings you can use to 
improve the quality of your renderings. 
Some can affect rendering times, so you may 
want to consider optimizing them for your 
needs in Final Views only. See “Previews vs 
Final Views” on page 698. 

Hardware Texture Filtering - Improves the 
appearance of textures, particularly on 
surfaces angled away from the camera. Not 
supported by some video cards. 

Use Triangles - When you have lights in 
your scene, triangles are used to make those 
lights appear to illuminate objects properly. 
Generally speaking the smaller you set your 
Triangle Size, the slower the render, but the 
higher-quality result you can achieve.

Use Transparency - Necessary to display 
transparent or semi-transparent surfaces in a 
rendered view. 

Software Edge Smoothing - Though slow, 
this can significantly improve the quality of 
3D views. 
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Chapter 30:

Dimensions

Home Designer Pro provides a variety of 
dimensioning tools for measuring walls, 
doors, windows, and many other objects in 
various 2D and 3D views. 

Dimensions can be used to accurately 
position objects relative to other objects. In 
addition, dimension lines and extensions can 
be selected and customized. 

Chapter Contents
•      Compatibility With Previous Versions
•      Dimension Preferences and Defaults
•      Dimension Defaults Dialog
•      Auto Dimension Defaults Dialogs
•      The Dimension Tools
•      Displaying Dimension Lines
•      Editing Dimension Lines
•      Editing Extension Lines
•      Moving Objects Using Dimensions
•      Dimension Line Specification Dialog

Compatibility With Previous Versions
Dimensions function differently in versions 
6.0 and later of Home Designer Pro than they 
did in their predecessor, Chief Architect 

Home Edition 5.0. Being familiar with these 
changes is necessary if you plan to open 
plans from earlier versions.

Dimension Preferences and Defaults
There are a number of settings in the 
Preferences dialog that affect dimensions, 
as well as several dimension defaults dialogs. 

Preferences
All plan and layout files save 
measurements in either Imperial or 

metric units. The type of unit used is 



720

Home Designer Pro 2014 Reference Manual

determined when the file is first created and 
cannot be changed later. See “Creating a 
New Plan or Layout” on page 42.

You can specify either metric or Imperial 
files to be used as the templates whenever 
you open a new, blank plan or layout file in 
the Preferences dialog. See “New Plans 
Panel” on page 71. 

You can also specify the minimum on-screen 
display size for dimension numbers in the 
Preferences dialog. See “Appearance 
Panel” on page 61. 

Default Settings
Select Edit> Default Settings or 

double-click the Dimension Tools  

parent button or any of its child buttons (with 

the exception of the Auto Exterior  and 

Auto Interior Dimensions  tools). There 
are three dimension defaults dialogs:
• Dimension Defaults Dialog 
• Two Auto Dimension Defaults Dialogs 

When Angle Snaps  are enabled, 
dimensions can be drawn at the Allowed 
Angles set in the General Plan Defaults 
dialog. Regardless of their angles, however, 
dimensions will only locate objects that are 
parallel to one another. See “General Plan 
Defaults Dialog” on page 58. 

Dimension Defaults Dialog
Select Edit> Default Settings, 
expand the “Dimension” category, 

select “Dimensions”, and click the Edit 
button to open the Dimension Defaults 
dialog. 

You can also double-click the Dimension 

Tools  parent button to open the this 
dialog.

The settings in this dialog are dynamic 
defaults, which means that any changes 
made here may affect existing dimension 
lines in the drawing that are using default 
values. See “Dynamic Defaults” on page 57. 
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Setup Tab

General - 

• Baseline Separation - Specify the dis-
tance between Baseline Dimension lines 
in plan inches (mm). This value should 
always be greater than the font size. If 
two formats are used, it should be at least 
twice the font size. 

• Specify how far manually drawn dimen-
sion lines Reach to locate walls and/or 
objects specified on the Locate Objects 
Tab. The default is 24” (450 mm) in plan 
files and 1” (10 mm) in layout.

Specify the initial spacing of 
Automatic Dimensions: specifically, 

Auto Exterior and Auto Interior Dimensions.
• Specify the Line Separation, which is 

the distance between Auto Exterior 
Dimension lines in plan inches (mm). 
This value should always be greater than 

the font size. If two formats are used, it 
should be at least twice the font size. 

• Specify the 1st Line Offset, which is the 
distance between each wall and the near-
est Automatic Dimension line that mea-
sures its length in plan inches (mm). 

Specify the use and appearance of 
Rounded Value Indicators, which can 

display when the degree of accuracy in use is 
not sufficient to describe a dimension’s true 
value. 
• Check + or - After Number to indicate 

that the actual dimension value is higher 
or lower than the value shown.

• Check ~ Before Number to indicate 
dimension values that are not accurate 
with the ~ symbol.

Rounding Method - Specify how the 
sections of dimension lines that locate 

more than two objects are rounded. 

1

2

3

4

1

2

3

4
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• Grid Rounding ensures that the sum of 
the parts of a dimension line add up to the 
whole distance. To produce this result, 
some sections may not be rounded accu-
rately. This is the recommended rounding 
method and is selected by default.

• Distance Rounding addresses each sec-
tion of a dimension line individually, 

which could result in the sum of these 
sections not being equal to the whole. 

Format Tab
The settings on the Format tab allow you to 
specify the units, degree of accuracy and 
position of dimension numbers. 

These settings are the same as those on the 
Format tab of the Dimension Line 
Specification dialog and the Dimension 
Format tab of the Room Label Defaults 

dialog. See “Dimension Line Specification 
Dialog” on page 739 and “Room Label 
Defaults” on page 230. 

The settings on this tab also control the 
format of numbers indicating object length in 
the Status Bar. See “The Status Bar” on page 
31. 

Specify the numbering Format for 
dimension numbers. 

• Select the Units of measurement to be 
used by dimensions from the drop-down 

list. The choices in this list correspond to 
all units measuring length specified in the 
Preferences dialog. See “Unit Conver-
sions Panel” on page 71.

You can avoid the appearance of inac-
curacy that rounding may cause by

placing the objects in your plan precisely and
by drawing with Grid Snaps enabled. See
“Grid Snaps” on page 112.  

1

2

3

1
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• Check Unit Indicators to display the unit 
of measurement along with the dimen-
sion number.

• Check Leading Zeros to include the zero 
before a decimal less than 1 or to display  
0’ or 0” when the ft-in or ’-” unit formats 
is used. 

• Check Trailing Zeros to display trailing 
zeros at the end of decimal values. When  
the ft-in or ’-” unit formats is used and 
fractional inches are specified, 0” will be 
included. 

Specify the Location of dimension 
numbers relative to the dimension line. 

• Center primary dimension numbers on 
the dimension line. If two formats are 
used, the primary format is placed above 
the line and the secondary format, 
beneath it. 

• Position dimension numbers Above 
Line. 

• Position dimension numbers Below Line. 

Specify the degree of Accuracy used 
by dimension numbers. 

• Select the Decimal Places radio button 
for dimension numbers in decimal for-
mat.  In the text field, specify the number 
of decimal places to use, from 0 to 20. If 
0 is used, no decimal places are used.

• Select the Smallest Fraction radio but-
ton for dimension numbers using whole 
numbers and fractions.  In the text field, 
specify the largest denominator to use, 
from 1 to 128. If 1 is entered, whole num-
bers are used. 

Locate Objects Tab
The settings on the Locate Objects tab 
specify whether or not dimension lines locate 
specific types of objects. Changes made on 
this tab only affect new dimension lines, not 
those already drawn.

These settings affect dimension lines as they 
are drawn. Once created, their extension 
lines can be edited so that they locate objects 
in ways not specified here.

The Locate Objects tab is also found in the 
Auto Exterior Dimension Defaults dialog. 
See “Auto Dimension Defaults Dialogs” on 
page 727. 

In the Dimension Defaults dialog when 
opened in a layout file, only the CAD 
Objects settings on this tab will be available.

Note: Although you can select Imperial or
metric units in any plan or layout, it is best to
use the same unit type that the file uses to
save measurements. See “Units of Measure-
ment” on page 42. .

2

3
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The Walls options affect Manual and 
Interior Dimensions and are also 

available in the Auto Exterior Dimension 
Defaults dialog. See “The Dimension Tools” 
on page 728 and “Auto Dimension Defaults 
Dialogs” on page 727. 

The first two settings also determine the 
marked location in wall assemblies referred 
to by Extension Lines as well as the Reach 
and 1st Line Offset settings. See “The 
Dimension Layer” on page 210. 
• Select Surfaces to locate exterior walls 

by outer surface and interior walls by one 
of their surfaces.

• Select Wall Dimension Layer to locate 
walls at the Dimension Layer. A wall’s 
Dimension Layer is specified in its wall 
type. See “Wall Type Definitions Dialog” 
on page 211. 

The next four settings control how 
dimensions locate interior walls where they 

intersect exterior walls, and only apply to 
interior walls drawn perpendicular to the 
exterior walls they intersect. 
• Select Interior Wall Centers to have 

dimension lines locate the centers of inte-
rior walls. If Wall Dimension Layer is 
selected above, dimensions locate interior 
walls at the center of their Main Layers. 
See “The Main Layer” on page 209. 

• Select Primary Wall Side to have 
dimension lines locate one side of interior 
walls. 

• Select Both Wall Sides to have dimen-
sion lines locate both surfaces of interior 
and exterior walls. Wall thicknesses are 
also dimensioned. 

• Check Interior Walls Only for dimen-
sions to ignore the interior surface of 
exterior walls and the thicknesses of inte-
rior walls. Only available when Both 
Wall Surfaces is selected. 

4

5
2
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The Cabinets options affect how 
dimension lines locate objects cabinets 

and cabinet fillers.
• Check Sides to locate the sides of cabinet 

objects. The sides must be perpendicular 
to the dimension line.

• Check Corners to locate the corners of 
all cabinet objects within the Reach area. 
Angled cabinets are dimensioned to their 
corners at a right angle to the dimension 
line. A cabinet’s front or sides do not 
need to be perpendicular or parallel to the 
dimension line for its corners to be 
located. 

• Check to locate the Centers of all cabinet 
objects within the Reach area. A cabi-
net’s front or sides do not need to be per-
pendicular or parallel to the dimension 
line for its center to be located. 

The Fixtures/Appliances options 
affect how dimension lines locate 

appliances and other fixtures. 
• Check to locate the Sides/Corners of 

appliances and other fixtures. For sides to 
be located, they must be perpendicular to 
the dimension line. 

• Check to locate the Centers of all fix-
tures within the Reach area. An object’s 
front or sides do not need to be perpen-
dicular or parallel to the dimension line 
for its center to be located. 

The Furniture options control how 
furnishings are located by dimension 

lines.

• Check to locate the Sides/Corners of fur-
nishings. For sides to be located, they 
must be perpendicular to the dimension 
line.

• Check to locate the Centers of all fur-
nishings within the Reach area. An 
object’s front or sides do not need to be 
perpendicular or parallel to the dimension 
line for its center to be located. 

The Openings options control how 
wall openings are located by dimension 

lines and are also available in the Auto 
Exterior Dimension Defaults dialog.
• Select Centers for dimensions to locate 

the centers of wall openings.
• Select Sides to locate both sides of wall 

openings. This option locates the nominal 
width - not the rough opening.

• Select Casing to locate both sides of wall 
openings at the outer edges of the casing. 
Because interior and exterior casing often 
has different widths, an opening may 
have different interior and exterior 
dimensions when this option is selected.

• Select Rough Opening to locate both 
sides of windows and doors at the rough 
opening. 

• Select None for dimensions to not locate 
wall openings. This setting does not 
affect Auto Exterior Dimensions. 

Note: Walls specified as No Locate will not be
located by some dimension tools. See “No
Locate” on page 196. 

2

3

4

Note: In cross section/elevation views,
dimensions can only locate furniture at points
where a surface is present. 

Note: Openings in walls specified as No
Locate will not be located by Auto Exterior
Dimensions. See “No Locate” on page 196. 

5
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The CAD Objects options control how 
dimension lines locate 2D CAD objects 

as well as CAD-based objects such as slabs 
and polyline solids, and stairs. . 
• Check Line/Sides to locate lines and 

edges that are perpendicular to the 
dimension line. If the lines or edges are 
not perpendicular to the dimension line, 
they are not dimensioned. 

• Check Ends/Corners to locate all ends 
of lines or corners of polylines, no matter 
what angle they are in relation to the 
dimension line.

• Check Callouts/Markers to locate these 
objects.

• Check Text to locate text objects.

The Other Objects options affect how 
dimension lines locate additional object 

types.. 
• Check Electrical to locate electrical 

objects. Use this option when you want to 
precisely position electrical objects.

• Check Plants and Images to locate these 
objects.

• Check Framing to locate these objects.

Extensions Tab

Specify the length and spacing of 
Extension Lines relative to the marked 

location on an object. 
• Select Gap From Marked Object to 

specify the distance between the end of 
the extension line and the marked 
location in plan inches or mm. If the 
dimension line is moved, the extension 
line updates, and the size of this gap is 
maintained.

• Select Length Towards Marked Object 
to specify a fixed length for the portion of 
the extension line that extends from the 
dimension line toward the object it 
locates. If the dimension line is moved, 
this length remains the same but the size 
of the gap updates.

• Specify the Length Away From Marked 
Object, which is the length of the portion 
of the extension line that extends from 
the dimension line in the opposite 
direction of the object it locates. 

6
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• Check Proximity Fixed to specify a 
fixed distance between the marked object 
and the dimension line. You can only fix 
the proximity for a single extension line. 
See “Using Proximity Fixed” on page 
737.

• Distance to Marked Object - When 
Proximity Fixed is checked, you can 
specify the distance from the dimension 
line to the marked object using a positive 
value. 

           Gap From Marked Object 

       +  Length Toward Marked Object

       =  Distance to Marked Object

Proximity Fixed only affects dimension lines 
that locate an object using an extension line. 
When a dimension line arrowhead points 
directly to the object without using an 
extension line, this option has no effect. 

Auto Exterior Dimensions ignore Distance to 
Marked Object and use the default 1st Line 
Offset and Line Separation values. See 
“Setup Tab” on page 721.

Legacy Support - Specify how 
dimensions behave in files created in 

Chief Architect Version 8 or prior. See 
“Compatibility With Previous Versions” on 
page 719. 
• Check Chief Version 8 Compatible 

Extensions to make extensions function 
as they did in Chief Architect Version 8. 

• Check Short Extensions to have short, 
uniform-length extension lines  instead of 
extension lines that reach all the way to 
the objects they locate. 

Arrow Tab
For information about the Arrow tab, see 
“Arrow Tab” on page 783.

Text StyleTab
The settings on the Text Style tab control the 
size, font and other attributes of automatic, 
manually drawn, and temporary dimension 
line labels. See “Dimension Labels” on page 
732. 

For information about the settings on this 
tab, see “Text Style Tab” on page 766.

Temporary dimension labels always use the 
color assigned to their layer - not the color 
specified in the Dimension Defaults dialog. 

Auto Dimension Defaults Dialogs
Select Edit> Default Settings or 
double-click either the Automatic 

Dimension Tools  or Dimension 

Tools  parent button. Expand the 
Dimension category, select either of the 
“Auto” subcategories , and click the Edit 
button. 

Extension Line and Gap lengths are
measured from the marked location on

a wall. See “The Dimension Layer” on page
210. 

2

Note: If you select an extension line, Chief
Version 8 Compatible Extensions will be
turned off automatically.
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The settings in thetwo Auto Dimension 
Defaults dialogs allow you to control the 
initial appearance and behavior of 
dimensions created using either of theAuto 
Dimension tools.

You can also add buttons to your toolbars 
that you can click to quickly open either of 

these dialogs. See “To add a button to a 
toolbar” on page 94.

The default Line Separation and First Line 
Offset values for automatic dimensions are 
set in the Dimension Defaults dialog. See 
“Setup Tab” on page 721.

General Tab

• Specify how far Auto Exterior Dimen-
sion  lines Reach to locate objects set 
back from exterior walls. The default is 
192 inches (4800 mm). If exterior walls 
are set back further than this distance, 
additional dimension lines are produced 
to dimension the set-back walls. Only 
available in the Auto Exterior 
Dimension Defaults dialog.

• Specify the Minimum Area: the mini-
mum enclosed area needed for Auto 
Dimensions to generate.

• Check Overall Dimension to generate 
the overall dimensions of a plan when 
Auto Dimensions are created.

Locate Objects Tab
The settings on the Locate Objects tab are 
also found on the same tab of the Dimension 
Defaults dialog. The available options will 
vary in each defaults dialog, depending on 
the functionality of the tool. See “Locate 
Objects Tab” on page 723. 

The Dimension Tools
Select CAD> Dimensions to access 
the Dimension Tools. Manually drawn 

dimensions are created by clicking and 
dragging like other line-based objects and 
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can be drawn in floor plan view, cross 
section/elevation views, and on layout pages. 

With the exception of Angular 

Dimensions , dimension lines only locate 
objects that are parallel or nearly parallel to 
one another and should be drawn orthogonal, 
or at right angles, to the objects being 
located. 

Dimension lines locate objects using Object 

Snaps , although they do not need to be 
enabled in order to draw dimensions. See 
“Object Snaps” on page 110. Bear in mind, 
though, that Object Snaps must be enabled in 
order to:
• Locate parallel objects drawn at angles 

other than Allowed Angles. 
• Locate more than one object drawn in the 

same space, such as a CAD line drawn 
over a wall. 

The zoom factor of the current view affects 
whether objects drawn close together are 
dimensioned or not. If you try to dimension 
an array of objects but the dimension line 
locates only the first and last objects along its 

path, Zoom  in on the objects and try 
again. Similarly, if you want to dimension 
between two objects but the dimension 
locates unwanted objects between them, 

Zoom  out. See “Zoom Tools” on page 
654.

Once created, both manually drawn and 
automatically generated dimension lines can 
be selected and edited.  See “Editing 
Dimension Lines” on page 733. 

Manual Dimensions
To display the distance between two 
objects, select CAD> Dimensions> 

Manual Dimension and drag a dimension 
line near or through the objects. 

Manual Dimensions locate objects as 
specified on the Locate Objects tab and lying 
within the Reach distance specified in the 
Dimension Defaults dialog. See “Dimension 
Defaults Dialog” on page 720.

End-to-End Dimensions
Use the End-to-End Dimension tool 
to dimension between any two defined 

objects in floor plan view, cross section/
elevation views and on layout pages. 

Select CAD> Dimensions> End-to-End 

Dimension , then click and drag the 
dimension from the first object to the second 
object. The dimension line snaps to each 
object, ignoring any other objects located 
between either end.

End-to-End Dimensions locate objects as 
specified on the Locate Objects tab and lying 
within the Reach distance specified in the 
Dimension Defaults dialog. 

Angular Dimensions
The Angular Dimension tool 
measures the angle between any two 

straight edges, including lines, walls, the 
sides of boxes, the straight sides of polylines, 
cabinets, and soffits. Edges nested up to four 
levels deep within a CAD block can be 
dimensioned.



730

Home Designer Pro 2014 Reference Manual

To create an angular dimension, click on the 
first edge to be dimensioned, then drag an arc 
and release on the second edge. 

As with other dimension lines, Angular 
Dimensions adjust if one of the dimensioned 
objects is moved. Angular Dimensions can 
also be selected and moved using its edit 
handle. As it is moved, an Angular 
Dimension maintains the location of its arc 
center. 

Like other dimension lines, an Angular 
Dimension can be included in a CAD block. 
When the block is exploded, the Angular 
Dimension may become invalid and 
disappear when edited or changed. If this 
occurs, it can be redrawn.

Interior Dimensions
Draw Interior Dimension lines 
parallel to walls in floor plan view to 

create interior dimensions. 

The Interior Dimension  tool locates 
interior wall surfaces only. It does not 
dimension between layer surfaces in the 
same wall, and it does not locate walls unless 
it actually intersects them. 

Interior Dimensions  locate either wall 
surfaces or the Main Layer, depending on the 
settings in the Locate Objects tab of the 
Dimension Defaults dialog. See “Locate 
Objects Tab” on page 723.

Point to Point Dimensions
The Point to Point Dimension tool 
places Point Markers at the start end 

and points of a dimension line as it is drawn 

and dimensions between them. See 
“Markers” on page 762.

Point to Point Dimensions can be drawn in 
either of two ways:

• When the Default  edit behavior is 
active, a Point to Point Dimension places 
Point Markers at its start and end points, 
which it locates. Any objects along the 
dimension line’s length are ignored. See 
“Point Markers” on page 774.

• When the Alternate  edit behavior is 
active, a Point to Point Dimension locates 
objects along its length as well as objects 
or Point Markers at its start and end. See 
“Edit Behaviors” on page 120.

Point Markers can be selected and edited. 
See “Editing Markers” on page 764.

If the objects or point markers located by a 

Point to Point Dimension  line are 
moved, the dimension updates to reflect the 
change. 

Objects and Point Markers located by a 

Point to Point Dimension  line can be 
accurately relocated by specifying new 
dimension values. See “Moving Objects 
Using Dimensions” on page 737. 

Auto Exterior Dimensions
The Auto Exterior Dimension tool 
generates dimensions around a plan’s 

exterior in floor plan view. The dimension 
lines locate walls and openings as specified 
in the Dimension Defaults dialog. See 
“Locate Objects Tab” on page 723.
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Auto Exterior Dimension  locate objects 
as specified in the Auto Exterior Dimension 
Defaults dialog. See “Auto Dimension 
Defaults Dialogs” on page 727.

If you edit an Auto Exterior Dimension  
line, it will be converted to a manual 
dimension, so if Auto Exterior Dimensions 
are later regenerated, your changes will not 
be lost. 

There are a maximum of three rows of 
automatically generated dimensions per 
exterior wall direction. The innermost 
dimension line locates exterior walls, interior 
walls, and all openings in exterior walls. The 
second dimension line locates exterior and 
interior walls. The outermost dimension line 
is the overall exterior dimension.

Auto Interior Dimensions
The Auto Interior Dimensions tool 
can be used in floor plan view in 

either of two ways: 
• Select CAD> Dimensions> Auto Inte-

rior Dimensions  to generate interior 
dimensions measuring each wall on the 
current floor. 

• Select one or more rooms and click the 

Auto Interior Dimensions  edit tool 
to generate interior dimensions that mea-

sure each wall defining the selected 
room(s). 

Auto Interior Dimensions  lines are 
generated inside of the rooms they measure 
and locate walls, openings, and other objects 
as specified in the Auto Interior Dimension 
Defaults dialog. See “Locate Objects Tab” 
on page 723. 

Auto Interior Dimensions  do not 
recognize the No Locate setting for walls. If 
a wall is specified as No Locate, Auto 
Interior Dimensions will locate it anyway. 
See “No Locate” on page 196. 

Display Temporary 
Dimensions

Temporary Dimensions display when 
an object is selected and show the 

distance between the object’s selected edge 
and other objects. Select CAD> 
Dimensions> Display Temporary 
Dimensions to turn on or off the display of 
temporary dimensions. This toggle affects all 
views and is saved between launches of 
Home Designer Pro.

As with other dimension lines, Temporary 
Dimensions only locate objects that are 
parallel or nearly parallel to one another. 
They will also locate the endpoints of CAD 
lines and the corners of objects located past 
the end of the selected edge, within 4 feet 
(1200 mm) of the point where you click to 
select the object. 

A temporary dimension will not display 
when an object is selected if a manually 
drawn dimension line is already present that 
shows the same information. 

Auto Exterior Dimensions do not gener-
ate properly if there is a gap in the exte-

rior walls. For example, sometimes angled
walls may not connect properly. If automatic
dimensions do not generate, try Build> Wall>
Fix Wall Connections .
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Tape Measure
Use the Tape Measure tool to draw a 
temporary dimension line between 

any two points in the drawing area. The tool 
will place temporary markers at the start and 

end points of the dimension line. These 
points and the line both disappear when you 
release the mouse button. If Object Snaps 

 are enabled and an object is located by 
the temporary line, you can snap to it.

Displaying Dimension Lines
The display of dimension lines is 
controlled in the Layer Display 

Options dialog. See “Displaying Objects” on 
page 102. 

Dimension lines created by any of the 
dimension tools share the same components.
• Dimension Lines run parallel with the 

distance being measured.
• Extension Lines are perpendicular to 

dimension lines, indicating what they 
locate. If a dimension line locates more 
than two objects, extension lines divide 
the dimension line into segments. 

• Arrowheads display at the intersections 
of dimension and extension lines.

• Dimension Labels display at the mid-
point of dimension line segments and 
indicate the distance that each segment 
measures.

If a manual dimension line is on a layer that 
is turned off and you select an object located 
by that dimension line, it will display for 
reference using the Move color specified in 
the Preferences dialog. See “Colors Panel” 
on page 63. This will happen only if Display 

Temporary Dimensions  is turned on. 
See “Display Temporary Dimensions” on 
page 731.

Extension Lines
If a dimension line is offset from the objects 
it locates, extension lines can help clarify 
exactly what is being located. You can 
specify the default length of extension lines 
in the Dimension Defaults dialog. See 
“Extensions Tab” on page 726.

Once drawn, the appearance of extension 
lines can be edited. See “Editing Extension 
Lines” on page 735.

Dimension Labels
Manually drawn, automatic and temporary 
dimension labels use the Text Style specified 
in the Dimension Defaults dialog. Unlike 
many objects that use Text Styles, by default 
dimensions use a Text Style specified in the 
defaults dialog rather than the Text Style 
assigned to their layer. See “Text StyleTab” 
on page 727. 

Dimension 
Labels

Extension Line Labels

Arrowheads
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By default, dimension labels have a solid fill 
that is the same as the Background Color 
set in the Preferences dialog. You can 
instead specify that labels use a Text Style 
that has a transparent or other fill. 

You can also specify the minimum size of 
dimension numbers displaying on screen in 
the Preferences dialog. See “Appearance 
Panel” on page 61.

Labels can be centered on dimension lines or 
located either above or below them. See 
“Format Tab” on page 722.

Dimension labels have their own edit handle 
and can be moved when a dimension line is 
selected.

Dimension Arrowheads
You can specify the style, color and size of  
dimension arrows in the Dimension 
Defaults and Dimension Line Specification 
dialogs. See “Arrow Tab” on page 783. 

The arrow at the end of a dimension line will 
not display if it is close enough to to another 
dimension arrow that the two will overlap. A 
typical example of this is where two sections 
of an Interior Dimension locate two sides of 
an interior wall. 

Editing Dimension Lines
With the exception of Temporary 
Dimensions, dimension lines can be selected 
and edited using the mouse, the edit toolbar 
buttons, and the Dimension Line 
Specification dialog. See “Dimension Line 
Specification Dialog” on page 739.

If an Auto Exterior Dimension line is edited, 
it will no longer be considered an automatic 
dimension line and will not be deleted and 
replaced the next time the Auto Exterior 

Dimensions   tool is used. 

Dimension line numbers and extension lines 
can be individually selected, moved and 
deleted, and new extension lines can be 
added. See “Editing Extension Lines” on 
page 735.

Using the Mouse
When a dimension line is selected, its edit 
handles can be seen. There are four types of 
dimension line edit handles. More than one 
of some types display, depending on how 
many extension lines are present.

Like other text, dimension labels are
subject to scaling. For example, A font

size of 6” prints a 1/8” tall number at 1/4” = 1’
scale. A font size of 125 mm prints a 3 mm
tall number at 1 m = 50 m scale. See
“Printing Text and Dimensions” on page
851.
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• The Extension Line handles mark the 
location being dimensioned and are used 
to move or delete extension lines. See 
“Moving Extension Lines” on page 736.

• The Add Extension Line handle displays 
to the side of the Move handle and is used 
to add extension lines to the dimension 
line. Dimension lines do not extend 
unless an object can be located. See 
“Adding Extension Lines” on page 735.

• The small, square Move Dimension 
Label handle is located at the center of 
the selected label. Use this handle to 
move the dimension number for each 
dimension line section. The pointer 
changes to a  four-headed arrow  when 
moved over this handle.

• The Move handle is located where you 
clicked to select the dimension line and is 
used to move the entire dimension line, 
including any subsections, perpendicular 
to itself. Extension lines are resized as 
appropriate. The pointer changes to a 
two-headed arrow  when moved over 
this handle.

• The Rotate handle is located one plan 
foot past the end of the dimension line 
and is used to rotate the dimension line. 

Using the Edit Tools
Dimension lines can be repositioned, copied, 
and deleted using the edit toolbar buttons just 
like other objects in the program can. See 
“The Edit Toolbar” on page 29. 

Click the Edit Dimension Ends  edit 
button to edit the dimension line using edit 
handles similar to those on line based 
objects. See “Editing Line Based Objects” on 
page 127.

Edit Dimension Ends  is useful for 
locating a point on an object that it might not 
locate otherwise, such as the corner of a 
polyline.

Click the Edit Extensions  edit button to 
edit the lengths of the selected dimension’s 
extension lines. See “Editing Extension 
Lines” on page 735.

Dimension Number Size
The initial size of dimension numbers is 
specified in the Dimension Defaults dialog. 
See “Dimension Defaults Dialog” on page 
720. 

You can specify number height for individual 
dimension lines in the Dimension Line 
Specification dialog. See “Dimension Tab” 
on page 740.

As with text and other objects, dimension 
number size is subject to scaling when sent to 
layout or printed. See “Printing Text and 
Dimensions” on page 851. 

Rotate

Extension Line

Extension Line

Move Dimension 
Label

Move

Add Extension 
Line
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Copying and Pasting 
Dimension Lines

Dimension lines can be copied and pasted 
into any view type that supports dimensions. 
If a dimension line is copied independent of 
the objects it originally locates, the pasted 
dimension line will locate point markers.

Deleting Dimension Lines
There are several ways to delete dimension 
lines. 

You can select any manual or automatic 
dimension line or group of dimension lines, 
then press the Delete key or click the 

Delete  edit button. See “Deleting 
Objects” on page 171.

The Delete Objects dialog allows you to 
delete all manually drawn and/or automatic 
dimension lines at once. See “Delete Objects 
Dialog” on page 171.

Individual dimension line segments located 
between extension lines can also be deleted. 
If a segment is located between two other 
segments along the same dimension line, that 
dimension will be broken in two.

To delete a portion of a dimension line

1. Select any Dimension Tool aside from 
Angular or Auto Exterior Dimensions.

2. Click and drag a manual dimension line 
over the segment that you wish to 
remove, dragging from extension line to 
extension line.

Editing Extension Lines
Extension lines can be added, edited, and 
deleted using the mouse. Extension lines are 
also affected by settings in the Dimension 
Line Specification dialog. See “Extensions 
Tab” on page 741.

Adding Extension Lines

To add an extension line

1. Select the dimension line.
2. Click the diamond-shaped Add Exten-

sion Line edit handle which displays 
near the Move edit handle. The pointer 
changes to a two-headed arrow .

3. Drag the handle to the object that you 
want to locate with a new extension han-
dle. This example adds an extension line 
to the window edge. 

4. Release the mouse button to add an 
extension line.
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Moving Extension Lines
Extension lines can be moved to locate the 
centers, sides, or surfaces of most objects. In 
this example an extension line is moved from 
the windows edge to the center.

To move an extension line

1. Select the dimension line it is connected 
to, not the extension line itself.

2. Click the Extension Line edit handle. 
The pointer changes to a two-headed 
arrow .

3. Drag the handle to a new location. The 
extension line snaps to possible marks as 
the handle is moved.

4. Release the mouse button at the new 
location.

Resizing Extension Lines
You can resize extension lines in the 
Dimension Line Specification dialog or 
using their edit handles. See “Extensions 
Tab” on page 726. 

To resize an extension line

1. Select the extension line or select the 
dimension line and click the Edit 

Extensions  edit button to display 
two handles along the extension line. 

2. Click either handle, turning the pointer 
into a two-headed arrow .

3. Extend or contract the extension line and 
release the mouse.

Not all library symbols can be located
by a dimension line as it is drawn. Once

a dimension is drawn, however, you can
move or add an extension line to locate the
library object.
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Using Proximity Fixed
The Proximity Fixed option allows you to 
specify a fixed length for one extension line 
that will not change if the object the 
extension line locates is moved. 

To use Proximity Fixed

1. Select a dimension line that locates mul-
tiple independent objects and note the 
Extension Number of extension line that 
you would like to have a fixed length. 

2. Open the Dimension Line 
Specification dialog and go to the 
Extensions tab. See “Extensions Tab” on 
page 726.

•  Select the Extension Number that you  
noted in step 1 from the Selected 
Extension drop-down list. 

•  Check Proximity Fixed.
•  Specify the desired Distance to 

Marked Object, which is the distance 
from the selected dimension line to the 
object that the Selected Extension 
locates. This distance includes the Gap 
From Marked Object. 

•  Click OK.

To see how Proximity Fixed works, select the 
object that the extension line with Proximity 

Fixed specified and move it.  Notice that the 
dimension line moves in response and that all 
extension lines’ lengths adjust except for the 
one with Proximity Fixed. 

Deleting Extension Lines
When an extension line is deleted, the 
remaining dimensions update. If a dimension 
line hasonly two extension lines, they cannot 
be deleted.

To remove an extension line

1. Select the dimension line it is connected 
to, not the extension line itself.

2. Click the Extension Line edit handle. 

3. Drag it perpendicular to the direction of 
the arrows, away from any dimension-
able object, and release the button when 
the extension line disappears.

Moving Objects Using Dimensions
Most objects can be moved by changing an 
automatic, manual or temporary dimension 
value that locates it. This technique can be 
applied in nearly any situation where 
dimensions are present, including angular 
dimensions. See “Moving Objects” on page 
152.

In addition, some objects can be resized 
using dimensions. See “Resizing Objects” on 
page 157.

Your pointer indicates which dimensions can 
be used to relocate the selected object by 
changing to a pointing hand icon. 
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Another way to tell is to select an object and 
drag it in the desired direction. As you drag, 
note which dimensions update. These 
dimensions are the dimensions that can be 
used to move that object. 

To move an object using dimensions

1. Select the object and click on a dimen-
sion line that locates it. An inline text 
field opens at the location where you 
clicked. 

•  The actual distance displays in the text 
field. 

•  If the dimension is locating two differ-
ent objects, the Move Edge and Move 
Entire Object buttons display to the 
right of the text field. 

•  If the dimension describes a selected 
wall’s length, the Move Start, Move 
End and Move Both Ends buttons dis-
play to the right instead. 

2. Click the Move button of your choice. 
3. Enter a new value in text field. 

•  To use a different unit, include its indi-
cator after the value.To move the 
selected object past a second object, to 

its opposite side, enter a negative 
value. 

4. The selected object moves or resizes 
when you press the Enter key or click 
outside of the text field. 

5. If Bumping/Pushing  is enabled, the 
object being moved will bump into any 
objects in its move path and not move 
the entire distance. Hold down the Ctrl 
key when you press Enter to override 
this move restriction. See “Bumping/
Pushing” on page 152. 

To resize an object using dimensions

1. Select the object along the edge that you 
would like to move. See “Selected 
Edge” on page 125.

2. Click on a dimension line that indicates 
its distance from the object’s opposite 
side. 

3. In the inline text field, enter a value. 
4. Click Move edge to move the selected 

edge only. 
5. The selected edge moves, resizing the 

object, when you press the Enter key. 

Resizing a House Using 
Exterior Dimensions

When resizing a house using dimensions, it 
is important to work your way around the 
house in one direction. Relocate one wall at a 
time in succession so that you do not redefine 
the same dimension more than once. 

Move Entire Object

Move Edge (selected)

Move Both Ends

Move Start       Move End You can cancel a move or resize opera-
tion using dimensions at any time by
pressing the Esc key.
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For more information, see “Adjusting Wall 
Positions” on page 36 of the User’s Guide. 

Using Angular Dimensions
Angular Dimensions are useful for 
adjusting the angles of polyline-based 

objects and walls.

To change an angular dimension

1. Draw an CAD> Dimensions> Angular 

Dimension , then click and drag to 
draw an arc within the angle you wish to 
measure.

2. Select the edge that you want to move.
3. Click the dimension value to open the 

Set Angular Dimension dialog.

The Set Angular Dimension dialog indi-
cates the Previous Value in degrees, minutes 
and seconds. 

4. Enter a value in the New Value field.
5. Specify what you want to rotate:

•  Select Rotate Edge to move the 
selected edge when you click OK, or 

•  Select Rotate entire polyline to rotate 
the entire object about the corner 
formed by the edges that the Angular 
Dimension locates, maintaining the 
previous value of that angle.

6. Click OK to apply the change.

Dimension Line Specification Dialog
To open the Dimension Line 
Specification dialog, double-click a 

dimension line using the Select Objects  

or Manual Dimension  tool, or select a 

dimension line or group of dimension lines 
and click the Open Object edit button.

The settings in this dialog are dynamic 
defaults. See “Dimension Defaults Dialog” 
on page 720. 
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Dimension Tab

Options - Specify the size and display 
of wall widths attributes for the selected 

dimension line. The minimum on-screen size 
can be set in the Preferences dialog. See 
“Appearance Panel” on page 61.
• Specify the Number Height for the 

selected dimension. Type “d” in the box 
to reset the number size to the default. 

• Check Suppress Wall Widths to sup-
press those portions of the dimension line 
that measure between two surfaces of the 
same wall. Both sides of a wall may still 
be located, but its width will not display.

This option is checked by default for 
most manually drawn dimensions, but is 
unchecked for Interior Dimensions.

Specify the use and appearance of 
Rounded Value Indicators, which can 

display when the degree of accuracy in use is 
not sufficient to describe a dimension’s true 
value. 
• Check Use Default to use the default 

indicator(s). Uncheck this box to make 
the options that follow active.

• Check + or - After Number to indicate 
that the actual dimension value is higher 
or lower than the value shown.

• Check ~ Before Number to indicate 
dimension values that are not accurate 
with the ~ symbol.

1

2

Dimension Number Height is subject to
scaling. For example, A Number Height

of 6” prints a 1/8” tall number at 1/4” = 1’
scale. A Number Height of 125 mm prints a 3
mm tall number at 1 m = 50 m scale. 

1

2
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Dimension Tab for Angular Dimensions

Number Height - Define a number 
height for the selected dimension. Type 

“D” in the box to reset the number size to the 
default.

Angle Style - Click a radio button to 
specify the how the selected angular 

dimension line’s angle value displays. See 
“Number Style/Angle Style Dialog” on page 
89.

Extensions Tab
The Extensions Tab is not available for  
dimensions selected as a group or for 

Angular Dimensions .

1 2

1 2

Opening this tab will turn off Version 8
Compatible Extensions if it is enabled in

the Dimension Defaults dialog. See “Exten-
sions Tab” on page 726.

1

3 4

2

5
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Selected Extension - Choose an 
extension line associated with the 

currently selected dimension from the drop-
down list. The selected extension can then be 
edited here. 

Each extension line’s number displays beside 
it when a dimension line is selected.

Uncheck Use Plan Default to enable 
the three settings that follow. Check 

this box to restore the default settings to the 
Selected Extension line. See “Dimension 
Defaults Dialog” on page 720.

These settings are the same as those 
found on the Extensions tab of the 

Dimension Defaults dialog, but apply to the 
extension lines associated with the selected 
dimension line only. See “Extensions Tab” 
on page 726.

Click Apply to All to apply the settings 
for the Selected Extension line to all 

extension lines associated with the selected 
dimension.

Check Proximity Fixed to specify a 
fixed distance between the marked 

object and the dimension line. You can only 
fix the proximity for a single extension line.
• Distance to Marked Object - When 

Proximity Fixed is checked, you can 
specify the distance from the dimension 
line to the marked object using a positive 
value. See “Extensions Tab” on page 726.

Arrow Tab
For information about the settings on this 
tab, see “Arrow Tab” on page 783.

1

2

3

4

5
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Chapter 31:

Text, Callouts
& Markers

Text, callouts and markers are an ideal way 
to draw attention to special details of your 
drawings. Text can be added in floor plan 
view, in cross section/elevation views, and to 
layout pages.

Text lines with arrow can be attached to text 
objects, allowing you to direct attention to 
specific plan details.

Chapter Contents
•      Text Defaults and Preferences
•      Fonts and Alphabets
•      The Text Tools
•      Creating Text, Callouts and Markers
•      Displaying Text, Arrows, Callouts and 

Markers
•      Rich Text Specification Dialog
•      Text Specification Dialog
•      Editing Text
•      Copying & Pasting Text
•      Text Arrows
•      Callouts
•      Callout Specification Dialog
•      Editing Callouts
•      Markers
•      Marker Specification Dialog
•      Editing Markers
•      Text Styles
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Text Defaults and Preferences
Text Defaults can be accessed by 
selecting Edit> Default Settings in 

any view in which text can be created. Click 
the "+" next to Text, Callouts and Markers 
to display the sub-headings. See “Default 
Settings vs Preferences” on page 56. 

The default settings for Rich Text, Callouts, 
Markers, and Arrows determine what these 
objects look like when they are first created. 
Text Style Defaults determine the appearance 
of text associated with things like dimensions 
and object labels. 

Changes made to default settings do not alter 
existing text objects, so it is a good idea to go 
over these settings before placing text. 

Text Style Defaults
Select “Text Style” from the list in the 
Default Settings dialog and click the Edit 
button to open the Saved Text Style 
Defaults dialog.

The Text Style Defaults dialog allows you to 
specify the attributes of the various Text 
Styles in use in the current file. See “Text 
Styles” on page 765.

Rich Text Defaults

Double-click the Rich Text  or Leader 

Line  tool to open the Rich Text Defaults 
dialog and specify the default appearance of 
Rich Text objects. 

The Rich Text Defaults dialog is similar to 
the Rich Text Specification dialog. See 
“Rich Text Specification Dialog” on page 
747.

Leader Lines  and Text Lines with 

Arrows  use the same default layer as 
Rich Text, so by default they have the same 
color, line weight and line style. See 
“Layers” on page 101.

Callout Defaults

Double-click the Callout  tool to open the 
Callout Defaults dialog and specify the 
default appearance of callouts. 

The Callout Defaults dialog looks almost the 
same as the Callout Specification dialog. 
See “Callout Specification Dialog” on page 
760.

Marker Defaults

Double-click the Marker  tool to open 
the Marker Defaults dialog and specify the 
default appearance of markers.

The Marker Defaults dialog looks almost the 
same as the Marker Specification dialog. 
See “Marker Specification Dialog” on page 
763.

Arrow Defaults

Double-click the Text Line with Arrow  
tool to open the Arrow Defaults dialog.

The settings in the Arrow Defaults dialog 
determine the initial settings for arrows 

drawn using the Leader Line , Text Line 

with Arrow  and Line With Arrow  
tools. These settings also determine the 
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initial appearance of arrows when they are 
added to CAD lines, arcs, and polylines.

The Arrow Defaults dialog looks almost the 
same as the Arrow tab of the Line 
Specification dialog. See “Arrow Tab” on 
page 783.

Preferences
Specify the number of segments for 
new leader lines and whether pressing 

the Enter key creates a new line of text or 
closes the Text Specification dialog in the 
Preferences dialog. See “Text & Page Setup 
Panel” on page 66.

Fonts and Alphabets
Home Designer Pro allows you to use any 
font found in your Windows Fonts directory. 

For best printed results, using true-type or 
open-type fonts is recommended. 

International Alphabets

The Rich Text  tool supports unicode 
alphabets and characters. In order to use a 
unicode alphabet or characters, the 
appropriate language support must be 
installed on your computer. 

Special characters can be added to any Rich 

Text  object by: 
• Copying and pasting the character from 

another application;
• Copying and pasting the character from 

the Windows Character Map;
• Typing the keystroke associated with the 

character.

See “Copying & Pasting Text” on page 756.

Character Size
Text, callouts, markers as well as dimension 
numbers can be sized to 1/128” accuracy 
when Inches is used as the number style 
(0.078125 mm when Decimal mm is used). 
See “Number Style/Angle Style Dialog” on 
page 89. 

Either of two font sizing methods may be 
used: 
• The default method specifies text size as 

the measurement from the baseline to the 
topmost part of the capital letter A. This 
method is similar to that used in most 
CAD programs. 

• Alternatively, you can use a font sizing 
method similar to most word processing 
applications, where size is based on 
information stored in the font. This infor-
mation varies from font to font and is 
responsible for apparent differences in 
font height. 

To size Rich Text  based on the size of 
the capital letter A, use CAD Style Font 
Sizing. See “Appearance Tab” on page 750.

Avoid typing any text in any text
Defaults dialog unless you want it to be

present in all text objects you create.
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To size Callouts , Markers  and 
dimension numbers based on font 
information, use Legacy Compatible Size.

The sizing method used for text objects can 
be set as defaults and also specified per 
object in objects’ specification dialogs. See 

“Text Defaults and Preferences” on page 
744.

The sizing method used for dimensions can 
only be specified in the Dimension Defaults 
dialog. See “Dimension Defaults Dialog” on 
page 720.

The Text Tools
Select CAD> Text to access the Text 
Tools. These tools are available in 

floor plan view, in cross section/elevation 
views, and in layout files.

The Rich Text tool is used to create 
text objects.

The Text Line with Arrow tool is 
used to connect text and another 

object with an arrow. See “Text Arrows” on 
page 757.

Text with Arrow tool places a Rich 
Text object with an arrow attached.

The Callout tool is used to place 
callouts. See “Callouts” on page 759.

The Marker tool is used to place 
markers for Level Lines, Test 

Borings and Point Markers. See “Markers” 
on page 762.

Creating Text, Callouts and Markers
Text, callouts and markers can be created in 
floor plan view, in cross section/elevation 
views, and on layout pages. 

Once created, text, callouts and markers can 
be selected and edited in a variety of ways. 
See “Editing Text” on page 754. 

To create Rich Text

1. Select CAD> Text> Rich Text . 
2. Type or paste the desired text into the 

Text Field.
3. Use the options  to change the font, style 

and size of any portion of the text. 

4. When you are finished, simply click out-
side of the Text Field to close it and the 

Edit Bar. The Rich Text  tool 
remains active, so you can click and 
drag to create additional Text objects if 
you wish.

Rich Text , Callouts  and 

Markers  can also be created by clicking 
where you want the upper left corner of the 
object to be created. The object’s specifica-

Note: If you do not type anything in the Text
Field, a text object will not be created when
you click outside of it.
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tion dialog will open: enter text and click 
OK.

You can also create lines with arrows 
connecting the text that you create to items in 
the drawing. See “Text Arrows” on page 757. 

Text and CAD Objects
Text can be used in combination with CAD 
objects to create legends, title blocks, and a 
wide variety of other details. See “CAD 
Objects” on page 769 and “Layout” on page 
863.

Displaying Text, Arrows, Callouts and Markers
As with other types of objects, the display of 
Text objects is controlled in the Layer 
Display Options dialog.  Text objects are 
located on layers with “Text” at the 
beginning of the layer name, such as “Text, 
Callouts”. See “Layer Display Options 
Dialog” on page 104. 

Text objects can only be displayed in views 
where text can be created. 

The display attributes of each individual text 
object can be controlled independent of the 
layer it is placed on. See “Rich Text Specifi-
cation Dialog” on page 747. 

To move text to a different layer, select the 
text object or group of text objects, then click 

the Open Object  edit button to open the 
Text Specification dialog. The selected text 
object’s layer can be changed on the Line 
Style tab. See “Line Style Tab” on page 781.

Rich Text Specification Dialog
The Rich Text Specification dialog 

opens if you select the Rich Text  
tool and then click once in the drawing area.

You can also open this dialog by selecting 

one or more Rich Text  objects, then 
clicking the Open Object edit button. 

When Rich Text  objects are group-
selected, the text content and zoom factor 
cannot be changed, but everything else can 
be. 

The Rich Text Specification dialog is 
similar to the Rich Text Defaults dialog but 
affects the selected text rather than all 
subsequently created text objects. See “Text 
Defaults and Preferences” on page 744.

Text Tab
The settings on the Text tab allow you to type 
the selected Rich Text object’s content and 
control many aspects of its appearance, 
including its font, size, color and style.

You can specify the appearance of the text 
before typing, and can also select and change 
the attributes of all or portions of the text 
content after it is typed. To change text that 
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already exists, simply highlight it using the 
mouse and/or the Shift + arrow keys and then 
make any needed changes to its attributes. 

Use the options on the Edit Bar, which 
displays above the Text Entry field, to 

change the font, style and size of the text.

Select the desired options before typing to 
affect the text as it is typed, or select some or 
all of the text and then specify which options 
to apply to it.
• Select a Font from the drop-down list.
• Specify the Text Size in drawing units. 

When imperial Inches or Feet and Inches 
are used, accuracy to 1/128” is possible.

• Click the Print Size  button to open 
the Printed Size Input dialog. See “Scal-
ing Text” on page 755.

• Click the Color  button to specify the 
color of the selected or subsequently 
typed text. See “Color Chooser Dialog” 
on page 652. If Layer Color Text is 
checked on the Appearance tab, any cus-
tom colors specified here are lost. 

• Click the Bold  button to specify the 
selected or subsequently typed  text as 
bold.

• Click the Italic  button to specify the 
selected or subsequently typed text as 
italic.

• Click the Underline  button to specify 
the selected or subsequently typed text as 
underlined.

• Click the Strikethrough  button to 
selected or specify the subsequently 
typed text as stricken-through.

• Click the Align Left , Align 

Center , or Align Right  button to 
specify the how the selected or subse-
quently typed text is aligned.

• Click the Paragraph Options  button 
to specify the selected paragraph’s align-

1

2

1
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ment, spacing and bullets or numbering 
in the Paragraph Options dialog. 

• Specify the Zoom factor of the selected 
text by typing a percentage value in the 
text field or clicking the up/down arrows. 
This setting only affects the text as it 
appears in this dialog.

Type or paste text in the Text Entry 
field. See “Copy, Cut and Paste” on 

page 756.

Right-click in the Text Entry field to access a 
contextual menu from which you can select 
Cut, Copy, Paste and Select All. See 
“Contextual Menus” on page 30. 

To edit text in the entry field, click and drag 
to highlight any portion of it and then use the 
tools on the Edit Bar as needed.

Paragraph Options Dialog

Specify the Alignment of the selected 
paragraph(s). See “Aligning Text” on 

page 756.

Specify the Line Spacing of the 
selected paragraph(s). 

• Click the radio button beside Single, 1.5 
Lines, Double or User Specified.

• If you select User Specified Line 
Height, type the desired height for each 
line of text in the selected paragraph(s). 
For best results, this value should be at 
least as much as the largest character size 
used in the selected paragraph(s). 

Specify the appearance of Bullets and 
numbering in the selected paragraph(s). 

• Select the desired bullet, numbered or let-
tered Type from the drop-down list.

Note: Some fonts cannot be drawn at certain
zoom factors. When this is the case, the
appearance of the text will not change.

2
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• Select the desired punctuation Style for 
the selected numbered or lettered Type. 
Only available when a numbered or let-
tered Type is selected. 

• Numbering Start At - Specify the num-
ber assigned to the first numbered or let-
tered paragraph in the selected text 
object. Value must be 1 or greater. 

To adjust the size of bullets
1. Click at the end of a bulleted paragraph 

to position your cursor there.
2. Hold down the Shift key and press the 

right arrow key once to highlight the end 
of the paragraph.

3. Specify the desired bullet size in the text 
size field at the top of the Text tab. 

Appearance Tab

Leader Lines  and Text Lines with 

Arrows  use the same default layer as 
Rich Text, so they share the same default 

color, line weight and line style. See 
“Layers” on page 101.

Specify the appearance of the text 
object’s Border. 

1
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• Check Display Border to display a bor-
der around the selected text object and 
enable the settings that follow.

• Check Layer Color to use the line color 
assigned to the text object’s layer, or click 
the Color bar to select a different color. 
See “Color Chooser Dialog” on page 
652.

• Check Use Layer Line Style to use the 
line style assigned to the text object’s 
layer, or choose another style either from 
the drop-down list.

• Check Use Layer Weight to use the line 
weight assigned to the text object’s layer, 
or specify a different weight. See “Line 
Weights” on page 849.

Specify the appearance of the text 
object’s Fill. 

• Check Display Fill to display a fill color 
within selected text object(s) and enable 
the settings that follow.

• Select Use Custom Color then click the 
Color bar to use a fill color of your 
choosing. See “Color Chooser Dialog” 
on page 652.

• Check Use Background Color to use 
program’s Background color as the text 
object’s fill color. See “Colors Panel” on 
page 63. 

• Check Use Layer Color to use the color 
assigned to the text object’s layer as its 
fill color.

Specify the Top, Bottom, Left and 
Right Margins, the distance between 

the text and the border, of the selected text 
object(s). 

2
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Options Tab

Options 

• CAD Style Font Sizing measures text 
size based on the total height of the capi-
tal letter A, as most CAD programs do. 
Uncheck this to instead size text accord-
ing to information stored with the font. 

• Check Rotate with Plan to rotate the 

selected text when Rotate Plan View  
is used. If unchecked, the selected text is 
unaffected when Rotate Plan View is 
used. See “Rotate Plan View” on page 
163. 

Rotate with Plan also affects text in 
views sent to layout if the layout box is 
rotated. See “CAD and Text in Layout” 
on page 868. 

• Check Add an Arrow to add a Text 
Arrow to the selected text object. See 
“Text Arrows” on page 757.

Specify the Position of the selected text 
object using CAD coordinates. 

The X Position and Y Position of the pointer 
can be set to display in the Status Bar, which 
may help determine the exact coordinates of 
a location in a plan or layout file. See 
“Appearance Panel” on page 61.

1
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An exact Angle can be entered. An angle of 
90 is vertical (pointing up) and an angle of 
180 is upside down.

Specify the Size of the selected text 
object. 

• Check Auto Height to automatically 
adjust the text object’s height to match its 
contents.

• Check Auto Width to automatically 
adjust the text objects width to match its 
contents. When Auto Width is used, text 
extends in a single line rather than wrap.

• Specify the Height of the selected text 
object(s).  

• Specify the Width to of the selected text 
object(s). 

The Drawing Group options control 
how the selected object(s) display 

relative to other objects. See “Drawing 
Groups” on page 150. 
• Specify the Back Group to display the 

selected object(s) behind objects in the 
other two drawing groups. 

• Specify the Default Group to display the 
selected object(s) in front of those in the 
Back Group but behind those in the Front 
Group. 

• Specify the Front Group to display the 
selected object(s) in front of objects in 
the other two drawing groups. 

• Check Move to Front of Group to dis-
play the selected object(s) in front of 
other objects in the same drawing group. 
This is an action rather than a state and is 
not available in the Rich Text Defaults 
dialog. 

Specify the desired Bumping behaviors 
for the selected object(s). See 

“Bumping/Pushing” on page 152. 
• Check CAD Stops Move to bump the 

selected object into other CAD or CAD-
based objects as it is moved.

• Check Wall Stops Move to stop the 
selected object when it bumps into a wall. 

Text Specification Dialog
The Text Specification dialog opens if you 
select a Room Label or a simple Text object 
in a legacy plan or layout file created in 
Version 8 or prior and click the Open Object 
edit button. See “Compatibility with Other 
Programs” on page 40.

Settings in the Text Specification dialog can 
also be found in other dialogs in the program, 
including the Room Label Specification and 
the Dimension Defaults dialogs. 

Text Tab
Text Style TabThe Text Style tab is 
available for a variety of objects in the 
program and control the appearance of the 

selected object’s text. See “Text Style Tab” 
on page 766. 
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Editing Text 
Once created, Rich Text  objects can be 
selected individually or as a group and edited 
using the edit handles, the edit toolbar 
buttons, and the Rich Text Specification 
dialog. See “Rich Text Specification Dialog” 
on page 747.

Text  objects can be selected and edited 
much the way Rich Text objects can; 
however, there are a few differences which 
are described here.

Editing Text Attributes
Most text attributes, including the font, size, 
style, and the content itself, are edited in the 
Rich Text Specification dialog.

In order to edit the attributes of an existing 

Rich Text  object, you must select some 
or all of the text before making changes. See 
“Text Tab” on page 747. 

To edit Rich Text attributes

1. Select a Rich Text  object and click 

the Open Object  edit button.
2. On the Text tab of the Rich Text 

Specification dialog, click and drag to 
select some or all of the text typed into 
the Text field. 

3. With some or all of the text selected, 
change any of the attributes available 

along the top of the tab, including the 
font, size, color, and style.

4. As changes are made, the selected text 
updates. Only the selected text is modi-
fied.

Text  objects do not support multiple 
fonts or other attributes in the same text 
object. When you choose an attribute, it is 
applied to all characters in the text object. 

Using the Mouse

A selected Rich Text  or Text   object 
has the same edit handles as other box-based 
objects. See “Editing Box-Based Objects” on 
page 141.

As a Text  box is made narrower or wider 
using an edit handle, the bottom of the text 

Resize

Extend/
Contract

Rotate

Move
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box may expand or contract to allow all text 
to be shown.

As a Rich Text  box is made smaller 
using an edit handle, not all of the text may 
be visible.

Depending on the active Edit Behavior , 
the text box and the characters within it may 
or may not resize together when a corner edit 
handle is dragged. See “Edit Behaviors” on 
page 120. 

• If Resize  editing is enabled, both the 
text object and the font resizes when a 
corner edit handle is dragged.

• If Default  or Concentric  editing 
is enabled, the text box resizes, but not 
the font size.

• If Fillet  editing is selecting, the cor-
ners become rounded and the font size 
does not change. See “Behaviors Panel” 
on page 78.

Using the Edit Tools

A selected Rich Text  or Text  object 
can be edited in a variety of ways using the 
buttons on the edit toolbar. See “The Edit 
Toolbar” on page 29.

Resizing Text
Both the border of a text object and the 
characters it contains can be resized.

The border of a text object can be resized 
using its edit handles or by specifying the 
Height and Width in its specification dialog. 

The default character height of Rich Text 

 objects can be specified as can the 
character height for individual objects, in 
their specification dialogs. See “Text 
Defaults and Preferences” on page 744.

Character height can be measured in either of 
two ways. See “Character Size” on page 745.

Scaling Text
As with the size of other objects, text size is 
subject to the current drawing scale specified 
in the Page Setup dialog. See “Page Setup 
Dialog” on page 853. 

To determine the Height needed to produce 
text of a certain printed size, click the Print 

size  button in the Rich Text 
Specification to open the Printed Size Input 
dialog.

To use the Printed Size Input dialog

1. Click the Print Size  button on the 
Text tab of the Rich Text Specification 
dialog.

When text is resized using the edit han-
dles, there is a “sticky point” at the natu-

ral size of the text box. Hold down the Ctrl key
while resizing to override this behavior. 
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2. In the Printed Size Input dialog, con-
firm the desired Drawing Scale. Enter 
the Desired Print Size of the text.

3. Click OK to return to the Text 
Specification dialog. The Height 
updates, reflecting the character height 
necessary to print the text at the Desired 
Print Size when printed at the specified 
Drawing Scale.

In most cases, the Drawing Scale does not 
need to be changed in the Printed Size Input 
dialog unless you intend to send the current 
view to layout at a different drawing scale.

Aligning Text
Text can be aligned in a number of ways. 
• The text content of a text object can be 

aligned to the left, right, center or justi-
fied in the Rich Text Specification dia-
log. See “Text Tab” on page 747.

• The text content of a text object can be 
also be aligned by clicking the Align 

Left , Align Right , Center , 

or Justify  edit button.  
• The center points of text objects can be 

aligned with one another by assigning 

them the same X and/or Y Position. See 
“Attributes Tab” on page 761. 

• Text objects can be aligned by bumped 
them against a CAD line or CAD based 
object such as a roof plane. See “Bump-
ing/Pushing” on page 152. 

A variety of other alignment methods are 
also available. See “Aligning Objects” on 
page 154.

Copy, Cut and Paste
Copy, Cut and Paste of text into and out of 
the text specification dialogs can be 
accomplished using keyboard hotkeys:
• Press Ctrl + X to Cut the selected text and 

save it to the Windows clipboard.
• Press Ctrl + C to Copy the selected text 

and copy it to the Windows clipboard.
• Press Ctrl + V to paste your last cut or 

copied selection in a new text object.

For more, see “Copying and Pasting 
Objects” on page 114.

Copy, Cut and Paste use the Windows 
clipboard, making it possible to to transfer 
text between text objects, between Home 
Designer Pro files, from a plan or layout into 
another application, or vice versa. 

Copying & Pasting Text
The Copy, Cut and Paste commands use the 
Windows clipboard, making it possible to 
transfer text between text objects, between 
Home Designer Pro files, from a plan or 
layout into another application such as a text 
editor or spreadsheet program, or vice versa. 

See “Copying and Pasting Objects” on page 
114.

All or selected portions of the Materials List 
can also be copied and pasted into a text 
object, as well as into a word processing or 
spreadsheet program. See “Materials Lists” 
on page 887.
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Cut, Copy, and Paste can also be accessed 
from the Edit menu of many applications, 
including Home Designer Pro. These menu 
commands are not available when the text 
specification dialogs are open, but you can 
use the associated hotkeys. 

To Copy, Cut and Paste text
1. On the Text tab of either text specifica-

tion dialog or in another program alto-
gether, highlight the text you wish to cut, 
copy or paste.

2. Press Ctrl + X to Cut the selected text 
out of its original location and save it to 
the Windows clipboard.

3. Press Ctrl + C to Copy the selected text 
to the Windows clipboard without 
removing it from its original location.

4. Open the text object or a file in another 
application and click to place your cur-
sor in the Text field, writing area, or 
spreadsheet cell.

5. Press Ctrl + V to Paste the copied text at 
the location of your cursor.

Bear in mind that when text is copied and 
pasted, its formatting is not always retained. 
The results depend on the program or type of 

text object in which the content was created 
as well as the type of text object into which it 
is pasted. 

Pasting into Rich Text
Text pasted into a Rich Text object 
from another source will retain most 

of its custom formatting. 

Text pasted into a Rich Text  object from 
a spreadsheet program retains basic column 
and row information. Column width cannot 

be adjusted as it can in simple Text ; 
however, as you add or remove text froma 
cell, row height will increase or decrease to 
accomodate your changes.

The background colors of two or more cells 
copied from a spreadsheet application will be 

retained if pasted in to Rich Text ; 
however, once pasted background color 
cannot be edited. 

If you want to retain the color of the actual 

text being pasted into a Rich Text  object, 
be sure to uncheck Layer Color Text in the 
Rich Text Specification dialog. See 
“Appearance Tab” on page 750.

Text Arrows
Text arrows, which are simply CAD lines 
with arrows drawn on the “Text” layer, can 
be used to connect text objects to details of 
interest in your drawing. See “Line Tools” on 
page 776. 

Text arrows can be snapped together to form 
open or closed polylines. If two lines with 
arrows meet within the bounding box of a 

text object, however, they will not join. This 
allows you to attach multiple, separate text 
arrows to a single text object. See “Editing 
Line Based Objects” on page 127.

Lines with arrows can be independent or 
attached to other objects. Arrows attach to 
closed polyline-based objects along their 
edges, but can attach to an architectural 
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object anywhere within its 2D symbol in 
floor plan view. If an arrow is attached to text 
or another object, deleting either the text or 
the object will also delete the arrow. 

Text with Arrow
The Text with Arrow tool places a text 
object with an arrow already attached. This 
arrow can be selected and edited like any 
other arrow.

Text Line with Arrow
Text Lines with Arrow can be 
attached to text, CAD and 

architectural objects by selecting CAD> 

Text> Text Line with Arrow  and then 
clicking and dragging to draw a line. There is 
no limit to the number of text lines with 
arrows that can be attached to an object.

The endpoints of Text Lines with 

Arrows  can be joined to form polylines 
with corners that can be adjusted using the 
edit handles. See “Polylines” on page 790. 

A Text Line with Arrow  behaves like a 

Line With Arrow  with one exception: 
Text Lines with Arrow are initially placed on 
the “Text” layer, not the “CAD, Default”. 
See “Layers” on page 101. 

Auto Positioning Arrows
If either or both ends of a line with arrow are 
attached to a text object, Auto Position Tail 
and Auto Position Head are in the Line 
Specification dialog. See “Arrow Tab” on 
page 783. 

Check either or both if you want the text line 
with arrow to update its position on the text 
object if the text object or text line with 
arrow is moved.
• The first segment of a polyline arrow 

attached to text maintains its angle when 
Auto Position is off and text is moved.

• Auto Position is turned off automatically 
when an arrow is not attached to one of 
the auto position locations.

• Arcs and splines with arrows can also be 
attached to text objects.

There are four auto position locations on a 
text object: one at the midpoint of each side.

The following image illustrates the behavior 
of auto positioning. The arrow has the Auto 
Position Tail option checked. When the head 
of the line with arrow is moved, the tail of 
the arrow snaps to different auto position 
locations on the text object, maintaining its 
connection.

If a selected Text Line with Arrow is moved 
away from an auto position location and you 
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check Auto Position Tail, the tail will snap 
to the nearest auto position location. 

Callouts
Select CAD> Text> Callout, then 
click at the location where you want a 

callout to be placed in floor plan view, a 
cross section/elevation view or on a layout 
page. The Callout Specification dialog 
displays. Make any needed changes and click 
OK to place a callout. See “Callout 
Specification Dialog” on page 760.

Cross Section Lines
Check the Cross Section Line box in the 
Callout Specification dialog to add a cross 
section line perpendicular to the nearest wall. 
See “Callout Tab” on page 760.

Cross section lines can be added to any 
callout shape. Resize or rotate the cross 
section line by dragging the triangular edit 
handle near the end of the cross section line. 

Pointers and Arrows
To add an arrow or “hat” to a callout, select 
the callout and drag the diamond-shaped 
handle away from the center of the callout. 
An arrow is created, pointing in the direction 
you dragged. 

• Change the arrow’s direction by selecting 
the callout and dragging the edit handle 
appearing just beyond the arrow. 

• Remove an arrow by clicking and drag-
ging the edit handle at the point of the 
arrow towards the center of the callout. 

You can also add as many lines with arrows 
as you like to callouts. To add an arrow to a 
callout, select CAD> Text> Text Line with 

Arrow , then click and drag to create a 
line with arrow, which can be moved or 
resized as needed.

Double Callouts
Any callout can be specified as a Double 
Callout in the Callout Specification dialog. 
See “Attributes Tab” on page 761.
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To resize the line between the two callout 
shapes, select the callout and then click and 
drag the edit handle at the center of either 

callout shape. The arrows on a double callout 
are always the same on both callouts. 

Callout Specification Dialog
To open the Callout Specification 
dialog, select a callout and click the 

Open Object edit button. This dialog also 
displays when a new callout is created using 

the Callout  tool. 

The Callout Specification dialog is similar 
to the Callout Defaults dialog but affects the 
selected callouts rather than all subsequently 
created callouts. See “Text Defaults and 
Preferences” on page 744.

Callout Tab

Specify the text of the selected callout’s 
Label by typing in the text fields here.

• Type a Callout Label, which displays 
inside the callout shape. If no Text Below 
Line is specified, the Callout Label is 
centered in the callout. 

• Type the Text Below Line for the bottom 
row, if desired. If Text Below Line is 
added, a line will separate it from the 
Callout Label.

Specify the Callout Shape by clicking 
the radio button beside one of the 

options here.

Additional Specifications can be set 
here.

• Uncheck Automatic to enable the Size 
field and specify a new value. When 
checked, the callout is sized so that it 
encompasses the text of its label.

• Specify the Angle of the selected callout. 
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Attributes Tab

Specify the attributes of the selected 
callout’s Cross Section Line. 

• Check Display to apply a cross section 
line to the selected callout. When 
unchecked, no cross section line is used.

• Check Double Callout to specify two 
identical callouts connected by the cross 
section line. Only available when Display 
is checked.

• Select the cross section line’s line Style 
from the drop-down list. When By Layer 
is checked, the line style specified in the 
Layer Display Options dialog is used.

• Specify the Weight of the cross section 
line or check By Layer to use the line 
weight specified in the Layer Display 
Options dialog. 

Specify the attributes of the Callout 
Arrows. 

• Check By Layer to use the color speci-
fied in the Layer Display Options dialog 

or click the Color bar to choose an arrow 
color. See “Color Chooser Dialog” on 
page 652.

• Check Filled to specify arrows with a 
solid fill. When unchecked, arrows are 
unfilled.

• Specify the Number of arrows and 
whether they are Small or Large. 

Line Style Tab
The Line Style tab is found in the 
specification dialogs for many different 
objects. For more information, see “Line 
Style Tab” on page 781.

Additional attributes for the cross section 
line and arrows can be specified on the 
Attributes Tab. 

Text StyleTab
The settings on this tab control the 
appearance of the selected object’s text. For 

1
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more information, see “Text Style Tab” on 
page 766. 

Editing Callouts
Callouts can be edited using the edit handles, 
the edit toolbar buttons and the Callout 
Specification dialog. See “Callout 
Specification Dialog” on page 760.

When a callout is selected, it has at least four 
edit handles. An additional rotate handle 
displays for each pointer added to the callout.

• The Move handle is located at the center 
of the callout and is used to move it.

• The triangular Extend/Rotate handle is 
used to extend and/or rotate the callout’s 
cross section line, if one exists. See 
“Cross Section Lines” on page 759.

• The small, square Resize handle is 
located on the edge of the callout and is 
used to resize it and its associated text.

• The Add pointer handle is used to add 
pointers by dragging away from the call-
out.

• The small triangular Rotate pointer han-
dle located at the end of a pointer, if one 
has been added, is used to rotate that 
pointer.

Resizing Callouts
Callout shapes can be resized either in the 
Callout Specification dialog or using the 
edit handles. See “Callout Tab” on page 760.

Callout text can be resized in the Callout 
Specification dialog. See “Attributes Tab” 
on page 761. 

As long as Specify Callout Size box is 
checked, a callout’s shape and text resize 
independent of one another. When this box is 
unchecked, the two are dynamically linked: 
if you resize the shape, the text adjusts 
accordingly or vice versa.

Markers
Markers for Level Lines, Test 
Borings and Point Markers can be 

placed in floor plan view, or cross sections. 
Framing Reference Markers should only 
be placed in floor plan views.

To create a marker, select CAD> Text> 

Marker  and click at the location where 
you want it to be placed. The Marker 
Specification dialog opens. 

ResizeAdd 

Move Extend/
Rotate

Rotate 
pointer
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You can also place a framing reference 
marker using Build> Framing> Framing 

Reference . See “Framing Reference 
Markers” on page 454.

Point Markers and Dimensions

When the Point to Point Dimension  tool 
is used to draw a dimension line and an 
object is not available to snap to at either the 
start or end point, a Point Marker will be 

automatically created and the dimension line 
will locate it. See “Point to Point 
Dimensions” on page 730. 

In addition, any dimensions drawn in a cross 
section/elevation view may locate Cross 
Section Lines that represent objects rather 
than the objects themselves. When this 
occurs, Point Markers will also be placed and 
the dimension lines will locate them. See 
“Cross Section Lines” on page 689. 

Marker Specification Dialog
To open the Marker Specification 
dialog, select a marker and click the 

Open Object edit button. 

This dialog also displays when a new marker 
is created by clicking in floor plan view 

using the Marker  tool. 

The Marker Specification dialog is similar 
to the Marker Defaults dialog but affects the 
selected markers rather than all subsequently 
created markers. See “Text Defaults and 
Preferences” on page 744.

Marker Tab

Enter optional Text Above Line. Enter optional Text Below Line (Level 
Line Marker only).

1
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Choose a Marker Type. 

Only a Framing Reference marker effects 
the model. The other marker types are only 
cosmetically different.

Enter a number in the Height field. The 
height value will display with the 

marker symbol when a pound sign (#) is 
entered in the Text Above and/or Below 
Line fields.

 Enter the Marker Radius, in inches or 
millimeters.

Line Style Tab
The Line Style tab is found in the 
specification dialogs for many different 
objects. For more information, see “Line 
Style Tab” on page 781.

Additional attributes for the cross section 
line and arrows can be specified on the 
Attributes Tab. 

Text Style Tab
The settings on this tab control the 
appearance of the selected object’s text. For 
more information, see “Text Style Tab” on 
page 766. 

Editing Markers
Markers can be edited using the edit handles, 
edit toolbar and Marker Specification 
dialog. See “Marker Specification Dialog” 
on page 763.

When a marker is selected, it has four edit 
handles.

• The Move handle is located at the center 
of the marker and is used to move it.

• The Resize handle is located on the edge 
of the marker and is used to resize the 
marker and associated text.

• The triangular Rotate handle is used to 
rotate the marker and associated text.

• The Extend handle is used to adjust the 
distance between the marker and its asso-
ciated text. 
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Text Styles
In Home Designer Pro, a Text Style is a set of 
attributes assigned to any object that displays 
text, such as Callouts, Markers, Dimensions, 
Plant Schedules, and object labels. 

You can create your own or edit existing Text 
Styles to suit your needs in the Text Style 
Defaults dialog  

Text Style Defaults
Select Edit> Default Settings, click on  
“Text Styles” and click Edit to open the Text 
Style Defaults dialog. The Saved Text Style 
Defaults dialog will open, allowing you to 
select which Saved Text Style Defaults you 
would like to edit.

Saved Text Style Defaults 
Dialog

• Select the Name of one of them from the 
drop-down list. This is the currently 
selected Text Style.

• Click the Copy button to create a new 
Text Style by copying the one currently 
selected in the Name field.

• Click the Edit button to open the defaults 
dialog for the selected Text Style so that 
you can edit it.

• Click the Rename button to change the 
name of the currently selected Text Style.

• Click the Delete button to remove the 
currently selected Text Style from the 
current plan or layout file.

• Click OK to close the Saved Text Style 
Defaults dialog and save any changes 
you made in the defaults dialog.

• Click Cancel to close the Saved Text 
Style Defaults dialog without saving any 
changes that you may have made in the 
defaults dialog.

The settings in the Text Style Defaults 
dialog are similar to those on the Text Style 
tab of object specification dialogs throughout 
the program but affect all objects using that 
style rather than an individual selected 
object. 

Note: Because of its ability to use multiple
attributes in the same object, Rich Text does
not use Text Styles. See “Rich Text Specifica-
tion Dialog” on page 747. 
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Text Style Tab

Specify where the selected object 
should draw its Text Style from. These 

options are not available in the Text Style 
Defaults dialog. 
• Select Use Layer for Text Style to use 

the Text Style assigned to the layer tht the 
selected text is located on. 

• Select Use Text Style, then choose a style 
from the drop-down list to apply that 
style to the selected object, regardless of 
what layer it is on. When this is not 
selected, the name of the selected object’s 
Text Style displays here for reference. 

• Select Use Custom Text Style to enable 
the settings below and customize the 
selected objects Text Style attributes. 

Check Use Default Text Style to use the 
default style for the selected object type, or 
uncheck this box to enable the settings below 
and define a custom style.

The settings that follow are only editable 
when Use Custom Text Style is selected. 
When it is not selected, information about 
the Text Style that is assigned to the selected 
object displays for reference.

Specify the attributes of the selected 
Text Style’s Font. 
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• Select a font from the drop-down list.
• The text styles Bold, Underline, Italic, 

and Strikeout are available. Check any 
of the boxes to apply that style.

Specify the Size of text using the 
selected Text Style. 

• Enter the Character Height in drawing 
units. This height is subject to the current 
drawing scale. When imperial Inches or 
Feet and Inches are used, accuracy to 
1/128” is possible. 

• Click the Scale button to open the 
Printed Size Input dialog. See “Scaling 
Text” on page 755.

• In Version 9, text size was driven by 
dimension information associated with 
the font. Check Legacy Compatible Size 
to use this information for text sizing. See 
“Character Size” on page 745.

Options - 

• Check Rotate with Plan to rotate text 
using the selected Text Style when 

Rotate View  is used. If unchecked, 
the text is unaffected when Rotate View 
is used. See “Rotate Plan View” on page 

163. 

Rotate with Plan also affects text in a 
view sent to layout if the layout box is 
rotated. See “CAD and Text in Layout” 
on page 868.

• Check Transparent to make text boxes 
using the selected Text Style transparent. 
When unchecked, text boxes have a solid 
fill the same color as your background 
color. See “Colors Panel” on page 63. 

Specify the selected Text Style’s Text 
Color. When Use Custom Text Style is 

not selected above, a Text Color does not 
display here for reference. 
• When  By Layer is checked, text uses the 

line color assigned to the layer that the 
object it is assigned to is located on. See 
“Displaying Objects” on page 102.  

• Uncheck By Layer, then click the Color 
bar to select a different color. See “Color 
Chooser Dialog” on page 652.

A preview of the Text Style currently 
assigned to the selected object displays 

here. 
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Chapter 32:

CAD Objects

With the 2D Computer Aided Design (CAD) 
tools included in Home Designer Pro, you 
can add details to views of your 3D model to 
create complete working drawings.

The CAD Tools are used to add information 
to 2D views of your model. CAD objects do 
not affect 3D objects or display in camera 
views or overviews, but they can be used to 
add details to layout pages, floor plan view 
and cross section/elevation views. 

CAD polylines can be converted to 3D 
objects such as countertops and terrain data, 
and shown in 3D views.  See “Convert 
Polyline” on page 165.

CAD objects are edited much like other 
objects in Home Designer Pro. See “Editing 
Objects” on page 119.

Chapter Contents
•      CAD Defaults and Preferences
•      The CAD Drawing Tools
•      Point Tools
•      Line Tools
•      Line Specification Dialog
•      Arc Tools
•      Drawing Arcs - Arc Creation Modes
•      Arc Specification Dialog
•      Circle Tools
•      CAD Circle/Oval/Ellipse Specification 

Dialog
•      Polylines
•      Polyline Specification Dialog
•      Box Tools
•      Box Specification Dialog
•      Splines
•      Displaying CAD Objects
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CAD Defaults and Preferences
CAD Defaults can be accessed by 
selecting Edit> Default Settings from 

the menu and expanding the CAD category.  

The behavior and appearance of CAD 
objects are also affected by settings on 

the CAD, Line Properties, Sun Angle, 

Behaviors, and Snap Properties Panels of the 
Preferences dialog. Unlike default settings, 
preference settings are global, affecting all 
plan and layout files. See “Preferences 
Dialog” on page 60.

CAD Defaults Dialog
The settings in the CAD Defaults 
dialog control the basic appearance of 

CAD objects. To open this dialog, select 
Edit> Default Settings from the menu and 
expanding the CAD category. It can also be 
opened by clicking the CAD Defaults 
button, which can be added to a toolbar See 
“To add a button to a toolbar” on page 94. 

Each plan file has multiple CAD Defaults 
dialogs: one affecting floor plan view and 
one for every cross section/elevation view. 
Layout files each have their own CAD 
defaults, as well. Each dialog can be 
accessed by opening the CAD Defaults 
dialog from within that view.

Specify whether to Display Line 
Length as either Fractional or 

Decimal Feet. This controls the appearance 
of line length indicators, which only display 
when Show Length is checked in an object’s 

specification dialog. See “Line Style Tab” on 
page 781.

Display Line Angles as - Specify the 
format to use when Show Angle is 

checked in an object’s specification dialog. 
See “Line Style Tab” on page 781.
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Line angles can be displayed using three 
basic methods: 
• Degrees/Minutes/Bearings - Measured 

counterclockwise from a line drawn hori-
zontally to the right of the angle’s vertex. 
Useful for most drawing tasks. Select the 
level of accuracy that you require.

• Quadrant Bearings - Measured from a 
vertical line representing North/ South, 
Quadrant Bearings use directional bear-
ings in their measurements. Useful for 
site drawings.

• Azimuth Bearings - Measured from a 
line drawn straight up from the angle’s 
vertex (ie, North on a site plan). Useful 
for site drawings, Azimuth Bearings use 
degrees, minutes, and seconds in their 
measurements.

Select any combination of the available 
Options.

• Check Show Arc Centers and Ends  
to show arc centers and ends. Ends dis-
play as small lines where arcs connect to 
one another. Centers also acts as snap 
points. See “Show Arc Centers” on page 
134. 

• Check Fill New Framing Members to 
draw all new framing members with a 
solid white fill. This settings is not view 
specific - it affects all new framing mem-
bers, regardless of the floor they are 
drawn on. 

• Check Use Line for Framing to show all 
framing members as single lines rather 
than as closed polylines in floor plan 
view. See “Displaying Framing” on page 
458. 

The CAD Drawing Tools
The CAD Tools are available in the 
CAD menu, and also in the CAD 

toolbar configuration, which can be accessed 
by clicking the CAD Configuration button. 
See “Toolbar Configurations” on page 98. 

Point Tools
Select CAD> Points to access the 
Point Tools.

Minutes + Seconds

Minutes

Degrees

Quadrant Bearing

Azimuth Bearing

Line length and angle indicators use
the Text Style of the layer that their

object is on. See “Text Styles” on page 765.

3

Show Arc Centers andEnds
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The Place Point , Input Point , Point 

Marker , and Delete Temporary 

Points  tools can be used to create or 
remove snap points for a variety of purposes. 
See “Point Tools” on page 772.

Line Tools
Select CAD> Line to access the Line 
Tools.

The Draw Line , Input Line , Line 

With Arrow , Sun Angle , and the 

North Pointer  allow you to create 
various types of lines. See “Line Tools” on 
page 776.

Arc Tools
Select CAD > Arcs to access the Arc 
Tools.

The Draw Arc , Input Arc , and the 

Arc With Arrow  tools allow you to 
create arcs. See “Arc Tools” on page 785.

Box Tools
Choose CAD > Boxes to access the 
Box Tools.

The Rectangular Polyline , Box , 

Cross Box , and Insulation  tools 
allow you to create a variety of polyline and 
box objects. See “Box Tools” on page 794. 

Circle Tools
Select CAD> Circles to access the 
Circle Tools.

The Circle , Circle About Center , 

Oval , and the Ellipse  tools are 
discussed in detail later in this chapter. See 
“Circle Tools” on page 788.

Splines
A Spline is a curve that passes 
smoothly through a set of points. 

Select CAD> CAD> Draw Spline to draw 
connected line segments that form a spline. 
See “Splines” on page 796.

Once created, a spline can be selected and 
edited. See “Editing Spline Based Objects” 
on page 144 and “Polyline Specification 
Dialog” on page 791.

Dimension Tools
Select CAD> Dimensions to access 
the Dimension Tools. The Dimension 

Tools can be used with CAD and 
architectural objects and are discussed in 
their own chapter. See “Dimensions” on page 
719.

Text Tools
Select CAD> Text to access the Text 
Tools. The Text Tools are discussed in 

their own chapter. See “Text, Callouts & 
Markers” on page 743. 

Point Tools
Select CAD> Points to access the Point Tools. 
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Temporary points created using the Place 

Point  and Input Point  tools and 

permanent Point Markers  can be used 

with Object Snaps  to accurately position 
a variety of objects. See “Object Snaps” on 
page 110. 

Place Point
Select CAD> Points> Place Point, 
then and click in the drawing area to 

place a temporary CAD point at that 
location. 

Input Point
Temporary CAD points can be placed 
with precision by entering 

coordinates. See “3D Drafting” on page 25.

To use the Input Point tool

1. Select CAD> Points> Input Point  
to open the New CAD Point dialog.

2. Select a Location option, and enter the 
desired location of the point. 

3. Click OK to close the dialog and create 
the new point. The new point becomes 
the Current Point and is highlighted. See 
“The Current Point” on page 774.

4. Alternatively, click Next to create the 
new point but remain in the New CAD 
Point dialog and create additional 
points. As each is created, it becomes 
the Current Point.

New CAD Point Dialog

The location of the Current Point 
displays here. If no CAD points are 

present, the origin (0, 0) displays. See “The 
Current Point” on page 774.

Begin by specifying how you want to 
define the location of the New Point.

• Absolute Location - Define the point in 
X Position (horizontal) and Y Position 
(vertical) coordinates, relative to (0,0).

• Relative to Current Point - Define the 
new point in X and Y coordinates that are 
relative to the Current Point, as though 
that point was at (0,0). Only available 
when a Current Point exists. 

• Check Polar to define the new point by 
its Distance and Angle from the Current 
Point rather than in X and Y coordinates. 
This is helpful when creating a plot plan. 
See “Plot Plans” on page 553.

The position of the New Point is 
defined here. The options available 

depend on the method chosen to define it.
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• X Position and Y Position coordinates 
relative to (0,0) are entered if the Abso-
lute Location method is specified.

• X Position and Y Position coordinates 
relative to the Current Point are entered if 
the Relative to Current Point method is 
specified.

• Distance and Angle from the Current 
Point are entered if the Relative to Cur-
rent Point: Polar method is specified.

• Click Next to create the new point with-
out exiting the dialog so you can input 
data for the next point. The newly created 
point becomes the Current Point.

Click Num Style to change the units 
shown in the New CAD Point dialog. 

See “Number Style/Angle Style Dialog” on 
page 89.

Point Markers
Use a permanent Point Marker as a 
snap point for dimension lines and 

other CAD objects. Select CAD> Points> 
Point Marker and click in the view to place 
a permanent point marker. Point markers 
display as a simple cross, with or without a 
text label. They can be opened for 
specification and modified to include a label 
or alter their attributes.

You can also place Point Markers using the 

Marker  tool, which lets you specify the 
marker label and type. See “Markers” on 
page 762.

Point Markers are also created when the 

Point to Point Dimension  tool is used. 

See “Point to Point Dimensions” on page 
730. 

Delete Temporary Points
All temporary points can be deleted at 
once using CAD> Points> Delete 

Temporary Points.

You can also press the Delete key when 
nothing is selected to delete the points one by 

one; however, Delete Temporary Points  
can save time when there are many points. 

The Current Point
In any plan view, there may be multiple tem-
porary CAD points created by the user and/or 
the program. The Current Point is either the 
most recently created or the most recently 
accessed temporary CAD point and is used 
for a variety of functions, such as: 
• As an anchor for snapping objects to a 

precise location.
• As the starting point for objects as they 

are drawn by entering data. See “Entering 
Coordinates” on page 113. 

• As the point about which objects are 
rotated. See “Rotating Objects” on page 
161. 

• To indicate the points at which roof 
planes can join. See “To find roof plane 
intersection points” on page 367. 

When multiple temporary points are on-
screen, the current CAD point is highlighted 
so it can be easily identified. 

4
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To delete the Current Point

1. Make sure no other objects are selected 

by clicking the Select Objects  but-
ton. You can also press the Esc key to 
deselect any selected objects. 

2. Press the Delete key on the keyboard to 
delete the Current Point. The temporary 
point created prior to this one becomes 
the new Current Point. 

3. If you continue pressing the Delete key, 
temporary points will be deleted in the 
reverse order that they were created.

Move Point Dialog
The Current Point can be repositioned 
relative to itself, another point, or a CAD 
object such as a line using the Move Point 
dialog.

For example, you can locate the point exactly 
one-quarter the distance along a given line, 
or exactly 6 inches from one end. This new 
location can then be used for the start point 
of a new line or other purpose.

To reposition a temporary point, double-click 
the point you want to move using the Select 

Objects  tool. Doing so makes that point 
the Current Point and also opens the Move 
Point dialog. 

The Current Location of the selected 
point displays here for reference. 

Begin by specifying how you want to 
define the New Location of the point.

• Absolute Location - Define the new 
location in X (horizontal) and Y (vertical) 
coordinates, relative to (0,0).

• Relative to Itself - Define the new loca-
tion in X Position and Y Position coordi-
nates relative to the current location, as 
though that point was at (0,0).  

• Relative to Prev. Point - Define the new 
location relative to the point that was the 
Current Point prior to this one, as though 
that point was at (0,0).  

Check Polar to define the new location’s 

Current 
Point

There can only be one Current Point
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Distance and Angle from the previous 
point instead of using X and Y coordi-
nates. 

• From Line End - Define the new loca-
tion along the edge of a nearby CAD 
object. This option is enabled only when 
the point is located on a CAD object and 
refers to the edge nearest to the point’s 
original location. When selected, the 
Along Line field becomes available, 
below.

Check Percentage (%) to specify the 
Along Line value as a percentage of the 
total line or arc length rather than as a 
distance. 0% moves the point to the clos-
est end of the nearest edge, 50% to the 
midpoint, and 100% to the other end. 
Negative numbers and percentages 
greater than 100 are allowed. 

If the point is near an arc, Along Line is 
measured along the curve.

If the point is near a box or polyline, Along 
Line is measured along the nearest side just 
as it does with an individual line or arc. 

If the point is near an oval or circle, Along 
Line is measured along an (invisible) axis 
line that the item was originally drawn along.

Specify the new position of the point 
here. The information used to define it 

depends on the method chosen to define the 
New Location.
• X Position and Y Position coordinates 

are entered if the Absolute Location 
method is specified or if either Relative 
method is used with Polar unchecked.

• Distance and Angle are entered if either 
Relative method is specified when Polar  
is checked.

• Along Line - When the From Line End 
method is used, specify the distance from 
the new location of the point along the 
nearest edge of the CAD object to the end 
it was originally closest to. When Per-
centage (%) is checked, enter this value 
as a percentage instead.

Click Num Style to change the units 
shown in the New CAD Point dialog. 

See “Number Style/Angle Style Dialog” on 
page 89.

Line Tools
Select CAD> Draw Lines to display 
the Line Tools.

If Object Snaps  is enabled and Edit 

Object Parts  is disabled, you can 
connect the ends of two lines and/or arcs to 
form a single entity called a polyline. See 
“Polylines” on page 790. 

Draw Line
Select CAD> Lines> Draw Line, 
then click and drag from beginning to 

end. 

3
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If you double-click the Draw Line tool,
the Input Line dialog will open. 
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Input Line
CAD lines can also be created using 
absolute values entered with the 

keyboard by selecting CAD> Lines> Input 
Line. This method is slower but more precise 
than using the mouse and is ideal when the 
desired length and angle of each line is 
known, such as with property lines.

Before any line is drawn using this method, a 
starting point must be defined. If a starting 
point has not been defined, Home Designer 
Pro assumes a starting point of 0,0.

To use the Input Line tool

1. Select CAD> Points> Place Point , 
then click the screen to place a CAD 
point. This is the Current Point, and is 
the start point for the new line. See “The 
Current Point” on page 774.

2. Select CAD> Lines> Input Line  to 
open the New CAD Line dialog. 
The New CAD Line dialog can also be 

opened by double-clicking the Line 

Tools  parent button. 
3. If necessary, specify the start point.
4. Specify the method used to define the 

location of the End Point. 
5. Click OK to close the dialog and draw 

the line, or click Next to draw the line 
but remain in the New CAD Line dialog 
and draw additional lines.

New CAD Line Dialog

The X Position (horizontal) and Y 
Position (vertical) coordinates of the 

start point for the new line display here. They 
can also be changed, if you wish.

Begin by specifying how you want to 
define the line End Point Location.

• Absolute Location - Define the end 
point of the new line in X Position (hori-
zontal) and Y Position (vertical) coordi-
nates, relative to (0,0).

• Relative to Start Point - Define the end 
point of the new line in X and Y coordi-
nates that are relative to the line’s Start 
Point, as though it were at (0,0).

• Check Polar to define the End Point of 
the new line by its Distance and Angle 
from the Start Point rather than in X and 
Y coordinates. This is helpful when cre-
ating a plot plan. See “Plot Plans” on 
page 553.

• Relative to Previous Line - Define the 
End Point of the new line by its Distance 

Note: If you accidentally click OK instead of
Next and need to continue drawing a polyline
using the New CAD Line dialog, select the
Input Line tool again and continue.
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and Angle relative to the end of the last 
line drawn, as though that line’s angle 
were at 0° and its End Point, at  (0,0). 

The new line’s End Point is defined 
here. The information used to define it 

depends on the method chosen to define the 
End Point Location.
• X Position (horizontal) and Y Position 

(vertical) coordinates relative to (0,0) are 
entered if the Absolute Location method 
is specified.

• X Position (horizontal) and Y Position 
(vertical) coordinates relative to the start 
point are entered if the Relative to Start 
Point method is specified.

• Distance and Angle from the start point 
are entered if the Relative to Start Point: 
Polar method is specified.

• Distance and Angle from the start point 
are entered if the Relative to Previous 
Line method is specified.

• Click Next to create the line without exit-
ing the dialog so you can input data for 
the next line. The start point of the next 
line is the end point of this line.

Click Num Style to change the units 
shown in this and other dialogs. See 

“Number Style/Angle Style Dialog” on page 
89.

Enter Coordinates
Similar to Input Line, lines can also be 
specified by pressing the Tab key on the 
keyboard when a line is in the process of 
being drawn. This opens the Enter 
Coordinates dialog. See “Entering 
Coordinates” on page 113.

Line With Arrow
Create a line or polyline with an arrow 
on one or both ends by selecting 

CAD> Lines> Line With Arrow, then 
clicking and dragging on screen. The initial 
attributes of the line’s arrow are set in the 
Arrow Defaults dialog. See “Arrow 
Defaults” on page 744. 

As with lines, lines with arrows can 
connected to form polylines and can be 
edited after they are created. See “Editing 
Line Based Objects” on page 127 and “Line 
Specification Dialog” on page 780.

You can also create arcs with arrowheads. 
See “Arc with Arrow” on page 786.

If a line or arc with arrow is snapped to 
another object such as text and that object is 
deleted, the line or arc with arrow will be 
deleted, as well.

North Pointer
The North Pointer defines the 
direction of true north in a plan. The 

direction of north does not affect the 
orientation of the Snap and Reference grids, 
but it does determine the direction of bearing 
information as well as how shadows and 
conditioned area totals are calculated. 

If a North Pointer  is not used, north is 
assumed to be straight up on screen in floor 
plan view. 

3

4

Every bearing is defined relative to
North, so establish this direction before

entering survey information for plot layout or
for bearings to establish polar direction for
the creation or editing of objects such as
points, lines, arcs, etc.
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Select CAD> North Pointer , then click 
and drag to draw the pointer, starting at the 
tail and dragging toward the point. Once it is 
drawn, you can define its exact length and 
angle in the Line Specification dialog. See 
“Line Specification Dialog” on page 780.

When a North Pointer is placed on one floor 
of a plan, a North Pointer drawn on any other 
floor automatically points in the same 
direction. If the direction of the North 
Pointer is reset on any floor, those on all 
other floors automatically reset, as well.

To enter the angle in bearings

1. First, type N or S (for North or South).
2. Next, type the degrees (followed by d), 

then the minutes (followed by '), then 
the seconds (followed by ").

3. Finally, type either E or W (for East or 
West).  

If minutes are zero, you do not need to enter 
a value. Following are some examples of 
bearings. It is not necessary to capitalize the 
letters. Spaces are also optional. 
• N 20d 30' E
• S 45' W
• N 89d 48' 30" W
• N 90' E

If you choose to display line angles when a 
North Pointer exists, be sure to select the 
appropriate format in the CAD Defaults 
dialog. See “CAD Defaults and Preferences” 
on page 770.
• If angles are set to Bearings, they are rel-

ative to the North Pointer. 

• If angles are set to show as Degrees, the 
angle relates to 0 degrees (horizontal to 
the right) even if a North Pointer is pres-
ent.  

North Pointers can be selected and edited 
using their edit handles and the edit toolbar 
buttons. All attributes of the N aside from its 
size are drawn from the Text Style assigned 
to the “CAD, Default” layer. For more 
information, see “Editing Line Based 
Objects” on page 127. 

Sun Angle
In floor plan view, you can create 
multiple Sun Angles. Select CAD> 

Line angle shown in degrees. This 
does not reference the North Pointer. 

The same line angle is set to show 
Bearings. This shows the angle in 
reference to the North Pointer.
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Lines> Sun Angle, then click in floor plan 
view. For each Sun Angle you place, specify 
time of year, time of day, and a location 
based on longitude and latitude.

Sun Angles affect the angle of the Default 
Sun Light. If a North Pointer is present, the 

Sun Angle will be accurate relative it. See 
“Sun Angles” on page 701. 

Sun Angles can be moved and extended 
using the edit handles, but cannot be rotated.

Line Specification Dialog
Select a CAD Line, Line With Arrow, 
or Text Line With Arrow and click the 

Open Object edit button to open the Line 
Specification dialog. 

The settings on the Line, Line Style, and 
Arrow tabs in this dialog are found in the 
specification dialogs for a variety of different 
objects in the program.

Line Tab
The information on the Line tab of the Line 
Specification dialog  is similar to that found 

on the Selected Line tabs of various 
specification dialogs in the program.

Lock - These lock options control how 
changing properties on this dialog 

affect the line.

Start - Select this option to keep the start of 
the line fixed when changing the length, 
angle, and end.

End- Select this option to keep the end of the 
line fixed when changing the length, angle, 
and start.

Center- Select this option to keep the center 
of the line fixed. Changing the length of the 
line moves the start and end of the line 
equally. Changing the angle rotates the line 
around the center.
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Select Length/Angle to keep the length and 
angle of the line segment fixed. Moving the 
start or end moves the other end so the length 
and angle of the line do not change.

Specify the Length and Angle of the 
selected line.

Specify the X and Y coordinate for the 
Start of the line.

Specify the X and Y coordinate for the 
End of the line.

The format used here can be changed by 
clicking the Num Style button. See “Number 
Style/Angle Style Dialog” on page 89.

Line Style Tab
The Line Style tab is found in the 
specification dialogs for many different 
objects. Here you can control the display of a 

CAD line(s) and/or arc(s) that make up an 
object.

Specify the Line Color used to show 
the selected object.

• Check By Layer to use the line color 
assigned to this layer.

• Click the color bar to assign a line color 
to the selected object(s). See  “Color 
Chooser Dialog” on page 652.

Specify the Line Style used to show the 
selected object.

• Check By Layer to use the line style 
assigned to this layer.

• Click the drop-down list to select from all 
available line styles. You can use the key-
board arrow keys to scroll up and down 
through the options.

Define the Line Weight (in pixels).  

Check By Layer to use the Line Weight 
assigned to the specified layer. 
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The Drawing Group options control 
how the selected object(s) display 

relative to other objects. Not available for 
Walkthrough Paths. See “Drawing Groups” 
on page 150. 
• Select Back Group to display the 

selected object(s) behind objects in the 
other two drawing groups.

• Select Default Group to display the 
selected object(s) in front of those in the 
Back Group but behind those in the Front 
Group.

• Select Front Group to display the 
selected object(s) in front of objects in 
the other two groups. 

• Check Move to Front of Group to dis-
play the selected object(s) in front of 
other objects in the same drawing group. 

You can also move a selected object to 
the front of its drawing group by clicking 

the Move to Front of Group  edit 
button. See “Move to Front of Group” on 
page 151.

Specify the desired Bumping behaviors 
for the selected object(s). 

• Check CAD Stops Move to bump the 
selected object into other CAD or CAD-
based objects as it is moved, and/or to 
push the other object(s). 

• Check Wall Stops Move to stop the 
selected object when it bumps into a wall. 
Walls cannot be pushed by other objects. 

CAD Stops Move and Wall Stops Move 
only function when Bumping/Pushing is 
enabled. See “Bumping/Pushing” on page 
152. 

Select the desired Display Options. 
These options not available for CAD 

Box- or CAD Circle-based objects, or for 
North Pointers or Sun Angles.
• Check Show Length to show the length 

of each line centered above the line. This 
option is available with line and arc seg-
ments and is commonly used for property 
lines. The length format for Imperial 
units (fractional or decimal feet) is 
defined in the CAD Defaults dialog. See 
“CAD Defaults Dialog” on page 770.

• Check Show Angle to show the angle of 
each line centered below the line and 
enable the two options that follow. The 
angle format (degrees or bearings) is 
defined in the CAD Defaults dialog. 

• Uncheck All Angles to show only those 
angles that are neither horizontal nor ver-
tical. This is automatically checked when 
Show Angle is checked. 

• Check Reverse Angle to reverse the 
angle by 180°. This may be helpful when 
showing a line’s bearing, since the direc-
tion a line is drawn from start point to end 
point defines its bearing.

Setting the line weight to zero (0)
makes the line weight print as thin as

possible.

Note: “Move to Front of Group” is an action,
not an attribute. The box is not checked the
next time the specification dialog is opened.

4
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Arrow Tab
The Arrow Tab is available for any line, arc, 
open polyline, or spline that can have an 
arrow.

Closed polylines, Sprinkler Lines and 
Electrical connections are examples of 
objects that cannot have arrows.

Check Include Arrow to turn the 
arrows on or off. 

Select an arrowhead Type from the 
drop-down list. 

If multiple arrows are selected, and they have 
more than one arrowhead type, check No 
Change to keep the defined arrow type for 
each arrow.

Check Default to set the arrow type to the 
default specified on the Arrow tab of the Text 
Defaults dialog. See “Text Defaults and 
Preferences” on page 744.

Select the Fill Color used to fill the 
arrowheads. 

If multiple arrows are selected and they have 
more than one fill color, check No Change to 
keep the defined Fill Color for each arrow.

Check Default to use the default fill color.

Define a Size for the arrow(s). 

Check Default to use the default size.

Select from the available Options.

Check Arrow on Both Ends to place a 
head on both ends of the selected arrow(s).

Auto Position Tail and Auto Position Head 
are available when either end of the line is 
attached to a text object. Check either or both 
options if you want this text line with arrow 
to update its position on the text object if the 
text object or text line with arrow is moved. 
See “Auto Positioning Arrows” on page 758.
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Drawing Arcs - Arc Creation Modes
There are two Arc Creation Modes 
that control how arcs and arc-based 

objects are drawn. Select Edit> Arc 
Creation Modes to select a mode.

The program remembers the last creation 
mode used between sessions. Once drawn, 
all arcs are edited similarly. See “Editing Arc 
Based Objects” on page 130.

Before deciding which Arc Tool or Arc 
Creation Mode is best for the project at hand, 
it is helpful to be familiar with the different 
components that make up an arc.

• The center of an arc is the point the arc is 
drawn about.

• The radius is the distance from the center 
to the arc.

• The start is where the arc begins.
• The end is where the arc stops.
• The chord is the straight line between the 

start and end point.
• A straight line that intersects an arc and is 

perpendicular to the radius of the arc at 
that point is tangent to the arc.

Free Form Arc
Free Form Arc mode allows you to 
define an arc by clicking and dragging 

along the desired path. There are two 
methods for using this mode.

To draw a Free Form arc

1. Select CAD> Arcs> Draw Arc , 
then click at the arc’s start point. 

2. Move the pointer along the desired 
curve while dragging to curve the arc.

3. Release the mouse button at the end 
point to complete the arc. 

Arc About Center
Arc About Center mode allows you to 
draw an arc by defining the center and 

then the start and end points. 

To draw an Arc About Center 

1. Select CAD> Arcs> Draw Arc , 
then click once to define the center 
point. 

2. Click and drag from the start point of the 
arc to its end point.

3. Or, click and drag an arc. The Current 
Point is used as the center. See “The 
Current Point” on page 774.

CenterRadius

ChordStart

End
Tangent



Arc Tools

 785

Arc Tools
Select CAD> Arcs to display the 
submenu of Arc Tools.

Draw Arc
The method used to draw an arc using 
Draw Arc depends on which Arc 

Creation Mode is currently active. Once 
drawn, an arc can be edited. See “Editing Arc 
Based Objects” on page 130.

Input Arc
An arc can be drawn to exact 
specifications using the New CAD Arc 

dialog. 

To use the Input Arc feature

1. Define a start point by clicking the 

screen using the Place Point  tool. 
The “X” defines the current point, which 
is the start point for the new arc.

2. With the start point defined, select 

CAD> Arcs> Input Arc  to open the 
New CAD Arc dialog. Define the arc 
endpoint, curvature, and direction.

3. Select either the Start Direction or the 
Chord Direction. 

•  The Start Direction defines the angle 
of the tangent from the arc’s start point. 

•  The Chord Direction defines the angle 
of the arc’s chord from the start point.

4. Define the Radius of the arc. 
5. The Extension settings control the 

length of the arc. Define only one: 
•  Arc Angle - The angle defined by 

imaginary lines drawn from the arc 
centerpoint to its two endpoints. 

Start Direction = 0° Chord Direction = 45°
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•  Arc Length - The length of the arc 
itself from one endpoint to the other.

•  Chord Length - The length of an 
imaginary straight line drawn from one 
arc endpoint to the other.

6. Select the direction the arc bends, either 
cw (clockwise) or ccw (counter 
clockwise).

7. Click OK to draw the specified arc.

Click the Num Style button to display the 
Number Style / Angle Style dialog. See 
“Number Style/Angle Style Dialog” on page 
89.

Arc with Arrow
You can create an arc with an arrow on 
one or both ends, using the Arc With 

Arrow tool.

Draw an Arc With Arrow  like a regular 
arc. When you release the mouse button,  the 
arc has an arrowhead at the end. The default 
attributes of the arrow are determined by the 
settings in the  Arrow Defaults dialog. See 
“Arrow Defaults” on page 744. 

As with regular arcs, arcs with arrows can be 
edited after they are created. See “Editing 
Arc Based Objects” on page 130 and “Arc 
Specification Dialog” on page 786.

Continue to draw connected lines and arcs to 
form a polyline with an arrowhead at the end. 
The arrowheads display only at the free ends, 
not where the lines connect. See “Polylines” 
on page 790.

Lines with arrowheads can also be created. 
See “Line With Arrow” on page 778.

Arc Specification Dialog
Select an arc and click the Open 
Object edit button to open the Arc 

Specification dialog.

Arc Angle = -90°

Chord Length = 
282 13/16

Arc Length = 314 3/16

Radius = 200

A line can be converted to an arc or vice
versa by selecting the line, pressing

and holding down the Alt key, then using the
edit handle at either end to bend the line.
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Arc Tab
The settings on the Arc tab are also found on 
the Selected Arc tabs for many objects.

The Lock options control how 
changing properties on this dialog 

affects the arc. 
• Start - Select this option to keep the start 

fixed when changing the arc, chord, or 
end.

• End - Select this option to keep the end 
fixed when changing the arc, chord, or 
start.

• Center - Select this option to keep the 
center of the arc fixed when changing the 
arc.

• Arc - Select this option to keep the arc 
fixed when changing the arc location.

• Chord - Select this option to keep the arc 
chord fixed when changing the arc 
radius.

Arc - These parameters define the arc. 
Various controls are disabled depending 

on what lock option is used.
• Center X - Specify the X coordinate for 

the center of the arc.
• Center Y - Specify the Y coordinate for 

the center of the arc.
• Radius - The distance between the center 

of the arc and the arc surface.

• Start Angle - Specify the angle that a line 
drawn from the arc center to the arc start 
makes with a horizontal line to the right.

1
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• End Angle - Specify the angle that a line 
drawn from the arc center to the arc end 
makes with a horizontal line to the right.

• Arc Angle - The angle between the cen-
ter of the arc and each end.

• Arc Length - The length of the arc along 
the curve.

Start - These values define the start 
point of the arc.

• Start X - Specify the X coordinate for the 
beginning of the arc.

• Start Y - Specify the Y coordinate for the 
beginning of the arc.

• Start Direction - Specify the angle of a 
tangent line at the start of the arc.

End - These values define the end point 
of the arc.

• End X - Specify the X coordinate for the 
end of the arc.

• End Y - Specify the Y coordinate for the 
end of the arc.

• End Direction - Specify the angle of a 
tangent line at the end of the arc.

Chord - These values define the chord 
of the arc.

• Chord Length - The straight line dis-
tance between the two ends of the arc.

• Chord Angle - Specify the angle of the 
chord (the imaginary straight line going 
from the start of the arc to the end of the 
arc).

Line Style Tab
For information about the Line Style tab, see 
“Line Style Tab” on page 781.

Arrow Tab
For information about the Arrow tab, see 
“Arrow Tab” on page 783.

Circle Tools
Select CAD> Circles to access the 
Circle Tools.

Draw a Circle by dragging across the 
diameter. If a small circle is needed, 

draw a larger circle and then resize it. 

3
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Use the Circle Specification dialog to 
accurately define size, position and other 
attributes. See “CAD Circle/Oval/Ellipse 
Specification Dialog” on page 789.

Draw Circle About Center
Select CAD> Circles>  Circle About 
Center to create a circle by dragging 

the radius out from the center point. 

To draw a Circle About Center

1. Click the Circle About Center  tool.
2. Click the screen to define the center.
3. Drag the radial distance and release the 

mouse button. If you are using Object 

Snaps , both the center point and the 
radius snap to any appropriate nearby 
CAD object, intersection or point.

Ovals
An Oval is a four-arc approximation 
of an ellipse. To draw an oval, select 

CAD> Circles> Oval, then click and drag. 

Use the CAD Oval Specification dialog to 
accurately set the length and width of the 
oval and other attributes.

Ellipses
An Ellipse is a set of points with a 
constant combined distance from two 

points called foci. An ellipse looks like a 
stretched circle, or a circular surface viewed 
at an angle. 

To draw an ellipse, select CAD> Circles> 

Ellipse  and drag at an angle to define its 
maximum height and width.

Use the CAD Ellipse Specification dialog to 
accurately set the length and width of the 
ellipse and other attributes. 

CAD Circle/Oval/Ellipse Specification Dialog
Select a circle, oval or ellipse and 
click the Open Object edit button to 

open the CAD Circle, Oval or Ellipse 
Specification dialog.

The CAD Circle, Oval and Ellipse 
Specification dialogs are almost exactly the 
same. The Oval and Ellipse Specification 
dialogs have an additional setting for Angle 
on the General tab.
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General Tab

Specify the Position of the circle, oval 
or ellipse. 

• Specify the X Position and Y Position of 
the center of the circle, oval or ellipse.

• Specify an oval or ellipse’s Angle. Not 
available for circles. 

Specify the Length and Width of an 
oval or ellipse, or the Diameter and 

Radius of a circle.

Line Style Tab
For information about the Line Style tab, see 
“Line Style Tab” on page 781.

Fill Style Tab
For information about the Fill Style tab, see 
“Fill Style Tab” on page 792.

Polylines
A polyline consists of two or more 
line and/or arc segments that are 

attached at their endpoints. Select CAD> 
Boxes> Rectangular Polyline, then click 
and drag from corner to corner to create a 
rectangular-shaped, closed polyline.

When Object Snaps  is enabled and Edit 

Object Parts  is disabled, you can also 
create a polyline by drawing lines and/or arcs 
end-to-end, allowing the end of each new 

object to snap to the end of the previous one. 
Line- and arc-based objects will only snap 
together to form a polyline if they are on the 
same layer and share identical attributes such 
as color, line style, and arrow specifications.

If one end of the polyline is connected to the 
other, it becomes a closed polyline. Closed 
polylines can be assigned a fill pattern and/or 
turned into special 3D objects such as slabs 
or countertops that display in 3D views. 
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Lines and polylines can be distinguished by 
the edit handles that display when you select 
each. A line displays an edit handle at each 
end and one in the middle. If more than three 
edit handles display, the object is a polyline.

Lines that appear connected to a polyline 
may prove to be unconnected when selected. 

For example, the two polylines in the 
following image appear identical until their 
left edges are selected. The polyline on the 
left reveals that its left edge is not attached. 
In contrast, the left edge of the polyline on 
the right is part of the larger polyline unit.

The Close Polyline  edit tool can be used 
to connect the edges of an open polyline. 
This tool adds a segment between the two 
open ends, closing the gap between them. 
See “Using Close Polyline” on page 138.

Polylines can be copied, moved, reshaped, or 
resized as a single unit. Additionally, the 
individual segments can be edited. See “Edit 
Object Parts” on page 125.

Once created, polylines can be edited in a 
variety of ways. See “Editing Open Polyline 
Based Objects” on page 134 and “Editing 
Closed-Polyline Based Objects” on page 
138.

Polyline Specification Dialog
Select an open polyline, closed 
polyline, spline, Sprinker polyline or 

Electrical connection and click the Open 

Object edit button to open the Polyline 
Specification dialog. 

Closed Polylines Open Polylines

Line

Polyline

Unconnected Connected
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Polyline Tab
The Polyline tab is found in the specification 
dialog for open- and closed-polyline-based 
objects throughout the program.

The Polyline tab indicates the polyline’s 
Length/Perimeter, its enclosed Area, and 
the Volume of a closed polyline.

If the polyline is not closed, the Area and 
Volume are described as “Not closed”. The 
Volume of a 2D polyline will always be 0, 
even if it is closed.  

Spline Tab
The Spline tab has a single option and is only 
available when the selected object is a spline.  
See “Splines” on page 796. 

New Segment Angle - Specify the angle 
between line segments that are used to draw 

the spline. Specifying a smaller angle makes 
the spline smoother. Specify a larger angle to 
draw the spline faster.

Selected Line Tab
The Selected Line tab is available when the 
selected edge of the polyline is a line as 
opposed to an arc. This tab is not available if 
the selected object is a spline. See “Editing 
Line Based Objects” on page 127.

Moving the Start of a line segment moves the 
end of the previous connected line, if there is 
one. Similarly, moving the End of a line 
segment moves the start of the next 
connected line, if there is one. 

This tab is similar to the Line tab of the Line 
Specification dialog. See “Line Tab” on 
page 780.

Selected Arc Tab
The Selected Arc tab is available when the 
selected segment of the polyline is an arc as 
opposed to a line. This tab is not available if 
the selected object is a spline. 

This tab is similar to the Arc tab of the Arc 
Specification dialog. See “Arc Tab” on page 
787.

Line Style Tab
This tab is similar to the Line Style tab in the 
Line Specification dialog. See “Line Style 
Tab” on page 781.

Fill Style Tab
The information on the Fill Style tab for 
polylines is similar to that for many other 
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objects in the program, including closed 
CAD shapes and a variety of architectural 
objects. 

The Fill Style tab is not available for 
Sprinkler Lines or Electrical Connections as 
these tools cannot be used to form closed 
shapes. 

Fill Pattern - Choose a fill pattern from 
the drop-down list. If the Custom 

pattern is selected, the Custom Pattern 
options become available below.

The options that follow are disabled until you 
select a pattern other than None from the Fill 
Pattern drop-down list.

Define the Spacing of the selected fill 
pattern. Hatch spacing set at 12" 

matches grid/reference spacing set at 12".

Define the Angle of the selected fill 
pattern.

Set the Line Weight for the selected fill 
pattern.

Check Transparent Fill to make the 
fill pattern transparent. When you 

check this option, any objects behind the fill 
pattern are visible through it. 

 Fill Color - Select a line color for the 
fill pattern, or fill color if a solid fill is 

specified. The layer color is used by default. 
See “Color Chooser Dialog” on page 652.

Select Use Background Color to use 
the background color for solid fills or 

patterns.

Check Use Layer Color to have the fill 
pattern use the layer color for the 

pattern lines. If it is a solid fill, the fill color 
is the same as the layer’s color.

The Custom Pattern File section is 
only enabled when “Custom” is 

selected from the Fill Pattern list.
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• Click the Browse button to open the 
Custom Pattern File dialog and select a 
pattern (.pat) file from the Home 
Designer Pro Patterns directory or a cus-
tom .pat file elsewhere on your com-
puter. The selected .pat file’s path name 
displays and can be edited in the text 
field.

• Select a Pattern from the drop-down list. 
This list includes all custom patterns 
available in the selected file.

• Specify a Scale for the selected Custom 
pattern. This setting affects all instances 
of the pattern in the current plan or layout 
file - not just in the selected object(s).

A preview of the selected pattern 
displays here. As changes are made to 

the settings on this tab, the preview will 
update.

Choose a Preview Width from the 
drop-down list. This value controls how 

large an area the preview represents. The 
selected value indicates the length of each 
side of the preview in actual plan inches 
(mm).

Arrow Tab
The Arrow tab is available for most open 
polylines and splines and is similar to the 
Arrow tab of the Line Specification dialog. 
See “Arrow Tab” on page 783. 

The Arrow tab is not available for closed 
polylines, Sprinkler Lines or Electrical 
Connections. 

Box Tools
Select CAD> Boxes to access the Box 
Tools.

Rectangular Polyline
A Rectangular Polyline can be drawn 
in either of two ways:

• Click in the drawing area to place a 24” x 
24” square polyline at that location.

• Click and drag from corner to corner to 
draw a rectangle of any size. 

Once created, a rectangular polyline can be 
edited into any shape or converted to a 3D 
object. See “Editing Closed-Polyline Based 
Objects” on page 138.

Box
Draw a 2D box from the midpoint of 
one side to the midpoint of the 

opposite side. The sides of a box can be 
resized, but a box always has four 90° 
corners.

Boxes have some unique editing behaviors. 
See “Editing Box-Based Objects” on page 
141.

Cross Box
The Cross Box behaves the same as a 
box. The only difference is the cross 

that is automatically drawn whenever this 
tool is used. Use the Cross Box to add 2D 
framing details to cross section views.

10

11
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Cross boxes are automatically maintained at 
ends of framing members cut by a cross 
section cutting plane. They automatically 
update when the cross section is first created 

and whenever you click Fill Window .

You may want to create and resize one cross 
box for each framing member size used, such 
as 2x4, 2x6, 2x12, then copy and paste the 
original as needed. It is easiest to resize using 
Box Specification dialog.

Insulation
Use the Insulation tool to draw 
insulation in cross section details. 

Drag the length of the insulated area, then 
select the object and use the edit handles to 
move or resize it. It may be easier to use the 
Box Specification dialog to define the 
insulation width and length exactly.

Box Specification Dialog
Select a CAD box, a framing box, a 
cross box, or insulation and click the 

Open Object edit button to open the Box 

Specification dialog. See “Box Tools” on 
page 794.

Drag to 
create

Result Select 
to edit
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General Tab

Specify a Box Style. Select Normal to 
specify a normal box, Cross to specify 

a cross box, or Insulation to specify an 
insulation box. If multiple CAD boxes are 
selected, “No Change” may display. 

Define the Position of the box. 

• Specify the X Position and Y Position of 
the center of the box.

• Specify the Angle of the box.

Define the Size of the box by 
specifying its Height and Width.

Line Style Tab
For information about the Line Style tab, see 
“Line Tab” on page 780.

Fill Style Tab
For information about the Fill Style tab, see 
“Fill Style Tab” on page 792.

Splines
A Spline is a curve that passes 
smoothly through a set of points. 

Splines are typically used in situations where 
there is an irregular curve. A contour line is a 

typical example. Splines are useful wherever 
a free-flowing curve is needed.

Once created, splines can be selected and 
edited. See “Editing Spline Based Objects” 
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To find out which direction is the height
and which is the width of a square box,

select it. The triangular rotate handle is near-
est the side you originally dragged from when
creating the box. Changing the height
changes the length of this side.
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on page 144 and “Polyline Specification 
Dialog” on page 791.

To use the Spline tool

1. Select CAD> Spline .
2. Draw the first spline segment just as you 

would a line. A single spline segment 
looks identical to a line. You may need 

to turn off Angle Snaps  to draw 
freely.

3. Draw the second segment from the end 
of the first at a different angle. Object 

Snaps  should be on to assure that 
new segments attach correctly to the 
ends of previous segments.

4. As soon as two straight spline segments 
connect end-to-end, the straight seg-
ments become a curve that passes 
through the endpoints defined by the 
original segments. Each point is called a 
vertex. 

5. Draw a few more segments, connecting 
each to the free end of a previously 
drawn segment.

6. Notice as additional segments are drawn 
that the spline changes the curvature of 
the previous segment to create a contin-
uous curve between the last three points.

7. Form a closed spline by drawing a seg-
ment between its two free ends.

8. The result is an irregular curve that 
flows smoothly through each vertex.

Spline-based objects will only snap together 
to form a single spline if they are on the same 

As drawn

Result

As drawn

Result

As drawn

Result

Draw segment to close

Result
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layer and share identical attributes such as 
color, line style, and arrow specifications.

Displaying CAD Objects
As with architectural objects, the display of 
CAD objects is controlled in the Layer 
Display Options dialog. See “Layer Display 
Options Dialog” on page 104.

CAD objects can be drawn in floor plan 
view, layout, and cross section/elevation 
views. They are 2D objects only, though, so 
they cannot be seen in any view other than 
the one they are drawn in and are never 
visible in camera views or overviews. See 
“Architectural vs CAD Objects” on page 
108.

Show Length and Angle
You can specify that line segment length and 
angle display along a CAD line, CAD arc, or 
along each segment of a CAD polyline. If the 

segment is an arc, its radius also displays. 
See “Line Style Tab” on page 781.

The format of the length and angle can be 
specified in the CAD Defaults dialog. See 
“CAD Defaults Dialog” on page 770.

Line length and angle indicators use the Text 
Style assigned to the layer that their CAD 
object is on. See “Text Styles” on page 765. 

Endcaps
Dashed lines often display endcaps, which 
are dashes of a particular length. You can 
specify the Printed Length of endcaps in the 
Preferences dialog. See “Line Properties 
Panel” on page 75.
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Chapter 33:

Project Management

The tools described in this chapter let you 
draw plans with ease and flexibility, run 
checks on plans so you can be more 
confident that they are free of code violations 
and common drawing errors, and consider 
loan calculations for your projects.

Chapter Contents
•      House Wizard
•      Plan Check
•      Loan Calculator

House Wizard
The House Wizard is a time-saving 
feature used to create a preliminary 

room-by-room design of a home without 
getting caught up in the details. Once the 
shape and layout of the rooms are finalized, 
the House Wizard converts them into a 
working plan that can be edited and detailed 
to completion.

Start House Wizard
Select Tools> House Wizard> Start 
House Wizard. The House Wizard 

leads you through a series of windows that 
gather information about the rooms you want 
to include in your house. When you click 

Finish and close the House Wizard, the 
selected room boxes display.



800

Home Designer Pro 2014 Reference Manual

Room boxes can now be arranged into a floor 
plan. 

Placing Room Boxes
In addition or as an alternative to the room 
boxes created for you by the House Wizard, 
you can create your own room boxes. To do 

so, select Tools> House Wizard , then 
choose the desired room type from the 
submenu. Click in floor plan view to place a 
room box of the selected type at that 
location. 

Displaying Room Boxes
Room boxes and their labels are located on 
the “House Wizard Room Boxes” layer. 
Room box labels use the Text Style assigned 
to that layer, as well. See “Displaying 
Objects” on page 102. 

Editing Rooms
Once created, room boxes can be edited in a 
variety of ways.

• Select room boxes using the Select 

Objects  tool just like other objects in 
Home Designer Pro. See “Selecting 
Objects” on page 124.

• Room boxes can be resized, rotated, and 
rearranged. See “Editing Box-Based 
Objects” on page 141.

• Try to line up the rooms so that they are 
just touching. Excessive overlaps may 
cause your rooms to form incorrectly. 
Closets are the exception. You can over-
lap a room with a closet, or place in 
inside another room box.

• Rooms can be copied and pasted using 

the Copy/Paste  edit button and 

deleted using the Delete  edit button.

• Select Tools> House Wizard  or click 

the Space Planning Configuration  
button to access the room box tools and 
place additional room boxes in your plan. 
Select a tool and click in the plan to place 
a room box of that type. 

• Select Tools> House Wizard> Hide 

Room Boxes  or click the toggle but-
ton to hide or show the room boxes.

Build House
When the rooms are in place, select Tools> 

House Wizard> Build House  to convert 
the rooms into a building model. Walls and 
doors are inserted between the rooms that 
you arranged. 
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When you Build House, the “House Wizard 
Room Boxes” layer is automatically turned 
off. The room boxes that you created are not 
deleted, however. 

Multiple Floors
If you specified a two-story house, follow 
these steps:

1. Edit and arrange the room boxes on 
Floor 1 as desired.

2. Select Tools> House Wizard> Build 

House  tool to create the walls on the 
first floor.

3. Go Up One Floor  and notice that 
the positions of the walls on Floor 1 dis-
play in red as a reference.

4. Arrange the rooms on Floor 2 as desired, 
using the reference display as a guide.

5. On the second floor, select Tools> 

House Wizard> Build House  to 
complete the second floor.

Plan Check
Plan Check checks the floor of your 
plan currently shown on screen for 

anything that appears to violate common 
building practices. Plan Check may not find 
all the problems in a plan, but does it point 
out areas that may need improvement. 

As your plan evolves, a number of things that 
may become incorrect can be fixed using 
Plan Check. For example, doors that change 
from exterior to interior as you add new 
rooms are redrawn without the threshold line 
that marks an exterior door. A cabinet, 
fixture or furniture item that is against a wall 
because the wall was moved into it, as 

opposed to the item moving, are attached to 
the wall.

To run Plan Check, select Tools> Checks> 

Plan Check .

Disclaimer: The Plan Check feature in
Home Designer Pro compares your

plan with common building practices. Plan
Check does not claim to detect all building
code and design requirements. Always have
your plans checked by a licensed profes-
sional before beginning actual construction.



802

Home Designer Pro 2014 Reference Manual

Plan Check Dialog

The current error number, along with 
the total number of errors found.

A description of the current error 
displays here.

Options for navigating Plan Check are 
found on the right side.

• Click Next to ignore the current error and 
proceed to the next.

• Click Previous to return to the previous 
error.

• Click Hold to suspend Plan Check so you 
can fix the current error. Select Tools> 
Checks> Plan Check again and the 
check starts where it left off.

• Click Done to terminate Plan Check.

Potential plan errors found are usually 
highlighted in floor plan view. To ensure the 
highlighted item is on-screen, make sure the 
entire plan is shown in the window before 

you run Plan Check .
If this dialog obscures the floor plan view, 
drag its title bar to move it. It remembers its 
new position and displays there the next time 

Plan Check  is run.

Room Types

Plan Check  can do a much better job of 
checking for problems if it knows what the 
rooms in your plan are to be used for, so you 
should assign a Room Type to each room in 
your plan. See “Room Types” on page 234.

The first time Plan Check  runs in a plan, 
it automatically assigns a room type to as 
many undesignated rooms as it can. Some 
rooms are determined by their size and 
shape, and others by their contents. For 
example, a shelf in a small room indicates a 
closet; a stove or refrigerator indicates a 
kitchen; or a bed, a bedroom. If the program 

cannot assign a room type, Plan Check  
highlights it and suggests that you do so 
manually. 

Loan Calculator
Select Tools> Loan Calculator to 
open the Loan Calculator dialog. This 

dialog lets you calculate different aspects of 

a loan for the current plan based on a variety 
of parameters. 

1
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Specify what aspect of the loan you 
would like to calculate from the 

Calculate drop-down list:
• Monthly Payment 
• Loan Amount 
• Term 
• Interest Rate 

The calculation Result, based on the 
information you provide, displays here.

If you make changes to any of the fields in 
the dialog, click the = button to refresh the 
Result.

The Required Fields are the same as 
the options in the Calculate drop-down 

list. The option selected under Calculate will 
be inactive under Required Fields.
• Specify the desired Loan Amount.
• Specify the desired Term, in years.
• Specify the desired Interest Rate.
• Specify the desired Monthly Payment.

The Optional Fields allow you to 
include additional information in your 

loan calculation. 
• Specify the expected Property Taxes per 

year. 
• Specify the expected Homeowner’s 

Insurance cost per year. 
• Specify the expected Private Mortgage 

Insurance (PMI) cost per year.
• Specify the cost of any expected Other 

Fees.

When Monthly Payment is calculated, each 
Optional value is divided by twelve (months) 
and then added to the total payment.

When a Calculate option other than Monthly 
Payment is selected, these values are divided 
by twelve (months) and then subtracted from 
the specified Monthly Payment value. The 
result, which does not display, is then used to 
determine the Loan Amount, Term or Interest 
Rate.

2
1
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Chapter 34:

Pictures, Images, &
Walkthroughs

Home Designer Pro uses picture files in a 
variety of ways to enhance your drawings. 

The Library Browser contains images of real 
world objects like plants, vehicles, and 
people that can display in 3D views.

Picture files can also be imported into Home 
Designer Pro and shown in most views. 

You can save any view using a variety of 
picture file formats. In addition, Home 
Designer Pro allows you to create virtual 
tours that can be saved as .avi files, shared 
with others, and played back later.

Chapter Contents
•      Picture Files vs Pictures and Image Objects
•      Images
•      Displaying Images
•      Editing Images
•      Image Specification Dialog
•      Pictures
•      Picture File Box Specification Dialog
•      Metafiles
•      Metafile Box Specification Dialog
•      Displaying Pictures and Metafiles
•      Editing Pictures and Metafiles
•      Copy Region as Picture
•      Walkthroughs
•      Walkthrough Path Specification Dialog



806

Home Designer Pro 2014 Reference Manual

Picture Files vs Pictures and Image Objects
In common computer language, picture files, 
pictures and images are more or less 
synonymous. In the Home Designer Pro 
environment, however, there are some 
notable differences between these terms.

In Home Designer Pro, a two dimensional 
image file such as a .bmp, .jpg, .gif, or .png is 
referred to as a picture file or an image file. 
Examples of these files are saved on most 
computers and can be opened in a variety of 
applications. 

A Picture, on the other hand, is a file that has 
been imported into the program. Pictures can 
be imported into floor plan view, cross 
section/elevation views, and layout pages. 

They are two-dimensional only and do not 
display in camera views or overviews. 

An Image object is also based on a picture 
file, but it does display in both 2D and 3D 
views. Images have 3D width and height data 
associated with them, as well as a 2D symbol 
which displays in floor plan view. 

Picture files have additional uses in Home 
Designer Pro, as well:
• Backdrops are picture files that display 

behind 3D views. See “3D Backdrops” 
on page 679.

• Textures are picture files that realistically 
represent materials in 3D views. See 
“About Materials” on page 632. 

Images
Images add realistic detail to 3D views 
without adding many surfaces to the 

model. For example, a tree image with a 
single surface can be used instead of a tree 
symbol with thousands, dramatically 
improving realism without compromising 
drawing time.

There are two types of Images in Home 
Designer Pro: 

• Images  rotate so that they always 
face the camera in 3D views.

• Billboard Images  do not rotate to 
face the camera. An example of when 
this may be useful is an image of a trellis, 
which might look awkward when facing 
a camera from a side view. 

Placing Images
A selection of Images are available in 
the Library Browser. Select one and 

click in a floor plan view, camera view or 
overview to place it. See “Placing Library 
Objects” on page 620.

Creating Images
Custom Images can be added to the 
Library Browser, as well as created in 

plan files. Home Designer Pro can use any 
image with a *.bmp, *.jpg, *.png, *.gif, 
*.tif, *.pcx, or *.tga extension.

Generally, .png files work best as Images 
because this format has good compression 
and allows for the Image to contain 
transparency information.
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To create an Image in floor plan view 

1. In floor plan view, select Build> 

Image> Create Image  or Billboard 

Image  to open the Image 
Specification dialog. See “Image Speci-
fication Dialog” on page 809.

2. On the Image tab:
• Click the Browse button to select a pic-

ture file on your computer or enter the 
path to a valid picture file in the Image 
File field.

• Select or 2D plan symbol to represent 
the image in floor plan view. Choose a 
2D Plan Symbol from the list or click 
the Library button and select a symbol 
from the library. See “Image Tab” on 
page 809.

• Enter Height and/or Width and Loca-
tion information. 

3. Specify transparency information on the 
Transparency tab. 

4. Click OK to close the Image 
Specification dialog.

5. Click to place the new Image in floor 
plan view. 

To create an image in the Library Browser 

1. In the Library Browser, right-click on an 
unlocked folder.

2. Select New> Image from the contextual 
menu to open the Image Specification 
dialog. 

3. Browse to the image file you want to 
add and select your other options. See 
“Image Specification Dialog” on page 
809.  

4. Once created, the image is listed in the 
library folder that you right-clicked on. 
Size and other data is saved. 

Using Paste Image
You can also import an image by first 
copying it to the Windows Clipboard, 

then navigating to a Home Designer Pro 
window and selecting Edit> Paste> Paste 
from the menu. See “Paste Special” on page 
117. 

Displaying Images
The display of images in floor plan 
and 3D views is controlled in the 

Layer Display Options dialog. See 
“Displaying Objects” on page 102.

Images are placed on the”Images” layer.

In Floor Plan View
In floor plan view, most images are typically 

represented by an Image  symbol. You 
can specify a different symbol to represent an 

image if you wish. See “Image Specification 
Dialog” on page 809. 

In 3D Views
The actual picture associated with an image 
object can be seen in 3D views. It is sized 
according to its Width and Height 
specifications. Any transparency data 
associated with the image is also applied. See 
“Image Specification Dialog” on page 809.
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Images can be set to either rotate so that they 
always face the camera or to remain 
stationary, like billboards. See “Images” on 
page 806. 

You can also choose to turn off the display of 
images in rendered 3D views in the 
Preferences dialog. See “Render Panel” on 
page 86.

In Layout
The symbols representing images in floor 
plan view can display on a layout sheet and 
be printed or plotted. See “Sending Views to 
Layout” on page 866.

Editing Images
Images can be selected in 2D and 3D views 
and edited using the edit handles, edit tools 
and the Image Specification dialog. 

Using the Mouse
Images can be resized in floor plan view by 
dragging the circular Resize handle at the top 
of the 2D symbol. 

Images can also be resized in 3D views by 
dragging the circular Resize edit handle at 
the top. 

When an image is resized, the aspect ratio of 
the image and its 2D symbol are retained, so 
the image resizes proportionally.

Using the Edit Tools
A selected image or images can be edited in a 
variety of ways using the buttons on the edit 
toolbar. As with most objects, images can be 
copied, replicated, moved, deleted, etc. See 
“The Edit Toolbar” on page 29.
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Image Specification Dialog
Select an image and click the Open 
Object edit button to open the Image 

Specification dialog. 

Image Tab

Image File - The path and name of the 
selected Image. You can click Browse 

to replace the current image file with a 
different one saved on your computer.

Select a2D Plan Symbol from the 
drop-down list to represent the Image in 

floor plan view. See “Displaying Images” on 
page 807.
• Click the Library button to choose a 

from the library to act as the Image’s 2D 

symbol. See “Select Library Object Dia-
log” on page 622.

Options

• Check Reverse Image to reflect the 
appearance of the image about an imagi-
nary vertical line through its center. 

• Check Do Not Rotate in Camera Views 
to prevent the image from rotating to face 
the camera in 3D views. This box is 
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checked for Billboard Images. See 
“Images” on page 806. 

Specify the Size of the image as it 
displays in 3D views.

• Enter a Height for the selected image. 
• Enter a Width for the selected image. 
• When Retain Aspect Ratio of is 

checked, if you change either the Height 
or Width, the other value changes to 
maintain this ratio. If this is unchecked 

and you resize the image, it may become 
distorted.

• Click Reset Original Aspect Ratio of to 
reset the image’s original aspect ratio and 
remove any distortion caused by resizing.

Specify the Location of the selected 
image.

• Position the selected image precisely by 
specifying its X and Y Coordinates.

• Specify the image’s Height Above 
Ground.

Transparency Tab

Click the Use Transparency From 
The Image File radio button to use any 

transparency data included in the image file.

A preview of the image displays here. 
If you select Use Custom Transparency 

Color, below, you can move your mouse 
pointer over this image to select a specific 
color to use as the Transparency Color.

4
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Click the Use Custom Transparency 
Color radio button to specify another 

color to represent the transparency. 
• Place your pointer over the preview 

image above. The pointer changes to an 
eyedropper and a magnified preview dis-
plays below. Click to select the color of 
the pixel your pointer is over as the trans-
parency color. The selected color dis-
plays in the Color box, below.

• Click the Color box to select a color in 
the Color Chooser dialog. See “Color 
Chooser Dialog” on page 652.

• Enter a level of Tolerance to be applied 
to colors that are almost the same color as 
the specified transparency color. Use the 
slide bar or type a number in the edit box.

A magnified preview of the area in the 
preview image above displays here, 

allowing for accurate pixel selection.

The Transparency Color
If the portion of the image file that you wish 
to use contains the transparency color, that 
part of the image also becomes transparent. 
If this happens, the image may appear 
partially disintegrated.

You may need to experiment to find the best 
transparency color and tolerance for the 
image.

Fill Style Tab
For information about the settings on this 
tab, see “Fill Style Tab” on page 792.

Pictures
A variety of picture file types can be 
imported into and exported out of Home 
Designer Pro. 

Metafiles are also types of picture files that 
can be imported and exported. See 
“Metafiles” on page 814.

Exporting Pictures
Using the Export Picture tool is 
similar to creating a screen capture of 

everything  in the current Home Designer 
Pro view window. Pictures can be saved in 
various file formats and used in other 
applications. 

Export Picture  is best suited for 
rendered views. When exporting a line-based 
view, best results can be achieved by saving 
it as a Metafile. See “To export a metafile” 
on page 815.

To export a picture

1. Open the view that you would like to 
export as a picture file. 

2. Zoom, pan or otherwise adjust the view 
so that what you see on screen suits your 
needs. See “Displaying 3D Views” on 
page 677.

3

4

Note: The  image preview will display its orig-
inal orientation, even if Reverse Image is
checked on the Image tab.
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3. Select File> Export> Picture (BMP, 

JPG, PNG)  in any view to open the 
Export Picture File dialog. See “Export-
ing Files” on page 45. 

The Copy Region as Picture  tool also 
lets you create a picture file based on the 
current view, but allows you to specify what 
portion of the view is exported. See “Copy 
Region as Picture” on page 819.

Importing Pictures
Pictures can be imported into and 
displayed in floor plan view, cross 

section/elevation views, and layout pages. 
Pictures do not display in camera views or 
overviews. See “Displaying Pictures and 
Metafiles” on page 817.

There are several ways to import a Picture 
into Home Designer Pro:
• Select File> Import> Picture (BMP, 

JPG, PNG)  to open the Import 

Picture File dialog, which is a typical 
open file dialog. See “Importing Files” 
on page 49. 

• Click and drag an image file from a Win-
dows Explorer window into the Home 
Designer Pro window.

• In any application, copy an image to the 
Windows Clipboard, then select Edit> 

Paste> Paste  from the Home 
Designer Pro menu in an eligible view 
window. See “Paste Special” on page 
117.

An imported picture is placed in the center of 
the current view. Once imported, pictures can 
be selected and edited. See “Editing Pictures 
and Metafiles” on page 817.

Note: Importing large, or multiple, Pictures
into a plan or layout file can result in program
slowness. 
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Picture File Box Specification Dialog
Select an imported picture file and 
click the Open Object edit button to 

open the Picture File Box Specification 
dialog.

Filename - The full pathname for the 
picture file. Type a new name to change 

the picture assigned to this box.
• Click the Browse button to choose a new 

picture file or to relink to a missing file.

Specify the Size of the picture in plan 
inches (mm).

• Check Retain Aspect Ratio to maintain 
the width to height ratio of the original 
image.  If you change one value, the other 

recalculates so the image is not stretched 
or distorted as it is resized.

• Reset Original Aspect Ratio - If the 
aspect ratio is changed, you can click this 
button to return the picture to its original 
aspect ratio. 

• Specify the desired Width of the picture 
box in plan inches.  The original width in 
pixels displays to the right.

1
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• Specify the desired Height of the picture 
box in plan inches. The original height in 
pixels displays to the right.

Specify the Position of the picture.

• X Position - The location of the picture 
box relative to the absolute origin.

• Y Position - The location of the picture 
box relative to the absolute origin.

• Angle - The current angle of the picture 
box relative to a horizontal line pointing 
towards the right hand side of the screen.

Input/Output (IO) Options - Specify 
how the image file information is stored 

in the plan or layout file.
• Check Save in Plan to embed the picture 

in the plan or layout file. If a picture file 
is embedded, you do not need to include 
it when sending the plan or layout to a 
different computer.

• Click the radio button beside either PNG 
or JPEG to specify how to save the 
embedded picture data. Pictures that were 
originally .jpg or .tga files use the JPEG 
option by default; those that were .gif or 
.png files use the PNG option by default.

• Specify the picture’s Quality %. when 
JPEG is selected. A lower value results 
in better compression, while a higher 
value reduces data loss. 

Choose from a variety of Display 
Options.

• Check  Black and White Dither to 
dither the selected picture file. Dithering 
creates a two tone effect that may pro-
duce better results when printed.

• Check Grayscale to replace the color in 
the selected picture file with shades of 
gray.

• Check Reflect to reverse the image.
• Enter a degree of Brightness from 1 - 

100%.
• Enter a degree of Contrast from 1 - 

100%.

Line Style Tab
The settings on this tab are similar to those 
on the Line Style tab in numerous other 
dialogs, with one exception. 

Uncheck the Show Outline box to turn off 
the display of the picture’s border polyline.

See “Line Style Tab” on page 781.

Metafiles
A metafile (.emf, .wmf) is a special picture 
file format made up of vectors (lines) that 

allow the image to be rescaled without loss 
of quality. 

3

4

Note: PNG is the better option for pictures of
line drawings, text, or large areas of a single
color. JPEG is the better option for photos. 

5
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High resolution pictures  of line-based views 
can be exported as a metafile.

Exporting Metafiles
An enhanced metafile (.emf) can be 
exported from any line-based view: 

that is, from floor plan view and 3D Vector 
Views. 

Only objects that display on screen are 
included in an exported metafile. 

To export a metafile

1. Accurately position the view on screen.
2. Select File> Export> Metafile 

(EMF) . 

3. Drag a marquee  from corner to cor-
ner, defining the area that will included 
in the metafile.

4. Release the mouse to open the Metafile 
Size dialog.

5. Specify the desired Width or Height of 
the metafile. When one value is edited, 
the other changes to maintain its aspect 
ratio. 

Specify, too, the desired Dots Per Inch 
(DPI) for the metafile. A larger value 

results in a higher quality metafile, but 
also a larger file size.

6. When a metafile is exported from a 3D 
Vector View, you can also specify the 
printed thickness of lines in the view. To 
increase the printing line weight, type a 
larger number in the Use Line Weight 
field.  See “Vector View” on page 711. 

Metafiles exported from floor plan view 
use the line weights defined in the Layer 
Display Options dialog. See “Layer 
Display Options Dialog” on page 104. 

7. Click OK to open the Export Metafile 
dialog, which is a typical Save As dia-
log. See “Saving, Exporting, and Back-
ing Up Files” on page 43. 

8. Enter a name and location on your com-
puter for the metafile, then click Save. 

Importing Metafiles
Metafiles can be imported into and 
displayed in floor plan view, cross 

section/elevation views, and layout pages. 
Metafiles do not display in camera views or 
overviews. See “Displaying Pictures and 
Metafiles” on page 817.

There are two ways to import a metafile into 
Home Designer Pro:
• Select File> Import> Metafile 

(EMF,WMF)  to open the Import 
Metafile dialog, which is a typical open 
file dialog. See “Importing Files” on page 
49. 

• You can also click and drag a metafile file 
from a Windows Explorer window into 
the Home Designer Pro window to 
import it.
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An imported metafile is placed in the center 
of the current view. Once imported, metafiles 

can be selected and edited. See “Editing 
Pictures and Metafiles” on page 817.

Metafile Box Specification Dialog
Select an imported metafile and click 
the Open Object edit button to open 

the Metafile Box Specification dialog.

General Tab

The metafile’s Size displays here. You 
can enter a different Width or Height.

Check Retain Aspect Ratio to 
maintain the aspect ratio when the 

Width or Height values are edited. Click 
Reset Original Aspect Ratio to reset the 
metafile to it’s original size if it has been 
edited.

The metafile’s current Position and 
orientation display here. Enter a new X 

Position and/or a Y Position to relocate the 
Metafile in absolute coordinates. You can 
also change the Metafile’s Angle.

Line Style Tab
The settings on this tab are similar to those 
on the Line Style tab in numerous other 
dialogs, with one exception. 

Uncheck the Show Outline box to turn off 
the display of the picture’s border polyline.

See “Line Style Tab” on page 781.

Fill Style Tab
For information about the Fill Style tab, see 
“Fill Style Tab” on page 792.
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Displaying Pictures and Metafiles
The display of pictures and metafiles  
is controlled in the Layer Display 

Options dialog. See “Displaying Objects” on 
page 102.

Pictures and metafiles  are placed on the 
“CAD, Default” layer.

Pictures and metafiles can be imported into 
and displayed in floor plan view, cross 
section/elevation views, and layout pages. A 
picture or metafile can only be seen in the 
view where it was imported and cannot be 
imported into a camera view or overview.

Drawing Groups
By default, imported pictures are placed in 
the Back Drawing Group, and imported 
metafiles are placed in the Default Drawing 
Group. Once imported, they can be moved to 
a different group. See “Drawing Groups” on 
page 150. 

In Layout
Pictures and metafiles are included when a 
view is sent to layout, and can also be 
imported directly onto a layout page. See 
“Pictures and Metafiles in Layout” on page 
869.

Editing Pictures and Metafiles
Pictures and metafiles can be selected and 
edited using the edit handles, the edit toolbar, 
and their specification dialogs. 

Using the Mouse
Pictures and metafiles can be edited like 
CAD boxes. See “Editing Box-Based 
Objects” on page 141. 

In the Specification Dialog
Pictures and metafiles can be customized in 
their specification dialog. See: 
• “Picture File Box Specification Dialog” 

on page 813
• “Metafile Box Specification Dialog” on 

page 816

Using the Edit Handles
A selected picture or metafile can be resized, 
moved, and rotated using the its edit handles. 
See “Editing Box-Based Objects” on page 
141.

Using Dimensions
Pictures and metafiles can be relocated 
relative to other objects with precision using 
dimensions. 

To avoid changing the selected object’s 
aspect ratio, make sure you choose to move 
the entire object rather than the selected 
edge. See “Moving Objects Using 
Dimensions” on page 737.
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Using the Edit Tools
A selected picture or metafile can be edited 
in a variety of ways using the buttons on the 
edit toolbar. See “The Edit Toolbar” on page 
29.

Point to Point Resize
A selected picture or metafile can be 
resized in either the X or Y direction 

with the Point to Point Resize edit tool. 

To use the Point to Point Resize tool

1. Select a picture box, metafile box, or 
PDF box.

2. Click the Point to Point Resize  edit 
button.

3. Click on two points in the selected 
object’s box area that have a known dis-
tance between them.

4. After you click at the second point, the 
Point to Point Resize dialog opens 
showing the current distance between 
the points.

5. Enter a new dimension that matches the 
desired distance between the points.

6. Click OK to resize the picture, metafile, 
or pdf.

Resize Factor
With a bit of calculation, an imported picture 
or metafile can be resized to scale using the 
Transform/Replicate Object dialog. Once 
resized, the information in the object box can 
be traced using Home Designer Pro’s 
drawing tools and then deleted. 

To calculate the Resize Factor

1. Find two items in the imported object 
that are separated by a known horizontal 
or vertical distance, such as two walls or 
plot lines. 

2. Draw parallel CAD lines on top of these 
two items. See “The CAD Drawing 
Tools” on page 771.

3. Find the distance between the CAD 
lines. See “The Dimension Tools” on 
page 728.

4. The Resize Factor for the image is the 
distance described in the picture divided 
by the distance between the CAD lines.

For example, if the items are supposed to be 
10 feet apart on the picture, but the distance 
between the two CAD lines drawn on them is 
only 2 feet, you need to set the Resize Factor 
for the picture to 5. (10’ divided by 2’ equals 
5). When the picture is 5 times the original 
size, the items on the picture are at the actual 
scale shown on the picture.
5. Select the picture and click the Trans-

form/Replicate Object  edit button. 

It is a good idea to delete a resized pic-
ture after it is traced to help avoid pro-

gram slowness and limit your plan or layout
file’s size.
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6. In the Transform/Replicate Object dia-
log, select the Resize Factor check box.

7. Enter the Resize Factor calculated 
above, then click OK.

Copy Region as Picture
You can copy any portion of the 
screen and save it as a picture file 

using the Copy Region as Picture tool. See 
“Exporting Pictures” on page 811.

To use Copy Region as Picture

1. Open the view that you would like to 
copy all or part of as a picture.

2. Select Edit> Copy Region as 

Picture . Your pointer displays a 

marquee  icon.

3. Click and drag a rectangular selection 
marquee around the desired region.

4. The selection is copied to the Windows 
clipboard.

• If the current view is vector-based, the 
Metafile Size dialog displays because 
metafiles are better suited for line-based 
pictures. See “Metafiles” on page 814.

• If the current view is a rendered view, 
the region is sent directly to the Win-
dows clipboard.

5. From there, the picture can be pasted 
into another view or another program.

Walkthroughs
A 3D Walkthrough is a series of 
pictures saved as an .avi file that can 

be played like a video by other applications 
such as Windows Media Player.

There are two approaches to recording a 
walkthrough of a plan: 
• Draw a path in floor plan view, then 

direct the program to record a walk-
through along that path.

• Create a 3D view, then begin recording 
and use the Move Camera tools to navi-
gate through the view. 

Create Walkthrough Path
There are several ways to record a 
walkthrough along a path, but the 

Create Walkthrough Path tool is the fastest 
and most flexible option. 

To create a Walkthrough Path

1. In floor plan view, select 3D> Walk-
throughs> Create Walkthrough 

Path , then click and drag to draw a 
Walkthrough Path. See “To use the 
Spline tool” on page 797.

2. Edit the direction and curvature of the 
spline’s segments, as needed. See “Edit-
ing Spline Based Objects” on page 144. 

3. Add Key Frames  to the path and 
modify their specifications.
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4. Select the path and click the Record 

Walkthrough Along Path  edit but-
ton. See “Record Walkthrough Along 
Path” on page 821. 

You can also create a walkthrough based on a 
regular CAD polyline or spline by selecting 
it and clicking the Record Walkthrough 
Along Path  edit button. This was the only 
way to record a walkthrough along a path in 
Home Designer Pro versions 8 through 2012 
and does not provide as many options as 
using a Walkthrough Path. 

In floor plan view, you can convert a CAD 
polyline or spline into a Walkthrough Path. 
See “Convert Polyline Dialog” on page 165. 

Walkthrough Paths display in floor plan view 
when the “Walkthrough Paths” layer is 
turned on. When displayed, Walkthrough 
Paths display in front of other objects and 
will print. They are included in views sent to 
layout or exported to .dxf. See “Layers” on 
page 101. 

Key Frames
Key Frames are points along a 
Walkthrough Path that allow you to 

change: 
• Camera direction, tilt angle, and height; 
• Changes in walkthrough speed;
• The floor that the walkthrough is on. 

These changes are applied as the camera 
moves along the Walkthrough Path from one 
Key Frame to another.

To add a Key Frame to a Walkthrough Path, 
select the path and click the Add Key 

Frame  edit button. Then click on the 
path to add a Key Frame at that location.

In floor plan view, each Key Frame is 
represented by a camera symbol centered 
along the walkthrough path. It displays the 
frame number, is pointed in the direction of 
its Camera Angle, and its position along the 
path corresponds to the Time setting. 

Key Frame positions and other properties can 
be edited in the Walkthrough Path 
Specification dialog. See “General Tab” on 
page 824. 

You can also use the Edit Key Frames  
edit tool to enable Move and Rotate edit 
handles for each Key Frame on the selected 
Walkthrough Path. 

To use the Edit Key Frames edit tool

1. Select a Walkthrough Path and click the 

Edit Key Frames  edit tool.
2. Each Key Frame on the selected Walk-

through Path will display a Move and 
Rotate edit handle.

• Click and drag the square Move handle 
to reposition the Key Frame along the 
path.

Walkthrough Paths can follow stairs
and ramps to span multiple floors. See
“Walkthrough Paths and Stairs” on

page 821.
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• Click and drag the rectangular Rotate 
handle to change the Key Frame’s direc-
tion angle 

3. When you are finished adjusting the Key 

Frames, click the Main Edit Mode  
edit tool to restore the Walkthrough 
Path’s normal edit handles. 

Walkthrough Paths and Stairs
If you draw a Walkthrough Path up or down 
a staircase or ramp, it will follow the height 
of the stairs or ramp and continue on the next 
floor. 

To create a multiple floor walkthrough

1. Draw a Walkthrough Path so that it 
extends into a staircase or ramp in the 
same direction as its Direction Arrow. 
See “Displaying Stairs, Ramps, and 
Landings” on page 402.

• Do not drag the Walkthrough Path 
across the entire length of the stairs or 
ramp. If you do, its height will remain 
relative to the current floor.

2. When you  release the mouse button, the 
program will automatically display a 
dashed line with an arrow extending past 
the last Key Frame on the current floor.

• If it follows stairs or a ramp going 
upward, the path will also extend to the 
top end of the staircase or ramp.

3. Go up or down one floor, select the 
Walkthrough Path, and resize and 
reshape it as needed. You can use the 

Create Walkthrough Path  tool to 
draw more segments and additional Key 
Frames can be added, as well. 

Record Walkthrough Along 
Path

Once a Walkthrough Path has been drawn, 
you can use it to record a walkthrough video. 

Before recording a walkthrough, it is a good 
idea to choose a codec that will best suit your 
needs. See “Selecting a Codec” on page 823.

To record a walkthrough along a path

1. In floor plan view, select a Walkthrough 
Path or a CAD polyline or spline. 

2. Click the Record Walkthrough Along 

Path  edit button or select 3D> 
Walkthroughs> Record Walkthrough 
Along Path from the menu.

3. An Information message displays, 
reminding you that while a walkthrough 
is being recorded along a path, you 
should avoid using your computer. 

4. In the Save Video As dialog, specify a 
name and saved location for your .avi 
walkthrough file. See “Exporting Files” 
on page 45. 

5. In the Walkthrough Options dialog: 
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• Specify the desired number of Frames 
Per Second, between 1 and 100. A 
higher number results in a higher quality 
recording but also a larger .avi file.

• Specify a Duration Along Path, in sec-
onds. 

• The Total Frames to Record displays 
for reference and equals the Frames Per 
Second times the Duration along Path.

• Specify a Compression percentage 
between 0 and 100. A value of 0 gives 
the highest quality images and largest 
file sizes.

• From the drop-down list, select the Ren-
dering Technique you would like the 
walkthrough to use. See “Rendering 
Techniques” on page 710.

• Click OK.

To cancel the recording as it is being created, 
press the ESC key on your keyboard.

Frame by Frame Walkthroughs
You can also create a walkthrough by 
recording it frame by frame. Although time-
consuming, creating a walkthrough in this 
manner lets you see exactly what is being 
recorded as you record it. 

As with walkthroughs recorded along paths, 
it is a good idea to select a codec that meets 
your needs before recording a walkthrough 
frame by frame. See “Selecting a Codec” on 
page 823.

To record a walkthrough frame by frame

1. Create a camera view. This view is the 
first frame of the walkthrough.

2. From the view, select 3D> Walk-

throughs> Record Walkthrough . 
3. Specify a location and name for the 

walkthrough in the Save Video As dia-
log and click Save. 

4. In the Walkthrough Options dialog: 

• Select a Frame Rate between 1 and 
100. The value entered is the number of 
frames per second. 

• Select a Compression Percent between 
0 and 100. A value of 0 gives the highest 
quality images and the largest file size.

• Click OK.
5. Use the camera movement tools to cre-

ate additional views. Each time the 
screen redraws, that view is recorded as 
the next frame in sequence. See “Editing 
3D Views” on page 684.

6. To move the camera without saving a 
view, select 3D> Walkthroughs> Pause 

Recording  to temporarily stop 
recording. 

• You can then select 3D> Walk-

throughs> Save Frame  button to 
control what views are saved.

• You can start recording again by select-

ing Pause Recording  once more.
7. When the walkthrough sequence is com-

plete, select 3D> Walkthroughs> Stop 

Recording  or close the view.
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If you resize the current view window while 
recording a walkthrough, the program will 
stop recording. 

Playing a Walkthrough
Once a walkthrough has been recorded, it 
can be played on any media player.

To play a walkthrough

1. Select 3D> Walkthroughs> Play 

Walkthrough  to open the Select 
Video File dialog. 

2. Browse to an .avi file on saved on your 
computer. Your default video application 
plays the walkthrough video.

Selecting a Codec
A codec is a a utility that compresses and 
decompresses media files, and is used when 
both recording and viewing .avi files such as 
walkthrough videos.

You can specify which codec to use when 
recording walkthroughs in the Preferences 
dialog. See “Render Panel” on page 86. 

Before recording a walkthrough, it is a good 
idea to try each of the codecs installed on 
your system to see how well their 
walkthrough quality and file compression 
meet your needs. 

Walkthrough Path Specification Dialog
Select a Walkthrough Path and click 
the Open Object edit button to open 

the Walkthrough Path Specification dialog. 
See “Walkthroughs” on page 819. 

Note: Zooming in and out and using the scroll
bars does not change the viewpoint and does
not produce a frame for the walkthrough.
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General Tab

A list of the selected path’s Key 
Frames displays on the left. Click on a 

Frame in the list to select and edit it using the 
settings on the right. When the dialog is 
opened, the last key frame edited in the cur-
rent program session will be selected auto-
matically. See “Key Frames” on page 820. 
• Specify the Floor that the selected Key 

Frame is located on. See “Multiple 
Floors” on page 315.

• Specify the Time in seconds at which the 
selected Key Frame is found in the dura-
tion of the walkthrough. Frame 1 is 
always at 0.0 and cannot be moved; simi-
larly, the last frame is always at the end 
of the walkthrough Duration. 

• Specify the Speed After (ft/s), which is 
how fast the camera moves along the 

walkthrough path from the current Key 
Frame to the next. Not available if the 
last Key Frame is selected.

• Specify the Camera Angle at the 
selected Key Frame.

• Specify the Tilt Angle of the camera at 
the selected Key Frame.

• Specify the Height of the camera at the 
selected Key Frame.

• Click the Delete button to remove the 
selected Key Frame from the path.

Walkthrough Options - 

• Specify the Duration, or total length of 
the walkthrough video in seconds.

Specify how Camera Angles are measured:

1

2

3

1

2
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• Select Relative to path to measure each 
camera angle relative to the direction of 
the walkthrough path at each Key Frame 
location. 

• Select Absolute to measure each camera 
angle relative to the plan’s X, Y, and Z 
axes. See “3D Drafting” on page 25.

Specify how Camera Height is measured: 
• Select Relative to floor/terrain to mea-

sure camera height relative to the floor or 
terrain at each Key Frame location. 

• Select Absolute to measure camera 
height relative to the plan’s Z axis. 

Specify the Key Frame Symbol Size, 
which is the size of the symbols 

representing the selected walkthrough path’s 
Key Frames in floor plan view. See “Key 
Frames” on page 820. 

By default, Key Frames use the Camera 
Symbol Size set in the Camera Defaults 
dialog.  See “Camera Defaults Dialog” on 
page 665. 

Polyline Tab
The Polyline tab indicates the path’s Length/
Perimeter. The Area and Volume of a 
walkthrough path will always be described as 
“Not closed”. See “Polyline Tab” on page 
792. 

Selected Line Tab
The Selected Line tab is available when the 
selected path edge is a line as opposed to an 
arc. See “Selected Edge” on page 125.

Moving the Start of a line segment moves the 
end of the previous connected line, if there is 
one. Similarly, moving the End of a line 
segment moves move the start of the next 
connected line, if there is one.

This tab is similar to the Line tab of the Line 
Specification dialog. See “Line Tab” on 
page 780.

Selected Arc Tab
The Selected Arc tab is available when the 
selected path edge is an arc as opposed to a 
line. See “Change Line/Arc” on page 159. 

This tab is similar to the Arc tab of the Arc 
Specification dialog. See “Arc Tab” on page 
787.

Spline Tab
The Spline tab has a single option and is only 
available if the selected walkthrough path is 
a spline.  See “Splines” on page 796. 

New Segment Angle - Specify the angle 
between line segments that are used to draw 
the spline. Specifying a smaller angle makes 
the spline’s curvature smoother. 

Note: When Relative Angles are used, a
Camera Angle of 0° points in the direction of
the walkthrough path. When Absolute Angles
are used, 0° always points in the positive
direction along the X axis. 

3
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Line Style Tab
This tab is similar to the Line Style tab in the 
Line Specification dialog. See “Line Style 
Tab” on page 781.
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Chapter 35:

Importing &
Exporting

Importing is the process of opening a file that 
was produced in a different program in 
Home Designer Pro. Exporting, on the other 
hand, is the process of saving information in 
a Home Designer Pro file to a format that can 
be read by another program. 

Home Designer Pro allows you to import and 
export a variety of information from and to 
other applications. This chapter focuses on 
importing and exporting 2D .dxf files and a 
variety of 3D file formats.

There are numerous other options for 
importing objects and data in Home Designer 
Pro. They are discussed in the chapters in 
which those objects or settings are discussed. 

Chapter Contents
•      DXF File Format
•      Importing 2D Drawings
•      Import Drawing Wizard
•      CAD to Walls
•      Exporting 2D DXF Files
•      Additional 2D Export Information
•      3D Data Import Requirements
•      Importing 3D Symbols
•      3D Symbols and Materials
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DXF File Format
.dxf (Drawing eXchange Format) is a 
standard file format created by Autodesk for 
the transfer of data between other programs.

Many design programs can read and write 
.dxf files. The .dxf file format interprets data 
as CAD objects such as lines, polylines, and 
circles. 

Importing 2D Drawings
2D drawings are imported by reading entities 
from a .dxf file and creating the equivalent 
CAD objects in Home Designer Pro. 

Home Designer Pro 2014 can import 2D .dxf 
files compatible with AutoCAD® through 
version 2012.

Only drawings created in AutoCAD®’s 
Model Space can be imported into Home 
Designer Pro. Entities drawn in Paper Space 
are not recognized. 

A .dxf file can be imported into floor plan 
view, a Wall Elevation or Cross Section/
Elevation view. 

In general, all Z coordinates are mapped to 
zero. If an entity in an imported drawing has 
thickness, Home Designer Pro ignores it.

Supported Entities
The following is a list of the entities that are 
imported and how they are converted. All 
other entities are ignored: 

• Lines - Both 2D and 3D lines.

• Circles - Fully supported in 2D.
• Arcs - Fully supported in 2D.

• Ellipses - Fully supported in 2D. 
• Spline entities - Fully supported as 2D 

polylines.
• Polylines and Lightweight Polylines - 

Polylines are imported as polylines. 
Bumps are converted to arcs. Line widths 
are ignored.

• Lightweight Polylines - Fully supported 
in 2D.

• Text & Multi-line Text - Both are 
imported as Rich Text and mapped to the 
Text layer. Multi-line text objects retain 
their original width. The first font in a 
multi-line text object is applied to the 
entire object. If that font is unavailable, 
Arial is used.

• Unicode Text - Fully supported.
• Blocks & Block Inserts - A block is a 

named group of CAD entities that have 
been joined together to behave as a single 
object. A block insert is a reference to 
such a block. Blocks are loaded by name. 
If a duplicate name is found, you can 
specify whether a block is imported under 
a new name, replaces an existing block or 
simply uses the existing block of the same 
name. 
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• Hatch entities - If Import Hatch entities 
is selected on the Select File page of the 
Import Drawing Wizard, Hatch patterns 
are imported as a CAD block consisting 
of solid black filled polylines. 

• 2D Solids (Not ACIS Solids) - Fully sup-
ported in 2D. 

• Solids - A solid is a 3 or 4-sided filled 
area. These are imported as 2D faces.

• 2D Solids (Not ACIS Solids)
• 3D Faces/Polyface Meshes - A 3D face 

has its Z coordinate mapped to zero, and 
imports as a polyline.

• Dimensions - Rotated, aligned and 3-
point angular dimensions are supported. 

All other dimension types are imported as 
lines and text rather than functioning 
dimensions.

• Attributes - Attributes are text objects 
associated with other items, like blocks. 
These are imported as text objects at the 
appropriate location but the association 
with the original object is broken.

• Line Styles - Line styles are not imported. 
Instead, if a style of the same name dis-
plays in the Home Designer Pro line 
styles, that line style is used. Otherwise a 
solid line style is used. 

• Layers - You can specify which layers in 
the imported drawing to import into your 
Home Designer Pro file. You can also 
choose how you wish to map drawing lay-
ers to layers in the destination file. See 
“Layers” on page 101.

Import Drawing Wizard
A .dxf file can be imported into floor 
plan view, a Wall Elevation or Cross 

Section/Elevation view. 

To import a 2D drawing file, open the view 
window in which you would like to place the 
drawing and select File> Import> Drawing 

(DXF)  to open the welcome page of the 

Import Drawing Wizard. Click Next to 
continue. 

You can also launch the Import Drawing 
Wizard by dragging a .dxf file from a 
Windows Explorer window into the Home 
Designer Pro window. 

Note: Blocks imported into Home Designer
Pro cannot be exploded into their individual
component objects. 
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Select File

Type the full pathname of the drawing 
file you want to import or click the 

Browse button to locate a file on your 
computer. The directory containing the last 
file selected using the Import Drawing 
Wizard displays in this field.

If you want to convert lines to polylines 
or boxes, check the appropriate options. 

Polylines are imported as polylines 
regardless of these settings.
• Check Polylines to import lines as poly-

lines. Unconnected lines will be con-
nected. 

• Check Boxes to import lines as boxes. 
Unconnected lines will be connected. 

Specify how to treat CAD blocks 
associated with the selected drawing.

• Select Import all CAD blocks to include 
all CAD blocks associated with the file 
being imported whether or not they are 
visible.  

• Select Only import CAD blocks if they 
are referenced in the drawing to reduce 
the volume of transferred data. 

Check Import Hatch entities to import 
areas of hatching as solid-filled 

polylines. 

Click Next to load the file into memory so 
that Home Designer Pro can present 
information about the contents of the file. 
This can take a while for larger files.

1

2

3

4

1

2

3
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Select Layers

A list of the layers found in the 
imported file and information about 

each layer displays in this table.
• In the Layer column, check the box to the 

left of each layer name to specify which 
layers you want to import. Layers with 
checked boxes are imported; those with 
unchecked boxes are not. 

• Layers that were Visible in the original 
program are checked by default. You can 
include a layer that is not visible by 
checking the box to the left of its name. 

• Layers that were Frozen in the original 
program are not checked by default. You 
can include a frozen layer by checking the 
box to its left.

• If a layer is set to Convert To a terrain 
perimeter or elevation data, it will be indi-

cated in this column provided that you are 
importing into floor plan view.

Click Check All to import all layers 
associated with the drawing. Click 

Check None to import none of the layers.

The Convert To drop-down list allows 
you convert the data on any layer into a 

“Terrain Perimeter” or “Elevation Data”. See 
“Terrain Perimeter” on page 538 and 
“Importing DXF Elevation Data” on page 
572. Only available when importing into 
floor plan view.

To convert a layer to terrain data, click on the 
layer in question in the table and then select 
an option from the Convert To drop-down 
list. The option you choose will then display 
in the Convert To column in the table. 

1

32
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Drawing Unit

What unit of measurement was used 
to create this drawing? - Select a unit 

of measurement from the drop-down list. 
Selecting the correct unit helps ensure that 
your imported drawing is accurately sized. 

If the file being imported was drawn at a 
scale other than 1:1, you can compensate for 
this scaling by creating a custom unit of 
measurement and specifying it here. See 
“Unit Conversions Panel” on page 71. 

Select Import as dimensions where 
possible to import dimensions as Home 

Designer Pro supported dimensions.

Select Import as CAD blocks to 
import dimensions as CAD entities that 

are not recognized by Home Designer Pro as 
dimensions.

Check Move drawing to the origin to 
place the drawing at 0,0. When 

unchecked, it is imported to the same 
location as it was drawn in the original 
application. See “3D Drafting” on page 25. 

Import Complete
When a file is imported into Home Designer 
Pro, its various components are selected as a 
group. The group-selection has Move and 
Rotate edit handles available for relocating 
the entire drawing. Once another object or 
tool is selected, the drawing components are 
no longer group-selected. 

Imported drawings are assigned the same 
coordinates at which they were originally 
drawn. If you do not see your imported 

drawing, select Window> Fill Window , 
as it may have been placed at a location not 
currently visible on screen. 

Note: if an open polyline is converted into a
Terrain Perimeter, the program will draw an
additional edge to close the gap. 

1
2

3
4

Note: During the import process, Home
Designer Pro defaults to inches or millime-
ters. If you are importing a site plan or topo
prepared by a surveyor, or if you are import-
ing a metric drawing into an imperial plan (or
vice versa), you may need to change units.

1
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When the drawing can be seen, move your 
mouse pointer over it and note its coordinates 
in the Status Bar. If any coordinate value has 
more than six digits, use the Transform/

Replicate Object  edit button to move it 

closer to the origin. See “Transform/
Replicate Object Dialog” on page 166.

Imported CAD objects can be selected and 
edited just like objects that were drawn in the 
program. See “Editing Objects” on page 119.

CAD to Walls
This feature allows you to convert a 
flat line drawing into a 3D model. 

Once a drawing has been imported into 
Home Designer Pro, CAD lines that 

represent wall layers and other structural 
items can be converted to actual Home 
Designer Pro walls or railings. See “CAD to 
Walls” on page 208.

Exporting 2D DXF Files
Line-based 2D files can be exported from 
Home Designer Pro in .dxf file format. You 
can specify the version of AutoCAD® to 
export to. Compatibility with other software 
may vary.

There are two ways to export a 2D drawing 
file in Home Designer Pro: Export Current 
View and Export All Floors.

Export Current View
To export a floor plan view or Vector 
View that is currently active, select 

File> Export> Current View (DXF). 

Bear in mind that Orthographic views are 
drawn to scale and will produce a 2D 
drawing that can be accurately dimensioned. 
Perspective views, on the other hand, are not 
scaled and do not produce drawings that can 
be dimensioned accurately. See “Perspective 
and Orthographic Views” on page 664.

Bear in mind that Orthographicf are drawn to 
scale and will produce a 2D drawing that can 
be accurately dimensioned. Perspective 
views, on the other hand, are not scaled and 
do not produce drawings that can be 
dimensioned accurately. See “Perspective 
and Orthographic Views” on page 664.

Export All Floors
To export the floor plan view for all 
floor plans simultaneously, select 

File> Export> All Floors  (DXF) from any 
floor of the plan. The floor plans are 
exported to a single .dxf file.

If you choose to export all floors, the file will 
contain all floors superimposed on each 
other. Upon export, each layer in your Home 
Designer Pro drawing is divided into 
separate layers: one for each floor. For 
example: “Electrical-2” contains objects on 
Floor 2 that were originally on the 
“Electrical” layer.
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Export Drawing File Dialog

Save In - The current directory displays 
here. Click the drop-down arrow and 

browse to the export location you prefer.

Existing .dxf files in the current 
directory are listed here.

Enter a File name.

Save as type - Home Designer Pro will 
use the .dxf format to export.

File Format Options - .dxf files 
created by Chief Architect can be 

compatible with a variety of AutoCAD® 

versions. Specify which version from the 
drop-down list. 

The Layer Options settings allow you 
to control the layers associated with the 

file being exported. See “Layers” on page 
101.
• Split Wall Assemblies Into Layers - 

Wall assemblies can be split into layers, 
allowing them to be edited separately.

• Select Export only displayed layers to 
export only those layers that are displayed 
on screen. This is what always occurs 
when exporting from layout, but is not an 
available option in layout files.

1

2
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• Select Export all used and named lay-
ers to export all layers that either have 
something on them or have a layer name 
specified. Not available in layout files.

Other Options  

• Scaling Unit - Select the unit of measure-
ment to be used. For best results, choose 
inches or feet for Imperial plan or layout 
files, or metric units for metric files. See 
“Dimension Preferences and Defaults” on 
page 719.

• Uncheck Create Associative Dimensions 
to export dimensions as simple CAD enti-
ties that are not recognized dimensions by 
other programs. Associative dimensions 
are recognized by AutoCAD® and many 
other CAD programs. 

When exporting a layout page, it is often 
best to uncheck this box. 

• Check Export Pattern Lines to export 
pattern lines. Pattern lines are exported as 
normal CAD lines.

• Check Export Filled Areas to export 
filled areas as AutoCAD® 2D solid enti-
ties. 

Dimension lines using non-default 
formatting will lose their changes and will 
use the default format upon export.

When you are satisfied with your 
selections, click Save to export the file 

as specified. 

The file is now ready to be opened by or 
imported into another program.

Additional 2D Export Information
The export process converts high level Home 
Designer Pro objects (doors, windows, etc) 
into simple, CAD-based objects (lines, arcs, 
etc). Home Designer Pro exports all data to 
AutoCAD®’s Model Space. 

Supported Entities
The following entity types are currently 
supported for 2D export:

Line - The simplest entity. In AutoCAD®, 
lines are 3 dimensional with the Z coordinate 
set to zero.

Arc - Arcs have a start angle, end angle and 
radius. 

Circle - Fully Supported.

Multi Line Text - If exporting to an 
AutoCAD® release that supports multi-line 
text, Home Designer Pro writes the file as 
multi-line text. If exporting to a version that 
does not support multi-line text, the file is 
written as simple text. 

Unicode Text - Fully supported.

Polylines - Polylines are a collection of 
points with lines or arcs connecting them. 
Home Designer Pro supports both lines and 
arcs. Arcs are referred to as bulges in 
AutoCAD®.

Block Insert - A block insert is a reference 
to a block, which is a named collection of 
entities. A block can also contain block 
inserts. 

 7

 8
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Dimensions
Aligned, rotated, and angular dimensions can 
all be exported.

Each dimension has an associated block 
containing a representation of the dimension 
as it is drawn in Home Designer Pro. It also 
contains all the data to recreate that 
information.
• When an exported dimension is modified 

in AutoCAD® or other CAD program, its 
appearance changes. 

• Home Designer Pro does not support 
arrowhead styles or fonts.

• Three kinds of dimensions are generated: 
Aligned, Rotated and 3 Point Angular. 

• Please refer to AutoCAD® documentation 
for more information.

Line Types
A line type, or line style, is used by layers 
and entities to determine how lines are 

drawn. Home Designer Pro line types 
installed with the program are supported on 
export.

Layers
Layers in other systems are similar to Home 
Designer Pro layers, but there are some 
subtle differences. Layer information is 
mapped as follows:

3D Data Import Requirements
Importing a symbol that can be used by 
Home Designer Pro is a relatively simple 
process that begins with previously created 
3D data. This 3D data often comes from a 
program other than Home Designer Pro. If 
you use another 3D modeling program to 
create the 3D data, be aware of the following 

requirements before attempting to create 
symbols.

Note: Uncheck “Use Associative Dimensions”
in the Export Drawing File dialog if the CAD
program you are using does not support
AutoCAD® Associative dimensions. See
“Export Drawing File Dialog” on page 834.

Home 
Designer 

Pro

Other Systems

Name Name

Color Nearest AutoCAD® Color. Home
Designer Pro uses the default

AutoCAD® color table to deter-
mine this mapping.

Display On

Size Line Weight. In AutoCAD®, line
weights are determined by a
table of mm line widths. Home
Designer Pro maps to the closest
match in the default line weight
table based the current view’s
Line Weight Scale. See “Page
Setup Dialog” on page 853.

Style Line type

Lock Lock

Home Designer Pro is not able to pro-
vide support for any third party soft-

ware.
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There are a number of requirements that 
must be met before any 3D data can be used 
to create a symbol in Home Designer Pro:
• The 3D data must be stored in a standard 

Drawing Exchange File (.dxf), object 
(.obj), 3D Studio Mesh (.3ds) or 
SketchUp version 8 and prior (.skp) file 
format. If you have 3D data in another 
format, you must convert it into one these 
formats first.

• Geometry and material information stored 
in .3ds files are imported; cameras and 
lights are not.

• The 3D model must be composed of 
3DSOLID solid entities, or face data. 
Faces are typically referred to as 3D 
faces, polygonal faces, or poly meshes. 
Other types of entities such as lines, 
curves, circles, polylines, and free form 
surfaces can exist in the file but are not 
imported when the symbol is created. 
This is true for all (.dxf/.obj/.3ds/.skp) 
file types.

• The face data should be assigned to dif-
ferent layers so that you can map them to 
the correct materials when viewing them 
in 3D. It is helpful to name your layers 
using a convention that identifies that 
materials should be assigned to each sub-
component.

• Pay attention to the origin and orientation 
of the 3D data when designing symbols. 
Home Designer Pro allows some adjust-
ment when creating the symbol, but it is 
easier to build the 3D data correctly 
before importing it into Home Designer 
Pro. For more information about defining 
the origin, see “Symbol Origin” on page 
54.

• Home Designer Pro does not support 
grouped objects in symbols imported 
from .3ds files. 

Surface Normals
If you use third party software to create a 
.dxf /.obj/.3ds./skp files that will be 
imported as a symbol, you should be familiar 
with the concept of surface normals.

If you use third party software to create a 
.dxf/.obj/.3ds./skp file that will be imported 
as a symbol, you should be familiar with the 
concept of surface normals.

A surface normal is a vector that is 
perpendicular to the plane of a surface. This 
vector points in one direction, determined by 
the way the face is drawn.

If a face is drawn clockwise, the surface 
normals are directed outward; if a face is 
drawn counter-clockwise, the surface 
normals point inward. Home Designer Pro 
assumes that the face on the positive side of 
the normal vector is the outside face.

Many objects can be drawn using only one 
side of each face. A cube is a good example: 
the inside of a cube is not visible, so it is not 
necessary to create its inside faces. When 
inside faces are not calculated, 3D views in 
Home Designer Pro can generate more 
quickly. 
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Importing 3D Symbols
Home Designer Pro supports the 
import of 3D surface and 3D solid 

objects saved to .dxf, .3ds, .obj, and .skp 
formats.

There are two ways to import a 3D symbol 
into Home Designer Pro:
• By dragging and dropping the file from 

Windows Explorer into floor plan view. 
• Using the Import 3D Symbol dialog.

Symbols imported by clicking and dragging 
are imported for use in the current plan, 
while those imported using the Import 3D 
Symbol dialog are also saved in the library. 
See “The Library” on page 603. 

To drag and drop a 3D symbol 

1. Open the plan in which you would like 
to import a 3D symbol and remain in 
floor plan view.

2. Open a Windows Explorer window in 
front of the Home Designer Pro program 
window.

3. If the Explorer window fills your screen, 
click the Restore Down button at the top 
right and resize the window so that the 

Home Designer Pro program window 
can be seen behind it.

4. Click on the desired  .3ds, .obj or .skp 
file and drag it into the Home Designer 
Pro program window.

5. When your cursor changes to a  +, click 
in the drawing area to place as many 
copies of the symbol as desired. When 
you are finished, select a different tool. 

Import 3D Symbol Dialog
Select File> Import> 3D Symbol to 
open the Import 3D Symbol dialog. 

The Import 3D Symbol dialog is a typical 
Open File dialog. See “Importing Files” on 
page 49

Home Designer Pro supports the import of 
3D surface and 3D solid objects saved to 
.3ds, .obj and .skp formats. Home Designer 
Pro treats imported symbols as stand alone 
fixtures.

3D Symbols and Materials
When a symbol is imported into Home 
Designer Pro, material definitions may be 
included with it. Whether and how material 
information is included depends on the 
symbol’s file format. See “About Materials” 
on page 632. 

DXF Files

.dxf files do not include information about 
material definitions. If the .dxf file 
associated with a symbol is changed, all 
previously specified material information for 
the symbol will be lost.

Note: SKP files are always imported using
inches, regardless of the default units used in
the plan file. See “Creating a New Plan or
Layout” on page 42.
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All layers, layer names, solids and instances 
of blocked solids from the .dxf file display in 
the list on the left side of the Materials 
window.

OBJ Files

Material definitions for most .obj files are 
saved in a separate file with the .mtl file 
extension. If such a file exists, the materials 
associated with the .obj file display in the list 
on the left side of the Materials window. 

If Home Designer Pro does not receive 
material definition information in an 
accompanying .mtl file, default material 
properties are assigned. 

Material definitions for .obj files can also 
include texture information in the form of 
image files (.jpg, .png, etc). 

In order to properly import an .obj file, 
Home Designer Pro needs the .obj file, the 
.mtl file, and any referenced texture files. If a 
texture file is not available, the material it is 
associated with is created without a texture.

The material definitions associated with an 
imported .obj symbol are not available for 

use by other objects in Home Designer Pro 
until that symbol has been placed into a plan. 
The associated texture files are then copied 
to the user’s Textures folder. See “Home 
Designer Pro Data” on page 41.  

3DS Files

Material definitions for .3ds files refer to 
texture information in separate image files.  

In order to properly import a .3ds file, Home 
Designer Pro needs these referenced image 
files. If a texture file is not available, the 
material it is associated with will be created 
without it. The associated texture files are 
copied to the user’s Textures folder. 

SKP Files

The textures associated with a .skp file are 
saved in the file. After you import a symbol 
and either place it in a plan or add it to the 
Library, these textures are saved in the Home 
Designer Pro Textures folder. 

Home Designer Pro does not support 
deformed textures. If a texture associated 
with a .skp file is deformed, it will be 
imported without the deformations. 

Texture Filename Conflict
If a texture of the same name already exists 
in the plan when an .obj, .3ds  or .skp file is 
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imported, the Texture Filename Conflict 
dialog displays. 

• Select Rename the imported texture, 
then click the Browse button to create a 
copy of the texture’s image file with a 
new name that you specify. 

• Select Use the existing texture instead 
of the imported texture to keep the 
existing texture.

• Select Replace the existing texture with 
the imported texture to replace the tex-

ture already present in the plan with the 
new, imported one.

• Check Do this for all remaining textures 
in this object to use the same selection 
for all textures with filename conflicts 
associated with this symbol. 
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Chapter 36:

Printing & Plotting

Home Designer Pro provides a variety of 
printing options, from printing plan and 3D 
views to a set of templates that can be 
assembled into a 3D model.

To create working drawings, you can use the 
program’s Layout facility. Multiple views of 
the model can be arranged on pages along 
with a border and title block. For more 
information, see “Layout” on page 863.

Home Designer Pro also allows you to save 
your drawings in electronic file formats that 
can then be sent to a printing service.

Chapter Contents
•      Introduction to Printing
•      Printers and Plotters
•      The Printing Tools
•      Display Options and Printing
•      Printing Directly from a View
•      Printing from Layout
•      Printing to Scale
•      Printing Across Multiple Pages
•      Printing to a PDF File
•      Line Weights
•      Printing Text and Dimensions
•      Creating Custom Sheet Sizes
•      Page Setup Dialog
•      Print Dialog
•      Print Image Dialog
•      Print Model

Screen captures are provided for
illustrative purposes only and are not an

endorsement of any products.
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Introduction to Printing
Home Designer Pro offers printing options to 
suit a variety of needs. You will benefit from 
understanding the output options clearly and 
choosing the one that makes the most sense 
for the project at hand.

Output Options
Printing From Layout - For professional 
quality drawings and details, printing from 
layout provides the most control and the best 
results. For more information, see “Layout” 
on page 863.

Printing Directly From a View - For 
individual drawings, you may prefer to print 
directly from a view. The process is quick 
and allows control over scaling, positioning, 
and line weights, depending on the view 
type. See “Printing Directly from a View” on 
page 846.

Printing to a Remote Plotter/Printer - 
Plans can be printed to a .pdf file and printed 
remotely. See “Printing to a PDF File” on 
page 848.

Print Model - If your final printed output 
will be used to create a 3D model of your 
design, the Print Model feature works best. 
See “Print Model” on page 858.

Terminology
There are a few terms that you should 
familiarize yourself with.

Sheet Size - The dimensions of the final 
printed output. This may or may not be the 
same as the printer paper size. If the sheet 
size and paper size are the same, only one 

page is required per sheet. See “Page Setup 
Dialog” on page 853.

Paper Size - The dimensions of the paper to 
be printed on. Specifying a paper size that is 
smaller than the Sheet Size allows large 
drawings to be printed across multiple pages.

The preview diagram in the Page Setup 
dialog illustrates the difference between page 
size and drawing sheet size. See “Page Setup 
Dialog” on page 853.

Check Plot - A test printing, typically at a 
smaller scale, made before final output to 
large paper format. For more information, 
see “Check Plots” on page 847.

Line Weight - The thickness of a line. A 
thicker line weight is easier to see, but may 
not show as much detail. See “Line Weights” 
on page 849.

Printing Scale - Drawings are often printed 
to scale for accuracy. ¼" = 1' and 1 m = 50 m 
are examples of common scales. Home 
Designer Pro prints to a scale of 1/4” = 1’ by 
default, although this scale can be changed in 
the Page Setup dialog. See “Page Setup 
Dialog” on page 853. 

When a Printer 
Paper size of Letter 
(8½” x 11”) is 
selected, 8 pages 
are required to fill 
an Architectural C 
Drawing Sheet size  
(18" x 24").
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When a particular scale is not important, 
drawings can also be sized to fill a particular 
area. See “Printing to Scale” on page 847.

Printing Problems
Home Designer Pro can print to almost any 
printer or plotter that supports printing 
graphics from Windows programs. If you 

encounter difficulties when trying to print, 
see “Troubleshooting Common Technical 
Issues” on page 910.

Printers and Plotters
There are many different types of printers 
and plotters. In general, a printer is smaller, 
normally outputting 8½ x 11" (Letter or 
ANSI A size), 8½ x 14" (Legal Size) or 
sometimes as large as 11 x 17" (Tabloid or 
ANSI B size).

Plotters are typically used to output larger 
sheets of paper such as 17 x 22" (ANSI C), 
22 x 34" (ANSI D) or 34 x 44" (ANSI E). 
Printing to pen plotters is not supported.

Printer Drivers
Printer drivers are programs that interpret 
between software programs and the printer. 
The drivers are usually created by the 
manufacturer of the printer and are typically 
updated regularly. Different drivers are used 
for different versions of Windows. 

It is useful to keep track of the drivers for 
each printer or plotter you use and update 
them whenever the Windows operating 
system is updated or replaced.

To find the version of your printer driver,  
select Start> Control Panel> Printers and 
Faxes to view the Printers information for 
Windows. Select the printer in question, then 
choose File> Properties.

In most Printer Properties dialogs is an 
About button which you can click to find the 
version and creation date of the driver 
currently in use. If you experience printing 
problems and yours is not the latest driver, 
consider replacing it with an updated driver. 
Visit your printer manufacturer’s Web site 
for more information.

Windows provides information about 
installing printer drivers. To access Windows 
Help, select Start> Help. If you have 
problems installing a driver, refer to your 
printer documentation for technical support.

Always familiarize yourself with your
printer or plotter before a deadline is

near, and bear in mind that it can take a little
time to configure a new printer.

Note: You should only update your printer
driver if you are having problems printing.

Options available with one driver may
not be available with another. Printers

and plotters supported in one version of
Windows may not be supported by the
manufacturer in another.
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Clearing Printer Information
Some information specific to individual 
printers and plotters, such as available paper 

sizes, is saved with each plan and layout file. 
You can select File> Print> Clear Printer 
Info to clear the printer-specific information 
stored with the plan or layout file.

The Printing Tools
Select File> Print to view the Print 
Tools submenu. 

Page Setup - Opens the Page Setup 
dialog, where printing options are set. 

See “Page Setup Dialog” on page 853.

Scale to Fit - Automatically selects a 
scale that fits your plan to the drawing 

sheet. See “Printing to Scale” on page 847.

Center Sheet - Automatically centers 
your drawing on the sheet. See “Cen-

ter Sheet” on page 846.

Print Preview - Shows how the 
current view will appear when printed. 

See “Print Preview” on page 845.

Print - Prints the current floor plan 
view, Vector View, or layout sheet. 

See “Print Dialog” on page 855.

Print Image - Prints a screen view 
including images, textures and 

backdrops. See “Print Image Dialog” on 
page 857.

Print Model - Opens the Print Model 
dialog, allowing you to print templates 

for making a physical model of your plan. 
See “Print Model” on page 858.

Customize Sheet Sizes - Allows you to 
create custom sheet sizes. See “Creating 
Custom Sheet Sizes” on page 852.

Clear Printer Info - Clears the printer 
information associated with the current page 
setup.  

Toggle Buttons
Toggle buttons are either on or off. When on, 
they appear depressed and remain depressed 
until clicked again. See “Toolbar 
Configurations” on page 98.

Show Line Weights - When this is on, 
line weights appear on screen as they 

will print.  See “Show Line Weights” on page 
845.

Show Sheet - Turn this toggle on for a 
preview of your plan relative to the 

current sheet size. See “Show Sheet” on page 
845.

Display Options and Printing
The display of objects in views can be used 
to affect the printed output. Some display 
options allow you to preview the printed 
output on screen before any paper is used.

Objects must be visible in order for them to 
print; but not all items that are visible print. 
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• Camera symbols in floor plan view, CAD 
points, and the snap and reference grids, 
for example, do not print. 

• The Reference Display does print if it is 
visible. See “Reference Display” on page 
327. 

Displaying Objects
You can control the display of objects 
when printing directly from a view in 

the Layer Display Options dialog. See 
“Layer Display Options Dialog” on page 
104.

To control the display of objects in an 
orthogonal view sent to layout, select the 
view, click the Layout Box Layers  edit 
button, and make any needed changes in the 
Layer Display Options dialog. 

To control the display of objects in a camera 
view sent to layout, turn layers on/off  in the 
view before it is sent to layout. 

Show Line Weights
Select Tools> Display Settings> 
Show Line Weights for an on-screen 

representation of line weights and line styles.  
Turning Show Line Weights on or off does 
not affect the final printed output.

When Show Line Weights is turned on, you 

can Zoom In  to see the location of lines 
and dashed lines as they will appear on the 
printed page.

When Show Line Weights  is off, dashed 
lines look the same, regardless of the zoom 
factor. 

Show Line Weights  can also be turned on or 
off in the Preferences dialog. See 
“Appearance Panel” on page 61.

Print Preview
Select File> Print> Print Preview for 
an on-screen representation of how 

the current view will appear when printed. 
Print Preview is only available in views that 
can be scaled. See “Printing to Scale” on 
page 847.

Objects such as camera symbols that do not 

print do not display in Print Preview . 
Text and dimension objects appear on-screen 
as they will on the printed page.

When Print Preview   is on the drawing 
sheet and line weights are displayed, and the 

toggle buttons Show Sheet  and Show 

Line Weights  are overridden.

Show Sheet
Select Tools> Display Settings> 
Show Sheet to show the drawing 

sheet on screen. The drawing sheet size is 
specified in the Page Setup dialog. See 
“Page Setup Dialog” on page 853.

Any portion of your plan that cannot fit on 
the drawing sheet at the current scale 
displays outside the sheet. 

A blue border represents the printable area, 
which varies depending on which printer is 
currently selected. This border may not 

To see how your printed output will
appear on paper, select File> Print>

Print Preview or click the Print Preview tog-
gle button.
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display on all edges of the drawing sheet. See 
“Printer Drivers” on page 843. 

When Show Sheet  is on, the drawing 
sheet behaves as an object. 
• When selected at its border the sheet has 

edit handles, allowing it to be moved. See 
“Editing Objects” on page 119.

• You can also resize the sheet using its edit 
handles; however, for best results, it is 
recommended that you instead select an 
available sheet size in the Page Setup 
dialog. See “Page Setup Dialog” on page 
853.

• Dimension lines locate the borders of the 
sheet. These dimensions can be used to 
relocate other objects in relation to the 

sheet. See “Moving Objects Using 
Dimensions” on page 737.

The drawing sheet cannot be rotated or 
copied. 

Center Sheet
Select File> Print> Center Sheet to 
center the drawing sheet on the 

drawing. This moves the sheet relative to the 
drawing but does not affect the coordinates 
of objects in the drawing. The location of the 
drawing sheet is independent for each floor 
of the model.

Printing Directly from a View
To print directly from any floor plan 
view or cross section/elevation view, 

choose File> Print> Print. See “Print Dia-
log” on page 855. 

To set up print formatting before printing, 

select File> Print> Page Setup . See 
“Page Setup Dialog” on page 853.

Rendered 3D views can be printed using 

File> Print> Print Image . See “Print 
Image Dialog” on page 857.

Printing from Layout
Home Designer Pro layout files can be used 
to print professional working drawings. 
Multiple views at different scales can be sent 
to each sheet and organized as desired. 

Layout sheets can accomodate a border and 
title block and can be printed at full size or 
printed at a smaller scale for check plots. See 
“Layout” on page 863.

Note: Specifying a standard sheet size
in the Page Setup dialog is preferable to

editing the sheet size on-screen.
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Printing to Scale
Several different print scaling options are 
available. The type of view that you are 
printing determines which options you may 
choose from.

Orthogonal Views
Floor plan views, Orthographic 3D views, 
and layout pages are orthogonal views, 
which means: 
• Your line of sight is at a right angle to all 

objects in the view. 
• Objects do not appear to decrease in size 

as their distances from the viewer 
increase.

Orthogonal views can be printed to scale; 
however, Orthographic 3D views can only be 
printed to scale when the Vector View 
Rendering Technique is used.

The scale set in the Page Setup dialog is 
inherited by the Print and Send to Layout 
dialogs. This scale can be overridden on an 
individual basis in either of these dialogs. 
See “Print Dialog” on page 855 and 
“Sending Views to Layout” on page 866. 

Select File> Print> Scale to Fit  in an 
orthogonal view to select a suitable scale and 
re-center the drawing sheet so that 
everything fits on the sheet.

Imperial drawing scales are typically noted 
in inches per foot. Larger scales, such as 1 
inch = 50 feet or 1:200m, are often used for 
property layouts.

Perspective Views
Camera views and Perspective overviews 
display the model much the way the eye 
would see it and cannot be scaled.
• Objects in the view may be at any angle 

relative to your line of sight. 
• Objects seem to decrease in size as their 

distances from the viewer increase.

Perspective views can only be printed using 

the Print Image  tool. See “Print Image 
Dialog” on page 857.

While perspective views cannot be scaled, 
you can control the printed size of the view. 
If Fit to Paper is selected in the Print dialog, 
a percent value can be set that defines how 
much of the printed page to fill. See “Print 
Dialog” on page 855. 50% causes the print to 
be 50% of both the height and width of the 
paper, including the non-printable border. 

For example, if printing to an 8½ x 11 page 
with a 1" non-printable border in each 
direction: 
• 100% would print an area 8½ x 11. This 

is not recommended, as part of the output 
could fall outside the printable area.

• 50% would print an area 4¼ x 5½. 
• Each printer may vary slightly.

Check Plots
A check plot is a test print that allows you to 
print at a reduced scale on smaller, less 
expensive paper so you can check that the 
drawing will print as expected. 
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In a check plot, the drawing scale is 
temporarily adjusted to a specified fraction 
of its true value. Both drawing scale and line 
weights are subject to this scale adjustment. 

For example, if a layout has a Drawing Scale 
of 1/4” = 1’ and a Drawing Sheet of 24” x 
36”, a check plot at 1/2 scale would result in 
a printed drawing scaled at 1/8” = 1’, which 
would fit on a 12” x 18” page. 

To create a check plot

1. Select File> Print> Page Setup . In 
the Page Setup dialog:

•  Confirm that the Drawing Sheet Size 
and Drawing Scale are correct for a 
full size print out - not a check plot.

•  Specify the Printer Paper Size that 
you would like to use for the check 
plot, then click OK.

2. Select File> Print> Print  to open 
the Print dialog.

•  Click the Check Plot at radio button, 
then choose the desired scale fraction 
from the drop-down list.

3. When you are finished printing the 
check plot, return to the Page Setup 
dialog and change the Printer Paper 
Size back to the setting you will use for 
a full size printing.

Printing Across Multiple Pages
When printing directly from a floor plan 
view, cross section/elevation view, or layout 
it is possible to print at a scale that does not 
fit the drawing on one page.

When printing to a paper size that is smaller 
than the sheet size, a 2% overlap is used. 
Crop marks print where the paper needs to be 
cut between pages. A solid line is drawn at 

the drawing sheet boundary on the sides that 
need to be cut.

To see on-screen what the drawing will look 
like when printed, select Tools> Display 

Settings> Show Sheet  and then 

Window> Fill Window . Grey lines 
across the drawing sheet  indicate where the 
page breaks will occur. See “Show Sheet” on 
page 845.

Printing to a PDF File
Portable Document Format, or .pdf files, are  
one of the most universally compatible and 
efficient file formats and can be viewed and 
printed on most computer platforms. 

Creating a .pdf document requires that a .pdf 
printer driver be installed on your computer. 

This is not a physical print device, but a 
software program that is recognized as a 
printer by all other programs and creates a 
.pdf file that can be read and printed using 
Adobe® Reader®. 
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When you print to a .pdf print driver, you 
will be asked for a file name and destination 
automatically. 

To print to .pdf 

1. Select your .pdf printer driver as you 
would select any other printer in the 
Page Setup dialog. See “Page Setup 
Dialog” on page 853. 

2. Select File> Print> Print  to open 
the Print dialog. Your .pdf printer driver 
will be listed as the selected printer.

3. Select the needed options in the Print 
dialog, then click OK. 

4. In the Save As dialog, select a File 
name and Save in location for your .pdf 
file. For information about the settings 
in the Save As dialog, see “Saving, 
Exporting, and Backing Up Files” on 
page 43.

Line Weights
The weight of a line refers to its thickness on 
the printed page and is described in absolute 
terms as a fraction of a unit, often 1/100th of 
a millimeter or 1/1000 of an inch. 

In Home Designer Pro, line weights are 
assigned to objects, patterns or layers using 
whole numbers that correspond to the 
numerator of this fraction.

You can specify the Line Weight Scale by 
defining the denominator and the unit used in 
this fraction in the Page Setup dialog. See 
“Page Setup Dialog” on page 853. 

The method for changing the line weight for 
a particular object depends on the object and 
the type of view.
• Most objects’ line weights can be set in 

their specification dialogs. See “Line 
Style Tab” on page 781.

• The line weight for a group of objects can 
be set by layer. See “Layer Display 
Options Dialog” on page 104.

• The line weights for walls in floor plan 
view are defined by wall type in the Wall 

Type Definitions dialog. See “Wall Type 
Definitions Dialog” on page 211.

• The line weights of material pattern lines, 
which are visible in Vector views, can be 
set in the Define Material dialog. See 
“Define Material Dialog” on page 644. 

• The line weight for fill patterns is set for 
individual objects on the Fill Style tab of 
their specification dialogs. See “Fill Style 
Tab” on page 792.

• The line weight applied to surface edges 
in  Vector views can be set in the Print 
dialog. See “Print Dialog” on page 855.

• The end cap length of dashed lines in 
floor plan view is controlled in the 
Preferences dialog.  See “Line 
Properties Panel” on page 75.

• An assigned line weight of 0 draws a line 
weight of 1 pixel, the thinnest line weight 
a printer allows. How thick this is varies 
from printer to printer. See “Printers and 
Plotters” on page 843. 
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Line Weights and Scaling
When a view is sent to layout, line weights 
may be affected by the drawing scale 
selected for the view. This occurs when the 
layout view’s scale is different from the 
drawing scale of the original view. 

For example, assume that you have an object 
in a view with a line weight of 20, and that 
the view’s drawing scale is 1 mm = 50 mm. 
• If you send the view to layout at 1 mm = 

25 mm scale, twice the original scale, the 
resulting printed line weight for this 
object will increase to 40 instead of 20. 

• If you send the view to layout at 1 mm = 
100 mm scale, half the original scale, the 
resulting printed line weight for this 
object will decrease to 10 instead of 20. 

You can specify the drawing scale for any 
orthogonal view by opening the Page Setup 
dialog while in that view.  See “Page Setup 
Dialog” on page 853. 

For any layout view, you can specify whether 
the original line weight is maintained or not 
in the Send to Layout dialog. See “Send To 
Layout Dialog” on page 867. 

Line weight scaling affects both line weights 
and line styles and can be particularly 
noticable with dashed line styles. 

In the following image, the same floor plan 
view has been sent to layout twice, at two 
different scales. The view on the left was sent 
at the same scale as the original view, 
1/8” = 1’.  The view on the right was sent at 

1” = 1’, or magnified eight times, to show an 
area of the plan in greater detail. 

Because the view on the right was sent to 
layout at a scale other than that of the 
original, it is subject to layout line scaling. 

The solid lines representing walls, cabinets 
and doors are rescaled to be eight times 
thicker than in the original view.

Similarly, the dashed lines representing the 
door jambs are rescaled so that the dashes 
and the spaces between them are eight times 
larger than in the original view. 

Note: Under most circumstances, you should
select Use Layout Line Scaling when sending
views to layout.

with Use Layout Line Scaling disabled
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If Use Layout Line Scaling is enabled, line 
weights are no longer scaled and the dashed 
lines display at the same size as in the 
original view. 

Because the view in this example is scaled 
eight times larger in this case, the dashes and 
line weights look relatively small and fine 
when Use Layout Line Scaling is enabled. 
Were the view rescaled to be smaller instead, 
the line weights would look relatively large 
and thick.

Printers and Line Weight
Line weight and print scaling are subject to 
the limitations of the printer being used. For 

example, you will not be able to see the 
difference between a line that is 1/150th of 
an inch wide and one that is 1/300th of an 
inch wide when they are printed using a 
printer that prints 150 dots per inch (DPI). 

That is, a CAD line with a line weight of 1 
will look the same as a CAD line with a line 
weight of 4 when the Line Weight Scale is 
set at 1 = 1/600th of an inch and you print to 
a printer capable of 150 DPI. 

Legacy Plans
When plans and layouts created in prior 
versions of Home Designer Pro are opened in 
Version 2014, they assume the Page Setup 
settings, including the Line Weight Scale, 
specified in the Preferences dialog. See 
“Text & Page Setup Panel” on page 66.

When working with legacy files, using a 
Line Weight Scale of 1 = 1/X, where X is the 
DPI of your printer, will produce the most 
faithful translation from the previous 
version. 

Printing Text and Dimensions
As with other objects your drawings, text and 
dimension numbers are subject to scaling 
when views are sent to layout or printed. See 
“Scaling Text” on page 755.

Printed text size is also influenced by the 
selected font and the method used to specify 
its size. See “Character Size” on page 745.

Text may not print exactly as it appears on-
screen. To get a better idea of how text and 

with Use Layout Line Scaling enabled

The default Line Weight Scale of 
1 = 1/100 mm makes it easy to meet

many professional drawing standards. In
most cases, this scale will produce positive
results using any printer or plotter and should
not be changed.
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dimension characters will print, you may 

find it helpful to Zoom In  on them. 

For best printed results, using true-type or 
open-type fonts is recommended. 

Creating Custom Sheet Sizes
Standard drawing sheet sizes can be selected 
in the Page Setup dialog.

To create custom sheet sizes, select File> 
Print> Customize Sheet Sizes or click 
Customize in the Page Setup dialog. 

Several options are available:
• Click New to create a new sheet size.
• Select a sheet size and click Copy to cre-

ate a duplicate sheet size.

• Click Delete to remove the selected sheet 
size.

• Select a sheet size and click Edit to open 
the Edit Paper Size dialog and change its 
description, dimensions, and units of 
measurement.

• Click OK to close the dialog. Any new 
sheet sizes created are now available in 
the Page Setup dialog.

• The data for this dialog is stored in the 
“sheetSizes.sheet” file in the program 
directory.

Text may not appear accurately on
screen when the font used by the

printer is different than the font used on
screen. Consult your printer documentation
for more information on font substitution.
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Page Setup Dialog
Select File> Print> Page Setup to 
open the Page Setup dialog. 

The Page Setup dialog is only available 
when an orthogonal view is active. When a 

perspective view is active, Page Setup  is 
not available. 

The settings in this dialog, including the 
selected printer, are specific to the current 
orthogonal view or layout file, and are saved 
with the .plan or .layout file. 

Click the Printer button to select the 
current printer or edit its settings. If you 

have questions about your printer’s settings, 
consult its documentation. 

Select the printer paper Size and 
Source. The options available in these 

drop-down lists are controlled by the 

currently selected printer’s driver. See 
“Printer Drivers” on page 843.

Specify the Orientation of the printer paper.

Check Show Page Breaks to display page 
breaks as grey lines across the drawing sheet 
in the plan or layout view when Show Sheet  
is enabled. See “Show Sheet” on page 845. 
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Specify the Size of the Drawing Sheet, 
which is the final printed output.

Click the Customize button to open the 
Customize Sheet Sizes dialog. See 
“Creating Custom Sheet Sizes” on page 852.

Specify the Orientation of the drawing 
sheet, which is the orientation of the entire 
drawing. The dialog preview at right updates 
as the orientation is changed.

Check Show Drawing Sheet to display the 
drawing sheet on screen.  

Specify the Drawing Scale for your 
printed plan. The scale is specified in 

two parts, which by default are 1 ft = 1 ft or 1 
m = 1 m for layout views, and ¼ inch = 1 ft 
or 1 m = 50 m for all other views. Both 
imperial and metric units of measurement are 
available and can be selected independently. 

This scale is applied for printing purposes 
only and has no effect on the plan scale. 

The Drawing Scale acts as the default scale 
for the Print, Printed Size Input, and Send 
to Layout dialogs. 

Select the Line Weight Scale. See 
“Line Weights and Scaling” on page 

850. This setting should always be the same 
for both a given layout file and any plan 
views associated with it.

Check Automatic to have the program 
specify the line weight scale and adjust it to 
maintain line thickness and dash size when 
the drawing scale is changed. Automatic 
Line Weight Scale is based on a 1/4 inch = 1 
foot drawing scale and 1= 1/300 inch line 
weight scale and is an option for .plan files. 
See “Line Weights” on page 849. 

Automatic Line Weight Scale is not 
available in .layout files.

Check Use These Settings When 
Converting Old Files and click OK to 

establish the current settings as the default 
settings for plans, and elevations when 
opening plans created in earlier versions of 
Home Designer Pro. Layout plans must be 
set separately. See “Text & Page Setup 
Panel” on page 66.

A preview of the drawing sheet and 
printer paper size displays on the right 

side of the dialog box. 

A line weight preview shows how 
changes to the drawing scale affect the 

printed size of various line weights at the 
current Drawing Scale. 

Clearing Printer Information
Select File> Print> Clear Printer Info to 
clear the printer-specific information stored 
in the Page Setup dialog.

Plotters can often have paper inserted
into the machine in either of two orienta-

tions. Test your own machine and refer to the
printer manual to find out which way to insert
the paper for correct results.

3

4

5

Setting the line weight to zero (0) for
any object or group of objects causes

the line weight to print as thin as is possible.

6
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 Print Dialog
To print directly from floor plan view, 
3D Vector Views and the Materials  

List, select File> Print> Print. The Print 
dialog opens.

Specify the Printer parameters.

Browse the Name list to choose a printer.

Click Properties to verify that the printer is 
configured correctly. Paper size, orientation, 
and other settings can be accessed here.

Select the Print to file check box if you need 
to create a file for remote printing. 

In the Print To File dialog, type the entire 
pathname of the file to be printed, making 
sure the name has a .prn or .plt extension. 

Do not check Print to file if you are creating 
a .pdf file.  

Note: 3D views that are not Vector Views can
be printed using Print Image. See “Print
Image Dialog” on page 857. 

2

3
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1

Printing to a PDF file is often preferable
to printing to file. For more information,

see “Printing to a PDF File” on page 848.
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Specify the Print Range. This setting 
is saved between program sessions.

• Select All to print the entire drawing. In a 
plan file, the current view is printed on as 
many pages as needed. In a layout, all 
pages are printed.

• Select Current Page to print only the 
currently active layout page. Current 
Page is selected by default in layout files.

• Select Pages to specify which layout 
pages to print, then type the first and last 
page numbers in the text fields. 

• Select Current Screen to print only that 
portion of the active view that can cur-
rently be seen on screen. If you are 
zoomed out, any blank space beyond the 
printable objects in the drawing is 
ignored. Not available in the Print 
Materials List dialog.

• Select Entire Sheet to print the entire 
sheet even though you may be zoomed in 
on a portion of the view. Not available in 
the Print Materials List dialog.

Specify the Scaling of the printed 
output. Not available in the Print 

Materials List dialog.
• Fit to Paper prints the view on one page. 

The program uses whatever scale is nec-
essary to fit the plan on one page. 

• When Fit to Paper is selected, specify 
the percentage of the paper to be used. 
The default value is 95%; however, any 
changes to this value are global, affecting 
all files, and will be retained between ses-
sions. 

• Select To Scale to print at the scale speci-
fied in the Page Setup dialog. See “Page 
Setup Dialog” on page 853.

• To print a check plot, select Check Plot 
at and choose a scale adjustment from the 
drop-down list. This temporarily modi-
fies the scale for the current print job but 
does not alter the scale specified in the 
Page Setup dialog. Line weights are also 
subject to the temporary scale adjust-
ment. If a drawing sheet larger than the 
printer paper is specified, a check plot 
prints across multiple pages.

Check the accuracy of your printed 
scaled documents using Height/Width 

Correction. If your scaled documents are not 
correct, you can fine tune or calibrate the 
printer with these adjustments. These 
numbers are multiplied into the scaling units. 
Such corrections should only be necessary if 
you are using a dot matrix printer. Not 
available in the Print Materials List dialog. 

Options - Only the Copies setting is 
available in the Print Materials List 

dialog.
• Specify the number of Copies you would 

like to print. 
• Check Print in Color to print in color or 

clear the check box to print in either gray-
scale or black and white. 

• To print in grayscale, check Obey Color 
On/Off Setting in the Preferences dia-

2

3

Note: None of these options override the
printer paper size specified in the Page Setup
dialog.

Check printer calibration by printing a
four foot square at ¼” = 1’-0”. Measure

the print to see if it measures out exactly 1"
square.

4

5
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log before printing, then uncheck Print 
in Color. See “Appearance Panel” on 
page 61. 

• To print in black and white, uncheck 
Obey Color On/Off Setting in the 
Preferences dialog before printing, then 
uncheck Print in Color. Lines and fill 
colors print as either black or white, 
depending on which is closer to the line 
or fill’s actual color. 

Most black and white printers print a grey 
scale approximation of the colors if Print in 
Color is selected. 

Double Buffered Printing uses computer 
memory to render the output at printer 

resolution. The resulting bitmap is then 
printed. This can greatly improve print speed 
when printing Vector Views, but a lot of 
memory is required. This method is not 
normally recommended for layouts, plans, or 
details; however, it may help you avoid 
issues with certain drivers for older printers. 
See “Printers and Plotters” on page 843.

If there are a lot of pictures on your plan or 
layout, using double buffered printing may 
improve your print speed.

Line Weight - Available for Vector Views 
only. Specify the Line Weight for all lines 
defining the edges of 3D objects. This is a 
global setting for all edges. Individual lines, 
other than superimposed CAD lines, cannot 
be defined with different line weights.

Print Image Dialog
Any view can be printed by selecting 
File> Print Image. This is the only 

way to print most 3D views. See “3D 
Rendering” on page 697.

The Print Image dialog is similar to the Print 
dialog; however, the printing process is 
different. Print Image prints individual 
pixels as opposed to vectors (lines).

Printing to pen plotters is not supported.

2 3

1
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Specify the Printer parameters.

• Choose a printer from the Name drop-
down list.

• Click Properties to verify that the 
printer’s paper size, orientation and other 
settings are configured correctly. 

• Select the Print to file check box to save 
the print to a file for remote printing. For 

more information, see “Print Dialog” on 
page 855.

Specify the Print Range. 

Specify the number of Copies.

Print Model
The Model Maker allows you to create 
a template of your plan that can be 

printed to scale and assembled into an actual 
3D model. Three groups of templates are 
used in the process. Walls and roofs are 
printed separately. These can then be placed 
onto a floor plan view, which is printed as a 
layout for the entire model.

Since different people build house models in 
different ways, the Model Maker focuses on 
providing the most necessary tools. It may 
not necessarily give you everything you 
might want in order to build house models 
your way. For example, you may want to 
affix tabs to certain wall or roof edges to help 
attach them to their neighbors. While you 

can draw some of these things onto printed 
sheets, the system does not provide them 
automatically. What it does provide is 
accurate templates for wall and roof sections. 
Combining these with your own skills helps 
you create professional quality models.

Printing the Model
The best way to understand how the various 
options affect the final product is to make a 
very simple two story plan and try them out.

To print the model templates, choose File> 

Print> Print Model . The Print Model 
dialog opens.

1

Printing to a PDF file is often preferable
to printing to file. For more information,

see “Printing to a PDF File” on page 848.

2

3
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Print Model Dialog

Printer - Select the printer for your 
model. Larger sheet sizes are better. 

Landscape is usually the best mode for 
printing models. If it is not your default 
printing mode, it can be selected via the 
Properties button.

Printer Info - Information about your 
printer and its current setup displays 

here. 
• Check this box if you prefer to Print to 

File. Leave this unchecked if you are 
printing to .pdf.

Uncheck Walls to prevent walls from 
printing. When Walls is checked, the 

settings below are available.
• Check Exterior Only to suppress interior 

wall surfaces. Normally it is only the 
exterior walls that display in a model. If 
interior walls and surfaces are produced, 
much more paper is required. Interior 
surfaces are typically printed when com-

posing a model of only the current floor, 
without a roof.

• Check Fold Interior Down to print the 
interior surface of a wall above its corre-
sponding exterior surface and upside 
down. This allows both walls to be cut in 
one piece and folded over. This is conve-
nient when making a separate model for 
each floor to show its interior.

• Check Combine Floors to print together 
the exterior surfaces of walls that are on 
top of each other. Interior surfaces of 
those walls still print separately.

• Allow Offset modifies the outcome of 
the Combine Floors option. Normally, 
the main layers of stacked walls must be 
closely aligned and have the same thick-
ness for walls to combine. Check this box 
to allow an offset of up to six inches (15 
cm) and allow different thicknesses. 
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• Check Railings to print railings along 
with walls.

• Check Outdoor Walls/Foundation 
Walls to include Outdoor Walls and/or 
Foundation Walls in the walls group. This 
also affects which walls display in the 
floor plan view template.

• Outdoor Walls - An Outdoor wall is nor-
mally a garden wall or a wall used as a 
fence. It may be a No Room Def. type 
wall, see “Wall Specification Dialog” on 
page 214, or have exterior type rooms, 
such as Deck, Porch, or Attic on both 
sides of it. If a plan has extensive outdoor 
walls, printing them all may use a consid-
erable amount of paper.

• Foundation Walls - Walls on floor zero, 
the foundation floor, still print unless 
they are specified as foundation walls on 
either the General or Foundation tab of 
the Wall Specification dialog. 

Uncheck Roofs to suppress roofs from 
printing.

Uncheck Plan View Instructions to 
suppress floor plan view instructions 

from printing. 

Specify the number of Copies to be 
printed. 

Specify the Scale to be printed in 
inches per feet. A simple ratio (1:48 for 

example) is used for metric plans. 

The system arranges as many wall or roof 
sections as possible onto a single sheet. For 
larger scale models, a printer with a larger 
sheet sizes is helpful. If any wall surface, 
roof surface, or floor plan view covers more 
than one sheet, it prints by itself on the 

number of sheets required. Models with large 
surfaces may require a lot of paper.

Specify the Floor Thickness, which is 
the thickness of the material you use for 

the floor platform. 

Print in Color - This option depends 
on whether you have a color printer. 

Check this box to print in color.

Assembling the Model
Once the templates have been printed, they 
are ready to be assembled. You need scissors 
and an adhesive and a rigid material that can 
be easily cut and glued, such as thin 
cardboard or styrofoam, to provide support 
for the 3D model.

Floor Plan View Template

Begin by laying out the floor plan view, 
which is used as a layout for the entire 3D 
model. If your floor plan view template 
printed on a number of sheets, they should be 
combined into one. Exterior and interior wall 
surfaces should match throughout.

Adhere your complete floor plan view 
template to a sturdy and dedicated surface to 
provide support for your walls.

Walls

Walls should be cut and fixed to a rigid 
backing so that they can stand on their own 
and support the weight of the roof or floors 
above them. How they are cut and assembled 
varies depending on the desired final 
appearance of the model and how they were 
printed. 

It may be helpful to take the thickness of the 
rigid material being used into consideration 
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and override the scale thickness of the walls 
so that it agrees with your material thickness.

If your walls were resized in the Print Model 
dialog, you may see unwanted lines between 
floors that should merge together seamlessly. 
This is usually due to walls whose exterior 
surfaces match but overall thickness does 
not. You can prevent this by checking Use 
Scale Wall Thickness, which prevents walls 
from resizing. This is best if you do not want 
to print the interior wall surfaces, or are 

using a modeling material that closely 
matches the scale thickness of your walls.

Roofs

Roof planes are joined together when 
possible before printing. For each roof 
surface, the fascia and soffit surfaces are 
attached at the eave, so that the least amount 
of taping produces the roof and adjoining 
surfaces. 
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Chapter 37:

Layout

The Home Designer Pro layout facility offers 
a set of easy to use tools for arranging 
multiple views on a single page for printing. 

Each layout page can contain multiple views, 
details, images, CAD objects or text.

For detailed information about printing in 
Home Designer Pro, see “Printing & 
Plotting” on page 841.

Chapter Contents
•      Layout Defaults
•      Preparing for Layout
•      Creating a Layout File
•      The Layout Tools
•      Sending Views to Layout
•      CAD and Text in Layout
•      Pictures and Metafiles in Layout
•      Keeping Layout Views Current
•      Displaying Layout Views
•      Layout Page Display Options
•      Opening Layout Views
•      Managing Layout Links
•      Printing Layout Files
•      Exporting Layout Files
•      Layout Box Specification Dialog

Layout Defaults
To access the layout defaults for the 
current layout file, select Edit> 

Default Settings. The options in the Default 
Settings dialog are similar to those found in 
this same dialog in a plan file, although there 

are fewer choices in the list. See “Default 
Settings” on page 56. 

In the Default Settings dialog, select Layout 
and click Edit. 
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The settings in the CAD Defaults dialog in 
layout are similar to those in a plan file but 
only affect CAD drawn on the layout page. 
Some options that do not apply to layouts are 
disabled. See “CAD Defaults Dialog” on 
page 770. 

The settings in the Layout Defaults dialog 
are similar to those in the Plan Defaults 

dialog. Some options that do not apply to 
layouts are disabled. See “General Plan 
Defaults Dialog” on page 58. 

The settings in the Page Setup dialog are 
also file-specific and are particularly 
important considerations in layout files. See 
“Page Setup Dialog” on page 853.

Preparing for Layout
Very little preparation is necessary before 
creating a layout file. There are a few things 
that are helpful to keep in mind.

Printer Setup
You can print to any printer or plotter that 
uses a Windows driver and can change the 
current printer at any time in the Page Setup 
dialog. See “Page Setup Dialog” on page 
853.

Printing Services
Find out what paper size the print service 
uses and select it in the Page Setup dialog. 

If you plan to use a printing service, you will 
need to install a PDF writer. See “Printing to 
a PDF File” on page 848. 

You can also print to file using the driver for 
the printer that the service will use. See 
“Printer Drivers” on page 843.

Check Plots
When a large drawing sheet size has been 
specified, you can print a check plot at a 
reduced scale so that it can be printed on a 
smaller printer. This allows you to make final 
checks before printing to the larger size. See 
“Check Plots” on page 847.
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Creating a Layout File
Choose File> New Layout to create a 
blank layout file. A layout file is 

created with the name untitled.layout. 

If a layout file is not open when you try to 
send a view to layout, a warning message 
will ask you if you want to create a new 
layout file. See “Sending Views to Layout” 
on page 866.

To open an existing layout file, select File> 

Open Layout . Browse to a directory and 
select the layout file to open. See “Opening 
and Importing Files” on page 48.

Only one layout can be open at a time. When 
a layout file is open, it is listed at the bottom 
of the Window menu as an open view. 

Select File> Save  to save the layout file. 
It is important that you save the layout in the 
same directory as the plan file from which 

views have been sent to the layout page. See 
“File Management” on page 39.

Although it is possible to use multiple plan 
files with a layout, it is generally best to 
associate only one plan file with a layout and 
to use the same file name for both. If more 
than one plan file is used, all should be saved 
in the same directory as the layout file. 

When you save your layout, take a moment 
to also save the plan file associated with it. 

The Layout Tools
There are a variety of tools available 
to send views to layout and edit them, 

as well as manage links. 

Many of the tools available in layout are 
described in the Printing chapter. See “The 
Printing Tools” on page 844. 

Sending Views to Layout
Select File> Send to Layout to open 
the Send to Layout dialog and send 

the current view to the specified layout page. 
See “Sending Views to Layout” on page 866.

In floor plan view, select a saved cross 
section/elevation view symbol and 

click the Send Camera’s View to Layout 
edit button. See “Saving & Printing 3D 
Views” on page 690.

Select a layout view and click the 
Open View edit button to open the 

view that was originally sent to layout. This 
tool is only available for dynamic views. See 
“Editing Dynamic Views” on page 871.

Select Window> Swap Views to 
switch between the current view and 

When a view is sent to layout, the lay-
out view is linked to the .plan file. Do

not change the path name by moving the
.plan file to a new folder or renaming it. If the
path name is changed, the link in the layout
file must be reestablished for the view to
appear in layout. See “Managing Layout
Links” on page 873.
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the view that was current before it. See 
“Swapping Views” on page 656.

Click the Show Layout button to 
switch to a layout file that is currently 

open. 

Sending Views to Layout
Layout files can contain multiple 
views sent to it from one or more plan 

files. To send a view from a plan file to 
layout, select File> Send to Layout.

You can also send one or more saved, closed 
cross section/elevation views to layout by 
selecting the camera symbol and clicking the 

Send Camera’s View to Layout  edit 
button. See “Saving & Printing 3D Views” 
on page 690.

When a view is sent to layout, the program 
sends it to the layout file that is currently 
open. While more than one plan file can be 
open at once, only one layout file can be 
open at a time. 

If no layout file is open, the program 
searches for a layout file with the same file 
name as the plan that the view is being sent 
from. If it cannot find such a layout file, the 
program asks if you want to create a new 
layout and send the view to it.

To send a view to layout

1. Prepare the view so that objects that 
should be seen are visible and those that 
should not are suppressed. See “Layer 
Display Options Dialog” on page 104.

Remember that if the Reference Display 
is turned on when a view is sent to lay-
out, it becomes a static part of the view 
and cannot be turned off later. See “Ref-
erence Display” on page 327.

2. Select File> Send to Layout . In the 
Send to Layout dialog, the available 
options vary depending on the type of 
view being sent to layout.

3. Click OK to send the view to the speci-
fied layout page. Depending on the type 
of view and size of the model, you may 
see a progress indicator in the Status 
Bar. See “The Status Bar” on page 31. 
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Send To Layout Dialog

Select a radio button to specify the 
method of Scaling for the view sent to 

layout.
• Select Fit to Sheet to send the view to 

layout at no specific scale. The view can 
be resized on the layout sheet later. 

• Specify the exact scale for the view in 
layout. Both Imperial and metric units of 
measurement are available and can be 
selected independently. 

• When views are sent to layout at different 
scales, line weights and line styles are 
subject to the same scaling. See “Line 
Weights and Scaling” on page 850. In 
most cases this is not desirable. When 
Use Layout Line Scaling is checked, the 
lines in views sent to layout appear the 
same as lines drawn directly on layout. 
This option is not available for rendered 
views.

Which Send Options are available 
depends on the type of view being sent 

to layout.

• Select Entire Plan/View to send to lay-
out the extent of the plan that is visible 

when you click Fill Window . This 
option is available for Vector views, wall 
details, and cross section/elevation views.

• Select Current Screen to send only what 
is shown on screen to layout. This option 
is available for Vector Views.

• Select Current Screen As Image to send 
only what is shown on screen to layout as 
an embedded image. See “Picture File 
Box Specification Dialog” on page 813. 
This option is available for all views, and 
is the only option available for rendered 
views.

Specify the desired Send Position for 
the view. These options are available 

for all views.
• Check Snap to Active CAD Point to 

snap the view you are sending to layout 
to the active CAD Point. See “Point 
Tools” on page 772.

3
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• Check Show Layout Page to go to the 
selected layout page when you click OK.

The Vector View Options are only 
available when a 3D view using the 

Vector View Rendering Technique is sent to 
layout. See “Rendered and Vector Views” on 
page 665. These settings are preserved 
between sessions. 
• Check Use Edge Line Defaults and 

specify a Default Line Weight to over-
ride all layer specific and object specific 
line weight settings when the view is sent 
to layout. If unchecked, the layout view 
respects the Surface Edge Lines settings 
in the 3D View Defaults dialog. See “3D 
View Defaults Dialog” on page 668.

• Check Use Pattern Line Defaults and 
specify a Default Pattern Weight to 

override the Line Weight setting in the 
Define Material dialog. See “General 
Tab” on page 645.

• Uncheck Merge Generated Lines to 
prevent the merging of colinear lines. 
Horizontal and vertical lines still merge.

If Merge Generated Lines is selected 
and a cross section/elevation view is sent 
to layout, the program merges any lines 
that are superimposed or parallel with 
each other so that the layout has only one 
line rather than several. This makes the 
final view easier to edit in layout if neces-
sary, but may slow down the process of 
sending 3D views containing non-vertical 
or horizontal lines to layout.

CAD and Text in Layout
CAD objects and text can be 
incorporated into your layout by both 

including them in your views sent to layout 
and by drawing them on the layout page. 

In Views Sent to Layout
CAD and text in views sent to layout are 
scaled just like other objects in the view. If 
you want text in a layout view to print at a 
particular size, specify its size based on the 
scaling you will use when you send the view 
to layout. See “Character Size” on page 745.

If you rotate a view on the layout page, any 
text in that view will rotate as well, provided 

that its Text Style is using the Rotate with 
Plan setting. See “Text Styles” on page 765. 

On the Layout Page
CAD and Text objects can also be added 
directly to any layout page. These are added 
to the layout page itself, not to any specific 
view on the page which may have its own 
CAD and text objects within it.

CAD and Text objects created in layout can 
be selected and edited just as they can in 
other views. See “Editing Text” on page 754 
and “CAD Objects” on page 769.

4
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Pictures and Metafiles in Layout
Picture files and metafiles can be imported 
onto a layout page just as they can into floor 
plan view. See “Displaying Pictures and 
Metafiles” on page 817.

Views can also be sent to layout as pictures. 
In fact, Rendered views sent to layout are 
always treated as imported pictures 
embedded in the file. See “Send To Layout 
Dialog” on page 867.

A picture or metafiles imported onto the 
layout page can be selected and edited using 
its edit handles, edit tools and specification 
dialog. See “Editing Pictures and Metafiles” 
on page 817. 

Keeping Layout Views Current
If a plan changes after views of the model are 
sent to layout, some of the views may 
become out of date. Depending on the type 
of view, some may update automatically and 
other must be updated manually. 

Dynamic and Static Views
A dynamic view references the view saved 
with the original plan. Any changes made to 
the original plan update the dynamic layout 
view. 

For information about controlling the display 
of dynamic views in layout, see “Displaying 
Layout Views” on page 872.

A static view does not reference the original 
plan and does not update when the plan 
changes. Static views are like a snapshot 
taken at a specific time; subsequent changes 
do not appear in that snapshot. Changes 
made in the original plan must be resent to 
layout manually.

Floor Plan Views
Floor plan views sent to layout are dynamic. 
Any changes made to these items in plan are 
reflected automatically in layout.
• The display of everything is under your 

control. All editing must be done in floor 
plan view, and all changes are automati-
cally reflected in layout.

• To edit the layer settings of a floor plan 
view sent to layout, select the view and 

click the Open View  edit button. 
This opens the plan file where editing can 
be done. Any changes made update the 
layout.

• If the reference display is on when a floor 
plan view is sent to layout, it becomes a 
permanent part of that layout view. See 
“Reference Display” on page 327.

Bear in mind that when you open a view to 
edit it, any changes that you make to your 
layer settings will be reflected on the layout 
page. When you are finished making changes 
to your layout view and wish to resume work 

Embedded pictures increase layout
file size. Limit the number of large

and/or multiple pictures.
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on the plan, save your work, close the plan, 
and then open it again. This will help avoid 
unintended changes to your layout view.

Cross Sections/Elevations
Views created using the Cross Section/

Elevation , Wall Elevation , and 

Backclipped Cross Section  tools are 
dynamic, but their behavior in layout is 
different from other dynamic views.
• CAD objects, text, and dimenions can be 

added to cross section/elevation views. If 
the view has been sent to layout, they are 
automatically shown in the layout view 
provided that their layer was set to dis-
play in  the view’s layer set when the 
view was sent to layout.

• CAD objects added in a cross section/ele-
vation view can only be edited in the 
cross section/elevation view. 

• Double-clicking a cross section/eleva-
tion view in layout using the Select 

Objects  tool activates the original 
view, allowing you to modify the model 
or add CAD objects.

Updating Cross Sections/
Elevations

If a cross section/elevation view is sent to 
layout,and that camera view is later closed 
while the layout sheet is open, you will be 
asked to choose whether to update the view 
on the layout page. 
• If the layout view is up-to-date with the 

3D model or if you do not want your 
changes to be seen in the layout view, 
select No.

• To update the view on the layout page 
choose OK. Any changes that you might 
have made to the layout view will be lost.

Static Views
With the exception of Cross Section/

Elevation , Backclipped Cross Section 

, and Wall Elevation  views, all 
camera views and overviews sent to layout 
are static. They are treated as imported 
images embedded in the layout file. See 
“Picture File Box Specification Dialog” on 
page 813.

Any changes made to the 3D model have no 
effect on static views. To update these views 
in layout, delete the old view and send a new 
one. See “Dynamic and Static Views” on 
page 869.

Editing Layout Views
To edit a layout view, first select its layout 

box using the Select Objects  tool. Once 
selected, the view box can be edited using its 

edit handles, edit toolbar or specification 
dialog. See “Layout Box Specification 
Dialog” on page 875.
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Using the Edit Handles
Layout view boxes can be edited like CAD 
boxes. See “Editing Box-Based Objects” on 
page 141. 

Floor plan views can be rotated. Both the 
layout box and the view inside it rotate. 
Cross section/elevation and 3D views sent to 
layout cannot be rotated.

In the Specification Dialog
Layout views can be customized in their 
specification dialog. See “Layout Box 
Specification Dialog” on page 875.

Using the Edit Tools
A selected layout view or views can be 
edited in a variety of ways using the buttons 
on the edit toolbar. See “The Edit Toolbar” 
on page 29.

Moving Layout Views
Layout views can be moved using the Move 
edit handle using dimensions.  See “Moving 
Objects Using Dimensions” on page 737.

Copying Views 
Just like many objects, views sent to layout 
can be copied and pasted into different layout 
files. 

As a general rule, though, if multiple copies 
of a view are needed, it is best to send the 
view to layout as many times as necessary 
because each view can then be controlled 
independently.

Bear in mind, too, that if a layout has views 
copied from a different layout file and is later 
moved to a different location on your 
computer, the link to the original plan file 
may be broken. See “Keeping Layout Views 
Current” on page 869. 

Editing Dynamic Views
Select a dynamic view and click the Open 

View  edit button to open the original 
view that was sent to layout. You can also 
double-click a dynamic view in layout to 
open the original view. See “Dynamic and 
Static Views” on page 869.

Resizing Scaled Views
Scaled views retain their scale regardless of 
how you resize the border. You can resize the 
border proportionally from a corner handle 
or select one of the handles on an edge to 
change the size in one direction only. The 
image may be cropped if the border is resized 
small enough. 

Resizing Non-Scaled Views
If the view was sent to layout using the Fit to 
Sheet setting, resizing may have one of 
several results:
• Drag a corner handle in or out to resize 

both the border and the image proportion-
ally. 

• If you drag a side handle in or out, the 
image stays the same size, but the border 
changes. If you make the border smaller, 
it may crop the image; if you make it 
larger, you may show more of the image.
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Displaying Layout Views
When a view is sent to layout, the current 
layer display settings are used. See 
“Displaying Objects” on page 102.

Once sent to layout, static views cannot be 
changed. See “Dynamic and Static Views” 
on page 869. 

The layer display settings referenced by a 
dynamic view are saved with the plan rather 
than the layout file, and the display of the 
view can be modified by turning layers on or 
off in the original view. 

Layout Box Borders and Labels
A border will display around each layout box 
when the “Layout Box Borders” layer is set 

to display in the Layout Page Display 
Options dialog. See “Layout Page Display 
Options” on page 872. 

Layout boxes can also display labels when 
the “Layout Box Labels” layer is set to 
display. See “Object Labels” on page 884. 

Automatic layout box labels display basic 
information about the original view in the 
plan. For example, floor plan view sent to 
layout from Floor 1 will have an automatic 
label that says, “1st Floor”. A camera view 
sent to layout will have a label that states the 
camera’s name. Layout box labels can be 
customized in the Layout Box Specification 
dialog. See “Label Tab” on page 877.

Layout Page Display Options
Select Tools> Display Settings> 
Display Options from a layout file to 

open the Layout Page Display Options 
dialog.

The Layout Page Display Options dialog is 
similar to the Layers Display Options 
dialog, but controls only the display of 
objects drawn on the layout page, such as the 

layout borders and other CAD objects, text 
and dimensions. 

For information about how to use this dialog, 
see “Layer Display Options Dialog” on page 
104.

For information about controlling the display 
of views sent to layout, see “Displaying 
Layout Views” on page 872.

Opening Layout Views
Dynamic views sent to layout 
reference an original view in a plan. 

From the layout page, you can quickly access 
that original view by selecting a layout view, 
then clicking the Open View edit button. The 
original view can also be opened by double-

clicking the layout view using the Select 

Objects  tool.

Changes made in this view update in the 
original layout view.  Depending on the 
changes, other views may also be affected.
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Managing Layout Links
Home Designer Pro allows you to review 
plan files linked to a current layout, change 
existing links from one plan file to another, 
and reestablish links to plan files that have 
been moved or renamed.

Protecting Layout Links
Careful file management is needed to avoid 
missing files and disrupted layout links. See 
“File Management” on page 39.

The following guidelines can help prevent 
layout links from being broken:
• Save plan files in the same folder as the 

layout, or in a sub-folder in that folder.
• Legacy plan files referenced by a layout 

must have the .plan file extension. Plans 
from version 6.0 with the .pl file exten-
sion cannot link to .layout files.

• Custom graphics included in a plan or 
layout should be embedded in the file or 
saved in the same folder as the layout.

• Plan files should never be renamed. If a 
new name is desired, make a copy of the 
file and rename it. Changes made in the 
copy do not affect the layout.

• Avoid sending cross section/elevations to 
layout more than once. Changes made to 
the view can affect layout views in unin-
tended ways.

• Layout files should never be moved. If a 
layout file must be moved, the entire 

folder it is saved in should be moved or 
copied and then moved.

• Use File> Backup Entire Plan  to 
create an independent copy of the origi-
nal layout. Avoid use of “Save As.”  See 
“Backup Entire Plan” on page 52.

Finding Missing Files
When a layout file is opened, the program 
performs a breadth-first search for 
dynamically linked views. This means that it:
• Looks first in the same folder as the lay-

out. 
• Looks next in the folders located closest 

to the layout’s folder. 
• If a missing file is not found, it expands 

its search further from the location of the 
layout file until the files with the linked 
views are located.

• If a missing file is not found, a second 
breadth-first search will be performed, 
searching all zipped files found in the 
first search. 

If a file remains missing after the program 
performs a search of your system, a Warning 
message will indicate that the program could 
not successfully open all of the layout’s 
associated plan files. When you click OK, 
the Layout Files dialog will open, allowing 
you to relink the layout to its missing 
associated files.
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Layout Files Dialog

Files Present in Layout lists all files 
with intact links to the layout.

Files NOT FOUND in Layout lists the 
names of files with disrupted links to 

the layout. Any files listed here have been 
moved, renamed, or deleted and cannot be 
found by the program. Intervention is 
required to find these files and reestablish 
their links to the layout. 

Select a missing file and click the 
Browse button just above the NOT 

FOUND field to open the Browse For 
Missing File dialog, which is a typical Open 
dialog. See “Opening and Importing Files” 
on page 48.
• Locate the missing file in your system’s 

directory structure. When the missing file 
is selected, click Open to link it to the 
layout. 

• You can also redirect an intact link to 
from a File Present in Layout to a differ-
ent file in the same manner.

Be sure to choose File> Save  when the 
missing files have been located to save their 
links to the layout file.

Results of Missing Files
If all missing files are correctly redefined, 
the layout opens when you click OK. 

If an error message displays, one or more of 
the missing files could not be replaced by the 
redefined file. Click OK to continue. The 
layout opens, but with the following 
characteristics:

1. Any floor plan views associated with the 
missing file(s) are blank. Only the bor-
der displays.

2. Any elevations or cross sections associ-
ated with the missing file(s) show the 
automatically generated lines, but any 
added CAD objects are absent. 
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Printing Layout Files
Printing layout files is similar to 
printing directly from a view in a plan 

file. See “Printing Directly from a View” on 
page 846. 

As in a plan view, printing options for 
layouts are set in the Page Setup dialog. 
These options apply to the layout file. See 
“Page Setup Dialog” on page 853.

Select File> Print> Print  to open the 
Print dialog. See “Print Dialog” on page 855. 

Scaling
The drawing scale is specified in the Page 
Setup dialog. While you can specify any 
drawing scale that you wish, in nearly all 
circumstances, you will want the scale to be 
1 in = 1 in for all layout files. 

The views sent to your layout page has 
already been assigned a scale, and if you 
select a scale other than 1 in = 1 in in the 
Page Setup dialog, these views will be 
scaled a second time when printed. 

You can also print a Check Plot which is a 
test printing, typically at a smaller scale, 
made before final output to large paper 
format. See “Check Plots” on page 864.

When a view is sent to layout at a scale other 
than that used by the original view, line 
weights may be affected. See “Line Weights 
and Scaling” on page 850. 

Exporting Layout Files
A layout can be exported to a .dxf file 
much like any other vector-based 

view. 

The main difference is in the scale of the 
output, which is in scaled paper units rather 

than model units. If a 50” line in a plan 
would be scaled to 1” inch when printed, it is 
exported as a 1” line instead of its length 
before prior to scaling. See “Exporting 2D 
DXF Files” on page 833.

Layout Box Specification Dialog
A layout box is essentially a CAD box 
that contains a view that has been sent 

to layout from a plan. When selected, a 
layout box has edit handles similar to those 
of a CAD box that allow you to rotate, 
relocate, and resize the layout box. See 
“Editing Box-Based Objects” on page 141.

Select a layout view and click the Open 

Object  edit button to open the Layout 
Box Specification dialog, which is very 
similar to the CAD Box Specification 
dialog.

Layout views will print at their specified
scales only when the drawing scale for

the layout file is 1 in = 1 in.
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General Tab

Specify the Position of the selected 
view’s bounding box. See “3D 

Drafting” on page 25.

Specify the Size of the selected view’s 
bounding box. 

Specify the Number Height for 
Dimensions in the selected view. Type 

a (D) to use the default height for the selected 
view. See “Dynamic Defaults” on page 57. 

This setting is only available for views sent 
to layout from floor plan view and CAD 
Details. It affects the size of dimension 
numbers in the layout view but not in the 
original view in the plan file. 

Line Style Tab
The Line Style tab allows you to set the 
properties of the selected layout box and to 
specify the selected layout box’s layout page. 

For more information, see “Line Style Tab” 
on page 781. 

Fill Style Tab
For information about the Fill Style tab, see 
“Fill Style Tab” on page 792.

1
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The Number Height setting is included
for legacy files and is not the recom-

mended method of specifying dimension
size. See “Dimension Labels” on page 732. 
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Label Tab
Layout box labels display in floor plan view 
when the “Layout Box Labels” layer is 
turned on and use the Text Style assigned to 

that layer. See “Layout Box Borders and 
Labels” on page 872. 

For more information about the settings on 
this tab, see “Label Tab” on page 885.
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Chapter 38:

Plant Schedules &
Object Labels

A Plant Schedule is a table that lists  all of 
the plants in your plan and can include a 
variety of information about them, including 
quantities, common and scientific names, 
and growing needs. 

Schedules update automatically whenever a 
plant is created, deleted, moved, or altered.

You should check each schedule carefully to 
be sure it accurately represents what is in the 
model. Never assume it includes what you 
expect or need. 

A variety of objects in Home Designer Pro 
have labels that display information about 
them in floor plan view.In addition, plants 
can display callout labels with schedule 
numbers instead of their default labels. 

Chapter Contents
•      Creating and Editing Schedules
•      Schedule Specification Dialog
•      Columns to Include
•      Object Labels

Creating and Editing Schedules
In floor plan view, select Terrain> Plant> 
Plant Schedule, then click anywhere in the 
view to place a schedule at that location. You 
can continue clicking to place additional 
copies of the schedule. See “Click-to-Create” 
on page 113.

Schedules can be edited using the edit 
handles, the edit toolbar buttons, or the 
Schedule Specification dialog. 
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Edit Handles
A selected schedule has the same edit 
handles as a CAD box. See “Editing Box-
Based Objects” on page 141.

In addition, schedules have edit handles 
along the side of each column, in the 
Schedule heading near the top. Click and 
drag one of these handles to adjust the width 
of the columns on either side. 

In the Specification Dialog
The appearance and other attributes of 
schedules can be modified in the 

Schedule Specification dialog. 

You can control how objects are listed by 
specifying which Columns to Include. For 
example, if you were to uncheck “Common 
Names” and “Scientific Names” in the Plant 
Schedule Specification dialog, and then 
check “Flower Color”, the resulting schedule 
would list all red flowers in one line item, 
regardless of their species. 

Using the Edit Tools
A selected schedule or schedules can be 
edited in a variety of ways using the buttons 

on the edit toolbar. See “The Edit Toolbar” 
on page 29.

Schedule Numbering
Schedule numbering is dependent on the 
order in which objects are placed in the plan, 
as well as the floor they are on. 
• Any objects present in your plan before a 

schedule is created will be listed first in 
ascending alphanumeric order, according 
to their Label information.

• A new, unique objects placed in the plan 
after the schedule is created will be added 
to the bottom of the schedule in the order 
that they are placed, regardless of its 
Label information.

When an object is edited, its schedule 
number may or may not change: 
• If an object with a Quantity of 1 in the 

schedule is edited, its position in the 
schedule will not change.

• If a group of objects listed on the same 
row in a schedule are edited simultane-
ously, their position will not change.

• If an object listed on the same row in a 
schedule with other similar objects is 
edited so that it is no longer similar 
enough to share the same row, it will 
move to the bottom of the schedule. See 
“Columns and Quantity” on page 884.

Schedule Specification Dialog
Schedules can be edited in the 
Schedule Specification dialog. To 

open this dialog, either select a schedule and 

click the Open Object edit button or double-
click the schedule using the Select Objects  
tool.

The behavior of the edit handles may
depend on the currently active Edit

Behavior. See “Edit Behaviors” on page 120.



Schedule Specification Dialog

 881

Schedule Tab

Specify a Title for the selected 
schedule. Check Show Title to display 

the title at the top of the schedule. 

Include From Floor - Specify the floor 
whose objects appear in the schedule. 

The default for all schedules except for room 
and plant schedules is All Floors. 
• Uncheck All Floors to specify a particu-

lar floor in the text field. 

Columns to Include - Check the box 
for each column you want to display in 

the schedule. At least one column must be 
checked to create a schedule.

Columns may be added or removed at any 
time by selecting or clearing check boxes. 
See “Columns to Include” on page 884. 
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Attributes Tab

Specify the appearance of the selected 
schedule’s Tabs. 

• Check Box/Grid to display lines around 
the rows and columns of schedule, form-
ing boxes around each item.

• In the text field, specify the number of 
spaces from the left edge of the schedule 
where each new column begins. The first 
column always starts at 0. In this case, the 
second column starts 22 spaces in, the 
third, 31 spaces in, and so on.

Specify the Alignment of the selected 
schedule’s text within its columns by 

choosing an option from the drop-down list. 

Define the Position of the selected 
schedule.

• Specify the X and Y Positions of the 
schedule’s center point.

• Specify the schedule’s Angle.

Line Style Tab
The Line Style tab lis found in the 
specification dialogs for many different 
objects. For more information, see “Line 
Style Tab” on page 781.

Fill Style Tab
For information about the settings on this 
tab, see “Fill Style Tab” on page 792. 

Text Style Tab
The settings on this tab control the 
appearance of the selected schedule’s text. 
For more information, see “Text Style Tab” 
on page 766. 

Label Tab
The Label tab of the Plant Schedule 
Specification dialog controls the type, size 

and appearance of the labels that display in 
floor plan view. 
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Check Show Labels to display object 
labels in floor plan view. This also turns 

on the appropriate layer for the objects labels 
in the Layer Display Options dialog. See 
“Layer Display Options Dialog” on page 
104. 

You can suppress the label for an individual 
door or window by checking Suppress 
Label in the specification dialog for that 
object. See “Label Tab” on page 885. 

When Use Callout For Label is 
checked, the callout shape and size can 

be specified below. When this option is 
unchecked, Automatic or user specified 
labels are used. See “Label Tab” on page 
885.

• Select a Callout Shape. There are six 
shapes to choose from. 

When callout labels are used, the schedule 
numbers are included in the labels. Like 
other object labels, callout labels use the Text 
Style assigned to the layer they are on. See 
“Text Styles” on page 765. 

Specify the label Callout Size. 
• Select Calculate from Text for callout 

labels that are sized to accomodate the 
text within them. 

• Select Size and then type the radius in 
inches (mm). This radius will be used 
regardless of the size of the label text. 

Additional Label Text options are 
available here.

• Label Prefix - Specify the leading char-
acters used in callout labels or when 
Include Schedule # is checked.
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Columns to Include
Every schedule has a selection of Columns 
to Include on the Schedule tab of its 
Schedule Specification dialog. See 
“Schedule Tab” on page 881.

A complete list of the columns and objects 
available in the program can be accessed by 

selecting Help> Contents and Index  
from the program menu and browsing to 
Schedules> Columns and Objects to Include 
on the Contents tab of the Home Designer 
Pro 2014 Help.

Columns and Quantity
It is important to remember that the number 
of columns you choose to include in a 
schedule influences the number of separate 
line items that will be listed in the schedule. 

For example, if you have three paper birch 
trees in your plan and do not include columns 
that refer to the trees’ age, such as the 
Starting Age column, then the three trees will 
be listed in the same line item - even though 
one is young, one medium, and one adult. 

Object Labels
Object labels can display in floor plan view 
for a variety of different object types based 
on one of several parameters: 
• Automatic Labels provide basic informa-

tion about the object, such as its type, 
size, or name.

• You can create a custom label for an 
object in its specification dialog using 
text. See “Label Tab” on page 885.

Automatic Labels
Most objects that can display labels have an 
Automatic Label created by the program that 
states basic information about it. When 
Automatic Labels is selected in the object’s 
specification dialog, this is usually the label 
that will be used; however:
• If a user-defined label is specified in the 

object’s defaults dialog, that label will be 
used instead of the Automatic Label.

• If a user-defined label is specified in the 
object’s specification dialog, that label 
will be used instead of the Automatic 
Label.

• If the object is a plant included in a 
schedule and callout labels are specified 
in that schedule, a callout label will be 
used.

Displaying Labels
The display of object labels can be 
controlled by layer in the Layer 

Display Options dialog. Label layer names 
begin with the object type, followed by the 
word Label: for example, cabinet labels are 
located on the “Cabinets, Labels” layer. See 
“Layer Display Options Dialog” on page 
104.

You can choose to suppress the label for an 
individual object on the Label tab of its 
specification dialog. 
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You can also turn the display of plant labels  
on or off in the Plant Schedule 
Specification dialog. See “Label Tab” on 
page 882.

Object labels use the Text Style assigned to 
each label’s layer. For example, cabinet 
labels use the “Cabinets, Labels” layer’s Text 
Style. See “Text Styles” on page 765. 

The minimum on screen display size of 
labels can be specified in the Preferences 
dialog. See “Appearance Panel” on page 61.

With the exception of those for rooms, roofs, 
and cameras, labels can also be included in 
the Materials List, Master List and in the 
Components dialog. Items in the Labels 
column of the Materials List are editable; 
however, any changes will not be applied to 
the objects’ labels. See “Materials List 
Columns” on page 892. 

Label Tab
The Label tab is found in the specification 
and defaults dialogs for a variety of different 
objects. 

Most objects have a Suppress Label 
option. Check this box to suppress the 

selected object’s label in floor plan view. 

Bay, Box and Bow Windows and Mulled 
Window units have several settings for 
controlling Multiple Component labels. See 
“Window Labels” on page 288. 
• Select Suppress All Labels to display no 

label in floor plan view. Individual com-
ponents are counted in the Materials List. 

• Select Show Component Labels to pro-
duce labels for each component in floor 
plan view. Individual components are 
counted in the Materials List.

• Select Show Single Label for Entire 
Unit to produce one label for the unit and 
suppress component labels. When this 
option is selected, the settings that follow 
on the Label tab become enabled.

Note: If the selected object is a plant and you
choose a callout shape in the Plant Schedule
Specification dialog, the settings here are
overridden and the schedule label is used
instead. See “Label Tab” on page 882.

1
2

1
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These settings also affect how Bay, Box and 
Bow Windows and Mulled Window units are 
counted in the materials list. See “Window 
Labels” on page 288 and “Displaying Mulled 
Units” on page 285.

Specify the desired Label Options, 
which control what information is 

contained in the label. Not available for 
cameras. See “Displaying 3D Views” on 
page 677. 
• Select Automatic Labels to use the 

default label for the selected object. See 
“Automatic Labels” on page 884. 

• Select Specify Label to replace the 
selected object’s Automatic Label with 
whatever you type in the text field below.

When Specify Label is chosen, the 
selected object’s Automatic Label ini-
tially populates the text field  

• To use the selected object’s Component 
Code as its label, type 
%component_code%. See “Components 
Dialog” on page 901.

2
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Chapter 39:

Materials Lists

Home Designer Pro can calculate a Materials 
List in three ways: From All Floors, From 
Area, or From Room.

Materials Lists can be created, edited, and 
printed directly from the program. They can 
also be exported as text, html or xls 
(Microsoft Excel) format files for use in 
other programs.

Chapter Contents
•      The Materials List Tools
•      Creating an Accurate Materials List
•      Organizing Materials Lists
•      Materials List Display Options Dialog
•      Materials List Columns
•      Editing Materials Lists
•      Managing Materials Lists
•      Exporting the Materials List
•      Conditioned Area Totals
•      Structural Member Reporting
•      The Master List
•      Components Dialog

The Materials List is based on certain 
assumptions that may not match your 

building style. Home Designer Pro makes no 
representation as to the accuracy or reliability 
of the Materials List generated by Home 
Designer Pro. Always compare the Materials 
List with a manual take-off before providing a 
quote or ordering materials for a job. 
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The Materials List Tools
Select Tools> Materials List to 
access the Materials List tools.

A Materials List is like a snapshot of the 
current plan at the time that the list is made. 
Any changes made to the model after a 
Materials List is generated are not included 
in that list. Create a new Materials List if you 
would like it to include these changes. 

It is not necessary to wait until the plan is 
complete to generate a Materials List. In fact, 
you can create a series of Materials Lists 
reflecting costs at various stages of a project.

When you close a Materials List window, the 
program will ask if you want to save the 
Materials List. Type a name and click Yes to 
save the list or click No to close the list 
without saving it.

Calculate from All Floors
Select Tools> Materials List> 
Calculate From All Floors to 

generate a Materials List for the entire 
model.

Materials lists calculated from all floors can 
be lengthy, and only a portion of the list may 
display on your screen at one time. Use the 
scroll bars to scroll through the complete list. 
Move the pointer to cells in the list and click 
to make changes. 

Calculate From Area
Select Tools> Materials List> Calcu-
late from Area to produce a Materials 

List for the portion of a plan on a single floor 
that is included within a rectangular 
Materials Polyline. 

To use Calculate from Area

1. Select Tools> Materials List> Calcu-
late from Area . 

2. Click and drag a rectangle around the 
area of the current floor that you would 
like to produce a Materials List for. 

3. When the mouse button is released, a 
Materials List for the area within the 
rectangle will display. 

Calculate From Area rectangles are 
temporary and do not display in floor plan 
view after the list is created.

Calculate From Room
To create the Materials List for a 
room, select the room, then select 

Tools> Materials List> Calculate From 
Room. 

Calculate From Room  is also available 
on a selected room’s edit toolbar. See 
“Editing Rooms” on page 233. 

A Materials List calculated from a room is 
created for only the contents of that room: 
wall materials are not included.

For comparison, generate Materials Lists 
with and without a proposed plan modifi-

cation.
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Master List
Select Tools> Materials List> Mas-
ter List to open the Master List, a list 

of previously used materials and any added 
information such as price or manufacturer. 
See “The Master List” on page 899.

Materials List Management
Select Tools> Materials List> 
Materials List Management to open 

a list of saved Materials Lists associated with 
the current plan. See “Managing Materials 
Lists” on page 896. 

Creating an Accurate Materials List
In order to take full advantage of Home 
Designer Pro’s Materials List capabilities, 
there are several things to keep in mind. 
• The accuracy of your Materials List is 

directly related to the accuracy of your 
model. Floor and ceiling heights, wall 
lengths, and structural settings all directly 
affect Materials List calculations.

• It takes more than just making your draw-
ing look right to generate an accurate 
Materials List. If, for example, you use 
CAD lines to draw an item on a floor 
plan, that item will not be included in the 
Materials List. A better way would be to 
use a symbol or structural element.

• If you use custom materials, make sure 
their material definitions are set up cor-
rectly.

• Bear in mind that using generic objects 
like geometric shapes from the library to 
represent objects that aren’t available in 
Home Designer Pro can result in items 
being calculated in the Materials List in a 
manner that you might not expect.

Framing in the Materials List
You can specify whether framing materials 
are calculated by lineal foot, as a cut list, or 
as a buy list. See “Structural Member 
Reporting” on page 898. 

For more information about how framing 
appears in the Materials List, see “Framing 
and the Materials List” on page 462.

Organizing Materials Lists
You can control what items are calculated in 
the Materials List by specifying which 
categories are used.

In addition, you can control how much 
information about each item is included by 
specifying which columns to display. 

There are some parts of a model that cannot 
be excluded from the Materials List. Floor 
and ceiling platforms are prime examples. If 
you need to generate a Materials List for only 
part of a plan, such as an addition, consider 
making a copy of the plan file. In the copy, 
delete the as-built portion of the plan and 
then generate a Materials List.
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Categories
The line items in the Materials and Master 
Lists are organized into a set of predefined 
categories, such as Electrical and Framing, 
which display in the ID column.

You can specify which category each item 
belongs to in the Materials List and Master 
List. In addition, many items can be assigned 
to a category prior to generating a Materials 
List in the Components dialog. See 
“Components Dialog” on page 901.

To specify a line item’s category

1. Create a Materials List, open the Master 
List, or open the Components dialog 
for a particular object.

2. Click in the cell in the ID column for a 
line item.

3. Select the desired category from the 
drop-down list that becomes available.

The categories that are available cannot be 
altered; however, you can specify which 
categories are included in the Materials List 
in either of two ways:

Categories

Columns
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• Globally, in the Preferences dialog. See 
“Materials List Panel” on page 82. 

• For individual lists in the Materials List 
Display Options dialog. See “Materials 
List Display Options Dialog” on page 
891.

Subcategories
You can create any number of subcategories 
for each Materials List category in the 
Preferences dialog. See “Categories Panel” 
on page 85. 

Items can be assigned to a subcategory in the 
Materials List and, for many items, in their 
object’s Components dialog in the same 
manner that they can be assigned to a 
category. 

Materials List Columns
There are two ways to specify which 
columns are included in the Materials List as 
well as the order in which they display:
• Globally, in the Preferences dialog. See 

“Report Style Panel” on page 83. 
• For individual lists in the Materials List 

Display Options dialog.

Materials List Display Options Dialog
When a Materials List or the Master 
List is open, select Tools> Display 

Options to open the Materials List Display 
Options dialog for the currently open list.

In the Materials List Display Options dialog 
for the Master List, only the Columns tab is 
available. See “The Master List” on page 
899.

Categories Tab

Check the box beside the name of each 
category that you want to include in the 
active Materials List. 
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These categories appear in the ID column in 
the order they are presented here. 

The Materials List changes automatically to 
reflect any changes you make as soon as the 
OK button is clicked.

Columns Tab

Check the box beside each column you want 
to include in the Materials List. You can 
suppress the column’s display by removing 
the check next to the column name.

Columns appear in the Materials List in the 
same order that they display here. 

Move Up - Click on a column name, then 
click this button to move that item up one 
place in the list. 

Move Down - Click this button to move the 
selected column down in the list.

Options Tab

Check Restrict to Floor and select a floor 
number to restrict the Materials List to. 
Whcn unchecked, the Materials List includes 
all floors. 

If you plan to buy materials from multiple 
suppliers, you can create a Materials List for 
each. Check Restrict to Supplier, then 
choose a supplier from the drop-down list. 
The resulting materials list will include only 
materials to be purchased from that supplier.

Suppliers can also be added to the list in the 
Components dialog. See “Components 
Dialog” on page 901.

Materials List Columns
The columns in the Materials List, the 
Components dialog, and the Master List are 
very similar, but not all columns appear in all 
places. 

The following lists the capabilities of each 
column.

Note: The information in a suppressed category 
is still part of the Materials List. If the Materials 
List is exported, suppressed categories are 
exported, as well.
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Column 
Name Available In Editable In Description

ID Materials List, 
Master List,
Components Dialog

Materials List, 
Components Dialog 

Displays an automatically generated identi-
fier for each line item. Select the cell in this 
column to change an item’s category.

Use Master List, 
Components Dialog

Master List, Com-
ponents Dialog

Check boxes indicate if each item is 
included in the Materials List. 

Sub 
Category

Materials List, 
Components Dialog

Materials List, 
Components Dialog

Select a cell in this column to change a line 
item’s subcategory. 

Floor Materials List N/A States the floor that the line item is located 
on. See “Multiple Floors” on page 315. 

Label Materials List, 
Master List,
Components Dialog

Materials List Lists the label that displays in floor plan 
view for most items that have labels asso-
ciated with them. See “Object Labels” on 
page 884. 

Supplier Materials List, 
Master List,
Components Dialog

Materials List, 
Master List,
Components Dialog

Specify a supplier for the item. A Supplier 
in the Master List is not used if one has 
been entered in the Components dialog.

Manufac-
turer

Materials List, 
Master List,
Components Dialog

Materials List, 
Master List,
Components Dialog

Specify a manufacturer for the item. A 
Manufacturer in the Master List is not used 
if one has been entered in the Components 
dialog.

Code Materials List, 
Master List,
Components Dialog

Materials List, 
Master List,
Components Dialog

Specify a Code, such as a SKU, for the 
item. A Code in the Master List is not used 
if one has been entered in the Components 
dialog. The Code can also be used in a 
schedule or used as a label. See “Plant 
Schedules & Object Labels” on page 
879. 

Size Materials List, 
Master List,
Components Dialog

Materials List, 
Components Dialog

Click in a cell to edit the size description of 
the line item. To restore the original size, 
delete the text you typed in. For a blank 
cell, type a single blank space
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Descrip-
tion

Materials List, 
Master List,
Components Dialog

Materials List, 
Components Dialog

Click in a cell to edit the description of the 
line item in the same way that the Size can 
be edited. 

Quantity Master List Master List Specify how many of an item must be 
found before information from the Master 
List is applied to it in a Materials List. If at 
least this many items are found, price, sup-
plier, and other information is used. 

Count Materials List, 
Components Dialog

Components Dialog This is the actual number of an item, either 
associated with the selected object or in 
the Materials List. Count can increased for 
accessories added to a selected object.

Extra Materials List, 
Components Dialog

Materials List, 
Components Dialog

Specify an additional amount of the line 
item. Changes made in the Components 
are reflected in the Count column in the 
Materials List.

Unit Materials List, 
Components Dialog

Materials List, 
Components Dialog

Indicates the units used to measure an 
item. When the unit is changed, the Quan-
tity updates to reflect the change.

Price Materials List, 
Master List,
Components Dialog

Materials List, 
Master List,
Components Dialog

This is the price of an item per unit. A Price 
in the Master List is not used if one has 
been entered in the Components dialog.

% 
Markup

Materials List, 
Master List,
Components Dialog

Materials List, 
Master List,
Components Dialog

Specify a markup percentage for the item. 
A markup in the Master List is not used if 
one has been entered in the Components 
dialog.

Labor Materials List, 
Master List,
Components Dialog

Materials List, 
Master List,
Components Dialog

Specify a labor cost for the item. A Labor 
value in the Master List is not used if one 
has been entered in the Components dia-
log.

Equip-
ment

Materials List, 
Master List,
Components Dialog

Materials List, 
Master List,
Components Dialog

Specify an equipment cost related to the 
item. An Equipment value in the Master 
List is not used if one has been entered in 
the Components dialog.

Total 
Cost

Materials List, 
Components Dialog

Materials List, 
Components Dialog

This is the total cost based on Count, Unit, 
Price, % Markup, Labor and Equip values.

Column 
Name Available In Editable In Description
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Editing Materials Lists
Materials lists can be edited in a variety of 
ways. You can adjust the width of a column 
by clicking and dragging the bar on the right 
side of the column name. 

Adding Information
You can enter information in the Price, 
Supplier, Code, Comment and Manufacturer 
columns for each item. 

Adding price or other information for any 
item is straightforward. Simply click in the 
cell and type the desired information. When 
the information is correct, you can add it to 
the Master List. See “Adding to the Master 
List” on page 901. 

You can switch between several existing 
suppliers or manufacturers for a given item 
by double-clicking on the right side of the 
cell in an appropriate column. A drop-down 
arrow displays to the left of the cell. Click it 
to view a list of suppliers or manufacturers 
for that item and select one.

When a Materials List is calculated, you can 
have the program search the Master List for 
Price, Supplier, and Code information for 
each item by selecting Tools> Update From 
Master. The information used is marked as 
“Default” in the Master List. See “Materials 
List Columns” on page 892.

Changing Information
Although the information in some columns 
cannot be saved to the Master List, you can 
change the information in any column in an 
individual Materials List. As with added 
information, click in a cell to select the 
existing text, then type in the desired text. 

To move an item in a Materials List to a new 
category, select the cell in the ID column and 
choose a new category from the drop-down 
list that becomes available. You can also 
select a subcategory by clicking in the cell in 
the Sub Category column. See “Categories” 
on page 890.

Default Master List Master List Indicates which item is to be used as the 
default when more than one item is avail-
able. Click in  this column to specify the line 
item as the default.

Com-
ment

Materials List, 
Master List,
Components Dialog

Materials List, 
Master List,
Components Dialog

Additional information related to the item 
can be entered here. A Comment in the 
Master List is not used if one has been 
entered in the Components dialog. A Com-
ment can also be used in a schedule.

Column 
Name Available In Editable In Description



896

Home Designer Pro 2014 Reference Manual

Total Cost
Total Cost is calculated using the Count, 
Unit, Price, %Markup, Labor and Equipment 
columns to calculate the cost. The formula 
used is: 

(Count + Extra) * Price * (1 + (%    
Markup/100)) + ((Count + Extra) * Labor) 
+ ((Count + Extra) * Equipment)

If a column does not appear, 0 is used for the 
value of that column with the exception of 
Count and Price, which are always used in 
the calculation even if they are not shown.

Copying Information
Portions of a Materials List can be copied 

and then pasted into a Text  object or into 

a word processing program or spreadsheet 
program using the standard Windows Copy 
(Ctrl + C), Cut (Ctrl + X), and Paste 
(Ctrl + V) commands. See “Copying & 
Pasting Text” on page 756.

Changing the Font
The font used for Materials Lists, the Master 
List and the Components dialog can be 
specified in the Preferences dialog. See 
“Font Panel” on page 64.

The size of the font used for Materials Lists, 
the Master List and the Components dialog 
can also be specified in the Preferences 
dialog. See “Report Style Panel” on page 83.

Managing Materials Lists
Select Tools> Materials List>  
Materials List Management to open 

the Materials List Management dialog, 
where you can access and manage a list of 
saved Materials Lists.

Click on the name of a saved Materials List 
in the list on the left to select it.
• Done - Close the Materials List 

Management dialog. 
• Help - Open the Help Index to the page 

describing this dialog.
• Edit - Open the selected Materials List. 

You can also double-click an item in the 
list.

• Delete - Delete the selected Materials 
List.

• Rename - Open the Rename Materials 
List dialog and type a new name for the 
list.
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Exporting the Materials List
Any Materials List can be exported 
into a text (.txt) file that can be 

opened directly by most spreadsheet 
programs. In a Materials List window, or in 

the Master List, select File> Export Materi-
als List to open the Materials List Export 
Options dialog.

Specify the File Type that you would 
like to export to.

• Select Tab Delimited (TXT) to create a 
text file with a tab between each field 
entry in the Materials List, and a carriage 
return between each row. 

• Select Comma Delimited (CSV) to cre-
ate a text file with a comma between each 
field entry in the Materials List and a car-
riage return between each row. 

• Select Excel (XLS) to create a Microsoft 
Excel format file.

• Select HTML to create an html file that 
you can view with your web browser.

Additional export options are available 
here.

• Check No Column Headers to prevent 
column headings from appearing in the 
first row of the text file.

• Check Run Default Spreadsheet or Edi-
tor to open the exported file with the pro-
gram specified on your computer when 
you finish exporting. 

When you click OK, the Write Materials 
Export File dialog will open. This is a typical 
File Save dialog. See “Exporting Files” on 
page 45. 

Estimating Software
You can export a Materials List to a word 
processor or spreadsheet program to arrange 
it in your estimating format. You can also 
export the Materials List to a number of 
commercial estimating programs in whose 
databases you can keep your current pricing, 
labor costs, and  markups and generate 
reports based on this data. 

Before purchasing an estimating software 
program, be sure that the program supports 
the direct import of Home Designer Pro 
Materials Lists. 

Any questions regarding estimating software 
packages and how they interact with Home 
Designer Pro should be directed toward the 
company providing the estimating software. 
Home Designer Pro is unable to provide any 
technical support for third party programs.

1
2
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Conditioned Area Totals
The Materials List calculates the total areas 
of walls, floors, ceilings, doors and windows 
that separate the conditioned space in a plan 
from unconditioned space. This information 
is listed in the General category of the 
Materials List. See “Categories” on page 
890.

Conditioned area totals can be entered into 
third party programs such as REScheck to 
determine whether the plan meets the energy 
code in use in your area. 

Walls, doors and windows are categorized as 
north, south, east, or west facing for the 
purposes of conditioned area totals. These 
directions  are based on the orientation of the 

plan’s North Pointer . If no North 
Pointer is used, north is assumed to be 

straight up on screen in floor plan view. See 
“North Pointer” on page 778. 

If a wall is oriented at 45º or less to north in a 
plan, it will be categorized as a “North” wall. 
Any doors and windows in this wall will also 
be categorized as “North”.

Similarly, south-facing walls, doors and 
windows are categorized as “South” if they 
are oriented at 45º or less of south in the plan.

Walls, doors and windows oriented within 
45º of either east or west will be classified as 
“East” or “West”, respectively.

The orientation of a curved wall is based on 
the direction of its chord. See “Drawing Arcs 
- Arc Creation Modes” on page 784. 

Doors are always categorized as doors rather 
than as glass (windows). This is the case 
even when a door is specified as a Glass 
Door or when it is part of a mulled unit.

Structural Member Reporting
The Structural Member Reporting 
dialog allows you to specify the 

method used to calculate framing members 
in the Materials List.  

To open the Structural Member Reporting 

dialog, select Edit> Default Settings , 
then select “Structural Member Reporting” 
from the tree list and click the Edit button. 
See “Default Settings vs Preferences” on 
page 56. 

You can also open this dialog by clicking the 

Structural Member Reporting  button, 
which can be added to your toolbars. See “To 
add a button to a toolbar” on page 94. 

You can create a list of the framing member 
sizes that you wish to purchase, and if an 
item in The Materials List is the same length 
as or shorter than one of these defined 
lengths, it will be described using the defined 
length rather than its actual length. 

Home Designer Pro does not check 
plans for compliance with building or 
energy codes.
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Structural Member Reporting Dialog

Choose a Method for reporting 
structural members in Materials 

Lists. The selected method will affect 
subsequently created Materials Lists, but not 
any that may already exist. 
• Select Mixed Reporting to calculate 

framing materials using a combination of 
lineal lengths and piece counts.

• Select Total Lineal Length to calculate 
the framing materials of the different 
structural components of the plan in linear 
feet. 

• Select Cut List to calculate the framing 
materials of the different structural com-
ponents of the plan by counting the indi-
vidual pieces present in the model.

• Select Buy List to calculate the framing 
materials of the different structural com-
ponents of the plan by counting individual 
pieces and matching them to common 
board lengths.

Specify the Length Units, from the 
drop-down list. The unit or units 

selected are used in the Materials List when 
either Cut List or Buy List is selected as the 
method of reporting. 

The Master List
Select Tools> Materials List> Mas-
ter List to specify price, supplier, 

manufacturer, and other information for all 
of the items in your Materials Lists. 

When a Materials List is calculated, click on 
a row number to select the row, then select 
Tools> Update from Master to have the 
program search the Master List for a record 
for the selected line item. If an identical 
record is available, its information is 
included in the Materials List. 

• Multiple rows can be selected by clicking 
on one row number, then holding down 
the Shift key and clicking on additional 
row numbers.

• Select all rows by clicking the cell at the 
top left corner of the Materials List, above 
the row numbers.

If the Master List contains more than one 
record for an item, the program references 
the last one entered. You can override this by 
defining one specific entry as the default. 

1
2
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This is achieved by clicking on the check box 
in the Def column. 

Home Designer Pro allows you to have more 
than one Master List. Only one can be active, 
however, and only the active list is updated 
with new information. You can specify 
which Master List is active in the 
Preferences dialog. See “Materials List 
Panel” on page 82. 

The Master List is almost identical to a 
Materials List, but has a few additional 
controls to help with viewing. 

The Category drop-down list at the top 
left corner of the window lets you select 

one particular category for display, or all 
categories.

As with individual Materials Lists, you 
can specify which Columns display in 

the list. See “Materials List Display Options 
Dialog” on page 891.

Use the Find field near the bottom of 
the window to search for text in the 

Master List.

The search starts from the currently selected 
cell and moves to the right, then moves down 
to the next row starting at the left column, 
and so on, until it finds an instance of the text 
you entered. 

The Status Bar at the bottom indicates 
how many entries are listed.

You should regularly back up the Master 
Materials List (mmaster.mat) or lists using 

Windows Explorer.

1
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Adding to the Master List
You can add edited records in a Materials 
List to the Master List by selecting Tools> 
Update to Master.

To use Update to Master

1. Create a Materials List and make 
changes to any editable column of a line 
item.

2. Select the line item by clicking on the 
line number on the left side of the list. 
When selected, then entire line becomes 
highlighted. 

3. You can select multiple adjacent rows by 
holding down the Shift key while click-
ing. 

4. Select Tools> Update to Master. The 
information in the selected line is saved 
in the Master List. 

Once Master List information exists for a 
particular item, you do not need to enter it 
again until you want to update it. 

Similarly, items in a Materials List can be 
updated to include changes made to the 
Master List by selecting rows in the Master 
List, then selecting Tools> Update from 
Master.

Editing the Master List
In the Master List, existing line items can be 
modified or deleted. For information about 

the editability of columns in the Master List, 
see “Materials List Columns” on page 892.

Often, the Master List will include items that 
you may not want to include in all Materials 
Lists.
• Checkboxes in the Use column indicate 

whether each item is included in the 
Materials List. If Use is unchecked, the 
item is not included. This is useful in 
cases where several line items will be pur-
chased as a single unit.

•  This Quantity column is used to specify 
how many of an item must be found 
before information from the Master List is 
applied to it in a Materials List. If at least 
this many of the item are found, price, 
supplier, and other information is used. 
Quantity is useful for applying a quantity 
discount.

• When more than one line item is available 
for a specific component or accessory, the 
Default column indicates which item is to 
be used. Click this column to specify this 
item as the default. This is useful when a 
line item has been updated to the Master 
List more than once with different price, 
supplier or other information.

To delete a row from the Master List, click 
on the row number at the far left. The entire 
row highlights. Select Edit> Delete, click the 

Delete  button, or press the Delete key on 
your keyboard.

Components Dialog
Many architectural objects in the 
program, from walls to cabinets to 

images, have components and accessories 

associated with them that are calculated in 
the Materials List.
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In addition to editing and adding information 
for objects and their accessories in the 
Materials and Master Lists, you can edit and 
add information directly to these objects in 
the Components dialog. 

Select an object, then click the 

Components  edit button to open the 
Components dialog for that object. 

You can also define the Components for a 
variety of items saved in unlocked categories 
of the Library Browser. When a library item 
is placed into a plan, its Components 
information goes along with it. See “Editing 
Library Objects” on page 625. 

The information in the Components dialog 
is the same as the Materials List line item(s) 
for the selected object and can be edited in 
much the same way. See “Editing Materials 
Lists” on page 895. 

Price, Supplier, Manufacturer, Comments, 
Code and Type information can be added and 
saved with the object itself. When that object 
is copied, even into a different plan, this 
information is transferred, as well, and will 
be calculated in the Materials List.

In addition to their components, cabinets also 
have subcomponents such as their doors, 
drawers and hardware. Subcomponent 

information in the ID, Size and Description 
columns is indented to help distinguish it 
from regular component information. 

If the selected object has a label, information 
in the Code column can be displayed in the 
label. In the object’s specification dialog, 
select Specify Label and type the text macro 
%component_code%. See “Label Tab” on 
page 885.

Accessories
In the Components dialog, you can add 
additional Materials List entries to a selected 



Components Dialog

 903

object. These user-created entries are called 
Accessories. 

To create a new accessory

1. Select an object and click the 

Components  edit button to open the 
Components dialog.

2. Click the Add button and a new line is 
added to the spreadsheet. 

3. The new entry is given an item name of 
Accessory#. You can give it any name 
you wish. 

4. All other columns for accessory items 
except ID can also be edited. 

5. To remove an accessory, click any part 

of its row and click the Delete  edit 
button.

To create a new cabinet sub-accessory

1. Select an object and click the 

Components  edit button to open the 
Components dialog.

2. Click in any cell in the row of the com-
ponent with the Description that 
matches the cabinet type: base, wall or 
utility cabinet. 

3. Click the Add button. A new line is 
added to the spreadsheet and its ID, Size 
and Description information is indented 
to denote that it is a sub-accessory. 

Note: Accessory quantities can only be edited 
when one object is selected. If multiple objects 
are group selected, accessory quantities are 
locked. 
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Appendix A

Additional
Resources

Home Designer Pro offers a variety of 
resources to help you become familiar with 
the many features it offers.

•      Reference Manual

•      User’s Guide
•      Home Designer Web Site
•      Home Talk Online User Forum
•      Technical Support

Reference Manual
The Home Designer Pro Reference Manual 
is a comprehensive source of information for 
Home Designer Pro 2014. Chapters are 
organized by subject, beginning with the 
fundamental concepts and progressing to the 
more advanced features. The Reference 

Manual is presented in .pdf file format and 
includes a Table of Contents and Index. This 
manual is available online by selecting 

Help> View Reference Manual  from 
the program menu.

User’s Guide
Written for new Home Designer Pro users, 
but a helpful reference for users of all 
experience levels as well, the User’s Guide 
features a series of tutorials designed to 
introduce the basics of using the program.

The Home Designer Pro User’s Guide is 
organized by topic and walks you through 

the process of creating a complete model, 
from the first wall to the interior design and 
landscaping.  

This guide is available online by selecting 
Help> View User’s Guide from the program 
menu.
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Online Help Videos
Another resource designed to illustrate Home 
Designer Pro’s powerful tools is the set of 
tutorial videos available on our web site. 

To view the online videos, select Help> 
View Online Help Videos from the program 
menu or visit 
video.homedesigner.chiefarchitect.com/vid-
eos.

Home Designer Web Site
If you have questions that the Reference 
Manual and online Help feature have not 
answered, feel free to turn to the our web 
site. 

A database of common technical support 
questions and answers related to supported 

versions of Home Designer Pro is available 
through a searchable interface. 

Select Help> Visit Home Designer Web 

Site  from the menu to launch your 
default internet browser to 
 www.HomeDesignerSoftware.com.

Home Talk Online User Forum
The Home Talk Bulletin Board offers several 
ongoing discussions about a variety of topics 
related to the use of Home Designer Pro. It's 
rich with useful tips and available free of 
charge to all registered Home Designer Pro 
users. 
• Discussions are initiated and carried out 

by users. 

• Experienced users share knowledge with 
each other and beginners. 

• Home Designer Pro Staff members post 
announcements, advice and technical 
information. 

To visit the Home Talk forum, select Help> 
Home Talk or go to:  HomeTalk.HomeDe-
signerSoftware.com.

Technical Support
Chief Architect takes pride in offering world 
class technical support services that can be 
accessed by telephone or on our web site. 
Select Help> Technical Support from the 
program menu to visit: 
 www.HomeDesignerSoftware.com.

Before contacting Technical Support, take a 
moment to see if the answer to your question 
is found in the Reference Manual, tutorial 
videos, or in our on-line Help Database at 
 www.HomeDesignerSoftware.com. 

http://video.homedesigner.chiefarchitect.com/videos
http://video.homedesigner.chiefarchitect.com/videos
http://www.homedesignersoftware.com/
http://hometalk.homedesignersoftware.com/
http://hometalk.homedesignersoftware.com/
http://www.homedesignersoftware.com/support/
http://www.homedesignersoftware.com/
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When you contact us, Technical Support will 
refer you to these resources if the answer can 
be found there.

So that our Technical Support specialists can 
assist you as efficiently as possible, please 

refer to “Technical Support Services” on 
page 909 for additional trouble-shooting 
suggestions and information that will be 
needed before placing your call.

Upgrade to Chief Architect
Chief Architect is a premium, professional 
residential drafting and 3D design program 
that allows builders, architects and other 
professionals in the building and interior 
design trades to produce construction 
documents and high quality 3D renderings of 
their plans. 

Chief Architect can open and edit plans 
created in Home Designer Pro. In addition, 

Home Designer Pro can open plans created 
in Chief Architect for viewing, as well.

To learn more, select Help> Upgrade to 
Chief Architect. to launch your default web 
browser to www.chiefarchitect.com.

http://www.chiefarchitect.com/
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Appendix B

Technical Support
Services

Chief Architect is committed to providing 
world-class technical support to complement 
our professional products. 

The primary function of technical support is 
to make sure our software is functioning 
correctly and to help you quickly resolve 
problems that prevent its normal use. Our 
technical support professionals are eager to 

work with you to make certain our software 
is functioning as designed. 

We have also assembled a team of certified 
trainers offering instruction in the use of our 
software. Training is available via online 
seminars, online personal training, and on-
site classroom seminars.

Reference and Training Resources
Chief Architect offers a variety of reference 
and training options in addition to the 
resources that come standard with the 
program. 

Help Database
The Home Designer online Help Database 
contains a variety of articles describing how 
to resolve common technical problems and 
achieve specific design goals. 

The Help Database is found in the Technical 
Support section of the Web site and can be 
referred to again and again at your 
convenience at 
 www.HomeDesignerSoftware.com .

Video Training
Chief Architect has developed a collection of 
training videos that contain in-depth training 
on a wide range of topics from beginning to 

http://www.homedesignersoftware.com/support/database.html
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advanced experience levels. These videos are 
available on our Web site,  
 www.HomeDesignerSoftware.com .

Interactive Training
If you have questions about how to use 
Home Designer Pro, consider contacting our 
Training Department for a Personal Training 
session. 

Personal Training is an excellent way to 
learn how to use the program, providing one-
on-one interaction with a certified Chief 
Architect trainer via the internet. Discuss  

topics that interest you and learn how to 
accomplish your specific design goals.

User Forum
Our Home Talk User Forum is a great place 
to discuss and exchange ideas with other 
Home Designer Pro users. Here you can post 
questions, read discussions from other users, 
and post suggestions to improve our product. 
In addition to our regular users, from time to 
time our support and engineering teams 
monitor the forum and provide input and 
discussion on current topics. This resource is 
available free of charge at   
HomeTalk.HomeDesignerSoftware.com. 

Troubleshooting Common Technical Issues
Chief Architect strives to make certain our 
software works correctly; however, from 
time to time issues arise that prevent its 
normal operation. 

Installation Issues
The following are common reasons for 
installation failure of Home Designer Pro 
and other software:
• Anti-virus software is enabled and inter-

fering with installation. Anti-virus soft-
ware is the most common cause of 
installation failures for any type of soft-
ware. Refer to your anti-virus software’s 
documentation for details on how to dis-
able the software and re-enable it once 
installation is complete.

• The recommended minimum system 
requirements are not met. See “System 
Requirements” on page 7.

• The computer has a CD drive but not a  
DVD drive. A standard CD drive will not 
read DVD discs. 

• The DVD has fingerprints, scratches, or 
other defects. Sometimes a small finger-
print can prevent the program from 
installing. Clean the disk with soft cotton 
cloth. Be sure to use soft cotton rather 
than paper products on disks to avoid 
scratching.

• You do not have sufficient rights to install 
the software. Verify that you have admin-
istrative rights and the administrative 
password during the installation process. 
If you are on a corporate network, consult 

If you see visible cracking on a CD or
DVD, do not insert it in your CD/DVD

drive. Cracked disks can fly apart and cause
damage to your drive.

http://video.homedesigner.chiefarchitect.com/videos
http://hometalk.homedesignersoftware.com/
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your network administrator for assis-
tance.

Refer to the on-line Help Database for 
solutions to common installation problems. 
If the answer to your question is not found 
there, contact our Technical Support 
department for assistance.

Emergency Transfer Message
When using Software Lock Security, you 
may receive an Emergency Transfer message 
when moving from one computer to another. 
To avoid this message, you must deactivate 
your license on the last computer on which 
you ran the program. See “Deactivating 
Home Designer Pro Licenses” on page 23.

If you must use the Emergency Transfer, type 
in the code you were given when you 
registered the program. See “Completing the 
Registration Wizard” on page 20.

Remember that you have a limited number of 
Emergency Transfers and that if you use 

them all, you will need to purchase 
additional transers from Chief Architect, Inc. 
You can avoid this expense by always 
deactivating your license before using it on a 
different computer, or by purchasing an 
additional license.

Hardware Lock Not Recognized
If you are using Hardware Lock Security and 
your hardware lock is not recognized on 
startup, launch the Hardware Lock 
Troubleshooter. The Troubleshooter can 
diagnose and provide solutions to most 
common problems with hardware locks. 

The Hardware Lock Troubleshooter can also 
be launched manually by selecting Help > 
Hardware Lock Troubleshooter. 

Troubleshooting Printing Problems
Printing problems fall into two main 
categories: those that prevent the printer 
from working in any program and problems 
printing from Home Designer Pro. To 
determine if the problem is specific to Home 
Designer Pro, try the following:

1. Begin by clicking on the Windows Start 
button, and select Printers. 

2. Right-click the printer that is not func-
tioning properly in the Printers folder. 

3. Click Properties from the menu that 
appears.

4. On the General tab, click the Print Test 
Page button. 

If the printer does not produce a test page, 
the problem is not one that Chief Architect 
Technical Support can solve. Follow these 
suggestions:
• Check the connection between the com-

puter and the printer.
• Check your printer documentation for 

troubleshooting printer problems.

If you use an Emergency Transfer, your
license will be immediately deactivated

on the other computer.
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• Contact your printer's manufacturer or 
check their Web site for support informa-
tion. 

Your printer manufacturer is the best 
resource for solving problems of this type. 
Chief Architect Technical Support is not able 
to help diagnose and solve problems that 
prevent printing from any program. 

Printers and plotters vary widely in how they 
function. Sometimes a faulty cable can be a 
problem. Other times, a plotter may require 
that the paper be loaded in a different 
orientation. Often, solving a printing 
problem is as simple as downloading and 
installing an updated printer driver. See 
“Printer Drivers” on page 843.

If you can print from Home Designer Pro but 
are not satisfied with the output, refer to 
“Printing & Plotting” on page 841 for 
information on how to set up and use the 
printing functions in the program. Legacy 
users should bear in mind that each release 
has new features and enhancements, so 
techniques that were used in prior versions 
may not work in the current version. 

Make sure that you use Print Preview  
before printing. Print Preview displays the 
printed paper, or drawing sheet, as a white 
rectangle on screen, and shows how the sheet 
is scaled and positioned relative to your 
drawing. If the drawing is not on the drawing 
sheet on-screen, it will not be on the sheet 

when you print. See “Print Preview” on page 
845.

Make sure that your scaling is correct for the 
paper size. If the plan is much smaller or 
much larger than the drawing sheet, you may 
need to change your Scale. See “Printing to 
Scale” on page 847.

64 Bit Versions of Windows
Some printers may not function correctly on 
64 bit Windows operating systems. If you are 
experiencing a printing problem while using 
a 64 bit version of Windows, please contact 
the printer’s manufacturer to verify that you 
have the correct driver installed.

Printing to a legacy parallel printer port on a 
Windows 64 bit machine may not work 
correctly when using a hardware lock. USB 
printers should not be affected. If you run 
into difficulty with this type of setup, you 
may want to consider Software Lock 
Security. 

Clearing Printer Information
Some information specific to individual 
printers and plotters, such as available printer 
paper sizes, is saved with each plan and 
layout file. 

If you are encountering problems when 
printing, or unexpected options in the Page 
Setup dialog, select File> Print> Clear 
Printer Info to clear the printer-specific 
information stored with the plan or layout 
file. 

After using Clear Printer Info, select File> 

Print> Page Setup . Make sure the 
settings in the Page Setup dialog are correct, 

and then click OK and Save  the file.

It is a good idea to keep the Owner’s
Manual for your printer or plotter close

at hand. Write inside the Owner’s Manual the
various phone numbers for technical support
for that printer or plotter – for the original
manufacturer and for your local dealer.
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Slow Printing from Layout
The most common reason for unusually slow 
printing from layout is the presence of a 
rotated view. To avoid this issue, rotate the 
view prior to sending it to layout, or change 
the orientation of the paper in layout so you 
do not need to rotate the view. See “Layout” 
on page 863.

Help Database
For answers to frequently asked questions 
regarding printing and other topics, select 
Help> Visit Home Designer Pro Web 

Site  and browse the Technical Support 
section of our Web site, 
 www.HomeDesignerSoftware.com. Our 
Technical Support specialists post new 
articles periodically to help resolve problems 
you may encounter. 

Error Messages
Most common error messages have a known 
cause and simple resolution. When you 
encounter an error or warning message in 
Home Designer Pro, you can click the Check 
Help Database button in the message box to 
launch your default internet browser to the 
Home Designer Help Database on our Web 
site,
 www.HomeDesignerSoftware.com. If an 
article discussing the message is available it 
will display, providing information about the 
message and how best to avoid it. 

It is important that abnormal errors be 
reported to Chief Architect Technical 
Support so that we can identify and resolve 
any problems. 

The content of an error message is useful in 
diagnosing its cause. If you encounter an 
error message, read it carefully and write 
down the error number and the exact text of 
the error message. 

If you encounter the error more than once, 
make a note of your steps prior to receiving 
the message.

Before you report an error, check the Help 
Database to see if the error is already 
documented by typing the error message or 
part of the error message into the search 
form. 

Finally, check to see if there are program 
updates available. These updates are 
provided free for the current version of 
Home Designer Pro and contain 
enhancements and other changes that allow 
the program to perform at an optimum level. 
Select Help> Download Program Updates 
from the Home Designer Pro menu to visit 
our Web site,

Press the Print Screen key on your key-
board to capture a picture of the error

message. Open a new word processing doc-
ument or e-mail message and choose Edit>
Paste to paste a copy of the error message
into the document for later reference.

http://www.homedesignersoftware.com/support/
http://www.homedesignersoftware.com/support/database.html
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 www.HomeDesignerSoftware.com, and 
follow the instructions.

Error Reporting
When and error occurs, you may have the 
option in the message box to send the report 
to Chief Architect. 

No personal information is sent. When you 
click Send, your default internet browser 
launches and a Web page appears on screen 
This message confirms that the report was 
sent successfully and may give you further 
instructions on how to proceed.

Contacting Technical Support
Before contacting Technical Support, take a 
moment to see if the answer to your question 
is found in the Reference Manual, Help 
index, or in our on-line Help Database. When 
you contact us, Technical Support will refer 
you to these resources if the answer can be 
found there.

Chief Architect's world-class technical 
support is available Monday through Friday 
from 6 AM to 5 PM Pacific Standard Time 
and can be reached at (208) 292-3375 or via 
our Web site, 
 www.HomeDesignerSoftware.com.

There are several things you can do to ensure 
a speedy answer to your question when you 
contact Technical Support.
• Before contacting Technical Support, 

select Help> About Home Designer Pro 
and make a note of the first characters of 
your Product Key and the exact version 
of Home Designer Pro you are using. 
Technical support is available to the own-
ers of software licenses. When you con-
tact Technical Support, be prepared to 
verify that you are the owner of the soft-
ware license.

• Before contacting Technical Support, 
check to see if there are program updates 
available for download. Our engineering 

team periodically creates updates to the 
program to resolve functionality or pro-
gram issues that were unknown at the 
time of release. These updates are pro-
vided free of charge for the current 
released version and can be accessed by 
selecting Help> Download Program 
Updates from the menu. 

• When you first encounter a problem or 
error message, copy the exact wording of 
the message or a detailed description of 
the problem. This helps us isolate the 
problem and provide you with a solution 
as quickly as possible. 

• When placing a call to Technical Support, 
be at the computer or work station that is 
experiencing the problem and have Home 
Designer Pro running. If you do not have 
access to the problem computer at the 
time of the call, the technician may be 
unable to reproduce the issue and/or sug-
gest a remedy that can be implemented 
and verified immediately.

• Be prepared to reproduce the problem 
when you contact us. If the problem can-
not be reproduced, there is a reduced 
chance that we will be able to resolve the 
problem on your first phone call.

http://www.homedesignersoftware.com/support/updates.html
http://www.homedesignersoftware.com/
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Online Information
Home Designer Pro has a variety of support 
resources available on our Web site. These 
include our Technical Support Help 
Database, the How do I…? Solution 
Finder, downloadable program updates, and 
ways to contact our Technical Support 
department. To access these resources, visit:  
www.HomeDesignerSoftware.com .

Our support team is happy to assist you in 
finding the best resource to answer your 
questions, and can resolve most issues in just 
a few minutes. In order to allow us to quickly 
answer your calls, we ask that you limit 
yourself to one question per support call. 

Online Support
Questions can be answered online by the 
Technical Support department. To submit a 

technical inquiry online, visit the Technical 
Support section of our Web site and use the   
Online Support Center . 

This route ensures that your question is 
delivered to the first available support 
professional. Requesting assistance of an 
individual specialist is not recommended, 
since that person may not be available to 
answer your question in a timely manner.

Telephone Support
Our Technical Support team is committed to 
answering your questions as quickly as 
possible and in the order received. Your call 
is important to us; however, there are times 
when we get more calls than expected and 
you may have to wait a few minutes before 
speaking to a technician. 

http://www.homedesignersoftware.com/
http://support.homedesignersoftware.com/
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Appendix C

What’s New in
Home Designer Pro

2014

Welcome to Home Designer Pro 2014. This 
appendix has been written to help our 
upgrading customers make a smooth 
transition from earlier versions of Home 
Designer Pro to Home Designer Pro 2014. 

Chapter Contents
•      Before You Begin
•      New and Improved Features by Chapter

Before You Begin
There are many new features in Home Designer Pro 2014, and many existing features have 
changed. These changes affect the way Home Designer Pro functions, so it is very important to 
be familiar with them. 

• “Getting Started Check List” on page 918

• “For Files Created in Version 2012 and Prior” on page 920

• “For Files Created in Version 10 and Prior” on page 921

• “For Files Created in Version 9 and Prior” on page 921

Be sure to read this section before opening any plans created in earlier versions
of Home Designer Pro.
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Home Designer Pro 2014 can open the .PL1, .LA1, .plan, and .layout files from prior 
versions. Before opening any files created in earlier versions of Home Designer Pro, it is 
important to be aware of changes made in the newest version and the effect they may have on 
your legacy plan and layout files. For details, see “For Files Created in Version 10 and Prior” 
on page 921 and“For Files Created in Version 9 and Prior” on page 921. 

As with any software, it is always best to finish any current projects you may have in progress 
in the version of the software in which you began them. If you do decide to bring a project 
forward, be sure to take the time to verify that everything in your drawing is correct when it is 
opened the new program version.

Getting Started Check List
The following checklist suggests steps you should take before migrating your files to Home 
Designer Pro 2014. More information about each of these steps can be found after the checklist.

1.      Check for and Install Program Updates
2.      Migrate Legacy Library Files
3.      Migrate Custom Graphics Files
4.      Review the New Features List
5.      Review Your Preferences Settings
6.      Set up Custom Toolbar Configurations
7.      Backup Entire Plan
8.      Check www.HomeDesignerSoftware.com for more information

1. Check for and Install Program Updates
Program updates contain improvements to the original release version and we recommend 
using the most current version available. By default, Home Designer Pro checks for program 
updates every day when you launch the program. For information about changing this, see 
“General Panel” on page 67. Please note that program updates are available for download, 
which means that you need internet access to acquire them.

You can check for updates at any time: 

• Select Help> Download Program Updates from the menu. 

• Visit the Program Updates page on the Home Designer Pro Web site at www.HomeDesign-
erSoftware.com. 

2. Migrate Legacy Library Files 
Library content from previous program versions cannot be installed or copied into the Home 
Designer Pro 2014 library. If you upgraded from version X1 or later and have custom library 

http://www.homedesignersoftware.com/
http://www.homedesignersoftware.com/
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content on your computer from that program version, the program installer will locate it and 
ask if you want to migrate it into the Home Designer Pro 2014 library. See “Migrating Library 
Catalogs” on page 20. TODO

You can import library files from versions X1 through 2012at any time by selecting Library> 
Import Library (.calib, .calibz) from the program menu. In addition, library files from 
versions 7and prior can be imported by selecting Library> Convert Legacy (.alb) Library 
Files from the program menu. See “Importing Library Catalogs” on page 612. 

3. Migrate Custom Graphics Files
If you have custom graphics files, including textures, images or backdrops, that you were using 
in a previous program version, you can copy them manually using Windows Explorer for use in 
Home Designer Pro 2014. See “Home Designer Pro Data” on page 41. 

• Copy custom texture files to the Home Designer Pro 2014 Textures folder located in the 
Home Designer Pro 2014 Data folder. 

• Copy custom image files to your Home Designer Pro 2014 Images folder located in the 
Home Designer Pro 2014 Data folder. 

• Copy custom backdrop files to your Home Designer Pro 2014 Backdrops folder located in 
the Home Designer Pro 2014 Data folder. 

In Home Designer Pro 2012 through 8, custom graphics were saved in the Home Designer Pro 
Data folder, as they are in version 2014. In version 7 and prior, they were located in the 
program’s installation directory, in folders that began with “My”. Custom backdrops, for 
example, were saved in “My Backdrops”. 

Texture and image files are not listed in the Library Browser. These files can be assigned to 
material and image objects, however, which are stored in the library so it is important to retain 
them. There are several tools available for adding materials and images to the library. For more 
information, see “Images” on page 806 and “Creating Materials” on page 637.

4. Review the New Features List 
There are a number of important reasons why you should familiarize yourself with the new and 
improved features in Home Designer Pro 2014:

• New and improved features allow you to produce drawings more efficiently, so it is to your 
advantage to use them. 

• Some changes to existing functionality may affect your accustomed drawing style and thus 
your productivity if you are not aware of them. 

• New features may affect your choice of settings in your template files, as well as your pre-
ferred Preferences settings. 

See “New and Improved Features by Chapter” on page 923. 
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5. Review Your Preferences Settings 
Any changes that you made to the Preferences settings in your previous version do not migrate 
into Home Designer Pro 2014. You should review all the settings in the Preferences dialog to 
make sure that they are set to suit your drawing needs. For more information, see “Preferences 
Dialog” on page 60.

6. Set up Custom Toolbar Configurations 
It is possible to migrate toolbar configuration files from previous versions to Home Designer 
Pro 2014; however, it is not recommended because it is likely that you will be missing new 
tools available in version 2014. 

Instead, we recommend that you set up your custom toolbars the way you would like them in 
Home Designer Pro 2014. You may find it most effective to customize your toolbars as you get 
used to working in the new program version, rather than beforehand. See “Toolbar 
Configurations” on page 98. 

7. Backup Entire Plan
Before migrating a legacy file created in Home Designer Pro 2012 or prior, it is a good idea to 
open the plan in the program version in which is was created and use the Backup Entire Plan 
tool (Export Entire Plan in version X3 and prior) to export the plan with all associated support 
files, including textures, backdrops and images. See “Backup Entire Plan” on page 52. 

8. Check www.HomeDesignerSoftware.com for more information
If you have additional questions about the changes in Home Designer Pro, up to date 
information is available in the Support section of our web site. You can also post questions on 
the Home Talk web forum at HomeTalk.HomeDesignerSoftware.com.

For Files Created in Version 2012 and Prior
In addition to the above recommendations, if you wish to open files created in Home Designer 
Pro Version 2012 or prior, bear in mind the following before you open legacy files in Home 
Designer Pro 2014. 

1. Roof Overhangs and Framing
In Home Designer Pro 2012 and prior, roof overhangs were measured to the outside of the 
subfascia, whereas in Version X5, they are measured to the outside of the fascia. In legacy 
plans opened in Version X5, this will not affect the appearance of roof planes in floor plan view 
because in 2012 and prior, roof plane polylines represented the projected framing area whereas 
in Version X5 they represent the total projected area.  But, the position of the fascia and 
subfascia will shift, as will the length of the rafters.See “Eave and Gable Overhangs” on page 
364. 

2. Door Swing Direction and Materials

http://hometalk.homedesignersoftware.com/
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In Home Designer Pro X4 and prior, exterior doors that swing outward display interior material 
on exterior side of door. This was corrected in Version 2014. Doors modified to work around 
the old behavior could be affected in legacy plans opened in Version X5. See “Changing Door 
Swings” on page 260. 

3. Door Swing Direction and Louvers
Improvements to door louver direction may affect louvers in all doors with the exception of 
bifold doors. See “Changing Door Swings” on page 260. 

4. Wrapped Door/Window Lintels and Window Sills
In Home Designer Pro 2012 and prior, wrapped lintels and sills extended out further than those 
that were not wrapped. In legacy plans opened in Version 2014, the extents of wrapped lintels 
and sills will be adjusted so that they equal their Extend setting. See “Door Casing” on page 
260 and “Window Casing & Sills” on page 290. 

5. Invisible Beams
The legacy Invisible Beam checkbox was removed from the Wall Specification dialog. When 
legacy plans are opened in Version 2014, any Invisible Beam walls will be converted to 
Invisible Walls.  See “General Tab” on page 214. 

For Files Created in Version 10 and Prior
In addition to the above recommendations, if you wish to open files created in Home Designer 
Pro Version 10 or prior, bear in mind the following before you open legacy files in Home 
Designer Pro 2014.

1. Text Styles
The appearance of a number of objects that include text - including object labels, the North 
Pointer, Sun Angles, Joist Direction Lines, the Up/Down arrows for stairs and ramps - can now 
be controlled using Text Style. Their appearance may be altered somewhat in legacy plans 
opened in Home Designer Pro 2014. See “Text Styles” on page 765.

2. Light Sources
The illumination created by light fixtures and Added Lights was improved in Home Designer 
Pro 2014. Lighting in legacy plans may appear noticeably brighter when viewed in version 
2014. See “Light Data Tab” on page 493. 

For Files Created in Version 9 and Prior
If you wish to open files created in Home Designer Pro Version 9 or prior, bear in mind the 
following file management changes and structural enhancements before you open legacy files 
in Home Designer Pro 2014.
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1. Material textures, images, and backdrops
Home Designer Pro 9 and prior installed with a catalog of library content, including a selection 
of material textures, images, and backdrops. This library catalog is no longer installed with the 
program because it is now available for download on-demand, so it will be possible to open a 
legacy plan in version 2014 and encounter numerous missing file warnings. To avoid this, we 
recommend using the Export Entire Plan feature in the original program version to create a 
folder that includes the plan and all associated textures, images, and backdrops before opening 
this file in 2014. This tool is renamed Backup Entire Plan in version 2014. See “Backup Entire 
Plan” on page 52.

2. Floor and ceiling finish thicknesses
In Home Designer Pro 9 and prior, floor and ceiling finish layers were not modeled in 3D, and 
objects such as railings, stairs, landings, cabinets, fixtures, and furnishings measured their 
Floor to Bottom height from the subfloor. These objects now measure their Floor to Bottom 
height from the floor finish surface, so it is possible that you may notice height changes for 
these objects - particularly in saved, annotated cross section/elevation views. See “Floor and 
Ceiling Platform Definitions” on page 322.

3. Riser heights and landing thicknesses
The default Best Fit Riser Height for stairs that do not reach the next level has been updated 
from 9” (225 mm) in version 9 and prior to 6 3/4” (169 mm) in Home Designer Pro 2014. This 
may affect the riser heights of stairs, as well as the thicknesses of landings attached to those 
stairs. See “Staircase Specification Dialog” on page 422. 

4. Auto Adjust Height
The Follow Terrain option in some specification dialogs was replaced by the Auto Adjust 
Height checkbox. If a cabinet, fireplace, fixture, furniture, or other library symbol had Follow 
Terrain unchecked in version 9 or prior and was located in a room with a floor height other than 
the default for the current floor, then the object’s Floor to Bottom Height will change to equal 
that room’s floor height. The object’s position in the model will not change, however. See 
“Terrain Height vs Floor Height” on page 539 of the Reference Manual. 

5. Adjustable Thickness Walls
In Home Designer Pro 9 and prior, generic, single-layer wall types were available for use. 
When a legacy plan file is opened in version 2014 and these wall types are detected, they are 
replaced by an updated, non-generic wall type. Framed walls and Railings will also acquire 1/
2” (13 mm) thick layers of sheetrock on each side. Railings that define a Deck room with 
Advanced Deck Framing Built will not acquire sheetrock layers. See “Legacy Wall Types” on 
page 211.

6. Stairwells defined by railings
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Interior railings that used a generic, single-layer wall type drawn in older program versions will 
acquire layers of sheetrock when the plan is opened in version 2014. This can affect the 
appearance of staircases where they join to a floor platform. To address this issue, select the 
railing and move it 1/2” (13 mm) away from the top edge of the staircase. See “Creating a 
Stairwell Manually” on page 420. 

7. Deck rooms
In legacy plans opened in Home Designer Pro 2014, Deck rooms with Advanced Deck 
Framing built retain the framing but have Automatic Deck Framing turned off by default. 
Decks with no Advanced Deck Framing built are converted to Balcony rooms. See “Decks” on 
page 238.

8. Structural Member Reporting
When a plan created in Home Designer Pro 9 or prior is opened in Home Designer Pro 2014, 
Materials Lists are set to calculate Total Lineal Length. For a combination of lineal length and 
piece count, select Mixed Reporting in the Structural Member Reporting dialog. See 
“Structural Member Reporting” on page 898.

9. Fill New Framing Members
In Home Designer Pro 9 and prior, Fill New Framing Members was view-specific; in Home 
Designer Pro 2014 it applies to the entire plan. As a result, it is turned off by default in legacy 
plans opened in version 2014. See “CAD Defaults Dialog” on page 770.

New and Improved Features by Chapter
The following is a list of  new and improved 
features in Home Designer Pro Version 2014. 
Where possible, cross-references to 
additional information has been provided.

Preferences & Default Settings
• The 3D Settings dialog was renamed 3D 

View Defaults and can now be accessed 
via the Default Settings dialog. See “3D 
View Defaults Dialog” on page 668. 

Toolbars & Hotkeys
• Removed ability of multiple custom tool-

bars to share the same name. See “To cre-
ate a new toolbar” on page 94. 

Layers
• New “Casings, Exterior” and “Casings, 

Interior” layers for door and window cas-
ings. See “Displaying Doors” on page 
257 and “Displaying Windows” on page 
287. 

Creating Objects
• When creating an object on a layer that is 

not turned on, you can now choose to 
Cancel. See “Object Creation and Lay-
ers” on page 114. 

• Polyline- and Spline-based objects can 
only be created when their components 
have the same layer and display attributes 
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- including line style and color. See 
“Clicking and Dragging” on page 113. 

Editing Objects
• Corner Boards and Quoins added to the 

Delete Objects dialog. See “Deleting 
Objects” on page 171. 

• Can now delete Manual and Automatic 
Dimensions separately in the Delete 
Objects dialog. See “Deleting Objects” 
on page 171. 

Walls, Railings & Fencing
• The Railing tab in the Wall Specification 

dialog was renamed to improve usability. 
See “Rail Style Tab” on page 224. 

• Can now specify the height of bottom rail 
or shoe on Railings and Deck Railings. 
See “Rail Style Tab” on page 224. 

• No Shoe and Raise Shoe settings were 
renamed Include Bottom Rail and Raise 
Bottom Rail. See “Rail Style Tab” on 
page 224. 

• Align With Above/Below  edit 
tools now work with Invisible Walls. See 
“Aligning Walls Between Floors” on 
page 202. 

• Legacy Invisible Beam checkbox was 
removed from the Wall Specification 
dialog. Invisible Beam walls in legacy 
plans will be converted to Invisible Walls 
when opened in version 2014. See “Gen-
eral Tab” on page 214. 

Rooms
• Improved feedback in the Room 

Specification dialog if the selected room 

has multiple rooms with different floor 
heights located directly above it. See 
“Structure Tab” on page 245.

• The General tab of the Room Defaults 
dialogs had no active settings, and Mate-
rials tab’s settings caused confusion, so 
both were removed from the dialog. See 
“Floor and Room Defaults” on page 230.

Doors and Windows
• Can now display door and window casing 

in floor plan view. See “Displaying 
Doors” on page 257 and “Displaying 
Windows” on page 287. 

• Can now specify the Depth of door and 
window casing. See “Casing Tab” on 
page 269 and “Casing Tab” on page 297. 

• New “Casings, Exterior” and “Casings, 
Interior” layers. See “Displaying Doors” 
on page 257 and “Displaying Windows” 
on page 287. 

• Can now specify wrapped lintels and sills 
on windows with recessed casing. See 
“Lintel Tab” on page 271 and “Lintel & 
Sill Tab” on page 299. 

• Improved usability of Extend setting for 
lintels and sills. See “Lintel Tab” on page 
271 and “Lintel & Sill Tab” on page 299. 

• New Reverse Interior/Exterior option 
in the Door Specification dialog.  See 
“General Tab” on page 266. 

• New Hardware on Fixed Section option 
in the Door Specification dialog.  See 
“Hardware Tab” on page 276. 

• Improved how Bi-fold doors, their 
hinges, and their louvers are generated. 
See “Bifold Doors” on page 255. 
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• Can now show Bi-fold doors as open in 
3D views. See “Displaying Doors” on 
page 257. 

• New Show in Plan setting lets you con-
trol the display of the concrete cutoutfor  
doors and windows in floor plan view. 
See “Displaying Doors” on page 257 and 
“Displaying Windows” on page 287. 

• Improved Louver direction behavior for 
doors.

• Improved how door materials are handled 
with the swing side is changed. See 
“Door Sides” on page 260. 

• New Fit Frame to Wall setting lets you 
specify that a window frame adjusts to fit 
the wall type that the window is placed 
in. See “Sash & Frame Tab” on page 301. 

• Improved display of window frames and 
sills in floor plan view. See “Displaying 
Windows” on page 287. 

• Windows can now have a lintel without 
also having a sill. See “Window Casing 
& Sills” on page 290. 

Foundations
• New Show in Plan setting for doors and 

windows lets you control the display of 
their concrete cutout in floor plan view. 
See “Displaying Doors” on page 257 and 
“Displaying Windows” on page 287. 

• Increased the default Add for Rough 
Opening value for fireplaces to 2” (50 
mm) on each side and the top. See “Gen-
eral Tab” on page 345. 

Roofs
• In floor plan view, roof plane polylines 

now reflect the thickness of the fascia and 

shadow boards rather than the extents of 
the framing. See “Eave and Gable Over-
hangs” on page 364.

• Can now specify eave and gable over-
hangs for Auto Dormers. See “Dormer 
Specification Dialog” on page 391.

• Can now specify the on center Spacing 
of rafters for individual roof planes in the 
Roof Plane Specification dialog. See 
“Framing Tab” on page 362.

• New No Special Snapping option pre-
vents roof planes from snapping to wall 
exteriors. See “General Tab” on page 
372. 

• Redesigned Change Roof Pitch or 
Height dialog. See “Change Roof Pitch 
or Height Dialog” on page 369. 

• Roof Baseline Polylines can now be cop-
ied and pasted. See “Roof Baseline Poly-
lines” on page 375. 

Stairs, Ramps & Landings
• No Shoe for Rail setting was renamed 

Include Bottom Rail on Landings for 
greater clarity. See “Railing Tab” on page 
427. 

Framing
• The bottom plates of framed interior 

walls are now specified as Treated if 
built on a monolithic slab foundation. See 
“Treated Sill Plates” on page 437.

• Posts  now use their default size when 
placed under a floor or ceiling beam 
instead of inheriting the beam’s width. 
See “Post” on page 440. 
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Electrical

• Improved how Auto Place Outlet  
tool positions outlets for appliances. See 
“Auto Place Outlets” on page 489. 

Trim & Moldings

• New Auto Place Corner Boards  and 

Auto Place Quoins  tools. See “Cor-
ner Boards” on page 498 and “Quoins” 
on page 500. 

• Corner Boards and Quoins added to the 
Delete Objects dialog. See “Delete 
Objects Dialog” on page 171. 

Cabinets
• New Specify Appliance setting allows 

multiple front appliances in the same cab-
inet. See “Front Tab” on page 526. 

• Can now assign multiple door and drawer 
styles to a single cabinet. See “Front Tab” 
on page 526. 

• New “Double False Drawer” option for 
cabinet fronts. See “Front Tab” on page 
526. 

• Drawers and Double Drawers automati-
cally change to False Drawers when a 
cooktop appliance is inserted into a cabi-
net. See “Built-In Appliances” on page 
511. 

• “Plain” cabinet doors renamed “Slab” 
cabinet doors. See “Door/Drawer Tab” on 
page 529. 

Other Objects

The Library
• New Update Library Catalogs option 

checks for updated Core, Manufacturer, 
and Bonus Catalogs content. See 
“Library Content” on page 609. 

• Improved the appearance of doorways 
added to the library in the Selection and 
Preview Panes. See “The Library 
Browser” on page 604. 

3D Views
• 3D Settings dialog was renamed 3D 

View Defaults and can now be accessed 
via the Default Settings dialog. See “3D 
View Defaults Dialog” on page 668. 

• Backdrop name now displays in 3D View 
Defaults. See “3D View Defaults Dia-
log” on page 668. 

• New Plan Display tab in Camera 
Specification dialogs allows control of 
camera symbol size, Clip Plane Indicator 
length, and focal point display.

• New Label tab in Camera Specification 
dialogs. See “Displaying 3D Views” on 
page 677. 

• Wall Elevation  tool now recognizes 
room definition created by invisible walls 
and railings. See “Cross Section/Eleva-
tion Camera Tools” on page 676. 

• Can now modify a saved camera without 
saving your changes. See “Activating 
Saved Views” on page 690. 

• Can now save Cross Section Slider set-
tings with saved cameras. See “Cross 
Section Slider” on page 686. 
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• New position text field in Cross Section 
Slider dialog. See “Cross Section Slider” 
on page 686. 

Dimensions

• New Auto Interior  tool. See “Auto 
Interior Dimensions” on page 731. 

• Can now delete Manual and Automatic 
Dimensions separately using the Delete 
Objects dialog. See “Delete Objects Dia-
log” on page 171. 

• Improved how dimensions locate door 
and window casing. See “Locate Objects 
Tab” on page 723. 

• Can now specify whether and how furni-
ture is located by dimensions. See 
“Locate Objects Tab” on page 723. 

Pictures, Images, & 
Walkthroughs

• New Create Walkthrough Path  tool 
with editable Key Frames. See “Create 
Walkthrough Path” on page 819. 

• The Resize Picture  edit tool is now 
available for selected metafile boxes and 
pdf boxes, and was renamed Point to 
Point Resize. See “Point to Point Resize” 
on page 818. 

Importing & Exporting
• Can now specify whether imported .dxf/

.dwg drawings are placed at their original 
location or at the origin ( 0,0). See 
“Drawing Unit” on page 832. 

Printing & Plotting
• The default Print Range in the Print dia-

log is now All by default and your last 
choice for this setting is remembered 
between program sessions. See “Print 
Dialog” on page 855. 
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Built into cabinets .............................. 511
Outlets, where placed ........................ 491

Arc
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Specification Dialog ........................... 786



930

Home Designer Pro 2014 Reference Manual
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Rooms .............................................. 235
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Place Corner Boards .......................... 498
Place Outlets ............................. 236, 489
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Roof Returns ..................................... 393
Save Files ..................................... 47, 68
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Auto Dimension
Defaults ............................................ 727
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Foundation ........................................ 336
Framing............................................. 438
Roofs ................................................ 355
Terrain .............................................. 552

Automatic
Exterior Dimensions ........................... 730
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Roofs vs. Manual Roofs ..................... 350

B
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Backdrops .......................................... 698
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Definition ........................................... 698
in Rendering Techniques.................... 672
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Background Color ............................... 63
Backup

Entire Plan .......................................... 52
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Balusters ............................................ 224

Definition ........................................... 399
Base
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Polylines (Roofs) ............................... 375
Roofs ................................................ 363
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Walkout ............................................. 340
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Bay Windows .....................................281
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Specification Dialog............................311
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Floor/Ceiling ......................................442
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Bearing Line .......................................456
Bearings .............................................779
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Cut ....................................................371
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Blind Cabinets ...................................522
Blocking

Joist ..................................................442
Roof ..................................................441
Wall...................................................447

Blocks
Architectural ......................................597
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Library Catalogs .................................610
Rooms ...............................................327
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Window Specification .........................313

Bow Windows ....................................281
Box

Tools .................................................794
Windows ............................................281

Break
Line ...................................................158
Line, complete ...................................159
Line, partial........................................159
Terrain Breaks ...................................544
Wall...................................................189

Build
Foundation ................................ 319, 334
Framing Dialog ..................................443
House................................................800
New Floor ..........................................317
Roof Dialog........................................355
Terrain ..............................................552

Bumping/Pushing ..............................152

C
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Defaults ............................................ 507
Designer ........................................... 507
Modules Library ................................. 510
Shelf Specification Dialog .................. 532
Specification Dialog ........................... 522
Tools ................................................ 509

Cabinets
Angled front ...................................... 520
Backsplash ....................................... 524
Base ................................................. 509
Bevel ................................................ 531
Blind ................................................. 522
Built-in appliances ............................. 511
Corner .............................................. 520
Countertop, custom ....................510, 513
Countertops ...................................... 513
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Editing .............................................. 517
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Fillers ............................................... 511
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Full Height ........................................ 509
General Defaults ............................... 508
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Lazy Susan ....................................... 529
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Peninsula radius ................................ 520
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Resize Increment .............................. 509
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Reverse Appliance ............................ 529
Separation ........................................ 528
Shaped ............................................. 520
Shelves ............................................ 532
Special shapes ...........................520, 523
Stile .................................................. 528
Toe kick ............................................ 524
Wall .................................................. 509
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Shape ............................................... 760
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Callouts .............................................. 759
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Heights ............................................. 239
Plane ........................................ 352, 379
Trusses ............................................. 470
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Ceilings
Automatic ..........................................443
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Circle about center .............................789
Draw using center and radius..............789
Ovals.................................................789

Clear Terrain ......................................540
Clear the Terrain................................540
Click Stairs .........................................398
Close

Plans and Views ................................. 53
Program ............................................. 54

Views................................................ 661
Color

Displaying images & pictures ............... 63
Off/On............................................... 149

Color Chooser ................................... 652
Dialog ............................................... 652
Eyedropper ....................................... 652

Compatibility
with other programs ............................. 40

Components ...................................... 627
Dialog ............................................... 901

Compound Raked Walls ................... 208
Concentric

Resizing............................................ 122
Configurations Tab ............................. 97
Connect

Electrical ........................................... 488
Walls ................................................ 191

Contextual Menus ............................... 61
In Render views ................................ 685

Contour Lines ................................... 551
Contours Tab..................................... 555
Convert

CAD Lines to Terrain Data ................. 573
CAD Objects ..................................... 164
Polyline ............................................. 165
Special Polylines into Polylines .......... 166

Copy
Floors ............................................... 320
Folders and Library Objects ............... 616
Region as Picture .............................. 819
Views................................................ 871

Copy/Paste
Main Edit Mode ................................. 116
Sticky Mode ...................................... 116

Corner
Boards .............................................. 498
Windows ........................................... 282

Corner Board
Specification Dialog ........................... 499

Countertops
Custom ......................................510, 513
Edge Profiles..................................... 520
Edit Custom ...................................... 519
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Create
New Plan Dialog .................................. 42
Plant Image....................................... 574

Cross Hairs.......................................... 76
Mouse .............................................. 154
Toggle On/Off ................................... 154

Cross Section Lines
Callouts ............................................ 761
In Camera Views ............................... 689

Cross Section Slider ........................ 686
Cross Section/Elevation Camera

Specification Dialog ........................... 694
Cross Section/Elevations ................ 673

Create .............................................. 675
Detailing ........................................... 677
Sent to Layout ................................... 870

Crown Molding
Cabinets ........................................... 519

Current
CAD Point ......................................... 774
Floor ................................................. 326
Floor, Delete ..................................... 320

Curved
Deck Edge ........................................ 182
Deck Railing...................................... 182
Stairs ................................................ 398
Walls, Draw....................................... 190

Custom
Countertops ...............................510, 513
Countertops, Editing .......................... 519

Custom Countertop
Specification Dialog ........................... 535

Custom Light Intensity Dialog ........ 495
Customize

Sheet Sizes Dialog ............................ 852
Toolbars ....................................... 29, 93

D
Deck

Advanced Deck Framing .................... 239
Designer ........................................... 182
Edges ............................................... 182

Framing..................................... 239, 248
Planking ............................................ 248
Railing .............................................. 182
Railing Defaults ................................. 180

Decks .......................................... 182, 238
Default

Lights ................................................ 700
Wall Heights ...................................... 217

Default Sun Light
Specification Dialog ........................... 707

Defaults
Auto Dimensions................................ 727
Cabinet ............................................. 507
Camera ............................................. 665
DeckRailing ....................................... 180
Defined ............................................... 56
Dimension ......................................... 719
Door.................................................. 253
Dormer .............................................. 351
Dynamic .............................................. 57
Electrical ........................................... 486
Fencing ............................................. 180
Floor ......................................... 230, 316
Foundation ........................................ 330
Framing..................................... 436, 443
General Plan ....................................... 58
Layout ............................................... 863
Material ............................................. 651
Railing .............................................. 180
Reset .................................................. 59
Roofs ................................................ 351
Room ................................................ 230
Settings............................................... 56
Structural Member Reporting .............. 898
Wall .................................................. 177
Window ............................................. 280

Define Material Dialog ...................... 644
Delete

3D Surface ........................................ 679
Built-in Fixtures and Appliances .......... 627
Current Floor ..................................... 320
Current Point ..................................... 775
Floors ............................................... 320
Foundation ........................................ 338
Framing............................................. 461
Gable Over Opening .......................... 384
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Library Content ..................................617
Objects ..............................................171
Objects, warning before ....................... 58
Roof Planes ............................... 353, 371
Temporary Points ...............................774
Tools from Toolbars ............................ 94
Wall Hatching ....................................188

Details
Cross section/elevations .....................677

Dimension
Defaults .............................................720
Tab ...................................................740
Tools .................................................728

Dimension Defaults ...........................719
Dialog................................................720

Dimension Line
Specification Dialog............................739

Dimensions
Angular.............................. 162, 729, 739
Auto Interior .......................................731
Display size ........................................ 63
Editing ...............................................733
To electrical items ..............................725
End to end .........................................729
Exterior .............................................730
Interior...............................................730
Interior, minimum area........................728
Locate Objects ...................................723
Locating railings .................................216
Minimum Interior Area ........................728
Move Objects Using ...........................737
Moving Labels....................................734
Number Height ...................................740
Overall ..............................................728
Point to point .....................................730
Printing ..............................................851
Rounding Method ...............................721
Tape Measure ....................................732
Temporary .........................................731
Wall Layers........................................210
Wall Widths .......................................740
Zeroes in ...........................................723

Display
3D Views ...........................................677
Arc Centers and Ends ........................771
CAD Objects ......................................798

Drawing Groups ................................ 150
Drawing Sheet................................... 845
Electrical ........................................... 490
Foundations ...................................... 335
Images.............................................. 807
Line Angles ......................................... 75
Line Length ......................................... 75
Objects ............................................. 102
Options, Layout ................................. 872
Pointer CAD Coordinates ..................... 62
Pony Walls in Floor Plan View ............ 194
Roof Planes ...................................... 364
Room labels ...................................... 237
Temporary Dimensions ...................... 731
Terrain .............................................. 551
Walls, Railings, and Fences ............... 192

Distributed Object Tab ..................... 563
Divided Lites see Lites
Doll House View .........................674–675
Door

Casing .............................................. 260
Defaults ............................................ 253
Specification Dialog ........................... 265
Swing Angle ...................................... 266
Tools ................................................ 254
Trim .................................................. 260

Doors
Arched .............................................. 274
Bifold Doors ...............................255, 263
Casing .............................................. 269
Center .............................................. 259
Change Opening/Hinge Side .............. 261
Change Swing Side ........................... 262
Doorways .......................................... 255
Double-swing .................................... 269
Frame ............................................... 273
Framing ............................................ 448
Gables Over ...................................... 382
Garage ............................................. 256
Garage, opening direction .................. 263
Garage, panels.................................. 269
Glass, muntins .................................. 273
Handles ............................................ 276
Hardware .......................................... 276
Hinged Doors .............................255, 261
Hinges .............................................. 276
Labels............................................... 258
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Library .......................................256, 266
Lites ................................................. 273
Lites, styles ....................................... 273
Locks ................................................ 276
Opening Indicators ............................ 257
Openings in railings ........................... 264
Plinth Blocks ..................................... 269
Pocket Doors .............................255, 262
Recessed...................................264, 269
Rough opening .................................. 266
Size .................................................. 266
Sliding Doors .................................... 262
Style ................................................. 266
Swing from Center ............................. 269
Swing, change .................................. 260
Threshold lines.................................. 257
Transoms.......................................... 264
Type ................................................. 266
Wrapped Openings ............................ 263

Doorways
Adding a Door ................................... 256
with Railing ....................................... 264

Dormer
Defaults ............................................ 351
Specification Dialog ........................... 391

Dormers ............................................. 387
Auto Dormer ..................................... 389
Auto Floating..................................... 388
Explode ............................................ 391
Framing ............................................ 452
Gable Over Door/Window .................. 382
Manually drawn ................................. 389
Windows in ....................................... 390

Double
Buffer Drawing .................................... 63
Buffered Printing ............................... 857
Trusses ............................................ 476

Draw
Arc About Center ............................... 784
Circle About Center ........................... 789
Curved Railing .................................. 190
Curved wall ....................................... 190
Lines ................................................ 776
Roof Planes ...................................... 362

Drawing Groups ................................ 150
Drawing Sheet

Center ............................................... 846
Select ............................................... 845
Show ................................................ 845

Driveway Tools .................................. 584
Driveways .......................................... 585
DXF

Elevation Data, Import ....................... 572
File Format ........................................ 828
Files, Import 2D ................................. 829

Dynamic
Defaults ........................................ 33, 57
Print Preview ..................................... 845
Views ................................................ 869

E
Earth Data Tab ................................... 708
Eaves

Boxed ............................................... 360
Fascia ............................................... 451
Framing............................................. 451
Plumb Cut ......................................... 360
Square cut......................................... 360

Edit
Handles............................................... 27
Paper Size Dialog .............................. 852
Polyline Parts .................................... 125
Preferences ......................................... 76
Toolbar ............................................... 29

Edit Area
(All Floors) ........................................ 169
(All Floors) Visible ............................. 169
Polyline as marquee .......................... 169
Tools................................................. 168
Visible ............................................... 169

Edit Behaviors ................................... 120
Alternate ........................................... 121
Concentric ......................................... 122
Default .............................................. 120
Edit Indicators ..................................... 79
Fillet.................................................. 123
Resize............................................... 121

Edit Handles ........................................ 27
Size .................................................... 77
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Tolerance ........................................... 77
Egress Windows ................................296
Electrical

Auto Place Outlets .............................489
Connections.......................................488
Defaults .............................................486
Deleting .............................................491
Dimension to......................................725
Dimensions to ....................................726
Displaying..........................................490
Editing Objects...................................490
General .............................................485
Labels ...............................................490
Library ...............................................489
Lights ................................................487
Outlets ..............................................487
Switches ............................................488
Tools .................................................487
Wiring................................................488

Electrical Service
Specification Dialog............................492

Elevation
Data Tools .........................................540
Points ................................................541
Regions .............................................543
Splines ..............................................543
Tab ...................................................559

Elevation Data
Import DXF ........................................572
Importing from DXF ............................572
Tools .................................................540

Elevation Line
Specification Dialog............................559

Elevation Point
Specification Dialog............................557

Elevation Region
Specification Dialog............................559

Elevations
Create ...............................................675
Interior...............................................673

Ellipse .................................................789
Specification Dialog............................789

End
Cabinets ............................................521
Caps .................................................. 75

To-End Dimensions ........................... 729
Trusses............................................. 480

Energy Heel ....................................... 476
Enhanced Metafiles .......................... 814
Enter

Coordinates ...................................... 778
Error Messages ................................. 913
Estimating Software ......................... 897
Exit Program ....................................... 54
Expand/Collapse All ......................... 608
Explode

Architectural Blocks ........................... 599
Dormers ............................................ 391

Export
2D Drawings ..................................... 833
All Floors .......................................... 833
Current View ..................................... 833
Drawing File Dialog ........................... 834
EMF.................................................. 815
From the Library ................................ 620
Layout Files ...................................... 875
Materials List..................................... 897
Picture Files ...................................... 811
Windows Metafiles............................. 815
Windows Metafiles Dialog .................. 815
WMF ................................................. 815

Extend
Slope Downward ............................... 204

Extension Lines
Adding .............................................. 735
Deleting ............................................ 737
Edit Extensions tool ........................... 734
Editing .............................................. 735

Extension Snaps ............................... 111
Extensions Tab ................................. 726
Exterior

Dimensions ....................................... 730
Room types ....................................... 235
The Exterior Room ............................ 232
Walls ................................................ 183
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F
F6 Key

Fill Window ....................................... 655
Faster Rendering .............................. 716
Fence Designer ................................. 183
Fencing .............................................. 183

Defaults ............................................ 180
Field of View...............................666, 686
File

Backing Up Your Files ......................... 45
Create New ......................................... 42
Management ....................................... 39
Menu, Recent File List ......................... 69
Open .................................................. 48
Organization ....................................... 40

File Management Preferences........... 68
Fill

Patterns ............................................ 792
Window............................................. 655
Window Building Only ........................ 655

Fill Style Tab ..................................... 792
Fillet ................................................... 123

Two Lines ......................................... 159
Fillet/Chamfer Dialog ....................... 160
Filter

Library Search................................... 609
Library Tree View .............................. 618

Final View .......................................... 698
with Shadows .................................... 698

Find Plan Wizard................................. 50
Fire Box Tab ...................................... 346
Fireplace

Direction facing ................................. 344
Interior wall ....................................... 344
Library .............................................. 347
Masonry............................................ 344
Prefabricated .................................... 347
Specification Dialog ........................... 345
Symbol ............................................. 347

Fireplaces .......................................... 343
Chimneys.......................................... 347
Foundations ...................................... 344

Freestanding ..................................... 344
In walls ............................................. 344
Types ................................................ 343

Fix
Connections ...................................... 192
Roofs ................................................ 353

Fixture/Furniture Resize .................... 59
Fixtures

Lights ................................................ 487
Flare/Curve Stairs ............................. 410
Flat Region ........................................ 546

Specification Dialog ........................... 560
Floating Auto Dormer ....................... 388
Floor

3D Overview ...................................... 673
Build New Floor ................................. 317
Camera ............................................. 672
Defaults .................................... 230, 316
Export all ........................................... 834
Export current.................................... 834
Framing............................................. 443
Heights ............................................. 239
Overview ........................................... 673
Tools................................................. 317
Trusses ............................................. 470

Floor Plan
Drawing............................................... 33
View.................................................... 35
View Template (Print Model) .............. 860

Floor Structure Definition ................ 323
Floor/Ceiling

Beam ................................................ 442
Floor/Ceiling Truss

Specification Dialog ........................... 482
Floors

Adding .............................................. 317
Attic .................................................. 327
Change Floor/Reference ............ 326, 328
Copying............................................. 320
Current Floor ..................................... 326
Deleting ............................................ 320
Floor Up/ Floor Down ......................... 326
FloorTabs .......................................... 443
Insert New Floor ................................ 318
Maximum number .............................. 315
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Raised ...............................................241
Reference Floor .................................327
Swap Floor/Reference ........................328

Folders Preferences ........................... 69
Follow Terrain ....................................555
Font

Materials List ...................................... 64
Preferences ........................................ 64

Fonts ...................................................745
and Alphabets ....................................745

Footings
Alignment ..........................................337
Chamfer ............................................220
Editing ...............................................337
Monolithic Slab ..................................220
Size...................................................220
Stem wall...........................................337
Stepped .............................................207

Foundation
Auto Rebuild ......................................336
Defaults .............................................330
Tab ........................................... 219, 331
Thickness ..........................................220
Walls .................................................183

Foundations
Alignment ..........................................337
Build..................................................334
Daylight Basement .............................340
Delete ...............................................338
Display ..............................................335
Footing size .......................................220
Garage ..............................................338
Piers .................................................332
Rebar ................................................333
Room supplies floor ...........................247
Slab at top of stem wall ......................332
Slab thickness ...................................332
Slab Tools .........................................341
Stem Wall ..........................................332
Step markers .....................................332
Stepped .............................................340
Types ................................................331
Use Mesh ..........................................333
Walkout Basement .............................340
Walls .................................................220

Framing

3D Overview ..................................... 675
Auto Rebuild ..................................... 438
Automatic.......................................... 438
Barge Rafter ..................................... 453
Beams .............................................. 449
Bearing Line ...................................... 456
Build Framing Dialog ......................... 443
Butt Joints ......................................... 443
Ceiling .............................................. 443
Cross Box ......................................... 794
Deck ..........................................239, 248
Defaults ............................................ 436
Defaults Dialog .................................. 443
Deleting ............................................ 461
Dimensions to ................................... 726
Displaying ......................................... 458
Doors................................................ 448
Dormer Holes .................................... 452
Editing .............................................. 460
Floor ................................................. 443
Headers ............................................ 448
Joists ................................................ 441
Keeping current ................................. 461
Lap Joints ......................................... 443
Layer ................................................ 209
Lookouts ........................................... 451
Manual vs. Automatic ........................ 437
Materials List..................................... 462
Mitered Joints.................................... 461
Mixing Trusses with Stick ................... 475
Plates ............................................... 447
Platforms .......................................... 443
Posts ................................................ 449
Reference Marker .............................. 454
Represented by single line ................. 771
Rim Joist ........................................... 443
Roof ................................................. 451
Rough Openings................................ 448
Sill Plates.......................................... 437
Specification Dialog ........................... 463
Steel ..........................................461, 463
Structural Member Reporting.............. 898
Stud Spacing..................................... 447
Stud Thickness.................................. 447
Tools ................................................ 440
Trimmers .......................................... 448
Trusses............................................. 453
Types ............................................... 463
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Wall Blocking .................................... 447
Walls ................................................ 446
Windows ........................................... 448

Full
Height Cabinets................................. 509
Overview ...................................673–674

G
Gable

Gable/Roof Line Tool ......................... 382
Over Door/Window ............................ 382

Garage
Door panels ...................................... 269
Door Tool .......................................... 256

Garages
Foundation ........................................ 338

Garden Bed
Kidney Shaped .................................. 548
Polyline............................................. 548
Round............................................... 548
Tools ................................................ 548

General............................................... 316
Cabinet Defaults................................ 508
Framing Tool ..................................... 440
Preferences ........................................ 67
Wall Defaults..................................... 176

Getting Help ........................................ 37
GFCI Outlet ........................................ 487
Girder Trusses .................................. 478
Glass, Stained ................................... 283
GPS

Importing .......................................... 570
Grade beams ..................................... 331
Grayscale

On Screen .......................................... 63
Printed .............................................. 856

Grid
Materials list reports ............................ 83
Snaps ......................................... 59, 112

Ground Fault Circuit Interrupt ........ 487

H
Half

Walls................................................. 225
Half-Walls ........................................... 181
Hardiness Zone Maps ....................... 579
Hardware

Lock Issues ....................................... 911
Hardware Tab

for Doors ........................................... 276
Hatch

Fill Patterns ....................................... 792
Wall .................................................. 188

Headers .............................................. 448
Height

Basement ceiling ............................... 332
Railings ............................................. 226

Help
Display ................................................ 28
Tool Tips ............................................. 37

Hill / Valley
Specification Dialog ........................... 561

Hill/Valley ........................................... 546
Hip

Truss ................................................ 475
Holes

In terrain ........................................... 547
Home Designer

Product Key......................................... 37
Version Number ................................... 37

Hotkeys .......................................... 29, 99
Snap Behaviors ................................. 110

House Wizard ............................ 191, 799
Editing Rooms ................................... 800
Multiple Floors ................................... 801
Placing Rooms .................................. 800

I
Icons

Arrange ............................................. 660
Image
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Specification Dialog............................809
Images ................................................698

Adding to Library ................................807
Creating ............................................807
Displaying..........................................807
Displaying in color ............................... 63
Editing ...............................................808
Place .................................................806
Printing ..............................................857
Select from library ..............................575
Transparency Color ............................811

Import
2D DXF/DWG Files ............................829
3D Data .............................................836
3D Symbols .......................................838
Drawing Wizard..................................829
DXF Elevation Data ............................572
GPS Data ..........................................570
Terrain Data ......................................567
Terrain Wizard ...................................568

Input
Arc ....................................................785
Line ...................................................777
Point .................................................773

Insert
Floor Dialog .......................................318

Insulation ...........................................795
Interior

Dimension Tool ..................................730
Dimensions, Auto ...............................731
Fireplace, wall....................................344
Room types .......................................235

Invisible Walls ........................... 186, 216

J
Join Roof Planes ...............................367
Joist

Direction Line.....................................457
Joist Direction

Specification Dialog............................457
Joists ..................................................441

Bearing Line ......................................456
Blocking ............................................442

Use Framing Reference ..................... 444
see also Framing

K
Key Frames ........................................ 820
Keyboard

Commands............................ 29, 99, 607
Kidney Shaped

Garden Bed....................................... 548
Pond ................................................. 548
Terrain Features ................................ 547

Kingpost ............................................ 480
Kitchen Island ................................... 522
Knee Walls ..................................206, 218

L
Label Tab ........................................... 885
Labels

Cabinet ............................................. 515
Display size......................................... 63
Displaying ......................................... 884
Door ................................................. 258
Electrical ........................................... 490
Roof Plane ........................................ 364
Room ................................................ 236
Trusses............................................. 474
Window ............................................. 288

Landing .............................................. 406
Unlocked........................................... 407

Landings
Custom Shapes ................................. 407
Height ............................................... 407
Locked .............................................. 408

Landscape Designer ......................... 537
Layer

Display Options Dialog....................... 104
Layer Sets ........................................ 103

Layers
Colors ............................................... 105
Locking ............................................. 103



942

Home Designer Pro 2014 Reference Manual

Primary and Secondary ..................... 102
Turn off to speed up 3D views ............ 716

Layout
CAD ................................................. 868
Create .............................................. 865
Cross Section/Elevations ................... 870
Defaults ............................................ 863
Editing Views .................................... 870
Exporting .......................................... 875
Files, Opening ..................................... 48
Floor plan view .................................. 869
Links, Managing ................................ 873
Missing Files ..................................... 873
Open View .................................865, 871
Page Display Options ........................ 872
Pictures in......................................... 869
Preparing for ..................................... 864
Printing ......................................846, 875
Resizing, Non-Scaled Views .............. 871
Resizing, Scaled Views...................... 871
Saving ................................................ 44
Sending views to ............................... 866
Text .................................................. 868

Layout Box
Labels............................................... 872
Specification Dialog ........................... 875

Layout Files Dialog .......................... 874
Layout Views

Copy................................................. 871
Keeping views current ....................... 869

Left Mouse Button
Definition ............................................ 26

Legacy Plans
Page Setup ......................................... 66
Text Conversion .................................. 64

Legends ............................................. 747
Library

Adding Folders .................................. 615
Bonus Catalogs ................................. 610
Content ............................................. 609
Deleting Content ............................... 617
Export ............................................... 620
Filter Tree View ................................. 618
Manage Library Filters Dialog ............ 619
Manufacturer Libraries ....................... 610
Renaming Libraries ........................... 616

Search .............................................. 609
Shortcuts........................................... 617
Third Party Libraries .......................... 613
Trash ................................................ 617

Library Browser ................................ 604
Adding Items ..................................... 613
Docking ............................................. 608
Panes ............................................... 604
Preferences ......................................... 65
Restore Position .................................. 66

Library Object
Specification Dialog ........................... 627

Library Object Button
Specification Dialog ........................... 623

Library Objects
and the Materials List ......................... 625
Editing .............................................. 625
Placing .............................................. 620

Light
Ambient............................................. 699
Specification Dialog ........................... 706

Light Sources .................................... 699
Added Lights ..................................... 700
Default Lights .................................... 700
Default Sun Light ............................... 702
Fixtures ............................................. 700
Parallel Lights.................................... 705
Point Lights ....................................... 705
Spot Lights ........................................ 705
Sun Angles ........................................ 701

Lights
Added ............................................... 700
Adjust ............................................... 704
Attenuation ........................................ 496
Casts Shadows.................................. 495
Color ................................................. 494
Connect to switch .............................. 488
Custom Intensity ................................ 495
Cut Off Angle..................................... 495
Direction ........................................... 494
Drop Off Rate .................................... 495
Fixtures ..................................... 487, 700
Floor Number .................................... 706
Height ............................................... 706
Intensity ............................................ 494
Light Data Tab ................................... 493
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Show Position in 3D ...........................495
Turn On/Off .......................................703
Types of sources................................705

Line
Angle Format .....................................770
CAD Drawing Tools ............................776
Endcaps ............................................. 75
Length Format ...................................770
Properties Panel ................................. 75
Specification Dialog............................780
Start and End Points ........................... 77
Tab ...................................................780
Weight ....................................... 842, 849
Weight Scaling ...................................850
Weights, Show ............................. 62, 845
with Arrow .........................................778

Line Style
Tab ...................................................781

Lites
Craftsman ..........................................303
Diamond ............................................303
Doors ................................................273
Normal ..............................................303
Prairie ...............................................303
Tab ...................................................302

Living Area .........................................237
and Room Types ................................235
Calculation ........................................238
Delete label .......................................237
Label .................................................237
Restore label .....................................237
Show .................................................. 59
vs. Footprint.......................................238

Loan Calculator .................................802
Locate

Roof Plane Intersections.....................367
Lock

Layers ...............................................103
Roof planes .......................................371
Tread Depth.......................................410

Lookouts ............................................451

M
Main

Edit Mode ......................................... 116
Layer ................................................ 209

Make
Parallel Dialog ................................... 162
Parallel/Perpendicular.................155, 162

Manage
Layout Links ...................................... 873
Library Filters .................................... 619
Materials Lists ................................... 896

Manual
Dimensions ....................................... 729
Roofs .........................................350, 362

Manufacturer Libraries .................... 610
Marker ................................................ 762

Defaults ............................................ 744
Editing .............................................. 764
Framing Reference ............................ 454
Specification Dialog ........................... 763
Tab ................................................... 763
Types ............................................... 764

Marquee Select ................................. 126
Masonry

Fireplace ........................................... 344
Stairs ................................................ 419

Master List ......................................... 899
Columns to display .............................. 84
File Location ....................................... 84
Materials List....................................... 84
Name of file......................................... 84
see also Materials List
Update to Master ............................... 901

Material
Defaults ............................................ 651
Eyedropper ....................................... 634

Material Painter ................................. 632
and Walls .......................................... 634
Blending ........................................... 633
Modes............................................... 632
Using ................................................ 633

Materials
Add to Library.................................... 614
Artwork ............................................. 639
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Blending ........................................... 638
Calculating amounts .......................... 592
Create using Color Chooser ............... 652
Creating ............................................ 637
Define Material Dialog ....................... 644
Editing .............................................. 636
On Soffits.......................................... 592
Plan Materials Dialog ......................... 642
Render properties.............................. 650
Stained glass .................................... 283
Tab................................................... 635
Textures ....................................648, 697
Types ............................................... 640
Walls ................................................ 193

Materials List .................................... 887
Calculate from All Floors .................... 888
Calculate from Room ......................... 888
Categories .......................................... 82
Columns, editing ............................... 892
Conditioned Areas ............................. 898
Display Options Dialog ...................... 891
Editing .............................................. 895
Estimating software ........................... 897
Export ............................................... 897
Font .................................................... 64
Framing ............................................ 462
Grid display on reports......................... 83
Library Objects .................................. 625
Manage ............................................ 896
Master List Preferences ....................... 84
Preferences ........................................ 82
Report Style Preferences ..................... 83
Restrict to Floor................................. 892
Restrict to Supplier ............................ 892
Saving .............................................. 888
Subcategories ..................................... 85

Max Tread Contraction .................... 417
Menus ................................................... 30
Mesh, Specify for foundation .......... 333
Message Boxes

Reset .................................................. 32
message URL http

//www.homedesignersoftware.com/
useraccess/content.html ................. 611

Metafile Size Dialog .......................... 815
Metafiles ............................................ 814

Middle Mouse Button.................. 27, 654
Mitre Ends of Angle Walls ............... 447
Model Maker

Floor Plan View Template .................. 860
Printing ............................................. 858

Molding
in Rooms ........................................... 250

Moldings Tab ..................................... 503
for Rooms ......................................... 250
for Windows ...................................... 299

Mouse Buttons
Using .................................................. 26

Move
Along Rails ........................................ 199
CAD Points........................................ 775
Folders and Library Objects................ 616
Object Using Dimensions ................... 737
Objects ............................................. 152
Restrictions ....................................... 153
to be Coplanar ................................... 368
to Framing Reference ........................ 154
to Front of Group ............................... 151
Walls with Cabinets Attached ............. 518

Move Point Dialog ............................. 775
Mulled Unit

Specification Dialog ........................... 294
Mulled Units

Framing............................................. 297
Labels ....................................... 297, 885
Mullion Depth .................................... 297
Treat as Door .................................... 297

Mullions
Window ............................................. 302

Multiple
Floors, Reverse Plan ......................... 164
Select ............................................... 126

Muntins
Window ............................................. 302

N
New

CAD Arc Dialog ................................. 785
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CAD Line Dialog ................................777
CAD Point Dialog ...............................773
Plans Preferences ............................... 71
Polygon Shaped Room .......................187

Newels
Definition ...........................................399

Newels/Balusters Tab .......................226
No Locate Wall ...................................216
North Pointer .....................................778
Number Style/Angle Style

Dialog................................................. 89

O
Object

Based Design ..................................... 25
Object Snaps......................................110

Extension Snaps ................................111
Object locations .................................110
Preferences ........................................ 79

One-Click Auto Dimension ...............730
One-Click Stairs ................................398
Open

Below ................................................235
Layout ................................................ 48
Object ................................................ 31
Plan Files ........................................... 48
Symbol ..............................................627
View ..................................................690

OpenGL ...............................................664
Openings

Dimensions to ....................................725
Headers.............................................448
Ignore casing for resize ....................... 58

Optimizations On................................ 86
Options Tab........................................360
Organizing

your Files............................................ 40
Orthogonal Views ..............................847
Outlets ................................................487

Above cabinet ....................................491
Automatic ..........................................489

Dishwasher ....................................... 487
For appliance .................................... 491
GFCI................................................. 487
Manually placed ................................ 487
Place ................................................ 489
Sink .................................................. 487
WP ................................................... 487

Oval .................................................... 789
Specification Dialog ........................... 789

Overall Dimension ............................ 728
Overhang ........................................... 363
Overview .............................................. 23

Camera tools..................................... 682
Full ................................................... 674

P
Page Setup Dialog ............................ 853

Legacy Layouts ................................... 66
Legacy Plans ...................................... 66

Painting
Over Materials ................................... 638

Pan
Pan Window Tool .............................. 656
the Display ........................................ 655
Using the Keyboard ........................... 655
Using the Mouse ............................... 656
Using the Scroll Bars ......................... 655

Paragraph Options Dialog ............... 749
Parallel Light ..................................... 705
Parent Buttons .................................... 94
Partition Tool .................................... 510
Pass-Thru .......................................... 282
Paste .................................................. 115

Hold Position ..................................... 117
in Place............................................. 117
Special ............................................. 117

Pattern Tab ........................................ 647
Patterns and Textures ...................... 638
PDF

Print to .............................................. 848
Peninsula Radius Cabinets ............. 521
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Personal Tutor .................................. 910
Picture

Copy Region as................................. 819
Displaying in color ............................... 63

Picture File Box
Specification Dialog ........................... 813

Picture Files
Export ............................................... 811
Import ............................................... 812
Scale ................................................ 817

Piers
and Pads .......................................... 341
Foundation ........................................ 332

Piers and Pads
Editing .............................................. 341

Pitch
Above Wall ....................................... 204
Show as degrees................................. 59

Place
Gable Over Window(s) ....................... 283
Images ............................................. 806
Library Object Button ......................... 623
Library Objects .................................. 620
Outlets .......................................236, 489

Plan
Create New ......................................... 42
Drawing .............................................. 33
Files, Opening ..................................... 48
Find Plan Wizard ................................. 50
General Defaults ................................. 58
Materials Dialog ................................ 642
Saving ................................................ 43
Trace ................................................ 818
View ................................................... 35

Plan Check ........................................ 801
and room labels................................. 236
Dialog ............................................... 802
Hold.................................................. 802
Restart.............................................. 802

Plant
2D Symbols ...................................... 575
Chooser Dialog ................................. 577
Encyclopedia .................................... 577
Tools ................................................ 573

Plant Image

Create ............................................... 574
Specification Dialog ........................... 574

Plinth Blocks ..................................... 269
Plot Plan

North pointer ..................................... 778
Plotters ............................................... 843
Point

Light ................................................. 705
Markers ............................................. 774

Point to Point
Dimensions ....................................... 730
Move................................................. 153
Resize............................................... 818

Pointer
Coordinates ................................... 32, 62
Cross Hairs ......................................... 76

Polygon
Shaped Deck ..................................... 182

Polyline
Area .................................................. 791
Definition ........................................... 790
Edit Area ........................................... 169
Garden Bed ....................................... 548
Rectangular Polyline Tool .................. 794
Specification Dialog ........................... 791
Tab ................................................... 792

Ponds ................................................. 548
Round ............................................... 548

Pony Walls ......................................... 184
Align upper and lower ........................ 179
Change wall types ............................. 185
Default height .................................... 179
Display .............................................. 194
Display Openings in ........................... 179
Show lower wall ................................. 179

Post..................................................... 440
Specification Dialog ........................... 465

Preferences
Appearance Panel ............................... 61
Architectural Panel............................... 73
Behaviors Panel .................................. 78
CAD Panel .......................................... 74
Categories Panel ................................. 85
Colors Panel........................................ 63
Definition of ......................................... 57
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Dialog................................................. 60
Edit Panel ........................................... 76
File Management Panel ....................... 68
Folders Panel ..................................... 69
Font Panel .......................................... 64
General Panel ..................................... 67
Global settings .................................... 60
Library Browser Panel ......................... 65
Line Properties Panel .......................... 75
Master List Panel ................................ 84
Materials List Panel ............................. 82
New Plans Panel ................................. 71
Render Panel ...................................... 86
Report Style Panel .............................. 83
Reset preferences ............................... 89
Snap Properties Panel......................... 79
Sun Angle Panel ................................. 75
Text & Page Setup Panel..................... 66
Unit Coversion Panel ........................... 71

Print ....................................................841
3D Views ...........................................847
Across Multiple Pages ........................848
Center Sheet .....................................846
Check Plots ............................... 842, 847
Clear Printer Info........................ 844, 912
Color or Black and White ....................856
Custom Sheet Size.............................852
Dialog................................................855
Dimensions ........................................851
Directly from a View ...........................846
Double-buffered printing .....................857
Drivers ..............................................843
Layout ....................................... 846, 875
Line Weights ......................................849
Line Weights and Scaling ...................850
Model ................................................858
Options..............................................844
Paper Size .........................................842
Perspective Views ..............................847
Plotters ..............................................843
Preview .............................................845
Printable Area ....................................845
Printing Scale ....................................842
Scale to Fit ........................................847
Services ............................................864
Sheet Size ................................. 842, 852
Terminology .......................................842

Text .................................................. 851
Tiled ................................................. 848
to PDF File ........................................ 848
To Scale ........................................... 847
Troubleshooting ................................ 910

Print Image ........................................ 691
Dialog ............................................... 857

Printed Size Input Dialog ................. 755
Printers .............................................. 843

Select Printer .................................... 855
Program Updates

Auto Check ......................................... 68
Property lines .................................... 777

North pointer ..................................... 778

Q
Quoin

Specification Dialog ........................... 501
Quoins ................................................ 500

R
Radius

End Cabinets .................................... 521
Radius To ......................................... 216

Rafters................................................ 441
Barge................................................ 453
Bearing Line ...................................... 456
Blocking ............................................ 441
Depth................................................ 373
Mixing with trusses ............................ 475
Use Framing Reference ..................... 452

Rail Style Tab .................................... 224
Railing

Defaults ............................................ 180
Railing Tab

for Stairs ........................................... 427
Railings .............................................. 185

Balusters .......................................... 224
Bottom Rail ....................................... 225
Cable ................................................ 186
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Connect walls.................................... 192
Decks ............................................... 182
Fix connections ................................. 192
Glass ................................................ 186
Half Walls ......................................... 181
in a Doorway ..................................... 264
Locate with dimensions...................... 216
Middle Rail ........................................ 225
Newels ............................................. 226
No Rail ............................................. 225
Open ................................................ 225
Openings .......................................... 264
Solid ................................................. 225
Stairs ................................................ 416

Raised / Lowered Region
Specification Dialog ........................... 562

Ramp
Slope ................................................ 431
Specification Dialog ........................... 430

Rebar
In Foundations .................................. 333

Rebuild ............................................... 355
3D .................................................... 689
Roof Framing .................................... 378
Roofs ................................................ 355
Walls/Floors/Ceilings ......................... 324

Recent File List ................................... 69
Recessed

Doors ........................................264, 269
Windows ....................................283, 297

Rectangular Polyline ........................ 794
Redo ................................................... 173
Reduce Gable .................................... 481
Reference

Display Options ................................. 328
Grid .................................................... 59

Reflect
About Object ..................................... 163
Objects ............................................. 163

Relative
to Current Point, new point................. 773

Remove
3D .................................................... 680
Backdrop .......................................... 672

Render
Added Lights ..................................... 700
Daytime Ambient ............................... 700
Graphics card .................................... 664
Interior Ambient ................................. 700
Light Fixtures..................................... 700
Light Sources .................................... 699
Nighttime Ambient ............................. 700
Preferences ......................................... 86
Status ................................................. 88
Tips .................................................. 697

Render Data Tab ............................... 709
Rendering Techniques ..................... 710

Backdrops in ..................................... 672
Defaults ............................................ 713
Options ............................................. 713

Replace from Library
Button ............................................... 624
Dialog ............................................... 624

Report Style Preferences ................... 83
Reset

Defaults .............................................. 59
Message Boxes ................................... 32
Preferences ......................................... 89

Reshape objects ............................... 158
Resize

Enable for symbols .............................. 59
Factor ............................................... 818
House using Dimensions .................... 738
Ignore casing....................................... 58
Objects ............................................. 157
Point to Point ..................................... 818

Restore
Toolbars .............................................. 92

Restrictions
Moving objects .................................. 153

Retain
Wall Framing ..................................... 218

Retaining Wall ................................... 550
Reverse

Plan .................................................. 164
Rich Text

Border Color ...................................... 750
Defaults ............................................ 744
Specification Dialog ........................... 747
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Text Color..........................................748
Right Button Definition...................... 26
Rim Joist ............................................443
Road

Specification Dialog............................586
Road Objects

Different Types ..................................584
Roads ..................................................584

Displaying..........................................585
Roof.....................................................349

Automatic ..........................................350
Baseline Polyline................................375
Baseline Polyline, Example Using .......376
Baseline, Angled ................................373
Baselines...........................................363
Beams ...............................................441
Birdsmouth Cut ..................................371
Birdsmouth Depth ..............................373
Extend Slope Downward .....................218
Full Gable Wall ..................................218
Groups ..............................................353
Over this room ...................................247
Pitches in Degrees .............................395
Second pitch ......................................219
Styles, Automatic ...............................353
Tab ...................................................218
Tools .................................................352
Truss .................................................470
Truss Specification Dialog ..................479

Roof Baseline
Specification Dialog............................377

Roof Beams ........................................590
Roof Designer ....................................352
Roof Hole/Skylight

Specification Dialog............................386
Roof Plane

Labels ...............................................364
Specification Dialog............................371

Roof Planes ................................ 352, 362
Aligning .............................................366
Area ..................................................374
Delete ...............................................371
Display ..............................................364
Edit ...................................................365
Intersections, Locate ..........................367

Join .................................................. 367
Low roof planes ................................. 359
Move to be Coplanar ......................... 368
Raising/Lowering ............................... 368

Roof Truss
Specification Dialog ........................... 479

Roofs ...........................................349, 355
Auto Rebuild ..............................355–356
Auto Roof Return ............................... 219
Automatic vs. Manual ........................ 350
Boxed Eaves ..................................... 360
Build Roof Dialog............................... 355
Crickets ............................................ 390
Defaults ............................................ 351
Dormers ............................................ 387
Eaves, aligning .................................. 368
Energy Heel ...................................... 476
Fix Roofs Tool ................................... 353
Framing ............................................ 451
Gutters ............................................. 394
Heights ............................................. 372
Hip Trusses....................................... 475
Hole for skylights ............................... 385
Ignore Top Floor ................................ 358
Knee walls ........................................ 206
Lock roof planes .........................359, 371
Manual.............................................. 362
Minimum Alcove Size......................... 360
Over Alcoves..................................... 384
Over curved walls .............................. 354
Overhang ...................................357, 363
Pitch ..........................................204, 372
Plumb Cut Eaves ............................... 360
Raise off plate ................................... 359
Retain edits ....................................... 374
Returns ............................................. 393
Roof Group ....................................... 245
Roof Plane ........................................ 352
Show pitch as degrees ................. 59, 373
Skylights ........................................... 385
Square Cut Eaves ............................. 360
Step Down Hip .................................. 475
Story-and-a-half ................................ 206
Subgirders ........................................ 476
Trusses............................................. 358
Upslope Mark .................................... 363
Vertical Rafter Depth ......................... 373
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Room .................................................. 230
Defaults ............................................ 230
Specification Dialog ........................... 244

Room Labels ..................................... 236
Custom ............................................. 236
Defaults ............................................ 230
Display ............................................. 237
Edit................................................... 237
Interior room area .............................. 237
Interior room dimensions ................... 237
Room area ........................................ 237
Standard room area ........................... 237

Rooms
Area ................................................. 237
Attic .................................................. 235
Auto Place Outlets............................. 236
Below Stairs ...................................... 421
Ceiling over....................................... 247
Editing .............................................. 233
Exterior types .................................... 235
Foundation floor definition.................. 247
Interior .............................................. 235
Interior area ...................................... 237
Interior dimensions ............................ 237
Living Area........................................ 235
Name for PlanCheck.......................... 802
Open Below ...................................... 235
Polygon Shaped ................................ 187
Roof over .......................................... 247
Room Definition................................. 231
Room Types...................................... 235
Selecting........................................... 231
Standard area ................................... 237
The Exterior Room ............................ 232
Types ............................................... 234

Rotate
CAD items .......................................... 78
Jump .................................................. 78
Plan View.......................................... 163

Rotate objects ................................... 161
Rough Openings ............................... 448
Round

Garden bed ....................................... 548
Pond................................................. 548
Window............................................. 308

S
Same

Height Eaves ..................................... 359
Roof Height at External Wall............... 359

Sash and Frame Tab ......................... 301
Save

3D Views ........................................... 690
and Save As ........................................ 43
Layout ................................................. 44
Plan .................................................... 43
Plan Thumbnail.................................... 46

Scale
Picture Files ...................................... 817
Printing to.......................................... 847
Terrain Data ...................................... 569
Text Size ........................................... 755
to Fit ................................................. 847

Schedule
Specification Dialog ........................... 880

Schematics, Wiring ........................... 488
Scissors Trusses .............................. 478
Scroll Bars ......................................... 655
Seat

in Bay Window ................................... 292
Section Views

Create ............................................... 675
Segment Angle at Curved Wall ....... 359
Select

Backdrop ........................................... 672
Components of Blocked Units ............. 284
Library Object Dialog ......................... 622
Marquee............................................ 126
Multiple Objects ......................... 126–127
Next Object ....................................... 126
Object Parts ...................................... 125
Objects button ................................... 124
Objects in 3D Views ........................... 688
Room ................................................ 231
Selected Edge ................................... 125
Shift+Click ......................................... 127
Similar Objects .................................. 124

Selection Fill Color ............................. 64
Send
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to Layout Dialog .................................867
Views to layout...................................866

Service Data Tab ...............................492
Set Angular Dimension Dialog 162, 739
Set Baseline Height Dialog ..............370
Shadows .............................................702
Shelf ....................................................510
Shelf Tool ...........................................510
Shelf/Partition

Specification Dialog............................533
Shelves in Cabinets ..........................532
Shift Key

Marquee selection ..............................126
Select multiple objects........................127

Short Extensions ...............................727
Shortcut Keys ................................29, 99
Show

Arc Centers .......................................134
Line Weights ................................ 62, 845
Living Area ......................................... 59
Pitch as degrees ................................. 59
Sheet ................................................845
Short extensions ................................727

Shutters ..............................................310
Sidewalk .............................................584
SidewalkTools....................................584
Sill Plates ...........................................437
Skylights..................................... 352, 385
Slab

At top of stem wall..............................332
Foundation ........................................332
Monolithic,Footings ............................220
Specification Dialog............................342

Slabs
and the Materials List .........................341
Interior Footings .................................337
Slab Tool ...........................................341
Tools .................................................341

Sliding Doors .....................................255
Sloped Soffits ....................................594
Snap Behaviors .................................109

Angle Snaps ......................................111

Extension Snaps ............................... 111
Grid Snaps .................................. 59, 112
Hotkeys ............................................ 110
Object locations................................. 110
Object Snaps .................................... 110

Snap Properties
Preferences ........................................ 79

Soffit
Defaults ............................................ 589
Specification Dialog ........................... 592

Soffits ..........................................510, 589
Calculating Materials ......................... 592
Corner .............................................. 590
Place under ceiling ............................ 594
Place under Roof ............................... 594
Sloped .............................................. 594
Special applications ........................... 590

Space Planner
Toolbar Configuration .......................... 98

Special
Shaped Cabinets ............................... 520

Specification Dialogs
Arc ................................................... 786
Bay/Box Window ............................... 311
Bow Window ..................................... 313
Cabinet ............................................. 522
Cabinet Shelf .................................... 532
CAD Box ........................................... 795
CAD Circle ........................................ 789
CAD Ellipse....................................... 789
CAD Oval .......................................... 789
Callout .............................................. 760
Camera ............................................. 691
Ceiling Plane ..................................... 380
Corner Boards ................................... 499
Cross Section/Elevation Camera ........ 694
Custom Countertop............................ 535
Default Sun Light ............................... 707
Dimension Line ................................. 739
Door ................................................. 265
Dormer ............................................. 391
Electrical Service ............................... 492
Elevation Line ................................... 559
Elevation Point .................................. 557
Elevation Region ............................... 559
Fireplace ........................................... 345
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Flat Region ....................................... 560
Framing ............................................ 463
Hill / Valley........................................ 561
Image ............................................... 809
Joist Direction ................................... 457
Layout Box ........................................ 875
Library Object ................................... 627
Library Object Button ......................... 623
Light ................................................. 706
Line .................................................. 780
Marker .............................................. 763
Plant Image....................................... 574
Polyline............................................. 791
Post .................................................. 465
Quoins .............................................. 501
Raised/Lowered Region ..................... 562
Ramp................................................ 430
Rich Text .......................................... 747
Road ................................................ 586
Roof Baseline.................................... 377
Roof Hole/Skylight ............................. 386
Roof Plane ........................................ 371
Room................................................ 244
Schedule .......................................... 880
Shelf/Partition ................................... 533
Slab .................................................. 342
Soffit................................................. 592
Sprinkler ........................................... 580
Stair Landing..................................... 433
Staircase .......................................... 422
Sun Angle ......................................... 708
Terrain .............................................. 554
Terrain Break .................................... 564
Terrain Feature ................................. 562
Terrain Path ...................................... 566
Text .................................................. 753
Wall .................................................. 214
Wall Hatch ........................................ 227
Window............................................. 294

Speed
3D View Generation .......................... 716
3D views ........................................... 670

Splines ............................................... 796
Split

Level Entries ..................................... 326
Level Floor Plans .............................. 325
Walls ................................................ 189

Spot Light .......................................... 705
Sprinkler

Designer ........................................... 580
Specification Dialog ........................... 580
Tools................................................. 580

Stacked Windows .............................. 284
Stair

Landing Specification Dialog .............. 433
Sections Move Independently ............... 74
Tools................................................. 398

Stair Designer.................................... 398
Stair Landing

Specification Dialog ........................... 433
Stair Landings

Custom Shapes ................................. 407
Height ............................................... 407
Locked .............................................. 408

Stair Railing
Panels............................................... 418
Partial ............................................... 416
Solid ................................................. 417

Stair Treads
Automatic .......................................... 423
Depth ................................................ 424
Lock Number ..................................... 423
Lock Tread Depth .............................. 423
Number ............................................. 424
Overhang .......................................... 427
Thickness .......................................... 427

Staircase
Specification Dialog ........................... 422

Stairs
Align Curved Stairs ............................ 157
Auto Stairwell .................................... 419
Change Line/Arc ................................ 405
Click ................................................. 398
Concrete ........................................... 418
Curved ...................................... 398, 401
Curved Treads ................................... 413
Deck to ground .................................. 402
Direction ........................................... 400
Down ................................................ 402
Edit Handles ...................................... 403
Editing .............................................. 403
Flare Radius ...................................... 411
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Flared................................................410
Landings............................................406
Landings, unlocked ............................407
Large Stringer Base ...........................426
Lock Tread Depth...............................410
Make Reach ......................................422
Masonry ............................................419
Merge Sections ..................................404
Railings .............................................416
Reach Next Floor ...............................422
Rooms Below .....................................421
Section Width ....................................424
Stairwell ............................................419
Starter Treads ....................................413
Straight .............................................398
Stringers ............................................425
Stringers, steel...................................419
Subsections ............................... 410, 422
Symmetrically Flared ..........................411
Terminology .......................................399
Tread Depth.......................................409
Treads ...............................................422
Walk Line ..........................................409
Winders ..................................... 414, 425
Wrapped ............................................415

Stairwell
Automatic ..........................................419

Start House Wizard ...........................799
Startup Options .................................. 24
Static Views .......................................869
Status Bar ......................................31, 62

Angle style .......................................... 89
Steel

Framing .............................................461
Stem Walls .........................................332

Align..................................................337
and Footings, Align ............................337

Stepped Foundations ........................340
Stepping Stones ................................549
Stick Framing

Mixing with Trusses ............................475
Sticky Mode........................................116
Stop at Ceiling ...................................217
Story-and-a-half .................................206

Straight
Deck Edge ........................................ 182
Stairs ................................................ 398

Streams .............................................. 549
Structural Member Reporting .......... 898
Stud

Spacing ............................................ 447
Thickness ......................................... 447

Subfloor Thickness .......................... 445
Subgirders ......................................... 476
Sun

Shadows ........................................... 550
Sun Angle .......................................... 701

Create .............................................. 701
Render Data...................................... 709
Specification Dialog ........................... 708

Swap
Views................................................ 656
Work-Reference ................................ 328

Switch
Three way ......................................... 488

Symbol
Enable resize ...................................... 59
Surface Normals................................ 837
vs. Native Objects ............................. 626

T
Tab Key .............................................. 126
Tape Measure .................................... 732
Technical Support .....................909, 917

Contact ............................................. 914
Error Messages ................................. 913
Hardware Lock Issues ....................... 911
Installation Issues .............................. 910
Online ............................................... 915
Online Articles ................................... 915
Telephone ......................................... 915

Temporary
CAD Points ....................................... 773
Dimensions ....................................... 731
File Directories .................................... 70

Terrain
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and 3D Draw Time............................. 552
Auto Rebuild ..................................... 552
Breaks .............................................. 544
Build ................................................. 552
Clear ................................................ 540
Contour Lines.................................... 551
Contour Smoothing............................ 556
Displaying ......................................... 551
Editing .............................................. 552
Elevation Data Tools ......................... 540
Feature Tools .................................... 546
Flat Region ....................................... 546
Grow All Plants Dialog ....................... 573
Hill.................................................... 546
Holes ................................................ 547
Modifier Tools ................................... 545
Specification Dialog ........................... 554
Sprinkler Tools .................................. 580
Sun Shadows .................................... 550
Toolbar Configuration .................. 98, 538
Valley ............................................... 546
Wall and Curb Tools .......................... 549

Terrain Break
Specification Dialog ........................... 564

Terrain Data
Convert CAD Lines to ........................ 573
Import ............................................... 567

Terrain Feature
Specification Dialog ........................... 562

Terrain Features
Clip................................................... 562
Height ............................................... 562

Terrain Modeler
3D Views .......................................... 552
Clear Terrain ..................................... 540

Terrain Path
Specification Dialog ........................... 566

Terrain Perimeter .............................. 538
Text

Arrows .............................................. 757
Bullets .............................................. 749
Character Size .................................. 745
Copy, Cut and Paste.......................... 756
Creating ............................................ 746
Displaying ......................................... 747
Editing .............................................. 754

Layer ................................................ 747
Layout ............................................... 868
Line Spacing ..................................... 749
Move................................................. 754
Numbering ........................................ 749
Paragraph Options ............................. 749
Printed Size....................................... 755
Printing ............................................. 851
Reshape ........................................... 754
Resize............................................... 755
Rotate ............................................... 754
Scaling .............................................. 755
Specification Dialog ........................... 753

Text Style Defaults Dialog ............... 765
Text Styles ......................................... 765
Texture

Filename Conflict Dialog .................... 839
Tab ................................................... 648

Textures ............................................. 697
Mapping ............................................ 638
View.................................................. 648

Thumbnails .......................................... 46
Creating .............................................. 46
Enable ................................................ 69
Size .................................................... 69

Tiling Views ....................................... 659
Toolbars ............................................... 28

Add Tools ............................................ 93
Child Buttons ....................................... 94
Configurations ..................................... 98
Customize ........................................... 93
Delete Tools ........................................ 94
Drop-Down .......................................... 92
Edit ..................................................... 29
Hide .................................................... 92
Parent Buttons..................................... 94
Parent-Child ........................................ 92
Restore ............................................... 92
Tool tips .............................................. 28

Transform/Replicate Object Dialog 167
Transom Windows ............................ 264
Transparency

Color ................................................. 811
Treated

Lumber ............................................. 465
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Sill Plates ..........................................437
Treatments Tab ..................................308
Trim

Door ..................................................260
Window .............................................290

Trimmers ............................................448
Truss

Envelope ...........................................474
Trusses ....................................... 358, 453

Attic trusses .......................................477
Ceiling Steps .....................................478
Copy .................................................470
Create ...............................................470
Double...............................................476
Drop Hip truss ....................................480
Edit ...................................................473
End truss ...........................................480
Energy Heel .......................................476
Floor and Ceiling ................................470
Force Truss Rebuild ...........................481
Force truss rebuild .............................483
Girder ................................................478
Hip ....................................................475
Hip jack .............................................475
Jack ..................................................475
Kingpost ............................................480
Labels ...............................................474
Laying out..........................................470
Lock Envelope ...................................481
Member Depth ........................... 480, 482
Mixing with rafters ..............................475
Reduce gable.....................................481
Roof ..................................................470
Scissors ............................................478
Shape, editing ....................................474
Special Snapping ...............................481
Step Down Hip ...................................475
Subgirders .........................................476
Webbing .................................... 481–482

U
Undo ....................................................173

Files ................................................... 48
Preferences ........................................ 67

Undo Zoom ....................................... 654
Unit Conversions ................................ 71
Unrestricted Movement .................... 153
Untitled Plan

see New Plan
Updates

Auto Check ......................................... 68
Use Layout Line Scaling .................. 867

V
Valley.................................................. 546
Vaulted Ceilings ................................ 242
Vents .................................................. 283
Video Card

Memory............................................. 664
OpenGL ............................................ 664
Status ................................................. 88

Videos
View Online Help Videos .................... 906

Views
Cascade ........................................... 657
Static and Dynamic ............................ 869
Tiling ................................................ 659

Virtual Graph Paper ............................ 58
Visual CAD Snaps ............................... 58
Volume

Of a Polyline ..................................... 792

W
Walk Line ........................................... 409
Walkthroughs .................................... 819

Along a Path ..................................... 819
Codecs ............................................. 823
Create Path....................................... 819
Key Frames....................................... 820
Pause Recording ............................... 822
Playing ............................................. 823
Recording ......................................... 822
Save Frame ...................................... 822
Stop Recording ................................. 822
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Wall
Assemblies ....................................... 209
Blocking ............................................ 447
Cabinets ........................................... 509
Defaults ............................................ 177
Elevation........................................... 673
Layer Fill Style .................................. 214
Specification Dialog ........................... 214
Tools ................................................ 181
Type Definitions Dialog ...................... 211
Types Tab......................................... 221

Wall Hatch
Specification Dialog ........................... 227

Wall Type Definitions Dialog ........... 211
Walls

Align between floors .......................... 202
Align colinear .................................... 202
Align pony walls ................................ 179
and Material Painter .......................... 634
Attic Walls..................................206, 216
CAD to Walls..................................... 208
Compound Raked .............................. 208
Connecting ....................................... 191
Curved.............................................. 190
Curved, align between floors .............. 203
Delete hatching ................................. 188
Dimensioning to ................................ 210
Display surfaces only ......................... 192
Drawing ............................................ 189
Editing .............................................. 197
Exterior and Interior ........................... 183
Fill styles .......................................... 214
Fix Connections ................................ 192
Flip layers ......................................... 189
Footing size ...................................... 220
Foundation .................................183, 220
Foundation thickness ......................... 220
Framing ............................................ 446
Framing Layer ................................... 209
Full Gable Wall.................................. 218
Grid snapping.................................... 190
Half .................................................. 225
Half Walls ......................................... 181
Hatching ........................................... 188
Heated Area...................................... 195
Heights ............................................. 199
Interior, fireplace in............................ 344

Invisible..................................... 186, 216
Knee Wall.......................................... 218
Layer fill style .................................... 214
Layers ............................................... 209
Layers, Resize About ......................... 176
Length............................................... 200
Main Layer ........................................ 209
Materials ........................................... 193
Move Along Rails ............................... 199
No Locate.......................................... 216
No Room Def..................................... 216
Opening with Railing .......................... 264
Openings in ....................................... 190
Pony Wall .......................................... 184
Pony wall height ................................ 179
Raked ............................................... 207
Removing Breaks .............................. 192
Resizing Using Dimensions ................ 738
Retain wall framing ............................ 218
Retaining Wall ................................... 550
Reverse Layers ................................. 189
Roofs over curved.............................. 354
Room Def (invisible) .......................... 216
Same Wall Type handles .................... 198
Show length when editing................... 177
Show lower pony wall......................... 179
Solid Railings .................................... 225
Split .................................................. 184
Stepped ............................................ 207
Thickness .......................................... 199
Wall Coverings .................................. 223
Widths, Dimensioning ........................ 740

Water Features .................................. 548
Water Proof Outlet ............................ 487
Webbing

Thickness .......................................... 483
Winders ...................................... 414, 425

Definition ........................................... 399
Window

Casing .............................................. 290
Casing, reveal ................................... 298
Defaults ............................................ 280
Seat .................................................. 292
Specification Dialog ........................... 294
Trim .................................................. 290

Windows
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Bay & bow dimensions .......................291
Bay Box & Bow ..................................290
Bench Seat ........................................292
Cascade ............................................657
Component ................................ 281, 291
Corner ...............................................282
Egress ...............................................296
Framing .............................................448
Gables Over ......................................382
Labels ...............................................288
Levels ...............................................285
Library ...............................................282
Match roof .........................................306
Minimum Separation...........................280
Mulled Units .......................................284
Mullions .............................................302
Muntins .............................................302
Opening Indicators .............................288
Pass-Thru ..........................................282
Recessed .................................. 283, 297
Shutters.............................................310
Special Shapes ..................................283
Stacked .............................................284
Stained glass material ........................283

Standard ........................................... 281
Transom ........................................... 264
Treatments........................................ 308
Types ............................................... 280
Vents ................................................ 283

Windows Metafiles............................ 814
Wiring Schematics, Creating........... 488
Wrapped

Openings .......................................... 263
Stairs ................................................ 415

Z
Zero

in Dimensions ................................... 723
Zoom .................................................. 654

Fill Window ....................................... 655
Mouse Wheel .............................. 27, 654
Tools ................................................ 654
Undo Zoom ....................................... 654
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