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Chapter 1:

Program Overview

Home Designer Suite is designed to help 
home enthusiasts visualize, develop and 
share their design ideas. Home Designer 
Suite uses parametric design technology, 
which means that as you draw, a 3D model is 
created and is updated as you make changes. 
You can tile a floor plan view next to a 3D 
view and watch one update automatically as 
you draw in the other.

Chapter Contents
•      Startup Options
•      The Home Designer Suite Environment
•      Using the Mouse
•      View and Side Windows
•      Toolbars and Hotkeys
•      Menus
•      Dialogs
•      The Status Bar
•      Message Boxes
•      Preferences and Default Settings
•      Drawing a Plan
•      Viewing Your Plan
•      Getting Help
•      About Home Designer Suite
•      Home Designer Suite Trial Software
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Startup Options
When Home Designer Suite opens, 
the Startup Options dialog displays, 

allowing you to choose how you want to 
begin working in the program or access 
useful resources. 

The Startup Options dialog can be opened at 
any time by selecting File> Startup 
Options .

Select a File command to open a .plan 
file.

• Click New Plan  to open a new, blank 
plan. See “Creating a New Plan” on page 
40.

• Choose Open Plan  to work on an 
existing plan file. See “Opening and 
Importing Files” on page 45.

Recent Files lists the names of the most 
recently opened files. Click on a name 

to open the file.

A selection of useful online Resources 
is available here. Select one to launch 

your default internet browser to a page on 
our web site, www.HomeDesignerSoft-
ware.com.

1 2

3
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• Select Overview Video to watch a 
browsable collection of videos outlining 
the software’s features and uses.

• Select Training Videos to access a 
searchable collection of videos focused 
on specific topics.

• Select Download Catalogs to visit our 
3D Library of downloadable bonus and 
manufacturer library catalogs. See 
“Downloading Library Content” on page 
348. 

Getting Started- Click to launch your 
default internet browser to the Getting 

Started page on our web site. There, you will 

find links to a variety of online resources to 
help you begin using the program.

Remove the check from Show Options 
on Startup if you do not want this 

dialog to display when you launch Home 
Designer Suite. Instead, the Create New 
Plan dialog opens. 

To have the Startup Options dialog display 
at startup again, select File> Startup 
Options  and place a check mark at Show 
Options on Startup. 

Your software version’s Build number 
and the first five characters of your 

Product Key display here for reference.

The Home Designer Suite Environment

Object-Based Design
Home Designer Suite’s parametric, object-
based design technology means you place 
and edit objects, rather than work with the 
many individual lines or surfaces used to 
represent them. 

You can quickly select and edit the location, 
size, shape, style and other properties of 
objects as well as change the materials 
applied to their surfaces. 

Use Home Designer Suite’s editing 
capabilities to make the objects you place in 
a plan match the objects they represent in 
real life. For example, you can set up your 
windows and doors to match those available 
from your supplier. 

3D Drafting
In Home Designer Suite, the entire drawing 
area is laid out on a Cartesian grid, a three 
dimensional coordinate system described 
using the X, Y, and Z axes. The current 
position of your mouse pointer displays in 
the Status Bar at the bottom of the program 
window.

Architectural objects take up space in all 
three dimensions and their height, width and 
depth can be specified in Imperial or metric 
units. In addition, the location of objects can 
be precisely defined using coordinates, again 
specified in Imperial or metric units.

CAD objects such as lines and arcs take up 
space in two dimensions in the current view. 
Their dimensions can also be specified in 
Imperial or metric units and their locations 
precisely defined using coordinates.

4

3 5 

6
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Easy Access to Tools
You can access Home Designer Suite’s 
features in various ways using the mouse and 
keyboard. 
• Menus provide access to most tools.
• Convenient toolbar buttons allow fast 

access to tools and let you customize the 
interface.

• Keyboard shortcuts are available for most 
tools.

• Contextual menus display with a right-
click of the mouse.

• The Status Bar at the bottom of the screen 
provides tool descriptions and other 
information about the current task. 

Interface Toggles
A number of useful drawing and editing 
behaviors, as well as the display of important 
elements in the interface, can be easily 
enabled and disabled using the menus. For 
example:

• Object Snaps, Angle Snaps, and Grid 
Snaps can be toggled on or off as needed. 
I See “Snap Behaviors” on page 78.

• Display Elements like Print Preview, 
Show Line Weights, and the Reference 
Display can be turned on when needed 
and then toggled off.

Status Bar

Parent 
Tools

Menus

Library 
Browser

Edit  
Toolbar

Pointer Crosshair 
Lines

Reference 
Grid Lines

Selected 
Object

Temporary 
Dimension

Library 
Preview 
Panes

Title 
Bar

Tool 
Palette
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When a setting is turned on, its icon in the 
menu will display a small checkmark at its 
lower right corner and have a border around 
it in. 

Many of these interface elements are global 
Preferences while others are file-specific 
default settings. See “Default Settings vs 
Preferences” on page 56.  

Using the Mouse
Many objects, such as doors and cabinets, are 
created by clicking the left mouse button. 
Others, such as walls, stairs and dimension 
lines, are created by dragging the pointer 
from one end of the object to the other.

The left button is the primary 
button used in Home Designer 
Suite. Unless specified otherwise, 
Home Designer Suite 

documentation refers to the left mouse 
button.

The Right button has several uses. 
Right-click to select any object.

If, for example, the Straight Exterior 
Wall  tool is active, the left mouse button 
allows you to select only walls. You can 
select other object types such as cabinets 
with the right mouse button.

You can also use the right mouse button to 
open a context sensitive menu with 
additional editing commands.

The Middle button can be used to 
pan in floor plan viewTo close a 
tabbed view window, click on its tab 
using the middle mouse button. You 

can also program it to work as a double-
click.

If your mouse does not have a middle mouse 
button, in the Mac version of Home Designer 
Suite you can use the left button and the 
Command key to achieve the same results.

The Mouse Wheel can be used to 
zoom in and out in most views.

Edit Handles
When you select an object, its edit handles 
display. 

When you pass the mouse over an edit 
handles, information about what the handle 
does displays in the Status Bar and the 

Angle Snaps is enabled

Object Snaps is disabled

Note: If you are left-handed and have re-pro-
grammed your mouse, reverse the instruc-
tions for left and right buttons in this manual. 
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pointer changes to show how you can use 
that handle. 
• A two-headed arrow indicates that the 

object, corner or edge can be moved in 
the direction of the arrows.  

• A four-headed arrow indicates that the 
selected object or edge may be moved in 
multiple directions. 

• A circular arrow indicates that the 
selected object can be rotated.

Resize handles display along the edges of the 
object are used to change the size. See 
“Resizing Objects” on page 108.

The Move handle at the object’s center lets 
you move the object. See “Moving Objects” 
on page 106.

The triangular Rotate handle lets you rotate 
the object. See “Rotating Objects” on page 
110.

You can cancel any edit handle operation 
before it is completed by pressing the Esc 
key on your keyboard or by pressing any two 
mouse buttons at the same time. 

The edit handles that display depend on the 
type of object selected, the current view, and 
how far you are zoomed out. 

Edit handles do not resize as you zoom in or 
out. If you are zoomed out far enough, some 
edit handles may be hidden so that they do 
not stack over one another. As you zoom in, 
these handles become visible again.

Using a Trackpad
In addition to the standard trackpad gestures 
on your system, in Home Designer Suite you 
can pinch to zoom. Panning, however, is not 
supported in the Windows version of the 
software.

View and Side Windows
Home Designer Suite’s main program 
window has a number of important features 
that let you interact with the program, such 
as toolbars and menus. It also features two 
different kinds of windows: view windows 
and side windows.

View Windows
View windows are sometimes referred to as 
“the drawing area” because most of them are 
windows in which you can draw or place 
architectural and/or CAD objects. There are 
a number of different types of view windows 
in Home Designer Suite:
• Floor plan view
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• Camera views and overviews
• Elevation views
• Materials Lists

View windows can be navigated by panning 
and zooming; and, they have scroll bars on 
the right side and on the bottom. You can 
turn off the display of the scroll bars by 
selecting View> Scrollbars . See “View 
Tools” on page 374.

Although only one view window can be 
active at any given time, there is no limit to 
the number of view windows that can be 
open. View windows can be tiled or tabbed, 
and you can navigate between them in a 
number of different ways. See “View and 
Window Tools” on page 373.

You can also tear a view window out of the 
main program window. This creates a 
second, separate program window complete 
with toolbars and menus.  Individual view 
windows can be torn out and transferred 
between program windows. 

Side Windows
Side windows provide access to a variety of 
tools and content that helps you add detail 
your drawings.

Side windows are so-named because they are 
typically docked to either the left or right 
side of the program window - although, they 
can also be docked to the top or bottom, or 
undocked entirely.  There are several 
different types of side window:
• Child Tool Palette
• The Library Browser

Each of these side windows can be opened 
via the View menu or by clicking the toolbar 

button associated with it. Similarly, each can 
be closed by clicking the Close button in its 
title bar or tab, via the View menu, or by 
clicking its toolbar button. See “View Tools” 
on page 374. 

To undock a side window, either drag its title 
bar out into the drawing area or click the 
Undock button on its title bar. To dock a side 
window, drag its title bar to any side of the 
program window.

Two or more side windows can be docked 
together to form a shared side window, and 
can be tiled and/or tabbed within that shared 
window. To create a shared side window, 
begin by docking a side window to a side of 
the main program window, then:
• To create tabbed side windows, drag a 

second side window over the first. When 
the docked window becomes highlighted, 
release the mouse button.

• To create tiled side windows, drag a sec-
ond side window over the first. When the 
docked window becomes highlighted, 
slowly drag the mouse towards one of its 
sides. When a highlighted space is cre-
ated along that side, release the mouse 
button. 

You can choose to disable Side Window 
Drag Docking in the Preferences dialog, 
and you can also enable Top/Bottom 
Docking See “Appearance Panel” on page 
59.
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Toolbars and Hotkeys
Using the toolbar buttons is the fastest, 
easiest way to access many program features. 
When you pass the pointer over a toolbar 
button, a “tool tip” displays the name of the 
tool and a more detailed description displays 
in the Status Bar at the bottom of the 
program window. When you see one of these 
tool tips, press the F1 key to get more 
information about that item. See “Getting 
Help” on page 34. 

Home Designer Suite’s tools are organized 
into families of related tools which can be 
accessed using either of two styles of toolbar 
interface: the Child Tool Palette or Drop 
Down tools. You can select the interface that 
you prefer in the Preferences dialog. See 
“Appearance Panel” on page 59. 

The Edit Toolbar
When you select an object, the edit toolbar 
appears. By default, it is located at the upper 
left side of the program window. The toolbar 
buttons that display can be used to edit the 

selected object(s). Which buttons display 
depends on the type of object selected, the 
current view, and how you selected the 
object.

The edit toolbar buttons are the same as the 
options in the contextual menu when you 
right-click on an object.

Hotkeys
Many commands can be invoked from the 
keyboard.  Press Alt on your keyboard and 
press the underlined letter in a menu name to 
access that menu, as well as items in the 
menus and submenus. 

Other keys or key combinations will invoke a 
variety of program commands. If a Home 
Designer Suite menu item has a keyboard 
shortcut, or hotkey, associated with it, that 
hotkey will display to the right of its name in 
the menu.

Menus
Home Designer Suite uses a standard 
Windows menu format. The menus are 
located below the title bar in the program 
window and can be used to access nearly all 
tools in the program. Click on a menu name 
to expand it, then click on a menu item to 
either activate that tool or access the item’s 
submenu. Items with a submenu have an 
arrow to the right of the name.

Menu items with an icon to their left have a 
toolbar button associated with them.

The menus can be accessed using the 
keyboard. Press the Alt key once to enable 
this functionality - one letter in each menu 
will become underlined. Press the key 
associated with one of these underlined 
letters to expand its menu - one letter in each 
menu item’s name will be underlined. Press 
the key associated with one of these letters to 
activate that tool or access the item’s 
submenu. Press the Esc key to undo your last 
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selection, or click with the mouse to exit out 
of this functionality. 

Many tools in Home Designer Suite also 
have hotkeys associated with them. If a menu 
item has a hotkey, it will display to the right 
of the item’s name. See “Hotkeys” on page 
71.

In the Home Designer Suite documentation, 
menu paths are written in this format: Build> 
Window> Box Window .  

Contextual Menus
Contextual menus are context-sensitive 
menus that display tools relevant to a 
selected object or view. To open a contextual 
menu, right-click on an object, in an empty 

space in a view window, or in a text field in a 
dialog box.

The options in an object’s contextual menu 
are usually the same as those on an object’s 
Edit toolbar. See “The Edit Toolbar” on page 
26.

Contextual menus can be enabled or disabled 
in the Preferences dialog. When contextual 
menus are disabled, right-clicks perform 
generic object selection, much like when the 

Select Objects  tool is active  See 
“Appearance Panel” on page 59. 

Dialogs
Default settings, object specifications, 
display settings, and many other functions 
are accessed through dialog boxes. 

Many dialogs have multiple panels, which 
are listed in a tree list on the left side of the 
dialog. Click on a panel name in the list to 
make it active, or navigate the list using the 
Up and Down arrow keys on the keyboard. 
By default, dialogs always open to the first 
panel in the list; if you prefer, you can choose 
to Open Dialogs to the Last Panel Visited. 
See “General Panel” on page 62, 

Dialog panels and settings can be accessed 
using the mouse. You can also navigate the 
settings on a given dialog panel using the 
keyboard. For example:
• Line items in tree lists can be browsed 

using the arrow keys. Up and Down navi-
gate the list, while Left and Right expand 
and contract categories.

• Press the Tab key to shift focus from the 
tree list to the first setting on the selected 
panel. 

Edit menu items with button icons 
to the left and hotkeys to the right
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• Press the Tab key to shift focus from one 
setting to the next, or Shift + Tab to go in 
the reverse direction. 

• A checkbox can be checked or cleared by 
pressing the Spacebar or the + or - keys, 
respectively, while it is in focus. 

• Columns of radio buttons can be navi-
gated using the Up and Down arrow 
keys; rows can be navigated using the 
Left and Right arrows. Select a radio but-
ton by pressing the Spacebar while it is in 
focus.

• Settings in list boxes can be navigated 
using the Up and Down arrow keys. 
When a checkbox is in focus, it can be 
checked or cleared by pressing the Space-
bar. 

• Drop-down lists can be browsed using 
the Up and Down arrow keys. When the 
mouse pointer is directly over the drop-
down, the mouse scroll wheel can also be 
used. In Windows only, you can press 
Tab to select the highlighted item in the 
list and proceed to the next setting. 

• Settings with spin control arrows  can 
be adjusted by typing in the text field or 
using the Up and Down arrow keys. 
When the mouse pointer is directly over 
the setting, the mouse scroll wheel can 
also be used.

• Slider bars  can be adjusted by typ-
ing in the text field or using the Left and 
Right arrow keys. When the mouse 
pointer is directly over the slider bar, the 
mouse scroll wheel can also be used.

• Line items in tables can be group selected 
using the Ctrl or Shift keys, or by press-
ing Ctrl+A.

• Press Enter on your keyboard to close 
most dialogs and apply your changes.

The units of measurement used in dialogs are 
determined by your choice of template files. 
See “Creating a New Plan” on page 40.

The number format used in dialogs are set 
based on your operating system’s defaults. 

Dialog Size and Position
Dialog boxes can be both moved and resized 
to suit your needs. By default, the program 
will remember both the position and size that 
you specify for a dialog and use it the next 
time you open it. You can specify whether 
the program does this always, per session, or 
never in the Preferences dialog. You can 
also reset the default sizes and positions. See 
“Reset Options Panel” on page 66.
• To move a dialog, position your mouse 

pointer within its title bar and then simply 
click and drag.

• To resize a dialog, position your mouse 
pointer on any edge or corner and then 
click and drag outward or inward. If you 
drag an edge, only that edge will move; if 
you drag a corner, the two adjacent edges 
will move. 

When a dialog is resized, some elements 
within it may resize in response: for 
example, some list boxes and text fields. 
Some elements within a dialog box can also 
be resized independently. See “Dialog Panel 
Splitters” on page 29. 

Note: Keyboard navigation in dialogs may
vary somewhat depending on your computer
platform. 
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Note that all dialogs have a minimum size 
limitation but no maximum size. If a dialog 
opens on a monitor with resolution too low to 
display its full extents, it will have vertical 
and/or horizontal scroll bars. 

Specification Dialogs
Each object in Home Designer Suite 
has a unique specification dialog 

where you can enter size, style and other 
information specific to the selected object. 
To access it, select the object and click the 
Open Object edit button. You can also 
double-click on an object with the Select 
Objects  tool active to open its 
specification dialog. See “Selecting Objects” 
on page 86.

Most objects also have a defaults dialog that 
lets you specify the initial values in the 
specification dialog. 

Dialog Preview Panes
Many specification dialogs have a preview 
pane that shows how changes affect the 
selected object. This preview updates when 
you click in a different field or press the Tab 
key on your keyboard. 

When you click in the preview pane, your 
mouse pointer changes to a four-headed 
arrow and you can rotate around the object as 
well as zoom in and out using the mouse 

scroll wheel. Some objects, notably walls, 
doors, and windows, have Interior and 
Exterior labels to indicate which side is 
visible in the preview. Click the Fill 
Window  button above the preview pane 
to zoom in or out so that the object fills the 
extents of the pane, maintaining the current 
rotation. 

A selection of Rendering Techniques can be 
applied to the preview: Standard, and Glass 
House. You can also choose to display the 
object as it appears in floor plan view. See 
“Rendering Techniques” on page 402. 

Click the Color  button to turn color in 
the preview off or on. Some objects have 
additional tools that affect object previews. 
For example, the Cabinet Specification 

dialogs have a Select Cabinet Face Item  
button. Object specific tools like this are 
discussed in the documentation for that 
object type. 

Dialog Panel Splitters
Many dialog panels are divided into up to 
three sections: a list of panels on the left, an 
object preview on the right, and a central 
area where settings are located. The vertical 
splitters separating these sections each have a 
pale, dotted handle. 

To resize the panel list or preview, as well as 
the area in the middle, move your mouse 
pointer over the vertical division line: when 

the splitter cursor  can be seen, click and 
drag to the left or right.  

Note: Some of the dialog box images in the
software documentation have been resized
smaller than their actual minimum size. 
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The Status Bar
The Status Bar at the bottom of the main 
program window displays information about 
the current state of the program. 

This information depends on a variety of 
conditions such as the type of object 
selected, and the current position of the 
pointer. The information may include the 
following:
• A brief description of the toolbar button 

or menu item highlighted by the mouse.

• A description of the selected object or of 
the edit handle that the pointer is over.

• The total number of objects currently 
group-selected.

• Basic information about a selected library 
object, folder, or catalog.

• The current floor.
• The length and/or angle of an object as it 

is being drawn.

Message Boxes
As you work in Home Designer Suite, the 
program will occasionally prompt you to 
examine your settings, alert you if you 
command it to do something that could 
potentially cause a problem, or notify you if 
it encounters a problem that needs your 
attention 

Situations where such message boxes may 
display include: 
• Closing a file without saving;
• Modifying an object that is set to rebuild 

automatically;
• A file referenced outside the program, 

such as an image or texture, is missing;

• Creating an object in a space too small to 
contain it.

As with dialog boxes, you can access the 
options in a message box using the mouse or 
navigate them using the keyboard.

A few messages have a Send Report button. 
Click this button to anonymously send 
details regarding the issue that prompted the 
message to Chief Architect via the internet. 

Some message boxes include a “Remember 
my choice” or a “Do not show this again” 
checkbox. Check this box to prevent 
messages of this specific type from 
displaying in the future. When this box is 
checked, some options in the message box 
may become inactive.

To allow all message boxes to display again, 
click the Reset Message Boxes button in the 
Preferences dialog. See “Reset Options 
Panel” on page 66. 
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Preferences and Default Settings
Preferences and default settings control 
many aspects of the user interface and tool 
behavior in Home Designer Suite. You can 
use these settings to customize the program 
to suit your personal work style.

For more information about defaults and 
preferences, see “Preferences and Default 
Settings” on page 55.

Preferences
Preference settings let you change program 
behavior to suit your workflow. For example, 
you can: 
• Turn certain display elements on or off.
• Choose background and editing feedback 

colors.
• Set rendering specifications to maximize 

efficiency and quality. 

Preference settings are global, affecting all 
plan files.

Defaults
Most objects in Home Designer Suite derive 
their intial properties from their respective 
default dialogs. 

For example, a newly placed Window  
gets its initial values from the Window 
Defaults dialog and a newly placed Hinged 
Door  gets its initial values from the Door 
Defaults dialog. 

Once an object is placed in a plan, its initial 
properties can be overridden, but setting up 
your defaults before you begin drawing can 
save you considerable time as you build a 
model in the program.

Default settings, unlike Preferences, are file 
specific.

Dynamic Defaults
Most default settings are static: if you change 
one, any objects of that type in the current 
file will not be affected. A few defaults, 
however, are dynamic: they are tied to 
existing objects in the drawing and if you 
change the default, those objects may be 
affected. See “Dynamic Defaults” on page 
57. 

Drawing a Plan
When you draw a plan in Home Designer 
Suite, you are placing 3D objects that 
represent building components. Home 
Designer Suite comes with predefined 
default settings so you can start drawing 
plans immediately. You should review these 
default settings to be sure they match your 

drawing and building methods. See 
“Preferences and Default Settings” on page 
55.

Set the Defaults

1. Specify the defaults for walls.
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2. Set material defaults for roof, walls, and 
rooms.

3. Set style defaults for doors, windows, 
cabinets and other objects.

Draw the Floors

1. While the size of the drawing area in 
Home Designer Suite is limited only by 
the resources on your computer, it is best 
to begin your drawing near the origin, 
0,0,0. See “3D Drafting” on page 21.

2. Draw the exterior walls on Floor 1. See 
“Drawing Walls” on page 122.

3. Adjust the perimeter shape and size as 
required. See “Using the Edit Handles” 
on page 127.

4. Place any first floor bearing walls. 
5. Define types for special rooms such as 

garages and decks in the plan. See 
“Room Types” on page 147. 

6. Place perimeter doors and windows. See 
“Doors” on page 161 and “Windows” on 
page 177.

7. Build additional floors. See “Adding 
Floors” on page 201.

8. Specify the default ceiling height for 
each floor as soon as it is created. See 
“Floor Defaults Dialog” on page 200.

9. Adjust the perimeter shape of additional 
floors as needed. See “Editing Walls” on 
page 127.

10. Align edited or moved walls with those 
above or below where appropriate. See 
“Aligning Walls” on page 130.

Entering Dimensions
When using Imperial units, enter distances as 
inches or feet and inches, in fractional or 
decimal form. Millimeters are the default 
unit for all metric distances. See “Dimen-
sions” on page 405.
• To enter feet, include the ( ' ) marker or 

the program assumes inches.
• In most cases, the program allows 

precision to 1/16th of an inch. Fractions 
with denominators 2, 4, 8 and 16 are 
allowed.

• The program usually converts decimals 
to fractions.

Build the Foundation

1. Derive the foundation plan from the first 
floor. See “Building a Foundation” on 
page 208.

2. Adjust the foundation perimeter shape 
as needed.

3. Place interior foundation walls as 
needed for the first floor bearing walls.

4. Place any other foundation walls 
required.

5. Align with Above as needed. See 
“Aligning Walls” on page 130.

Add Structure and Details

1. Build non-structural interior walls. 
Begin on floor one and work up in mul-
tiple story structures. 

2. Add walls where needed to create fea-
tures such as chimney chases, plumbing 
walls, or Open Below areas.
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3. Finish the relevant interior structure 
including interior doors, doorways, cabi-
nets, fixtures, and fireplaces.

4. Build the terrain and landscaping. See 
“Terrain” on page 289.

Viewing Your Plan
You can see your model in a variety of 
different 2D and 3D views. You can display 
more than one view at a time; and in any 
view, you can pan or zoom in or out. See 
“View and Window Tools” on page 373. 
Floor plan view is a 2D view of the model and 
is most commonly used for drawing and 
editing. In floor plan view, each floor displays 
separately and you can only  edit one floor at a 
time; however, you  have extensive control 
over which objects display at any given time, 
can easily switch between floors, and can also 
display items on a second floor for reference. 
See “Multiple Floors” on page 199.

You can create interior and exterior 3D views 
of your model from any perspective. As in 
floor plan view, you can select and edit many 
objects in 3D views and control which objects 
are visible. See “3D Views” on page 381. 

You can also create Doll House Views that 
show only the current floor plus any floors 
beneath it. Ceilings on the current floor are 
omitted so you can see the interior, visualize 
the relationships between spaces, and plan 
traffic flow.

Framing Overviews display framing in 3D. 
You can customize 3D views to serve special 
purposes such as this.

All views can be exported as a graphic 
image. See “To export a picture” on page 
454.
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Getting Help
There are many forms of help 
available in Home Designer Suite 

including: Tool Tips, the Status Bar, and the 
online Help menu. 

All these forms of help assume you have a 
basic working knowledge of your operating 
system, including how to use a mouse, open, 
close and save files, copy, paste, and right-
click to access contextual menus. Help also 
assumes you are familiar with basic 
computer terminology.

More information is available in the product 
documentation in electronic format and on 
Home Designer’s official web site,  
www.HomeDesignerSoftware.com. 

See “Additional Resources” on page 499.

Tool Tips
When you move the pointer over a toolbar 
button or menu item, a Tool Tip displays, 
offering a brief description of the tool. More 
information displays in the Status Bar at the 
bottom of the window.

Contextual Help
Online Help is a searchable menu that 
provides information about all of the 

tools in Home Designer Suite. Select Help> 
Launch Help to open the program’s Help 
and explore the table of contents, browse the 
Index, or Search for keywords.

The Help can also be used to provide instant 
information about toolbar buttons, menu 
items, and objects in your plan.
• When you move the cursor over a toolbar 

button or menu item, a brief summary of 
that tool displays in the Status Bar. Press 
the F1 key to open online Help to a page 
with more information about the tool.

• When an object is selected, edit handles 
display. Place the cursor over an edit han-
dle and press F1 to open online Help to a 
page with information about that handle. 

• Press the Help button in any dialog box 
to open online Help to a page describing 
the options in that dialog. 

About Home Designer Suite
Select Help> About Home Designer Suite 
in Windows® or Chief Architect> About 
Chief Architect in Mac OS X® to view 
information about your software license, the 

program’s version number, and its release 
date.

Contact information for Chief Architect, Inc. 
is available on the More Information panel.

Chief Architect strives to make our docu-
mentation as helpful as possible for all of
our customers. Please send any questions,
comments, or feedback to 
documentation@chiefarchitect.com.
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Upgrade to Chief Architect
Select Help> Upgrade to Chief Architect to 
launch your default web browser to the Chief 
Architect web page, www.chiefarchi-
tect.com, where you can learn about this 
powerful home design software for building 
professionals.

Chief Architect can open plans originally 
created in Home Designer, and offers an 
extensive set of drawing, editing and 
rendering tools that allows you to produce 
complete, professional working drawings.

Home Designer Suite Trial Software
Free Trial versions of some Home Designer 
programs are available for download at  
www.chiefarchitect.com. 

The Trial software offers the same 
functionality as a purchased license with a 
few limitations:
• File Saving
• Printing
• File Exporting
• Recording of Walkthroughs
• Printing or Exporting of Materials Lists
• Library Browser restrictions

Full details can be found in the software’s 
Help and at  www.chiefarchitect.com.

Converting the Trial Version
An installation of the Home Designer Suite 
Trial software can be converted into a full 
working version of the program at any time 
by purchasing a software license. There are 

several ways to begin this process in the 
Trial: 
• Click the Purchase Full Version Now 

button in any Trial Restriction message 
box.

• Select Help> Purchase Home Designer 

Suite . 

• Select File> Startup Options  and 
then click the Purchase Full Version 
Now button.

Once you have purchased a license, you can 
activate it while the Trial software is running.

To activate the full version

1. Select Help> Activate Full Version.
2. In the Product Activation dialog, type 

or paste the Product Key associated 
with your software license.

3. Click the Activate button.
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Chapter 2:

File Management

Home Designer Suite saves the complete 3D 
model of a structure and surrounding terrain 
as well as any CAD data associated with the 
model in .plan files.

All commands related to opening, saving and 
closing plans are located in the File menu. 
You can also open plans from the Startup 
Options dialog. See “Startup Options” on 
page 20.

Just as with files created in other software 
applications, you should back up your plan 
files externally on a regular basis to avoid 
accidental loss of work.

Chapter Contents
•      Compatibility with Other Programs
•      Organizing Your Files
•      Home Designer Suite Data
•      Creating a New Plan
•      Saving, Exporting, and Backing Up Files
•      Thumbnail Images
•      Auto Archive
•      Undo Files
•      Opening and Importing Files
•      Searching for Plans
•      Backup Entire Plan
•      Closing Views and Files
•      Exiting Home Designer Suite
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Compatibility with Other Programs
Plans produced in the following programs 
can all be read by Home Designer Suite 
2015. 

• Chief Architect® X1 through X5 (limited 
editability if enabled)

• Chief Architect® 5.0 through 10.08 (read 
only)

• 3D Home Architect® 3.0 and 4.0

• Chief Architect® Home Edition 5.0
• All Better Homes and Gardens Home 

Designer® products, Interior Designer, 
and Landscaping and Deck Designer, Ver-
sions 6 through 8. 

• All Chief Architect Home Designer® 
products, Interior Designer, and Land-
scaping and Deck Designer, Versions 9 
through 2014.

• Trading Spaces® Design Companion™

Files that have been opened and saved in 
Home Designer Suite 2015 cannot be read by 
any of the program versions listed above. To 
continue to read files in the program in which 

they were created, be sure to create copies of 
your files before opening them in Home 
Designer Suite 2015. 

Opening Chief Architect Plans 
in Home Designer Programs

Plans created in Chief Architect Versions 5 
through X5 and Home Designer Pro Versions 
6 through 2014 can be opened in the latest 
Home Designer programs for viewing and 
annotating, but not for general editing or 
drawing of architectural objects. 

Plans created in Chief Architect, build 11.4 
and later, and Home Designer Pro 2015 can 
be set to allow limited editability in other 
Home Designer programs. When this 
permission is enabled, a Home Designer user 
can use all of their program’s drawing tools 
and can edit objects in the plan that those 
tools can create. If an object cannot be 
created in the Home Designer program, 
however, it will not be editable. 

In addition, Chief Architect and Home 
Designer Pro have the ability to lock layers. 
Objects cannot be drawn on locked layers; 
objects on locked layers cannot be selected; 
and locked layers cannot be unlocked in the 
other Home Designer programs. See 
“Layers” on page 73.

Organizing Your Files
You should keep your plan files separate 
from the support files needed to run Home 
Designer Suite. To keep files organized, you 

may find it helpful to create a new folder for 
each project.

Note: 3D Home Architect 5.0 was not devel-
oped by Chief Architect, Inc. Plans written
using 3D Home Architect 5.0 or later cannot
be read by Home Designer Suite software.
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Home Designer Suite files may use imported 
images, textures and other custom content 
saved in their own external data files. 
Consider storing copies of all external files in 
the same folder as the plan files that use them 
so that they are easily found. 

Here is one way to organize your files:
• Create a folder in your Documents direc-

tory called “Home Designer Suite Plans” 
or another name you prefer. See your 
operating system’s Help to learn how to 
create folders.

• Inside this folder, make a new folder for 
each project. Save all the files for that 

project inside this folder, including plan 
files and referenced external files. See 
“Saving, Exporting, and Backing Up 
Files” on page 41.

Bear in mind, though, that path names 
exceeding 260 characters cannot be opened 
by Home Designer Suite. As a result, it is a 
good idea to limit the number of embedded 
folders you use in your file organization 
method.

Once you understand the file management of 
Home Designer Suite, you can decide on a 
naming convention that suits your needs. 

Home Designer Suite Data
When Home Designer Suite 2015 is 
installed, the program automatically creates a 
folder in the user Documents directory called 
Home Designer Suite 2015 Data. This 
folder contains important user-specific 
information saved in the following folders 
and files and should not be moved, renamed 
or deleted: 
• Archives - A folder of automatically 

archived plan files. See “Auto Archive” 
on page 44. 

• Backdrops - A folder of custom back-
drop images. See “3D Backdrops” on 
page 387.

• Images - A folder of custom images. See 
“Adding Materials and Images” on page 
350.

• Database Libraries - A folder of user 
library data. See “Library Content” on 
page 346.

• Scripts - A folder for custom Ruby 
scripts associated with Chief Architect 
plans.

• Templates - A folder of plan template 
files. See “Creating a New Plan” on page 
40.

• Textures - A folder where you can save 
image files used to create custom material 
textures. See “Creating Materials” on 
page 366. 

• Toolbars - A folder of toolbar files. See 
“Toolbar Arrangement” on page 69. 

If the Home Designer Suite 2015 Data
folder is renamed, moved or deleted,

the program will automatically replace it
using default information from the Home
Designer Suite installation folder. When this
occurs, customized user settings and cus-
tom user library content will not be available.
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Because the Home Designer Suite 2015 Data 
contains custom user data, it is not deleted 
when the program is uninstalled. See 

“Uninstalling Home Designer Suite” on page 
17 of the User’s Guide.

Creating a New Plan
To open the Create New Plan dialog, 
select File> New Plan. 

You can also choose New Plan in the 
Startup Options dialog. See “Startup 
Options” on page 20.

Template Plans
When you select File> New Plan in 
Home Designer Suite, the Create New 

Plan dialog opens, letting you select a 
template for your new plan. The resulting 
new plan uses either metric or Imperial units 
of measurement and predefined default 
settings, layer settings, wall definitions, and 
page setup information. 

Home Designer Suite includes a selection of 
plan templates, each with different default 
settings that allow you to begin working in a 
particular plan style quickly. See “Default 
Settings vs Preferences” on page 56.

Choose a category from the drop-down list, 
then select a style template from the 
scrollable list beneath it. If you are uncertain 
as to the right style for your plan, choose 
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Default, as you cannot change the plan style 
template once a plan has been created.

Select either U.S. Units or Metric Units of 
measurement, and click OK. The floor plan 

view window opens, ready for you to begin 
drawing.

New, blank plans are called Untitled.plan. 
Unless these files are named and saved, they 
will be lost when closed. 

Saving, Exporting, and Backing Up Files
Saving, exporting, and backing up your files 
are three separate tasks that accomplish 
different things: 
• Saving a plan file retains your work so 

that it can be later opened in Home 
Designer Suite.

• Exporting a file allows you to save certain 
kinds of data in a format that can be used 
by a program other than Home Designer 
Suite.

• Backing up your files involves taking 
steps to make sure that your valuable data 
is protected and available when needed. 

Whether you are saving, exporting, or 
backing up your data, it is important that you 
select a location on your computer for the 
files you create, and also specify a short, 
meaningful name that you will be able to 
identify in the future. 

To save an untitled plan file

1. Select File> Save  to open the Save 
File dialog.

2. Specify a location on your computer 
where you would like to save the file. 
See “Organizing Your Files” on page 38.

3. In the File name text field, type a name 
for the file. 

4. Home Designer Suite automatically 
assigns the File of type and file exten-
sion .plan.

5. When both the Save in location and File 
name are correct, click Save. 

Saving Plan Files
When you first save a new, 
untitled file, you must select a 

location for it on your computer and give it a 
name. There are two options for saving plan 
files: File> Save and File> Save As.

Both Save  and Save As  can be used 
to save your plan files; however, they 
accomplish this in two different ways.

• File> Save  saves the current state of 
your plan file without changing its name 
and should normally be used for saving 
your work.

• File> Save As  opens the Save File 
dialog, allowing you to save the plan file 
using a different name or location on your 
computer. 

Although the program warns you if you
try to exit without saving, you should get

in the habit of saving plan files before exiting
the program.
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Initially, all Open  and Save As  
operations go to the “My Documents” folder 
of your computer. After that, the location last 
visited is remembered and subsequent 

Open  or Save As  commands default 
to the directory last used for that operation. 
This path is saved when the program exits. 
The next time Home Designer Suite is 
launched, these defaults are used.

Save File Dialog
The Save File dialog uses the operating 
system’s file save dialog format, and is also 
used when exporting files. The dialog name 

may vary, depending on the type of file being 
saved or exported.

Choose a location on your local 
computer for the file you are saving.

Any existing folders and/or files in the 
current location display here.

In the File Name field, type a name for 
the file. If you select an existing file 

from the space above, its name will display 
here automatically.

When saving a file, the program will 
choose the appropriate file type from 

the Save as type drop-down list. When 
exporting, you may need to choose a specific 
file type.

Saving Revision Files
Revisions are a common aspect of any design 
project. There are a number of possible 
strategies for organizing revision files:
• Prepending the file name;
• Appending the file name;

1
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• Saving revisions in separate folders.

To avoid confusion and potential mistakes, it 
is recommended that you always give files 
unique names - including revision files. If 
you choose to organize your revisions by 
saving them in separate folders, you should 
also give each file a unique name that makes 
it impossible to confuse it with another file 
saved in a different folder.

Exporting Files
Home Designer Suite has a number of 
options for exporting and importing 
information out of and your drawings. See 
“Pictures, Images, and Walkthroughs” on 
page 449. 

Often, file export dialogs are simply versions 
of the Save File dialog. 

Similarly, file import dialogs are often 
similar to the Open File dialog. See 
“Importing Files” on page 47. 

Backup Entire Plan

File> Save As  is a simple way to transfer 
a plan to a different location on your 
computer. Bear in mind, though, that plan 
files often reference external data files such 
as imported textures, images, and backdrops. 
These external files are not affected when 

Save As  is used. 

If you transfer a plan file from one computer 
to another, the program will warn you of 
missing files if the external data files used by 
the plan cannot be found when you open it. 

When transferring plans to another computer 
that does not have these external files, use 

the Backup Entire Plan  tool. See 
“Backup Entire Plan” on page 51.

Backing Up Your Files
It is always a good idea to create backup 
copies of all your important files on your 
computer. 

It is strongly recommended, however, that 
you never save directly onto removable 
media such as a USB thumb drive, CD, or 
DVD. Instead, copy your files to such 
locations only after you have saved them on 
your computer’s hard drive and exited the 
program.

Archive folders are used by Home Designer 
Suite to manage prior versions of your files. 
You should not view these files as a 
substitute for your own backup routine, and 
should never save a file in an archive folder. 
See “Auto Archive” on page 44.

When backing up your Home Designer Suite 
files, consider backing up not only your 
.plan files, but your custom user data, as well 
- including library content, toolbar 
configurations, and textures. This custom 
data is all located in the Home Designer 
Suite Data folder, so it can be easily backed 
up. See “Home Designer Suite Data” on page 
39.

You can, if you wish, create a folder inside 
the Data folder for your .plan files, as well. 
See “Organizing Your Files” on page 38.
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Thumbnail Images
A thumbnail is a miniature image that helps 
identify a file in the Open Plan File dialog. 
Any view of a plan can be saved as the 
thumbnail. See “Searching for Plans” on 
page 47.

The program automatically creates a 
thumbnail imagewhen you first save a new 
plan. You can choose to generate small or 
large thumbnails. 

To create a custom thumbnail image

1. You must save the file and give it a name 
before you can save a thumbnail.

2. Create the 2D or 3D view that you want 
to use as a thumbnail for the current file.

3. With the desired view active, select 

File> Save Thumbnail Image .

Thumbnail images are saved in the plan file 
that they are associated with. 

Auto Archive
The first time a plan is saved, Home 
Designer Suite creates an Archive folder in 
the Home Designer Suite Data folder. The 
Archive folder contains Auto Save and 
Archive files. 

The program does not create Auto Save and 
Archive files for untitled plans. In order for 
these to be created, a file must have been 
previously saved and given a name and save 
location on your computer. Further, Archive 
files are only updated when you save your 
work.

Auto Save and Archive files should not be 
viewed as a substitute for regularly saving 

your work by selecting File> Save  or 
pressing Ctrl + S on the keyboard, nor should 
they be considered an alternative to your own 
file backup routine.

Archive Files
Every time a drawing is saved, Archive files 
that keep a historical archive of your plan are 
automatically created or updated. 

Plan files from previous versions of the 
program are automatically moved to the 
archive folder when the plan is opened and 
saved in Home Designer Suite.

Archive files are meant to be for emergency 
use only. If you must access an archive file, 
open it as you would any other file. See 
“Creating a New Plan” on page 40. As soon 

as the file is open, use Save As  to save 
this file to another location.

Auto Save Files
As you work, Home Designer Suite 

automatically creates Auto Save files at 
regular intervals when changes are made to a 

If you do not save your work regularly,
your archive files will not be updated.
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file but not saved by selecting File> 
Save . 

These Auto Save files are appended 
_auto_save.plan and are saved in the 
Archive folder. 

When you close a file normally, its Auto 
Save file is retained until the next time the 
file is opened - at which time the Auto Save 
file is overwritten.

Auto save files created as a result of an 
improper program shutdown are appended 
_auto_save_bak.plan.

If your computer shuts down accidentally, 
you can recover some of your work by 
opening the _auto_save_bak file.

When you reopen a file after a computer shut 
down or system crash, the program will 
notify you if an Auto Save file newer than 
the original file is found and give you the 
option to one that file. 

Even with Auto Save, you should save your 
work manually on a regular basis using any 
of the following methods: 

• Click the Save  button.

• Select File> Save .
• Press Ctrl + S on the keyboard.

Undo Files
Home Designer Suite stores a set number of 
copies of all open plan file changes, known 
as undo files. Undo files are referenced 

whenever you select Edit> Undo  or 

Edit> Redo . See “Undo and Redo” on 
page 113.

Undo files are stored in the Windows 
Temporary Directory.  When you use 
Windows system cleanup features, these files 
can be deleted.  Because of this, you should 
only use these type of utilities when Home 
Designer Suite is not running.

When Home Designer Suite is closed 
normally, any current Undo files are deleted.

Opening and Importing Files
Opening and importing files are often similar 
tasks, but accomplish two very different 
things:

• Opening a file refers to opening it in the 
program in which it was created. Only 
plan files can be opened in Home 

Auto Save file after normal shut-down

Auto Save file after abnormal shut-down

A file is auto saved only if you have
saved it previously. Auto Save does not

work for unnamed files. 
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Designer Suite. See “Compatibility with 
Other Programs” on page 38. 

• Importing a file brings data that was cre-
ated in a different program into Home 
Designer Suite. A number of different file 
types can be imported into Home 
Designer Suite.

Select File> Open Plan to open an 
existing .plan file located on your 

computer. Home Designer Suite 
automatically browses to the directory last 
used.

Open File Dialog
The Open File dialog uses the operating 
system’s file open dialog format, and is also 
used when importing files. The dialog name 

may vary, depending on your operating 
system and the type of file being opened or 
imported.

Choose the location on your local 
computer for the file you are opening.

Any existing folders and/or files in the 
current location display here.

In the File Name field, type the file’s 
name. If you select the file in the space 

above, its name will automatically display  
here.

Never open a file located on a server or
other computer on a network, or on a

removable storage device. Copy such files to
your local machine’s hard drive first, and then
open the copy.

1
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When opening or importing a file, the 
program will usually choose the 

appropriate file type from the Save as type 
drop-down list. When importing, you may 
need to choose a specific file type.

Plan files open to the floor that was active 
when the file was last saved and closed.  

Importing Files
Home Designer Suite has a number of 
options for exporting and importing 
information out of and into your drawings. 
Often, file import dialogs are simply versions 
of the Open File dialog. See “Pictures, 
Images, and Walkthroughs” on page 449. 

Similarly, file export dialogs are often similar 
to the Save File dialog. See “Exporting 
Files” on page 43. 

Recently Opened Files
A list of recently opened and saved plan files 
can be accessed by selecting File> Open 
Recent Files. Select one of these files to 
open it without using the Open File dialog. 

The names of recent files also display in the 
Startup Options dialog. Click on the name 
of a file to open it. See “Startup Options” on 
page 20.

Searching for Plans
Select File> Search for Plans to 
locate an existing, fully-editable 

sample plan or search a selection of non-
editable plans by popular home designers. 
This command opens the Find Plan 
Assistant, which helps you search for plans 
based on parameters that you define. 

At the bottom of each page, the number of 
plans that match your current search 
parameters displays. As you modify the 
parameters, this number increases or 
decreases as matching plans are found.

On any page, click the Back button to 
modify any  previously selected parameters. 

Find Plan Assistant
The Find Plan Assistant can be used to 
search for plans using stored information 
about each plan, such as the square footage 

and the number of bedrooms and other room 
types. 

4
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Begin by selecting either a database of 
editable sample plans or a collection of house 

plan drawings by popular home plan 
companies, then click Next to continue. 
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House Style

Select a style of house from the drop-
down list.

Specify the maximum number of floors 
that you would like. 

Specify the minimum and maximum 
number of bedrooms that you would 

like. 

The number of plans in the database 
that match your search parameters thus 

far displays here for reference. 

Click Next to continue. 

1
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4
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House Size

Specify the minimum and maximum 
number of bathrooms you would like. 

Specify the minimum and maximum 
number of square feet that you would 

like. 

The number of plans in the database 
that match your search parameters thus 

far displays here for reference. 

Click Next to continue. 

1

2

3
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Plan Details

Click on the name of a plan to select it 
and view information about it.

Basic information about the selected 
plan display here. 

A preview of the selected plan displays 
here. 

A written description of the selected 
plan provides additional details 

displays here. 

Click Next to continue, then click Finish to 
view the selected plan. 

Backup Entire Plan
Because Home Designer Suite plans 
often contain many references to other 

external files, it is necessary to copy all the 
associated files to a new location when a plan 

1

2

3

4

home-designer-suite-2015-reference-manual.book  Page 51  Thursday, May 29, 2014  4:26 PM



52

Home Designer Suite 2015 Reference Manual

is moved. You can do this easily by selecting 
File> Backup Entire Plan.

Backing up an Entire Plan is important when:
• Migrating legacy files created in older 

program versions. 
• Transferring files to another computer or 

sending them to another user. 
• Archiving or backing up your work.

To back up a plan

1. To copy all associated plan files to a new 
directory, select File> Backup Entire 
Plan . The Backup Entire Plan dia-
log opens for you to choose what files 
are copied.

•  Choose Backup All Files to copy all 
plan files and all externally referenced 
files such as linked plan files, inserted 
picture files, metafiles, and texture, 
image, and backdrop graphics files. 

•  Choose Backup Plan Files Only to 
copy all associated plan files and any 
externally linked files and inserted pic-
ture files, but no graphics or texture 
files. This is best used only when trans-
ferring a file to a computer that already 
has the graphics files installed.

•  Click OK.
2. The Select the Plan Backup Folder 

dialog opens next. This is a typical Save 
File dialog. See “Saving, Exporting, and 
Backing Up Files” on page 41.

3. Navigate to an empty folder on your sys-
tem and select it. With the destination 
folder for the backup selected, click OK. 

Closing Views and Files
There are several ways to close a view 
window:
• Select File> Close to close the active win-

dow. 
• Press Ctrl + W on the keyboard to close 

the active window.
• Click the Close button in the active 

view’s title bar or in any view’s tab.
• A tabbed view can be closed by clicking 

on its tab using the middle mouse button.

• Select File> Close All to close all cur-
rently open view windows instead of just 
the active window. 

If a plan has only one view window open and 
you try to close it, the program will prompt 
you to save before closing if there are any 
unsaved changes. 

You must select an empty folder for the
Backup Entire Plan feature to work. If

you select an existing folder that is not empty,
the backup is cancelled.

Although the program warns you if you
try to exit without saving, you should get

in the habit of saving plan files before exiting. 
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Exiting Home Designer Suite
Select File> Exit to exit the program. If you 
have not saved any open plans, you are 
reminded to do so. It is better to save your 
work before exiting than to save on exit. 

When you exit from the program using File> 
Exit, all Autosave files and Undo files are 
automatically deleted. 

On a Mac, if you click the program window’s 
red Close button, the window will close but 
the program itself will continue to run. To 
close it down completely, right-click on its 
icon on the Dock and select Quit from the 
contextual menu.
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Chapter 3:

Preferences and
Default Settings

Preferences are global settings that affect the 
functionality and appearance of the Home 
Designer Suite environment, while default 
settings control what objects look like when 
they are initially created. You can save time 
by becoming familiar with these settings and 
customizing them before you begin a new 
drawing.

Chapter Contents
•      Default Settings vs Preferences
•      Dynamic Defaults
•      General Plan Defaults Dialog
•      Preferences Dialog
•      Angle Style Dialog
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Default Settings vs Preferences
Default and preference settings have 
important effects on how the tools in Home 
Designer Suite function. Default settings are 
file specific, while Preferences are global, 
taking effect regardless of what file is open. 

Defaults and Preferences can be customized 
to suit your needs, so it is recommended that 
you become familiar with them and learn 
how you can use them to your advantage.

Default Settings
Default settings determine the initial 
characteristics of objects when they 

are first drawn. For example, when you place 
a base cabinet in a plan, its size, materials, 
front items, and hardware are determined by 
settings in the Base Cabinet Defaults 
dialog.

Defaults are file-specific, which means that 
any changes that you make to the default 
settings in one plan file will have no effect on 
other plans. 

You can access a complete list of the various 
default settings in the current plan file by 

selecting Edit> Default Settings  from 
the menu.

• Click the + beside a category to expand it 
and access the defaults for items related to 
that category.

• To open the defaults dialog associated 
with an item in the list, double-click on 
the line item, or click on the item and then 
click the Edit button.

Preferences
Preference settings influence the 
overall environment of the program, 

such as what the interface looks like and how 
the tools are accessed. See “Preferences 
Dialog” on page 59. 

Unlike default settings, preferences are 
global, which means that any changes that 
you make to them will take effect in all plan 
files. 

To access the Preferences dialog, select 

Edit> Preferences  from the menu.
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Dynamic Defaults
Dynamic defaults are values that can be 
changed globally throughout a model. 
• If you change a dynamic default value in 

a defaults dialog, all objects of that type 
that are set to use the default will update 
automatically to use the new value.

• Any objects of that type that are not using 
the default value because of editing will 
not be affected if you change the default. 

Dynamic defaults are found in the default 
dialogs of a variety of objects, including 
dimension lines, walls, doors, cabinets and 
rooms.

Materials are another example of an attribute 
that uses Dynamic Defaults. See “Material 
Defaults” on page 369.

In object specification dialogs, dynamic 
defaults are followed by either a (D) in the 
value field or a Default checkbox.

To edit a dynamic default, delete the (D) or 
remove the check from Default box and type 
the desired value. 

To reset a value back to the dynamic default, 
type the letter D in the field or click the 
Default checkbox.

General Plan Defaults Dialog
The settings in the General Plan Defaults 
dialog control basic features of the Home 
Designer Suite environment in plan files. 
Just as with other default settings, they are 
file specific, which means that they can be 

set differently in individual plan files. To 
open this dialog, select Edit> Default 
Settings , select Plan, and click the Edit 
button.
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General Settings - Specify the default 
functionality for a variety of general 

behaviors in the program.
• Casing is the trim that surrounds a door or 

window. When you resize a door or win-
dow, its sides are kept away from inter-
secting walls by the width of the casing. 
Check Ignore Casing for Opening 
Resize to allow wall openings to be posi-
tioned against an intersecting wall. Clear 
this box retain sufficient space for the 
opening’s specified trim width. 

• The Arrow Key Scroll Distance setting 
determines how far to scroll in floor plan 
view when you press an arrow key. The 
initial default is 12 inches (300 mm). See 
“Using the Arrow Keys” on page 376.

The Snap Grid allows you to snap 
objects to specific points on-screen as 

they are moved or resized. See “Grid Snaps” 
on page 79.
• Check Use Snap Grid/Units to enable 

Grid Snaps.
• Specify the Snap Unit you wish to use. 

The initial default is 1 inch (10 mm).

Specify the display of the Reference 
Grid.

• Check Show Reference Grid to display 
the Reference Grid, the virtual graph 
paper used to create a sense of scale in 
floor plan view.

• Specify the Reference Grid Size.
• Check Display as Dots to display the 

Reference Grid using dots rather than 
lines. 

Specify how the Living Area label is 
calculated and whether it displays in 
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floor plan view. Not available in layout files. 
See “Living Area” on page 150. 
• Select Main Layer to have the Living 

Area calculation measure from the walls’ 
Main Layer.

• Select Surface to have the Living Area 
calculation measure from the walls’ exte-
rior surface.

• Uncheck Show “Living Area” to disable 
the display of the Living Area label. 

Preferences Dialog
The settings in the Preferences 
dialog are global: they apply to all 

plan files and are preserved between 
sessions. To access this dialog, select Edit> 
Preferences. in Windows® or Chief 
Architect> Preferences in Mac OS X®.

The Preferences dialog consists of panels 
which are accessed by clicking on the names 
in the Category tree along the left side.

The category tree structure is similar to other 
Windows programs. A “+” next to a category 
indicates that it has subcategories. Click the 
“+” to make the subcategories visible; to hide 
them, click the “-.”

The program remembers which panel you 
last accessed and opens to that panel the next 
time you open the dialog.

Preferences dialog panels: 
•      Appearance Panel
•      Colors Panel
•      Library Browser Panel
•      General Panel
•      Folders Panel
•      Edit Panel
•      Render Panel
•      Video Card Status Panel
•      Reset Options Panel

Appearance Panel
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Check Contextual Menus to activate 
contextual menus that display when 

you right-click. See “Contextual Menus” on 
page 27.
• Check Click Twice to Display to require 

two right-clicks on an object before the 
contextual menu displays. This allows the 
first right-click to be used for object 
selection. See “Selecting Objects” on 
page 86. 

In 3D views, the two clicks must be on 
the same object surface in order for the 
contextual menu to display: Clicking on 
two different surfaces of the same object 
is treated like two single-clicks. 

Specify how Toolbars present child 
tools when a parent button is clicked.

• Choose Parent-Child to display child 
tools as buttons at the end of the toolbar 
where the parent button resides.

• Choose Drop Down to display child tools 
when the drop-down arrow to the right of 
the parent button is clicked.

• Uncheck Scale Toolbar Icons for High 
DPI to prevent toolbar icons from becom-
ing larger on systems using high DPI res-
olution. When checked, toolbar buttons 
will increase in size when high DPI is 
used.

Uncheck Side Window Drag Docking 
to prevent undocked side windows 

from docking when moved using the mouse. 
See “View and Side Windows” on page 24.
• Top/Bottom Docking - Check the box 

beside a side window’s name to allow it to 
dock on the top and bottom edges of the 
program window. Does not affect docking 
to the left and right sides.

Colors Panel

Click a color bar to open the Select Color 
dialog. See “Select Color Dialog” on page 
370. 
• Specify the Background Color for floor 

plan view.

The background color for 3D views that 
do not use or a backdrop image is set in 
the 3D Backdrop dialog. See “Backdrop 
Dialog” on page 382.

1

2

3

home-designer-suite-2015-reference-manual.book  Page 60  Thursday, May 29, 2014  4:26 PM



Preferences Dialog

 61

• Specify the Selection Line Color, which 
is the color of the lines that represent 
object(s) and their edit handles when they 
are selected.

• Specify the Handle Fill Color, which is 
the fill color of the edit handles for 
selected objects.

• Specify the Selection Fill Color, which is 
the fill color for selected objects. Note 

that depending on the fill assigned to a 
selected object, its Selection Fill color 
may vary.

Library Browser Panel
The Library Browser panel controls the 
appearance of the Library Browser window. 
See “The Library Browser” on page 342. 

View options control the display of the 
main sections of the Library Browser.

• Check Hide Selection Pane to hide the 
pane that displays objects in a selected 
library or library folder.

• Check Hide Preview Pane to hide the 
pane that shows a preview of a selected 
object.

Specify how selected library items look 
in the Preview Pane. 

• Standard View Display - Library items 
previews display textures and appear as 
they do in 3D views.

• Vector View Display - Library item pre-
views are line-based and display patterns. 

To restore the original size and position of 
the Library Browser and other side windows, 
click the Restore Side Windows button on 
the Reset Options Panel.

Note: If the Selection Line and Handle Fill
Colors are similar, it may be difficult to distin-
guish between active and inactive CAD
Points. 

1

2
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General Panel

Check Show Options at Startup to open the 
Startup Options dialog when Home 

Designer Suite is launched. See “Startup 
Options” on page 20.

Folders Panel

Important user-specific information is saved 
in a folder on your computer called Home 
Designer Suite 2015 Data. This folder 
contains custom library content, toolbars, 
template files, archive files, and other 
important data and is located in My 
Documents by default. See “Home Designer 
Suite Data” on page 39.

While you cannot change the name of this 
directory, you can change its location. To 

avoid unexpected results, it is best to use a 
location on your local hard drive.

If you move this folder on your computer 
without specifying its location here, the 
program will automatically replace it using 
default information from the Home Designer 
Suite installation folder. The same result will 
occur if you specify a location on a network 
or removable device and this location 
becomes inaccessible. When this occurs, 
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customized user settings will not be used and 
custom library content will not be available. 

All Program Paths - Click the Show button 
to open the Program Paths dialog, where 

you can find the location of files that may be 
needed for troubleshooting purposes. See 
“Program Paths Dialog” on page 508.

Edit Panel

You can use a cursor with Cross Hairs and 
control its appearance. 
• Check Enable in Plan andElevation 

Views to use a cross hair cursor in floor 
plan and elevation views. This option is 
checked by default.

• When Synchronize with Cursor is 
checked, the mouse pointer and cross 
hairs always move together on screen. If 
you feel that they do not keep up with 

your mouse movements, try unchecking 
this option. 

• Click the Color bar to open the Select 
Color dialog and specify the color of the 
cross hairs. 

• Cross hair Size is specified as a percent-
age of the view Window Width. Specify 
the Size as 100% to extend the cross hairs 
across the entire screen. 

Render Panel
The Render panel settings control how 3D 
views are generated, particularly Render 

Previews and Final Views. See “Previews vs 
Final Views” on page 400.
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The General Options settings affect 
both Render Previews and Final Views.

• Zoom Using Field of View directs the 
program to zoom in 3D views by adjust-
ing the camera’s Field of View, which can 
result in perspective distortion. See “Field 
of View” on page 392.
When Zoom Using Field of View is 
unchecked, zooming in 3D views is done 
by cropping or expanding the view’s 
extents. See “Zooming” on page 392.

• Hardware Texture Filtering uses your 
video card to filter textures and improve 
their appearance: noticeably, on surfaces 
angled away from the camera. In some 
rare instances, this may slow rendering 
time somewhat. Not supported by some 
video cards. 

• Reflections in Mirrors allows flat sur-
faces using a Mirror material to display 
reflections of other objects in the scene. 
Reflections may slow program perfor-
mance in 3D views, particularly when 
multiple mirrors are present. By default, 

this is checked for Final Views but not for 
Previews. See “Reflections” on page 399. 

• Show Shadows controls whether or not 
shadows display. in Previews. 

• Check Legacy Shadows to generate 
shadows using the method used in version 
X5 and prior. Legacy shadows are signifi-
cantly slower than standard shadows, but 
are often of higher quality with smoother 
edges. 

• Soft Shadows displays shadows with soft 
edges instead of hard edges in Final 
Views with Shadows . See “Render-
ing Tips” on page 399.

• Hardware Edge Smoothing uses the 
video card to remove the jagged edges 
that sometimes result along surface edges, 
producing cleaner lines. Select an MSAA 
(Multi Sample Anti-Aliasing) multiplier 
from the drop-down list: the higher the 
multiplier, the smoother the surface edges 
and longer the rendering time. Not avail-

1
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able if your video card does not support 
this feature. 

Select a Codec for Walkthrough 
Recordings from the drop-down list. 

By default, “Cinepak codec” is selected in 
the 32-bit Windows version of the software, 
“IYUV codec” in the 64-bit Windows 
version, and “H.264” in the Mac version; but 
any other codecs that you  may have installed 
on your system will also display in the list.  
See “Walkthroughs” on page 462.

The Troubleshooting settings can be 
used to troubleshoot performance in 3D 

views.
• Optimizations On saves rendering data 

to your video card, which speeds up ren-
dering time. This option may cause prob-
lems if the rendering data for your model 
exceeds the video card’s memory. 
If the program stops responding when 
rendering, try unchecking Optimizations 
On. This slows down rendering time con-

siderably, though, so if the problem is not 
solved, leave this checkbox selected.

• When Use Enhanced Lighting is 
checked, Standard rendered views gener-
ate lighting effects that require a video 
card that supports OpenGL 2.0. Uncheck-
ing this box may speed up Standard ren-
dering times somewhat; however, the 
quality of lighting effects will be reduced. 
Not available if your video card does not 
support OpenGL 2.0. See “OpenGL and 
Hardware” on page 382. 

• Command Flushing - Select an option 
from the drop-down list to control how 
often the program flushes cached video 
memory. “Rarely” is selected by default 
and will produce fastest rendering times 
on most systems, but “Frequently” may 
be helpful for older video cards. 

Video Card Status Panel
The Video Card Status panel displays 
information about your video card, including 
the vendor and the OpenGL version it uses. 
See “OpenGL and Hardware” on page 382.

This information may be important if you are 
having problems generating 3D views.

Notice the Max Lights value. This indicates 
how many lights can be rendered in a 3D 
view. This value should be 8 or higher, 
depending on your video card. See 
“Lighting” on page 400.

2

3

Note: If your video card does not support this
feature, Optimizations On may be unchecked
automatically to avoid problems. 

home-designer-suite-2015-reference-manual.book  Page 65  Thursday, May 29, 2014  4:26 PM



66

Home Designer Suite 2015 Reference Manual

Reset Options Panel

• If message boxes have been suppressed, 
you can make them display again by 
clicking Reset Message Boxes. See 
“Message Boxes” on page 30.

• Home Designer Suite retains a list of 
locations where you have located missing 
files in the past. If you find that the pro-
gram takes a long time to search for files 
before informing you that they are miss-
ing, you can click the Reset Search Fold-
ers button to clear this list. 

• Click the Reset Dialog Sizes button to 
restore all dialog boxes to their original 

sizes and positions. See “Dialogs” on 
page 27. 

• Click the Reset Side Windows button to 
restore all side windows to their original 
sizes and positions. See “Side Windows” 
on page 25. 

• Click the Reset Preferences button to 
restore all preferences to those that origi-
nally came with the program. For the reset 
to take effect, you will need to restart the 
program. 

Angle Style Dialog
At the bottom of the Terrain Specification 
dialog, you can click the Angle Style button 
to open the Angle Style dialog. See “Terrain 
Specification Dialog” on page 301.

The selection in this dialog is global, 
affecting all plans during the current program 
session, and controls the format of angles in 
dialog boxes as well as in the Status Bar. See 
“The Status Bar” on page 30.

Although this setting controls the format of 
values used in dialogs, it does not limit how 
you can enter these values. For example, if 
you set  your Number Style to use Inches, 
values will display using fractional inches. 
You can, however, enter values using 
decimal inches, inches and feet, or even 
decimal feet. When the dialog you’re typing 
in updates, the value will be converted to 
fractional inches. 
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Angles can be displayed using one of five 
methods: 

• Degrees/Minutes/Seconds - Measured 
counterclockwise from a line drawn hori-
zontally to the right of the angle’s vertex. 
Useful for most drawing tasks. Select the 
level of accuracy that you require.

• Bearings - Measured from a vertical line 
representing North/ South, Quadrant 
Bearings use directional bearings in their 
measurements. Useful for site drawings. 

• Pitch - Defined as a ratio of vertical rise 
to horizontal run. In Imperial units, the 
run is always 12”; in metric units it is 
1000 mm. 
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Chapter 4:

Toolbars and
Hotkeys

Two of the most efficient ways to access 
Home Designer Suite’s tools are the toolbars 
and keyboard shortcuts, also referred to as 
hotkeys.

Chapter Contents
•      Toolbar Arrangement
•      Hotkeys

Toolbar Arrangement
Home Designer Suite’s toolbars provide fast 
access to the program’s most commonly used 
tools, and are organized so that related tools 
are grouped together and easy to find. 

The toolbars that display in a given view 
depend on the view type. For example, the 
toolbars that are available in floor plan and 
3D views are not available in Materials Lists.

Many of Home Designer Suite’s tools are 
organized into families of related tools which 
can be accessed using either of two styles of 
toolbar interface: the Child Tool Palette or 
Drop Down tools. You can select the 
interface that you prefer in the Preferences 
dialog. See “Appearance Panel” on page 59. 

Drop-Down Tools
Click on the arrow to the right of a button to 
display a drop-down list of related tools. For 
example, click the arrow to the right of the 

Window  button to display a drop-down 
list of the other Window Tools.
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The most recently selected tool displays in 
the toolbar.

Child Tool Palette
An alternative to Drop-Down toolbars is the 
Parent button and Child Tool Palette 
interface. Parent toolbar buttons have a blue 
triangle in the lower right corner. When you 
select a Parent button, its Child tools display 
in the Child Tool Palette. If the Child Tool 
Palette has been closed, it will open.

You can open the Tool Palette at any time, 
even when Drop Down tools are enabled, by 
selecting View> Tool Palette. See “View 
Tools” on page 374.

When you click the Window Tools  
Parent button, for example, its Child buttons 
display in the Child Tool Palette.

By default, the Child Tool Palette is docked 
on the left side of the program window; but it 
can be undocked and moved, as well as 
resized and closed, just like other side 
windows. See “Side Windows” on page 25. 

Click the Palette Options  button at the 
bottom of the palette to select how the tools 
within it are presented: 

• Select Fit Palette  to resize the palette 
so that it is one row wide. 

• Select Grid View  to display only the 
button icons of the child tools in a grid 
that may have multiple rows, depending 
on the width of the palette side window.

• Select List View  to display child 
tools in a vertical list with each tool’s but-
ton icon and name in a row.

As long as it is open, the Child Tool Palette 
will also display the members of a selected 
tool’s family when the Drop Down interface 
is active. If you select a tool that does not 
belong to a family, the previously selected 
tool’s family will continue to display in the 
Tool Palette.

Moving Toolbars
You can move any toolbar to a different 
location by clicking and dragging its dotted 
grab bar. Toolbars can be docked to any side 
of the program window, or they can be 
undocked and left floating. 

Undocked toolbars can be moved outside of 
the program window, and they can be closed 
completely. They can also be reshaped; 
however, they cannot be resized in such a 
manner that any buttons become hidden.

The location of moved toolbars is not saved 
between program sessions. The next time 
you use Home Designer Suite, the toolbars 
will be back in their original locations.
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Hotkeys
Many Home Designer Suite tools have a 
keyboard shortcut, or hotkey, associated with 
them. If such a hotkey exists, it will display 
to the right of the tool’s name in the menu.

To use a hotkey, simply press the appropriate 
key or combination of keys on your keyboard 
instead of selecting the menu item or clicking 
the toolbar button. For example, press the 
Ctrl and Z keys at the same time to perform 

an Undo .

Edit menu items with button icons 
to the left and hotkeys to the right
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Chapter 5:

Layers

Layers are used to organize and manage the 
display of all objects in all views. A layer can 
be thought of as a transparency sheet with 
objects placed on it for viewing. Nearly all 
views use multiple layers, like a stack of 
transparencies put together to show different 
types of objects. 

You can customize how each layer displays 
in a particular view in the Display Options 
dialog. 

Multiple layers are organized into Layer 
Sets, which allow you to control which 
objects display in different views.

Chapter Contents
•      Displaying Objects
•      Layer Sets
•      Display Options Dialog
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Displaying Objects
The display of objects in different views is 
controlled by layer sets and layers in the 
Display Options dialog. See “Display 
Options Dialog” on page 75.

Primary and Secondary Layers
Every object is placed on a layer which 
controls whether it displays in a given view. 
This layer is referred to as the object’s 
primary layer. 

In addition, some objects have secondary 
layers which may alter the appearance of 
objects on the primary layer, but do not 
control whether the objects display or not. 

For example, the primary layer for base 
cabinets is “Cabinets, Base”. In addition, 
base cabinets have a number of secondary 
layers that control the display of the 
countertop, face indicators, door opening 
indicators, module lines and labels.

All layers with a check in the “Disp.” column 
display when the current layer set is active. 

Objects that are not displayed cannot be seen 
or selected. If you try to place or draw an 
object on a layer that is hidden, the program 
asks if you want to turn the layer on.

Some objects cannot stand alone in a 
drawing: they can only be inserted into 
another object. If the display of an object that 
contains an inserted object is turned off, the 
display of the inserted object will be turned 
off, as well  For example, if the display of a 
wall is turned off, any doors and windows in 
that wall will not display either. See 
“Inserted Objects” on page 355.

The Color attribute assigned to a layer 
determines how the lines representing 
objects on that layer appear in floor plan and 
Elevation views. 

Many objects, including CAD and text 
objects, allow you to override the line color 
without changing the layer’s color attribute.

Layer Sets
Layer Sets are used to control the layer 
settings for different views in a plan file. 

A layer set consists of a complete list of the 
layers in the current plan along with the 

display settings for each layer as set for a 
particular type of view. These display 
settings can be modified, and can be different 
for each type of view. See “Display Options 
Dialog” on page 75.

Note: If an object’s primary layer is turned off,
information on its secondary layers will not
display - even if those layers are turned on.
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Layer sets are file specific, which means that 
changes made in one plan file have no effect 
on the settings in other files. 

Home Designer Suite uses a different layer 
set for the each type of view of your plan:
• Floor plan view.
• Camera views and Overviews. See “3D 

View Tools” on page 383.
• Elevation views. See “Elevation Views” 

on page 385.
• Framing Overviews. See “Framing Over-

view” on page 385.
• Reference Floor. See “The Reference 

Floor” on page 205.

• Print Model. See “Print Model” on page 
487.

While any view is active, select Tools> 
Display Options  to make changes to the 
layer set used for that view type. 

Any changes made to settings in the Display 
Options dialog for one particular view will 
affect all views using that same layer set. For 
example, if you make changes for a camera 
view, all camera views and overviews in the 
current plan will be affected. See “Display 
Options Dialog” on page 75. 

Unlike other layer sets, the Print Model layer 
set cannot be modified.

Display Options Dialog
The display of objects in all views is 
controlled in the Display Options 

dialog. To make changes to the display 
settings for a particular type of view, open a 
view of that type and select Tools> Display 
Options.

If the display of a particular layer is turned 
off and an object assigned to that layer is 
placed in the plan, the program will 
automatically ask you if the layer should be 
turned on so that the new object will be 
visible. After you make your choice, the 
object will be created - even if you select 
“No.”

Only displayed objects are included when 
DXF and EMF files are exported, and only 
displayed objects print.

• Remove the check from the “Disp.” col-
umn to turn off the display of a category 
of objects. 
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• Click a color bar to open the Select 
Color dialog and set the display color for 
objects on that layer in floor plan and 
Elevation views. See “Select Color Dia-
log” on page 370. 

• Click on a column header to sort all lay-
ers by that column. Click again to sort in 
reverse order.

• Click the size grip at the lower right cor-
ner and drag to resize the dialog box.

Note: Not all objects display in all views. For
instance, invisible walls do not appear in
camera views or materials lists.
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Chapter 6:

Creating Objects

There are a wide variety of objects in Home 
Designer Suite that you can use to create 3D 
models and plan drawings. Although these 
objects are sometimes very different from 
one another, the methods used to create them 
are similar. 

Once an object is created, it can be selected 
and edited to meet the requirements of your 
project. The editing characteristics common 
to most objects are described elsewhere. See 
“Editing Objects” on page 85. 

Chapter Contents
•      Architectural vs CAD Objects
•      Snap Behaviors
•      Object Snaps
•      Angle Snaps
•      Grid Snaps
•      Creating Objects
•      Copying and Pasting Objects
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Architectural vs CAD Objects
There are two broad categories of objects in 
Home Designer Suite: architectural objects 
and CAD objects. 

CAD objects such as  lines, arcs, text, and 
dimensions are 2D objects that can be 
created and edited in floor plan view and  but 
do not display in 3D camera views and 
overviews. See “The CAD Drawing Tools” 
on page 431. 

In contrast, architectural objects such as 
walls, cabinets, doors, windows, and stairs 
display in 2D and 3D views.

Some architectural objects, such as terrain 
features, have some behaviors in common 
with CAD objects and are referred to as 
CAD-based.

Snap Behaviors
There are three categories of snap behavior 
in Home Designer Suite that affect how 
objects are created and how they can be 
edited: 

• Object Snaps , which snap CAD and 
architectural objects to other objects. 

• Angle Snaps , which snap objects at 
specific angles. 

• Grid Snaps  , which snap objects to 
points on a grid.

You can select Edit> Snap Settings to 
quickly turn Object, Angle and Grid Snaps 
on or off. 

To temporarily disable Snap Behaviors and 
other move restrictions, press the Ctrl key 
while dragging an edit handle. See “Moving 
Objects” on page 106.

Object Snaps
Object Snaps allow you to position objects 
precisely relative to each other; for example, 
to position lines so that their endpoints meet.

Object Snaps can be turned on or off by 
selecting Edit> Snap Settings> Object 
Snaps.

There are many locations on an object that 
other objects can snap to.
• Object endpoints and corners
• The midpoints of object edges

• Object center points
• Intersection points where an object drawn 

at an allowed angle meets another object.

In addition, On Object snapping occurs 
anywhere on an object’s edges and is most 
noticeable when Angle and Grid Snaps are 
turned off.

When multiple objects are selected, the 
selection set’s only snap point is its midpoint.
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Extension Snaps
Extension snaps allow you to snap to a point 
that is not actually on an object. Instead, 
these snaps locate points that are either 
colinear to the end of a wall or orthogonal (at 
a 90° angle) to it. 

Extension snaps function when you are 
drawing or editing walls and create a “sticky 
point” where the wall being drawn reaches a 
point that is either colinear or orthogonal to 
another wall’s end point. See “Drawing 
Walls” on page 122. 

Angle Snaps
It is often important that objects be 
drawn at exact angles. This can be 

accomplished using Angle Snaps. Angle 
Snaps allow you to draw walls, lines, and 
other objects at angles in 7.5° increments. 
Angle Snaps also affect the way objects 
rotate, the radius of arcs, and a variety of 
other operations.

Angle Snaps can be turned on or off by 
selecting Edit> Snap Settings> Angle 
Snaps . When Angle Snaps are disabled, 
the Angle Snaps  icon will display near 
the mouse pointer. 

Grid Snaps
Grid Snaps allow you to snap objects 
to points on an on-screen grid. This 

grid cannot be seen directly, but as you draw, 
move or resize an object, you can sometimes 
see it snapping at regular increments. The 
size of this Snap Grid can be controlled in the 
Plan Defaults dialog. See “General Plan 
Defaults Dialog” on page 57.

It is recommended that you draw and 
position the exterior walls of your plan with 

Grid Snaps  enabled. Once these walls 
are in place, you may choose to turn Grid 
Snaps off to finish the rest of the drawing. 

Grid Snaps are turned on and off by selecting 

Edit> Snap Settings>Grid Snaps  or in 
the Plan Defaults dialog. 

In addition to the Snap Grid, the Reference 
Grid is provided to give you a visual sense 
of scale. The Reference Grid is composed of 
12” x 12” squares and is useful for zooming 
in and out, or for general layout guidelines, 
but is not used for snapping. The Reference 
Grid can be toggled on and off by selecting 
View> Reference Grid. See “View Tools” 
on page 374.

Grid Snaps and Angle Snaps
Of the three snap behaviors, Grid Snaps have 
the lowest priority and are overridden by 
Angle Snaps and Object Snaps. 

When Grid snaps and Angle Snaps are both 
enabled, objects are drawn and edited using 
Polar Coordinates. For example, if the grid 
Snap Unit is set to 12" (1 foot), drawing a 
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new wall at an Allowed Angle snaps the wall 
length to 0", 12", 24", and so on.

Creating Objects
In Home Designer Suite, there are three ways 
to create objects: by clicking to place an 
object, by clicking and dragging to draw an 
object, or by importing custom symbols, 
pictures or metafiles.

If you create an object using any of these 
methods and the layer it will go on is turned 
off, the program will ask you if you want to 
display the layer. See “Object Creation and 
Layers” on page 81.

While the size of the drawing area in Home 
Designer Suite is limited only by the 
resources on your computer, it is best to 
begin your drawing near the origin, 0,0,0. 
The current position of your mouse pointer 
displays in the Status Bar at the bottom of the 
program window. See “3D Drafting” on page 
21. 

Click-to-Create
Many objects, including doors and windows, 
cabinets, library symbols, terrain objects, 
text, pictures and images  are created by 
clicking. Select a or library object, then click 
in the drawing area to place the object at that 
location. 

Continue clicking to place the selected object 
until another tool is selected.

If you click at a location where there is not 
enough room for the object to be placed, one 
of two things may happen:

• Some objects, notably cabinets, doors, 
and windows, will resize smaller to fit 
into the space. 

• Most objects cannot resize in this man-
ner, so the program will present a warn-
ing message indicating that there is not 
sufficient space at the current location.

When most drawing tools are active or 
library symbols selected for placement, a 
preview outline follows your mouse pointer, 
indicating the size and shape of the object to 
be created. If your pointer is positioned at a 
location where the object cannot be placed, 
this preview outline will not display.

As you move the mouse pointer, the center 
point of the object’s back edge will snap to 

active snap points when Grid Snaps  or 
Object Snaps are enabled. See “Snap 
Behaviors” on page 78.

Many architectural objects can be created in 
floor plan view or any 3D view. In order to 
place a stand-alone, click-to-create object in 
3D, it is necessary to click near a wall or 
within the Terrain Perimeter as these objects 
help orient the new object within the 3D 
space. 

Clicking and Dragging
Other objects, including walls and railings, 
straight stairs, and CAD and CAD-based 
objects are created by clicking and dragging 

To draw a line or wall at an Allowed
Angle but with unrestricted length, dis-

able Grid Snaps and leave Angle Snaps on.
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to define either a path or an enclosed area. 
Select a tool, then click and drag in the 
drawing area to draw an object between your 
start and end points.

Continue drawing the selected object until 
another tool is selected.

You can temporarily slow the movement of 
the mouse as you drag by holding down the 
Shift key on your keyboard..

You can cancel any click-and-drag drawing 
operation before it is completed by pressing 
the Esc key on your keyboard, or by pressing 
any two mouse buttons at the same time. 

Importing Objects
Custom symbols,  pictures and metafiles can 
be imported into the program and placed in 
the drawing area with a click. See “Importing 

and Exporting” on page 469 and “Pictures, 
Images, and Walkthroughs” on page 449. 

Object Creation and Layers
When it is created, every object is placed on 
a layer which controls whether and how it 
displays. See “Layers” on page 73. 

If you try to create an object on a layer that is 
not set to display in the current view, the 
program will ask if you want to turn that 
layer on. See “Message Boxes” on page 30. 
• Click Yes to create the object and turn on 

its layer in the current view.
• Click No to create the object but leave its 

layer turned off in the current view. 
• Click Cancel to not create the object and 

leave the layer turned off.

Copying and Pasting Objects
New objects can also be created by cutting, 
copying, and pasting existing objects, either 
individually or in groups. Objects can be 
copied from one floor to another, one view 
window to another, and one file to another. 
Because copying uses the Windows 
Clipboard, some objects can be pasted into 
other applications, as well.

Objects cannot be pasted into any views that 
they cannot be created in normally. For 
example, CAD objects cannot be pasted into 
a 3D camera view or overview. 

A few objects, such as Terrain Perimeters 
and camera symbols, cannot be copied. 

Cut
Select Edit> Cut to remove the 
selected object(s) from the file and 

save them in the Windows Clipboard. To 
paste the selection in Home Designer Suite 
or another application, select Edit> Paste or 
press Ctrl + V while in that application to 
enable the Paste function.

Copy
Select Edit> Copy to copy the 
selected object(s) to the Windows 

Clipboard. To paste the selection in Home 

Objects created in an Imperial plan
should not be pasted into a metric file, or

vice versa. See “Template Plans” on page
40. 
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Designer Suite or another application, select 
Edit> Paste or press Ctrl + V while in that 
application to enable the Paste function. 

Paste
Select Edit> Paste to enable Paste 
mode, then left- or right-click in the 

current view to paste the selected object(s) 
previously copied to the Windows Clipboard 
at that location. 

Once pasted, these object(s) are selected. 
Objects pasted in 3D views are selected on 
their top surfaces.

If the selection being pasted consists of text, 
it is placed in a Text object.

Copy/Paste
Click the Copy/Paste edit button to 
copy the selected object(s) to the 

Windows Clipboard and immediately enable 

the Paste  function in Home Designer 
Suite. 

The Copy/Paste  edit button activates 
Paste mode in which each available edit tool 
and handle makes a copy in addition to its 
primary function and four new edit buttons 
display on the edit toolbar.

• Click the Sticky Mode  edit button 
remain in the current mode and place 
multiple copies of the selected object(s). 

• Click the Main Edit Mode  edit but-
ton or press the Esc key to return to the 
selected objects’s main edit toolbar.

If you paste a selection in a file other than its 
original source file, when you return to the 
original, Paste mode is still enabled. 

The Copy/Paste  edit button can be used 
with the edit handles in either of two ways: 
by clicking or by dragging an edit handle.

To Copy/Paste by clicking

1. Select an object or objects to copy.

2. Click the Copy/Paste  edit button, 

select Edit> Copy  from the menu or 
press Ctrl + C to copy and then Ctrl + 
V to activate the Paste functionality. The 
cursor displays the Copy/Paste icon.

3. If you wish to paste the copy in a differ-
ent view or program window, open that 
window. 

4. If your cursor does not display the Copy/
Paste icon, select Edit> Paste from the 
menu or press Ctrl + V.

5. Left- or right-click once to paste a copy 
of the object at that location.

To Copy/Paste by dragging

1. Select an object or objects to copy.

2. Click the Copy/Paste  edit button, 

select Edit> Copy  from the menu or 
press Ctrl + C. The cursor displays the 
Copy/Paste icon.

3. Drag an edit handle:
•  Drag the Move edit handle to position 

the copy at a new location. 
4. You can position the copy accurately 

with respect to the original by watching 
the moved distance in the Status Bar at 
the bottom of the screen.
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Sticky Mode
Normally, after an action is performed 
using the edit tools or handles while in 

an edit mode such as Paste mode, you  return 
to the Main Edit Mode. Click the Sticky 
Mode edit button to remain in Paste mode 
and continue pasting copies of the selected 
object(s). 

To exit Paste mode and return to the main 
edit toolbar for the selected object, click the 

Main Edit Mode  edit button or press the 
Esc key on your keyboard. If you have not 
pasted a copy of the selected object and 

immediately click Copy/Paste  after 
returning to the Main Edit Mode, Sticky 
Mode  is still enabled. 

Copy and Paste in Place
Click the Copy and Paste in Place 
edit button to create a copy of the 

selected object(s) at the same location as the 
original. The copy remains selected so you 
can perform additional operations.

Because multiple walls, railing and fencing 
cannot share the same space, the Copy and 
Paste in Place  edit button is not avail-
able for these objects.

Paste Hold Position
When copying between different 
floors or view windows, you can paste 

a copy at the same absolute position as the 
original selection using Paste Hold Position.

To use Paste Hold Position

1. Select the object(s) to be copied.

2. Click the Copy/Paste  edit button.
3. Switch to the desired floor or plan file 

and select Edit> Paste> Paste Hold 
Position .

4. A copy is placed at the same X, Y coor-
dinates on the new floor or in the new 
plan as the original’s position.

Paste Special
The Paste Special tool allows you to 
choose a representation for the 

selection to be pasted. 

Selections can be pasted as:
• Enhanced Windows Metafiles (EMF). 

See “Metafiles” on page 455. 
• Device Independent Bitmaps (BMP). See 

“Importing Pictures” on page 454.
• Unformatted non-unicode text (TXT).
• File Name (a path to a file). Depending 

on the file type, it will be either opened or 
imported (if supported). 

• Unformatted text (HTML). Pastes as text.
• Model Objects - Home Designer Suite 

format, not compatible with other pro-
grams.

To use Paste Special

1. Select an object, image, text or file on 
your computer and copy it.

2. Switch to the desired Home Designer 
Suite view window and select Edit> 
Paste> Paste Special .

3. In the Paste Special dialog, select the 
desired representation for the selection 
and click OK.
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4. Click in the drawing area to place the 
copy at that location.

Copy Region as Picture
The Copy Region as Picture tool 
allows you to copy any portion of the 

screen and save it as a picture.  See “Copy 
Region as Picture” on page 459. 
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Chapter 7:

Editing Objects

Just as the methods used to create different 
objects in Home Designer Suite are similar, 
the options for moving, rotating, resizing, 
and otherwise editing them are also alike. 

Edit handles allow objects to be resized, 
relocated, or rotated using the mouse. Edit 
toolbar buttons and the contextual menus 
access edit tools relevant to the selected 
object(s). Most objects have a specification 
dialog that allows you to edit it in ways that 
are specific to that type of object. 

The editing characteristics common to most 
objects are described in this chapter. Unique, 
object-specific editing behaviors and the 
specification dialogs are covered in their 
respective chapters. 

Chapter Contents
•      Selecting Objects
•      Editing Line Based Objects
•      Editing Arc Based Objects
•      Editing Open Polyline Based Objects
•      Editing Closed-Polyline Based Objects
•      Editing Box-Based Objects
•      Editing Spline Based Objects
•      Editing Circles, Ovals and Ellipses
•      Displaying Objects
•      Moving Objects
•      Aligning Objects
•      Resizing Objects
•      Reshaping Objects
•      Rotating Objects
•      Deleting Objects
•      Undo and Redo
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Selecting Objects
“Select” refers to selecting an object for 
editing. An object must be selected before it 
can be edited. 

In order for an object to be selected, it must 
be visible in the current view. See “Layers” 
on page 73. 

When an object is selected, it displays edit 
handles and a grey selection fill color. In 3D 
views, a selected object will also display 
lines representing the selected edge or 
surface. The size of the edit handles does not 
change as you zoom in or out. To prevent 
them from stacking on one another, some 
edit handles may not display as you zoom 
away from the selected object. 

When an object is selected, its edit toolbar 
also displays, typically on the upper left side 
of the Home Designer Suite program 
window.  See “The Edit Toolbar” on page 26.

Information about the selected object or 
objects may also display in the Status Bar. 
See “The Status Bar” on page 30.

A selected object remains selected until 
another object is selected, a different tool is 
activated, the Esc key on the keyboard is 
pressed, or any two mouse buttons are 
pressed at the same time. 

Select Objects
Any object created using Home 
Designer Suite can be selected using 

the Select Objects tool. Select Edit> Select 
Objects, click the toolbar button or press the 
Space bar on your keyboard to activate this 
tool, then click on an object to select it.

You can also select objects or open context 
sensitive menus using the right mouse button 
when any tool is active.

Selecting Similar Objects

If a tool other than Select Objects  is 
active, you can only select objects of that 
type using the left mouse button. For 

example, if the Straight Exterior Wall  
tool is active, you can only select walls using 
the left mouse button. 

This can be useful for selecting an object 
when many objects of a different type 
occupy the same space in floor plan view. 

Objects can be selected using the right mouse 
button, regardless of which tool is active. 

Right-Clicking
Regardless of which tool is active, you can 
select an eligible object by right-clicking on 
it once. When you right-click to select an 
object a contextual menu also appears, 
displaying the object’s edit tools. See 
“Contextual Menus” on page 27.

If a drawing tool is active and you right-click 
to select an object, you can unselect it by 
left-clicking in an empty space in the 
drawing area. Although a drawing tool is 
active, it is not used. If you then left-click a 
second time, the active tool will be used. 

Selected Edge
When you click on a polyline- or box-based 
object, the edge that you click nearest 
becomes the selected edge and displays an 
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edit handle larger than those on other edges. 
The handle on this edge may also display at 
the point where you clicked to select it.  

This edge can be edited on the Selected Line 
or Selected Arc panel of the object’s 
specification dialog. See “Moving Objects 
Using Dimensions” on page 414, “Line 
Panel” on page 434 and “Arc Panel” on page 
436.

Select Next Object
If there is more than one object in a 
particular space, it may be difficult to 

select the desired object. When a nearby 
object is selected, click the Select Next 
Object edit button or press the Tab key until 
the desired object becomes selected. This 
function cannot be applied to groups of 
selected objects.

Marquee Select
Groups of objects can be selected by holding 
down either the Shift or Ctrl key when the 

Select Objects  tool is active and then 
dragging a marquee around the objects to be 
selected. An object does not need to be 
completely enclosed by the marquee to be 
selected: it will be selected if the marquee 
includes only a small portion of it. 

If an object is currently selected and a 
selection marquee is drawn around it, that 
object becomes de-selected.  If an object is 
currently selected and a marquee is drawn 
around other objects, the original object  
remains selected and the other objects are 
added to the selection set.

When using the marquee-select method, both 
CAD and architectural objects included in 
the marquee are selected. To remove an 
object from the selection set, hold down the 
Shift key and click it.

The Shift key can also be used to marquee-
select objects of a similar type. For example, 

click the Hinged Door  child button, hold 
down the Shift key, drag a marquee, release 
the mouse button, and only door objects 
within the marquee are selected. The Ctrl key 
will always marquee-select objects of all 
types, regardless of the active tool. 

Shift and Ctrl Select
You can select a group of objects by adding 
them to the selection set one by one. Select 
an object, hold down either the Shift or Ctrl 
key, and click additional objects to select 
them. 

More than one type of object can be selected 
using this method, but the ability to edit the 
group-selected items is limited to attributes 
that all selected objects have in common.

To remove an object from a selection set, 
click it once more - again, with either the 
Shift or Ctrl key pressed.

To make marquee selection easier, you
can turn off the display of objects you

do not want to include in your selection set.
See “Displaying Objects” on page 74.
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The Shift and Ctrl keys can be used to select 
multiple items in a variety of contexts, such 
as:  the Library and Project Browsers, lists in 
dialog boxes, and files to be imported.

Edit Area
The Edit Area tool allows you to 
quickly define an area of your plan 

and select the objects in that area. Once 
selected, they can then be repositioned, 
rotated, or deleted. Select Edit> Edit Area, 

then click and drag a rectangular marquee 
around the area that you would like to move.

Unlike other selection methods, the Edit 
Area tool cuts walls, railings and fencing 
where the selection marquee intersects them, 
allowing you to edit only the selected portion 
of these objects. 

Some objects, such as cabinets, are included 
in the selection only if more than half of the 
object is contained within the marquee. 

Editing Line Based Objects
Objects are considered line-based when they 
can be edited similar to CAD lines using 
their edit handles.

CAD lines, straight walls and railings, 
straight stairs and straight roads are examples 
of line-based objects. 

Most line-based objects can be connected to 
other like objects to form polylines or 
polyline-based objects. See “Editing Open 
Polyline Based Objects” on page 93 and 
“Editing Closed-Polyline Based Objects” on 
page 96.

Some objects, notably walls, have line-based 
editing behavior only when selected on 
certain surfaces. See “Editing Walls” on page 
127.

Wall openings such as doors and windows 
have line-based editing behavior in floor plan 
view only but cannot be rotated, reversed or 
converted to an arc. See “Editing Doors” on 
page 165 and “Editing Windows” on page 
183.

Other objects, such as stairs and roads, have 
additional edit handles that allow you to 
concentrically adjust the object’s width. 

Using the Edit Handles
When selected, a typical line-based object 
displays four edit handles.  

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.
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Move
• Movement may be limited or stopped by 

other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 106.

Rotate
• The Rotate handle is used to rotate the 

object about its center. See “Rotating 
Objects” on page 110.

Extend/Change Angle 
• Drag an end handle parallel to the 

selected line to change its length. 
• Drag an end handle at an angle to the 

selected line to change its angle. When 

Angle Snaps  are on, the line snaps to 
Allowed Angles. See “Angle Snaps” on 
page 79.

Adjust Width

Some line-based objects, such as stairs and 
roads, have additional handles that allow the 
width of the object to be adjusted.

• Click and drag a small, round Expand 
handle to increase or decrease the 

object’s width. By default, objects are 
resized in 1" increments. This Snap Unit 
is defined in the Plan Defaults dialog. 
See “General Plan Defaults Dialog” on 
page 57.

Using Dimensions
Dimensions can be used to position 
line-based objects relative to other 

objects. See “Moving Objects Using 
Dimensions” on page 414.

Dimensions cannot, however, be used to 
adjust the length of line-based objects, or the 
width of line-based objects such as stairs.

Using the 
Specification Dialog

Line-based objects can be edited using 
their specification dialogs. See “Line 

Specification Dialog” on page 434.

Using the Edit Toolbar
A selected line-based object can be edited in 
a variety of ways using the buttons on the 
edit toolbar. 

The following toolbar buttons may display 
on the edit toolbar for a selected line-based 
object: 

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 86.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 29.

Rotate

Extend/Change Angle

Move

Adjust Width
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• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 
elsewhere. See “Copying and Pasting 
Objects” on page 81.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 83.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 111.

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 

fixture. See “Using Center Object” on 
page 107.

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 105.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 109.

• Click the Change Line/Arc  edit but-
ton to change a line-based object to an 
arc, or vice versa. See “Change Line/
Arc” on page 110.

Editing Arc Based Objects
Objects are considered arc-based when they 
can be edited similar to CAD arcs using their 
edit handles.  

CAD arcs, curved walls and railings, curved 
stairs, and curved roads are examples of arc-
based objects.  

Most arc-based objects can be connected to 
other like objects to form polylines or 
polyline-based objects. See “Editing Open 
Polyline Based Objects” on page 93 and 
“Editing Closed-Polyline Based Objects” on 
page 96.

Some objects, notably curved walls, have 
arc-based editing behavior only when 
selected on certain surfaces. See “Editing 
Walls” on page 127.
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Other objects, such as curved stairs and 
roads, have additional edit handles that allow 
you to concentrically adjust the object’s 
width. 

Using the Edit Handles
When selected, a typical arc-based object 
displays seven edit handles. 

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Two Move edit handles allow the arc to 

be relocated without changing its shape. 
One is located at the center of the chord 
and the other, at the arc center. 

• Movement may be limited or stopped by 
other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 106.

Rotate
• The Rotate handle is used to rotate the 

arc about its center. See “Rotating 
Objects” on page 110.

Extend
• The end edit handles expand or contract 

the arc when moved along the arc radius 
or chord. 

• If you follow the path of the arc, the end 
edit handles allow you to adjust the arc 
length.

• The angle formed by the center point of 
the arc and its two endpoints is referred to 
as the Included Angle. If Angle 
Snaps  are on, the Included Angle of 
the arc can be rotated at Allowed Angles. 
See “Angle Snaps” on page 79.

Resize
• Drag the small, round Resize edit handle 

to change the radius and included angle 
of the arc while maintaining its center. 

Extend
 (along arc or chord)

Move Arc 
Center

Reshape
(moves center)

Resize
(changes radius)

Rotate

Move 
Chord

Move edit handle

Extend edit handles
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Reshape
• Drag the small triangular Reshape 

handle to change the length and location 
of the center without moving the 
endpoints.

Adjust Width

Some arc-based objects, such as stairs, have 
additional handles that allow the width of the 
object to be adjusted. 

• Click and drag a small, round edit handle 
to increase or decrease the object’s width. 
By default, objects are resized according 
to the Snap Unit defined in the Plan 
Defaults dialog. See “General Plan 
Defaults Dialog” on page 57.

Using Dimensions
Dimensions can be used to position 
arc-based objects. Dimension lines 

typically locate tangent extension lines and 
any extension lines that may be parallel to 
those lines rather than the arc itself. See 
“Moving Objects Using Dimensions” on 
page 414.

Using the 
Specification Dialog

Arc-based objects can be edited using 
their specification dialogs. See “Arc 

Specification Dialog” on page 436.

Using the Edit Toolbar
A selected arc-based object can be edited in a 
variety of ways using the buttons on the edit 
toolbar. 

The following toolbar buttons may display 
on the edit toolbar for a selected arc-based 
object:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 86.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 29.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 
elsewhere. See “Copying and Pasting 
Objects” on page 81.

Resize edit handle

Reshape edit handle

Adjust Width
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• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 83.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 111.

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 107.

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 105.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 109.

• Click the Change Line/Arc  edit but-
ton to change an arc-based object to a 
line, or vice versa. See “Change Line/
Arc” on page 110.

Editing Open Polyline Based Objects
Open polyline-based objects are composed 
of individual line- and arc-based objects that 
are connected at their end points but do not 
form an enclosed area. See “Polylines” on 
page 438. 

Objects are considered open polyline-based 
when they can be edited similar to open CAD 
polylines using their edit handles. 

Open CAD polylines, connected walls, 
stairs, and roads are examples of open 
polyline-based objects. 

For information about editing closed 
polyline-based objects, see “Editing Closed-
Polyline Based Objects” on page 96.

Other objects, such as connected stair and 
road segments, have additional edit handles 
that allow you to concentrically adjust the 
width of all segments of the object. 

home-designer-suite-2015-reference-manual.book  Page 93  Thursday, May 29, 2014  4:26 PM



94

Home Designer Suite 2015 Reference Manual

Using the Edit Handles
A polyline can be composed of many 
segments. See “Polylines” on page 438. 

When selected, an open polyline-based 
object displays a Move handle, a Rotate 
handle, a Reshape handle at the intersection 
of each segment, and an Extend handle at 
each end. 

Each straight, line-based segment also has a 
Move edit handle along its length. 

Each curved, arc-based segment has its own 
Move handle at the center of its chord, a 
Resize handle and, if it has an unlocked 
center, a Reshape handle. See “Editing Arc 
Based Objects” on page 90.

When a polyline is selected, the edge that 
you click nearest is called the selected edge, 
and certain operations affect only this edge. 
The Move handle of the selected edge is 
larger than that of other edges. It displays 
along the length of a line segment, or at the 
center of the chord on an arc segment. See 
“Selected Edge” on page 86.

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Click and drag the Move handle to move 

the object. 
• Movement may be limited or stopped by 

other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 106.

Rotate
• The Rotate handle is used to rotate the 

object about its center. Its position varies 
depending on which edge is currently 
selected. See “Rotating Objects” on page 
110.

Extend
• Click and drag an Extend handle to 

lengthen or shorten the unconnected end 
of the selected line or arc segment, or to 
change the radius of the selected arc. See 
“Editing Arc Based Objects” on page 90.

Reshape 
• Click and drag a Reshape edit handle to 

change the angle and/or length of the seg-
ments on either side of it, or the size of 
the object. 

Move Line Segment
• The Move Line Segment edit handle is 

found on straight segments of open poly-
lines and moves the straight section per-
pendicular to itself. Adjacent segments 
may extend or contract in their original 
directions to maintain their connections. 

Move Arc
• Click and drag the Move Arc edit handle 

to change the radius and/or chord length 
or position. Adjacent segments may 

Move 
polyline

Move arc 
segment

Rotate
Extend

Resize 
arc

Reshape 
arc

Move line 
segment

Reshape 
polyline
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extend, contract, or change angle to 
maintain their connections. 

Resize Arc
• Click and drag the Resize Arc edit handle 

to change the radius, chord length and 
chord position of the arc segment. Adja-
cent segments may extend, contract, or 
change angle to maintain their connec-
tions. 

Reshape Arc
• Click and drag the Reshape Arc edit han-

dle to change the radius of the arc without 
moving its end points. 

Adjust Width

Some arc-based objects, such as stairs and 
roads, have additional handles that allow the 
width of the object to be adjusted. 

• Click and drag a small, round edit handle 
to increase or decrease the object’s width. 
By default, objects are resized in 1" 
increments. This Snap Unit is defined in 
the Plan Defaults dialog. See “General 
Plan Defaults Dialog” on page 57.

Using Dimensions
Dimensions can be used to move or 
reshape polyline-based objects. See 

“Moving Objects Using Dimensions” on 
page 414.

Using the Specification 
Dialog

Open polyline-based objects can be 
edited using their specification 

dialogs. See “Polyline Specification Dialog” 
on page 438.

Using the Edit Toolbar
A selected open polyline-based object can be 
edited in a variety of ways using the buttons 
on the edit toolbar. 

The following toolbar buttons may display 
on the edit toolbar for a selected open 
polyline-based object:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 86.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 29.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 
elsewhere. See “Copying and Pasting 
Objects” on page 81.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 83.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 111.

Adjust 
Width
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• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 107.

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 105.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 

selected object. See “Break Line” on 
page 109.

• Click the Change Line/Arc  edit but-
ton to change a line-based polyline edge 
to an arc, or vice versa. See “Change 
Line/Arc” on page 110.

• Click the Record Walkthrough Along 
Path  edit button to record a walk-
through video of your model along the 
path defined by the selected polyline. See 
“Walkthroughs” on page 462.

Editing Closed-Polyline Based Objects
Closed polyline-based objects are composed 
of individual line- and arc-based objects 
joined end-to-end and forming an enclosed 
area. See “Polylines” on page 438. 

Objects are considered closed polyline-based 
when they can be edited similar to closed 
CAD polylines using their edit handles. 

Closed CAD polylines and terrain features 
are examples of closed polyline-based 
objects. 

For information about editing open polyline-
based objects, see “Editing Open Polyline 
Based Objects” on page 93.

Some objects, such as connected road 
segments, have additional edit handles that 

allow you to concentrically adjust the width 
of all segments of the object. 

Using the Edit Handles
A polyline can be composed of many 
segments. See “Polylines” on page 438. 

When selected, a closed polyline-based 
object displays a Move handle, a Rotate 
handle, and a Reshape handle at the 
intersection of each segment. 

Each straight, line-based segment has a 
Move edit handle along its length. 

Each curved, arc-based segment has its own 
Move handle at the center of its chord, a 
Resize handle and a Reshape handle. See 
“Editing Arc Based Objects” on page 90.

When a polyline is selected, the edge that 
you click nearest is called the selected edge, 
and certain operations affect only this edge. 
The Move handle of the selected edge is 
larger than that of other edges. It displays 
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along the length of a line segment, or at the 
center of the chord on an arc segment. See 
“Selected Edge” on page 86.

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Click and drag the Move handle to move 

the object. 
• Movement may be limited or stopped by 

other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 106.

Rotate
• The Rotate handle is used to rotate the 

object about its center. Its position varies 
depending on which edge is currently 
selected. See “Rotating Objects” on page 
110.

Reshape
• Click and drag a Reshape edit handle to 

change the angle and/or length of the seg-
ments on either side of it, or the size of 
the object. 

Move Line Segment
• The Move Line Segment edit handle is 

found on straight segments of closed 

polylines and moves the straight section 
perpendicular to itself. Adjacent seg-
ments may extend or contract in their 
original directions to maintain their con-
nections. 

Move Arc
• Click and drag the Move Arc edit handle 

to change the radius and/or chord length 
or position. Adjacent segments may 
extend, contract, or change angle to 
maintain their connections. 

Resize Arc
• Click and drag the Resize Arc edit handle 

to change the radius, chord length and 
chord position of the arc segment. Adja-
cent segments may extend, contract, or 
change angle to maintain their connec-
tions. 

Reshape Arc
• Click and drag the Reshape Arc edit han-

dle to change the radius of the arc without 
moving its end points. 

Using Dimensions
Dimensions can be used to move or 
reshape closed polyline-based objects. 

See “Moving Objects Using Dimensions” on 
page 414.

Using the 
Specification Dialog

Closed polyline-based objects can be 
edited using their specification 

dialogs. See “Polyline Specification Dialog” 
on page 438.

Move 
polyline

Move arc 
segment

Rotate

Resize 
arc

Reshape 
arc

Move line 
segment

Reshape 
polyline
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Using the Edit Toolbar
A selected closed polyline-based object can 
be edited in a variety of ways using the 
buttons on the edit toolbar. 

The following toolbar buttons may display 
on the edit toolbar for a selected closed 
polyline-based object:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 86.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 29.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 
elsewhere. See “Copying and Pasting 
Objects” on page 81.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 83.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 111.

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 107.

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 105.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 109.

• Click the Change Line/Arc  edit but-
ton to change a line-based polyline edge 
to an arc, or vice versa. See “Change 
Line/Arc” on page 110.

• Click the Record Walkthrough Along 
Path  edit button to record a walk-
through video of your model along the 
path defined by the selected polyline. See 
“Walkthroughs” on page 462.

Editing Box-Based Objects
Objects are considered box-based when they 
can be edited similar to CAD boxes using 
their edit handles. 

Box-based objects are similar to closed 
polyline-based objects, but must always have 
four sides with right-angled corners. 

In addition to the CAD Box tools, Text 
objects, many library symbols, pictures and 
images are examples of box-based objects.

Using the Edit Handles
When selected, a box-based object displays 
ten edit handles. Unlike polylines, boxes 
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must always have four sides with right-
angled corners.

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

• Click and drag the Move handle to move 
the object. 

• Movement may be limited or stopped by 
other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 106.

• The four Resize handles located at each 
corner are used to increase or decrease 
the size of the object. 

• The four Extend handles display along 
each edge. If you select an object on an 

edge, the Extend handle displays at the 
point where you clicked; otherwise, it 
displays at the center of the edge.

• The triangular Rotate handle located 
near the selected edge of the object is 
used to rotate it about its center. The 
pointer changes to a circular arrow  
when moved over this handle. See 
“Rotating Objects” on page 110.

Using Dimensions
Dimensions can be used to move or 
reshape box-based objects. See 

“Moving Objects Using Dimensions” on 
page 414.

Using the 
Specification Dialog

Box-based objects can be edited using 
their specification dialogs. See “Box 

Specification Dialog” on page 440.

Move

Rotate

Resize

Extend
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Using the Edit Toolbar
A selected closed polyline-based object can 
be edited in a variety of ways using the 
buttons on the edit toolbar.  

The following toolbar buttons may display 
on the edit toolbar for a selected closed 
polyline-based object:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 86.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 29. 

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 

elsewhere. See “Copying and Pasting 
Objects” on page 81.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 83.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 111.

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 107.

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 105.

Editing Spline Based Objects
A Spline is a curve that passes smoothly 
through a set of points, or vertices. Splines 
are typically used in situations where an 
irregular, free-flowing curve is needed.

Objects are considered spline-based when 
they can be edited similar to CAD splines 
using their edit handles. See “Splines” on 
page 433. 

Sprinkler lines, spline terrain curbs, spline 
terrain walls and both round and kidney-
shaped terrain features are spline-based 
objects. See “Terrain” on page 289.

Using the Edit Handles
When a spline is selected, several different 
types of handles display. 
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Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move
• Click and drag the Move handle to move 

the object. 
• Movement may be limited or stopped by 

other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 106.

Rotate
• Click and drag the Rotate edit handle to 

rotate the entire spline. 

Reshape
• The Reshape edit handles display along 

the spline at each vertex. Click and drag a 
Reshape edit handle to change the length, 
angle and curve of adjacent segments 
without affecting other reshape handles. 

Resize
• The Resize edit handles display along the 

spline, between each vertex. Click and 
drag a Resize edit handle to move the 
adjacent vertices and lengthen or shorten 
adjacent segments.

Using the 
Specification Dialog

Spline-based objects can be edited 
using their specification dialogs. See 

“Polyline Specification Dialog” on page 438.

Using the Edit Toolbar
A selected spline-based object can be edited 
in a variety of ways using the buttons on the 
edit toolbar.  

The following toolbar buttons may display 
on the edit toolbar for a selected spline-based 
object:

Move

Rotate

Vertex

Resize

Reshape
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• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 86.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Polyline 
Specification Dialog” on page 438.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 
elsewhere. See “Copying and Pasting 
Objects” on page 81.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 83.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 111.

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 107.

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 105.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. See “Break Line” on 
page 109.

• Click the Record Walkthrough Along 
Path  edit button to record a walk-
through video of your model along the 
path defined by the selected polyline. See 
“Walkthroughs” on page 462. 

Editing Circles, Ovals and Ellipses
Objects created using the Circle, Oval and 
Ellipse Tools are unusual in that no 
architectural objects share their 
functionalities.

Using the Edit Handles
When selected, circles, ovals and ellipses 
display eleven edit handles. 

Unlike Ovals  and Ellipses , a 

Circle  cannot be edited into any other 
shapes; it can only be a circle

Any action performed using the edit handles 
can be cancelled by pressing the Esc key or 
any two mouse buttons at the same time.

Move

Concentric 
Resize

Rotate

Reshape
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Move
• Click and drag the Move handle to move 

the object. 
• Movement may be limited or stopped by 

other objects or Snap Behaviors. Move 
restrictions can be overridden by holding 
down the Ctrl key while dragging. See 
“Unrestricted Movement” on page 106.

Rotate
• Click and drag the Rotate handle of an 

oval or ellipse to change its orientation.

Reshape
• The eight edit handles beyond the perim-

eter are Reshape edit handles. Move them 
in or out to resize and reshape an oval or 
ellipse.

• Unlike ovals and ellipses, circles cannot 
be reshaped.  When a Reshape handle is 
dragged on a circle, it is only resized.

Concentric Resize
• The Concentric Resize edit handle dis-

plays on the perimeter of a circle between 
a corner Reshape handle and the center.  
Click and drag this handle to resize the 
circle without moving its center point. 

Using Dimensions
Dimensions can be used to move or 
resize circle-based objects. See 

“Moving Objects Using Dimensions” on 
page 414.

Using the 
Specification Dialog

Circles, ovals and ellipses can be 
edited using their specification 

dialogs. See “CAD Circle/Oval/Ellipse 
Specification Dialog” on page 437.
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Using the Edit Toolbar
A selected circle, oval or ellipse can be 
edited in a variety of ways using the buttons 
on the edit toolbar.  

The following toolbar buttons may display 
on the edit toolbar for a selected circle, oval 
or ellipse:

• Click the Select Next Object  edit 
button to select nearby objects instead of 
the selected object. See “Selecting 
Objects” on page 86.

• Click the Open Object  edit button to 
open the specification dialog for the 
selected object(s). See “Specification 
Dialogs” on page 29.

• Click the Copy/Paste  edit button to 
copy the selected object(s) to the Win-
dows Clipboard so they can be pasted 

elsewhere. See “Copying and Pasting 
Objects” on page 81.

• Click the Copy and Paste in Place  
edit button to create a copy of the 
selected object(s) at the same location as 
the original. See “Copy and Paste in 
Place” on page 83.

• Click the Delete  edit button to delete 
the selected object(s). See “Deleting 
Objects” on page 111.

• Click the Center Object  edit button 
to center an object along along a wall 
within a room or relative to a cabinet 
fixture. See “Using Center Object” on 
page 107.

• Click the Move to Front of Group  
edit button to display the selected object 
in front of other objects in the same 
drawing group. See “Move to Front of 
Group” on page 105.

Displaying Objects
The display of objects in 2D and 3D views 
can be controlled by layer. See “Displaying 
Objects” on page 74.

Line and Fill Styles
Line style and color can be controlled by 
layer or overridden in the specification 
dialogs for many objects. See “Line Style 
Panel” on page 434. 

In addition, some objects have a fill style that 
can be specified in the objects’ specification 
dialogs. See “Fill Style Panel” on page 439.

Color On/Off
The display of color on-screen can be 
toggled on and off in any view by 

selecting View> Color. 

• If Color  is toggled off in any 3D 
view, the view will be displayed in gray-
scale. 

• If Color  is toggled off in floor plan 
view, the view will be displayed in black 
and white. 

You can also print in color or gray scale. See 
“Print View Dialog” on page 483.
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Drawing Groups
Each object in a plan file belongs to one of 
three drawing groups, which influences 
whether it displays in front of or behind other 
objects. 
• The Default Group is where most 

objects are placed when first created. 
• Objects on the Back Group display 

behind those in the other two drawing 
groups.

• Objects on the Front Group display in 
front of those in the other two drawing 
groups. 

Most objects are drawn in the Default Group. 
Notable exceptions are imported pictures, 
which are placed in the Back Group, and 
Walkthrough Paths, which are placed in the 
Front Group. Objects in the Default Group 
display in front or behind one another 
according to program-defined rules that can 
be modified in only limited ways.

Move to Front of Group
Click the Move to Front of Group 
edit button to move the selected 

object(s) so that it displays in front of other 
objects in the same drawing group.

Move to Front of Group  only affects 
the display of objects when they are of the 
same type: for example, CAD objects, 
furnishings, base cabinets, or wall cabinets. 
It cannot make a base cabinet display in front 
of a wall cabinet; but it can make a selected 
wall cabinet display in front of other wall 
cabinets. 

Move to Front of Group  is not available 
for Walkthrough Paths.  

Textures
The appearance of architectural objects in 3D 
views is affected by the materials applied to 
the objects’ surfaces. See “Materials” on 
page 361. 

In 3D views, you can turn on or off the 
display of textures by selecting 3D> Toggle 
Textures . 

Delete Surface
In any 3D view, select 3D> Delete 
Surface, then click a surface in the 

view to temporarily remove the surface from 
the current view. See “Delete 3D Surface” on 
page 387.

Refresh Display
Refresh Display redraws the current 
window to clean up extra lines, show missing 
items, and correct random on-screen effects 
caused by changes to a model. Select View> 
Refresh Display or press the F5 key to 
refresh the on-screen display. 
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Moving Objects
Objects can be moved using the edit handles 
as well as a variety of edit tools. Multiple 
selected objects can also be moved as a 
group. See “Selecting Objects” on page 86.

Using the Edit Handles
Select an object, then click the Move edit 
handle and drag it to a new location. When 
your pointer is over the Move handle, it 
displays a four-headed arrow. 

When moved, the selected object moves 
orthogonal, or at a right angle to, any of its 
edges.

As an object is moved, it jumps at set 

increments when Grid Snaps  are 
enabled. See “Grid Snaps” on page 79.

If an selected object passes over its original 
location as it is being moved, it will snap to 
that location.

You can temporarily slow the movement of 
your mouse as you drag an edit handle by  
holding down the Shift key on your 
keyboard.

Bumping/Pushing
When an object bumps into another similar 
object while it is being moved, it stops. If 
you do not release the mouse button and 

continue to drag, however, the selected 
object resumes movement and continues past 
the obstructing object. 

Instead of dragging through and past an one 
or more obstructing objects, you can instead 
push them. To do this, bump an object into an 
obstructing object and release the mouse 
button. Then, click and drag the Move edit 
handle a second time in the same direction. 

Walls, wall openings, cabinets, furnishings 
and fixtures, and CAD and CAD-based 
objects are examples of objects that can 
bump into as well as push other objects. 

Bumping/Pushing does not affect objects 
moved using dimensions. See “Moving 
Objects Using Dimensions” on page 414. 

Unrestricted Movement
Many objects have restrictions placed on 
their movement by their own properties or 
specification settings. Architectural objects, 
for example, bump into other 3D objects as 
they are being moved. 

Other move restrictions are activated by the 
Snap Settings. See “Snap Behaviors” on 
page 78.

These restrictions can be overridden when 
necessary by holding down the Ctrl key 
while dragging to move an object.

To move an object freely 

1. Select the object. 
2. Hold down the Ctrl key.
3. Click  the Move edit handle and drag it 

to the new location.
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You can also press the Ctrl key while 
dragging an object’s Move handle to override 
move restrictions. 

Center Object
The Center Object edit button allows 
you to move walls, cabinets and other 

objects so that they are centered along a wall 

within a room or relative to a window or 
cabinet. 

Using Dimensions
Objects or the selected edges of some 
objects can be moved using 

dimensions. See “Moving Objects Using 
Dimensions” on page 414.

Aligning Objects
It is often important to align objects such as 
text boxes or walls, or to align objects on 
different floors. There are several methods to 
choose from. 

Using the Mouse 
Cross Hairs

Objects can be aligned by eye using the 
mouse cross hairs as a reference. This 
method can help you draw, place and edit 
objects quickly and with reasonable 
accuracy, but is not necessarily as accurate as 
some of the other approaches described here.

The mouse cross hairs can be turned on and 
off in the Preferences dialog. See “Edit 
Panel” on page 63.

Using Snap Settings
With Object Snaps, you can snap the edge 
of a selected object to that of another. Select 
an edge of an object. Drag it to the edge of 
another object, then release the mouse.

With Grid Snaps  on and Angle 
Snaps  off, select the left side of the 
object, and drag from the center move 

handle. This snaps the selected side to the 
grid.

When both Grid Snaps  and Angle 
Snaps  on, objects snap at increments 
equal to the Snap unit specified in the Plan 
Defaults dialog rather than onto the grid 
itself. This does not align objects to the grid 
unless they were already snapped to the grid. 
See “Snap Behaviors” on page 78. 

Using Dimensions
Create a temporary or manual 
dimension relative to an object such as 

a wall or line, and relocate the objects to the 
same dimension. See “Moving Objects 
Using Dimensions” on page 414. 

Using Center Object
The Center Object edit button can be 
used to center a variety of objects 

relative to another object. Center Object can 
be used in floor plan and elevation views.

Text objects can be aligned using set-
tings in the Text Specification dialog.

See “Aligning Text” on page 425.
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To center an object 

1. Select an object.

2. Click the Center Object  edit button.
3. Move the mouse pointer over the object 

you would like to center the selected 
object relative to.

•  As the pointer passes over an eligible 
object, it becomes highlighted and a 
dashed centering axis line displays.

4. When the desired centering axis dis-
plays, click once to center the selected 
object along that axis line.

To center an object in a room

1. Select an object such a cabinet.

2. Click the Center Object  edit button.
3. Move the mouse pointer in the room that 

you would like to center the selected 
object relative to.

•  As you move the pointer, a centering 
axis will display along the wall it is 
closest to.

•  The selected object does not have to be 
inside a room in order to be centered 
relative to that room.

4. When a centering axis displays along the 
correct wall, click once. 

5. The object is moved perpendicular to the 
centering axis. 

If you click outside an exterior wall instead 
of clicking inside, the selected object is 
centered along the edge of the Exterior 
Room. See “The Exterior Room” on page 
145. 

Aligning Objects on 
Different Floors

Objects on different floors can be aligned 
with one another using the Reference 
Display . See “The Reference Floor” on 
page 205.

Resizing Objects
Objects can be resized using the edit handles 
and specification dialogs. 

Using the Edit Handles
The end, corner and/or side edit handles can 
be used to resize a selected object. 

To override any movement restrictions 
caused by snap settings or the presence of 
other objects, press the Ctrl key while 
dragging an edit handle.

As an object is resized, any dimensions 
indicating its size will update to reflect yoru 
changes. You can use dimensions as 
references to help you achieve the correct 
size for most objects. 

You can temporarily slow the movement of 
your mouse as you drag an edit handle by  
holding down the Shift key on your 
keyboard.
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Using the 
Specification Dialog

Most objects can be accurately resized 
in their specification dialogs. See 

“Specification Dialogs” on page 29. 

Using Dimensions
Many objects can be resized by 
selecting an edge and then moving 

that edge using dimensions. See “Moving 
Objects Using Dimensions” on page 414.

Walls can also be resized using dimensions; 
however, it is important to understand that 
the selected edges of other objects cannot be 
resized using dimensions - they can only be 
moved. To resize an edge, select an adjacent 
edge and move that edge instead.

Reshaping Objects
There is a variety of ways to reshape objects 
using the edit handles, specification dialogs 
and edit toolbar buttons.

Some objects, notably circles and box-based 
objects, cannot be reshaped - only resized. 
See “Resizing Objects” on page 108.

Using the Edit Handles
Depending on the type of object selected, the 
end, corner and/or side edit handles can be 
used to reshape a selected object. 

To override any movement restrictions 
caused by snap settings or the presence of 
other objects, press the Ctrl key while 
dragging an edit handle.

You can temporarily slow the movement of 
your mouse as you drag an edit handle by  
holding down the Shift key on your 
keyboard.

Using the 
Specification Dialog

A variety of CAD and CAD-based 
objects can be reshaped by editing 

values on either the Selected Line or Selected 
Arc panel of their specification dialogs. See 
“Polyline Specification Dialog” on page 438.

Using Dimensions
Both temporary and manually drawn 
dimensions can be used to increase or 

decrease the distance between the edge a 
line- or polyline-based object and another, 
parallel edge or line. 

Break Line
The Break Line edit button can be 
used to break an individual line-, arc-, 

or spline-based object into two segments. 
The edges of a polyline-based object can also 
be broken.

The Break Line  edit tool can be used to 
create two types of breaks: partial breaks and 
complete breaks.

Note: The Break Line edit button is not avail-
able for box-based objects, objects created
with the Circle Tools, or some architectural
objects such as stairs.
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When a partial break is created, a new corner 
edit handle is placed at the location of the 
break. Partial breaks are also referred to as 
joints, nodes or pivot points.

• Click the Break Line  edit button to 
add a new corner or pivot point to the 
selected object. 

To create a partial break

1. Click the object or edge that you want to 
break into two segments.

2. Click the Break Line  edit button 
once or press the 3 key. 

3. Click the edge to create a new corner 
edit handle at that location and two sepa-
rate edges on either side of that handle. 

If you click and drag one of the edit handles 
on either side of the partial break, the edge 
moves at a right angle to itself and another 
edge forms, connecting the moved edge with 
the one on the other side that does not move.

You can remove an edge from a polyline-
based object by clicking and dragging a 
corner handle until it snaps to an adjacent 
corner handle.

To remove a break from an edge

1. Make sure that Object Snaps are 
enabled. See “Object Snaps” on page 78.

2. Select the object that has a break that 
you want to remove.

3. Click on the corner edit handle 
associated with the break that you want 
to remove and drag it to an adjacent 
corner handle.

4. Release the mouse button and the handle 
that you selected will be removed.

Change Line/Arc
Select an individual line-based or arc-
based object or a segment of a 

polyline-based object and click the Change 
Line/Arc edit button to convert the selected 
segement from a line to an arc or vice versa.

Rotating Objects
Objects can be rotated using the edit handles 
as well as a variety of edit tools. Multiple 
selected objects can also be rotated as a 
group. See “Selecting Objects” on page 86. 

By default, an object or group of objects  
rotate about the center point of the selection 
set. 

Using the Edit Handles
Select an object, then click the triangular 
Rotate edit handle and drag it in any 
direction. When your pointer is over the 
Rotate handle, it displays a curved arrow.

The angles of line-based objects can also be 
changed by dragging an end handle in a 
direction other than parallel to the object. 
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The object rotates about the opposite end 
point. See “Editing Line Based Objects” on 
page 88.

Objects snap to Allowed Angles as they are 
rotated. See “Angle Snaps” on page 79. 

To override any movement restrictions 
caused by snap settings or the presence of 
other objects, press the Ctrl key while 
dragging an edit handle.

You can temporarily slow the movement of 
your mouse as you drag an edit handle by  
holding down the Shift key on your 
keyboard.

Using the 
Specification Dialog

The exact angle of some objects such 
as lines, arcs, walls and the selected 

edges of polylines can be specified on either 
the General panel, Selected Line panel, or 
Selected Arc panel of that object’s 
specification dialog. See “Polyline 
Specification Dialog” on page 438.

Reverse Plan
The Reverse Plan tool is a quick way 
to mirror a plan so that everything on 

all floors of the entire plan is swapped left to 
right. 

Select Tools> Reverse Plan  to reflect an 
entire plan right to left, as though it were 
reflected about a vertical line. 

Deleting Objects
Objects can be deleted in a variety of ways: 
• Select an object or group of objects, then 

click the Delete  edit button, select 

Edit> Delete  from the menu, or press 
the either the Delete or Backspace key on 
your keyboard. 

• Entire categories of objects can be 
deleted using the Delete Objects dialog.

• Objects are deleted if the floor they are 
placed on is deleted. See “Deleting 
Floors” on page 202.

If an object has a line with arrow attached to 
it, the arrow is deleted if the object is deleted. 
To prevent the arrow from being deleted, 
drag the attached end away from the object 
before deleting it. 

Delete Objects Dialog
Use the Delete Objects dialog to 
delete all objects of one or more 

specified types in one room, on the current 
floor, or in the entire plan. 
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Select a Delete Scope: 

• Choose Single Room to delete objects 
only in specific rooms on the current 
floor.

• Choose All Rooms on This Floor to 
delete objects in all rooms on the current 
floor.

Specify categories of Objects to Delete 
by checking the box beside each 

category that you wish to delete.

To use the Delete Objects dialog

1. Select Edit> Delete Objects  to open 
the Delete Objects dialog.

2. Specify the Delete Scope as Single 
Room or All Rooms On This Floor. 

3. In the Delete section, check the box for 
each category of objects you want to 
delete. Click Select All to check all the 
boxes or Clear All to uncheck all boxes.

4. When the scope is set to Single Room:
•  Move your cursor into the drawing area 

and click in a room of the plan to delete 
objects of the selected type within that 
room without closing the dialog. 

•  Continue clicking on rooms or choose a 
different Delete Scope.

•  Click Done when all selections have 
been deleted.

5. If you select All Rooms On This Floor, 
you do not need to click in floor plan 
view. The Delete button becomes avail-
able, and clicking it closes the dialog 
and deletes the specified objects. 

Deleting Polyline Edges
To remove an edge from a polyline, drag a 
corner handle until it overlaps an adjacent 
corner handle to remove the edge between 
them and merge them into a single handle. 
See “Reshaping Objects” on page 109.

Delete Surface
In any 3D view, select 3D> Delete 
Surface, then click a surface in the 

view to temporarily remove the surface from 
the current view without permanently 
affecting the object. See “Delete 3D Surface” 
on page 387.

1

2
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Undo and Redo
The Undo and Redo commands 
allow you to both undo the last 

action performed, as well as redo actions that 
were recently Undone. 

The ten most recent actions can be Undone 
or Redone. Actions that can be Undone and 
Redone include creating, editing, and 
deleting objects. 

To Undo an action, select Edit> Undo , 

click the Undo  button, or press Ctrl + Z 
on your keyboard.

The Redo command is only available 
immediately after Undo has been used. To 
Redo an Undone action, select Edit> 
Redo , click the Redo  button or press 
Ctrl + Y on your keyboard. 

It is important to note that Undo  and 

Redo  do not affect all actions in the 
program, including:
• Save and Save As. See “Saving, Export-

ing, and Backing Up Files” on page 41. 
• Changes made in the Library Browser. 

See “The Library Browser” on page 342. 
• Changes made in a Materials List. See 

“Materials Lists” on page 491. 
• Changes made in a dialog while the dia-

log box is open. See “Dialogs” on page 
27.

• Changes made to the display by panning 
the display or zooming in or out. See 
“Undo Zoom” on page 375.
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Chapter 8:

Walls, Railings, and
Fencing

Walls are the single most important building 
component in Home Designer Suite. By 
creating walls and defining the rooms created 
by the walls, you are telling the program how 
you want the 3D model built.

There are several ways that walls can be 
created in Home Designer Suite. The most 
common is to simply draw them with the 
Wall Tools. 

In addition, exterior walls can be generated 
automatically when a new floor is built by 
using another floor as a model. For more, see 
“Adding Floors” on page 201.

Another feature that can be used to generate 
walls automatically is the Space Planning 
Assistant. See “Space Planning” on page 
443.

Chapter Contents
•      Wall Defaults
•      Wall Tools
•      Railing and Deck Tools
•      Fencing Tools
•      Exterior and Interior Walls
•      Foundation Walls
•      Railing and Deck Tools
•      Room Dividers and Invisible Walls
•      Polygon Shaped Decks
•      Hatch Wall
•      Break Wall
•      Drawing Walls
•      Connecting Walls
•      Displaying Walls
•      Measuring Walls
•      Editing Walls
•      Aligning Walls
•      Roof Directives in Walls
•      Attic Walls
•      Wall Type Definitions
•      Wall Specification Dialog
•      Railing and Fencing Specification Dialogs
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•      Wall Hatch Specification Dialog

Wall Defaults
Default Settings can be accessed by 
selecting Edit> Default Settings. 

Click on “Walls” and click the Edit button to 
open the Wall Defaults dialog. 

The settings in the wall defaults dialog 
determines what wall types are drawn when 
the different wall tools are used. It is a good 
idea to be familiar with these settings and 
how they relate to your style of building.

Exterior/Interior Wall Defaults Dialog
Specify which wall types are drawn using the 

Exterior  and Interior Wall  tools in 
the Exterior/Interior Wall Defaults dialog.

Exterior Wall Tool - From the drop-
down list, select the wall type drawn 

with the Exterior Wall  tool.  

Interior Wall Tool - From the drop-
down list, select the wall type drawn by 

the Interior Wall  tool. 

Wall Tools
Select Build> Wall  to access the Wall Tools. 
The type of wall drawn by each wall tool is 
specified in its corresponding defaults 
dialog. 

The Curved Wall tools are similar to their 
corresponding Straight Wall Tools. Select 
Build> Curved Wall  to access these tools. 

1

2
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Exterior Walls
The Exterior Wall and Curved 
Exterior Wall tools draw walls 

using the default wall type specified for 
exterior walls in the Exterior/Interior Wall 
Defaults dialog. See “Exterior and Interior 
Walls” on page 119.

Interior Walls
The Interior Wall and Curved 
Interior Wall tools draw walls 

using the wall type specified for interior 
walls. The interior wall type is defined in the 
Exterior/Interior Wall Defaults Defaults 
dialog. 

Half-Walls
The Half-Wall and Curved 
Half-Wall tools create solid 

railings: walls that are 36” (900 mm) high 
topped with a handrail.

Room Dividers
Room Dividers are Invisible walls 
with a thickness of 0” (mm) that are 

used to define separate room areas in a plan. 
They can display in floor plan view but not in 
3D views. See “Room Dividers and Invisible 
Walls” on page 120.

Hatch Wall
The Hatch Wall tool applies a hatch 
pattern to a wall that displays in floor 

plan views. You must click the wall that you 
want to apply the hatch pattern to. You can 
then select the hatch and resize it if you want 
to only hatch a portion of a wall. See “Hatch 
Wall” on page 121.

Break Wall
The Break Wall tool applies a break 
in a wall. Once a wall is broken, the 

two wall segments are separate walls that can 
be modified independent of each other. See 
“Break Wall” on page 122.

Railing and Deck Tools
Select Build> Railing and Deck to 
access the Railing and Deck Tools. 

Railings are typically used to define interior 
spaces, while the various Deck tools are used 
to define exterior Deck rooms. 

With the exception of the Polygon Shaped 
Deck tool, each of the tools in this family 
have both Straight and Curved versions, and 

are created and edited just like walls. See 
“Drawing Walls” on page 122.

To create a break in a railing for a stairway or 

other access, use a Doorway  . This keeps 
the railing continuous and maintains room 
definition. See “Room Definition” on page 
144.  

Note: Whether a wall is recognized as an
exterior or interior wall by the program is
determined by its position in the model, not
by the tool used to draw it. See “Exterior and
Interior Walls” on page 119.
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When first drawn, railings are specified as 
No Locate, which prevents Auto Exterior 
Dimensions  from locating them. This 
attribute may also be helpful if you do not 
want a railing to divide an area into two 
separate rooms. See “General Panel” on page 
135.

Railings
The Railing and Curved Railing 
tools create railings that are 

primarily used to define interior spaces.

Railings are ideal for a number of tasks:
• Creating changes in floor and/or ceiling 

height. See “Floor and Ceiling Heights” 
on page 151.

• Creating stairwells. See “Creating a Stair-
well” on page 245.

Deck Railing
The Straight Deck Railing and 
Curved Deck Railing tools draw 

decks, complete with framing and bounded 
by a railing. If a foundation level exists, 
supports for the deck are also created. See 
“Decks” on page 151.

When a room is defined using deck railing, 
its Room Type is automatically set to 
“Deck”. See “Decks” on page 151.

Deck Edges
The Straight Deck Edge and 
Curved Deck Edge draw decks 

complete with framing, but without a railing. 
No deck supports are created. 

Polygon Shaped Deck
The Polygon Shaped Deck tool 
opens the New Polygon Shaped 

Deck dialog, where you can specify the exact 
size and number of sides of a new polygonal 
deck room and then click in floor plan view 
to create that deck room. See “Polygon 
Shaped Decks” on page 121.

Railing Types
A variety of railing types can be specified in 
the Railing and Deck Railing Specification 
dialogs. See “Rail Style Panel” on page 138. 
Available types include:
• Baluster creates railings composed of 

newel posts, balusters, a railing, and an 
optional bottom rail. 

• Solid produces a framed railing wall, or 
Half Wall. See “Half-Walls” on page 117. 

Deck Railings

Deck Edges
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• If Panels is selected, you can choose a 
panel style such as glass or ironwork from 
the library. See “Newels/Balusters Panel” 
on page 140.

Newels and balusters do not display in floor 
plan view.

Fencing Tools
Select Build> Fencing or click the 
Fencing Tools to access the fencing 

tools. Fencing automatically follows the 
shape of the terrain.

The Fencing and Curved 
Fencing tools are used to draw 

fences, which are similar to railings but by 
default do not define room areas. Fencing is 
created and edited much like walls and 
railings, and normally used outside of a 
building and follows the shape of the terrain.  
See “Terrain” on page 289.

You can specify a fence panel style in the 
Fencing Specification dialog. See “Railing 
and Fencing Specification Dialogs” on page 
138.

Exterior and Interior Walls
Most walls are drawn using either 
the Straight Exterior Wall and 

Straight Interior Wall tools. 

Exterior and interior walls can 
also be drawn using the Curved 

Exterior Wall  and Curved Interior Wall  
tools. 

The only difference between the Exterior and 
Interior Wall Tools is the wall type used: 
Exterior Walls use a wall type set up to 
model a wall with siding, while Interior 
Walls model interior walls with sheetrock. 
You can specify the default wall type for 
each tool in the Exterior/Interior Wall 
Defaults dialog. See “Exterior/Interior Wall 
Defaults Dialog” on page 116.

To draw a wall using a different wall type, 
you can change the default wall type for 
either tool in the Exterior/Interior Wall 
Defaults dialog. You can also draw a wall 
using the default type and then change the 
wall type in the Wall Specification dialog.

Whether a wall is recognized by the program 
as an actual exterior or interior wall is based 
on the model, not by which tool you use to 
draw the wall. Any wall that is entirely 
surrounded by interior room areas is 
considered an interior wall. Any wall 
exposed to the outside of the building is 
considered an exterior wall. See “Room 
Types” on page 147. 
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Foundation Walls
Foundation walls are similar to the interior 
and exterior walls but also have a footing. 
Foundation walls are created automatically 
when a foundation floor is created. See 
“Building a Foundation” on page 208. 

Room Dividers and Invisible Walls
The Room Divider tool is used to 
define separate room areas in a plan; 

typically, by dividing a large room area into 
two or more smaller areas. See “Room 
Definition” on page 144.

Common uses for Room Dividers  
include dividing areas of an open floor plan 
into areas with different purposes. 

Room Dividers can also be used to define 
areas with different floor or ceiling materials 
or heights. 

Room Dividers  are simply walls that are 
specified as Invisible and have a single layer 
of an “Air Gap” material with a thickness of 
0” (mm). 

If a zero-thickness Room Divider  
separates two rooms with different floor and/
or ceiling heights, its wall type will be 
changed to the current plan’s default Interior 
Wall so that the platform step created by the 
height difference can be enclosed. 

Any wall, regardless of its wall type or 
thickness, can also be specified as Invisible - 
or vie versa - in the Wall Specification 
dialog. See “General Panel” on page 135.

Room Dividers are placed on the “Walls, 
Invisible” layer by default, as are walls that 
are specified as Invisible.  

Walls specified as Invisible can display in 
floor plan view but not in 3D views or the 
Materials List. See “Displaying Walls” on 
page 125.

Room Dividers separate this dining area 
from adjacent rooms 
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Important Notes on 
Invisible Walls

• Floor, wall and ceiling areas are calcu-
lated separately for rooms divided by 
invisible and normal walls.

• Invisible walls are ignored by the Auto 
Place Outlets  tool; it functions as 
though they were not present. 

• Cabinets, fixtures and furniture can be 
moved freely through Invisible walls. 

• Invisible walls can be drawn through a 
cabinet to attach to the wall behind.

• Room Dividers are automatically gener-
ated to connect “island” rooms to the 
larger structure around them. See “Room 
Definition” on page 144.

Polygon Shaped Decks
Select Build> Railing and Deck> 
Polygon Shaped Deck to open the 

New Polygon Shaped Deck dialog and 
create a polygon shaped deck with regular 
sides.

The settings in this dialog are saved between 
program sessions. 

To create a polygon shaped deck

1. Click the radio button beside an option 
to specify whether you want to Define 
Polygon by Side Length, Radius to 
Corner or Radius to Side.

2. Specify the desired Number of Sides.
3. Specify the desired Side Length or,
4. Specify the desired Radius.
5. Uncheck Include Railing to produce a 

deck platform defined by Deck Edges. 
This option is not available in the New 
Polygon Shaped Room dialog.

6. Click OK, then click once in floor plan 
view to create the specified polygon 
shaped deck.

Hatch Wall
The Hatch Wall tool can be used to 
fill wall segments with a single hatch 

pattern in floor plan view.  

To apply wall hatching, select Build> Wall> 
Hatch Wall , then click on a wall. The 
hatch pattern covers the entire length and 
width of the wall segment.
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Hatch Wall  places a hatch pattern across 
all layers of the selected wall, covering any 
fill styles specified for that wall type.

Once created, wall hatching can be selected, 
edited and deleted much like other line-based 
objects. See “Editing Line Based Objects” on 
page 88.

If you use the Hatch Wall  tool to apply a 
hatch pattern to a wall that has been divided 
into multiple segments using the Break 

Wall  tool, the pattern is only applied to 
the segment that you clicked on . See “Break 
Wall” on page 122.

Like doors and windows, wall hatching 
cannot extend across multiple wall segments. 
Unlike these objects, hatching cannot be 
located by dimension lines.

The wall hatch pattern can be specified in the 
Wall Hatch Specification dialog. See “Wall 
Hatch Specification Dialog” on page 141. 

When editing or deleting wall hatching, 
make sure that it is selected rather than the 
wall by noting that “Wall Hatching” displays 
in the Status Bar. See “The Status Bar” on 
page 30. 

Break Wall
To divide a wall or railing, select  Build> 
Wall> Break Wall and click on the wall. 
The wall is divided into two wall sections at 
the point where you click. 

The Break Wall  tool remains 
active, so you can continue to place 

breaks in walls. When you are finished, 
select a different tool.

If a wall break is placed near the intersection 
of two walls, the break is positioned at the 
center of the intersection. 

Once a break is placed, click the Select 
Objects  tool and select the original wall. 
If edit handles display near the break, the 
wall was correctly broken.

Walls separated by a break can be rejoined. 
Select one of the segments, then click on the 
end edit handle located at the break and drag 
it a few plan inches (mm) away from the 
break. See “Connecting Walls” on page 124.

The Break Wall  tool can be used to 
create aligned walls on either side of a gap. 
See “Creating a Nook” on page 130.

Drawing Walls
Walls, railings, and fencing are drawn similar 
to the way CAD lines are drawn: select a 
Wall Tool and then click and drag from end 

to end in the drawing area. Walls can be 
drawn in floor plan view, camera views, and 
overviews. See “Draw Lines” on page 431.

Note: The Hatch Wall tool cannot be used to
apply a hatch pattern to Invisible Walls. See
“Room Dividers and Invisible Walls” on page
120.
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Drawing walls to create a floor plan is simple 
if you keep a few things in mind: 
• Draw exterior walls first to define the 

building’s footprint, then draw the interior 
walls after the perimeter is in place. 

• It is easiest to draw walls at the approxi-
mate location and length needed and then 
move or resize them precisely using 
dimensions later. See “Moving Objects 
Using Dimensions” on page 414. 

• When drawing and positioning exterior 

walls, make sure Grid Snaps  are 
enabled. Once these walls are in place, 
you may prefer to turn Grid Snaps off to 
draw and position interior walls and other 
objects. See “Grid Snaps” on page 79. 

• As walls are drawn, “sticky” points iden-
tify points that are either collinear or 
orthogonal to the end points of other 
walls, making alignment easier. See 
“Extension Snaps” on page 79. 

• When walls enclose an area to form a 
room, the program will orient all exterior 
walls so that the siding material faces out-
ward. 

• To flip the layers of a wall after it is 
drawn, select it and click the Reverse 
Layers  edit button. See “Editing 
Walls” on page 127.

• Initial wall heights are determined by the 
default floor and ceiling heights of the 
current floor.

Wall Positioning
The recommended method of drawing walls 
is to draw them at their approximate location 
and length, then move them into position 

with accuracy using dimensions. To make 
this task quick and efficient: 
• Notice the temporary wall that displays as 

you draw. Its length and angle display in 
the Status Bar at the bottom of the win-
dow and adjust as you move the mouse. 
Release the mouse button to draw the wall 
at the displayed length and angle. See 
“The Status Bar” on page 30. 

• Use Snaps to help ensure proper wall 
alignment and orientation. See “Snap 
Behaviors” on page 78. 

Once walls are drawn, they can be accurately 
dimensioned and moved as needed. See 
“Measuring Walls” on page 126. 

Wall Openings
To create a door or doorway, do not draw 
wall sections with a gap between them. Walls 
should be drawn to completely enclose 
rooms, and then door and window objects 
should be placed in the walls to create 
openings later. See “Doors” on page 161 and 
“Windows” on page 177. 

Masonry fireplaces placed in walls are also 
considered to be wall openings. See 
“Fireplaces” on page 213.

Temporary Dimensions
Temporary dimensions will display along the 
length of a wall as it is drawn, helping you 
draw walls to the desired length. Although 
dimensions display as you are drawing, you 
do not need to position walls precisely when 
you first draw them: they can be easily 
moved into place at any time. See “Editing 
Walls” on page 127. 
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Drawing Curved Walls
Drawing a curved wall, curved railing, or 
curved fence is similar to drawing a CAD 
arc. See “Draw Arc” on page 432.

A straight wall can also be converted into a 
curved wall and vice versa using the Change 
Line/Arc  edit button. See “Change Line/
Arc” on page 110.

Space Planning Assistant
The Space Planning Assistant Tools 
allow you to place and arrange room  

boxes that can then be converted into a fully 
editable house plan, including walls. See 
“Space Planning” on page 443.

Connecting Walls
When walls are drawn sufficiently close to 
one another, they will snap together to form 
an intersection. This snapping occurs when 
the walls’ center lines are within a distance 
defined by the larger of the two walls’ widths 
and will occur even when Object Snaps are 
turned off. See “Object Snaps” on page 78.

If the two walls in question have identical 
specifications and are collinear, they will 
merge to become a single wall. See 
“Aligning Collinear Walls” on page 130.  

When three or more walls connect to form a 
completely enclosed area, that area defines a 
room. See “Rooms” on page 143.

When walls snap together to form an 
intersection and Object Snaps are enabled, 
the program joins them at theirMain Layers. 
See “Aligning Walls” on page 130. 
• The wall that is being drawn or edited will 

move, lengthen, or shorten slightly to 
meet the other wall. 

• The other wall will not move; however, 
its length may be affected. 

Removing Wall Breaks

The Break Wall  tool allows you to break 
a wall into two or more separate wall 
segments. See “Break Wall” on page 122.

To merge two collinear walls separated by a 
break,select one of the segments, then click 
on the end edit handle located at the break 
and drag it a few plan inches (mm) away 
from the break. 

If the two walls do not merge, either one or 
both walls have been moved and they are no 
longer collinear, or one or both has been 
edited in some way and they are no longer 
identical. Open the Wall Specification 
dialog for each wall and determine how they 
differ. See “Wall Hatch Specification 
Dialog” on page 141.

To create a room in the shape of a cir-
cle, you must draw two curved walls.
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Displaying Walls
The display of walls in all views is 
controlled in the Display Options 

dialog. See “Displaying Objects” on page 74.

If a “Walls” layer is turned off, any doors and 
windows placed in walls on that layer will 
not display, either. See “Displaying Doors” 
on page 164 and “Displaying Windows” on 
page 182.

In Floor Plan View
There are several options for controlling how 
walls are displayed in floor plan view. In the 
Display Options dialog, you can specify 
whether or not various types of walls display. 
Walls are placed on layers with “Walls” at 
the beginning of the layer name, such as 
“Walls, Normal”. 

It is sometimes helpful to display the walls 
from a floor other than the current floor. To 
do this, select and display a reference floor. 
See “The Reference Floor” on page 205. 

In 3D Views
As in floor plan view, the display of walls 
can be controlled by layer in the Display 
Options dialog. 

While most architectural objects in the 
program can display in both floor plan and 
3D views, a few cannot. Invisible walls and 
Wall Hatching are examples of objects that 
do not display in 3D.

Wall Materials
There are several ways that materials can be 
assigned to walls. See “Rooms” on page 143. 

When you draw a wall, it uses the. 

You can change the surface material of an 
individual wall in the Wall Specification 
dialog. If you select “Use Default” as the 
material and the wall is used to define a 
room, the program refers to the material 
specified in the Room Specification dialog. 
See “Wall Specification Dialog” on page 
134.

You can also change a room’s wall material 
in the Room Specification dialog. See 
“Materials Panel” on page 364. To restore the 
default Wall Type material, select Use 
Default in the Select Library Object dialog. 
See “Select Library Object Dialog” on page 
356. 

Note: In floor plan view, railings not specified
as Solid display their Main Layer regardless
of whether “Walls, Layers” or “Walls, Main
Layer Only” is turned on.  

Note: Wall materials that are specified on the
Materials panel of either the Wall or Room
Specification dialog are not calculated in the
Materials List.
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Measuring Walls
Accurate wall measurements are an essential 
aspect of any drawing, and can be achieved 
by following two basic rules:
• Be aware of what part of a wall assembly 

dimensions are locating;
• Position walls using dimensions rather 

than edit handles or edit tools.

These rules can easily be met when you keep 
the following recommendations in mind.

Use Dimension Defaults
Dimensions can be set to locate walls at their 
Main Layers or at surfaces. Before drawing 
dimensions - and particularly, before using 
them to move your walls into position - make 
sure that your Dimension Defaults are set up 
to meet your needs. See “Dimension 
Defaults Dialog” on page 405.

Edit Dimension Lines
Once a dimension line has been drawn, its 
extension lines can be edited to locate a 
number of locations on a wall assembly:
• The exterior surface
• The Main Layer’s exterior
• The center line of the wall assembly
• The Main Layer’s center line
• The Main Layer’s interior
• The interior surface

See “Editing Extension Lines” on page 413. 

Moving Walls Using 
Dimensions

By far, the most precise method of 
positioning walls is using dimension lines. 
To produce accurate measurements, 
remember to:
• Be aware of what part of your walls is 

being located by dimensions.
• Avoid specifying dimension values with 

greater accuracy than your dimensions are 
set to display. See “Format Panel” on 
page 407. 

See “Using Dimensions” on page 128.

Use Object, Angle and 
Grid Snaps

Object Snaps, Angle Snaps, and Grid Snaps 
make it easier to align walls when they are 
being drawn as well as when they are edited. 
See “Snap Behaviors” on page 78. 

Object Snaps help to ensure consistent wall 
connections and are particularly helpful 
when aligning collinear walls. 

When Grid Snaps are enabled, walls are 
drawn on a regularly spaced grid, which 
helps avoid inaccurate wall placement. This 
can become particularly important if you 
forego positioning walls using dimensions in 
favor of using edit handles to move them. 

Using Grid Snaps is recommended
when you are laying out exterior shell

walls, but may be inconvenient when posi-
tioning interior walls or other objects. 
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Angle Snaps make it easy to accurately draw 
walls at regular angles, ensuring walls that 
are truly parallel or perpendicular to one 
another and separated by consistent 
distances.

No Locate
If a wall is specified as No Locate in the 
Wall Specification dialog, it will be ignored 

by Auto Exterior Dimensions  in floor 
plan view, as will any doors or windows 
placed in it.  By default, Railings, Deck 
Railings, and Room Dividers are specified 

as No Locate. See “General Panel” on page 
135.

The No Locate setting also affects the 

behavior of Manual Dimensions  and 

End to End Dimensions . If a Manual or 
End to End Dimension is drawn between two 
No Locate walls, a dimension line will be 
created; however, if one of the walls is No 
Locate and one is not, no dimension line will 
be drawn. See “Dimensions” on page 405.

Once a dimension line has been created, it 
can be edited so that it locates a No Locate 
wall or railing that is perpendicular to it. See      
Editing Dimension Lines. 

Editing Walls
Walls can be selected individually and as a 
group in all views. When a wall is selected, it 
displays edit handles and an edit toolbar that 
can be used to edit it in various ways. When 
a wall is selected, temporary dimensions will 
also display.

The ways in which a wall can be edited 
depends on the current view and which edge 
is selected. See “Selecting Objects” on page 
86. 

Selecting Walls
• When you try to select a wall in a 3D 

view, the interior or exterior room that it 
defines may be selected first. Click the 
Select Next Object  edit button or 
press the Tab key on your keyboard to 
select the wall itself. 

• In floor plan view, if wall hatching has 
been applied to a wall using the Hatch 

Wall  tool, the hatching may be 
selected first. Click Select Next 
Object  to select the wall itself. See 
“Hatch Wall” on page 121.

Using the Edit Handles
A selected wall can be modified in a variety 
of ways using its edit handles in any view. 
The handles that are available will depend on 
the current view type.
• In floor plan view, straight and curved 

walls can be edited like other line- and 
arc-based objects. See “Editing Line 
Based Objects” on page 88 and “Editing 
Arc Based Objects” on page 90.

• In a camera view or overview, click on the 
top surface of a wall to display the same 
edit handles as in floor plan view, allow-
ing you to rotate, move, and extend or 
shorten the length of the wall. 
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• Moving a wall in any view will move any 
cabinets attached to that wall, as well.

• In an Elevation view, the side edges of 
straight walls can be moved to shorten or 
lengthen the segment. Curved walls can 
be shortened in this manner, but not 
lengthened.

• In a camera view or overview, click on an 
interior or exterior surface to display an 
edit handle at the center of each side edge, 
allowing you to shorten or lengthen the 
wall. Curved walls can be shortened in 
this manner, but not lengthened.

• When a wall is connected to other walls, it 
can only be moved perpendicular to itself 
or, in the case of curved walls, perpendic-
ular to its chord using the Move edit han-
dle. 

In the Specification Dialog
The appearance and structure of walls 
can be customized in the Wall 

Specification dialog. See “Wall 
Specification Dialog” on page 134.

The characteristics of the roof directly above 
a selected wall can also be specified in the 
Wall Specification dialog. See “Roof Panel” 
on page 136.

Using the Edit Tools
A selected wall or walls can be edited in a 
variety of ways using the buttons on the edit 
toolbar. See “The Edit Toolbar” on page 26.

Using Dimensions
Automatic, manually-drawn, and 
temporary dimension lines can be 

used to both resize and move walls with 
accuracy. Select a wall, then click on a 
dimension line that locates it and type in the 
value that you need. See “Moving Objects 
Using Dimensions” on page 414.

When a wall is resized using dimensions, the 
inline text field used to edit the dimension 
will have three unique buttons: Move Start, 
Move End, and Move Both Ends. Choose 
the option that you want to use before 
pressing the Enter key.

If both ends of the selected wall intersect 
walls that are not parallel to one another, a 
fourth option will be available: Move Along 
Rails . When this option is used, the 
selected wall both resizes and changes 
position so that it remains connected to the 
other walls when you press the Enter key.

Depending on your Dimension Defaults 
settings, dimension lines may locate wall 
surfaces or Main Layers. See “Dimension 
Defaults Dialog” on page 405.

Move Both Ends

Move Start       Move End

 Move Along Rails resizes 
and moves a selected wall.
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Wall Thickness
The initial thickness of a wall is determined 
by its wall type. 

You can specify a selected wall’s thickness in 
its Wall Specification dialog. See “General 
Panel” on page 135. 

If a selected wall’s thickness is changed: 
• A copy of the wall’s wall type is created 

with the same name but appended with a 
number equal to the thickness of the 
structural layer, and that new type is 
assigned to the wall.

• The change in thickness will be applied to 
new wall type’s structural layer. 

• The structural layer must be at least 1/16” 
thick, and the wall’s thickness cannot be 
less than the original wall type’s total 
thickness minus the thickness of its struc-
tural layer.  

If a wall type’s thickness is modified, the 
wall will resize about the outside edge of its 
Main Layer. In some instances, the wall may 
appear to move as a result of changes made 
to the thicknesses of its layers.

Wall Heights
The height of a wall is controlled by the 
ceiling height of the room(s) it defines. If the 
ceiling or floor height of a room is changed, 
the height of the walls that define it also 
change. 

• The initial ceiling height for all rooms on 
a floor is set in the Floor Defaults dialog 
for that floor. See “Floor Defaults” on 
page 144. Whenever possible, it is best to 
set all ceiling heights using the default.

• The ceiling height of a single room can be 
set in its Room Specification dialog. See 
“General Panel” on page 155.

Wall Length
Wall length can be modified in several 
different ways: 
• Using dimensions. See “Measuring 

Walls” on page 126.
• In the Wall Specification dialog. See 

“General Panel” on page 135.
• By dragging the end edit handles. See 

“Editing Line Based Objects” on page 88 
and “Editing Arc Based Objects” on page 
90. 

Bear in mind that if you try to resize a wall 
by a small amount using one of its edit 
handles and that wall is connected to another 
wall at that end, its length will not change 
because its end will snap back to the existing 
intersection. See “Connecting Walls” on 
page 124. 

The most accurate way to specify wall length 
is using dimensions. By default, wall length 
is measured at the outside edge of the Main 
Layer. You can instead specify that 
dimension lines locate surfaces in the 
Dimension Defaults dialog. See “Dimension 
Defaults Dialog” on page 405.
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Editing Straight/Curved Wall Combinations
If you move a straight wall connected to a 
curved wall with a locked center, the curved 
wall extends along its curve and the straight 
wall will either lengthen or shorten as needed 
to stay connected to the curved wall. 

If the connection between the straight and 
curved wall cannot be maintained because of 
the curved wall’s radius, it will be broken.

Aligning Walls
Wall alignment refers to the way wall 
segments line up with one another, either on 
the same floor or on the floor above or 
below.  Walls may need to be aligned in a 
variety of situations.

To make alignment easier when drawing or 
resizing walls, “sticky” points identify points 
that are either collinear or orthogonal to the 
end points of other walls. See “Extension 
Snaps” on page 79. 

Aligning Collinear Walls
Collinear walls are parallel walls connected 
end to end and drawn on the same floor. 
When collinear walls join end-to-end, the 
walls snap together. If these walls have the 
same wall type and identical specifications, 
and if Object Snaps are enabled, they will 
merge to become a single wall segment.

Creating a Nook
Walls can be aligned across an opening such 
as a nook, so that they are collinear, using the 

Break Wall  tool. 

To align walls across a gap

1. Select a wall to build a nook into and 

click the Break Wall  edit button. 
2. Click at a point on the wall close to one 

side of the nook area. Do not worry 
about exact placement right now. 

3. Click again near the other side of the 
nook. Two short lines at each location 
where you clicked indicate Wall Breaks. 
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4. Right-click the middle section of the 
wall to select the wall section. 

5. Click the middle Move handle and drag 
the wall outward. 

6. Draw side walls to connect the wall back 
to the rest of the house. 

7. Move these short walls using dimen-
sions to accurately size the nook. 

Aligning Walls 
Between Floors

Walls can be aligned between floors by 

clicking the Align With Wall Above  and 

Align With Wall Below  edit buttons.

To align walls between floors

1. Select a wall that you want to align with 
another wall either above or below it.

2. If the wall is above or below the other 
wall along only part of its length, you 
must click on it along that part. Select 
Tools> Reference Floors> Reference 
Display On  to help make sure you 
click on the correct part of the wall.

3. When you have selected the wall at the 
desired location, click either the Align 
With Wall Above  or Align With 
Wall Below  edit button.

Aligning Curved Walls 
Between Floors

Curved walls are aligned between floors 
using the same technique to align straight 
walls. If the centers and radii of the walls are 
within a few inches of each other, the Align 
With Wall Above  and Align With Wall 
Below  edit buttons are enabled for the 
selected wall. The selected curved wall will 
take on the radius and center of the 
referenced wall when the walls are aligned.

Roof Directives in Walls
To automatically generate a roof plane using 
values other than the defaults or to not 
generate a roof plane bearing on a particular 
wall (as for a gable or the sides of a shed 

roof), you can change the settings in the Wall 
Specification dialog. See “Roof Panel” on 
page 136. 

In order for these edit tools to be avail-
able, the areas of the walls in question

must be partially aligned, or overlapping.

Place Wall 
Breaks here

Position these 
walls as needed
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Hip, Gable, and Shed Roofs
By default, the program will produce a roof 
plane over each exterior wall to create a hip 
roof. You can instead specify a gable or shed 
roof above the selected wall. 
• Check Full Gable Wall to create a gable 

with a ridge centered above the selected 
wall(s).

• Check High Shed/Gable Wall for the 
side walls or the wall under the high side 
of a shed roof. 

• You can also select a wall and click the 

Change to Gable Wall(s)  edit button, 
or change it back by clicking the Change 
to Hip Wall(s)  edit button. 

Pitch
The default pitch for roof planes is set in the 
Build Roof dialog. However, any exterior 
wall can define the pitch of the roof plane 
built above it.

You can also specify a second, upper pitch 
above a given wall. Mansard, gambrel, gull 
wing and half-hip are examples of roof styles 
that use two pitches. See “Roof Tutorial” on 
page 57 of the User’s Guide.

Roof Returns
Check Auto Roof Return to generate roof 
returns on the selected wall. In most cases, 
roof returns only generate on Full Gable 
Walls. See “Roof Returns” on page 230.

Extend Slope Downward
Check Extend Slope Downward to extend 
the roof plane downward over a bumpout, 
instead of creating additional roof planes. 
The two connecting walls that create the 
bumpout must be Full Gable walls.

In the following image, the bearing wall of 
the bumpout has Extend Slope Downward 
checked. The two short side walls are Full 
Gable Walls. 

Attic Walls
In Home Designer Suite, walls are built 
between the floor and ceiling platforms of 

the current floor.  See “Floor and Ceiling 
Heights” on page 151. When the program 

Before

After

Full Gable 
Wall

Extend Slope 
Downward
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detects an open space between a wall and the 
roof plane above it, it automatically creates 
an Attic Wall on the floor above that wall to 
fill in the gap. 

Attic Walls are typically found above Full 
Gable Walls, forming a gable or closing the 
top portion of a side wall of a shed roof. Attic 
Walls are often found on the Attic floor, but 
can be generated on other floors, as well. See 
“The Attic Floor” on page 205. 

Removing Attic Walls
Occasionally, the program will generate an 
Attic wall where one is not wanted. There are 
several ways to address this:
• Turn off the display of the “Walls, Attic” 

layer.
• Specify the Attic Wall as Invisible. See 

“Room Dividers and Invisible Walls” on 
page 120.

• Select the Attic Wall and Delete  it. 
The program will specify the wall as 
Invisible automatically. If you delete this 
Invisible wall, a new Attic Wall will be 
created.

Knee Walls
Knee Walls are a bit like Attic Walls in that 
they are not meant to generate to full ceiling 
height. Instead, they build upward until they 
encounter a roof plane. Unlike Attic Walls, 
however, Knee Walls are used in the interior 
of a structure, typically to separate unused 
areas from rooms on the upper floor of a 
story-and-a-half structure. See “Room 
Types” on page 147.

Home Designer Suite does not specify walls 
as Knee Walls automatically. If an interior 
wall is drawn in a location where the roof is 
lower than the ceiling height, you should 
specify it as a Knee Wall in the Wall 
Specification dialog. See “Roof Panel” on 
page 136.

Wall Type Definitions
Every wall drawn in a plan is assigned a wall 
type, and its Wall Type Definition determines 
its structure, its appearance in floor plan 
view, and its default materials. 

You can specify the default wall types used 
when walls are first created, and can specify 
the wall type of any wall after it is drawn in 
the Wall Specification dialog. See “Wall 
Defaults” on page 116 and “General Panel” 
on page 135. 

The structural layer of a wall type is its Main 
Layer, which controls a number of things:
• At intersections, walls join at the interior 

surfaces of their Main Layers. See “Con-
necting Walls” on page 124. 

• Exterior walls on different floors are 
aligned by the exterior edges of their 
Main Layers. 

• Roof baselines are placed at the outer 
edge of the Main Layer.

If you do not want to keep a particular
Attic Wall in your plan, specify it as

Invisible. See “Room Dividers and Invisible
Walls” on page 120.
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• Walls resize about the exterior surface of 
their Main Layer when their wall type is 
changed.

• Object Snaps locate the exterior surface 
of a wall’s Main Layer. See “Object 
Snaps” on page 78. 

• By default, dimension lines locate walls at 
their Main Layer. See “Dimension 
Defaults Dialog” on page 405. 

Interior and Exterior Surfaces
Every wall has an interior and exterior 
surface - including walls in a plan that are 

recognized by the program as being interior 
walls. See “Exterior and Interior Walls” on 
page 119.

Having separate designations for a wall’s two 
surfaces allows you to specify different 
materials for each in the Wall Specification 
dialog. See “Materials Panel” on page 137.

In floor plan view, you can identify a 
selected wall’s exterior surface by the 
location of its edit handles, which display on 
the exterior of the Main Layer.

Wall Specification Dialog
To open the Wall Specification 
dialog, select a wall and click the 

Open Object edit button. 

The panels of the Wall Specification dialog 
are also found in the Railing, Deck Railing, 
and Fencing Specification dialogs. See 
“Railing and Fencing Specification Dialogs” 
on page 138. 
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General Panel

Specify General  properties of the 
selected wall or railing. 

• The Thickness of the selected wall dis-
plays and can be changed here. If the wall 
is a Post to Overhead Beam railing, this 
setting also affects the width of the beam. 
See “Wall Thickness” on page 129. 

• Wall Angle - The current absolute angle 
of the wall in a floor plan view is shown. 
If you type in a new angle, any walls 
attached to it will not move. If the 
selected wall is curved, this value 
describes the angle of the chord and can-
not be modified. 

• Wall Length - The current length is 
shown. If you type a new length, any 

walls attached to the selected wall will not 
move. If the selected wall is curved, this 
value cannot be modified.  

Check any of the Options to modify the 
selected wall accordingly. In most 

cases, multiple options can be selected. Not 
available for fencing. 
• Check Invisible to specify the wall as 

invisible. Invisible walls can display in 
floor plan view but not in 3D views or the 

Materials List. Room Dividers  are 
invisible by default. See “Room Dividers 
and Invisible Walls” on page 120. 

• Check No Room Def. to display the wall 
in floor plan and/or 3D views but not cre-

1

2
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ate room definition. See “Room Defini-
tion” on page 144. 

• Check No Locate to prevent Auto Exte-
rior Dimensions  from locating the 
wall in floor plan view. See “No Locate” 
on page 127.

Select the Wall Type assigned to the 
selected wall from the drop-down list. 

A preview diagram of the selected wall 

type’s layers, as seen in floor plan view, 
displays below. 

A preview of the selected wall, 
including any doors, windows, and/or 

fireplaces inserted into it, displays on the 
right. If the selected wall is specified as 
Invisible, its plan view will display here by 
default. See “Dialog Preview Panes” on page 
29. 

Roof Panel
Any automatically generated roof style other 
than a hip requires roof information to be 
defined in the exterior walls. On the Roof 
panel, you can specify how the selected wall 
interacts with the roof plan, defining the 
portion of the roof plan that bears on it..

The Roof panel is not available for 
Foundation Walls or Fencing. See 
“Foundation Walls” on page 120 and 
“Fencing Tools” on page 119. 

3
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Roof Options - Specify the shape of 
the wall relative to the roof. 

• Check Full Gable Wall to create a gable 
end over the selected wall. 

• Check High Shed/Gable Wall to specify 
the selected wall as the high end of a shed 
roof. 

• Check Knee Wall to define the selected 
interior wall as a knee wall. Only an inte-
rior wall can be defined as a knee wall. A 
knee wall’s height is defined by the roof 
above, not the ceiling height. See “Knee 
Walls” on page 133.

• Check Extend Slope Downward to con-
tinue a roof down over a bumpout in an 
exterior wall. See “Extend Slope Down-
ward” on page 132. 

Pitch Options - Specify the pitch or 
pitches of the roof plane(s) above the 

selected wall.
• Enter a value to define the Pitch of the 

roof plane bearing on the selected wall. 
• Check Upper Pitch to create a roof with 

two pitches or, if the selected wall is a 
Full Gable Wall, a half hip condition.

• Enter the Pitch of the second, upper roof.
• Specify the Height that the Upper Pitch 

Starts at, or define the distance in from 
Baseline that the second pitch begins. The 
two values are dynamic. Press the Tab key 
to update the relative numbers.

Specify the Overhang Length, which 
is the horizontal distance from the 

outside of the wall’s Main Layer to the eave. 
See “Wall Type Definitions” on page 133.

Check Auto Roof Return to generate 
roof returns on the selected wall. In 

most cases, roof returns only work for Full 

Gable Walls. See “Roof Returns” on page 
230.
• Specify the horizontal Length of the roof 

return in inches (mm).
• Enter a value in inches (mm) to Extend 

the roof returns past the overhang. 
• Specify a Gable, Hip, or Full roof return. 
• Specify a Sloping or Flat roof return. 

A preview of the selected wall, 
including any doors, windows, and/or 

fireplaces inserted into it, displays on the 
right. See “Dialog Preview Panes” on page 
29. 

Rail Style Panel
The Rail Style panel is only available for 
Railings, Half Walls, Deck Railings, and 
Fencing. See “Rail Style Panel” on page 138.

Newels/Balusters Panel
The Newels/Balusters panel is only available 
for Railings, Half Walls, Deck Railings, and 
Fencing. See “Newels/Balusters Panel” on 
page 140.

Materials Panel
All walls - including interior walls, railings 
and fencing - have an “Exterior Wall 
Surface” and an “Interior Wall Surface”. See 
“Interior and Exterior Surfaces” on page 134. 

The materials specified on the Materials 
panel affect the appearance of walls and 

1

2

3

4

Additional information about using the
settings on this panel can be found in
the “Roof Tutorial” on page 57 of the

Reference Manual. 

5

home-designer-suite-2015-reference-manual.book  Page 137  Thursday, May 29, 2014  4:26 PM



138

Home Designer Suite 2015 Reference Manual

Solid Railings in 3D views but are not 
calculated in the Materials List. See 
“Materials Lists” on page 491. 

For most railing types, the “Exterior Wall 
Surface” component only affects the 

appearance of the floor platform under the 
railing. and “Interior Wall Surface” 
component is not used. For fencing, neither 
material component is used. 

Railing and Fencing Specification Dialogs
To open the Railing or Fencing 
Specification dialog, select a railing 

or fencing and click the Open Object edit 
button. 

The Railing and Fencing Specification 
dialogs are the same as the Wall 
Specification dialog, but have two panels 
that apply only to Railings, Half Walls, Deck 
Railings, and Fencing. See “Wall 
Specification Dialog” on page 134. 

Rail Style Panel
The Rail Style panel is only available for 
Railings, Deck Railings, and Fencing. See 
“Railing and Deck Tools” on page 117, 

“Fencing Tools” on page 119, and “Fencing 
Tools” on page 119.
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Railing Type - Select the radio button 
for the desired railing type. A preview 

of the selected type displays to the left.
• Check Balusters to create regularly 

spaced balusters between larger newel 
posts. 

• Check Solid to create a solid railing or 
Half Wall. 

• Check Open to create a railing with only 
newel posts and top and bottom rails.

• Check Middle Rail to create a railing 
with newel posts and top, bottom, and 
middle rails.

• Check No Rail to eliminate rails, leaving 
only newels or posts and an overhead 
beam, if selected. 

• Check Panels to create a railing com-
posed of panels.

Specify the properties of the selected 
railing’s Newels/Posts.

• Check Post to Rail to create newel posts 
from the floor to the top rail. This option 
is selected by default.

• Check Post to Overhead Beam to create 
newel posts from floor to an overhead 

beam placed just under the ceiling height. 
The beam’s width is based on the Thick-
ness of the selected railing wall.

• Check Post to Ceiling to extend the 
newel posts to the ceiling.

• When none of the above Post options is 
selected, newel posts will build to the top 
of the railing.

The Bottom Rail options control the 
placement of the bottom rail, or shoe. If 

neither box is checked, the bottom rail is 
placed at floor platform level. Not available 
for railings specified as Solid or No Rail. 
• Uncheck Include Bottom Rail to elimi-

nate the bottom rail and extend the balus-
ters to the floor. Not available for Panel 
railings.

• Check Raise Bottom Rail, then specify 
the bottom rail’s height off the floor plat-
form in the text field below.

A preview of the selected railing or 
fence, including any doorways or gates 

inserted into it, displays on the right. See 
“Dialog Preview Panes” on page 29. 

1

2

3

4
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Newels/Balusters Panel

Specify the height of the Railing. 

• Specify the Railing Height. For interior 
railings, this is measured from the height 
of the floor finish.

Specify the characteristics of the 
selected railing’s Newels/Posts. 

• Specify the Width of each newel at its 
widest point.

• Specify the Height, which is the height 
from the floor or ground to the top of the 
newel. Not available if Post to Rail, Post 
to Overhead Beam or Post to Ceiling is 
selected on the Rail Style panel.

• Specify the on-center Spacing of the 
newel posts.

• Type - Select Square, Round, or Library 
newels.

Specify the characteristics of the 
selected railing’s Balusters. These set-

tings are only available when the railing type 
is “Balusters”. 
• Specify the Width or diameter of each 

baluster at its widest point. 
• Specify the on-center Spacing of the bal-

usters.
• Type - Select Square, Round, or Library 

balusters .

Specify the characteristics of the 
selected railing’s Panels. These settings 

1

2

Note: Selecting Library from the drop-down
list is the same as clicking the Library button
to the immediate right and allows you to
select a symbol from the library. See “Select
Library Object Dialog” on page 356.

3

4
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are only available when the railing type is 
“Panels”. 
• Specify the panel’s Thickness.
• Panel Type is only available when the 

railing type has been specified as Panels 
on the Rail Style panel. Select “Solid”, 

“Framed”, or “Library” to select a symbol 
to be used as a railing panel. 

A preview of the selected railing or 
fence, including any doorways or gates 

inserted into it, displays on the right. See 
“Dialog Preview Panes” on page 29. 

Wall Hatch Specification Dialog 
To open the Wall Hatch Specification 
dialog, select a Wall Hatch and click the 
Open Object edit button. See “Hatch Wall” 
on page 121.

• Choose a Fill Pattern from the drop-
down list.  A preview of the selected pat-
tern displays to the right.

The options that follow are disabled until 

you select a pattern other than None from 
the Fill Pattern drop-down list.

• Define the Spacing for the selected fill 
pattern. Hatch spacing set at 12" matches 
grid/reference spacing set at 12".

• Check Transparent Pattern Fill to make 
the fill pattern transparent. When you 
check this option, any objects behind the 
fill pattern are visible through it. 

• Fill Color - Click the color bar to select a 
color for the fill pattern lines or fill color 
if a solid fill is specified. This overrides 
the layer color. See “Select Color Dialog” 
on page 370.

• Choose a Preview Width from the drop-
down list. This value controls how large 
an area the preview represents. The 
selected value indicates the length of each 
side of the preview in plan inches (mm).

5
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Chapter 9:

Rooms

When walls or railings create an enclosed 
area, a “room” is created. You can select 
rooms defined in this manner like other 
objects in Home Designer Suite.

Rooms are assigned a Room Type. Each 
Room Type has predefined characteristics. 
For example, a room defined as Porch is 
assigned certain attributes that are different 
than a Kitchen. 

Floor and ceiling heights, baseboard, chair-
rail, and crown moldings and materials can 
be defined room-by-room or for the entire 
floor.

Chapter Contents
•      Floor and Room Defaults
•      Room Definition
•      Selecting Rooms
•      Displaying Rooms
•      Editing Rooms
•      Room Types
•      Room Labels
•      Decks
•      Floor and Ceiling Heights
•      Stepped Floor and Ceiling Platforms
•      Special Ceilings
•      Room Specification Dialog
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Floor and Room Defaults
Select Edit> Default Settings to open 
the Default Settings dialog where 

you can access several defaults dialogs 
which directly affect rooms. 

Floor Defaults
Default values for rooms are specified in the 
Floor Defaults dialog for the current floor. 
This dialog also controls important 
information that the program uses to create 
3D models - particularly floor and ceiling 
heights and materials. Moldings can also be 
specified in the Floor Defaults dialog. 

Only the defaults for the first floor of a 
building can be set ahead of time. The 
program uses the setting from the first floor 
to create subsequent floors. Once a new floor 
is built, its floor defaults can be changed. See 
“Floor Defaults Dialog” on page 200.

Room Defaults
Additional material defaults for several 
categories of Room Types can also be 
specified:
• Normal Rooms
• Kitchens/Baths/Utility Rooms
• Decks
• Garage/Porches/Slabs

These Room Defaults dialogs are accessed 
by expanding the “Rooms” category in the 
Default Settings dialog. Select a room type 
and click the Edit button to open the defaults 
dialog for that room type. See “Room Types” 
on page 147.

These dialogs allow you to specify the floor 
and ceiling covering materials for different 
Room Types.

Room Definition
A room is a totally enclosed area defined by 
any combination of joined walls or railings, 
visible or invisible. To be recognized as a 
room by Home Designer Suite, a room must 
have an unbroken perimeter.

Unless otherwise specified, rooms generate 
floor and ceiling platforms automatically. 
Most rooms are also automatically covered 
by the roof when one is built. There are 
exceptions to this, such as rooms defined as 
Decks. See “Room Types” on page 147.

If a room is drawn within a larger structure 
and none of its walls connect to the exterior 
walls, either directly or indirectly by 

connecting to walls that do, it is referred to as 
an “island” room. The program will connect 
such a room to the larger structure with an 
Invisible Wall. See “Room Dividers and 
Invisible Walls” on page 120.

Room definition disappears if part or all of a 
surrounding wall is deleted. It is a good idea 
to finalize the position of walls before 
defining rooms with names and attributes 
such as floor height and ceiling height.

Subdividing Rooms
When a room area is first defined, it inherits 
its characteristics from the Floor Defaults 
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dialog for that floor. If the room is then 
specified as a particular type, it may inherit 
properties from the Room Defaults dialog 
associated with its type. 

If a new room is created by subdividing a 
larger room, it inherits its characteristics 
from that larger room - including any non-
default settings. 

Selecting Rooms
Room definition is established when a room 
is completely enclosed by walls. You can 
confirm that a room has room definition by 

using the Select Objects  tool to select it. 
When a fully-enclosed room is selected, the 
room highlights. 

The Exterior Room
You can also select the exterior of a model. 
This allows you to control the building’s 
exterior wall coverings and materials using 
the Room Specification dialog. 

Click just outside an exterior wall using the 

Select Objects  tool to select the Exterior 
Room. When it is selected, a highlighted 
band around the plan’s exterior displays. 
This band represents the selection area for 
the Exterior Room.

In camera views and overviews, the Exterior 
Room can be selected by clicking on the 
exterior surface of an exterior wall using the 

Select Objects  tool.

In 3D Views
Click on the floor of a room or on a wall 
surface inside the room in a 3D view using 

the Select Objects  tool. If you select 
another object instead of the room, click 

Select Next Object  edit button or press 
the Tab key until the room is selected. The 
Status Bar indicates which object is currently 
selected.

The Exterior Room can also be in 3D views 
selected by clicking once on the exterior 

The room at left is selected

The Exterior Room is selected
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surface of an exterior wall using the Select 
Objects  tool. 

Displaying Rooms
Unlike most things in Home Designer Suite, 
a room is not an individual object. Rather, a 
room is defined by the walls that enclose it.

In Floor Plan View
Rooms typically display a transparent fill in 
floor plan view. You can, however, specify a 
solid color or fill pattern for individual rooms 
in the Room Specification dialog. See “Fill 
Style Panel” on page 160.

In order for room fill styles to display, the 
“Rooms” layer must be turned on. See 
“Displaying Objects” on page 74. 

Room labels that include the room’s name as 
well as its size and other information can be 

set to display in floor plan view. See “Room 
Labels” on page 149. 

In 3D Views
Rooms can be viewed in 3D views created by 
any of the 3D view tools. The Dollhouse 
View tool can be used to see all rooms on the 
current floor without their ceilings. See 
“Creating Overviews” on page 384.

In the Materials List
The contents of a room, including 
furnishings and floor and ceiling materials 
can be calculated using the Calculate From 
Room tool. See “Calculate From Room” on 
page 492.

Editing Rooms
Once a room is defined by walls or railings, 
its structure and appearance can be edited 
using the edit buttons or the Room 
Specification dialog. 

In 3D Views
The floor and ceiling heights for floors and 
rooms can be edited using edit handles in 3D 
views. Lowered ceilings cannot be edited in 
3D. See “3D Views” on page 381. 

The default floor and ceiling heights for an 
entire model can be edited by selecting the 
Exterior Room. See “The Exterior Room” on 
page 145.

To change default ceiling heights in 3D

1. Create a 3D view of the exterior of your 
plan. 

2. Click on the exterior surface of a wall to 
select the Exterior Room. The Status Bar 
indicates when the exterior room is 

Note: If the wall height of the Exterior Room
is adjusted in a 3D view, the default Floor or
Ceiling Height of the entire floor is changed.
See “Floor and Room Defaults” on page 144.
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selected. See “The Exterior Room” on 
page 145.

3. Click and drag the edit handle on the top 
wall edge to adjust the default ceiling 
height, or the edit handle on the bottom 
edge to adjust the default floor height. 
Temporary dimensions display.

To adjust room heights in 3D

1. Create a 3D view of your plan.
2. Click on the surface of a wall that faces 

the room to select it. When the room is 
selected in 3D:

•  The room highlights. 
•  The Status Bar says “Room”. See “The 

Status Bar” on page 30.
•  Two edit handles display on the top and 

bottom edges of the highlighted wall.

3. Click and drag the edit handle on the top 
wall edge to adjust the room ceiling 
height, or the handle on the bottom edge 
to adjust its floor height. Temporary 
dimensions display.

4. As you drag a handle, notice that all 
walls defining that room are affected.

Room materials such as floor, ceiling, and 
wall materials can be changed in 3D views 

using the Material Painter . See “The 
Material Painter” on page 362.

In the Specification Dialog
Floor and ceiling heights, floor 
platform structure, moldings, and 

materials can all be specified in the Room 
Specification dialog. See “Room 
Specification Dialog” on page 155.
• Click the Calculate Materials for 

Room  edit button to create a materi-
als list of the contents of the selected 
room, not including walls. See “Calculate 
From Room” on page 492.

Room Types
When a room is first created by enclosing an 
area with walls, it is assigned a generic room 
type of “Unspecified.” 

Once your floor plan is laid out, each room 
should be assigned a Room Type in the 
Room Specification dialog. See “General 
Panel” on page 155. The Room Type applies 
appropriate structural and display properties 
to the room. 

When you assign a Room Type, a label 
showing the room’s Type displays in floor 
plan view.

You can edit the text of a room label in floor 
plan view, but the type of room originally 
assigned remains until it is changed in the 
Room Specification dialog. See “Editing 
Room Labels” on page 149.

Note: Any rooms that do not update when the
default floor or ceiling height is changed are
not using the default values. To use the
default values for a specific room, check
Default for any of the room height values in
its specification dialog. See “General Panel”
on page 155.
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Available Room Types
There are three categories of room types: 
Interior, Exterior and Hybrid.

Interior - Living, Dining, Family, Kitchen, 
Nook, Bath, Master Bath, Master Bedrm, 
Bedroom, Study, Office, Entry, Hall, Closet, 
Dressing, Storage, Laundry, Utility and 
Unspecified.

Exterior - Court, Deck, Balcony.

Hybrid - Open Below, Garage, Slab, Porch, 
Attic.

Effects of Room Types
The program applies specific structural and 
display properties to rooms depending on the 
assigned Room Type.

Living and Conditioned Areas
• All interior type rooms are included in 

Living Area calculations; exterior and 
hybrid type rooms are not. 

• With the exception of Unspecified rooms, 
all interior type rooms are included in 
Conditioned Area calculations. Open 
Below rooms are also included; however, 
exterior and other hybrid type rooms are 
not. See “Conditioned Area Totals” on 
page 497.

Ceilings and Roofs
• Interior rooms have a ceiling and roof 

above them unless specified otherwise.
• Exterior rooms are assumed to be open to 

the outside and do not generate a roof 
above them, or room moldings.

• Attic rooms are ignored by the program’s 
automatic roof generator.

• Garage, Slabs, and Porches are treated 
like exterior rooms in all cases except that 
they generate a ceiling and a roof above 
them.

• A room’s default ceiling structure and fin-
ish definitions are determined by its 
Room Type. See “Room Defaults” on 
page 144.

Floors and Foundations
• Open Below is a unique type of interior 

room. It has no floor platform and can be 
used for defining stairwell openings. 

• Walls that define the garage have a foun-
dation under them  with a concrete slab at 
the top of stem wall or grade beam.

• The floor in Garage and Slab rooms dis-
play in 3D on Floor 0, not the first floor. 
See “Garages” on page 211.

• A room’s default floor structure and finish 
definitions are determined by its Room 
Type. See “Room Defaults” on page 144.

• Courts, decks and balconies do not gener-
ate foundations.

Doors and Windows
• A window placed in a wall between an 

exterior room and an interior room always 
faces out toward the exterior. 

• Windows placed between interior rooms 
generate a warning message. 

• Door placed between interior and exterior 
type rooms display threshold lines.

• Interior doors do not display thresholds.
• Open Below rooms are treated as interior 

rooms for window and door placement.
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Electrical

• The Auto Place Outlets  tool adds 
outlets automatically to all interior rooms 
except bathrooms. Only one outlet over 
each sink is added for a bathroom.

• The Auto Place Outlets  tool places 
fewer outlets in hybrid rooms. 

• The Auto Place Outlets  tool does not 
place outlets in exterior type rooms, 
Porches or Open Below rooms.

• Any outlet manually placed in an exterior 
room automatically becomes a waterproof 
outlet designed for exterior use. 

Trim and Molding
• Moldings are not automatically drawn in 

exterior or hybrid rooms.
• Baseboards and chair rails are not initially 

drawn in Open Below rooms, but crown 
molding, if present, is. 

Plan Check

• Plan Check  uses the room type and 
its characteristics for basic plan checking. 
For example, a closet does not need a 
smoke detector but a bedroom does. See 
“Plan Check” on page 445. 

Room Labels
A label can display in floor plan view for any 
area defined as a room. There are two parts 
to each room label: 
• The Room Name, which is similar to a 

Text  object and can be selected and 
edited. See “The Text Tools” on page 419. 

• The room area, which is not a standard 
text entry and cannot be directly edited. 

You can assign a custom Room Name, move 
a room label or even delete it without 
affecting the Room Type. See “Room Types” 
on page 147.

Displaying Room Labels
The display of room labels is controlled in 
the Display Options dialog. Room labels are 
placed on the “Rooms, Labels” layer and use 

the Text Style assigned to that layer. See 
“Display Options Dialog” on page 75. 

You can specify how the area of rooms is 
calculated by the program by turning on the 
display of one or more of these layers: 
• Rooms, Standard Area is measured from 

the center of interior walls to the exterior 
wall framing. It is rounded to the nearest 
square foot or mm and does not include 
the area within bay, box and bow win-
dows. 

• Rooms, Interior Area is measured from 
the inner surfaces of all the room's walls. 

• Rooms, Interior Dimensions is also 
measured from the inner surfaces of the 
room walls. 

Editing Room Labels

Room labels are similar to simple Text  
objects and can be changed, moved and 

Room labels can move or even disap-
pear when room entries are revalidated.
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resized much like any other text object. You 
can also modify a room label’s Text Style 
and other attributes in the Room Label 
Specification dialog.

The text of a room label cannot be modified 
in its specification dialog, however: it must 
be specified in the Room Specification 
dialog. See “General Panel” on page 155.

If you delete a room label, the Room Type 
and Room Name remain unchanged in the 
Room Specification dialog. To restore the 
label, check the Show Room Label 
checkbox on the General panel of that dialog.

Room Area
Unlike the rest of a room label, the room area 
and dimensions are not standard text entries 
and cannot be edited or changed. The room 
area moves, resizes and rotates with the rest 
of the room label, but you can turn the area 
and dimensions on or off separately in the 
Display Options dialog. See “Displaying 
Rooms” on page 146.

The Interior Area room area calculation 
includes the areas within bay, box or bow 
windows, while the Standard Area and 
Interior Dimensions calculations do not.

Living Area
The Living Area label displays the area of 
the floor platform for living areas in a plan. It 
is found near the bottom center of the plan as 
soon as a room area is defined by walls and/
or railing.

The Living Area displays for an individual 
building if half or more of that building's area 

is living area. For example, a living area 
label would not display for a detached garage 
that includes a small bathroom.

You can choose not to display this label by 
unchecking Show Living Area Label in the 
General Plan Defaults dialog or by turning 
off the display of the “Room Labels” layer in 
the Display Options dialog. See “General 
Plan Defaults Dialog” on page 57.

The Living Area label can be moved or 
deleted. To restore a deleted Living Area 

label, select Tools> Plan Check . You 
can click the Done button immediately, 
without actually completing Plan Check. See 
“Plan Check” on page 445.

Living Area vs. Footprint
The Living Area should not be mistaken for 
the footprint of the house. Only true livable 
areas are included in the Living Area 
calculation. By default, exterior and hybrid 
room types such as Garage, Deck, and Porch 
are not included. Neither is any room labeled 
Open Below or Attic. See “Available Room 
Types” on page 148. 

Regardless of its room type, you can specify 
whether a room is included in the Living 
Area calculation in the RoomSpecification 
dialog. See “General Panel” on page 155. 

Living Area is measured from either the 
outside surface or the outer surface of the 
structural layer of exterior walls. When walls 
separate the living area from exterior or 
hybrid room types, it is measured to the wall 
center line.
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Decks
A Deck room is an exterior-type room that 
uses deck planking and framing to create a 
floor platform rather than using a single floor 
surface that spans the entire room area.

To draw a deck, select Build> Deck> Deck 
Railing , then click and drag to draw a 
railing. 
• To create a deck without a railing, use one 

of the Deck Edge tools. See “Fencing 
Tools” on page 119.

• You can also create a regular, polygon-
shaped deck using the Polygon Shaped 
Deck  tool. See “Polygon Shaped 
Deck” on page 118.

A room does not have to be defined by Deck 
Railing to be specified as a “Deck.” See 

“Room Types” on page 147. You can also 
define a room as a “Deck” in the Room 
Specification dialog. See “General Panel” 
on page 155. 

By default, decks do not have roofs. If you 
want a roof over a deck, check Roof Over 
This Room in the Room Specification 
dialog. See “Structure Panel” on page 156.

To give the roof a visible means of support, 
you can select the Post to Beam option in the 
Wall Specification dialog. See “Rail Style 
Panel” on page 138.

Openings in deck railings can be created 

using Doorways . See “Openings in 
Railings” on page 169. 

Floor and Ceiling Heights
Use the Room Specification dialog to set 
floor heights on a room-by-room basis. See 
“Room Specification Dialog” on page 155. 

Different rooms on the same floor can have 
unique floor and ceiling heights, allowing 
you to create: 
• Split levels and bi-levels
• Sunken living rooms and garages
• Cathedral and coffered ceilings.

In 3D views, you can adjust the default floor 
and ceiling height for the entire floor or the 
floor and ceiling height for an individual 
room. See “In 3D Views” on page 146.

In order to raise or lower an area’s floor or 
ceiling height, you must give it a room 
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definition. To create room definition without 
enclosing an area with solid walls, use 

Railings . 

Ceiling and floor heights are interrelated. 
Changing the floor height in one room can 
affect ceiling heights of the rooms below. 
• If a room’s floor is lowered, its ceiling 

height is increased while the ceiling 
below that room drops. 

• If the floor is raised, the ceiling height 
decreases while the ceiling below that 
room is raised. 

If the rooms above a particular room have 
more than one floor height, the room’s 
ceiling is stepped.

In a situation like this, a Lowered Ceiling can 
be used to cover “steps” made by different 

floor heights on the floor above. See 
“General Panel” on page 155.

To ensure that steps in floor and ceiling 
platforms have solid sides, define their room 
areas using Invisible Railings. 

Split Levels
A split level can be created by raising or 
lowering the floor and ceiling heights of 
various areas of the plan.

In the following example, the lowest floor 
height is 0, the next is 24, and the next is 48 
inches. The ceiling height in each room is set 
at 109 inches. See “Split Levels” on page 
203.

Stepped Floor and Ceiling Platforms
Each floor has default floor and ceiling 
heights. You can, however, use the Room 
Specification dialog to specify floor and 
ceiling heights on a room by room basis to 
create stepped floors and ceilings. See 
“Structure Panel” on page 156. 

If you require a single floor platform with a 
uniform height and thickness but different 
ceiling heights for the rooms below, specify a 
lowered ceiling using the Ceiling Finish 
Specification dialog. See “Lowered 
Ceilings” on page 153.
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Special Ceilings
By default, the program builds a flat ceiling 
platform on top the wall plates of a room. 
More varied and complex ceilings are made 

using settings in the Room Specification 
dialog.

Lowered Ceilings
You can define a lowered or dropped ceiling 
in a room without affecting the top plate 
height of the walls by increasing the 
thickness of the Ceiling Finish.

In the following illustration, the default 
ceiling height for the entire first floor is 120", 
and the room on the right has a ceiling finish 
lowered to 96".  

To create a lowered ceiling

1. Select the room in which you would like 
to specify a lowered ceiling.

2. Click the Open Object  edit button 
to open the Room Specification dialog.

3. On the Structure panel, increase the 
Ceiling Finish value by the amount that 
you would like to lower the ceiling.

4. Notice that the preview diagram repre-
sents the Finished Ceiling height (F).

Cathedral Ceilings
A cathedral ceiling has the same pitch as the 
roof and is created using the underside of the 
roof above the room. 

To create a cathedral ceiling

1. Build a roof for your plan. See “Roofs” 
on page 219. 

2. Select the room and open the Room 
Specification dialog. See “Room Speci-
fication Dialog” on page 155.

3. On the Structure panel, clear the check-
box for Ceiling Over This Room.

Normal ceiling Lowered ceiling
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Tray Ceilings
A tray ceiling is flat in the center and sloped 
around the perimeter, and is easily created 
using the underside of roof planes above.

To create a tray ceiling

1. In the Room Specification dialog, make 
sure that Ceiling Over this Room is 
checked, then specify the desired height 
of the walls as the Ceiling Height. See 
“Structure Panel” on page 156.

2. Make sure that Auto Rebuild Roofs is 
unchecked, then build the roof. See 
“Build Roof Dialog” on page 221.

3. Change the Ceiling Height of the room 
to the desired height of the flat ceiling 
surface in its center. 

In floor plan view, dashed lines indicate 
where the ceiling changes from sloped to 
flat. These lines are located on the “Ceiling 
Break Lines” layer in the Display Options 
dialog. See “Display Options Dialog” on 
page 75.

If the roof is rebuilt after the ceiling height is 
adjusted upward, the new roof will be raised 
to match the new ceiling height and a tray 
ceiling will not be created.

In the following example, a hip roof is built 
on 8’ (2400 mm) ceilings. After the roof is 
built, the Ceiling Height is raised to 10’ 
(3000 mm). The resulting ceiling follows the 
roof pitch for 2’ (600 mm), then becomes a 
flat ceiling. 

Cantilever Undersides
Occasionally, a room will cantilever out past 
an exterior wall. You can specify the surface 
material of the underside of a cantilever on 

the Materials panel of the Room 
Specification dialog. See “Room 
Specification Dialog” on page 155.

       Hip roof with 
cathedral ceiling over.

Hip roof, ceiling over, 
ceiling height raised.

Ceiling Break lines in 
   floor plan view. 
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Room Specification Dialog
The Room Specification dialog 
controls the structural characteristics 

and appearance of a selected room. To open 
the Room Specification dialog, select a 
room and click the Open Object edit button. 
See “Selecting Rooms” on page 145. 

Several of the panels in the Room 
Specification dialog are also found in the 
Floor and Room Defaults dialogs. See 
“Floor and Room Defaults” on page 144. 

Some values in this dialog are dynamic. A 
value with Default checked is referenced 
from the Floor Defaults dialog. To return a 
value to the default, replace the check mark. 
See “Dynamic Defaults” on page 57.

The settings in this dialog are similar to those 
in the Floor Defaults dialog, but affect only 
the selected room See “Floor Defaults 
Dialog” on page 200.

General Panel
The General panel is not available in the 
Room Defaults dialog, and only two of the 
settings here are active in the Floor Defaults 

dialog. See “Floor and Room Defaults” on 
page 144.

The settings here control the Room 
Type and the appearance of the Room 

Label
• Select the Room Type. This affects some 

of the room’s characteristics. See “Room 
Types” on page 147.

• If you wish to use a custom name in the 
room label, uncheck Use Room Type, 

then specify the desired Room Name in 
the text field.

• Check Show Room Label to display the 
room label in floor plan view. This option 
is unchecked automatically if you select 
“Unspecified” as the room type. See 
“Room Labels” on page 149.

1

home-designer-suite-2015-reference-manual.book  Page 155  Thursday, May 29, 2014  4:26 PM



156

Home Designer Suite 2015 Reference Manual

• Uncheck Display in Uppercase to use the 
same capitalization as the selected Room 
Type or Room Name in the room label. 
When this is checked, all letters in the 
label are capitalized.

Specify whether the selected room is 
included in the Living Area 

calculation. See “Living Area” on page 150. 

• Select Include in Total Living Area Cal-
culation to include the room in the Living 
Area regardless of its Room Type. 

• Select Exclude from Total Living Area 
Calculation exclude the room from the 
Living Area regardless of its Room Type. 

• Select Use Default for Room Type 
(Included/Excluded) to base the selected 
room’s inclusion in the Living Area on its 
Room Type. The default for the selected 
Room Type is stated in parentheses.

Structure Panel
The Structure panel is also found in the Floor 
and Room Defaults dialogs and features a 
cross section diagram that shows the 
relationships between its various heights and 
platform thicknesses. It is meant to represent 
the relationships between heights and 
thicknesses rather than provide a scaled 
drawing of the model.

Two floors can be included in the diagram: 
the floor that the selected room is located on, 
and the floor below it, if one exists. 

What appears in both the diagram and in the 
settings to its left may be affected by the 
location where you clicked to select the 
room. For example:
• If the selected room is located above two 

rooms with different structural settings, 
the position of the pointer relative to these 
two lower rooms determines which of 
them displays as the floor below.

• If the selected room is located below two 
rooms with different floor heights, its 
absolute and relative ceiling height set-
tings will be disabled. 

2

home-designer-suite-2015-reference-manual.book  Page 156  Thursday, May 29, 2014  4:26 PM



Room Specification Dialog

 157

Check the Default box beside any height 
value to restore the default setting. 

Absolute Elevations - These height 
values are measured from the default 

first floor height of zero.  See “Floor and 
Ceiling Heights” on page 151.
• Specify the Floor Above height, which is 

the floor height of the room or rooms on 
the floor above the selected room. If mul-
tiple floor heights are specified directly 
above the selected room, this setting will 
be inactive and “No Change” will display. 

• Specify the Ceiling height of the selected 
room. Not available in the Floor Defaults 
dialog on Floor 0, or if multiple floor 

heights are specified above the selected 
room. 

• Specify the Floor height. 

If a room is defined directly beneath the 
selected room on the floor below, additional 
settings may be available. 
• Specify the Floor Below height, which is 

the floor height of the room directly 

1

Note: The default floor height for Floor 1 is 0.
It can be modified in the Room Specification
dialog, but not in the Floor 1 Defaults dialog.
See “Floor and Room Defaults” on page 144.
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below where you clicked to select the cur-
rently selected room. 

• If the selected room is directly above a 
Garage and there is a foundation present, 
you can specify the SWT Below height, 
which is the top height of the concrete 
stem walls around the perimeter of the 
garage. 

Relative Heights - These height values 
are measured from surfaces within the 

selected room or the room below. 
• Specify the Rough Ceiling height, as 

measured from the subfloor surface to the 
bottom of the ceiling framing. Not avail-
able if multiple floor heights are specified 
directly above the selected room.

• Specify the Finished Ceiling height, as 
measured from the finished floor surface 
to the finished ceiling surface. Not avail-
able if multiple floor heights are specified 
directly above the selected room.

• Specify the distance from the Stem Wall 
Top to Ceiling. Only available when 
Floor for this Room is Supplied by the 
Foundation ‘Room’ from the Floor 
Below has been checked.

• Specify the Ceiling Below height, which 
is the height of the ceiling of the room 
below, as measured from that room’s sub-
floor to rough ceiling surfaces. Not avail-
able when Auto Rebuild Foundation is 
enabled or if there is no room below the 
selected room. See “Rebuilding Founda-
tions” on page 210.

• Specify the Stem Wall height, which is 
measured from the bottom of the room’s 
floor framing to the top of the foundation 
wall footing and including a treated sill 
plate, if one is specified. Only available if 
the selected room or the room below it is 
defined by foundation walls.

A cross section diagram showing the 
relationship between the various height 

settings displays here for reference. 

Specify the characteristics of the 
room’s Ceiling. 

• If Roof Over This Room is checked, a 
roof automatically generates over the 
room. If unchecked, no roof generates.

• If Ceiling Over This Room is checked, 
the room has a flat ceiling. If unchecked, 
the ceiling follows the underside of the 
roof.

• Check Use Soffit Surface for Ceiling to 
improve the 3D appearance of the transi-
tion between ceiling and eaves of exterior 
rooms with Ceiling Over This Room 
unchecked. 

• The thickness of the Ceiling Structure 
displays here for reference but cannot be 
changed. 

• Specify the thickness of the Ceiling Fin-
ish layer. 

Specify the thickness of the Floor Fin-
ish layer. 

• The thickness of the Floor Structure dis-
plays here for reference but cannot be 
changed. 

Moldings Panel
Chair rail, crown and base moldings can be 
assigned to a selected room on the Moldings 

panel. Moldings are placed around the wall 
surfaces of a room and continue around the 

2
3

4

5
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surface of any soffit that is attached to the 
wall at the molding height.

The settings on this panel are also similar to 
those found in the Floor Defaults dialog, but 
affect only the selected room instead of all 
rooms on the current floor. 

Uncheck Use Room Default to enable 
the settings that follow. When checked, 

the room uses the default moldings set in the 
Floor Defaults dialog. See “Floor Defaults 
Dialog” on page 200. 

Specify the Molding Profiles assigned 
to the selected room. The Default Base 

Molding is a basic rectangular stock profile 
rather than a profile from the library.
• The Selected Molding displays at the top 

of the drop-down list. Click the arrow to 
see all moldings currently applied to the 
selected room. 

• Click the Add New button to open the 
Select Library Object dialog and select a 
new molding profile to apply to the room. 
See “Select Library Object Dialog” on 
page 356.

• Click the Replace button to replace the 
currently selected molding with a 
different molding profile. 

• Click the Delete button to remove the 
currently selected molding from the room. 

Selected Molding Specification - 
Make changes to the currently selected 

molding. 

1

2

3
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• Specify the Height and Width of the 
currently selected molding. 

• When Retain Aspect Ratio is checked, if 
you change either the Height or Width, 
the other value changes to maintain their 
original ratio. When this is unchecked, the 
two values can be edited independently.

• Select the currently selected molding’s 
Type from the drop-down list: Base, 
Chair Rail, or Base Molding.

Selected Profile Offset - Specify the 
distance of the selected molding From 

Floor and select whether this distance is 
measured To Top or To Bottom of the 
molding profile.

Fill Style Panel
The settings on this panel affect the 
appearance of the room in floor plan view. 
This panel is also found in the Floor 
Defaults dialog. For more information, see 
“Fill Style Panel” on page 439.

Materials Panel
The settings on this panel affect the 
appearance of a selected room’s walls, floor, 
ceiling and moldings in 3D views. See 
“Materials Panel” on page 364. 

Default molding and ceiling and floor 
covering materials can be set in the Floor 
Defaults dialogs.

4
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Chapter 10:

Doors

Home Designer Suite comes with tools for 
creating a wide variety of interior and 
exterior doors. In addition, the library offers 
a large selection of specialty doors and 
doorways including hinged, sliding, pocket, 
bifold, and garage doors. Additional name-
brand door catalogs are also available for 
download from our web site,  
www.HomeDesignerSoftware.com.

Chapter Contents
•      Door Defaults
•      The Door Tools
•      Displaying Doors
•      Editing Doors
•      Changing Door Swings
•      Special Doors
•      Door Specification Dialog

Door Defaults
Default Settings are accessed by 
selecting Edit> Default Settings. 

Click the “+” next to Doors to show the door 
sub-headings. Select a subheading and click 
the Edit button to open the defaults dialog 
associated with your selection: 

The values in the Door Defaults dialog are 
initial values for interior or exterior doors. 
Individual doors can be edited after they are 
created. 

The Door Defaults dialogs look nearly the 
same as the Door Specification dialog. See 

“Door Specification Dialog” on page 170. 
There are only a couple of differences: 
• Since default settings are specified here, 

“Use Default” is not an option for some 
settings as it is in the Door Specification 
dialog.

• The Door Type cannot be changed in the 
Defaults dialogs.
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The Door Tools
To place a door, select the type you 
want from the Build> Door submenu. 

With a Door Tool active, move your mouse 
pointer over a wall section. If there is room 
enough along the wall to fit a 12” (300 mm) 
wide door, a preview of the door will display. 
When a preview can be seen, click on a wall 
to place a door in the wall at that location.

Hinged and Sliding Doors have both Interior 
and Exterior Door Defaults. If the wall is an 
exterior wall or one that separates an interior 
from an exterior room, the program places an 
exterior door based on the default settings for 
exterior doors. If the wall is an interior wall, 
the program places an interior door based on 
the default settings for interior doors. This 
rule applies to doors copied and pasted from 
one location to another just as it does to 
newly placed doors. See “Door Defaults” on 
page 161.

Once placed, any door may be changed into 
any other type of door using the Door 
Specification dialog. See “Door 
Specification Dialog” on page 170.

Hinged Doors
Select Build> Door> Hinged Door 
and click a wall where you want to 

place a hinged door. Hinged doors can be 
placed on interior or exterior walls, and can 
be set up so that different door styles are 
placed in each. A hinged door becomes a 
double door when its width is four feet or 
greater. 

The initial swing direction of a hinged door 
depends on the location of the mouse pointer 

relative to the wall when you click. The door 
will swing towards the side of the wall that 
you click nearest. 

The initial hinge side of a hinged door can be 
set by clicking to place the door and then 
holding the mouse button down rather than 
releasing it. Move the mouse toward the end 
of the door that you would like the hinges to 
be on: as the mouse pointer nears either end, 
the door preview’s hinge side will move to 
that end. You can also adjust the door’s 
swing direction in this manner. When the 
swing direction and hinge side are correct, 
release the mouse button.

Doorways
Choose Build> Door>  Doorway and 
click a wall to place a doorway (an 

opening without a door). Doorways can be 
placed on interior or exterior walls, or in 
railings and fences to provide an opening. 
You can assign a door from the library to a 
doorway.

Sliding Doors
Select Build> Door> Sliding Door 
and click a wall where you want to 

place a sliding door. Sliding doors can be 
placed on interior or exterior walls and can 
be set up so that different door styles are 
placed in each. If placed in an exterior wall, 
the door is glass; if placed in an interior wall, 
it is a solid slab.

The initial opening side of a sliding door can 
be specified by moving the mouse pointer 
along the wall while the mouse button is still 
pressed.  
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The default sliding door dimensions are 
5’-0” x 6’-8” with a 12” bottom frame and a 
6” frame on the sides and top. 

Pocket Doors
Select Build> Door> Pocket Door  
and click a wall where you want to 

place a pocket door.

As with sliding doors, the initial opening side 
of a pocket door can be specified by moving 
the mouse pointer along the wall while the 
mouse button is still pressed.  

The default pocket door dimensions are 2’-6” 
x 6’-8” high. A pocket door becomes a 
double pocket door if its width is four feet or 
greater. 

Bifold Doors
Choose Build> Door> Bifold Door 
and click a wall where you want to 

place a bifold door.

Like a hinged door, the initial opening side of 
a bifold door depends on the location of the 
mouse pointer relative to the wall when you 
click. The door will open towards the side of 
the wall that you click nearest. 

Similarly, the initial hinge side of a sliding 
door can be specified by moving the mouse 
pointer along the wall while the mouse 
button is still pressed.  

The default interior single bifold door is 2’-
6” x 6’-8”. A bifold door becomes a double 
bifold if its width is greater than three feet.

Bifold doors always display closed in all 3D 
views.

Garage Doors
Choose Build> Door> Garage Door 
and click a wall to place a garage 

door.

The default garage door is 8’-0” x 7’-0” high. 
A garage door must be at least two feet wide.

In floor plan view, dashed lines show the size 
and location of the garage door when open.

Garage doors will build into a garage stem 
wall provided the room is designated as a 
garage before the door is inserted. See 
“Room Types” on page 147.

The Doors & Doorways 
Library Catalog

The Doors & Doorways library 
catalog can be accessed by selecting 

View> Library Browser and browsing to 
Home Designer Core Catalogs> 
Architectural. This catalog contains a variety 
of interior and exterior doors, as well as 
special entryways and wrapped openings. 

Entryways and wrapped openings are 
examples of Doorways, which are wall 
openings that do not have doors within them.

To add a door to the Doorway, select a Door 
Type other than “Doorway” from the drop-
down list in the Door Specification dialog. 
See “General Panel” on page 171. 
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You can also select a custom door from the 
library and place it into a doorway in floor 
plan view or any 3D view.

To place a library door in a doorway

1. Go to floor plan view or any 3D view. 
2. Open the Library Browser. 

3. Browse or search to find a custom door 
style that suits your needs. 

4. Select the door in the Library Browser, 
then click on the doorway to place the 
selected door within it. If a door already 
exists, it is replaced. 

5. Continue clicking other doorways as 
needed.

Displaying Doors
The display of doors and door labels is 
controlled in the Display Options 

dialog. See “Display Options Dialog” on 
page 75. 

Doors can only be placed in walls, so if a 
wall’s layer is turned off, any doors placed in 
that wall will not display, either. See 
“Displaying Walls” on page 125. 

If the “Doors” layer is turned off, doors and 
their casing do not display but openings in 
the walls where they are located are visible.

In Floor Plan View
A door’s jamb, and swing are all represented 
in floor plan view. Doors in exterior walls 
and doors that open to exterior type rooms 
such as a Garage, Porch, or Deck have a 
threshold line across the opening in floor 
plan view. See “Room Types” on page 147.

You can specify whether an exterior door has 
a threshold in the Door Specification dialog. 
See “Casing Panel” on page 173.

If an exterior door to a Garage room on Floor 
1 extends into a Garage stem wall or curb on 
Floor 0, its location will be indicated on 
Floor 0. See “Garages” on page 211. 

In 3D Views
You can specify whether a selected door is 
shown open or closed in 3D views by 

clicking the Show Door Open in 3D  and 

Show Door Closed in 3D  edit buttons as 
well as in the Door Specification dialog. 
See“General Panel” on page 171.

If a door is set to display open in 3D, the 
angle of the open door can be changed using 

Threshold
Line
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the edit handles in floor plan view. See 
“Using the Mouse” on page 165.

Door Labels
Door labels display in floor plan view, 
centered on the doors they represent, when 
the “Doors, Labels” layer is turned on and 
use the “Default Label Style” Text Style. See 
“Object Labels” on page 429.

Door labels indicate Width and Height. For 
example: 
• In Imperial plans, the label for a 3’-0” 

wide, 6’-8” high double hung window 
will read 3068.

• In metric plans, the label for a 900 mm 
wide, 2100 mm high double hung window 
will read 900x2100.

Editing Doors
Before a door can be edited, it must be 
selected. To select a door, click it when the 

Select Objects  tool or any of the Door 
Tools  are active. Doors and/or windows 
can also be group selected and edited. See 
“Selecting Objects” on page 86. 

Blocked units are made up of individual 
doors and windows that have been grouped 
together to act as one object. You can create 
what is essentially a blocked door unit by 
assigning a library door to a doorway from 
the library

Select a blocked unit by clicking on it in any 
view. To select a door that is a component of 
a blocked unit, click at the location of the 
component in question, then click the Select 
Next Object  edit button. See “Selecting 
Objects” on page 86.

In the Specification Dialog
The most precise method of editing a 
door is to use the Door Specification 

dialog. Door type, size, casing, materials, 
and more can all be specified in this dialog. 

See “Door Specification Dialog” on page 
170. 

Using the Mouse
In floor plan view, click either of the two end 
handles and drag along the wall to change the 
width. The label showing the size updates as 
the handles are dragged. Click and drag the 
Move handle at the center to move the door 
along the wall it is placed in. Use the 
triangular Rotate handle to adjust the door’s 
swing.  If the door’s label displays, an 
additional handle is available to move the 
label.

In 3D views, a selected door has five edit 
handles: the Move handle at the center and a 
Resize handle on each edge.  Click and drag 
an edge handle to resize the door.  

A door or window moved against an 
intersecting wall temporarily stops when the 
casing meets the intersecting wall. You can 
continue to drag and it resumes movement 
past the intersecting wall. 
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Using the Edit Tools
A selected door or doors can be edited in a 
variety of ways using the buttons on the edit 
toolbar. See “The Edit Toolbar” on page 26.
• Click the Change Opening/Hinge Side 

 edit button to change the side of the 
door that its hinges are on. See “Changing 
Door Swings” on page 166.

• Click the Change Swing Side  edit 
button to change which direction the 
selected door swings. 

• Click the Show Door Open in 3D  or 

Show Door Closed in 3D  edit button 
to control the selected door’s appearance 
in 3D views. See “In 3D Views” on page 
164.

• Click the Gable Over Door/Window  
to create a gable over the selected door(s) 
the next time the roof is rebuilt. See 

“Gable Over Door/Window” on page 
224. 

Centering Doors
The Center Object edit button allows 
you to center a selected door along a 

wall within a room or relative to a cabinet or 
window. See “Using Center Object” on page 
107.

To center a door along a wall 

1. Select a door or combination of win-
dows and doors in floor plan view. 

2. Click the Center Object  edit button 
then choose from one of the following 
options: 

•  Click near a wall inside a room to cen-
ter the door along that wall in that 
room.

•  Click outside the house (on the exterior 
room) near an exterior wall to center 
the door along an exterior wall.

Changing Door Swings
Door swing direction and hinge 
side can be changed using the 

Change Opening/Hinge Side and Change 
Swing Side edit buttons.

The Change Opening/Hinge Side  edit 
button is available for all doors except 
double doors and garage doors.

The Change Swing Side  edit button is 
available for all doors except pocket doors. 

Hinged Doors
In addition to using the edit buttons, hinged 
doors’ hinge side and swing direction can be 
changed using the triangular Rotate edit 
handle.

To adjust the angle of swing:

1. In floor plan view, select the door and 
grab the triangular handle.

2. Drag to change the amount of swing. 
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3. Release the mouse. 

If you drag near the closed position, the door 
snaps to a closed position.

To change the swing using edit handles:

1. In floor plan view, select the door and 
grab the triangular edit handle.

2. Drag the pointer along the path of the 
new arc to change the hinge side and/or 
swing direction.

3. Release the mouse.

To change the swing using edit buttons:

1. In floor plan view, select the door.

2. To change the hinge side, click the 

Change Opening/Hinge Side  edit 
button.

3. To change the swing direction, click the 
Change Swing Side  edit button.

Sliding Doors
To change the side of a sliding door that is 
fixed, select the sliding door then click the 

Change Opening/Hinge Side  edit 
button.
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To flip the fixed and moving sides of the 

door, click the Change Swing Side  edit 
button.

As with hinged doors, you can also change 
the Opening/Hinge and Swing sides of a 
sliding door by clicking and dragging the 
triangular edit handle.

Pocket Doors
To change the direction of a pocket door, 
select it and click the Change Opening/
Hinge Side  edit button.

As with hinged doors, you can also change 
the Opening/Hinge side of a pocket door by 

clicking and dragging the triangular edit 
handle.

Bifold Doors
To change the side of a bifold door that is 
fixed, select it then click the Change 
Opening/Hinge Side  edit button.

To change the hinged side of the door, click 

the Change Swing Side  edit button.

As with hinged doors, you can also change 
the Opening/Hinge and Swing sides of a 
bifold door by clicking and dragging the 
triangular edit handle.

Garage Doors
To change the side of a garage door that it 
faces, select it and click the Change Swing 
Side  edit button.

Note: There must be enough room for the
entire door to fit in the opposite wall or the
door does not change.
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As with other door types, you can also 
change the Swing side of a bifold door by 
clicking and dragging the triangular edit 
handle. 

Special Doors
A variety of special doors and doorways can 
be created in Home Designer Suite.

Wrapped Openings
Wrapped openings of various shapes are 
available in the Doors & Doorways 
Library. 

You can also create a wrapped opening by 
unchecking Use Interior Casing and/or  Use 
Exterior Casing in a Doorway’s Door 
Specification dialog. See “Casing Panel” on 
page 173. If base molding is present, it will 
wrap around the opening. 

Openings in Railings

Use the Doorway  tool to open a railing 
for a stairway or other access. 

To open a railing across an entire section, 
resize the doorway’s Width so that it is 
greater than the length of the railing in the 
Door Specification dialog. The opening 
resizes to the maximum width possible for 
that space. See “General Panel” on page 171.

To add a gate, specify the doorway’s Door 
Type as a Door, then choose an appropriate 
gate as the Door Style. A selection of gates is 
available in the Fences & Railings library 
folder. See “Placing Library Objects” on 
page 354. 

Doorway
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Transoms Above Doors
Transom windows above doors are created 
the same as other stacked windows. See 
“Grouped Windows” on page 181.

Creating a Doorway 
with a Railing

When a railing is specified as No Room Def, 
it can be positioned within a Doorway .

To create a doorway with railing

1. Place a Doorway  at the desired loca-
tion in your plan.

2. Select Build> Wall> Straight 
Railing , then click and drag to draw 
a railing parallel to the wall with the 
doorway. 

3. Select the railing, then use the Resize 
edit handles to adjust the length of the 

railing as needed. See “Using the Edit 
Handles” on page 88.

4. With the railing selected, click the Open 
Object  edit button.

5. On the General panel of the Railing 
Specification dialog, check No Room 
Def and click OK. See “General Panel” 
on page 135.

6. With the railing still selected, Ctrl + drag 
it into position within the doorway. See 
“To move an object freely” on page 106.

Placing a Gable Over a Door
Click the Gable Over Door/Window 
edit button to produce a gable roof 

over the selected door(s) the next time 
automatic roofs are built. See “Gable Over 
Door/Window” on page 224.

You can manually edit or delete this gable 
line at any time. Your changes take effect 
when the automatic roofs are rebuilt. This 
can also be used with group selected doors.

Door Specification Dialog
To open the Interior or Exterior Door 
Specification dialog, select a door 

and click the Open Object edit button or 

double-click on a door using the Select 
Objects  or any Door  tool.

Positioning a railing in a doorway
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General Panel

General 

• Door Style - Select Slab, Glass, Panel, or 
Louvered from the drop-down list; select 
a style from the Library; or choose Use 
Default to use the default door style set in 
the Door Defaults dialog. See “Door 
Defaults” on page 161.

• Select “Library” from the drop-down list 
or click the Library button to choose a 
door symbol from the library. Once a 
library door is selected, its name is added 
to the Door Style list. See “Select Library 
Object Dialog” on page 356.

• Specify the Door Type as Doorway, 
Hinged, Slider, Pocket, Bifold, or Garage. 
In the Door Defaults dialogs, the Door 
Type cannot be changed. 

Specify the Size and Position of the 
selected door. 

• Specify the Width, Height, and Thick-
ness of the door. 

• Floor to Bottom - Specify the height of 
the bottom of the door frame as measured 
from the subfloor. 

Panel Frame Options - Specify the 
dimensions of the selected door’s rails 

and stiles. Only available for Glass, Panel, 
and Louvered doors. 
• Specify the Width of the stiles and top 

rail. 
• Specify the height of the Bottom rail.

The Interior Doors settings are only 
available when the selected door is 

placed in an interior wall. See “Exterior and 
Interior Walls” on page 119.
• Check Separate Trim and Materials for 

Each Side to specify the casing, lintels, 
and all materials for each side of the 

1

2

3

4
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selected door independently. When 
unchecked, the two sides of the door use 
the same trim and materials. 

A preview of the door displays on the 
right side of the dialog box. See 

“Dialog Preview Panes” on page 29.

Options Panel

Specify the number of Door Units or 
panels that the selected door has. Not 

available for garage doors. 
• Select Calculate From Width to use the 

program defaults. Hinged, Pocket and 
Bifold doors default to Single Door when 
less than four feet (1200 mm) wide. If the 
width is greater than four feet, Double 
Door is the default. 

• Select Single Door to force the selected 
hinged, pocket or bifold door to be a sin-
gle door, regardless of its width.

• Select Double Door to force the selected 
hinged, pocket or bifold door to be a dou-
ble door, regardless of its width.

• If a Slider door is selected, instead choose 
Two, Three, or Four Panel.

3D Display - Specify whether the 
selected door is drawn open or closed in 

3D and Elevation views. 

If Draw Open is selected, the Swing Angle 
set on the General panel is used in 3D views. 
See “General Panel” on page 171.

5

1

Note: The defaults for Calculate From Width
are not editable.

2
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Casing Panel

Check Use Interior Casing, then 
specify the Width of the casing.

Check Use Exterior Casing, then 
specify the Width of the casing.

Uncheck Use Sill/Threshold to prevent 
a sill from being generated under the 

door. See “Displaying Doors” on page 164. 

A preview of the door displays on the 
right side of the dialog box. If casing is 

not specified for a Doorway, the Show Wall 
option will be toggled on automatically. See 
“Dialog Preview Panes” on page 29.

Lites Panel
The settings on the Lites panel of the Door 
Specification dialogs are only available 
when the selected door is specified as a Glass 
door on the General Panel. These settings are 

also found on the Lites panel of the Window 
Specification dialog. See “Lites Panel” on 
page 187.

Arch Panel
The settings on the Arch panel are not 
available if the selected door is a Sliding, 
Bifold or Garage door.

1

2

3

4
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Define the style and size of the Arch. 

• Select a Type of arch from the drop-down 
list.

• Specify the Height of the arch, as mea-
sured from the base of the arch to the top 

of the door. Not available for Round Top 
Arches.

A preview of the door displays on the 
right side of the dialog box. See 

“Dialog Preview Panes” on page 29.

Hardware Panel
Many of the settings on the Hardware tab are 
Dynamic Defaults: if “Use Default” is 
selected, the setting in the Door Defaults 

dialog is used. See “Dynamic Defaults” on 
page 57.

1

2
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Specify the Handles to be used on the 
selected door. 

• Select an Interior Handle and/or Exte-
rior Handle from the drop-down lists. 

• Specify the location of the door handles  
In From Door Edge.

• Specify the location of the door handles 
Up From Bottom.

Specify the door’s interior and exterior 
Locks. 

• Select an Interior Lock and/or Exterior 
Lock from the drop-down lists.  

• Specify the location of the door locks Up 
From Bottom. The locks use the same In 
From Door Edge value as the handles.

Specify the Hinges to be used on the 
selected door.

• Select a style of Hinges from the drop-
down list.  

• Specify the distance In From Top/Bot-
tom of the door to the center of the top 
and bottom hinges. 

• Specify the Number of Hinges on the 
selected door. Interior hinged doors and 
bifold doors typically have two hinges 
while exterior hinged doors have three.

A preview of the door displays on the 
right side of the dialog box. See 

“Dialog Preview Panes” on page 29.

Materials Panel
The Materials panel is available for a variety 
of objects throughout the program. For more 
information, see “Materials Panel” on page 
364.

1

2

3

Note: For hinges to look right, it is best to
have at least a 1/4" (6 mm) reveal for the inte-
rior, or hinge side, door casing. 

4
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Label Panel
Door labels display in floor plan view when 
the “Doors, Labels” is turned on and use the 
Text Style assigned to that layer. See “Door 
Labels” on page 165. 

For information about the settings on this 
panel, see “Label Panel” on page 429.
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Chapter 11:

Windows

Home Designer Suite can model a wide 
variety of windows. Fixed glass, hung, 
casement, sliding, awning, hopper, and 
louver window styles can all be created with 
the standard Window tool. Home Designer 
Suite can create bay, box, and bow windows 
with a single click. In addition, the library 
contains many mulled window 
combinations. 

Chapter Contents
•      Window Defaults
•      The Window Tools
•      Special Windows
•      Grouped Windows
•      Displaying Windows
•      Editing Windows
•      Window Specification Dialog
•      Bay, Box, and Bow Windows
•      Bay, Box, Bow Windows and Roofs
•      Bay/Box and Bow Window 

Specification Dialogs
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Window Defaults
Default Settings can be accessed by 
selecting Edit> Default Settings. 

Select Window from the Default Settings 
dialog.

The settings in the Window Defaults dialog 
control the attributes of a window when it is 
initially placed in a plan, so you should 
define the type of window that will be placed 
most often in your model. See “Default 
Settings vs Preferences” on page 56.

The panels in the Window Defaults dialog 
are similar to those found in the Window 

Specification dialog. For more information, 
see “Window Specification Dialog” on page 
184.

Dynamic Window Defaults
A variety of window default values are 
dynamic, including the Window Type, 
Casing Specifications, and Sash sizes. All 
Materials are also dynamic. When a 
dynamic default is changed, existing 
windows using the default value are affected. 
See “Dynamic Defaults” on page 57. 

The Window Tools
To place a window, select Build> 
Window and choose the desired 

window type. Click on a wall to place a 
window of the selected type at that location. 
Bay, box and bow windows can only be 
placed in straight walls, while standard 
windows can be placed in both straight and 
curved walls. 

Standard Windows
Select Build> Window> Window, 
then click on a straight or curved wall 

to place a standard window at that location.

A standard window is a single window that is 
not a bay, box, or bow window. These 
special types are made up of multiple 
standard windows. 

A standard window that is part of a special 
window is called a component window.

Standard windows can be specified as any of 
a variety of window types, such as double 
hung, casement and awning. See “Window 
Specification Dialog” on page 184.

Bay Windows

A Bay Window is composed of three 
wall sections, each with a single 

component window. The two side walls are 
at an angle to the main wall. Select Build> 
Window> Bay Window and click on a 
straight wall to produce a bay window. 

When initially placed, bay windows measure  
2’-2” across at the front, 4’-2” across at the 
back, and are 1’-0” deep. The component 
windows are specified in the Window 

The roof is affected by Bay, Box and
Bow Windows. These windows should

therefore be placed before the roof is built.
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Defaults dialog and their sizes adjust to fit 
the available space. 

Box Windows
A Box Window is a bay window with 
side angles set at 90°. Select Build> 

Window> Box Window and click on a 
straight wall to produce a box window. 

Box windows initially measure 4’-2” wide 
with a depth of 1’-6”. The component 
windows are specified in the Window 
Defaults dialog and their sizes adjust to fit 
the available space. 

Bow Windows
A Bow Window is a group of 
identical wall segments that form a 

segmented curve. Select Build> Window> 
Bow Window and click on a straight wall to 
produce a 5-section bow window. 

The component windows are specified in the 
Window Defaults dialog. Their sizes adjust 
to fit the available space.

The 5-section bow below has a 4’-10” radius 
centered 3’-9” inside the wall, giving an 
opening 5’-10” across and a depth of 11½”.

Pass-Through
Select Build> Window> Pass-
Through, then click on a straight or 

curved wall to place a Pass Through at that 
location. 

A Pass-Through is simply a wall opening 
without a window unit placed inside. Like a 
window, it can have casing and a sill. It does 
not, however, have a sash, frame, or glass. It 
is one of the window Types available in the 
Window Specification dialog. See “General 
Panel” on page 185.

Windows Library
Select View> Library Browser, then 
browse to Home Designer Core 

Catalogs> Architectural> Windows to access 
a selection of special window units. Select 
the desired window, then click on a wall to 
place the window at that location. 

Note: Bay, box, and bow window areas are
not included in the living area or in room stan-
dard area calculations. They are included in
room interior area calculations.

home-designer-suite-2015-reference-manual.book  Page 179  Thursday, May 29, 2014  4:26 PM



180

Home Designer Suite  2015 Reference Manual

Special Windows
A variety of special windows can be created 
using multiple standard windows, the edit 
tools or custom symbols.

Creating Manual Bay, Box 
and Bow Windows

Sometimes it is easier to draw bay, box and 
bow windows manually than to use the 
automatic tools. Bays created using walls can 
have more than one window per section, 
which is not possible using a bay window 
unit.

Bear in mind that moving a manually created 
bay, box or bow window is generally more 
difficult than moving a unit created with one 

of the Window Tools  since it is 
composed of individual walls.

Corner Windows
Corner windows are produced when each  
window has one edge at or past the interior 
side of the adjacent wall.

To create a corner window, first create the 
desired window on each side of the corner. 
The header height and the sill height of both 
windows must be the same. 

Once the corner window is formed, its 
components and corner post size can be 
adjusted. Blocked units can also meet at a 
corner this way.

Special Window Shapes
A selection of special shaped windows is 
available in the Windows Library, including 
arched windows and mulled units. 

In addition, you can create a variety of 
window shapes in the Window Specification 
dialog, including:
• Arched windows. See “Arch Panel” on 

page 190.
• Trapezoidal windows. See “Shape Panel” 

on page 189.

Placing a Gable 
Over a Window

Click the Gable Over Door/Window 
edit button to produce a gable roof 

over the selected window(s) the next time 
automatic roofs are built. See “Gable Over 
Door/Window” on page 224.

You can manually edit or delete this gable 
line at any time. Your changes take effect 
when the automatic roofs are rebuilt. This 
tool can also be used with group selected 
windows.

To move a window all the way into a
corner, check Ignore Casing for Open-

ing Resize in the Plan Defaults dialog. See
“General Plan Defaults Dialog” on page 57.
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Vents
A selection of attic, foundation and gable 
vents are available in the Library Browser. 
See “The Library” on page 341.

Vents are placed in the same manner as 
regular windows and can be edited in much 
the same way, as well. 

Grouped Windows
Windows can be grouped together to create a 
wide variety of custom configurations. 
Stacked windows are easy to create in 3D 
views, particularly Elevation views, using 
their edit handles. See “Editing Windows” on 
page 183.

Notice how the windows and door in this 
example are separate, with spaces between 
them. Doors and/or windows can also be 
organized into a unit in which there are no 
spaces between the windows and door units, 
and the casing between them is shared. 

Automatically Mulled Openings
To form a mulled group of windows and/or 
doors, move them close enough together so 
that their casings touch. Once the casings 
touch, the windows are mulled together with 
one casing between the two of them. 

The sill of each window in the group must be 
at the same level for them to share the middle 

casing. The casing tops do not have to be at 
the same level. The casings are modeled as if 
they are one unit but the windows  remain 
separate objects for dimensioning and the 
Materials List.

Windows can be automatically mulled to 
doors if the bottom of the window is at the 
elevation of the floor, equal to the bottom of 
the door. 

Mulled Units in the Library
A selection of mulled window units is 
available in the Windows library. To place 
one in your plan, select it and click on a wall 
in any view. See “Placing Library Objects” 
on page 354.

Selecting Components 
of Mulled Units

To select a component of a mulled unit from 
the library, click at the location of the com-
ponent in question, then click the Select 
Next Object  edit button or press the Tab 
key until that individual component is 
selected. Only the component clicked on is 
selectable using this method. If you need to 
select a different component, click on it and 
repeat the process.

If there are multiple levels, it is easiest to 
select the components in a 3D view. When 
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you have selected an individual component, 
you can change its parameters in the Window 
Specification dialog. See “Window 
Specification Dialog” on page 184.

If the selected component is not itself a 
mulled unit and has no components above it, 
its Height and Arch parameters can be 
changed. Changing the Height causes the 
component top to move. The bottom remains 
stationary.

Displaying Mulled Units
As with other windows, the display of 
mulled window units is controlled in 

the Display Options dialog. See “Displaying 
Objects” on page 74.

Mulled units are placed on the “Windows” 
layer by default and have a single label, 
which is on the “Windows, Labels” layer. 
Mulled units from the library are also 
included in the windows category of the 
Materials List. If the component objects of a 
mulled unit have unique moldings or 
materials, they will not be noted in the 
Materials List.

Displaying Windows
The display of windows in floor plan 
and 3D views can be controlled in the 

Display Options dialog. See “Display 
Options Dialog” on page 75.

Windows can only be placed in walls, so if a 
wall’s layer is turned off, any windows 
placed in that wall will not display, either. 
See “Displaying Walls” on page 125. 

If the “Windows” layer is not set to display, 
window casing and other components are not 
visible, but the openings in the walls where 
they are located can still be seen.

In Floor Plan View
A window’s frame, glass, and sill are all 
represented in floor plan view. This makes 
some window types, notably Sliding and 
Double and Triple Casement windows, 
distinguishable. 

Bay, box,and bow windows have dimensions 
lines associated with them. 
• You can suppress their display by turning 

off the “Manual Dimensions” layer or on 
a unit by unit basis in the unit’s specifica-
tion dialog. See “Bay/Box and Bow Win-
dow Specification Dialogs” on page 196. 

Double Hung

Left Sliding

Triple Casement
Window types in floor plan view
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• The arrow style and fill are set in the 
Dimension Defaults dialog. See 
“Dimension Defaults Dialog” on page 
405.

Window Labels
Window labels display in floor plan view, 
centered on the windows they represent, 
when the “Windows, Labels” layer is turned 
on and use the “Default Label Style” Text 
Style See “Object Labels” on page 429.

Window labels indicate Width and Height, 
followed by Type. For example: 
• In Imperial plans, the automatic label for 

a 3’-0” wide, 4’-0” high double hung 
window will read 3040 DH.

• In metric plans, the automatic label for a 
900 mm wide, 1200 mm high double 
hung window will read 900x1200 DH.

You can specify whether a Bay, Box or Bow 
Window displays a single label or displays 
the labels of its component windows.
• When Suppress All Labels is selected, 

individual components of Bay, Box and 
Bow Windows are counted in the Materi-
als List. 

• When Show Component Labels is 
selected, components of Bay, Box and 
Bow Windows are counted in the Materi-
als List.

• When Show Single Label for Entire 
Unit is selected, the Bay, Box or Bow 
Windows has one label in floor plan view 
but each component is counted separately 
in the materials list. 

These options are also available for mulled 
units but affect their display the materials list 
somewhat differently. See “Displaying 
Mulled Units” on page 182. 

Customized labels can also be specified in 
the Window Specification dialog. 

Editing Windows
Before a window can be edited, it must be 
selected. Click on a window when the Select 
Objects  tool or any of the Window 
Tools  are active. Doors and/or windows 
can also be group-selected and edited. See 
“Selecting Objects” on page 86.

To select a window that is part of a blocked 
unit, click the component window, then click 

the Select Next Object  edit button. See 
“Selecting Components of Mulled Units” on 
page 181.

Windows can be edited using their edit 
handles, the edit toolbar buttons, and the 
Window Specification dialog. See “Window 
Specification Dialog” on page 184.

When you select a window in floor plan 
view, the window size label displays the 
width followed by the height. For example, a 
3036 window is 3’-0” wide by 3’-6” high. 

In the Specification Dialog
The most precise method of editing a 
window is to use the Window 

Specification dialog. The window type, size, 
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casing, materials, and more can all be 
specified in this dialog. See “Window 
Specification Dialog” on page 184.

Using the Mouse
• In floor plan view, click either of the two 

end handles and drag along the wall to 
change the width. The label showing the 
size updates as the window is resized. 

• In 3D views, a selected window has five 
edit handles: the Move handle at the cen-
ter and a Resize handle on each edge. 
Click and drag an edge handle to resize 
the window.

• A single window or a group of windows 
can be moved with the center edit handle.

• A door or window moved against an 
intersecting wall temporarily stops when 
it is the casing distance from the inter-
secting wall. You can continue to drag 
and it resumes movement past or onto the 
intersecting wall. Enable Ignore Casing 
for Opening Resize in the Plan Defaults 
dialog to turn off this behavior. See “Gen-
eral Plan Defaults Dialog” on page 57.

Using the Edit Tools
A selected window or windows can be edited 
in a variety of ways using the buttons on the 
edit toolbar. See “The Edit Toolbar” on page 
26.

• Click the Gable Over Door/Window  
to create a gable over the selected win-
dow(s) the next time the roof is rebuilt. 
See “Gable Over Door/Window” on page 
224. 

Window Specification Dialog
To open the Window Specification 
dialog, select a window and click the 

Open Object edit button; or double-click the 

window using the Select Objects  or a 

Window  tool. 

The settings in this dialog are similar to those 
in the Window Defaults dialog. See 
“Window Defaults” on page 178.

The settings in this dialog are also similar to 
those in the Mulled Unit and Window 
Symbol Specification dialogs. Although 
similar, a number of the options cannot be 
edited when either a window symbol or a 
mulled unit from the library is selected, and 
some panels are not available. See “Grouped 
Windows” on page 181.

Note: Using the edit handles is the only way
to resize bay, box and bow window units.
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General Panel

Window Type - Select the type of 
window from the list. The first entry in 

the list is the Default type set in the Window 
Defaults dialog. 

Specify the Size and Position of the 
selected window. 

• Specify the window’s Width and Height. 
• Floor to Top - Specify the height of the 

top of the window frame as measured 
from the subfloor. 

• Floor to Bottom - Specify the height of 
the bottom of the window frame as mea-
sured from the subfloor. 

• Specify the Bottom Component Size for 
Single Hung, Double Hung, Double 
Awning, Double Hopper, and Triple Hop-
per windows; specify the Top/Bottom 

Component Size for Triple Awning win-
dows; or, 

• Specify the Side Component Size for 
Triple Casement and Triple Sliding win-
dows, the Right Component Size for 
Left Sliding windows, or the Left Com-
ponent Size for Right Sliding and Dou-
ble Casement windows.

A Component Size value of 0 creates  a 
window with identically sized components. 

The Interior Windows settings are 
only present when the selected window 

is placed in an interior wall. See “Exterior 
and Interior Walls” on page 119. 
• Check Separate Trim and Materials for 

Each Side to specify the casing and all 
materials for each side of the selected 
window independently. When 
unchecked, the two sides of the window 
use the same trim and materials. Only 
available for Pass-Throughs placed in 
interior walls.

Note: When either the Floor to Top or Floor
to Bottom setting is modified, the other will
adjust in response to prevent the overall
Height value from changing.

1
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3
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A preview of the selected window 
displays here. See “Dialog Preview 

Panes” on page 29. 

Casing Panel
The Casing panel is not available in the 
Window Symbol Specification dialog.

Check Use Interior Casing, then 
specify the Width of the casing.

Check Use Exterior Casing, then 
specify the Width of the casing.

A preview of the selected window 
displays here. You may need to rotate 

the preview to see the casing you are 
editing.If casing is not specified for a Pass-
Through, the Show Wall option will be 
toggled on automatically.  See “Dialog 
Preview Panes” on page 29. 

Sash Panel
The settings on the Sash panel control the 
size and position of the selected window’s 
sash. Note that increasing the Side, Middle, 

Top or Bottom Width decreases the area of 
the glass and vice versa. 

4
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3
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Specify the width and depth of the 
selected window’s Sash, which are the 

pieces of the window that hold the glass.
• Specify the Side Width of all vertical 

sash members: those at the window sides 
as well as the central members of Case-
ment and Sliding windows. This is also 
the width of the top portion of the win-
dow when an arch is specified.

• Specify the Middle width of horizontal 
components between the top and bottom 
sash in Double Hung, Double and Triple 
Awning, and Double and Triple Hopper 

windows. It does not affect Casement and 
Sliding windows.

• Specify the Top and Bottom Widths. 
The Top value is not used if the window 
has an arch.

• Specify the Depth, or thickness, of the 
sash stock measured from the exterior to 
the interior.

A preview of the selected window 
displays here. See “Dialog Preview 

Panes” on page 29. 

Lites Panel
The Lites panel allows you to add muntins to 
various window styles, and is also available 
for Glass doors. See “Doors” on page 161. 

There are four possible styles of muntin bars.

1

2
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Specify the number, position and style 
of Lites for the selected window.

• Select a Type, or style, of window lite 
from the drop-down list. 

• Normal style is the most common, with 
muntins going horizontally and vertically. 
Colonial windows are an example of the 
normal style.

• Diamond style uses angled muntin bars 
to divide up the lites. French windows are 
an example of the diamond style.

• Prairie style is based on the normal style, 
but with all the central muntin bars 
removed, leaving only the two outside 
muntin bars both horizontally and verti-
cally. Typically, both Lites Across and 

Lites Vertical should be set between 6 
and 8. Federal or Federation windows are 
an example of the Prairie style.

• Craftsman style is based on the normal 
style, but only the topmost horizontal 
muntin bar is kept with all the portions of 
the vertical muntin bars above it. Typi-
cally, both Lites Across and Lites Vertical 
should be set between 4 and 8.

• Enter the number of horizontal Lites 
Across in each sash. 

• Enter the number of vertical Lites Verti-
cal in each sash.

• Check or uncheck Lites in Top and/or 
Lites in Bottom - or Lites in Left and/or 
Lights in Right - to specify either one or 
both of the sashes to have divided lites. 

• Check Auto Adjust Lites for Compo-
nent Size to have the program produce 
lites that are consistent in size across all 
components. When this is checked, the 
window’s lites and its specification set-
tings may not agree; when unchecked, 

1
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lites in the components may not be con-
sistent in size. 

A preview of the selected window 
displays here. See “Dialog Preview 

Panes” on page 29. 

Shape Panel
The settings on the Shape panel control the 
position of the selected window’s corners, 
allowing you to create angled edges and 
mitered top corners. 

If any of these settings are used to create a 
custom shape, the selected window will be 
automatically specified as “Fixed Glass” on 
the General panel. If the selected window has 

an arch specified on the Arch panel, it will be 
removed.

The Shape panel is not available for mulled 
units or window symbols from the library.

Window Width displays for reference. 
It can be changed on the      General 

Panel.
• Click Match Roof to match the angle of 

the top of the window to the pitch of the 

roof above by changing its Sides heights, 
below. If either Top Inside Corner box is 
checked, it will become unchecked. 

Match Roof does not work for curved 

Note: Because the fixed window in a Triple
Sliding window is twice the size of the mov-
able windows, the fixed section has a vertical
muntin bar. To eliminate this, uncheck Auto
Adjust Lites for Component Size..

2

Note: The Left and Right settings on this
panel refer to the window’s exterior.

1
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roofs, has no effect if the window is not 
in a gable end wall, and is not available in 
the Window Defaults dialog.

• Click Revert to restore the window to its 
original shape, type and arch settings. 

Specify the height of the window’s Left 
and Right Sides, as measured from the 

bottom of the window. By default, these 
settings match the window’s Height. 

A preview of the selected window 
displays here. You may want to rotate 

the view so the window’s exterior can be 
seen. See “Dialog Preview Panes” on page 
29. 

Arch Panel
The Arch panel is not available for window 
symbols from the library, and its settings are 

not available if the selected window has been 
modified using the      Shape Panel.

Define the style and size of the Arch. 

• Select the Type of arch desired from the 
drop-down list.

• Specify the Height of the arch, as mea-
sured from the top of the window to the 
base of the arch. The Height can be 
defined for all arch types except Round 
Top and Octagonal Arches.

A preview of the selected window 
displays here. You may want to rotate 

the view so the window’s exterior can be 
seen. See “Dialog Preview Panes” on page 
29.

2 Note: The Left and Right settings on this
panel refer to the window’s exterior.

3

1

Round
Top

GothicBroken

2
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Shutters Panel
The settings on the Shutters panel allow you 
to specify exterior shutters for the selected 
window or mulled unit from the library.

The Shutters panel is not available for 
window symbols from the library.

Select a Type of Shutters from the 
drop-down list. 

Specify the Size of the selected 
shutters. 

• When Match Opening Width is 
checked, each shutter’s width is exactly 
half that of the window, excluding casing.

• Uncheck Match Opening Width to 
specify a Width in the text field. If the 
window is later resized, the shutters will 
not adjust in response.

• When Match Opening Height is 
checked, each shutter’s height equals that 
of the window, excluding casing.

• Uncheck Match Opening Height to 
specify a Height in the text field. If the 
window is later resized, the shutters will 
not adjust in response.

Specify the Position of the shutters 
relative to the window. 

• Select On Casing to position the shutters 
just outside the window frame, like func-
tional shutters. 

• Select Outside Casing to position shut-
ters outside the window casing, as deco-
rative shutters often are.

Additional shutter Options can be 
specified here.

Note: The Left and Right settings on this
panel refer to the window’s exterior.

1

2

3

4
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• Check Reverse Direction to orient the 
shutters so their exterior sides face out-
ward and their interior sides face the 
wall. For functional shutters, this should 
remain unchecked. 

A preview of the selected window 
displays on the right. In order to see the 

shutters, you may need to rotate the preview 
to show the Exterior. See “Dialog Preview 
Panes” on page 29. 

Materials Panel
The settings on the Materials panel are the 
same as those found on the same panel in 
dialogs throughout the program. See 
“Materials Panel” on page 364.

Label Panel
Window labels display in floor plan view 
when the “Windows, Labels” layer is turned 
on and use the Text Style assigned to that 
layer. See “Window Labels” on page 183. 

For more information about the settings on 
this panel. See “Label Panel” on page 429.

Bay, Box, and Bow Windows
Bay, Box and Bow Windows 
are created much the way 

regular windows are: select a tool, then click 
a wall to place that window type. 

Home Designer Suite automatically builds a 
foundation under bay/box/bow windows 
placed on floor 1 unless they are raised from 
their original position. That section of the 
foundation wall is also a bay/box/bow, but 
without windows. If the foundation was 
generated before the window is placed, the 
foundation must be rebuilt or edited 
manually.

Editing Bay, Box and 
Bow Windows

Bay, box and bow windows are edited 
similar to regular windows, with one 
exception: in floor plan view, a diamond-
shaped Depth edit handle displays on the 
section. Drag this Depth handle outward to 
increase the depth, or inward to decrease the 

depth of the unit. See “Editing Windows” on 
page 183.

Bay, box and bow windows can also be 
edited in their respective specification 
dialogs. See “Bay/Box and Bow Window 
Specification Dialogs” on page 196.

Displaying Bay, Box 
and Bow Windows

The display of bay, box and bow windows is 
controlled in the Display Options dialog. 
See “Display Options Dialog” on page 75. 

Like other windows, bay, box and bow 
windows can display labels: either a single 

5

Depth edit handle on a bay window
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label for the unit, or one for each component. 
See “Window Labels” on page 183. 

Bay, box and bow window width and radius 
dimensions, which display in floor plan view 
when specified to do so in the window’s 
specification dialog, are placed on the 
“Dimensions, Manual” layer. See “Options 
Panel” on page 197.

Component Windows
A component window within a bay, box or 
bow window can be resized like any other 
standard window. To select a component 
window, click at the location of the 
component in question, then click the Select 
Next Object  edit button or press the Tab 
key. 
• Only the bay or box window component 

that was clicked on is selected using this 
method. If you need to select a different 
component, click on it and repeat the pro-
cess.

• In a bow window, all components are 
identical, so only one component can be 
selected. Changing this component 
changes them all.

Resizing Components
An individual component window can be 
resized using the edit handles, by changing 
settings in the component’s Window 
Specification dialog. 

When a bay/box/bow window is first created, 
there is room for one standard trimmer on 

each side of each component window. When 
the bay as a whole is moved and resized, its 
components automatically resize so that a 
standard trimmer is still accommodated. 

If a component window is resized, it retains 
its size if at all possible when the containing 
bay/box/bow window is moved or resized. If 
the bay is resized in such a way that the 
component is too large to fit even with a 
thinner trimmer, the component resumes its 
default behavior, resizing as the containing 
bay window is resized.

Floors and Ceilings
When originally created, the floor and 
ceiling within a bay, box, or bow window are 
the same heights as the floor and ceiling of 
the room in which it is placed. 

Both the top and bottom heights of these 
window units can be adjusted in its 
specification dialog or a 3D view using its 
edit handles to create a lowered ceiling and/
or a bench seat or garden window.
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When the ceiling is lowered, the top heights 
of the walls that define the window unit are 
also lowered. When a roof is built over the 
unit, its height will be affected, as well.

When the bottom of the window is raised to 
create a bench seat, the unit’s walls will not 
reach the ground. As a result, window units 
with bench seats will have no foundation 
beneath them when the foundation is built.

Bay, Box, Bow Windows and Roofs
Several different roof styles can be specified 
for bay, box and bow window units in the 
Bay/Box/Bow Specification dialog. See 
“Bay/Box and Bow Window 
Specification Dialogs” on page 196. 

If you change a bay, box, or bow window’s 
roof specification, you will need to rebuild 
the roofs to see the changes. See “Rebuilding 
Roofs” on page 221. 

Hip Roofs
By default, a hip roof is built above the unit 
when roofs are automatically generated. No 

roof directives need to be selected in the 
specification dialog to produce this roof.

Use the Existing Roof
To generate a standard roof that ignores a 
bay, box, or bow window, check Use 
Existing Roof. 
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With this option the bay, box, or bow 
windows is tucked under the roof eave. You 
may find it helpful to increase the width of 
the eaves. See “Roof Panel” on page 222.

Extend the Existing Roof
To have the main roof extend down over the 
window unit and follow the shape of the unit, 
select Extend Existing Roof. 

For this roof style, the ceiling heights of the 
window unit and the adjacent room must be 
the same. If you lower the ceiling of the 
window unit and then build the roof, a lower 
hip roof over the window is created. See 
“Floors and Ceilings” on page 193.

If a header is desired over the window unit, 
first build the roof, then lower the ceiling of 
the window unit. Do not rebuild roof planes.

Rectangular Hip Roofs
To create a rectangular-shaped hip roof 
above a bay, box, or bow window, select 
Rectangular Roof Over.

Extend Existing Roof - 
Rectangular

To extend the main roof down over a window 
unit to create a rectangular roof over it rather 
than one that follows its shape, select both 
Extend Existing Roof over and 
Rectangular Roof Over. 

Gable Roof
A gable roof is not one of the automatic 
options for the roof above a bay, box or bow 
window.

To create a gable roof over a normal
window, use the Gable Over Door/

Window edit button. See “Gable Over Door/
Window” on page 224.
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Bay/Box and Bow Window Specification Dialogs
To open the Bay/Box Window 
Specification or the Bow Window 

Specification dialog, select a Bay, Box or 
Bow Window and click the Open Object 
edit button. 

The options in this dialog can only be set for 
objects placed in a plan: Bay, Box, and Bow 
Windows do not have defaults dialogs. 

General Panel

Size - Specify the Width and Depth of 
the selected Bay, Box, or Bow Window. 

Specify the height and structure of the 
Ceiling within the selected window. 

• Check Has Lowered Ceiling to enable 
the settings that follow. When this is 
unchecked, the ceiling height and finish 
material within the window is the same as 
that for the adjacent room.

• Specify the Height Lowered, which is 
measured from the ceiling height of the 
adjacent room. 

Specify the height and structure of the 
Floor within the selected window. 

• Check Has Raised Floor to enable the 
settings that follow. When this is 
unchecked, the floor height and material 
within the window is the same as that for 
the adjacent room. 

• Specify the Height Raised, which is the 
measured from the floor height of the 
adjacent room. 

Note: If the Height Lowered is 0”, Has Low-
ered Ceiling will become unchecked when
you click OK.

1

2

Note: If the Height Raised is 0”, Has Raised
Floor will become unchecked when you click
OK.

3
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Options Panel

Specify the structure of the Roof over 
the selected window unit. See “Bay, 

Box, Bow Windows and Roofs” on page 194. 
• Check Use Existing Roof if the existing 

roof needs no changes to accommodate 
the bay window.

• Check Extend Existing Roof Over to 
extend the existing roof plane to cover 
the bay window below.

• Check Rectangular Roof Over to create 
a roof over the bay window that is square 
across the end instead of following the 
profile of the roof. 

Specify the appearance of the selected 
window unit’s Dimensions in floor 

plan view. 
• Check Display Standard Dimension to 

display the automatically-produced 
dimensions that show the window’s 
width and depth.

• Check Display Dimensions to Center to 
display a Bow Window’s radial dimen-
sion.

Materials Panel
The settings on the Materials panel are the 
same as those found on the same panel in 
dialogs throughout the program. See 
“Materials Panel” on page 364.

Label Panel
Bay, Box, and Bow Window labels display in 
floor plan view when the “Windows, Labels” 
layer is turned on and use the Text Style 
assigned to that layer. See “Window Labels” 
on page 183. 

For more information about the settings on 
this panel. See “Label Panel” on page 429.

1

2
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Chapter 12:

Multiple Floors

When a new plan file is opened in Home 
Designer Suite, two floor levels are present: 
Floor 1 and the Attic Floor. You can add 
more floors whenever you like: up to 3 total. 
Once created, floors can also be copied and 
deleted.  

Home Designer Suite also supports special 
floors for foundations and attics. Only one 
foundation level and one attic can exist in a 
plan. Foundations are discussed in their own 
chapter. See “Foundations” on page 207.

Chapter Contents
•      Floor Defaults Dialog
•      Floor Tools
•      Adding Floors
•      Displaying Floors
•      Deleting Floors
•      Split Levels
•      The Current Floor
•      The Attic Floor
•      The Reference Floor
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Floor Defaults Dialog
There is a Floor Defaults dialog for 
each floor in a plan file. The defaults 

for the current floor can be accessed by 
selecting Edit> Default Settings. Select 
“Floor” from the category tree and click the 
Edit button to open the Floor Defaults 
dialog for the currently active floor. See 
“Default Settings vs Preferences” on page 
56.

The Floor Defaults dialog also opens 
whenever you add a new floor to the plan. 
See “Adding Floors” on page 201. 

The Floor Defaults dialog does not open 
when you build a foundation; however, the 
Floor 0 Default settings are created based on 
the current Foundation Defaults. See 
“Building a Foundation” on page 208. 

The Floor Defaults dialog is similar to the 
Room Specification dialog, but controls the 
default settings for all rooms on the current 
floor. The settings here also control the 
height of individual walls as they are drawn 
on the floor in question. See “Room 
Specification Dialog” on page 155.

Structure Panel
The settings on the Structure panel are 
similar to those in the Room Specification 
dialog. See “Structure Panel” on page 156. 

Moldings Panel
The settings on the Moldings panel are 
similar to those in the Room Specification 
dialog. See “Moldings Panel” on page 158. 

Fill Style Panel
The settings on the Fill Style panel are 
similar to those in the specification dialogs 
for many objects throughout the program. 
See “Fill Style Panel” on page 439. 

Materials Panel
The settings on the Materials tab are similar 
to those in the specification dialogs for many 
objects throughout the program. See 
“Materials Panel” on page 364. 

Floor Tools
Select Build> Floor to access the 
floor tools.

Select Build> Floor> Build New 
Floor to build a new floor. A new 

floor can be generated based upon the 

perimeter of the floor below or a blank floor 
can be created and drawn from scratch. See 
“Adding Floors” on page 201.

Choose Build> Floor> Delete 
Current Floor to remove the current 

Note: The default floor height for Floor 1 is 0.
It can be modified in the Room Specification
dialog, but not in the Floor 1 Defaults dialog.
See “Floor and Room Defaults” on page 144.
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floor from the plan. For more information, 
see “Deleting Floors” on page 202.

Choose Build> Floor> Build 
Foundation to open the Foundation 

Defaults dialog and build a foundation floor. 
See “Building a Foundation” on page 208.

Select Build> Floor> Delete 
Foundation to remove the foundation 

from the plan. See “Deleting Foundations” 
on page 211.

Adding Floors
When a new plan file is opened in Home 
Designer Suite, two floor levels are present: 
Floor 1 and the Attic Floor. You can add up 
to 3 total living floors, as well as create a 
foundation below Floor 1.

Floors can be added whenever you like; and 
once created, they can also be copied and 
deleted. 

Build New Floor
New floors can be created in floor 
plan view as well as in 3D views, and 

are always added above the top living floor. 
To create a new floor, select Build> Floor> 
Build New Floor. 

• Derive new 2nd floor plan from the 1st 
floor plan creates a new top floor with 
exterior walls generated directly over the 
exterior walls of the floor below. Wall 
types and roof directives associated with 
the walls on the floor below are dupli-
cated; however, interior walls are not. See 
“Roof Panel” on page 136.

• Check Move Highest Floor’s Roof Up to 
move any roof planes displaying on the 
highest floor in the plan up one floor 
when the new floor is created. Roof 
planes displaying on floors other than the 
top floor are unaffected. This option is 
only available if there are roof planes 
built on the top floor and is not available 
when Auto Rebuild Roofs is enabled. 
See “Build Roof Dialog” on page 221.

• Check Step floor/ceiling elevations to 
match existing floor to maintain all ceil-
ing heights on the existing floor by step-
ping floor heights on the new floor to 
match. Ceiling heights on the new floor 
also become stepped accordingly. See 
“Stepped Floor and Ceiling Platforms” on 
page 152. 

• Make new (blank) plan for the 2nd 
floor creates a new top floor that is blank. 
This option is typically selected only if 
none of the exterior walls on the new 

Note: Home Designer Suite allows only one
floor, the foundation/basement, below the first
floor. Keep this in mind when you begin an
as-built or plan for a multi-story building. See
“Foundations” on page 207. 
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floor will be directly above the exterior 
walls on the floor below. If you choose 
this method, it may be helpful to turn on 
the Reference Floor when drawing walls 
on the new floor. See “The Reference 
Floor” on page 205.

When you click OK, the Room Defaults 
dialog for the newly created floor opens. 
Make any necessary changes to the floor 
structure, moldings, or materials and click 
OK. See “Floor Defaults Dialog” on page 
200.

The new floor becomes the current floor in 
floor plan view. If, however, the new floor is 
created in a 3D view, the camera remains on 
its original floor and does not move. 

Adding a Foundation
To add a foundation, select Build> Floor> 
Build Foundation . See “Building a 
Foundation” on page 208.

Displaying Floors
Home Designer Suite allows you to view the 
floors in your plan in a variety of ways.

In Floor Plan View
In floor plan view, only one floor can be 
active for editing at a time. This is referred to 
as the Current Floor. See “The Current 
Floor” on page 204. 

In addition to the Current Floor, one other 
floor can be displayed for reference 
purposes: the Reference Floor. Objects on 
the Current Floor can snap to those on the 
Reference Floor, helping you align objects. 
See “The Reference Floor” on page 205.

In 3D Views
In most 3D views, all floors in a plan are 
visible, from the foundation up to the attic. 
There are three exceptions: 

• Floor Camera  views.

• Doll House View .

• Interior Elevation  views.

Floor Cameras and Doll House Views show 
the Current Floor only, not including its ceil-
ing, while interior Elevation views show a 
wall on a single floor in a single room. See 
“3D View Tools” on page 383. 

Deleting Floors
Select Build> Floor> Delete Current 
Floor to remove the current floor 

from the plan. If there is a floor above, it 
becomes the current floor; if there is no floor 
below, the floor beneath becomes the current 
floor. 

To delete Floor 0, select Build> 
Floor> Delete Foundation. You can 

delete the foundation without actually being 
on Floor 0. Floor 0 cannot be deleted while 
Auto Rebuild Foundation is turned on. See 
“Deleting Foundations” on page 211.
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Split Levels
Both split level floor plans and split level 
entries can be created by controlling the floor 
and ceiling heights of individual rooms in a 
multiple story structure. 

Split Level Floor Plans
A split level, or tri-level, structure is a 
building where the floor level in one part of 
the plan is located approximately half way 
between the floor and ceiling levels of 
another part of the plan. 

To create a simple split level plan

1. Draw a simple rectangular structure 
divided into two separate halves by an 
interior wall.

2. Select one of the rooms and click the 

Open Object  edit button. See 
“Room Specification Dialog” on page 
155.

3. Raise the Floor Height then press the 
Tab key.

4. Restore the Relative Rough Ceiling to 
the default value, then click OK.

5. Build a stem wall foundation. See 
“Foundations” on page 207.

•  The foundation under the room with 
the lower floor height will have the 
specified Min Stem Wall Height. 

•  The foundation under the room with 
the raised floor will have taller stem 
walls. 

•  Both can be edited in the Room 
Specification dialog.

6. If you add a Floor 2, note that the Ceil-
ing Height in the room on Floor 1 will 
be reset to the default value. 

•  To maintain a stepped condition on 
multiple floors, return to this room and 
set the Relative Rough Ceiling back to 
using the default.

Split Level Entries
A split level entry, or divided entry, is 
characterized by an entry door that opens 
onto a landing positioned half way between 
the basement floor and first floor levels. 

When a floor is deleted, all objects on
that floor are deleted with it.

Split Level Home

Split Level Entry
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To create a simple split level entry

1. Create a plan file with a full basement at 
the location of the entry door. See 
“Basement Rooms” on page 212.

2. Go to Floor 0 and draw a stair 

Landing  at the location of the entry. 
See “Landings” on page 240.

3. Draw stairs upward from the basement 
floor to the landing.

•  The number of treads and risers in the 
stair section will determine the landing 
height.

4. Draw a second stair section from the 
landing upward. 

5. Select the stairs and click the Auto 
Stairwell  edit button. See “Creating 
a Stairwell” on page 245. 

Split level entries are often associated with 
daylight basements. See “Daylight 
Basements” on page 213. 

For more detailed instructions, visit  
www.HomeDesignerSoftware.com.

The Current Floor
Only one floor can be active at any given 
time. The active floor is referred to as the 
Current Floor, and it is the only floor on 
which objects can be edited.

If you want to edit two different floors at the 
same time, you can open the plan again. This 
opens a second window on the current open 
plan that has the same editing abilities as the 
first. Only one of these windows can be 
active at any given time.

Floor Up / Floor Down
If you are working with 
more than one floor, you 

can select Tools> Reference Floors> Up 
One Floor or Down One Floor to switch 
from one floor to another. 

You can change the current floor in floor plan 
and 3D views. The current floor displays on 

the Change Floor/Reference  button, 
which can be found between the Down One 
Floor and the Up One Floor buttons. 

Floors become available once they have been 
built. The Attic and foundation levels are 
also accessible using these tools. 

Change Floor / Reference
If there are multiple floors, select 
Tools> Reference Floors> Change 

Floor/Reference to open the Change Floor/
Reference dialog, where you can select both 
the current floor and which floor is used in 
the Reference Floor, as well as control the 
appearance of the Reference Floor. 
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The Attic Floor
Home Designer Suite automatically 
creates a floor above the top 

numbered floor level of each plan. This floor 
is called the Attic floor and has only one 
purpose: to provide a space for automatically 
generated Attic walls. See “Attic Walls” on 
page 132.

Because the Attic floor is not meant to be a 
living area, a warning message will display if 

you try to draw walls or other objects on this 
floor.

In some situations, you may find it necessary 
to draw one or more walls on this floor; 
however, even if you enclose an area with 
walls, rooms cannot be created on the Attic 
floor.

If you wish to create an attic loft, bonus 
room, or storage area in your plan, you will 
need do so on a numbered floor level. 

The Reference Floor
When there is more than one floor in a 
model, it is often helpful to see how they 
relate to each other. Any floor can be shown 
as the Reference Floor along with the 
current floor. 

When the Reference Floor Display is turned 
on, the floor that you were last on prior to the 
current floor is used as the Reference Floor 
and is shown in red. Objects on the 
Reference Floor cannot be selected or edited.

Reference Floor Display
To turn on the Reference Floor, select 
Tools> Reference Floors> Reference 

Floor Display or press F9 on your keyboard.

If the Reference Floor is turned on when a 
view is printed, it will be included in the 

printed output. See “Displaying Objects” on 
page 479. 

Reference Floor Display 
Options

The display of objects in the 
Reference Floor is controlled by 

selecting Tools> Reference Floors> 
Reference Floor Display Options. See 
“Display Options Dialog” on page 75.

Change Floor / Reference
By default, the floor below the current 
floor is the Reference Floor, but any 

floor can be referenced using the Change 

Floor/Reference dialog. To open the dialog, 
select Tools> Reference Floors> Change 
Floor/Reference button. 

Note: If objects on the current floor and the
Reference Floor have edges that line up, the
Reference Floor may be difficult to see on
screen. When lines of two different colors are
superimposed upon each other, discoloration
may result.
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The Current Floor is highlighted here. 
You can select another floor to make it 

the current floor.

The Reference Floor currently used for 
reference is highlighted here. You can 

select another floor to display it instead. 

Swap Floor/Reference
If one floor is defined as the current 
floor and another floor is defined as 

the reference floor, select Tools> Reference 
Floors> Swap Floor/Reference to switch 
the status of the two floors.

1

2
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Chapter 13:

Foundations

There are two foundation types in Home 
Designer Suite: stem walls with footings and 
monolithic slab. The foundation type can be 
specified in the Foundation Defaults dialog 
when the foundation is built.

There can be only one foundation level in 
your plan, Level 0. Foundation walls can be 
drawn on upper floors using the Wall tool.

Chapter Contents
•      Foundation Defaults
•      Building a Foundation
•      Displaying Foundations
•      Editing Foundations
•      Deleting Foundations
•      Foundations and Rooms
•      Foundations and the Terrain
•      Fireplaces
•      Fireplace Specification Dialog
•      Library Fireplaces
•      Chimneys

Always consult registered geotechnical
and civil engineers for information

regarding the proper foundation for your site. 
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Foundation Defaults
Foundation Defaults can be accessed 
by selecting Edit> Default Settings. 

Select “Foundation” and click the Edit 
button to open the Foundation Defaults 
dialog. 

The settings in the Foundation Defaults 
dialog are similar to those in the Build 
Foundation dialog, which opens when 

Build> Floor> Build Foundation  is 
selected. The primary difference is that when 
you click OK in the Foundation Defaults 
dialog, no changes are made to the model. 
See “Building a Foundation” on page 208.

Check Auto Rebuild Foundation to 
automatically rebuild the foundation 

whenever changes are made to Floor 1 that 
affect the structure of the foundation.  See 
“Rebuilding Foundations” on page 210. 

Click the radio button beside either 
Monolithic Slab or Walls with 

Footings to specify which foundation type 
the program should build.

Wall Options - Specify characteristics 
of the foundation walls. 

• Wall Thickness - Specify the desired 
thickness of the foundation walls. See 
“Wall Thickness” on page 129.

• Wall Height - Specify the desired height 
of the foundation walls. 

If the wall height is at least 6 feet (1800 mm), 
a slab floor is generated above the footings 
and inside the foundation walls. The Wall 
Height includes the thickness of this slab.

If you do not want this slab, specify the 
“rooms” on Floor 0 as Open Below in the 
Room Specification dialog. See “Available 
Room Types” on page 148.

Building a Foundation
Two foundation types are available: 
stem walls with footings and 

monolithic slabs. The first option is created 
using walls; the second creates concrete slabs 
with footings.

Automatically built foundations are placed 
on Floor 0 and are based on wall positions 

and floor heights on Floor 1. Foundation 
walls or slab footings are generated under:
• All exterior walls on Floor 1 that define a 

room other than a Court, Deck or Bal-
cony room type. See “Room Definition” 
on page 144.

1

2

3
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• Any interior walls on Floor 1 defining 
rooms with different floor heights. See 
“Floor and Ceiling Heights” on page 151. 

At least one room must be defined on Floor 1 
for a foundation to be automatically 
generated. If no rooms are defined on Floor 
1, a blank Floor 0 is created. 

To build an automatic foundation

1. Select Build> Floor> Build Founda-
tion . 

2. Specify the desired foundation type and 
other information in the Build 
Foundation dialog. The settings in this 
dialog are similar to those in the Foun-
dation Defaults dialog. See “Foundation 
Defaults” on page 208.

3. In the New Floor dialog, select Derive 
new Foundation plan from the 1st 
floor plan and click OK to build a foun-
dation based on Floor 1.

If you prefer, you can instead select Make 
new (blank) plan for the Foundation to 
create an empty foundation level where you 
can manually draw foundation walls or slabs.

In most cases, it is preferable to base Floor 0 
off the first floor plan and then manually edit 
the foundation as needed. See “Editing 
Foundations” on page 210.

Mixing Foundation Types
You can also create a foundation that 
combines stem walls and/or monolithic 
slabs.

To create a foundation of multiple types

1. Begin by specifying any rooms on Floor 
1 that require a slab floor as either a 
Garage or Slab Room Type. See “Foun-
dations and Rooms” on page 211.

2. Build Foundation , as described 
above.

Displaying Foundations
The display of foundation walls, slabs, 
curbs and footings is controlled in the 

Display Options dialog. See “Display 
Options Dialog” on page 75. 
• Foundation Walls, including slab footings 

and Garage curbs, are placed on the 
“Walls, Foundation” layer.

• Footings under Foundation Walls and 
slab footings are placed on the “Foot-
ings” layer. 

If a door on Floor 1 extends into a stem wall 
or curb defining a Garage room, its location 
will be indicated on Floor 0.

In 3D views, all objects on Floor 0 will only 
display when the “Foundation” layer is 
turned on. 

While the display of foundation walls and 
their footings can be controlled independent 
of one another in floor plan view, in 3D 
views this is not the case. If a foundation 
wall is set to display, its footing will as well - 
even if the “Footings” layer is turned off. The 
reverse is also true - if a foundation wall’s 
display is turned off, so will its footing’s.

The display of monolithic slab foundations in 
3D views is controlled by the “Foundation” 
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layer. Slab footings are located on the 
“Walls, Foundation” layer; but if this layer is 
turned off, any slab footings that define a 

foundation room will continue to display as 
long as the “Foundation” layer is on. 

Editing Foundations
Stem wall with footings and monolithic slab 
foundations are both created using walls 
which enclose room areas.
• Foundation walls can be selected and 

edited much like other walls. See “Edit-
ing Walls” on page 127.

• Foundation rooms can also be selected 
and edited like other rooms. See      Foun-
dations and Rooms.

Rebuilding Foundations
By default, foundations update automatically 
when changes are made to the structure on 
Floor 1. For example, if exterior walls are 
moved or floor platforms are raised or 
lowered, the foundation will be rebuilt.

If you prefer that the foundation not rebuild 
automatically, you can uncheck Auto 
Rebuild Foundation in the Foundation 
Defaults dialog. See “Foundation Defaults” 
on page 208.

You can also rebuild an automatically 
generated foundation by selecting Build> 
Floor> Build Foundation  from the 
menu. 

When Auto Rebuild Foundation is enabled, 
walls cannot be edited, manually drawn or 
deleted on Floor 0. When the foundation is 
rebuilt, any manually drawn or edited walls 
are deleted. Similarly, rooms on Floor 0 
cannot be edited while this option is enabled. 
If you try to draw a wall or edit a room or a 

wall while Auto Rebuild Foundation is 
turned on, a warning message will display.

Changing Foundation Types
When a foundation is generated, the program 
creates Floor Defaults settings for Floor 0 
based on the information in the Build 
Foundation dialog. If you specify a 
Monolithic Slab foundation, the default 
Floor Structure on Floor 1 will also be 
changed to a slab rather than a framed 
platform. See “Floor Defaults Dialog” on 
page 200.

If you rebuild the foundation using a 
different Foundation Type, it is advisable to 
check the floor heights of all rooms on Floor 
1 - particularly Garage and Slab rooms, as 
well as any rooms that do not use the default 
floor height of 0”. 

Stem Wall Height
When a foundation is created, all of Floor 0 
uses the stem wall height specified in the 
Foundation Defaults dialog, 

This height is measured from the bottom of 
floor platform of Floor 1 to top of the stem 
walls’ footings. If Floor 1 has multiple floor 

To avoid unexpected results, it is rec-
ommended that you not change the

Foundation Type once the foundation is built.
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platform heights, the foundation stem walls 
will be stepped.

Once a foundation is created, stem wall 
heights can be adjusted either on a room-by-
room basis or for individual walls.

To change a room’s stem wall height

1. Select a room on Floor 0 and click the 

Open Object  edit button. 

2. Specify the desired Stem Wall Height 
in the Room Specification dialog. See 
“General Panel” on page 155.

3. If you wish to reduce the Stem Wall 
Height, you will first need to reduce the 
Ceiling Height value by the same 
amount. 

If adjacent rooms have stem wall heights that 
differ by at least 1/16 of an inch, the stem 
wall separating them uses the larger of these 
two values.

Deleting Foundations
Select Build> Floor> Delete Foun-
dation to delete the entire foundation 

floor. 

You can also select and delete individual 
foundation walls and slabs by clicking the 

Delete  edit button or pressing the Delete 
key. See “Deleting Objects” on page 111.

Deleting and rebuilding the foundation is 
often the quickest way to update the model 
when substantial changes are made to Floor 1 
after the foundation is built.

Foundations and Rooms
When a foundation plan is created, rooms 
included in the Living Area calculation 
generate a stem wall or slab foundation 
below them. Garage rooms generate slab 
foundations, but exterior rooms such as 
Decks, Courts and Balconies do not generate 
any foundation. See “Room Types” on page 
147. 

Interior foundation walls are not generated 
unless:
• They separate the area under a Slab or 

Garage room from the rest of the plan;
• They define areas under rooms with dif-

ferent floor heights.

Garages
When a foundation is generated based on the 
floor plan of Floor 1, a room on the first floor 
specified as either a Garage or Slab type will 
receive a foundation with a slab floor and 
stem walls. If a monolithic slab foundation is 
generated, the room will receive a slab floor 
with curbs.

Note: To remove all or part of the concrete
slab in the basement area, select a basement
room and define it as Open Below in the
Room Specification dialog.
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By default, a room on Floor 1 specified as a 
Garage or a Slab will be assigned a lower 
floor height when the foundation is built. The 
amount that it is lowered depends on the 
foundation type:
• The floor height will drop the default 

thickness of the floor platform for Floor 1 
plus 12” (300 mm) - a total of 24 5/8” 
(618 mm) - in a Walls with Footings 
foundation.

• The floor height will drop 3 1/2” (88 mm) 
in a Monolithic Slab foundation. 

To build a Garage slab with stem walls

1. Before the foundation is generated, 
specify the room as a Garage or Slab. 

2. Build a Wall with Footings foundation.

To build a Garage slab with curbs

1. Before the foundation is generated, 
specify the room as a Garage or Slab. 

2. Build a Monolithic Slab foundation, 
specifying the required Lower Garage 
Floor value.

Basement Rooms
When a foundation’s type is Walls with 
Footings and it is assigned a Minimum Wall 
Height of 76” (1900 mm) or greater, the 
resulting basement is automatically created 
with a 4” (100 mm) concrete slab floor. 

Similarly, if a foundation is set up to have a 
Basement Ceiling Height of 72” (1800 mm) 
or greater when built, it is automatically 
given a painted drywall Ceiling Finish. 

Regardless of its ceiling height, however, 
you can specify a ceiling finish for any room 
in the Room Specification dialog. See 
“Structure Panel” on page 156.

The resulting basement can be divided into 

separate rooms using Interior Walls  or 
any wall type you wish.

Foundations and the Terrain
Home Designer Suite automatically positions 
the terrain a set distance below Floor 1. See 
“Terrain Height vs Floor Height” on page 
290. 

In a plan with a foundation present, this 
distance will be: 
• 6” (187 mm) below the top of the stem 

walls in a Walls with Footings founda-
tion. 

• 8” (200 mm) below the top of the slab in 
a Monolithic Slab foundation. 

Floor platform

Stem Wall Top

Terrain
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By default, the program will also create a 
flattened pad under the building footprint.

Not all foundations have these requirements, 
of course, so you can customize your 
foundation and terrain to suit your needs.

Daylight Basements
Daylight basements, also referred to as look-
out basements, have walls that are tall 
enough for basement windows to be 
positioned above the terrain. They are often 
found in split level or split entry structures.

To create a daylight basement condition,  
build a stem wall foundation and modify 
these settings in the Terrain Specification 
dialog: 
• Uncheck Auto Calculate Elevation.
• Increase the Building Pad Elevation, 

which is the distance between the default 
floor height of Floor 1 and the terrain. 

Walkout Basements
Walkout basements are a type of daylight 
basement typically located on sloped terrain. 
They feature walls that are above ground at 
the lower end of the slope so that a door can 
be positioned above the terrain at that end. 

To create a walkout basement, build a stem 
wall foundation and modify these settings in 
the Terrain Specification dialog: 

• Uncheck Flatten Pad.
• Uncheck Auto Calculate Elevation.

You will also need to create sloped terrain 
and adjust the Building Pad Elevation and/
or terrain data so that the terrain is at the 
appropriate height relative to the structure at 
both the high and low ends of the slope.

Stepped Foundations
Stepped foundations are usually built on 
sloping terrain. A stepped foundation will be 
produced automatically if more than one 
floor height is present on Floor 1 when the 
foundation is built. 

As with a walkout basement, you will need 
to build a stem wall foundation and modify 
these settings in the Terrain Specification 
dialog: 
• Uncheck Flatten Pad.
• Uncheck Auto Calculate Elevation.

You will also need to create sloped terrain 
and adjust the Building Pad Elevation and/
or terrain data so that the terrain is at the 
appropriate height relative to the structure at 
both the high and low ends of the slope.

You can also create a stepped foundation by 
editing foundation rooms. See “Stem Wall 
Height” on page 210.

Fireplaces
A masonry fireplace can be placed in 
or away from a wall by selecting 

Build> Fireplace and then clicking in the 
drawing area. 

• If created in a wall, it is considered a wall 
opening and can be moved or resized like 
a window or door. 
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• If created away from a wall, it moves and 
resizes similar to a cabinet.

A selection of prefabricated metal fireplaces 
is also available from the Fixtures (Interior) 
library category. These can be framed in with 
standard walls. See “The Library” on page 
341.

The display of fireplaces is controlled in the 
Display Options dialog. See “Display 
Options Dialog” on page 75.

Fireplaces are edited, moved, resized, and 
deleted similar other objects. See “Editing 
Objects” on page 85.

Built into a Wall
To place a masonry fireplace in a wall, select 

Build> Fireplace  and click on a wall. A 
fireplace is created with the outside of the 
fireplace flush with the outside of the wall.

Select the fireplace to display four edit 
handles located along the wall.

Click the diamond-shaped Depth handle and 
drag toward the outside of the wall. The 
fireplace will stop when the firebox front is 
flush with the inside edge of the wall.

In 3D views, fireplaces placed in walls 
display five edit handles: a Resize handle 
along each edge and a Move handle at the 
center. 

Fireplaces always face the interior when 
placed on an exterior wall. When placing a 
fireplace in an interior wall, click on the edge 
of the wall that you want the fireplace to 
face. The fireplace is created with the firebox 
on the same side as the wall edge you clicked 
on to create it. 

Freestanding
To place a free-standing masonry fireplace, 

select Build> Fireplace  and click in an 
open area away from a wall.

Unlike fireplaces placed in walls, free-
standing fireplace have ten edit handles when 
selected and may be rotated, resized, or 
moved in any direction, similar to the way 
CAD boxes can. See “Editing Box-Based 
Objects” on page 98.
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Fireplace Foundations
When a Walls with Footings foundation is 
built, a fireplace foundation will be 

generated under any Fireplaces  present 
on Floor 1. See “Building a Foundation” on 
page 208. 

Fireplace foundations are the same material 
type as the original fireplace, but do not have 
a firebox or a hearth. Fireplace foundations 
can be edited or deleted as needed. A firebox 
and hearth can be added in the Fireplace 
Specification dialog. 

Fireplace Specification Dialog
Select a masonry fireplace and click 
the Open Object edit button to 

display the Fireplace Specification dialog. 

Dimensions in this dialog here must be 
entered in whole inches. Fractions and 
decimals are not accepted.

General Panel

Specify the Size and Position of the 
selected fireplace and its hearth. 

• Specify the Height, Width, and Depth of 
the fireplace.

• Specify the Hearth Depth. This is mea-
sured from the front of the fireplace out 
into the room. To eliminate the hearth 
altogether, enter a zero for this value.

• Specify the Hearth Height, relative to 
the floor in the room that the fireplace 
faces.

• Enter the Floor to Bottom distance from 
the floor to the bottom of the hearth.

• When the selected free-standing fireplace 
is outside a room and Auto Adjust 
Height is checked , its Floor to Bottom 
height is measured relative to the terrain 

1
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height. When this is unchecked, the Floor 
to Bottom height is measured from the 
default floor height of Floor 1. Only 
available for free-standing fireplaces. See 
“Terrain Height vs Floor Height” on page 
290 of the Reference Manual. 

Plan Display - Check Suppress 
Dimensions to turn off the display of 

the selected fireplace’s width and firebox 
width dimensions in floor plan view. 

The preview of the fireplace updates as 
changes are made. See “Dialog Preview 

Panes” on page 29. 

Firebox Panel

Define the Size of the selected 
fireplace’s firebox.

• Specify the firebox’s Height and Width.
• Specify the Depth of the firebox.

Define the firebox Offset, measured 
from the center of the fireplace. 

• Enter the offset Distance, which is how 
far the firebox is offset from the fireplace 
center. A value of 0 centers the firebox in 
the fireplace. 

• Offset to Left/Right - Choose to offset 
the firebox to the left or to the right. 

The preview of the fireplace updates as 
changes are made. See “Dialog Preview 

Panes” on page 29. 

Materials Panel
For information about the settings on this 
panel, see “Materials Panel” on page 364.

2

3

1

2

3
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Library Fireplaces
A variety of different fireplace symbols are 
available in library. The fireplace symbols in 
the Library behave just like other Library 
objects.  See “The Library” on page 341. 

Placing a Library Fireplace
A variety of fireplace symbols are available 
in the library. See “Placing Library Objects” 
on page 354.

Flush fireplaces are designed to snap to wall 
surfaces. 

Some fireplace symbols can be enclosed by 
walls or positioned to project through a wall.

Chimneys
Chimneys can be created using a variety of 
methods. 

Masonry Fireplace Chimneys

To create a chimney on a masonry fireplace

1. Select the fireplace in a 3D view. 
2. Ctrl + drag the top edge of the chimney 

upward through all the floors and the 
roof until it is to the desired height. See 
“Unrestricted Movement” on page 106.

3. When the chimney is approximately the 
correct height, select the fireplace, click 

the Open Object  edit button, and 
type in the exact height.

Chimney Chases and Caps
There are two ways to draw a chimney chase: 
• Place a closed box Geometric Shape or 

Soffit over the chimney chase, resize it to 
match, then increase its height either in 
its specification dialog or in a 3D view 
using the same method as extending a 
masonry fireplace. 

• Use walls to define the chimney chase as 
a room area, making sure these walls are 
aligned between floors. The chimney 

Always check the manufacturer’s prod-
uct information for the framing and

clearance requirements of the fireplace unit
you plan to use, and design your plan
accordingly

Open Front fireplace projecting through a wall
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chase “room” on the uppermost floor 
should have a much higher ceiling than 
the other rooms on that floor and should 
also have no ceiling or roof. See “Room 
Specification Dialog” on page 155.

A selection of chimney tops is available in 
the library. In addition, custom chimney caps 
can be made using  Geometric Shapes and/or 
Soffits. See “Other Objects” on page 331.
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Chapter 14:

Roofs

Home Designer Suite’s automatic Roof Tools 
allow you to draw almost any roof style. 

Proficiency with the Roof Tools can only be 
attained through practice, but mastering 
these tools saves you time and effort in plan 
development. For information about creating 
specific roof styles, see “Roof Tutorial” on 
page 57 of the User’s Guide.

Chapter Contents
•      Roof Defaults
•      The Roof Tools
•      Automatic Roofs
•      Build Roof Dialog
•      Editing Roofs
•      Skylights
•      Skylight Specification Dialog
•      Dormers
•      Editing Auto Dormers
•      Dormer Specification Dialog
•      Roof Returns and Other Details
•      Roof Pitches in Degrees
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Roof Defaults
Select Edit> Default Settings, to 
open the Default Settings dialog for a 

variety of drawing tools, several of which 
directly affect roof generation. 

Build Roof Dialog
While not listed in the Default Settings 
dialog, the Build Roof dialog functions as 
the defaults dialog for roofs. Many, but not 
all, initial default values for automatically 
generated roofs are set in this dialog. See 
“Build Roof Dialog” on page 221.

Floor and Ceiling Heights
The initial heights of floors and ceilings, 
which influence roof heights, are specified in 
the Floor Defaults dialog for each floor. See 
“Floor Defaults Dialog” on page 200.

The floor and ceiling heights in individual 
rooms also influence roof heights and are 
specified in the Room Specification dialog. 
See “Structure Panel” on page 156.

Wall Specification Dialog
By default, when a roof is built, a roof plane 
is generated over each exterior wall, creating 
a hip roof. 

Any deviations from this default hip roof, 
such as a gable or a different pitch, can be 
specified in the Wall Specification dialog for 
any exterior wall. See “Roof Panel” on page 
136. 

Dormer Defaults
The settings in the Dormer Defaults dialog 
determine the initial settings for automatic 
dormers and are much like those in the 
Dormer Specification dialog. See “Dormer 
Specification Dialog” on page 228.

The Roof Tools
Select Build> Roof to access the Roof 
Tools. 

Build Roof
Select Build> Roof> Build Roof to 
open the Build Roof dialog, specify 

the settings for automatically generated roof 
planes, and build or rebuild a roof. See 
“Build Roof Dialog” on page 221.

When roofs are automatically generated, a 
roof plane is created over each exterior wall 
by default, resulting in a hip roof.

To automatically generate a roof plane using 
values other than the defaults or to not 
generate a roof plane bearing on a particular 
wall (as with a gable or the sides of a shed 
roof), you can change the settings in the Wall 
Specification dialog. See “Roof Panel” on 
page 136.

If Auto Rebuild Roofs is checked in the
Build Roof dialog and you change floor

or ceiling heights, wall positions or roof direc-
tives in walls, the roof rebuilds to reflect your
changes. See “Rebuilding Roofs” on page
221.
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For more information about creating 
different roof styles, see “Roof Tutorial” on 
page 57 of the User’s Guide. 

Skylight
Select Build> Roof> Skylight, then 
draw a rectangle over an existing roof 

plane to create a skylight. The skylight, sky-
light shaft, and ceiling hole (if a ceiling 
exists) are drawn at the same time. See 
“Skylights” on page 224.

Dormer
Select Build> Roof> Dormer and 
click within an existing roof plane to 

place an auto floating dormer. See 
“Dormers” on page 227.

Delete Roof
Select Build> Roof> Delete Roof to 
delete all roof planes in the plan. See 

“Deleting Roof Planes” on page 223.

Automatic Roofs
When roofs are automatically generated, a 
roof plane is created over each exterior wall 
by default, resulting in a hip roof.

Roof Directives in Walls
To automatically generate a roof plane using 
values other than the defaults or to not 
generate a roof plane bearing on a particular 
wall (as with a gable or the sides of a shed 
roof), you can change the settings in the Wall 
Specification dialog for that wall. See “Roof 
Panel” on page 136.

For more information about creating 
different roof styles, see “Roof Tutorial” on 
page 57 of the User’s Guide. 

Rebuilding Roofs
By default, whenever changes are made to 
wall placement, floor/ceiling heights, or roof 
directives in walls, the roof will update in 
response. If you do not want the roof to 
rebuild automatically, uncheck Auto 
Rebuild Roofs in the Build Roof dialog. See 
“Roof Panel” on page 222.

You can also rebuild the roof at any time to 
reflect the current state of the model by 
opening the Build Roof dialog and clicking 
OK.

Build Roof Dialog
The Build Roof dialog is used to 
automatically build or rebuild roof 

planes.To open the Build Roof dialog, select 

Build> Roof> Build Roof .

Roof planes are generated based on the 
positions and roof directive settings for each 
exterior wall in the plan. If you make 
changes to any of these walls, you will need 
to build the roof again for them to take effect. 
See “Roof Panel” on page 136. 
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There are three panels in the Build Roof 
dialog: 
•      Roof Panel

•      Materials Panel
•      Roof Styles Panel

Roof Panel

The Build options are commands 
related to building and rebuilding roofs.  

• If you check Auto Rebuild Roofs, the 
program automatically rebuilds the roof  
if you make a change that affects the roof, 
such as to exterior wall positions or ceil-
ing heights. 

• Check Ignore Top Floor to build the roof 
so that it bears on the walls of the floor 
below the top living floor in the plan. 
When unchecked, the roof builds so that it 
bears on the walls on the top floor of the 
plan.

The Specifications settings affect basic 
roof structure. 

• Enter a value to describe the Pitch. In 
plans using U.S. units of measurement, 
pitch is described as a ratio over 12; in 

metric plans, it is measured in degrees. 
For a conversion to degrees, see “Roof 
Pitches in Degrees” on page 231.

• Minimum Alcove Size - Specify the min-
imum width of an alcove (depression into 
an otherwise straight exterior wall). Any 
alcove less than the specified width is 
treated as though the exterior wall contin-
ues straight across. Alcoves that measure 
wider than this value are not roofed over; 
they cause a change in roof planes. 

Following is an example showing this 
difference. If Min Alcove is 36", a 36" wide 
alcove requires a change in the roof line. 
Each wall of the alcove has an eave. On the 
right, the alcove is less than the 36" 
minimum, so the roof passes right over it.

1

2
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The Roof Overhang is measured 
horizontally from the exterior surface of the 
wall’s framing layer to the end of the top of 
the rafter. It does not include gutters, 
sheathing or siding. 
• Normal is the overhang at the eaves and 

is always the overhang for a roof plane 
having the default Pitch specified above. 
If the pitch for a particular roof plane is 
set differently, its overhang may try to 
maintain its fascia at the same height. 
Overhang can be greater for a shallower 
pitch, lesser for a greater pitch.

• Gable is the overhang dimension at gable 
ends or rake walls. 

Materials Panel
The settings on this allow you to specify 
materials for the roof’s various components. 
See “Materials Panel” on page 364.

Roof Styles Panel
The Roof Styles panel provides links to 
tutorial information about creating different 
roof styles automatically. Click on a roof 
style to launch the online Help to a page with 
information about the roof style you selected. 
See “Roof Tutorial” on page 57 of the User’s 
Guide. 

Editing Roofs
Unlike most other objects in Home Designer 
Suite, roof planes cannot be selected and 
edited. To make changes to the roof, you 
must edit the edit roof directives in walls 
and/or settings in the Build Roof dialog, and 
then rebuild. See “Rebuilding Roofs” on 
page 221.

An exception to this rule is the Material 
Painter  tool, which you can use to 
change the materials used by  individual roof 
planes without rebuilding the roof. Bear in 
mind, though, that any changes made using 

the Material Painter  will not be retained 

if the roof is later rebuilt. See “The Material 
Painter” on page 362.

Deleting Roof Planes
There are several ways to delete roof planes.

Delete the entire roof quickly by 
selecting Build> Roof> Delete Roof. 

You can also delete all roof planes at 
once in the Delete Objects dialog. 

See “Delete Objects Dialog” on page 111.

If the roof overhang values are not suffi-
cient to extend past the outer layer of

exterior walls, the walls may  not generate
correctly in 3D views..
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Gable Over Door/Window
The Gable Over Door/Window edit 
button allows you to add a small gable 

dormer  over one or more selected doors or 
windows the next time automatic roof planes 
are built.

To use the Gable Over Door/Window tool

1. Select one or more doors or windows. 
2. Click the Gable Over Door/

Window  edit button.

•  Gable Over Door/Window  is not 
available for openings placed in Full 
Gable Walls or for Bay, Box or Bow 
Windows. See “Bay, Box, Bow 
Windows and Roofs” on page 194.

3. The next time automatic roof planes are 
built, gables will be created over each of 
these doors and windows.

•  Each gable will extend 12” (300 mm) 
on either side of its door or window.

•  If two of these openings are within 30” 
(750 mm) of each other on the same 
wall, a single gable will be created. 

•  If you move or resize the door or 
window(s), the associated Gable Line 
will not update until the roof is built 
again. 

4. To remove a Gable Over Door/Window, 
select the door(s) or window(s) and click 

the Delete Gable Over Opening  
edit button. The next time the roof is 
built, the gable will be removed. 

Skylights
A skylight can be created by selecting 
Build> Roof> Skylight and drawing a 

rectangular polyline within a single roof 
plane. You can also simply click once within 
a roof plane to place a 2’ x 2’ skylight.

The Skylight  tool places a flat panel 
skylight into a roof hole, produces a hole in 
the ceiling platform below, and automatically 
generates the skylight shaft between these 
two holes.
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To place a skylight in a vaulted ceiling, 
uncheck Ceiling Over This Room in the 
Room Specification dialog, draw the ceiling 
planes to produce the vault and edit them as 
needed, and then draw the skylight. See 
“Structure Panel” on page 156.

Editing Skylights
Skylights can be edited using the edit 
handles, edit toolbar buttons, or the Skylight 
Specification dialog. See “Skylight 
Specification Dialog” on page 225.

Skylights must always be contained by a 
single roof plane. If the roof plane is deleted, 
any skylights it contains are also deleted. 
Aside from this restriction, skylights can be 
edited much like standard closed polylines. 
See “Editing Closed-Polyline Based 
Objects” on page 96. 

Skylight Specification Dialog
Select a skylight and click the Open 
Object edit button to open the 

Skylight Specification dialog. See 
“Skylights” on page 224.
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General Panel

Specify the Frame Width and Height 
of the selected skylight.

Angle for Inside Hole Rim - Defines 
the shape of the skylight well where it 

passes through the roof plane.
• Square Sides - The framing for the sky-

light is cut square to the pitch of the roof.
• Plumb Sides - The framing for the sky-

light is plumb-cut.
• Plumb/Square - The bottom edge is 

plumb-cut, the top edge square-cut.

Polyline Panel
The Polyline panel indicates the skylight’s 
Perimeter, its Framing Area, and its 
Projected Area.
• The Perimeter is the length of the sky-

light’s perimeter with the pitch taken into 
account. It does not equal the perimeter as 
measured in floor plan view. 

• The Framing Area is the area of the sky-
light with the pitch taken into account. 

• The Projected Area is the area of the 
skylight as seen in floor plan view. 

Line Style Panel
For information about the settings on this 
panel, see “Line Style Panel” on page 434.

Fill Style Panel
The settings on the Fill Style panel control 
the appearance of the selected skylight in 
floor plan view. For information about these 
settings, see “Fill Style Panel” on page 439.

Materials Panel
For information about the Materials panel, 
see “Materials Panel” on page 364.

Label Panel
Skylight labels display when the “Roofs, 
Labels” layer is turned on and use the 
“Default Label Style” Text Style. The 
Automatic Label for these objects is blank, 
but you can specify a custom label. 

For information about the settings on this 
panel, see “Object Labels” on page 429.

1

2
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Dormers
Dormers can be drawn manually or 
placed automatically using the 

Dormer tool.

Automatic Dormers can  be placed only 
under certain conditions: 
• Automatic Dormers can only be placed 

entirely within a single roof plane. They 
cannot extend past the eaves or ridge of 
this roof plane.

• Automatic Dormer side walls cannot be 
positioned above other walls in the plan.

If you click within a roof plane to place an 
automatic dormer, but click too close to an 
eave or the ridge, a dormer will not be 
created; however, its outline will. Move this 
outline box to a location that meets the 
dormer’s requirements and it will be created.

Dormer
Select Build> Roof> Dormer and 
click the roof plane where you would 

like to place the center of the dormer's front 
wall. 

The bottom edges of all dormer walls are cut 
off by the underlying roof plane. 

The images below show both the outside and 
inside of a typical dormer.

A dormer can be placed in floor plan view on 
the same floor that its underlying roof plane 
displays on, or it can be placed on the floor 
above. Normally, it does not matter what 
floor the dormer is on; but in some cases, it 
may need to be on the floor above so that the 
dormer walls do not interfere with walls or 
railings in the room below. 

Regardless of which floor it is placed on, a 
dormer must always fit within a single roof 
plane. When placing a dormer on the floor 
above, you may find it helpful to turn on the 

Reference Display . See “Reference 
Floor Display” on page 205. 

The initial width, height, roof style and other 
settings of Auto Dormers are set in the 
Dormer Defaults dialog. See “Dormer 
Defaults” on page 220.
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Manually Drawn Dormers
Once you are familiar with Home Designer 
Suite’s roof tools, drawing dormers manually 
can be quite simple. There are several 
different ways to draw dormers; some 
methods work better in certain applications. 

A variety of resources with information 
about drawing dormers manually is available 
at www.HomeDesignerSoftware.com . 

See, too, “Manually Drawn Dormers” on 
page 72 of the User’s Guide.

Editing Auto Dormers
Auto Dormers are a collection of objects that 
behave as one. When a dormer is selected, it 
can be edited using its edit handles, edit 
tools, and specification dialog. See “Dormer 
Specification Dialog” on page 228.

Using the Mouse
When selected, an auto dormer displays three 
edit handles. The Move handle displays over 
the front wall and allows you to relocate the 
dormer. Two resize handles display on the 
side walls and allow you to change the width 
of the dormer.

There are some things to keep in mind when 
editing auto dormers and auto floating 
dormers using the mouse.

• Dormers move at 90° angles unless the 
Ctrl key is pressed before moving them.

• The dormer must be contained within one 
underlying roof plane.

• Auto dormers cannot be moved beyond 
the required knee wall.

Editing the Window
Dormer windows can be selected, edited, 
deleted and replaced just like other windows. 
See “Editing Windows” on page 183. You 
can place several windows in the front wall.

Unless the dormer's window has been edited 
or changed in the Window Specification 
dialog, when the dormer width is changed, its 
width changes automatically to fill the front 
dormer wall. If the window has been edited, 
its width stays fixed. If a change to the 
dormer makes its front wall too short to hold 
the window, the window reverts to auto 
width.

Dormer Specification Dialog
Select a dormer and click the Open 
Object edit button to open the 

Dormer Specification dialog.

Move Resize
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The settings in this dialog are also found in 
the Dormer Defaults dialog, where they 

apply to all dormers as they are created rather 
than to a selected dormer.

Roof Panel

Specify the selected dormer’s Roof 
Style. 

• Choose a roof Type from the drop-down 
list.  You can choose from Hip, Gable, 
Shed, Gambrel, Mansard, Barrel, Curved 
Eave, Hip Curved Eave or Eyebrow. 

Describe the Pitch of the dormer’s roof 
planes.

• Specify the Pitch of the dormer roof 
planes. The default dormer pitch applies 

to all dormer roof types except Shed, 
which has a default 3 in 12 pitch. For 
Gambrel and Mansard types, this applies 
to the lowest, or eave, roof planes. 

• Check Pitch in Degrees to display the 
pitch in degrees; uncheck it to display the 
pitch in terms of rise and run. See “Roof 
Pitches in Degrees” on page 231.

Roof Overhang - Specify the depth of 
the selected dormer’s Eave and Gable 

Overhangs.

Check Auto Roof Returns to generate 
roof returns on the selected dormer. 

Roof Returns can be only specified for Gable 
dormers. See “Roof Returns” on page 230.
• Specify the horizontal Length of the roof 

return in inches (mm).
• Specify a Gable, Hip, or Full roof return. 
• Specify a Sloping or Flat roof return. 

1

Dormer Roof Types 

2

3

4
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Walls Panel

• Select a Wall Type for the dormer walls 
from the drop-down list. 

• Specify the Height of the dormer, as mea-
sured from where the top of the underly-
ing roof plane meets the dormer front wall 
exterior to the top plate of the dormer 
roof’s bearing walls.

• Check Set to Existing Ceiling to assign 
the ceiling height of the room behind the 

dormer to the dormer. Not available in the 
Dormer Defaults dialog. 

• Specify the dormer’s Width, measured 
from the outside surfaces of the dormer 
side walls.

Line Style Panel
For information about the settings on this 
panel, see “Line Style Panel” on page 434.

Roof Returns and Other Details
Home Designer Suite offers a selection of 
tools to add architectural details to your roof 
design.

Roof Returns
A roof return is a small decorative roof plane 
that connects to the low side of a gable roof 
overhang and extends below the upper 
triangular portion of the gable wall. Three 
styles of roof returns that can be produced.

The first two styles are called Gable and Hip 
returns since the return ends in a gable or hip. 

The third is called a Full return because it 
extends under the entire gable to connect 

Hip Return Gable Return
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both sides and is sometimes referred to as a 
water table. In order for a Full return to be 
created, the roof planes on each side must 
have the same height.

Roof returns are generated automatically on 
a wall by wall basis using settings found in 
the Wall Specification dialog. See “Roof 
Panel” on page 136.

These roof return settings are also found in 
the Dormer Specification dialog for gable 
roof dormers and function similarly. See 
“Roof Panel” on page 229.

Roof Pitches in Degrees

Full Return
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Chapter 15:

Stairs and
Landings

Staircases can be composed of one or more 
straight or curved stair sections and landings. 
Stairs can be drawn, selected and edited in 
2D and 3D views.

Stairwells can be created automatically or 
manually and can be seen in 3D views. 

Chapter Contents
•      Stair Defaults
•      The Stair Tools
•      Anatomy of a Staircase
•      Drawing Stairs
•      Displaying Stairs and Landings
•      Editing Stairs
•      Merging Stair Sections
•      Landings
•      Maintaining Tread Depth
•      Starter Treads
•      Wrapped Stairs
•      Other Special Railings and Stairs
•      Creating a Stairwell
•      Rooms Below Staircases
•      Staircase Specification Dialog
•      Stair Landing Specification Dialog

Stair Defaults
The purpose of interior stairs is to provide 
passage from one floor platform to another, 
so the attributes that influence floor heights - 
including ceiling heights - also influence the 
structure of stairs. When considering a 

staircase’s structure, bear in mind that riser 
height is directly dependent on the distance 
from one floor platform to another. 

Local building and fire authorities must
be consulted for specific stair construc-

tion codes and access requirements.
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The Stair Tools
Select Build> Stairs to access the 
Stair Tools.

Straight Stairs
To draw a straight staircase select 
Build> Stairs> Straight Stairs, then 

click and drag in floor plan or a 3D view. 
You can also click once to place a staircase 
that extends from the current floor up to the 
next floor. See “Drawing Stairs” on page 
235.

Click Stairs
 Select Build> Stairs> Click Stairs to 
create stairs between levels on the 

same floor with a single click of the mouse. 
Click the low side, within a few feet of where 
the floor changes height. 
• If you click on the low side of a floor 

platform defined by a railing, a doorway 
will be created in the railing, adjacent to 
the stairs. 

• If you click on the low side of a floor 
platform defined by a wall, stairs will be 
created but a doorway will not.

• If you click at a location that is not near 
the edge of a floor platform, a full height 
staircase will be created.

Curved Stairs
Select Build> Stairs> Curve to 
Left or Curve to Right and click 

once in floor plan view to place a curved 
staircase. See “Curved Stairs” on page 236.

Landing
Select Build> Stairs> Landing to 
draw a landing, which is a platform 

connecting two or more stair sections. See 
“Landings” on page 240.

There are two ways to create a landing using 
this tool:
• Click once to place a landing measuring 

39” (975 mm) on each side.
• Click and drag from end to end to draw a 

rectangular landing sized as needed. See 
“Polylines” on page 438.  

Anatomy of a Staircase
Stairs are often described in terms of rise and 
run. Rise is typically between 6" and 8", and 
the run between 10" and 12". In metric plans,  
rise is 177 to 190 mm, and the run is about 
250 mm.

Staircase Terminology
Balusters - The vertical members that run 
between the handrail and the treads or 
bottom rail. 

Bracket - Decorative L-shaped supports on 
the exposed side of stairs below each tread.
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Landing - A platform connecting two or 
more stair sections.

Newels - The end post of a stair railing 
located at landings and the beginnings and 
endings of new stair sections.

Rise - The height of a riser, measured from 
tread surface to tread surface, Also referred 
to as Unit Rise. 

Rise Angle - The angle of the staircase or 
stair section, defined by a line drawn through 
the back surfaces of its treads.

Riser - The vertical stair member located 
between the treads. Risers may be solid or 
open. When open, the front surfaces of the 
stringers are considered the risers. 

Run - The depth of a tread, measured from 
riser surface to riser surface. Run does not 
include the Tread Overhang. Also referred to 
as Unit Run. 

Runner - The carpet that runs down the 
center of the staircase.

Shoe - The bottom railing, placed on the 
landing floor, that anchors the balusters at 
landings. 

Stringer - The inclined support member of a 
staircase that supports the treads and risers.

Tread - The horizontal member of a stair that 
the foot is placed on. 

Tread Overhang - The portion of a tread 
extending past the front surface of the riser 

and over the tread below. Also referred to as 
Nosing or Nosing Extension, it is not 
included in the Run or Tread Depth 
measurements.

Thread Thickness - The vertical depth of 
the tread material.

Stair Structure and the Model
Stairs locate the height of the floor platform 
that they are drawn on, and seek the next 
level, which may be the floor platform of the 
floor above or a landing. The stringers locate 
the subfloor of the floor platforms and 
maintain consistent riser height. If the stairs 
are long enough to reach the next level at a 
reasonable rise angle, their tread depth and 
number of treads are automatically 
calculated to create a staircase with 
consistent tread and riser dimensions along 
its entire length. 

Stair Sections and 
Subsections

In Home Designer Suite, staircases can be 
composed of multiple sections and 
subsections. See “Merging Stair Sections” on 
page 238. 
• Stair sections are separated by landings.
• Subsections are considered part of the 

same section because they are connected 
to one another directly rather than sepa-
rated by a landing.  

Drawing Stairs
Stairs can be drawn in floor plan and 3D 
views but not in elevation views. In 3D 
views, these objects can only be drawn in the 

presence of a floor platform or terrain 
perimeter. See “Working in 3D” on page 394.
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There are a few things to keep in mind when 
drawing stairs:
• Before stairs are created, make sure that 

the heights for both the lower and upper 
floors are correctly defined. 

• Stairs are drawn going UP, so they should 
be drawn from the lower of the two floors 
they connect. 

• By default, stairs adjust their riser and 
tread dimensions to connect two floor 
heights if possible. The rise and run are 
calculated so that the steps are consistent 
in size. 

• Stairs will snap to the Reference Display 

, if you have it turned on. 
• If a stairwell room has been defined on 

the floor above, the top of the stairs can 
be dragged until it stops at the railing or 
wall defining the stairwell.

• When drawing stairs up from the terrain, 
it is a good idea to make sure the terrain 
is up to date. See “Building the Terrain” 
on page 300.

Straight Stairs

Straight Stairs  can be created in three 
different ways:
• Click and drag in a straight line to draw 

stairs that are the length that you drag.
• Click once to place stairs that go from the 

current floor up to the height of the next 
floor level.

• Click once using the Click Stairs  
tool to create stairs between rooms on the 
same floor with different floor heights or 
between exterior rooms and the terrain.

An individual stair section must be between 
6” (150 mm) and 100’ (30,000 mm) in 
length. If a greater length is needed, connect 
two sections using a landing.

Curved Stairs
Curved Stairs can be created in 
floor plan view by selecting 

Build> Stairs> Curve to Left or Curve to 
Right. Click to place a 90º curved stair 
section that can then be edited. You can 
continue clicking to place additional curved 
staircases until another tool is selected.
• In addition, you can change a straight 

stair section into curved stairs, or vice 
versa by selecting the stairs and clicking 

the Change Line/Arc  edit button. 
See “Change Line/Arc” on page 110.

Drawing Stairs Downward
Stairs can be drawn from the current floor 
level downward; however, drawing stairs 
between floors in this manner is not 
recommended. Drawing downward should 
only be used to create a staircase between a 
porch or deck and the terrain when you 
require the direction arrow to say “DN” 
instead of “UP”. 

To draw stairs going downward

1. Select Build> Stairs> Straight 
Stairs .

2. Hold down the Alt key or the right 
mouse button.

3. Click and drag to create straight stairs.

When drawing stairs from a floor platform to 
the terrain, or vice versa, they will locate the 
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height of the terrain as long as it is lower than 
the floor height. You can also create “room” 
outside the structure and use it to establish 

the bottom height of the stairs. Then, draw in 
an upward direction from the lower platform 
to the upper platform. 

Displaying Stairs and Landings
The display of stairs and landings in 
all views is controlled in the Display 

Options dialog. Stairs and landings are 
placed on the Stairs & Ramps” layer. See 
“Displaying Objects” on page 74.

In Floor Plan View
In floor plan view, stairs and landings display 
on the floor they were drawn on and are only 
visible from the floor above if there is a 
stairwell. 

Stairs have an arrow indicating the direction 
they run. Interior stairs have an UP arrow on 
the floor they were created on and a DN 
arrow when viewed from the floor above. 
See “Drawing Stairs” on page 235. 

The style and size of a direction arrow can be 
specified in the Staircase or Ramp 
Specification dialog. The color and display 
are controlled by the “Stairs & Ramps, Up/
Down Arrows” layer. 

When a staircase is selected in floor plan 
view, the numbers associated with each of its 

sections and subsections display. Stair 
sections are assigned a single-digit number. 
Subsection numbers have two parts: a section 
number and subsection number, separated by 
a hyphen.

In 3D Views
Although stairs span between two floors, 
they can only belong to one floor. As a result, 
only multi-floor views show the upper floor 
with the platform opening and the lower 
floor with the staircase simultaneously. In 
Floor Cameras and Doll House Views, 
stairwells may appear as an empty spaces. 
See “3D View Tools” on page 383.

Editing Stairs
Staircases can be selected and edited in floor 
plan view and 3D views. See “Selecting 
Objects” on page 86. 

Using the Mouse
When a staircase is selected, its edit handles 
display. These edit handles can be used to 
customize the object in many ways. See 
“Editing Objects” on page 85.

Stair section 
number

Stair subsection 
numbers
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• Straight stair sections are edited like 
lines. They have additional edit handles 
for resizing the width of the section. See 
“Editing Line Based Objects” on page 
88.

• Curved stair sections are edited like arcs 
and also include edit handles for resizing 
the stair’s width. See “Editing Arc Based 
Objects” on page 90.

• When stair sections are merged, the edit 
handles display differently depending on 
what subsection is currently selected. See 
“Merging Stair Sections” on page 238.

• When moving merged stair sections, all 
merged sections move as one.

• Additional edit handles display on the 
first two treads of a staircase if the 

Starter Tread  edit button is clicked. 
See “Starter Treads” on page 243. 

In the Specification Dialog
Stairs can be customized in the 
Staircase Specification dialog. See 

“Staircase Specification Dialog” on page 
248.

Using the Edit Tools
A selected staircase can be edited in a variety 
of ways using the buttons on the edit toolbar. 
See “The Edit Toolbar” on page 26.

Merging Stair Sections
Any combination of straight and curved stair 
sections using Automatic Heights can be 
merged. The resulting staircase section is 
made up of subsections and, if there are no 
landings, functions as a single unit. 

Stair subsections must be drawn in the same 
direction if they are to be merged: 
• The top edge of a stair section cannot 

merge with the bottom edge of another 
section.

• Combinations of stairs drawn in the UP 
and DOWN directions cannot be merged. 

Stair subsections merge at the center points 
of their upper and lower edges. 

To merge stair sections 

1. Confirm that the stairs that you wish to 
merge are using Automatic Heights. 
See “General Panel” on page 248.

2. Position the sections so they are in the 
desired relationship to each other. 

•  In order to merge stair sections cor-
rectly, they must be parallel to one 
another.  

•  To create merged subsections that 
change direction, make one of the 
merged sections curved.

3. Select either stair section so that its edit 
handles display.

4. Click the Extend handle on the end to be 
merged and drag it to the point where the 
two stairs are to meet. 
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A staircase consisting of merged subsections 
resembles a single stair section in floor plan 
view. The UP (or DN) arrows join, becoming 
a single direction arrow. 

When a subsection is selected, the entire 
staircase is selected. Additional edit handles, 
indicating the presence of multiple 
subsections and allowing you to reposition 
the line along which they join.  See “Using 
the Mouse” on page 237.

Curved Subsections
Stair subsections attached at both ends by 
other sections do not have a free end that can 
be dragged into a curve. In this situation, 
change the middle sub-section to a curve 

using the Change Line/Arc  edit button. 
See “Change Line/Arc” on page 110.

To curve an enclosed stair subsection

1. Draw three straight stair sections and 
connect them end to end.

2. Select the middle subsection.

3. Click the Change Line/Arc  edit 
button. The center section turns into a 
curved stair section.

4. Use the triangular Change Curve edit 
handle to adjust the curvature of the 
middle section as needed.

Merging parallel stair sections

The middle stair subsection is selected

After using Change Line/Arc
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Landings
Stair landings are platforms between stair 
sections and can be created in either of two 
ways:

• Using the Landing  tool. 
• By clicking between two stair sections 

using the Straight Stairs  tool.

To create a landing between stair sections:

1. Draw two stair sections going UP. They 
can be at any angle.

2. Click between the two sections using the 

Straight Stairs  tool to create a land-
ing. Notice that only one direction arrow 
displays after the sections are joined by 
a landing.

Multiple stair sections can be connected to 
one landing. For example, two or three stair 
sections might meet at a landing with a single 
stair section continuing to the next level.

To be linked by a landing, all sections must 
be drawn in the same UP direction and the 
top of one section should be near the bottom 
of the next.

Stair sections connected with a landing will 
move together as a single unit.

A landing formed between two stair sections 
having less than a 90º angle between them 
are created with a short edge not less than 6” 
(150 mm). This is because most building 
codes require the shortest tread to be at least 
6” wide. This edge can be manually edited to 
less than 6” if needed.

Editing Landings
Landings can be selected in 2D and 3D 
views, both individually and in groups, and 
edited using the edit handles, the edit toolbar, 
and the Landing Specification dialog. See 
“Stair Landing Specification Dialog” on 
page 253. 

Landings derive their initial materials and 
railing characteristics from the stairs attached 
to them. You can assign a unique material to 
a landing in its specification dialog or using 

the Material Painter ; however, the 
railing style is always defined by the attached 
stairs. 

Custom Shaped Landings
Landings can be edited like other closed 
polyline-based objects. You can add or 
remove edges, convert an edge from straight 
to curved, or vice versa. A curved landing 
creates curved railings. See “Editing Closed-
Polyline Based Objects” on page 96.

You can edit the shape of a landing into a 
wide variety of shapes. So that the railings of 
stair sections connect properly to the landing 
railings, make sure that each stair section end 
is snapped to a landing edge with the same 
length as the stair’s width. If necessary, use 

Creating a stair landing
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the Break Line  tool to create a break in a 
landing edge if it is longer than the 
connecting stairs are wide. See “Break Line” 
on page 109.

Landing Height
A landing’s height is controlled by the 
program and will adjust automatically as the 
stairs attached to it are modified so that the 
stairs maintain a consistent rise angle.

If you specify a landing’s height, that landing 
becomes locked and will maintain that height 
no matter how the stairs connected to it are 
adjusted.

Unlocked Landings
By default, new landings are unlocked, 
which means that their height is determined 
by the stair or ramp sections attached to it. 
An unlocked landing will automatically 
adjust its height as necessary to maintain the 
same riser height and rise angle for all 
attached sections. 

In this example, two stair sections with eight 
treads each are connected by a landing. 

Because the sections have the same number 
of treads, the landing height is one half of the 
distance between the two connected floors.

If a change is made to either stair section, the 
program will maintain the stairs’ connection 
to the floors above and below, and will 
instead modify the height of the landing and 
the other stair section so that a consistent 
riser height is maintained.

As long as a stair or ramp system consists of 
a landing connecting only two stair sections, 
the program can easily set landing heights 
and produce consistent a rise angle. If more 
than two stair sections meet at a landing, the 
relationship between them becomes more 
complex. In this situation, you may want to 
define the exact height of the landing instead 
of letting the program define it for you.

Locked Landings
A locked landing has a specifically defined 
height that does not adjust automatically 
when there are changes in the attached stairs. 
Instead, the stairs adjust to the landing. 

For example, start with the same staircase 
used to illustrate unlocked landings, with one  

Unlocked landings maintain 
   consistent riser height

home-designer-suite-2015-reference-manual.book  Page 241  Thursday, May 29, 2014  4:26 PM



242

Home Designer Suite 2015 Reference Manual

change: the landing height is now defined at 
78 inches (1980 mm). 

Since the landing height is now closer to the 
upper floor than to the lower floor, the upper 
stair section has a very shallow riser height 
and the lower section has a tall riser height.

Stair and ramp sections attached to a locked 
landing no longer relate to one another: 
• Changes to one section do not affect the 

other. 
• The Staircase and Ramp Specification 

dialogs show only the selected section 
and those connected to it by unlocked 
landings, rather than the entire system.

• Locked landings do not move when 
attached stair or ramp sections are 
moved. Only unlocked landings and the 
sections attached to them will move.

Locked landing can be used to break up a 
complex network of stairs and landings into 
smaller pieces with known bottom and top 
heights. 

To lock a landing

1. Select the landing and click the Open 
Object  edit button to open the Stair 
Landing Specification dialog. See 
“General Panel” on page 253.

2. On the General panel, uncheck Auto 
Adjust Height When Connected to 
Stairs. 

3. Specify the desired Top Height and 
click OK. 

4. The landing moves to the specified 
height and all stairs that connect to that 
landing are redefined.

To unlock a landing, open its specification 
dialog, check Auto Adjust Height When 
Connected to Stairs, and click OK. The Top 
Height will automatically adjust to any stair 
or ramp sections attached to it and will try to 
produce a staircase with a single riser height. 

Maintaining Tread Depth
Most building codes require staircases to 
maintain a consistent tread depth. 

Home Designer Suite measures a stair 
section’s length and tread depth along a Walk 
Line located 12" (30 cm) from the right edge 

of the stair section. On curved stairs, it is 
located 12” (30 cm) from the inside edge of 
the curve. 

When a curved stair section has Automatic 
Treads specified in the Staircase 

 Locked landings produce 
independent stair sections
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Specification dialog and the Walk Line is 
used, the number and/or width of treads in a 
section or subsection changes when the inner 

edge is moved. For this reason, it is best to 
finalize stair section width as early as 
possible.

Starter Treads
The first and second treads of a 
staircase can be turned into starter 

treads by clicking the Starter Tread edit 
button. Starter treads extend to the side of the 
staircase, have rounded edges and are 
common on traditional staircases. 

A starter tread can be added only to open 
sides of a stair section. If one side of a stair 
section is against a wall or wrapped (see 
“Wrapped Stairs” on page 244), only the 
exposed tread end can become a starter tread. 

To create starter treads

1. Click on a staircase to select it.

2. Click the Starter Tread  edit button. 
An edit handle displays on each end of 
both the first and second treads.

3. Drag either of the handles on the first 
tread outward from the stair section. If 
the stair section is against a wall, only 
one handle displays on the side opposite 
the wall.

4. As you drag, the ends of the tread 
become rounded.

5. Two additional edit handles display on 
each side of the tread, along the back 
edge. 

6. Drag either of the two square handles 
upward to increase the width of the 
rounded ends of the tread. 

7. Drag the edit handle on the second tread 
outward from the stair section to create a 
second starter tread. 
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8. To make changes to existing starter 
treads, select the stairs, click the Starter 

Tread  edit button and repeat the 
above steps as needed. 

9. When you are finished editing the starter 

treads, click the Main Edit Mode  to 
restore the stairs’ regular edit handles 
and toolbar buttons. 

Wrapped Stairs
Stairs can be wrapped around the corner of a 
deck or landing. Curved stairs and stairs with 
multiple subsections cannot be wrapped. See 
“Style Panel” on page 250.

To wrap stairs around a deck

1. Begin by drawing a deck. See “Decks” 
on page 151. 

2. Use the Click Stairs  tool to place a 
stair section on each side of the corner 
around which you want them to wrap.

3. Move the stair sections toward the cor-
ner of the deck. When the two sections 
are sufficiently close to the corner, they 
will merge to form wrapped steps.

To wrap stairs around a landing

1. Draw two perpendicular Straight 
Stair  sections.

2. Click between them to create a landing.
3. Rotate one stair section 180°. 

You can also draw stairs down from a
deck by right-clicking to draw them or by

pressing the Alt key while you drag. See “To
draw stairs going downward” on page 236.
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4. The stairs wrap around the corner. 
Notice that the Up arrow displays on the 
most recently edited stair section.

Other Special Railings and Stairs
Stairs can be customized to meet a variety of 
needs.

Solid Railings
To create a solid rail along a staircase, create 
the Railing against, but not underneath, the 
stairs and specify it as Solid. See “Rail Style 
Panel” on page 138.

The solid railing recognizes the adjacent 
stairs and climbs alongside them. 

If any balusters show beyond the railing, 
eliminate them by unchecking Left railing 
or Right railing in the Staircase 
Specification dialog. See “Style Panel” on 
page 250.

Creating a Stairwell
An interior staircase must be located in a 
stairwell, an opening to the floor above. A 

stairwell is an Open Below room type on the 
floor above. See “Room Types” on page 147.

Solid Railing

home-designer-suite-2015-reference-manual.book  Page 245  Thursday, May 29, 2014  4:26 PM



246

Home Designer Suite 2015 Reference Manual

If you create a stairwell away from other 
walls so the Open Below is created in the 
center of another room, connect a wall of the 
Open Below room to another wall using an 
invisible wall. 

Creating a Stairwell 
Automatically

To create a stairwell that matches the 
perimeter of a selected staircase, click 

the Auto Stairwell edit button. This button is 
only available when a living space exists 
above the staircase. It will not be available if 
the space above is Open Below or on the 
Attic Floor.

Auto Stairwell  automatically creates a 
room on the floor above enclosed by railings, 
defined as Open Below in the Room 
Specification dialog, and given a Stairwell 
room label. This room can be selected and 
edited like any other room.

Creating a Stairwell Manually
Stairwells can also be created manually. 

To create a manual stairwell

1. Draw a two-story building. Create the 
staircase on the first floor.

2. Make the second floor the Current 
Floor and the first floor the Reference 
Floor. See “The Reference Floor” on 
page 205.

3. Select Tools> Reference Floors> 
Reference Display  to show the Ref-
erence Floor, including the stairs. 

4. On the upper floor, use the Railing  
tool to create a room around the stairs. 
Use the edit handles to position the rail-
ings as needed. 

5. Select the railings one at a time and 
move them into position. 

•  When a railing is selected, its bounding 
box shows the location of the outer sur-
face of the railing’s drywall layer. For 
best results, this outer surface (which 
does not display when the railing is not 
selected) should meet the top edge of 
the stairs.

•  If you prefer, you can also go Down 
One Floor  and adjust the top edge 
of the staircase to snap it to the surface 
of the railing on the floor above.

6. When the railings are positioned prop-
erly, select Tools> Reference Floors> 
Reference Display  to turn off the 
display of the Reference Floor.

7. Click inside the room using the Select 
Objects  tool to select it, then click 

the Open Object  edit button.
8. On the General panel of the Room 

Specification dialog, select “Open 
Below” from the Room Type list. Click 
OK to close the dialog.
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9. Place a Doorway  in the railing at the 
top step for an opening. 

10. Select the doorway and define a large 
width in the Door Specification dialog. 

If the doorway is specified wider than 
the railing, its width maximizes to fit the 
space available.

 

Rooms Below Staircases
Rooms such as closets or storage areas are 
commonly located beneath staircases.

To create a room below a staircase

1. Draw a staircase, select it, and click the 

Open Object  edit button to open the 
Staircase Specification dialog.

•  On the Fill Style panel, select None 
(Transparent) so the walls and other 
objects under the stairs can be seen.

2. On the same floor as the staircase, draw 

the Interior Walls  under them, fol-
lowing their shape. 

3. Reposition the walls as needed, making 
sure that each is entirely under the stairs.

4. The wall at the foot of the stairs should 
be placed no closer to the bottom than 
the second step.

5. Add a door and specify the Room Type.

home-designer-suite-2015-reference-manual.book  Page 247  Thursday, May 29, 2014  4:26 PM



248

Home Designer Suite 2015 Reference Manual

Staircase Specification Dialog
Staircases can be defined with the 
greatest accuracy in the Staircase 

Specification dialog. To open this dialog, 
select a stair section and click the Open 
Object edit button or double-click a stair 

section using the Straight Stairs   or 
Select Objects  tool. 

If a staircase is composed of multiple stair 
sections, the section that you clicked on to 

select the staircase is the Selected Section; 
however, information about all the sections is 
available and can be edited in the dialog. 

General Panel

Staircase Information - Structural 
information about the selected staircase 

displays here for reference and updates as 
changes are made on the General panel. 

• The first comment tells whether or not 
the staircase reaches the next level. It also 
indicates whether its rise angle is either 
steeper or more shallow than the Best Fit, 

It is recommended that all floor heights,
ceiling heights and platform thicknesses

be established before using the Staircase
Specification dialog.

1
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described below. If Automatic Heights 
is unchecked, this comment instead says 
“Start and end heights are set manually”. 

• The second comment, Best fit riser 
height of ___ requires ___ total risers 
to reach ___ to next level, describes the 
ideal rise and run for the selected 
staircase. The program defines the Best 
Fit Riser Height as the riser height closest 
to 6 3/4” (168.75 mm) that allows the 
selected staircase to meet the next level 
precisely.  This comment is only active if 
Automatic Heights is checked, below.

• The total number of stair Sections, 
Landings, and Risers associated with the 
selected staircase also display here. 

• The Rise Angle of the currently active 
stair section also displays here.

• Click the Make Best Fit button to add or 
remove risers to the Selected Section. 
Only available when Automatic Heights 
is checked and the staircase does not cur-
rently use the Best Fit Riser Height. 

Make Best Fit will also extend stairs drawn 
in a downward direction until they reach the 
terrain. See “Terrain Perimeter” on page 289. 

A diagram of a sample staircase’s structure 
displays here for reference, as well. 

The Advanced Options apply to all 
sections and subsections.

• Select Automatic Treads to have the 
program define the depth and number of 
stair treads. If the staircase has multiple 
sections, each may have different tread 
depths. 

• Select Lock Tread Depth to specify the 
Tread Depth for each stair section, below, 
and prevent them from changing. When 

Lock Tread Depth is selected and the 
length of the stairs is changed, the num-
ber of treads will change.

• Select Lock Number of Treads to spec-
ify the number of treads in each stair sec-
tion and prevent it from changing. When 
Lock Number of Treads is selected and 
the length of the stairs is changed, the 
tread depths will change.

The specifications for each stair section 
and subsection are listed and can be 

edited here. A maximum of ten items can 
display. 

A change in one value usually affects other 
values. You may need to reposition the 
staircase after making changes.
• The Section Number column identifies 

the Selected Section and the number of 
each section of the selected staircase. The 
radio button to the left indicates which 
section or subsection is selected. See 
“Displaying Stairs and Landings” on 
page 237.

• Define the Length, or run, of each sec-
tion.

When the length of a section changes, 
other sections and landings in the stair-
case unit move in response. You can 
specify whether the bottom or top edge of 
the Selected Section moves when you 
resize it by selecting either the Lock Bot-
tom or Lock Top radio button, above. 

• Define the Width of each section.  If a 
section is connected to a landing, its 
width should equal the length of the land-
ing edge that it connects to. See “Land-
ings” on page 240. 

2

3
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• Specify the Tread Depth, or run, of each 
stair tread in the selected section. 

• Define the number of Treads in a stair 
section or subsection. 

• Define the Riser Height, the height of 
the risers in each stair section. 

Style Panel
The settings on the Style panel affect all stair 
sections and subsections. 

Specify the attributes of the selected 
staircase’s Stringers, which are the 

angled support members that support the 
treads. See “Anatomy of a Staircase” on page 
234. 
• Specify the height of the Stringer Top 

when Stringer at Wall or Closed 
Stringer is selected. This is measured 
along the plane of the riser face from the 
top of a tread to the top of the stringer. It 
cannot be less than 2 inches (5 cm). 

• Specify the height of the Stringer Bot-
tom, as measured from the top back cor-
ner of a tread down to the bottom edge of 
the stringer. It must be equal to or greater 
than the riser height.

• Check Stringer at Wall to produce a 
raised stringer top baseboard at the sides 
of the stair sections against walls. This 
baseboard follows the slope of the stair.

• Check Single Stringer to form a single 5-
inch (125 mm) thick stringer in the center 

1
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of the staircase. Checking Single 
Stringer automatically checks Open Ris-
ers and unchecks Stringer at Wall and 
Closed Stringer. 

• Check Closed Stringer to raise the tops 
of the exposed stringers to cover the sides 
of the treads. If this is checked, no central 
stringer is applied to open riser stairs. 
This setting only affects those stringers 
that are not against a wall.

• Check Large Stringer Base to widen the 
stringers at the foot of the staircase. This 
is helpful when walls are created below 
the stairs.

• Extend Stringer Top is checked by 
default and extends a triangular portion 
of the stringer under the landing or plat-
form at the top of the stairs.

The Open Options control whether the 
selected stairs have open risers or an 

open underside. They are not available when 
Single Stringer is checked, above. 

• Uncheck Open Underneath to add a 
skirt below the staircase along the two 
sides. It looks like a wall in 3D, but only 
has a single face. Base molding does not 
generate along the bottom of the skirt, 
and doors cannot be placed in it. In most 
cases, the recommended way to enclose 
the area beneath stairs is to use walls. See 
“Rooms Below Staircases” on page 247.

• Check Open Risers to eliminate the riser 
face under each tread and expose the 
stringers. If Closed Sides is also selected, 
no central stringer is supplied.

Specify the attributes of the staircase’s 
carpet Runner. Only available when 

Open Risers is unchecked, above.
• Specify the Runner Width. The default 

value of 0 does not create a runner. 
• Uncheck Runner Tucked to have the 

runner drop straight down from the tread 
front to the riser below. This is checked  
by default. 

Specify the characteristics of the 
staircase Treads. See “Anatomy of a 

Staircase” on page 234.
• Specify the Tread Overhang, which is 

the distance that each tread overhangs the 
riser.

• Specify the Tread Thickness.

Railing Panel
The settings on the Railing panel will also 
affect the appearance of railings on any 

landings attached to the selected staircase or 
ramp. See “Landings” on page 240.

Large Stringer Base shown at right

2

3

4
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Specify how the Railing is applied to 
the selected staircase. 

• Stair Rail Height defines the height from 
tread surface directly over the riser to 
railing top. 

• Landing Rail Height defines the height 
of the landing rail top from the landing 
surface.

• Railing at Wall - Select Left and/or 
Right to specify the placement of wall 
railings. Not available for ramps.

Newel/Baluster specifications -.

• Newel Type - Select Square, Round, or 
Library newels. Selecting Library from 
the drop-down list is the same as clicking 
the Library button to the right and 
allows selection of a newel from the 
library.

• Specify the Newel Width, which is the 
width or diameter of each newel. For 
Library newels, this is the width at its 
widest point.

• Specify the Newel Height, which is the 
height from the landing surface to the top 
of the newel. This is used only when Rail 
passes over Newel is unchecked.

• Check Newels at First Tread to place a 
newel where the rail starts at the base of 
the stairs. A newel is placed only on a 
side of the stairs not against a wall. 

• Uncheck Rail Passes Over Newel, then 
adjust the Newel Height to as needed. 
When this is checked, the Newel Height 
setting is ignored.

• Baluster Type - Select Square, Round, 
or Library balusters. Selecting Library 
from the drop-down list is the same as 
clicking the Library button to the right 

1

2
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and allows selection of a baluster from 
the library.

• Specify the Baluster Width, which is the 
width or diameter of each baluster. For 
Library balusters, this is the width at its 
widest point. 

• Cut Baluster Top - Each tread normally 
has two to three balusters, growing lon-
ger toward its back. The default is to use 
the same baluster and cut it off at the bot-
tom to shorten it toward the tread front. 
Check this box to cut the balusters at the 
top instead.

Line Style Panel
The settings on the Line Style panel are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Panel” on page 434.

Fill Style Panel
The settings on the Fill Style panel affect the 
appearance of the selected staircase in floor 
plan view. For information about these 
settings, see “Fill Style Panel” on page 439.

Materials Panel
The settings on the Materials panel affect the 
appearance of the selected staircase in 3D 
views and are available for a variety of 
objects throughout the program. For 
information about these settings, see 
“Materials Panel” on page 364.

The settings on this panel will also affect the 
materials applied to any landings attached to 
the selected staircase. See “Landings” on 
page 240.

Stair Landing Specification Dialog
Select a landing and click the Open 
Object edit button to open the Stair 

Landing Specification dialog. See 
“Landings” on page 240.

General Panel
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Uncheck Auto Adjust Height When 
Connected to Stairs to specify the selected 
landing’s Top Height. 
• A free-standing interior landing will have 

a default Top Height of 6 3/4” (169 mm) 
plus the thickness of the default floor fin-
ish. A free-standing exterior landing will 
have a default top height equal to its 
thickness. When this box is checked, the 
landing height may adjust as needed to 
maintain consistent riser height in all 
connected stair sections. 

• The Top Height field is only active when 
Auto Adjust Height When Connected to 
Stairs is unchecked. See “Locked Land-
ings” on page 241. 

Uncheck Auto Adjust Thickness When 
Connected to Stairs to specify the selected 
landing’s Thickness. 
• A free-standing landing will have a 

default thickness of 6 3/4” (169 mm). 
When checked, the thickness is based on 
the riser height of the stair sections it is 
attached to, or the thickness of the ramps 
it is attached to.

• The Thickness field is only active when 
Auto Adjust Thickness When Connected 
to Stairs is unchecked. 

Check No Rail on Selected Edge to suppress 
the railing on the selected edge of this 
landing. See “Selected Edge” on page 86.

Polyline Panel
The Polyline panel indicates the length of the 
landing’s Perimeter, its enclosed Area, and 
its Volume. 

The settings on the this panel are available 
for a variety of other objects in the program. 
For information about the settings on this 
panel, see “Polyline Panel” on page 438.

Selected Line Panel
The Selected Line panel is available when 
the selected edge is a line as opposed to an 
arc. See “Selected Edge” on page 86.

The settings on this panel are available for a 
variety of other objects in the program. For 
information about the settings on this panel, 
see “Line Panel” on page 434.

Moving the End of a line segment moves the 
start of the next connected line.

Selected Arc Panel
The Selected Arc panel is available only 
when the selected edge has been converted to 
an arc. See “Change Line/Arc” on page 110.

The settings on this panel are available for a 
variety of other objects in the program. For 
information about these settings, see “Arc 
Panel” on page 436.

Line Style Panel
The settings on the Line Style panel are 
available for a variety of objects throughout 
the program. For information about these 
settings, see “Line Panel” on page 434.

Fill Style Panel
The settings on the Fill Style panel affect the 
appearance of the selected landing in floor 
plan view. For information about these 
settings, see “Fill Style Panel” on page 439.
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Materials Panel
When a landing is attached to stairs, its initial 
materials are derived from the stairs.  

The settings on this are available for a variety 
of objects throughout the program. For 
information about these settings, see 
“Materials Panel” on page 364.
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Chapter 16:

Electrical

The electrical plan shows the location of all 
electrical objects such as lights, switches, 
outlets, smoke detectors and vent fans. Basic 
wiring diagrams show which objects share 
circuits and the locations of the controlling 
switches.

Electrical objects can be displayed in 2D and 
3D views. Some electrical light fixtures also 
add light sources to 3D views. See 
“Lighting” on page 400.

Usually, the electrical plan is one of the last 
additions to a plan since the position of most 
electrical objects is determined by the 
location of walls, cabinets and other objects.

Chapter Contents
•      The Electrical Tools
•      Auto Place Outlets
•      Creating Wiring Schematics
•      Electrical Library Content
•      Displaying Electrical Objects
•      Editing Electrical Objects
•      Electrical Service Specification Dialog

Building requirements vary throughout
the country and around the world. It is

your responsibility to comply with local codes.
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The Electrical Tools
Select Build> Electrical to access the 
Electrical Tools. 

Click in floor plan view to place an electrical 
object. Some can only be placed against 
walls, some only on the ceiling or floor, and 
some automatically change as needed. If you 
click within 12" of the wall, the selected 
object is placed on the wall. 

Once an electrical object has been placed, it 
can be edited in the Electrical Service 
Specification dialog. See “Electrical Service 
Specification Dialog” on page 262.

Outlets
Select Build> Electrical> 110V 
Outlet to place 110 volt duplex 

outlets in walls or on the floor. Select Build> 
Electrical> 220V Outlet to place 220 volt 
outlets. 

The type and height of an outlet will vary 
depending on  where it is placed. For 
example:
• In rooms defined as Bath or Master Bath, 

Ground Fault Circuit Interrupt (GFCI) 
outlets are placed. 

• An outlet placed at the back of a base 
cabinet in floor plan view is positioned 
above the counter. 

• An outlet placed at the back of a base 
cabinet containing a kitchen sink is 

placed at the standard 11 1/2" (300 mm) 
above the floor. 

• Outlets placed outside the building or in 
an exterior area such as a deck or porch 
are labeled WP, or Water Proof.

To take advantage of the program’s 
capabilities, define room types properly 
before placing electrical objects. See “Room 
Types” on page 147.

Light Fixtures
Select Build> Electrical> Light to 
place light fixtures. All light fixtures 

placed in a plan can also serve as light 
sources in  3D views. To place a light fixture 
using the Light tool
• Click near a wall to place a wall-mounted 

fixture at that location. 
• Click away from a wall to place a ceiling 

mounted light. 
• Some light symbols from the library can 

be mounted under wall cabinets, as well. 

Switches
Select Build> Electrical> Switch to 
place electrical switches as specified 

in the Electrical Defaults dialog. Like 
outlets, the height of switches is measured 
from the floor to the center of the object.

An electrical switch can be placed on either a 
wall or a cabinet, depending on the type of 
switch. A selection of each type is available 
in the Library Browser. See “Placing Library 
Objects” on page 354.

If standard outlets are placed in a room
prior to defining it as a Bath, you should

replace them with GFCI outlets.
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Auto Place Outlets
Select Build> Electrical> Auto Place 
Outlets and click in a room tool to 

place outlets at regular intervals around the 
entire room. See “Auto Place Outlets” on 
page 259.

Connect Electrical
Select Build> Electrical> Connect 
Electrical, then click and drag to draw 

splines that snap to electrical switches, 
outlets, and lights to illustrate wiring circuits. 

See “Creating Wiring Schematics” on page 
260.

Lighting and Electrical 
Library Catalogs

A selection of free-standing and 
ceiling-, wall- and cabinet-mounted 

light fixtures is available in the Library 
Browser at Home Designer Core Catalogs> 
Architectural> Lighting. 

Special use outlets, switches, jacks and 
numerous other electrical items can be found 
at Home Designer Core Catalogs> 
Mechanical, Electrical, Plumbing> 
Electrical. See “The Library” on page 341. 

Auto Place Outlets
Select Build> Electrical> Auto Place 
Outlets and click in a room to place 

110 volt outlets around the entire room, 
spaced so that no wall position is farther than 
six feet (1800mm) from the nearest outlet. 
110 or 220 volt outlets are also placed behind 
large appliances. In addition, a light is placed 
above each sink. 

It is important that a room’s Type be defined 

before Auto Place Outlets  is used so 
that outlets are placed appropriately. For 
example, GFCI (Ground Fault Circuit 
Interrupter) outlets are placed over cabinets 
in Kitchen, Bath and Master Bath rooms.  
See “Room Types” on page 147.

Auto Place Outlets  does not work in 
rooms assigned an exterior room type such as 
Deck. To place outlets in an exterior room, 

place them from the Electrical Library or use 

the 110V Outlets  tool.

Railings and invisible walls are ignored by 

Auto Place Outlets . If it is used in a 
room defined by railings or invisible walls, 
outlets are automatically placed in any 
adjacent rooms on the other side of these 
wall types. See “Room Definition” on page 
144. 

Once placed, any outlet can be moved, 
edited, or deleted. See “Editing Electrical 
Objects” on page 261. 

If you connect two or more switches in a
circuit, they update to 3-way or 4-way

switches automatically.

Note: Auto Place Outlets requires that a room
have a door before outlets can be placed.
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Creating Wiring Schematics
Electrical schematics can be created in two 

ways. Using the Connect Electrical  tool 
is quick and easy, but if you need detailed 
schematics, you can create your own wiring 
diagrams using the CAD tools. See “CAD 
Objects” on page 431. 

Connect Electrical

Select Build> Electrical> Connect 
Electrical, then click and drag to draw 

splines that snap to electrical switches, 
outlets, and lights to illustrate wiring circuits.

To create a new circuit or add to an existing 
circuit, click on a switch, outlet, or light 

while the Connect Electrical  tool is 
active, drag to the next object and 

release.Connect Electrical  splines 
cannot be snapped to one another: they can 
only snap to electrical objects. Once drawn, 
though, they can be edited to form complex 

curves. See “Editing Spline Based Objects” 
on page 100. 

To remove a connection from a circuit, 

simply select and Delete  it. If you 
remove an electrical object from a circuit, 
any Connect Electrical splines snapped to it 
will also be deleted. See “Deleting Objects” 
on page 111.

Three- and Four-Way Switches
Multiple switches can control an object or 
group of objects. 
• Two switches controlling the same 

objects are referred to as three-way 
switches. 

• Three switches controlling the same 
objects are called four-way switches. 

In floor plan view, a three- or four-way 
switches’s “way” number will automatically 
display in its 2D symbol.

Electrical Library Content
Select View> Library Browser to 
accesses a variety of electrical 

symbols. See “The Library” on page 341.

Browse for electrical objects such as bath 
vent fans, an electrical panel, fluorescent 

lights, chandeliers, a smoke detector, 
thermostat, and more. Select a symbol, then 
click in your plan to place it on a wall, floor, 
or ceiling.

Displaying Electrical Objects
The display of electrical objects and 
connections is controlled in the 

Display Options dialog. See “Displaying 
Objects” on page 74.
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When displayed in 3D views, light fixtures 
act as sources of light that help illuminate the 
3D model. See “Lighting” on page 400.

Electrical Labels
Electrical labels display in floor plan view 
when the “Electrical, Labels” layer is turned 
on and use the “Default Label Style” Text 
Style See “Object Labels” on page 429.

Customized labels can be specified in the 
Electrical Service Specification dialog.

In the Materials List
Electrical objects, including outlets, 
switches, lights, and symbols from the 
library, are listed under the Electrical 
Category in the Materials List. See 
“Materials Lists” on page 491. 

Editing Electrical Objects
Electrical objects can be selected as a group 
and individually in 2D and 3D and edited 
using the edit handles and the edit toolbar. 

Using the Edit Handles
The edit handles for electrical objects vary 
depending on the location of the object. Wall 
mounted electrical objects cannot be rotated, 
so only the Move edit handle displays.

Electrical objects placed on floors and 
ceilings can be rotated.

Electrical connections edit like splines. See 
“Editing Spline Based Objects” on page 100.

Using the Edit Buttons
A selected electrical symbol can be edited in 
a variety of ways using the buttons on the 
edit toolbar. See “The Edit Toolbar” on page 
26.

Adjusting Electrical Object 
Heights

When a wall-mounted electrical object is 
placed in floor plan view, its initial height is 
based on commonly used standards. 

An electrical object placed on a wall in a 3D 
view is positioned wherever you click on the 
wall, regardless of the height at that point. 

Note: Some electrical objects are repre-
sented in floor plan view by a symbol that
includes text. This text is not part of the
object’s label and does not use the Default
Label Text Style. 

Wall-mounted outlet in 2D and 3D views
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Once placed, a wall-mounted electrical 
object’s height can be edited in either of two 
ways: 
• Specify the height in the Electrical 

Service Specification dialog. See “Elec-
trical Service Specification Dialog” on 
page 262.

• In 3D views, the position of an electrical 
object can be adjusted using its edit han-
dles.

Deleting Electrical Objects
An electrical object can be deleted by 

selecting it and clicking the Delete  edit 
button or by pressing the Delete key.

All electrical objects in a room, on a floor, or 
in the entire plan can also be deleted as a 
group using the Delete Objects dialog. See 
“Deleting Objects” on page 111.

Electrical Service Specification Dialog
Select an electrical object and click 
the Open Object edit button to open 

the Electrical Service Specification dialog. 

The settings in this dialog vary, depending on 
the type of object(s) you select.

General Panel
The items on this panel vary, depending on 
the type of electrical object selected.
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The Name of the selected object as 
used in the Library Browser and 

Materials List displays here.

Specify the Position of the selected 
electical object. The options available 

depend on the type of object selected.
• Specify the Offset From Ceiling of a 

ceiling outlet or ceiling mounted light. If 
the light is mounted to a cabinet, this 
value is the offset from the cabinet.

• Specify the Height to Center of a 
switch, wall outlet or wall light. 

• Specify the Offset From Floor of a floor 
outlet or floor lamp. 

• Specify the Distance From Wall of a 
wall mounted symbol. A negative value 
will recess the symbol into the wall and 
may prevent it from being seen in 3D. 

Specify the Size of the selected 
electical symbol. 

• Specify the Height, Width and Depth of 
the selected symbol. 

• Click the Reset button to restore the elec-
trical symbol’s original size. 

Options - 

• Check Automatically Change Switch 
Type When Wiring for a selected switch 
to become a three- or four-way switch if 

your wiring plan later uses it as such. See 
“Connect Electrical” on page 260. 
Switches placed from the toolbar use this 
option by default; switches placed from 
the library do not. Only available for 
switches. 

Any Copyright information associated 
with the selected symbol will be stated 

here.

A preview of the selected object 
displays here. See “Dialog Preview 

Panes” on page 29. 

Materials Panel
The Materials panel is found in the 
specification dialogs for a variety of objects. 
For more information, see “Materials Panel” 
on page 364.

Label Panel
Labels for electrical fixtures display in floor 
plan view when the “Electrical, Labels” layer 
is turned on and use the “Default Label 
Style” Text Style. See “Electrical Labels” on 
page 261. 

For information about the settings on this 
panel, see “Label Panel” on page 429.

1

2

3
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6
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Chapter 17:

Trim Tools

The Trim Tools allow you to place corner 
boards and quoins at wall intersections that 
form corners. 

You can also assign moldings to a variety of 
objects, such as rooms and cabinets, in those 
objects’ specification dialogs. See 
“Specification Dialogs” on page 29.

Chapter Contents
•      Trim and Molding Defaults
•      Corner Boards
•      Corner Board Specification Dialog
•      Quoins
•      Quoin Specification Dialog
•      Editing Corner Boards and Quoins
•      Millwork
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Trim and Molding Defaults
Select Edit> Default Settings to open 
the Default Settings dialog where 

you can access the defaults for a variety of 
drawing tools, including a number that affect 
trim and moldings. 
• Select “Floor” and click the Edit button 

to specify the default moldings for rooms 
on the current floor. See “Floor Defaults” 
on page 144. 

• Click the + beside “Door” to access the 
defaults for Interior and Exterior Doors. 
See “Door Defaults” on page 161. 

• Select “Window” and click the Edit but-
ton to specify the default casing for win-
dows. See “Window Defaults” on page 
178.

Wall and Full Height cabinets in many of the 
new plan Style Templates have crown 
molding. These cabinets can be placed from 
the library into any plan. See “Cabinet 
Defaults” on page 272.

Corner Boards
Corner boards are added to a building 
exterior in any view by selecting 

Build> Trim> Corner Boards.

Click at a wall corner where you want to add 
trim. Be sure to click where the outside wall 
surfaces meet. If you click where the inside 
surfaces meet, corner trim will be created 
inside the room.

.Corner boards extend from the top plate 
down to the bottom of the floor platform of 
the floor on which it is placed, but do not 
extend to other floors. You must add corner 
boards to all floors of the building that you 
want to have corner boards. 

A selected corner board or boards can be 
moved, but only to another wall corner or 
corners.  In 3D views, corner boards can be 
lengthened or shortened using the edit 
handles. Corner boards can be copied, 
deleted and resized similar to other objects 
using the edit toolbar or  the Corner Board 
Specification dialog. 

The default material for corner boards is 
defined by the Exterior Trim entry in the 
Material Defaults dialog. See “Material 
Defaults” on page 369.
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Corner Board Specification Dialog
Select a corner board and click the 
Open Object edit button to open the 

Corner Board Specification dialog.

General Panel

Specify the Width of the selected corner 
board.

Materials Panel
The settings on the Materials panel are 
available for a wide variety of objects in the 
program. For information about these 
settings, see “Materials Panel” on page 364.

Quoins
Select Build> Trim> Quoins in any 
view and click at a wall corner where 

you want to place quoins. 

A selected quoin or quoins can be moved, 
but only to another wall corner or corners. In 

3D views, quoins can be lengthened or 
shortened using the edit handles. Quoins can 
be copied, deleted and resized similar to 
other objects using the edit toolbar or  the 
Quoin Specification dialog. 

The size of quoins in floor plan view is 
relative on their size in 3D.

Initially, quoins use the same material as the 
default material of the wall surface they are 
placed against. 
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Quoin Specification Dialog
Select a quoin and click the Open 
Object edit button to open the Quoin 

Specification dialog.

General Panel

Specify the Size of the quoins in the 
selected Quoin object. 

• Specify the Width, which is the horizon-
tal dimension of each quoin in the 
selected Quoin object. The dimension 
along the other wall is half this value 
when they are staggered or mirrored.

• Specify the Quoin Height for individual 
quoins in the selected Quoin object.

Specify the arrangement of quoins used 
by the selected Quoin object. 

• Uniform - Produce quoins that are of 
equal length on both sides of the corner.

• Staggered - Produce quoins that have 
one long side and one short side stag-
gered on opposite sides of the corner.

Materials Panel
The settings on the Materials panel are 
available for a wide variety of objects in the 
program. For information about these 
settings, see “Materials Panel” on page 364.

Editing Corner Boards and Quoins
Before a corner board or quoin can be edited, 
it must be selected. Click on a trim object 

when the Select Objects  tool is active. 
Corner boards and quoins can also be group 

selected and edited. See “Selecting Objects” 
on page 86

Corner boards and quoins can be edited using 
their edit handles, the edit toolbar buttons, 
and their specification dialogs. 

1

2
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Using the Mouse
Depending on the type of view, a corner 
board or quoin displays a different set of edit 
handles when selected. 
• In floor plan view, corner boards and 

quoins display one edit handle and can be 
moved from one eligible location at a 
wall corner to another.

• In3D views, corner boards and quoins 
can be moved, lengthened, and shorted 
much the other line-based objects are. 
See “Editing Line Based Objects” on 
page 88. 

Using the Edit Buttons
A selected corner board or quoin can be 
edited in a variety of ways using the buttons 
on the edit toolbar. See “The Edit Toolbar” 
on page 26.

Deleting Corner Trim
Corner boards and quoins can be selected 
individually or in groups and deleted using 

the Delete  edit button or the Delete key 
on the keyboard. They can also be removed 
using the Delete Objects dialog. See 
“Deleting Objects” on page 111. 

Millwork
A selection of various types of millwork 
including columns, corbels and finials is 
available in the Library Browser. See “The 
Library Browser” on page 342. 

Most millwork items can be placed in a plan 
as free-standing objects.  Some items - 

notably, newels and balusters - can be 
assigned to objects such as railings, stairs 
and ramps. See “Placing Library Objects” on 
page 354. 
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Chapter 18:

Cabinets

With Home Designer Suite’s cabinet tools 
you can create base, wall, and full height 
cabinets as well as soffits, shelves and 
partitions. These objects are very versatile, 
allowing for a wide range of customization. 

A selection of cabinet door and drawer styles 
are available in the Library Browser.

Home Designer Suite also has many 
customized cabinet symbols and cabinet 
groups available in the library.

Chapter Contents
•      Cabinet Defaults
•      The Cabinet Tools
•      Cabinet Fillers
•      Placing Cabinets
•      Displaying Cabinets
•      Editing Cabinets
•      Editing Cabinet Styles
•      Special Cabinets
•      Cabinet Specification Dialog
•      Shelf/Partition Specification Dialog
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Cabinet Defaults
Access default settings for each 
cabinet tool by selecting Edit> 

Default Settings, then clicking the + beside 
Cabinets. Select a subheading and click the 
Edit button to open the defaults dialog 
associated with your selection: 

Each type of cabinet object has default 
definitions for size, style, materials and 
more. In fact, the default dialog for each 
cabinet type is similar to its corresponding 

specification dialog. For descriptions of 
these settings, see “Cabinet Specification 
Dialog” on page 280, “Shelf/Partition 
Specification Dialog” on page 286 and 
“Soffit Specification Dialog” on page 334.

In many of the new plan Style Templates, 
Wall and Full Height cabinets have crown 
molding. These cabinets can be placed from 
the library into any plan. See “Template 
Plans” on page 40. 

General Cabinet Defaults
The General Cabinet Defaults dialog can be 
accessed only from the Default Settings 
dialog.

Specify the Minimum Cabinet Width. 
The minimum allowable width is 1/16 

of an inch (10 mm).

 Specify how Cabinet Resizing takes 
place when the edit handles are used.

• Select Use Grid Snaps to resize cabinets 
using Snap Grid increments. See “Grid 
Snaps” on page 79.

• Select Use Resize Increment to resize 
cabinets using the increment specified 
here. 

• Set the Resize Increment at which cabi-
nets resize. The minimum allowable 
increment is 1/16 of an inch (10 mm).

The Cabinet Tools
Select Build> Cabinet to access the 
Cabinet Tools.

Cabinets are easily created with a single click 
in floor plan view or any camera view. See 
“Click-to-Create” on page 80.

Typically, groups of cabinet objects are 
positioned closely together and arranged to 
form work spaces, and there are some special 
behaviors and techniques to be aware of. See 
“Placing Cabinets” on page 275.

Once created, cabinets, soffits, shelves, 
partitions and fillers can be selected and 

1
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edited much like other box-based objects. 
See “Editing Cabinets” on page 277.

Base Cabinets
Select Build> Cabinet> Base 
Cabinet and click in any view. Base 

cabinets can be placed directly under wall 
cabinets and generate a countertop and toe 
kick by default.

Wall Cabinets
To place a wall cabinet, select Build> 
Cabinet> Wall Cabinet and click in 

any view. Wall cabinets can be placed 
directly over base cabinets. 

Full Height Cabinets
To place a full height cabinet, select 
Build> Cabinet> Full Height and 

click in any view. Full height cabinets 
generate a toe kick by default and cannot be 
placed on top of other cabinets.

Soffits
Soffits typically fill the space between 
cabinet tops and the ceiling, but can 

also be used to create any object that can be 
modeled as a 3D box. To place a soffit, select 
Build> Cabinet> Soffit and click in any 
view.

By default, soffits use the material assigned 
to interior walls in the Material Defaults 
dialog. Like cabinets, soffits can have 
molding profiles applied to them.

For more information about using soffits for 
a variety of purposes, see “Other Objects” on 
page 331.

Shelves
Select Build> Cabinet>  Shelf and 
click in any view to create a shelf. 

Create corner shelves by placing one shelf on 
each wall, then moving or stretching them 
until they touch.

Once created, shelves can be selected and 
edited. See “Shelf/Partition Specification 
Dialog” on page 286.

Partitions
Select Build> Cabinet> Partition 
button and click in any view to create 

a vertical partition. 

Like shelves, partitions can be selected and 
edited after they are placed.  

Partitions can be used with shelves to create 
complex storage systems.

Cabinets Library Catalog
In the Library Browser, browse to 
Home Designer Core Catalogs> 

Architectural> Cabinets to access a selection 
of specialty cabinets. Select the library object 
you want, then click in any view to place it in 
the plan. Once placed, library cabinets can be 
edited. See “The Library” on page 341.

Cabinet Doors, Drawers, 
and Panels Catalog

A selection of cabinet door, drawer, 
and panel styles is available in  Home 

Designer Core Catalogs> Architectural. 
Select an item, then click on a cabinet in your 
plan to place the door or drawer onto that 
cabinet. Doors, drawers, and panels can be 
assigned to a cabinet in its specification 
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dialog, as well. Cabinet doors, drawers, and 
panels can also be placed as stand-alone 
fixtures. 

Built-In Appliances
A variety of fixtures and appliances such as 
sinks, cooktops, and dishwashers can be 
placed into cabinets. See “Inserted Objects” 
on page 355. 

To insert a fixture into a cabinet, select the 
fixture in the Library Browser, then click on 
a cabinet. There must be enough space in the 
cabinet or adjoining cabinets to contain the 
selected fixture. 

If a sink or cooktop is inserted into a cabinet 
with a top Drawer or Double Drawer, its Item 
Type will automatically change to a False 
Drawer or False Double Drawer. 

Once placed, an inserted fixture can be 
selected and edited:
• To select a fixture in a cabinet top, click 

on it and then click the Select Next 
Object  edit button. See “Select Next 
Object” on page 87.

• Front fixtures can only be modified or 
deleted in the Cabinet Specification dia-
log. See “Front Panel” on page 282. 

Electrical Switches and Outlets
Electrical switches and outlets placed within 
the backsplash area of a base cabinet will 
display in front of the backsplash in 3D 
views when the “Electrical” layer is turned. 
See “The Electrical Tools” on page 258.

Cabinet Fillers
By default, Home Designer Suite models a 
continuous countertop and generates fillers 
automatically when cabinets of the same 
height are either touching or placed with 3” 
(75 mm) of one another. 

If two cabinets meeting at a corner are 
separated from each other by 3”(75 mm) or 
less, the program will automatically generate 
a filler in the angle between them. A filler is 
used to separate the front of one of these 

cabinets from the one it meets so that 
drawers and doors have room to operate.

Place fixtures and appliances into cabi-
nets early, so that any resizing can be

done while there is adequate free space.
Fixtures can be added to both the top
and front of the same cabinet. It is up to

you to determine which can be effectively and
safely combined in the real world. 

Two base cabinets and the filler between them
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Placing Cabinets
Cabinets are easily created with a single click 
in any view. See “Click-to-Create” on page 
80. 

 When used near a wall corner, the Cabinet 
Tools will produce corner cabinets and 
soffits. See “Corner Cabinets” on page 279.

When created, cabinets are positioned 
relative to the floor of the room in which they 
are placed. Base and full height cabinets 
typically rest on the floor while wall cabinets 
are placed a set distance above the floor. See 
“Cabinet Defaults” on page 272.

If the ceiling height of the room does not 
accomodate the height of a cabinet, its Floor 
to Bottom value will be retained and its 
Height will be reduced so that it fits under 
the ceiling. When this happens, some front 
items may be removed from the cabinet if 
there is not enough room for them. See 
“Front Panel” on page 282.

Because cabinets are typically organized into 
groups with shared attributes, they have 
some special behaviors. 

Cabinet Snapping and Aligning
Cabinets have several special snapping and 
aligning behaviors which help you create 
precisely aligned cabinets quickly and easily.
• When Base and/or Full Height cabinets 

are within 3” of one another’s sides, they 
will snap together. Wall cabinets snap in a 
similar manner, but only with other Wall 
cabinets.

• When Base and/or Full Height cabinets 
are within 3” of one another’s sides and 
their front or back surfaces are within 3” 

of aligning, they will become aligned. 
Wall cabinets snap in a similar manner 
with other Wall cabinets as well as Full 
Height cabinets.

• When a Base and/or Full Height cabinet 
is placed against the back of another Base 
or Full Height cabinet, its back surface 
will automatically face the other cabinet’s 
back. Wall cabinets snap in a similar 
manner with other Wall as well as Full 
Height cabinets.

• When a cabinet is placed against a wall, 
its back and/or side will snap to the wall 
and, if the wall is moved, the cabinet will 
move with it.

When cabinets are snapped to a wall or to 
other cabinets, only exposed end cabinets 
have side counter overhangs.

Cabinet snapping and aligning occurs even 
when when Object Snaps are turned off; 
however, you can override this behavior by 
moving a cabinet into the desired position 
using dimensions. See “Moving Objects 
Using Dimensions” on page 414.

Cabinet Merging
When cabinets of the same height and type 
are placed side-by-side within 3” (30 mm) of 
one another they will automatically merge, 
making any shared components such as the 
toe kick, countertop, backsplash, and 
moldings continuous. Any gap between 
merged cabinets will be automatically filled.

The exposed ends of merged cabinets have 
side counter overhangs.
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Cabinets placed at different angles will also 
merge if they face toward one another and 
meet at a front corner. Cabinets that meet at a 
back corner will also merge provided that 
they face away from one another at an angle 
no greater than 87°. In either case, a filler is 
created in the angle between the two. 

If the side of a cabinet is placed within 3” (30 
mm) of a wall, the countertop will extend to 
the wall and a filler will be created. 

Base and Wall Cabinets
Base and wall cabinets have different default 
heights, so they can be placed directly above 
or below one another without interference. 
You can use Object Snaps to center a wall 
cabinet’s back center point above that of a 
base cabinet, or vice versa. See “Click-to-
Create” on page 80.

Minimum Cabinet Size
If you try to place a cabinet into a space that 
is too narrow for its default size, the program 
will place a smaller cabinet with a width that 
is a multiple of the default Resize 
Increment. For example, if you try to place a 
24” wide cabinet in a 20” wide space and 
your Resize Increment is 3”, the program 
places an 18” cabinet. See “General Cabinet 
Defaults” on page 272.

If you try to place a cabinet into a space 
narrower than the default Minimum 
Cabinet Width, a cabinet will not be placed. 
If, for example, you have a space that is 8” 
and your Minimum Cabinet Width is 9”, no 
cabinet is placed. 

Displaying Cabinets
The display of the various cabinet 
object types, labels, module lines, 

door opening indicators and more is 
controlled in the Display Options dialog. 
See “Displaying Objects” on page 74.

Cabinets are drawn so that wall cabinets, 
soffits and shelves are always in front of base 
and full height cabinets and partitions.

Cabinet labels display in floor plan view 
when the “Cabinets, Labels” layer is turned 
on and use the “Default Label Style” Text 
Style. See “Object Labels” on page 429.

Countertops display if the “Cabinets, 
Countertops” layer is turned on. 

By default, cabinet module lines display in 
floor plan view when cabinet objects of the 
same type are placed side by side. If you 
prefer that these lines not display, turn off the 
“Cabinets, Module Lines” layer. You can 
also specify whether module lines are full or 
partial. 

You can also display cabinet front indicator 
arrows in floor plan view by turning on the 
“Cabinets, Front Indicators” layer. 
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Editing Cabinets
Cabinets can be selected in 2D and 3D views 
and edited using the edit handles, the edit 
toolbar and their specification dialog.

Using the Mouse
Cabinets can be edited like other box-based 
objects. See “Editing Box-Based Objects” on 
page 98. The edit handles that a cabinet 
displays when selected will vary depending 
on the view. 

When a cabinet is selected in floor plan view 
or on its top surface in a 3D view, ten edit 
handles display: the Move handle at the 
center, the Rotate handle, and a Resize 
handle on each edge and at each corner.

In 3D views, cabinets can be selected on any 
surface: front, side, back or top. When the 
side of a cabinet is selected, five edit handles 
are available: the Move handle and a Resize 
handle on each edge. 

In the Specification Dialog
A selected cabinet can be customized 
in a variety of ways in its specification 

dialog. See “Cabinet Specification Dialog” 
on page 280. 

Using the Edit Tools
A cabinet or cabinets can be edited in a 
variety of ways using the buttons on the edit 
toolbar. See “The Edit Toolbar” on page 26.

Moving Walls with 
Cabinets Attached

When a cabinet is placed or moved against a 
wall, it will snap to the wall and become 
attached to it. When a wall is moved, all 
attached cabinets move with it. 

Moving a wall to an unattached cabinet will 
not attach the cabinet to it: the cabinet must 
be moved to the wall. A cabinet can also be 

attached to a wall when Plan Check  is 
used. See “Plan Check” on page 445. 

Editing Cabinet Styles
A variety of settings allow you customize the 
appearance of your cabinets to create styles 
ranging from traditional to contemporary.

If the desired style is known before cabinets 
are placed, you can save time by specifing 
that style in the Cabinet Defaults dialogs 

home-designer-suite-2015-reference-manual.book  Page 277  Thursday, May 29, 2014  4:26 PM



278

Home Designer Suite 2015 Reference Manual

before you start drawing. See “Cabinet 
Defaults” on page 272.

Cabinet Face Items
A variety of different face items can be 
added to the front of any cabinet, including 
doors, drawers, cutting boards, and 
horizontal separations. Face items can also 
be moved, resized, as well as removed. See 
“Front Panel” on page 282.

When adding, removing, or resizing face 
items, it is helpful to keep a few rules in 
mind: 
• When the overall height of a cabinet or 

the height of a face item is changed, the 
height of the lowest face item that is not a 
Separation is adjusted to accommodate 
the change. 

• If you increase the height of the lowest 
face item, the non-Separation item 
directly above is adjusted; if you decrease 
its height, a Blank Area and Separation 
are created below it. 

Doors, Drawers and Panels
Cabinet doors, drawers, and panels can be 
applied in either of two ways:  
• In the Cabinet Specification dialog. See 

“Door/Drawer Panel” on page 284.
• Directly from the Library  Browser.

Select a style in the library, then click on a 
cabinet to apply the selected style to that 
cabinet. In 3D views, click on a face item to 
apply the selected library object to that item. 
See “Placing Library Objects” on page 354.

Cabinet Hardware
Cabinet handles, pulls, and hinges can be 
assigned in the Cabinet Specification 
dialog. See “Door/Drawer Panel” on page 
284.

In 3D views, pulls and handles can also be 
applied directly from the Library Browser. 
Select a hardware item, then click on the 
cabinet face item to apply it to that face item.

Countertops and Backsplashes
Countertop thickness, overhang, and material 
for a selected base cabinet can be specified in 
the Base Cabinet Specification dialog. See 
“General Panel” on page 281. 

Backsplashes can also be applied to base 
cabinets, also on the General panel of their 
specification dialog.

Special Cabinets
There are a number of special cabinet shapes 
that can be specified. Certain requirements 
must be met before some special cabinet 
shapes can be specified. If the requirements 

are not met, a warning message will explain 
what is needed. See “Cabinet Specification 
Dialog” on page 280.

Note: To ensure that Face Item heights
always equal the total cabinet front height,
the program automatically adjusts the bottom
Face Item as changes are made elsewhere.
This means you should start editing Face
Items at the top and work down. 
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Standard Cabinets

Select Build> Cabinet> Base Cabinet  
and click in floor plan view to place a 
standard, rectangular base cabinet.

Corner Cabinets
To create a corner cabinet, click as close to 
an inside wall corner as possible in using 

either the Base Cabinet , Wall Cabinet 
, or Full Height  cabinet tool. A 

corner cabinet remains a corner cabinet when 
it is moved, edited or copied.

Turn an existing cabinet  into a corner 
cabinet by selecting Corner from the Special 
drop-down list in its specification dialog. See 
“General Panel” on page 281.
• Before a corner cabinet can be specified 

in the Cabinet Specification dialog, the 
cabinet’s Width must be greater than its 
Depth.

• The Left and the Right Side Widths can 
be set independently for corner cabinets. 

• You can specify a Diagonal Door on cor-
ner cabinets to create an angled corner 
cabinet. See “Front Panel” on page 282.

End Cabinets
Open a cabinet for specification and select 
Left or Right End Cabinet from the Special 
drop-down list to create an end cabinet.

• End Cabinets have an angled front and 
side.

• The cabinet width must be no greater 
than its depth for an end cabinet to be 
specified.

Standard (default) cabinet

Corner cabinet with sides of equal width

Corner cabinet with diagonal door

Left End Cabinet
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Radius End Cabinets
Open a cabinet for specification and select 
Right or Left Radius End from the Special 
drop-down list to create a radius end cabinet.

As you face the cabinet, a right radius end 
curves to the right, and a left radius end 
curves to the left.

Peninsula Radius Cabinets
Open a cabinet for specification and select 
Peninsula Radius from the Special drop-
down list to create peninsula radius cabinet.

Kitchen Islands
To create a kitchen island, simply place 
several cabinets back-to-back and/or side-to-

side. Match the widths so that each cabinet 
back or side meets the back or side of only 
one other cabinet. If this is not done, the lines 
separating the cabinets cannot be suppressed. 

Two cabinets cannot merge with the same 
side of another cabinet. The picture shows 
two instances when cabinets are placed back-
to-back. Cabinet fronts and joining surfaces 
are shown.

Blind Cabinets
Often, when two cabinets meet in a corner, 
one is partially hidden by the other. This 
partially hidden cabinet is called a “blind” 
cabinet. Home Designer Suite will resize and 
offset the front items of the partially hidden 
cabinet so that they are not located in the 
hidden portion of the cabinet face.

Cabinet Specification Dialog
Select a cabinet and click the Open 
Object edit button to open the 

Cabinet Specification dialog.

Radius End cabinets have a 90° arch

Peninsula Radius Cabinet

Correct - 
Widths of front and 

back cabinets match

Incorrect - 
Solid line here is not 

suppressed.
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The options in the Cabinet Specification 
dialogs are similar to the corresponding 

Cabinet Defaults dialog. See “Cabinet 
Defaults” on page 272.

General Panel

A number of Cabinet Types are 
available in the drop-down list. Certain 

requirements must be met before some types 
can be specified.  See “Special Cabinets” on 
page 278. 

Size/Position - The selected cabinet’s 
dimensions and position relative to the 

floor can be specified here. Fractional values 
are supported to 1/16th of an inch (1 mm).
• Specify the Height (Including Counter) 

of the cabinet box, as measured from bot-
tom to top. For base cabinets, this value 
includes the countertop thickness, but not 
the height of the backsplash. 

• Specify the Width of the cabinet box, as 
measured across the front of the cabinet 
box from left to right. This does not 
include the countertop overhang.

• Specify the Depth of the cabinet box, as 
measured from front to back. It does not 
include the thickness of overlay doors or 
the countertop overhang. 

1

2

Note: Height refers to the height of the entire
cabinet, including countertop and toe kick. If
you change the Countertop Thickness or Toe
Kick Height, the cabinet’s total height is not
altered. Instead, the cabinet face height and
the heights of face items change in response. 
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• For Corner cabinets, the Width and 
Depth fields are instead named Right 
Side Width and Left Side Width.

• Specify the Floor to Bottom distance. 
For base and full height cabinets, this is 
usually 0. 

• When the selected cabinet is outside a 
room and Auto Adjust Height is 
checked, its Floor to Bottom height is 
measured relative to the terrain height. 
When this is unchecked, the Floor to Bot-
tom height is measured from the default 
floor height of Floor 1. See “Terrain 
Height vs Floor Height” on page 290 of 
the Reference Manual. 

Specify the dimensions and style of the 
Countertop here. Only available for 

base cabinets. 
• Specify the countertop Thickness. 

Changing this value does not alter the 
cabinet height, but it does affect the 
height of face items. See “Front Panel” 
on page 282.

• Specify the countertop Overhang. The 
Overhang is used for any side of a cabinet 
not against a wall or another cabinet. 

• Check Flat Sides to eliminate the counter 
overhang on the cabinet’s exposed ends.

• Check Flat Back to eliminate the over-
hang on cabinets with an exposed back. 

The dimensions and style of the 
Backsplash are specified here. The 

backsplash only displays when the cabinet is 
against a wall. Only available for base cabi-
nets. 
• Specify the backsplash Height and 

Thickness.
• Check Side to add the same height back-

splash on the side of the cabinet if it is 
against a wall or a taller cabinet. 

• Check Always Present to display the 
backsplash at all times. If unchecked, a 
backsplash is present only when the cabi-
net is against a wall.

The backsplash for a base cabinet is 
measured from the countertop up.  

A preview of the selected cabinet 
displays on the right side of the panel. 

See “Dialog Preview Panes” on page 29. 
• The Cabinet Label displays below the 

preview pane.

Front Panel
If you click on a cabinet face item in the 
preview on the right side of the dialog, the 

Front panel will become active and that face 
item will be selected. 

3

4

5
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Most of the Face Items settings are 
only active when a door, drawer, or 

other face item is selected. To select a face 
item, choose it from the Item Number drop-
down list or click on it in the preview. When 
a face item is selected, it is  highlighted in the 
preview and its attributes can be edited. The 
vertical frame pieces on the sides of the 
cabinet front are referred to as stiles and 
cannot be selected in the preview.
• The Item Number of the selected face 

item displays here. Click the drop-down 
list to select a different item. Item num-
bers start at the top of the cabinet and go 
down the face. Item Number 1 is usually 
the top face frame Separation, or rail. 

• The Action buttons let you add, remove, 
and organize the cabinet’s face items. See 
“Cabinet Face Items” on page 278.

• Click Add New to add a new face item 
directly below the currently selected 

item. When a face item is added, the 
height of the lowest item on the cabinet 
front is reduced to make room for the 
new item. If you click Add New with no 
face item selected, the new item is added 
to the bottom of the cabinet face.

• In the New Cabinet Face Item dialog, 
define the Item Type, Item Height, and 
click OK. If the Item Type is “Separa-
tion”, you can check Default to use the 
default Separation Height. 

• Click Delete to remove the selected face 
item. When an Auto Left, Auto Right, 
Left, Right, or Double Door is deleted, it 
is replaced by an Opening; when other 

1
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face item types are deleted, the height of 
the lowest item is increased to make up 
the difference.

• Click Move Up to move the currently 
selected item up one position, switching 
places with the item directly above.

• Click Move Down to move the currently 
selected item down one position, switch-
ing places with the item directly below.

• Choose the selected face item’s Item 
Type from the drop-down list:

• Specify the selected face item’s Item 
Height. Fractional values are supported 
to 1/16th of an inch (1 mm). For best 
results, edit face item heights starting at 
the top of the cabinet and work down. 
See “Cabinet Face Items” on page 278.

• Check Include Shelves to include 
shelves in the selected “Door” or “Open-
ing” face item.

Additional Options for Corner 
cabinets and appliances inserted into 

the selected cabinet:
• Uncheck Diagonal Door to create double 

doors at right angles instead of a single 
diagonal door. This option is only avail-
able for Corner Cabinets and is checked 
by default in the Cabinet Defaults dia-
log. See “Corner Cabinets” on page 279.

• Select Reverse Appliance to reverse any 
appliances inserted into the selected cabi-
net from left to right: for example, to 
change a left hand door on a built-in 
refrigerator to a right hand door. This 
option is only available for cabinets with 
an inserted appliance. 

A preview of the selected object 
displays on the right side of the panel. 

See “Dialog Preview Panes” on page 29.  
• The Cabinet Label displays below the 

preview diagram.

Door/Drawer Panel
The settings on the Door/Drawer panel allow 
you to control the appearance of the selected 
cabinet’s doors and hardware. 

The program tries to maintain a single
separation between all face items.

When you add or delete a face item, separa-
tions are usually added or deleted with them.

Note: If the Height of an Appliance has been
changed, entering a “d” restores its default
height. See “Built-In Appliances” on page
274. 

2

3
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Specify the appearance of the Doors 
applied to selected cabinet. 

Select a door Style from the drop-down list. 
See “Doors, Drawers and Panels” on page 
278.
• Select “Use Default” to apply the door 

style specified in the defaults dialog for 
the selected cabinet’s type. See “Cabinet 
Defaults” on page 272. 

• Select “Slab Doors” to apply a flat door 
front or “Framed Doors” to apply a door 
with a frame and flat panel front.

• Select “Library” or click the Library 
button to select a cabinet door from the 
library. If a library door has been previ-
ously selected, its name will display in 
the list. See “Select Library Object Dia-
log” on page 356.

• Check Glass Doors to use a glass mate-
rial for the panel of Framed doors or for 
the entire door for Slab doors. Not avail-
able when “Library” is the selected door 
Style. 

Specify the characteristics of the 
selected cabinet’s Door Handles. 

• Select a door handle Style from the drop-
down list. 

• Specify the position of the handle In 
From Edge, as measured from the edge 
of the door opposite the hinges.

• Specify the height of the handle Down 
From Top, as measured from the top 
edge of the door. For wall cabinets, this 
value is measured Up From Bottom.

Specify the characteristics of the 
cabinet Door Hinges. 

1

2

3
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• Select a door hinge Style from the drop-
down list. 

• Specify the location of the hinges Up/
Down From Edge, as measured from the 
door edge. If the cabinet door is more 
than 35 1/4” (880 mm) high, three hinges 
will be created instead of two. 

Select a Drawer Style from the drop-
down list or choose one from the 

Library. For best results, “Framed” drawers 
should be at least  6” (150 mm) high.

Specify the characteristics of the 
selected cabinet’s Drawer Handles.  

• Select a drawer Handle Style from the 
drop-down list. 

• The In From Drawer Edge setting cre-
ates two handles the specified distance 
from the left and right drawer edges. A 
value of 0 creates a single handle cen-
tered horizontally on the drawer.

• Specify the location of the handle Down 
From Top. A value of 0 centers the han-
dle vertically on the drawer.

A preview of the selected object 
displays on the right side of the panel. 

See “Dialog Preview Panes” on page 29.  
• The Cabinet Label displays below the 

preview diagram.

Materials Panel
The settings on the Materials panel affect the 
appearance of the selected cabinet in 3D 
views. For information about these settings, 
see “Materials Panel” on page 364.

Label Panel
Cabinet labels display in floor plan view 
when the “Cabinets, Labels” layer is turned 
on and use the Text Style assigned to that 
layer.

For more information about the settings on 
this panel, see “Label Panel” on page 429.

Shelf/Partition Specification Dialog
Select a shelf or partition and click the 
Open Object edit button to open the 

Shelf Specification or Partition 
Specification dialog.

The options in these specification dialogs are 
similar to the corresponding defaults dialogs. 
See “Cabinet Defaults” on page 272.

4

5

6
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General Panel

Size/Position - Specify the Height, 
Width, Depth, and the distance from 

the Floor to Bottom of the shelf or partition. 
• When the selected object is outside a 

room and Auto Adjust Height is 
checked , its Floor to Bottom height is 
measured relative to the terrain height. 
When this is unchecked, the Floor to Bot-
tom height is measured from the default 
floor height of Floor 1. See “Terrain 
Height vs Floor Height” on page 290 of 
the Reference Manual. 

A preview of the selected object 
displays on the right side of the panel. 

See “Dialog Preview Panes” on page 29.  

Materials Panel
The settings on the Materials panel affect the 
appearance of the selected object in 3D 
views. For information about these settings, 
see “Materials Panel” on page 364.

Label Panel
Shelf and Partition labels display in floor 
plan view when the “Cabinets, Labels” layer 
is turned on and use the Text Style assigned 
to that layer. The Automatic Labels for 
Shelves and Partitions re blank, but you can 
specify custom labels

For more information about the settings on 
this panel, see “Label Panel” on page 429.

1

2
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Chapter 19:

Terrain

Home Designer Suite allows you to model 
the terrain around a house. Begin by 
specifying elevation data that creates the 
surface contours, and then add surface 
features such as planting areas and water 
features.

You can import terrain data from a variety of 
sources and use this data to produce your 3D 
model. 

Roads and sidewalks as well as plants are 
among the objects that can be placed in your 
terrain and are discussed in “Plants and 

Sprinklers” on page 323 and  “Roads, 
Driveways and Sidewalks” on page 317.

Chapter Contents
•      Terrain Perimeter
•      Elevation Data Tools
•      Terrain Modifier Tools
•      Terrain Feature Tools
•      Garden Bed Tools
•      Water Feature Tools
•      Stepping Stone Tools
•      Terrain Wall and Curb Tools
•      Terrain Objects in the Library

Terrain Perimeter
The Terrain Perimeter is a closed 
polyline defining the boundary of the 

terrain that generates in 3D views and of the 
contour lines that generate in floor plan view. 
A Terrain Perimeter should be present in 
your plan already, but if one is not, select 
Terrain> Create Terrain Perimeter to 
create one.
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If you create a terrain perimeter in floor plan 
view but do not see it, select Window> Fill 
Window . See “Zoom Tools” on page 
374. 

Once created, the terrain perimeter can be 
resized and edited like other polyline-based 
objects. See “Editing Closed-Polyline Based 
Objects” on page 96. 

When a terrain perimeter is first created, it is 
completely flat and is placed at a height of 
0’-0”, or sea level.

The terrain perimeter by itself does not have 
elevation data associated with it. You can use 

the Elevation Data  and Terrain 
Modifier  tools to create terrain that 
slopes in a wide variety of ways. If you do 
not create elevation data within the terrain 
perimeter, the terrain remains flat at an 

elevation of 0' - 0". See “Elevation Data 
Tools” on page 291 and “Terrain Modifier 
Tools” on page 294.

Terrain Height vs Floor Height
Home Designer Suite always defines the 
default height of Floor 1 at 0’-0”. This height 
value is the constant by which the heights of 
architectural objects and structural elements 
in the program, including walls, floors, and 
ceilings, are measured. 

The default height of Floor 1 is not, however, 
the absolute by which terrain elevation is 
measured. Instead, elevation data is  
measured relative to sea level. This means 
that if you want to, you can use real-world 
elevation data to generate a 3D terrain model 
without also having to measure floor and 
ceiling heights from sea level. See 
“Importing Elevation Data” on page 311. 

The program automatically positions Floor 1 
a set distance above the terrain. To do this, it 
first finds the center point of the building 
footprint. Then, it determines the elevation of 
the terrain at that point. Finally, it adds 6” 
(150 mm) plus the thickness of the floor 
platform to this value. The resulting value, 
referred to as the Building Pad Elevation, is 
how far the default height of Floor 1 is above 
sea level in the current plan. See 
“Foundations and the Terrain” on page 212.

In a plan with a foundation present, the 
Elevation distance will equal the exact 
terrain elevation at the building footprint 
center point, plus 6” (150 mm), plus the 
thickness of the floor platform.
• In a plan with no elevation data, the ter-

rain is assumed to be at sea level and this 
Elevation distance is 6” (150 mm) plus 

Terrain Perimeter

    Terrain perimeter at 0' - 0" in a 3D view
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the thickness of the floor platform when a 
foundation is present. 

• In a plan with flat terrain at 100’ (30 m) 
and a foundation present, the Elevation 
distance is 100’ 6” (30.468 m) plus the 
thickness of the floor platform.

Once terrain has been built, the Elevation 
distance is stated in the Terrain 
Specification dialog. You can specify a 
custom Elevation value to produce a daylight 
or walkout basement. See “General Panel” 
on page 301. 

Build Terrain
Select Terrain> Build Terrain to 
generate the terrain surface based on 

the provided elevation data. Build Terrain 
also updates the Building Pad Elevation 
value in the Terrain Specification dialog. 
See “Building the Terrain” on page 300.

The Terrain Perimeter has a variety of  
editable properties that affect the appearance 
of the terrain in 2D and 3D views.  See 
“Terrain Specification Dialog” on page 301.

Elevation Data Tools
Select Terrain> Elevation Data to 
add elevation information to your 

terrain. 

When terrain is generated, this data is used to 
calculate the surface of your site and is 
represented by contour lines in floor plan 
view and a curved surface in 3D. See 
“Displaying Terrain” on page 299.

Elevation data can be specified using the 

Elevation Point , Elevation Line ,  
and Flat Region  tools. 

Elevation data can also be imported. See 
“Importing Elevation Data” on page 311.

The elevation of each Elevation Line, Spline 
and Region is specified relative to sea level. 

In order to create rising and/or falling terrain, 
multiple terrain data objects with different 
elevation values must be used. If only one 

terrain data object is placed, the terrain will 
be flat regardless of the object’s specified 
elevation.

Elevation Points
An Elevation Point contains the 
absolute elevation data for one point 

in the terrain model. Typically, Elevation 
Points are imported rather than placed 
manually. 

Home Designer Suite requires many points 
to make an accurate approximation of your 
site. Even small sites may require over a 
hundred points to generate an accurate model 
of the terrain if it is sloped. For the sake of 

Note: When no foundation has been built, the
distance from Floor 1 to the terrain is 12” (320
mm). 

To avoid unexpected results, do not
draw Elevation Data objects with differ-

ent elevation information at the same loca-
tion. 
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illustration, the following example shows 
only a few elevation points.

To place an elevation point

1. Select Terrain> Elevation Data> Ele-
vation Point  and click in floor plan 
view at the point where you would like 
to place elevation data.

2. The Elevation Point Specification dia-
log opens. Enter an elevation value and 
click OK. See “Elevation Point Specifi-
cation Dialog” on page 303.

3. Click somewhere else in floor plan view 
and the Elevation Point Specification 
dialog opens again with the last eleva-
tion value entered. 

4. Repeat steps 1, 2 and 3 to place addi-
tional elevation points with varied eleva-
tion values as needed.

5. Select Terrain> Build Terrain . See 
“Building the Terrain” on page 300.

Elevation Lines
An Elevation Line contains absolute 
elevation data for many points along a 

line at a constant elevation. Elevation lines 
can be connected to create a polyline with 
many straight sections. For the sake of 
illustration, the images in the following 
example show single-section elevation lines.

To draw an elevation line

1. Select Terrain> Elevation Data> Ele-
vation Line , then click and drag a 
line inside the Terrain Perimeter in floor 
plan view. 

2. Click on the elevation line to select it, 

then click the Open Object  edit but-
ton.

3. At first, an elevation line is at elevation 
0' - 0". In the Elevation Line 

Elevation Points before terrain generation

Elevation Points are most effective
when they are imported. When adding

elevation data manually, use Elevation Lines
instead. See “Importing Elevation Data” on
page 311.

Contour lines after terrain generation
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Specification dialog, specify the desired 
elevation and click OK. See “Elevation 
Line/Region Specification Dialog” on 
page 304.

4. Repeat steps 2 and 3 to draw additional 
elevation lines as needed. 

5. Select Terrain> Build Terrain . See 
“Building the Terrain” on page 300.

After it is drawn, an Elevation Line can be 
edited much the way other line-based objects 
can. See “Editing Line Based Objects” on 
page 88. 

Elevation Regions
An Elevation Region contains 
absolute elevation data for an 

enclosed region and is ideal for creating a flat 
surface in your terrain. 

To create an elevation region

1. Select Terrain> Elevation Data> Ele-
vation Region . 

2. There are two ways to add a Terrain 
Modifier to your plan: 

•  Click once to place an 8’ (0.6 m) 
square feature at that location.

•  Click and drag from end to end to draw 
a feature sized as needed. See “Draw 
Polyline” on page 432.

3. Click on the region to select it, then click 

the Open Object  edit button.
4. At first, an elevation line is at elevation 

0' - 0". In the Elevation Region 
Specification dialog, specify the desired 
elevation and click OK. See “Elevation 
Line/Region Specification Dialog” on 
page 304.

120"

0"

Elevation Lines before terrain generation

Contour lines after terrain generation

Full Overview after terrain generation
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An Elevation Region  can also be created 
by drawing a closed polyline using Eleva-
tion Lines . 

After it is drawn, and Elevation Region can 
be reshaped much the way other closed 
polyline-based objects can. See “Editing 
Closed-Polyline Based Objects” on page 96.

Terrain Modifier Tools
Select Terrain> Modifier to access 
tools that allow you to modify the 

existing elevation data by drawing a closed 
polyline. Their height is relative to the terrain 
surface generated from the Elevation Data 
provided in your plan. 

The elevation data associated with a Terrain 
Modifier only affects the terrain within its 

perimeter. The rest of the terrain is 
unaffected. 

Raised and Lowered Regions
The Raised Region tool creates a 
raised area with a top surface that 

is flattened like a plateau but follows the 
surface of the terrain. The Lowered Region 

240"

0"

120"

Elevation lines create a terrain grade; an 
elevation region creates a building pad.

Contour lines after terrain generation

Full Overview after terrain generation
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tool creates a depression with a bottom that 
follows the terrain and is flattened. 

Hills and Valleys
The Hill and Valley tools create 
raised and lowered areas in the 

terrain that come to a point rather than  
flattening at their highest or lowest 
elevations. 

There are two ways to add a Terrain Modifier 
to your plan: 
• Click once to place a modifier with end-

points that form a 10’ (4 m) square at that 
location. 

• Click and drag from end to end to draw a 
feature sized as needed. See “Draw 
Polyline” on page 432.

Terrain Modifiers can only be drawn when a 
Terrain Perimeter is present, and will only 
display in 3D when they are drawn within the 
perimeter. See “Displaying Terrain” on page 
299.

Once created, Terrain Modifiers can be 
selected and edited in a variety of ways. See 
“Editing Spline Based Objects” on page 100. 

Terrain Feature Tools
Select Terrain> Feature to access 
tools for drawing bounded areas that 

follow the contours of the terrain rather than 
modifying them. 

Terrain Features are useful for creating 
landscaping features because they have 
specified heights and materials. You can, for 
example, create paths and planting beds with 
gravel or mulch materials that stand out in a 
grassy Terrain Perimeter. See “Adding 
Terrain Features” on page 142 of the User’s 
Guide. 

In fact, Driveways , Garden Beds , 

Water Features  and Stepping 
Stones  are special Terrain Features with 
material and height attributes already applied 
to them, saving you time when drawing these 
objects.

Terrain Features can only be drawn when a 
Terrain Perimeter is present, and will only 
display in 3D when they are drawn within the 
perimeter. See “Displaying Terrain” on page 
299.

Lowered 
Region

Raised 
Region

Valley
Hill
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Terrain Features can be created in either of 
two ways: 
• Click once to place a feature with end-

points that form a 10’ (4 m) square at that 
location. 

• Click and drag from end to end to draw a 
feature sized as needed. See “Draw 
Polyline” on page 432.

Once created, Terrain Features can be edited 
into nearly any shape you require. See “Edit-
ing Closed-Polyline Based Objects” on page 
96 and “Editing Spline Based Objects” on 
page 100.

Rectangular Features
The Rectangular Feature tool can be 
used to create straight-sided features 

that can be edited into a wide variety of 
shapes. 

Rectangular Features can also be edited like 
other closed polyline-based objects. See 
“Editing Closed-Polyline Based Objects” on 
page 96.

Round Feature
The Round Feature tool can be used 
to create features with rounded edges 

and smoothly curved corners. 

Round Features can be edited like other 
closed spline-based objects. See “Editing 
Spline Based Objects” on page 100.

Kidney Shaped Features
The Kidney Shaped Feature tool 
allows you to quickly create features 

with curved edges, smooth corners and a 
right angle bend in its shape.

Kidney Shaped Features can be edited like 
other closed spline-based objects. See “Edit-
ing Spline Based Objects” on page 100.

For information about adding height and 
material information to Terrain Features, see 
“Terrain Feature Specification Dialog” on 
page 305.

Terrain Holes
A Terrain Hole is a region that cuts a 
hole in the terrain. 

Terrain Holes  are useful for manually 
clipping the terrain around a foundation that 
does not match the footprint of the first floor.

Garden Bed Tools
Select Terrain> Garden Bed to 
access tools that can be used to place 

garden bed features in your terrain. 

Garden Beds are basically Terrain Features 
with material and height attributes typical of 

planting beds. See “Terrain Feature Tools” 
on page 295.

In addition, you can choose to distribute 
copies of a plant image within a Garden Bed. 
See “Distributed Plant Panel” on page 306.

Terrain Features can be drawn in 2D
and 3D views. 
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Polyline Garden Bed
This tool draws a garden bed with 
straight sides and four right angles. 

See “Rectangular Features” on page 296.

Round Garden Bed
Use this tool to draw garden beds with 
rounded edges and smoothly curved 

corners. See “Round Feature” on page 296. 

Kidney Shaped Garden Bed
You can draw a kidney shaped garden 
bed with this tool. See “Kidney 

Shaped Features” on page 296.

Once drawn, Garden Beds can be selected 
and edited just like other Terrain Features. 

Specify the material and set the height of 
Garden Beds in the Terrain Feature 
Specification dialog.  See “Terrain Feature 
Specification Dialog” on page 305. 

Water Feature Tools
Select Terrain> Water Feature to 
access tools for drawing ponds and 

streams in your terrain.

Ponds are basically Terrain Features with 
material and height attributes typical of 
bodies of water. See “Terrain Feature Tools” 
on page 295.

Similarly, Streams are Terrain Curbs with a 
water material. See “Terrain Wall and Curb 
Tools” on page 298. 

Round Pond
Use this tool to draw a pond with 
rounded edges. See “Round Feature” 

on page 296. 

Kidney Shaped Pond
This tool draws a kidney shaped pond. 
See “Kidney Shaped Features” on 

page 296.

Stream
Select the Stream tool, then click and 
drag to draw a stream. Streams are 

drawn and edited the same way that splines 
are. See “Splines” on page 433 and “Editing 
Spline Based Objects” on page 100.

Streams follow the contours of the terrain, so 
they may appear to flow uphill if they are not 
drawn correctly in the terrain. Try to draw 
them so that they follow a downward course 
for their entire length.

Once drawn, Water Features can be selected 
and edited just like any other Terrain Feature. 

Specify the material and set the height of 
Water Features in their specification dialogs.  
See Terrain Object Specification Dialogs on 
page 689.  
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Stepping Stone Tools
Select Terrain> Stepping Stone to 
place a walkway made of individual 

stepping stones. 

Stepping Stones are basically Terrain 
Features with material and height attributes 
typical of walking paths. See “Terrain 
Feature Tools” on page 295.

There are two ways to draw Stepping Stones: 
• Click once to place a stepping stone with 

endpoints that form a 1’ (300 mm) square 
at that location. 

• Click and drag from end to end to draw a 
stepping stone sized as needed. See 
“Draw Polyline” on page 432.

Polyline Stepping Stone
The Polyline Stepping Stone tool 
draws rectangular stepping stones. See 

“Rectangular Features” on page 296. 

Round Stepping Stone
The Round Stepping Stone tool 
draws stepping stones with rounded 

edges. See “Round Feature” on page 296.

Once drawn, Stepping Stones can be selected 
and edited just like any other Terrain Feature. 

By default, Stepping Stones have a concrete 
material; however, you can specify the 
material and set the height of Stepping 
Stones in the Terrain Feature Specification 
dialog.  See “Terrain Feature Specification 
Dialog” on page 305. 

Terrain Wall and Curb Tools
Select Terrain> Terrain Wall and 
Curb to draw landscaping walls and 

curbs that follow the contours of the terrain. 

Straight and curved Terrain Walls and Curbs 
are drawn just as other walls are. See 
“Drawing Walls” on page 122.

Terrain Walls and Curbs are examples of 
Terrain Paths. Other examples include 
Sidewalks and Streams. See “Terrain Path 
Specification Dialog” on page 309.

Terrain Walls
Use the Straight Terrain Wall tool to 
draw a wall that sits on top of and 

follows the terrain. 

Use the Spline Terrain Wall to draw 
a curved terrain wall. This wall is 

drawn the same way as a CAD Spline. See 
“Splines” on page 433.

Once drawn, a Terrain Wall can be like other 
line-based objects. See “Editing Line Based 
Objects” on page 88 and “Editing Spline 
Based Objects” on page 100.

Terrain walls are 5’ (1500 mm) high and con-
crete by default, but you can specify the 
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material, height and more in the Terrain Path 
Specification. See “Terrain Path 
Specification Dialog” on page 309. 

Retaining Walls
Use the Straight Retaining Wall tool 
draws a straight wall that holds back 

sloped terrain.

Use the Curved Retaining Wall tool 
to draw a curved retaining wall. 

A Retaining Wall’s height is determined by 
the elevation of the terrain on each side. By 
default, the height of the wall matches the 
terrain on the high side of the break and the 
bottom matches the low side. If you insert a 
Retaining Wall into flat terrain, it looks like a 
concrete strip in 3D views.

Once drawn, a Retaining Wall can be edited 
much like other walls. See “Editing Walls” 
on page 127.

Terrain Curbs
Terrain Curbs are useful for creating curbs 
around planting beds and along paths, 
driveways and roads.

Use the Straight Terrain Curb tool 
to draw a straight landscaping curb.

 Use the Spline Terrain Curb tool to 
draw a curved landscaping curb. This 

curb is drawn the same way as a CAD 
Spline. See “Splines” on page 433. 

Once drawn, a Terrain Curb can be like other 
line-based objects. See “Editing Line Based 
Objects” on page 88 and “Editing Spline 
Based Objects” on page 100.

You can specify the height of straight and 
spline terrain curbs on the General panel of 
the Terrain Path Specification. See “Terrain 
Path Specification Dialog” on page 309. 

Terrain Objects in the Library
The Library Browser contains a 
variety of objects that can be placed in 

a plan’s terrain, including plants, exterior 

fixtures, accessories and roadway objects. 
See “The Library Browser” on page 342. 

Displaying Terrain
The display of terrain objects in 2D 
and 3D views is controlled in the 

Display Options dialog. See “Display 
Options Dialog” on page 75.

You can customize appearance of Terrain 
Features, Roads and other terrain objects in 
floor plan view by changing their line and fill 
styles.  

You can also add Fencing to your ter-
rain, complete with gates from the

Doors Library. See “Fencing Tools” on page
119. 
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Plant images are represented in floor plan 
view by 2D CAD symbols. You can select a 
plant’s symbol in the Plant Image 
Specification dialog. See “Image Panel” on 
page 327. 

When elevation data has been drawn or 
imported into a plan, contour lines will 
display in floor plan view. See “Elevation 
Data Tools” on page 291.

In 3D Views
In order for objects such as Terrain Features 
and Roads to be visible in 3D views, the 
Terrain Perimeter layer must also display. In 
addition, only the portions of these objects 
that are drawn within the Terrain Perimeter 
will be seen in 3D views. See “Terrain 
Feature Tools” on page 295.

A variety of tools are available to help you 
adjust the perspective of your 3D views. See 
“Editing 3D Views” on page 391.

Building the Terrain
When terrain is generated, Home 
Designer Suite gathers all elevation 

data that has been added to the model and 
creates a terrain surface. The program 

interpolates the data to produce smooth 
contours. 

A terrain perimeter with no additional 
elevation data drawn within it generates 
terrain that is flat at the elevation 0' - 0", or 
sea level. 

The terrain is automatically built before a 3D 
view is generated. This process takes a 
variable amount of time, depending on the 
amount of elevation data and number of 
terrain features in the plan. The Building 
Terrain progress dialog displays as terrain is 
generated, sometimes only briefly, indicating 
the progress.

Terrain and 3D Drawing Time
Terrain is typically large with many surfaces, 
which often increases the drawing time of 3D 
views. The time required is affected by the 
amount of elevation data and number of 
terrain features present.  

Lights and symbols can be placed outdoors 
and included in 3D views when the terrain is 
generated. These objects can also contribute 
to the time needed to generate 3D views. See 
“Rendering Tips” on page 399.

Editing Terrain Objects
Before a terrain object can be edited, it must 
be selected. All terrain objects can be 
selected in floor plan view. In addition, the 
Terrain Perimeter and Terrain Features can 
be selected in 3D views. See “Selecting 
Objects” on page 86. 

A selected terrain object can be edited using 
its edit handles, edit tools and specification 

dialog. See “Specification Dialogs” on page 
29.

Any time elevation data is changed, the 
terrain must be regenerated. This occurs 
automatically when a 3D view is created. It 
can also be done manually by selecting 

Terrain> Build Terrain .
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Using the Edit Handles
• The shape of the Terrain Perimeter can be 

edited like other polyline-based objects. 
See “Editing Closed-Polyline Based 
Objects” on page 96. 

• Elevation Points can be moved in floor 
plan view using the Move edit handle.

• Elevation Lines are edited like other line-
based objects. See “Editing Line Based 
Objects” on page 88 and “Editing Closed-
Polyline Based Objects” on page 96. 

• The shape of a Raised Region, Lowered 
Region, Hill, and Valley can be edited 
like a spline. See “Editing Spline Based 
Objects” on page 100.

• Terrain Features are edited like other 
spline- and polyline-based objects. See 
“Editing Closed-Polyline Based Objects” 
on page 96 and “Editing Spline Based 
Objects” on page 100.

Using the Edit Tools
A selected terrain object can be edited 
in a variety of ways using the buttons 

on the edit toolbar. The edit tools available 
for a terrain object depends on the type of 
terrain object selected. See “The Edit 
Toolbar” on page 26.

Terrain Specification Dialog
The Terrain Specification dialog 
controls how your terrain is modeled, 

as well as its appearance.

The Terrain Specification dialog can be 
accessed in any of two ways:

• Select the Terrain Perimeter and click the 

Open Object  edit button.
• Double-click the Terrain Perimeter using 

the Select Objects  tool. 

General Panel

Note: If you copy terrain objects from one
plan to another, you cannot view the pasted
objects in 3D unless a Terrain Perimeter
exists. 
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Specify how the Building Pad is 
generated beneath the structure. See 

“Foundations and the Terrain” on page 212. 
• To specify the distance between Floor 1 

and the terrain at the building footprint 
center, uncheck Automatic and enter a 
value in the Pad Elevation field.

• Check Automatic to have Home 
Designer Suite automatically lower the 
terrain relative to the first floor.  See “Ter-
rain Height vs Floor Height” on page 290.

• Check Flatten Pad to flatten the area 
beneath the building. To create a walkout 
basement, uncheck this box.

Clipping - Check Hide Terrain 
Intersected by Building to cut out the 

portion of the terrain that is intersected by the 
first floor footprint. Checking this box 
prevents the generation of contour lines 
inside the house. 

Polyline Panel
The Polyline panel indicates the polyline’s 
Length/Perimeter, its enclosed Area, and 
its Volume. 

The settings on the this panel are available 
for a variety of other objects in the program. 
For information about these settings, see 
“Polyline Panel” on page 438.

Selected Line Panel
The Selected Line panel is available when 
the selected edge of the Terrain Perimeter is a 
line as opposed to an arc. See “Selected 
Edge” on page 86.

The settings on this panel are available for a 
variety of other objects in the program. For 
information about these settings, see “Line 
Panel” on page 434.

Selected Arc Panel
The Selected Arc panel is available when the 
selected segment of the polyline is an arc as 
opposed to a line. See “Change Line/Arc” on 
page 110.

The settings on this panel are available for a 
variety of other objects in the program. For 
information about these settings, see “Arc 
Panel” on page 436.

Line Style Panel
The settings on the Line Style panel are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Panel” on page 434.

Fill Style Panel
The settings on the Fill Style panel affect the 
appearance of the Terrain Perimeter in floor 
plan view. For information about these 
settings, see “Fill Style Panel” on page 439.

Materials Panel
The settings on the Materials panel let you 
specify the terrain surface and terrain skirt 
materials used in 3D views. These materials 
are not calculated in the Materials List. See 
“Materials Panel” on page 364.

1

2
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Elevation Point Specification Dialog
To open the Elevation Point 
Specification dialog, select an eleva-

tion point and click the Open Object edit 
button, or double-click on an Elevation Point 

using the Select Objects  tool.

Use the Elevation Point Specification 
dialog to define the selected elevation point 
and control its appearance in floor plan view. 

Location - Specify the exact location of 
the elevation point.

• Specify the Elevation of the selected Ele-
vation Point. 

• X Coordinate - Enter the x coordinate of 
the elevation point.

• Y Coordinate - Enter the y coordinate of 
the elevation point.

Display -  

• In the Text field, type any notes that you 
would like to display beside the selected 
Elevation Point in floor plan view. You 
can also enter a pound (#) sign to display 
the point’s elevation value. 

• Enter the Marker Radius , which is size 
of the point marker, measured from the 
center to an edge. 

Line Style Panel
The settings on the Line Style panel are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Panel” on page 434.

Text Style Panel
The settings on the Text Style panel control 
the appearance of the selected Elevation 
Point’s text. For more information, see “Text 
Style Panel” on page 428. 

1

2
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Elevation Line/Region Specification Dialog
To open the Elevation Line or 
Elevation Region Specification dia-

log, select one or more Elevation Line, or a 
polyline composed of elevation Lines, or an 
Elevation Region and click the Open Object 
edit button. You can also double-click an 

Elevation Line using the Select Objects  
tool.

The Elevation Line Specification dialog is 
used to define the selected Elevation Line 
and controls its appearance in floor plan 
view. 

The settings in this dialog are the same as 
those in the Elevation Region Specification 
dialog. See “Elevation Regions” on page 
293. 

Elevation Panel

• Specify the Elevation of the selected Ele-
vation Line, Spline, or Polyline.

Polyline Panel
The Polyline panel indicates the line or 
polyline’s Length/Perimeter. If multiple 

Elevation Line segments form a closed 
Elevation Region, its Area will be calculated. 
Elevation Lines do not have a thickness, so 
they have no Volume. 

Selected Line Panel
The Selected Line panel is available when 
the selected object or segment is a line as 
opposed to one that has been converted to an 
arc. See “Selected Edge” on page 86.

The settings on this panel are available for a 
variety of other objects in the program. For 
information about these settings, see “Line 
Panel” on page 434.

Selected Arc Panel
The Selected Arc panel is available when the 
selected object or segment is an arc as 
opposed to a line.

The settings on this panel are available for a 
variety of other objects in the program. For 
information about these settings, see “Arc 
Panel” on page 436.

Line Style Panel
The settings on the Line Style panel are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Panel” on page 434.

Hill / Valley Specification Dialog
The Hill/Valley Specification defines 
the selected Hill or Valley and 

controls its appearance in floor plan view. 
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To open the Hill/Valley Specification dialog, 
select a Hill or Valley and click the Open 
Object edit button, or double-click the 

region(s) using the Select Objects  tool.

Hill / Valley Panel

• Enter a Height for the selected Hill or 
Valley. This height is relative to the ter-
rain surface that is generated from the 
Elevation Data in your plan. See “Terrain 
Modifier Tools” on page 294.

Polyline Panel
The Polyline panel indicates the polyline’s 
Length/Perimeter and its enclosed Area. 
Hills and Valleys do not have a volume 
measurement.

Line Style Panel
The settings on the Line Style panel are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Panel” on page 434.

Fill Style Panel
The settings on the Fill Style panel affect the 
appearance of the selected object in floor 
plan view. For information about these 
settings, see “Fill Style Panel” on page 439.

Raised / Lowered Region Specification Dialog
To open the Raised/Lowered Region 
Specification dialog, select a raised 

or lowered region and click the Open Object 
edit button, or double-click the region(s) 

using the Select Objects  tool.

The Raised / Lowered Region 
Specification dialog is similar to the Hill / 
Valley Specification dialog. See “Hill / 
Valley Specification Dialog” on page 304.

Terrain Feature Specification Dialog
To open the Terrain Feature 
Specification dialog, select a Terrain 

Feature and click the Open Object edit 
button, or double-click the Terrain Feature 

using the Select Objects  tool.

Most of the panels in this dialog are similar 
to those for a variety of other objects in the 

program, including Water Features, Stepping 
Stones, Driveways, and Parking Lots.

Garden Beds are also a type of Terrain 
Feature and have an additional Distributed 
Plant panel in their specification dialog. 
Garden Beds also have a preview pane on the 
right side of their specification dialog. 
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General Panel

• Specify the top Height of the Terrain Fea-
ture, relative to the terrain surface, using a 
positive or negative number. 

• Specify the feature’s Thickness.

If a feature’s height above the terrain is 
greater than its thickness, the program will 
fill in the resulting gap.

• Check Clip Overlapping Terrain Fea-
tures to suppress the 3D display of any 
part of the selected Terrain Feature inter-
sected by other Terrain Features with a 
lower Height value. Clipping is useful for 
creating features that contain other fea-
tures such as planters or swimming pools.

Distributed Plant Panel
This panel is only available when the 
selected Terrain Feature is a Garden Bed. See 
“Garden Bed Tools” on page 296.
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Specify the Current Object assigned 
to the selected garden bed. When an 

object is assigned, its name and a preview of 
a single instance of it display here. 
• Click the Select button to choose an 

object from the library. See “Select 
Library Object Dialog” on page 356.

• Click the Delete button to unassign the 
Current Object from the selected garden 
bed.

• Click the Edit button to open the Current 
Object’s specification dialog. Changes 

made here affect all objects generated 
within the garden bed. See “Specification 
Dialogs” on page 29.

Display Options - 

• Check Show Objects to display the dis-
tributed objects in floor plan view.

• Check Show Region to display the edges 
of the garden bed in floor plan view.

Object Spacing - Specify how the 
objects in the garden bed are spaced. 

1

2

3
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• Specify the Distance between the objects 
in the garden bed, as measured from their 
center points. 

• Select Standard Grid to position the 
objects in rows and columns based on the 
standard X/Y grid in the program. 

• Select Alternate Grid to position the 
objects in rows and columns based on the 
shape of the garden bed. 

Object Orientation - Specify how or if 
the objects in the garden bed are 

rotated. These settings do not affect the 
garden bed itself or its edges.
• Specify the Angle that the distributed 

objects should be placed at. 
• Select Absolute Angle to rotate the 

objects to the specified Angle as mea-
sured from an imaginary horizontal line 
drawn from the origin towards the right. 

• Select Relative Angle to rotate the 
objects relative to the angle of the 
region’s first edge or, if that edge is 
curved, to the angle of its chord. The first 
edge is typically located at the top of the 
garden bed when it is first created; how-
ever, this can change as the bed is edited.

• Select Random Angle to rotate the 
objects in the region at a variety of ran-
dom angles. 

Object Positioning - Specify the 
positioning of the distributed objects 

relative to a point of origin within the garden 
bed. 
• Specify the X Offset, the horizontal dis-

tance in floor plan view from the garden 
bed’s specified point of origin. 

• Specify the Y Offset, the vertical distance 
in floor plan view from the garden bed’s 
specified point of origin. 

• Select From Polyline Center to measure 
the offset from the garden bed’s center 
point. 

• Select Polyline Start to measure the off-
set from the garden bed’s start point. This 
start point is typically located at the top 
left of the garden bed when it is first cre-
ated; however, this can change as the gar-
den bed is edited. 

A preview of the garden bed displays 
on the right side of the dialog box. See 

“Dialog Preview Panes” on page 29. 

Polyline Panel
The Polyline panel indicates the polyline’s 
Length/Perimeter, its enclosed Area, and 
the Volume of a closed polyline. 

Selected Line Panel
The Selected Line panel is available when 
the selected edge of the polyline is a line as 
opposed to an arc. See “Selected Edge” on 
page 86.

The settings on this panel are available for a 
variety of other objects in the program. For 
information about these settings, see “Line 
Panel” on page 434.

Selected Arc Panel
The Selected Arc panel is available when the 
selected segment of the polyline is an arc as 
opposed to a line. See “Change Line/Arc” on 
page 110.

The settings on this panel are available for a 
variety of other objects in the program. For 

4

5

6
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information about these settings, see “Arc 
Panel” on page 436.

Line Style Panel
The settings on the Line Style panel are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Panel” on page 434.

Fill Style Panel
The settings on the Fill Style panel affect the 
appearance of the selected object in floor 
plan view. For information about these 
settings, see “Fill Style Panel” on page 439.

Materials Panel
The settings on the Materials panel affect the 
appearance of the selected object in 3D 
views. See “Materials Panel” on page 364.

Garden Bed Specification Dialog
To open the Garden Bed 
Specification dialog, select a Garden 

Bed and click the Open Object edit button 
or double-click the Garden Bed using the 

Select Objects  tool.

Because a Garden Bed is a type of Terrain 
Feature, the settings in this dialog are 
essentially the same as those in the Terrain 
Feature Specification dialog. See “Terrain 
Feature Specification Dialog” on page 305.

Terrain Path Specification Dialog
To open the Terrain Path 
Specification dialog, select a 

Sidewalk, Stream, Terrain Wall or Terrain 
Curb and click the Open Object edit button 

or double-click the terrain path using the 

Select Objects  tool.

Most of the panels in this dialog are similar 
to those for a variety of other objects in the 
program.
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General Panel

Size - Enter the Width of the object and the 
Height above the terrain. If the Height value 
is a negative number, the object sinks into the 
terrain. 

Polyline Panel
The Polyline panel indicates the Terrain Path 
polyline’s Length/Perimeter, its enclosed 
Area, and the Volume of a closed polyline. 

Selected Line Panel
The Selected Line panel is available when 
the selected edge of the Terrain Perimeter is a 
line as opposed to an arc. See “Selected 
Edge” on page 86.

The settings on this panel are available for a 
variety of other objects in the program. For 
information about these settings, see “Line 
Panel” on page 434.

Selected Arc Panel
The Selected Arc panel is available when the 
selected segment of the polyline is an arc as 
opposed to a line. See “Break Line” on page 
109.

The settings on this panel are available for a 
variety of other objects in the program. For 
information about these settings, see “Arc 
Panel” on page 436.

Line Style Panel
The settings on the Line Style panel are 
available for a variety of other objects in the 
program. For information about these 
settings, see “Line Style Panel” on page 434.

Fill Style Panel
The settings on the Fill Style panel affect the 
appearance of the selected object in floor 
plan view. For information about these 
settings, see “Fill Style Panel” on page 439.

Materials Panel
The settings on the Materials panel affect the 
appearance of the selected object in 3D 
views. See “Materials Panel” on page 364.
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Importing Elevation Data
Elevation data can be added to a plan using 
the tools and techniques described in this 
chapter or it can be imported from a file. 

Home Designer Suite can import elevation 
data saved in GPS Exchange (.gpx) and a 
variety of text file formats (.txt, .csv, .prn, 
.xyz, .auf and .nez). If your terrain data is not 
saved in one of these file formats, there are 
third party programs available that can 
convert to these formats. 

Text Files
Elevation data can be saved in text files as x, 
y, and z coordinates where x and y define the 
location of a point on a Cartesian grid, and z 
defines the elevation for that point. Each data 
point must be on a separate line in the text 
file. 

Importable text files can come from 
surveyors, other software programs, or you 
can create your own using a GPS system. 

Elevation data saved in text files can be 
imported using the Import Terrain 
Assistant. 

GPS Exchange Files
Elevation data in standard format .gpx files 
created using a GPS system can also be 
imported using the Import GPS Data 
Assistant. See “Import GPS Data Assistant” 
on page 313. 

GPS data may include three types of points - 
Way, Track, and Route. Home Designer Suite 
can only import a .gpx file if it includes one 
or more Way Points, and cannot use Route 
Points at all. If a .gpx file does not include 
any Way Points, it will not be imported, and 
if it includes any Route Points, they will be 
ignored.  

Home Designer Suite supports the import of 
data in standard .gpx files that adhere to the 
GPX 1.1 Schema. Files that do not follow 
this standard cannot be imported.

Import Terrain Assistant
The Import Terrain Assistant allows 
you to import elevation data saved in 

text (.txt) file format into a plan.

Each data point in this format has informa-
tion about its X-axis (East to West location), 
Y-axis (North to South location), and Z-axis 
(elevation). It might also have a brief 

description. In order to import elevation data 
from a text file, you need to know how the 
data in the file is organized. 

To launch the Import Terrain Assistant, 

select File> Import> Terrain Data . 
Click Next.
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Select File

Select a file to import.  

• Click the Browse button to locate a file 
on your computer. See “Importing Files” 
on page 47. 

• If a file has been selected, its full path-
name displays here for reference; if a file 
has not been selected, the directory of the 
last file imported displays.

Select the organization of the data.  

Elevation information can be organized in 
one of six different ways, and can be 
separated by either a comma (comma 
delimited) or a space (space delimited). 
• XYZ - Information in this format begins 

with the X coordinate, followed by the Y 
coordinate and the Z coordinate.

• #XYZ - Information in this format begins 
with a number that belongs to each data 

point followed by the X coordinate, the Y 
coordinate, and the Z coordinate.

• #XYZ Description - Information in this 
format begins with a number that belongs 
to each data point followed by the X coor-
dinate, the Y coordinate, the Z coordinate, 
and a description.

• YXZ - Information in this format begins 
with the Y coordinate followed by the X 
coordinate and the Z coordinate.

• #YXZ - Information in this format begins 
with a number that belongs to each data 
point followed by the Y coordinate, the X 
coordinate, and the Z coordinate.

• #YXZ Description - Information in this 
format begins with a number that belongs 
to each data point followed by the Y coor-
dinate, the X coordinate, the Z coordinate, 
and a description.

Click Next to continue.

1

2
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Scale Data

The total number of data points to be 
imported and the ranges of their 

coordinates are described here.

Select the Units of measurement used 
for each axis. 

Click Next to finish.

Import GPS Data Assistant
The Import GPS Data Assistant 
allows you to import terrain data from 

the standard .gpx file format. See “GPS 
Exchange Files” on page 311.

Select File> Import> GPS Data to open the 
Import GPS Data Assistant, then click Next 
to continue.

1 2

Due to the lack of accuracy in some
GPS systems, exact distances using

the Import GPS Data Assistant are not guar-
anteed.
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Select File

Select a file to import.  

• Click the Browse button to locate a .gpx 
file on your computer. See “Importing 
Files” on page 47. 

• If a file has been selected, its full path-
name displays here for reference; if a file 

has not been selected, the directory of the 
last file imported displays.

Click Next to continue.

Import Data As

Specify which items you want to import 
by checking the box to the left of the 

Name. Items with unchecked boxes are not 
imported.

Specify what you would like the 
selected item to Import As from the 

drop-down list.

1

Note: Not all GPS programs use the standard
.gpx file format; however, only files using the
standard format can be imported. 

1 2
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• Only Way Points have elevation data 
associated with them. To import this data, 
import them as “Elevation Points”. 

• Select “Marker” to import either Way 
Points or Track Points as location mark-
ers. Markers have no elevation data asso-
ciated with them.

• Select “Polyline” to create an open CAD 
polyline based on the position of Way 
Points or Track Points. The points them-
selves are not imported. Polylines have no 
elevation data associated with them.

• Select “Terrain Perimeter” to create a 
closed Terrain Perimeter polyline based 
on the position of either Way Points or 
Track Points. The points themselves are 
not imported. A Terrain Perimeter has no 
elevation data associated with it. See 
“Terrain Perimeter” on page 289. 

Click Next to continue.

Transform Coordinates

Lower Elevation Data by: 

• Specify the amount that you would like to 
lower all imported elevation data.

Rotate North Counterclockwise: 

• Specify an amount to rotate the terrain 
data counterclockwise, or to the left. 

Map this point to the origin. 

• Specify a point in the imported terrain 
data, defined by degrees Latitude and 
Longitude, that you would like to locate 
at the origin in the Home Designer Suite 
plan.

Click Next to finish. 

If you do not see the imported terrain, select 

Window> Fill Window . 

Way Points are typically imported as
“Elevation Data”, while Track Points are

imported as “Markers”, “Polylines’, or “Terrain
Perimeter”. 

1

2

3
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Chapter 20:

Roads, Driveways
and Sidewalks

Roads and sidewalks are modeled in 3D like 
other terrain objects in Home Designer Suite. 
Because they have much in common with 
terrain objects and rely upon terrain data to 
be viewed in 3D, it is helpful to be familiar 

with terrain modeling before using these 
tools. See “Terrain” on page 289.

Chapter Contents
•      Road, Driveway and Sidewalk Tools
•      Displaying Road Objects
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Road, Driveway and Sidewalk Tools
Road objects can be drawn in floor 
plan view, camera views and 

overviews, but only when a Terrain 
Perimeter exists in the plan. See “Terrain 
Perimeter” on page 289. 

Road objects created with the Road Tools 
have a consistent width that can be defined in 
their specification dialogs. See “Road 
Specification Dialog” on page 320, “Terrain 
Feature Specification Dialog” on page 305, 
and “Terrain Path Specification Dialog” on 
page 309.  

Driveways and Parking Lots are actually 
Terrain Features.  See “Terrain Feature 
Tools” on page 295. They are drawn as 
rectangles but can be edited to any shape. 
See “Editing Closed-Polyline Based 
Objects” on page 96.

Roads and sidewalks are flat along their 
widths, which makes it easy to create roads 
on sloping terrain. Driveways and Parking 
Lots follow the contours of the terrain rather 
than cut into them. 

Once road objects have been placed, they can 
be edited individually or as a group. See 
“Editing Road Objects” on page 319.

Straight Road
To place a road without any curves, 
select Terrain> Road> Straight 

Road and click and drag to draw a line in 
floor plan view. The ends of multiple road 
sections can be connected together.

Roads are edited alone their center line like 
CAD lines and polylines. See “Editing Line 
Based Objects” on page 88.

Spline Road
Use Terrain> Road> Spline Road to 
draw a curved road. Spline roads are 

drawn and edited like CAD splines. See 
“Splines” on page 433. 

Straight Sidewalk
To create a sidewalk with no curves, 
select Terrain> Road and Sidewalk> 

Straight Sidewalk, then click and drag from 
end to end to draw a line. The ends of 
multiple sidewalk sections can be connected 
together.

Sidewalks are edited along their center line 
like line- and polyline- based objects. See 
“Editing Line Based Objects” on page 88. 

Sidewalks can be edited in their specification 
dialog. See “Terrain Path Specification 
Dialog” on page 309.

Spline Sidewalk
Use the Spline Sidewalk tool to 
create a curved sidewalk. Select 

Terrain> Sidewalk> Spline Sidewalk. 
Spline roads are drawn and edited like CAD 
splines. See “Splines” on page 433.

Driveway Area
A Driveway Area is a terrain feature 
with a concrete material assignment. 

To create a driveway, select Terrain> Road 
and Sidewalk> Driveway Area, then click 
and drag from corner to corner to draw a 
rectangle. See “Draw Polyline” on page 432. 
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Height, thickness and material information 
can be specified in a driveway’s specification 
dialog. See “Terrain Feature Specification 
Dialog” on page 305.

Driveways can be edited like other closed 
polylines. See “Editing Closed-Polyline 
Based Objects” on page 96. 

Parking Lot
A Parking Lot is a terrain feature 
with an asphalt material assignment. 

To place a parking lot, select Terrain> Road 
and Sidewalk> Parking Lot, then click and 
drag from corner to corner to draw a 
rectangle. See “Draw Polyline” on page 432. 

Height, thickness and material information 
can be specified in a parking lot’s 
specification dialog. See “Terrain Feature 
Specification Dialog” on page 305.

Displaying Road Objects
Roads and sidewalks display in floor 
plan and 3D views based on the 

settings in the Display Options dialog. See 
“Layers” on page 73.

In 3D Views
Road objects display in 3D views within the 
Terrain Perimeter. If the display of the 
Terrain Perimeter is turned off in 3D views, 

roads and sidewalks will not display, either: 
even if their layers are turned on.

By default, terrain rebuilds automatically 
when road objects are added, removed or 
edited. If it does not, you can select Terrain> 
Build Terrain . See “Terrain Perimeter” 
on page 289.

Editing Road Objects
Road objects can be selected in 2D and 3D 
views and edited using the edit handles, the 
edit toolbar and their specification dialogs. 

Using the Mouse
The edit handles available for a selected road 
object depend on the type of object selected. 

• Straight Roads  and Straight 
Sidewalks  are edited along their cen-
terline like a line or open polyline. See 

“Editing Line Based Objects” on page 
88. 

• Spline Roads  and Spline Sidewalks 

 are edited along their centerline like 
CAD splines. See “Splines” on page 433.

• Driveway Areas  and Parking 
Lots  are edited like other closed 
polyline based objects. See “Editing 
Closed-Polyline Based Objects” on page 
96.
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In the Specification Dialog
Road objects can be customized in 
their specification dialogs. See “Road 

Specification Dialog” on page 320, “Terrain 
Feature Specification Dialog” on page 305, 
and “Terrain Path Specification Dialog” on 
page 309.

Using the Edit Tools
A selected road object can be edited in a 
variety of ways using the buttons on the edit 
toolbar. See “The Edit Toolbar” on page 26.

Road Specification Dialog
To open the Road Specification 
dialog, select a Straight Road or 

Spline Road and click the Open Object edit 
button. 

Many of the settings in this dialog are similar 
to those in the Terrain Path Specification 
dialog. 

General Panel

Size - Specify the Width and Height of the 
road relative to the terrain. 

Polyline Panel
The Polyline panel lists the length of the 
road’s Perimeter, Area and Volume. For more 
information, see “Polyline Panel” on page 
438. 

Selected Line/Arc Panel
The Selected Line panel is available when a 
Straight Road is selected. For more 
information, see “Line Panel” on page 434.  

The Selected Arc panel is available when the 
curved segment of a  Straight Road is 
selected. See “Arc Panel” on page 436.  

Line Style Panel
This panel is the same as the Line Style panel 
in many other specification dialogs. See 
“Line Style Panel” on page 434. 
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Fill Style Panel
The settings on the Fill Style panel affect the 
appearance of the selected object in floor 
plan view. For information about these 
settings, see “Fill Style Panel” on page 439.

Materials Panel
The settings on the Materials panel affect the 
appearance of the selected object in 3D 

views. For information about these settings, 
see “Materials Panel” on page 364.

The material selected here is not calculated 
in the Materials List. See “Materials Lists” 
on page 491. 
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Chapter 21:

Plants and
Sprinklers

The Plant Tools and sprinklers from the 
Library Browser allow you to create planting 
designs and irrigation systems in your 
terrain. 

The Terrain Tools are discussed in their own 
chapter. See “Terrain” on page 289.

Chapter Contents
•      Plant Tools
•      Plant Chooser Dialog
•      Hardiness Zones
•      Plant Image Specification Dialog
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Plant Tools
Select Terrain> Plant to add plants to 
your landscaping plan. Plants can also 

be placed in a plan directly from the library. 
See “Placing Library Objects” on page 354.

Plant objects are actually images, which 
provide realism while avoiding high 3D 
surface count. Once created, plant images 
can be selected and edited much like other 
image objects. See “Editing Images” on page 
452.

Select Terrain> Plant> Plant 
Chooser to open the Plant Chooser 

dialog and find plants based on their 
characteristics and requirements. See “Plant 
Chooser Dialog” on page 324.

Select Terrain> Plant> Create Plant 
Image to create a plant image. Once a 

plant image is created, it can be added to the 
library for future use. See “Creating Images” 
on page 450. 

Select Terrain> Plant> Show 
Hardiness Zones  to access regional 

climate zone maps. See “Hardiness Zones” 
on page 326.

Garden Beds
Garden Beds are special Terrain 
Features with material and height 

attributes typical of planting beds.  In 
addition, you can choose to distribute copies 
of a plant image within a Garden Bed. See 
“Garden Bed Tools” on page 296.

Plants Library Catalogs
In the Library Browser, browse to 
Home Designer Core Catalogs> 

Plants to access a selection of plant images. 
Select the library object you want, then click 
in any view to place it in the plan. See “The 
Library” on page 341.

A selection of Bonus Catalogs of plants is 
also available for download. See “Home 
Designer Bonus Catalogs” on page 347. 

In addition, you can add plants to the library. 
See “Adding Library Content” on page 350. 

Plant Chooser Dialog
Select Terrain> Plant> Plant 
Chooser to open the Plant Chooser 

dialog or click the Plant Chooser button at 
the bottom of the Library Browser window.

Use the Plant Chooser to search the library 
for plant images and symbols that meet your 

search parameters. You can search using any 
or all of the options in this dialog.

The search parameters in the Plant Chooser 
dialog correspond to the settings on the Plant 
Information panel of the Plant Image 
Specification dialog. See “Plant Information 
Panel” on page 328.
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Type the Name of a plant that you 
would like to find.. 

• Specify the plant’s Common Name, Sci-
entific Name, or its Variety Name. 

• A Pronunciation field is also provided. 
In the Plant Image Specification dialog, it 
is populated with a phonetic pronuncia-
tion guide for the plant’s scientific name. 

Check one or more boxes to indicate 
selected plant Type to search for.

Check one or more boxes to specify the 
selecte Sub-Type to search for.

Specify the plant Needs to search for. 
These include the Sun, Water, Soil pH, 

and Hardiness Zone range. See “Hardiness 
Zones” on page 326.

Flowers and Foliage -

• Specify the Flower Color to search for. 
Multiple colors can be selected.

1

2

3

4

5
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• Specify the Leaf Color to search for. 
Multiple colors can be selected

• Specify the Bloom Time to search for, 
which is the season when the plant pro-
duces flowers. 

Specify the plant Height at maturity to 
search for.

• An average mature height range can be 
entered using the From and To drop-
down lists.

• A specific Height at Maturity to search 
for can be entered in the text field.

• A specific Starting Age, in months, can 
be entered in the text field.

• A specific Age at Maturity, in months, 
can be entered in the text field.

Check one or more boxes to search for 
plants with Special Characteristics.

Click the Search button at the bottom 
of the dialog to search for plants that 

meet your search criteria. The search results 
display to the right. 

Your search results display here. 

• The Number of Items that match your 
search criteria is stated.

• Specify whether you want the search 
results to use the Common Name or Sci-
entific Name. 

• Click on the name of a plant in the list to 
see its location in the Library Browser.

Click the View Item button to see more 
information about the selected plant in 

the Plant Information dialog. See “Plant 
Image Specification Dialog” on page 327.

Hardiness Zones
Select Terrain> Plant> Show 
Hardiness Zones to view a selection 

of regional Hardiness Zone Maps. Click the 
drop-down list at the top left to select various 
regions.

6

7

8

9
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Plant Image Specification Dialog
Select a plant in a floor plan or 3D 
view and click the Open Object edit 

button to open the Plant Image 
Specification dialog. 

This dialog can also be accessed by selecting 

Terrain> Plant> Create Plant Image .

The Plant Information and Plant Description 
panels are also found in the Plant 
Information dialog, which can be accessed 
from the Plant Chooser dialog. See “Plant 
Chooser Dialog” on page 324.

Image Panel

General - 

• The path and name of the selected plant’s 
Image File displays here. 

• Click Browse to specify the saved loca-
tion on your computer of the image that 
represents the plant in 3D views.

• A number of 2D Plant Symbols are avail-
able to represent the image in floor plan 
view. Select one from the drop-down list.

1
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Specify the Size of the plant image, as 
seen in 3D views. 

• Enter a Height for the image. 
• Enter a Width for the image. 
• When Retain Aspect Ratio of is checked, 

if you change either the Height or Width, 
the other value changes to maintain this 
ratio. If this is unchecked and you resize 
the plant image, it may become distorted.

• Click Reset Original Aspect Ratio of to 
reset the image’s original aspect ratio and 
remove any distortion caused by resizing.

Specify the location of the selected 
plant image’s Center Point.

• Position the selected plant image in refer-
ence to the plan coordinates by specifying 
its X Coordinate and Y Coordinate.

• Specify the selected plant image’s Height 
Above Ground.

Options  - 

• Check Reverse Image to reflect the 
appearance of the image about an imagi-
nary vertical line through its center. 

• Check Do not rotate in 3D view to pre-
vent the plant image from rotating with 
the camera.

If the selected plant image has been 
copyrighted, its Copyright 

Information displays here. 

A preview of the selected sprinkler 
symbol displays here. The Glass House 

Rendering Technique is not available for 
plant images. See “Dialog Preview Panes” 
on page 29.

Plant Information Panel
The settings on the Plant Information panel 
correspond to the search parameters in the 
Plant Chooser. See “Plant Chooser Dialog” 
on page 324.

2
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Plant Description Panel

A detailed Description of the plant 
displays in this text field.

Information in the Lighting 
Comments fields describes the plant’s 

light requirements.

Hardiness Zone Comments are given 
here. See “Hardiness Zones” on page 

326.

Fill Style Panel
The Fill Style panel controls the appearance 
of the selected plant’s 2D Plant Symbol in 
floor plan view.  By default, plant images’ 
fill style is None (Transparent). For 

information about the settings on this panel, 
see “Fill Style Panel” on page 439.

If the plant’s 2D Plan Symbol does not form 
a closed shape, the settings on the Fill Style 
panel will have no effect on the appearance 
of the plant in floor plan view. 

1

2

3
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Chapter 22:

Other Objects

Home Designer Suite has additional objects 
that can be used to customize your design. 

Chapter Contents
•      General Shapes
•      Soffits
•      Special Applications for Soffits
•      Soffit Specification Dialog

General Shapes
Items in the Home Designer Core 
Catalogs> Shapes library catalog 

allow you to create a variety of custom 
objects using basic geometric shapes. These 
shapes can can be used individually or 

combined to create a wide variety of custom 
objects. 

General Shape objects are placed and edited 
much like other library objects. See “Editing 
Box-Based Objects” on page 98.

Soffits
Soffits typically fill the space between 
the tops of wall cabinets and the 

ceiling, but they are very versatile and can be 
used to create almost any other object that 
can be modeled as a 3D box. Select Build> 
Cabinet> Soffit to activate this tool.

Soffit Defaults
The default settings for soffits are set in the 
Soffit Defaults dialog. The settings in this 
dialog are similar to those in the Soffit 
Specification dialog. See “Soffit 
Specification Dialog” on page 334.
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For best results when placing soffits above 
wall cabinets:
• The default soffit should be the same 

width as and 1" (20mm) deeper than the 
default wall cabinet. See “Cabinet 
Defaults” on page 272. 

• The default soffit Floor to Bottom value 
should equal the sum of the default wall 
cabinet’s Floor to Bottom value plus its 
Height. See “General Panel” on page 
334.

• The default soffit Height should be equal 
to or greater than the space between the 
ceiling and the top of the wall cabinets. 

If the sum of the default soffit’s Floor to 
Bottom value and Height is larger than the 
ceiling height of the room in which a soffit is 
placed, the Floor to Bottom value will be 
retained and its Height will be adjusted so 
that it fits under the ceiling. 

The maximum soffit width is 250 feet (48m), 
and the minimum width is 1/16" (1 mm).

Once a soffit is placed in a plan, you can 
change its size and position to meet a variety 
of needs. 

Placing Soffits
Soffits can be created in both 2D and 3D 

views by simply clicking with the Soffit  
tool active. See “Click-to-Create” on page 
80. 

They can be assigned materials that are 
calculated in the Materials List, but by 
default they use the material assigned to the 
default wall. See “Wall Defaults” on page 
116.

When positioned against a wall in a room, 
soffits will display any moldings present in 
that room that are at the same height as the 
soffit. See “Moldings Panel” on page 158.

To create a corner soffit, click as close to an 
inside wall corner as possible. A corner soffit 
retains its shape when it is moved, edited, or 
copied. 

When a soffit is created, it is placed on the 
“Cabinets, Soffits” layer. See “Displaying 
Objects” on page 74. 

Special Applications for Soffits
Nearly any object with straight, flat sides can 
be represented by one or more Soffits. They 
can be resized to as small as 1/16" (1mm) per 
side, or as large as 250 feet (48m).

Soffits can have materials applied to them to 
represent simple mirrors, posts, chimneys 
and so on. Following are some additional 
examples.

Coffered Ceilings
Soffits can be used to create coffered 
ceilings. When placed against a wall, a soffit 
will display any moldings assigned to the 
room it is in that are at its height.
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Accent Tiles
A material such as ceramic tile can be 
assigned to one or more soffits applied to the 
walls above tubs or in showers.

Masonry Veneer
You can use a soffit to create a brick or stone 
veneer over part of a wall. Specify a soffit 

depth equal to the masonry material to be 
used. 

Soffits automatically stop at the floor 
platform when moved downward or at the 
ceiling platform when moved upward - even 
when the soffit is not located in a room. To 
more or resize a soffit through a floor or 
ceiling platform, select it and hold the Ctrl 
key down while dragging its edit handles. 
See “Unrestricted Movement” on page 106.

Calculating Materials on Soffits
The number of bricks, tiles, shingles, shakes 
or other materials applied to a soffit is 
calculated using the following rules:
• If the soffit depth is less than the larger of 

4 inches (10 mm) or 1 ½ times the mate-
rial thickness, then only the front area of 
the soffit is used. Thus if a soffit is 
48"x48”x4” thick, and the Dark Red 
brick material is used (3"x 8" with 3/8” 
mortar joint) the front of the soffit is 
48"x48”=2304 square inches. Including 
the mortar joint, each brick requires 3 3/
8” x 8 3/8” = 28.26 square inches. 2304 
sq. in. divided by 28.26 sq. in. per brick 
gives 81.5 bricks.
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• If the soffit depth is greater than both 4 
inches (10 mm) and 1 ½ times the mate-
rial thickness, then the surface areas of 
the soffit back, sides and top are used in 
addition to the front, if these surfaces are 
not attached to a wall or other soffit. 
However, only those portions of the 
sides, top and bottom remaining after 
subtracting twice the material thickness 
are used. So, for Dark Red brick, which 
has a depth of 4", the sides, top and bot-
tom surface areas cannot contribute to the 
brick count unless the soffit depth is 
greater than 8 inches.

• If surface materials such as brick are 
applied to a large soffit, the soffit center 
is assumed to be hollow, with only a sin-
gle layer of the material applied to each 
applicable face.

• For shingles and shakes, the overlap 
amount should be subtracted from the 
height, as opposed to brick or tile, where 
the joint width is added to the size.

• For materials in the area category, the 
soffit area calculation above is used, with 
the material thickness treated as zero.

• For materials in the volume, concrete or 
earth categories, the true volume of the 
soffit is used.

Soffit Specification Dialog
To open the Soffit Specification 
dialog, select the soffit and click the 

Open Object edit button or double-click on 

a soffit using the Soffit  tool.

The settings in this dialog are similar to those 
in the Soffit Defaults dialog, but affect only 
the selected object(s). 

General Panel
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Define the Size and Position of the 
selected soffit relative to the floor or 

terrain. 
• Specify the Width of the soffit. 
• Define the vertical Height of the soffit. 
• Depth - Define the distance between the 

front and the back of the soffit. When 
selected in floor plan view, the front of a 
soffit has a “V,” and the back of the soffit 
has a triangular rotation handle.

• If the selected soffit is a corner soffit, the 
Width controls its left side width, and 
Depth controls its right side width. 

• Floor to Bottom - Specify the distance 
from the bottom of the soffit to the floor. 
This is sometimes more easily done by 
positioning the soffit in a 3D view.

• When the selected soffit is outside a room 
and Auto Adjust Height is checked , its 
Floor to Bottom height is measured rela-
tive to the terrain height. When this is 
unchecked, the Floor to Bottom height is 
measured from the default floor height of 

Floor 1. See “Terrain Height vs Floor 
Height” on page 290 of the Reference 
Manual. 

A preview of the soffit displays on the 
right side of the dialog box. See 

“Dialog Preview Panes” on page 29.

Materials Panel
For information about the settings on this 
panel, see “Materials Panel” on page 364.

Label Panel
Soffit labels display in floor plan view when 
the “Cabinets, Labels” layer is turned on and 
use the Text Style assigned to that layer. The 
Automatic Label for Soffits is blank, but you 
can specify a custom label.  

For more information about the settings on 
this panel, see “Label Panel” on page 429.

1

2
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Chapter 23:

Architectural
Blocks

A selection of pre-arranged rooms is 
available in the Library Browser at Home 
Designer Suite Content> Interiors> Pre-
Arranged Rooms. These pre-arranged rooms 
are a collection of fixtures, furnishings and 
accessories that are grouped together so that 
they can be placed and  moved as a single 
object.

3D objects that are grouped together like this 
are referred to as Architectural Blocks. 
Although blocked together, these objects 
retain many of their own attributes, such as 
materials.

Architectural blocks can also be exploded so 
that the individual sub-objects become 
independent of one another.

Chapter Contents
•      Displaying Architectural Blocks
•      Editing Architectural Blocks
•      Architectural Blocks and Sub-Objects
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Displaying Architectural Blocks
Architectural blocks are placed on the 
“Architectural Blocks” layer and can be 
displayed in all views. The display of 
architectural blocks, including their 

bounding box, is controlled in the Display 
Options dialog. See “Displaying Objects” on 
page 74.

Editing Architectural Blocks
Architectural blocks can be selected and 
edited in 2D and 3D views. See “Selecting 
Objects” on page 86. 

Once selected, an architectural block can be 
edited using its edit handles and edit toolbar 
buttons.

Using the Edit Handles
A selected architectural block displays a 
Move handle and a Rotate handle.  

Architectural blocks cannot be resized, but 
the individual objects in the block can be. 

Using the Edit Tools
A selected architectural block or blocks can 
be edited in a variety of ways using the 
buttons on the edit toolbar. See “The Edit 
Toolbar” on page 26.

Editing Sub-Objects
The individual objects included in an 
architectural block can also be selected and 
edited. See “To select a sub-object” on page 
339.

Explode Architectural Block
You can break an architectural block 
to make its objects independent. 

Select the architectural block and click the 
Explode Architectural Block edit button.  

Once exploded, an architectural block cannot 
be made into a single object again. 

Architectural Blocks and Sub-Objects
An architectural block is composed of a 
group of sub-objects that have been blocked 
together. For example, a kitchen island 
architectural block may consist of cabinets, 
appliances, and other accessories.

Each of the sub-objects in an architectural 
block may contain additional parts called  
components. The cabinets in a kitchen island, 
for example, may contain handles, hinges, 
and drawer glide.

Note: If you open a plan created in another
version of Home Designer and an architec-
tural block includes an object that you cannot
create in your version of the software, you
cannot unblock it or edit its components. 
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Sub-Objects
Certain attributes of an architectural block 
can be edited at the sub-object level. A sub-
object can be edited by accessing its 
specification dialog in either of two ways:
• Explode the architectural block, select 

the sub-object, and click the Open 
Object  edit button.

• Select the sub-object while it is part of 
the architectural block and click the 

Open Object  edit button. Some attri-
butes may not be editable while the 
object is part of a block. See “Editing 
Architectural Blocks” on page 338.

To select a sub-object

1. Click the Select Objects  button, 
then click on the sub-object that you 
would like to edit.

2. With the architectural block selected, 

click the Select Next Object  edit 
button or press the Tab key. 
The selection switches to the individual 
object and it can be edited using its edit 
handles, edit toolbar and specification 
dialog.

The options for editing a sub-object may be 
more restricted than if the object were 
independent. If more extensive editing is 
required, the architectural block must be 
exploded.  
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Chapter 24:

The Library

Home Designer Suite’s library offers 
thousands of symbols, materials, and images 
that can enhance any plan. 

New library catalogs and enhancements are  
made available by Chief Architect on a 
continuing basis and are available for 
download for the current program version. 

You can also customize items from the 
library or import new items from outside the 
program and then save them in the library for 
future use.

Chapter Contents
•      The Library Browser
•      Searching the Library
•      Library Content
•      Downloading Library Content
•      Importing Library Catalogs
•      Adding Library Content
•      Organizing the Library
•      Exporting Library Catalogs
•      Placing Library Objects
•      Select Library Object Dialog
•      Displaying Library Objects
•      Editing Library Objects
•      Symbol Object Specification Dialogs
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The Library Browser
The Home Designer Suite Library 
Browser allows you to manage the 

contents of the library as well as add library 
content to your drawings. 

To open the Library Browser:

• Select View> Library Browser .

• Click the Library Browser button .
• Press Ctrl + L on your keyboard.

By default, the Library Browser is docked to 
the right side of the program window, but can 
be undocked or docked to another side. See 
“Docking the Library Browser” on page 345.

The Library Browser has four sections: 
• The search options at the top. 
• The Directory and Search Results Pane. 
• The Selection Pane. 
• The Preview Pane. 

To adjust the height or width of a section, 
place the pointer over the split bar you want 
to move. When the double-headed arrow  
displays, click and drag. 

You can work on your drawing with the 
Library Browser open. To close the Browser, 
click the Close  button or double-click on 
an object in the Selection Pane. 

The library directory is presented in a tree list 
with five categories: Home Designer Core 

Catalogs, Home Designer Bonus Catalogs, 
Manufacturer Catalogs, User Catalog and 
Trash. See “Library Content” on page 346. 

Search the library using keywords and 
optional search filters. See “Searching 

the Library” on page 345.
• Begin typing in the text field to search for 

library items. As you type, search results 
will display in the Directory Pane. 

• Right-click on an item in the Search 
Results list and select Show in Browser 

You can control the configuration of the
Library Browser panes in the Prefer-

ences dialog. See “Library Browser Panel” on
page 61. 1
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to view the item’s location in the Direc-
tory list.

• Click the Browse  button to stop 
searching and restore the Directory list.

• Click the Search  button to display the 
search results for your search entry.

• Click the Search Filtering Options  
button to customize your search parame-
ters. 

The library Directory and Search 
Results display here. The basic 

structure of the directory tree is: 

Library items are always placed in 
alphabetical order within their heirarchy.

The Library Browser includes a Trash bin, 
where deleted items are moved until you 
choose to Empty Trash. See “Deleting 
Library Items” on page 353.

Navigate the Directory Pane using the 
mouse. Click the gray Expand arrow  
beside a catalog or folder to display its 
contents. Once expanded, you can click the 
black Collapse arrow  to close it again. 
You can also browse the list using the arrow 
keys on your keyboard. 

Click on an item to select it. Preview images 
display in the Selection and Preview Panes 
and basic information about it also displays 
in the program’s Status Bar. See “The Status 
Bar” on page 30.

The Selection Pane shows a thumbnail 
image of the item selected in the 

Directory Pane.  

When an item is selected in the Directory 
Pane, a basic line-based representation of the 
item displays in the Selection Pane.
• If the selected item is a single object, a 

preview of that object displays in the Pre-
view Pane. You can move your cursor 
into the drawing area to place the item. 
See “Placing Library Objects” on page 
354. 

• If the selected item is a folder, a thumb-
nail image displays, representing each 
item inside. Move your pointer over an 
item in this pane to see a Tool Tip with 
the item’s name. Click on a folder in the 
Selection Pane to display its contents 
here and make it the item selected in the 
Directory Pane.

• Some folders may have too many items 
to display useful thumbnails for each; 
when this is the case, they do not display.

Click the Show/Hide Selection Pane  
button to toggle the Selection Pane on and 
off.

When an individual object is selected in 
either the Directory or Selection Pane, 

an image of it displays in the Preview Pane. 

You can click the Toggle Display  button 
at the bottom of the browser window to 
switch between preview images in high and 
low detail. 

If the selected object is a 3D symbol, you can  
rotate and zoom in or out on the Preview 
using the mouse.

2

3

4
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If you have rotated a view in the Preview 
Pane, you can restore the default angle either 
by clicking in the Selection Pane or by right-
clicking on the Preview Pane and selecting 
Reset Preview.  

Click the Show/Hide Preview Pane  
button to toggle the Preview Pane on and off. 

The toolbar at the bottom of the 
browser aids in searching, displaying 

panes, and managing library content. 

Click the Plant Chooser button to 
open the Plant Chooser dialog. See 

“Plant Chooser Dialog” on page 324.

Click the Get Additional Online 
Content button to launch your default 

web browser to the Home Designer Suite 
web site, where additional library content is 
available for download.

Click the Show/Hide Selection Pane 
button to toggle the Selection Pane on 

and off.

Click the Show/Hide Preview Pane 
button to toggle the Preview Pane on 

and off.

Click the Toggle Display button to 
switch between  high and low detail 

images of a selected library object in the 
Preview Pane. 

Click the Preferences button at the 
bottom of the Library Browser to open 

the Preferences dialog, where display 
properties for the Library Browser can be 
controlled. See “Library Browser Panel” on 
page 61. 

Using the Contextual Menus
A number of important library functions can 
be accessed using the contextual menus. 
Right-click on an item in the Library 
Browser to open a contextual menu 
displaying options related to that item. See      
Contextual Menus.

The options in the contextual menu vary 
depending on the item selected, but may 
include: 
• Cut/Copy/Paste
• Paste Shortcut
• Rename
• Delete
• Export Library
• Open
• Reset Preview
• Expand All/Collapse All
• Show in Browser

Keyboard Commands
The Library Browser can be navigated using 
the arrow keys on your keyboard. 
• The right and left arrow keys expand and 

collapse folders.

5
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• The up and down keys change which 
library object is currently selected.

• Select an item and press F2 to rename it.
• Select an item and press the Delete key to 

delete it. 

Expand/Collapse All
When a library category or folder is selected 
in the Directory Pane, Expand All and 
Collapse All are available in the contextual 
menu, allowing you to expand or contract its 
contents in the tree view.

Docking the Library Browser
Initially, the Library Browser side window is 
docked to the right side of the main Home 
Designer Suite program window. To undock 
it, click and drag its title bar towards the 
center of the program window. Once 
undocked, it can be moved and redocked in 

the same manner. See “Side Windows” on 
page 25. 

When moved to the top, bottom, or side of 
the program window, it automatically docks 
in a vertical or horizontal orientation, 
depending on its location.
• Holding down the Ctrl key while drag-

ging the Library Browser from docking.

To return the Library Browser to its original 
position and size, click the Restore Position/
Size button in the Preferences dialog. See 
“Reset Options Panel” on page 66. 

Closing the Library Browser
The Library Browser can be closed in either 
of two ways: 

• Click the Close  button at the top right 
corner of the browser window.

• Select View> Library Browser .

Searching the Library
The Library Browser filtering options let you 
focus your searches to meet parameters that 
you define. 

To search the Library Browser

1. Select View> Library Browser  and 
click in the Search field at the top of the 
Library Browser.

2. Begin typing a keyword to search for.
3. As you type, the search results will pop-

ulate in the Directory Pane below.

4. If you move your mouse pointer over the 
Search field, a Tool Tip will state the 
number of results of your search.

5. Right-click on an item in the Search 
Results list and select Show in Browser 
to view the item’s location in the Direc-
tory list.

Substrings are not included. For example, 
searching for “windows” will not produce 
“window” as a search result. On the other 
hand, searching for “window” will produce 
“windows” as a search result.
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To search using custom filters

1. Click the Turn on search filtering 
options  button. 

•  Check Match Keyword to match the 
entered search keyword with an 
object’s search attributes. 

•  Check Match Entire Word to match 
the entire keyword or words with the 
complete name of the object. 

•  Check Match Folders to include 
library folders in your search.

2. Check Filter by to enable additional fil-
tering options, which display below.

3. Select a filtering option from the drop-
down list on the left, then choose what to 
include in the filter from the drop-down 
list on the right:

•  Select Type, then select a category of 
library item to include in your search.

•  Select Style, then choose a design style 
to restrict the search results to objects 
of that style.

•  Select Manufacturer, then choose the 
name of a manufacturer to include in 
your search. Manufacturer catalogs 
that were imported during the current 
program session will not be listed until 
you exit out of and restart Home 
Designer Suite.

4. Multiple filters can be created and used 
at the same time:

•  Click the Add  button to the right of 
a filter to make copy of that filter.

•  Specify a new Type, Style, and/or 
Manufacturer for the new filter. 

•  Click the Delete  button to the right 
of a filter to remove that filter.

Library Content
The Home Designer Suite library has five 
categories: Home Designer Core Catalogs, 
Home Designer Bonus Catalogs, 
Manufacturer Catalogs, User Catalog and 
Trash. See Getting Started Guide, “Deleting 
Library Items” on page 353.

Home Designer Core Catalogs
The Home Designer Core Catalogs category 
contains a wide selection of 3D symbols, 
images, and materials. When you install the 

program from DVD, this library content will 
also be installed; if you download the 
software, you will be able to download the 
Core Catalogs separately, after the program 
is installed. 

When you launch the program for the first 
time, it will ask if you want to download the 
Core Catalogs. Click Yes to begin the 
download. If you click No, you can 
download at any time by selecting Library> 
Install Core Content from the menu. 

Note: Your custom search settings are not
retained when you end the current program
session.
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Home Designer 
Bonus Catalogs

Chief Architect regularly posts new library 
catalogs available for download. Select  
Library> Get Additional Content 
Online  from the menu to access the 
bonus catalogs and content. 

Manufacturer Catalogs
A variety of  name brand library catalogs are 
available for download on the Home 
Designer web site with content ranging from 
materials to fixtures.

Select Library> Get Additional Content 
Online  to access these Manufacturer 
Catalogs. 

The User Catalog
The User Catalog is the location for items 
that you add to the library either from a 
drawing or by importing. See “Adding 
Library Content” on page 350. 

You can create and organize custom library 
folders and imported items such as symbols, 
images, backdrops, and materials. See 
“Organizing the Library” on page 351.

Updating Library Catalogs
The Home Designer Core Catalogs, Bonus 
Catalogs, and Manufacturer Catalogs are 
updated periodically to include new and 
improved content. You can update your 
installed catalogs to include the latest content 
by selecting Library> Update Library 
Catalogs at any time. 

The program will gather information about 
the content in each of these three categories, 

and then download and replace any content 
that is not up to date, and you may see a 
progress indicator at the bottom of the 
Library Browser while it is doing so. See 
“Download Progress” on page 348.

Backing up Library Content
The Home Designer Suite User Catalog File, 
User_Library.calib, is located in the Home 
Designer Suite 2015 Data folder. See “Home 
Designer Suite Data” on page 39. 

The best way to back up your custom library 
content is to export the items in your User 
Catalog, as this will ensure that the textures 
used by custom materials or imported 
symbols are not lost. See “Backing Up Your 
Files” on page 43. 

Exported libraries use the .calibz file format: 
a zipped file type that can include textures 
and images along with other library data.

To back up your custom library content

1. Launch Home Designer Suite and select 

View> Library Browser  from the 
menu.

2. Right-click on a folder or item in the 
User Catalog. 

3. Select Export Library from the contex-
tual menu.

4. The Export Library Data dialog is a typ-
ical Save dialog. See “Exporting Files” 
on page 43.

•  Notice that the file type in the Save as 
type field is “Library File with Tex-
tures/Images (*.calibz)”.
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Downloading Library Content
The Home Designer Core Catalogs, Home 
Designer Bonus Catalogs, Manufacturer 
Catalogs are all available for internet 
download. 

Core Catalogs
When you launch Home Designer Suite for 
the first time, you will be asked if you want 
to download the Core Catalogs. Click Yes to 
begin the download. 

If you click No, you can download at any 
time by selecting Library> Install Core 
Content from the menu. 

Bonus and Manufacturer 
Catalogs

Bonus and Manufacturer Catalogs can be 
downloaded from our web site,
 www.homedesignersoftware.com. Select 
Library> Get Additional Content 
Online  to launch your default internet 
browser to our Content Resources page. 

Download Progress
When library content is downloading, a 
green progress bar will display at the bottom 
of the Library Browser. If you choose to 
download the Core Catalogs while the library 
is not open, the Browser will open so the 
progress indicator can display. 

Click on the progress bar to display the name 
of the current file being downloaded, the 
total amount of data to be downloaded in 
KB, and the amount downloaded so far.

Pausing and Resuming
Library downloads can only take place while 
Home Designer Suite is running. If you close 
the program while a download is in progress, 
a dialog will confirm whether you wish to 
stop the download.
• Click Stop Download and Close Pro-

gram to stop the download and close the 
program. 

• Click Cancel to leave the program open 
and continue downloading. 

Most catalogs are composed of a single file. 
If you stop the download midway, none of 
the downloaded data will be retained.

The Core Catalogs, on the other hand, 
contain a large volume of data saved in 
multiple files. If you close the program and 
stop the Core Catalogs download midway, 
only data associated with the file currently 
being downloaded will be lost. You can 
resume the download beginning with that file 
at a later time by selecting Library> Install 
Core Content.

Download Errors
If any problems occur during the library 
download process, a dialog box will notify 
you at the end of the download. Click Retry 
Download to repeat the download and 

home-designer-suite-2015-reference-manual.book  Page 348  Thursday, May 29, 2014  4:26 PM



Importing Library Catalogs

 349

correct any errors or click Cancel to discard 
the downloaded catalog. 

Importing Library Catalogs
Home Designer Suite library files have two 
different file extensions: .calib and .calibz. 
Both files can include any combination of 
Home Designer Suite library items; in 
addition, .calibz files are able to save data 
associated with textures and images. Both 
file types can be imported into the Home 
Designer Suite library.

There are several ways to import a .calib or 
.calibz file into the program library:
• Double-click on the file in an operating 

system window.
• Drag the file from an operating system 

window and drop it into the Home 
Designer Suite program window. 

• Select Library> Import Library from 
the program menu.

To import library files into the library

1. Select Library> Import Library to dis-
play the Import Library Data dialog.

2. Browse to the .calib or .calibz file that 
you want to import and select the files so 
that its name displays in the File Name 
field.

3. Click the Open button. 
4. A progress bar will display, telling you 

the progress of each library data file as it 
is imported. Once imported, each file 
will be located in the User Catalog.

When a .calib or .calibz file is imported into 
the program, its contents are automatically 

placed in the User Catalog. Any images or 
textures saved in a .calibz file will be copied 
into the Home Designer Suite 2015 Data\ 
Images and Textures folders for backup 
purposes. The program will only reference 
these copies if it cannot locate the files in 
their original locations. See “Home Designer 
Suite Data” on page 39. 

Legacy Library Conversion
You can import .calib and .calibz files 
created in Home Designer versions 2012, 10, 
or 9 for use in version 2015 at any time. See 
“Exporting Library Catalogs” on page 353.

In addition, legacy .alb files created in Home 
Designer versions 8.0 and prior can be 
converted for use in version 2015. 

To convert legacy library files

1. Select Library> Convert Legacy (.alb) 
Library Files. 

2. In the Select a Legacy Library File 
Folder dialog, select an .alb  file that 
you want to bring in to Home Designer 
Suite 2015.

3. The selected file’s name will display in 
the File name: field.

Note: Library content exported from Home
Designer Suite 2012 will not include catalog
names. Any subscribed content from version
10 that has not been downloaded will not be
included, either. 
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4. Click the Open button to import the 
prior version third party .alb file into the 
User Catalog.

5. Organize the imported content to suit 
your needs. See “Organizing the 
Library” on page 351.

Adding Library Content
In addition to downloading Home Designer 
Suite Content and importing entire catalogs 
into the library, you can also add a variety of 
individual objects to the library. 

Add to Library
Nearly any object imported into a plan or 
placed from the Library Browser can be 
added to the User Catalog in the library. 
• Check Add to Library in the Import 3D 

Symbol dialog. See “Importing 3D 
Symbols” on page 473.

• Select an object in your plan and click the 

Add to Library  edit button.

In addition, some Home Designer Suite 
objects that are not symbols, such as 
cabinets, terrain objects, architectural blocks, 
doorways, and windows can be added to the 
library. See “Native Objects vs Symbols” on 
page 358.

An object created using a drawing tool in 
Home Designer Suite will automatically be 
added to the User Catalog using the name of 
that tool, whereas a symbol imported will 
automatically use the Symbol Name. These 
objects can be renamed after adding them to 
the Library, either before or after moving 
them to their appropriate user created folder 
in the User Catalog. See “Renaming Library 
Items” on page 352. 

Adding Materials and Images
New materials, images, and plant images can 
be created in the User Catalog. Right-click 
on the User Catalog or a folder within it, 
select New> from the contextual menu, then 
select the type of item you wish to create 
from the submenu. 

Home Designer Suite can use materials and 
images in a variety of file formats and 
provides several means of adding new 
material and image files to the library. For 
more information, see “Creating Materials” 
on page 366 and “To create an image in the 
Library Browser” on page 451. 

Adding New Backdrops
A backdrop is an image, typically of an 
exterior view, that displays in the background 
of 3D views to help place the model into a 
realistic setting and add a sense of 
perspective. See “3D Backdrops” on page 
460. 

A new backdrop image can be created using 
a variety of graphic file formats and can be 
imported into Home Designer Suite in 
several ways: 

• Select File> Import> Backdrop  to 
open the Import Backdrop File dialog, 
which is similar to the Import Picture 
File dialog. See “Importing Pictures” on 
page 454. 
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• Right-click on the User Catalog and 
select New> Backdrop from the contex-
tual menu.

• Copy and paste an image into Home 
Designer Suite. See “Copying and 
Pasting Objects” on page 81. 

Creating a Customized 
Library Item

You can customize an existing library object 
and save your changes for future use by first 
copying the item into an unlocked library. 

To customize a library object

1. Right-click on a library item and select 

Copy  from the contextual menu.

2. Browse to the User Catalog or a folder 
within it and right-click on it.

3. Select Paste from the contextual menu 
to make a copy of the library item in this 
new location.

4. Right-click on the copied item and select 

Open  from the menu.
5. The item’s specification dialog opens, 

and you can make any changes that you 
wish to the item.

6. Make any needed changes to the item, 
then click OK. Your changes will be 
saved with this item for use in any plan.

Organizing the Library
Library folders and objects can be copied, 
pasted, moved, and deleted: allowing you to 
organize your User Catalog to best suit your 
work style and needs. 

Adding New Folders
New folders can be added to the User 
Catalog or to any folder located within it. To 
add a new folder, right-click on User Catalog 
or one of its sub-folders and select New> 
Folder from the contextual menu. 

The new folder is created inside the library 
item you right-clicked on and is initially 
named “Untitled”. Type a short, descriptive 
name and press Enter. 

Selecting Library Items
To select a library object, folder, or category, 
simply click on it.

When an item is selected, preview images 
display in the Selection and Preview Panes 
and basic information about it also displays 
in the program’s Status Bar. See “The Status 
Bar” on page 30. 
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A selected library item can be modified in a 
number of ways to help meet your 
organizational needs. 

Renaming Library Items
Only folders and objects in the User Catalog 
can be renamed. There are several ways to do 
this from the tree list: 
• Right-click on the item, select Rename 

from the contextual menu, and type a 
new name. 

• Click once on the item, press F2 on your 
keyboard and type a new name.

• Click once on the item, pause for a 
moment, then click a second time and 
type a new name.

Library names are case-sensitive and can 
contain up to 63 characters. While you can 
have more than one library item that uses the 
same name, it is best to use short, descriptive 
and unique names.

Moving Library Items
Folders and objects in the User Catalog can 
be moved to new locations within the User 
Catalog. Folders and library objects are 
always organized alphabetically within each 
hierarchy.

To move an item to a different location, 
select it in the tree list, then click and drag it 
to the new location in the list. Directories and 
folders able to accept new content highlight 
as your mouse pointer moves over them. 
Release the mouse button to relocate the 
selected library item in the highlighted 
location.

You can also cut a library item from one 
location and paste it in another. When an 

item is cut, it is removed from its current 
location and saved to the Windows 
Clipboard. To cut an item:
• Right-click on it and select Cut from the 

contextual menu. 
• Click on the library item and press 

Ctrl + X on your keyboard.

To Paste the item, click on a library catalog 
or folder in the Library Browser tree view 
and either:
• Right-click on the new location and 

select Paste from the contextual menu.
• Press Ctrl + V on your keyboard. 

Copying Library Items
All library folders and library objects can be 
copied and pasted to new locations in the 
User Catalog. 

There are two ways to copy a library item to 
the Windows Clipboard: 
• Right-click on it and select Copy from 

the contextual menu. 
• Click on the library item and press 

Ctrl + C on your keyboard.

To Paste the item, click on a library catalog 
or folder in the Library Browser tree view 
and either:
• Right-click on the new location and 

select Paste from the contextual menu.
• Press Ctrl + V on your keyboard. 

When a library item is copied and pasted, the 
new item that results is independent of the 
original item. If you make changes to it, the 
original item is unaffected. Similarly, 
changes to the original item do not affect the 
copy.
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Library Shortcuts
In addition to copying and pasting to create 
new, independent library items, you can copy 
and paste to create Library Shortcuts. Library 
Shortcuts are not independent items - they 
are linked to the original item and are 
affected if changes are made to the original.

Library Shortcuts are advantageous because 
you can place a given library item in multiple 
locations to suit your organizational style 
without increasing the size of the library 
database and without having to maintain 
multiple copies of the same item.

To create a Library Shortcut, copy a library 
item to the Windows Clipboard. Then, right-
click on the location where you would like to 
create a copy and select Paste Shortcut from 
the contextual menu. Library Shortcuts use 
the same name as their source item but use 

the Library Shortcut  icon.

To locate a Library Shortcut’s source item, 
right-click on it in the tree list and select 
Locate Shortcut Source 

If you move or delete an item from the 
library, any shortcuts to it will not be updated 
or removed. If you try to use a “hanging” 
shortcut, a message about its status will 
display in the library preview panes.

Deleting Library Items
The five installed library categories: Home 
Designer Core Catalogs, Home Designer 

Bonus Catalogs, Manufacturer Catalogs, 
User Catalog, and Trash cannot be deleted. 

Catalog level folders in all categories can be 
deleted; however, individual subfolders and 
objects can only be deleted out of the User 
Catalog.

Items in the library that are eligible for 
deletion can be deleted in either of two ways: 
• Right-click on it and choose Delete from 

the contextual menu.
• Select it and press the Delete key on your 

keyboard.

When items from the User Catalog are 
deleted, they are moved to the Library 

Browser Trash . Items in the Trash can be 
retrieved by clicking and dragging them into 
any location in the User Catalog.

To empty the Trash , right-click on it and 
select Empty Trash from the contextual 
menu. 

Depending on how much content is in the 
Trash, emptying it can be time consuming. 
You can click the Cancel button to end the 
process if you wish. 

Exporting Library Catalogs
Exporting library files allows you to: 
• Back up your custom library content.

• Transfer library content between comput-
ers.

The Empty Trash command is both
immediate and permanent. It cannot be

undone, so use care when using it. You
should back up all your library files regularly.
See “Backing up Library Content” on page
347. 
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Exporting is often preferable to simply 
copying library files because it allows you to 
include images and textures in the exported 
library. 

To export content from the library

1. Locate an object, folder, or catalog that 
you want to export, right click on it, and 
select Export Library.

2. In the Export Library Data dialog.
•  Choose the appropriate Save in: loca-

tion for your exported library file.

•  Type a short, descriptive name for your 
library file in the File Name field.

•  Click the Save as type: drop down list 
and select whether or not you want the 
library to include Textures/Images.

•  Click Save.
3. Your exported library file can now be 

copied to a network location or storage 
device in an operating system window. 

Placing Library Objects
Library objects are subject to placement 
restrictions based upon typical real-life 
placement. Most library objects require 
sufficient free space at the location where 
they are placed, for example, and some 
library objects have additional requirements.

Library windows and doors, for example, 
must be placed in a wall just like standard 
windows and doors, and some fixtures are 
designed to be placed in cabinets.

Library symbols have placement restrictions 
that are determined when the symbol is 
created but can be changed later. See “Native 
Objects vs Symbols” on page 358 and 
“Symbol Specification Dialog” on page 59.

If a warning message displays when placing 
a library object, it will indicate where the 
object can be placed. 

There are three main categories of items 
available in the Library Browser:

• Stand-alone objects that can be placed 
directly into a plan. Examples include 
cabinet modules, furnishings and images.

• 3D objects designed to be inserted into 
another 3D object. Examples include 
cabinet fixtures, windows and doors. 
Some items, such as cabinet doors and 
fixtures and fence panels, can be inserted 
into another object or placed as stand-
alone objects. 

• Materials, which cannot stand alone and 
must be assigned or applied to another 
object.

Stand-Alone Objects
Most library categories contain objects that 
can be selected in the Library Browser and 
placed directly in a 2D or 3D view. 
• Most stand-alone objects are designed to 

rest on the floor or terrain.

If any of the items being exported are
images or use textures, be sure to
select the .calibz file type.
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• Some objects will rest on top of a cabinet, 
shelf, furniture or roof plane object if one 
is located at the point where they are first 
placed.

• A few objects, notably some light fix-
tures, will mount on the bottom of a wall 
cabinet or on the ceiling.

• In addition, some objects will attach to a 
wall if one is nearby.

To place a stand alone library object

1. Click on an object in the tree view or 
Selection Pane of the Library Browser to 
select it for placement. See “The Library 
Browser” on page 342. 

2. Move your cursor into the view area and 
notice that it displays an icon indicating 
the type of object selected instead of an 
arrow icon.

3. Click to place the selected object at that 
location. 

4. Continue clicking to place as many 
instances of the selected object as 
needed. When you are finished, click the 

Select Objects  button. 

Once a stand-alone object has been placed, it 
can be edited in a variety of ways. See 
“Editing Library Objects” on page 357.

Inserted Objects
Some objects cannot stand alone and must be 
placed into other objects in a plan. For 
example, doors and windows must be 
inserted into a wall, while some appliances 
and plumbing fixtures must be placed inside 
a base cabinet. See “Doors” on page 161, 

“Windows” on page 177 and “Cabinets” on 
page 271.

An inserted object can only display in a 2D 
or 3D view if the object that contains it is set 
to display. This is the case even if the 
inserted object’s layer is turned on. See 
“Displaying Library Objects” on page 357. 

To insert a library object

1. Click on an object in the tree view or 
Selection Pane of the Library Browser to 
select it for placement. See “The Library 
Browser” on page 342. 

2. Move your cursor into the drawing area.
3. Click on the object into which you wish 

to insert the selected library item. The 
library item is inserted into the object.

4. Continue clicking to place as many 
instances of the selected item as needed. 
When you are finished, click the Select 
Objects  button.

Assigned Items
Some library items, such as materials, are not 
objects in themselves but can be applied to 
objects in a variety of ways.
• Using the specification dialog of the con-

taining object. See “Select Library Object 
Dialog” on page 356.

• By selecting the item in the library and 
then clicking on the containing object in 
floor plan view.

• Materials can be assigned to objects 
directly from the library in 3D views by 
by selecting the material and then 
clicking on an object’s surface. See “The 
Material Painter” on page 362.
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Select Library Object Dialog
The Select Library Object dialog is a modal 
version of the Library Browser that is 
accessible from object specification dialogs 
that display the  button.

Click this button to select and apply items 
from the library to the selected object. See 
“Specification Dialogs” on page 29. 

The Select Library Object dialog only 
displays categories that are related to the 
selected object. For example, this is how the 
dialog looks when accessed from the General 
panel of the Door Specification dialog:

To make your selection, highlight the desired 
object and click OK, or simply double-click 
on the object in the Selection Pane to close 
the Select Library Object dialog. 

The Select Library Object dialog has most 
of the same functionality that the Library 
Browser has, including the search and search 
filtering options, and resizable Preview and 

Selection Panes. See “The Library Browser” 
on page 342. 

If the Select Library Object dialog is opened 
by clicking the Select Material button on the 
Materials panel of any specification dialog  

or using the Material Painter , two 
additional options are available: 
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• Click the Add New Material  button 
to open the Define Material dialog and 
create a new material.

• Check Use Default Material to apply the 
default material for the selected object, if 

one exists. See “Material Defaults” on 
page 369.

See “Materials Panel” on page 364 or “The 
Material Painter” on page 362.

Displaying Library Objects
The display options available for library 
objects depend on the type of object in 
question, as well as the view.

If the display of an object is turned off in a 
2D or 3D view, any objects inserted into it 
will not display in that view, either - even if 
the inserted object’s layer is turned on. See 
“Inserted Objects” on page 355. 

In Floor Plan View
All library objects except materials, doors 
and drawers applied to cabinets, and 
backdrops can display in floor plan view. 
Library objects are represented in floor plan 
view by 2D symbols that resemble the size 
and shape of the object when viewed from 
above.

As with other architectural objects, the 
display of library objects is controlled by 
layer in the Display Options dialog. Each 
library category has its own layer.  See 
“Display Options Dialog” on page 75.

Object Labels
Fixtures, Furnishings, Geometric Shapes, 
Hardware, Millwork and Plants can display 
labels in floor plan view when the 
appropriate layer is set to display in the 
Display Options dialog. For example, 
fixture labels are placed on the “Fixtures, 
Labels” layer. See “Object Labels” on page 
429.

You can specify a custom label for many 
library objects in the Symbol Object 
Specification dialog. See “Symbol Object 
Specification Dialogs” on page 359. 

In 3D Views
All library objects can display in 3D views. 

By default, images rotate to face the camera 
in 3D views. For information about turning 
off image rotation, see “Image Specification 
Dialog” on page 452.

Editing Library Objects
Like native Home Designer Suite objects, 
library objects can be customized to suit your 
design needs. There are three approaches to 
editing library objects:

• Select an object in the User Catalog, edit 
it using any of the options in its contex-
tual menu, and your changes will be 
reflected when you next place this library 
object in a drawing.
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• Place an object in a drawing and then edit 
it using the various edit tools available 
for it. This will not affect the original 
object still saved in the library.

• Place an object in a drawing, edit it using 
the available edit tools, and then add it 
back to the library for future use. This 
will not replace the original object still 
saved in the library. See “Add to Library” 
on page 350.

Library objects placed in a drawing can be 
selected individually or as a group, like other 
objects in Home Designer Suite. See 
“Selecting Objects” on page 86. 

Once selected, library objects can be edited 
in a variety of ways using the edit handles, 
the edit toolbar buttons and the specification 
dialog. See “Symbol Object Specification 
Dialogs” on page 359. 

Any changes made to objects like fixtures 
and furniture will not be reflected in their 
Materials List Description, although they 
may be seen in other columns, such as Size. 
See “Materials Lists” on page 491. 

Native Objects vs Symbols
In Home Designer Suite, objects created 
using the program’s standard tools, such as 

the Door Tools  and Cabinet Tools , 
are referred to as native objects. 

On the other hand, objects placed from the 
library, such as fixtures and furnishings, are 
symbols. Symbols are typically more limited 
than native objects in how they can be edited.

In addition to the symbols available in the 
library, you can import additional symbols 
into the program from 3D .obj, .3ds or .skp 
files. See “Importing 3D Symbols” on page 
473. 

Using Edit Handles
Most library symbols are box-based objects 
and can be edited as such once placed in a 
drawing. See “Editing Box-Based Objects” 
on page 98. Depending on the type of view 
and the surface selected, the edit handles a 
symbol displays will vary. 

When a furnishing or fixture symbol is 
selected in floor plan view or on the top 
surface in a 3D view, up to ten edit handles 
display. They are the Move handle at the 
center, the Rotate handle just outside the 
front indicator (a V) and a Resize handle on 
each edge and at each corner. 

When a symbol is selected on a side in a 3D 
view, it displays five edit handles: the Move 
handle and a Resize handle on each edge. 

Fixtures and furniture placed in a plan are 
subject to bumping/pushing behavior when 
moved. See “Bumping/Pushing” on page 
106.

Deleting Built-in Fixtures 
and Appliances

A fixture installed into the front of a cabinet 
becomes a cabinet face item, like a door or 
drawer. It can be resized or deleted like other 
face items in the Cabinet Specification 
dialog. See “Front Panel” on page 282. 
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Symbol Object Specification Dialogs
The Fixture, Furniture, Geometric 
Shape, Hardware, and Millwork 

Specification dialogs all feature the same 
options. The actual name of the dialog is 
determined by the type of object that is 
currently selected. 

For example, selecting a library object 
placed from the Interiors Core Catalog and 

clicking the Open Object  edit button 
opens the Furniture Specification dialog. 

General Panel

The Name of the selected symbol 
object displays here.

Size/Position - 

• Specify the Height, Width, and Depth of 
the object.

• Check Retain Aspect Ratio to maintain 
the ratio between the object’s Height, 
Width, and Depth when it is resized in the 
specification dialog. Does not affect the 
behavior of the object’s edit handles. 

• Click Reset Size to reset the symbol’s 
original, unmodified size. The Floor to 
Bottom value, below, is not affected by 
this button.

• Floor to Bottom - Enter the distance 
from the floor to the bottom of the object. 
A value of zero rests the object on the 
floor. 

• If the selected symbol is ceiling mounted, 
Height Above Ceiling will be available 
instead of Floor to Bottom. Specify the 
selected object’s height above the ceiling. 

1

2
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Enter a negative value to offset the sym-
bol below the ceiling, or uncheck Follow 
Ceiling if you prefer to specify the 
object’s Floor to Bottom height instead. 

• When the selected object is outside a 
room and Auto Adjust Height is 
checked, its Floor to Bottom height is 
measured relative to the terrain height. 
When this is unchecked, the Floor to Bot-
tom height is measured from the default 
floor height of Floor 1. See “Terrain 
Height vs Floor Height” on page 290 of 
the Reference Manual. 

Check Reverse Symbol to reverse the 
object’s appearance, so that features on 

its left are positioned on its right, and vice 
versa. This turns a right-hand refrigerator, for 
example, into a left-hand refrigerator. This 
option has no effect on objects that are 
symmetrical. 

If the selected object has a Copyright, 
information about it displays here.

A preview of the selected library object 
displays here and updates with changes. 

See “Dialog Preview Panes” on page 29.

Materials Panel
For information about the settings on this 
tab, see “Materials Panel” on page 364.

Label Panel
A variety of library objects can display labels 
in floor plan view. Labels use the Text Style 
assigned to the layer they are on.

For information about the settings on this 
tab, see “Label Panel” on page 429.

Manufacturer Panel
If the selected symbol or material is from a 
Manufacturer’s catalog, the Manufacturer 
panel lists contact information about the 
manufacturer. See “Manufacturer Catalogs” 
on page 347.

3

4

5
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Chapter 25:

Materials

The objects used in Home Designer Suite 
have a variety of 3D properties. These 
objects - walls, windows, doors, cabinets, 
roof planes, lot perimeters, etc. - can have 
materials assigned to them so that they look 
realistic in 3D views. These materials can 
also be used to generate materials lists that 
can help with cost estimations. 

Designing with objects that look correct in 
3D and calculate properly in the Materials 
List requires that you use realistic material 
definitions and apply them appropriately to 
objects in your plan.

Home Designer Suite comes with many 
materials that are ready for use. From siding, 
roofing, flooring, masonry, tile, and paneling, 
to grass, water, and wood materials, Home 
Designer Suite has materials for every 
application, inside and out. If you cannot find 

a material that suits your needs, you can 
customize the materials provided or create 
your own.

Chapter Contents
•      About Materials
•      The Material Painter
•      Materials Panel
•      Editing Materials
•      Creating Materials
•      Define Material Dialog
•      Material Defaults
•      Select Color Dialog

About Materials
The materials that are assigned to objects in 
Home Designer Suite perform two important 

roles:

Redefining only the visual properties of a
material may create unexpected results.

For example, changing the image of a brick
material to represent siding does not cause
the material to be considered as siding during
material calculations.
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• They determine what the surfaces of 
objects look like in 3D views. 

• They influence how objects are calculated 
in the Materials List. See “Materials 
Lists” on page 491.

Materials are stored in the Materials library 
in the Library Browser and can be applied to 
objects in either of two ways:

• Using the Material Painter . 
• In an object’s specification dialog. See 

“Materials Panel” on page 364.

Textures
In Home Designer Suite, materials have 
textures associated with them that determine 
how they look in 3D views.

Textures are created using special image files 
that tile seamlessly when applied to surfaces.

In 3D views, you can turn the display of 
textures on and off by selecting 3D> Render 
View Options> Toggle Textures . When 
textures are turned off, materials are 
represented using solid colors. 

 The Material Painter
Select 3D> Material Painter to 
access the Material Painter Tools, 

which are used to apply materials to object 
surfaces in 3D views. 

The Material Painter  tool can also be 
activated by selecting a material in the 
library while a 3D view is active. 

Material Painter Modes
There are five Material Painter Modes. Each 
mode specifies how broadly or narrowly the 
selected material will be applied to surfaces 
in your plan. 
• The Material Painter Component Mode 

 is the default mode. This applies the 
selected material to an object component. 
Using this tool is the same as opening an 
object for specification and changing the 
material for one of its components on the 
Materials panel. See “Materials Panel” on 
page 364.

• The Material Painter Object Mode  
applies a material to all components of an 
object that share the same material assign-
ment. 

• The Material Painter Room Mode  
applies a material to all the objects in the 
room that currently have the same mate-
rial. For example, if you apply a material 
to a dining room chair, this mode applies 
the material to all other objects in the 
room with the same original material, 
such as other chairs and the dining table.

• The Material Painter Floor Mode  
applies the selected material to all sur-
faces on the floor that currently have the 
same material. For example, if you apply 
a material to the kitchen countertops 
using this mode, the bathroom counter-
tops on the same floor also have the mate-
rial applied.

• The Material Painter Plan Mode  
applies the selected material to all sur-
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faces in the entire plan that currently have 
the same material. For example, if you 
have the same carpet on all floors in a 
plan, applying a selected material while 
this mode is active will change all carpet 
on all floors. 

When the Material Painter  tool is 
active, the Material Painter Mode toolbar 
buttons display in the edit toolbar, allowing 
you to quickly change modes.

You can also specify the active mode by 
selecting 3D> Material Painter. A check 
displays next to the active mode in the 
submenu.

Blend Colors With Materials
In addition to the Material Painter 
Modes, the Blend Colors With 

Materials option allows you to apply a solid 
color to a surface displaying a pattern and 
blend the two. 

Blend Colors With Materials  works in 
all five Material Painter Modes. See 
“Blending Materials” on page 367.

To use the Material Painter tool

1. Create a 3D view in which the patterned 
material is visible.

2. Select 3D> Material Painter> Mate-
rial Painter . 

3. Select a solid color material from the 
Select Library Object dialog. See 
“Select Library Object Dialog” on page 
356.

•  Check Use Default Material at the 
bottom left of the dialog to apply the 
default material to any object that has a 
defaults dialog. See “Material 
Defaults” on page 369.

4. Select a Material Painter Mode from the 
edit toolbar, which displays on the left 
side of the program window when the 
Material Painter is enabled.

5. Click the Blend Colors With Textures 

 edit button to turn this feature on or 
off depending on your needs.

6. Note that the name of the material being 
painted displays on the left side of the 
Status Bar at the bottom of the program 
window. See “The Status Bar” on page 
30. 

•  Move your pointer over a surface in the 
3D view. The Status Bar now states 
both the material being painted and the 
current material on the target surface.

7. Click on the surface to apply the 
selected material to that surface. The 
material is applied to surfaces in the 
model based on the active Material 
Painter Mode. 

•  When both the Material Painter  
and Blend Colors With Textures  are 
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active, the cursor displays a paint roller 

icon .

•  When the Material Painter  is 
active and Blend Colors With 
Textures  is not, the cursor displays 

a spray can icon . 

8. If either the Component  or Object 
Mode  is active, you can continue to 
click on surfaces to apply the selected 
material. When you are finished, select a 
different tool. 

Material Painter and Walls

As a general rule, the Material Painter  
cannot be used to apply a material to an 
individual wall. Rather, it applies the 
material to an entire room, to all the rooms 
on the floor, or to all the rooms in the entire 
plan, depending on which Material Painter 
Mode is active.

There are a couple of exceptions to this rule 
that apply when the wall surface being 
painted faces an exterior room such a porch 
and/or the Exterior Room. See “Room 
Types” on page 147.

• If the Material Painter Room Mode  
is active, the selected material is applied 

to the entire exterior room. If any walls 
defining this room also define other exte-
rior rooms, their entire lengths are also 
affected. 

• If the Material Painter Component 
Mode  is active, the entire length of 
the individual wall is painted. Other walls 
defining the exterior room(s) are unaf-
fected. 

Material Eyedropper
The Material Eyedropper tool 
allows you to load the material 

assigned to an existing object and apply that 
material to other objects.

In a 3D view, select 3D> Material Painter> 
Material Eyedropper  and then move 
your mouse pointer over a surface in the 
view. The name of the material on that 
surface is stated on the left side of the Status 
Bar. Click on the surface to load its material 
assignment. The pointer then changes to 
indicate that the material is ready to be 
applied to another object using the Material 
Painter  tool. Depending on the currently 
active Material Painter Mode, you can 
continue to apply the material to the surfaces 
of other objects.

Materials Panel
The specification dialogs for most objects 
include a Materials panel. Select an object 

and click the Open Object  edit button to 
open the specification dialog for that 
selection. 

On the Materials panel, you can specify 
material assignments for the components that 
make up that object. When a new material is 
assigned, the appearance of the preview 
image on the right side of the dialog updates. 
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The tree list on the left side of the panel 
lists the components of the selected 

object that can be assigned unique materials. 
Some objects may have only one component 
while more complex objects may have many. 
In addition, some components contain 
additional sub-components, which display 
separately in the components tree list. 
• Click on a component in the tree list to 

select it and assign a new material to it. 

The box to the right of the tree list 
displays a preview of the material 

assigned to the selected component. If “No 
Texture” displays in the preview window, 

either the material has no texture assigned or 
the texture file could not be found on the 
system.
• Click Select Material to open the Select 

Library Object dialog. Select a material 
and click OK to assign that material to the 
selected component. See “Select Library 
Object Dialog” on page 356. 

A preview of the selected object 
displays on the right side of the panel. 

To view material textures, select Standard 
as the View Type. See “Dialog Preview 
Panes” on page 29. 

Editing Materials
Much like objects, materials in Home 
Designer Suite can be edited so that they 

better suits your design needs. There are two 
approaches to material editing:

1

2

3
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• Select a material in an unlocked library in 
the Library Browser, edit it, and your 
changes will be used when you next use 
the material in any plan. Changes made in 
this manner do not affect materials 
already in use in a plan. 

• Apply a material to an object in a plan and 
then edit that applied material using the 

Adjust Material Definition  tool. 
Changes made in this way will affect any 
instances of that material in the current 
plan only. 

Editing the material applied to an object is 
not the same as applying a different material 
to that object. See “The Material Painter” on 
page 362.

Library Browser
Right-click on a material in an unlocked 
library and select Open from the contextual 

menu to open the Define Material dialog for 
that material. See “Define Material Dialog” 
on page 367.

Adjust Material Definition
The Adjust Material Definition tool 
is useful for changing plan materials 

directly from a 3D view. 

Select 3D> Materials> Adjust Material 
Definition  and then click any surface in 
a 3D view to modify the material currently 
assigned to that surface in the Define 
Material dialog. See “Define Material 
Dialog” on page 367.

Changing a material definition with this tool 
affects all objects in the current plan that are 
using that material but does not affect any 
materials saved in the library or materials 
used in other plans. See “Adding Library 
Content” on page 350.

Creating Materials
Home Designer Suite provides a wide variety 
of materials - including numerous name 
brand material catalogs - that are ready to 
download and use. If you cannot find a 
suitable material, you can edit an existing 
material or create a new one. See “Editing 
Materials” on page 365.

In the Library Browser
Materials can be created in the Library 
Browser, making them available for use in 
any plan. See “Adding Library Content” on 
page 350. 

In the directory pane of the Library Browser, 
right-click on an unlocked folder and select 
New> Material from the contextual menu. 
See “Using the Contextual Menus” on page 
344.

The Define Material dialog opens, allowing 
you to specify the new material’s attributes. 
See “Define Material Dialog” on page 367. 

Note: Adding a material to a plan is not the
same as adding it to the library. If you want a
new material to be available for use in other
plans, create it in the Library Browser.
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Blending Materials
In 3D views, you can create a new 
material by blending a solid color 

such as a paint color with a textured material. 
Select 3D> Material Painter> Blend 
Colors With Materials to toggle this feature 
on or off. See “Blend Colors With Materials” 
on page 363.

The result is a new material that is saved in 
the current plan. 

Materials created using the Blend Colors 
With Materials  tool are given the name 
of the patterned/textured material with the 
extension “--PAINTED:” followed by the 
name of the solid color material. 

Stretch to Fit
Some special textures, often used for 
artwork, stretch across any surfaces that they 
are applied to. Materials that behave this way 
are specified as Stretch to Fit in the Define 
Material dialog. 

To display an artwork texture, first place a 
wall or desk frame in your plan. A selection 
of both are available in the library. See 
“Placing Library Objects” on page 354.

Next, simply apply a material specified as 
Stretch to Fit to the center portion of the 
frame. See “The Material Painter” on page 
362. 

For more information about creating and 
using custom materials, see “Materials 
Tutorial” on page 115 of the User’s Guide.

Define Material Dialog
The Define Material dialog allows you to 
adjust how materials look in 3D views and 
can be accessed in a number of ways:

• Use the Adjust Material Definition  
tool. See “Adjust Material Definition” on 
page 366. 

• Right-click on a material in an unlocked 
library in the Library Browser and select 
Open from the contextual menu. See 
“Using the Contextual Menus” on page 
344. 

• You can also right-click on an unlocked 
library and select New> Material. 

Manufacturer Panel
If the selected material was copied from the 
Manufacturer library category, the 
Manufacturer panel lists contact information. 
See “Manufacturer Catalogs” on page 347. 
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The Material Name displays here. In 
this field, you can type a new name if 

you wish. Renaming the material does not 
create a new material: it redefines the 
existing material in the current plan.
• Click the Solid Color radio button to 

specify the material as a solid color, then 
click the Select button to open the Select 
Color dialog and select a new color. See 
“Select Color Dialog” on page 370.

• Click the Texture radio button to specify 
a texture for the material instead of a solid 
color, then click the Select button to open 
the Select Texture File dialog, a standard 
Open File dialog, and specify an image 
saved on your computer to serve as the 
texture. 

The Texture Options are only enabled 
when Texture is selected, above. 

• Check Blend Color and Texture to blend 
the selected texture with a solid color, 
then click the Select Color button to 
specify the color you would like to blend 
it with. When a new material is created 
using the Blends Color With Materials 

 tool, the resulting material has this 
box checked. See “Blend Colors With 
Materials” on page 363.

• Specify the X and Y Scale for the chosen 
texture in inches (mm). If you specify x 
and y values of 30”, the pattern repeats 
every 30 inches in both directions along a 
surface. 

1 2
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• Check Stretch to Fit to stretch the texture 
image over the entirety of each surface it 
is applied to. This is useful when you 
wish to create a painting or photo material 
to display in a frame. See “Stretch to Fit” 
on page 367.

• Rotate Angle - Specify how the texture is 
rotated on the surface it is applied to.

General Options - 

• Brightness controls how bright the mate-
rial appears relative to other materials.

• Shininess controls the sheen of the mate-
rial when it is rendered with a point or 
spot light source on it. Shiny materials 
such as metal will reflect light when 
viewed at the right angle.

• Transparency controls the opacity of the 
material. A transparency value of 0 results 
in a completely opaque material, while a 
value of 100 creates a material that is 
completely invisible. 

• Use the Emissive slider bar or text field to 
control how bright a material appears 
independent of the lighting in the scene. It 
can be used to simulate surfaces that are 
glowing with their own light, such as the 
glass on a light fixture. 

Any Copyright information about the 
material displays here. 

A preview of the selected texture or 
color displays in the square pane. 

A preview of the material applied to an 
object displays here and updates as 

changes are made to the material definition. 
Various options allow you to view different 
aspects of the material’s attributes: 
• Zoom and orbit the object in the view.
• Toggle Color on or off.
• Select an object shape: Cube, Sphere, or 

Teapot.

Material Defaults
Most objects in the program have 
defaults dialogs which allow you to 

set up a variety of attributes, including 
materials, before the objects are created. 
Default Settings are accessed by selecting 
Edit> Default Settings. See “Preferences 
and Default Settings” on page 55.

The Material Defaults dialog serves two 
purposes. It allows you to:

• Set the default materials for objects that 
do not have a defaults dialog. Fireplaces 
and furnishings from the library are 
examples of objects that do not have a 
defaults dialog. 

• Set the initial materials that can then pop-
ulate a variety of defaults dialogs for 
objects that do have them. Door, Window, 
and Cabinet Defaults are examples of 
defaults dialogs that can draw their mate-

Note: Changing the scale or selecting Stretch
to Fit can cause textures to appear distorted if
they are mapped to a surface using a different
aspect ratio than they were originally created
with.

3

4

5

6
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rial assignments from the Material 
Defaults dialog. 

Because material defaults are Dynamic 
Defaults, you can also use the Material 
Defaults dialog to apply a material to 
multiple objects that share similar 
components. For example, the “Room 
Moldings” Material Default applies to the 
base, crown, and chair rail moldings that can 
be assigned to rooms, as well as to interior 
door and window casing. If you change this 
Material Default, all of these objects in the 
plan can be affected. See “Dynamic 
Defaults” on page 57. 

Material Defaults Dialog

Select Edit> Default Settings  from the 
menu, select “Materials”, and click the Edit 
button to open the Material Defaults dialog. 

The settings here are similar to those on the 
Materials panel found in object specification 

dialogs throughout the program. See “Mate-
rials Panel” on page 364.

• Select a category from the scrollable list. 
• Click the Select Material button or mate-

rial preview box to open the Select 
Library Object dialog. See “Select 
Library Object Dialog” on page 356.

Select Color Dialog
The Select Color dialog can be opened by 
clicking on the color bar that can be found in 
many dialogs throughout the program. 
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The currently selected color displays in 
the rectangle at the lower center of the 

dialog. There are a number of ways to select 
a color in this dialog:

Click in any one of the Basic colors 
boxes to select it.

Click anywhere in the color palette area 
to select a color. The location of the 

selected color is identified by a crosshairs.
• Click anywhere in the vertical bar or drag 

the arrow to the right to adjust the 
selected color’s darkness.

Define the selected color by specifying 
its Hue, Saturation, and Value (HSV) 

or its Red, Green, and Blue (RGB) values.

Click in one of the Custom colors 
boxes to either select it as the new color 

or to specify it as the box for a new custom 
color to be defined.
• Click the Add to Custom Colors to add 

the currently selected color to the Custom 
Colors group.

Click the Color Chooser Eyedropper, 
then click anywhere on your monitor to 

select the color displaying at that location.

Click OK to apply the currently selected 
color to the object’s line or fill style, or to the 
material’s pattern color. 

1

2

3

4

5

You can select a color from any program
window. Before opening the Color

Chooser dialog, make sure the desired color
can be seen onscreen by tiling Home Designer
Suite and the other program window.

6
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Chapter 26:

View and Window Tools

The View and Window Tools let you control 
how views of your drawing are shown on 
screen, as well as toggle useful drawing aides 
on and off.

There is no limit to the number of plan files 
that can be open. The name of the file and the 
type of view displays at the top of each view 
window in its title bar. 

Chapter Contents
•      View Tools
•      Zoom Tools
•      Undo Zoom
•      Fill Window
•      Panning the Display
•      Working in Multiple Views
•      Closing Views
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View Tools
The View Tools allow you to open and close 
the program’s side windows, as well as 
toggle a variety of references and drawing 
aides. Select the View menu to access these 
tools. 

Refresh Display redraws the current 
window to clean up extra lines, show 

missing items, and correct random on-screen 
effects caused by changes to the model. See 
“Refresh Display” on page 105.

Library Browser opens and closes 
the Library Browser side window. See 

“The Library” on page 341.

Tool Palette opens and closes the Tool 
Palette, which will display related tools. See 
“Child Tool Palette” on page 70.

Scrollbars displays and suppresses 
scrollbars on view windows. See 

“View Windows” on page 24. 

Color toggles the display of color in 
the current view. See “Color On/Off” 

on page 104.

Reference Grid toggles the display of 
the Reference Grid in all views in the 

current plan or layout file. See “Grid Snaps” 
on page 79.

Zoom Tools
Zoom is used to magnify any given 
area on the plan or 3D view. Select 

Window> Zoom, then click and drag a 
marquee around an area on screen. When 
you release the mouse, the selected area 
expands to fill the screen. 

When the zoom is complete, whatever tool 

was active prior to selecting the  Zoom  
tool automatically becomes active again. If 

another zoom is needed, click the  Zoom  
tool again.

Zoom In - Click to zoom in towards 
the screen center by a factor of two.

Zoom Out - Click to zoom out from 
the screen center by a factor of two.

Undo Zoom - Reverse the last zoom 
operation.

Fill Window - Fits all visible items on 
screen.

Fill Window Building Only - Fits all 
walls and railings on the current floor 

on screen. 

Zooming With 
the Mouse Wheel

Use the mouse wheel to zoom in and 
out in plan and 3D views. Scrolling 
the mouse wheel one click up or 

down zooms in or out, centering on the 
location of your pointer and changing the 
zoom by about 10%.
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Zooming in 3D Views
Zooming in 3D views does not change the 
camera’s location or field of view. Instead, 
the extents of the view are expanded or 
cropped. 

Undo Zoom
Select Window> Undo Zoom to 
reverse the last zoom operation. 

Zoom  and Undo Zoom  are also 
available through the contextual menu. See 
“Contextual Menus” on page 27. 

Fill Window
In floor plan view or an Elevation 
view, select Window> Fill Window 

or press the F6 key to view nearly everything 
on screen that is visible, including the 
Reference Display. CAD Points are the only 
objects that are not included when Fill 
Window is used. 

If you are zoomed in so that only a portion of 
the drawing displays on screen, selecting Fill 
Window  zooms out so that the entire 
view fits on the screen. If you are zoomed 
out so that the entire drawing is smaller than 

the screen, selecting  Fill Window  
zooms in until the drawing fills the screen.

When the drawing sheet is shown, Fill 
Window  zooms to the sheet borders.

Fill Window Building Only
Window> Fill Window Building 
Only is similar to Fill Window, but 

zooms in or out to so that all walls and 
railings in the view fill the current window. 
Other objects are ignored.

In 3D Views

In 3D views, Fill Window  and Fill 
Window Building Only  adjust the 
camera’s Field of View is adjusted so that all 
surfaces in the 3D view are included.  

Panning the Display
There are four ways to pan the display 
without changing the zoom factor.

Note: Depending on the configuration of your
mouse, it may be necessary to hold down the
Ctrl key while turning the mouse wheel. If
zooming in and out are not working correctly,
contact the manufacturer of your mouse and
mouse driver for their assistance. 

Note: Undo and Redo do not affect zoom.
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Using the Scroll Bars
One method is to use the scroll bars on the 
right and bottom edges of the window.

• Drag the square button in the bar itself in 
order to pan a larger distance. 

• Click the end arrow keys on the scroll 
bars to shift the display in 12" incre-
ments. 

• The 12" increment is defined in the Plan 
Defaults dialog under Inches Scrolled 
by Arrow Key. See “General Plan 
Defaults Dialog” on page 57.

Using the Arrow Keys
In floor plan view, the arrow keys on the 
keyboard work exactly like clicking the 
arrow buttons on the scroll bar. They shift the 
display according to the number of inches 
defined in the Plan Defaults dialog.

Using the Mouse
If you have a wheel mouse, you can pan the 
display by pressing the middle mouse button, 

or wheel, and moving the mouse in the 
direction you would like to pan. When the 
middle mouse button is held down, the 

pointer changes to a hand  icon. 

In the Mac version of Home Designer Suite, 
you can pan using the left mouse button and 
Command key.

Mouse drivers sometimes have other 
functions assigned to the wheel and buttons. 
These override the Home Designer Suite 
setting.

Using a Mac Trackpad
In the Mac version of Home Designer Suite, 
you can two finger drag to pan the display. 
See “Using a Trackpad” on page 24. 

Using the Pan Window Tool
The Pan Window tool works much 
like the mouse wheel method.

Select Window> Pan Window . The 

pointer changes to a hand  icon. Click and 
drag to pan the window. The program reverts 
to the previously active tool when you 
release the mouse button.

Working in Multiple Views
There is no limit to the number of plan files 
that can be open, nor is there a limit to the 
number of plan view windows that can be 
open. The name of the file and the type of 

view is stated at the top of each view window 
in its title bar as well as in its tab. 

By default, Home Designer Suite uses a 
tabbed document interface, which means that 

Scroll Bars
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when more than one view window is open in 
the program window, each open window will 
have a tab that displays in a row above the 
currently active view.
• Each tab states the name of file the view 

type. Click on a tab to make it the active 
view.

• If there is not enough room in the pro-
gram window to display all tabs, left and 

right arrow buttons allow you to scroll 
through the tabs.

There is no limit to the number of 3D view 
windows that you can have open at a given 
time; bear in mind, though, that each window 
demands use of your computer’s resources 
and that you may see poor performance if too 
many views are open. See “3D Views” on 
page 381.

Tiling Views
As an alternative to tabbed views, 
windows can be instead be tiled. 

Tiling allows you to display multiple views 
in a single Home Designer Suite window so 
you can see the results of changes in floor 
plan view in 3D or vice versa. It can also be 
useful for copying objects from one plan to 
another. 
• Click and drag a view window’s title bar 

or tab into the part of the drawing area 
that you would like it to be. When a high-
lighted space is created, release the 
mouse button. 

• Select Window> Tile Horizontally  
to display views in a horizontal orienta-
tion, one above the other. 

• Select Window> Tile Vertically  or 
press Shift + F6 on the keyboard to dis-
play views in a vertical, side by side, ori-
entation. 

Views are tiled left to right or top to bottom 
in the order in which they were last active: 
the most recent view is on the left or at the 
top, while least recent is on the right or on 
the bottom. 

To activate a view, click on its title bar or 
anywhere in the view window. Note that any 

changes you make in the active window are 
reflected in other views as well.

To end window tiling, select Window> Tab 
Windows.

home-designer-suite-2015-reference-manual.book  Page 377  Thursday, May 29, 2014  4:26 PM



378

Home Designer Suite  2015 Reference Manual

Multiple Program Windows
To create a second program window, click 
and drag the title bar or tab of a view window 
completely out of the current program 
window: for example, onto a second monitor.  
A second Home Designer Suite program 
window will be created with its own menu 
and toolbars. 

Swapping Views
There are a number of ways to switch 
between open view windows:
• Click on a view window’s tab.

• Select Window> Next Window  or 

Window> Previous Window  to 
cycle through all open views in the order 
you prefer. 

• In Windows, press the Ctrl + Tab (Next 
Window) or Ctrl + Shift + Tab (Previous 
Window) keys to cycle through all open 
views. 

• On a Mac, press the Ctrl + } (Next Win-
dow) or Ctrl + Shift + { (Previous Win-
dow) keys to cycle through all open 
views. 

• A list of all the views currently open is 
located at the bottom of the Window 
menu. Each view is identified by its name 
and what type of view it is. A checkmark 
is beside the view that is currently active. 
Select one to go directly to that view. 

If more than eight view windows are open, 
More Windows will be the last item in the 
Window menu. Select this option to open the 
Select Window dialog:

Select the name of a view in the list and click 
OK to make it the active view.

Floor plan view and a camera view Tiled Vertically
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Closing Views
If a view is still needed, swap to a different 
view without closing the current views. If, 
however, a view is no longer neede, it can be 

closed. See “Closing Views and Files” on 
page 52. 
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Chapter 27:

3D Views

Little preparation is needed to create a 3D 
view of a model: simply click a button to 
create an overview or click and drag to create 
a cameraelevation view. 

To improve the quality of the rendering and 
create a custom look, you can adjust lighting 
and edit the materials used in the plan. You 
can create Final views that are even more 
realistic. See “3D Rendering” on page 399.

Many objects can be placed and edited in 3D 
views, and any camera view or overview can 
be saved or even used to record a 
walkthrough. See “Pictures, Images, and 
Walkthroughs” on page 449.

Chapter Contents
•      OpenGL and Hardware
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OpenGL and Hardware
Home Designer Suite features an easy to use 
rendering engine that makes use of OpenGL 
rendering technology, which has good 
hardware support on most video cards. 

To take full advantage of the rendering 
capabilities of Home Designer Suite, a 
graphics card or chipset that supports 
OpenGL 2.1 or higher hardware acceleration 
is required. 

Backdrop Dialog
Select 3D> 3D Backdrop from the 
menu to open the 3D Backdrop 

dialog. This dialog allows you to specify a 

solid color or picture file of your choice to 
use as a background for 3D views. See “3D 
Backdrops” on page 460. 

Specify Backdrop -A preview of the 
selected backdrop image is shown here.

• Backdrop Name - The name of the 
selected backdrop image displays for ref-
erence. 

• Click Select Backdrop to choose a back-
drop image from the library. See “Select 
Library Object Dialog” on page 356.

• Click Remove Backdrop to use a solid 
color instead of a backdrop image in all 
3D views, then specify the color below.

1
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• Click the Color bar to select the Back-
ground Color that displays when a back-
drop image is not being used. See “Select 
Color Dialog” on page 370. 

The Show Backdrop in options let you 
specify the conditions under which the 

selected backdrop image displays.

• Specify in which View Types a backdrop 
image is used. By default, only Camera 
Views are set to use a backdrop. See “3D 
View Tools” on page 383.

• Specify in which Rendering Techniques 
a backdrop image is used. See 
“Rendering Techniques” on page 402.

3D View Tools
Select 3D> Create Camera View to display 
the Camera View Tools. 

Camera Views
The Full Camera tool creates multi-
floor views of the 3D model. It can be 

used to create interior and exterior 
perspectives, and is good for displaying 
cathedral ceilings, roofs, lofts, stairwell 
openings, and other variation in floor and 
ceiling levels.

The Floor Camera tool creates 
perspective views of the current floor 

only. Nothing above the ceiling surface is 
generated, and neither is anything below the 
floor. 

The Glass House Camera tool 
creates full camera view of the 3D 

model using  the Glass House Rendering 
Technique. See “Glass House” on page 403.

Overviews
The Full Overview tool creates views 
of the entire model including all 

floors, ceilings, and the roof. 

The Doll House View tool creates 
views of the current floor without a 

roof or ceiling. 

TheFraming Overview tool creates 
views of the framing in the model. See 

“Framing Overview” on page 385. 

Elevation Views
The Wall Elevation tool creates 
views similar to the traditional, 

orthographic views often used in drafting. 
See “Elevation Views” on page 385. 
• When an interior view is created, an ele-

vation of a wall on a single floor and in a 
single room is shown. 

• When an exterior view is created, the 
entire model is shown. 

Creating Camera Views
Full and floor camera views are created using 
the same method.

2
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To create a camera view

1. In floor plan view, select the desired 
camera tool. The mouse pointer displays 

the camera   icon. 
2. Click and drag a line to define the view 

direction. 
•  Where your line begins is the camera’s 

position. 
•  The line that you drag defines the 

direction the camera is pointed. 
•  The end of the line is the focal point of 

the view, the point the camera rotates 
around.

•  By default, the field of view is 45°, 
which is similar to what the human eye 
sees or a 50mm camera lens. 

3. When you release the mouse button, a 
view generates in a new window.

4. Return to the floor plan view. A camera 
symbol now displays in floor plan view. 
See “Working in Multiple Views” on 
page 376.

Creating Overviews
Overviews generate as soon as you select the 
tool and are always created at the same 
angle. The focal point is always located at 
the center of the model; however, the 
position of the camera will vary depending 
on the size of the 3D model. The larger or 
more spread out the model, the further away 
the camera will be from the focal point so 
that the entire model can be seen in the view. 

Once generated, an overview window’s title 
bar indicates its view type and a camera 
symbol representing the overview displays in 
floor plan view, The overview ‘camera’ can 
be edited much like regular camera views 
can. See “Editing 3D Views” on page 391.

Full Overview
Select 3D> Create Camera View> 
Full Overview to generate an exterior 

view of the entire model.

Doll House View
Select 3D> Create Camera View> 
Doll House View to create a view of 

Camera 
(click)

Focal Point 
(release)

Line of Sight 
(drag)

1.

2.

3.
Field of View 
Indicator
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the current floor with the ceiling removed 
and all floors beneath it visible.

Doll House Views are an effective tool for 
illustrating traffic flow and the relationships 
between spaces.  

To see a different floor, select Tools> 
Reference Floors> Up One Floor  or 

Down One Floor . You can also return to 
floor plan view and make another floor 

current before generating the Doll House 
View.

Framing Overview
Select 3D> Create Camera View> 
Framing Overview to create a view 

of the entire model, displaying only framing 
and the foundation. 

Framing overviews include all floor, wall, 
and roof framing as well as foundations.  

Elevation Views
The Elevation tool produces views in 
which all lines and dimensions are 

their true lengths, regardless of their distance 
from the camera. 

To create an Elevation view

1. Select the Elevation  tool. The 
pointer changes to a  with crosshairs 
marking the position of the pointer.

•  Click in the building’s interior to create 
an elevation of a wall on a single floor 
and in a single room. 

•  Click outside of the building to create a 
view of the entire model. 

2. Click and drag a line in floor plan view. 

•  A Camera symbol displays where you 
click.

3. Drag in the direction of the Line of Sight 
to draw a camera arrow.

•  Always drag the camera arrow perpen-
dicular to the wall to be viewed. 

Camera 
(click)

Focal Point 
(release)

Line of Sight 
(drag)

1.
2. 3.

Clip Plane Indicators
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4. When you release the mouse button, the 
view generates in a new window.

If the Line of Sight does not cut through a 3D 
object, such as a window shown in elevation, 

the object retains its 3D definition and can be 
selected, moved, stretched, or otherwise 
modified in the view. The 3D model is 
updated in all views.

Displaying 3D Views
A variety of tools and settings allow you to 
control the appearance of your 3D views. 
There are also numerous ways to adjust the 
position, focal point and field of view of a 
3D view. See “Editing 3D Views” on page 
391.

The name of the current plan file and the type 
of view displays at the top of each view 
window in its title bar. 

There is no limit to the number of 3D view 
windows that you can have open at a given 
time; bear in mind, though, that each window 
demands use of your computer’s resources 
and that you may see poor performance if too 
many views are open. See “Working in 
Multiple Views” on page 376. 

Display Options
Which objects display in a 3D view is 
controlled in the Display Options 

dialog. See “Display Options Dialog” on 
page 75. 

Different view types use different layer sets 
when they are created. See “Layer Sets” on 
page 74.

In Floor Plan View
3D cameras are represented in floor plan 
viewby symbols that indicate the camera’s 
position, field of view and focal point. 

The symbols for Elevation views and Full 
Overviews display on all floors, while those 
for Full and Floor Cameras and Doll House 
Views display only on the floor where the 
view was created. See “Creating Camera 
Views” on page 383.

Active cameras can have labels indicating 
the cameranumber. Camera labels are 
located on the “Cameras, Labels” layer. They 
are numbered sequentially in each plan in the 
order they were created. 

Camera symbols are an on-screen reference: 
they do not print unless Print Image is used.

In Rendered Views
There are a number of factors that contribute 
to the appearance of rendered 3D views:

• Select 3D> Toggle Textures  in a 3D 
view to turn off the display of material 
textures. See “About Materials” on page 
361. Not available in Glass House Views. 
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• Select 3D> Lighting> Adjust Sunlight 
 to open the Default Sun Light 

Specification dialog. See “Default Sun 
Light Specification Dialog” on page 402.

• Select 3D> Lighting> Toggle Sunlight  
to turn on and off the light source that 
represents the sun. This feature can be 
used to simulate day vs. night exterior 
views. User defined exterior lights are 
turned off in day views and turned on in 
night views. See “Default Sun Light” on 
page 401.

• Select 3D> Final View  or Final 
View with Shadows  to regenerate 
the 3D view with improved quality and/
or shadows. See “Previews vs Final 
Views” on page 400 

3D Backdrops
A backdrop is an image, usually of an 
exterior view, that displays in the background 
of 3D views to help place the model into a 
realistic setting and add a sense of 
perspective. If a backdrop is not specified, 
Home Designer Suite applies a background 
color. See “3D Backdrops” on page 460.

Delete 3D Surface
The individual surface of an object 
can be temporarily removed from any 

3D view by selecting 3D> Delete Surface 
and then clicking on a surface. When the 
pointer is over a surface, that surface will 
become highlighted.

Surfaces removed in one view are removed 
in all 3D views, but are not permanently 
removed from the model. Continue clicking 
surfaces to remove them, then select another 
tool when you are finished.

Surfaces in 3D views are composed of 
multiple triangles. Hold the Alt key while 
clicking to delete one triangular face at a 
time rather than all triangles forming a  
surface. 

Select 3D> Delete Surface  or click the 
toolbar button to restore the most recently 
deleted surface. All surfaces can be restored 
by selecting Build> Floor> Rebuild Walls/
Floors/Ceilings or by exiting the 3D view 
and reopening it.

Rebuild 3D
Select 3D> Rebuild 3D to regenerate 
all 3D data associated with the current 

plan. All open views will remain open.

Repositioning Cameras
Once a 3D view is created, there are many 
ways to manipulate the camera location and 
the direction of its line of site using the 
mouse, the keyboard, and the menus. 

When the keyboard or menu commands are 
used to move or rotate a camera, the 
adjustments occur in regular increments. The 

size of these increments is specified in the 
Camera Specification dialog: 
• The Incremental Move Distance con-

trols Panning movement and forward and 
backward Dolly movement. 
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• The Incremental Rotate Angle controls 
Orbit movement, Tilt movement, and side 
to side Dolly movement.

See “Camera Specification Dialog” on page 
396. 

Each time you move the camera, the view is 
updated. If you are using either the toolbar or 
keyboard to move the camera,  you can hold 
down the Shift key, suppressing the redraw 
of the view until the Shift key is released and 
allowing you to move multiple increments 
more quickly. 

Move Camera with Mouse
An active camera’s position can be 
edited using the mouse. Select 3D> 

Move Camera With Mouse to access the 

Move Camera with Mouse modes. These 
tools are not available in Elevation views.

Move Camera with Arrow Keys
An active camera’s position can be changed 
using the arrow keys on your keyboard. 

Select 3D> Move Camera with Arrow 
Keys to access Move Camera with Arrow 

Hotkey Description

Alt + O Mouse-Orbit Camera lets you move the mouse to rotate the camera 
around its focal point. The camera’s position and direction both change.

To continuously rotate the camera around its focal point, click in the 3D 
view, drag the mouse, and release the mouse button to “throw” the 
view. Click again in the view to stop it from rotating. 

Alt + P Mouse-Pan Camera lets you move the mouse to move the camera up, 
down, left and right. The camera’s position changes, but its direction 
does not.

Alt + D Mouse-Dolly Camera lets you move the mouse up and down to move 
the camera forward and backward. Move the mouse left or right to 
rotate the camera side to side.

Alt + T Mouse-Tilt Camera lets you move the mouse to tilt the camera in any 
direction while staying in the same location. 

3D Center Camera on Point lets you focus the camera at a particular 
point in the scene. This also sets the camera center so that future use of 
Mouse-Orbit Camera rotates around that point. To use the 3D Center 
tool, activate the tool and then click on any object in the scene.
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Key modes. These tools are not available in 
Elevation views.

These modes use the Incremental Move 
Distance and Incremental Rotate Angle set 
in the active 3D view’s Camera 
Specification dialog. 
• Arrow-Orbit Camera lets you use the 

arrow keys to rotate the camera around 
the current focal point. The camera’s 
position and direction both change.

• Arrow-Pan Camera lets you move the 
camera up, down, right, and left using the 

arrow keys. The camera’s position 
changes, but its direction does not.

• Arrow-Dolly Camera lets you move the 
camera forward and back using the up 
and down arrow keys, and rotate side to 
side using the left and right arrow keys. 

• Arrow-Tilt Camera lets you use the 
arrow keys to tilt the camera up, down, or 
side to side to change the focal point. The 
camera’s direction changes, but its posi-
tion does not.

Move Camera Tools
Select 3D> Move Camera in a 3D 
view to access these tools. These tools 

change the active camera’s position, but not 
its direction and are not available in 
Elevation views. 

These tools use the Incremental Move 
Distance set in the active 3D view’s Camera 
Specification dialog. 

Hotkey Description

F Move Camera Forward moves the camera and its focal point forward. 

B Move Camera Back moves the camera and the focal point back. 

L Move Camera Left moves the camera and the focal point to the left in 
a line perpendicular to the line of sight. 

R Move Camera Right moves the camera and the focal point to the right 
in a line perpendicular to the line of sight. 

U Move Camera Up moves the camera and the focal point up. 

D Move Camera Down moves the camera and the focal point down. 
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Orbit Camera Tools
Select 3D> Orbit Camera in a 3D 
view to access these tools. Orbiting 

the camera rotates it about the focal point 
using the Incremental Rotate Angle set in 

the active view’s Camera Specification 
dialog. 

These tools are not available in Elevation 
views.

Tilt Camera Tools
Select 3D> Tilt Camera to access 
these tools. Tilting keeps the camera 

in one place and pivots the camera about its 
vertical or horizontal axis. This movement 
uses the Incremental Rotate Angle set in 
the active view’s Camera Specification 

dialog and is similar to tilting your head up 
and down or turning it side-to-side. 

These tools are not available in Elevation 
views. 

Hotkey Description

I Move Camera In moves the camera closer to the focal point along the 
line of sight. The camera cannot move past the focal point using this 
tool.

O Move Camera Out moves the camera away from the focal point along 
the line of sight. 

Orbit Camera Upward rotates the camera up about the focal point. 
The camera cannot rotate past a vertical line looking straight down on 
the focal point.

Orbit Camera Downward rotates the camera down about the focal 
point. The camera cannot rotate past a vertical line looking straight up 
at the focal point.

Orbit Camera Left rotates the camera to the left about the focal point.

Orbit Camera Right rotates the camera to the right about the focal 
point. 
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Editing 3D Views
In addition to its position and direction, there 
are other ways to modify a 3D view.

In the Specification Dialog
You can  make adjustments to a 
camera view or overview in the 

Camera Specification dialog. This dialog is 
particularly helpful for making fine 
adjustments to the camera’s position, 
appearance, and other attributes. See 
“Camera Specification Dialog” on page 396.

Using the Edit Handles
Return to floor plan view without closing the 
3D view. See “Working in Multiple Views” 
on page 376. 

Using the Select Objects  tool, select the 
camera object. When a camera symbol is 
selected it displays four edit handles. 

• Drag the Line of Sight handle to change 
the camera angle without moving the 
focal point.

• Drag the Move handle to relocate the 
camera while maintaining its relative 
angle.

Hotkey Description

Tilt Camera Upward tilts the camera up while keeping it in the same 
location. The camera cannot tilt beyond the vertical position.

Tilt Camera Downward tilts the camera down while keeping it in the 
same location. The camera cannot tilt beyond the vertical position.

Turn Camera Left turns the camera to the left while staying in the 
same location.

Turn Camera Right turns the camera to the right while staying in the 
same location.

Tile a 3D view and the floor plan view
and use the camera movement tools to

see how they affect the camera. See “Tiling
Views” on page 377.

Rotate

Focal Point

Move

Line of Sight

Move
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• Drag the Focal Point handle to reposition 
the focal point and change the line of 
sight without moving the camera.

• Drag the Rotate handle to rotate the cam-
era’s line of sight about its center.

The 3D view corresponding to the camera 
symbol reflects changes made to the symbol 
in floor plan view. 

Multiple camera symbols can be selected; 
however, their editing options are limited to 
being moved, rotated, and deleted. 

Using the Contextual Menu
In a 3D view, right-click in an empty space in 
which the backdrop or background color 
displays to access the contextual menu. See 
“Contextual Menus” on page 27. 

These options are a selection of tools and 
toggles specific to 3D views.

Up One Floor/Down One Floor
You can move a camera to a different floor. 
While the camera view is active, select 
Tools> Reference Floors> Up One 
Floor  or Down One Floor . 

The position and movement of a camera is 
affected by its location within the model. 
When the camera is outside a building, its 
height is relative to the terrain and follows 

the terrain as it is moved. When inside a 
building, the camera height is relative to the 
floor of the room it is drawn in.

If the camera is on an upper floor and you 
move the camera outside of the building, the 
camera remains at the same height relative to 
the floor it was created on.

Zooming
The Zoom Tools are available in all 
3D views. See “Zoom Tools” on page 

374. 

Selecting Window> Zoom In , Zoom 
Out  or Fill Window  does not change 
the camera’s location or field of view. 
Instead, the extents of the view are expanded 
or cropped. 

Field of View
The Field of View refers to a camera’s field 
of vision. A wider field of view makes the 
focal point appear further away, as more of 
the image is included in the same view 
window. 

In floor plan view, the angled lines of a 
camera symbol indicate its field of view. 

FOV Indicators
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A camera’s field of view can be adjusted in 
the Camera Specification dialog. See 
“Camera Specification Dialog” on page 396.

The field of view can also be adjusted while 
in a camera view using the keyboard:
• W - Increase camera Field of View.
• N - Decrease camera Field of View.

Cross Section Slider
Select 3D> Cross Section Slider 
when a camera view or overview is 

active to open the Cross Section Slider 
dialog. 

To use the Cross Section Slider

1. Click on the radio button beneath one of 
the cross section angles to select it.

•  The option at top right turns off the cut-
ting plane, so no cross section is made.

2. Move the Position slider to adjust the 
position of the cutting plane. 

3. You can position the cutting plane with 
accuracy using the text field to the right 
of the slider. 

•  This value is measured from the edge 
of the model that is cut first by the 
selected cross section angle.

4. Click OK to close the dialog. If the 
active camera is saved, its Cross Section 
Slider settings will also be retained. See 
“Saving 3D Views” on page 395. 
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Working in 3D
A variety of tools are available in 3D views 
that allow you to edit your 3D model.

Creating Objects in 3D Views
You can place windows, doors, and most 
library objects directly into 3D views. To do 
this, select the appropriate tool and click in 
the 3D view. You can then edit the object’s 
size and placement. 

When created in 3D, most objects must be 
placed against a wall, on a floor platform, or 
within the Terrain Perimeter.  

You can also click and drag to draw some 
objects such as terrain features and road, in 
camera views and overviews views. 

Selecting and Editing 
Objects in 3D Views

Most objects can be selected and edited in 

3D views. Select Edit> Select Objects  
and click on the surface of an object to select 
it. Once selected, objects can be edited using 
their edit handles, buttons on the edit toolbar, 
and the object’s specification dialog. See 
“Editing Objects” on page 85.

When you select an object, edit handles and a 
handle surface display. The handle surface is 
a rectangle around the perimeter of the object 
that indicates the overall height and width of 
the selected surface. The edit handles that 
display depend on the type of object selected. 
Walls, for example, display two resize edit 
handles when selected while a slab displays 
ten handles, allowing you to move, resize 
and reshape it.

All moving or resizing is in the plane of the 
handle surface. You cannot  move an object 
directly towards or away from the camera, 
for example, because that surface plane 
cannot be seen in the view. 

By default, object movement is restricted to 
one inch or 10 mm increments. See “Grid 
Snaps” on page 79.

Unrestricted positioning can also be enabled 
by holding down the Ctrl key while moving 
or resizing an object. See “Unrestricted 
Movement” on page 106. 

Temporary dimension lines display when 
many objects are selected to help you resize 
the object and determine its height.

Because Elevation views are orthogonal and 
display objects at their actual dimensions, 
they are sometimes more suitable for editing 
objects than camera views or overviews. See 
“Elevation Views” on page 385.

When several 3D views are open, changes 
made in the plan automatically rebuild the 
model in all views.  Because of this, it is 
typically faster to make changes to your plan 
with as few windows open as possible.

Editing Materials in 3D Views
Select 3D> Materials> Adjust 
Material Definition, then click on a 

surface in the 3D view to open the Define 

Note: If the wall height of the Exterior Room
is adjusted in a 3D view, the default Floor or
Ceiling Height of the entire floor is changed.
See “Floor and Room Defaults” on page 144.
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Material dialog for that material. See “Adjust 
Material Definition” on page 366.

Select 3D> Material Painter to apply 
materials to surfaces in the view using 

the Material Painter Tools. See “The Material 
Painter” on page 362.

Select 3D> Material Painter> 
Material Eyedropper to apply the 

material on a surface in the view to other 

surfaces in the view. See “Material 
Eyedropper” on page 364. 

Rebuild 3D
As changes are made to your plan, a 
3D view automatically updates to 

reflect any changes visible in the view. If you 
find that a view is not updating as expected, 
select 3D> Rebuild 3D to rebuild the entire 
3D model.

Saving and Printing 3D Views
3D camera views, overviews and Elevation 
views can be saved with the plan in which 
they are created, exported and saved as 
image files, as well as printed. 

Saving 3D Views
Select 3D> Save Active Camera to 
save the current camera in the plan. 

You can also save a camera view by checking 
the Saved box in the Camera Specification 
dialog. See “Camera Specification Dialog” 
on page 396. 

Saved cameras can be closed and re-opened 
for later use, and retain their Cross Section 
Slider and Glass House settings. See “Cross 
Section Slider” on page 393 and “Rendering 
Techniques” on page 402 

Activating Saved Views
There are three ways to open a saved 3D 
view: 
• Select the camera symbol in floor plan 

view and click the Open View  edit 
button.

• Double-click the camera symbol using 

the Select Objects  tool.
• Right-click on it and select Open View 

from the contextual menu.

Unsaved cameras that are open in another 
view window can also be activated using the 

Open View  edit button.

If you open a saved camera view and then 
modify its location or direction using any of 
the tools available in that view, the program 
will confirm whether you want to re-save the 
camera using these new settings when you 
close it. See “Repositioning Cameras” on 
page 387.

Exporting 3D Views
All 3D views can be exported and 
saved as .bmp, .jpg, .png, or .tif files. 

Select File> Export> Picture to save the 
current screen image as an image file. See 
“To export a picture” on page 454.

Once saved, a picture can be opened and 
converted into many other formats using a 
graphics program.
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When a picture is exported, it is assigned the 
same size as it displays on screen. You can 
change the size of the view window to create 
a smaller or bigger picture.

Printing 3D Views
Since 3D views are created using 
pixels instead of lines, File> Print> 

Print Image must be used when printing. 

Print Image is a special Home Designer 
Suite function that prints the screen in picture 
format. The entire view prints, including 
images such as plants and textures. 

The quality of your print image is affected by 
your current window size and screen 
resolution. To maximize the quality of your 
printed image, generate it in full screen size 
and use the maximum screen resolution.

Camera Specification Dialog
The Camera Specification dialog can 
be accessed in floor plan view by 

selecting a camera symbol and clicking the 
Open Object edit button. See “In Floor Plan 
View” on page 386.

This dialog can also be accessed while a 
camera view or overview is active by 

selecting 3D> Edit Active Camera . 

The selected view’s specific type is indicated 
in the dialog’s title bar: the specification 

dialog for a Full Camera , for example, 
is named Full Camera Specification.  

To change a setting, first uncheck Default, 
then type a new value in the text field. 

Specify the Name that displays in the 
camera label in floor plan view.

The Positioning settings determine the 
position and orientation of the camera. 

See “Repositioning Cameras” on page 387. 
• The Incremental Move Distance con-

trols how far the camera moves each time 
you Pan in any direction or Dolly for-
wards or backward. For interior views a 
small number is good, but for exterior 
you may want a larger increment.

Note: Elevation views do not have a specifi-
cation dialog. See “Elevation Views” on page
383.

1

2
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• The Incremental Rotate Angle defines 
how many degrees the camera rotates 
each time you Tilt, Orbit, or Dolly side to 
side. A setting of 90° would make one 
full rotation in four moves.

• The Height Above Floor defines the 
height that the camera is above the floor 
level for the current floor.

• The Field of View defines the camera’s 
field of vision in angular degrees. See 
“Field of View” on page 392.

• The Tilt Angle determines the vertical 
angle that the camera is tilted. The cam-
era maintains its focal point and position 
in floor plan view, but if the camera is 
tilted, the focal point is above or below 
the current camera height. 

You can increase a camera’s Field of
View when the view is active by press-

ing the W key, or decrease the Field of View
by pressing the N key. 
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Chapter 28:

3D Rendering

There are a variety of tools available to 
create 3D views of a model: simply click a 
button to create an overview, or click and 
drag to create a camera or elevation view. 
See “3D Views” on page 381.

To improve the quality of the rendering and 
create a custom look, you can adjust lighting, 
edit the materials used in the plan, choose 
from several rendering techniques and fine-
tune 3D view quality settings. From most 3D 

views, you can create Final views of even 
higher quality.

Chapter Contents
•      Rendering Tips
•      Lighting
•      Displaying Lights
•      Default Sun Light Specification Dialog
•      Speeding up 3D View Generation

Rendering Tips
There are a variety of factors which affect the 
appearance and quality of rendered 3D 
views. You can use these tools and settings to 
achieve renderings that meet your needs. 

Lighting
Lighting is extremely important in most 3D 
renderings. Lighting controls the visibility of 
objects in a view, affects the appearance of 
surfaces, and influences the appearances of 
colors and textures on those surfaces. Even 

small changes to light intensity, direction and 
color can have a large impact on image 
quality. See “Lighting” on page 400.

Reflections
Reflections are another aspect of lighting that 
can increase a 3D view’s realism. When a 
flat surface is assigned a Mirror material, it 
can display the reflections of other objects in 
the scene.
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Note that a Mirror surface cannot display the 
reflection of another mirror. When one 
mirror can be seen in another, its material is 
shown rather than a reflection.

Reflections can slow down 3D view 
generation and responsiveness considerably 
and are turned off by default in rendered 
Previews. They can be turned on and off for 
both Previews and Final Views in the 
Preferences dialog. See “Render Panel” on 
page 63.

Material Textures
Textures are graphic files that represent 
contoured surfaces of objects such as carpet, 
bricks, tile, and wood in 3D views. Textures 
are assigned to materials which in turn are 
assigned to objects. See “Textures” on page 
362. 

The display of materials in 3D views is 
controlled by settings in the Define Material 
dialog. See “Define Material Dialog” on 
page 367.

Brightness, shininess and transparency 
control how light sources affect the display 
of surfaces in 3D views. See “Lighting” on 
page 400.

If no texture is selected for a material or if 
the display of textures is turned off, affected 
surfaces are a solid color instead.

Images
Images are very important for the appearance 
of 3D views. Images are picture files that 
represent individual objects such as trees, 
flowers, cars,  and people. See “Placing 
Images” on page 450.

Backdrops
A backdrop is an image, usually of an 
exterior view, that displays in the background 
of 3D views to help place the model into a 
realistic setting and add a sense of 
perspective. If a backdrop is not specified, 
Home Designer Suite applies a background 
color. See “3D Backdrops” on page 460.

Previews vs Final Views
When a rendered 3D view is first created, it 
uses quality settings that allow the view to 
generate quickly but with reasonable quality.

Final Views produce much higher quality 
images that are more suitable for printing or 
saving as graphics files. Final Views often 
take significantly longer to generate than 
Previews, so the 3D view reverts back to the 
Preview settings as soon as anything is 
changed within the view.

When you have finished making adjustments 

in the 3D view, select 3D> Final View  or 

Final View with Shadows . 

Lighting
In 3D views, lighting is calculated on a 
room-by-room basis; only the light sources 
in the room containing the camera are used. 

When the camera is outside a building, the 
program normally uses sunlight for lighting 
calculations and turns off all other light 
sources. You can turn the sunlight off and use 
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all the other exterior lights to simulate night 
time views.

The maximum number of light sources that 
can be turned on in a view at the same time is 
determined by your video card. If your video 
card’s maximum number of lights is eight, 
the program only uses the eight light sources 
closest to the camera’s position. 

There are three ways to create light sources 
for 3Dviews:
• Default Lights
• Light Fixtures
• Default Sun Light

Default Lights
If you create an interior 3D view of a room 
and no lights have been placed there, the 
program creates a Default Light source 
within that room. The Default interior light 
acts like a central point light source. 

The Default Light cannot be adjusted in any 
way. If you want to control the light in an 
interior 3D view, you must add a light to the 

room that you are rendering by placing a 
lighting fixture. 

Light Fixtures
An electric symbol that represents a Light 
Fixture has a light source associated with it. 
When a light is placed in a room, it will be 
used as a light source in 3D views instead of 
the Default Light. In large rooms, more than 
one light fixture may be needed for sufficient 
light.

Default Sun Light
If you create an exterior 3D view, the 
program creates a Default Sun light source. 

The Default Sun can be modified in a 3D 
view by selecting 3D> Lighting> Adjust 
Sunlight . See “Default Sun Light 
Specification Dialog” on page 402.

Select 3D> Lighting> Toggle Sunlight  
turn the Default Sun on or off to simulate 
either daytime or nighttime exterior lighting.

Displaying Lights
The display of light fixtures in floor 
plan and 3D views is controlled in the 

Display Options dialog. See “Display 
Options Dialog” on page 75.

In addition, they can serve as sources of light 
in rendered 3D views. They can be turned on 
and off, as well.

Light fixtures are placed on the “Electrical” 
layer. See “Displaying Objects” on page 74. 

In floor plan view, light fixtures can display 
labels when the “Electrical, Labels”layer is 
turned on. 

To turn a light on or off

There are several ways to turn a light 
fixtureon or off: 
• Select one or more fixtures and click the 

Turn Light(s) Off in 3D  or Turn 
Light(s) On in 3D  edit button. 
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Default Sun Light Specification Dialog
The Default Sun Light Specification dialog 
allows you to control the intensity, direction 
and color of the Default Sun light source. See 
“Default Sun Light” on page 401.

While in a 3D view, select 3D> Lighting> 
Adjust Sunlight . See “Default Sun 
Light” on page 401.
 

• Use the Intensity slider bar or text field 
to control how bright the default sun light 
appears in 3D views. 
An intensity of 0% is the same as turning 
the sun light off. An intensity of 100% is 
the maximum brightness allowed. 

• Click the Color bar to define the color of 
the light being modeled. Colored sun 
light may be used to achieve special 
lighting effects, but may alter the appear-
ance of your material colors and textures. 

• Specify the Tilt Angle, which is the angle 
of the sun light with respect to the hori-
zon. A value of 90° means that the light 
points straight up, while a value of -90° 
means that the light points straight down. 
0° is parallel to the horizon.

• Specify the Direction Angle, which is 
the direction that the sun light points 
toward. Zero degrees is measured hori-
zontally on screen, pointing to the right. 
Positive values rotate in a counter-clock-
wise direction from there, while negative 
values rotate clockwise. 

The Default Sun light color is pure white, 
which has the least effect on the material 
colors and textures.

Rendering Techniques
Any camera view,elevation view, or 
overview can be generated using 

either of two Rendering Techniques. When a 
3D view is active, select 3D> Rendering 
Techniques to access these tools. 

Standard Rendering
Standard rendering is a photo-
realistic technique that represents 

materials using textures, models lighting, and 
can also display shadows. Lighting is limited 
to the room containing the camera and the 
capabilities of your video card. 

home-designer-suite-2015-reference-manual.book  Page 402  Thursday, May 29, 2014  4:26 PM



Speeding up 3D View Generation

 403

In floor plan view, the camera 
symbol for a view using the 
Standard technique displays an S 
in its center. See “Displaying 3D 

Views” on page 386.

Glass House
Glass House rendering uses different shades 
of a single color to display the model with 
surface edge lines and semi-transparent 
surfaces. Lighting and shadows are not 
modeled, and materials are not represented, 
so textures are not used. 

In floor plan view, the camera 
symbol for a view using the Glass 
House technique displays a G in 
its center. 

Glass House Options
You can modify the appearance of 
Glass House Views by selecting 3D> 

Rendering Techniques> Glass House 
Options. 

• Click the Color bar to select a color for 
the semi-transparent surfaces and lines in 
a Glass House view. See “Select Color 
Dialog” on page 370. 

• Specify the Transparency of the surfaces 
in Glass House view. For example, to cre-
ate a wireframe line drawing of your 
structure, turn transparency to full and 
minimize line thickness.

• Specify the Line Thickness of surface 
lines in Glass House view. 

• Click Reset to Defaults to restore the 
default settings used when the Glass 
House view was first created. 

Speeding up 3D View Generation
Depending on the speed of your processor, 
how many cores your processor has, and 

your computer’s video memory, a 3D view 
may generate in a few seconds or less. 
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When you have a large, complex model with 
a lot of detail, it may take a few minutes to 
generate a 3D view of everything in the 
model. During this process, progress 
information may display in the Status Bar 
and in a message window. 

There are several ways to speed up the 
generation time of views.

Turn Off Layers
The display of objects in 3D views 
can be turned on or off by layer in the 

Display Options dialog. Turning off the 
display of unneeded objects in 3D views can 
speed up 3D view generation time. See 
“Display Options Dialog” on page 75. 

Halt Generation with Esc Key
Using the Esc key, you can interrupt the 
modeling process at any point and display 
the incomplete model “as is.” This is 
particularly helpful when you just need to 

reorient a model on the screen for a specific 
angle or view.

The Esc option allows you to place the view 
quickly, then press the F5 function key to 
refresh the display with all 3D faces intact. 

Faster Rendering
To increase rendering speed, consider turning 
off some or all of the following options in the 
Preferences dialog. Bear in mind that render 
quality may be affected. See “Render Panel” 
on page 63.

Use Optimizations - Many video cards with 
OpenGL are capable of optimizing 3D views 
for subsequent redraws. The effects of this 
option varies from video card to video card. 

In general, you should leave this option 
turned on unless you are experiencing 
crashes when rendering.
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Chapter 29:

Dimensions

Home Designer Suite provides a variety of 
dimensioning tools for measuring walls, 
doors, windows, and many other objects. 

Dimensions can be used to accurately 
position objects relative to other objects. In 
addition, dimension lines and extensions can 
be selected and customized. 

Chapter Contents
•      Dimension Unit Defaults
•      Dimension Defaults Dialog
•      The Dimension Tools
•      Displaying Dimension Lines
•      Editing Dimension Lines
•      Editing Extension Lines
•      Moving Objects Using Dimensions
•      Dimension Line Specification Dialog

Dimension Unit Defaults
All plan files save measurements in either 
Imperial or metric units. The type of unit 
used is determined when the file is first 

created and cannot be changed later. See 
“Creating a New Plan” on page 40.

Dimension Defaults Dialog
Select Edit> Default Settings, select 
“Dimension”, and click the Edit 

button to open the Dimension Defaults 
dialog. 

The settings in this dialog are dynamic 
defaults, which means that any changes 

made here may affect existing dimension 
lines in the drawing that are using default 
values. See “Dynamic Defaults” on page 57. 
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Setup Panel

Uncheck Auto Refresh Exterior 
Dimensions to prevent Auto Exterior 

Dimensions from being regenerated as 
changes are made to the plan. When checked, 
Auto Exterior Dimensions will be created 
when walls enclose a room area and will 
refresh whenever walls, doors, or windows 
are added or moved. See “Auto Exterior 
Dimensions” on page 409.

Specify how Manual and Auto Exterior 
Dimension lines locate both interior 

and exterior walls. 
• Select Surfaces to have dimensions 

locate the outer surfaces of walls. 

• Select Main Wall Layer to have dimen-
sions locate the structural layer of exte-
rior walls.

Specify how Manual and Auto Exterior 
Dimension lines locate interior walls.

• Select Centers to have exterior dimen-
sions locate the centers of interior walls. 

1

2

Dimensions locating wall Surfaces

Dimensions locating walls’ Main Wall Layers

3

Dimensions locating an intersecting wall’s center
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• Select Both Wall Sides to have dimen-
sions locate both sides of interior walls. 
Either the wall Surfaces or both sides of 
the Main Wall Layers will be located, 
depending on your selection above. 

You can always change the object or surface 
that a dimension locates after it has been cre-
ated. See “Editing Extension Lines” on page 
413.

Format Panel
The settings on the Format panel allow you 
to specify the units, degree of accuracy, and 
position of dimension numbers. 

The settings on this panel also control the 
format of numbers indicating object length in 
the Status Bar. See “The Status Bar” on page 
30. 

Specify the numbering Format for 
dimension numbers. 

• Select the Units of measurement to be 
used by dimensions from the drop-down 
list.

Dimensions locating an interior wall’s 
                  Main Wall Layer

1
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• Check Unit Indicators to display the unit 
of measurement along with the dimen-
sion number.

• Check Leading Zeros to include the zero 
before a decimal less than 1 or to display  
0’ or 0” when the ft-in or ’-” unit formats 
is used. 

• Check Trailing Zeros to display trailing 
zeros at the end of decimal values. When 
the ft-in or ’-” unit format is used and 
fractional inches are specified, 0” will be 
included. 

Specify the degree of Accuracy used 
by dimension numbers. 

• Select the Decimal Places radio button 
for dimension numbers in decimal for-
mat.  In the text field, specify the number 
of decimal places to use, from 0 to 20. If 
0 is used, no decimal places are used.

• Select the Smallest Fraction radio but-
ton for dimension numbers using whole 
numbers and fractions. In the text field, 
specify the largest denominator to use, 
from 1 to 128. If 1 is entered, whole num-
bers are used. 

Specify the Dimension Text Position, 
which is the location of dimension 

numbers relative to the dimension line. 

• Center primary dimension numbers on 
the dimension line. If two formats are 
used, the primary format is placed above 
the line and the secondary format, 
beneath it. 

• Position dimension numbers Above 
Line. 

• Position dimension numbers Below Line. 

Arrow Panel
For information about the Arrow panel, see 
“Arrow Panel” on page 435.

Text Style Panel
The settings on the Text Style panel control 
the size, font and other attributes of 
automatic, manually drawn, and temporary 
dimension line labels. See “Dimension 
Labels” on page 411. 

For information about the settings on this 
panel, see “Text Style Panel” on page 428.

Temporary dimension labels always use the 
color assigned to their layer - not the color 
specified in the Dimension Defaults dialog. 

The Dimension Tools
Select CAD> Dimensions to access 
the Dimension Tools. Manually drawn 

dimensions are created by clicking and 
dragging like other line-based objects and 
can be drawn in floor plan view. 

The zoom factor of the current view affects 
whether objects drawn close together are 

dimensioned or not. If you try to dimension 
an array of objects but the dimension line 
locates only the first and last objects along its 

path, Zoom  in on the objects and try 
again. Similarly, if you want to dimension 
between two objects but the dimension 
locates unwanted objects between them, 

2

3
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Zoom  out. See “Zoom Tools” on page 
374.

Once created, both manually drawn and 
automatically generated dimension lines can 
be selected and edited.  See “Editing 
Dimension Lines” on page 411. 

Manual Dimensions
To display the distance between two 
objects, select CAD> Dimensions> 

Manual Dimension and drag a dimension 
line near or through the objects. 

Manual Dimensions locate walls as specified 
in the Dimension Defaults dialog. See 
“Dimension Defaults Dialog” on page 405.

End-to-End Dimensions
Use the End-to-End Dimension tool 
to dimension between any two defined 

objects in floor plan view. 

Select CAD> Dimensions> End-to-End 
Dimension , then click and drag the 
dimension from the first object to the second 
object. The dimension line snaps to each 
object, ignoring any other objects located 
between either end.

Interior Dimensions
Draw Interior Dimension lines 
parallel to walls in floor plan view to 

create interior dimensions. 

The Interior Dimension  tool locates 
interior wall surfaces only. It does not 
dimension between layer surfaces in the 
same wall, and it does not locate walls unless 
it actually intersects them. 

Auto Exterior Dimensions
The Auto Exterior Dimension tool 
generates dimensions around a plan’s 

exterior in floor plan view. These dimension 
lines locate walls as specified in the 
Dimension Defaults dialog. See “Dimension 
Defaults Dialog” on page 405.

If you edit an Auto Exterior Dimension  
line, it will be converted to a manual 
dimension, so if Auto Exterior Dimensions 
are later regenerated, your changes will not 
be lost. 

There are a maximum of three rows of 
automatically generated dimensions per 
exterior wall direction. The innermost 
dimension line locates exterior walls, interior 
walls, and all openings in exterior walls. The 
second dimension line locates exterior and 
interior walls. The outermost dimension line 
is the overall exterior dimension.

Auto Interior Dimensions
The Auto Interior Dimensions tool 
creates a set of interior dimensions in 

each room that measures each wall on the 
current floor. It can be used in floor plan 
view in either of two ways:
• Select one or more rooms and click the 

Auto Interior Dimensions  edit tool 
to generate interior dimensions that mea-
sure each wall defining the selected 
room(s). 

Auto Exterior Dimensions do not gener-
ate properly if there is a gap in the exte-

rior walls or if they do not connect properly. 
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• Select CAD> Dimensions> Auto Inte-
rior Dimensions  to generate a set of 
interior dimensions in every room on the 
current floor. 

Auto Interior Dimensions  lines are 
generated inside of the rooms they measure 
and do not recognize the No Locate setting 
for walls. If a wall is specified as No Locate, 
Auto Interior Dimensions will locate it 
anyway. See “No Locate” on page 127. 

Temporary Dimensions
Temporary Dimensions display when an 
object is selected and show the distance 
between the object’s selected edge and other 
objects. 

As with other dimension lines, Temporary 
Dimensions only locate objects that are 
parallel or nearly parallel to one another. 
They will also locate the endpoints of CAD 
lines and the corners of objects located past 

the end of the selected edge, within 4 feet 
(1200 mm) of the point where you click to 
select the object. 

A temporary dimension will not display 
when an object is selected if a manually 
drawn dimension line is already present that 
shows the same information. 

Tape Measure
Use the Tape Measure tool to draw a 
temporary dimension line between 

any two points in the drawing area. The tool 
will place temporary markers at the start and 
end points of the dimension line. These 
points and the line both disappear when you 
release the mouse button. If an object is 
located by the temporary line, you can snap 
to it.

The Tape Measure  tool can be used in 
Elevation views as well as in floor plan view. 
See “Elevation Views” on page 385. 

Displaying Dimension Lines
The display of dimension lines is controlled 
in the Display Options dialog. See 
“Displaying Objects” on page 74. 

Dimension lines created by any of the 
dimension tools share the same components.
• Dimension Lines run parallel with the 

distance being measured.
• Extension Lines are perpendicular to 

dimension lines, indicating what they 

locate. If a dimension line locates more 
than two objects, extension lines divide 
the dimension line into segments. 

• Arrowheads display at the intersections 
of dimension and extension lines.

• Dimension Labels display at the mid-
point of dimension line segments and 
indicate the distance that each segment 
measures.
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If a manual dimension line is on a layer that 
is turned off and you select an object located 
by that dimension line, it will display for 
reference in grey.

Dimension Labels
Manually drawn, automatic and temporary 
dimension labels use the Text Style specified 
in the Dimension Defaults dialog. Unlike 

many objects that use Text Styles, by default 
dimensions use a Text Style specified in the 
defaults dialog rather than the Text Style 
assigned to their layer. See “Text Style 
Panel” on page 408. 

Dimension Arrowheads
You can specify the style, color and size of  
dimension arrows in the Dimension 
Defaults and Dimension Line Specification 
dialogs. See “Arrow Panel” on page 435. 

The arrow at the end of a dimension line will 
not display if it is close enough to to another 
dimension arrow that the two will overlap. A 
typical example of this is where two sections 
of an Interior Dimension locate two sides of 
an interior wall. 

Editing Dimension Lines
With the exception of Temporary 
Dimensions, dimension lines can be selected 
and edited using the mouse and the edit 
toolbar buttons.

If an Auto Exterior Dimension line is edited, 
it will no longer be considered an automatic 
dimension line and will not be deleted and 
replaced the next time the Auto Exterior 
Dimensions  tool is used. 

Using the Mouse
When a dimension line is selected, its edit 
handles can be seen. There are four types of 
dimension line edit handles. More than one 
of some types display, depending on how 
many extension lines are present.

• The Extension Line handles mark the 
location being dimensioned and are used 
to move or delete extension lines. See 
“Moving Extension Lines” on page 413.

Dimension 
Labels

Extension Lines

Arrowheads

Rotate

Extension Line

Extension Line

Move

Add Extension 
Line
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• The Add Extension Line handle displays 
to the side of the Move handle and is used 
to add extension lines to the dimension 
line. Dimension lines do not extend 
unless an object can be located. See 
“Adding Extension Lines” on page 413.

• The small, square Move Dimension 
Label handle is located at the center of 
the selected label. Use this handle to 
move the dimension number for each 
dimension line section. The pointer 
changes to a  four-headed arrow  when 
moved over this handle.

• The Move handle is located where you 
clicked to select the dimension line and is 
used to move the entire dimension line, 
including any subsections, perpendicular 
to itself. Extension lines are resized as 
appropriate. The pointer changes to a 
two-headed arrow  when moved over 
this handle.

• The Rotate handle is located one plan 
foot past the end of the dimension line 
and is used to rotate the dimension line. 

Using the Edit Tools
Dimension lines can be repositioned, copied, 
and deleted using the edit toolbar buttons just 
like other objects in the program can. See 
“The Edit Toolbar” on page 26. 

Dimension Number Size
The initial size of dimension numbers is 
specified in the Dimension Defaults dialog. 
See “Dimension Defaults Dialog” on page 
405. 

You can specify number height for individual 
dimension lines in the Dimension Line 

Specification dialog. See “Dimension 
Panel” on page 416.

As with text and other objects, dimension 
number size is subject to scaling when or 
printed.  

Copying and Pasting 
Dimension Lines

Dimension lines can be copied and pasted 
into any view type that supports dimensions. 
If a dimension line is copied independent of 
the objects it originally locates, the pasted 
dimension line will locate point markers.

Deleting Dimension Lines
There are several ways to delete dimension 
lines. 

You can select any manual or automatic 
dimension line or group of dimension lines, 
then press the Delete key or click the 

Delete  edit button. See “Deleting 
Objects” on page 111.

The Delete Objects dialog allows you to 
delete all manually drawn and/or automatic 
dimension lines at once. See “Delete Objects 
Dialog” on page 111.

Individual dimension line segments located 
between extension lines can also be deleted. 
If a segment is located between two other 
segments along the same dimension line, that 
dimension will be broken in two.

To delete a portion of a dimension line

1. Select any Dimension Tool aside from 
Auto Exterior Dimensions.
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2. Manually draw a dimension line over 
the segment that you wish to remove, 

dragging from extension line to exten-
sion line.

Editing Extension Lines
Extension lines can be added, edited, and 
deleted using the mouse. 

Adding Extension Lines

To add an extension line

1. Select the dimension line.
2. Click the diamond-shaped Add Exten-

sion Line edit handle which displays 
near the Move edit handle. The pointer 
changes to a two-headed arrow .

3. Drag the handle to the object that you 
want to locate with a new extension han-
dle. This example adds an extension line 
to the window edge. 

4. Release the mouse button to add an 
extension line.

Moving Extension Lines
Extension lines can be moved to locate the 
centers, sides, or surfaces of most objects. In 
this example an extension line is moved from 
the windows edge to the center.

To move an extension line

1. Select the dimension line it is connected 
to, not the extension line itself.

2. Click the Extension Line edit handle. 
The pointer changes to a two-headed 
arrow .

3. Drag the handle to a new location. The 
extension line snaps to possible marks as 
the handle is moved.
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4. Release the mouse button at the new 
location.

Deleting Extension Lines
When an extension line is deleted, the 
remaining dimensions update. If a dimension 

line hasonly two extension lines, they cannot 
be deleted.

To remove an extension line

1. Select the dimension line it is connected 
to, not the extension line itself.

2. Click the Extension Line edit handle. 

3. Drag it perpendicular to the direction of 
the arrows, away from any dimension-
able object, and release the button when 
the extension line disappears.

Moving Objects Using Dimensions
Most objects can be moved by changing an 
automatic, manual or temporary dimension 
value that locates it. This technique can be 
applied in nearly any situation where 
dimensions are present. See “Moving 
Objects” on page 106.

In addition, some objects can be resized 
using dimensions. See “Resizing Objects” on 
page 108.

Your pointer indicates which dimensions can 
be used to relocate the selected object by 
changing to a pointing hand icon. 

Another way to tell is to select an object and 
drag it in the desired direction. As you drag, 
note which dimensions update. These 

dimensions are the dimensions that can be 
used to move that object. 

To move an object using dimensions

1. Select the object and click on a dimen-
sion line that locates it. An inline text 
field opens at the location where you 
clicked. 

•  The actual distance displays in the text 
field. 

•  If the dimension is locating two differ-
ent objects, the Move Edge and Move 
Entire Object buttons display to the 
right of the text field. 

Not all library symbols can be located
by a dimension line as it is drawn. Once

a dimension is drawn, however, you can
move or add an extension line to locate the
library object.
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•  If the dimension describes a selected 
wall’s length, the Move Start, Move 
End and Move Both Ends buttons dis-
play to the right instead. 

2. Click the Move button of your choice. 
3. Enter a new value in text field. 

•  To use a different unit, include its indi-
cator after the value.To move the 
selected object past a second object, to 
its opposite side, enter a negative 
value. 

4. The selected object moves or resizes 
when you press the Enter key or click 
outside of the text field. 

To resize an object using dimensions

1. Select the object along the edge that you 
would like to move. See “Selected 
Edge” on page 86.

2. Click on a dimension line that indicates 
its distance from the object’s opposite 
side. 

3. In the inline text field, enter a value. 
4. Click Move edge to move the selected 

edge only. 
5. The selected edge moves, resizing the 

object, when you press the Enter key. 

Resizing a House Using 
Exterior Dimensions

When resizing a house using dimensions, it 
is important to work your way around the 
house in one direction. Relocate one wall at a 
time in succession so that you do not redefine 
the same dimension more than once. 

For more information, see “Measuring 
Walls” on page 126. 

Dimension Line Specification Dialog
To open the Dimension Line 
Specification dialog, double-click a 

dimension line using the Select Objects  

or Manual Dimension  tool, or select a 

dimension line and click the Open Object 
edit button.

The settings in this dialog are dynamic 
defaults. See “Dimension Defaults Dialog” 
on page 405. 

Move Entire Object

Move Edge (selected)

Move Both Ends

Move Start       Move End

You can cancel a move or resize opera-
tion using dimensions at any time by
pressing the Esc key.
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Dimension Panel

Specify the Number Height for the selected 
dimension. Type “d” in the box to reset the 
number size to the default.

Arrow Panel
For information about the settings on this 
panel, see “Arrow Panel” on page 435.
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Chapter 30:

Text

Text is an ideal way to draw attention to 
special details of your drawings in floor plan 
view.

Text lines with arrow can be attached to text 
objects, allowing you to direct attention to 
specific plan details.

Chapter Contents
•      Text Defaults
•      Fonts and Alphabets
•      The Text Tools
•      Creating Text
•      Displaying Text
•      Rich Text Specification Dialog
•      Text Specification Dialog
•      Editing Text
•      Copying and Pasting Text
•      Text Arrows
•      Text Styles
•      Object Labels

Text Defaults
Text Defaults can be accessed by 
selecting Edit> Default Settings in 

any view in which text can be created. See 
“Default Settings vs Preferences” on page 
56. 

The default settings for Rich Text determine 
what these objects look like when they are 
first created. Text Style Defaults determine 

the appearance of text associated with things 
like dimensions and object labels. 

Text Style Defaults
Select “Text Style” from the list in the 
Default Settings dialog and click the Edit 
button to open the Saved Text Style 
Defaults dialog.
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The Text Style Defaults dialog allows you to 
specify the attributes of the various Text 
Styles in use in the current file. See “Text 
Styles” on page 427.

Rich Text Defaults
The Rich Text Defaults dialog is similar to 
the Rich Text Specification dialog. See 
“Rich Text Specification Dialog” on page 
420.

Text Lines with Arrows  use the same 
default layer as Rich Text, so by default they 
have the same color, line weight and line 
style. See “Layers” on page 73.

Arrow Defaults
The settings in the Arrow Defaults dialog 
determine the initial settings for arrows 

drawn using the Text Line with Arrow  

and Line With Arrow  tools. These 
settings also determine the initial appearance 
of arrows when they are added to CAD lines, 
arcs, and polylines.

The Arrow Defaults dialog looks almost the 
same as the Arrow panel of the Line/Polyline 
Specification dialog. See“Arrow Panel” on 
page 435

Fonts and Alphabets
Home Designer Suite allows you to use any 
font found in your Windows Fonts directory. 

International Alphabets

The Rich Text  tool supports unicode 
alphabets and characters. In order to use a 
unicode alphabet or characters, the 
appropriate language support must be 
installed on your computer. 

Special characters can be added to any Rich 
Text  object by: 
• Copying and pasting the character from 

another application;

• Copying and pasting the character from 
the Windows Character Map;

• Typing the keystroke associated with the 
character.

See “Copying and Pasting Text” on page 
425.

Missing Fonts
If you open a plan file that uses a font that is 
not installed on the current computer, the 
program will give you an opportunity to 
replace it in the Replace Fonts dialog. 

Avoid typing any text in the Rich Text
Defaults dialog unless you want it to be

present in all text objects you create.
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The table lists all missing fonts and how they 
will be replaced. 

• Click on a font name in the list to select 
it. Use the Shift or Ctrl key to select mul-
tiple fonts. See “Shift and Ctrl Select” on 
page 87. 

• Select a replacement font from the 
Replace With drop-down list, or leave 
“No Change” as the selection to maintain 
the file’s association with the missing 
fonts. 

• A preview of the selected font displays 
below the Replace Width list.

If you do not plan to return the file to the 
computer where it was created, you may 
want to replace missing fonts with the fonts 
you normally use. On the other hand, if you 
do intend to return the file, you may prefer to 
not replace any missing fonts.

The Text Tools
Select CAD> Text to access the Text 
Tools. These tools are available in 

floor plan view only.

The Rich Text tool is used to create 
text objects.

The Text Line with Arrow tool is 
used to connect text and another 

object with an arrow. See “Text Arrows” on 
page 426.

The Text with Arrow tool places a 
Rich Text object with an arrow 

attached.

Creating Text
Text can be created in floor plan view only. 

Once created, text can be selected and edited 
in a variety of ways. See “Editing Text” on 
page 423. 

To create Rich Text

1. Select CAD> Text> Rich Text . 

2. Type or paste the desired text into the 
Text Field.

3. Use the options  to change the font, style 
and size of any portion of the text. 

Note: If you do not type anything in the Text
Field, a text object will not be created when
you click outside of it.
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You can also create lines with arrows 
connecting the text that you create to items in 
the drawing. See “Text Arrows” on page 426. 

Displaying Text
As with other types of objects, the display of 
Text objects is controlled in the Display 
Options dialog.   All Text objects, including 
Text Lines with Arrows, are located on the 
“Text” layer. See “Display Options Dialog” 
on page 75. 

Text objects can only be displayed in floor 
plan view. 

The display attributes of each individual text 
object can be controlled independent of the 
layer it is placed on. See “Rich Text Specifi-
cation Dialog” on page 420. 

Rich Text Specification Dialog
The Rich Text Specification dialog 

opens if you select the Rich Text  
tool and then click once in the drawing area.

You can also open this dialog by selecting a 

Rich Text  object, then clicking the Open 
Object edit button. 

The Rich Text Specification dialog is 
similar to the Rich Text Defaults dialog but 
affects the selected text rather than all 
subsequently created text objects. See “Text 
Defaults” on page 417.

Text Panel
The settings on the Text panel allow you to 
type the selected Rich Text object’s content 
and control many aspects of its appearance, 
including its font, size, color and style.

You can specify the appearance of the text 
before typing, and can also select and change 
the attributes of all or portions of the text 
content after it is typed. To change text that 
already exists, simply highlight it using the 

mouse and/or the Shift + arrow keys and then 
make any needed changes to its attributes. 

Note: If you do not type anything in the text
field on this panel when creating a new
object, no object will be created when you
click OK. On the other hand, if you remove
the text from an existing object and click OK,
an empty text box will result.
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Use the options on the Edit Bar, which 
displays above the Text Entry field, to 

change the font, style and size of the text.

Select the desired options before typing to 
affect the text as it is typed, or select some or 
all of the text and then specify which options 
to apply to it.
• Select a Font from the drop-down list.
• Specify the Text Size in drawing units. 

• Click the Color  button to specify the 
color of the selected or subsequently 
typed text. See “Select Color Dialog” on 
page 370. 

• Click the Bold  button to specify text 
as bold.

• Click the Italic  button to specify text 
as italic.

• Click the Underline  button to specify 
text as underlined.

• Click the Strikethrough  button to 
selected or specify text as stricken-
through.

• Click the Align Left , Align 
Center , or Align Right  button to 
specify the how text is aligned.

• Click the Paragraph Options  button 
to specify the selected paragraph’s align-
ment, spacing and bullets or numbering 
in the Paragraph Options dialog. 

• Specify the Zoom factor of the selected 
text by typing a percentage value in the 
text field or clicking the up/down arrows. 
This setting only affects the text as it 
appears in this dialog.

Type or paste text in the Text Entry 
field. See “Copy, Cut and Paste” on 

page 425.

Right-click in the Text Entry field to access a 
contextual menu from which you can select 
Undo, Redo, Cut, Copy, Paste and Select All. 
See “Contextual Menus” on page 27. 

1

Note: Some fonts cannot be drawn at certain
zoom factors. When this is the case, the
appearance of the text will not change.

2
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To edit text in the entry field, click and drag 
to highlight any portion of it and then use the 
tools on the Edit Bar as needed.

Paragraph Options Dialog

Specify the Alignment of the selected 
paragraph(s). See “Aligning Text” on 

page 425.

Specify the Line Spacing of the 
selected paragraph(s). 

• Click the radio button beside Single, 1.5 
Lines, Double or User Specified.

• If you select User Specified Line 
Height, type the desired height for each 
line of text in the selected paragraph(s). 
For best results, this value should be at 
least as much as the largest character size 
used in the selected paragraph(s). 

Specify the appearance of the side 
Margins of the selected paragraph(s), 

as measured in from edges of the text box. 
Only positive Margin values can be used. 
• Specify the Indent, which is measured 

from the left side margin. A negative 
value can be used if a left Margin has 
been specified.

Specify the appearance of Bullets and 
numbering in the selected paragraph(s). 

• Select the desired bullet, numbered, or 
lettered Type from the drop-down list.

• Specify the Number Prefix, which are 
any characters that you would like to dis-
play before the selected paragraph’s num-
ber or letter. Does not affect paragraphs 
using circle or square bullets.

• Specify the Number Suffix, which are 
any characters that you would like to dis-
play after the selected paragraph’s num-
ber or letter and before its actual text. 
Does not affect paragraphs using circle or 
square bullets.

1

2

3

4
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Text Specification Dialog
The Text Specification dialog opens 
if you select a Room Label or a simple 

Text object in a legacy plan file created in 
Version 8 or prior and click the Open Object 
edit button. See “Compatibility with Other 
Programs” on page 38.

Settings in the Text Specification dialog can 
also be found in other dialogs in the program, 
including the Room Label Specification and 
the Dimension Defaults dialogs. 

Text Panel
The settings on the Text panel allow you to 
type the selected Text object’s content. Text 

cannot be added to a selected Room Label, 
however.

Enter text in the Text Entry field. This 
field is not available if the selected 

object is a Room Label. See “Room Labels” 
on page 149. 

Select an Alignment option from the 
drop-down list to apply to the text.

A preview of the selected text object 
displays on the right.

Text Style Panel
The Text Style panel is available for a variety 
of objects in the program and control the 
appearance of the selected object’s text. See 
“Text Style Panel” on page 428. 

Editing Text 
Once created, Rich Text  objects can be selected individually or as a group and edited 

using the edit handles and the edit toolbar 

1

2

3
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buttons Individual text objects can also be 
edited in the Rich Text Specification dialog. 
See “Rich Text Specification Dialog” on 
page 420.

Editing Text Attributes
Most text attributes, including the font, size, 
style, and the content itself, are edited in the 
Rich Text Specification dialog.

In order to edit the attributes of an existing 

Rich Text  object, you must select some 
or all of the text before making changes. See 
“Text Panel” on page 420. 

To edit Rich Text attributes

1. Select a Rich Text  object and click 

the Open Object  edit button.
2. On the Text panel of the Rich Text 

Specification dialog, click and drag to 
select some or all of the text typed into 
the Text field. 

3. With some or all of the text selected, 
change any of the attributes available 
along the top of the panel, including the 
font, size, color, and style.

4. As changes are made, the selected text 
updates. Only the selected text is modi-
fied.

Using the Mouse

A selected Rich Text  object has the same 
edit handles as other box-based objects. See 
“Editing Box-Based Objects” on page 98.

As a text box’s width is made narrower or 
wider using an edit handle, its height may 
increase or decrease so that none of the text 
becomes hidden. The opposite is not true, 
however: a text box’s height cannot be 
resized smaller than the height of the rows of 
text it currently contains.

Using the Edit Tools

A selected Rich Text  or Text  object 
can be edited in a variety of ways using the 
buttons on the edit toolbar. See “The Edit 
Toolbar” on page 26.

Resizing Text
The default character height of Rich Text 

 objects can be specified as can the 
character height for individual objects, in 
their specification dialogs. See “Text 
Defaults” on page 417.

Resize

Extend/
Contract

Rotate

Move
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Scaling Text
As with the size of other objects, text size is 
subject to the current drawing scale specified 
in the Page Setup dialog. See “Drawing 
Sheet Setup Dialog” on page 479. 

Aligning Text
Text can be aligned in a couple of ways. 
• The text content of a text object can be 

aligned to the left, right, center or justi-
fied in the Rich Text Specification dia-
log. See “Text Panel” on page 420.

• The text content of a text object can be 
also be aligned by clicking the Align 
Left , Align Right , Center , 

or Justify  edit button. 

Copy, Cut and Paste
Copy, Cut and Paste of text into and out of 
the Rich Text Specification dialog can be 
accomplished using keyboard hotkeys:
• Press Ctrl + X to Cut the selected text and 

save it to the system clipboard.
• Press Ctrl + C to Copy the selected text 

and copy it to the system clipboard.
• Press Ctrl + V to paste your last cut or 

copied selection in a new text object.

For more, see “Copying and Pasting 
Objects” on page 81.

Copy, Cut and Paste use the system 
clipboard, making it possible to to transfer 
text between text objects, between Home 
Designer Suite files, from a plan into another 
application, or vice versa. 

Copying and Pasting Text
The Copy, Cut and Paste commands use the 
system clipboard, making it possible to 
transfer text between text objects, between 
Home Designer Suite files, from a plan into 
another application such as a text editor or 
spreadsheet program, or vice versa. See 
“Copying and Pasting Objects” on page 81.

All or selected portions of the Materials List 
can also be copied and pasted into a text 
object, as well as into a word processing or 
spreadsheet program. See “Materials Lists” 
on page 491.

Cut, Copy, and Paste can also be accessed 
from the Edit menu of many applications, 
including Home Designer Suite. These menu 
commands are not available when the text 

specification dialogs are open, but you can 
use the associated hotkeys. 

To Copy, Cut and Paste text
1. On the Text panel of either text specifi-

cation dialog or in another program alto-
gether, highlight the text you wish to cut, 
copy or paste.

2. Press Ctrl + X to Cut the selected text 
out of its original location and save it to 
the system clipboard.

3. Press Ctrl + C to Copy the selected text 
to the system clipboard without remov-
ing it from its original location.

4. Open the text object or a file in another 
application and click to place your cur-
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sor in the Text field, writing area, or 
spreadsheet cell.

5. Press Ctrl + V to Paste the copied text at 
the location of your cursor.

Bear in mind that when text is copied and 
pasted, its formatting is not always retained. 
The results depend on the program or type of 
text object in which the content was created 
as well as the type of text object into which it 
is pasted. 

Pasting into Rich Text
Text pasted into a Rich Text object 
from another source will retain most 

of its custom formatting. 

Text pasted into a Rich Text  object from 
a spreadsheet program retains basic column 
and row information. Column width cannot 
be adjusted; however, as you add or remove 
text froma cell, row height will increase or 
decrease to accomodate your changes.

The background colors of two or more cells 
copied from a spreadsheet application will be 

retained if pasted in to Rich Text ; 
however, once pasted background color 
cannot be edited. 

Text Arrows
Text arrows, which are simply CAD lines 
with arrows drawn on the “Text” layer, can 
be used to connect text objects to details of 
interest in your drawing. See “Draw Lines” 
on page 431. 

Text arrows can be snapped together to form 
open or closed polylines. If two lines with 
arrows meet within the bounding box of a 
text object, however, they will not join. This 
allows you to attach multiple, separate text 
arrows to a single text object. See “Editing 
Line Based Objects” on page 88.

Lines with arrows can be independent or 
attached to other objects. Arrows attach to 
closed polyline-based objects along their 
edges, but can attach to an architectural 
object anywhere within its 2D symbol in 
floor plan view. If an arrow is attached to text 
or another object, deleting either the text or 
the object will also delete the arrow. 

Text with Arrow
The Text with Arrow tool places a 
text object with an arrow already 

attached. This arrow can be selected and 
edited like any other arrow.

Text Line with Arrow
Text Lines with Arrow can be 
attached to text, CAD and 

architectural objects by selecting CAD> 
Text> Text Line with Arrow  and then 
clicking and dragging to draw a line. There is 
no limit to the number of text lines with 
arrows that can be attached to an object.

The endpoints of Text Lines with 
Arrows  can be joined to form polylines 
with corners that can be adjusted using the 
edit handles. See “Polylines” on page 438. 
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A Text Line with Arrow  behaves like a 

Line With Arrow  with one exception: 
Text Lines with Arrow are initially placed on 
the “Text” layer, not the “CAD, Default”. 
See “Layers” on page 73. 

Auto Positioning Arrows
There are four auto position locations on a 
text object: one at the midpoint of each side.

The following image illustrates the behavior 
of auto positioning. When the head of the 
line with arrow is moved, the tail of the 

arrow snaps to different auto position 
locations on the text object, maintaining its 
connection.

Text Styles
In Home Designer Suite, a Text Style is a set 
of attributes assigned to any object that 
displays text, such as Dimensions and object 
labels. 

There are three Text Styles in Home 
Designer Suite. You can edit these Text 
Styles to suit your needs in the Text Style 
Defaults dialog  
• The Default Label Style affects the 

appearance of labels for objects such as 
doors and windows;

• The Default Text Style controls the 
appearance of legacy Text objects, and 
dimension line labels, unless specified 
otherwise. 

• The Default Room Style controls the 
appearance of room labels.

Text Style Defaults
Select Edit> Default Settings, click 
on “Text Styles” and click Edit to 

open the Text Style Defaults dialog. The 
Saved Text Style Defaults dialog will open, 
allowing you to select which Saved Text 
Style Defaults you would like to edit.

Saved Text Style Dialog

Note: Because of its ability to use multiple
attributes in the same object, Rich Text does
not use Text Styles. See “Rich Text Specifica-
tion Dialog” on page 420. 
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• Select the Name of one of them from the 
drop-down list. This is the currently 
selected Text Style.

• Click the Edit button to open the defaults 
dialog for the selected Text Style so that 
you can edit it.

• Click OK to close the Saved Text Style 
Defaults dialog and save any changes 
you made in the defaults dialog.

• Click Cancel to close the Saved Text 
Style Defaults dialog without saving any 
changes that you may have made in the 
defaults dialog.

The settings in the Text Style Defaults 
dialog are similar to those on the Text Style 
panel of object specification dialogs in the 
program but affect all objects using that style 
rather than an individual selected object. 

Text Style Panel

Check Use Default Text Style to use 
the default style for the selected object 

type, or uncheck this box to enable the 
settings below and define a custom style.

The settings that follow are only editable 
when Use Default Text Style is unchecked. 
When it is checked, information about the 
Text Style that is assigned to the selected 
object displays for reference.

Specify the attributes of the selected 
Text Style’s Font. 

• Select a font from the drop-down list.
• The text styles Bold, Underline, Italic, 

and Strikeout are available. Check any 
of the boxes to apply that style.

Specify the Character Height of text 
using the selected Text Style. 

1 2

3
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• Enter the Character Height in drawing 
units. This height is subject to the current 
drawing scale. 

Specify the selected Text Style’s Text 
Color. When Use Custom Text Style is 

not selected above, a Text Color does not 
display here for reference. 
• When  By Layer is checked, text uses the 

line color assigned to the layer that the 

object it is assigned to is located on. See 
“Displaying Objects” on page 74.  

• Uncheck By Layer, then click the Color 
bar to select a different color. See “Select 
Color Dialog” on page 370.

A preview of the Text Style currently 
assigned to the selected object displays 

here. 

Object Labels
Object labels can display in floor plan view 
for a variety of different object types. 
• Automatic Labels provide basic informa-

tion about the object, such as its type, 
size, or name.

• You can create a custom label for an 
object in its specification dialog using 
text. See “Label Panel” on page 429.

Automatic Labels
Most objects that can display labels have an 
Automatic Label created by the program that 
states basic information about it. When 
Automatic Labels is selected in the object’s 
specification dialog, this is usually the label 
that will be used; however:
• If a user-defined label is specified in the 

object’s defaults dialog, that label will be 
used instead of the Automatic Label.

• Fixtures and appliances inserted into cab-
inets do not have labels of their own.

Displaying Labels
The display of object labels can be 
controlled by layer in the Layer 

Display Options dialog. Label layer names 
begin with the object type, followed by the 
word Label: for example, cabinet labels are 
located on the “Cabinets, Labels” layer. See 
“Display Options Dialog” on page 75.

You can choose to suppress the label for an 
individual object on the Label panel of its 
specification dialog. 

Object labels use the “Default Label Style” 
Text Style. See “Text Styles” on page 427. 

Label Panel
The Label panel is found in the specification 
and defaults dialogs for a variety of different 
objects. 

4

5
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Most objects have a Suppress Label 
option. Check this box to prevent the 

selected object’s label from displaying in 
floor plan view. 

Bay, Box and Bow Windows and Mulled 
Window units have several settings for 
controlling Multiple Component labels. See 
“Window Labels” on page 183. 
• Select Suppress All Labels to display no 

label in floor plan view. Individual com-
ponents are counted in the Materials List. 

• Select Show Component Labels to pro-
duce labels for each component in floor 
plan view. Individual components are 
counted in the Materials List.

• Select Show Single Label for Entire 
Unit to produce one label for the unit and 
suppress component labels. When this 
option is selected, the settings that follow 
on the Label panel become enabled.

These settings also affect how Bay, Box and 
Bow Windows and Mulled Window units are 

counted in the Materials List. See “Window 
Labels” on page 183 and “Displaying Mulled 
Units” on page 182.

The Label Options control what 
information is contained in the label. 

See “Displaying 3D Views” on page 386. 
• Select Automatic Labels to use the 

default label for the selected object. See 
“Automatic Labels” on page 429. 

• Select Specify Label to replace the 
selected object’s Automatic Label with 
whatever you type in the text field below.

When Specify Label is chosen, the 
selected object’s Automatic Label ini-
tially populates the text field  

In most specification dialogs, a preview 
of the selected object displays here. In 

the preview pane, labels can be seen in Plan 
View only. See “Dialog Preview Panes” on 
page 29. 

1
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Chapter 31:

CAD Objects

The CAD Tools are used to add information 
to 2D views of your model. CAD objects do 
not affect 3D objects or display in camera 
views or overviews, but they can be used to 
add details to floor plan view. 

CAD objects are edited much like other 
objects in Home Designer Suite. See 
“Editing Objects” on page 85.

Chapter Contents
•      The CAD Drawing Tools
•      Line Specification Dialog
•      Arc Specification Dialog
•      CAD Circle/Oval/Ellipse Specification 

Dialog
•      Polylines
•      Polyline Specification Dialog
•      Box Specification Dialog
•      Displaying CAD Objects

The CAD Drawing Tools
The CAD drawing tools can be 
accessed by selecting CAD> CAD or 

by clicking the CAD Tools button. 

The CAD drawing tools can be 
accessed by selecting CAD> CAD or 

by clicking the CAD Tools button. 

Draw Lines
Select CAD> Draw Line or 
CAD> Draw Line With Arrow 

to draw lines with or without arrows. 

To draw a line or line with arrow

1. Select CAD> CAD> Draw Line  or 

Draw Line With Arrow .
2. Click and drag in the drawing area to 

draw a line. 
3. Continue drawing lines as needed, then 

select another tool when you are 
finished. 

Once a line is created, it can be edited. You 
can snap the ends of lines together to form 
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polylines. See “Editing Line Based Objects” 
on page 88 and “Line Specification Dialog” 
on page 434. 

Draw Arc
Select CAD > CAD> Draw Arc to 
draw an arc. 

To draw an arc

1. Select CAD> Arcs> Draw Arc , 
then click at the arc’s start point. 

2. Move the pointer along the desired 
curve while dragging to curve the arc.

3. Release the mouse button at the end 
point to complete the arc. 

Once an arc is created, it can be edited. See 
“Editing Arc Based Objects” on page 90 and 
“Arc Specification Dialog” on page 436.

You can snap the ends of arcs together with 
other arcs or with lines to form polylines. See 
“Polylines” on page 438. 

Draw Polyline
Select CAD > CAD> Draw Polyline 
to draw a rectangular polyline in 

either of two ways:
• Click in the drawing area to place a 24” x 

24” square polyline at that location.
• Click and drag from corner to corner to 

draw a rectangle of any size. 

Once drawn, a rectangular polyline can be 
edited into any shape. See “Editing Closed-
Polyline Based Objects” on page 96  and 
“Polyline Specification Dialog” on page 438.

Draw Box
Select CAD > CAD> Draw Box to 
draw a box.

CAD boxes are drawn from corner to corner, 
forming a rectangle that can then be edited. 
Unlike a polyline, a box always has four 90 
degree corners. See “Editing Box-Based 
Objects” on page 98 and “Box Specification 
Dialog” on page 440.

Draw Circle
Select CAD > CAD> Draw Circle to 
draw a circle. 

Draw a Circle  by dragging across the 
diameter, in any direction. 

If a small circle is needed, draw a larger 
circle and then resize it. See “Editing Circles, 
Ovals and Ellipses” on page 102 and “CAD 
Circle/Oval/Ellipse Specification Dialog” on 
page 437.

Ovals
Select CAD > CAD> Draw Oval to 
draw an oval, which is a four-arc 

approximation of an ellipse. 

Draw an oval, by clicking and dragging at an 
angle to define its maximum height and 
width. 

Once an oval is created, it can be edited. See 
“Editing Circles, Ovals and Ellipses” on 
page 102 and “CAD Circle/Oval/Ellipse 
Specification Dialog” on page 437. 

Ellipses
An Ellipse is a set of points with a 
constant combined distance from two 

home-designer-suite-2015-reference-manual.book  Page 432  Thursday, May 29, 2014  4:26 PM



The CAD Drawing Tools

 433

points called foci. An ellipse looks like a 
stretched circle, or a circular surface viewed 
at an angle. 

To draw an ellipse, select CAD> CAD> 
Draw Ellipse  and drag at an angle to 
define its maximum height and width.

Once an ellipse is created, it can be edited. 
See “Editing Circles, Ovals and Ellipses” on 
page 102 and “CAD Circle/Oval/Ellipse 
Specification Dialog” on page 437. 

Splines
A Spline is a curve that passes 
smoothly through a set of points. 

Select CAD> CAD> Draw Spline to draw 
connected line segments that form a spline. 

Once created, a spline can be selected and 
edited. See “Editing Spline Based Objects” 
on page 100 and “Polyline Specification 
Dialog” on page 438.

To use the Spline tool

1. Select CAD> CAD> Spline .
2. Draw the first spline segment just as you 

would a line. A single spline segment 
looks identical to a line. 

You may need to turn off Angle Snaps 

 to draw freely. See “Angle Snaps” 
on page 79.

3. Draw the second segment from the end 
of the first at a different angle. 

4. As soon as two straight spline segments 
connect end-to-end, the straight seg-
ments become a curve that passes 
through the endpoints defined by the 
original segments. Each point is called a 
vertex. 

5. Draw a few more segments, connecting 
each to the free end of a previously 
drawn segment.

6. Notice as additional segments are drawn 
that the curvature of the previous seg-
ment changes to create a continuous 
curve between the last three points.

The result is an irregular curve that flows 
smoothly through each vertex.

You can also form a closed spline by drawing 
a segment between its two free ends.

Dimension Tools
Select CAD> Dimensions to access 
the Dimension Tools. The Dimension 

Tools can be used with CAD and 
architectural objects and are discussed in 

As drawn

Result

As drawn

Result
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their own chapter. See “Dimensions” on page 
405.

Text Tools
Select CAD> Text to access the Text 
Tools. The Text Tools are discussed in 

their own chapter. See “Text” on page 417. 

Line Specification Dialog
Select a CAD Line, Line With Arrow, 
or Text Line With Arrow and click the 

Open Object edit button to open the Line 
Specification dialog. 

The settings on the panels in this dialog are 
found in the specification and defaults 
dialogs for a variety of different objects in 
the program.

Line Panel
The information on the Line panel of the 
Line Specification dialog is similar to that 

found on the Selected Line panels of various 
specification dialogs in the program.

Specify the Length and Angle of the 
selected line. 

The X and Y Position coordinates of 
the selected line’s Start Point display 

for reference but cannot be changed here. 

The Start Point can be changed using the 
line’s edit handles, however. See “Editing 
Line Based Objects” on page 88. 

Specify the X and Y Position of the 
selected line’s End Point. 

Line Style Panel
The Line Style panel is found in the 
specification dialogs for many different 

1

2
3
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objects. The settings here control the 
appearance of the lines and/or arcs that make 
up an object.

• Click the Line Color box to specify a 
new line color. See “Select Color Dialog” 
on page 370.

• Click the Line Style drop-down list to 
select from a variety of available line 
styles.

Arrow Panel
The Arrow panel is available for any line, 
arc, open polyline, or spline that can have an 
arrow. The defaults for arrows are set in the 
Arrow Defaults dialog. 

Closed polylines and Electrical connections 
are examples of objects that cannot have 
arrows.

• Check Include Arrow to create an 
arrowhead at the end of the selected line, 
arc, or open polyline.

• Select an arrowhead Style from the drop-
down list.

• Click the Fill Color box to select a color 
for the arrowhead to be used if a solid 

Style is selected. See “Select Color Dia-
log” on page 370.

• Specify the arrowhead’s Size.
• Check the box beside Arrow On Both 

Ends to create a two-headed arrow.
• Place a check in any of the Default boxes 

to restore that setting to the default. 
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Arc Specification Dialog
Select an arc and click the Open 
Object edit button to open the Arc 

Specification dialog.

Arc Panel
The settings on the Arc panel are also found 
on the Selected Arc panels for many objects.

These settings define the Arc. Some 
values are listed for reference only and 

cannot be directly changed here. They can, 
however, be changed using the edit handles 
and edit tools. See “Editing Arc Based 
Objects” on page 90.

• The Center X and Center Y Points are 
the Y and Y coordinates of the center of 
the arc and display for reference. They 
may update as changes are made to other 
settings in this dialog.

1
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• Radius - Specify the distance between 
the center of the arc and the arc surface.

• Start Angle - The angle of a line drawn 
from the arc center to the arc start points. 
This displays for reference only but may 
update as changes are made to other set-
tings in this dialog.

• End Angle - Specify the angle of a line 
drawn from the arc center to the arc end.

• Arc Angle - Specify the angle between 
the center of the arc and each end.

• Arc Length - Specify the length of the 
arc along its curve.

Start Point - Specify information about 
the starting point of the selected arc.

• The Start X and Start Y Position coordi-
nates display for reference. They may 
update as changes are made to other set-
tings in this dialog. 

• Start Direction - Specify the angle of a 
tangent line at the start of the arc.

End Point - Specify information about 
the end point of the selected arc.

• End X - Specify the X coordinate for the 
end of the arc.

• End Y - Specify the Y coordinate for the 
end of the arc.

• End Direction - The the angle of a tan-
gent line at the end of the arc displays for 
reference. This displays for reference 
only but may update as changes are made 
to other settings in this dialog. 

Define the selected arc’s Chord, which 
is the straight line between its start and 

end points.
• Chord Length - The straight line dis-

tance between the two ends of the arc.
• Chord Angle - Specify the angle of the 

chord.

Line Style Panel
For information about the Line Style panel, 
see “Line Style Panel” on page 434.

Arrow Panel
For information about the Arrow panel, see 
“Arrow Panel” on page 435.

CAD Circle/Oval/Ellipse Specification Dialog
Select a circle, oval or ellipse and 
click the Open Object edit button to 

open the CAD Circle, Oval or Ellipse 
Specification dialog.

The CAD Circle, Oval and Ellipse 
Specification dialogs are almost exactly the 
same.

Line Style Panel
For information about the Line Style panel, 
see “Line Style Panel” on page 434.

Fill Style Panel
For information about the Fill Style panel, 
see “Fill Style Panel” on page 439.

2

3

4
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Polylines
A polyline consists of two or more 
line and/or arc segments that are 

attached at their endpoints. Select 
CAD>CAD> Rectangular Polyline, then 
click and drag from corner to corner to create 
a rectangular-shaped, closed polyline. A 
closed polyline measuring 2’x 2’ (600 mm x 
600 mm) can also be created by clicking 
once while the Rectangular Polyline tool is 
active.

You can also create a polyline by drawing 
lines and/or arcs end-to-end, allowing the 
end of each new object to snap to the end of 
the previous one. Line- and arc-based objects 
will only snap together to form a polyline if 
they are on the same layer and share identical 
attributes such as color, line style, and arrow 
specifications.If one end of the polyline is 
connected to the other, it becomes a closed 
polyline.  

Polylines can be copied, moved, reshaped, or 
resized as a single unit. 

Once created, polylines can be edited in a 
variety of ways. See “Editing Open Polyline 
Based Objects” on page 93 and “Editing 
Closed-Polyline Based Objects” on page 96.

Polyline Specification Dialog
Select an open polyline, closed 
polyline, spline or Electrical 

connection and click the Open Object edit 
button to open the Polyline Specification 
dialog. 

Polyline Panel
The Polyline panel indicates the Length/ 
Perimeter, enclosed Area, and Volume of a 

selected polyline and is found in the 
specification dialogs for open- and closed-
polyline-based objects throughout the 
program.

If the polyline is not closed, the Area and 
Volume are described as “Not closed”. The 
Volume of a 2D polyline will always be 0, 
even if it is closed.  

Closed Polylines Open Polylines
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Selected Line Panel
The Selected Line panel is available when 
the selected edge of the polyline is a line as 
opposed to an arc. This panel is not available 
if the selected object is a spline. See “Editing 
Line Based Objects” on page 88.

Moving the End of a line segment moves the 
start of the next connected line, if there is 
one. 

This panel is similar to the Line panel of the 
Line Specification dialog. See “Line Panel” 
on page 434.

Selected Arc Panel
The Selected Arc panel is available when the 
selected segment of the polyline is an arc as 
opposed to a line. This panel is not available 
if the selected object is a spline. 

This panel is similar to the Arc panel of the 
Arc Specification dialog. See “Arc Panel” 
on page 436.

Line Style Panel
This panel is similar to the Line Style panel 
in the Line Specification dialog. See “Line 
Style Panel” on page 434.

Fill Style Panel
The information on the Fill Style panel for 
closed polylines is similar to that for many 
other objects in the program, including 
closed CAD shapes and a variety of 
architectural objects. 

The Fill Style panel is not available for 
Electrical Connections as this tool cannot be 
used to form closed shapes. 

Specify the characteristics of the selected 
object’s fill Pattern. When “None” is the 
selected pattern Type, the rest of these 
settings are disabled. 

• Choose a pattern Type from the drop-
down list.

• Specify the Spacing of the selected fill 
pattern. Not available for “Solid” fill.
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• Check Transparent Fill to make the 
spaces between fill pattern lines transpar-
ent, allowing any objects behind the fill 
pattern to be visible through it. Not avail-
able for “Solid” fill.

• Specify the Color of the lines that make 
up the fill pattern, or the fill color of 
“Solid” fill, by clicking the color bar. The 
layer color is used by default. See “Select 
Color Dialog” on page 370.

A preview of the selected pattern displays to 
the right. As changes are made to the settings 
on this panel, the preview will update.

• Choose a Preview Width from the drop-
down list. This value controls how large 
an area the preview represents. The 
selected value indicates the length of 
each side of the preview in actual plan 
inches (mm).

Arrow Panel
The Arrow panel is available for most open 
polylines and splines and is similar to the 
Arrow panel of the Line Specification 
dialog. See “Arrow Panel” on page 435. 

The Arrow panel is not available for closed 
polylines or Electrical Connections. 

Box Specification Dialog
Select a CAD box and click the Open 
Object edit button to open the Box 

Specification dialog. See “Draw Box” on 
page 432.

Line Style Panel
For information about the Line Style panel, 
see “Line Panel” on page 434.

Fill Style Panel
For information about the Fill Style panel, 
see “Fill Style Panel” on page 439.

Splines
A Spline is a curve that passes 
smoothly through a set of points. 

Splines are typically used in situations where 
there is an irregular curve. A contour line is a 
typical example. Splines are useful wherever 
a free-flowing curve is needed.

Once created, splines can be selected and 
edited. See “Editing Spline Based Objects” 
on page 100 and “Polyline Specification 
Dialog” on page 438.

To use the Spline tool

1. Select CAD> Spline .
2. Draw the first spline segment just as you 

would a line. A single spline segment 
looks identical to a line. You may need 

to turn off Angle Snaps  to draw 
freely.
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3. Draw the second segment from the end 
of the first at a different angle. Object 
Snaps  should be on to assure that 
new segments attach correctly to the 
ends of previous segments.

4. As soon as two straight spline segments 
connect end-to-end, the straight seg-
ments become a curve that passes 
through the endpoints defined by the 
original segments. Each point is called a 
vertex. 

5. Draw a few more segments, connecting 
each to the free end of a previously 
drawn segment.

6. Notice as additional segments are drawn 
that the spline changes the curvature of 
the previous segment to create a contin-
uous curve between the last three points.

7. Form a closed spline by drawing a seg-
ment between its two free ends.

8. The result is an irregular curve that 
flows smoothly through each vertex.

Spline-based objects will only snap together 
to form a single spline if they are on the same 
layer and share identical attributes such as 
color, line style, and arrow specifications.

As drawn

Result

As drawn

Result

As drawn

Result

Draw segment to close

Result
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Displaying CAD Objects
As with architectural objects, the display of 
CAD objects is controlled in the Display 
Options dialog. See “Display Options 
Dialog” on page 75.

CAD objects can be drawn in floor plan 
view. They are 2D objects only, though, so 

they cannot be seen in any view other than 
the one they are drawn in and are never 
visible in camera views or overviews. See 
“Architectural vs CAD Objects” on page 78.
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Chapter 32:

Project Planning

The tools described in this chapter let you 
draw plans with ease and flexibility, run 
checks on plans so you can be more 
confident that they are free of common 
drawing errors, and consider loan 
calculations for your project.

Chapter Contents
•      Space Planning
•      Plan Check
•      Loan Calculator

Space Planning
The Space Planning Assistant Tools 
are a time-saving way to create a 

preliminary room-by-room design of a home 
without getting caught up in the details. Once 
the shape and layout of the rooms are 
finalized, the Build House tool converts 
them into a working plan that can be edited 
and detailed to completion.

Space Planning Assistant
Select Tools> Space Planning> 
Space Planning. The Space 

Planning Assistant leads you through a 
series of windows that gather information 
about the rooms you want to include in your 

house. When you click Finish, the selected 
room boxes display.
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Room boxes can now be arranged into a floor 
plan. 

Placing Room Boxes
In addition or as an alternative to the room 
boxes created for you by the Space 
Planning Assistant, you can create your 
own room boxes. To do so, select Tools> 
Space Planning , then choose the desired 
room type from the submenu. Click in floor 
plan view to place a room box of the selected 
type at that location. 

Displaying Room Boxes
Room boxes and their labels are located on 
the “Space Planning Boxes” layer. Space 
Planning Box labels use the Text Style 
assigned to that layer, as well. See 
“Displaying Objects” on page 74. 

Editing Rooms
Once created, room boxes can be edited in a 
variety of ways.

• Select room boxes using the Select 
Objects  tool just like other objects in 
Home Designer Suite. See “Selecting 
Objects” on page 86.

• Room boxes can be resized, rotated, and 
rearranged. See “Editing Box-Based 
Objects” on page 98.

• Try to line up the rooms so that they are 
just touching. Excessive overlaps may 
cause your rooms to form incorrectly. 
Closets are the exception. You can over-
lap a room with a closet, or place in 
inside another room box.

• Rooms can be copied and pasted using 

the Copy/Paste  edit button and 

deleted using the Delete  edit button.

• Select Tools> Space Planning  to 
access the room box tools and place addi-
tional room boxes in your plan. Select a 
tool and click in the plan to place a room 
box of that type. 

• Select Tools> Space Planning> Toggle 
Room Boxes  to hide or show the 
room boxes.

Build House
When the rooms are in place, select Tools> 
Space Planning> Build House  to 
convert the rooms into a building model. 
Walls and doors are inserted between the 
rooms that you arranged. 
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When you Build House, the “Space Planning 
Boxes” layer is automatically turned off. The 
room boxes that you created are not deleted, 
however. 

Multiple Floors
If you specified a two-story house, follow 
these steps:

1. Edit and arrange the room boxes on 
Floor 1 as desired.

2. Select Tools> Space Planning> Build 
House  tool to create the walls on the 
first floor.

3. Go Up One Floor  and notice that 
the positions of the walls on Floor 1 dis-
play in red as a reference.

4. Arrange the rooms on Floor 2 as desired, 
using the reference display as a guide.

5. On the second floor, select Tools> 
Space Planning> Build House  to 
complete the second floor.

Plan Check
Plan Check checks the floor of your plan 
currently shown on screen for anything that 
appears to violate common building 
practices. Plan Check may not find all the 
problems in a plan, but does it point out areas 
that may need improvement. 

As your plan evolves, a number of 
things that may become incorrect can 

be fixed using Plan Check. For example, 
doors that change from exterior to interior as 
you add new rooms are redrawn without the 
threshold line that marks an exterior door. A 
cabinet, fixture or furniture item that is 
against a wall because the wall was moved 

into it, as opposed to the item moving, are 
attached to the wall.

To run Plan Check, select Tools> Plan 
Check .

Disclaimer: The Plan Check feature in
Home Designer Suite compares your

plan with common building practices. Plan
Check does not claim to detect all building
code and design requirements. Always have
your plans checked by a licensed profes-
sional before beginning actual construction.
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Plan Check Dialog

The current error number, along with 
the total number of errors found.

A description of the current error 
displays here.

Options for navigating Plan Check are 
found on the right side.

• Click Next to ignore the current error and 
proceed to the next.

• Click Previous to return to the previous 
error.

• Click Hold to suspend Plan Check so you 
can fix the current error. Select Tools> 
Checks> Plan Check again and the 
check starts where it left off.

• Click Done to terminate Plan Check.

Potential plan errors found are usually 
highlighted in floor plan view. To ensure the 
highlighted item is on-screen, make sure the 
entire plan is shown in the window before 

you run Plan Check .
If this dialog obscures the floor plan view, 
drag its title bar to move it. It remembers its 
new position and displays there the next time 

Plan Check  is run.

Room Types

Plan Check  can do a much better job of 
checking for problems if it knows what the 
rooms in your plan are to be used for, so you 
should assign a Room Type to each room in 
your plan. See “Room Types” on page 147.

The first time Plan Check  runs in a plan, 
it automatically assigns a room type to as 
many undesignated rooms as it can. Some 
rooms are determined by their size and 
shape, and others by their contents. For 
example, a shelf in a small room indicates a 
closet; a stove or refrigerator indicates a 
kitchen; or a bed, a bedroom. If the program 

cannot assign a room type, Plan Check  
highlights it and suggests that you do so 
manually. 

Loan Calculator
Select Tools> Loan Calculator to 
open the Loan Calculator dialog. This 

dialog lets you calculate different aspects of 

a loan for the current plan based on a variety 
of parameters. 

1

2

3
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Specify what aspect of the loan you 
would like to calculate from the 

Calculate drop-down list:
• Monthly Payment 
• Loan Amount 
• Term 
• Interest Rate 

The calculation Result, based on the 
information you provide, displays here.

If you make changes to any of the fields in 
the dialog, click the = button to refresh the 
Result.

The Required Fields are the same as 
the options in the Calculate drop-down 

list. The option selected under Calculate will 
be inactive under Required Fields.
• Specify the desired Loan Amount.
• Specify the desired Term, in years.
• Specify the desired Interest Rate.
• Specify the desired Monthly Payment.

The Optional Fields allow you to 
include additional information in your 

loan calculation. 
• Specify the expected Property Taxes per 

year. 
• Specify the expected Homeowner’s 

Insurance cost per year. 
• Specify the expected Private Mortgage 

Insurance (PMI) cost per year.
• Specify the cost of any expected Other 

Fees.

When Monthly Payment is calculated, each 
Optional value is divided by twelve (months) 
and then added to the total payment.

When a Calculate option other than Monthly 
Payment is selected, these values are divided 
by twelve (months) and then subtracted from 
the specified Monthly Payment value. The 
result, which does not display, is then used to 
determine the Loan Amount, Term or Interest 
Rate.

1
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Chapter 33:

Pictures, Images,
and Walkthroughs

Home Designer Suite uses picture files in a 
variety of ways to enhance your drawings. 

The Library Browser contains images of real 
world objects like plants, vehicles, and 
people that can display in 3D views.

Picture files can also be imported into Home 
Designer Suite and shown in most views. 

You can save any view using a variety of 
picture file formats. In addition, Home 
Designer Suite allows you to create virtual 
tours that can be saved as .avi files, shared 
with others, and played back later.

Chapter Contents
•      Picture Files vs Pictures and Image Objects
•      Images
•      Displaying Images
•      Editing Images
•      Image Specification Dialog
•      Pictures
•      Picture File Box Specification Dialog
•      Metafiles
•      Metafile Box Specification Dialog
•      PDF Files
•      PDF Box Specification Dialog
•      Displaying Pictures, Metafiles, and PDF 

Boxes
•      Editing Pictures, Metafiles, and PDF Boxes
•      Copy Region as Picture
•      3D Backdrops
•      Walkthroughs
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Picture Files vs Pictures and Image Objects
In common computer language, picture files, 
pictures and images are more or less 
synonymous. In the Home Designer Suite 
environment, however, there are some 
notable differences between these terms.

In Home Designer Suite, a two dimensional 
image file such as a .bmp, .jpg, .gif, or .png is 
referred to as a picture file or an image file. 
Examples of these files are saved on most 
computers and can be opened in a variety of 
applications. 

A Picture, on the other hand, is a file that has 
been imported into the program. Pictures can 
be imported into floor plan view and 
Elevation views. They are two-dimensional 

only and do not display in camera views or 
overviews. 

An Image object is also based on a picture 
file, but it does display in both 2D and 3D 
views. Images have 3D width and height data 
associated with them, as well as a 2D symbol 
which displays in floor plan view. 

Picture files have additional uses in Home 
Designer Suite, as well:
• Backdrops are picture files that display 

behind 3D views. See “3D Backdrops” 
on page 387.

• Textures are picture files that realistically 
represent materials in 3D views. See 
“About Materials” on page 361. 

Images
Images add realistic detail to 3D views 
without adding many surfaces to the model. 
For example, a tree image with a single 
surface can be used instead of a tree symbol 
with thousands, dramatically improving 
realism without compromising drawing time.

There are two types of Images in Home 
Designer Suite: 

• Images  rotate so that they always 
face the camera in 3D views.

• Billboard Images  do not rotate to 
face the camera. An example of when 
this may be useful is an image of a trellis, 
which might look awkward when facing 
a camera from a side view. 

Placing Images
A selection of Images are available in 
the Library Browser. Select one and 

click in a floor plan view, camera view or 
overview to place it. See “Placing Library 
Objects” on page 354.

Creating Images
Custom Images can be added to the 
Library Browser, as well as created in 

plan files. Home Designer Suite can use any 
image with a *.bmp, *.jpg, *.png, *.gif, 
*.tif, *.pcx, or *.tga extension.

Generally, .png files work best as Images 
because this format has good compression 
and allows for the Image to contain 
transparency information.
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To create an Image in floor plan view 

1. In floor plan view, select Build> 
Image> Create Image  or Billboard 
Image  to open the Image 
Specification dialog. See “Image Speci-
fication Dialog” on page 452.

2. On the Image panel:
• Click the Browse button to select a pic-

ture file on your computer or enter the 
path to a valid picture file in the Image 
File field.

• Select a 2D Plan Symbol from the drop-
down list or click the Library button 
and select a symbol from the library. The 
selected symbol represents the image in 
floor plan view. See “Image Panel” on 
page 453.

• Specify the Size and Position of the 
image. 

3. Specify transparency information on the 
Transparency panel. 

4. Click OK to close the Image 
Specification dialog.

5. Click to place the new Image in floor 
plan view. 

To create an image in the Library Browser 

1. In the Library Browser, right-click on an 
unlocked folder.

2. Select New> Image from the contextual 
menu to open the Image Specification 
dialog. 

3. Browse to the image file you want to 
add and select your other options. See 
“Image Specification Dialog” on page 
452.  

4. Once created, the image is listed in the 
library folder that you right-clicked on. 
Size and other data is saved. 

Using Paste Image
You can also import an image by first 
copying it to the Windows Clipboard, 

then navigating to a Home Designer Suite 
window and selecting Edit> Paste> Paste 
from the menu. See “Paste Special” on page 
83. 

Displaying Images
The display of images in floor plan 
and 3D views is controlled in the 

Display Options dialog. See “Displaying 
Objects” on page 74.

Images are placed on the”Images” layer.

In Floor Plan View
In floor plan view, most images are typically 

represented by an Image  symbol. You 
can specify a different symbol to represent an 

image if you wish. See “Image Specification 
Dialog” on page 452. 

In 3D Views
The actual picture associated with an image 
object can be seen in 3D views, as can any 
transparency data associated it. See “Image 
Specification Dialog” on page 452.
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Images can be set to either rotate so that they 
always face the camera or remain stationary, 
like billboards. See “Images” on page 450. 

Editing Images
Images can be selected in 2D and 3D views 
and edited using the edit handles, edit tools 
and the Image Specification dialog. 

Using the Mouse
In floor plan view, a selected image rotated, 
moved, and resized. In 3D views, a selected 
image only has one edit handle: the circular 
Resize handle. 

When an image is resized using the edit 
handle, its aspect ratio is retained and 2D 
symbol resizes proportionally.

Using the Edit Toolbar
A selected image or images can be edited in a 
variety of ways using the buttons on the edit 
toolbar. As with most objects, images can be 
copied, replicated, moved, deleted, etc. See 
“The Edit Toolbar” on page 26.

Image Specification Dialog
Select an image and click the Open 
Object edit button to open the Image 

Specification dialog. 
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Image Panel
 

General information about the selected 
Image can be specified here.

• The Image File associated with the 
Image can be specified. Click Browse to 
choose a file saved on your computer or 
type the file’s full pathname in the text 
field. 

• Select a2D Plan Symbol from the drop-
down list to represent the Image in floor 
plan view. See “Displaying Images” on 
page 451.

Specify the Size of the image as it 
displays in 3D views.

• Enter a Height for the selected image. 
• Enter a Width for the selected image. 

• Uncheck Retain Aspect Ratio of X if 
you would like to modify the Height or 
Width without affecting the other value. 
If you do this, the image may appear dis-
torted. 
This checkbox does not affect editing 
performed outside of this dialog and is an 
action rather than a state: the next time 
you open this dialog, it will be checked.

• Click Reset Original Aspect Ratio of to 
reset the image’s original aspect ratio and 
remove any distortion caused by resizing.

Specify the location of the selected 
Image’s Center Point.

• Position the selected image precisely by 
specifying its X and Y Coordinates.

1

2 3
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• Specify the image’s Height Above 
Ground.

Options - 

• Check Reverse Image to reflect the 
appearance of the image about an imagi-
nary vertical line through its center. 

• Check Image Always Faces Camera to 
prevent the image from rotating to face 
the camera in 3D views. This box is 
unchecked for Billboard Images. See 
“Images” on page 450. 

Any Copyright information associated 
with the selected Image will be stated 

here. 

A preview of the selected Image 
displays here. The Glass House 

Rendering Techniques is not available for 
images. See “Dialog Preview Panes” on page 
29. 

Fill Style Panel
For information about the settings on this 
panel, see “Fill Style Panel” on page 439.

Pictures
A variety of picture file types can be 
imported into and exported out of Home 
Designer Suite. 

Metafiles are also types of picture files that 
can be imported and exported. See 
“Metafiles” on page 455.

Exporting Pictures
Using the Export Picture tool is 
similar to creating a screen capture of 

everything  in the current Home Designer 
Suite view window. Pictures can be saved in 
various file formats and used in other 
applications. 

Export Picture  is best suited for 3D 
views. When exporting a line-based view, 
best results can be achieved by saving it as a 
Metafile. See “To export a metafile” on page 
455.

To export a picture

1. Open the view that you would like to 
export as a picture file. 

2. Zoom, pan or otherwise adjust the view 
so that what you see on screen suits your 
needs. See “Displaying 3D Views” on 
page 386.

3. Select File> Export> Picture (BMP, 
JPG, PNG)  in any view to open the 
Export Picture File dialog. See “Export-
ing Files” on page 43. 

The Copy Region as Picture  tool also 
lets you create a picture file based on the 
current view, but allows you to specify what 
portion of the view is exported. See “Copy 
Region as Picture” on page 459.

Importing Pictures
Pictures can be imported into and 
displayed in floor plan view. Pictures 

do not display in camera views or overviews. 

4

5

6
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See “Displaying Pictures, Metafiles, and 
PDF Boxes” on page 458.

There are several ways to import a Picture 
into Home Designer Suite:
• Select File> Import> Picture (BMP, 

JPG, PNG)  to open the Import 
Picture File dialog, which is a typical 
open file dialog. See “Importing Files” 
on page 47. 

• Click and drag an image file from an 
operating system window into the Home 
Designer Suite window.

• In any application, copy an image to the 
Windows Clipboard, then select Edit> 
Paste> Paste  from the Home 
Designer Suite menu in an eligible view 
window. See “Paste Special” on page 83.

An imported picture is placed in the center of 
the current view. Once imported, pictures can 
be selected and edited. See “Editing Pictures, 
Metafiles, and PDF Boxes” on page 458.

Picture File Box Specification Dialog
Select an imported picture file and 
click the Open Object edit button to 

open the Picture File Box Specification 
dialog.

The settings in this dialog are similar to those 
on the Line Style panel in numerous other 

dialogs, with one exception: uncheck Show 
Outline to turn off the display of the 
picture’s border polyline.

See “Line Style Panel” on page 434.

Metafiles
A metafile (.emf, .wmf) is a special picture 
file format made up of vectors (lines) that 
allow the image to be rescaled without loss 
of quality. High resolution pictures of line-
based views can be exported as a metafile.

Exporting Metafiles
An enhanced metafile (.emf) can be 
exported from floor plan view. 

Only objects that display on screen are 
included in an exported metafile. 

To export a metafile

1. Accurately position the view on screen.
2. Select File> Export> Metafile 

(EMF) . 

Note: Importing large, or multiple, Pictures
into a plan file can result in program slow-
ness. 

Note: Metafiles are not supported in Mac
operating systems and cannot be imported or
exported in Mac versions of the software. 
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3. Drag a marquee  from corner to cor-
ner, defining the area that will included 
in the metafile.

4. Release the mouse to open the Metafile 
Size dialog.

5. Specify the desired Width or Height of 
the metafile. When one value is edited, 
the other changes to maintain its aspect 
ratio. 

Specify, too, the desired Dots Per Inch 
(DPI) for the metafile. A larger value 
results in a higher quality metafile, but 
also a larger file size.

6. Click OK to open the Export Metafile 
dialog, which is a typical Save As dia-
log. See “Saving, Exporting, and Back-
ing Up Files” on page 41. 

7. Enter a name and location on your com-
puter for the metafile, then click Save. 

Importing Metafiles
Metafiles can be imported into and 
displayed in floor plan view. Metafiles 

do not display in camera views or overviews. 
See “Displaying Pictures, Metafiles, and 
PDF Boxes” on page 458.

There are two ways to import a metafile into 
Home Designer Suite:
• Select File> Import> Metafile 

(EMF,WMF)  to open the Import 
Metafile dialog, which is a typical open 
file dialog. See “Importing Files” on page 
47. 

• You can also click and drag a metafile file 
from an operating system window into 
the Home Designer Suite window to 
import it.

An imported metafile is placed in the center 
of the current view. Once imported, metafiles 
can be selected and edited. See “Editing 
Pictures, Metafiles, and PDF Boxes” on page 
458.

Metafile Box Specification Dialog
Select an imported metafile and click 
the Open Object edit button to open 

the Metafile Box Specification dialog. 

The settings in this dialog are similar to those 
on the Line Style panel in numerous other 

dialogs, with one exception. Uncheck Show 
Border to turn off the display of the picture’s 
border polyline.

See “Line Style Panel” on page 434.
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PDF Files
Portable Document Format (.pdf) files are a 
special type of file that can be viewed on 
nearly any computer and can include a wide 
variety of visual information.  

You can import .pdf files into Home 
Designer Suite in floor plan view. Once 
imported, PDF boxes behave and can be 
edited similar to imported pictures and 
metafiles. See “Editing Pictures, Metafiles, 
and PDF Boxes” on page 458.

Some .pdf files can contain both 2D and 3D 
information; however, Home Designer Suite 

can only support 2D data in an imported .pdf 
file. When a 3D .pdf file is imported, it may 
display text, a static image of the 3D model, 
or it may not import at all. 

You can also create a 2D .pdf from 
any view by printing. See “Printing to 

a PDF File” on page 483.

Importing PDF Files
To import a .pdf file, select File> 
Import> Import PDF. 

You can also import a .pdf file by dragging it 
from an operating system window into the 
Home Designer Suite window.

The full Filename of the .pdf file 
displays here.  

• Click the Browse button to choose a new 
.pdf file or to relink to a missing file.

• Specify the Page of the .pdf file that dis-
plays in the preview on the right. Type a 

page number in the text field or use the 
arrow buttons to browse the pages 
sequentially.

A preview of the page selected above 
displays here.  

Note: Importing large, or multiple, .pdf files
into a plan or layout file can result in program
slowness. 

1

2
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Specify how much of the .pdf file you 
wish to Import. When multiple pages 

are imported, a separate PDF box is created 
for each one.
• Select Current Page to import only the 

page specified above and shown in the 
preview to the right. 

• Select Pages, then specify the starting 
page in the From field and the ending 
pgae in the To field. 

• Select All to import the entire .pdf file. 

PDF Box Specification Dialog
Select an imported PDF box and click 
the Open Object edit button to open 

the PDF Box Specification dialog. 

The settings in this dialog are similar to those 
on the Line Style panel in numerous other 

dialogs, with one exception: uncheck the 
Show Outline box to turn off the display of 
the PDF box’s border polyline.

See “Line Style Panel” on page 434.

Displaying Pictures, Metafiles, and PDF Boxes
The display of Pictures, Metafiles, and 
PDF Boxes is controlled in the 

Display Options dialog. See “Displaying 
Objects” on page 74.

Pictures, Metafiles, and PDF Boxes are 
placed on the “CAD, Default” layer.

Pictures, Metafiles, and PDF Boxes can be 
imported into and displayed in floor plan 
view. A Picture, Metafile, or PDF Box can 
only be seen in the view where it was 

imported and cannot be imported into a 
camera view or overview.

Drawing Groups
Imported pictures are placed in the Back 
Drawing Group, and imported metafiles and 
PDF Boxes are placed in the Default 
Drawing Group. See “Drawing Groups” on 
page 105. 

Editing Pictures, Metafiles, and PDF Boxes
Pictures, Metafiles, and PDF Boxes can be 
selected and edited using the edit handles, 
the edit toolbar, and their specification 
dialogs. 

In the Specification Dialog
Pictures, Metafiles, and PDF Boxes can be 
customized in their specification dialog. See: 
• “Picture File Box Specification Dialog” 

on page 455

3
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• “Metafile Box Specification Dialog” on 
page 456

• “PDF Box Specification Dialog” on page 
458

Using the Mouse
Pictures, Metafiles, and PDF Boxes have edit 
handles similar to other box-based objects. 
See “Editing Box-Based Objects” on page 
98. 
• The corner Resize handles behave do not 

behave the same for Pictures, Metafiles, 
and PDF Boxes as they do for CAD 
boxes, however. If you drag a corner han-
dle of one of these objects while the 
Default Edit Behavior is active, its con-
tents will resize and height to width ratio 
will be retained.

• If you drag an Extend handle along a 
Picture, Metafile, or PDF Box’s edge, the 
contents of the box will not be resized. If 
you resize it larger, an empty space will 
be created between that edge and the con-
tents; if you resize it smaller, the contents 
will be cropped.

To resize a picture or metafile

1. Find two items on the imported picture 
or metafile that are separated by a 

known horizontal or vertical distance, 
such as two walls or plot lines. 

2. Draw parallel CAD lines to represent 
these two items and use dimensions to 
position the lines so that they are the 
known distance between the two items 
in the imported picture. See “The CAD 
Drawing Tools” on page 431. 

3. Click and drag one of the imported pic-
ture’s corner edit handles to resize it 
concentrically until the two items are 
aligned with the two CAD lines. 

Using Dimensions
Pictures, Metafiles, and PDF Boxes can be 
relocated relative to other objects with 
precision using dimensions. 

To avoid changing the selected object’s 
aspect ratio, make sure you choose to move 
the entire object rather than the selected 
edge. See “Moving Objects Using 
Dimensions” on page 414.

Using the Edit Tools
A selected Picture, Metafile, or PDF Box can 
be edited in a variety of ways using the 
buttons on the edit toolbar. See “The Edit 
Toolbar” on page 26.

Copy Region as Picture
You can copy any portion of the 
screen and save it as a picture file 

using the Copy Region as Picture tool. See 
“Exporting Pictures” on page 454.

To use Copy Region as Picture

1. Open the view that you would like to 
copy all or part of as a picture.
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2. Select Edit> Copy Region as 
Picture . Your pointer displays a 
marquee  icon.

3. Click and drag a rectangular selection 
marquee around the desired region.

4. The selection is copied to the Windows 
clipboard.

• If the current view is vector-based, the 
Metafile Size dialog displays because 
metafiles are better suited for line-based 
pictures. See “Metafiles” on page 455.

• If the current view is a 3D view, the 
region is sent directly to the Windows 
clipboard.

5. From there, the picture can be pasted 
into another view or another program.

3D Backdrops
A backdrop is an image, typically of an 
exterior view, that displays in the background 
of 3D views to help place the model into a 
realistic setting and add a sense of 
perspective. 

A selection of backdrop images is available 
in the Library Browser. You can also create 
your own backdrop images and import them 
into the library. See “Adding New 
Backdrops” on page 350.

Backdrops automatically adjust to fit each 
view window, so they look best when they 
are created with a height to width ratio that is 
similar to the window you are working in.

Specifying a Backdrop
You can select a backdrop image for a plan 
from the library in either of two ways: 
• In any view, select 3D> 3D 

Backdrop  to open the Backdrop dia-
log. See “Backdrop Dialog” on page 382. 

• In a 3D view, open the Library Browser. 
Select a Backdrop image, then move your 
mouse pointer  into the view window. 
Click anywhere in the view to apply the 
selected backdrop. 

Regardless of how it is selected, only one 
backdrop can be used in a plan at any given 
time. If a backdrop is not applied, Home 
Designer Suite applies a background color. 

You can specify which view types and 
Rendering Techniques use the selected 
backdrop in the Backdrop dialog.

The backdrop in this view includes hills and clouds

You can create digital photos of a build-
ing site for use as a backdrop.
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Backdrop Specification Dialog
To open the Backdrop Specification 
dialog, select File> Import> 

Backdrop or right-click on the User Catalog 
in the Library Browser and select New> 
Backdrop from the contextual menu. See 
“Adding New Backdrops” on page 350.

You can also open this dialog by right-
clicking on a backdrop image in the User 
Catalog in the Library Browser and selecting  

Open  from the contextual menu.  

A preview of the selected image 
displays here. 
Backdrop - Specify backdrop’s Name 
and the image file associated with it.

• Type a Name for the selected backdrop, 
to be used in the Library Browser and 3D 
View Defaults dialog. 

• In the Location field, type the full path-
name of the image file or click the 
Browse button and browse to the file on 
your computer. 

If the selected image has a Copyright, 
information about it will display here. 

1

2

3
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Walkthroughs
A 3D Walkthrough is a series of 
pictures saved as an .avi file that can 

be played like a video by other applications 
such as Windows Media Player.

There are two approaches to recording a 
walkthrough of a plan: 
• Draw a path in floor plan view, then 

direct the program to record a walk-
through along that path.

• Create a 3D view, then begin recording 
and use the Move Camera tools to navi-
gate through the view. 

Create Walkthrough Path
There are several ways to record a 
walkthrough along a path, but the Create 
Walkthrough Path tool is the fastest and 
most flexible option. 

To create a Walkthrough Path

1. In floor plan view, select 3D> Walk-
throughs> Create Walkthrough 
Path , then click and drag to draw a 
Walkthrough Path. See “To use the 
Spline tool” on page 440.

2. Edit the direction and curvature of the 
spline’s segments, as needed. See “Edit-
ing Spline Based Objects” on page 100. 

3. Add Key Frames  to the path and 
modify their specifications.

4. Select the path and click the Record 
Walkthrough Along Path  edit but-
ton. See “Record Walkthrough Along 
Path” on page 463. 

You can also create a walkthrough based on a 
regular CAD polyline or spline by selecting 
it and clicking the Record Walkthrough 
Along Path  edit button. This was the only 
way to record a walkthrough along a path in 
Home Designer Suite versions and does not 
provide as many options as using a 
Walkthrough Path. 

Walkthrough Paths display in floor plan view 
when the “Walkthrough Paths” layer is 
turned on. When displayed, Walkthrough 
Paths display in front of other objects and 
will print. They are included in views 
exported to .dxf. See “Layers” on page 73. 

Key Frames
Key Frames are points along a Walkthrough 
Path that allow you to change: 
• Camera direction, tilt angle, and height; 
• Changes in walkthrough speed;
• The floor that the walkthrough is on. 

These changes are applied as the camera 
moves along the Walkthrough Path from one 
Key Frame to another.

To add a Key Frame to a Walkthrough Path, 
select the path and click the Add Key 
Frame  edit button. Then click on the 
path to add a Key Frame at that location.

Walkthrough Paths can follow stairs
and ramps to span multiple floors. See
“Walkthrough Paths and Stairs” on

page 463.
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In floor plan view, each Key Frame is 
represented by a camera symbol centered 
along the walkthrough path. It displays the 
frame number, is pointed in the direction of 
its Camera Angle, and its position along the 
path corresponds to the Time setting. 

Key Frame positions and other properties can 
be edited in the Walkthrough Path 
Specification dialog. See “General Panel” 
on page 466. 

You can also use the Edit Key Frames  
edit tool to enable Move and Rotate edit 
handles for each Key Frame on the selected 
Walkthrough Path. 

To use the Edit Key Frames edit tool

1. Select a Walkthrough Path and click the 

Edit Key Frames  edit tool.
2. Each Key Frame on the selected Walk-

through Path will display a Move and 
Rotate edit handle.

• Click and drag the square Move handle 
to reposition the Key Frame along the 
path.

• Click and drag the rectangular Rotate 
handle to change the Key Frame’s direc-
tion angle 

3. When you are finished adjusting the Key 

Frames, click the Main Edit Mode  
edit tool to restore the Walkthrough 
Path’s normal edit handles. 

Walkthrough Paths and Stairs
If you draw a Walkthrough Path up or down 
a staircase or ramp, it will follow the height 
of the stairs or ramp and continue on the next 
floor. 

To create a multiple floor walkthrough

1. Draw a Walkthrough Path so that it 
extends into a staircase or ramp in the 
same direction as its Direction Arrow. 
See “Displaying Stairs and Landings” on 
page 237.

• Do not drag the Walkthrough Path 
across the entire length of the stairs or 
ramp. If you do, its height will remain 
relative to the current floor.

2. When you  release the mouse button, the 
program will automatically display a 
dashed line with an arrow extending past 
the last Key Frame on the current floor.

• If it follows stairs or a ramp going 
upward, the path will also extend to the 
top end of the staircase or ramp.

3. Go up or down one floor, select the 
Walkthrough Path, and resize and 
reshape it as needed. You can use the 

Create Walkthrough Path  tool to 
draw more segments and additional Key 
Frames can be added, as well. 

Record Walkthrough Along 
Path

Once a Walkthrough Path has been drawn, 
you can use it to record a walkthrough video. 
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To record a walkthrough along a path

1. In floor plan view, select a Walkthrough 
Path or a CAD polyline or spline. 

2. Click the Record Walkthrough Along 
Path  edit button or select 3D> 
Walkthroughs> Record Walkthrough 
Along Path from the menu.

3. An Information message displays, 
reminding you that while a walkthrough 
is being recorded along a path, you 
should avoid using your computer. 

4. In the Save Video As dialog, specify a 
name and saved location for your .avi 
walkthrough file. See “Exporting Files” 
on page 43. 

5. In the Walkthrough Options dialog: 

• Specify the desired number of Frames 
Per Second, between 1 and 100. A 
higher number results in a higher quality 
recording but also a larger .avi file.

• Specify a Duration Along Path, in sec-
onds. 

• The Total Frames to Record displays 
for reference and equals the Frames Per 
Second times the Duration along Path.

• Specify a Compression percentage 
between 0 and 100. A value of 0 gives 
the highest quality images and largest 
file sizes.

• From the drop-down list, select the Ren-
dering Technique you would like the 
walkthrough to use. See “Rendering 
Techniques” on page 402.

• Click OK.

To cancel the recording as it is being created, 
press the ESC key on your keyboard.

Frame by Frame Walkthroughs
You can also create a walkthrough by 
recording it frame by frame. Although time-
consuming, creating a walkthrough in this 
manner lets you see exactly what is being 
recorded as you record it. 

To record a walkthrough frame by frame

1. Create a camera view. This view is the 
first frame of the walkthrough.

2. From the view, select 3D> Walk-
throughs> Record Walkthrough . 

3. Specify a location and name for the 
walkthrough in the Save Video As dia-
log and click Save. 

4. In the Walkthrough Options dialog: 

• Select a Frame Rate between 1 and 
100. The value entered is the number of 
frames per second. 
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• Select a Compression Percent between 
0 and 100. A value of 0 gives the highest 
quality images and the largest file size.

• Click OK.
5. Use the camera movement tools to cre-

ate additional views. Each time the 
screen redraws, that view is recorded as 
the next frame in sequence. See “Editing 
3D Views” on page 391.

6. To move the camera without saving a 
view, select 3D> Walkthroughs> Pause 
Recording  to temporarily stop 
recording. 

• You can then select 3D> Walk-
throughs> Save Frame  button to 
control what views are saved.

• You can start recording again by select-

ing Pause Recording  once more.

7. When the walkthrough sequence is com-
plete, select 3D> Walkthroughs> Stop 
Recording  or close the view.

If you resize the current view window while 
recording a walkthrough, the program will 
stop recording. 

To play a walkthrough

1. Select 3D> Walkthroughs> Play 
Walkthrough  to open the Select 
Video File dialog. 

2. Browse to an .avi file on saved on your 
computer. Your default video application 
plays the walkthrough video.

Walkthrough Path Specification Dialog
Select a Walkthrough Path and click 
the Open Object edit button to open 

the Walkthrough Path Specification dialog. 
See “Walkthroughs” on page 462. 

Note: Zooming in and out and using the scroll
bars does not change the viewpoint and does
not produce a frame for the walkthrough.
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General Panel

A list of the selected path’s Key 
Frames displays on the left. Click on a 

Frame in the list to select and edit it using the 
settings on the right. When the dialog is 
opened, the last key frame edited in the cur-
rent program session will be selected auto-
matically. See “Key Frames” on page 462. 
• Specify the Floor that the selected Key 

Frame is located on. See “Multiple 
Floors” on page 199.

• Specify the Time in seconds at which the 
selected Key Frame is found in the dura-
tion of the walkthrough. Frame 1 is 
always at 0.0 and cannot be moved; simi-
larly, the last frame is always at the end 
of the walkthrough Duration. 

• Specify the Speed After (ft/s), which is 
how fast the camera moves along the 
walkthrough path from the current Key 

Frame to the next. Not available if the 
last Key Frame is selected.

• Specify the Camera Angle at the 
selected Key Frame.

• Specify the Tilt Angle of the camera at 
the selected Key Frame.

• Specify the Height of the camera at the 
selected Key Frame.

• Click the Delete button to remove the 
selected Key Frame from the path.

• Specify the Key Frame Symbol Size, 
which is the size of the symbols repre-
senting the selected walkthrough path’s 
Key Frames in floor plan view. See “Key 
Frames” on page 462. 

Walkthrough Options - 

1

2
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• Specify the Duration, or total length of 
the walkthrough video in seconds.

Specify how Camera Angles are measured:
• Select Relative to Path to measure each 

camera angle relative to the direction of 
the walkthrough path at each Key Frame 
location. 

• Select Absolute to measure each camera 
angle relative to the plan’s X, Y, and Z 
axes. See “3D Drafting” on page 21.

Specify how Camera Height is measured: 

• Select Relative to Floor/Terrain to mea-
sure camera height relative to the floor or 
terrain at each Key Frame location. 

• Select Absolute to measure camera 
height relative to the plan’s Z axis. 

Polyline Panel
The Polyline panel indicates the path’s 
Length/Perimeter. The Area and Volume 
of a walkthrough path will always be 
described as “Not closed”. See “Polyline 
Panel” on page 438. 

Line Style Panel
This panel is similar to the Line Style panel 
in the Line Specification dialog. See “Line 
Style Panel” on page 434.

Note: When Relative Angles are used, a
Camera Angle of 0° points in the direction of
the walkthrough path. When Absolute Angles
are used, 0° always points in the positive
direction along the X axis. 

home-designer-suite-2015-reference-manual.book  Page 467  Thursday, May 29, 2014  4:26 PM



468

Home Designer Suite 2015 Reference Manual

home-designer-suite-2015-reference-manual.book  Page 468  Thursday, May 29, 2014  4:26 PM



 469

Chapter 34:

Importing and
Exporting

Importing is the process of opening a file that 
was produced in a different program in 
Home Designer Suite. Exporting, on the 
other hand, is the process of saving 
information in a Home Designer Suite file to 
a format that can be read by another 
program. 

Home Designer Suite allows you to import 
and export a variety of information from and 
to other applications. This chapter focuses on 
importing and exporting 2D .dxf files and a 
variety of 3D file formats. Other importing 
and exporting options are described in the 
chapters in which those objects or settings 
are discussed. 

Chapter Contents
•      Import Room Planner File
•      DXF File Format
•      Exporting 2D DXF Files
•      Additional 2D Export Information
•      3D Data Import Requirements
•      Importing 3D Symbols
•      3D Symbols and Materials
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Import Room Planner File
Select File> Import> Import Room 
Planner File, then log in to your 

account on the Chief Architect web site to 

select and download a Room Planner 2.0 and 
higher file from the cloud. 

DXF File Format
.dxf (Drawing eXchange Format) is a 
standard file format created by Autodesk for 
the transfer of data between other programs.

Many design programs can read and write 
.dxf files. The .dxf file format interprets data 
as CAD objects such as lines, polylines, and 
circles. 

Exporting 2D DXF Files
Line-based 2D files can be exported from 
Home Designer Suite in .dxf file format. You 
can specify the version of AutoCAD® to 
export to. Compatibility with other software 
may vary.

There are two ways to export a 2D drawing 
file in Home Designer Suite: Export Current 
View and Export All Floors.

Export Current View
To export a floor plan view that is 
currently active, select File> Export> 

Current View (DXF). 

Export All Floors
To export the floor plan view for all 
floor plans simultaneously, select 

File> Export> All Floors  (DXF) from any 
floor of the plan. The floor plans are 
exported to a single .dxf file.

If you choose to export all floors, the file will 
contain all floors superimposed on each 
other. Upon export, each layer in your Home 
Designer Suite drawing is divided into 
separate layers: one for each floor. For 
example: “Electrical-2” contains objects on 
Floor 2 that were originally on the 
“Electrical” layer.

Export Drawing File Dialog

Specify which Compatible Version of 
AutoCAD® you want your .dxf file to be 
compatible with.

Click the Export button to save the exported 
file as a .dxf file. See “Exporting Files” on 
page 43.
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Additional 2D Export Information
The export process converts high level Home 
Designer Suite objects (doors, windows, etc) 
into simple, CAD-based objects (lines, arcs, 
etc). Home Designer Suite exports all data to 
AutoCAD®’s Model Space. 

Supported Entities
The following entity types are currently 
supported for 2D export:

Line - The simplest entity. In AutoCAD®, 
lines are 3 dimensional with the Z coordinate 
set to zero.

Arc - Arcs have a start angle, end angle and 
radius. 

Circle - Fully Supported.

Multi Line Text - If exporting to an 
AutoCAD® release that supports multi-line 
text, Home Designer Suite writes the file as 
multi-line text. If exporting to a version that 
does not support multi-line text, the file is 
written as simple text. 

Polylines - Polylines are a collection of 
points with lines or arcs connecting them. 
Home Designer Suite supports both lines and 
arcs. Arcs are referred to as bulges in 
AutoCAD®.

Block Insert - A block insert is a reference 
to a block, which is a named collection of 
entities. A block can also contain block 
inserts. 

Dimensions
Each dimension has an associated block 
containing a representation of the dimension 

as it is drawn in Home Designer Suite. It also 
contains all the data to recreate that 
information.
• When an exported dimension is modified 

in AutoCAD® or other CAD program, its 
appearance changes. 

• Home Designer Suite does not support 
arrowhead styles or fonts.

• Three kinds of dimensions are generated: 
Aligned, Rotated and 3 Point Angular. 

• Please refer to AutoCAD® documentation 
for more information.

Layers
Layers in other systems are similar to Home 
Designer Suite layers, but there are some 
subtle differences. Layer information is 
mapped as follows:

Note: Uncheck “Use Associative Dimensions” 
in the Export Drawing File dialog if the CAD 
program you are using does not support 
AutoCAD® Associative dimensions. See 
“Export Drawing File Dialog” on page 470.

Home 
Designer 

Suite

Other Systems

Name Name

Color Nearest AutoCAD® Color. Home 
Designer Suite uses the default 
AutoCAD® color table to deter-
mine this mapping.

Display On

home-designer-suite-2015-reference-manual.book  Page 471  Thursday, May 29, 2014  4:26 PM



472

Home Designer Suite 2015 Reference Manual

Line Types
A line type, or line style, is used by layers 
and entities to determine how lines are 
drawn. Home Designer Suite line types 
installed with the program are supported on 
export.

3D Data Import Requirements
Importing a symbol that can be used by 
Home Designer Suite is a relatively simple 
process that begins with previously created 
3D data. This 3D data often comes from a 
program other than Home Designer Suite. If 
you use another 3D modeling program to 
create the 3D data, be aware of the following 
requirements before attempting to create 
symbols.

There are a number of requirements that 
must be met before any 3D data can be used 
to create a symbol in Home Designer Suite:
• The 3D data must be stored in an, object 

(.obj), 3D Studio® Mesh (.3ds) , or 
SketchUp version 8 and prior (.skp) file 
format. If you have 3D data in another 
format, you must convert it into one these 
formats first.

• Geometry and material information stored 
in .3ds files are imported; cameras and 
lights are not.

• The 3D model must be composed of 
3DSOLID solid entities, or face data. 
Faces are typically referred to as 3D 
faces, polygonal faces, or poly meshes. 
Other types of entities such as lines, 
curves, circles, polylines, and free form 
surfaces can exist in the file but are not 
imported when the symbol is created. 
This is true for all (.obj/.3ds/.skp) file 
types.

• The face data should be assigned to dif-
ferent layers so that you can map them to 
the correct materials when viewing them 
in 3D. It is helpful to name your layers 
using a convention that identifies that 
materials should be assigned to each sub-
component.

• Pay attention to the origin and orientation 
of the 3D data when designing symbols. 
Home Designer Suite allows some adjust-
ment when creating the symbol, but it is 
easier to build the 3D data correctly 
before importing it into Home Designer 
Suite. For more information about defin-
ing the origin, see “Symbol Origin” on 
page 71.

Size Line Weight. In AutoCAD®, line 
weights are determined by a 
table of mm line widths. Home 
Designer Suite maps to the clos-
est match in this table based the 
current view’s Line Weight Scale. 
See “Drawing Sheet Setup Dia-
log” on page 479.

Style Line type

Lock Lock

Home Designer Suite is not able to pro-
vide support for any third party soft-

ware.

home-designer-suite-2015-reference-manual.book  Page 472  Thursday, May 29, 2014  4:26 PM



Importing 3D Symbols

 473

• If a symbol with faces that have more 
than four vertices is imported, the faces 
are truncated, resulting in an object that 
appears to have holes. The best remedy is 
to re-export the model from the original 
application using only triangular or quad-
rilateral faces.

• Home Designer Suite does not support 
grouped objects in symbols imported 
from .3ds files. 

Surface Normals
If you use third party software to create a 
.dxf /.obj/.3ds./skp files that will be 
imported as a symbol, you should be familiar 
with the concept of surface normals.

If you use third party software to create an 
.obj/.3ds./skp file that will be imported as a 
symbol, you should be familiar with the 
concept of surface normals.

A surface normal is a vector that is 
perpendicular to the plane of a surface. This 
vector points in one direction, determined by 
the way the face is drawn.

If a face is drawn clockwise, the surface 
normals are directed outward; if a face is 
drawn counter-clockwise, the surface 
normals point inward. Home Designer Suite 
assumes that the face on the positive side of 
the normal vector is the outside face.

Many objects can be drawn using only one 
side of each face. A cube is a good example: 
the inside of a cube is not visible, so it is not 
necessary to create its inside faces. When 
inside faces are not calculated, 3D views in 
Home Designer Suite can generate more 
quickly. 

Importing 3D Symbols
Home Designer Suite supports the 
import of 3D surface and 3D solid 

objects saved in .3ds, .obj, and .skp formats.

There are two ways to import a 3D symbol 
into Home Designer Suite:
• By dragging and dropping the file from an 

operating system window into floor plan 
view. 

• Using the Import 3D Symbol  tool.

Symbols imported by clicking and dragging 
are imported for use in the current plan, 
while those imported using the Import 3D 
Symbol dialog are also saved in the library. 
See “The Library” on page 341. 

To drag and drop a 3D symbol file

1. Open the plan in which you would like 
to import a 3D symbol and remain in 
floor plan view.

home-designer-suite-2015-reference-manual.book  Page 473  Thursday, May 29, 2014  4:26 PM



474

Home Designer Suite 2015 Reference Manual

2. Open an operating system window in 
front of the Home Designer Suite pro-
gram window.

3. Resize and position the window so that 
the Home Designer Suite program win-
dow can be seen behind it.

4. Click on the desired  .3ds, .obj or .skp 
file and drag it into the Home Designer 
Suite program window.

5. When your cursor changes to a  +, click 
in the drawing area to place as many 
copies of the symbol as desired. When 
you are finished, select a different tool. 

Import 3D Symbol Dialog
Select File> Import> 3D Symbol to 
open the Import 3D Symbol dialog. 

The Import 3D Symbol File dialog is a 
typical Open File dialog in which multiple 
files can be group-selected for import. See 
“Importing Files” on page 47.

The Import 3D Symbol dialog, which opens 
next, allows you to specify additional 
information about the symbol.

Home Designer Suite supports the import of 
3D surface and 3D solid objects saved to 
.3ds, .obj and .skp formats. Home Designer 
Suite treats imported symbols as stand alone 
fixtures.

3D Symbols and Materials
When a symbol is imported into Home 
Designer Suite, material definitions may be 
included with it. How material information is 
included depends on the symbol’s file 
format. See “About Materials” on page 361. 

OBJ Files

Material definitions for most .obj files are 
saved in a separate file with the .mtl file 
extension. If such a file exists, the materials 
associated with the .obj file display in the list 
on the left side of the Materials panel of its 
specification dialog. 

If Home Designer Suite does not receive 
material definition information in an 
accompanying .mtl file, default material 
properties are assigned. 

Material definitions for .obj files can also 
include texture information in the form of 
image files (.jpg, .png, etc). 

In order to properly import an .obj file, 
Home Designer Suite needs the .obj file, the 
.mtl file, and any referenced texture files. If a 
texture file is not available, the material it is 
associated with is created without a texture.

The material definitions associated with an 
imported .obj symbol are not available for 
use by other objects in Home Designer Suite 
until that symbol has been placed into a plan. 
The associated texture files are then copied 
to the user’s Textures folder. See “Home 
Designer Suite Data” on page 39.  

Note: SKP files are always imported using 
inches, regardless of the default units used in 
the plan file. See “Creating a New Plan” on 
page 40.
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3DS and DAE Files

Material definitions for .3ds files refer to 
texture information in separate image files.  

In order to properly import a .3ds file, Home 
Designer Suite needs these referenced image 
files. If a texture file is not available, the 
material it is associated with will be created 
without it. The associated texture files are 
copied to the user’s Textures folder. 

SKP Files

The textures associated with a .skp file are 
saved in the file. After you import a symbol 
and either place it in a plan or add it to the 
Library, these textures are saved in the Home 
Designer Suite Textures folder. 

Home Designer Suite does not support 
deformed textures. If a texture associated 
with a .skp file is deformed, it will be 
imported without the deformations. 

Texture Filename Conflict
If a texture of the same name already exists 
in the plan when an .obj, .3ds  or .skp file is 
imported, the Texture Filename Conflict 
dialog displays. 

• Select Rename the imported texture, 
then click the Browse button to create a 
copy of the texture’s image file with a 
new name that you specify. 

• Select Use the existing texture instead 
of the imported texture to keep the 
existing texture.

• Select Replace the existing texture with 
the imported texture to replace the tex-
ture already present in the plan with the 
new, imported one.

• Check Do this for all remaining textures 
in this object to use the same selection 
for all textures with filename conflicts 
associated with this symbol. 
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Chapter 35:
Chapter 35:

Printing

Home Designer Suite provides a variety of 
printing options, from printing scaled plan 
views and 3D perspectives, to a set of 
templates that can be assembled into a 3D 
model.

Home Designer Suite also allows you to save 
your drawings in .pdf file format that can 
then be sent to a printing service.

Chapter Contents
•      Introduction to Printing
•      The Printing Tools
•      Drawing Sheet Setup Dialog
•      Print Preview
•      Printing to Scale
•      Printing Across Multiple Pages
•      Printing to a PDF File
•      Print View Dialog
•      Print Image Dialog
•      Print ModelNote: Screen captures are provided for

illustrative purposes only and are not an
endorsement of any products.
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Introduction to Printing
Home Designer Suite offers printing options 
to suit a variety of needs. It is helpful to be 
familiar with these options and choose the 
one that makes the most sense for the project 
at hand.

Output Options
Printing a View - Floor plan and elevation 
views can be printed to scale. See “The 
Printing Tools” on page 479.

Printing an Image - Any view of your plan 
can be printed as an unscaled image. See 
“Print Image Dialog” on page 486. 

Printing to PDF - Plans can be printed to a 
.pdf file and printed remotely. See “Printing 
to a PDF File” on page 483.

Print Model - Creates a set of templates that 
can be used to create a 3D model of your 
design. See “Print Model” on page 487.

Terminology
Paper Size - The dimensions of the paper to 
be printed on. Specifying a paper size that is 
smaller than the scaled drawing allows large 
drawings to be printed across multiple pages.

Drawing Scale - Drawings are often printed 
to scale for accuracy. ¼" = 1' and 1 m = 50 m 
are examples of common scales. You can 
specify this scale in the Drawing Sheet 
Setup dialog. See “Drawing Sheet Setup 
Dialog” on page 479. 

When a particular scale is not important, 
drawings can also be sized to fill a particular 
area. See “Printing to Scale” on page 481.

Printing Problems
If you encounter difficulties when trying to 
print, see “Troubleshooting Common 
Technical Issues” on page 504.

Printer Drivers
A printer driver is a program that allows a 
printer to communicate with the rest of the 
computer system. Drivers are usually created 
by the printer manufacturer, are typically 
updated regularly, and can usually be 
downloaded free of charge from the 
manufacturer’s web site. 

In addition to interpreting between the 
printer and the rest of the system, printer 
drivers save default page size, orientation, 
margin size, and other information that 
Home Designer Suite refers to unless you 
specify otherwise. See “Print View Dialog” 
on page 483.

If you experience printing problems, 
consider installing updated drivers for your 
printer. Visit your printer manufacturer’s web 
site for more information. 

Clearing Printer Information
Some information specific to individual 
printers, such as available paper sizes, is 
saved with each plan file. You can select 
File> Print> Clear Printer Info to clear the 

Options available with one driver may
not be available with another. Printers

supported in one operating system may not
be supported by the manufacturer in another.
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printer-specific information stored with the 
plan file.

Displaying Objects
You can control the display of objects 
when printing directly from a view in 

the Display Options dialog. See “Display 
Options Dialog” on page 75.

Objects must be visible in order for them to 
print; however, not all items that are visible 
will print. See “Print Preview” on page 481.

The Printing Tools
Select File> Print to view the Print 
Tools submenu. These tools fall into 

two categories. 

Print Setup Tools
Drawing Sheet Setup - Opens the 
Drawing Sheet Setup dialog. See 

“Drawing Sheet Setup Dialog” on page 479.

Scale to Fit - Automatically selects a 
scale that fits your plan to the printer 

page. See “Printing to Scale” on page 481.

Center Sheet - Automatically centers 
the drawing sheet on your drawing. 

See “Center Sheet” on page 481.

Print Preview - Shows on screen how 
the current view will appear printed, 

based on the current scale and other settings. 
See “Print Preview” on page 481.

Print Tools
Print - Prints the current floor plan to 
a specified scale. See “Print View Dia-

log” on page 483.

Print Image - Prints the current view 
including images, textures, and 

backdrop. Views printed with Print Image 
are not scaled. See “Print Image Dialog” on 
page 486.

Print Model - Opens the Print Model 
dialog, allowing you to print templates 

for making a physical model of your plan. 
See “Print Model” on page 487.

Clear Printer Info - Clears the printer 
information associated with the current page 
setup.  

Drawing Sheet Setup Dialog
Select File> Print> Drawing Sheet 
Setup to open the Drawing Sheet 

Setup dialog. 

The Drawing Sheet Setup dialog is only 
available when floor plan view or an 
Elevation view is active. When a perspective 

home-designer-suite-2015-reference-manual.book  Page 479  Thursday, May 29, 2014  4:26 PM



480

Home Designer Suite 2015 Reference Manual

view is active, Drawing Sheet Setup  is 
not available. 

The settings in this dialog are specific to the 
current floor plan view and are saved with 
the .plan file.. 

Specify the Orientation and Size of the 
Drawing Sheet, which is the final 

printed output. 

Specify the Drawing Scale for the 
active view. This scale is applied only 

when the view is printed. 

The scale is specified in two parts, which by 
default are ¼ inch = 1 ft or 1 m = 50 m. Both 
imperial and metric units of measurement are 
available and can be selected independently. 

Specify the Drawing Margins. which 
define the extents of the printable area 

of the active view’s Drawing Sheet. 
• Specify the width of the desired Top, 

Left, Right, and Bottom margins.

Clearing Printer Information
Select File> Print> Clear Printer Info to 
clear the printer-specific information stored 
in the Drawing Sheet Setup dialog. 

Print Preview
Print Preview and its related display 
toggles allow you to get a sense of 

what the current view will look like when it 
is printed. 

1

2

3
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Print Preview
Select File> Print> Print Preview for 
an on-screen representation of how 

the current view will appear when printed. 
Print Preview is only available in floor plan 
view. See “Printing to Scale” on page 481.

The printer page displays as a solid white 
rectangle, and blue lines along the edges of 
the printer page indicate the edges of the 
printable area, as defined by the currently 
selected printer. See “Drawing Sheet Setup 
Dialog” on page 479.

Objects such as camera symbols, and the 
Reference Grid that do not print do not 

display in Print Preview . Text and 
dimension objects appear on-screen as they 
will on the printed page.

When Print Preview  is enabled, color 
will display depending on whether Print in 
Color is selected in the Print View dialog. 
See “Print View Dialog” on page 483. 

The Reference Display does print if it is 
visible. See “Reference Floor Display” on 
page 205. 

Color
The Color toggle turns the on-screen display 
of color on or off in all views. 

Reference Grid
The Reference Grid is an on-screen grid 
composed of regular squares that can be used 
to convey a sense of scale while drawing.  It 
does not print, and its size can be specified in 
the General Plan Defaults dialog. See 
“General Plan Defaults Dialog” on page 57.  

Center Sheet
Select File> Print> Center Sheet to 
center the printer page on the drawing. 

This moves the printer page relative to the 
drawing but does not affect the coordinates 
of objects in the drawing. The location of the 
printer page is independent for each floor of 
the model.

Printing to Scale
Several different print scaling options are 
available. The type of view that you are 
printing determines which options you may 
choose from.

Orthogonal Views
Floor plan  views are orthogonal views, 
which means: 
• Your line of sight is at a right angle to all 

objects in the view. 

• Objects do not appear to decrease in size 
as their distances from the viewer 
increase.

Orthogonal views can be printed to scale.

The scale set in the Page Setup dialog is 
inherited by the Print dialog. This scale can 
be overridden on an individual basis in the 
Print dialog. See “Print View Dialog” on 
page 483. 
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Select File> Print> Scale to Fit  in an 
orthogonal view to select a suitable scale and 
re-center the printer page so that everything 
fits on the page.

Imperial drawing scales are typically noted 
in inches per foot. Larger scales, such as 1 
inch = 50 feet or 1:200m, are often used for 
property layouts.

Perspective Views
Camera views and overviews display the 
model much the way the eye would see it and 
cannot be scaled.
• Objects in the view may be at any angle 

relative to your line of sight. 
• Objects seem to decrease in size as their 

distances from the viewer increase.

Perspective views can only be printed using 

the Print Image  tool. See “Print Image 
Dialog” on page 486.

Printing Across Multiple Pages
When printing directly from a floor plan 
view it is possible to print at a scale that does 
not fit the drawing on one page.

To see on-screen what the drawing will look 
like when printed, select File> Print> Print 
Preview  and then Window> Fill 
Window . Grey lines across the drawing 
sheet  indicate where the page breaks will 
occur. See “Print Preview” on page 481.

To print across multiple pages

1. Select File> Print> Print Preview  
to display the white rectangle represent-
ing the printer paper. See “Print Pre-
view” on page 481.

2. Click the Select Objects  button, 
then click near an edge of the printer 
paper rectangle to select it. 
When selected, the printer paper is 
highlighted in pale grey and a square 
Move edit handle displays at its center.

3. Click and drag the Move edit handle to 
position the printer paper so that the por-
tion of your drawing that you would like 
to print on your first page is located 
within the printable area of the page. 

4. Select File> Print> Print . In the 
Print dialog, make sure To Scale is 
selected, then click OK. See “Print View 
Dialog” on page 483.

5. Select the printer paper rectangle and 
move it so that the desired contents of 
your second printed page are within the 
printable area and print To Scale.

6. Continue moving the printer paper and 
printing as needed.

When printing multiple pages, it is generally 
a good idea to leave some overlap on the 
edges of each page to make sure that 
information near those edges is not left off 
the printed pages by mistake. 
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Printing to a PDF File
Portable Document Format, or .pdf files, are  
one of the most universally compatible and 
efficient file formats and can be viewed and 
printed on most computer platforms. 

You can save any view as a .pdf file by 
selecting Save as PDF as the Destination 
printer Name in either the Print View or 
Print Image dialog. See “Print View Dialog” 
on page 483 and “Print Image Dialog” on 
page 486. 

If you have a .pdf writer installed on your 
system, you can use it to create a .pdf file 
instead. To print to .pdf, simply select it as 
your printer in the Print View or Print Image 
dialog. 

When you either save as or print to .pdf, you 
will be asked to create a file name and 
choose a destination automatically. For more 
information, see “Saving, Exporting, and 
Backing Up Files” on page 41.

Print View Dialog
To print from floor plan view and the 
Materials  List, select File> Print> 

Print. The Print View or or Print Materials 

List dialog opens. The settings that are 
available will vary depending on which 
version of the dialog is open. 
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Select the Name of the Printer that you 
would like to use from the drop-down 

list. To print to .pdf, select “Save as PDF” 
from the list, or choose a .pdf writer installed 
on your system. See “Printing to a PDF File” 
on page 483. 
• Select the DPI, or Dots Per Inch to use 

when printing, from the drop-down list. 

The available options may vary depend-
ing on the selected printer.

Select the Paper Orientation, Size, 
and Source. The available Size and 

Source options are controlled by the selected 
printer’s driver.

Note: 3D views can be printed using Print
Image.

1

2
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• When possible, the program will auto-
matically set the Size and Orientation to 
match those of the Drawing Sheet.

Specify the Print Source. Not available 
in the Print Materials List dialog.

• Select Drawing Sheet to print the entire 
sheet even though you may be zoomed in 
on a portion of the view. 

• Select Current View to print only that 
portion of the active view that is currently 
visible on screen. If you are zoomed out, 
any blank space outside of the printable 
objects in the view is ignored. 

Specify the Drawing Scale of the 
printed output. Not available in the 

Print Materials List dialog or in camera 
views or overviews. 
• Fit to Paper prints the view on one page. 

The program uses whatever scale is nec-
essary to fit the plan on one page. 

• When Fit to Paper is selected, specify 
the percentage of the paper to be used. 
The default value is 95%.

• Select To Scale to print at the scale speci-
fied in the Drawing Sheet Setup dialog. 
See “Drawing Sheet Setup Dialog” on 
page 479.

Options - Specify the number of Cop-
ies you would like to print. 

Advanced Options - Click the Open 
System Print Dialog button to close 

the Print View dialog and print using your 
operating system’s Print dialog instead. Not 
available when No Printer is selected.

Control the appearance of the print job 
Preview on the right side of the dialog.

• Specify the Page that displays in the Pre-
view area.

• Click the buttons to Zoom In, Zoom 
Out, or Fit the selected Page to the 
extents of the Preview area. 

• Uncheck Update Automatically to turn 
off the print job Preview and prevent it 
from updating as changes are made to the 
settings in this dialog. 

• Click the Update button to update the 
print job Preview to reflect the current 
settings in this dialog. If Update Auto-
matically is unchecked, clicking Update 
may force the Preview to be blank.

When Update Automatically is 
checked, a preview of the current print 

job displays here. The drawing sheet displays 
as a white rectangle, and if multiple sheets 
are required, you can scroll through them. If 
the print job is large, a progress dialog may 
display briefly as the preview draws or 
updates.

To help prevent unwanted printed 
output, information messages regarding 

page size, resolution, and scale may display 
here, depending on the settings in this dialog. 

Note: The Fit to Paper percentage value is
global - affecting all views in all files, and is
retained between sessions.

3

4

5

6

7

8

9
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Print Image Dialog
Any view can be printed by selecting 
File> Print Image. This is the only 

way to print 3D views. See “3D Rendering” 
on page 399.

The Print Image dialog is similar to the Print 
View dialog; however, the printing process is 
different. Print Image prints individual 
pixels as opposed to vectors (lines).

Select the Name of the Printer you 
wish to use from the drop-down list. To 

print to .pdf, select “Save as PDF” from the 
list, or choose a .pdf writer installed on your 
system. See “Printing to a PDF File” on page 
483.

Select the Paper Orientation, Size, 
and Source. The available Size and 

Source options are controlled by the selected 
printer’s driver. See “Printer Drivers” on 
page 478.

Specify the number of Copies you 
would like to print. 

Advanced Options - Click the Open 
System Print Dialog button to close 

the Print View dialog and print using your 
operating system’s Print dialog instead. Not 
available when No Printer is selected.

Control the appearance of the print job 
Preview on the right side of the dialog.

• Specify the Page that displays in the Pre-
view area.

• Click the buttons to Zoom In, Zoom 
Out, or Fit the selected Page to the 
extents of the Preview area. 

1

2

3

4

5
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• Uncheck Update Automatically to turn 
off the print job Preview and prevent it 
from updating as changes are made to the 
settings in this dialog. 

• Click the Update button to update the 
print job Preview to reflect the current 
settings in this dialog. If Update Auto-
matically is unchecked, clicking Update 
may force the Preview to be blank.

When Update Automatically is 
checked, a preview of the current print 

job displays here. If the print job is large, a 
progress dialog may display briefly as the 
preview draws or updates.

To help prevent unwanted printed 
output, information messages regarding 

page size and resolution may display here, 
depending on the settings in this dialog. 

Print Model
The Model Maker allows you to print 
scaled drawings of wall and roof 

surfaces in your plan that can be assembled 
into a 3D model. Three types of prints are 
created: walls, roof planes, and a.floor plan 
wall layout template.

Printing the Model
To print the model templates, choose File> 
Print> Print Model . The Print Model 
dialog opens.

A good way to understand which options 
best meet your needs is to make a very 
simple two story plan and try them out.

6

7
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Print Model Dialog

Select the Name of the Printer that you 
would like to use from the drop-down 

list.  To print to .pdf, select “Save as PDF” 
from the list, or choose a .pdf writer installed 
on your system. See “Printing to a PDF File” 
on page 483

Select the Paper Orientation, Size, 
and Source. The available Size and 

Source options are controlled by the selected 
printer’s driver. See “Printer Drivers” on 
page 478.
• Larger page sizes and Landscape orienta-

tion are usually best for Print Model. 
• Select All to print the entire drawing. 

Options -  
 

• Specify the Floor Thickness, which is 
the thickness of the material you plan to 
use for the model’s floor platform. 

• Specify the Scale to be used when print-
ing the model. 

• Specify the number of Copies to be 
printed. 

• Check Print in Color to print in color.

Advanced Options - Click the Open 
System Print Dialog button to close 

the Print Model dialog and print using your 

1

2

3

4
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operating system’s Print dialog instead. Not 
available when No Printer is selected. 

Control the appearance of the print job 
Preview on the right side of the dialog.

• Specify the Page that displays in the Pre-
view area.

• Click the buttons to Zoom In, Zoom 
Out, or Fit the selected Page to the 
extents of the Preview area. 

• Check Update Automatically to have 
the print job Preview display and update 
as changes are made to the settings in this 
dialog. This is not unchecked by default 
because updating the Preview in the Print 
Model dialog can be time-consuming. 

• Click the Update button to update the 
print job Preview to reflect the current 
settings in this dialog. If Update Auto-
matically is unchecked, clicking Update 
may force the Preview to be blank.

A preview of the current print job 
displays here. The drawing sheet for 

each page displays as a white rectangle, and 
you can scroll through the pages. If the print 
job is large, a progress dialog may display 
briefly as the preview draws or updates.

To help prevent unwanted printed 
output, information messages regarding 

page size and resolution may display here, 
depending on the settings in this dialog. 

Assembling the Model
Once the templates have been printed, they 
can be assembled. You need scissors, an 

adhesive, and a rigid material like cardboard 
or foamboard that can be easily cut and glued 
to provide support for the 3D model.

The Model Maker produces templates of 
wall and roof surfaces in the model, but does 
not include tabs or other means of connecting 
them together. If you wish, you can leave 
extra paper beyond the template edges as you 
cut them out for use assembling the model. 

Wall Layout Template

Begin by laying out the Wall Layout 
template. If it printed on multiple sheets, they 
should be combined into one. Make sure that 
exterior and interior wall surfaces line up 
where the sheets join together.

Fasten the Wall Layout Template to a sturdy 
surface to provide support for your walls.

Walls

Walls should be cut and fixed to a rigid 
backing so that they can stand on their own 
and support the weight of the roof or floors 
above them. How they are cut and assembled 
varies depending on the desired final 
appearance of the model and how they were 
printed. 

Roofs

Roof planes are joined together when 
possible before printing. For each roof 
surface, the fascia and soffit surfaces are 
attached at the eave. 

5

6

7
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Chapter 36:

Materials Lists

Home Designer Suite can calculate a 
Materials List in three ways: From All 
Floors, From Area, or From Room.

Materials Lists can be created, edited, and 
printed directly from the program. They can 
also be exported as text files for use in other 
programs.

Chapter Contents
•      The Materials List Tools
•      Creating an Accurate Materials List
•      Structural Member Reporting
•      Organizing Materials Lists
•      Materials List Display Options Dialog
•      Editing Materials Lists
•      Printing and Exporting the Materials List
•      Conditioned Area Totals

The Materials List is based on certain 
assumptions that may not match your 

building style. Home Designer Suite makes no 
representation as to the accuracy or reliability 
of the Materials List generated by Home 
Designer Suite. Always compare the Materials 
List with a manual take-off before providing a 
quote or ordering materials for a job. 
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The Materials List Tools
Select Tools> Materials List to 
access the Materials List tools.

A Materials List is like a snapshot of the 
current plan at the time that the list is made. 
Any changes made to the model after a 
Materials List is generated are not included 
in that list. Create a new Materials List if you 
would like it to include these changes. 

It is not necessary to wait until the plan is 
complete to generate a Materials List. In fact, 
you can create a series of Materials Lists 
reflecting costs at various stages of a project.

Calculate from All Floors
Select Tools> Materials List> 
Calculate From All Floors to 

generate a Materials List for the entire 
model.

Materials lists calculated from all floors can 
be lengthy, and only a portion of the list may 
display on your screen at one time. Use the 
scroll bars to scroll through the complete list. 
Move the pointer to cells in the list and click 
to make changes. 

Calculate From Area
In floor plan view only, select Tools> 
Materials List> Calculate from 

Area to produce a Materials List for the 
portion of a plan on a single floor that is 
included within a temporary rectangular 
Materials Polyline. 

To use Calculate from Area

1. In floor plan view, select Tools> Mate-
rials List> Calculate from Area . 

2. Click and drag a rectangle around the 
area of the current floor that you would 
like to produce a Materials List for. 

3. When the mouse button is released, a 
Materials List for the area within the 
rectangle will display. 

Calculate From Area rectangles are 
temporary and do not display in floor plan 
view after the list is created.

Calculate From Room
To create the Materials List for a 
room, select the room, then select 

Tools> Materials List> Calculate From 
Room. 

Calculate From Room  is also available 
on a selected room’s edit toolbar. See 
“Editing Rooms” on page 146. 

A Materials List calculated from a room is 
created for only the contents of that room: 
wall materials are not included.

For comparison, generate Materials Lists 
with and without a proposed plan modifi-

cation.
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Creating an Accurate Materials List
In order to take full advantage of Home 
Designer Suite’s Materials List capabilities, 
there are several things to keep in mind. 
• The accuracy of your Materials List is 

directly related to the accuracy of your 
model. Floor and ceiling heights, wall 
lengths, and structural settings all directly 
affect Materials List calculations.

• It takes more than just making your draw-
ing look right to generate an accurate 
Materials List. If, for example, you use 
CAD lines to draw an item on a floor 
plan, that item will not be included in the 
Materials List. A better way would be to 
use a symbol or structural element. See 

“Architectural vs CAD Objects” on page 
78.

• Bear in mind that using generic objects 
like geometric shapes from the library to 
represent objects that aren’t available in 
Home Designer Suite can result in items 
being calculated in the Materials List in a 
manner that you might not expect.

Framing in the Materials List
You can specify whether framing materials 
are calculated by lineal foot, as a cut list, or 
as a buy list in the Structural Member 
Reporting dialog.

Structural Member Reporting
The Structural Member Reporting dialog 
allows you to specify the method used to 
calculate framing members in the Materials 
List.  

To open the Structural Member Reporting 

dialog, select Edit> Default Settings , 
then select “Structural Member Reporting” 
from the tree list and click the Edit button. 
See “Default Settings vs Preferences” on 
page 56. 

You can create a list of the framing member 
sizes that you wish to purchase, and if an 
item in The Materials List is the same length 
as or shorter than one of these defined 
lengths, it will be described using the defined 
length rather than its actual length. 

home-designer-suite-2015-reference-manual.book  Page 493  Thursday, May 29, 2014  4:26 PM



494

Home Designer Suite 2015 Reference Manual

Structural Member Reporting Dialog

Choose a Materials List Report Method. 
The selected method will affect subsequently 
created Materials Lists, but not any that may 
already exist. 
• Select Mixed Reporting to calculate 

framing materials using a combination of 
lineal lengths and piece counts.

• Select Total Lineal Length to calculate 
the framing materials of the different 
structural components of the plan in linear 
feet. 

• Select Cut List to calculate the framing 
materials of the different structural com-

ponents of the plan by counting the indi-
vidual pieces present in the model.

• Select Buy List to calculate the framing 
materials of the different structural com-
ponents of the plan by counting individual 
pieces and matching them to common 
board lengths.

• Specify which Length Units you want to 
use from the drop-down list. The selected 
unit(s) are usedin the Materials List when 
either Cut List or Buy List is the selected 
method of reporting. Not available when 
Mixed Reporting or Total Lineal 
Length is selected.

Organizing Materials Lists
You can control what items are calculated in 
the Materials List by specifying which 
categories are used.

There are some parts of a model that cannot 
be excluded from the Materials List. Floor 
and ceiling platforms are prime examples. If 

you need to generate a Materials List for only 
part of a plan, such as an addition, consider 
making a copy of the plan file. In the copy, 
delete the as-built portion of the plan and 
then generate a Materials List.
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Categories
The line items in the Materials List are 
organized into a set of predefined categories, 
such as Electrical and Framing, which 
display in the ID column.

To specify a line item’s category

1. Create a Materials List.

2. Click in the cell in the ID column for a 
line item.

3. Select the desired category from the 
drop-down list that becomes available.

The categories that are available cannot be 
altered; however, you can specify which 
categories are included for individual lists in 
the Materials List Display Options dialog. 

Materials List Display Options Dialog
When a Materials List is open, select 
Tools> Display Options to open the 

Materials List Display Options dialog for 
the current list.

Categories

Columns
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The Categories  listed here appear in the ID 
column of the Materials List in the order they 
are presented here. Check the box beside the 

name of each category that you want to dis-
play in the currently active Materials List. 

Editing Materials Lists
Materials lists can be edited in a variety of 
ways. You can adjust the width of a column 
by clicking and dragging the bar on the right 
side of the column name. 

Adding Information
You can enter information in the Price and 
Comment columns for each item. 

Adding price or other information for any 
item is straightforward. Simply click in the 
cell and type the desired information.

Changing Information
You can change the information in any 
column in an individual Materials List. As 
with added information, click in a cell to 

select the existing text, then type in the 
desired text. 

To move an item in a Materials List to a new 
category, select the cell in the ID column and 
choose a new category from the drop-down 
list that becomes available. See “Categories” 
on page 495.

Total Cost
Total Cost is calculated using the Count, 
Unit, Price, %Markup, Labor and Equipment 
columns to calculate the cost. The formula 
used is: 

(Count + Extra) * Price * (1 + (%    
Markup/100)) + ((Count + Extra) * Labor) 
+ ((Count + Extra) * Equipment)

Note: The information in a suppressed category 
is still part of the Materials List. If the Materials 
List is exported, suppressed categories are 
exported, as well.
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If a column does not appear, 0 is used for the 
value of that column with the exception of 
Count and Price, which are always used in 
the calculation even if they are not shown.

Copying Information
Portions of a Materials List can be copied 

and then pasted into a Text  object or into 

a word processing program or spreadsheet 
program using the standard Windows Copy 
(Ctrl + C), Cut (Ctrl + X), and Paste 
(Ctrl + V) commands. See “Copying and 
Pasting Text” on page 425.

Printing and Exporting the Materials List
To print a Materials List, select File> 
Print while the Materials List window 

is active. See “Print View Dialog” on page 
483.

A Materials List can also be exported 
into a tab delimited text (.txt) file that 

can be opened directly by most spreadsheet 
programs. In a Materials List window, select 
File> Export Materials List.

The Write Materials Export File dialog will 
open. This is a typical File Save dialog. See 
“Exporting Files” on page 43. 

Estimating Software
You can export a Materials List to a word 
processor or spreadsheet program to arrange 

it in your estimating format. You can also 
export the Materials List to a number of 
commercial estimating programs in whose 
databases you can keep your current pricing 
and generate reports based on this data. 

Before purchasing an estimating software 
program, be sure that the program supports 
the direct import of Chief Architect Materials 
Lists. 

Any questions regarding estimating software 
packages and how they interact with Home 
Designer Suite should be directed toward the 
company providing the estimating software. 
Home Designer Suite is unable to provide 
any technical support for third party 
programs.

Conditioned Area Totals
Conditioned Area is the space within a 
building that is heated and/or air conditioned, 
and a Thermal Envelope is a three 
dimensional boundary built around the 
Conditioned Space that separates it from the 
unconditioned space around it. Thermal 

Envelopes are composed of floor platforms, 
ceiling platforms, walls, doors, and windows.  

When a Materials List is created, Home 
Designer Suite calculates the total areas of 
the components that make up a structure’s 
Thermal Envelope and lists them in the 
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General category of the Materials List. See 
“Categories” on page 495. 

Doors are always categorized as doors rather 
than as windows. This is the case even when 
a door is specified as a Glass Door or when it 
is part of a mulled unit. 

Conditioned area totals can be entered into 
third party programs such as REScheck™ to 
determine whether the plan meets the energy 
code in use in your area. 

Conditioned Area
With the exception of Unspecified rooms, 
rooms that are assigned an interior Room 
Type are included in the Conditioned Area. 
“Open Below” rooms are also included; 
however, other hybrid Room Types as well 

as exterior Room Types are not. See “Room 
Types” on page 147.

Building Orientation
Walls, doors, and windows are categorized as 
north-, south-, east-, or west-facing for the 
purposes of conditioned area totals. The 
definition of North in a plan is straight up on 
screen in floor plan view. 
• If a wall is oriented at 45º or less to north 

in a plan, it will be categorized as a 
“North” wall. Any doors and windows in 
this wall will also be categorized as 
“North”.

• Similarly, walls, doors, and windows ori-
ented within 45º of south, east, or west 
will be classified as “South”, “East” or 
“West”, respectively.

The orientation of a curved wall is based on 
the direction of its chord.  

Home Designer Suite does not check 
plans for compliance with building or 
energy codes.
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Additional
Resources

Home Designer Suite offers a variety of 
resources to help you become familiar with 
the many features it offers.

•      Reference Manual

•      User’s Guide
•      Home Designer Web Site
•      HomeTalk Online User Forum
•      Technical Support

Reference Manual
The Home Designer Suite Reference Manual 
is a comprehensive source of information for 
Home Designer Suite 2015. Chapters are 
organized by subject, beginning with the 
fundamental concepts and progressing to the 
more advanced features. The Reference 

Manual is presented in .pdf file format and 
includes a Table of Contents and Index. This 
manual is available online by selecting 

Help> View Reference Manual  from 
the program menu.

User’s Guide
Written for new Home Designer Suite users, 
but a helpful reference for users of all 
experience levels as well, the User’s Guide 
features a series of tutorials designed to 
introduce the basics of using the program.

The Home Designer Suite User’s Guide is 
organized by topic and walks you through 

the process of creating a complete model, 
from the first wall to the interior design and 
landscaping.  

This guide is available online by selecting 
Help> View User’s Guide from the program 
menu.
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Online Help Videos
Another resource designed to illustrate Home 
Designer Suite’s powerful tools is the set of 
tutorial videos available on our web site. 

To view the online videos, select Help> 
View Online Help Videos from the program 
menu or visit 
video.homedesigner.chiefarchitect.com/vid-
eos.

Home Designer Web Site
If you have questions that the online Help 
feature ha not answered, feel free to turn to 
the our web site. 

A database of common technical support 
questions and answers related to Home 

Designer Suite is available through a 
searchable interface. 

Select Help> Visit Home Designer Web 
Site  from the menu to launch your 
default internet browser to 
 www.HomeDesignerSoftware.com.

HomeTalk Online User Forum
The HomeTalk Bulletin Board offers several 
ongoing discussions about a variety of topics 
related to the use of Home Designer Suite. 
It's rich with useful tips and available free of 
charge to all registered Home Designer Suite 
users. 
• Discussions are initiated and carried out 

by users. 

• Experienced users share knowledge with 
each other and beginners. 

• Home Designer Suite Staff members post 
announcements, advice and technical 
information. 

To visit the HomeTalk forum, select Help> 
HomeTalk or go to:  HomeTalk.HomeDe-
signerSoftware.com.

Technical Support
Chief Architect takes pride in offering world 
class technical support services that can be 
accessed by telephone or on our web site. 
Select Help> Technical Support from the 
program menu to visit: 
 www.HomeDesignerSoftware.com.

Before contacting Technical Support, take a 
moment to see if the answer to your question 
is found in the Help resources, tutorial 
videos, or in our on-line Knowledge Base at 
 www.HomeDesignerSoftware.com. 
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When you contact us, Technical Support will 
refer you to these resources if the answer can 
be found there.

So that our Technical Support specialists can 
assist you as efficiently as possible, please 

refer to “Technical Support Services” on 
page 503 for additional trouble-shooting 
suggestions and information that will be 
needed before placing your call.

Upgrade to Chief Architect
Chief Architect is a premium, professional 
residential drafting and 3D design program 
that allows builders, architects and other 
professionals in the building and interior 
design trades to produce construction 
documents and high quality 3D renderings of 
their plans. 

Chief Architect can open and edit plans 
created in Home Designer Suite. In addition, 

Home Designer Suite can open plans created 
in Chief Architect for viewing, as well.

To learn more, select Help> Upgrade to 
Chief Architect. to launch your default web 
browser to www.chiefarchitect.com.
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Technical Support
Services

Chief Architect is committed to providing 
world-class technical support to complement 
our products. 

The primary function of technical support is 
to make sure our software is functioning 

correctly and to help you quickly resolve 
problems that prevent its normal use. Our 
technical support professionals are eager to 
work with you to make certain our software 
is functioning as designed. 

Reference and Training Resources
Chief Architect offers a variety of reference 
options in addition to the resources that come 
standard with the program. 

Online Knowledge Base
The Home Designer online Knowledge Base 
contains a variety of articles describing how 
to resolve common technical problems and 
achieve specific design goals. 

The Knowledge Base is found in the 
Technical Support section of the Web site 
and can be referred to again and again at your 

convenience at 
 www.HomeDesignerSoftware.com .

Online Help Videos
Chief Architect has developed a collection of 
training videos that contain in-depth training 
on a wide range of topics. These videos are 
available on our Web site,  
 www.HomeDesignerSoftware.com .

User Forum
Our HomeTalk User Forum is a great place 
to discuss and exchange ideas with other 
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Home Designer Suite users. Here you can 
post questions, read discussions from other 
users, and post suggestions to improve our 
product. In addition to our regular users, 
from time to time our support and 

engineering teams monitor the forum and 
provide input and discussion on current 
topics. This resource is available free of 
charge at   
HomeTalk.HomeDesignerSoftware.com. 

Troubleshooting Common Technical Issues
Chief Architect strives to make certain our 
software works correctly; however, from 
time to time issues arise that prevent its 
normal operation. 

Installation Issues
The following are common reasons for 
installation failure of Home Designer Suite 
and other software:
• Anti-virus software is enabled and inter-

fering with installation. Anti-virus soft-
ware is the most common cause of 
installation failures for any type of soft-
ware. Refer to your anti-virus software’s 
documentation for details on how to dis-
able the software and re-enable it once 
installation is complete.

• The recommended minimum system 
requirements are not met. See “System 
Requirements” on page 7.

• The computer has a CD drive but not a  
DVD drive. A standard CD drive will not 
read DVD discs. 

• The DVD has fingerprints, scratches, or 
other defects. Sometimes a small finger-
print can prevent the program from 
installing. Clean the disk with soft cotton 
cloth. Be sure to use soft cotton rather 
than paper products on disks to avoid 
scratching.

• You do not have sufficient rights to install 
the software. Verify that you have admin-
istrative rights and the administrative 
password during the installation process. 
If you are on a corporate network, consult 
your network administrator for assis-
tance.

Refer to the on-line Knowledge Base for 
solutions to common installation problems. 
If the answer to your question is not found 
there, contact our Technical Support 
department for assistance.

Troubleshooting Printing Problems
Printing problems fall into two main 
categories: those that prevent the printer 
from working in any program and problems 

printing from Home Designer Suite. To 
determine if the problem is specific to Home 
Designer Suite, try the following:

If you see visible cracking on a CD or
DVD, do not insert it in your CD/DVD

drive. Cracked disks can fly apart and cause
damage to your drive.
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1. Begin by clicking on the Windows Start 
button, and select Printers. 

2. Right-click the printer that is not func-
tioning properly in the Printers folder. 

3. Click Properties from the menu that 
appears.

4. On the General tab, click the Print Test 
Page button. 

If the printer does not produce a test page, 
the problem is not one that Chief Architect 
Technical Support can solve. Follow these 
suggestions:
• Check the connection between the com-

puter and the printer.
• Check your printer documentation for 

troubleshooting printer problems.
• Contact your printer's manufacturer or 

check their Web site for support informa-
tion. 

Your printer manufacturer is the best 
resource for solving problems of this type. 
Chief Architect Technical Support is not able 
to help diagnose and solve problems that 
prevent printing from any program. 

Printers vary widely in how they function. 
Sometimes a faulty cable can be a problem. 
Often, solving a printing problem is as 
simple as downloading and installing an 
updated printer driver. See “Printer Drivers” 
on page 478.

If you can print from Home Designer Suite 
but are not satisfied with the output, refer to 
“Printing” on page 477 for information on 
how to set up and use the printing functions 
in the program. Legacy users should bear in 
mind that each release has new features and 
enhancements, so techniques that were used 
in prior versions may not work in the current 
version. 

Make sure that you use Print Preview  
before printing. Print Preview displays the 
printed paper, or drawing sheet, as a white 
rectangle on screen, and shows how the sheet 
is scaled and positioned relative to your 
drawing. If the drawing is not on the drawing 
sheet on-screen, it will not be on the sheet 
when you print. See “Print Preview” on page 
481.

Make sure that your scaling is correct for the 
paper size. If the plan is much smaller or 
much larger than the drawing sheet, you may 
need to change your Scale. See “Printing to 
Scale” on page 481.

64 Bit Versions of Windows
Some printers may not function correctly on 
64 bit Windows operating systems. If you are 
experiencing a printing problem while using 
a 64 bit version of Windows, please contact 
the printer’s manufacturer to verify that you 
have the correct driver installed.

Printing to a legacy parallel printer port on a 
Windows 64 bit machine may not work 
correctly when using a hardware lock. USB 
printers should not be affected. 

It is a good idea to keep the Owner’s
Manual for your printer close at hand.

Write inside the Owner’s Manual the various
phone numbers for technical support for that
printer – for the original manufacturer and for
your local dealer.
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Clearing Printer Information
Some information specific to individual 
printers, such as available printer paper sizes, 
is saved with each plan file. 

If you are encountering problems when 
printing, or unexpected options in the Page 
Setup dialog, select File> Print> Clear 
Printer Info to clear the printer-specific 
information stored with the plan file. 

After using Clear Printer Info, select File> 
Print> Page Setup . Make sure the 

settings in the Page Setup dialog are correct, 

and then click OK and Save  the file.

Online Knowledge Base
For answers to frequently asked questions 
regarding printing and other topics, select 
Help> Visit Home Designer Suite Web 
Site  and browse the Technical Support 
section of our Web site, 
 www.HomeDesignerSoftware.com. Our 
Technical Support specialists post new 
articles periodically to help resolve problems 
you may encounter. 

Error Messages
Most common error messages have a known 
cause and simple resolution. When you 
encounter an error or warning message in 
Home Designer Suite, you can click the 
Check Knowledge Base button in the 
message box to launch your default internet 
browser to the Home Designer Knowledge 
Base on our Web site,
 www.HomeDesignerSoftware.com.

If an article discussing the message is 
available it will display, providing 
information about the message and how best 
to avoid it. 

It is important that abnormal errors be 
reported to Chief Architect Technical 
Support so that we can identify and resolve 
any problems. 

The content of an error message is useful in 
diagnosing its cause. If you encounter an 
error message, read it carefully and write 
down the error number and the exact text of 
the error message. 

If you encounter the error more than once, 
make a note of your steps prior to receiving 
the message.

Before you report an error, check the 
Knowledge Base to see if the error is already 
documented by typing the error message or 
part of the error message into the search 
form. 

Finally, check to see if there are program 
updates available. These updates are 
provided free for the current version of 
Home Designer Suite and contain 
enhancements and other changes that allow 
the program to perform at an optimum level. 
Select Help> Download Program Updates 

Press the Print Screen key on your key-
board to capture a picture of the error

message. Open a new word processing doc-
ument or e-mail message and choose Edit>
Paste to paste a copy of the error message
into the document for later reference.
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from the Home Designer Suite menu and 
follow the instructions on our Web site,
 www.HomeDesignerSoftware.com.

Error Reporting
When an error occurs, you may have the 
option in the message box to send the report 
to Chief Architect. 

No personal information is sent. When you 
click Send, your default internet browser 
launches and a Web page appears on screen 
This message confirms that the report was 
sent successfully and may give you further 
instructions on how to proceed.

Contacting Technical Support
Before contacting Technical Support, take a 
moment to see if the answer to your question 
is found in the Reference Manual, Help 
index, or in our on-line Knowledge Base. 
When you contact us, Technical Support will 
refer you to these resources if the answer can 
be found there.

Chief Architect's world-class technical 
support is available Monday through Friday 
from 6 AM to 5 PM Pacific Standard Time 
and can be reached at (208) 292-3375 or via 
our Web site, 
 www.HomeDesignerSoftware.com.

There are several things you can do to ensure 
a speedy answer to your question when you 
contact Technical Support.
• Before contacting Technical Support, 

select Help> About Home Designer 
Suite and make a note of the first charac-
ters of your Product Key and the exact 
version of Home Designer Suite you are 
using. Technical support is available to 
the owners of software licenses. When 
you contact Technical Support, be pre-
pared to verify that you are the owner of 
the software license.

• Before contacting Technical Support, 
check to see if there are program updates 

available for download. Our engineering 
team periodically creates updates to the 
program to resolve functionality or pro-
gram issues that were unknown at the 
time of release. These updates are pro-
vided free of charge for the current 
released version and can be accessed by 
selecting Help> Download Program 
Updates from the menu. 

• When you first encounter a problem or 
error message, copy the exact wording of 
the message or a detailed description of 
the problem. This helps us isolate the 
problem and provide you with a solution 
as quickly as possible. 

• When placing a call to Technical Support, 
be at the computer or work station that is 
experiencing the problem and have Home 
Designer Suite running. If you do not 
have access to the problem computer at 
the time of the call, the technician may be 
unable to reproduce the issue and/or sug-
gest a remedy that can be implemented 
and verified immediately.

• Be prepared to reproduce the problem 
when you contact us. If the problem can-
not be reproduced, there is a reduced 
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chance that we will be able to resolve the 
problem on your first phone call.

Online Information
Home Designer Suite has a variety of support 
resources available on our Web site. These 
include our Technical Support Knowledge 
Base, the How do I…? Solution Finder, 
downloadable program updates, and ways to 
contact our Technical Support department. 
To access these resources, visit:  
www.HomeDesignerSoftware.com .

Our support team is happy to assist you in 
finding the best resource to answer your 
questions, and can resolve most issues in just 
a few minutes. In order to allow us to quickly 
answer your calls, we ask that you limit 
yourself to one question per support call. 

Online Support
Questions can be answered online by the 
Technical Support department. To submit a 
technical inquiry online, visit the Technical 
Support section of our Web site and use the   
Online Support Center . 

This route ensures that your question is 
delivered to the first available support 
professional. Requesting assistance of an 
individual specialist is not recommended, 
since that person may not be available to 
answer your question in a timely manner.

Telephone Support
Our Technical Support team is committed to 
answering your questions as quickly as 
possible and in the order received. Your call 
is important to us; however, there are times 
when we get more calls than expected and 
you may have to wait a few minutes before 
speaking to a technician. 

Program Paths Dialog
Some technical issues can be caused by 
problems with support files used by Home 
Designer Suite. In the event of such an issue, 
Chief Architect Technical Support may 
direct you to the Program Paths dialog. This 
dialog displays a list of files utilized by the 
software along with the pathname of each.  

To avoid unintended problems that could 
prevent you from using the software, it is 
strongly recommended that you make no 
changes to any of the files in this list except 
with the direct assistance of Technical 
Support.
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